Database object index

AdventureWorks2016CTP3

CollapseAll image

Collapse image Database object index

Objects | Total
Datatypes | 8
Fulltext catalogs | 1
Functions | 22
Procedures | 82
Roles | 12
Tables | 95
Triggers | 29
Users | 20
Views | 23

Collapse image SQL Server 2016 object index

Objects | Total
DDL triggers | 1
Schemas | 21
XML schema collections | 6

Collapse image See also

Database overview


Database object index

AdventureWorks2016CTP3

Collapse image Database object index

Objects | Total
Datatypes | 8
Fulltext catalogs | 1
Functions | 22
Procedures | 82
Roles | 12
Tables | 95
Triggers | 29
Users | 20
Views | 23

Collapse image SQL Server 2016 object index

Objects | Total
DDL triggers | 1
Fulltext stoplists | 0
Schemas | 21
Sequences | 0
XML schema collections | 6

Collapse image See also

Database overview


List of datatypes

Collapse image Datatypes

Name | Schema | Description | Storage type | Allow nulls | Rule | Default
AccountNumber | dbo |  | nvarchar |  |  |
Flag | dbo |  | bit |  |  |
Name | dbo |  | nvarchar |  |  |
NameStyle | dbo |  | bit |  |  |
OrderNumber | dbo |  | nvarchar |  |  |
Phone | dbo |  | nvarchar |  |  |
SalesOrderDetailType_inmem | Sales |  | table type |  |  |
SalesOrderDetailType_ondisk | Sales |  | table type |  |  |
Total: 8 datatype(s)

Collapse image See also

Defaults

Rules

Database overview


AccountNumber

Datatype: AdventureWorks2016CTP3.dbo.AccountNumber

Collapse image Properties

Name | Value
Name | AccountNumber
Schema | dbo
Owner | dbo
Storage type | nvarchar
Maximum length (chars or Bytes) | 15
Precision | 15
Scale | 0
Allow nulls |
Rule |
Default |
ID | 257
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
AccountNumber | Purchasing.Vendor | Vendor account (identification) number.
AccountNumber | Sales.SalesOrder_json |
AccountNumber | Sales.SalesOrderHeader | Financial accounting number reference.
Total: 3 column(s)

Collapse image Objects that depend on AccountNumber

Object name | Object type | Dep level
Sales.SalesOrder_json | Table | 1
Sales.SalesOrderHeader | Table | 1
Purchasing.Vendor | Table | 1
Total 3 object(s)

Collapse image SQL

CREATE TYPE [dbo].[AccountNumber]
    FROM [nvarchar](15)
    NULL
GO

Collapse image See also

List of datatypes


Flag

Datatype: AdventureWorks2016CTP3.dbo.Flag

Collapse image Properties

Name | Value
Name | Flag
Schema | dbo
Owner | dbo
Storage type | bit
Maximum length (chars or Bytes) | 1
Precision | 1
Scale | 0
Allow nulls |
Rule |
Default |
ID | 258
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
CurrentFlag | HumanResources.Employee | 0 = Inactive, 1 = Active
SalariedFlag | HumanResources.Employee | Job classification. 0 = Hourly, not exempt from collective bargaining. 1 = Salaried, exempt from collective bargaining.
Test column 3 | HumanResources.Employee |
@CurrentFlag | HumanResources.uspUpdateEmployeeHireInfo | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee.
@CurrentFlag | HumanResources.uspUpdateEmployeeLogin | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee.
IsOnlyStateProvinceFlag | Person.StateProvince | 0 = StateProvinceCode exists. 1 = StateProvinceCode unavailable, using CountryRegionCode.
IsOnlyStateProvinceFlag | Person.vStateProvinceCountryRegion |
FinishedGoodsFlag | Production.Product | 0 = Product is not a salable item. 1 = Product is salable.
MakeFlag | Production.Product | 0 = Product is purchased, 1 = Product is manufactured in-house.
Primary | Production.ProductProductPhoto | 0 = Photo is not the principal image. 1 = Photo is the principal image.
ActiveFlag | Purchasing.Vendor | 0 = Vendor no longer used. 1 = Vendor is actively used.
PreferredVendorStatus | Purchasing.Vendor | 0 = Do not use if another vendor is available. 1 = Preferred over other vendors supplying the same product.
OnlineOrderFlag | Sales.SalesOrder_json |
OnlineOrderFlag | Sales.SalesOrderHeader | 0 = Order placed by sales person. 1 = Order placed online by customer.
Total: 14 column(s)

Collapse image Objects that depend on Flag

Object name | Object type | Dep level
HumanResources.uspUpdateEmployeeHireInfo | Procedure | 1
HumanResources.uspUpdateEmployeeLogin | Procedure | 1
HumanResources.Employee | Table | 1
Production.Product | Table | 1
Production.ProductProductPhoto | Table | 1
Sales.SalesOrder_json | Table | 1
Sales.SalesOrderHeader | Table | 1
Person.StateProvince | Table | 1
Purchasing.Vendor | Table | 1
Total 9 object(s)

Collapse image SQL

CREATE TYPE [dbo].[Flag]
    FROM [bit]
    NOT NULL
GO

Collapse image See also

List of datatypes


Name

Datatype: AdventureWorks2016CTP3.dbo.Name

Collapse image Properties

Name | Value
Name | Name
Schema | dbo
Owner | dbo
Storage type | nvarchar
Maximum length (chars or Bytes) | 50
Precision | 50
Scale | 0
Allow nulls |
Rule |
Default |
ID | 260
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
GroupName | HumanResources.Department | Name of the group to which the department belongs.
Name | HumanResources.Department | Name of the department.
Name | HumanResources.Shift | Shift description.
CountryRegionName | HumanResources.vEmployee |
FirstName | HumanResources.vEmployee |
LastName | HumanResources.vEmployee |
MiddleName | HumanResources.vEmployee |
PhoneNumberType | HumanResources.vEmployee |
StateProvinceName | HumanResources.vEmployee |
Department | HumanResources.vEmployeeDepartment |
FirstName | HumanResources.vEmployeeDepartment |
GroupName | HumanResources.vEmployeeDepartment |
LastName | HumanResources.vEmployeeDepartment |
MiddleName | HumanResources.vEmployeeDepartment |
Department | HumanResources.vEmployeeDepartmentHistory |
FirstName | HumanResources.vEmployeeDepartmentHistory |
GroupName | HumanResources.vEmployeeDepartmentHistory |
LastName | HumanResources.vEmployeeDepartmentHistory |
MiddleName | HumanResources.vEmployeeDepartmentHistory |
Shift | HumanResources.vEmployeeDepartmentHistory |
FirstName | HumanResources.vEmployeePersonTemporalInfo |
LastName | HumanResources.vEmployeePersonTemporalInfo |
MiddleName | HumanResources.vEmployeePersonTemporalInfo |
Name | Person.AddressType | Address type description. For example, Billing, Home, or Shipping.
Name | Person.ContactType | Contact type description.
Name | Person.CountryRegion | Country or region name.
FirstName | Person.Person | First name of the person.
LastName | Person.Person | Last name of the person.
MiddleName | Person.Person | Middle name or middle initial of the person.
FirstName | Person.Person_json |
LastName | Person.Person_json |
MiddleName | Person.Person_json |
FirstName | Person.Person_Temporal |
LastName | Person.Person_Temporal |
MiddleName | Person.Person_Temporal |
FirstName | Person.Person_Temporal_History |
LastName | Person.Person_Temporal_History |
MiddleName | Person.Person_Temporal_History |
Name | Person.PhoneNumberType | Name of the telephone number type
Name | Person.StateProvince | State or province description.
FirstName | Person.vAdditionalContactInfo |
LastName | Person.vAdditionalContactInfo |
MiddleName | Person.vAdditionalContactInfo |
CountryRegionName | Person.vStateProvinceCountryRegion |
StateProvinceName | Person.vStateProvinceCountryRegion |
Name | Production.Culture | Culture description.
Name | Production.Location | Location description.
Name | Production.Product | Name of the product.
Name | Production.ProductCategory | Category description.
Name | Production.ProductModel | Product model description.
ReviewerName | Production.ProductReview | Name of the reviewer.
Name | Production.ProductSubcategory | Subcategory description.
Name | Production.ScrapReason | Failure description.
Name | Production.UnitMeasure | Unit of measure description.
Name | Production.vProductAndDescription |
ProductModel | Production.vProductAndDescription |
Name | Production.vProductModelCatalogDescription |
Name | Production.vProductModelInstructions |
Name | Purchasing.ShipMethod | Shipping company name.
Name | Purchasing.Vendor | Company name.
AddressType | Purchasing.vVendorWithAddresses |
CountryRegionName | Purchasing.vVendorWithAddresses |
Name | Purchasing.vVendorWithAddresses |
StateProvinceName | Purchasing.vVendorWithAddresses |
ContactType | Purchasing.vVendorWithContacts |
FirstName | Purchasing.vVendorWithContacts |
LastName | Purchasing.vVendorWithContacts |
MiddleName | Purchasing.vVendorWithContacts |
Name | Purchasing.vVendorWithContacts |
PhoneNumberType | Purchasing.vVendorWithContacts |
Name | Sales.Currency | Currency name.
FirstName | Sales.CustomerPII |
LastName | Sales.CustomerPII |
Name | Sales.SalesReason | Sales reason description.
ReasonType | Sales.SalesReason | Category the sales reason belongs to.
Name | Sales.SalesTaxRate | Tax rate description.
Name | Sales.SalesTerritory | Sales territory description
Name | Sales.Store | Name of the store.
AddressType | Sales.vIndividualCustomer |
CountryRegionName | Sales.vIndividualCustomer |
FirstName | Sales.vIndividualCustomer |
LastName | Sales.vIndividualCustomer |
MiddleName | Sales.vIndividualCustomer |
PhoneNumberType | Sales.vIndividualCustomer |
StateProvinceName | Sales.vIndividualCustomer |
CountryRegionName | Sales.vSalesPerson |
FirstName | Sales.vSalesPerson |
LastName | Sales.vSalesPerson |
MiddleName | Sales.vSalesPerson |
PhoneNumberType | Sales.vSalesPerson |
StateProvinceName | Sales.vSalesPerson |
TerritoryName | Sales.vSalesPerson |
SalesTerritory | Sales.vSalesPersonSalesByFiscalYears |
AddressType | Sales.vStoreWithAddresses |
CountryRegionName | Sales.vStoreWithAddresses |
Name | Sales.vStoreWithAddresses |
StateProvinceName | Sales.vStoreWithAddresses |
ContactType | Sales.vStoreWithContacts |
FirstName | Sales.vStoreWithContacts |
LastName | Sales.vStoreWithContacts |
MiddleName | Sales.vStoreWithContacts |
Name | Sales.vStoreWithContacts |
PhoneNumberType | Sales.vStoreWithContacts |
Name | Sales.vStoreWithDemographics |
Total: 104 column(s)

Collapse image Objects that depend on Name

Object name | Object type | Dep level
Person.AddressType | Table | 1
Person.ContactType | Table | 1
Person.CountryRegion | Table | 1
Production.Culture | Table | 1
Sales.Currency | Table | 1
Sales.CustomerPII | Table | 1
HumanResources.Department | Table | 1
Production.Location | Table | 1
Person.Person | Table | 1
Person.Person_json | Table | 1
Person.Person_Temporal | Table | 1
Person.Person_Temporal_History | Table | 1
Person.PhoneNumberType | Table | 1
Production.Product | Table | 1
Production.ProductCategory | Table | 1
Production.ProductModel | Table | 1
Production.ProductReview | Table | 1
Production.ProductSubcategory | Table | 1
Sales.SalesReason | Table | 1
Sales.SalesTaxRate | Table | 1
Sales.SalesTerritory | Table | 1
Production.ScrapReason | Table | 1
HumanResources.Shift | Table | 1
Purchasing.ShipMethod | Table | 1
Person.StateProvince | Table | 1
Sales.Store | Table | 1
Production.UnitMeasure | Table | 1
Purchasing.Vendor | Table | 1
Total 28 object(s)

Collapse image SQL

CREATE TYPE [dbo].[Name]
    FROM [nvarchar](50)
    NULL
GO

Collapse image See also

List of datatypes


NameStyle

Datatype: AdventureWorks2016CTP3.dbo.NameStyle

Collapse image Properties

Name | Value
Name | NameStyle
Schema | dbo
Owner | dbo
Storage type | bit
Maximum length (chars or Bytes) | 1
Precision | 1
Scale | 0
Allow nulls |
Rule |
Default |
ID | 259
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
NameStyle | Person.Person | 0 = The data in FirstName and LastName are stored in western style (first name, last name) order. 1 = Eastern style (last name, first name) order.
NameStyle | Person.Person_json |
NameStyle | Person.Person_Temporal |
NameStyle | Person.Person_Temporal_History |
Total: 4 column(s)

Collapse image Objects that depend on NameStyle

Object name | Object type | Dep level
Person.Person | Table | 1
Person.Person_json | Table | 1
Person.Person_Temporal | Table | 1
Person.Person_Temporal_History | Table | 1
Total 4 object(s)

Collapse image SQL

CREATE TYPE [dbo].[NameStyle]
    FROM [bit]
    NOT NULL
GO

Collapse image See also

List of datatypes


OrderNumber

Datatype: AdventureWorks2016CTP3.dbo.OrderNumber

Collapse image Properties

Name | Value
Name | OrderNumber
Schema | dbo
Owner | dbo
Storage type | nvarchar
Maximum length (chars or Bytes) | 25
Precision | 25
Scale | 0
Allow nulls |
Rule |
Default |
ID | 261
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
PurchaseOrderNumber | Sales.SalesOrder_json |
PurchaseOrderNumber | Sales.SalesOrderHeader | Customer purchase order number reference.
Total: 2 column(s)

Collapse image Objects that depend on OrderNumber

Object name | Object type | Dep level
Sales.SalesOrder_json | Table | 1
Sales.SalesOrderHeader | Table | 1
Total 2 object(s)

Collapse image SQL

CREATE TYPE [dbo].[OrderNumber]
    FROM [nvarchar](25)
    NULL
GO

Collapse image See also

List of datatypes


Phone

Datatype: AdventureWorks2016CTP3.dbo.Phone

Collapse image Properties

Name | Value
Name | Phone
Schema | dbo
Owner | dbo
Storage type | nvarchar
Maximum length (chars or Bytes) | 25
Precision | 25
Scale | 0
Allow nulls |
Rule |
Default |
ID | 262
Is assembly type |
Is table type |
Is memory optimized |

Collapse image Columns defined on

Name | Parent | Description
PhoneNumber | HumanResources.vEmployee |
PhoneNumber | Person.PersonPhone | Telephone number identification number.
PhoneNumber | Purchasing.vVendorWithContacts |
PhoneNumber | Sales.vIndividualCustomer |
PhoneNumber | Sales.vSalesPerson |
PhoneNumber | Sales.vStoreWithContacts |
Total: 6 column(s)

Collapse image Objects that depend on Phone

Object name | Object type | Dep level
Person.PersonPhone | Table | 1
Total 1 object(s)

Collapse image SQL

CREATE TYPE [dbo].[Phone]
    FROM [nvarchar](25)
    NULL
GO

Collapse image See also

List of datatypes


SalesOrderDetailType_inmem

Datatype: AdventureWorks2016CTP3.Sales.SalesOrderDetailType_inmem

CollapseAll image

Collapse image Properties

Name | Value
Name | SalesOrderDetailType_inmem
Schema | Sales
Owner | dbo
Storage type | table type
Rule |
Default |
ID | 264
Is assembly type |
Is table type |
Is memory optimized |
Table type object ID | 612197231

Collapse image Columns defined on

Name | Parent | Description
@SalesOrderDetails | Sales.usp_InsertSalesOrder_inmem |
Total: 1 column(s)

Collapse image Objects that depend on Sales.SalesOrderDetailType_inmem

Object name | Object type | Dep level
Sales.usp_InsertSalesOrder_inmem | Procedure | 1
Total 1 object(s)

Collapse image Objects that Sales.SalesOrderDetailType_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image SQL

CREATE TYPE [Sales].[SalesOrderDetailType_inmem]
AS TABLE (
        [OrderQty]           [smallint] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [SpecialOfferID]     [int] NOT NULL
)
WITH (MEMORY_OPTIMIZED = ON)
GO

Collapse image See also

List of datatypes


SalesOrderDetailType_ondisk

Datatype: AdventureWorks2016CTP3.Sales.SalesOrderDetailType_ondisk

CollapseAll image

Collapse image Properties

Name | Value
Name | SalesOrderDetailType_ondisk
Schema | Sales
Owner | dbo
Storage type | table type
Rule |
Default |
ID | 263
Is assembly type |
Is table type |
Is memory optimized |
Table type object ID | 1460200252

Collapse image Columns defined on

Name | Parent | Description
@SalesOrderDetails | Sales.usp_InsertSalesOrder_ondisk |
Total: 1 column(s)

Collapse image Objects that depend on Sales.SalesOrderDetailType_ondisk

Object name | Object type | Dep level
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Total 1 object(s)

Collapse image Objects that Sales.SalesOrderDetailType_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image SQL

CREATE TYPE [Sales].[SalesOrderDetailType_ondisk]
AS TABLE (
        [OrderQty]           [smallint] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [SpecialOfferID]     [int] NOT NULL
)
GO

Collapse image See also

List of datatypes


DDL triggers

List of DDL triggers

Collapse image DDL triggers

Name | Description
tr_ddl_AUDIT |
Total: 1 ddl trigger(s)

Collapse image See also

Database overview


tr_ddl_AUDIT

DDL trigger: AdventureWorks2016CTP3.tr_ddl_AUDIT

Collapse image DDL trigger properties

Name | Value
Encrypted |
Disabled |
ID | 152387612
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that tr_ddl_AUDIT depends on

Object name | Object type | Dep level
AUDIT_LOG_DDL | Table | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [tr_ddl_AUDIT]
ON DATABASE
FOR
DDL_DATABASE_LEVEL_EVENTS
AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DDL TRIGGER for auditing DDL_DATABASE_LEVEL_EVENTS
-- Author:       ApexSQL Software
BEGIN
    DECLARE @data XML;
    DECLARE @databaseName nvarchar(100);
    DECLARE @schemaName nvarchar(100);
    DECLARE @objectType nvarchar(100);
    DECLARE @objectName nvarchar(100);
    DECLARE @action nvarchar(100);
    DECLARE @oldValue nvarchar(100);
    DECLARE @newValue nvarchar(100);
    DECLARE @modifiedBy nvarchar(100);
    DECLARE @modifiedDate datetime;
  DECLARE @appName nvarchar(100);
  DECLARE @hostName nvarchar(100);
  DECLARE @ddlDescription nvarchar(100);
  DECLARE @sqlCommand nvarchar(1000);
  SET NOCOUNT ON
    SET @data = EVENTDATA();
    SET @databaseName = @data.value('(/EVENT_INSTANCE/DatabaseName)[1]', 'nvarchar(100)');
    SET @schemaName = @data.value('(/EVENT_INSTANCE/SchemaName)[1]', 'nvarchar(100)');
    SET @objectType = @data.value('(/EVENT_INSTANCE/ObjectType)[1]', 'nvarchar(100)');
    SET @objectName = @data.value('(/EVENT_INSTANCE/ObjectName)[1]', 'nvarchar(100)');
    SET @action = @data.value('(/EVENT_INSTANCE/EventType)[1]', 'nvarchar(100)');
    SET @oldValue = @data.value('(/EVENT_INSTANCE/ObjectName)[1]', 'nvarchar(100)');
  SET @newValue = @data.value('(/EVENT_INSTANCE/ObjectName)[1]', 'nvarchar(100)');
    SET @modifiedBy = @data.value('(/EVENT_INSTANCE/LoginName)[1]', 'nvarchar(100)');
    SET @modifiedDate = GETDATE();
  SET @appName = APP_NAME();
  SET @hostName = HOST_NAME();
  SET @ddlDescription = N' ';
  SET @sqlCommand = @data.value('(/EVENT_INSTANCE/TSQLCommand/CommandText)[1]', 'nvarchar(1000)');
  IF @action LIKE '%CREATE%'
    BEGIN
      SET @ddlDescription = UPPER(LEFT(@objectType,1))+LOWER(SUBSTRING(@objectType,2,LEN(@objectType))) + ' created';
      SET @oldValue = N'';
        SET @action = 'CREATE';
    END
  ELSE IF @action LIKE '%ALTER%'
    BEGIN
      IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% ADD CONSTRAINT %'
        BEGIN
          SET @ddlDescription = 'Added constraint'
          SET @oldValue = N'';
          SET @newValue = @data.value('(/EVENT_INSTANCE/AlterTableActionList/Create/Constraints/Name)[1]', 'nvarchar(100)');
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% ADD INDEX %'
        BEGIN
          SET @ddlDescription = 'Added index on column'
          SET @oldValue = N'';
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% ADD%'
        BEGIN
          SET @ddlDescription = 'Table column created'
          SET @oldValue = N'';
          SET @newValue = @data.value('(/EVENT_INSTANCE/AlterTableActionList/Create/Columns/Name)[1]', 'nvarchar(100)');
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% ALTER COLUMN %'
        BEGIN
          SET @ddlDescription = 'Table column modified'
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% DROP COLUMN %'
        BEGIN
          SET @ddlDescription = 'Table column deleted'
          SET @newValue = N'';
          SET @oldValue = @data.value('(/EVENT_INSTANCE/AlterTableActionList/Drop/Columns/Name)[1]', 'nvarchar(100)');
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% DROP CONSTRAINT %'
        BEGIN
          SET @ddlDescription = 'Constraint deleted'
          SET @newValue = N'';
          SET @oldValue = @data.value('(/EVENT_INSTANCE/AlterTableActionList/Drop/Constraints/Name)[1]', 'nvarchar(100)');
        END
      ELSE IF @sqlCommand LIKE '%ALTER TABLE%' AND @sqlCommand LIKE '% DROP INDEX %'
        BEGIN
          SET @ddlDescription = 'Index deleted'
          SET @newValue = N'';
        END
      ELSE
        BEGIN
          SET @ddlDescription = UPPER(LEFT(@objectType,1))+LOWER(SUBSTRING(@objectType,2,LEN(@objectType))) + ' altered';
        END
        SET @action = 'ALTER';
    END
  ELSE IF @action LIKE '%DROP%'
    BEGIN
      SET @ddlDescription = UPPER(LEFT(@objectType,1))+LOWER(SUBSTRING(@objectType,2,LEN(@objectType))) + ' deleted';
      SET @newValue = N'';
        SET @action = 'DROP';
    END
  IF @action = 'RENAME' AND @objectType = 'COLUMN'
    BEGIN
        SET @objectType = 'TABLE';
        SET @objectName = @data.value('(/EVENT_INSTANCE/TargetObjectName)[1]', 'nvarchar(100)');
        SET @action = 'ALTER';
      SET @oldValue = @data.value('(/EVENT_INSTANCE/ObjectName)[1]', 'nvarchar(100)');
      SET @newValue = @data.value('(/EVENT_INSTANCE/NewObjectName)[1]', 'nvarchar(100)');
        SET @ddlDescription = 'Table column renamed';
      END
  ELSE IF @action = 'RENAME'
    BEGIN
        SET @action = 'ALTER';
      SET @oldValue = @data.value('(/EVENT_INSTANCE/ObjectName)[1]', 'nvarchar(100)');
      SET @newValue = @data.value('(/EVENT_INSTANCE/NewObjectName)[1]', 'nvarchar(100)');
        SET @ddlDescription = UPPER(LEFT(@objectType,1))+LOWER(SUBSTRING(@objectType,2,LEN(@objectType))) + ' renamed';
      END
  IF @objectName NOT LIKE '%TRIGGER_%' AND @objectName NOT LIKE '%AUDIT_%' AND @sqlCommand NOT LIKE '%LOCK_ESCALATION%'
    BEGIN
        INSERT INTO AUDIT_LOG_DDL
        (
            [DATABASE],
            [SCHEMA],
            OBJECT_TYPE,
            OBJECT_NAME,
            ACTION,
            OLD_VALUE,
            NEW_VALUE,
            MODIFIED_BY,
            MODIFIED_DATE,
        APP_NAME,
        HOST_NAME,
        DESCRIPTION
        )
        VALUES
        (
            @databaseName,
            @schemaName,
            @objectType,
            @objectName,
            @action,
            @oldValue,
            @newValue,
            @modifiedBy,
            @modifiedDate,
        @appName,
        @hostName,
        @ddlDescription
        );
    END
END
GO

Collapse image See also

List of DDL triggers


Fulltext catalogs

List of fulltext catalogs

Collapse image Fulltext catalogs

Name
AW2014FullTextCatalog
Total: 1 fulltext catalog(s)

Collapse image See also

Database overview


AW2014FullTextCatalog

Fulltext catalog: AdventureWorks2016CTP3.AW2014FullTextCatalog

CollapseAll image

Collapse image Fulltext catalog properties

Name | Value
Owner | dbo
Is default |
Is accent sensitive |
File group | PRIMARY
Path |
ID | 5

Collapse image Objects that depend on AW2014FullTextCatalog

Object name | Object type | Dep level
Production.Document | Table | 1
HumanResources.JobCandidate | Table | 1
Production.ProductReview | Table | 1
Total 3 object(s)

Collapse image SQL

CREATE FULLTEXT CATALOG [AW2014FullTextCatalog]
    WITH ACCENT_SENSITIVITY = ON
    AS DEFAULT
    AUTHORIZATION [dbo]
GO

Collapse image See also

List of fulltext catalogs


Functions

List of functions

Collapse image Functions

Name | Schema | Description | Type | Schema bound | Deterministic | Encrypted | Creation date
AUDIT_fn_HexToStr | dbo |  | Scalar |  |  |  | 21.09.2016
AUDIT_fn_SqlVariantToString | dbo |  | Scalar |  |  |  | 21.09.2016
customerAccessPredicate | Security |  | Inline |  |  |  | 23.10.2015
ufnGetAccountingEndDate | dbo | Scalar function used in the uSalesOrderHeader trigger to set the starting account date. | Scalar |  |  |  | 16.11.2015
ufnGetAccountingEndDate_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetAccountingStartDate | dbo | Scalar function used in the uSalesOrderHeader trigger to set the ending account date. | Scalar |  |  |  | 16.11.2015
ufnGetAccountingStartDate_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetContactInformation | dbo | Table value function returning the first name, last name, job title and contact type for a given contact. | Table |  |  |  | 16.11.2015
ufnGetDocumentStatusText | dbo | Scalar function returning the text representation of the Status column in the Document table. | Scalar |  |  |  | 16.11.2015
ufnGetDocumentStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetProductDealerPrice | dbo | Scalar function returning the dealer price for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetProductListPrice | dbo | Scalar function returning the list price for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetProductStandardCost | dbo | Scalar function returning the standard cost for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetPurchaseOrderStatusText | dbo | Scalar function returning the text representation of the Status column in the PurchaseOrderHeader table. | Scalar |  |  |  | 16.11.2015
ufnGetPurchaseOrderStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetSalesOrderStatusText | dbo | Scalar function returning the text representation of the Status column in the SalesOrderHeader table. | Scalar |  |  |  | 16.11.2015
ufnGetSalesOrderStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetStock | dbo | Scalar function returning the quantity of inventory in LocationID 6 (Miscellaneous Storage)for a specified ProductID. | Scalar |  |  |  | 16.11.2015
ufnLeadingZeros | dbo | Scalar function used by the Sales.Customer table to help set the account number. | Scalar |  |  |  | 23.10.2015
ufnLeadingZeros_native | dbo |  | Scalar |  |  |  | 23.10.2015
vSalesOrderDetail_extended_inmem | Sales |  | Inline |  |  |  | 23.10.2015
vSalesOrderHeader_extended_inmem | Sales |  | Inline |  |  |  | 23.10.2015
Total: 22 Function(s)

Collapse image See also

Procedures

Database overview


AUDIT_fn_HexToStr

Function: AdventureWorks2016CTP3.dbo.AUDIT_fn_HexToStr

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 120387498

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@hex |  | varbinary | 8000 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | varchar | 8000

Collapse image Objects that depend on AUDIT_fn_HexToStr

Object name | Object type | Dep level
AUDIT_fn_SqlVariantToString | Function | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

create function [dbo].[AUDIT_fn_HexToStr](@hex varbinary(8000))
returns varchar(8000)
as
begin
declare
    @len int,
    @counter int,
    @res varchar(8000),
    @string char(16),
    @byte binary(1)
    set @string = '0123456789ABCDEF'
    set @res = '0x'
    set @len = datalength(@hex)
    set @counter = 1
    while(@counter <= @len)
    begin
        set @byte = substring(@hex, @counter, 1)
        set @res = @res + substring(@string, 1 + @byte/16, 1) + substring(@string, 1 + @byte - (@byte/16)*16, 1)
        set @counter = @counter + 1
    end
    return @res
end
GO

Collapse image See also

List of functions


AUDIT_fn_SqlVariantToString

Function: AdventureWorks2016CTP3.dbo.AUDIT_fn_SqlVariantToString

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 136387555

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@var |  | sql_variant | 8016 |
@string |  | bit | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 4000

Collapse image Objects that AUDIT_fn_SqlVariantToString depends on

Object name | Object type | Dep level
AUDIT_fn_HexToStr | Function | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

create function dbo.AUDIT_fn_SqlVariantToString(@var sql_variant, @string bit)
returns nvarchar(4000)
as
begin
declare
@type varchar(20),
@result nvarchar(4000)
set @type = cast(SQL_VARIANT_PROPERTY(@var,'BaseType') as varchar(20))
if (@type='binary' or @type='varbinary')
    set @result = cast(dbo.AUDIT_fn_HexToStr(cast(@var as varbinary(8000))) as nvarchar(4000))
else if (@type='float' or @type='real')
    set @result = convert(nvarchar(4000), @var, 3)
else if (@type='int'
    or @type='tinyint'
    or @type='smallint'
    or @type='bigint'
    or @type='bit'
    or @type='decimal'
    or @type='numeric'
    )
    set @result = convert(nvarchar(4000), @var)
else if (@type='timestamp')
    set @result = convert(nvarchar(4000), convert(bigint, @var))
else if (@string = 1)
    set @result = 'N''' + convert(nvarchar(4000), @var) + ''''
else
    set @result = convert(nvarchar(4000), @var)
return @result
end
GO

Collapse image See also

List of functions


customerAccessPredicate

Function: AdventureWorks2016CTP3.Security.customerAccessPredicate

CollapseAll image

Collapse image Function properties

Name | Value
Schema | Security
Owner | dbo
Creation date | 23.10.2015
Type | Inline
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1678629023

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@TerritoryID |  | int | 4 |

Collapse image Recordset returned

Name | Datatype | Max length
accessResult | int | 4

Collapse image Objects that Security.customerAccessPredicate depends on

Object name | Object type | Dep level
Security | Schema | 1
HumanResources.Employee | Table | 1
Sales.SalesPerson | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION Security.customerAccessPredicate(@TerritoryID int)
    RETURNS TABLE
    WITH SCHEMABINDING
AS
    RETURN SELECT 1 AS accessResult
    FROM HumanResources.Employee e
    INNER JOIN Sales.SalesPerson sp ON sp.BusinessEntityID = e.BusinessEntityID
    WHERE
        ( RIGHT(e.LoginID, LEN(e.LoginID) - LEN('adventure-works\')) = USER_NAME() AND sp.TerritoryID = @TerritoryID )
        OR IS_MEMBER('SalesManagers') = 1
        OR IS_MEMBER('db_owner') = 1
GO

Collapse image See also

List of functions


ufnGetAccountingEndDate

Function: AdventureWorks2016CTP3.dbo.ufnGetAccountingEndDate

Collapse image Description

Scalar function used in the uSalesOrderHeader trigger to set the starting account date.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1357247890

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
@Return | datetime | 8

Collapse image Objects that depend on ufnGetAccountingEndDate

Object name | Object type | Dep level
Sales.uSalesOrderHeader | Trigger | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function used in the uSalesOrderHeader trigger to set the starting account date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetAccountingEndDate]()
RETURNS [datetime]
AS
BEGIN
    RETURN DATEADD(millisecond, -2, CONVERT(datetime, '20040701', 112));
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function used in the uSalesOrderHeader trigger to set the starting account date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetAccountingEndDate', NULL, NULL
GO

Collapse image See also

List of functions


ufnGetAccountingEndDate_native

Function: AdventureWorks2016CTP3.dbo.ufnGetAccountingEndDate_native

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1652200936

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
@Return | datetime | 8

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION dbo.ufnGetAccountingEndDate_native()
RETURNS [datetime]
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL=SNAPSHOT, LANGUAGE=N'us_english')

    RETURN DATEADD(millisecond, -2, CONVERT(datetime, '20160701', 112));

END
GO

Collapse image See also

List of functions


ufnGetAccountingStartDate

Function: AdventureWorks2016CTP3.dbo.ufnGetAccountingStartDate

CollapseAll image

Collapse image Description

Scalar function used in the uSalesOrderHeader trigger to set the ending account date.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1341247833

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
@Return | datetime | 8

Collapse image Objects that depend on ufnGetAccountingStartDate

Object name | Object type | Dep level
Sales.uSalesOrderHeader | Trigger | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function used in the uSalesOrderHeader trigger to set the ending account date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetAccountingStartDate]()
RETURNS [datetime]
AS
BEGIN
    RETURN CONVERT(datetime, '20030701', 112);
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function used in the uSalesOrderHeader trigger to set the ending account date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetAccountingStartDate', NULL, NULL
GO

Collapse image See also

List of functions


ufnGetAccountingStartDate_native

Function: AdventureWorks2016CTP3.dbo.ufnGetAccountingStartDate_native

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1668200993

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
@Return | datetime | 8

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].ufnGetAccountingStartDate_native()
RETURNS [datetime]
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL=SNAPSHOT, LANGUAGE=N'us_english')

    RETURN CONVERT(datetime, '20150701', 112);

END
GO

Collapse image See also

List of functions


ufnGetContactInformation

Function: AdventureWorks2016CTP3.dbo.ufnGetContactInformation

CollapseAll image

Collapse image Description

Table value function returning the first name, last name, job title and contact type for a given contact.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Table
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1373247947

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@PersonID | Input parameter for the table value function ufnGetContactInformation. Enter a valid PersonID from the Person.Contact table. | int | 4 |

Collapse image Recordset returned

Name | Datatype | Max length
PersonID | int | 4
FirstName | nvarchar | 50
LastName | nvarchar | 50
JobTitle | nvarchar | 50
BusinessEntityType | nvarchar | 50

Collapse image Objects that ufnGetContactInformation depends on

Object name | Object type | Dep level
Person.BusinessEntityContact | Table | 1
Person.ContactType | Table | 1
Sales.Customer | Table | 1
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Sales.Store | Table | 1
Purchasing.Vendor | Table | 1
Total 7 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Table value function returning the first name, last name, job title and contact type for a given contact.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetContactInformation](@PersonID int)
RETURNS @retContactInformation TABLE
(
    -- Columns returned by the function
    [PersonID] int NOT NULL,
    [FirstName] [nvarchar](50) NULL,
    [LastName] [nvarchar](50) NULL,
    [JobTitle] [nvarchar](50) NULL,
    [BusinessEntityType] [nvarchar](50) NULL
)
AS
-- Returns the first name, last name, job title and business entity type for the specified contact.
-- Since a contact can serve multiple roles, more than one row may be returned.
BEGIN
    IF @PersonID IS NOT NULL
        BEGIN
        IF EXISTS(SELECT * FROM [HumanResources].[Employee] e
                    WHERE e.[BusinessEntityID] = @PersonID)
            INSERT INTO @retContactInformation
                SELECT @PersonID, p.FirstName, p.LastName, e.[JobTitle], 'Employee'
                FROM [HumanResources].[Employee] AS e
                    INNER JOIN [Person].[Person] p
                    ON p.[BusinessEntityID] = e.[BusinessEntityID]
                WHERE e.[BusinessEntityID] = @PersonID;

        IF EXISTS(SELECT * FROM [Purchasing].[Vendor] AS v
                    INNER JOIN [Person].[BusinessEntityContact] bec
                    ON bec.[BusinessEntityID] = v.[BusinessEntityID]
                    WHERE bec.[PersonID] = @PersonID)
            INSERT INTO @retContactInformation
                SELECT @PersonID, p.FirstName, p.LastName, ct.[Name], 'Vendor Contact'
                FROM [Purchasing].[Vendor] AS v
                    INNER JOIN [Person].[BusinessEntityContact] bec
                    ON bec.[BusinessEntityID] = v.[BusinessEntityID]
                    INNER JOIN [Person].ContactType ct
                    ON ct.[ContactTypeID] = bec.[ContactTypeID]
                    INNER JOIN [Person].[Person] p
                    ON p.[BusinessEntityID] = bec.[PersonID]
                WHERE bec.[PersonID] = @PersonID;

        IF EXISTS(SELECT * FROM [Sales].[Store] AS s
                    INNER JOIN [Person].[BusinessEntityContact] bec
                    ON bec.[BusinessEntityID] = s.[BusinessEntityID]
                    WHERE bec.[PersonID] = @PersonID)
            INSERT INTO @retContactInformation
                SELECT @PersonID, p.FirstName, p.LastName, ct.[Name], 'Store Contact'
                FROM [Sales].[Store] AS s
                    INNER JOIN [Person].[BusinessEntityContact] bec
                    ON bec.[BusinessEntityID] = s.[BusinessEntityID]
                    INNER JOIN [Person].ContactType ct
                    ON ct.[ContactTypeID] = bec.[ContactTypeID]
                    INNER JOIN [Person].[Person] p
                    ON p.[BusinessEntityID] = bec.[PersonID]
                WHERE bec.[PersonID] = @PersonID;

        IF EXISTS(SELECT * FROM [Person].[Person] AS p
                    INNER JOIN [Sales].[Customer] AS c
                    ON c.[PersonID] = p.[BusinessEntityID]
                    WHERE p.[BusinessEntityID] = @PersonID AND c.[StoreID] IS NULL)
            INSERT INTO @retContactInformation
                SELECT @PersonID, p.FirstName, p.LastName, NULL, 'Consumer'
                FROM [Person].[Person] AS p
                    INNER JOIN [Sales].[Customer] AS c
                    ON c.[PersonID] = p.[BusinessEntityID]
                    WHERE p.[BusinessEntityID] = @PersonID AND c.[StoreID] IS NULL;
        END

    RETURN;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Table value function returning the first name, last name, job title and contact type for a given contact.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetContactInformation', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the table value function ufnGetContactInformation. Enter a valid PersonID from the Person.Contact table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetContactInformation', 'PARAMETER', N'@PersonID'
GO

Collapse image See also

List of functions


ufnGetDocumentStatusText

Function: AdventureWorks2016CTP3.dbo.ufnGetDocumentStatusText

CollapseAll image

Collapse image Description

Scalar function returning the text representation of the Status column in the Document table.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1453248232

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status | Input parameter for the scalar function ufnGetDocumentStatusText. Enter a valid integer. | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 16

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the text representation of the Status column in the Document table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetDocumentStatusText](@Status [tinyint])
RETURNS [nvarchar](16)
AS
-- Returns the sales order status text representation for the status value.
BEGIN
    DECLARE @ret [nvarchar](16);

    SET @ret =
        CASE @Status
            WHEN 1 THEN N'Pending approval'
            WHEN 2 THEN N'Approved'
            WHEN 3 THEN N'Obsolete'
            ELSE N'** Invalid **'
        END;

    RETURN @ret
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the text representation of the Status column in the Document table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetDocumentStatusText', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetDocumentStatusText. Enter a valid integer.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetDocumentStatusText', 'PARAMETER', N'@Status'
GO

Collapse image See also

List of functions


ufnGetDocumentStatusText_native

Function: AdventureWorks2016CTP3.dbo.ufnGetDocumentStatusText_native

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1700201107

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status |  | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 15

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION dbo.ufnGetDocumentStatusText_native (@Status tinyint)
RETURNS nvarchar(15)
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL = SNAPSHOT, LANGUAGE = N'English')

    IF @Status=1 RETURN 'Pending approval'
    IF @Status=2 RETURN 'Approved'
    IF @Status=3 RETURN 'Obsolete'

    RETURN '** Invalid **'

END
GO

Collapse image See also

List of functions


ufnGetProductDealerPrice

Function: AdventureWorks2016CTP3.dbo.ufnGetProductDealerPrice

CollapseAll image

Collapse image Description

Scalar function returning the dealer price for a given product on a particular order date.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1389248004

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@ProductID | Input parameter for the scalar function ufnGetProductDealerPrice. Enter a valid ProductID from the Production.Product table. | int | 4 |
@OrderDate | Input parameter for the scalar function ufnGetProductDealerPrice. Enter a valid order date. | datetime | 8 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | money | 8

Collapse image Objects that ufnGetProductDealerPrice depends on

Object name | Object type | Dep level
Production.Product | Table | 1
Production.ProductListPriceHistory | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the dealer price for a given product on a particular order date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetProductDealerPrice](@ProductID [int], @OrderDate [datetime])
RETURNS [money]
AS
-- Returns the dealer price for the product on a specific date.
BEGIN
    DECLARE @DealerPrice money;
    DECLARE @DealerDiscount money;

    SET @DealerDiscount = 0.60  -- 60% of list price

    SELECT @DealerPrice = plph.[ListPrice] * @DealerDiscount
    FROM [Production].[Product] p
        INNER JOIN [Production].[ProductListPriceHistory] plph
        ON p.[ProductID] = plph.[ProductID]
            AND p.[ProductID] = @ProductID
            AND @OrderDate BETWEEN plph.[StartDate] AND COALESCE(plph.[EndDate], CONVERT(datetime, '99991231', 112)); -- Make sure we get all the prices!

    RETURN @DealerPrice;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the dealer price for a given product on a particular order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductDealerPrice', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductDealerPrice. Enter a valid order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductDealerPrice', 'PARAMETER', N'@OrderDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductDealerPrice. Enter a valid ProductID from the Production.Product table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductDealerPrice', 'PARAMETER', N'@ProductID'
GO

Collapse image See also

List of functions


ufnGetProductListPrice

Function: AdventureWorks2016CTP3.dbo.ufnGetProductListPrice

Collapse image Description

Scalar function returning the list price for a given product on a particular order date.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1405248061

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@ProductID | Input parameter for the scalar function ufnGetProductListPrice. Enter a valid ProductID from the Production.Product table. | int | 4 |
@OrderDate | Input parameter for the scalar function ufnGetProductListPrice. Enter a valid order date. | datetime | 8 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | money | 8

Collapse image Objects that ufnGetProductListPrice depends on

Object name | Object type | Dep level
Production.Product | Table | 1
Production.ProductListPriceHistory | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the list price for a given product on a particular order date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetProductListPrice](@ProductID [int], @OrderDate [datetime])
RETURNS [money]
AS
BEGIN
    DECLARE @ListPrice money;

    SELECT @ListPrice = plph.[ListPrice]
    FROM [Production].[Product] p
        INNER JOIN [Production].[ProductListPriceHistory] plph
        ON p.[ProductID] = plph.[ProductID]
            AND p.[ProductID] = @ProductID
            AND @OrderDate BETWEEN plph.[StartDate] AND COALESCE(plph.[EndDate], CONVERT(datetime, '99991231', 112)); -- Make sure we get all the prices!

    RETURN @ListPrice;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the list price for a given product on a particular order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductListPrice', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductListPrice. Enter a valid order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductListPrice', 'PARAMETER', N'@OrderDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductListPrice. Enter a valid ProductID from the Production.Product table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductListPrice', 'PARAMETER', N'@ProductID'
GO

Collapse image See also

List of functions


ufnGetProductStandardCost

Function: AdventureWorks2016CTP3.dbo.ufnGetProductStandardCost

CollapseAll image

Collapse image Description

Scalar function returning the standard cost for a given product on a particular order date.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1421248118

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@ProductID | Input parameter for the scalar function ufnGetProductStandardCost. Enter a valid ProductID from the Production.Product table. | int | 4 |
@OrderDate | Input parameter for the scalar function ufnGetProductStandardCost. Enter a valid order date. | datetime | 8 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | money | 8

Collapse image Objects that ufnGetProductStandardCost depends on

Object name | Object type | Dep level
Production.Product | Table | 1
Production.ProductCostHistory | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the standard cost for a given product on a particular order date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetProductStandardCost](@ProductID [int], @OrderDate [datetime])
RETURNS [money]
AS
-- Returns the standard cost for the product on a specific date.
BEGIN
    DECLARE @StandardCost money;

    SELECT @StandardCost = pch.[StandardCost]
    FROM [Production].[Product] p
        INNER JOIN [Production].[ProductCostHistory] pch
        ON p.[ProductID] = pch.[ProductID]
            AND p.[ProductID] = @ProductID
            AND @OrderDate BETWEEN pch.[StartDate] AND COALESCE(pch.[EndDate], CONVERT(datetime, '99991231', 112)); -- Make sure we get all the prices!

    RETURN @StandardCost;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the standard cost for a given product on a particular order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductStandardCost', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductStandardCost. Enter a valid order date.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductStandardCost', 'PARAMETER', N'@OrderDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetProductStandardCost. Enter a valid ProductID from the Production.Product table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetProductStandardCost', 'PARAMETER', N'@ProductID'
GO

Collapse image See also

List of functions


ufnGetPurchaseOrderStatusText

Function: AdventureWorks2016CTP3.dbo.ufnGetPurchaseOrderStatusText

CollapseAll image

Collapse image Description

Scalar function returning the text representation of the Status column in the PurchaseOrderHeader table.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1469248289

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status | Input parameter for the scalar function ufnGetPurchaseOrdertStatusText. Enter a valid integer. | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 15

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the text representation of the Status column in the PurchaseOrderHeader table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetPurchaseOrderStatusText](@Status [tinyint])
RETURNS [nvarchar](15)
AS
-- Returns the sales order status text representation for the status value.
BEGIN
    DECLARE @ret [nvarchar](15);

    SET @ret =
        CASE @Status
            WHEN 1 THEN 'Pending'
            WHEN 2 THEN 'Approved'
            WHEN 3 THEN 'Rejected'
            WHEN 4 THEN 'Complete'
            ELSE '** Invalid **'
        END;

    RETURN @ret
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the text representation of the Status column in the PurchaseOrderHeader table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetPurchaseOrderStatusText', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetPurchaseOrdertStatusText. Enter a valid integer.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetPurchaseOrderStatusText', 'PARAMETER', N'@Status'
GO

Collapse image See also

List of functions


ufnGetPurchaseOrderStatusText_native

Function: AdventureWorks2016CTP3.dbo.ufnGetPurchaseOrderStatusText_native

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1716201164

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status |  | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 15

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION dbo.ufnGetPurchaseOrderStatusText_native (@Status tinyint)
RETURNS nvarchar(15)
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL = SNAPSHOT, LANGUAGE = N'English')

    IF @Status=1 RETURN 'Pending'
    IF @Status=2 RETURN 'Approved'
    IF @Status=3 RETURN 'Rejected'
    IF @Status=4 RETURN 'Complete'

    RETURN '** Invalid **'

END
GO

Collapse image See also

List of functions


ufnGetSalesOrderStatusText

Function: AdventureWorks2016CTP3.dbo.ufnGetSalesOrderStatusText

CollapseAll image

Collapse image Description

Scalar function returning the text representation of the Status column in the SalesOrderHeader table.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1485248346

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status | Input parameter for the scalar function ufnGetSalesOrderStatusText. Enter a valid integer. | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 15

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the text representation of the Status column in the SalesOrderHeader table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetSalesOrderStatusText](@Status [tinyint])
RETURNS [nvarchar](15)
AS
-- Returns the sales order status text representation for the status value.
BEGIN
    DECLARE @ret [nvarchar](15);

    SET @ret =
        CASE @Status
            WHEN 1 THEN 'In process'
            WHEN 2 THEN 'Approved'
            WHEN 3 THEN 'Backordered'
            WHEN 4 THEN 'Rejected'
            WHEN 5 THEN 'Shipped'
            WHEN 6 THEN 'Cancelled'
            ELSE '** Invalid **'
        END;

    RETURN @ret
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the text representation of the Status column in the SalesOrderHeader table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetSalesOrderStatusText', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetSalesOrderStatusText. Enter a valid integer.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetSalesOrderStatusText', 'PARAMETER', N'@Status'
GO

Collapse image See also

List of functions


ufnGetSalesOrderStatusText_native

Function: AdventureWorks2016CTP3.dbo.ufnGetSalesOrderStatusText_native

CollapseAll image

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1684201050

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Status |  | tinyint | 1 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | nvarchar | 15

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION dbo.ufnGetSalesOrderStatusText_native (@Status tinyint)
RETURNS nvarchar(15)
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL = SNAPSHOT, LANGUAGE = N'English')

    IF @Status=1 RETURN 'In Process'
    IF @Status=2 RETURN 'Approved'
    IF @Status=3 RETURN 'Backordered'
    IF @Status=4 RETURN 'Rejected'
    IF @Status=5 RETURN 'Shipped'
    IF @Status=6 RETURN 'Cancelled'

    RETURN '** Invalid **'

END
GO

Collapse image See also

List of functions


ufnGetStock

Function: AdventureWorks2016CTP3.dbo.ufnGetStock

Collapse image Description

Scalar function returning the quantity of inventory in LocationID 6 (Miscellaneous Storage)for a specified ProductID.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1437248175

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@ProductID | Input parameter for the scalar function ufnGetStock. Enter a valid ProductID from the Production.ProductInventory table. | int | 4 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | int | 4

Collapse image Objects that ufnGetStock depends on

Object name | Object type | Dep level
Production.ProductInventory | Table | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function returning the quantity of inventory in LocationID 6 (Miscellaneous Storage)for a specified ProductID.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnGetStock](@ProductID [int])
RETURNS [int]
AS
-- Returns the stock level for the product. This function is used internally only
BEGIN
    DECLARE @ret int;

    SELECT @ret = SUM(p.[Quantity])
    FROM [Production].[ProductInventory] p
    WHERE p.[ProductID] = @ProductID
        AND p.[LocationID] = '6'; -- Only look at inventory in the misc storage

    IF (@ret IS NULL)
        SET @ret = 0

    RETURN @ret
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function returning the quantity of inventory in LocationID 6 (Miscellaneous Storage)for a specified ProductID.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetStock', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnGetStock. Enter a valid ProductID from the Production.ProductInventory table.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnGetStock', 'PARAMETER', N'@ProductID'
GO

Collapse image See also

List of functions


ufnLeadingZeros

Function: AdventureWorks2016CTP3.dbo.ufnLeadingZeros

Collapse image Description

Scalar function used by the Sales.Customer table to help set the account number.

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 677577452

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Value | Input parameter for the scalar function ufnLeadingZeros. Enter a valid integer. | int | 4 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | varchar | 8

Collapse image Objects that depend on ufnLeadingZeros

Object name | Object type | Dep level
Sales.Customer | Table | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Scalar function used by the Sales.Customer table to help set the account number.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].[ufnLeadingZeros](
    @Value int
)
RETURNS varchar(8)
WITH SCHEMABINDING
AS
BEGIN
    DECLARE @ReturnValue varchar(8);

    SET @ReturnValue = CONVERT(varchar(8), @Value);
    SET @ReturnValue = REPLICATE('0', 8 - DATALENGTH(@ReturnValue)) + @ReturnValue;

    RETURN (@ReturnValue);
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Scalar function used by the Sales.Customer table to help set the account number.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnLeadingZeros', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the scalar function ufnLeadingZeros. Enter a valid integer.', 'SCHEMA', N'dbo', 'FUNCTION', N'ufnLeadingZeros', 'PARAMETER', N'@Value'
GO

Collapse image See also

List of functions


ufnLeadingZeros_native

Function: AdventureWorks2016CTP3.dbo.ufnLeadingZeros_native

Collapse image Function properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | Scalar
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 1732201221

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | DataType | Max length | ReadOnly
@Value |  | int | 4 |

Collapse image Recordset returned

Name | Datatype | Max length
@Return | varchar | 8

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE FUNCTION [dbo].ufnLeadingZeros_native(
    @Value int
)
RETURNS varchar(8)
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH (TRANSACTION ISOLATION LEVEL = SNAPSHOT, LANGUAGE = N'English')

    DECLARE @ReturnValue varchar(8);

    SET @ReturnValue = CONVERT(varchar(8), @Value);

    DECLARE @i int = 0, @count int = 8 - LEN(@ReturnValue)

    WHILE @i < @count
    BEGIN
        SET @ReturnValue = '0' + @ReturnValue;
        SET @i += 1
    END

    RETURN (@ReturnValue);

END

GO

Collapse image See also

List of functions


vSalesOrderDetail_extended_inmem

Function: AdventureWorks2016CTP3.Sales.vSalesOrderDetail_extended_inmem

CollapseAll image

Collapse image Function properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | Inline
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 596197174

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
SalesOrderID | int | 4
SalesOrderDetailID | bigint | 8
CarrierTrackingNumber | nvarchar | 25
OrderQty | smallint | 2
ProductID | int | 4
SpecialOfferID | int | 4
UnitPrice | money | 8
UnitPriceDiscount | money | 8
ModifiedDate | datetime2 | 8
LineTotal | decimal | 17

Collapse image Objects that Sales.vSalesOrderDetail_extended_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderDetail_inmem | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE FUNCTION Sales.[vSalesOrderDetail_extended_inmem] ()
RETURNS TABLE
WITH SCHEMABINDING, NATIVE_COMPILATION
    RETURN SELECT SalesOrderID,
        SalesOrderDetailID,
        CarrierTrackingNumber,
        OrderQty,
        ProductID,
        SpecialOfferID,
        UnitPrice,
        UnitPriceDiscount,
        ModifiedDate,
        ISNULL(UnitPrice * (1.0 - UnitPriceDiscount) * OrderQty, 0.0) AS LineTotal
    FROM Sales.SalesOrderDetail_inmem
GO

Collapse image See also

List of functions


vSalesOrderHeader_extended_inmem

Function: AdventureWorks2016CTP3.Sales.vSalesOrderHeader_extended_inmem

CollapseAll image

Collapse image Function properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | Inline
Is schema bound |
Is deterministic |
Encrypted |
Implementation type | Transact SQL
ID | 452196661

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Recordset returned

Name | Datatype | Max length
SalesOrderID | int | 4
RevisionNumber | tinyint | 1
OrderDate | datetime2 | 8
DueDate | datetime2 | 8
ShipDate | datetime2 | 8
Status | tinyint | 1
OnlineOrderFlag | bit | 1
PurchaseOrderNumber | nvarchar | 25
AccountNumber | nvarchar | 15
CustomerID | int | 4
SalesPersonID | int | 4
TerritoryID | int | 4
BillToAddressID | int | 4
ShipToAddressID | int | 4
ShipMethodID | int | 4
CreditCardID | int | 4
CreditCardApprovalCode | varchar | 15
CurrencyRateID | int | 4
SubTotal | money | 8
Freight | money | 8
TaxAmt | money | 8
Comment | nvarchar | 128
ModifiedDate | datetime2 | 8
SalesOrderNumber | nvarchar | 25
TotalDue | money | 8

Collapse image Objects that Sales.vSalesOrderHeader_extended_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderHeader_inmem | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE FUNCTION Sales.[vSalesOrderHeader_extended_inmem] ()
RETURNS TABLE
WITH SCHEMABINDING, NATIVE_COMPILATION
    RETURN SELECT SalesOrderID,
        RevisionNumber,
        OrderDate,
        DueDate,
        ShipDate,
        Status,
        OnlineOrderFlag,
        PurchaseOrderNumber,
        AccountNumber,
        CustomerID,
        SalesPersonID,
        TerritoryID,
        BillToAddressID,
        ShipToAddressID,
        ShipMethodID,
        CreditCardID,
        CreditCardApprovalCode,
        CurrencyRateID,
        SubTotal,
        Freight,
        TaxAmt,
        Comment,
        ModifiedDate,
        ISNULL(N'SO' + CONVERT([nvarchar](23), SalesOrderID), N'*** ERROR ***') AS SalesOrderNumber,
        ISNULL(SubTotal + TaxAmt + Freight, 0) AS TotalDue
    FROM Sales.SalesOrderHeader_inmem
GO

Collapse image See also

List of functions


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
AUDIT_prc_AggregateReport | dbo |  | 10 | 0 |  | 21.09.2016
AUDIT_prc_Analyze | dbo |  | 0 | 10 |  | 21.09.2016
AUDIT_prc_DDLReport | dbo |  | 6 | 0 |  | 21.09.2016
AUDIT_prc_DeleteArchitecture | dbo |  | 1 | 0 |  | 21.09.2016
AUDIT_prc_Purge_AUDIT_LOG | dbo |  | 4 | 0 |  | 21.09.2016
AUDIT_prc_ReportingAddFilterValue | dbo |  | 2 | 0 |  | 21.09.2016
AUDIT_prc_ReportingEnd | dbo |  | 0 | 0 |  | 21.09.2016
AUDIT_prc_ReportingStart | dbo |  | 0 | 0 |  | 21.09.2016
AUDIT_prc_StandardReport | dbo |  | 6 | 0 |  | 21.09.2016
uspAddOrderTrackingEvent | dbo |  | 3 | 0 |  | 16.11.2015
uspGetBillOfMaterials | dbo | Stored procedure using a recursive query to return a multi-level bill of material for the specified ProductID. | 2 | 0 |  | 16.11.2015
uspGetEmployeeManagers | dbo | Stored procedure using a recursive query to return the direct and indirect managers of the specified employee. | 1 | 0 |  | 16.11.2015
uspGetManagerEmployees | dbo | Stored procedure using a recursive query to return the direct and indirect employees of the specified manager. | 1 | 0 |  | 16.11.2015
uspGetOrderTrackingBySalesOrderID | dbo |  | 1 | 0 |  | 16.11.2015
uspGetOrderTrackingByTrackingNumber | dbo |  | 1 | 0 |  | 16.11.2015
uspGetWhereUsedProductID | dbo | Stored procedure using a recursive query to return all components or assemblies that directly or indirectly use the specified ProductID. | 2 | 0 |  | 16.11.2015
uspLogError | dbo | Logs error information in the ErrorLog table about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without inserting error information. | 0 | 1 |  | 23.10.2015
uspPrintError | dbo | Prints error information about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without printing any error information. | 0 | 0 |  | 23.10.2015
uspSearchCandidateResumes | dbo |  | 4 | 0 |  | 16.11.2015
usp_DemoInitSeed | Demo |  | 1 | 0 |  | 23.10.2015
usp_DemoReset | Demo |  | 0 | 0 |  | 23.10.2015
sp_GetEmployee_Person_Info_AsOf | HumanResources |  | 1 | 0 |  | 23.10.2015
sp_UpdateEmployee_Temporal | HumanResources |  | 7 | 0 |  | 23.10.2015
uspUpdateEmployeeHireInfo | HumanResources | Updates the Employee table and inserts a new row in the EmployeePayHistory table with the values specified in the input parameters. | 7 | 0 |  | 16.11.2015
uspUpdateEmployeeLogin | HumanResources | Updates the Employee table with the values specified in the input parameters for the given BusinessEntityID. | 6 | 0 |  | 16.11.2015
uspUpdateEmployeePersonalInfo | HumanResources | Updates the Employee table with the values specified in the input parameters for the given EmployeeID. | 5 | 0 |  | 16.11.2015
sp_DeletePerson_Temporal | Person |  | 1 | 0 |  | 23.10.2015
sp_UpdatePerson_Temporal | Person |  | 8 | 0 |  | 23.10.2015
usp_InsertSalesOrder_inmem | Sales |  | 16 | 1 |  | 23.10.2015
usp_InsertSalesOrder_ondisk | Sales |  | 16 | 1 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_inmem | Sales |  | 7 | 0 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_native | Sales |  | 7 | 0 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_ondisk | Sales |  | 7 | 0 |  | 23.10.2015
test | SQLCop |  | 0 | 0 |  | 21.09.2016
[test Ad hoc distributed queries] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Agent Service] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto close] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto create statistics] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto Shrink] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto update statistics] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Buffer cache hit ratio] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column collation does not match database default] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column data types (Numeric vs. Int)] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column Name Problems] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns of data type Text/nText] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns with float data type] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns with image data type] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Compatibility Level] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database and Log files on the same disk] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database collation] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database Mail] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Decimal Size Problem] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Forwarded Records] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Fragmented Indexes] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Instant File Initialization] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Login Language] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Max degree of parallelism] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Missing Foreign Key Indexes] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Missing Foreign Keys] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Old Backups] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Ole Automation Procedures] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Orphaned Users] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Page life expectancy] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures Named SP_] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures that call undocumented procedures] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures using dynamic SQL without sp_executesql] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures with @@Identity] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures With SET ROWCOUNT] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures without SET NOCOUNT ON] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Service Account] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test SMO and DMO] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Table name problems] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables that start with tbl] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables without a primary key] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables without any data] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test UniqueIdentifier with NewId] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Unnamed Constraints] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test User Aliases] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Varchar Size Problem] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Views with order by] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Wide Table] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test xp_cmdshell is enabled] | SQLCop |  | 0 | 0 |  | 19.09.2016
Total: 82 procedure(s)

Collapse image See also

Functions

Database overview


AUDIT_prc_AggregateReport

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_AggregateReport

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 1291867669
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@DATE_FROM |  | nvarchar | 50 | Input |
@DATE_TO |  | nvarchar | 50 | Input |
@WHERE |  | nvarchar | 4000 | Input |
@ROW_COUNT |  | int | 4 | Input |
@GroupByDate |  | tinyint | 1 | Input |
@GroupByTableName |  | bit | 1 | Input |
@GroupByMODIFIED_BY |  | bit | 1 | Input |
@GroupByACTION |  | bit | 1 | Input |
@GroupByAPPLICATION |  | bit | 1 | Input |
@GroupByCOMPUTER |  | bit | 1 | Input |

Collapse image Objects that depend on AUDIT_prc_AggregateReport

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE [dbo].[AUDIT_prc_AggregateReport]
    @DATE_FROM             nvarchar(50)    = NULL,
    @DATE_TO             nvarchar(50)    = NULL,
    @WHERE                nvarchar(4000)    = NULL,
    @ROW_COUNT             int             = NULL,
    @GroupByDate         tinyint         = 1,
    @GroupByTableName     bit             = 0,
    @GroupByMODIFIED_BY bit             = 0,
    @GroupByACTION         bit             = 0,
    @GroupByAPPLICATION bit             = 0,
    @GroupByCOMPUTER     bit             = 0
AS
DECLARE    @sqlstr nvarchar(4000)
DECLARE    @DateExpression varchar(8000)
DECLARE    @DateFieldName varchar(20)
DECLARE @SearcheableName nvarchar(261)
declare @len int
declare @ver7 bit
declare @ver2000 bit
declare @WhereSql nvarchar(4000)
declare @cmptlvl int
Select @cmptlvl = t1.cmptlevel
from master.dbo.sysdatabases t1
where t1.[name]=DB_NAME()
set @ver7 = 0
IF @cmptlvl < 80 set @ver7 = 1
set @ver2000 = 0
IF @cmptlvl < 90 set @ver2000 = 1
IF @GroupByDate not in (0,1,2,3,4)
BEGIN
  RAISERROR ('@GroupByDate must be one of: 0,1,2,3,4',16,1)
  RETURN -1
END
if (select count(*) from ##Filter where [index]='DATABASE') = 0
    insert into ##Filter([index], [value]) values('DATABASE', '%')
if (select count(*) from ##Filter where [index]='TABLE_NAME') = 0
    insert into ##Filter([index], [value]) values('TABLE_NAME', '%')
if (select count(*) from ##Filter where [index]='TABLE_OWNER') = 0
    insert into ##Filter([index], [value]) values('TABLE_OWNER', '%')
if (select count(*) from ##Filter where [index]='USER_NAME') = 0
    insert into ##Filter([index], [value]) values('USER_NAME', '%')
if (select count(*) from ##Filter where [index]='ACTION_ID') = 0
    insert into ##Filter([index], [value]) values('ACTION_ID', '%')
if (select count(*) from ##Filter where [index]='HOST_NAME') = 0
    insert into ##Filter([index], [value]) values('HOST_NAME', '%')
if (select count(*) from ##Filter where [index]='APP_NAME') = 0
    insert into ##Filter([index], [value]) values('APP_NAME', '%')
SET @DateExpression =
  CASE
   WHEN @GroupByDate = 0
    THEN ''
   WHEN @GroupByDate = 1
    THEN 'LEFT(CONVERT(varchar(20), convert(datetime,MODIFIED_DATE), 100),14) + RIGHT(CONVERT(varchar(20), convert(datetime,MODIFIED_DATE), 100),2) '
   WHEN @GroupByDate = 2
    THEN 'CONVERT(varchar(20), CONVERT(datetime,MODIFIED_DATE), 107) '
   WHEN @GroupByDate = 3
    THEN 'LEFT(CONVERT(varchar(20), CONVERT(datetime,MODIFIED_DATE), 107),4)+RIGHT(CONVERT(varchar(20), CONVERT(datetime,MODIFIED_DATE), 107),4) '
   WHEN @GroupByDate = 4
    THEN 'RIGHT(CONVERT(varchar(20), CONVERT(datetime,MODIFIED_DATE), 107),4) '
  END
SET @DateFieldName =
  CASE
   WHEN @GroupByDate = 0
    THEN ''
   WHEN @GroupByDate = 1
    THEN ' AS ''Hour'''
   WHEN @GroupByDate = 2
    THEN ' AS ''Date'''
   WHEN @GroupByDate = 3
    THEN ' AS ''Month'''
   WHEN @GroupByDate = 4
    THEN ' AS ''Year'''
  END
SET @sqlstr = '
select TOP'+STR(CASE WHEN @ROW_COUNT is null THEN 99999 ELSE @ROW_COUNT END)+' * from (
SELECT sum(DATA_COUNT) AS [#], t.[DATABASE] as ''Database'''+
 CASE
  WHEN @GroupByTableName = 0 THEN ''
  ELSE ', TABLE_NAME as [Table name], TABLE_SCHEMA as [' +
    CASE @ver2000 WHEN 1 THEN 'Owner' ELSE 'Table schema' END +']'
 END +
 CASE
  WHEN @GroupByMODIFIED_BY = 0 THEN ''
  ELSE ', MODIFIED_BY as [Modified by]'
 END +
 CASE
  WHEN @GroupByACTION = 0 THEN ''
  ELSE ', CASE t.AUDIT_ACTION_ID
              WHEN 1 THEN ''Update''
              WHEN 2 THEN ''Insert''
              WHEN 3 THEN ''Delete''
          END AS [Action]'
 END +
 CASE
  WHEN @GroupByAPPLICATION = 0 THEN ''
  ELSE ', APPLICATION as [Application]'
 END +
 CASE
  WHEN @GroupByCOMPUTER = 0 THEN ''
  ELSE ', COMPUTER as [Computer]'
 END +
 CASE
  WHEN @DateExpression <> ''
  THEN ', '
  ELSE ''
 END +
@DateExpression+
@DateFieldName
set @sqlstr = @sqlstr +
 ' FROM (
        SELECT
              [DATABASE],
              TABLE_NAME,
              TABLE_SCHEMA,
              AUDIT_ACTION_ID,
              MODIFIED_BY,
              CONVERT(varchar(20), MODIFIED_DATE, 113) AS MODIFIED_DATE,
              HOST_NAME AS COMPUTER,
              APP_NAME as APPLICATION,
                 count(distinct convert(nvarchar(100), t.AUDIT_LOG_TRANSACTION_ID)) [DATA_COUNT]
        from dbo.AUDIT_LOG_TRANSACTIONS t
            inner join dbo.AUDIT_LOG_DATA d
            on t.AUDIT_LOG_TRANSACTION_ID=d.AUDIT_LOG_TRANSACTION_ID
        group by
            [DATABASE] ,
            [TABLE_NAME] ,
            [TABLE_SCHEMA] ,
            [AUDIT_ACTION_ID] ,
            [HOST_NAME] ,
            [APP_NAME] ,
            [MODIFIED_BY] ,
            [MODIFIED_DATE]
    ) t
    inner join ##Filter f1 on f1.[index]=''TABLE_NAME'' and t.TABLE_NAME like Replace(f1.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f2 on f2.[index]=''TABLE_OWNER'' and t.TABLE_SCHEMA like Replace(f2.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f3 on f3.[index]=''APP_NAME'' and t.APPLICATION like Replace(f3.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f4 on f4.[index]=''HOST_NAME'' and t.COMPUTER like Replace(f4.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f5 on f5.[index]=''USER_NAME'' and t.MODIFIED_BY like Replace(f5.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f6 on f6.[index]=''ACTION_ID'' and Cast(t.AUDIT_ACTION_ID as char(1)) like Replace(f6.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    inner join ##Filter f7 on f7.[index]=''DATABASE'' and t.[DATABASE] like Replace(f7.[value]' + case @ver7 when 0 then ' collate database_default' else '' end + ', ''['', ''[[]'')
    where [DATA_COUNT]=[DATA_COUNT]
' +
 CASE
  WHEN @DATE_FROM is NULL THEN ''
  ELSE ' AND CONVERT(DATETIME,MODIFIED_DATE) >= '''+CONVERT(varchar(20),@DATE_FROM,120)+''''
 END +
 CASE
  WHEN @DATE_TO is NULL THEN ''
  ELSE ' AND CONVERT(DATETIME,MODIFIED_DATE) < '''+CONVERT(varchar(20),@DATE_TO,120)+''''
 END +
CASE
  WHEN @DateExpression = ''  THEN ' GROUP BY '
  ELSE ' GROUP BY ' + @DateExpression + ','
 END
 + '[DATABASE], ' +
 CASE WHEN @GroupByTableName     = 1     THEN ' TABLE_SCHEMA, TABLE_NAME,'     ELSE '' END +
 CASE WHEN @GroupByMODIFIED_BY     = 1     THEN ' MODIFIED_BY,'     ELSE '' END +
 CASE WHEN @GroupByACTION     = 1     THEN ' AUDIT_ACTION_ID,'     ELSE '' END +
 CASE WHEN @GroupByAPPLICATION     = 1     THEN ' APPLICATION,'     ELSE '' END +
 CASE WHEN @GroupByCOMPUTER     = 1     THEN ' COMPUTER,'     ELSE '' END
set @len = len(@sqlstr)
if substring(@sqlstr, @len, 1) = ','
begin
    set @sqlstr = substring(@sqlstr,1,@len-1)
end
set @sqlstr = @sqlstr + ') [table]'
if @WHERE IS NOT NULL
begin
    set @WhereSql = @sqlstr+' where '+@WHERE
    exec sp_executesql @WhereSql
end
else
begin
    exec sp_executesql @sqlstr
end
RETURN @@ERROR
GO

Collapse image See also

List of procedures


AUDIT_prc_Analyze

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_Analyze

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 1435868182
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@DDL |  | bit | 1 | Input/output or output |
@Identity |  | bit | 1 | Input/output or output |
@View |  | bit | 1 | Input/output or output |
@standard |  | bit | 1 | Input/output or output |
@aggregate |  | bit | 1 | Input/output or output |
@ddl_report |  | bit | 1 | Input/output or output |
@purge |  | bit | 1 | Input/output or output |
@undo |  | bit | 1 | Input/output or output |
@Delete |  | bit | 1 | Input/output or output |
@Analyze |  | bit | 1 | Input/output or output |

Collapse image Objects that depend on AUDIT_prc_Analyze

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE dbo.AUDIT_prc_Analyze
    @DDL          bit    output,
    @Identity     bit    output,
    @View          bit    output,
    @standard     bit    output,
    @aggregate     bit    output,
    @ddl_report    bit    output,
    @purge          bit    output,
  @undo          bit    output, -- Retained for compatibility with previous architecture
    @Delete        bit    output,
    @Analyze    bit    output
as
    declare @cmptlvl int
    set @Identity=1 --now always
    Select @cmptlvl = t1.cmptlevel
        from master.dbo.sysdatabases t1
        where t1.[name]=DB_NAME()
    --    DDL
    set @DDL=1
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingEnd]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingEnd is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingStart is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingAddFilterValue is Missing'
        END
        if NOT EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_LOG_DATA]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
        BEGIN
            set @DDL = 0
            PRINT '     AUDIT_LOG_DATA is Missing'
        END
        if NOT EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_LOG_TRANSACTIONS]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
        BEGIN
            set @DDL = 0
            PRINT '     AUDIT_LOG_TRANSACTIONS is Missing'
        END
        IF @cmptlvl > 70
        BEGIN
        IF OBJECTPROPERTY(OBJECT_ID('dbo.AUDIT_fn_HexToStr'), 'IsScalarFunction') IS NULL
        BEGIN
            set @DDL = 0
            PRINT '     dbo.AUDIT_fn_HexToStr is Missing'
        END
        IF OBJECTPROPERTY(OBJECT_ID('dbo.AUDIT_fn_SqlVariantToString'), 'IsScalarFunction') IS NULL
        BEGIN
            set @DDL = 0
            PRINT '     dbo.AUDIT_fn_SqlVariantToString is Missing'
        END
        END
                IF @DDL = 0
                BEGIN
                    PRINT 'Internal DDL Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Internal DDL Script(s) OK'
                END
    --    Indentity
    set @View = 1
        if NOT EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_VIEW]') and OBJECTPROPERTY(id, N'IsView') = 1)
        BEGIN
            set @View = 0
            PRINT '     AUDIT_VIEW is Missing'
        END
                    IF @View = 0
                    BEGIN
                        PRINT 'Audit View Script(s) Missing or Incomplete'
                    END
                    ELSE
                    BEGIN
                        PRINT 'Audit View Script(s) OK'
                    END
    set @aggregate = 1
        if NOT EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_AggregateReport]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @aggregate  = 0
            PRINT '     AUDIT_prc_AggregateReport is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @aggregate  = 0
            PRINT '     AUDIT_prc_ReportingStart is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingEnd]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @aggregate  = 0
            PRINT '     AUDIT_prc_ReportingEnd is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @aggregate  = 0
            PRINT '     AUDIT_prc_ReportingAddFilterValue is Missing'
        END
                IF @aggregate = 0
                BEGIN
                    PRINT 'Aggregate Reporting Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Aggregate Reporting Script(s) OK'
                END
    set @standard = 1
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_StandardReport]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard = 0
            PRINT '     AUDIT_prc_StandardReport is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingEnd]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingEnd is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingStart is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @standard  = 0
            PRINT '     AUDIT_prc_ReportingAddFilterValue is Missing'
        END
                IF @standard = 0
                BEGIN
                    PRINT 'Standard Reporting Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Standard Reporting Script(s) OK'
                END
    set @ddl_report = 1
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_DDLReport]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @ddl_report = 0
            PRINT '     AUDIT_prc_DDLReport is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingEnd]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @ddl_report  = 0
            PRINT '     AUDIT_prc_ReportingEnd is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @ddl_report  = 0
            PRINT '     AUDIT_prc_ReportingStart is Missing'
        END
        if not exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @ddl_report  = 0
            PRINT '     AUDIT_prc_ReportingAddFilterValue is Missing'
        END
                IF @ddl_report = 0
                BEGIN
                    PRINT 'DDL Reporting Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'DDL Reporting Script(s) OK'
                END
    set @purge = 1
        if NOT exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_Purge_AUDIT_LOG]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @purge = 0
            PRINT '     AUDIT_prc_Purge_AUDIT_LOG'
        END
                IF @purge = 0
                BEGIN
                    PRINT 'Audit Data Purge Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Audit Data Purge Script(s) OK'
                END
    set @Delete = 1
        if NOT EXISTS (select * from dbo.sysobjects where name = 'AUDIT_prc_DeleteArchitecture')
        BEGIN
            set @Delete = 0
            PRINT '     AUDIT_prc_DeleteArchitecture is Missing'
        END
                IF @Delete = 0
                BEGIN
                    PRINT 'Delete Architecture Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Delete Architecture Script(s) OK'
                END
    set @Analyze = 1
        if NOT EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_Analyze]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
        BEGIN
            set @Delete = 0
            PRINT '     AUDIT_prc_Analyze is Missing'
        END
                IF @Analyze = 0
                BEGIN
                    PRINT 'Analyze Script(s) Missing or Incomplete'
                END
                ELSE
                BEGIN
                    PRINT 'Analyze Script(s) OK'
                END
GO

Collapse image See also

List of procedures


AUDIT_prc_DDLReport

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_DDLReport

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 72387327
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@DATE_FROM |  | nvarchar | 50 | Input |
@DATE_TO |  | nvarchar | 50 | Input |
@OLD_VALUE |  | nvarchar | 4000 | Input |
@NEW_VALUE |  | nvarchar | 4000 | Input |
@WHERE |  | nvarchar | 4000 | Input |
@ROW_COUNT |  | int | 4 | Input |

Collapse image Objects that depend on AUDIT_prc_DDLReport

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE dbo.AUDIT_prc_DDLReport
(    @DATE_FROM             nvarchar(50)        = NULL,
    @DATE_TO               nvarchar(50)        = NULL,
  @OLD_VALUE            nvarchar(4000)    = NULL,
  @NEW_VALUE            nvarchar(4000)    = NULL,
  @WHERE                  nvarchar(4000)    = NULL,
  @ROW_COUNT            int               = NULL)
AS
SET NOCOUNT ON;
DECLARE
@rowCount nchar(100),
@database nchar(1000),
@schema nchar(1000),
@action nchar(1000),
@oldValue nchar(1000),
@newValue nchar(1000),
@appName nchar(1000),
@hostName nchar(1000),
@modifiedBy nchar(1000),
@modifiedDate nchar(1000),
@dateFrom nchar(100),
@dateTo nchar(100),
@whereClause nchar(1000),
@query nchar(4000);
-- Set row count
IF @ROW_COUNT IS NULL
  BEGIN
    SET @rowCount = '99999';
  END
ELSE
  BEGIN
    SET @rowCount = CAST(@ROW_COUNT as nchar(100));
  END
-- Set new value
IF @NEW_VALUE IS NULL
  BEGIN
    SET @newValue = '%';
  END
ELSE
  BEGIN
    SET @newValue = '%' + RTRIM(@NEW_VALUE) + '%';
  END
-- Set new value
IF @OLD_VALUE IS NULL
  BEGIN
    SET @oldValue = '%';
  END
ELSE
  BEGIN
    SET @oldValue = '%' + RTRIM(@OLD_VALUE) + '%';
  END
-- Set WHERE clause
IF @WHERE IS NULL
  BEGIN
    SET @whereClause = '';
  END
ELSE
  BEGIN
    SET @whereClause = ' AND (' + RTRIM(@WHERE) + ')';
  END
-- Set date from
IF @DATE_FROM IS NULL
  BEGIN
    SET @dateFrom = '1/1/1900';
  END
ELSE
  BEGIN
    SET @dateFrom = CONVERT(nchar(100), @DATE_FROM, 120);
  END
-- Set date to
IF @DATE_TO IS NULL
  BEGIN
    SET @dateTo = '1/1/3900';
  END
ELSE
  BEGIN
    SET @dateTo = CONVERT(nchar(100), @DATE_TO, 120);
  END
DECLARE
@id int,
@value nchar(1000);
DECLARE
@counter int,
@filterValue nchar(1000);
-- Set filter for DATABASE
IF (select count(*) from ##Filter WHERE [index]='DATABASE') = 0
  BEGIN
      SET @database = ' WHERE [DATABASE] LIKE ''%''';
  END
ELSE
  BEGIN
      SET @database = ' WHERE [DATABASE] LIKE ''%''';
  END
  SET @database = RTRIM(@database);
-- Set filter for SCHEMA
CREATE TABLE ##FilterSchema
(
  id int identity(1,1) not null,
  value nchar(1000)
  primary key(id)
)
IF (select count(*) from ##Filter WHERE [index]='SCHEMA') = 0
  SET @schema = '';
ELSE
BEGIN
  INSERT INTO ##FilterSchema (value)
    SELECT [value] FROM ##Filter
    WHERE [index] = 'SCHEMA';
  SET @counter = 1;
  WHILE (@counter <= (SELECT MAX(id) FROM ##FilterSchema))
    BEGIN
      SET @filterValue = (SELECT value FROM ##FilterSchema WHERE id=@counter);
      IF @counter = 1
        BEGIN
          SET @schema = ' AND ([SCHEMA] LIKE ''' + RTRIM(@filterValue) + ''''
        END
      ELSE
        BEGIN
          SET @schema = RTRIM(@schema) + ' OR [SCHEMA] LIKE ''' + RTRIM(@filterValue) + ''''
        END
      SET @counter = @counter + 1
      SET @schema = RTRIM(@schema);
    END
    SET @schema = RTRIM(@schema) + ')';
END
    DROP TABLE ##FilterSchema;
-- Set filter for ACTION
CREATE TABLE ##FilterAction
(
  id int identity(1,1) not null,
  value nchar(1000)
  primary key(id)
)
IF (select count(*) from ##Filter WHERE [index]='ACTION_ID') = 0
    SET @action = '';
ELSE
  INSERT INTO ##FilterAction (value)
    SELECT [value] FROM ##Filter
    WHERE [index] = 'ACTION_ID';
  SET @counter = 1;
  WHILE (@counter <= (SELECT MAX(id) FROM ##FilterAction))
    BEGIN
      SET @filterValue = (SELECT value FROM ##FilterAction WHERE id=@counter);
      IF @filterValue LIKE '%4%'
        BEGIN
          SET @filterValue = 'CREATE'
        END
      ELSE IF @filterValue LIKE '%5%'
        BEGIN
          SET @filterValue = 'ALTER'
        END
      ELSE IF @filterValue LIKE '%6%'
        BEGIN
          SET @filterValue = 'DROP'
        END
      ELSE
        BEGIN
          SET @filterValue = 'unknown'
        END
      IF @counter = 1
        BEGIN
          SET @action = ' AND (ACTION LIKE ''' + RTRIM(@filterValue) + ''''
        END
      ELSE
        BEGIN
          SET @action = RTRIM(@action) + ' OR ACTION LIKE ''' + RTRIM(@filterValue) + ''''
        END
      SET @counter = @counter + 1;
      SET @action = RTRIM(@action);
    END
    SET @action = RTRIM(@action) + ')';
    DROP TABLE ##FilterAction;
-- Set filter for OLD_VALUE
IF @OLD_VALUE IS NULL
  SET @oldValue = '';
ELSE
  SET @oldValue = ' AND (OLD_VALUE LIKE ''' + RTRIM(@oldValue) + ''')';
-- Set filter for NEW_VALUE
IF @NEW_VALUE IS NULL
  SET @newValue = '';
ELSE
  SET @newValue = ' AND (NEW_VALUE LIKE ''' + RTRIM(@newValue) + ''')';
-- Set filter for APP_NAME
CREATE TABLE ##FilterAppName
(
  id int identity(1,1) not null,
  value nchar(1000)
  primary key(id)
)
IF (select count(*) from ##Filter WHERE [index]='APP_NAME') = 0
    SET @appName = '';
ELSE
BEGIN
  INSERT INTO ##FilterAppName (value)
    SELECT [value] FROM ##Filter
    WHERE [index] = 'APP_NAME';
  SET @counter = 1;
  WHILE (@counter <= (SELECT MAX(id) FROM ##FilterAppName))
    BEGIN
      SET @filterValue = (SELECT value FROM ##FilterAppName WHERE id=@counter);
      IF @counter = 1
        BEGIN
          SET @appName = ' AND (APP_NAME LIKE ''' + RTRIM(@filterValue) + ''''
        END
      ELSE
        BEGIN
          SET @appName = RTRIM(@appName) + ' OR APP_NAME LIKE ''' + RTRIM(@filterValue) + ''''
        END
      SET @counter = @counter + 1;
      SET @appName = RTRIM(@appName);
    END
    SET @appName = RTRIM(@appName) + ')';
END
    DROP TABLE ##FilterAppName;
-- Set filter for HOST_NAME
CREATE TABLE ##FilterHostName
(
  id int identity(1,1) not null,
  value nchar(1000)
  primary key(id)
)
IF (select count(*) from ##Filter WHERE [index]='HOST_NAME') = 0
    SET @hostName = '';
ELSE
BEGIN
    INSERT INTO ##FilterHostName (value)
    SELECT [value] FROM ##Filter
    WHERE [index] = 'HOST_NAME';
  SET @counter = 1;
  WHILE (@counter <= (SELECT MAX(id) FROM ##FilterHostName))
    BEGIN
      SET @filterValue = (SELECT value FROM ##FilterHostName WHERE id=@counter);
      IF @counter = 1
        BEGIN
          SET @hostName = ' AND (HOST_NAME LIKE ''' + RTRIM(@filterValue) + ''''
        END
      ELSE
        BEGIN
          SET @hostName = RTRIM(@hostName) + ' OR HOST_NAME LIKE ''' + RTRIM(@filterValue) + ''''
        END
      SET @counter = @counter + 1;
      SET @hostName = RTRIM(@hostName);
    END
    SET @hostName = RTRIM(@hostName) + ')';
END
    DROP TABLE ##FilterHostName;
-- Set filter for MODIFIED_BY
CREATE TABLE ##FilterModifiedBy
(
  id int identity(1,1) not null,
  value nchar(1000)
  primary key(id)
)
IF (select count(*) from ##Filter WHERE [index]='USER_NAME') = 0
    SET @modifiedBy = '';
ELSE
BEGIN
    INSERT INTO ##FilterModifiedBy (value)
    SELECT [value] FROM ##Filter
    WHERE [index] = 'USER_NAME';
  SET @counter = 1;
  WHILE (@counter <= (SELECT MAX(id) FROM ##FilterModifiedBy))
    BEGIN
      SET @filterValue = (SELECT value FROM ##FilterModifiedBy WHERE id=@counter);
      IF @counter = 1
        BEGIN
          SET @modifiedBy = ' AND (MODIFIED_BY LIKE ''' + RTRIM(@filterValue) + ''''
        END
      ELSE
        BEGIN
          SET @modifiedBy = RTRIM(@modifiedBy) + ' OR MODIFIED_BY LIKE ''' + RTRIM(@filterValue) + ''''
        END
      SET @counter = @counter + 1;
      SET @modifiedBy = RTRIM(@modifiedBy);
    END
    SET @modifiedBy = RTRIM(@modifiedBy) + ')';
END
    DROP TABLE ##FilterModifiedBy;
-- Set filter for MODIFIED_DATE
SET @modifiedDate = ' AND MODIFIED_DATE >= ''' + RTRIM(@dateFrom) + ''' AND MODIFIED_DATE <= ''' + RTRIM(@dateTo) + '''';
SET @query = 'SELECT TOP ' + RTRIM(@rowCount) + ' LogId as ''Log ID'', [DATABASE] as ''Database'', [SCHEMA] as ''Schema'', OBJECT_TYPE as ''Object type'', OBJECT_NAME as ''Object name'', ACTION as ''Action'', OLD_VALUE as ''Old value'', NEW_VALUE as ''New value'', DESCRIPTION as ''Description'', MODIFIED_BY as ''Modified by'', MODIFIED_DATE as ''Modified date'', APP_NAME as ''Application name'', HOST_NAME as ''Host name'' FROM AUDIT_LOG_DDL'
+ RTRIM(@database)
+ RTRIM(@whereClause)
+ RTRIM(@schema)
+ RTRIM(@action)
+ RTRIM(@oldValue)
+ RTRIM(@newValue)
+ RTRIM(@appName)
+ RTRIM(@hostName)
+ RTRIM(@modifiedBy)
+ RTRIM(@modifiedDate);
EXECUTE sp_executesql @query;
GO

Collapse image See also

List of procedures


AUDIT_prc_DeleteArchitecture

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_DeleteArchitecture

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 1419868125
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@RemoveServer |  | bit | 1 | Input |

Collapse image Objects that AUDIT_prc_DeleteArchitecture depends on

Object name | Object type | Dep level
dbo.AUDIT_prc_AddAuditUndoItem | Procedure | 1
AUDIT_prc_AggregateReport | Procedure | 1
AUDIT_prc_Analyze | Procedure | 1
dbo.AUDIT_prc_CheckAuditUndo | Procedure | 1
dbo.AUDIT_prc_CommitUndo | Procedure | 1
dbo.AUDIT_prc_CreateAuditUndoReport | Procedure | 1
AUDIT_prc_DDLReport | Procedure | 1
dbo.AUDIT_prc_ExecUndo | Procedure | 1
dbo.AUDIT_prc_GetAuditUndoReport | Procedure | 1
AUDIT_prc_Purge_AUDIT_LOG | Procedure | 1
AUDIT_prc_ReportingAddFilterValue | Procedure | 1
AUDIT_prc_ReportingEnd | Procedure | 1
AUDIT_prc_ReportingStart | Procedure | 1
dbo.AUDIT_prc_RollbackUndo | Procedure | 1
dbo.AUDIT_prc_RunUndo | Procedure | 1
AUDIT_prc_StandardReport | Procedure | 1
dbo.AUDIT_prc_UndoAddTriggersCheck | Procedure | 1
dbo.AUDIT_prc_UndoCheck | Procedure | 1
dbo.AUDIT_prc_UndoGenerateCommand | Procedure | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_DDL | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
dbo.tr_ddl_AUDIT | Trigger | 1
AUDIT_UNDO | View | 1
AUDIT_VIEW | View | 1
Total 25 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE dbo.AUDIT_prc_DeleteArchitecture
    @RemoveServer bit
AS
declare @cmptlvl int
-- Delete Audit Tables
IF  EXISTS (SELECT * FROM sysobjects WHERE id = OBJECT_ID(N'[dbo].[AUDIT_LOG_DATA]') AND type in (N'U')) DROP TABLE [dbo].[AUDIT_LOG_DATA]
IF  EXISTS (SELECT * FROM sysobjects WHERE id = OBJECT_ID(N'[dbo].[AUDIT_LOG_TRANSACTIONS]') AND type in (N'U')) DROP TABLE [dbo].[AUDIT_LOG_TRANSACTIONS]
IF  EXISTS (SELECT * FROM sysobjects WHERE id = OBJECT_ID(N'[dbo].[AUDIT_LOG_DDL]') AND type in (N'U')) DROP TABLE [dbo].[AUDIT_LOG_DDL]
-- Delete DDL trigger
IF EXISTS (SELECT * FROM sys.triggers WHERE name = N'tr_ddl_AUDIT' AND type in (N'TR'))
BEGIN
    DROP TRIGGER tr_ddl_AUDIT ON DATABASE
END
Select @cmptlvl = t1.cmptlevel
from master.dbo.sysdatabases t1
where t1.[name]=DB_NAME()
IF @cmptlvl > 70
BEGIN
declare
@fn_sql nvarchar(4000)
set @fn_sql = 'DROP FUNCTION dbo.AUDIT_fn_HexToStr'
IF OBJECTPROPERTY(OBJECT_ID('dbo.AUDIT_fn_HexToStr'), 'IsScalarFunction') IS NOT NULL
    exec sp_executesql @fn_sql
set @fn_sql = 'DROP FUNCTION dbo.AUDIT_fn_SqlVariantToString'
IF OBJECTPROPERTY(OBJECT_ID('dbo.AUDIT_fn_SqlVariantToString'), 'IsScalarFunction') IS NOT NULL
    exec sp_executesql @fn_sql
END
-- Delete Audit View
IF OBJECT_ID('dbo.AUDIT_VIEW', 'V') IS NOT NULL DROP VIEW dbo.AUDIT_VIEW
IF OBJECT_ID('dbo.AUDIT_UNDO', 'V') IS NOT NULL DROP VIEW dbo.AUDIT_UNDO
-- Delete Common Reporting functions
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
drop procedure [dbo].[AUDIT_prc_ReportingStart]
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingEnd]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
drop procedure [dbo].[AUDIT_prc_ReportingEnd]
-- Delete Aggregate Report
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
    drop procedure [dbo].[AUDIT_prc_ReportingStart]
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
    drop procedure [dbo].[AUDIT_prc_ReportingAddFilterValue]
IF OBJECT_ID('dbo.AUDIT_prc_AggregateReport','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_AggregateReport
-- Delete Standard Report
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingStart]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
    drop procedure [dbo].[AUDIT_prc_ReportingStart]
if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_prc_ReportingAddFilterValue]') and OBJECTPROPERTY(id, N'IsProcedure') = 1)
    drop procedure [dbo].[AUDIT_prc_ReportingAddFilterValue]
IF OBJECT_ID('dbo.AUDIT_prc_StandardReport','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_StandardReport
-- Delete DDL Report
IF OBJECT_ID('dbo.AUDIT_prc_DDLReport','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_DDLReport
-- Delete Purge Data Sproc
IF OBJECT_ID('dbo.AUDIT_prc_Purge_AUDIT_LOG','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_Purge_AUDIT_LOG
-- Delete Undo Procedures
IF OBJECT_ID('dbo.AUDIT_prc_AddAuditUndoItem','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_AddAuditUndoItem
IF OBJECT_ID('dbo.AUDIT_prc_CheckAuditUndo','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_CheckAuditUndo
IF OBJECT_ID('dbo.AUDIT_prc_CommitUndo','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_CommitUndo
IF OBJECT_ID('dbo.AUDIT_prc_RollbackUndo','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_RollbackUndo
IF OBJECT_ID('dbo.AUDIT_prc_UndoGenerateCommand','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_UndoGenerateCommand]
IF OBJECT_ID('dbo.AUDIT_prc_UndoCheck','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_UndoCheck]
IF OBJECT_ID('dbo.AUDIT_prc_GetAuditUndoReport','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_GetAuditUndoReport]
IF OBJECT_ID('dbo.AUDIT_prc_RunUndo','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_RunUndo]
IF OBJECT_ID('dbo.AUDIT_prc_ExecUndo','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_ExecUndo]
IF OBJECT_ID('dbo.AUDIT_prc_CreateAuditUndoReport','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_CreateAuditUndoReport]
IF OBJECT_ID('dbo.AUDIT_prc_UndoAddTriggersCheck','P') IS NOT NULL DROP PROCEDURE [dbo].[AUDIT_prc_UndoAddTriggersCheck]
-- Delete Analyze Procedures
IF OBJECT_ID('dbo.AUDIT_prc_Analyze','P') IS NOT NULL DROP PROCEDURE dbo.AUDIT_prc_Analyze
-- Delete Audit Triggers
DECLARE @trname nvarchar(261)
DECLARE @usname nvarchar(261)
DECLARE @sql nvarchar(4000)
create table #names(username nvarchar(2000), name nvarchar(2000));
IF @cmptlvl < 90
set @sql='insert into #names select u.name, o.name
from sysobjects o, syscomments c, sysusers u
  where o.xtype = ''TR''
  and o.id = c.id
  and c.colid = 1
  and u.uid=o.uid
  and c.text like ''%<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>%'''
else
set @sql='insert into #names select u.name, o.name
from sysobjects o, syscomments c, sys.schemas u
  where o.xtype = ''TR''
  and o.id = c.id
  and c.colid = 1
  and u.schema_id=o.uid
  and c.text like ''%<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>%'''
EXEC sp_executesql @sql
DECLARE CRTR CURSOR LOCAL FAST_FORWARD READ_ONLY FOR
  SELECT distinct username, name
  FROM #names
OPEN CRTR
FETCH CRTR INTO @usname, @trname
WHILE @@FETCH_STATUS=0
BEGIN
   SET @sql=N'DROP TRIGGER ['+@usname+'].['+@trname+']'
   print @sql
   EXEC sp_executesql @sql
   FETCH CRTR INTO @usname, @trname
END
CLOSE CRTR DEALLOCATE CRTR
drop table #names;
GO

Collapse image See also

List of procedures


AUDIT_prc_Purge_AUDIT_LOG

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_Purge_AUDIT_LOG

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 1403868068
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@DELETE_ALL |  | bit | 1 | Input |
@OLDER_THAN |  | int | 4 | Input |
@OLDER_THAN_TYPE |  | tinyint | 1 | Input |
@MAX_ROWS |  | int | 4 | Input |

Collapse image Objects that depend on AUDIT_prc_Purge_AUDIT_LOG

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image Objects that AUDIT_prc_Purge_AUDIT_LOG depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_DDL | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
/* ------------------------------------------------------------
   PROCEDURE:     AUDIT_prc_Purge_AUDIT_LOG
   AUTHOR:        ApexSQL
   UPDATED:            19 Apr 2004
   CHANGES:       Version 2.10
                    Added @DELETE_ALL Parameter which will delete ALL Audit
                    Log data regardless of what other parameters were specifiec
                    Fixed some problems where data in AUDIT_LOG_DATA was not being deleted only AUDIT_LOG_TRANSACTIONS
------------------------------------------------------------ */
CREATE PROCEDURE dbo.AUDIT_prc_Purge_AUDIT_LOG
(
    @DELETE_ALL BIT,            --    This will delete all data
    @OLDER_THAN INT = NULL,            --    pass NULL to skip this check
    @OLDER_THAN_TYPE TINYINT = NULL,    --     1 - DAY, 2 - WEEK, 3 - MONTH; if @older_than is NULL, this parameter is not important
    @MAX_ROWS INT = NULL            --    pass NULL to skip this check
)
AS
BEGIN
  DECLARE @DDLExists BIT
  SET @DDLExists = 0
  BEGIN
    IF EXISTS (select * from dbo.sysobjects where id = object_id(N'[dbo].[AUDIT_LOG_DDL]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
          BEGIN
              set @DDLExists = 1
          END
  END
  -- Delete all data from auditing tables
    If @DELETE_ALL = 1
    BEGIN
        DELETE FROM dbo.AUDIT_LOG_DATA
        DELETE FROM dbo.AUDIT_LOG_TRANSACTIONS
    IF @DDLExists = 1
    BEGIN
      DELETE FROM dbo.AUDIT_LOG_DDL
    END
    END
    IF @OLDER_THAN IS NOT NULL
    BEGIN
        -- Get the cut off date and time
        DECLARE @CUTOFF_DATETIME DATETIME
        SET @CUTOFF_DATETIME =
            CASE @OLDER_THAN_TYPE
                WHEN 1 THEN DATEADD(DAY, -@OLDER_THAN, GETDATE())
                WHEN 2 THEN DATEADD(WEEK,-@OLDER_THAN, GETDATE())
                WHEN 3 THEN DATEADD(MONTH, -@OLDER_THAN, GETDATE())
            END
        -- Delete all rows from auditing tables that are older than n day(s)
        PRINT CONVERT(VARCHAR,@CUTOFF_DATETIME)
        DELETE
        FROM dbo.AUDIT_LOG_DATA
        WHERE AUDIT_LOG_TRANSACTION_ID IN
        (SELECT AUDIT_LOG_TRANSACTION_ID FROM dbo.AUDIT_LOG_TRANSACTIONS
        WHERE    MODIFIED_DATE < @CUTOFF_DATETIME)
        DELETE
        FROM dbo.AUDIT_LOG_TRANSACTIONS
        WHERE
            MODIFIED_DATE < @CUTOFF_DATETIME
    IF @DDLExists = 1
    BEGIN
      DELETE
          FROM dbo.AUDIT_LOG_DDL
          WHERE
              MODIFIED_DATE < @CUTOFF_DATETIME
    END
    END
    -- Check if we should check for max number of rows
    IF @MAX_ROWS IS NOT NULL
    BEGIN
        -- Get AUDIT_LOG_TRANSACTIONS row count
        DECLARE @ROW_COUNT INT
        SELECT @ROW_COUNT = COUNT(*)
        FROM dbo.AUDIT_LOG_TRANSACTIONS
        -- Check if there are more than @MAX_ROWS rows in the database
        IF @ROW_COUNT > @MAX_ROWS
        BEGIN
            -- Create temporary tables to hold ids of records to be purged
            CREATE TABLE #AUDIT_LOG_PURGE_PROCESS_TEMP_TABLE (AUDIT_LOG_TRANSACTION_ID nvarchar(100))
      IF @DDLExists = 1
      BEGIN
        CREATE TABLE #AUDIT_LOG_PURGE_PROCESS_DDL_TEMP_TABLE (LogId int)
      END
            -- Create dynamic queries to fill the temporary tables
            DECLARE @SQL NVARCHAR(4000)
            SET @SQL ='
            INSERT
            INTO #AUDIT_LOG_PURGE_PROCESS_TEMP_TABLE
            SELECT TOP ' + CAST((@ROW_COUNT - @MAX_ROWS) AS varchar(10)) + ' AUDIT_LOG_TRANSACTION_ID
            FROM dbo.AUDIT_LOG_TRANSACTIONS
            ORDER BY MODIFIED_DATE'
      IF @DDLExists = 1
      BEGIN
        DECLARE @SQL_DDL NVARCHAR(4000)
              SET @SQL_DDL ='
              INSERT
              INTO #AUDIT_LOG_PURGE_PROCESS_DDL_TEMP_TABLE
              SELECT TOP ' + CAST((@ROW_COUNT - @MAX_ROWS) AS varchar(10)) + ' LogId
              FROM dbo.AUDIT_LOG_DDL
              ORDER BY MODIFIED_DATE'
      END
            --PRINT @SQL
      --PRINT @SQL_DDL
            -- Fill temporary tables
            EXEC sp_executesql @SQL
      IF @DDLExists = 1
      BEGIN
        EXEC sp_executesql @SQL_DDL
      END
            -- Delete records from auditing tables
            DELETE
            FROM dbo.AUDIT_LOG_DATA
            WHERE AUDIT_LOG_TRANSACTION_ID IN
                    (SELECT AUDIT_LOG_TRANSACTION_ID
                     FROM #AUDIT_LOG_PURGE_PROCESS_TEMP_TABLE)
            DELETE
            FROM dbo.AUDIT_LOG_TRANSACTIONS
            WHERE AUDIT_LOG_TRANSACTION_ID IN
                (SELECT AUDIT_LOG_TRANSACTION_ID
                 FROM #AUDIT_LOG_PURGE_PROCESS_TEMP_TABLE)
      IF @DDLExists = 1
      BEGIN
        DELETE
              FROM dbo.AUDIT_LOG_DDL
              WHERE LogId IN
                  (SELECT LogId
                  FROM #AUDIT_LOG_PURGE_PROCESS_DDL_TEMP_TABLE)
        --Drop temp table
        DROP TABLE #AUDIT_LOG_PURGE_PROCESS_DDL_TEMP_TABLE
      END
            -- Drop temporary tables
            DROP TABLE #AUDIT_LOG_PURGE_PROCESS_TEMP_TABLE
        END
    END
END
GO

Collapse image See also

List of procedures


AUDIT_prc_ReportingAddFilterValue

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_ReportingAddFilterValue

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 56387270
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@index |  | nvarchar | 100 | Input |
@value |  | nvarchar | 4000 | Input |

Collapse image Objects that depend on AUDIT_prc_ReportingAddFilterValue

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

create procedure dbo.AUDIT_prc_ReportingAddFilterValue
@index nvarchar(100),
@value nvarchar(4000)
as
begin
if not exists (select [value] from ##Filter where [index]=@index and [value] like Replace(@value collate database_default, '[', '[[]'))
    insert into ##Filter([index], [value]) values(@index, @value)
end
GO

Collapse image See also

List of procedures


AUDIT_prc_ReportingEnd

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_ReportingEnd

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 40387213
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that depend on AUDIT_prc_ReportingEnd

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
create procedure dbo.AUDIT_prc_ReportingEnd
as
begin
drop table ##Filter
end
GO

Collapse image See also

List of procedures


AUDIT_prc_ReportingStart

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_ReportingStart

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 24387156
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that depend on AUDIT_prc_ReportingStart

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
create procedure dbo.AUDIT_prc_ReportingStart
as
begin
create table ##Filter([index] nvarchar(20), [value] nvarchar(4000))
end
GO

Collapse image See also

List of procedures


AUDIT_prc_StandardReport

Procedure: AdventureWorks2016CTP3.dbo.AUDIT_prc_StandardReport

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 1387868011
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@DATE_FROM |  | nvarchar | 50 | Input |
@DATE_TO |  | nvarchar | 50 | Input |
@OLD_VALUE |  | nvarchar | 4000 | Input |
@NEW_VALUE |  | nvarchar | 4000 | Input |
@WHERE |  | nvarchar | 4000 | Input |
@ROW_COUNT |  | int | 4 | Input |

Collapse image Objects that depend on AUDIT_prc_StandardReport

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE [dbo].[AUDIT_prc_StandardReport]
  (    @DATE_FROM             nvarchar(50)    = NULL,
    @DATE_TO             nvarchar(50)    = NULL,
    @OLD_VALUE            nvarchar(4000)    = NULL,
    @NEW_VALUE            nvarchar(4000)    = NULL,
    @WHERE                nvarchar(4000)   = NULL,
    @ROW_COUNT            int              = NULL)
AS
declare
@strSql nvarchar(4000),
@ver7 bit,
@ver2000 bit,
@WhereSql nvarchar(4000),
@cmptlvl int
Select @cmptlvl = t1.cmptlevel
from master.dbo.sysdatabases t1
where t1.[name]=DB_NAME()
set @ver7 = 0
IF @cmptlvl < 80 set @ver7 = 1
set @ver2000 = 0
IF @cmptlvl < 90 set @ver2000 = 1
set nocount on
/* Set replacement values for filter parameter */
if (select count(*) from ##Filter where [index]='DATABASE') = 0
    insert into ##Filter([index], [value]) values('DATABASE', '%')
if (select count(*) from ##Filter where [index]='TABLE_OWNER') = 0
    insert into ##Filter([index], [value]) values('TABLE_OWNER', '%')
if (select count(*) from ##Filter where [index]='TABLE_NAME') = 0
    insert into ##Filter([index], [value]) values('TABLE_NAME', '%')
if (select count(*) from ##Filter where [index]='FIELD_NAME') = 0
    insert into ##Filter([index], [value]) values('FIELD_NAME', '%')
if (select count(*) from ##Filter where [index]='USER_NAME') = 0
    insert into ##Filter([index], [value]) values('USER_NAME', '%')
if (select count(*) from ##Filter where [index]='ACTION_ID') = 0
    insert into ##Filter([index], [value]) values('ACTION_ID', '%')
if (select count(*) from ##Filter where [index]='HOST_NAME') = 0
    insert into ##Filter([index], [value]) values('HOST_NAME', '%')
if (select count(*) from ##Filter where [index]='APP_NAME') = 0
    insert into ##Filter([index], [value]) values('APP_NAME', '%')
IF @DATE_FROM IS NULL
   SET @DATE_FROM= '1/1/1900'
IF @DATE_TO IS NULL
   SET @DATE_TO = '1/1/3900'
IF @OLD_VALUE IS NULL
   SET @OLD_VALUE = '%'
IF @NEW_VALUE IS NULL
   SET @NEW_VALUE = '%'
IF @ROW_COUNT IS NULL
   SET @ROW_COUNT = 99999
/* Get Object ID */
--SELECT @obj_id = object_id(@full_table_name)
set @strSql = '
declare
@DATE_FROM      datetime,
@DATE_TO        datetime,
@OLD_VALUE      varchar(8000),
@NEW_VALUE      varchar(8000),
@ROW_COUNT      int
set @DATE_FROM = '''+convert(nvarchar(100), @DATE_FROM, 120)+'''
set @DATE_TO = '''+convert(nvarchar(100), @DATE_TO, 120)+'''
set @OLD_VALUE = '''+@OLD_VALUE+'''
set @NEW_VALUE = '''+@NEW_VALUE+'''
set @ROW_COUNT = '+cast(@ROW_COUNT as nvarchar(100))+'
select top '+cast(@ROW_COUNT as nvarchar(100))+' * from (
   SELECT  t.[DATABASE] ''Database'',
           t.TABLE_NAME ''Table name'',
           t.TABLE_SCHEMA ''' +
    CASE @ver2000 WHEN 1 THEN 'Owner' ELSE 'Table schema' END +''',
           CASE    t.AUDIT_ACTION_ID
               WHEN 2 then ''Insert''
               WHEN 1 then ''Update''
               WHEN 3 then ''Delete''
           END         ''Action'',
           KEY1 as ''Key 1'',
           KEY2 as ''Key 2'',
           KEY3 as ''Key 3'',
           KEY4 as ''Key 4'',
           d.COL_NAME ''Column name'',
           d.OLD_VALUE ''Old value'',
           d.NEW_VALUE ''New value'',
           t.MODIFIED_BY ''Modified by'',
           t.MODIFIED_DATE ''Modified date'',
           t.HOST_NAME ''Computer'',
           t.APP_NAME ''Application''
    FROM dbo.AUDIT_LOG_TRANSACTIONS t
    JOIN dbo.AUDIT_LOG_DATA d ON d.AUDIT_LOG_TRANSACTION_ID = t.AUDIT_LOG_TRANSACTION_ID,
    (select [value] from ##Filter where [index]=''DATABASE'') t_db,-- database
    (select [value] from ##Filter where [index]=''TABLE_OWNER'') t_owners,-- owners
    (select [value] from ##Filter where [index]=''TABLE_NAME'') t_tables,-- tables
    (select [value] from ##Filter where [index]=''FIELD_NAME'') t_columns,-- columns
    (select [value] from ##Filter where [index]=''USER_NAME'') t_users,-- users
    (select [value] from ##Filter where [index]=''ACTION_ID'') t_actions,-- actions
    (select [value] from ##Filter where [index]=''HOST_NAME'') t_hosts,-- hosts
    (select [value] from ##Filter where [index]=''APP_NAME'') t_apps -- applications
    WHERE
    t.[DATABASE] like Replace(t_db.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND t.TABLE_SCHEMA like Replace(t_owners.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND t.TABLE_NAME like Replace(t_tables.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND d.COL_NAME like Replace(t_columns.[value]
    ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND t.MODIFIED_BY like Replace(t_users.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND t.MODIFIED_DATE >= @DATE_FROM
      AND t.MODIFIED_DATE < @DATE_TO
      AND Cast(t.AUDIT_ACTION_ID as char(1)) like Replace(t_actions.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND ((d.OLD_VALUE IS NULL AND @OLD_VALUE = ''%'') OR (d.OLD_VALUE LIKE @OLD_VALUE))
      AND ((d.NEW_VALUE IS NULL AND @NEW_VALUE = ''%'') OR (d.NEW_VALUE LIKE @NEW_VALUE))
      AND t.HOST_NAME like Replace(t_hosts.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
      AND t.APP_NAME like Replace(t_apps.[value] ' +
    case @ver7 when 0 then ' collate database_default'
        else '' end +
        ', ''['', ''[[]'')
) [table]'
if @WHERE IS NOT NULL
begin
    set @WhereSql = @strSql+' where '+@WHERE
    exec sp_executesql @WhereSql
end
else
    exec sp_executesql @strSql
RETURN @@ERROR
GO

Collapse image See also

List of procedures


uspAddOrderTrackingEvent

Procedure: AdventureWorks2016CTP3.dbo.uspAddOrderTrackingEvent

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 2029250284
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input |
@TrackingEventID |  | int | 4 | Input |
@EventDetails |  | nvarchar | 2000 | Input |

Collapse image Objects that uspAddOrderTrackingEvent depends on

Object name | Object type | Dep level
uspLogError | Procedure | 1
Sales.OrderTracking | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

----------------------------------------------------------------
-- Create supporting stored procedures
----------------------------------------------------------------
CREATE PROCEDURE [dbo].[uspAddOrderTrackingEvent]
   @SalesOrderID INT,
   @TrackingEventID INT,
   @EventDetails NVARCHAR(2000)
AS
BEGIN
/* Example:
      exec dbo.uspGetOrderTrackingBySalesOrderID 53498
      exec dbo.uspAddOrderTrackingEvent 53498, 7, 'invalid address, package is undeleverable'
      exec dbo.uspGetOrderTrackingBySalesOrderID 53498
*/
   SET NOCOUNT ON;

   BEGIN TRY
      BEGIN TRANSACTION;

      DECLARE @TrackingNumber NVARCHAR(25);

      SET @TrackingNumber = (
         SELECT TOP 1 ot.CarrierTrackingNumber
           FROM Sales.OrderTracking ot
          WHERE ot.SalesOrderID = @SalesOrderID);

      IF (@TrackingNumber IS NULL)
      BEGIN
         SET @TrackingNumber = SUBSTRING(CONVERT(CHAR(255), NEWID()),2,25);
      END;

      INSERT INTO Sales.OrderTracking
         (SalesOrderID, CarrierTrackingNumber, TrackingEventID, EventDetails, EventDateTime)
      VALUES
         (@SalesOrderID, @TrackingNumber, @TrackingEventID, @EventDetails, GETDATE());

      COMMIT TRANSACTION;
   END TRY
   BEGIN CATCH
      -- Rollback any active or uncommittable transactions before
      -- inserting information in the ErrorLog
      IF @@TRANCOUNT > 0
      BEGIN
         ROLLBACK TRANSACTION;
      END

      EXECUTE [dbo].[uspLogError];
   END CATCH;
END;
GO

Collapse image See also

List of procedures


uspGetBillOfMaterials

Procedure: AdventureWorks2016CTP3.dbo.uspGetBillOfMaterials

Collapse image Description

Stored procedure using a recursive query to return a multi-level bill of material for the specified ProductID.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1501248403
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@StartProductID | Input parameter for the stored procedure uspGetBillOfMaterials. Enter a valid ProductID from the Production.Product table. | int | 4 | Input |
@CheckDate | Input parameter for the stored procedure uspGetBillOfMaterials used to eliminate components not used after that date. Enter a valid date. | datetime | 8 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
ProductAssemblyID | int | 4
ComponentID | int | 4
ComponentDesc | nvarchar | 50
TotalQuantity | decimal | 17
StandardCost | money | 8
ListPrice | money | 8
BOMLevel | smallint | 2
RecursionLevel | int | 4

Collapse image Objects that uspGetBillOfMaterials depends on

Object name | Object type | Dep level
Production.BillOfMaterials | Table | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stored procedure using a recursive query to return a multi-level bill of material for the specified ProductID.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetBillOfMaterials]
    @StartProductID [int],
    @CheckDate [datetime]
AS
BEGIN
    SET NOCOUNT ON;

    -- Use recursive query to generate a multi-level Bill of Material (i.e. all level 1
    -- components of a level 0 assembly, all level 2 components of a level 1 assembly)
    -- The CheckDate eliminates any components that are no longer used in the product on this date.
    WITH [BOM_cte]([ProductAssemblyID], [ComponentID], [ComponentDesc], [PerAssemblyQty], [StandardCost], [ListPrice], [BOMLevel], [RecursionLevel]) -- CTE name and columns
    AS (
        SELECT b.[ProductAssemblyID], b.[ComponentID], p.[Name], b.[PerAssemblyQty], p.[StandardCost], p.[ListPrice], b.[BOMLevel], 0 -- Get the initial list of components for the bike assembly
        FROM [Production].[BillOfMaterials] b
            INNER JOIN [Production].[Product] p
            ON b.[ComponentID] = p.[ProductID]
        WHERE b.[ProductAssemblyID] = @StartProductID
            AND @CheckDate >= b.[StartDate]
            AND @CheckDate <= ISNULL(b.[EndDate], @CheckDate)
        UNION ALL
        SELECT b.[ProductAssemblyID], b.[ComponentID], p.[Name], b.[PerAssemblyQty], p.[StandardCost], p.[ListPrice], b.[BOMLevel], [RecursionLevel] + 1 -- Join recursive member to anchor
        FROM [BOM_cte] cte
            INNER JOIN [Production].[BillOfMaterials] b
            ON b.[ProductAssemblyID] = cte.[ComponentID]
            INNER JOIN [Production].[Product] p
            ON b.[ComponentID] = p.[ProductID]
        WHERE @CheckDate >= b.[StartDate]
            AND @CheckDate <= ISNULL(b.[EndDate], @CheckDate)
        )
    -- Outer select from the CTE
    SELECT b.[ProductAssemblyID], b.[ComponentID], b.[ComponentDesc], SUM(b.[PerAssemblyQty]) AS [TotalQuantity] , b.[StandardCost], b.[ListPrice], b.[BOMLevel], b.[RecursionLevel]
    FROM [BOM_cte] b
    GROUP BY b.[ComponentID], b.[ComponentDesc], b.[ProductAssemblyID], b.[BOMLevel], b.[RecursionLevel], b.[StandardCost], b.[ListPrice]
    ORDER BY b.[BOMLevel], b.[ProductAssemblyID], b.[ComponentID]
    OPTION (MAXRECURSION 25)
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stored procedure using a recursive query to return a multi-level bill of material for the specified ProductID.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetBillOfMaterials', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetBillOfMaterials used to eliminate components not used after that date. Enter a valid date.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetBillOfMaterials', 'PARAMETER', N'@CheckDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetBillOfMaterials. Enter a valid ProductID from the Production.Product table.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetBillOfMaterials', 'PARAMETER', N'@StartProductID'
GO

Collapse image See also

List of procedures


uspGetEmployeeManagers

Procedure: AdventureWorks2016CTP3.dbo.uspGetEmployeeManagers

Collapse image Description

Stored procedure using a recursive query to return the direct and indirect managers of the specified employee.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1517248460
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID | Input parameter for the stored procedure uspGetEmployeeManagers. Enter a valid BusinessEntityID from the HumanResources.Employee table. | int | 4 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
RecursionLevel | int | 4
BusinessEntityID | int | 4
FirstName | nvarchar | 50
LastName | nvarchar | 50
OrganizationNode | nvarchar | 4000
ManagerFirstName | nvarchar | 50
ManagerLastName | nvarchar | 50

Collapse image Objects that uspGetEmployeeManagers depends on

Object name | Object type | Dep level
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stored procedure using a recursive query to return the direct and indirect managers of the specified employee.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetEmployeeManagers]
    @BusinessEntityID [int]
AS
BEGIN
    SET NOCOUNT ON;

    -- Use recursive query to list out all Employees required for a particular Manager
    WITH [EMP_cte]([BusinessEntityID], [OrganizationNode], [FirstName], [LastName], [JobTitle], [RecursionLevel]) -- CTE name and columns
    AS (
        SELECT e.[BusinessEntityID], e.[OrganizationNode], p.[FirstName], p.[LastName], e.[JobTitle], 0 -- Get the initial Employee
        FROM [HumanResources].[Employee] e
            INNER JOIN [Person].[Person] as p
            ON p.[BusinessEntityID] = e.[BusinessEntityID]
        WHERE e.[BusinessEntityID] = @BusinessEntityID
        UNION ALL
        SELECT e.[BusinessEntityID], e.[OrganizationNode], p.[FirstName], p.[LastName], e.[JobTitle], [RecursionLevel] + 1 -- Join recursive member to anchor
        FROM [HumanResources].[Employee] e
            INNER JOIN [EMP_cte]
            ON e.[OrganizationNode] = [EMP_cte].[OrganizationNode].GetAncestor(1)
            INNER JOIN [Person].[Person] p
            ON p.[BusinessEntityID] = e.[BusinessEntityID]
    )
    -- Join back to Employee to return the manager name
    SELECT [EMP_cte].[RecursionLevel], [EMP_cte].[BusinessEntityID], [EMP_cte].[FirstName], [EMP_cte].[LastName],
        [EMP_cte].[OrganizationNode].ToString() AS [OrganizationNode], p.[FirstName] AS 'ManagerFirstName', p.[LastName] AS 'ManagerLastName'  -- Outer select from the CTE
    FROM [EMP_cte]
        INNER JOIN [HumanResources].[Employee] e
        ON [EMP_cte].[OrganizationNode].GetAncestor(1) = e.[OrganizationNode]
        INNER JOIN [Person].[Person] p
        ON p.[BusinessEntityID] = e.[BusinessEntityID]
    ORDER BY [RecursionLevel], [EMP_cte].[OrganizationNode].ToString()
    OPTION (MAXRECURSION 25)
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stored procedure using a recursive query to return the direct and indirect managers of the specified employee.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetEmployeeManagers', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetEmployeeManagers. Enter a valid BusinessEntityID from the HumanResources.Employee table.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetEmployeeManagers', 'PARAMETER', N'@BusinessEntityID'
GO

Collapse image See also

List of procedures


uspGetManagerEmployees

Procedure: AdventureWorks2016CTP3.dbo.uspGetManagerEmployees

Collapse image Description

Stored procedure using a recursive query to return the direct and indirect employees of the specified manager.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1533248517
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID | Input parameter for the stored procedure uspGetManagerEmployees. Enter a valid BusinessEntityID of the manager from the HumanResources.Employee table. | int | 4 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
RecursionLevel | int | 4
OrganizationNode | nvarchar | 4000
ManagerFirstName | nvarchar | 50
ManagerLastName | nvarchar | 50
BusinessEntityID | int | 4
FirstName | nvarchar | 50
LastName | nvarchar | 50

Collapse image Objects that uspGetManagerEmployees depends on

Object name | Object type | Dep level
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stored procedure using a recursive query to return the direct and indirect employees of the specified manager.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetManagerEmployees]
    @BusinessEntityID [int]
AS
BEGIN
    SET NOCOUNT ON;

    -- Use recursive query to list out all Employees required for a particular Manager
    WITH [EMP_cte]([BusinessEntityID], [OrganizationNode], [FirstName], [LastName], [RecursionLevel]) -- CTE name and columns
    AS (
        SELECT e.[BusinessEntityID], e.[OrganizationNode], p.[FirstName], p.[LastName], 0 -- Get the initial list of Employees for Manager n
        FROM [HumanResources].[Employee] e
            INNER JOIN [Person].[Person] p
            ON p.[BusinessEntityID] = e.[BusinessEntityID]
        WHERE e.[BusinessEntityID] = @BusinessEntityID
        UNION ALL
        SELECT e.[BusinessEntityID], e.[OrganizationNode], p.[FirstName], p.[LastName], [RecursionLevel] + 1 -- Join recursive member to anchor
        FROM [HumanResources].[Employee] e
            INNER JOIN [EMP_cte]
            ON e.[OrganizationNode].GetAncestor(1) = [EMP_cte].[OrganizationNode]
            INNER JOIN [Person].[Person] p
            ON p.[BusinessEntityID] = e.[BusinessEntityID]
        )
    -- Join back to Employee to return the manager name
    SELECT [EMP_cte].[RecursionLevel], [EMP_cte].[OrganizationNode].ToString() as [OrganizationNode], p.[FirstName] AS 'ManagerFirstName', p.[LastName] AS 'ManagerLastName',
        [EMP_cte].[BusinessEntityID], [EMP_cte].[FirstName], [EMP_cte].[LastName] -- Outer select from the CTE
    FROM [EMP_cte]
        INNER JOIN [HumanResources].[Employee] e
        ON [EMP_cte].[OrganizationNode].GetAncestor(1) = e.[OrganizationNode]
            INNER JOIN [Person].[Person] p
            ON p.[BusinessEntityID] = e.[BusinessEntityID]
    ORDER BY [RecursionLevel], [EMP_cte].[OrganizationNode].ToString()
    OPTION (MAXRECURSION 25)
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stored procedure using a recursive query to return the direct and indirect employees of the specified manager.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetManagerEmployees', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetManagerEmployees. Enter a valid BusinessEntityID of the manager from the HumanResources.Employee table.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetManagerEmployees', 'PARAMETER', N'@BusinessEntityID'
GO

Collapse image See also

List of procedures


uspGetOrderTrackingBySalesOrderID

Procedure: AdventureWorks2016CTP3.dbo.uspGetOrderTrackingBySalesOrderID

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 2061250398
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
SalesOrderID | int | 4
CarrierTrackingNumber | nvarchar | 25
OrderTrackingID | int | 4
TrackingEventID | int | 4
EventName | nvarchar | 255
EventDetails | nvarchar | 2000
EventDateTime | datetime2 | 8

Collapse image Objects that uspGetOrderTrackingBySalesOrderID depends on

Object name | Object type | Dep level
Sales.OrderTracking | Table | 1
Sales.TrackingEvent | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetOrderTrackingBySalesOrderID]
   @SalesOrderID [int] NULL
AS
BEGIN
/* Example:
      exec dbo.uspGetOrderTrackingBySalesOrderID 53498
*/
   SET NOCOUNT ON;

   SELECT
      ot.SalesOrderID,
      ot.CarrierTrackingNumber,
      ot.OrderTrackingID,
      ot.TrackingEventID,
      te.EventName,
      ot.EventDetails,
      ot.EventDateTime
   FROM
      Sales.OrderTracking ot,
      Sales.TrackingEvent te
   WHERE
      ot.SalesOrderID = @SalesOrderID AND
      ot.TrackingEventID = te.TrackingEventID
   ORDER BY
      ot.SalesOrderID,
      ot.TrackingEventID;
END;
GO

Collapse image See also

List of procedures


uspGetOrderTrackingByTrackingNumber

Procedure: AdventureWorks2016CTP3.dbo.uspGetOrderTrackingByTrackingNumber

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 2045250341
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@CarrierTrackingNumber |  | nvarchar | 25 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
SalesOrderID | int | 4
CarrierTrackingNumber | nvarchar | 25
OrderTrackingID | int | 4
TrackingEventID | int | 4
EventName | nvarchar | 255
EventDetails | nvarchar | 2000
EventDateTime | datetime2 | 8

Collapse image Objects that uspGetOrderTrackingByTrackingNumber depends on

Object name | Object type | Dep level
Sales.OrderTracking | Table | 1
Sales.TrackingEvent | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetOrderTrackingByTrackingNumber]
   @CarrierTrackingNumber [nvarchar](25) NULL
AS
BEGIN
/* Example:
      EXEC dbo.uspGetOrderTrackingByTrackingNumber 'EE33-45E8-9F'
      EXEC dbo.uspAddOrderTrackingEvent 53498, 7, 'invalid address, package is undeleverable'
      EXEC dbo.uspGetOrderTrackingByTrackingNumber 'EE33-45E8-9F'
*/
   SET NOCOUNT ON;

   IF (@CarrierTrackingNumber IS NULL)
   BEGIN
      RETURN;
   END;

   SELECT
      ot.SalesOrderID,
      ot.CarrierTrackingNumber,
      ot.OrderTrackingID,
      ot.TrackingEventID,
      te.EventName,
      ot.EventDetails,
      ot.EventDateTime
   FROM
      Sales.OrderTracking ot,
      Sales.TrackingEvent te
   WHERE
      ot.CarrierTrackingNumber = @CarrierTrackingNumber AND
      ot.TrackingEventID = te.TrackingEventID
   ORDER BY
      ot.SalesOrderID,
      ot.TrackingEventID;
END;

GO

Collapse image See also

List of procedures


uspGetWhereUsedProductID

Procedure: AdventureWorks2016CTP3.dbo.uspGetWhereUsedProductID

CollapseAll image

Collapse image Description

Stored procedure using a recursive query to return all components or assemblies that directly or indirectly use the specified ProductID.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1549248574
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@StartProductID | Input parameter for the stored procedure uspGetWhereUsedProductID. Enter a valid ProductID from the Production.Product table. | int | 4 | Input |
@CheckDate | Input parameter for the stored procedure uspGetWhereUsedProductID used to eliminate components not used after that date. Enter a valid date. | datetime | 8 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
ProductAssemblyID | int | 4
ComponentID | int | 4
ComponentDesc | nvarchar | 50
TotalQuantity | decimal | 17
StandardCost | money | 8
ListPrice | money | 8
BOMLevel | smallint | 2
RecursionLevel | int | 4

Collapse image Objects that uspGetWhereUsedProductID depends on

Object name | Object type | Dep level
Production.BillOfMaterials | Table | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stored procedure using a recursive query to return all components or assemblies that directly or indirectly use the specified ProductID.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [dbo].[uspGetWhereUsedProductID]
    @StartProductID [int],
    @CheckDate [datetime]
AS
BEGIN
    SET NOCOUNT ON;

    --Use recursive query to generate a multi-level Bill of Material (i.e. all level 1 components of a level 0 assembly, all level 2 components of a level 1 assembly)
    WITH [BOM_cte]([ProductAssemblyID], [ComponentID], [ComponentDesc], [PerAssemblyQty], [StandardCost], [ListPrice], [BOMLevel], [RecursionLevel]) -- CTE name and columns
    AS (
        SELECT b.[ProductAssemblyID], b.[ComponentID], p.[Name], b.[PerAssemblyQty], p.[StandardCost], p.[ListPrice], b.[BOMLevel], 0 -- Get the initial list of components for the bike assembly
        FROM [Production].[BillOfMaterials] b
            INNER JOIN [Production].[Product] p
            ON b.[ProductAssemblyID] = p.[ProductID]
        WHERE b.[ComponentID] = @StartProductID
            AND @CheckDate >= b.[StartDate]
            AND @CheckDate <= ISNULL(b.[EndDate], @CheckDate)
        UNION ALL
        SELECT b.[ProductAssemblyID], b.[ComponentID], p.[Name], b.[PerAssemblyQty], p.[StandardCost], p.[ListPrice], b.[BOMLevel], [RecursionLevel] + 1 -- Join recursive member to anchor
        FROM [BOM_cte] cte
            INNER JOIN [Production].[BillOfMaterials] b
            ON cte.[ProductAssemblyID] = b.[ComponentID]
            INNER JOIN [Production].[Product] p
            ON b.[ProductAssemblyID] = p.[ProductID]
        WHERE @CheckDate >= b.[StartDate]
            AND @CheckDate <= ISNULL(b.[EndDate], @CheckDate)
        )
    -- Outer select from the CTE
    SELECT b.[ProductAssemblyID], b.[ComponentID], b.[ComponentDesc], SUM(b.[PerAssemblyQty]) AS [TotalQuantity] , b.[StandardCost], b.[ListPrice], b.[BOMLevel], b.[RecursionLevel]
    FROM [BOM_cte] b
    GROUP BY b.[ComponentID], b.[ComponentDesc], b.[ProductAssemblyID], b.[BOMLevel], b.[RecursionLevel], b.[StandardCost], b.[ListPrice]
    ORDER BY b.[BOMLevel], b.[ProductAssemblyID], b.[ComponentID]
    OPTION (MAXRECURSION 25)
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stored procedure using a recursive query to return all components or assemblies that directly or indirectly use the specified ProductID.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetWhereUsedProductID', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetWhereUsedProductID used to eliminate components not used after that date. Enter a valid date.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetWhereUsedProductID', 'PARAMETER', N'@CheckDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspGetWhereUsedProductID. Enter a valid ProductID from the Production.Product table.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspGetWhereUsedProductID', 'PARAMETER', N'@StartProductID'
GO

Collapse image See also

List of procedures


uspLogError

Procedure: AdventureWorks2016CTP3.dbo.uspLogError

Collapse image Description

Logs error information in the ErrorLog table about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without inserting error information.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 661577395
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@ErrorLogID | Output parameter for the stored procedure uspLogError. Contains the ErrorLogID value corresponding to the row inserted by uspLogError in the ErrorLog table. | int | 4 | Input/output or output |

Collapse image Objects that depend on uspLogError

Object name | Object type | Dep level
uspAddOrderTrackingEvent | Procedure | 1
HumanResources.uspUpdateEmployeeHireInfo | Procedure | 1
HumanResources.uspUpdateEmployeeLogin | Procedure | 1
HumanResources.uspUpdateEmployeePersonalInfo | Procedure | 1
Purchasing.dVendor | Trigger | 1
Sales.iduSalesOrderDetail | Trigger | 1
Purchasing.iPurchaseOrderDetail | Trigger | 1
Production.iWorkOrder | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderHeader | Trigger | 1
Sales.uSalesOrderHeader | Trigger | 1
Production.uWorkOrder | Trigger | 1
Total 12 object(s)

Collapse image Objects that uspLogError depends on

Object name | Object type | Dep level
uspPrintError | Procedure | 1
ErrorLog | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Logs error information in the ErrorLog table about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without inserting error information.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

-- uspLogError logs error information in the ErrorLog table about the
-- error that caused execution to jump to the CATCH block of a
-- TRY...CATCH construct. This should be executed from within the scope
-- of a CATCH block otherwise it will return without inserting error
-- information.
CREATE PROCEDURE [dbo].[uspLogError]
    @ErrorLogID [int] = 0 OUTPUT -- contains the ErrorLogID of the row inserted
AS                               -- by uspLogError in the ErrorLog table
BEGIN
    SET NOCOUNT ON;

    -- Output parameter value of 0 indicates that error
    -- information was not logged
    SET @ErrorLogID = 0;

    BEGIN TRY
        -- Return if there is no error information to log
        IF ERROR_NUMBER() IS NULL
            RETURN;

        -- Return if inside an uncommittable transaction.
        -- Data insertion/modification is not allowed when
        -- a transaction is in an uncommittable state.
        IF XACT_STATE() = -1
        BEGIN
            PRINT 'Cannot log error since the current transaction is in an uncommittable state. '
                + 'Rollback the transaction before executing uspLogError in order to successfully log error information.';
            RETURN;
        END

        INSERT [dbo].[ErrorLog]
            (
            [UserName],
            [ErrorNumber],
            [ErrorSeverity],
            [ErrorState],
            [ErrorProcedure],
            [ErrorLine],
            [ErrorMessage]
            )
        VALUES
            (
            CONVERT(sysname, CURRENT_USER),
            ERROR_NUMBER(),
            ERROR_SEVERITY(),
            ERROR_STATE(),
            ERROR_PROCEDURE(),
            ERROR_LINE(),
            ERROR_MESSAGE()
            );

        -- Pass back the ErrorLogID of the row inserted
        SET @ErrorLogID = @@IDENTITY;
    END TRY
    BEGIN CATCH
        PRINT 'An error occurred in stored procedure uspLogError: ';
        EXECUTE [dbo].[uspPrintError];
        RETURN -1;
    END CATCH
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Logs error information in the ErrorLog table about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without inserting error information.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspLogError', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Output parameter for the stored procedure uspLogError. Contains the ErrorLogID value corresponding to the row inserted by uspLogError in the ErrorLog table.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspLogError', 'PARAMETER', N'@ErrorLogID'
GO

Collapse image See also

List of procedures


uspPrintError

Procedure: AdventureWorks2016CTP3.dbo.uspPrintError

Collapse image Description

Prints error information about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without printing any error information.

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 645577338
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that depend on uspPrintError

Object name | Object type | Dep level
uspLogError | Procedure | 1
Purchasing.dVendor | Trigger | 1
Sales.iduSalesOrderDetail | Trigger | 1
Purchasing.iPurchaseOrderDetail | Trigger | 1
Production.iWorkOrder | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderHeader | Trigger | 1
Sales.uSalesOrderHeader | Trigger | 1
Production.uWorkOrder | Trigger | 1
Total 9 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Prints error information about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without printing any error information.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

-- uspPrintError prints error information about the error that caused
-- execution to jump to the CATCH block of a TRY...CATCH construct.
-- Should be executed from within the scope of a CATCH block otherwise
-- it will return without printing any error information.
CREATE PROCEDURE [dbo].[uspPrintError]
AS
BEGIN
    SET NOCOUNT ON;

    -- Print error information.
    PRINT 'Error ' + CONVERT(varchar(50), ERROR_NUMBER()) +
          ', Severity ' + CONVERT(varchar(5), ERROR_SEVERITY()) +
          ', State ' + CONVERT(varchar(5), ERROR_STATE()) +
          ', Procedure ' + ISNULL(ERROR_PROCEDURE(), '-') +
          ', Line ' + CONVERT(varchar(5), ERROR_LINE());
    PRINT ERROR_MESSAGE();
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Prints error information about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without printing any error information.', 'SCHEMA', N'dbo', 'PROCEDURE', N'uspPrintError', NULL, NULL
GO

Collapse image See also

List of procedures


uspSearchCandidateResumes

Procedure: AdventureWorks2016CTP3.dbo.uspSearchCandidateResumes

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1613248802
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@searchString |  | nvarchar | 1000 | Input |
@useInflectional |  | bit | 1 | Input |
@useThesaurus |  | bit | 1 | Input |
@language |  | int | 4 | Input |

Collapse image Objects that uspSearchCandidateResumes depends on

Object name | Object type | Dep level
HumanResources.JobCandidate | Table | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

--A stored procedure which demonstrates integrated full text search

CREATE PROCEDURE [dbo].[uspSearchCandidateResumes]
    @searchString [nvarchar](1000),
    @useInflectional [bit]=0,
    @useThesaurus [bit]=0,
    @language[int]=0

WITH EXECUTE AS CALLER
AS
BEGIN
    SET NOCOUNT ON;

      DECLARE @string nvarchar(1050)
      --setting the lcid to the default instance LCID if needed
      IF @language = NULL OR @language = 0
      BEGIN
            SELECT @language =CONVERT(int, serverproperty('lcid'))
      END

            --FREETEXTTABLE case as inflectional and Thesaurus were required
      IF @useThesaurus = 1 AND @useInflectional = 1
        BEGIN
                  SELECT FT_TBL.[JobCandidateID], KEY_TBL.[RANK] FROM [HumanResources].[JobCandidate] AS FT_TBL
                        INNER JOIN FREETEXTTABLE([HumanResources].[JobCandidate],*, @searchString,LANGUAGE @language) AS KEY_TBL
                   ON  FT_TBL.[JobCandidateID] =KEY_TBL.[KEY]
            END

      ELSE IF @useThesaurus = 1
            BEGIN
                  SELECT @string ='FORMSOF(THESAURUS,"'+@searchString +'"'+')'
                  SELECT FT_TBL.[JobCandidateID], KEY_TBL.[RANK] FROM [HumanResources].[JobCandidate] AS FT_TBL
                        INNER JOIN CONTAINSTABLE([HumanResources].[JobCandidate],*, @string,LANGUAGE @language) AS KEY_TBL
                   ON  FT_TBL.[JobCandidateID] =KEY_TBL.[KEY]
        END

      ELSE IF @useInflectional = 1
            BEGIN
                  SELECT @string ='FORMSOF(INFLECTIONAL,"'+@searchString +'"'+')'
                  SELECT FT_TBL.[JobCandidateID], KEY_TBL.[RANK] FROM [HumanResources].[JobCandidate] AS FT_TBL
                        INNER JOIN CONTAINSTABLE([HumanResources].[JobCandidate],*, @string,LANGUAGE @language) AS KEY_TBL
                   ON  FT_TBL.[JobCandidateID] =KEY_TBL.[KEY]
        END

      ELSE --base case, plain CONTAINSTABLE
            BEGIN
                  SELECT @string='"'+@searchString +'"'
                  SELECT FT_TBL.[JobCandidateID],KEY_TBL.[RANK] FROM [HumanResources].[JobCandidate] AS FT_TBL
                        INNER JOIN CONTAINSTABLE([HumanResources].[JobCandidate],*,@string,LANGUAGE @language) AS KEY_TBL
                   ON  FT_TBL.[JobCandidateID] =KEY_TBL.[KEY]
            END

END;
GO

Collapse image See also

List of procedures


usp_DemoInitSeed

Procedure: AdventureWorks2016CTP3.Demo.usp_DemoInitSeed

Collapse image Procedure properties

Name | Value
Schema | Demo
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1620200822
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@items_per_order |  | int | 4 | Input |

Collapse image Objects that Demo.usp_DemoInitSeed depends on

Object name | Object type | Dep level
Demo | Schema | 1
Demo.DemoSalesOrderDetailSeed | Table | 1
Demo.DemoSalesOrderHeaderSeed | Table | 1
Sales.SalesOrderHeader_inmem | Table | 1
Sales.SpecialOfferProduct_inmem | Table | 1
Total 5 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE Demo.usp_DemoInitSeed @items_per_order int = 5
AS
BEGIN
    DECLARE @ProductID int, @SpecialOfferID int,
        @i int = 1
    DECLARE @seed_order_count int = (SELECT COUNT(*)/@items_per_order FROM Sales.SpecialOfferProduct_inmem)

    DECLARE seed_cursor CURSOR FOR
        SELECT
            ProductID,
            SpecialOfferID
        FROM Sales.SpecialOfferProduct_inmem

    OPEN seed_cursor

    FETCH NEXT FROM seed_cursor
    INTO @ProductID, @SpecialOfferID

    BEGIN TRAN

        DELETE FROM Demo.DemoSalesOrderHeaderSeed

        INSERT INTO Demo.DemoSalesOrderHeaderSeed
        (
            DueDate,
            CustomerID,
            SalesPersonID,
            BillToAddressID,
            ShipToAddressID,
            ShipMethodID
        )
        SELECT
            dateadd(d, (rand(BillToAddressID*CustomerID)*10)+1,cast(sysdatetime() as date)),
            CustomerID,
            SalesPersonID,
            BillToAddressID,
            ShipToAddressID,
            ShipMethodID
        FROM Sales.SalesOrderHeader_inmem

        WHILE @@FETCH_STATUS = 0
        BEGIN
            INSERT Demo.DemoSalesOrderDetailSeed
            SELECT
                @i % 6 + 1,
                @ProductID,
                @SpecialOfferID,
                @i % (@seed_order_count+1)

            SET @i += 1

            FETCH NEXT FROM seed_cursor
            INTO @ProductID, @SpecialOfferID
        END

        CLOSE seed_cursor
        DEALLOCATE seed_cursor
    COMMIT

    UPDATE STATISTICS Demo.DemoSalesOrderDetailSeed
    WITH FULLSCAN, NORECOMPUTE
END
GO

Collapse image See also

List of procedures


usp_DemoReset

Procedure: AdventureWorks2016CTP3.Demo.usp_DemoReset

Collapse image Procedure properties

Name | Value
Schema | Demo
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1636200879
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that Demo.usp_DemoReset depends on

Object name | Object type | Dep level
Demo | Schema | 1
Sales.SalesOrderDetail | Table | 1
Sales.SalesOrderDetail_inmem | Table | 1
Sales.SalesOrderDetail_ondisk | Table | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesOrderHeader_inmem | Table | 1
Sales.SalesOrderHeader_ondisk | Table | 1
Total 7 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE Demo.usp_DemoReset
AS
BEGIN
    truncate table Sales.SalesOrderDetail_ondisk
    delete from Sales.SalesOrderDetail_inmem
    delete from Sales.SalesOrderHeader_ondisk
    delete from Sales.SalesOrderHeader_inmem

    CHECKPOINT

    SET IDENTITY_INSERT Sales.SalesOrderHeader_inmem ON
    INSERT INTO Sales.SalesOrderHeader_inmem
        ([SalesOrderID],
        [RevisionNumber],
        [OrderDate],
        [DueDate],
        [ShipDate],
        [Status],
        [OnlineOrderFlag],
        [PurchaseOrderNumber],
        [AccountNumber],
        [CustomerID],
        [SalesPersonID],
        [TerritoryID],
        [BillToAddressID],
        [ShipToAddressID],
        [ShipMethodID],
        [CreditCardID],
        [CreditCardApprovalCode],
        [CurrencyRateID],
        [SubTotal],
        [TaxAmt],
        [Freight],
        [Comment],
        [ModifiedDate])
    SELECT
        [SalesOrderID],
        [RevisionNumber],
        [OrderDate],
        [DueDate],
        [ShipDate],
        [Status],
        [OnlineOrderFlag],
        [PurchaseOrderNumber],
        [AccountNumber],
        [CustomerID],
        ISNULL([SalesPersonID],-1),
        [TerritoryID],
        [BillToAddressID],
        [ShipToAddressID],
        [ShipMethodID],
        [CreditCardID],
        [CreditCardApprovalCode],
        [CurrencyRateID],
        [SubTotal],
        [TaxAmt],
        [Freight],
        [Comment],
        [ModifiedDate]
    FROM Sales.SalesOrderHeader
    SET IDENTITY_INSERT Sales.SalesOrderHeader_inmem OFF

    SET IDENTITY_INSERT Sales.SalesOrderHeader_ondisk ON
    INSERT INTO Sales.SalesOrderHeader_ondisk
        ([SalesOrderID],
        [RevisionNumber],
        [OrderDate],
        [DueDate],
        [ShipDate],
        [Status],
        [OnlineOrderFlag],
        [PurchaseOrderNumber],
        [AccountNumber],
        [CustomerID],
        [SalesPersonID],
        [TerritoryID],
        [BillToAddressID],
        [ShipToAddressID],
        [ShipMethodID],
        [CreditCardID],
        [CreditCardApprovalCode],
        [CurrencyRateID],
        [SubTotal],
        [TaxAmt],
        [Freight],
        [Comment],
        [ModifiedDate])
    SELECT *
    FROM Sales.SalesOrderHeader_inmem
    SET IDENTITY_INSERT Sales.SalesOrderHeader_ondisk OFF

    SET IDENTITY_INSERT Sales.SalesOrderDetail_inmem ON
    INSERT INTO Sales.SalesOrderDetail_inmem
        ([SalesOrderID],
        [SalesOrderDetailID],
        [CarrierTrackingNumber],
        [OrderQty],
        [ProductID],
        [SpecialOfferID],
        [UnitPrice],
        [UnitPriceDiscount],
        [ModifiedDate])
    SELECT
        [SalesOrderID],
        [SalesOrderDetailID],
        [CarrierTrackingNumber],
        [OrderQty],
        [ProductID],
        [SpecialOfferID],
        [UnitPrice],
        [UnitPriceDiscount],
        [ModifiedDate]
    FROM Sales.SalesOrderDetail
    SET IDENTITY_INSERT Sales.SalesOrderDetail_inmem OFF

    SET IDENTITY_INSERT Sales.SalesOrderDetail_ondisk ON
    INSERT INTO Sales.SalesOrderDetail_ondisk
        ([SalesOrderID],
        [SalesOrderDetailID],
        [CarrierTrackingNumber],
        [OrderQty],
        [ProductID],
        [SpecialOfferID],
        [UnitPrice],
        [UnitPriceDiscount],
        [ModifiedDate])
    SELECT *
    FROM Sales.SalesOrderDetail_inmem
    SET IDENTITY_INSERT Sales.SalesOrderDetail_ondisk OFF

    CHECKPOINT
END
GO

Collapse image See also

List of procedures


sp_GetEmployee_Person_Info_AsOf

Procedure: AdventureWorks2016CTP3.HumanResources.sp_GetEmployee_Person_Info_AsOf

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1982630106
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@asOf |  | datetime2 | 8 | Input |

Collapse image Recordsets returned

Name | Datatype | Max length
BusinessEntityID | int | 4
Title | nvarchar | 8
FirstName | nvarchar | 50
LastName | nvarchar | 50
MiddleName | nvarchar | 50
JobTitle | nvarchar | 50
MaritalStatus | nchar | 1
Gender | nchar | 1
VacationHours | smallint | 2
SickLeaveHours | smallint | 2
Name | Datatype | Max length
BusinessEntityID | int | 4
Title | nvarchar | 8
FirstName | nvarchar | 50
LastName | nvarchar | 50
MiddleName | nvarchar | 50
JobTitle | nvarchar | 50
MaritalStatus | nchar | 1
Gender | nchar | 1
VacationHours | smallint | 2
SickLeaveHours | smallint | 2

Collapse image Objects that HumanResources.sp_GetEmployee_Person_Info_AsOf depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.vEmployeePersonTemporalInfo | View | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

/*
    Stored procedure used for querying Employee and Person data AS OF
    If @AsOf parameter is NULL, current data is queried
    otherwise both current and historical data is queried
*/
CREATE  PROCEDURE [HumanResources].[sp_GetEmployee_Person_Info_AsOf]
@asOf datetime2 = NULL
AS
IF @asOf IS NULL
    SELECT * FROM [HumanResources].[vEmployeePersonTemporalInfo]
ELSE
    SELECT * FROM [HumanResources].[vEmployeePersonTemporalInfo] FOR SYSTEM_TIME AS OF @asOf;
GO

Collapse image See also

List of procedures


sp_UpdateEmployee_Temporal

Procedure: AdventureWorks2016CTP3.HumanResources.sp_UpdateEmployee_Temporal

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1966630049
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID |  | int | 4 | Input |
@LoginID |  | nvarchar | 256 | Input |
@JobTitle |  | nvarchar | 50 | Input |
@MaritalStatus |  | nchar | 1 | Input |
@Gender |  | nchar | 1 | Input |
@VacationHours |  | smallint | 2 | Input |
@SickLeaveHours |  | smallint | 2 | Input |

Collapse image Objects that HumanResources.sp_UpdateEmployee_Temporal depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Employee_Temporal | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

/*
    Stored procedure for updating columns of [HumanResources].[Employee_Temporal]
    If all parameters except @BusinessEntityID are NULL no update is performed
    For NON NULL columns NULL values are ignored (i.e. existing values is applied)
*/
CREATE PROCEDURE [HumanResources].[sp_UpdateEmployee_Temporal]
 @BusinessEntityID INT
,@LoginID nvarchar(256) = NULL
,@JobTitle nvarchar(50) = NULL
,@MaritalStatus nchar(1) = NULL
,@Gender nchar(1) = NULL
,@VacationHours smallint = 0
,@SickLeaveHours smallint = 0

AS
IF @LoginID IS NOT NULL OR @JobTitle IS NOT NULL OR @MaritalStatus IS NOT NULL
OR @Gender IS NOT NULL OR @VacationHours IS NOT NULL OR @SickLeaveHours IS NOT NULL

    UPDATE [HumanResources].[Employee_Temporal]
    SET  [LoginID] = ISNULL (@LoginID, LoginID),
    JobTitle = ISNULL (@JobTitle, JobTitle),
    MaritalStatus = ISNULL (@MaritalStatus, MaritalStatus),
    Gender = ISNULL (@Gender, Gender),
    VacationHours = ISNULL (@VacationHours, VacationHours),
    SickLeaveHours = ISNULL (@SickLeaveHours, SickLeaveHours)
    WHERE BusinessEntityID = @BusinessEntityID;

GO

Collapse image See also

List of procedures


uspUpdateEmployeeHireInfo

Procedure: AdventureWorks2016CTP3.HumanResources.uspUpdateEmployeeHireInfo

CollapseAll image

Collapse image Description

Updates the Employee table and inserts a new row in the EmployeePayHistory table with the values specified in the input parameters.

Collapse image Procedure properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1565248631
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid BusinessEntityID from the Employee table. | int | 4 | Input |
@JobTitle | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a title for the employee. | nvarchar | 50 | Input |
@HireDate | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a hire date for the employee. | datetime | 8 | Input |
@RateChangeDate | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the date the rate changed for the employee. | datetime | 8 | Input |
@Rate | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the new rate for the employee. | money | 8 | Input |
@PayFrequency | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the pay frequency for the employee. | tinyint | 1 | Input |
@CurrentFlag | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee. | Flag | 1 | Input |

Collapse image Objects that HumanResources.uspUpdateEmployeeHireInfo depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
uspLogError | Procedure | 1
HumanResources.Employee | Table | 1
HumanResources.EmployeePayHistory | Table | 1
Flag | Datatype | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Updates the Employee table and inserts a new row in the EmployeePayHistory table with the values specified in the input parameters.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [HumanResources].[uspUpdateEmployeeHireInfo]
    @BusinessEntityID [int],
    @JobTitle [nvarchar](50),
    @HireDate [datetime],
    @RateChangeDate [datetime],
    @Rate [money],
    @PayFrequency [tinyint],
    @CurrentFlag [dbo].[Flag]
WITH EXECUTE AS CALLER
AS
BEGIN
    SET NOCOUNT ON;

    BEGIN TRY
        BEGIN TRANSACTION;

        UPDATE [HumanResources].[Employee]
        SET [JobTitle] = @JobTitle
            ,[HireDate] = @HireDate
            ,[CurrentFlag] = @CurrentFlag
        WHERE [BusinessEntityID] = @BusinessEntityID;

        INSERT INTO [HumanResources].[EmployeePayHistory]
            ([BusinessEntityID]
            ,[RateChangeDate]
            ,[Rate]
            ,[PayFrequency])
        VALUES (@BusinessEntityID, @RateChangeDate, @Rate, @PayFrequency);

        COMMIT TRANSACTION;
    END TRY
    BEGIN CATCH
        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Updates the Employee table and inserts a new row in the EmployeePayHistory table with the values specified in the input parameters.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid BusinessEntityID from the Employee table.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@CurrentFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a hire date for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@HireDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a title for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@JobTitle'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the pay frequency for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@PayFrequency'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the new rate for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@Rate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the date the rate changed for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeHireInfo', 'PARAMETER', N'@RateChangeDate'
GO

Collapse image See also

List of procedures


uspUpdateEmployeeLogin

Procedure: AdventureWorks2016CTP3.HumanResources.uspUpdateEmployeeLogin

CollapseAll image

Collapse image Description

Updates the Employee table with the values specified in the input parameters for the given BusinessEntityID.

Collapse image Procedure properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1581248688
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID | Input parameter for the stored procedure uspUpdateEmployeeLogin. Enter a valid EmployeeID from the Employee table. | int | 4 | Input |
@OrganizationNode | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid ManagerID for the employee. | hierarchyid | 892 | Input |
@LoginID | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid login for the employee. | nvarchar | 256 | Input |
@JobTitle | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a title for the employee. | nvarchar | 50 | Input |
@HireDate | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a hire date for the employee. | datetime | 8 | Input |
@CurrentFlag | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee. | Flag | 1 | Input |

Collapse image Objects that HumanResources.uspUpdateEmployeeLogin depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
uspLogError | Procedure | 1
HumanResources.Employee | Table | 1
Flag | Datatype | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Updates the Employee table with the values specified in the input parameters for the given BusinessEntityID.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [HumanResources].[uspUpdateEmployeeLogin]
    @BusinessEntityID [int],
    @OrganizationNode [hierarchyid],
    @LoginID [nvarchar](256),
    @JobTitle [nvarchar](50),
    @HireDate [datetime],
    @CurrentFlag [dbo].[Flag]
WITH EXECUTE AS CALLER
AS
BEGIN
    SET NOCOUNT ON;

    BEGIN TRY
        UPDATE [HumanResources].[Employee]
        SET [OrganizationNode] = @OrganizationNode
            ,[LoginID] = @LoginID
            ,[JobTitle] = @JobTitle
            ,[HireDate] = @HireDate
            ,[CurrentFlag] = @CurrentFlag
        WHERE [BusinessEntityID] = @BusinessEntityID;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Updates the Employee table with the values specified in the input parameters for the given BusinessEntityID.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeLogin. Enter a valid EmployeeID from the Employee table.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter the current flag for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@CurrentFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a hire date for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@HireDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a title for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@JobTitle'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid login for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@LoginID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a valid ManagerID for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeeLogin', 'PARAMETER', N'@OrganizationNode'
GO

Collapse image See also

List of procedures


uspUpdateEmployeePersonalInfo

Procedure: AdventureWorks2016CTP3.HumanResources.uspUpdateEmployeePersonalInfo

CollapseAll image

Collapse image Description

Updates the Employee table with the values specified in the input parameters for the given EmployeeID.

Collapse image Procedure properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Type | P
Encrypted |
ID | 1597248745
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID | Input parameter for the stored procedure uspUpdateEmployeePersonalInfo. Enter a valid BusinessEntityID from the HumanResources.Employee table. | int | 4 | Input |
@NationalIDNumber | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a national ID for the employee. | nvarchar | 15 | Input |
@BirthDate | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a birth date for the employee. | datetime | 8 | Input |
@MaritalStatus | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a marital status for the employee. | nchar | 1 | Input |
@Gender | Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a gender for the employee. | nchar | 1 | Input |

Collapse image Objects that HumanResources.uspUpdateEmployeePersonalInfo depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
uspLogError | Procedure | 1
HumanResources.Employee | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Updates the Employee table with the values specified in the input parameters for the given EmployeeID.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [HumanResources].[uspUpdateEmployeePersonalInfo]
    @BusinessEntityID [int],
    @NationalIDNumber [nvarchar](15),
    @BirthDate [datetime],
    @MaritalStatus [nchar](1),
    @Gender [nchar](1)
WITH EXECUTE AS CALLER
AS
BEGIN
    SET NOCOUNT ON;

    BEGIN TRY
        UPDATE [HumanResources].[Employee]
        SET [NationalIDNumber] = @NationalIDNumber
            ,[BirthDate] = @BirthDate
            ,[MaritalStatus] = @MaritalStatus
            ,[Gender] = @Gender
        WHERE [BusinessEntityID] = @BusinessEntityID;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Updates the Employee table with the values specified in the input parameters for the given EmployeeID.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', NULL, NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a birth date for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', 'PARAMETER', N'@BirthDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeePersonalInfo. Enter a valid BusinessEntityID from the HumanResources.Employee table.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', 'PARAMETER', N'@BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a gender for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', 'PARAMETER', N'@Gender'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a marital status for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', 'PARAMETER', N'@MaritalStatus'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Input parameter for the stored procedure uspUpdateEmployeeHireInfo. Enter a national ID for the employee.', 'SCHEMA', N'HumanResources', 'PROCEDURE', N'uspUpdateEmployeePersonalInfo', 'PARAMETER', N'@NationalIDNumber'
GO

Collapse image See also

List of procedures


sp_DeletePerson_Temporal

Procedure: AdventureWorks2016CTP3.Person.sp_DeletePerson_Temporal

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Person
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1950629992
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID |  | int | 4 | Input |

Collapse image Objects that Person.sp_DeletePerson_Temporal depends on

Object name | Object type | Dep level
Person | Schema | 1
HumanResources.Employee_Temporal | Table | 1
Person.Person_Temporal | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

/*
    Stored procedure that deletes row in [Person].[Person_Temporal]
    and corresponding row in [HumanResources].[Employee_Temporal]
*/
CREATE PROCEDURE [Person].[sp_DeletePerson_Temporal]
@BusinessEntityID INT
AS

DELETE FROM [HumanResources].[Employee_Temporal] WHERE [BusinessEntityID] = @BusinessEntityID;
DELETE FROM [Person].[Person_Temporal] WHERE [BusinessEntityID] = @BusinessEntityID;

GO

Collapse image See also

List of procedures


sp_UpdatePerson_Temporal

Procedure: AdventureWorks2016CTP3.Person.sp_UpdatePerson_Temporal

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Person
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1934629935
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@BusinessEntityID |  | int | 4 | Input |
@PersonType |  | nchar | 2 | Input |
@Title |  | nvarchar | 8 | Input |
@FirstName |  | nvarchar | 50 | Input |
@MiddleName |  | nvarchar | 50 | Input |
@LastName |  | nvarchar | 50 | Input |
@Suffix |  | nvarchar | 10 | Input |
@EmailPromotion |  | smallint | 2 | Input |

Collapse image Objects that Person.sp_UpdatePerson_Temporal depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person_Temporal | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

/*
    Stored procedure for updating columns of Person_Temporal
    If all parameters except @BusinessEntityID are NULL no update is performed
    For NON NULL columns NULL values are ignored (i.e. existing values is applied)
*/
CREATE PROCEDURE [Person].[sp_UpdatePerson_Temporal]
@BusinessEntityID INT,
@PersonType nchar(2) = NULL,
@Title nvarchar(8) = NULL,
@FirstName nvarchar(50) = NULL,
@MiddleName nvarchar(50) = NULL,
@LastName nvarchar(50) = NULL,
@Suffix nvarchar(10) = NULL,
@EmailPromotion smallint = NULL

AS

IF @PersonType IS NOT NULL OR @Title IS NOT NULL OR @FirstName IS NOT NULL OR @MiddleName IS NOT NULL
OR @LastName IS NOT NULL OR @Suffix IS NOT NULL OR @EmailPromotion IS NOT NULL

    UPDATE Person.Person_Temporal
    SET PersonType = ISNULL (@PersonType, PersonType),
    Title = @Title,
    FirstName = ISNULL (@FirstName, FirstName),
    MiddleName = ISNULL (@MiddleName, MiddleName),
    LastName = ISNULL (@LastName, LastName),
    Suffix = @Suffix,
    EmailPromotion = ISNULL(@EmailPromotion, EmailPromotion)
    WHERE BusinessEntityID = @BusinessEntityID;

GO

Collapse image See also

List of procedures


usp_InsertSalesOrder_inmem

Procedure: AdventureWorks2016CTP3.Sales.usp_InsertSalesOrder_inmem

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1780201392
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input/output or output |
@DueDate |  | datetime2 | 8 | Input |
@CustomerID |  | int | 4 | Input |
@BillToAddressID |  | int | 4 | Input |
@ShipToAddressID |  | int | 4 | Input |
@ShipMethodID |  | int | 4 | Input |
@SalesOrderDetails |  | Sales.SalesOrderDetailType_inmem | 0 | Input |
@Status |  | tinyint | 1 | Input |
@OnlineOrderFlag |  | bit | 1 | Input |
@PurchaseOrderNumber |  | nvarchar | 25 | Input |
@AccountNumber |  | nvarchar | 15 | Input |
@SalesPersonID |  | int | 4 | Input |
@TerritoryID |  | int | 4 | Input |
@CreditCardID |  | int | 4 | Input |
@CreditCardApprovalCode |  | varchar | 15 | Input |
@CurrencyRateID |  | int | 4 | Input |
@Comment |  | nvarchar | 128 | Input |

Collapse image Objects that Sales.usp_InsertSalesOrder_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderDetailType_inmem | Datatype | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE Sales.usp_InsertSalesOrder_inmem
    @SalesOrderID int OUTPUT,
    @DueDate [datetime2](7) NOT NULL,
    @CustomerID [int] NOT NULL,
    @BillToAddressID [int] NOT NULL,
    @ShipToAddressID [int] NOT NULL,
    @ShipMethodID [int] NOT NULL,
    @SalesOrderDetails Sales.SalesOrderDetailType_inmem READONLY,
    @Status [tinyint] NOT NULL = 1,
    @OnlineOrderFlag [bit] NOT NULL = 1,
    @PurchaseOrderNumber [nvarchar](25) = NULL,
    @AccountNumber [nvarchar](15) = NULL,
    @SalesPersonID [int] NOT NULL = -1,
    @TerritoryID [int] = NULL,
    @CreditCardID [int] = NULL,
    @CreditCardApprovalCode [varchar](15) = NULL,
    @CurrencyRateID [int] = NULL,
    @Comment nvarchar(128) = NULL
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH
  (TRANSACTION ISOLATION LEVEL = SNAPSHOT,
   LANGUAGE = N'us_english')

    DECLARE @OrderDate datetime2 NOT NULL = SYSDATETIME()

    DECLARE @SubTotal money NOT NULL = 0

    SELECT @SubTotal = ISNULL(SUM(p.ListPrice * (1 - ISNULL(so.DiscountPct, 0))),0)
    FROM @SalesOrderDetails od
        JOIN Production.Product_inmem p on od.ProductID=p.ProductID
        LEFT JOIN Sales.SpecialOffer_inmem so on od.SpecialOfferID=so.SpecialOfferID

    INSERT INTO Sales.SalesOrderHeader_inmem
    (    DueDate,
        Status,
        OnlineOrderFlag,
        PurchaseOrderNumber,
        AccountNumber,
        CustomerID,
        SalesPersonID,
        TerritoryID,
        BillToAddressID,
        ShipToAddressID,
        ShipMethodID,
        CreditCardID,
        CreditCardApprovalCode,
        CurrencyRateID,
        Comment,
        OrderDate,
        SubTotal,
        ModifiedDate)
    VALUES
    (
        @DueDate,
        @Status,
        @OnlineOrderFlag,
        @PurchaseOrderNumber,
        @AccountNumber,
        @CustomerID,
        @SalesPersonID,
        @TerritoryID,
        @BillToAddressID,
        @ShipToAddressID,
        @ShipMethodID,
        @CreditCardID,
        @CreditCardApprovalCode,
        @CurrencyRateID,
        @Comment,
        @OrderDate,
        @SubTotal,
        @OrderDate
    )

    SET @SalesOrderID = SCOPE_IDENTITY()

    INSERT INTO Sales.SalesOrderDetail_inmem
    (
        SalesOrderID,
        OrderQty,
        ProductID,
        SpecialOfferID,
        UnitPrice,
        UnitPriceDiscount,
        ModifiedDate
    )
    SELECT
        @SalesOrderID,
        od.OrderQty,
        od.ProductID,
        od.SpecialOfferID,
        p.ListPrice,
        ISNULL(p.ListPrice * so.DiscountPct, 0),
        @OrderDate
    FROM @SalesOrderDetails od
        JOIN Production.Product_inmem p on od.ProductID=p.ProductID
        LEFT JOIN Sales.SpecialOffer_inmem so on od.SpecialOfferID=so.SpecialOfferID

END
GO

Collapse image See also

List of procedures


usp_InsertSalesOrder_ondisk

Procedure: AdventureWorks2016CTP3.Sales.usp_InsertSalesOrder_ondisk

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1492200366
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input/output or output |
@DueDate |  | datetime2 | 8 | Input |
@CustomerID |  | int | 4 | Input |
@BillToAddressID |  | int | 4 | Input |
@ShipToAddressID |  | int | 4 | Input |
@ShipMethodID |  | int | 4 | Input |
@SalesOrderDetails |  | Sales.SalesOrderDetailType_ondisk | 0 | Input |
@Status |  | tinyint | 1 | Input |
@OnlineOrderFlag |  | bit | 1 | Input |
@PurchaseOrderNumber |  | nvarchar | 25 | Input |
@AccountNumber |  | nvarchar | 15 | Input |
@SalesPersonID |  | int | 4 | Input |
@TerritoryID |  | int | 4 | Input |
@CreditCardID |  | int | 4 | Input |
@CreditCardApprovalCode |  | varchar | 15 | Input |
@CurrencyRateID |  | int | 4 | Input |
@Comment |  | nvarchar | 128 | Input |

Collapse image Objects that Sales.usp_InsertSalesOrder_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Production.Product_ondisk | Table | 1
Sales.SalesOrderDetail_ondisk | Table | 1
Sales.SalesOrderHeader_ondisk | Table | 1
Sales.SpecialOffer_ondisk | Table | 1
Sales.SalesOrderDetailType_ondisk | Datatype | 1
Total 6 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE Sales.usp_InsertSalesOrder_ondisk
    @SalesOrderID int OUTPUT,
    @DueDate [datetime2](7) ,
    @CustomerID [int] ,
    @BillToAddressID [int] ,
    @ShipToAddressID [int] ,
    @ShipMethodID [int] ,
    @SalesOrderDetails Sales.SalesOrderDetailType_ondisk READONLY,
    @Status [tinyint]  = 1,
    @OnlineOrderFlag [bit] = 1,
    @PurchaseOrderNumber [nvarchar](25) = NULL,
    @AccountNumber [nvarchar](15) = NULL,
    @SalesPersonID [int] = -1,
    @TerritoryID [int] = NULL,
    @CreditCardID [int] = NULL,
    @CreditCardApprovalCode [varchar](15) = NULL,
    @CurrencyRateID [int] = NULL,
    @Comment nvarchar(128) = NULL
AS
BEGIN
    BEGIN TRAN

        DECLARE @OrderDate datetime2 = sysdatetime()

        DECLARE @SubTotal money = 0

        SELECT @SubTotal = ISNULL(SUM(p.ListPrice * (1 - ISNULL(so.DiscountPct, 0))),0)
        FROM @SalesOrderDetails od
            JOIN Production.Product_ondisk p on od.ProductID=p.ProductID
            LEFT JOIN Sales.SpecialOffer_ondisk so on od.SpecialOfferID=so.SpecialOfferID

        INSERT INTO Sales.SalesOrderHeader_ondisk
        (    DueDate,
            Status,
            OnlineOrderFlag,
            PurchaseOrderNumber,
            AccountNumber,
            CustomerID,
            SalesPersonID,
            TerritoryID,
            BillToAddressID,
            ShipToAddressID,
            ShipMethodID,
            CreditCardID,
            CreditCardApprovalCode,
            CurrencyRateID,
            Comment,
            OrderDate,
            SubTotal,
            ModifiedDate)
        VALUES
        (
            @DueDate,
            @Status,
            @OnlineOrderFlag,
            @PurchaseOrderNumber,
            @AccountNumber,
            @CustomerID,
            @SalesPersonID,
            @TerritoryID,
            @BillToAddressID,
            @ShipToAddressID,
            @ShipMethodID,
            @CreditCardID,
            @CreditCardApprovalCode,
            @CurrencyRateID,
            @Comment,
            @OrderDate,
            @SubTotal,
            @OrderDate
        )

        SET @SalesOrderID = SCOPE_IDENTITY()

        INSERT INTO Sales.SalesOrderDetail_ondisk
        (
            SalesOrderID,
            OrderQty,
            ProductID,
            SpecialOfferID,
            UnitPrice,
            UnitPriceDiscount,
            ModifiedDate
        )
        SELECT
            @SalesOrderID,
            od.OrderQty,
            od.ProductID,
            od.SpecialOfferID,
            p.ListPrice,
            ISNULL(p.ListPrice * so.DiscountPct, 0),
            @OrderDate
        FROM @SalesOrderDetails od
            JOIN Production.Product_ondisk p on od.ProductID=p.ProductID
            LEFT JOIN Sales.SpecialOffer_ondisk so on od.SpecialOfferID=so.SpecialOfferID

    COMMIT
END
GO

Collapse image See also

List of procedures


usp_UpdateSalesOrderShipInfo_inmem

Procedure: AdventureWorks2016CTP3.Sales.usp_UpdateSalesOrderShipInfo_inmem

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1524200480
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input |
@ShipDate |  | datetime2 | 8 | Input |
@Comment |  | nvarchar | 128 | Input |
@Status |  | tinyint | 1 | Input |
@TaxRate |  | smallmoney | 4 | Input |
@Freight |  | money | 8 | Input |
@CarrierTrackingNumber |  | nvarchar | 25 | Input |

Collapse image Objects that Sales.usp_UpdateSalesOrderShipInfo_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
-- wrapper stored procedure that contains retry logic to deal with update conflicts
-- alternatively, the client can perform retries in case of conflicts

-- for simplicity, we assume all items in the order are shipped in the same package, and thus have the same carrier tracking number
CREATE PROCEDURE Sales.usp_UpdateSalesOrderShipInfo_inmem
    @SalesOrderID int ,
    @ShipDate datetime2 = NULL,
    @Comment nvarchar(128) = NULL,
    @Status tinyint,
    @TaxRate smallmoney = 0,
    @Freight money,
    @CarrierTrackingNumber nvarchar(25)
AS
BEGIN

  DECLARE @retry INT = 10
  SET @ShipDate = ISNULL(@ShipDate, SYSDATETIME())

  WHILE (@retry > 0)
  BEGIN
    BEGIN TRY

      EXEC Sales.usp_UpdateSalesOrderShipInfo_native
        @SalesOrderID = @SalesOrderID,
        @ShipDate = @ShipDate,
        @Comment = @Comment,
        @Status = @Status,
        @TaxRate = @TaxRate,
        @Freight = @Freight,
        @CarrierTrackingNumber = @CarrierTrackingNumber

      SET @retry = 0
    END TRY
    BEGIN CATCH
      SET @retry -= 1

      IF (@retry > 0 AND error_number() in (41302, 41305, 41325, 41301))
      BEGIN

        IF XACT_STATE() <> 0
          ROLLBACK TRANSACTION

      END
      ELSE
      BEGIN
        ;THROW
      END
    END CATCH
  END
END
GO

Collapse image See also

List of procedures


usp_UpdateSalesOrderShipInfo_native

Procedure: AdventureWorks2016CTP3.Sales.usp_UpdateSalesOrderShipInfo_native

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1508200423
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input |
@ShipDate |  | datetime2 | 8 | Input |
@Comment |  | nvarchar | 128 | Input |
@Status |  | tinyint | 1 | Input |
@TaxRate |  | smallmoney | 4 | Input |
@Freight |  | money | 8 | Input |
@CarrierTrackingNumber |  | nvarchar | 25 | Input |

Collapse image Objects that depend on Sales.usp_UpdateSalesOrderShipInfo_native

Object name | Object type | Dep level
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure | 1
Total 1 object(s)

Collapse image Objects that Sales.usp_UpdateSalesOrderShipInfo_native depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE PROCEDURE Sales.usp_UpdateSalesOrderShipInfo_native
    @SalesOrderID int ,
    @ShipDate datetime2,
    @Comment nvarchar(128),
    @Status tinyint,
    @TaxRate smallmoney,
    @Freight money,
    @CarrierTrackingNumber nvarchar(25)
WITH NATIVE_COMPILATION, SCHEMABINDING
AS
BEGIN ATOMIC WITH
  (TRANSACTION ISOLATION LEVEL = SNAPSHOT,
   LANGUAGE = N'us_english')

    DECLARE @now datetime2 = SYSDATETIME()

    UPDATE Sales.SalesOrderDetail_inmem
    SET CarrierTrackingNumber = @CarrierTrackingNumber, ModifiedDate = @now
    WHERE SalesOrderID = @SalesOrderID

    UPDATE Sales.SalesOrderHeader_inmem
    SET RevisionNumber = RevisionNumber + 1,
        ShipDate = @ShipDate,
        Status = @Status,
        TaxAmt = SubTotal * @TaxRate,
        Freight = @Freight,
        ModifiedDate = @now
    WHERE SalesOrderID = @SalesOrderID

END
GO

Collapse image See also

List of procedures


usp_UpdateSalesOrderShipInfo_ondisk

Procedure: AdventureWorks2016CTP3.Sales.usp_UpdateSalesOrderShipInfo_ondisk

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 23.10.2015
Type | P
Encrypted |
ID | 1540200537
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Parameters

Name | Description | Datatype | Max length | Type | ReadOnly
@SalesOrderID |  | int | 4 | Input |
@ShipDate |  | datetime2 | 8 | Input |
@Comment |  | nvarchar | 128 | Input |
@Status |  | tinyint | 1 | Input |
@TaxRate |  | smallmoney | 4 | Input |
@Freight |  | money | 8 | Input |
@CarrierTrackingNumber |  | nvarchar | 25 | Input |

Collapse image Objects that Sales.usp_UpdateSalesOrderShipInfo_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderDetail_ondisk | Table | 1
Sales.SalesOrderHeader_ondisk | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
-- for simplicity, we assume all items in the order are shipped in the same package, and thus have the same carrier tracking number
CREATE PROCEDURE Sales.usp_UpdateSalesOrderShipInfo_ondisk
    @SalesOrderID int ,
    @ShipDate datetime2 = NULL,
    @Comment nvarchar(128) = NULL,
    @Status tinyint,
    @TaxRate smallmoney = 0,
    @Freight money,
    @CarrierTrackingNumber nvarchar(25)
AS
BEGIN
  SET @ShipDate = ISNULL(@ShipDate, SYSDATETIME())

  BEGIN TRAN
    DECLARE @now datetime2 = SYSDATETIME()

    UPDATE Sales.SalesOrderDetail_ondisk
    SET CarrierTrackingNumber = @CarrierTrackingNumber, ModifiedDate = @now
    WHERE SalesOrderID = @SalesOrderID

    UPDATE Sales.SalesOrderHeader_ondisk
    SET RevisionNumber = RevisionNumber + 1,
        ShipDate = @ShipDate,
        Status = @Status,
        TaxAmt = SubTotal * @TaxRate,
        Freight = @Freight,
        ModifiedDate = @now
    WHERE SalesOrderID = @SalesOrderID
  COMMIT

END
GO

Collapse image See also

List of procedures


test

Procedure: AdventureWorks2016CTP3.SQLCop.test

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 21.09.2016
Type | P
Encrypted |
ID | 468912742
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.test depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
Total 1 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
-- =============================================
-- Author:        <Author,,Name>
-- Create date: <Create Date,,>
-- Description:    <Description,,>
-- =============================================
CREATE PROCEDURE [SQLCop].[test]
AS
BEGIN
    --  replace content of stored procedure
    --  with required test staments

    -- SET NOCOUNT ON added to prevent extra result sets from
    -- interfering with SELECT statements.

    SET NOCOUNT ON;
END
GO

Collapse image See also

List of procedures


test Ad hoc distributed queries

Procedure: AdventureWorks2016CTP3.SQLCop.[test Ad hoc distributed queries]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 2143346700
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Ad hoc distributed queries] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Ad hoc distributed queries]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Ad_Hoc_Distributed_Queries

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select    @Output = 'Status: Ad Hoc Distributed Queries are enabled'
    from    sys.configurations
    where    name = 'Ad Hoc Distributed Queries'
            and value_in_use = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Ad_Hoc_Distributed_Queries'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Agent Service

Procedure: AdventureWorks2016CTP3.SQLCop.[test Agent Service]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 11863109
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Agent Service] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Agent Service]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Find_out_if_SQL_Agent_running

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    DECLARE @service NVARCHAR(100)

    Set @Output = ''

    If Convert(VarChar(100), ServerProperty('Edition')) Like 'Express%'
      Select @Output = 'SQL Server Agent not installed for express editions'
    Else If Is_SrvRoleMember('sysadmin') = 0
      Select @Output = 'You need to be a member of the sysadmin server role to run this check'
    Else
      Begin
        SELECT @service = CASE WHEN CHARINDEX('\',@@SERVERNAME)>0
               THEN N'SQLAgent$'+@@SERVICENAME
               ELSE N'SQLSERVERAGENT' END

        Create Table #Temp(Output VarChar(1000))
        Insert Into #Temp
        EXEC master..xp_servicecontrol N'QUERYSTATE', @service

        Select    Top 1 @Output = Output
        From    #Temp
        Where    Output Not Like 'Running%'

        Drop    Table #Temp
      End

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Find_out_if_SQL_Agent_running'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Auto close

Procedure: AdventureWorks2016CTP3.SQLCop.[test Auto close]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 27863166
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Auto close] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Auto close]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/sql-server-auto-close

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + 'Database set to Auto Close' + Char(13) + Char(10)
    Where   DatabaseProperty(db_name(), 'IsAutoClose') = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/sql-server-auto-close'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Auto create statistics

Procedure: AdventureWorks2016CTP3.SQLCop.[test Auto create statistics]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 43863223
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Auto create statistics] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Auto create statistics]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.sql-server-performance.com/tips/optimizing_indexes_general_p1.aspx

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @OUtput + 'Database not set to Auto Create Statistics' + Char(13) + Char(10)
    Where  DatabaseProperty(db_name(), 'IsAutoCreateStatistics') = 0

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.sql-server-performance.com/tips/optimizing_indexes_general_p1.aspx'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Auto Shrink

Procedure: AdventureWorks2016CTP3.SQLCop.[test Auto Shrink]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 59863280
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Auto Shrink] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Auto Shrink]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.sqlskills.com/blogs/paul/post/Auto-shrink-e28093-turn-it-OFF!.aspx

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @OUtput + 'Database set to Auto Shrink' + Char(13) + Char(10)
    Where  DatabaseProperty(db_name(), 'IsAutoShrink') = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.sqlskills.com/blogs/paul/post/Auto-shrink-e28093-turn-it-OFF!.aspx'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Auto update statistics

Procedure: AdventureWorks2016CTP3.SQLCop.[test Auto update statistics]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 75863337
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Auto update statistics] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Auto update statistics]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.microsoft.com/technet/abouttn/flash/tips/tips_070604.mspx

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + 'Database not set to Auto Update Statistics' + Char(13) + Char(10)
    Where  DatabaseProperty(db_name(), 'IsAutoUpdateStatistics') = 0

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.microsoft.com/technet/abouttn/flash/tips/tips_070604.mspx'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Buffer cache hit ratio

Procedure: AdventureWorks2016CTP3.SQLCop.[test Buffer cache hit ratio]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 91863394
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Buffer cache hit ratio] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Buffer cache hit ratio]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/MSSQLServerAdmin/use-sys-dm_os_performance_counters-to-ge

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    If Exists(Select 1 From fn_my_permissions(NULL, 'SERVER') WHERE permission_name = 'VIEW SERVER STATE')
        SELECT    @Output = Convert(DECIMAL(4,1), (a.cntr_value * 1.0 / b.cntr_value) * 100.0)
        FROM    sys.dm_os_performance_counters  a
                JOIN  (
                    SELECT cntr_value,OBJECT_NAME
                    FROM   sys.dm_os_performance_counters
                    WHERE  counter_name collate SQL_LATIN1_GENERAL_CP1_CI_AI = 'Buffer cache hit ratio base'
                            AND OBJECT_NAME collate SQL_LATIN1_GENERAL_CP1_CI_AI like '%Buffer Manager%'
                    ) b
                    ON  a.OBJECT_NAME = b.OBJECT_NAME
        WHERE    a.counter_name collate SQL_LATIN1_GENERAL_CP1_CI_AI = 'Buffer cache hit ratio'
                AND a.OBJECT_NAME collate SQL_LATIN1_GENERAL_CP1_CI_AI like '%:Buffer Manager%'
                and Convert(DECIMAL(4,1), (a.cntr_value * 1.0 / b.cntr_value) * 100.0) < 95
    Else
        Set @Output = 'You do not have VIEW SERVER STATE permissions within this instance.'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/MSSQLServerAdmin/use-sys-dm_os_performance_counters-to-ge'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Column collation does not match database default

Procedure: AdventureWorks2016CTP3.SQLCop.[test Column collation does not match database default]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 107863451
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Column collation does not match database default] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Column collation does not match database default]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/sql-server-collation-conflicts

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT    @Output = @Output + C.TABLE_SCHEMA + '.' + C.TABLE_NAME + '.' + C.COLUMN_NAME + Char(13) + Char(10)
    FROM    INFORMATION_SCHEMA.COLUMNS C
            INNER JOIN INFORMATION_SCHEMA.TABLES T
                ON C.Table_Name = T.Table_Name
    WHERE    T.Table_Type = 'BASE TABLE'
            AND COLLATION_NAME <> convert(VarChar(100), DATABASEPROPERTYEX(db_name(), 'Collation'))
            AND COLUMNPROPERTY(OBJECT_ID(C.TABLE_NAME), COLUMN_NAME, 'IsComputed') = 0
            AND C.TABLE_SCHEMA <> 'tSQLt'
    Order By C.TABLE_SCHEMA, C.TABLE_NAME, C.COLUMN_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/sql-server-collation-conflicts'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Column data types (Numeric vs. Int)

Procedure: AdventureWorks2016CTP3.SQLCop.[test Column data types (Numeric vs. Int)]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 123863508
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Column data types (Numeric vs. Int)] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Column data types (Numeric vs. Int)]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/always-include-precision-and-scale-with

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select    @Output = @Output + ProblemItem + Char(13) + Char(10)
    From    (
            SELECT    TABLE_SCHEMA + '.' + TABLE_NAME + '.' + COLUMN_NAME As ProblemItem
            FROM    INFORMATION_SCHEMA.COLUMNS C
            WHERE    C.DATA_TYPE IN ('numeric','decimal')
                    AND NUMERIC_SCALE = 0
                    AND NUMERIC_PRECISION <= 18
                    AND TABLE_SCHEMA <> 'tSQLt'
            ) As Problems
    Order By ProblemItem

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/sql-server-types-numeric-vs-int'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Column Name Problems

Procedure: AdventureWorks2016CTP3.SQLCop.[test Column Name Problems]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 139863565
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Column Name Problems] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Column Name Problems]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-spaces-or-other-invalid-chara

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT     @Output = @Output + TABLE_SCHEMA + '.' + TABLE_NAME + '.' + COLUMN_NAME + Char(13) + Char(10)
    FROM    INFORMATION_SCHEMA.COLUMNS
    WHERE    COLUMN_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE '%[^a-z_$]%'
            And TABLE_SCHEMA <> 'tSQLt'
    Order By TABLE_SCHEMA,TABLE_NAME,COLUMN_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-spaces-or-other-invalid-chara'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Columns of data type Text/nText

Procedure: AdventureWorks2016CTP3.SQLCop.[test Columns of data type Text/nText]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 155863622
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Columns of data type Text/nText] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Columns of data type Text/nText]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/don-t-use-text-datatype-for-sql-2005-and

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT  @Output = @Output + SCHEMA_NAME(o.uid) + '.' + o.Name + '.' + col.name + Char(13) + Char(10)
    from    syscolumns col
            Inner Join sysobjects o
                On col.id = o.id
            inner join systypes
                 On col.xtype = systypes.xtype
    Where   o.type = 'U'
            And ObjectProperty(o.id, N'IsMSShipped') = 0
            AND systypes.name IN ('text','ntext')
            And SCHEMA_NAME(o.uid) <> 'tSQLt'
    Order By SCHEMA_NAME(o.uid),o.Name, col.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/don-t-use-text-datatype-for-sql-2005-and'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Columns with float data type

Procedure: AdventureWorks2016CTP3.SQLCop.[test Columns with float data type]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 171863679
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Columns with float data type] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Columns with float data type]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-the-float-data-type

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT     @Output = @Output + TABLE_SCHEMA + '.' + TABLE_NAME + '.' + COLUMN_NAME + Char(13) + Char(10)
    FROM    INFORMATION_SCHEMA.COLUMNS
    WHERE    DATA_TYPE IN ('float', 'real')
            AND TABLE_SCHEMA <> 'tSQLt'
    Order By TABLE_SCHEMA,TABLE_NAME,COLUMN_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-the-float-data-type'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Columns with image data type

Procedure: AdventureWorks2016CTP3.SQLCop.[test Columns with image data type]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 187863736
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Columns with image data type] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Columns with image data type]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/don-t-use-text-datatype-for-sql-2005-and

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT  @Output = @Output + SCHEMA_NAME(o.uid) + '.' + o.Name + '.' + col.name
    from    syscolumns col
            Inner Join sysobjects o
                On col.id = o.id
            inner join systypes
                 On col.xtype = systypes.xtype
    Where   o.type = 'U'
            And ObjectProperty(o.id, N'IsMSShipped') = 0
            And systypes.name In ('image')
            And SCHEMA_NAME(o.uid) <> 'tSQLt'
    Order By SCHEMA_NAME(o.uid),o.Name, col.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/don-t-use-text-datatype-for-sql-2005-and'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Compatibility Level

Procedure: AdventureWorks2016CTP3.SQLCop.[test Compatibility Level]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 203863793
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Compatibility Level] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Compatibility Level]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Database_compatibilty_level

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + Name + Char(13) + Char(10)
    FROM   master.dbo.sysdatabases
    WHERE  cmptlevel != 10 * CONVERT(Int, CONVERT(FLOAT, CONVERT(VARCHAR(3), SERVERPROPERTY('productversion'))))

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Database_compatibilty_level'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Database and Log files on the same disk

Procedure: AdventureWorks2016CTP3.SQLCop.[test Database and Log files on the same disk]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 219863850
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Database and Log files on the same disk] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Database and Log files on the same disk]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.brentozar.com/archive/2009/02/when-should-you-put-data-and-logs-on-the-same-drive/

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + db_name() + Char(13) + Char(10)
    FROM   sys.database_files
    Having Count(*) != Count(Distinct Left(Physical_Name, 3))

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.brentozar.com/archive/2009/02/when-should-you-put-data-and-logs-on-the-same-drive/'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Database collation

Procedure: AdventureWorks2016CTP3.SQLCop.[test Database collation]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 235863907
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Database collation] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Database collation]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/collation-conflicts-with-temp-tables-and

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select  @Output = @Output + 'Warning: Collation conflict between user database and TempDB' + Char(13) + Char(10)
    Where   DatabasePropertyEx('TempDB', 'Collation') <> DatabasePropertyEx(db_name(), 'Collation')

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/collation-conflicts-with-temp-tables-and'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Database Mail

Procedure: AdventureWorks2016CTP3.SQLCop.[test Database Mail]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 251863964
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Database Mail] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Database Mail]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Database_Mail_XPs

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select @Output = @Output + 'Status: Database Mail procedures are enabled' + Char(13) + Char(10)
    from   sys.configurations
    where  name = 'Database Mail XPs'
           and value_in_use = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Database_Mail_XPs'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Decimal Size Problem

Procedure: AdventureWorks2016CTP3.SQLCop.[test Decimal Size Problem]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 267864021
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Decimal Size Problem] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Decimal Size Problem]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/always-include-precision-and-scale-with

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + Schema_Name(Schema_id) + '.' + name + Char(13) + Char(10)
    From    sys.objects
    WHERE    schema_id <> Schema_ID('SQLCop')
            And schema_id <> Schema_Id('tSQLt')
            and (
            REPLACE(REPLACE(Object_Definition(Object_ID), ' ', ''), 'decimal]','decimal') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE '%decimal[^(]%'
            Or REPLACE(REPLACE(Object_Definition(Object_ID), ' ', ''), 'numeric]','numeric') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE '%[^i][^s]numeric[^(]%'
            )
    Order By Schema_Name(Schema_id), name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/always-include-precision-and-scale-with'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Forwarded Records

Procedure: AdventureWorks2016CTP3.SQLCop.[test Forwarded Records]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 283864078
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Forwarded Records] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Forwarded Records]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Finding_Forwarded_Records_SQL_Server_2008

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    If Exists(Select cmptlevel from master.dbo.sysdatabases Where dbid = db_ID() And cmptlevel > 80)
        Begin
            Create Table #Results(ProblemItem VarChar(1000))

            Insert Into #Results(ProblemItem)
            Exec ('    SELECT    SCHEMA_NAME(O.Schema_Id) + ''.'' + O.name As ProblemItem
                    FROM    sys.dm_db_index_physical_stats (DB_ID(), NULL, NULL, NULL, ''DETAILED'') AS ps
                            INNER JOIN sys.indexes AS i
                                ON ps.OBJECT_ID = i.OBJECT_ID
                                AND ps.index_id = i.index_id
                            INNER JOIN sys.objects as O
                                On i.OBJECT_ID = O.OBJECT_ID
                    WHERE  ps.forwarded_record_count > 0
                    Order By SCHEMA_NAME(O.Schema_Id),O.name')

            If Exists(Select 1 From #Results)
                Select    @Output = @Output + ProblemItem + Char(13) + Char(10)
                From    #Results

        End
    Else
      Set @Output = 'Unable to check index forwarded records when compatibility is set to 80 or below'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Finding_Forwarded_Records_SQL_Server_2008'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Fragmented Indexes

Procedure: AdventureWorks2016CTP3.SQLCop.[test Fragmented Indexes]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 299864135
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Fragmented Indexes] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Fragmented Indexes]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Finding_Fragmentation_Of_An_Index_And_Fixing_It

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    Create Table #Result (ProblemItem VarChar(1000))

    If Exists(Select cmptlevel from master.dbo.sysdatabases Where dbid = db_ID() And cmptlevel > 80)
        If Exists(Select 1 From fn_my_permissions(NULL, 'DATABASE') WHERE permission_name = 'VIEW DATABASE STATE')
            Begin
                Insert Into #Result(ProblemItem)
                Exec('
                        SELECT    OBJECT_NAME(OBJECT_ID) + ''.'' + s.name As ProblemItem
                        FROM    sys.dm_db_index_physical_stats (DB_ID(), NULL, NULL , NULL, N''LIMITED'') d
                                join sysindexes s
                                    ON    d.OBJECT_ID = s.id
                                    and d.index_id = s.indid
                        Where    avg_fragmentation_in_percent >= 30
                                And OBJECT_NAME(OBJECT_ID) + ''.'' + s.name > ''''
                                And page_count > 1000
                                Order By Object_Name(OBJECT_ID), s.name')
            End
        Else
            Set @Output = 'You do not have VIEW DATABASE STATE permissions within this database'
        Else
            Set @Output = 'Unable to check index fragmentation when compatibility is set to 80 or below'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Finding_Fragmentation_Of_An_Index_And_Fixing_It'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Instant File Initialization

Procedure: AdventureWorks2016CTP3.SQLCop.[test Instant File Initialization]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 315864192
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Instant File Initialization] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Instant File Initialization]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.bradmcgehee.com/2010/07/instant-file-initialization-speeds-sql-server/#more-1704

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    CREATE TABLE #Output(Value VarChar(8000))

    If Exists(select * from sys.configurations Where name='xp_cmdshell' and value_in_use = 1)
        Begin
            If Is_SrvRoleMember('sysadmin') = 1
                Begin
                    Insert Into #Output EXEC ('xp_cmdshell ''whoami /priv''');

                    If Not Exists(Select 1 From #Output Where Value LIKE '%SeManageVolumePrivilege%')
                        Select @Output = 'Instant File Initialization disabled'
                    Else
                        Select    @Output = 'Instant File Initialization disabled'
                        From    #Output
                        Where    Value LIKE '%SeManageVolumePrivilege%'
                                And Value Like '%disabled%'
                End
            Else
                Set @Output = 'You do not have the appropriate permissions to run xp_cmdshell'
        End
    Else
        Begin
            Set @Output = 'xp_cmdshell must be enabled to determine if instant file initialization is enabled.'
        End
    Drop Table #Output

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.bradmcgehee.com/2010/07/instant-file-initialization-speeds-sql-server/#more-1704'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Login Language

Procedure: AdventureWorks2016CTP3.SQLCop.[test Login Language]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 331864249
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Login Language] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Login Language]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/setting-a-standard-dateformat-for-sql-se

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Declare @DefaultLanguage VarChar(100)

    Set @Output = ''

    Select  @DefaultLanguage = L.Name
    From    Master.dbo.sysconfigures C
            Inner Join Master.dbo.syslanguages L
              On C.Value = L.LangId
              And C.Comment = 'default Language'

    Select  @Output = @Output + Name + Char(13) + Char(10)
    From    master..syslogins
    Where   Language <> @DefaultLanguage
    Order By Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/setting-a-standard-dateformat-for-sql-se'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Max degree of parallelism

Procedure: AdventureWorks2016CTP3.SQLCop.[test Max degree of parallelism]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 347864306
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Max degree of parallelism] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Max degree of parallelism]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://sqlblog.com/blogs/adam_machanic/archive/2010/05/28/sql-university-parallelism-week-part-3-settings-and-options.aspx

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select @Output = 'Warning: Max degree of parallelism is setup to use all cores'
    from   sys.configurations
    where  name = 'max degree of parallelism'
           and value_in_use = 0

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://sqlblog.com/blogs/adam_machanic/archive/2010/05/28/sql-university-parallelism-week-part-3-settings-and-options.aspx'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Missing Foreign Key Indexes

Procedure: AdventureWorks2016CTP3.SQLCop.[test Missing Foreign Key Indexes]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 363864363
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Missing Foreign Key Indexes] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Missing Foreign Key Indexes]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.jasonstrate.com/2010/06/index-those-foreign-keys/

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    If Exists(Select 1 From fn_my_permissions(NULL, 'DATABASE') WHERE permission_name = 'VIEW DATABASE STATE')
        SELECT    @Output = @Output + Convert(VarChar(300), fk.foreign_key_name) + Char(13) + Char(10)
        FROM    (
                SELECT    fk.name AS foreign_key_name,
                        'PARENT' as foreign_key_type,
                        fkc.parent_object_id AS object_id,
                        STUFF((    SELECT ', ' + QUOTENAME(c.name)
                                FROM    sys.foreign_key_columns ifkc
                                        INNER JOIN sys.columns c
                                            ON ifkc.parent_object_id = c.object_id
                                            AND ifkc.parent_column_id = c.column_id
                                WHERE fk.object_id = ifkc.constraint_object_id
                                ORDER BY ifkc.constraint_column_id
                                FOR XML PATH('')), 1, 2, '') AS fk_columns,
                        (    SELECT    QUOTENAME(ifkc.parent_column_id,'(')
                            FROM    sys.foreign_key_columns ifkc
                            WHERE    fk.object_id = ifkc.constraint_object_id
                            ORDER BY ifkc.constraint_column_id
                            FOR XML PATH('')) AS fk_columns_compare
                FROM    sys.foreign_keys fk
                        INNER JOIN sys.foreign_key_columns fkc
                            ON fk.object_id = fkc.constraint_object_id
                WHERE fkc.constraint_column_id = 1

                UNION ALL

                SELECT    fk.name AS foreign_key_name,
                        'REFERENCED' as foreign_key_type,
                        fkc.referenced_object_id AS object_id,
                        STUFF((    SELECT    ', ' + QUOTENAME(c.name)
                                FROM    sys.foreign_key_columns ifkc
                                        INNER JOIN sys.columns c
                                            ON ifkc.referenced_object_id = c.object_id
                                            AND ifkc.referenced_column_id = c.column_id
                                WHERE fk.object_id = ifkc.constraint_object_id
                                ORDER BY ifkc.constraint_column_id
                                FOR XML PATH('')), 1, 2, '') AS fk_columns,
                        (    SELECT    QUOTENAME(ifkc.referenced_column_id,'(')
                            FROM    sys.foreign_key_columns ifkc
                            WHERE    fk.object_id = ifkc.constraint_object_id
                            ORDER BY ifkc.constraint_column_id
                            FOR XML PATH('')) AS fk_columns_compare
                FROM    sys.foreign_keys fk
                        INNER JOIN sys.foreign_key_columns fkc
                            ON fk.object_id = fkc.constraint_object_id
                WHERE    fkc.constraint_column_id = 1
                ) fk
                INNER JOIN (
                    SELECT    object_id,
                            SUM(row_count) AS row_count
                    FROM    sys.dm_db_partition_stats ps
                    WHERE    index_id IN (1,0)
                    GROUP BY object_id
                ) rc
                    ON fk.object_id = rc.object_id
                LEFT OUTER JOIN (
                    SELECT    i.object_id,
                            i.name,
                            (
                            SELECT    QUOTENAME(ic.column_id,'(')
                            FROM    sys.index_columns ic
                            WHERE    i.object_id = ic.object_id
                                    AND i.index_id = ic.index_id
                                    AND is_included_column = 0
                            ORDER BY key_ordinal ASC
                            FOR XML PATH('')
                            ) AS indexed_compare
                    FROM    sys.indexes i
                    ) i
                ON fk.object_id = i.object_id
                AND i.indexed_compare LIKE fk.fk_columns_compare + '%'
        WHERE    i.name IS NULL
        ORDER BY OBJECT_NAME(fk.object_id), fk.fk_columns
    Else
        Set @Output = 'You do not have VIEW DATABASE STATE permissions within this database'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.jasonstrate.com/2010/06/index-those-foreign-keys/'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Missing Foreign Keys

Procedure: AdventureWorks2016CTP3.SQLCop.[test Missing Foreign Keys]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 379864420
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Missing Foreign Keys] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Missing Foreign Keys]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/missing-foreign-key-constraints

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    DECLARE @AcceptableSymbols VARCHAR(100)

    SET @AcceptableSymbols = '_$'
    SET @Output = ''

    SELECT  @Output = @Output + C.TABLE_SCHEMA + '.' + C.TABLE_NAME + '.' + C.COLUMN_NAME + Char(13) + Char(10)
    FROM    INFORMATION_SCHEMA.COLUMNS C
            INNER Join INFORMATION_SCHEMA.TABLES T
              ON C.TABLE_NAME = T.TABLE_NAME
              AND T.TABLE_TYPE = 'BASE TABLE'
              AND T.TABLE_SCHEMA = C.TABLE_SCHEMA
            LEFT Join INFORMATION_SCHEMA.CONSTRAINT_COLUMN_USAGE U
              ON C.TABLE_NAME = U.TABLE_NAME
              AND C.COLUMN_NAME = U.COLUMN_NAME
              AND U.TABLE_SCHEMA = C.TABLE_SCHEMA
    WHERE   U.COLUMN_NAME IS Null
            And C.TABLE_SCHEMA <> 'tSQLt'
            AND C.COLUMN_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%id'
    ORDER BY C.TABLE_SCHEMA, C.TABLE_NAME, C.COLUMN_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/missing-foreign-key-constraints'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Old Backups

Procedure: AdventureWorks2016CTP3.SQLCop.[test Old Backups]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 395864477
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Old Backups] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Old Backups]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/the-sql-server-backup-foundation-of-any

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select  @Output = @Output + 'Outdated Backup For '+ D.Name + Char(13) + Char(10)
    FROM    Master..sysdatabases As D
            Left Join MSDB.dbo.BackupSet As B
              On  B.database_name = D.Name
              And B.Type = 'd'
    WHERE   D.Status & 512 = 0
    GROUP BY D.Name
    Having Coalesce(DATEDIFF(D, Max(Backup_Finish_Date), Getdate()), 1000) > 7
    ORDER BY D.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/the-sql-server-backup-foundation-of-any'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Ole Automation Procedures

Procedure: AdventureWorks2016CTP3.SQLCop.[test Ole Automation Procedures]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 411864534
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Ole Automation Procedures] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Ole Automation Procedures]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Ole_Automation_Procedures

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select @Output = @Output + 'Warning: Ole Automation procedures are enabled' + Char(13) + Char(10)
    from   sys.configurations
    where  name = 'Ole Automation Procedures'
           and value_in_use = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#Ole_Automation_Procedures'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Orphaned Users

Procedure: AdventureWorks2016CTP3.SQLCop.[test Orphaned Users]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 427864591
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Orphaned Users] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Orphaned Users]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Fix_Orphaned_Database_Users

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Set NOCOUNT ON
    If is_rolemember('db_owner') = 1
        Begin
            Declare @Temp Table(UserName sysname, UserSid VarBinary(85))

            Insert Into @Temp Exec sp_change_users_login 'report'

            Select @Output = @Output + UserName + Char(13) + Char(10)
            From   @Temp
            Order By UserName
        End
    Else
        Set @Output = 'Only members of db_owner can perform this check.'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Fix_Orphaned_Database_Users'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Page life expectancy

Procedure: AdventureWorks2016CTP3.SQLCop.[test Page life expectancy]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 443864648
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Page life expectancy] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Page life expectancy]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/MSSQLServerAdmin/use-sys-dm_os_performance_counters-to-ge#PLE

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    If Exists(Select 1 From fn_my_permissions(NULL, 'SERVER') WHERE permission_name = 'VIEW SERVER STATE')
        SELECT    @Output = @Output + Convert(VarChar(100), cntr_value) + Char(13) + Char(10)
        FROM    sys.dm_os_performance_counters
        WHERE    counter_name collate SQL_LATIN1_GENERAL_CP1_CI_AI = 'Page life expectancy'
                AND OBJECT_NAME collate SQL_LATIN1_GENERAL_CP1_CI_AI like '%:Buffer Manager%'
                And cntr_value <= 300
    Else
        Set @Output = 'You do not have VIEW SERVER STATE permissions within this instance.'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/MSSQLServerAdmin/use-sys-dm_os_performance_counters-to-ge#PLE'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Procedures Named SP_

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures Named SP_]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 459864705
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures Named SP_] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures Named SP_]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/don-t-start-your-procedures-with-sp_

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    SELECT    @Output = @Output + SPECIFIC_SCHEMA + '.' + SPECIFIC_NAME + Char(13) + Char(10)
    From    INFORMATION_SCHEMA.ROUTINES
    Where    SPECIFIC_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE 'sp[_]%'
            And SPECIFIC_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI NOT LIKE '%diagram%'
            AND ROUTINE_SCHEMA <> 'tSQLt'
    Order By SPECIFIC_SCHEMA,SPECIFIC_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/don-t-start-your-procedures-with-sp_'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Procedures that call undocumented procedures

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures that call undocumented procedures]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 475864762
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures that call undocumented procedures] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures that call undocumented procedures]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/identify-procedures-that-call-sql-server

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    DECLARE @Temp TABLE(ProcedureName VARCHAR(50))

    INSERT INTO @Temp VALUES('sp_MStablespace')
    INSERT INTO @Temp VALUES('sp_who2')
    INSERT INTO @Temp VALUES('sp_tempdbspace')
    INSERT INTO @Temp VALUES('sp_MSkilldb')
    INSERT INTO @Temp VALUES('sp_MSindexspace')
    INSERT INTO @Temp VALUES('sp_MShelptype')
    INSERT INTO @Temp VALUES('sp_MShelpindex')
    INSERT INTO @Temp VALUES('sp_MShelpcolumns')
    INSERT INTO @Temp VALUES('sp_MSforeachtable')
    INSERT INTO @Temp VALUES('sp_MSforeachdb')
    INSERT INTO @Temp VALUES('sp_fixindex')
    INSERT INTO @Temp VALUES('sp_columns_rowset')
    INSERT INTO @Temp VALUES('sp_MScheck_uid_owns_anything')
    INSERT INTO @Temp VALUES('sp_MSgettools_path')
    INSERT INTO @Temp VALUES('sp_gettypestring')
    INSERT INTO @Temp VALUES('sp_MSdrop_object')
    INSERT INTO @Temp VALUES('sp_MSget_qualified_name')
    INSERT INTO @Temp VALUES('sp_MSgetversion')
    INSERT INTO @Temp VALUES('xp_dirtree')
    INSERT INTO @Temp VALUES('xp_subdirs')
    INSERT INTO @Temp VALUES('xp_enum_oledb_providers')
    INSERT INTO @Temp VALUES('xp_enumcodepages')
    INSERT INTO @Temp VALUES('xp_enumdsn')
    INSERT INTO @Temp VALUES('xp_enumerrorlogs')
    INSERT INTO @Temp VALUES('xp_enumgroups')
    INSERT INTO @Temp VALUES('xp_fileexist')
    INSERT INTO @Temp VALUES('xp_fixeddrives')
    INSERT INTO @Temp VALUES('xp_getnetname')
    INSERT INTO @Temp VALUES('xp_readerrorlog')
    INSERT INTO @Temp VALUES('sp_msdependencies')
    INSERT INTO @Temp VALUES('xp_qv')
    INSERT INTO @Temp VALUES('xp_delete_file')
    INSERT INTO @Temp VALUES('sp_checknames')
    INSERT INTO @Temp VALUES('sp_enumoledbdatasources')
    INSERT INTO @Temp VALUES('sp_MS_marksystemobject')
    INSERT INTO @Temp VALUES('sp_MSaddguidcolumn')
    INSERT INTO @Temp VALUES('sp_MSaddguidindex')
    INSERT INTO @Temp VALUES('sp_MSaddlogin_implicit_ntlogin')
    INSERT INTO @Temp VALUES('sp_MSadduser_implicit_ntlogin')
    INSERT INTO @Temp VALUES('sp_MSdbuseraccess')
    INSERT INTO @Temp VALUES('sp_MSdbuserpriv')
    INSERT INTO @Temp VALUES('sp_MSloginmappings')
    INSERT INTO @Temp VALUES('sp_MStablekeys')
    INSERT INTO @Temp VALUES('sp_MStablerefs')
    INSERT INTO @Temp VALUES('sp_MSuniquetempname')
    INSERT INTO @Temp VALUES('sp_MSuniqueobjectname')
    INSERT INTO @Temp VALUES('sp_MSuniquecolname')
    INSERT INTO @Temp VALUES('sp_MSuniquename')
    INSERT INTO @Temp VALUES('sp_MSunc_to_drive')
    INSERT INTO @Temp VALUES('sp_MSis_pk_col')
    INSERT INTO @Temp VALUES('xp_get_MAPI_default_profile')
    INSERT INTO @Temp VALUES('xp_get_MAPI_profiles')
    INSERT INTO @Temp VALUES('xp_regdeletekey')
    INSERT INTO @Temp VALUES('xp_regdeletevalue')
    INSERT INTO @Temp VALUES('xp_regread')
    INSERT INTO @Temp VALUES('xp_regenumvalues')
    INSERT INTO @Temp VALUES('xp_regaddmultistring')
    INSERT INTO @Temp VALUES('xp_regremovemultistring')
    INSERT INTO @Temp VALUES('xp_regwrite')
    INSERT INTO @Temp VALUES('xp_varbintohexstr')
    INSERT INTO @Temp VALUES('sp_MSguidtostr')

    Select @Output = @Output + u.name + '.' + o.name + Char(13) + Char(10)
    FROM   sysobjects o
           INNER JOIN syscomments c
             ON o.id = c.id
             AND o.xtype = 'P'
           INNER JOIN sysusers u
             ON o.uid = u.uid
           INNER JOIN @Temp t
             ON c.text COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE '%' + t.ProcedureName + '%'
    WHERE  xtype = 'P'
           AND OBJECTPROPERTY(o.id, N'IsMSShipped') = 0
           AND u.name <> 'tSQLt'
    ORDER BY u.name + '.' + o.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/identify-procedures-that-call-sql-server'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Procedures using dynamic SQL without sp_executesql

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures using dynamic SQL without sp_executesql]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 491864819
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures using dynamic SQL without sp_executesql] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures using dynamic SQL without sp_executesql]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/avoid-conversions-in-execution-plans-by-

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    SELECT    @OUtput = @Output + SCHEMA_NAME(so.uid) + '.' + so.name + Char(13) + Char(10)
    From    sys.sql_modules sm
            Inner Join sys.sysobjects so
                On  sm.object_id = so.id
                And so.type = 'P'
    Where    so.uid <> Schema_Id('tSQLt')
            And so.uid <> Schema_Id('SQLCop')
            And Replace(sm.definition, ' ', '') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%Exec(%'
            And Replace(sm.definition, ' ', '') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Not Like '%sp_Executesql%'
            And OBJECTPROPERTY(so.Id, N'IsMSSHIPPED') = 0
    Order By SCHEMA_NAME(so.uid),so.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/avoid-conversions-in-execution-plans-by-'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Procedures with @@Identity

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures with @@Identity]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 507864876
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures with @@Identity] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures with @@Identity]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/6_Different_Ways_To_Get_The_Current_Identity_Value

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select    @Output = @Output + Schema_Name(schema_id) + '.' + name + Char(13) + Char(10)
    From    sys.all_objects
    Where    Type = 'P'
            AND name Not In('sp_helpdiagrams','sp_upgraddiagrams','sp_creatediagram','testProcedures with @@Identity')
            And Object_Definition(Object_id) COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%@@identity%'
            And is_ms_shipped = 0
            and schema_id <> Schema_id('tSQLt')
            and schema_id <> Schema_id('SQLCop')
    ORDER BY Schema_Name(schema_id), name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/6_Different_Ways_To_Get_The_Current_Identity_Value'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Procedures With SET ROWCOUNT

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures With SET ROWCOUNT]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 523864933
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures With SET ROWCOUNT] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures With SET ROWCOUNT]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://sqltips.wordpress.com/2007/08/19/set-rowcount-will-not-be-supported-in-future-version-of-sql-server/

      SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    SELECT    @Output = @Output + Schema_Name(schema_id) + '.' + name + Char(13) + Char(10)
    From    sys.all_objects
    Where    Type = 'P'
            AND name Not In('sp_helpdiagrams','sp_upgraddiagrams','sp_creatediagram','testProcedures With SET ROWCOUNT')
            And Replace(Object_Definition(Object_id), ' ', '') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%SETROWCOUNT%'
            And is_ms_shipped = 0
            and schema_id <> Schema_id('tSQLt')
            and schema_id <> Schema_id('SQLCop')
    ORDER BY Schema_Name(schema_id) + '.' + name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://sqltips.wordpress.com/2007/08/19/set-rowcount-will-not-be-supported-in-future-version-of-sql-server/'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Procedures without SET NOCOUNT ON

Procedure: AdventureWorks2016CTP3.SQLCop.[test Procedures without SET NOCOUNT ON]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 539864990
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Procedures without SET NOCOUNT ON] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Procedures without SET NOCOUNT ON]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/Optimization:_Set_Nocount_On

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    SELECT    @Output = @Output + Schema_Name(schema_id) + '.' + name + Char(13) + Char(10)
    From    sys.all_objects
    Where    Type = 'P'
            AND name Not In('sp_helpdiagrams','sp_upgraddiagrams','sp_creatediagram','testProcedures without SET NOCOUNT ON')
            And Object_Definition(Object_id) COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI not Like '%SET NOCOUNT ON%'
            And is_ms_shipped = 0
            and schema_id <> Schema_id('tSQLt')
            and schema_id <> Schema_id('SQLCop')
    ORDER BY Schema_Name(schema_id) + '.' + name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/Optimization:_Set_Nocount_On'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Service Account

Procedure: AdventureWorks2016CTP3.SQLCop.[test Service Account]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 555865047
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Service Account] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Service Account]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://msdn.microsoft.com/en-us/library/ms143504.aspx#Use_startup_accounts

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    --Declare a variable to hold the value
    DECLARE @serviceaccount varchar(100)

    --Retrieve the Service account from registry
    EXECUTE master.dbo.xp_instance_regread
            N'HKEY_LOCAL_MACHINE',
            N'SYSTEM\CurrentControlSet\Services\MSSQLSERVER',
            N'ObjectName',
            @ServiceAccount OUTPUT,
            N'no_output'

    --Display the Service Account
    SELECT @Output = 'Service account set to LocalSystem'
    Where  @ServiceAccount = 'LocalSystem'

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://msdn.microsoft.com/en-us/library/ms143504.aspx#Use_startup_accounts'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test SMO and DMO

Procedure: AdventureWorks2016CTP3.SQLCop.[test SMO and DMO]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 571865104
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test SMO and DMO] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test SMO and DMO]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#SMO_and_DMO_XPs

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select @Output = @Output + 'Status: SMO and DMO procedures are enabled' + Char(13) + Char(10)
    from   sys.configurations
    where  name = 'SMO and DMO XPs'
           and value_in_use = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#SMO_and_DMO_XPs'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Table name problems

Procedure: AdventureWorks2016CTP3.SQLCop.[test Table name problems]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 587865161
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Table name problems] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Table name problems]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-spaces-or-other-invalid-chara

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    DECLARE @AcceptableSymbols VARCHAR(100)

    SET @AcceptableSymbols = '_$'
    SET @Output = ''

    SELECT  @Output = @Output + TABLE_SCHEMA + '.' + TABLE_NAME + Char(13) + Char(10)
    FROM    INFORMATION_SCHEMA.TABLES
    WHERE   TABLE_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%[^a-z' + @AcceptableSymbols + ']%'
            AND TABLE_SCHEMA <> 'tSQLt'
    ORDER BY TABLE_SCHEMA,TABLE_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/do-not-use-spaces-or-other-invalid-chara'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Tables that start with tbl

Procedure: AdventureWorks2016CTP3.SQLCop.[test Tables that start with tbl]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 603865218
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Tables that start with tbl] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Tables that start with tbl]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/don-t-prefix-your-table-names-with-tbl

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT    @Output = @Output + TABLE_SCHEMA + '.' + TABLE_NAME + Char(13) + Char(10)
    From    INFORMATION_SCHEMA.TABLES
    WHERE    TABLE_TYPE = 'BASE TABLE'
            And TABLE_NAME COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI LIKE 'tbl%'
            And TABLE_SCHEMA <> 'tSQLt'
    Order By TABLE_SCHEMA,TABLE_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/don-t-prefix-your-table-names-with-tbl'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Tables without a primary key

Procedure: AdventureWorks2016CTP3.SQLCop.[test Tables without a primary key]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 619865275
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Tables without a primary key] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Tables without a primary key]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/best-practice-every-table-should-have-a

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT    @Output = @Output + su.name + '.' + AllTables.Name + Char(13) + Char(10)
    FROM    (
            SELECT    Name, id, uid
            From    sysobjects
            WHERE    xtype = 'U'
            ) AS AllTables
            INNER JOIN sysusers su
                On AllTables.uid = su.uid
            LEFT JOIN (
                SELECT parent_obj
                From sysobjects
                WHERE  xtype = 'PK'
                ) AS PrimaryKeys
                ON AllTables.id = PrimaryKeys.parent_obj
    WHERE    PrimaryKeys.parent_obj Is Null
            AND su.name <> 'tSQLt'
    ORDER BY su.name,AllTables.Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/best-practice-every-table-should-have-a'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Tables without any data

Procedure: AdventureWorks2016CTP3.SQLCop.[test Tables without any data]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 635865332
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Tables without any data] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Tables without any data]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/List_all_empty_tables_in_your_SQL_Server_database

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    CREATE TABLE #EmptyTables(Table_Name VarChar(100))
    EXEC     sp_MSforeachtable 'IF NOT EXISTS(SELECT 1 FROM ?) INSERT INTO #EmptyTables VALUES(''?'')'
    SELECT    @Output = @Output + Table_Name + Char(13) + Char(10)
    FROM    #EmptyTables
    Where    Left(Table_Name, 7) <> '[tSQLt]'
    ORDER BY Table_Name
    DROP TABLE #EmptyTables

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/List_all_empty_tables_in_your_SQL_Server_database'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test UniqueIdentifier with NewId

Procedure: AdventureWorks2016CTP3.SQLCop.[test UniqueIdentifier with NewId]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 651865389
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test UniqueIdentifier with NewId] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test UniqueIdentifier with NewId]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/best-practice-don-t-not-cluster-on-uniqu

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT  @Output = @Output + so.name + '.' + col.name + Char(13) + Char(10)
    FROM    sysobjects so
            INNER JOIN sysindexes sind
                ON so.id=sind.id
            INNER JOIN sysindexkeys sik
                ON sind.id=sik.id
                AND sind.indid=sik.indid
            INNER JOIN syscolumns col
                ON col.id=sik.id
                AND col.colid=sik.colid
            INNER JOIN systypes
                ON col.xtype = systypes.xtype
            INNER JOIN syscomments
                ON col.cdefault = syscomments.id
    WHERE    sind.Status & 16 = 16
            AND systypes.name = 'uniqueidentifier'
            AND keyno = 1
            AND sind.OrigFillFactor = 0
            AND syscomments.TEXT COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%newid%'
            and so.name <> 'tSQLt'
    ORDER BY so.name, sik.keyno

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/best-practice-don-t-not-cluster-on-uniqu'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Unnamed Constraints

Procedure: AdventureWorks2016CTP3.SQLCop.[test Unnamed Constraints]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 667865446
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Unnamed Constraints] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Unnamed Constraints]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/how-to-name-default-constraints-and-how-

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT    @Output = @Output + CONSTRAINT_SCHEMA + '.' + CONSTRAINT_NAME + Char(13) + Char(10)
    From    INFORMATION_SCHEMA.CONSTRAINT_TABLE_USAGE
    Where    CONSTRAINT_NAME collate sql_latin1_general_CP1_CI_AI Like '%[_][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f][0-9a-f]'
            And TABLE_NAME <> 'sysdiagrams'
            And CONSTRAINT_SCHEMA <> 'tSQLt'
    Order By CONSTRAINT_SCHEMA,CONSTRAINT_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/how-to-name-default-constraints-and-how-'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test User Aliases

Procedure: AdventureWorks2016CTP3.SQLCop.[test User Aliases]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 683865503
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test User Aliases] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test User Aliases]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://www.mssqltips.com/tip.asp?tip=1675

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select @Output = @Output + Name + Char(13) + Char(10)
    From   sysusers
    Where  IsAliased = 1
    Order By Name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://www.mssqltips.com/tip.asp?tip=1675'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Varchar Size Problem

Procedure: AdventureWorks2016CTP3.SQLCop.[test Varchar Size Problem]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 699865560
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Varchar Size Problem] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Varchar Size Problem]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/always-include-size-when-using-varchar-n

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    Select    @Output = @Output + ProblemItem + Char(13) + Char(10)
    From    (
            SELECT    DISTINCT su.name + '.' + so.Name As ProblemItem
            From    SYSCOMMENTS sc
                    Inner Join SYSOBJECTS so
                        On  sc.id = so.id
                        And so.xtype = 'P'
                    INNER JOIN sys.schemas su
                        ON so.uid = su.schema_id
            Where    REPLACE(Replace(sc.text, ' ', ''), 'varchar]','varchar') COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI Like '%varchar[^(]%'
                    And ObjectProperty(sc.Id, N'IsMSSHIPPED') = 0
                    And su.schema_id <> schema_id('tSQLt')
                    and su.schema_id <> Schema_id('SQLCop')
            ) As Problems
    Order By ProblemItem

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DBProgramming/MSSQLServer/always-include-size-when-using-varchar-n'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End

END;

GO

Collapse image See also

List of procedures


test Views with order by

Procedure: AdventureWorks2016CTP3.SQLCop.[test Views with order by]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 715865617
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Views with order by] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Views with order by]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/create-a-sorted-view-in-sql-server-2005--2008

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    SELECT    @Output = @Output + sysusers.name + '.' + sysobjects.name + Char(13) + Char(10)
    FROM    sysobjects
            INNER JOIN syscomments
              ON sysobjects.id = syscomments.id
            INNER JOIN sysusers
              ON sysobjects.uid = sysusers.uid
    WHERE    xtype = 'V'
            and syscomments.text COLLATE SQL_LATIN1_GENERAL_CP1_CI_AI like '%order by%'
            and sysusers.name <> 'tSQLt'
    ORDER BY sysusers.name,sysobjects.name

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/create-a-sorted-view-in-sql-server-2005--2008'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test Wide Table

Procedure: AdventureWorks2016CTP3.SQLCop.[test Wide Table]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 731865674
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test Wide Table] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test Wide Table]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_wide_table_check

    SET NOCOUNT ON

    DECLARE @Output VarChar(max)
    SET @Output = ''

    Select  @Output = @Output + C.TABLE_SCHEMA + '.' + C.TABLE_NAME + Char(13) + Char(10)
    From    INFORMATION_SCHEMA.TABLES T
            INNER JOIN INFORMATION_SCHEMA.COLUMNS C
              On  T.TABLE_NAME = C.TABLE_NAME
              AND T.TABLE_SCHEMA = C.TABLE_SCHEMA
              And T.TABLE_TYPE = 'BASE TABLE'
            INNER JOIN systypes S
                On C.DATA_TYPE = S.name
    WHERE   C.TABLE_SCHEMA <> 'tSQLt'
    GROUP BY C.TABLE_SCHEMA,C.TABLE_NAME
    HAVING SUM(ISNULL(NULLIF(CONVERT(BIGINT,S.Length), 8000), 0) + ISNULL(NULLIF(C.CHARACTER_MAXIMUM_LENGTH, 2147483647), 0)) > 8060
    ORDER BY C.TABLE_SCHEMA,C.TABLE_NAME

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_wide_table_check'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


test xp_cmdshell is enabled

Procedure: AdventureWorks2016CTP3.SQLCop.[test xp_cmdshell is enabled]

CollapseAll image

Collapse image Procedure properties

Name | Value
Schema | SQLCop
Owner | dbo
Creation date | 19.09.2016
Type | P
Encrypted |
ID | 747865731
Implementation type | Transact SQL
Is native compiled |

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Objects that SQLCop.[test xp_cmdshell is enabled] depends on

Object name | Object type | Dep level
SQLCop | Schema | 1
tSQLt.Fail | Unknown | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE [SQLCop].[test xp_cmdshell is enabled]
AS
BEGIN
    -- Written by George Mastros
    -- February 25, 2012
    -- http://sqlcop.lessthandot.com
    -- http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#xp_cmdshell

    SET NOCOUNT ON

    Declare @Output VarChar(max)
    Set @Output = ''

    select @Output = @Output + 'Warning: xp_cmdshell is enabled' + Char(13) + Char(10)
    from   sys.configurations
    where  name = 'xp_cmdshell'
           and value_in_use = 1

    If @Output > ''
        Begin
            Set @Output = Char(13) + Char(10)
                          + 'For more information:  '
                          + 'http://wiki.lessthandot.com/index.php/SQLCop_informational_checks#xp_cmdshell'
                          + Char(13) + Char(10)
                          + Char(13) + Char(10)
                          + @Output
            EXEC tSQLt.Fail @Output
        End
END;

GO

Collapse image See also

List of procedures


Roles

List of roles

Collapse image Roles

Name | Role type | Users and roles with this role
db_accessadmin | User-defined role |
db_backupoperator | User-defined role |
db_datareader | User-defined role |
db_datawriter | User-defined role |
db_ddladmin | User-defined role |
db_denydatareader | User-defined role |
db_denydatawriter | User-defined role |
db_owner | User-defined role | dbo
db_securityadmin | User-defined role |
public | Standard role (built-in) | amy0, brian3, david8, dbo, garrett1, guest, jae0, jillian0, josé1, linda3, lynn0, michael9, pamela0, rachel0, ranjit0, shu0, stephen0, syed0, tete0, tsvi0
SalesManagers | User-defined role | amy0, brian3, stephen0, syed0
SalesPersons | User-defined role | david8, garrett1, jae0, jillian0, josé1, linda3, lynn0, michael9, pamela0, rachel0, ranjit0, shu0, tete0, tsvi0
Total: 12 role(s)

Collapse image See also

Users

Database overview


db_accessadmin

Role: AdventureWorks2016CTP3.dbo.db_accessadmin

Collapse image Role properties

Name | Value
Name | db_accessadmin
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_backupoperator

Role: AdventureWorks2016CTP3.dbo.db_backupoperator

Collapse image Role properties

Name | Value
Name | db_backupoperator
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_datareader

Role: AdventureWorks2016CTP3.dbo.db_datareader

Collapse image Role properties

Name | Value
Name | db_datareader
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_datawriter

Role: AdventureWorks2016CTP3.dbo.db_datawriter

Collapse image Role properties

Name | Value
Name | db_datawriter
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_ddladmin

Role: AdventureWorks2016CTP3.dbo.db_ddladmin

Collapse image Role properties

Name | Value
Name | db_ddladmin
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_denydatareader

Role: AdventureWorks2016CTP3.dbo.db_denydatareader

Collapse image Role properties

Name | Value
Name | db_denydatareader
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_denydatawriter

Role: AdventureWorks2016CTP3.dbo.db_denydatawriter

Collapse image Role properties

Name | Value
Name | db_denydatawriter
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


db_owner

Role: AdventureWorks2016CTP3.dbo.db_owner

Collapse image Role properties

Name | Value
Name | db_owner
Owner | dbo
Type | User-defined role

Collapse image Users and roles with this role

User
dbo

Collapse image See also

List of roles


db_securityadmin

Role: AdventureWorks2016CTP3.dbo.db_securityadmin

Collapse image Role properties

Name | Value
Name | db_securityadmin
Owner | dbo
Type | User-defined role

Collapse image See also

List of roles


public

Role: AdventureWorks2016CTP3.dbo.public

Collapse image Role properties

Name | Value
Name | public
Owner | dbo
Type | Standard role (built-in)

Collapse image Users and roles with this role

User
amy0
brian3
david8
dbo
garrett1
guest
jae0
jillian0
josé1
linda3
lynn0
michael9
pamela0
rachel0
ranjit0
shu0
stephen0
syed0
tete0
tsvi0

Collapse image SQL

NA

Collapse image See also

List of roles


SalesManagers

Role: AdventureWorks2016CTP3.dbo.SalesManagers

Collapse image Role properties

Name | Value
Name | SalesManagers
Owner | dbo
Type | User-defined role

Collapse image Users and roles with this role

User
amy0
brian3
stephen0
syed0

Collapse image Permissions

Object | Alter | Control | Select | Insert | Update | Delete | Execute | DRI | Take Ownership | View Definition | Send | Receive
Sales.CustomerPII |  |  |  |  |  |  |  |  |  |  |  |

Collapse image SQL

CREATE ROLE [SalesManagers] AUTHORIZATION [dbo]
GO

ALTER ROLE [SalesManagers] ADD MEMBER [amy0]

GO
ALTER ROLE [SalesManagers] ADD MEMBER [brian3]

GO
ALTER ROLE [SalesManagers] ADD MEMBER [stephen0]

GO
ALTER ROLE [SalesManagers] ADD MEMBER [syed0]

GO

Collapse image See also

List of roles


SalesPersons

Role: AdventureWorks2016CTP3.dbo.SalesPersons

Collapse image Role properties

Name | Value
Name | SalesPersons
Owner | dbo
Type | User-defined role

Collapse image Users and roles with this role

User
david8
garrett1
jae0
jillian0
josé1
linda3
lynn0
michael9
pamela0
rachel0
ranjit0
shu0
tete0
tsvi0

Collapse image Permissions

Object | Alter | Control | Select | Insert | Update | Delete | Execute | DRI | Take Ownership | View Definition | Send | Receive
Sales.CustomerPII |  |  |  |  |  |  |  |  |  |  |  |

Collapse image SQL

CREATE ROLE [SalesPersons] AUTHORIZATION [dbo]
GO

ALTER ROLE [SalesPersons] ADD MEMBER [david8]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [garrett1]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [jae0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [jillian0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [josé1]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [linda3]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [lynn0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [michael9]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [pamela0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [rachel0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [ranjit0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [shu0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [tete0]

GO
ALTER ROLE [SalesPersons] ADD MEMBER [tsvi0]

GO

Collapse image See also

List of roles


Schemas

List of schemas

Collapse image Schemas

Name | Owner | Description
db_accessadmin | db_accessadmin |
db_backupoperator | db_backupoperator |
db_datareader | db_datareader |
db_datawriter | db_datawriter |
db_ddladmin | db_ddladmin |
db_denydatareader | db_denydatareader |
db_denydatawriter | db_denydatawriter |
db_owner | db_owner |
db_securityadmin | db_securityadmin |
dbo | dbo |
Demo | dbo |
guest | guest |
HumanResources | dbo | Contains objects related to employees and departments.
INFORMATION_SCHEMA | INFORMATION_SCHEMA |
Person | dbo | Contains objects related to names and addresses of customers, vendors, and employees
Production | dbo | Contains objects related to products, inventory, and manufacturing.
Purchasing | dbo | Contains objects related to vendors and purchase orders.
Sales | dbo | Contains objects related to customers, sales orders, and sales territories.
Security | dbo |
SQLCop | dbo |
sys | sys |
Total: 21 schema(s)

Collapse image See also

Users

Roles

Database overview


db_accessadmin

Schema: AdventureWorks2016CTP3.db_accessadmin.db_accessadmin

Collapse image Schema properties

Name | Value
Name | db_accessadmin
Owner | db_accessadmin
ID | 16385

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_accessadmin]
    TO [db_accessadmin]
GO

Collapse image See also

List of schemas


db_backupoperator

Schema: AdventureWorks2016CTP3.db_backupoperator.db_backupoperator

CollapseAll image

Collapse image Schema properties

Name | Value
Name | db_backupoperator
Owner | db_backupoperator
ID | 16389

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_backupoperator]
    TO [db_backupoperator]
GO

Collapse image See also

List of schemas


db_datareader

Schema: AdventureWorks2016CTP3.db_datareader.db_datareader

Collapse image Schema properties

Name | Value
Name | db_datareader
Owner | db_datareader
ID | 16390

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_datareader]
    TO [db_datareader]
GO

Collapse image See also

List of schemas


db_datawriter

Schema: AdventureWorks2016CTP3.db_datawriter.db_datawriter

Collapse image Schema properties

Name | Value
Name | db_datawriter
Owner | db_datawriter
ID | 16391

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_datawriter]
    TO [db_datawriter]
GO

Collapse image See also

List of schemas


db_ddladmin

Schema: AdventureWorks2016CTP3.db_ddladmin.db_ddladmin

Collapse image Schema properties

Name | Value
Name | db_ddladmin
Owner | db_ddladmin
ID | 16387

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_ddladmin]
    TO [db_ddladmin]
GO

Collapse image See also

List of schemas


db_denydatareader

Schema: AdventureWorks2016CTP3.db_denydatareader.db_denydatareader

CollapseAll image

Collapse image Schema properties

Name | Value
Name | db_denydatareader
Owner | db_denydatareader
ID | 16392

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_denydatareader]
    TO [db_denydatareader]
GO

Collapse image See also

List of schemas


db_denydatawriter

Schema: AdventureWorks2016CTP3.db_denydatawriter.db_denydatawriter

CollapseAll image

Collapse image Schema properties

Name | Value
Name | db_denydatawriter
Owner | db_denydatawriter
ID | 16393

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_denydatawriter]
    TO [db_denydatawriter]
GO

Collapse image See also

List of schemas


db_owner

Schema: AdventureWorks2016CTP3.db_owner.db_owner

Collapse image Schema properties

Name | Value
Name | db_owner
Owner | db_owner
ID | 16384

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_owner]
    TO [db_owner]
GO

Collapse image See also

List of schemas


db_securityadmin

Schema: AdventureWorks2016CTP3.db_securityadmin.db_securityadmin

CollapseAll image

Collapse image Schema properties

Name | Value
Name | db_securityadmin
Owner | db_securityadmin
ID | 16386

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[db_securityadmin]
    TO [db_securityadmin]
GO

Collapse image See also

List of schemas


dbo

Schema: AdventureWorks2016CTP3.dbo.dbo

Collapse image Schema properties

Name | Value
Name | dbo
Owner | dbo
ID | 1

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
AUDIT_UNDO | View
AUDIT_VIEW | View
Total: 59 object(s)

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[dbo]
    TO [dbo]
GO

Collapse image See also

List of schemas


Demo

Schema: AdventureWorks2016CTP3.dbo.Demo

Collapse image Schema properties

Name | Value
Name | Demo
Owner | dbo
ID | 11

Collapse image Objects

Name | Type
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
Total: 4 object(s)

Collapse image Objects that depend on Demo

Object name | Object type | Dep level
Demo.usp_DemoInitSeed | Procedure | 1
Demo.usp_DemoReset | Procedure | 1
Demo.DemoSalesOrderDetailSeed | Table | 1
Demo.DemoSalesOrderHeaderSeed | Table | 1
Total 4 object(s)

Collapse image SQL

CREATE SCHEMA [Demo]
    AUTHORIZATION [dbo]
GO

Collapse image See also

List of schemas


guest

Schema: AdventureWorks2016CTP3.guest.guest

Collapse image Schema properties

Name | Value
Name | guest
Owner | guest
ID | 2

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[guest]
    TO [guest]
GO

Collapse image See also

List of schemas


HumanResources

Schema: AdventureWorks2016CTP3.dbo.HumanResources

Collapse image Description

Contains objects related to employees and departments.

Collapse image Schema properties

Name | Value
Name | HumanResources
Owner | dbo
ID | 5

Collapse image Objects

Name | Type
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Total: 34 object(s)

Collapse image Objects that depend on HumanResources

Object name | Object type | Dep level
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure | 1
HumanResources.sp_UpdateEmployee_Temporal | Procedure | 1
HumanResources.uspUpdateEmployeeHireInfo | Procedure | 1
HumanResources.uspUpdateEmployeeLogin | Procedure | 1
HumanResources.uspUpdateEmployeePersonalInfo | Procedure | 1
HumanResources.Department | Table | 1
HumanResources.Employee | Table | 1
HumanResources.Employee_Temporal | Table | 1
HumanResources.Employee_Temporal_History | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
HumanResources.EmployeePayHistory | Table | 1
HumanResources.JobCandidate | Table | 1
HumanResources.Shift | Table | 1
HumanResources.dEmployee | Trigger | 1
HumanResources.tr_d_AUDIT_Department | Trigger | 1
HumanResources.tr_d_AUDIT_Employee | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger | 1
HumanResources.tr_i_AUDIT_Department | Trigger | 1
HumanResources.tr_i_AUDIT_Employee | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger | 1
HumanResources.tr_u_AUDIT_Department | Trigger | 1
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger | 1
HumanResources.vEmployee | View | 1
HumanResources.vEmployeeDepartment | View | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
HumanResources.vEmployeePersonTemporalInfo | View | 1
HumanResources.vJobCandidate | View | 1
HumanResources.vJobCandidateEducation | View | 1
HumanResources.vJobCandidateEmployment | View | 1
HumanResources.HRResumeSchemaCollection | XML Schema Collection | 1
Total 34 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains objects related to employees and departments.

Collapse image SQL

CREATE SCHEMA [HumanResources]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains objects related to employees and departments.', 'SCHEMA', N'HumanResources', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


INFORMATION_SCHEMA

Schema: AdventureWorks2016CTP3.INFORMATION_SCHEMA.INFORMATION_SCHEMA

CollapseAll image

Collapse image Schema properties

Name | Value
Name | INFORMATION_SCHEMA
Owner | INFORMATION_SCHEMA
ID | 3

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[INFORMATION_SCHEMA]
    TO [INFORMATION_SCHEMA]
GO

Collapse image See also

List of schemas


Person

Schema: AdventureWorks2016CTP3.dbo.Person

Collapse image Description

Contains objects related to names and addresses of customers, vendors, and employees

Collapse image Schema properties

Name | Value
Name | Person
Owner | dbo
ID | 6

Collapse image Objects

Name | Type
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Person.iuPerson | Trigger
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Total: 23 object(s)

Collapse image Objects that depend on Person

Object name | Object type | Dep level
Person.sp_DeletePerson_Temporal | Procedure | 1
Person.sp_UpdatePerson_Temporal | Procedure | 1
Person.Address | Table | 1
Person.AddressType | Table | 1
Person.BusinessEntity | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.BusinessEntityContact | Table | 1
Person.ContactType | Table | 1
Person.CountryRegion | Table | 1
Person.EmailAddress | Table | 1
Person.Password | Table | 1
Person.Person | Table | 1
Person.Person_json | Table | 1
Person.Person_Temporal | Table | 1
Person.Person_Temporal_History | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Person.StateProvince | Table | 1
Person.iuPerson | Trigger | 1
Person.vAdditionalContactInfo | View | 1
Person.vStateProvinceCountryRegion | View | 1
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection | 1
Person.IndividualSurveySchemaCollection | XML Schema Collection | 1
Total 23 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains objects related to names and addresses of customers, vendors, and employees

Collapse image SQL

CREATE SCHEMA [Person]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains objects related to names and addresses of customers, vendors, and employees', 'SCHEMA', N'Person', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


Production

Schema: AdventureWorks2016CTP3.dbo.Production

Collapse image Description

Contains objects related to products, inventory, and manufacturing.

Collapse image Schema properties

Name | Value
Name | Production
Owner | dbo
ID | 7

Collapse image Objects

Name | Type
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Total: 34 object(s)

Collapse image Objects that depend on Production

Object name | Object type | Dep level
Production.BillOfMaterials | Table | 1
Production.Culture | Table | 1
Production.Document | Table | 1
Production.Illustration | Table | 1
Production.Location | Table | 1
Production.Product | Table | 1
Production.Product_inmem | Table | 1
Production.Product_ondisk | Table | 1
Production.ProductCategory | Table | 1
Production.ProductCostHistory | Table | 1
Production.ProductDescription | Table | 1
Production.ProductDocument | Table | 1
Production.ProductInventory | Table | 1
Production.ProductListPriceHistory | Table | 1
Production.ProductModel | Table | 1
Production.ProductModelIllustration | Table | 1
Production.ProductModelProductDescriptionCulture | Table | 1
Production.ProductPhoto | Table | 1
Production.ProductProductPhoto | Table | 1
Production.ProductReview | Table | 1
Production.ProductSubcategory | Table | 1
Production.ScrapReason | Table | 1
Production.TransactionHistory | Table | 1
Production.TransactionHistoryArchive | Table | 1
Production.UnitMeasure | Table | 1
Production.WorkOrder | Table | 1
Production.WorkOrderRouting | Table | 1
Production.iWorkOrder | Trigger | 1
Production.uWorkOrder | Trigger | 1
Production.vProductAndDescription | View | 1
Production.vProductModelCatalogDescription | View | 1
Production.vProductModelInstructions | View | 1
Production.ManuInstructionsSchemaCollection | XML Schema Collection | 1
Production.ProductDescriptionSchemaCollection | XML Schema Collection | 1
Total 34 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains objects related to products, inventory, and manufacturing.

Collapse image SQL

CREATE SCHEMA [Production]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains objects related to products, inventory, and manufacturing.', 'SCHEMA', N'Production', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


Purchasing

Schema: AdventureWorks2016CTP3.dbo.Purchasing

Collapse image Description

Contains objects related to vendors and purchase orders.

Collapse image Schema properties

Name | Value
Name | Purchasing
Owner | dbo
ID | 8

Collapse image Objects

Name | Type
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Total: 11 object(s)

Collapse image Objects that depend on Purchasing

Object name | Object type | Dep level
Purchasing.ProductVendor | Table | 1
Purchasing.PurchaseOrderDetail | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Purchasing.ShipMethod | Table | 1
Purchasing.Vendor | Table | 1
Purchasing.dVendor | Trigger | 1
Purchasing.iPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderHeader | Trigger | 1
Purchasing.vVendorWithAddresses | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 11 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains objects related to vendors and purchase orders.

Collapse image SQL

CREATE SCHEMA [Purchasing]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains objects related to vendors and purchase orders.', 'SCHEMA', N'Purchasing', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


Sales

Schema: AdventureWorks2016CTP3.dbo.Sales

Collapse image Description

Contains objects related to customers, sales orders, and sales territories.

Collapse image Schema properties

Name | Value
Name | Sales
Owner | dbo
ID | 9

Collapse image Objects

Name | Type
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 50 object(s)

Collapse image Objects that depend on Sales

Object name | Object type | Dep level
Sales.usp_InsertSalesOrder_inmem | Procedure | 1
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure | 1
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure | 1
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure | 1
Sales.CountryRegionCurrency | Table | 1
Sales.CreditCard | Table | 1
Sales.Currency | Table | 1
Sales.CurrencyRate | Table | 1
Sales.Customer | Table | 1
Sales.CustomerPII | Table | 1
Sales.OrderTracking | Table | 1
Sales.PersonCreditCard | Table | 1
Sales.SalesOrder_json | Table | 1
Sales.SalesOrderDetail | Table | 1
Sales.SalesOrderDetail_inmem | Table | 1
Sales.SalesOrderDetail_ondisk | Table | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesOrderHeader_inmem | Table | 1
Sales.SalesOrderHeader_ondisk | Table | 1
Sales.SalesOrderHeaderSalesReason | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesPersonQuotaHistory | Table | 1
Sales.SalesReason | Table | 1
Sales.SalesTaxRate | Table | 1
Sales.SalesTerritory | Table | 1
Sales.SalesTerritoryHistory | Table | 1
Sales.ShoppingCartItem | Table | 1
Sales.SpecialOffer | Table | 1
Sales.SpecialOffer_inmem | Table | 1
Sales.SpecialOffer_ondisk | Table | 1
Sales.SpecialOfferProduct | Table | 1
Sales.SpecialOfferProduct_inmem | Table | 1
Sales.SpecialOfferProduct_ondisk | Table | 1
Sales.Store | Table | 1
Sales.TrackingEvent | Table | 1
Sales.iduSalesOrderDetail | Trigger | 1
Sales.uSalesOrderHeader | Trigger | 1
Sales.vSalesOrderDetail_extended_inmem | Function | 1
Sales.vSalesOrderHeader_extended_inmem | Function | 1
Sales.SalesOrderDetailType_inmem | Datatype | 1
Sales.SalesOrderDetailType_ondisk | Datatype | 1
Sales.vIndividualCustomer | View | 1
Sales.vPersonDemographics | View | 1
Sales.vSalesPerson | View | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Sales.vStoreWithAddresses | View | 1
Sales.vStoreWithContacts | View | 1
Sales.vStoreWithDemographics | View | 1
Sales.StoreSurveySchemaCollection | XML Schema Collection | 1
Total 50 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains objects related to customers, sales orders, and sales territories.

Collapse image SQL

CREATE SCHEMA [Sales]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains objects related to customers, sales orders, and sales territories.', 'SCHEMA', N'Sales', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


Security

Schema: AdventureWorks2016CTP3.dbo.Security

Collapse image Schema properties

Name | Value
Name | Security
Owner | dbo
ID | 10

Collapse image Objects

Name | Type
Security.customerAccessPredicate | Function
Total: 1 object(s)

Collapse image Objects that depend on Security

Object name | Object type | Dep level
Security.customerAccessPredicate | Function | 1
Total 1 object(s)

Collapse image SQL

CREATE SCHEMA [Security]
    AUTHORIZATION [dbo]
GO

Collapse image See also

List of schemas


SQLCop

Schema: AdventureWorks2016CTP3.dbo.SQLCop

Collapse image Schema properties

Name | Value
Name | SQLCop
Owner | dbo
ID | 13

Collapse image Objects

Name | Type
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
Total: 49 object(s)

Collapse image Objects that depend on SQLCop

Object name | Object type | Dep level
SQLCop.test | Procedure | 1
SQLCop.[test Ad hoc distributed queries] | Procedure | 1
SQLCop.[test Agent Service] | Procedure | 1
SQLCop.[test Auto close] | Procedure | 1
SQLCop.[test Auto create statistics] | Procedure | 1
SQLCop.[test Auto Shrink] | Procedure | 1
SQLCop.[test Auto update statistics] | Procedure | 1
SQLCop.[test Buffer cache hit ratio] | Procedure | 1
SQLCop.[test Column collation does not match database default] | Procedure | 1
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure | 1
SQLCop.[test Column Name Problems] | Procedure | 1
SQLCop.[test Columns of data type Text/nText] | Procedure | 1
SQLCop.[test Columns with float data type] | Procedure | 1
SQLCop.[test Columns with image data type] | Procedure | 1
SQLCop.[test Compatibility Level] | Procedure | 1
SQLCop.[test Database and Log files on the same disk] | Procedure | 1
SQLCop.[test Database collation] | Procedure | 1
SQLCop.[test Database Mail] | Procedure | 1
SQLCop.[test Decimal Size Problem] | Procedure | 1
SQLCop.[test Forwarded Records] | Procedure | 1
SQLCop.[test Fragmented Indexes] | Procedure | 1
SQLCop.[test Instant File Initialization] | Procedure | 1
SQLCop.[test Login Language] | Procedure | 1
SQLCop.[test Max degree of parallelism] | Procedure | 1
SQLCop.[test Missing Foreign Key Indexes] | Procedure | 1
SQLCop.[test Missing Foreign Keys] | Procedure | 1
SQLCop.[test Old Backups] | Procedure | 1
SQLCop.[test Ole Automation Procedures] | Procedure | 1
SQLCop.[test Orphaned Users] | Procedure | 1
SQLCop.[test Page life expectancy] | Procedure | 1
SQLCop.[test Procedures Named SP_] | Procedure | 1
SQLCop.[test Procedures that call undocumented procedures] | Procedure | 1
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure | 1
SQLCop.[test Procedures with @@Identity] | Procedure | 1
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure | 1
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure | 1
SQLCop.[test Service Account] | Procedure | 1
SQLCop.[test SMO and DMO] | Procedure | 1
SQLCop.[test Table name problems] | Procedure | 1
SQLCop.[test Tables that start with tbl] | Procedure | 1
SQLCop.[test Tables without a primary key] | Procedure | 1
SQLCop.[test Tables without any data] | Procedure | 1
SQLCop.[test UniqueIdentifier with NewId] | Procedure | 1
SQLCop.[test Unnamed Constraints] | Procedure | 1
SQLCop.[test User Aliases] | Procedure | 1
SQLCop.[test Varchar Size Problem] | Procedure | 1
SQLCop.[test Views with order by] | Procedure | 1
SQLCop.[test Wide Table] | Procedure | 1
SQLCop.[test xp_cmdshell is enabled] | Procedure | 1
Total 49 object(s)

Collapse image Extended properties

Name | Value
tSQLt.TestClass | 1

Collapse image SQL

CREATE SCHEMA [SQLCop]
    AUTHORIZATION [dbo]
GO
EXEC sp_addextendedproperty N'tSQLt.TestClass', 1, 'SCHEMA', N'SQLCop', NULL, NULL, NULL, NULL
GO

Collapse image See also

List of schemas


sys

Schema: AdventureWorks2016CTP3.sys.sys

Collapse image Schema properties

Name | Value
Name | sys
Owner | sys
ID | 4

Collapse image SQL

ALTER AUTHORIZATION
    ON SCHEMA::[sys]
    TO [sys]
GO

Collapse image See also

List of schemas


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Data size KB | Index size KB | Creation date | Columns | Rows
AUDIT_LOG_DATA | dbo |  | 0 KB | 0 KB | 21.09.2016 | 15 | 0
AUDIT_LOG_DDL | dbo |  | 312 KB | 32 KB | 21.09.2016 | 13 | 714
AUDIT_LOG_TRANSACTIONS | dbo |  | 0 KB | 0 KB | 21.09.2016 | 11 | 0
AWBuildVersion | dbo | Current version number of the AdventureWorks 2014 sample database. | 8 KB | 8 KB | 23.10.2015 | 6 | 1
DatabaseLog | dbo | Audit table tracking all DDL changes made to the AdventureWorks database. Data is captured by the database trigger ddlDatabaseTriggerLog. | 808 KB | 24 KB | 23.10.2015 | 8 | 179
ErrorLog | dbo | Audit table tracking errors in the the AdventureWorks database that are caught by the CATCH block of a TRY...CATCH construct. Data is inserted by stored procedure dbo.uspLogError when it is executed from inside the CATCH block of a TRY...CATCH construct. | 0 KB | 0 KB | 23.10.2015 | 9 | 0
DemoSalesOrderDetailSeed | Demo |  | 0 KB | 0 KB | 23.10.2015 | 5 | 0
DemoSalesOrderHeaderSeed | Demo |  | 0 KB | 0 KB | 23.10.2015 | 7 | 0
Department | HumanResources | Lookup table containing the departments within the Adventure Works Cycles company. | 8 KB | 24 KB | 23.10.2015 | 4 | 16
Employee | HumanResources | Employee information such as salary, department, and title. | 56 KB | 136 KB | 23.10.2015 | 18 | 290
Employee_Temporal | HumanResources |  | 56 KB | 16 KB | 23.10.2015 | 14 | 290
Employee_Temporal_History | HumanResources |  | 0 KB | 0 KB | 23.10.2015 | 14 | 0
EmployeeDepartmentHistory | HumanResources | Employee department transfers. | 16 KB | 48 KB | 23.10.2015 | 6 | 296
EmployeePayHistory | HumanResources | Employee pay history. | 16 KB | 16 KB | 23.10.2015 | 5 | 316
JobCandidate | HumanResources | Résumés submitted to Human Resources by job applicants. | 128 KB | 152 KB | 23.10.2015 | 4 | 13
Shift | HumanResources | Work shift lookup table. | 8 KB | 40 KB | 23.10.2015 | 5 | 3
Address | Person | Street address information for customers, employees, and vendors. | 2904 KB | 2752 KB | 23.10.2015 | 9 | 19614
AddressType | Person | Types of addresses stored in the Address table. | 8 KB | 40 KB | 23.10.2015 | 4 | 6
BusinessEntity | Person | Source of the ID that connects vendors, customers, and employees with address and contact information. | 768 KB | 568 KB | 23.10.2015 | 3 | 20777
BusinessEntityAddress | Person | Cross-reference table mapping customers, vendors, and employees to their addresses. | 880 KB | 1432 KB | 23.10.2015 | 5 | 19614
BusinessEntityContact | Person | Cross-reference table mapping stores, vendors, and employees to people | 48 KB | 144 KB | 23.10.2015 | 5 | 909
ContactType | Person | Lookup table containing the types of business entity contacts. | 8 KB | 24 KB | 23.10.2015 | 3 | 20
CountryRegion | Person | Lookup table containing the ISO standard codes for countries and regions. | 16 KB | 48 KB | 23.10.2015 | 3 | 238
EmailAddress | Person | Where to send a person email. | 1992 KB | 1504 KB | 23.10.2015 | 5 | 19972
Password | Person | One way hashed authentication information | 1880 KB | 16 KB | 23.10.2015 | 5 | 19972
Person | Person | Human beings involved with AdventureWorks: employees, customer contacts, and vendor contacts. | 30552 KB | 53896 KB | 23.10.2015 | 13 | 19972
Person_json | Person |  | 1624 KB | 16 KB | 23.10.2015 | 13 | 19972
Person_Temporal | Person |  | 1464 KB | 16 KB | 23.10.2015 | 11 | 19972
Person_Temporal_History | Person |  | 0 KB | 0 KB | 23.10.2015 | 11 | 0
PersonPhone | Person | Telephone number and type of a person. | 1184 KB | 992 KB | 23.10.2015 | 4 | 19972
PhoneNumberType | Person | Type of phone number of a person. | 8 KB | 8 KB | 16.11.2015 | 3 | 3
StateProvince | Person | State and province lookup table. | 16 KB | 64 KB | 23.10.2015 | 8 | 181
BillOfMaterials | Production | Items required to make bicycles and bicycle subassemblies. It identifies the heirarchical relationship between a parent product and its components. | 160 KB | 200 KB | 23.10.2015 | 9 | 2679
Culture | Production | Lookup table containing the languages in which some AdventureWorks data is stored. | 8 KB | 24 KB | 23.10.2015 | 3 | 8
Document | Production | Product maintenance documents. | 336 KB | 176 KB | 23.10.2015 | 14 | 13
Illustration | Production | Bicycle assembly diagrams. | 240 KB | 8 KB | 23.10.2015 | 3 | 5
Location | Production | Product inventory and manufacturing locations. | 8 KB | 24 KB | 23.10.2015 | 5 | 14
Product | Production | Products sold or used in the manfacturing of sold products. | 104 KB | 128 KB | 23.10.2015 | 25 | 504
Product_inmem | Production |  | 0 KB | 0 KB | 23.10.2015 | 24 | 0
Product_ondisk | Production |  | 96 KB | 96 KB | 23.10.2015 | 24 | 504
ProductCategory | Production | High-level product categorization. | 8 KB | 40 KB | 23.10.2015 | 4 | 4
ProductCostHistory | Production | Changes in the cost of a product over time. | 24 KB | 16 KB | 23.10.2015 | 5 | 395
ProductDescription | Production | Product descriptions in several languages. | 144 KB | 56 KB | 23.10.2015 | 4 | 762
ProductDocument | Production | Cross-reference table mapping products to related product documents. | 8 KB | 8 KB | 23.10.2015 | 3 | 32
ProductInventory | Production | Product inventory information. | 56 KB | 16 KB | 23.10.2015 | 7 | 1069
ProductListPriceHistory | Production | Changes in the list price of a product over time. | 24 KB | 16 KB | 23.10.2015 | 5 | 395
ProductModel | Production | Product model classification. | 144 KB | 216 KB | 23.10.2015 | 6 | 128
ProductModelIllustration | Production | Cross-reference table mapping product models and illustrations. | 8 KB | 8 KB | 23.10.2015 | 3 | 7
ProductModelProductDescriptionCulture | Production | Cross-reference table mapping product descriptions and the language the description is written in. | 32 KB | 16 KB | 23.10.2015 | 4 | 762
ProductPhoto | Production | Product images. | 2280 KB | 16 KB | 23.10.2015 | 6 | 101
ProductProductPhoto | Production | Cross-reference table mapping products and product photos. | 16 KB | 40 KB | 23.10.2015 | 4 | 504
ProductReview | Production | Customer reviews of products they have purchased. | 16 KB | 120 KB | 23.10.2015 | 8 | 4
ProductSubcategory | Production | Product subcategories. See ProductCategory table. | 8 KB | 40 KB | 23.10.2015 | 5 | 37
ScrapReason | Production | Manufacturing failure reasons lookup table. | 8 KB | 24 KB | 23.10.2015 | 3 | 16
TransactionHistory | Production | Record of each purchase order, sales order, or work order transaction year to date. | 6344 KB | 4448 KB | 23.10.2015 | 9 | 113443
TransactionHistoryArchive | Production | Transactions for previous years. | 5000 KB | 3680 KB | 23.10.2015 | 9 | 89253
UnitMeasure | Production | Unit of measure lookup table. | 8 KB | 24 KB | 23.10.2015 | 3 | 38
WorkOrder | Production | Manufacturing work orders. | 4232 KB | 2408 KB | 23.10.2015 | 10 | 72591
WorkOrderRouting | Production | Work order details. | 5600 KB | 1648 KB | 23.10.2015 | 12 | 67131
ProductVendor | Purchasing | Cross-reference table mapping vendors with the products they supply. | 40 KB | 64 KB | 23.10.2015 | 11 | 460
PurchaseOrderDetail | Purchasing | Individual products associated with a specific purchase order. See PurchaseOrderHeader. | 512 KB | 192 KB | 23.10.2015 | 11 | 8845
PurchaseOrderHeader | Purchasing | General purchase order information. See PurchaseOrderDetail. | 336 KB | 160 KB | 23.10.2015 | 13 | 4012
ShipMethod | Purchasing | Shipping company lookup table. | 8 KB | 40 KB | 23.10.2015 | 6 | 5
Vendor | Purchasing | Companies from whom Adventure Works Cycles purchases parts or other goods. | 16 KB | 32 KB | 23.10.2015 | 8 | 104
CountryRegionCurrency | Sales | Cross-reference table mapping ISO currency codes to a country or region. | 8 KB | 24 KB | 23.10.2015 | 3 | 109
CreditCard | Sales | Customer credit card information. | 1496 KB | 832 KB | 23.10.2015 | 6 | 19118
Currency | Sales | Lookup table containing standard ISO currencies. | 8 KB | 24 KB | 23.10.2015 | 3 | 105
CurrencyRate | Sales | Currency exchange rates. | 768 KB | 440 KB | 23.10.2015 | 7 | 13532
Customer | Sales | Current customer information. Also see the Person and Store tables. | 968 KB | 1328 KB | 23.10.2015 | 7 | 19820
CustomerPII | Sales |  | 7992 KB | 8 KB | 23.10.2015 | 8 | 19118
OrderTracking | Sales | Individual tracking events associated with a specific sales order. | 35352 KB | 19056 KB | 16.11.2015 | 6 | 188790
PersonCreditCard | Sales | Cross-reference table mapping people to their credit card information in the CreditCard table. | 480 KB | 16 KB | 23.10.2015 | 3 | 19118
SalesOrder_json | Sales |  | 5456 KB | 32 KB | 23.10.2015 | 26 | 31465
SalesOrderDetail | Sales | Individual products associated with a specific sales order. See SalesOrderHeader. | 9968 KB | 6776 KB | 23.10.2015 | 11 | 121317
SalesOrderDetail_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 9 | 0
SalesOrderDetail_ondisk | Sales |  | 8432 KB | 2728 KB | 23.10.2015 | 9 | 121317
SalesOrderHeader | Sales | General sales order information. | 5536 KB | 2872 KB | 23.10.2015 | 26 | 31465
SalesOrderHeader_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 23 | 0
SalesOrderHeader_ondisk | Sales |  | 4936 KB | 928 KB | 23.10.2015 | 23 | 31465
SalesOrderHeaderSalesReason | Sales | Cross-reference table mapping sales orders to sales reason codes. | 688 KB | 16 KB | 23.10.2015 | 3 | 27647
SalesPerson | Sales | Sales representative current information. | 8 KB | 24 KB | 23.10.2015 | 9 | 17
SalesPersonQuotaHistory | Sales | Sales performance tracking. | 16 KB | 32 KB | 23.10.2015 | 5 | 163
SalesReason | Sales | Lookup table of customer purchase reasons. | 8 KB | 8 KB | 23.10.2015 | 4 | 10
SalesTaxRate | Sales | Tax rate lookup table. | 8 KB | 40 KB | 23.10.2015 | 7 | 29
SalesTerritory | Sales | Sales territory lookup table. | 8 KB | 40 KB | 23.10.2015 | 10 | 10
SalesTerritoryHistory | Sales | Sales representative transfers to other sales territories. | 8 KB | 24 KB | 23.10.2015 | 6 | 17
ShoppingCartItem | Sales | Contains online customer orders until the order is submitted or cancelled. | 8 KB | 24 KB | 23.10.2015 | 6 | 3
SpecialOffer | Sales | Sale discounts lookup table. | 8 KB | 24 KB | 23.10.2015 | 11 | 16
SpecialOffer_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 10 | 0
SpecialOffer_ondisk | Sales |  | 8 KB | 8 KB | 23.10.2015 | 10 | 16
SpecialOfferProduct | Sales | Cross-reference table mapping products to special offer discounts. | 24 KB | 64 KB | 23.10.2015 | 4 | 538
SpecialOfferProduct_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 3 | 0
SpecialOfferProduct_ondisk | Sales |  | 16 KB | 72 KB | 23.10.2015 | 3 | 538
Store | Sales | Customers (resellers) of Adventure Works products. | 808 KB | 616 KB | 23.10.2015 | 6 | 701
TrackingEvent | Sales | Tracking event lookup table. | 8 KB | 8 KB | 16.11.2015 | 2 | 7
Total: 95 table(s)

Collapse image See also

Table Statistics Summary

Database overview


Table statistics summary

Collapse image Statistics pages

Page statistics

Extent statistics

Row statistics

Collapse image See also

List of tables


Page statistics

Collapse image Page statistics

Name | Count | Avg. page density % | Avg. B Free | Forwarded records count
AUDIT_LOG_DATA | 0 | 0 | 0 | 0
AUDIT_LOG_DDL | 39 | 95.5 | 363.948 | 0
AUDIT_LOG_TRANSACTIONS | 0 | 0 | 0 | 0
AWBuildVersion | 1 | 0.54 | 8050 | 0
DatabaseLog | 82 | 75.08 | 2017.28 | 0
ErrorLog | 0 | 0 | 0 | 0
HumanResources.Department | 1 | 20.24 | 6456 | 0
HumanResources.Employee | 7 | 91.16 | 715.142 | 0
HumanResources.Employee_Temporal | 7 | 86.56 | 1088 | 0
HumanResources.Employee_Temporal_History | 0 | 0 | 0 | 0
HumanResources.EmployeeDepartmentHistory | 2 | 54.83 | 3656 | 0
HumanResources.EmployeePayHistory | 2 | 74.15 | 2092 | 0
HumanResources.JobCandidate | 11 | 70.01 | 2427.363 | 0
HumanResources.Shift | 1 | 1.53 | 7970 | 0
Person.Address | 359 | 93.55 | 522.027 | 0
Person.AddressType | 1 | 4.1 | 7762 | 0
Person.BusinessEntity | 96 | 98.91 | 88.197 | 0
Person.BusinessEntityAddress | 110 | 99.11 | 72.09 | 0
Person.BusinessEntityContact | 6 | 84.2 | 1278.5 | 0
Person.ContactType | 1 | 15.91 | 6806 | 0
Person.CountryRegion | 2 | 69.26 | 2488 | 0
Person.EmailAddress | 249 | 99.23 | 62.184 | 0
Person.Password | 235 | 99.73 | 22.212 | 0
Person.Person | 3815 | 85.53 | 1170.815 | 0
Person.Person_json | 203 | 99.12 | 71.467 | 0
Person.Person_Temporal | 183 | 99.17 | 67.562 | 0
Person.Person_Temporal_History | 0 | 0 | 0 | 0
Person.PersonPhone | 148 | 99.08 | 74.824 | 0
Person.PhoneNumberType | 1 | 1.2 | 7997 | 0
Person.StateProvince | 2 | 85.92 | 1140 | 0
Production.BillOfMaterials | 20 | 97.62 | 192.95 | 0
Production.Culture | 1 | 5.24 | 7670 | 0
Production.Document | 1 | 68.24 | 2571 | 0
Production.Illustration | 1 | 4.78 | 7707 | 0
Production.Location | 1 | 10.3 | 7260 | 0
Production.Product | 13 | 92.8 | 582.769 | 0
Production.Product_ondisk | 12 | 91.71 | 670.666 | 0
Production.ProductCategory | 1 | 2.84 | 7864 | 0
Production.ProductCostHistory | 3 | 73.18 | 2171 | 0
Production.ProductDescription | 18 | 93.14 | 555.222 | 0
Production.ProductDocument | 1 | 10.65 | 7232 | 0
Production.ProductInventory | 7 | 92.59 | 600 | 0
Production.ProductListPriceHistory | 3 | 73.18 | 2171 | 0
Production.ProductModel | 12 | 65.69 | 2776.833 | 0
Production.ProductModelIllustration | 1 | 2.14 | 7921 | 0
Production.ProductModelProductDescriptionCulture | 4 | 87.06 | 1047.5 | 0
Production.ProductPhoto | 50 | 84.61 | 1245.44 | 0
Production.ProductProductPhoto | 2 | 80.92 | 1544 | 0
Production.ProductReview | 2 | 63.47 | 2957 | 0
Production.ProductSubcategory | 1 | 28.68 | 5773 | 0
Production.ScrapReason | 1 | 12.95 | 7046 | 0
Production.TransactionHistory | 793 | 98.95 | 84.892 | 0
Production.TransactionHistoryArchive | 625 | 98.78 | 98.931 | 0
Production.UnitMeasure | 1 | 20.61 | 6426 | 0
Production.WorkOrder | 529 | 98.31 | 137.062 | 0
Production.WorkOrderRouting | 700 | 98.32 | 136.181 | 0
Purchasing.ProductVendor | 5 | 81.81 | 1472 | 0
Purchasing.PurchaseOrderDetail | 64 | 99.01 | 80.218 | 0
Purchasing.PurchaseOrderHeader | 42 | 99.11 | 72 | 0
Purchasing.ShipMethod | 1 | 5.47 | 7651 | 0
Purchasing.Vendor | 2 | 58.33 | 3373 | 0
Sales.CountryRegionCurrency | 1 | 41.72 | 4717 | 0
Sales.CreditCard | 187 | 99.23 | 62.491 | 0
Sales.Currency | 1 | 66.31 | 2727 | 0
Sales.CurrencyRate | 96 | 99.24 | 61.375 | 0
Sales.Customer | 121 | 99.14 | 69.719 | 0
Sales.CustomerPII | 999 | 97.01 | 241.827 | 6926
Sales.OrderTracking | 4419 | 98.78 | 98.975 | 0
Sales.PersonCreditCard | 60 | 98.39 | 130.166 | 0
Sales.SalesOrder_json | 682 | 98.86 | 91.913 | 0
Sales.SalesOrderDetail | 1246 | 98.69 | 106.202 | 0
Sales.SalesOrderDetail_ondisk | 1054 | 99.6 | 31.973 | 0
Sales.SalesOrderHeader | 692 | 97.44 | 207.579 | 0
Sales.SalesOrderHeader_ondisk | 617 | 99.2 | 64.643 | 0
Sales.SalesOrderHeaderSalesReason | 86 | 99.27 | 59.081 | 0
Sales.SalesPerson | 1 | 16.36 | 6770 | 0
Sales.SalesPersonQuotaHistory | 2 | 53.34 | 3776.5 | 0
Sales.SalesReason | 1 | 7.88 | 7456 | 0
Sales.SalesTaxRate | 1 | 32.0 | 5504 | 0
Sales.SalesTerritory | 1 | 14.75 | 6900 | 0
Sales.SalesTerritoryHistory | 1 | 11.95 | 7127 | 0
Sales.ShoppingCartItem | 1 | 1.87 | 7943 | 0
Sales.SpecialOffer | 1 | 32.89 | 5432 | 0
Sales.SpecialOffer_ondisk | 1 | 29.73 | 5688 | 0
Sales.SpecialOfferProduct | 3 | 90.82 | 743.333 | 0
Sales.SpecialOfferProduct_ondisk | 2 | 83.06 | 1371 | 0
Sales.Store | 101 | 91.9 | 655.415 | 0
Sales.TrackingEvent | 1 | 4.63 | 7719 | 0

Collapse image See also

Table statistics


Extent statistics

Collapse image Extent statistics

Name | Count | Switches | Scan density % | Best count | Actual count | Logical frag % | Extent frag %
AUDIT_LOG_DATA | 0 | 0 | 100 | 0 | 0 | 0 | 0
AUDIT_LOG_DDL | 5 | 4 | 100 | 5 | 5 | 7.69 | 80
AUDIT_LOG_TRANSACTIONS | 0 | 0 | 100 | 0 | 0 | 0 | 0
AWBuildVersion | 1 | 0 | 100 | 1 | 1 | 0 | 0
DatabaseLog | 13 | 12 | 84.62 | 11 | 13 | 0 | 61.54
ErrorLog | 0 | 0 | 100 | 0 | 0 | 0 | 0
HumanResources.Department | 1 | 0 | 100 | 1 | 1 | 0 | 0
HumanResources.Employee | 1 | 0 | 100 | 1 | 1 | 0 | 0
HumanResources.Employee_Temporal | 2 | 1 | 50 | 1 | 2 | 0 | 50
HumanResources.Employee_Temporal_History | 0 | 0 | 100 | 0 | 0 | 0 | 0
HumanResources.EmployeeDepartmentHistory | 2 | 1 | 50 | 1 | 2 | 50 | 50
HumanResources.EmployeePayHistory | 2 | 1 | 50 | 1 | 2 | 50 | 50
HumanResources.JobCandidate | 5 | 4 | 40 | 2 | 5 | 45.45 | 80
HumanResources.Shift | 1 | 0 | 100 | 1 | 1 | 0 | 0
Person.Address | 48 | 47 | 93.75 | 45 | 48 | 6.41 | 54.17
Person.AddressType | 1 | 0 | 100 | 1 | 1 | 0 | 0
Person.BusinessEntity | 12 | 11 | 100 | 12 | 12 | 0 | 8.33
Person.BusinessEntityAddress | 14 | 13 | 100 | 14 | 14 | 0.91 | 14.29
Person.BusinessEntityContact | 3 | 2 | 33.33 | 1 | 3 | 33.33 | 66.67
Person.ContactType | 1 | 0 | 100 | 1 | 1 | 0 | 0
Person.CountryRegion | 2 | 1 | 50 | 1 | 2 | 50 | 0
Person.EmailAddress | 32 | 31 | 100 | 32 | 32 | 0 | 12.5
Person.Password | 30 | 29 | 100 | 30 | 30 | 0 | 16.67
Person.Person | 489 | 488 | 97.55 | 477 | 489 | 1.0 | 10.84
Person.Person_json | 27 | 26 | 96.3 | 26 | 27 | 0.49 | 3.7
Person.Person_Temporal | 24 | 23 | 95.83 | 23 | 24 | 0.55 | 4.17
Person.Person_Temporal_History | 0 | 0 | 100 | 0 | 0 | 0 | 0
Person.PersonPhone | 19 | 18 | 100 | 19 | 19 | 0 | 5.26
Person.PhoneNumberType | 1 | 0 | 100 | 1 | 1 | 0 | 0
Person.StateProvince | 1 | 0 | 100 | 1 | 1 | 50 | 0
Production.BillOfMaterials | 4 | 3 | 75 | 3 | 4 | 15 | 25
Production.Culture | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.Document | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.Illustration | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.Location | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.Product | 4 | 3 | 50 | 2 | 4 | 30.77 | 75
Production.Product_ondisk | 3 | 2 | 66.67 | 2 | 3 | 8.33 | 66.67
Production.ProductCategory | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.ProductCostHistory | 2 | 1 | 50 | 1 | 2 | 66.67 | 50
Production.ProductDescription | 3 | 2 | 100 | 3 | 3 | 0 | 0
Production.ProductDocument | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.ProductInventory | 4 | 3 | 25 | 1 | 4 | 57.14 | 50
Production.ProductListPriceHistory | 1 | 0 | 100 | 1 | 1 | 66.67 | 0
Production.ProductModel | 2 | 1 | 100 | 2 | 2 | 0 | 0
Production.ProductModelIllustration | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.ProductModelProductDescriptionCulture | 1 | 0 | 100 | 1 | 1 | 50 | 0
Production.ProductPhoto | 7 | 6 | 100 | 7 | 7 | 0 | 0
Production.ProductProductPhoto | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.ProductReview | 1 | 0 | 100 | 1 | 1 | 50 | 0
Production.ProductSubcategory | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.ScrapReason | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.TransactionHistory | 114 | 118 | 84.03 | 100 | 119 | 4.54 | 14.91
Production.TransactionHistoryArchive | 102 | 104 | 75.24 | 79 | 105 | 5.28 | 9.8
Production.UnitMeasure | 1 | 0 | 100 | 1 | 1 | 0 | 0
Production.WorkOrder | 76 | 80 | 82.72 | 67 | 81 | 5.86 | 39.47
Production.WorkOrderRouting | 102 | 104 | 83.81 | 88 | 105 | 4.57 | 19.61
Purchasing.ProductVendor | 2 | 1 | 50 | 1 | 2 | 40 | 50
Purchasing.PurchaseOrderDetail | 8 | 7 | 100 | 8 | 8 | 0 | 0
Purchasing.PurchaseOrderHeader | 6 | 5 | 100 | 6 | 6 | 0 | 0
Purchasing.ShipMethod | 1 | 0 | 100 | 1 | 1 | 0 | 0
Purchasing.Vendor | 1 | 0 | 100 | 1 | 1 | 50 | 0
Sales.CountryRegionCurrency | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.CreditCard | 24 | 23 | 100 | 24 | 24 | 0 | 4.17
Sales.Currency | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.CurrencyRate | 12 | 11 | 100 | 12 | 12 | 0 | 8.33
Sales.Customer | 16 | 15 | 100 | 16 | 16 | 0 | 12.5
Sales.CustomerPII | 127 | 126 | 98.43 | 125 | 127 | 0 | 21.26
Sales.OrderTracking | 557 | 556 | 99.28 | 553 | 557 | 0.23 | 12.93
Sales.PersonCreditCard | 8 | 7 | 100 | 8 | 8 | 0 | 12.5
Sales.SalesOrder_json | 87 | 86 | 98.85 | 86 | 87 | 0.15 | 1.15
Sales.SalesOrderDetail | 169 | 171 | 90.7 | 156 | 172 | 2.89 | 31.95
Sales.SalesOrderDetail_ondisk | 133 | 132 | 99.25 | 132 | 133 | 0.19 | 17.29
Sales.SalesOrderHeader | 105 | 107 | 80.56 | 87 | 108 | 5.06 | 7.62
Sales.SalesOrderHeader_ondisk | 78 | 77 | 100 | 78 | 78 | 0.16 | 2.56
Sales.SalesOrderHeaderSalesReason | 11 | 10 | 100 | 11 | 11 | 0 | 9.09
Sales.SalesPerson | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SalesPersonQuotaHistory | 1 | 0 | 100 | 1 | 1 | 50 | 0
Sales.SalesReason | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SalesTaxRate | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SalesTerritory | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SalesTerritoryHistory | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.ShoppingCartItem | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SpecialOffer | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SpecialOffer_ondisk | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.SpecialOfferProduct | 2 | 1 | 50 | 1 | 2 | 66.67 | 50
Sales.SpecialOfferProduct_ondisk | 1 | 0 | 100 | 1 | 1 | 0 | 0
Sales.Store | 13 | 12 | 100 | 13 | 13 | 0 | 0
Sales.TrackingEvent | 1 | 0 | 100 | 1 | 1 | 0 | 0

Collapse image See also

Table statistics


Row statistics

Collapse image Row statistics

Name | Count | Min. size B | Max. size B | Avg. size B
AUDIT_LOG_DATA | 0 | 0 | 0 | 0
AUDIT_LOG_DDL | 714 | 330 | 542 | 420.34
AUDIT_LOG_TRANSACTIONS | 0 | 0 | 0 | 0
AWBuildVersion | 1 | 44 | 44 | 44
DatabaseLog | 179 | 243 | 7664 | 2782.66
ErrorLog | 0 | 0 | 0 | 0
HumanResources.Department | 16 | 69 | 147 | 100.5
HumanResources.Employee | 290 | 130 | 205 | 176.16
HumanResources.Employee_Temporal | 290 | 121 | 196 | 167.16
HumanResources.Employee_Temporal_History | 0 | 0 | 0 | 0
HumanResources.EmployeeDepartmentHistory | 296 | 28 | 28 | 28
HumanResources.EmployeePayHistory | 316 | 36 | 36 | 36
HumanResources.JobCandidate | 13 | 63 | 7279 | 4794.54
HumanResources.Shift | 3 | 36 | 44 | 40
Person.Address | 19614 | 108 | 198 | 136.63
Person.AddressType | 6 | 47 | 61 | 53.67
Person.BusinessEntity | 20777 | 35 | 35 | 35
Person.BusinessEntityAddress | 19614 | 43 | 43 | 43
Person.BusinessEntityContact | 909 | 43 | 43 | 43
Person.ContactType | 20 | 33 | 85 | 62.5
Person.CountryRegion | 238 | 33 | 113 | 45.13
Person.EmailAddress | 19972 | 87 | 129 | 98.16
Person.Password | 19972 | 93 | 93 | 93
Person.Person | 19972 | 543 | 3540 | 1320.83
Person.Person_json | 19972 | 65 | 121 | 79.56
Person.Person_Temporal | 19972 | 57 | 113 | 71.56
Person.Person_Temporal_History | 0 | 0 | 0 | 0
Person.PersonPhone | 19972 | 51 | 65 | 57.44
Person.PhoneNumberType | 3 | 31 | 31 | 31
Person.StateProvince | 181 | 62 | 104 | 74.86
Production.BillOfMaterials | 2679 | 57 | 57 | 57
Production.Culture | 8 | 39 | 107 | 51.25
Production.Document | 13 | 93 | 1010 | 423
Production.Illustration | 5 | 47 | 83 | 75.8
Production.Location | 14 | 40 | 74 | 57.71
Production.Product | 504 | 152 | 234 | 191.79
Production.Product_ondisk | 504 | 135 | 217 | 174.79
Production.ProductCategory | 4 | 49 | 61 | 56
Production.ProductCostHistory | 395 | 43 | 43 | 43
Production.ProductDescription | 762 | 45 | 577 | 176.13
Production.ProductDocument | 32 | 25 | 25 | 25
Production.ProductInventory | 1069 | 46 | 50 | 47.09
Production.ProductListPriceHistory | 395 | 43 | 43 | 43
Production.ProductModel | 128 | 49 | 8021 | 496.67
Production.ProductModelIllustration | 7 | 23 | 23 | 23
Production.ProductModelProductDescriptionCulture | 762 | 35 | 35 | 35
Production.ProductPhoto | 101 | 229 | 7837 | 3389.37
Production.ProductProductPhoto | 504 | 24 | 24 | 24
Production.ProductReview | 4 | 603 | 7735 | 2567.5
Production.ProductSubcategory | 37 | 51 | 77 | 60.78
Production.ScrapReason | 16 | 49 | 83 | 63.63
Production.TransactionHistory | 113443 | 54 | 54 | 54
Production.TransactionHistoryArchive | 89253 | 54 | 54 | 54
Production.UnitMeasure | 38 | 33 | 65 | 41.95
Production.WorkOrder | 72591 | 56 | 56 | 56
Production.WorkOrderRouting | 67131 | 81 | 81 | 81
Purchasing.ProductVendor | 460 | 70 | 70 | 70
Purchasing.PurchaseOrderDetail | 8845 | 56 | 56 | 56
Purchasing.PurchaseOrderHeader | 4012 | 82 | 82 | 82
Purchasing.ShipMethod | 5 | 79 | 91 | 87
Purchasing.Vendor | 104 | 55 | 145 | 88.83
Sales.CountryRegionCurrency | 109 | 29 | 29 | 29
Sales.CreditCard | 19118 | 66 | 82 | 76.58
Sales.Currency | 105 | 31 | 83 | 49.13
Sales.CurrencyRate | 13532 | 55 | 55 | 55
Sales.Customer | 19820 | 47 | 47 | 47
Sales.CustomerPII | 26044 | 9 | 471 | 299.22
Sales.OrderTracking | 188790 | 141 | 211 | 185.19
Sales.PersonCreditCard | 19118 | 23 | 23 | 23
Sales.SalesOrder_json | 31465 | 154 | 195 | 171.49
Sales.SalesOrderDetail | 121317 | 66 | 94 | 80.06
Sales.SalesOrderDetail_ondisk | 121317 | 54 | 82 | 68.06
Sales.SalesOrderHeader | 31465 | 154 | 195 | 171.49
Sales.SalesOrderHeader_ondisk | 31465 | 138 | 179 | 155.49
Sales.SalesOrderHeaderSalesReason | 27647 | 23 | 23 | 23
Sales.SalesPerson | 17 | 76 | 76 | 76
Sales.SalesPersonQuotaHistory | 163 | 51 | 51 | 51
Sales.SalesReason | 10 | 45 | 93 | 62
Sales.SalesTaxRate | 29 | 72 | 122 | 87.38
Sales.SalesTerritory | 10 | 104 | 124 | 117.6
Sales.SalesTerritoryHistory | 17 | 55 | 55 | 55
Sales.ShoppingCartItem | 3 | 49 | 49 | 49
Sales.SpecialOffer | 16 | 138 | 196 | 164.5
Sales.SpecialOffer_ondisk | 16 | 122 | 180 | 148.5
Sales.SpecialOfferProduct | 538 | 39 | 39 | 39
Sales.SpecialOfferProduct_ondisk | 538 | 23 | 23 | 23
Sales.Store | 701 | 1035 | 1125 | 1070.04
Sales.TrackingEvent | 7 | 35 | 81 | 51.86

Collapse image See also

Table statistics


AUDIT_LOG_DATA

Table: AdventureWorks2016CTP3.dbo.AUDIT_LOG_DATA

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 21.09.2016
ID | 1147867156
Located on | PRIMARY
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__AUDIT_LO__40D2552DE38D4F0A]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | AUDIT_LOG_DATA_ID |  |  | int | 4 |  |  |  |  |
 |  | Foreign key | AUDIT_LOG_TRANSACTION_ID |  |  | int | 4 |  |  |  |  |
 |  |  | PRIMARY_KEY_DATA |  |  | nvarchar | 1500 |  |  |  |  |
 |  |  | COL_NAME |  |  | nvarchar | 128 |  |  |  |  |
 |  |  | OLD_VALUE_LONG |  |  | ntext | 1073741823 |  |  |  |  |
 |  |  | NEW_VALUE_LONG |  |  | ntext | 1073741823 |  |  |  |  |
 |  |  | NEW_VALUE_BLOB |  |  | image | 2147483647 |  |  |  |  |
 |  |  | NEW_VALUE |  | True | nvarchar | 4000 |  |  |  |  | (isnull(CONVERT([nvarchar](4000),[NEW_VALUE_LONG]),CONVERT([varchar](8000),CONVERT([varbinary](8000),substring([NEW_VALUE_BLOB],(1),(8000))))))
 |  |  | OLD_VALUE |  | True | nvarchar | 4000 |  |  |  |  | (CONVERT([nvarchar](4000),[OLD_VALUE_LONG]))
 |  |  | PRIMARY_KEY |  | True | nvarchar | 1500 |  |  |  |  | ([PRIMARY_KEY_DATA])
 |  |  | DATA_TYPE |  |  | char | 1 |  | ('A') |  |  |
 |  |  | KEY1 |  |  | nvarchar | 500 |  |  |  |  |
 |  |  | KEY2 |  |  | nvarchar | 500 |  |  |  |  |
 |  |  | KEY3 |  |  | nvarchar | 500 |  |  |  |  |
 |  |  | KEY4 |  |  | nvarchar | 500 |  |  |  |  |
Total: 15 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PRIMARY_KEY_DATA | nvarchar(1500) | 0 | 0 | 0 | 0 |
COL_NAME | nvarchar(128) | 0 | 0 | 0 | 0 |
NEW_VALUE | nvarchar(4000) | 0 | 0 | 0 | 0 | (isnull(CONVERT([nvarchar](4000),[NEW_VALUE_LONG]),CONVERT([varchar](8000),CONVERT([varbinary](8000),substring([NEW_VALUE_BLOB],(1),(8000))))))
OLD_VALUE | nvarchar(4000) | 0 | 0 | 0 | 0 | (CONVERT([nvarchar](4000),[OLD_VALUE_LONG]))
PRIMARY_KEY | nvarchar(1500) | 0 | 0 | 0 | 0 | ([PRIMARY_KEY_DATA])
DATA_TYPE | char(1) | 0 | 0 | 0 | 0 |
KEY1 | nvarchar(500) | 0 | 0 | 0 | 0 |
KEY2 | nvarchar(500) | 0 | 0 | 0 | 0 |
KEY3 | nvarchar(500) | 0 | 0 | 0 | 0 |
KEY4 | nvarchar(500) | 0 | 0 | 0 | 0 |
Total: 10 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__AUDIT_LO__40D2552DE38D4F0A | AUDIT_LOG_DATA_ID |  |  |  | 0 | 0
IDX1_AUDIT_LOG_DATA | COL_NAME |  |  |  | 0 | 0
IDX2_AUDIT_LOG_DATA | AUDIT_LOG_TRANSACTION_ID |  |  |  | 0 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
AUDIT_LOG_DATA_ID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
AUDIT_LOG_TRANSACTIONS | PK__AUDIT_LO__EC2FB09B1A76BC40 | FK_AUDIT_LOG_TRANSACTION_ID
Total: 1 table(s)

Collapse image Objects that depend on AUDIT_LOG_DATA

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
AUDIT_prc_Purge_AUDIT_LOG | Procedure | 1
tr_d_AUDIT_AWBuildVersion | Trigger | 1
tr_d_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_d_AUDIT_Department | Trigger | 1
HumanResources.tr_d_AUDIT_Employee | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger | 1
tr_d_AUDIT_ErrorLog | Trigger | 1
tr_i_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_i_AUDIT_Department | Trigger | 1
HumanResources.tr_i_AUDIT_Employee | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger | 1
tr_i_AUDIT_ErrorLog | Trigger | 1
tr_u_AUDIT_AWBuildVersion | Trigger | 1
tr_u_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_u_AUDIT_Department | Trigger | 1
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger | 1
AUDIT_UNDO | View | 1
AUDIT_VIEW | View | 1
Total 23 object(s)

Collapse image Objects that AUDIT_LOG_DATA depends on

Object name | Object type | Dep level
AUDIT_LOG_TRANSACTIONS | Table | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[AUDIT_LOG_DATA] (
        [AUDIT_LOG_DATA_ID]            [int] IDENTITY(1, 1) NOT NULL,
        [AUDIT_LOG_TRANSACTION_ID]     [int] NOT NULL,
        [PRIMARY_KEY_DATA]             [nvarchar](1500) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [COL_NAME]                     [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OLD_VALUE_LONG]               [ntext] COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [NEW_VALUE_LONG]               [ntext] COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [NEW_VALUE_BLOB]               [image] NULL,
        [NEW_VALUE]                    AS (isnull(CONVERT([nvarchar](4000),[NEW_VALUE_LONG]),CONVERT([varchar](8000),CONVERT([varbinary](8000),substring([NEW_VALUE_BLOB],(1),(8000)))))),
        [OLD_VALUE]                    AS (CONVERT([nvarchar](4000),[OLD_VALUE_LONG])),
        [PRIMARY_KEY]                  AS ([PRIMARY_KEY_DATA]),
        [DATA_TYPE]                    [char](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [KEY1]                         [nvarchar](500) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [KEY2]                         [nvarchar](500) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [KEY3]                         [nvarchar](500) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [KEY4]                         [nvarchar](500) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        CONSTRAINT [PK__AUDIT_LO__40D2552DE38D4F0A]
        PRIMARY KEY
        CLUSTERED
        ([AUDIT_LOG_DATA_ID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[AUDIT_LOG_DATA]
    ADD
    CONSTRAINT [DF__AUDIT_LOG__DATA___46535886]
    DEFAULT ('A') FOR [DATA_TYPE]
GO
ALTER TABLE [dbo].[AUDIT_LOG_DATA]
    WITH CHECK
    ADD CONSTRAINT [FK_AUDIT_LOG_TRANSACTION_ID]
    FOREIGN KEY ([AUDIT_LOG_TRANSACTION_ID]) REFERENCES [dbo].[AUDIT_LOG_TRANSACTIONS] ([AUDIT_LOG_TRANSACTION_ID])
ALTER TABLE [dbo].[AUDIT_LOG_DATA]
    CHECK CONSTRAINT [FK_AUDIT_LOG_TRANSACTION_ID]

GO
CREATE NONCLUSTERED INDEX [IDX1_AUDIT_LOG_DATA]
    ON [dbo].[AUDIT_LOG_DATA] ([COL_NAME])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IDX2_AUDIT_LOG_DATA]
    ON [dbo].[AUDIT_LOG_DATA] ([AUDIT_LOG_TRANSACTION_ID])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


AUDIT_LOG_DDL

Table: AdventureWorks2016CTP3.dbo.AUDIT_LOG_DDL

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 21.09.2016
ID | 88387384
Located on | PRIMARY
Data size KB | 312 KB
Index size KB | 32 KB
Rows | 714
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__AUDIT_LO__5E54864804DBC213]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | LogId |  |  | int | 4 |  |  |  |
 |  | DATABASE |  |  | nvarchar | 100 |  |  |  |
 |  | SCHEMA |  |  | nvarchar | 100 |  |  |  |
 |  | OBJECT_TYPE |  |  | nvarchar | 100 |  |  |  |
 |  | OBJECT_NAME |  |  | nvarchar | 100 |  |  |  |
 |  | ACTION |  |  | nvarchar | 100 |  |  |  |
 |  | OLD_VALUE |  |  | nvarchar | 100 |  |  |  |
 |  | NEW_VALUE |  |  | nvarchar | 100 |  |  |  |
 |  | MODIFIED_BY |  |  | nvarchar | 100 |  |  |  |
 |  | MODIFIED_DATE |  |  | datetime | 8 |  |  |  |
 |  | APP_NAME |  |  | nvarchar | 100 |  |  |  |
 |  | HOST_NAME |  |  | nvarchar | 100 |  |  |  |
 |  | DESCRIPTION |  |  | nvarchar | 100 |  |  |  |
Total: 13 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
DATABASE | nvarchar(100) | 22 | 22 | 22 | 0.11000000000000
SCHEMA | nvarchar(100) | 5 | 3 | 14 | 0.07000000000000
OBJECT_TYPE | nvarchar(100) | 8 | 4 | 9 | 0.04500000000000
OBJECT_NAME | nvarchar(100) | 22 | 3 | 53 | 0.26500000000000
ACTION | nvarchar(100) | 4 | 4 | 6 | 0.03000000000000
OLD_VALUE | nvarchar(100) | 13 | 0 | 53 | 0.26500000000000
NEW_VALUE | nvarchar(100) | 9 | 0 | 53 | 0.26500000000000
MODIFIED_BY | nvarchar(100) | 41 | 41 | 41 | 0.20500000000000
APP_NAME | nvarchar(100) | 37 | 28 | 38 | 0.19000000000000
HOST_NAME | nvarchar(100) | 7 | 7 | 7 | 0.03500000000000
DESCRIPTION | nvarchar(100) | 16 | 12 | 20 | 0.10000000000000
Total: 11 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__AUDIT_LO__5E54864804DBC213 | LogId |  |  |  | 344 | 0
IDX1_AUDIT_LOG_DDL | LogId |  |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
LogId | 1 | 1 |

Collapse image Objects that depend on AUDIT_LOG_DDL

Object name | Object type | Dep level
tr_ddl_AUDIT | DDL Trigger | 1
AUDIT_prc_DeleteArchitecture | Procedure | 1
AUDIT_prc_Purge_AUDIT_LOG | Procedure | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[AUDIT_LOG_DDL] (
        [LogId]             [int] IDENTITY(1, 1) NOT NULL,
        [DATABASE]          [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [SCHEMA]            [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [OBJECT_TYPE]       [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OBJECT_NAME]       [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ACTION]            [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OLD_VALUE]         [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [NEW_VALUE]         [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [MODIFIED_BY]       [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MODIFIED_DATE]     [datetime] NULL,
        [APP_NAME]          [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [HOST_NAME]         [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [DESCRIPTION]       [nvarchar](100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        CONSTRAINT [PK__AUDIT_LO__5E54864804DBC213]
        PRIMARY KEY
        CLUSTERED
        ([LogId])
    ON [PRIMARY]
) ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IDX1_AUDIT_LOG_DDL]
    ON [dbo].[AUDIT_LOG_DDL] ([LogId])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


AUDIT_LOG_TRANSACTIONS

Table: AdventureWorks2016CTP3.dbo.AUDIT_LOG_TRANSACTIONS

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 21.09.2016
ID | 1099866985
Located on | PRIMARY
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__AUDIT_LO__EC2FB09B1A76BC40]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | AUDIT_LOG_TRANSACTION_ID |  |  | int | 4 |  |  |  |  |
 |  | DATABASE |  |  | nvarchar | 128 |  | (db_name()) |  |  |
 |  | TABLE_NAME |  |  | nvarchar | 261 |  |  |  |  |
 |  | TABLE_SCHEMA |  |  | nvarchar | 261 |  |  |  |  |
 |  | AUDIT_ACTION_ID |  |  | tinyint | 1 |  |  |  |  |
 |  | HOST_NAME |  |  | varchar | 128 |  |  |  |  |
 |  | APP_NAME |  |  | varchar | 128 |  |  |  |  |
 |  | MODIFIED_BY |  |  | varchar | 128 |  |  |  |  |
 |  | MODIFIED_DATE |  |  | datetime | 8 |  |  |  |  |
 |  | AFFECTED_ROWS |  |  | int | 4 |  |  |  |  |
 |  | SYSOBJ_ID |  | True | int | 4 |  |  |  |  | (object_id([TABLE_NAME]))
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
DATABASE | nvarchar(128) | 0 | 0 | 0 | 0
TABLE_NAME | nvarchar(261) | 0 | 0 | 0 | 0
TABLE_SCHEMA | nvarchar(261) | 0 | 0 | 0 | 0
HOST_NAME | varchar(128) | 0 | 0 | 0 | 0
APP_NAME | varchar(128) | 0 | 0 | 0 | 0
MODIFIED_BY | varchar(128) | 0 | 0 | 0 | 0
Total: 6 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__AUDIT_LO__EC2FB09B1A76BC40 | AUDIT_LOG_TRANSACTION_ID |  |  |  | 0 | 0
IDX1_AUDIT_LOG_TRANSACTIONS | TABLE_NAME |  |  |  | 0 | 0
IDX2_AUDIT_LOG_TRANSACTIONS | MODIFIED_DATE |  |  |  | 0 | 0
IDX3_AUDIT_LOG_TRANSACTIONS | MODIFIED_BY |  |  |  | 0 | 0
IDX4_AUDIT_LOG_TRANSACTIONS | HOST_NAME |  |  |  | 0 | 0
Total: 5 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
AUDIT_LOG_TRANSACTION_ID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
AUDIT_LOG_DATA | FK_AUDIT_LOG_TRANSACTION_ID | PK__AUDIT_LO__EC2FB09B1A76BC40
Total: 1 table(s)

Collapse image Objects that depend on AUDIT_LOG_TRANSACTIONS

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
AUDIT_prc_Purge_AUDIT_LOG | Procedure | 1
AUDIT_LOG_DATA | Table | 1
tr_d_AUDIT_AWBuildVersion | Trigger | 1
tr_d_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_d_AUDIT_Department | Trigger | 1
HumanResources.tr_d_AUDIT_Employee | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger | 1
tr_d_AUDIT_ErrorLog | Trigger | 1
tr_i_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_i_AUDIT_Department | Trigger | 1
HumanResources.tr_i_AUDIT_Employee | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger | 1
tr_i_AUDIT_ErrorLog | Trigger | 1
tr_u_AUDIT_AWBuildVersion | Trigger | 1
tr_u_AUDIT_DatabaseLog | Trigger | 1
HumanResources.tr_u_AUDIT_Department | Trigger | 1
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger | 1
AUDIT_UNDO | View | 1
AUDIT_VIEW | View | 1
Total 24 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[AUDIT_LOG_TRANSACTIONS] (
        [AUDIT_LOG_TRANSACTION_ID]     [int] IDENTITY(1, 1) NOT NULL,
        [DATABASE]                     [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [TABLE_NAME]                   [nvarchar](261) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [TABLE_SCHEMA]                 [nvarchar](261) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [AUDIT_ACTION_ID]              [tinyint] NOT NULL,
        [HOST_NAME]                    [varchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [APP_NAME]                     [varchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MODIFIED_BY]                  [varchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MODIFIED_DATE]                [datetime] NOT NULL,
        [AFFECTED_ROWS]                [int] NOT NULL,
        [SYSOBJ_ID]                    AS (object_id([TABLE_NAME])),
        CONSTRAINT [PK__AUDIT_LO__EC2FB09B1A76BC40]
        PRIMARY KEY
        CLUSTERED
        ([AUDIT_LOG_TRANSACTION_ID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[AUDIT_LOG_TRANSACTIONS]
    ADD
    CONSTRAINT [DF__AUDIT_LOG__DATAB__4376EBDB]
    DEFAULT (db_name()) FOR [DATABASE]
GO
CREATE NONCLUSTERED INDEX [IDX1_AUDIT_LOG_TRANSACTIONS]
    ON [dbo].[AUDIT_LOG_TRANSACTIONS] ([TABLE_NAME], [AUDIT_ACTION_ID])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IDX2_AUDIT_LOG_TRANSACTIONS]
    ON [dbo].[AUDIT_LOG_TRANSACTIONS] ([MODIFIED_DATE])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IDX3_AUDIT_LOG_TRANSACTIONS]
    ON [dbo].[AUDIT_LOG_TRANSACTIONS] ([MODIFIED_BY])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IDX4_AUDIT_LOG_TRANSACTIONS]
    ON [dbo].[AUDIT_LOG_TRANSACTIONS] ([HOST_NAME])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


AWBuildVersion

Table: AdventureWorks2016CTP3.dbo.AWBuildVersion

Collapse image Description

Current version number of the AdventureWorks 2014 sample database.

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 789577851
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 1
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_AWBuildVersion_SystemInformationID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SystemInformationID | Primary key for AWBuildVersion records. |  | tinyint | 1 |  |  |  |
 |  | Database Version | Version number of the database in 9.yy.mm.dd.00 format. |  | nvarchar | 25 |  |  |  |
 |  | VersionDate | Date and time the record was last updated. |  | datetime | 8 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
 |  | Test column |  |  | xml | 2147483647 |  |  |  |
 |  | Test column2 |  |  | nchar | 10 |  |  |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Database Version | nvarchar(25) | 8 | 8 | 8 | 0.16000000000000
Test column2 | nchar(10) | 0 | 0 | 0 | 0
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_AWBuildVersion_SystemInformationID | SystemInformationID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
SystemInformationID | 1 | 1 |

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
tr_u_AUDIT_AWBuildVersion | dbo |  |  |  | For Update |  | AWBuildVersion
tr_d_AUDIT_AWBuildVersion | dbo |  |  |  |  | For Delete | AWBuildVersion
Total: 2 triggers(s)

Collapse image Objects that depend on AWBuildVersion

Object name | Object type | Dep level
tr_d_AUDIT_AWBuildVersion | Trigger | 1
tr_u_AUDIT_AWBuildVersion | Trigger | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Current version number of the AdventureWorks 2014 sample database.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[AWBuildVersion] (
        [SystemInformationID]     [tinyint] IDENTITY(1, 1) NOT NULL,
        [Database Version]        [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [VersionDate]             [datetime] NOT NULL,
        [ModifiedDate]            [datetime] NOT NULL,
        [Test column]             [xml] NULL,
        [Test column2]            [nchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        CONSTRAINT [PK_AWBuildVersion_SystemInformationID]
        PRIMARY KEY
        CLUSTERED
        ([SystemInformationID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'CONSTRAINT', N'PK_AWBuildVersion_SystemInformationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'INDEX', N'PK_AWBuildVersion_SystemInformationID'
GO
ALTER TABLE [dbo].[AWBuildVersion]
    ADD
    CONSTRAINT [DF_AWBuildVersion_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'CONSTRAINT', N'DF_AWBuildVersion_ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Version number of the database in 9.yy.mm.dd.00 format.', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'COLUMN', N'Database Version'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for AWBuildVersion records.', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'COLUMN', N'SystemInformationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', 'COLUMN', N'VersionDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Current version number of the AdventureWorks 2014 sample database. ', 'SCHEMA', N'dbo', 'TABLE', N'AWBuildVersion', NULL, NULL
GO

Collapse image See also

List of tables


DatabaseLog

Table: AdventureWorks2016CTP3.dbo.DatabaseLog

Collapse image Description

Audit table tracking all DDL changes made to the AdventureWorks database. Data is captured by the database trigger ddlDatabaseTriggerLog.

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 565577053
Located on | PRIMARY
Data size KB | 808 KB
Index size KB | 24 KB
Rows | 179
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_DatabaseLog_DatabaseLogID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | DatabaseLogID | Primary key for DatabaseLog records. |  | int | 4 |  |  |  |
 |  | PostTime | The date and time the DDL change occurred. |  | datetime | 8 |  |  |  |
 |  | DatabaseUser | The user who implemented the DDL change. |  | sysname | 128 |  |  |  |
 |  | Event | The type of DDL statement that was executed. |  | sysname | 128 |  |  |  |
 |  | Schema | The schema to which the changed object belongs. |  | sysname | 128 |  |  |  |
 |  | Object | The object that was changed by the DDL statment. |  | sysname | 128 |  |  |  |
 |  | TSQL | The exact Transact-SQL statement that was executed. |  | nvarchar | 1073741823 |  |  |  |
 |  | XmlEvent | The raw XML data generated by database trigger. |  | xml | 2147483647 |  |  |  |
Total: 8 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
DatabaseUser | nvarchar(128) | 3 | 3 | 3 | 0.01171875000000
Event | nvarchar(128) | 14 | 11 | 28 | 0.10937500000000
Schema | nvarchar(128) | 5 | 3 | 14 | 0.05468750000000
Object | nvarchar(128) | 14 | 4 | 38 | 0.14843750000000
TSQL | nvarchar(max) | 592 | 20 | 6759 | -6759.00000000000000
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_DatabaseLog_DatabaseLogID | DatabaseLogID | Primary key (nonclustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
DatabaseLogID | 1 | 1 |

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
tr_i_AUDIT_DatabaseLog | dbo |  |  | For Insert |  |  | DatabaseLog
tr_u_AUDIT_DatabaseLog | dbo |  |  |  | For Update |  | DatabaseLog
tr_d_AUDIT_DatabaseLog | dbo |  |  |  |  | For Delete | DatabaseLog
Total: 3 triggers(s)

Collapse image Objects that depend on DatabaseLog

Object name | Object type | Dep level
tr_d_AUDIT_DatabaseLog | Trigger | 1
tr_i_AUDIT_DatabaseLog | Trigger | 1
tr_u_AUDIT_DatabaseLog | Trigger | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Audit table tracking all DDL changes made to the AdventureWorks database. Data is captured by the database trigger ddlDatabaseTriggerLog.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[DatabaseLog] (
        [DatabaseLogID]     [int] IDENTITY(1, 1) NOT NULL,
        [PostTime]          [datetime] NOT NULL,
        [DatabaseUser]      [sysname] COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Event]             [sysname] COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Schema]            [sysname] COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Object]            [sysname] COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [TSQL]              [nvarchar](max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [XmlEvent]          [xml] NOT NULL,
        CONSTRAINT [PK_DatabaseLog_DatabaseLogID]
        PRIMARY KEY
        NONCLUSTERED
        ([DatabaseLogID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (nonclustered) constraint', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'CONSTRAINT', N'PK_DatabaseLog_DatabaseLogID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index created by a primary key constraint.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'INDEX', N'PK_DatabaseLog_DatabaseLogID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for DatabaseLog records.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'DatabaseLogID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The user who implemented the DDL change.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'DatabaseUser'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The type of DDL statement that was executed.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'Event'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The object that was changed by the DDL statment.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'Object'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The date and time the DDL change occurred.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'PostTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The schema to which the changed object belongs.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'Schema'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The exact Transact-SQL statement that was executed.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'TSQL'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The raw XML data generated by database trigger.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', 'COLUMN', N'XmlEvent'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Audit table tracking all DDL changes made to the AdventureWorks database. Data is captured by the database trigger ddlDatabaseTriggerLog.', 'SCHEMA', N'dbo', 'TABLE', N'DatabaseLog', NULL, NULL
GO

Collapse image See also

List of tables


ErrorLog

Table: AdventureWorks2016CTP3.dbo.ErrorLog

Collapse image Description

Audit table tracking errors in the the AdventureWorks database that are caught by the CATCH block of a TRY...CATCH construct. Data is inserted by stored procedure dbo.uspLogError when it is executed from inside the CATCH block of a TRY...CATCH construct.

Collapse image Table properties

Name | Value
Schema | dbo
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 597577167
Located on | PRIMARY
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ErrorLog_ErrorLogID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ErrorLogID | Primary key for ErrorLog records. |  | int | 4 |  |  |  |
 |  | ErrorTime | The date and time at which the error occurred. |  | datetime | 8 |  | (getdate()) |  |
 |  | UserName | The user who executed the batch in which the error occurred. |  | sysname | 128 |  |  |  |
 |  | ErrorNumber | The error number of the error that occurred. |  | int | 4 |  |  |  |
 |  | ErrorSeverity | The severity of the error that occurred. |  | int | 4 |  |  |  |
 |  | ErrorState | The state number of the error that occurred. |  | int | 4 |  |  |  |
 |  | ErrorProcedure | The name of the stored procedure or trigger where the error occurred. |  | nvarchar | 126 |  |  |  |
 |  | ErrorLine | The line number at which the error occurred. |  | int | 4 |  |  |  |
 |  | ErrorMessage | The message text of the error that occurred. |  | nvarchar | 4000 |  |  |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
UserName | nvarchar(128) | 0 | 0 | 0 | 0
ErrorProcedure | nvarchar(126) | 0 | 0 | 0 | 0
ErrorMessage | nvarchar(4000) | 0 | 0 | 0 | 0
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ErrorLog_ErrorLogID | ErrorLogID | Primary key (clustered) constraint |  |  | 0 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ErrorLogID | 1 | 1 |

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
tr_i_AUDIT_ErrorLog | dbo |  |  | For Insert |  |  | ErrorLog
tr_d_AUDIT_ErrorLog | dbo |  |  |  |  | For Delete | ErrorLog
Total: 2 triggers(s)

Collapse image Objects that depend on ErrorLog

Object name | Object type | Dep level
uspLogError | Procedure | 1
tr_d_AUDIT_ErrorLog | Trigger | 1
tr_i_AUDIT_ErrorLog | Trigger | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Audit table tracking errors in the the AdventureWorks database that are caught by the CATCH block of a TRY...CATCH construct. Data is inserted by stored procedure dbo.uspLogError when it is executed from inside the CATCH block of a TRY...CATCH construct.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [dbo].[ErrorLog] (
        [ErrorLogID]         [int] IDENTITY(1, 1) NOT NULL,
        [ErrorTime]          [datetime] NOT NULL,
        [UserName]           [sysname] COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ErrorNumber]        [int] NOT NULL,
        [ErrorSeverity]      [int] NULL,
        [ErrorState]         [int] NULL,
        [ErrorProcedure]     [nvarchar](126) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ErrorLine]          [int] NULL,
        [ErrorMessage]       [nvarchar](4000) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        CONSTRAINT [PK_ErrorLog_ErrorLogID]
        PRIMARY KEY
        CLUSTERED
        ([ErrorLogID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'CONSTRAINT', N'PK_ErrorLog_ErrorLogID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'INDEX', N'PK_ErrorLog_ErrorLogID'
GO
ALTER TABLE [dbo].[ErrorLog]
    ADD
    CONSTRAINT [DF_ErrorLog_ErrorTime]
    DEFAULT (getdate()) FOR [ErrorTime]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'CONSTRAINT', N'DF_ErrorLog_ErrorTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The line number at which the error occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorLine'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ErrorLog records.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorLogID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The message text of the error that occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorMessage'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The error number of the error that occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The name of the stored procedure or trigger where the error occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorProcedure'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The severity of the error that occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorSeverity'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The state number of the error that occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorState'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The date and time at which the error occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'ErrorTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The user who executed the batch in which the error occurred.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', 'COLUMN', N'UserName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Audit table tracking errors in the the AdventureWorks database that are caught by the CATCH block of a TRY...CATCH construct. Data is inserted by stored procedure dbo.uspLogError when it is executed from inside the CATCH block of a TRY...CATCH construct.', 'SCHEMA', N'dbo', 'TABLE', N'ErrorLog', NULL, NULL
GO

Collapse image See also

List of tables


DemoSalesOrderDetailSeed

Table: AdventureWorks2016CTP3.Demo.DemoSalesOrderDetailSeed

Collapse image Table properties

Name | Value
Schema | Demo
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1556200594
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__DemoSale__499359DA37DC4424]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
 |  | OrderQty |  |  | smallint | 2 |  |  |  |
 |  | ProductID |  |  | int | 4 |  |  |  |
 |  | SpecialOfferID |  |  | int | 4 |  |  |  |
 |  | OrderID |  |  | int | 4 |  |  |  |
Primary key | Identity | LocalID |  |  | int | 4 |  |  |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__DemoSale__499359DA37DC4424 | OrderQty |  |  |  | 0 | 0
IX_OrderID | OrderID |  |  |  | 0 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
LocalID | 1 | 1 |

Collapse image Objects that depend on Demo.DemoSalesOrderDetailSeed

Object name | Object type | Dep level
Demo.usp_DemoInitSeed | Procedure | 1
Total 1 object(s)

Collapse image Objects that Demo.DemoSalesOrderDetailSeed depends on

Object name | Object type | Dep level
Demo | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Demo].[DemoSalesOrderDetailSeed] (
        [OrderQty]           [smallint] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [SpecialOfferID]     [int] NOT NULL,
        [OrderID]            [int] NOT NULL,
        [LocalID]            [int] IDENTITY(1, 1) NOT NULL,
        CONSTRAINT [PK__DemoSale__499359DA37DC4424]
        PRIMARY KEY
        NONCLUSTERED
        ([LocalID]),
INDEX [IX_OrderID] NONCLUSTERED HASH  ([OrderID])
    WITH ( BUCKET_COUNT=1048576)
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO

Collapse image See also

List of tables


DemoSalesOrderHeaderSeed

Table: AdventureWorks2016CTP3.Demo.DemoSalesOrderHeaderSeed

Collapse image Table properties

Name | Value
Schema | Demo
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1588200708
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__DemoSale__499359DA31897820]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
 |  | DueDate |  |  | datetime2 | 8 |  |  |  |
 |  | CustomerID |  |  | int | 4 |  |  |  |
 |  | SalesPersonID |  |  | int | 4 |  |  |  |
 |  | BillToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipMethodID |  |  | int | 4 |  |  |  |
Primary key | Identity | LocalID |  |  | int | 4 |  |  |  |
Total: 7 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__DemoSale__499359DA31897820 | DueDate |  |  |  | 0 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
LocalID | 1 | 1 |

Collapse image Objects that depend on Demo.DemoSalesOrderHeaderSeed

Object name | Object type | Dep level
Demo.usp_DemoInitSeed | Procedure | 1
Total 1 object(s)

Collapse image Objects that Demo.DemoSalesOrderHeaderSeed depends on

Object name | Object type | Dep level
Demo | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Demo].[DemoSalesOrderHeaderSeed] (
        [DueDate]             [datetime2](7) NOT NULL,
        [CustomerID]          [int] NOT NULL,
        [SalesPersonID]       [int] NOT NULL,
        [BillToAddressID]     [int] NOT NULL,
        [ShipToAddressID]     [int] NOT NULL,
        [ShipMethodID]        [int] NOT NULL,
        [LocalID]             [int] IDENTITY(1, 1) NOT NULL,
        CONSTRAINT [PK__DemoSale__499359DA31897820]
        PRIMARY KEY
        NONCLUSTERED
        ([LocalID])
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO

Collapse image See also

List of tables


Department

Table: AdventureWorks2016CTP3.HumanResources.Department

Collapse image Description

Lookup table containing the departments within the Adventure Works Cycles company.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1365579903
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 16
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Department_DepartmentID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | DepartmentID | Primary key for Department records. |  | smallint | 2 |  |  |  |
 |  | Name | Name of the department. |  | Name | 50 |  |  |  |
 |  | GroupName | Name of the group to which the department belongs. |  | Name | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 14 | 5 | 26 | 0.26000000000000
GroupName | nvarchar(50) | 24 | 13 | 36 | 0.36000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Department_DepartmentID | DepartmentID | Primary key (clustered) constraint |  |  | 32 | 0
AK_Department_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
DepartmentID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
HumanResources.EmployeeDepartmentHistory | FK_EmployeeDepartmentHistory_Department_DepartmentID | PK_Department_DepartmentID
Total: 1 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
HumanResources.tr_i_AUDIT_Department | HumanResources |  |  | For Insert |  |  | HumanResources.Department
HumanResources.tr_u_AUDIT_Department | HumanResources |  |  |  | For Update |  | HumanResources.Department
HumanResources.tr_d_AUDIT_Department | HumanResources |  |  |  |  | For Delete | HumanResources.Department
Total: 3 triggers(s)

Collapse image Objects that depend on HumanResources.Department

Object name | Object type | Dep level
HumanResources.EmployeeDepartmentHistory | Table | 1
HumanResources.tr_d_AUDIT_Department | Trigger | 1
HumanResources.tr_i_AUDIT_Department | Trigger | 1
HumanResources.tr_u_AUDIT_Department | Trigger | 1
HumanResources.vEmployeeDepartment | View | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
Total 6 object(s)

Collapse image Objects that HumanResources.Department depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table containing the departments within the Adventure Works Cycles company.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [HumanResources].[Department] (
        [DepartmentID]     [smallint] IDENTITY(1, 1) NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [GroupName]        [dbo].[Name] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_Department_DepartmentID]
        PRIMARY KEY
        CLUSTERED
        ([DepartmentID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'CONSTRAINT', N'PK_Department_DepartmentID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'INDEX', N'PK_Department_DepartmentID'
GO
ALTER TABLE [HumanResources].[Department]
    ADD
    CONSTRAINT [DF_Department_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'CONSTRAINT', N'DF_Department_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Department_Name]
    ON [HumanResources].[Department] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'INDEX', N'AK_Department_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Department records.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'COLUMN', N'DepartmentID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the group to which the department belongs.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'COLUMN', N'GroupName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the department.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table containing the departments within the Adventure Works Cycles company.', 'SCHEMA', N'HumanResources', 'TABLE', N'Department', NULL, NULL
GO

Collapse image See also

List of tables


Employee

Table: AdventureWorks2016CTP3.HumanResources.Employee

Collapse image Description

Employee information such as salary, department, and title.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1557580587
Located on | PRIMARY
Data size KB | 56 KB
Index size KB | 136 KB
Rows | 290
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Employee_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key for Employee records. Foreign key to BusinessEntity.BusinessEntityID. |  | int | 4 |  |  |  |  |
 |  | NationalIDNumber | Unique national identification number such as a social security number. |  | nvarchar | 15 |  |  |  |  |
 |  | LoginID | Network login. |  | nvarchar | 256 |  |  |  |  |
 |  | OrganizationNode | Where the employee is located in corporate hierarchy. |  | hierarchyid | 892 |  |  |  |  |
 |  | OrganizationLevel | The depth of the employee in the corporate hierarchy. | True | smallint | 2 |  |  |  |  | ([OrganizationNode].[GetLevel]())
 |  | JobTitle | Work title such as Buyer or Sales Representative. |  | nvarchar | 50 |  |  |  |  |
 |  | BirthDate | Date of birth. |  | date | 3 |  |  |  |  |
 |  | MaritalStatus | M = Married, S = Single |  | nchar | 1 |  |  |  |  |
 |  | Gender | M = Male, F = Female |  | nchar | 1 |  |  |  |  |
 |  | HireDate | Employee hired on this date. |  | date | 3 |  |  |  |  |
 |  | SalariedFlag | Job classification. 0 = Hourly, not exempt from collective bargaining. 1 = Salaried, exempt from collective bargaining. |  | Flag | 1 |  | ((1)) |  |  |
 |  | VacationHours | Number of available vacation hours. |  | smallint | 2 |  | ((0)) |  |  |
 |  | SickLeaveHours | Number of available sick leave hours. |  | smallint | 2 |  | ((0)) |  |  |
 |  | CurrentFlag | 0 = Inactive, 1 = Active |  | Flag | 1 |  | ((1)) |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
 |  | Test column 3 |  |  | Flag | 1 |  |  |  |  |
 |  | Test column |  |  | nchar | 10 |  |  |  |  |
Total: 18 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
NationalIDNumber | nvarchar(15) | 8 | 5 | 9 | 0.30000000000000
LoginID | nvarchar(256) | 22 | 19 | 28 | 0.05468750000000
JobTitle | nvarchar(50) | 24 | 5 | 40 | 0.40000000000000
MaritalStatus | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Gender | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Test column | nchar(10) | 0 | 0 | 0 | 0
Total: 6 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Employee_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 192 | 0
AK_Employee_LoginID | LoginID | Unique nonclustered index. |  |  | 40 | 0
AK_Employee_NationalIDNumber | NationalIDNumber | Unique nonclustered index. |  |  | 32 | 0
AK_Employee_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
IX_Employee_OrganizationLevel_OrganizationNode | OrganizationLevel | Unique nonclustered index. |  |  | 16 | 0
IX_Employee_OrganizationNode | OrganizationNode | Unique nonclustered index. |  |  | 16 | 0
Total: 6 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_Employee_BirthDate | ([BirthDate]>='1930-01-01' AND [BirthDate]<=dateadd(year,(-18),getdate()))
CK_Employee_Gender | (upper([Gender])='F' OR upper([Gender])='M')
CK_Employee_HireDate | ([HireDate]>='1996-07-01' AND [HireDate]<=dateadd(day,(1),getdate()))
CK_Employee_MaritalStatus | (upper([MaritalStatus])='S' OR upper([MaritalStatus])='M')
CK_Employee_SickLeaveHours | ([SickLeaveHours]>=(0) AND [SickLeaveHours]<=(120))
CK_Employee_VacationHours | ([VacationHours]>=(-40) AND [VacationHours]<=(240))

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
HumanResources.EmployeeDepartmentHistory | FK_EmployeeDepartmentHistory_Employee_BusinessEntityID | PK_Employee_BusinessEntityID
HumanResources.EmployeePayHistory | FK_EmployeePayHistory_Employee_BusinessEntityID | PK_Employee_BusinessEntityID
HumanResources.JobCandidate | FK_JobCandidate_Employee_BusinessEntityID | PK_Employee_BusinessEntityID
Production.Document | FK_Document_Employee_Owner | PK_Employee_BusinessEntityID
Purchasing.PurchaseOrderHeader | FK_PurchaseOrderHeader_Employee_EmployeeID | PK_Employee_BusinessEntityID
Sales.SalesPerson | FK_SalesPerson_Employee_BusinessEntityID | PK_Employee_BusinessEntityID
Total: 6 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Person | PK_Person_BusinessEntityID | FK_Employee_Person_BusinessEntityID
Total: 1 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
HumanResources.dEmployee | HumanResources |  |  |  |  | For Delete | HumanResources.Employee
HumanResources.tr_i_AUDIT_Employee | HumanResources |  |  | For Insert |  |  | HumanResources.Employee
HumanResources.tr_d_AUDIT_Employee | HumanResources |  |  |  |  | For Delete | HumanResources.Employee
Total: 3 triggers(s)

Collapse image Objects that depend on HumanResources.Employee

Object name | Object type | Dep level
uspGetEmployeeManagers | Procedure | 1
uspGetManagerEmployees | Procedure | 1
HumanResources.uspUpdateEmployeeHireInfo | Procedure | 1
HumanResources.uspUpdateEmployeeLogin | Procedure | 1
HumanResources.uspUpdateEmployeePersonalInfo | Procedure | 1
Production.Document | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
HumanResources.EmployeePayHistory | Table | 1
HumanResources.JobCandidate | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Sales.SalesPerson | Table | 1
HumanResources.dEmployee | Trigger | 1
HumanResources.tr_d_AUDIT_Employee | Trigger | 1
HumanResources.tr_i_AUDIT_Employee | Trigger | 1
Security.customerAccessPredicate | Function | 1
ufnGetContactInformation | Function | 1
HumanResources.vEmployee | View | 1
HumanResources.vEmployeeDepartment | View | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
Sales.vSalesPerson | View | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Total 21 object(s)

Collapse image Objects that HumanResources.Employee depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Person.Person | Table | 1
Flag | Datatype | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Employee information such as salary, department, and title.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [HumanResources].[Employee] (
        [BusinessEntityID]      [int] NOT NULL,
        [NationalIDNumber]      [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [LoginID]               [nvarchar](256) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OrganizationNode]      [hierarchyid] NULL,
        [OrganizationLevel]     AS ([OrganizationNode].[GetLevel]()),
        [JobTitle]              [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [BirthDate]             [date] NOT NULL,
        [MaritalStatus]         [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Gender]                [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [HireDate]              [date] NOT NULL,
        [SalariedFlag]          [dbo].[Flag] NOT NULL,
        [VacationHours]         [smallint] NOT NULL,
        [SickLeaveHours]        [smallint] NOT NULL,
        [CurrentFlag]           [dbo].[Flag] NOT NULL,
        [rowguid]               [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]          [datetime] NOT NULL,
        [Test column 3]         [dbo].[Flag] NULL,
        [Test column]           [nchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        CONSTRAINT [PK_Employee_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'PK_Employee_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'PK_Employee_BusinessEntityID'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_BirthDate]
    CHECK
    ([BirthDate]>='1930-01-01' AND [BirthDate]<=dateadd(year,(-18),getdate()))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [BirthDate] >= ''1930-01-01'' AND [BirthDate] <= dateadd(year,(-18),GETDATE())', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_BirthDate'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_BirthDate]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_Gender]
    CHECK
    (upper([Gender])='F' OR upper([Gender])='M')
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Gender]=''f'' OR [Gender]=''m'' OR [Gender]=''F'' OR [Gender]=''M''', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_Gender'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_Gender]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_HireDate]
    CHECK
    ([HireDate]>='1996-07-01' AND [HireDate]<=dateadd(day,(1),getdate()))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [HireDate] >= ''1996-07-01'' AND [HireDate] <= dateadd(day,(1),GETDATE())', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_HireDate'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_HireDate]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_MaritalStatus]
    CHECK
    (upper([MaritalStatus])='S' OR upper([MaritalStatus])='M')
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [MaritalStatus]=''s'' OR [MaritalStatus]=''m'' OR [MaritalStatus]=''S'' OR [MaritalStatus]=''M''', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_MaritalStatus'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_MaritalStatus]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_SickLeaveHours]
    CHECK
    ([SickLeaveHours]>=(0) AND [SickLeaveHours]<=(120))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SickLeaveHours] >= (0) AND [SickLeaveHours] <= (120)', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_SickLeaveHours'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_SickLeaveHours]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [CK_Employee_VacationHours]
    CHECK
    ([VacationHours]>=(-40) AND [VacationHours]<=(240))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [VacationHours] >= (-40) AND [VacationHours] <= (240)', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'CK_Employee_VacationHours'
GO
ALTER TABLE [HumanResources].[Employee]
CHECK CONSTRAINT [CK_Employee_VacationHours]
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_CurrentFlag]
    DEFAULT ((1)) FOR [CurrentFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_CurrentFlag'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_ModifiedDate'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_rowguid'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_SalariedFlag]
    DEFAULT ((1)) FOR [SalariedFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1 (TRUE)', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_SalariedFlag'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_SickLeaveHours]
    DEFAULT ((0)) FOR [SickLeaveHours]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_SickLeaveHours'
GO
ALTER TABLE [HumanResources].[Employee]
    ADD
    CONSTRAINT [DF_Employee_VacationHours]
    DEFAULT ((0)) FOR [VacationHours]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'DF_Employee_VacationHours'
GO
ALTER TABLE [HumanResources].[Employee]
    WITH CHECK
    ADD CONSTRAINT [FK_Employee_Person_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [HumanResources].[Employee]
    CHECK CONSTRAINT [FK_Employee_Person_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'CONSTRAINT', N'FK_Employee_Person_BusinessEntityID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Employee_LoginID]
    ON [HumanResources].[Employee] ([LoginID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'AK_Employee_LoginID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Employee_NationalIDNumber]
    ON [HumanResources].[Employee] ([NationalIDNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'AK_Employee_NationalIDNumber'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Employee_rowguid]
    ON [HumanResources].[Employee] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'AK_Employee_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_Employee_OrganizationLevel_OrganizationNode]
    ON [HumanResources].[Employee] ([OrganizationLevel], [OrganizationNode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'IX_Employee_OrganizationLevel_OrganizationNode'
GO
CREATE NONCLUSTERED INDEX [IX_Employee_OrganizationNode]
    ON [HumanResources].[Employee] ([OrganizationNode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'INDEX', N'IX_Employee_OrganizationNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date of birth.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'BirthDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Employee records.  Foreign key to BusinessEntity.BusinessEntityID.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Inactive, 1 = Active', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'CurrentFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'M = Male, F = Female', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'Gender'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee hired on this date.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'HireDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work title such as Buyer or Sales Representative.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'JobTitle'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Network login.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'LoginID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'M = Married, S = Single', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'MaritalStatus'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique national identification number such as a social security number.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'NationalIDNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The depth of the employee in the corporate hierarchy.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'OrganizationLevel'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Where the employee is located in corporate hierarchy.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'OrganizationNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Job classification. 0 = Hourly, not exempt from collective bargaining. 1 = Salaried, exempt from collective bargaining.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'SalariedFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Number of available sick leave hours.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'SickLeaveHours'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Number of available vacation hours.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'COLUMN', N'VacationHours'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee information such as salary, department, and title.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', NULL, NULL
GO

Collapse image See also

List of tables


Employee_Temporal

Table: AdventureWorks2016CTP3.HumanResources.Employee_Temporal

CollapseAll image

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1870629707
Located on | PRIMARY
Data size KB | 56 KB
Index size KB | 16 KB
Rows | 290
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Employee_History_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | BusinessEntityID |  |  | int | 4 |  |  |  |  |
 | NationalIDNumber | dd |  | nvarchar | 15 |  |  |  |  |
 | LoginID |  |  | nvarchar | 256 |  |  |  |  |
 | OrganizationNode |  |  | hierarchyid | 892 |  |  |  |  |
 | OrganizationLevel |  | True | smallint | 2 |  |  |  |  | ([OrganizationNode].[GetLevel]())
 | JobTitle |  |  | nvarchar | 50 |  |  |  |  |
 | BirthDate |  |  | date | 3 |  |  |  |  |
 | MaritalStatus |  |  | nchar | 1 |  |  |  |  |
 | Gender |  |  | nchar | 1 |  |  |  |  |
 | HireDate | ggg |  | date | 3 |  |  |  |  |
 | VacationHours |  |  | smallint | 2 |  |  |  |  |
 | SickLeaveHours |  |  | smallint | 2 |  |  |  |  |
 | ValidFrom |  |  | datetime2 | 8 |  |  |  |  |
 | ValidTo |  |  | datetime2 | 8 |  |  |  |  |
Total: 14 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
NationalIDNumber | nvarchar(15) | 8 | 5 | 9 | 0.30000000000000
LoginID | nvarchar(256) | 22 | 19 | 28 | 0.05468750000000
JobTitle | nvarchar(50) | 24 | 5 | 40 | 0.40000000000000
MaritalStatus | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Gender | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Employee_History_BusinessEntityID | BusinessEntityID |  |  |  | 72 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
HumanResources.tr_u_AUDIT_Employee_Temporal | HumanResources |  |  |  | For Update |  | HumanResources.Employee_Temporal
Total: 1 triggers(s)

Collapse image Objects that depend on HumanResources.Employee_Temporal

Object name | Object type | Dep level
Person.sp_DeletePerson_Temporal | Procedure | 1
HumanResources.sp_UpdateEmployee_Temporal | Procedure | 1
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger | 1
HumanResources.vEmployeePersonTemporalInfo | View | 1
Total 4 object(s)

Collapse image Objects that HumanResources.Employee_Temporal depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [HumanResources].[Employee_Temporal] (
        [BusinessEntityID]      [int] NOT NULL,
        [NationalIDNumber]      [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [LoginID]               [nvarchar](256) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OrganizationNode]      [hierarchyid] NULL,
        [OrganizationLevel]     AS ([OrganizationNode].[GetLevel]()),
        [JobTitle]              [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [BirthDate]             [date] NOT NULL,
        [MaritalStatus]         [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Gender]                [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [HireDate]              [date] NOT NULL,
        [VacationHours]         [smallint] NOT NULL,
        [SickLeaveHours]        [smallint] NOT NULL,
        [ValidFrom]             [datetime2](7) NOT NULL,
        [ValidTo]               [datetime2](7) NOT NULL,
        CONSTRAINT [PK_Employee_History_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'ggg', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee_Temporal', 'COLUMN', N'HireDate'
GO
EXEC sp_addextendedproperty N'aaass', N'test', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee_Temporal', 'COLUMN', N'NationalIDNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'dd', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee_Temporal', 'COLUMN', N'NationalIDNumber'
GO

Collapse image See also

List of tables


Employee_Temporal_History

Table: AdventureWorks2016CTP3.HumanResources.Employee_Temporal_History

CollapseAll image

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1902629821
Located on | PRIMARY
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key |
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
BusinessEntityID |  |  | int | 4 |  |  |  |
NationalIDNumber | test66 |  | nvarchar | 15 |  |  |  |
LoginID |  |  | nvarchar | 256 |  |  |  |
OrganizationNode |  |  | hierarchyid | 892 |  |  |  |
OrganizationLevel |  |  | smallint | 2 |  |  |  |
JobTitle |  |  | nvarchar | 50 |  |  |  |
BirthDate |  |  | date | 3 |  |  |  |
MaritalStatus |  |  | nchar | 1 |  |  |  |
Gender |  |  | nchar | 1 |  |  |  |
HireDate |  |  | date | 3 |  |  |  |
VacationHours |  |  | smallint | 2 |  |  |  |
SickLeaveHours |  |  | smallint | 2 |  |  |  |
ValidFrom |  |  | datetime2 | 8 |  |  |  |
ValidTo |  |  | datetime2 | 8 |  |  |  |
Total: 14 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
NationalIDNumber | nvarchar(15) | 0 | 0 | 0 | 0
LoginID | nvarchar(256) | 0 | 0 | 0 | 0
JobTitle | nvarchar(50) | 0 | 0 | 0 | 0
MaritalStatus | nchar(1) | 0 | 0 | 0 | 0
Gender | nchar(1) | 0 | 0 | 0 | 0
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ix_Employee_Temporal_History | BusinessEntityID |  |  |  | 0 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Objects that HumanResources.Employee_Temporal_History depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [HumanResources].[Employee_Temporal_History] (
        [BusinessEntityID]      [int] NOT NULL,
        [NationalIDNumber]      [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [LoginID]               [nvarchar](256) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [OrganizationNode]      [hierarchyid] NULL,
        [OrganizationLevel]     [smallint] NULL,
        [JobTitle]              [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [BirthDate]             [date] NOT NULL,
        [MaritalStatus]         [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Gender]                [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [HireDate]              [date] NOT NULL,
        [VacationHours]         [smallint] NOT NULL,
        [SickLeaveHours]        [smallint] NOT NULL,
        [ValidFrom]             [datetime2](7) NOT NULL,
        [ValidTo]               [datetime2](7) NOT NULL
) ON [PRIMARY]
GO
CREATE CLUSTERED INDEX [ix_Employee_Temporal_History]
    ON [HumanResources].[Employee_Temporal_History] ([BusinessEntityID], [ValidFrom], [ValidTo])
    WITH (     DATA_COMPRESSION = PAGE)
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'test66', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee_Temporal_History', 'COLUMN', N'NationalIDNumber'
GO

Collapse image See also

List of tables


EmployeeDepartmentHistory

Table: AdventureWorks2016CTP3.HumanResources.EmployeeDepartmentHistory

CollapseAll image

Collapse image Description

Employee department transfers.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1765581328
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 48 KB
Rows | 296
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_EmployeeDepartmentHistory_BusinessEntityID_StartDate_DepartmentID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Employee identification number. Foreign key to Employee.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | DepartmentID | Department in which the employee worked including currently. Foreign key to Department.DepartmentID. |  | smallint | 2 |  |  |  |
Primary key | Foreign key | ShiftID | Identifies which 8-hour shift the employee works. Foreign key to Shift.Shift.ID. |  | tinyint | 1 |  |  |  |
Primary key |  | StartDate | Date the employee started work in the department. |  | date | 3 |  |  |  |
 |  | EndDate | Date the employee left the department. NULL = Current department. |  | date | 3 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_EmployeeDepartmentHistory_BusinessEntityID_StartDate_DepartmentID | BusinessEntityID | Primary key (clustered) constraint |  |  | 64 | 0
IX_EmployeeDepartmentHistory_DepartmentID | DepartmentID | Nonclustered index. |  |  | 16 | 0
IX_EmployeeDepartmentHistory_ShiftID | ShiftID | Nonclustered index. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_EmployeeDepartmentHistory_EndDate | ([EndDate]>=[StartDate] OR [EndDate] IS NULL)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Department | PK_Department_DepartmentID | FK_EmployeeDepartmentHistory_Department_DepartmentID
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_EmployeeDepartmentHistory_Employee_BusinessEntityID
HumanResources.Shift | PK_Shift_ShiftID | FK_EmployeeDepartmentHistory_Shift_ShiftID
Total: 3 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeeDepartmentHistory
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeeDepartmentHistory
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeeDepartmentHistory
Total: 3 triggers(s)

Collapse image Objects that depend on HumanResources.EmployeeDepartmentHistory

Object name | Object type | Dep level
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger | 1
HumanResources.vEmployeeDepartment | View | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
Total 5 object(s)

Collapse image Objects that HumanResources.EmployeeDepartmentHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Department | Table | 1
HumanResources.Employee | Table | 1
HumanResources.Shift | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Employee department transfers.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [HumanResources].[EmployeeDepartmentHistory] (
        [BusinessEntityID]     [int] NOT NULL,
        [DepartmentID]         [smallint] NOT NULL,
        [ShiftID]              [tinyint] NOT NULL,
        [StartDate]            [date] NOT NULL,
        [EndDate]              [date] NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_EmployeeDepartmentHistory_BusinessEntityID_StartDate_DepartmentID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [StartDate], [DepartmentID], [ShiftID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'PK_EmployeeDepartmentHistory_BusinessEntityID_StartDate_DepartmentID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'INDEX', N'PK_EmployeeDepartmentHistory_BusinessEntityID_StartDate_DepartmentID'
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    ADD
    CONSTRAINT [CK_EmployeeDepartmentHistory_EndDate]
    CHECK
    ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate] OR [EndDate] IS NUL', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'CK_EmployeeDepartmentHistory_EndDate'
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
CHECK CONSTRAINT [CK_EmployeeDepartmentHistory_EndDate]
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    ADD
    CONSTRAINT [DF_EmployeeDepartmentHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'DF_EmployeeDepartmentHistory_ModifiedDate'
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_EmployeeDepartmentHistory_Department_DepartmentID]
    FOREIGN KEY ([DepartmentID]) REFERENCES [HumanResources].[Department] ([DepartmentID])
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    CHECK CONSTRAINT [FK_EmployeeDepartmentHistory_Department_DepartmentID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Department.DepartmentID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'FK_EmployeeDepartmentHistory_Department_DepartmentID'
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_EmployeeDepartmentHistory_Employee_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    CHECK CONSTRAINT [FK_EmployeeDepartmentHistory_Employee_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.EmployeeID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'FK_EmployeeDepartmentHistory_Employee_BusinessEntityID'
GO
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_EmployeeDepartmentHistory_Shift_ShiftID]
    FOREIGN KEY ([ShiftID]) REFERENCES [HumanResources].[Shift] ([ShiftID])
ALTER TABLE [HumanResources].[EmployeeDepartmentHistory]
    CHECK CONSTRAINT [FK_EmployeeDepartmentHistory_Shift_ShiftID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Shift.ShiftID', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'CONSTRAINT', N'FK_EmployeeDepartmentHistory_Shift_ShiftID'
GO
CREATE NONCLUSTERED INDEX [IX_EmployeeDepartmentHistory_DepartmentID]
    ON [HumanResources].[EmployeeDepartmentHistory] ([DepartmentID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'INDEX', N'IX_EmployeeDepartmentHistory_DepartmentID'
GO
CREATE NONCLUSTERED INDEX [IX_EmployeeDepartmentHistory_ShiftID]
    ON [HumanResources].[EmployeeDepartmentHistory] ([ShiftID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'INDEX', N'IX_EmployeeDepartmentHistory_ShiftID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee identification number. Foreign key to Employee.BusinessEntityID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Department in which the employee worked including currently. Foreign key to Department.DepartmentID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'DepartmentID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the employee left the department. NULL = Current department.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Identifies which 8-hour shift the employee works. Foreign key to Shift.Shift.ID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'ShiftID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the employee started work in the department.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee department transfers.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeeDepartmentHistory', NULL, NULL
GO

Collapse image See also

List of tables


EmployeePayHistory

Table: AdventureWorks2016CTP3.HumanResources.EmployeePayHistory

CollapseAll image

Collapse image Description

Employee pay history.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1813581499
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 16 KB
Rows | 316
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_EmployeePayHistory_BusinessEntityID_RateChangeDate]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Employee identification number. Foreign key to Employee.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key |  | RateChangeDate | Date the change in pay is effective |  | datetime | 8 |  |  |  |
 |  | Rate | Salary hourly rate. |  | money | 8 |  |  |  |
 |  | PayFrequency | 1 = Salary received monthly, 2 = Salary received biweekly |  | tinyint | 1 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_EmployeePayHistory_BusinessEntityID_RateChangeDate | BusinessEntityID | Primary key (clustered) constraint |  |  | 32 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_EmployeePayHistory_PayFrequency | ([PayFrequency]=(2) OR [PayFrequency]=(1))
CK_EmployeePayHistory_Rate | ([Rate]>=(6.50) AND [Rate]<=(200.00))

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_EmployeePayHistory_Employee_BusinessEntityID
Total: 1 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
HumanResources.tr_d_AUDIT_EmployeePayHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeePayHistory
HumanResources.tr_i_AUDIT_EmployeePayHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeePayHistory
HumanResources.tr_u_AUDIT_EmployeePayHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeePayHistory
Total: 3 triggers(s)

Collapse image Objects that depend on HumanResources.EmployeePayHistory

Object name | Object type | Dep level
HumanResources.uspUpdateEmployeeHireInfo | Procedure | 1
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger | 1
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger | 1
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger | 1
Total 4 object(s)

Collapse image Objects that HumanResources.EmployeePayHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Employee | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Employee pay history.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [HumanResources].[EmployeePayHistory] (
        [BusinessEntityID]     [int] NOT NULL,
        [RateChangeDate]       [datetime] NOT NULL,
        [Rate]                 [money] NOT NULL,
        [PayFrequency]         [tinyint] NOT NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_EmployeePayHistory_BusinessEntityID_RateChangeDate]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [RateChangeDate])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'CONSTRAINT', N'PK_EmployeePayHistory_BusinessEntityID_RateChangeDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'INDEX', N'PK_EmployeePayHistory_BusinessEntityID_RateChangeDate'
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
    ADD
    CONSTRAINT [CK_EmployeePayHistory_PayFrequency]
    CHECK
    ([PayFrequency]=(2) OR [PayFrequency]=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [PayFrequency]=(3) OR [PayFrequency]=(2) OR [PayFrequency]=(1)', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'CONSTRAINT', N'CK_EmployeePayHistory_PayFrequency'
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
CHECK CONSTRAINT [CK_EmployeePayHistory_PayFrequency]
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
    ADD
    CONSTRAINT [CK_EmployeePayHistory_Rate]
    CHECK
    ([Rate]>=(6.50) AND [Rate]<=(200.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Rate] >= (6.50) AND [Rate] <= (200.00)', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'CONSTRAINT', N'CK_EmployeePayHistory_Rate'
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
CHECK CONSTRAINT [CK_EmployeePayHistory_Rate]
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
    ADD
    CONSTRAINT [DF_EmployeePayHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'CONSTRAINT', N'DF_EmployeePayHistory_ModifiedDate'
GO
ALTER TABLE [HumanResources].[EmployeePayHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_EmployeePayHistory_Employee_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [HumanResources].[EmployeePayHistory]
    CHECK CONSTRAINT [FK_EmployeePayHistory_Employee_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.EmployeeID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'CONSTRAINT', N'FK_EmployeePayHistory_Employee_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee identification number. Foreign key to Employee.BusinessEntityID.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'1 = Salary received monthly, 2 = Salary received biweekly', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'COLUMN', N'PayFrequency'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Salary hourly rate.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'COLUMN', N'Rate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the change in pay is effective', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', 'COLUMN', N'RateChangeDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee pay history.', 'SCHEMA', N'HumanResources', 'TABLE', N'EmployeePayHistory', NULL, NULL
GO

Collapse image See also

List of tables


JobCandidate

Table: AdventureWorks2016CTP3.HumanResources.JobCandidate

Collapse image Description

Résumés submitted to Human Resources by job applicants.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1909581841
Located on | PRIMARY
Data size KB | 128 KB
Index size KB | 152 KB
Rows | 13
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_JobCandidate_JobCandidateID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | JobCandidateID | Primary key for JobCandidate records. |  | int | 4 |  |  |  |
 |  | Foreign key | BusinessEntityID | Employee identification number if applicant was hired. Foreign key to Employee.BusinessEntityID. |  | int | 4 |  |  |  |
 |  |  | Resume | Résumé in XML format. |  | xml(HumanResources.HRResumeSchemaCollection) | 2147483647 |  |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_JobCandidate_JobCandidateID | JobCandidateID | Primary key (clustered) constraint |  |  | 120 | 0
IX_JobCandidate_BusinessEntityID | BusinessEntityID | Nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Fulltext index

Fulltext index | Description | Size KB
FULLTEXT_INDEX_JobCandidate |  | 0

Collapse image Identity column

Name | Seed | Increment | Not for replication
JobCandidateID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_JobCandidate_Employee_BusinessEntityID
Total: 1 table(s)

Collapse image Objects that depend on HumanResources.JobCandidate

Object name | Object type | Dep level
uspSearchCandidateResumes | Procedure | 1
HumanResources.vJobCandidate | View | 1
HumanResources.vJobCandidateEducation | View | 1
HumanResources.vJobCandidateEmployment | View | 1
Total 4 object(s)

Collapse image Objects that HumanResources.JobCandidate depends on

Object name | Object type | Dep level
AW2014FullTextCatalog | Fulltext Catalog | 1
HumanResources | Schema | 1
HumanResources.Employee | Table | 1
HumanResources.HRResumeSchemaCollection | XML Schema Collection | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Résumés submitted to Human Resources by job applicants.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [HumanResources].[JobCandidate] (
        [JobCandidateID]       [int] IDENTITY(1, 1) NOT NULL,
        [BusinessEntityID]     [int] NULL,
        [Resume]               [xml](CONTENT [HumanResources].[HRResumeSchemaCollection]) NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_JobCandidate_JobCandidateID]
        PRIMARY KEY
        CLUSTERED
        ([JobCandidateID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'CONSTRAINT', N'PK_JobCandidate_JobCandidateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'INDEX', N'PK_JobCandidate_JobCandidateID'
GO
ALTER TABLE [HumanResources].[JobCandidate]
    ADD
    CONSTRAINT [DF_JobCandidate_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'CONSTRAINT', N'DF_JobCandidate_ModifiedDate'
GO
ALTER TABLE [HumanResources].[JobCandidate]
    WITH CHECK
    ADD CONSTRAINT [FK_JobCandidate_Employee_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [HumanResources].[JobCandidate]
    CHECK CONSTRAINT [FK_JobCandidate_Employee_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.EmployeeID.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'CONSTRAINT', N'FK_JobCandidate_Employee_BusinessEntityID'
GO
CREATE NONCLUSTERED INDEX [IX_JobCandidate_BusinessEntityID]
    ON [HumanResources].[JobCandidate] ([BusinessEntityID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'INDEX', N'IX_JobCandidate_BusinessEntityID'
GO
CREATE FULLTEXT INDEX ON [HumanResources].[JobCandidate]
    ([Resume] LANGUAGE 1033)
    KEY INDEX [PK_JobCandidate_JobCandidateID]
    ON (FILEGROUP [PRIMARY], [AW2014FullTextCatalog])
    WITH CHANGE_TRACKING AUTO, STOPLIST SYSTEM
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee identification number if applicant was hired. Foreign key to Employee.BusinessEntityID.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for JobCandidate records.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'COLUMN', N'JobCandidateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Résumé in XML format.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', 'COLUMN', N'Resume'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Résumés submitted to Human Resources by job applicants.', 'SCHEMA', N'HumanResources', 'TABLE', N'JobCandidate', NULL, NULL
GO

Collapse image See also

List of tables


Shift

Table: AdventureWorks2016CTP3.HumanResources.Shift

Collapse image Description

Work shift lookup table.

Collapse image Table properties

Name | Value
Schema | HumanResources
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 366624349
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 3
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Shift_ShiftID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ShiftID | Primary key for Shift records. |  | tinyint | 1 |  |  |  |
 |  | Name | Shift description. |  | Name | 50 |  |  |  |
 |  | StartTime | Shift start time. |  | time | 5 |  |  |  |
 |  | EndTime | Shift end time. |  | time | 5 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 5 | 3 | 7 | 0.07000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Shift_ShiftID | ShiftID | Primary key (clustered) constraint |  |  | 48 | 0
AK_Shift_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_Shift_StartTime_EndTime | StartTime | Unique nonclustered index. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ShiftID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
HumanResources.EmployeeDepartmentHistory | FK_EmployeeDepartmentHistory_Shift_ShiftID | PK_Shift_ShiftID
Total: 1 table(s)

Collapse image Objects that depend on HumanResources.Shift

Object name | Object type | Dep level
HumanResources.EmployeeDepartmentHistory | Table | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
Total 2 object(s)

Collapse image Objects that HumanResources.Shift depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Work shift lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [HumanResources].[Shift] (
        [ShiftID]          [tinyint] IDENTITY(1, 1) NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [StartTime]        [time](7) NOT NULL,
        [EndTime]          [time](7) NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_Shift_ShiftID]
        PRIMARY KEY
        CLUSTERED
        ([ShiftID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'CONSTRAINT', N'PK_Shift_ShiftID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'INDEX', N'PK_Shift_ShiftID'
GO
ALTER TABLE [HumanResources].[Shift]
    ADD
    CONSTRAINT [DF_Shift_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'CONSTRAINT', N'DF_Shift_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Shift_Name]
    ON [HumanResources].[Shift] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'INDEX', N'AK_Shift_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Shift_StartTime_EndTime]
    ON [HumanResources].[Shift] ([StartTime], [EndTime])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'INDEX', N'AK_Shift_StartTime_EndTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shift end time.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'COLUMN', N'EndTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shift description.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Shift records.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'COLUMN', N'ShiftID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shift start time.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', 'COLUMN', N'StartTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work shift lookup table.', 'SCHEMA', N'HumanResources', 'TABLE', N'Shift', NULL, NULL
GO

Collapse image See also

List of tables


Address

Table: AdventureWorks2016CTP3.Person.Address

Collapse image Description

Street address information for customers, employees, and vendors.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 693577509
Located on | PRIMARY
Data size KB | 2904 KB
Index size KB | 2752 KB
Rows | 19614
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Address_AddressID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | AddressID | Primary key for Address records. |  | int | 4 |  |  |  |
 |  |  | AddressLine1 | First street address line. |  | nvarchar | 60 |  |  |  |
 |  |  | AddressLine2 | Second street address line. |  | nvarchar | 60 |  |  |  |
 |  |  | City | Name of the city. |  | nvarchar | 30 |  |  |  |
 |  | Foreign key | StateProvinceID | Unique identification number for the state or province. Foreign key to StateProvince table. |  | int | 4 |  |  |  |
 |  |  | PostalCode | Postal code for the street address. |  | nvarchar | 15 |  |  |  |
 |  |  | SpatialLocation | Latitude and longitude of this address. |  | geography |  |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
AddressLine1 | nvarchar(60) | 17 | 5 | 39 | 0.32500000000000
AddressLine2 | nvarchar(60) | 0 | 1 | 28 | 0.23333333333333
City | nvarchar(30) | 8 | 3 | 21 | 0.35000000000000
PostalCode | nvarchar(15) | 4 | 2 | 10 | 0.33333333333333
Total: 4 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Address_AddressID | AddressID | Primary key (clustered) constraint |  |  | 5624 | 0
AK_Address_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 528 | 0
IX_Address_AddressLine1_AddressLine2_City_StateProvinceID_PostalCode | AddressLine1 | Nonclustered index. |  |  | 1728 | 0
IX_Address_StateProvinceID | StateProvinceID | Nonclustered index. |  |  | 288 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
AddressID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.BusinessEntityAddress | FK_BusinessEntityAddress_Address_AddressID | PK_Address_AddressID
Sales.SalesOrderHeader | FK_SalesOrderHeader_Address_BillToAddressID | PK_Address_AddressID
Sales.SalesOrderHeader | FK_SalesOrderHeader_Address_ShipToAddressID | PK_Address_AddressID
Total: 3 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.StateProvince | PK_StateProvince_StateProvinceID | FK_Address_StateProvince_StateProvinceID
Total: 1 table(s)

Collapse image Objects that depend on Person.Address

Object name | Object type | Dep level
Person.BusinessEntityAddress | Table | 1
Sales.SalesOrderHeader | Table | 1
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Sales.vStoreWithAddresses | View | 1
Purchasing.vVendorWithAddresses | View | 1
Total 7 object(s)

Collapse image Objects that Person.Address depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.StateProvince | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Street address information for customers, employees, and vendors.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Address] (
        [AddressID]           [int] IDENTITY(1, 1) NOT FOR REPLICATION NOT NULL,
        [AddressLine1]        [nvarchar](60) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [AddressLine2]        [nvarchar](60) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [City]                [nvarchar](30) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [StateProvinceID]     [int] NOT NULL,
        [PostalCode]          [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [SpatialLocation]     [geography] NULL,
        [rowguid]             [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [PK_Address_AddressID]
        PRIMARY KEY
        CLUSTERED
        ([AddressID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'Address', 'CONSTRAINT', N'PK_Address_AddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'INDEX', N'PK_Address_AddressID'
GO
ALTER TABLE [Person].[Address]
    ADD
    CONSTRAINT [DF_Address_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'Address', 'CONSTRAINT', N'DF_Address_ModifiedDate'
GO
ALTER TABLE [Person].[Address]
    ADD
    CONSTRAINT [DF_Address_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'Address', 'CONSTRAINT', N'DF_Address_rowguid'
GO
ALTER TABLE [Person].[Address]
    WITH CHECK
    ADD CONSTRAINT [FK_Address_StateProvince_StateProvinceID]
    FOREIGN KEY ([StateProvinceID]) REFERENCES [Person].[StateProvince] ([StateProvinceID])
ALTER TABLE [Person].[Address]
    CHECK CONSTRAINT [FK_Address_StateProvince_StateProvinceID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing StateProvince.StateProvinceID.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'CONSTRAINT', N'FK_Address_StateProvince_StateProvinceID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Address_rowguid]
    ON [Person].[Address] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'INDEX', N'AK_Address_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [IX_Address_AddressLine1_AddressLine2_City_StateProvinceID_PostalCode]
    ON [Person].[Address] ([AddressLine1], [AddressLine2], [City], [StateProvinceID], [PostalCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'INDEX', N'IX_Address_AddressLine1_AddressLine2_City_StateProvinceID_PostalCode'
GO
CREATE NONCLUSTERED INDEX [IX_Address_StateProvinceID]
    ON [Person].[Address] ([StateProvinceID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'INDEX', N'IX_Address_StateProvinceID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Address records.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'AddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'First street address line.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'AddressLine1'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Second street address line.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'AddressLine2'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the city.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'City'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Postal code for the street address.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'PostalCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Latitude and longitude of this address.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'SpatialLocation'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique identification number for the state or province. Foreign key to StateProvince table.', 'SCHEMA', N'Person', 'TABLE', N'Address', 'COLUMN', N'StateProvinceID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Street address information for customers, employees, and vendors.', 'SCHEMA', N'Person', 'TABLE', N'Address', NULL, NULL
GO

Collapse image See also

List of tables


AddressType

Table: AdventureWorks2016CTP3.Person.AddressType

Collapse image Description

Types of addresses stored in the Address table.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 741577680
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 6
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_AddressType_AddressTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | AddressTypeID | Primary key for AddressType records. |  | int | 4 |  |  |  |
 |  | Name | Address type description. For example, Billing, Home, or Shipping. |  | Name | 50 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 7 | 4 | 11 | 0.11000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_AddressType_AddressTypeID | AddressTypeID | Primary key (clustered) constraint |  |  | 48 | 0
AK_AddressType_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_AddressType_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
AddressTypeID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.BusinessEntityAddress | FK_BusinessEntityAddress_AddressType_AddressTypeID | PK_AddressType_AddressTypeID
Total: 1 table(s)

Collapse image Objects that depend on Person.AddressType

Object name | Object type | Dep level
Person.BusinessEntityAddress | Table | 1
Sales.vIndividualCustomer | View | 1
Sales.vStoreWithAddresses | View | 1
Purchasing.vVendorWithAddresses | View | 1
Total 4 object(s)

Collapse image Objects that Person.AddressType depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Types of addresses stored in the Address table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[AddressType] (
        [AddressTypeID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]              [dbo].[Name] NOT NULL,
        [rowguid]           [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_AddressType_AddressTypeID]
        PRIMARY KEY
        CLUSTERED
        ([AddressTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'CONSTRAINT', N'PK_AddressType_AddressTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'INDEX', N'PK_AddressType_AddressTypeID'
GO
ALTER TABLE [Person].[AddressType]
    ADD
    CONSTRAINT [DF_AddressType_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'CONSTRAINT', N'DF_AddressType_ModifiedDate'
GO
ALTER TABLE [Person].[AddressType]
    ADD
    CONSTRAINT [DF_AddressType_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'CONSTRAINT', N'DF_AddressType_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_AddressType_Name]
    ON [Person].[AddressType] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'INDEX', N'AK_AddressType_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_AddressType_rowguid]
    ON [Person].[AddressType] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'INDEX', N'AK_AddressType_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for AddressType records.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'COLUMN', N'AddressTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Address type description. For example, Billing, Home, or Shipping.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'AddressType', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Types of addresses stored in the Address table. ', 'SCHEMA', N'Person', 'TABLE', N'AddressType', NULL, NULL
GO

Collapse image See also

List of tables


BusinessEntity

Table: AdventureWorks2016CTP3.Person.BusinessEntity

Collapse image Description

Source of the ID that connects vendors, customers, and employees with address and contact information.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 949578421
Located on | PRIMARY
Data size KB | 768 KB
Index size KB | 568 KB
Rows | 20777
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_BusinessEntity_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | BusinessEntityID | Primary key for all customers, vendors, and employees. |  | int | 4 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_BusinessEntity_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 1336 | 0
AK_BusinessEntity_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 552 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
BusinessEntityID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.BusinessEntityAddress | FK_BusinessEntityAddress_BusinessEntity_BusinessEntityID | PK_BusinessEntity_BusinessEntityID
Person.BusinessEntityContact | FK_BusinessEntityContact_BusinessEntity_BusinessEntityID | PK_BusinessEntity_BusinessEntityID
Person.Person | FK_Person_BusinessEntity_BusinessEntityID | PK_BusinessEntity_BusinessEntityID
Purchasing.Vendor | FK_Vendor_BusinessEntity_BusinessEntityID | PK_BusinessEntity_BusinessEntityID
Sales.Store | FK_Store_BusinessEntity_BusinessEntityID | PK_BusinessEntity_BusinessEntityID
Total: 5 table(s)

Collapse image Objects that depend on Person.BusinessEntity

Object name | Object type | Dep level
Person.BusinessEntityAddress | Table | 1
Person.BusinessEntityContact | Table | 1
Person.Person | Table | 1
Sales.Store | Table | 1
Purchasing.Vendor | Table | 1
Total 5 object(s)

Collapse image Objects that Person.BusinessEntity depends on

Object name | Object type | Dep level
Person | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Source of the ID that connects vendors, customers, and employees with address and contact information.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Person].[BusinessEntity] (
        [BusinessEntityID]     [int] IDENTITY(1, 1) NOT FOR REPLICATION NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_BusinessEntity_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'CONSTRAINT', N'PK_BusinessEntity_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'INDEX', N'PK_BusinessEntity_BusinessEntityID'
GO
ALTER TABLE [Person].[BusinessEntity]
    ADD
    CONSTRAINT [DF_BusinessEntity_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'CONSTRAINT', N'DF_BusinessEntity_ModifiedDate'
GO
ALTER TABLE [Person].[BusinessEntity]
    ADD
    CONSTRAINT [DF_BusinessEntity_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'CONSTRAINT', N'DF_BusinessEntity_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_BusinessEntity_rowguid]
    ON [Person].[BusinessEntity] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'INDEX', N'AK_BusinessEntity_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for all customers, vendors, and employees.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Source of the ID that connects vendors, customers, and employees with address and contact information.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntity', NULL, NULL
GO

Collapse image See also

List of tables


BusinessEntityAddress

Table: AdventureWorks2016CTP3.Person.BusinessEntityAddress

Collapse image Description

Cross-reference table mapping customers, vendors, and employees to their addresses.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 997578592
Located on | PRIMARY
Data size KB | 880 KB
Index size KB | 1432 KB
Rows | 19614
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_BusinessEntityAddress_BusinessEntityID_AddressID_AddressTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key. Foreign key to BusinessEntity.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | AddressID | Primary key. Foreign key to Address.AddressID. |  | int | 4 |  |  |  |
Primary key | Foreign key | AddressTypeID | Primary key. Foreign key to AddressType.AddressTypeID. |  | int | 4 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_BusinessEntityAddress_BusinessEntityID_AddressID_AddressTypeID | BusinessEntityID | Primary key (clustered) constraint |  |  | 2312 | 0
AK_BusinessEntityAddress_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 680 | 0
IX_BusinessEntityAddress_AddressID | AddressID | Nonclustered index. |  |  | 368 | 0
IX_BusinessEntityAddress_AddressTypeID | AddressTypeID | Nonclustered index. |  |  | 368 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Address | PK_Address_AddressID | FK_BusinessEntityAddress_Address_AddressID
Person.AddressType | PK_AddressType_AddressTypeID | FK_BusinessEntityAddress_AddressType_AddressTypeID
Person.BusinessEntity | PK_BusinessEntity_BusinessEntityID | FK_BusinessEntityAddress_BusinessEntity_BusinessEntityID
Total: 3 table(s)

Collapse image Objects that depend on Person.BusinessEntityAddress

Object name | Object type | Dep level
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Sales.vStoreWithAddresses | View | 1
Purchasing.vVendorWithAddresses | View | 1
Total 5 object(s)

Collapse image Objects that Person.BusinessEntityAddress depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Address | Table | 1
Person.AddressType | Table | 1
Person.BusinessEntity | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping customers, vendors, and employees to their addresses.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Person].[BusinessEntityAddress] (
        [BusinessEntityID]     [int] NOT NULL,
        [AddressID]            [int] NOT NULL,
        [AddressTypeID]        [int] NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_BusinessEntityAddress_BusinessEntityID_AddressID_AddressTypeID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [AddressID], [AddressTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'PK_BusinessEntityAddress_BusinessEntityID_AddressID_AddressTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'INDEX', N'PK_BusinessEntityAddress_BusinessEntityID_AddressID_AddressTypeID'
GO
ALTER TABLE [Person].[BusinessEntityAddress]
    ADD
    CONSTRAINT [DF_BusinessEntityAddress_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'DF_BusinessEntityAddress_ModifiedDate'
GO
ALTER TABLE [Person].[BusinessEntityAddress]
    ADD
    CONSTRAINT [DF_BusinessEntityAddress_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'DF_BusinessEntityAddress_rowguid'
GO
ALTER TABLE [Person].[BusinessEntityAddress]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityAddress_Address_AddressID]
    FOREIGN KEY ([AddressID]) REFERENCES [Person].[Address] ([AddressID])
ALTER TABLE [Person].[BusinessEntityAddress]
    CHECK CONSTRAINT [FK_BusinessEntityAddress_Address_AddressID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Address.AddressID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'FK_BusinessEntityAddress_Address_AddressID'
GO
ALTER TABLE [Person].[BusinessEntityAddress]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityAddress_AddressType_AddressTypeID]
    FOREIGN KEY ([AddressTypeID]) REFERENCES [Person].[AddressType] ([AddressTypeID])
ALTER TABLE [Person].[BusinessEntityAddress]
    CHECK CONSTRAINT [FK_BusinessEntityAddress_AddressType_AddressTypeID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing AddressType.AddressTypeID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'FK_BusinessEntityAddress_AddressType_AddressTypeID'
GO
ALTER TABLE [Person].[BusinessEntityAddress]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityAddress_BusinessEntity_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[BusinessEntity] ([BusinessEntityID])
ALTER TABLE [Person].[BusinessEntityAddress]
    CHECK CONSTRAINT [FK_BusinessEntityAddress_BusinessEntity_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing BusinessEntity.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'CONSTRAINT', N'FK_BusinessEntityAddress_BusinessEntity_BusinessEntityID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_BusinessEntityAddress_rowguid]
    ON [Person].[BusinessEntityAddress] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'INDEX', N'AK_BusinessEntityAddress_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_BusinessEntityAddress_AddressID]
    ON [Person].[BusinessEntityAddress] ([AddressID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'INDEX', N'IX_BusinessEntityAddress_AddressID'
GO
CREATE NONCLUSTERED INDEX [IX_BusinessEntityAddress_AddressTypeID]
    ON [Person].[BusinessEntityAddress] ([AddressTypeID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'INDEX', N'IX_BusinessEntityAddress_AddressTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Address.AddressID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'COLUMN', N'AddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to AddressType.AddressTypeID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'COLUMN', N'AddressTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to BusinessEntity.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping customers, vendors, and employees to their addresses.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityAddress', NULL, NULL
GO

Collapse image See also

List of tables


BusinessEntityContact

Table: AdventureWorks2016CTP3.Person.BusinessEntityContact

Collapse image Description

Cross-reference table mapping stores, vendors, and employees to people

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1045578763
Located on | PRIMARY
Data size KB | 48 KB
Index size KB | 144 KB
Rows | 909
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_BusinessEntityContact_BusinessEntityID_PersonID_ContactTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key. Foreign key to BusinessEntity.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | PersonID | Primary key. Foreign key to Person.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | ContactTypeID | Primary key. Foreign key to ContactType.ContactTypeID. |  | int | 4 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_BusinessEntityContact_BusinessEntityID_PersonID_ContactTypeID | BusinessEntityID | Primary key (clustered) constraint |  |  | 192 | 0
AK_BusinessEntityContact_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 48 | 0
IX_BusinessEntityContact_ContactTypeID | ContactTypeID | Nonclustered index. |  |  | 40 | 0
IX_BusinessEntityContact_PersonID | PersonID | Nonclustered index. |  |  | 40 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.BusinessEntity | PK_BusinessEntity_BusinessEntityID | FK_BusinessEntityContact_BusinessEntity_BusinessEntityID
Person.ContactType | PK_ContactType_ContactTypeID | FK_BusinessEntityContact_ContactType_ContactTypeID
Person.Person | PK_Person_BusinessEntityID | FK_BusinessEntityContact_Person_PersonID
Total: 3 table(s)

Collapse image Objects that depend on Person.BusinessEntityContact

Object name | Object type | Dep level
ufnGetContactInformation | Function | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 3 object(s)

Collapse image Objects that Person.BusinessEntityContact depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.BusinessEntity | Table | 1
Person.ContactType | Table | 1
Person.Person | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping stores, vendors, and employees to people

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Person].[BusinessEntityContact] (
        [BusinessEntityID]     [int] NOT NULL,
        [PersonID]             [int] NOT NULL,
        [ContactTypeID]        [int] NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_BusinessEntityContact_BusinessEntityID_PersonID_ContactTypeID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [PersonID], [ContactTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'PK_BusinessEntityContact_BusinessEntityID_PersonID_ContactTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'INDEX', N'PK_BusinessEntityContact_BusinessEntityID_PersonID_ContactTypeID'
GO
ALTER TABLE [Person].[BusinessEntityContact]
    ADD
    CONSTRAINT [DF_BusinessEntityContact_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'DF_BusinessEntityContact_ModifiedDate'
GO
ALTER TABLE [Person].[BusinessEntityContact]
    ADD
    CONSTRAINT [DF_BusinessEntityContact_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'DF_BusinessEntityContact_rowguid'
GO
ALTER TABLE [Person].[BusinessEntityContact]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityContact_BusinessEntity_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[BusinessEntity] ([BusinessEntityID])
ALTER TABLE [Person].[BusinessEntityContact]
    CHECK CONSTRAINT [FK_BusinessEntityContact_BusinessEntity_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing BusinessEntity.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'FK_BusinessEntityContact_BusinessEntity_BusinessEntityID'
GO
ALTER TABLE [Person].[BusinessEntityContact]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityContact_ContactType_ContactTypeID]
    FOREIGN KEY ([ContactTypeID]) REFERENCES [Person].[ContactType] ([ContactTypeID])
ALTER TABLE [Person].[BusinessEntityContact]
    CHECK CONSTRAINT [FK_BusinessEntityContact_ContactType_ContactTypeID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ContactType.ContactTypeID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'FK_BusinessEntityContact_ContactType_ContactTypeID'
GO
ALTER TABLE [Person].[BusinessEntityContact]
    WITH CHECK
    ADD CONSTRAINT [FK_BusinessEntityContact_Person_PersonID]
    FOREIGN KEY ([PersonID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Person].[BusinessEntityContact]
    CHECK CONSTRAINT [FK_BusinessEntityContact_Person_PersonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'CONSTRAINT', N'FK_BusinessEntityContact_Person_PersonID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_BusinessEntityContact_rowguid]
    ON [Person].[BusinessEntityContact] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'INDEX', N'AK_BusinessEntityContact_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_BusinessEntityContact_ContactTypeID]
    ON [Person].[BusinessEntityContact] ([ContactTypeID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'INDEX', N'IX_BusinessEntityContact_ContactTypeID'
GO
CREATE NONCLUSTERED INDEX [IX_BusinessEntityContact_PersonID]
    ON [Person].[BusinessEntityContact] ([PersonID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'INDEX', N'IX_BusinessEntityContact_PersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to BusinessEntity.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.  Foreign key to ContactType.ContactTypeID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'COLUMN', N'ContactTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Person.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'COLUMN', N'PersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping stores, vendors, and employees to people', 'SCHEMA', N'Person', 'TABLE', N'BusinessEntityContact', NULL, NULL
GO

Collapse image See also

List of tables


ContactType

Table: AdventureWorks2016CTP3.Person.ContactType

Collapse image Description

Lookup table containing the types of business entity contacts.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1093578934
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 20
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ContactType_ContactTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ContactTypeID | Primary key for ContactType records. |  | int | 4 |  |  |  |
 |  | Name | Contact type description. |  | Name | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 19 | 5 | 31 | 0.31000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ContactType_ContactTypeID | ContactTypeID | Primary key (clustered) constraint |  |  | 32 | 0
AK_ContactType_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ContactTypeID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.BusinessEntityContact | FK_BusinessEntityContact_ContactType_ContactTypeID | PK_ContactType_ContactTypeID
Total: 1 table(s)

Collapse image Objects that depend on Person.ContactType

Object name | Object type | Dep level
Person.BusinessEntityContact | Table | 1
ufnGetContactInformation | Function | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 4 object(s)

Collapse image Objects that Person.ContactType depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table containing the types of business entity contacts.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[ContactType] (
        [ContactTypeID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]              [dbo].[Name] NOT NULL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_ContactType_ContactTypeID]
        PRIMARY KEY
        CLUSTERED
        ([ContactTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'CONSTRAINT', N'PK_ContactType_ContactTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'INDEX', N'PK_ContactType_ContactTypeID'
GO
ALTER TABLE [Person].[ContactType]
    ADD
    CONSTRAINT [DF_ContactType_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'CONSTRAINT', N'DF_ContactType_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ContactType_Name]
    ON [Person].[ContactType] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'INDEX', N'AK_ContactType_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ContactType records.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'COLUMN', N'ContactTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contact type description.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table containing the types of business entity contacts.', 'SCHEMA', N'Person', 'TABLE', N'ContactType', NULL, NULL
GO

Collapse image See also

List of tables


CountryRegion

Table: AdventureWorks2016CTP3.Person.CountryRegion

Collapse image Description

Lookup table containing the ISO standard codes for countries and regions.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1157579162
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 48 KB
Rows | 238
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_CountryRegion_CountryRegionCode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | CountryRegionCode | ISO standard code for countries and regions. |  | nvarchar | 3 |  |  |  |
 | Name | Country or region name. |  | Name | 50 |  |  |  |
 | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CountryRegionCode | nvarchar(3) | 2 | 2 | 2 | 0.33333333333333
Name | nvarchar(50) | 10 | 4 | 44 | 0.44000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_CountryRegion_CountryRegionCode | CountryRegionCode | Primary key (clustered) constraint |  |  | 64 | 0
AK_CountryRegion_Name | Name | Unique nonclustered index. |  |  | 32 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.StateProvince | FK_StateProvince_CountryRegion_CountryRegionCode | PK_CountryRegion_CountryRegionCode
Sales.CountryRegionCurrency | FK_CountryRegionCurrency_CountryRegion_CountryRegionCode | PK_CountryRegion_CountryRegionCode
Sales.SalesTerritory | FK_SalesTerritory_CountryRegion_CountryRegionCode | PK_CountryRegion_CountryRegionCode
Total: 3 table(s)

Collapse image Objects that depend on Person.CountryRegion

Object name | Object type | Dep level
Sales.CountryRegionCurrency | Table | 1
Sales.SalesTerritory | Table | 1
Person.StateProvince | Table | 1
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Person.vStateProvinceCountryRegion | View | 1
Sales.vStoreWithAddresses | View | 1
Purchasing.vVendorWithAddresses | View | 1
Total 9 object(s)

Collapse image Objects that Person.CountryRegion depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table containing the ISO standard codes for countries and regions.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[CountryRegion] (
        [CountryRegionCode]     [nvarchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Name]                  [dbo].[Name] NOT NULL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_CountryRegion_CountryRegionCode]
        PRIMARY KEY
        CLUSTERED
        ([CountryRegionCode])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'CONSTRAINT', N'PK_CountryRegion_CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'INDEX', N'PK_CountryRegion_CountryRegionCode'
GO
ALTER TABLE [Person].[CountryRegion]
    ADD
    CONSTRAINT [DF_CountryRegion_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'CONSTRAINT', N'DF_CountryRegion_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_CountryRegion_Name]
    ON [Person].[CountryRegion] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'INDEX', N'AK_CountryRegion_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO standard code for countries and regions.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'COLUMN', N'CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Country or region name.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table containing the ISO standard codes for countries and regions.', 'SCHEMA', N'Person', 'TABLE', N'CountryRegion', NULL, NULL
GO

Collapse image See also

List of tables


EmailAddress

Table: AdventureWorks2016CTP3.Person.EmailAddress

Collapse image Description

Where to send a person email.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1509580416
Located on | PRIMARY
Data size KB | 1992 KB
Index size KB | 1504 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_EmailAddress_BusinessEntityID_EmailAddressID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | Foreign key | BusinessEntityID | Primary key. Person associated with this email address. Foreign key to Person.BusinessEntityID |  | int | 4 |  |  |  |
Primary key | Identity |  | EmailAddressID | Primary key. ID of this email address. |  | int | 4 |  |  |  |
 |  |  | EmailAddress | E-mail address for the person. |  | nvarchar | 50 |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
EmailAddress | nvarchar(50) | 27 | 22 | 43 | 0.43000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_EmailAddress_BusinessEntityID_EmailAddressID | BusinessEntityID | Primary key (clustered) constraint |  |  | 3496 | 0
IX_EmailAddress_EmailAddress | EmailAddress | Nonclustered index. |  |  | 1488 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
EmailAddressID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Person | PK_Person_BusinessEntityID | FK_EmailAddress_Person_BusinessEntityID
Total: 1 table(s)

Collapse image Objects that depend on Person.EmailAddress

Object name | Object type | Dep level
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 5 object(s)

Collapse image Objects that Person.EmailAddress depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Where to send a person email.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[EmailAddress] (
        [BusinessEntityID]     [int] NOT NULL,
        [EmailAddressID]       [int] IDENTITY(1, 1) NOT NULL,
        [EmailAddress]         [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_EmailAddress_BusinessEntityID_EmailAddressID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [EmailAddressID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'CONSTRAINT', N'PK_EmailAddress_BusinessEntityID_EmailAddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'INDEX', N'PK_EmailAddress_BusinessEntityID_EmailAddressID'
GO
ALTER TABLE [Person].[EmailAddress]
    ADD
    CONSTRAINT [DF_EmailAddress_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'CONSTRAINT', N'DF_EmailAddress_ModifiedDate'
GO
ALTER TABLE [Person].[EmailAddress]
    ADD
    CONSTRAINT [DF_EmailAddress_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'CONSTRAINT', N'DF_EmailAddress_rowguid'
GO
ALTER TABLE [Person].[EmailAddress]
    WITH CHECK
    ADD CONSTRAINT [FK_EmailAddress_Person_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Person].[EmailAddress]
    CHECK CONSTRAINT [FK_EmailAddress_Person_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'CONSTRAINT', N'FK_EmailAddress_Person_BusinessEntityID'
GO
CREATE NONCLUSTERED INDEX [IX_EmailAddress_EmailAddress]
    ON [Person].[EmailAddress] ([EmailAddress])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'INDEX', N'IX_EmailAddress_EmailAddress'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Person associated with this email address.  Foreign key to Person.BusinessEntityID', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'E-mail address for the person.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'COLUMN', N'EmailAddress'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. ID of this email address.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'COLUMN', N'EmailAddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Where to send a person email.', 'SCHEMA', N'Person', 'TABLE', N'EmailAddress', NULL, NULL
GO

Collapse image See also

List of tables


Password

Table: AdventureWorks2016CTP3.Person.Password

Collapse image Description

One way hashed authentication information

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 2037582297
Located on | PRIMARY
Data size KB | 1880 KB
Index size KB | 16 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Password_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID |  |  | int | 4 |  |  |  |
 |  | PasswordHash | aaa |  | varchar | 128 |  |  |  |
 |  | PasswordSalt | Random value concatenated with the password string before the password is hashed. |  | varchar | 10 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PasswordHash | varchar(128) | 44 | 44 | 44 | 0.34375000000000
PasswordSalt | varchar(10) | 8 | 8 | 8 | 0.80000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Password_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 1896 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Person | PK_Person_BusinessEntityID | FK_Password_Person_BusinessEntityID
Total: 1 table(s)

Collapse image Objects that Person.Password depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | One way hashed authentication information

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Password] (
        [BusinessEntityID]     [int] NOT NULL,
        [PasswordHash]         [varchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [PasswordSalt]         [varchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_Password_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'Password', 'CONSTRAINT', N'PK_Password_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'Password', 'INDEX', N'PK_Password_BusinessEntityID'
GO
ALTER TABLE [Person].[Password]
    ADD
    CONSTRAINT [DF_Password_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'Password', 'CONSTRAINT', N'DF_Password_ModifiedDate'
GO
ALTER TABLE [Person].[Password]
    ADD
    CONSTRAINT [DF_Password_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'Password', 'CONSTRAINT', N'DF_Password_rowguid'
GO
ALTER TABLE [Person].[Password]
    WITH CHECK
    ADD CONSTRAINT [FK_Password_Person_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Person].[Password]
    CHECK CONSTRAINT [FK_Password_Person_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'Password', 'CONSTRAINT', N'FK_Password_Person_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'Password', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'aaa', 'SCHEMA', N'Person', 'TABLE', N'Password', 'COLUMN', N'PasswordHash'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Random value concatenated with the password string before the password is hashed.', 'SCHEMA', N'Person', 'TABLE', N'Password', 'COLUMN', N'PasswordSalt'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'Password', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'One way hashed authentication information', 'SCHEMA', N'Person', 'TABLE', N'Password', NULL, NULL
GO

Collapse image See also

List of tables


Person

Table: AdventureWorks2016CTP3.Person.Person

Collapse image Description

Human beings involved with AdventureWorks: employees, customer contacts, and vendor contacts.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 2085582468
Located on | PRIMARY
Data size KB | 30552 KB
Index size KB | 53896 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Person_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key for Person records. |  | int | 4 |  |  |  |
 |  | PersonType | Primary type of person: SC = Store Contact, IN = Individual (retail) customer, SP = Sales person, EM = Employee (non-sales), VC = Vendor contact, GC = General contact |  | nchar | 2 |  |  |  |
 |  | NameStyle | 0 = The data in FirstName and LastName are stored in western style (first name, last name) order. 1 = Eastern style (last name, first name) order. |  | NameStyle | 1 |  | ((0)) |  |
 |  | Title | A courtesy title. For example, Mr. or Ms. |  | nvarchar | 8 |  |  |  |
 |  | FirstName | First name of the person. |  | Name | 50 |  |  |  |
 |  | MiddleName | Middle name or middle initial of the person. |  | Name | 50 |  |  |  |
 |  | LastName | Last name of the person. |  | Name | 50 |  |  |  |
 |  | Suffix | Surname suffix. For example, Sr. or Jr. |  | nvarchar | 10 |  |  |  |
 |  | EmailPromotion | 0 = Contact does not wish to receive e-mail promotions, 1 = Contact does wish to receive e-mail promotions from AdventureWorks, 2 = Contact does wish to receive e-mail promotions from AdventureWorks and selected partners. |  | int | 4 |  | ((0)) |  |
 |  | AdditionalContactInfo | Additional contact information about the person stored in xml format. |  | xml(Person.AdditionalContactInfoSchemaCollection) | 2147483647 |  |  |  |
 |  | Demographics | Personal information such as hobbies, and income collected from online shoppers. Used for sales analysis. |  | xml(Person.IndividualSurveySchemaCollection) | 2147483647 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 13 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PersonType | nchar(2) | 2 | 2 | 2 | 0.50000000000000
Title | nvarchar(8) | 0 | 2 | 4 | 0.25000000000000
FirstName | nvarchar(50) | 5 | 2 | 24 | 0.24000000000000
MiddleName | nvarchar(50) | 0 | 1 | 16 | 0.16000000000000
LastName | nvarchar(50) | 5 | 2 | 22 | 0.22000000000000
Suffix | nvarchar(10) | 0 | 2 | 3 | 0.15000000000000
Total: 6 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Person_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 32560 | 0
AK_Person_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 536 | 0
IX_Person_LastName_FirstName_MiddleName | LastName |  |  |  | 1128 | 0
PXML_Person_AddContact |  | Primary XML index. |  |  | 40 | 0
PXML_Person_Demographics |  | Primary XML index. |  |  | 51768 | 0
XMLPATH_Person_Demographics |  | Secondary XML index for path. |  |  | 0 | 0
XMLPROPERTY_Person_Demographics |  | Secondary XML index for property. |  |  | 0 | 0
XMLVALUE_Person_Demographics |  | Secondary XML index for value. |  |  | 0 | 0
Total: 8 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_Person_EmailPromotion | ([EmailPromotion]>=(0) AND [EmailPromotion]<=(2))
CK_Person_PersonType | ([PersonType] IS NULL OR (upper([PersonType])='GC' OR upper([PersonType])='SP' OR upper([PersonType])='EM' OR upper([PersonType])='IN' OR upper([PersonType])='VC' OR upper([PersonType])='SC'))

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
HumanResources.Employee | FK_Employee_Person_BusinessEntityID | PK_Person_BusinessEntityID
Person.BusinessEntityContact | FK_BusinessEntityContact_Person_PersonID | PK_Person_BusinessEntityID
Person.EmailAddress | FK_EmailAddress_Person_BusinessEntityID | PK_Person_BusinessEntityID
Person.Password | FK_Password_Person_BusinessEntityID | PK_Person_BusinessEntityID
Person.PersonPhone | FK_PersonPhone_Person_BusinessEntityID | PK_Person_BusinessEntityID
Sales.Customer | FK_Customer_Person_PersonID | PK_Person_BusinessEntityID
Sales.PersonCreditCard | FK_PersonCreditCard_Person_BusinessEntityID | PK_Person_BusinessEntityID
Total: 7 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.BusinessEntity | PK_BusinessEntity_BusinessEntityID | FK_Person_BusinessEntity_BusinessEntityID
Total: 1 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Person.iuPerson | Person |  |  | For Insert | For Update |  | Person.Person
Total: 1 triggers(s)

Collapse image Objects that depend on Person.Person

Object name | Object type | Dep level
uspGetEmployeeManagers | Procedure | 1
uspGetManagerEmployees | Procedure | 1
Person.BusinessEntityContact | Table | 1
Sales.Customer | Table | 1
Person.EmailAddress | Table | 1
HumanResources.Employee | Table | 1
Person.Password | Table | 1
Sales.PersonCreditCard | Table | 1
Person.PersonPhone | Table | 1
Sales.iduSalesOrderDetail | Trigger | 1
Person.iuPerson | Trigger | 1
ufnGetContactInformation | Function | 1
Person.vAdditionalContactInfo | View | 1
HumanResources.vEmployee | View | 1
HumanResources.vEmployeeDepartment | View | 1
HumanResources.vEmployeeDepartmentHistory | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vPersonDemographics | View | 1
Sales.vSalesPerson | View | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 22 object(s)

Collapse image Objects that Person.Person depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.BusinessEntity | Table | 1
Name | Datatype | 1
NameStyle | Datatype | 1
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection | 1
Person.IndividualSurveySchemaCollection | XML Schema Collection | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Human beings involved with AdventureWorks: employees, customer contacts, and vendor contacts.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Person] (
        [BusinessEntityID]          [int] NOT NULL,
        [PersonType]                [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [NameStyle]                 [dbo].[NameStyle] NOT NULL,
        [Title]                     [nvarchar](8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [FirstName]                 [dbo].[Name] NOT NULL,
        [MiddleName]                [dbo].[Name] NULL,
        [LastName]                  [dbo].[Name] NOT NULL,
        [Suffix]                    [nvarchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [EmailPromotion]            [int] NOT NULL,
        [AdditionalContactInfo]     [xml](CONTENT [Person].[AdditionalContactInfoSchemaCollection]) NULL,
        [Demographics]              [xml](CONTENT [Person].[IndividualSurveySchemaCollection]) NULL,
        [rowguid]                   [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]              [datetime] NOT NULL,
        CONSTRAINT [PK_Person_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'PK_Person_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'PK_Person_BusinessEntityID'
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [CK_Person_EmailPromotion]
    CHECK
    ([EmailPromotion]>=(0) AND [EmailPromotion]<=(2))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EmailPromotion] >= (0) AND [EmailPromotion] <= (2)', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'CK_Person_EmailPromotion'
GO
ALTER TABLE [Person].[Person]
CHECK CONSTRAINT [CK_Person_EmailPromotion]
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [CK_Person_PersonType]
    CHECK
    ([PersonType] IS NULL OR (upper([PersonType])='GC' OR upper([PersonType])='SP' OR upper([PersonType])='EM' OR upper([PersonType])='IN' OR upper([PersonType])='VC' OR upper([PersonType])='SC'))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [PersonType] is one of SC, VC, IN, EM or SP.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'CK_Person_PersonType'
GO
ALTER TABLE [Person].[Person]
CHECK CONSTRAINT [CK_Person_PersonType]
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [DF_Person_EmailPromotion]
    DEFAULT ((0)) FOR [EmailPromotion]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'DF_Person_EmailPromotion'
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [DF_Person_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'DF_Person_ModifiedDate'
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [DF_Person_NameStyle]
    DEFAULT ((0)) FOR [NameStyle]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'DF_Person_NameStyle'
GO
ALTER TABLE [Person].[Person]
    ADD
    CONSTRAINT [DF_Person_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'DF_Person_rowguid'
GO
ALTER TABLE [Person].[Person]
    WITH CHECK
    ADD CONSTRAINT [FK_Person_BusinessEntity_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[BusinessEntity] ([BusinessEntityID])
ALTER TABLE [Person].[Person]
    CHECK CONSTRAINT [FK_Person_BusinessEntity_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing BusinessEntity.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'CONSTRAINT', N'FK_Person_BusinessEntity_BusinessEntityID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Person_rowguid]
    ON [Person].[Person] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'AK_Person_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_Person_LastName_FirstName_MiddleName]
    ON [Person].[Person] ([LastName], [FirstName], [MiddleName])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Additional contact information about the person stored in xml format. ', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'AdditionalContactInfo'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Person records.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Personal information such as hobbies, and income collected from online shoppers. Used for sales analysis.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'Demographics'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Contact does not wish to receive e-mail promotions, 1 = Contact does wish to receive e-mail promotions from AdventureWorks, 2 = Contact does wish to receive e-mail promotions from AdventureWorks and selected partners. ', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'EmailPromotion'
GO
EXEC sp_addextendedproperty N'MS_Description', N'First name of the person.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'FirstName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Last name of the person.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'LastName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Middle name or middle initial of the person.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'MiddleName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = The data in FirstName and LastName are stored in western style (first name, last name) order.  1 = Eastern style (last name, first name) order.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'NameStyle'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary type of person: SC = Store Contact, IN = Individual (retail) customer, SP = Sales person, EM = Employee (non-sales), VC = Vendor contact, GC = General contact', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'PersonType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Surname suffix. For example, Sr. or Jr.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'Suffix'
GO
EXEC sp_addextendedproperty N'MS_Description', N'A courtesy title. For example, Mr. or Ms.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'COLUMN', N'Title'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Human beings involved with AdventureWorks: employees, customer contacts, and vendor contacts.', 'SCHEMA', N'Person', 'TABLE', N'Person', NULL, NULL
GO
SET ANSI_PADDING ON
GO
CREATE PRIMARY XML INDEX [PXML_Person_AddContact]
    ON [Person].[Person] ([AdditionalContactInfo])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary XML index.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'PXML_Person_AddContact'
GO
SET ANSI_PADDING ON
GO
CREATE PRIMARY XML INDEX [PXML_Person_Demographics]
    ON [Person].[Person] ([Demographics])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary XML index.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'PXML_Person_Demographics'
GO
SET ANSI_PADDING ON
GO
CREATE XML INDEX [XMLPATH_Person_Demographics]
    ON [Person].[Person] ([Demographics])
    USING XML INDEX [PXML_Person_Demographics]
    FOR PATH
GO
EXEC sp_addextendedproperty N'MS_Description', N'Secondary XML index for path.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'XMLPATH_Person_Demographics'
GO
SET ANSI_PADDING ON
GO
CREATE XML INDEX [XMLPROPERTY_Person_Demographics]
    ON [Person].[Person] ([Demographics])
    USING XML INDEX [PXML_Person_Demographics]
    FOR PROPERTY
GO
EXEC sp_addextendedproperty N'MS_Description', N'Secondary XML index for property.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'XMLPROPERTY_Person_Demographics'
GO
SET ANSI_PADDING ON
GO
CREATE XML INDEX [XMLVALUE_Person_Demographics]
    ON [Person].[Person] ([Demographics])
    USING XML INDEX [PXML_Person_Demographics]
    FOR VALUE
GO
EXEC sp_addextendedproperty N'MS_Description', N'Secondary XML index for value.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'INDEX', N'XMLVALUE_Person_Demographics'
GO

Collapse image See also

List of tables


Person_json

Table: AdventureWorks2016CTP3.Person.Person_json

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1534628510
Located on | PRIMARY
Data size KB | 1624 KB
Index size KB | 16 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Person_json_PersonID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | PersonID |  |  | int | 4 |  |  |  |
 |  | PersonType |  |  | nchar | 2 |  |  |  |
 |  | NameStyle |  |  | NameStyle | 1 |  | ((0)) |  |
 |  | Title |  |  | nvarchar | 8 |  |  |  |
 |  | FirstName |  |  | Name | 50 |  |  |  |
 |  | MiddleName |  |  | Name | 50 |  |  |  |
 |  | LastName |  |  | Name | 50 |  |  |  |
 |  | Suffix |  |  | nvarchar | 10 |  |  |  |
 |  | EmailPromotion |  |  | int | 4 |  | ((0)) |  |
 |  | AdditionalContactInfo |  |  | nvarchar | 1073741823 |  |  |  |
 |  | Demographics |  |  | nvarchar | 1073741823 |  |  |  |
 |  | rowguid |  |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate |  |  | datetime | 8 |  | (getdate()) |  |
Total: 13 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PersonType | nchar(2) | 2 | 2 | 2 | 0.50000000000000
Title | nvarchar(8) | 0 | 2 | 4 | 0.25000000000000
FirstName | nvarchar(50) | 5 | 2 | 24 | 0.24000000000000
MiddleName | nvarchar(50) | 0 | 1 | 16 | 0.16000000000000
LastName | nvarchar(50) | 5 | 2 | 22 | 0.22000000000000
Suffix | nvarchar(10) | 0 | 2 | 3 | 0.15000000000000
AdditionalContactInfo | nvarchar(max) | 0 | 0 | 0 | 0
Demographics | nvarchar(max) | 0 | 0 | 0 | 0
Total: 8 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Person_json_PersonID | PersonID |  |  |  | 1640 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
AdditionalContactInfo must be formatted as JSON | (isjson([AdditionalContactInfo])>(0))
Demographics must be formatted as JSON | (isjson([Demographics])>(0))

Collapse image Identity column

Name | Seed | Increment | Not for replication
PersonID | 1 | 1 |

Collapse image Objects that Person.Person_json depends on

Object name | Object type | Dep level
Person | Schema | 1
dbo.isjson | Unknown | 1
Name | Datatype | 1
NameStyle | Datatype | 1
Total 4 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Person_json] (
        [PersonID]                  [int] IDENTITY(1, 1) NOT FOR REPLICATION NOT NULL,
        [PersonType]                [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [NameStyle]                 [dbo].[NameStyle] NOT NULL,
        [Title]                     [nvarchar](8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [FirstName]                 [dbo].[Name] NOT NULL,
        [MiddleName]                [dbo].[Name] NULL,
        [LastName]                  [dbo].[Name] NOT NULL,
        [Suffix]                    [nvarchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [EmailPromotion]            [int] NOT NULL,
        [AdditionalContactInfo]     [nvarchar](max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Demographics]              [nvarchar](max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [rowguid]                   [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]              [datetime] NOT NULL,
        CONSTRAINT [PK_Person_json_PersonID]
        PRIMARY KEY
        CLUSTERED
        ([PersonID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [AdditionalContactInfo must be formatted as JSON]
    CHECK
    (isjson([AdditionalContactInfo])>(0))
GO
ALTER TABLE [Person].[Person_json]
CHECK CONSTRAINT [AdditionalContactInfo must be formatted as JSON]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [Demographics must be formatted as JSON]
    CHECK
    (isjson([Demographics])>(0))
GO
ALTER TABLE [Person].[Person_json]
CHECK CONSTRAINT [Demographics must be formatted as JSON]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [DF__Person_js__Email__5E54FF49]
    DEFAULT ((0)) FOR [EmailPromotion]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [DF__Person_js__Modif__6225902D]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [DF__Person_js__NameS__5D60DB10]
    DEFAULT ((0)) FOR [NameStyle]
GO
ALTER TABLE [Person].[Person_json]
    ADD
    CONSTRAINT [DF__Person_js__rowgu__61316BF4]
    DEFAULT (newid()) FOR [rowguid]
GO

Collapse image See also

List of tables


Person_Temporal

Table: AdventureWorks2016CTP3.Person.Person_Temporal

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1822629536
Located on | PRIMARY
Data size KB | 1464 KB
Index size KB | 16 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Person_Temporal_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | BusinessEntityID |  |  | int | 4 |  |  |  |
 | PersonType |  |  | nchar | 2 |  |  |  |
 | NameStyle |  |  | NameStyle | 1 |  |  |  |
 | Title |  |  | nvarchar | 8 |  |  |  |
 | FirstName |  |  | Name | 50 |  |  |  |
 | MiddleName |  |  | Name | 50 |  |  |  |
 | LastName |  |  | Name | 50 |  |  |  |
 | Suffix |  |  | nvarchar | 10 |  |  |  |
 | EmailPromotion |  |  | int | 4 |  |  |  |
 | ValidFrom |  |  | datetime2 | 8 |  |  |  |
 | ValidTo |  |  | datetime2 | 8 |  |  |  |
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PersonType | nchar(2) | 2 | 2 | 2 | 0.50000000000000
Title | nvarchar(8) | 0 | 2 | 4 | 0.25000000000000
FirstName | nvarchar(50) | 5 | 2 | 24 | 0.24000000000000
MiddleName | nvarchar(50) | 0 | 1 | 16 | 0.16000000000000
LastName | nvarchar(50) | 5 | 2 | 22 | 0.22000000000000
Suffix | nvarchar(10) | 0 | 2 | 3 | 0.15000000000000
Total: 6 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Person_Temporal_BusinessEntityID | BusinessEntityID |  |  |  | 1480 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Objects that depend on Person.Person_Temporal

Object name | Object type | Dep level
Person.sp_DeletePerson_Temporal | Procedure | 1
Person.sp_UpdatePerson_Temporal | Procedure | 1
HumanResources.vEmployeePersonTemporalInfo | View | 1
Total 3 object(s)

Collapse image Objects that Person.Person_Temporal depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
NameStyle | Datatype | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Person_Temporal] (
        [BusinessEntityID]     [int] NOT NULL,
        [PersonType]           [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [NameStyle]            [dbo].[NameStyle] NOT NULL,
        [Title]                [nvarchar](8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [FirstName]            [dbo].[Name] NOT NULL,
        [MiddleName]           [dbo].[Name] NULL,
        [LastName]             [dbo].[Name] NOT NULL,
        [Suffix]               [nvarchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [EmailPromotion]       [int] NOT NULL,
        [ValidFrom]            [datetime2](7) NOT NULL,
        [ValidTo]              [datetime2](7) NOT NULL,
        CONSTRAINT [PK_Person_Temporal_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO

Collapse image See also

List of tables


Person_Temporal_History

Table: AdventureWorks2016CTP3.Person.Person_Temporal_History

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1854629650
Located on | PRIMARY
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key |
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
BusinessEntityID |  |  | int | 4 |  |  |  |
PersonType |  |  | nchar | 2 |  |  |  |
NameStyle |  |  | NameStyle | 1 |  |  |  |
Title |  |  | nvarchar | 8 |  |  |  |
FirstName |  |  | Name | 50 |  |  |  |
MiddleName |  |  | Name | 50 |  |  |  |
LastName |  |  | Name | 50 |  |  |  |
Suffix |  |  | nvarchar | 10 |  |  |  |
EmailPromotion |  |  | int | 4 |  |  |  |
ValidFrom |  |  | datetime2 | 8 |  |  |  |
ValidTo |  |  | datetime2 | 8 |  |  |  |
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PersonType | nchar(2) | 0 | 0 | 0 | 0
Title | nvarchar(8) | 0 | 0 | 0 | 0
FirstName | nvarchar(50) | 0 | 0 | 0 | 0
MiddleName | nvarchar(50) | 0 | 0 | 0 | 0
LastName | nvarchar(50) | 0 | 0 | 0 | 0
Suffix | nvarchar(10) | 0 | 0 | 0 | 0
Total: 6 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ix_Person_Temporal_History | BusinessEntityID |  |  |  | 0 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Objects that Person.Person_Temporal_History depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
NameStyle | Datatype | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[Person_Temporal_History] (
        [BusinessEntityID]     [int] NOT NULL,
        [PersonType]           [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [NameStyle]            [dbo].[NameStyle] NOT NULL,
        [Title]                [nvarchar](8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [FirstName]            [dbo].[Name] NOT NULL,
        [MiddleName]           [dbo].[Name] NULL,
        [LastName]             [dbo].[Name] NOT NULL,
        [Suffix]               [nvarchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [EmailPromotion]       [int] NOT NULL,
        [ValidFrom]            [datetime2](7) NOT NULL,
        [ValidTo]              [datetime2](7) NOT NULL
) ON [PRIMARY]
GO
CREATE CLUSTERED INDEX [ix_Person_Temporal_History]
    ON [Person].[Person_Temporal_History] ([BusinessEntityID], [ValidFrom], [ValidTo])
    WITH (     DATA_COMPRESSION = PAGE)
    ON [PRIMARY]
GO

Collapse image See also

List of tables


PersonPhone

Table: AdventureWorks2016CTP3.Person.PersonPhone

Collapse image Description

Telephone number and type of a person.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 82099333
Located on | PRIMARY
Data size KB | 1184 KB
Index size KB | 992 KB
Rows | 19972
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_PersonPhone_BusinessEntityID_PhoneNumber_PhoneNumberTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Business entity identification number. Foreign key to Person.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key |  | PhoneNumber | Telephone number identification number. |  | Phone | 25 |  |  |  |
Primary key | Foreign key | PhoneNumberTypeID | Kind of phone number. Foreign key to PhoneNumberType.PhoneNumberTypeID. |  | int | 4 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PhoneNumber | nvarchar(25) | 15 | 12 | 19 | 0.38000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_PersonPhone_BusinessEntityID_PhoneNumber_PhoneNumberTypeID | BusinessEntityID | Primary key (clustered) constraint |  |  | 2176 | 0
IX_PersonPhone_PhoneNumber | PhoneNumber | Nonclustered index. |  |  | 976 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Person | PK_Person_BusinessEntityID | FK_PersonPhone_Person_BusinessEntityID
Person.PhoneNumberType | PK_PhoneNumberType_PhoneNumberTypeID | FK_PersonPhone_PhoneNumberType_PhoneNumberTypeID
Total: 2 table(s)

Collapse image Objects that depend on Person.PersonPhone

Object name | Object type | Dep level
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 5 object(s)

Collapse image Objects that Person.PersonPhone depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person | Table | 1
Person.PhoneNumberType | Table | 1
Phone | Datatype | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Telephone number and type of a person.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[PersonPhone] (
        [BusinessEntityID]      [int] NOT NULL,
        [PhoneNumber]           [dbo].[Phone] NOT NULL,
        [PhoneNumberTypeID]     [int] NOT NULL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_PersonPhone_BusinessEntityID_PhoneNumber_PhoneNumberTypeID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [PhoneNumber], [PhoneNumberTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'CONSTRAINT', N'PK_PersonPhone_BusinessEntityID_PhoneNumber_PhoneNumberTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'INDEX', N'PK_PersonPhone_BusinessEntityID_PhoneNumber_PhoneNumberTypeID'
GO
ALTER TABLE [Person].[PersonPhone]
    ADD
    CONSTRAINT [DF_PersonPhone_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
ALTER TABLE [Person].[PersonPhone]
    WITH CHECK
    ADD CONSTRAINT [FK_PersonPhone_Person_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Person].[PersonPhone]
    CHECK CONSTRAINT [FK_PersonPhone_Person_BusinessEntityID]

GO
ALTER TABLE [Person].[PersonPhone]
    WITH CHECK
    ADD CONSTRAINT [FK_PersonPhone_PhoneNumberType_PhoneNumberTypeID]
    FOREIGN KEY ([PhoneNumberTypeID]) REFERENCES [Person].[PhoneNumberType] ([PhoneNumberTypeID])
ALTER TABLE [Person].[PersonPhone]
    CHECK CONSTRAINT [FK_PersonPhone_PhoneNumberType_PhoneNumberTypeID]

GO
CREATE NONCLUSTERED INDEX [IX_PersonPhone_PhoneNumber]
    ON [Person].[PersonPhone] ([PhoneNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'INDEX', N'IX_PersonPhone_PhoneNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Business entity identification number. Foreign key to Person.BusinessEntityID.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Telephone number identification number.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'COLUMN', N'PhoneNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Kind of phone number. Foreign key to PhoneNumberType.PhoneNumberTypeID.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', 'COLUMN', N'PhoneNumberTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Telephone number and type of a person.', 'SCHEMA', N'Person', 'TABLE', N'PersonPhone', NULL, NULL
GO

Collapse image See also

List of tables


PhoneNumberType

Table: AdventureWorks2016CTP3.Person.PhoneNumberType

Collapse image Description

Type of phone number of a person.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 16.11.2015
ID | 1885249771
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 3
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_PhoneNumberType_PhoneNumberTypeID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | PhoneNumberTypeID | Primary key for telephone number type records. |  | int | 4 |  |  |  |
 |  | Name | Name of the telephone number type |  | Name | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 4 | 4 | 4 | 0.04000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_PhoneNumberType_PhoneNumberTypeID | PhoneNumberTypeID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
PhoneNumberTypeID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.PersonPhone | FK_PersonPhone_PhoneNumberType_PhoneNumberTypeID | PK_PhoneNumberType_PhoneNumberTypeID
Total: 1 table(s)

Collapse image Objects that depend on Person.PhoneNumberType

Object name | Object type | Dep level
Person.PersonPhone | Table | 1
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Sales.vStoreWithContacts | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 6 object(s)

Collapse image Objects that Person.PhoneNumberType depends on

Object name | Object type | Dep level
Person | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Type of phone number of a person.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[PhoneNumberType] (
        [PhoneNumberTypeID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]                  [dbo].[Name] NOT NULL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_PhoneNumberType_PhoneNumberTypeID]
        PRIMARY KEY
        CLUSTERED
        ([PhoneNumberTypeID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', 'CONSTRAINT', N'PK_PhoneNumberType_PhoneNumberTypeID'
GO
ALTER TABLE [Person].[PhoneNumberType]
    ADD
    CONSTRAINT [DF_PhoneNumberType_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', 'CONSTRAINT', N'DF_PhoneNumberType_ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the telephone number type', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for telephone number type records.', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', 'COLUMN', N'PhoneNumberTypeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Type of phone number of a person.', 'SCHEMA', N'Person', 'TABLE', N'PhoneNumberType', NULL, NULL
GO

Collapse image See also

List of tables


StateProvince

Table: AdventureWorks2016CTP3.Person.StateProvince

Collapse image Description

State and province lookup table.

Collapse image Table properties

Name | Value
Schema | Person
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 782625831
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 64 KB
Rows | 181
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_StateProvince_StateProvinceID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | StateProvinceID | Primary key for StateProvince records. |  | int | 4 |  |  |  |
 |  |  | StateProvinceCode | ISO standard state or province code. |  | nchar | 3 |  |  |  |
 |  | Foreign key | CountryRegionCode | ISO standard country or region code. Foreign key to CountryRegion.CountryRegionCode. |  | nvarchar | 3 |  |  |  |
 |  |  | IsOnlyStateProvinceFlag | 0 = StateProvinceCode exists. 1 = StateProvinceCode unavailable, using CountryRegionCode. |  | Flag | 1 |  | ((1)) |  |
 |  |  | Name | State or province description. |  | Name | 50 |  |  |  |
 |  | Foreign key | TerritoryID | ID of the territory in which the state or province is located. Foreign key to SalesTerritory.SalesTerritoryID. |  | int | 4 |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 8 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
StateProvinceCode | nchar(3) | 2 | 2 | 3 | 0.50000000000000
CountryRegionCode | nvarchar(3) | 2 | 2 | 2 | 0.33333333333333
Name | nvarchar(50) | 9 | 3 | 24 | 0.24000000000000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_StateProvince_StateProvinceID | StateProvinceID | Primary key (clustered) constraint |  |  | 80 | 0
AK_StateProvince_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_StateProvince_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
AK_StateProvince_StateProvinceCode_CountryRegionCode | StateProvinceCode | Unique nonclustered index. |  |  | 16 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
StateProvinceID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.Address | FK_Address_StateProvince_StateProvinceID | PK_StateProvince_StateProvinceID
Sales.SalesTaxRate | FK_SalesTaxRate_StateProvince_StateProvinceID | PK_StateProvince_StateProvinceID
Total: 2 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.CountryRegion | PK_CountryRegion_CountryRegionCode | FK_StateProvince_CountryRegion_CountryRegionCode
Sales.SalesTerritory | PK_SalesTerritory_TerritoryID | FK_StateProvince_SalesTerritory_TerritoryID
Total: 2 table(s)

Collapse image Objects that depend on Person.StateProvince

Object name | Object type | Dep level
Person.Address | Table | 1
Sales.SalesTaxRate | Table | 1
HumanResources.vEmployee | View | 1
Sales.vIndividualCustomer | View | 1
Sales.vSalesPerson | View | 1
Person.vStateProvinceCountryRegion | View | 1
Sales.vStoreWithAddresses | View | 1
Purchasing.vVendorWithAddresses | View | 1
Total 8 object(s)

Collapse image Objects that Person.StateProvince depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.CountryRegion | Table | 1
Sales.SalesTerritory | Table | 1
Flag | Datatype | 1
Name | Datatype | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | State and province lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Person].[StateProvince] (
        [StateProvinceID]             [int] IDENTITY(1, 1) NOT NULL,
        [StateProvinceCode]           [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [CountryRegionCode]           [nvarchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [IsOnlyStateProvinceFlag]     [dbo].[Flag] NOT NULL,
        [Name]                        [dbo].[Name] NOT NULL,
        [TerritoryID]                 [int] NOT NULL,
        [rowguid]                     [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]                [datetime] NOT NULL,
        CONSTRAINT [PK_StateProvince_StateProvinceID]
        PRIMARY KEY
        CLUSTERED
        ([StateProvinceID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'PK_StateProvince_StateProvinceID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'INDEX', N'PK_StateProvince_StateProvinceID'
GO
ALTER TABLE [Person].[StateProvince]
    ADD
    CONSTRAINT [DF_StateProvince_IsOnlyStateProvinceFlag]
    DEFAULT ((1)) FOR [IsOnlyStateProvinceFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1 (TRUE)', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'DF_StateProvince_IsOnlyStateProvinceFlag'
GO
ALTER TABLE [Person].[StateProvince]
    ADD
    CONSTRAINT [DF_StateProvince_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'DF_StateProvince_ModifiedDate'
GO
ALTER TABLE [Person].[StateProvince]
    ADD
    CONSTRAINT [DF_StateProvince_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'DF_StateProvince_rowguid'
GO
ALTER TABLE [Person].[StateProvince]
    WITH CHECK
    ADD CONSTRAINT [FK_StateProvince_CountryRegion_CountryRegionCode]
    FOREIGN KEY ([CountryRegionCode]) REFERENCES [Person].[CountryRegion] ([CountryRegionCode])
ALTER TABLE [Person].[StateProvince]
    CHECK CONSTRAINT [FK_StateProvince_CountryRegion_CountryRegionCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CountryRegion.CountryRegionCode.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'FK_StateProvince_CountryRegion_CountryRegionCode'
GO
ALTER TABLE [Person].[StateProvince]
    WITH CHECK
    ADD CONSTRAINT [FK_StateProvince_SalesTerritory_TerritoryID]
    FOREIGN KEY ([TerritoryID]) REFERENCES [Sales].[SalesTerritory] ([TerritoryID])
ALTER TABLE [Person].[StateProvince]
    CHECK CONSTRAINT [FK_StateProvince_SalesTerritory_TerritoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesTerritory.TerritoryID.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'CONSTRAINT', N'FK_StateProvince_SalesTerritory_TerritoryID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_StateProvince_Name]
    ON [Person].[StateProvince] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'INDEX', N'AK_StateProvince_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_StateProvince_rowguid]
    ON [Person].[StateProvince] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'INDEX', N'AK_StateProvince_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_StateProvince_StateProvinceCode_CountryRegionCode]
    ON [Person].[StateProvince] ([StateProvinceCode], [CountryRegionCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'INDEX', N'AK_StateProvince_StateProvinceCode_CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO standard country or region code. Foreign key to CountryRegion.CountryRegionCode. ', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = StateProvinceCode exists. 1 = StateProvinceCode unavailable, using CountryRegionCode.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'IsOnlyStateProvinceFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'State or province description.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO standard state or province code.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'StateProvinceCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for StateProvince records.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'StateProvinceID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ID of the territory in which the state or province is located. Foreign key to SalesTerritory.SalesTerritoryID.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'State and province lookup table.', 'SCHEMA', N'Person', 'TABLE', N'StateProvince', NULL, NULL
GO

Collapse image See also

List of tables


BillOfMaterials

Table: AdventureWorks2016CTP3.Production.BillOfMaterials

Collapse image Description

Items required to make bicycles and bicycle subassemblies. It identifies the heirarchical relationship between a parent product and its components.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 821577965
Located on | PRIMARY
Data size KB | 160 KB
Index size KB | 200 KB
Rows | 2679
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_BillOfMaterials_BillOfMaterialsID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | BillOfMaterialsID | Primary key for BillOfMaterials records. |  | int | 4 |  |  |  |
 |  | Foreign key | ProductAssemblyID | Parent product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  | Foreign key | ComponentID | Component identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  |  | StartDate | Date the component started being used in the assembly item. |  | datetime | 8 |  | (getdate()) |  |
 |  |  | EndDate | Date the component stopped being used in the assembly item. |  | datetime | 8 |  |  |  |
 |  | Foreign key | UnitMeasureCode | Standard code identifying the unit of measure for the quantity. |  | nchar | 3 |  |  |  |
 |  |  | BOMLevel | Indicates the depth the component is from its parent (AssemblyID). |  | smallint | 2 |  |  |  |
 |  |  | PerAssemblyQty | Quantity of the component needed to create the assembly. |  | decimal | 5 |  | ((1.00)) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
UnitMeasureCode | nchar(3) | 2 | 2 | 2 | 0.33333333333333
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_BillOfMaterials_BillOfMaterialsID | BillOfMaterialsID | Primary key (clustered) constraint |  |  | 88 | 0
AK_BillOfMaterials_ProductAssemblyID_ComponentID_StartDate | ProductAssemblyID | Clustered index. |  |  | 360 | 0
IX_BillOfMaterials_UnitMeasureCode | UnitMeasureCode | Nonclustered index. |  |  | 96 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_BillOfMaterials_BOMLevel | ([ProductAssemblyID] IS NULL AND [BOMLevel]=(0) AND [PerAssemblyQty]=(1.00) OR [ProductAssemblyID] IS NOT NULL AND [BOMLevel]>=(1))
CK_BillOfMaterials_EndDate | ([EndDate]>[StartDate] OR [EndDate] IS NULL)
CK_BillOfMaterials_PerAssemblyQty | ([PerAssemblyQty]>=(1.00))
CK_BillOfMaterials_ProductAssemblyID | ([ProductAssemblyID]<>[ComponentID])

Collapse image Identity column

Name | Seed | Increment | Not for replication
BillOfMaterialsID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_BillOfMaterials_Product_ComponentID
Production.Product | PK_Product_ProductID | FK_BillOfMaterials_Product_ProductAssemblyID
Production.UnitMeasure | PK_UnitMeasure_UnitMeasureCode | FK_BillOfMaterials_UnitMeasure_UnitMeasureCode
Total: 3 table(s)

Collapse image Objects that depend on Production.BillOfMaterials

Object name | Object type | Dep level
uspGetBillOfMaterials | Procedure | 1
uspGetWhereUsedProductID | Procedure | 1
Total 2 object(s)

Collapse image Objects that Production.BillOfMaterials depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Production.UnitMeasure | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Items required to make bicycles and bicycle subassemblies. It identifies the heirarchical relationship between a parent product and its components.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[BillOfMaterials] (
        [BillOfMaterialsID]     [int] IDENTITY(1, 1) NOT NULL,
        [ProductAssemblyID]     [int] NULL,
        [ComponentID]           [int] NOT NULL,
        [StartDate]             [datetime] NOT NULL,
        [EndDate]               [datetime] NULL,
        [UnitMeasureCode]       [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [BOMLevel]              [smallint] NOT NULL,
        [PerAssemblyQty]        [decimal](8, 2) NOT NULL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_BillOfMaterials_BillOfMaterialsID]
        PRIMARY KEY
        NONCLUSTERED
        ([BillOfMaterialsID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'PK_BillOfMaterials_BillOfMaterialsID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'INDEX', N'PK_BillOfMaterials_BillOfMaterialsID'
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [CK_BillOfMaterials_BOMLevel]
    CHECK
    ([ProductAssemblyID] IS NULL AND [BOMLevel]=(0) AND [PerAssemblyQty]=(1.00) OR [ProductAssemblyID] IS NOT NULL AND [BOMLevel]>=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ProductAssemblyID] IS NULL AND [BOMLevel] = (0) AND [PerAssemblyQty] = (1) OR [ProductAssemblyID] IS NOT NULL AND [BOMLevel] >= (1)', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'CK_BillOfMaterials_BOMLevel'
GO
ALTER TABLE [Production].[BillOfMaterials]
CHECK CONSTRAINT [CK_BillOfMaterials_BOMLevel]
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [CK_BillOfMaterials_EndDate]
    CHECK
    ([EndDate]>[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint EndDate] > [StartDate] OR [EndDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'CK_BillOfMaterials_EndDate'
GO
ALTER TABLE [Production].[BillOfMaterials]
CHECK CONSTRAINT [CK_BillOfMaterials_EndDate]
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [CK_BillOfMaterials_PerAssemblyQty]
    CHECK
    ([PerAssemblyQty]>=(1.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [PerAssemblyQty] >= (1.00)', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'CK_BillOfMaterials_PerAssemblyQty'
GO
ALTER TABLE [Production].[BillOfMaterials]
CHECK CONSTRAINT [CK_BillOfMaterials_PerAssemblyQty]
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [CK_BillOfMaterials_ProductAssemblyID]
    CHECK
    ([ProductAssemblyID]<>[ComponentID])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ProductAssemblyID] <> [ComponentID]', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'CK_BillOfMaterials_ProductAssemblyID'
GO
ALTER TABLE [Production].[BillOfMaterials]
CHECK CONSTRAINT [CK_BillOfMaterials_ProductAssemblyID]
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [DF_BillOfMaterials_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'DF_BillOfMaterials_ModifiedDate'
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [DF_BillOfMaterials_PerAssemblyQty]
    DEFAULT ((1.00)) FOR [PerAssemblyQty]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1.0', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'DF_BillOfMaterials_PerAssemblyQty'
GO
ALTER TABLE [Production].[BillOfMaterials]
    ADD
    CONSTRAINT [DF_BillOfMaterials_StartDate]
    DEFAULT (getdate()) FOR [StartDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'DF_BillOfMaterials_StartDate'
GO
ALTER TABLE [Production].[BillOfMaterials]
    WITH CHECK
    ADD CONSTRAINT [FK_BillOfMaterials_Product_ComponentID]
    FOREIGN KEY ([ComponentID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[BillOfMaterials]
    CHECK CONSTRAINT [FK_BillOfMaterials_Product_ComponentID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ComponentID.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'FK_BillOfMaterials_Product_ComponentID'
GO
ALTER TABLE [Production].[BillOfMaterials]
    WITH CHECK
    ADD CONSTRAINT [FK_BillOfMaterials_Product_ProductAssemblyID]
    FOREIGN KEY ([ProductAssemblyID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[BillOfMaterials]
    CHECK CONSTRAINT [FK_BillOfMaterials_Product_ProductAssemblyID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductAssemblyID.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'FK_BillOfMaterials_Product_ProductAssemblyID'
GO
ALTER TABLE [Production].[BillOfMaterials]
    WITH CHECK
    ADD CONSTRAINT [FK_BillOfMaterials_UnitMeasure_UnitMeasureCode]
    FOREIGN KEY ([UnitMeasureCode]) REFERENCES [Production].[UnitMeasure] ([UnitMeasureCode])
ALTER TABLE [Production].[BillOfMaterials]
    CHECK CONSTRAINT [FK_BillOfMaterials_UnitMeasure_UnitMeasureCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing UnitMeasure.UnitMeasureCode.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'CONSTRAINT', N'FK_BillOfMaterials_UnitMeasure_UnitMeasureCode'
GO
CREATE UNIQUE CLUSTERED INDEX [AK_BillOfMaterials_ProductAssemblyID_ComponentID_StartDate]
    ON [Production].[BillOfMaterials] ([ProductAssemblyID], [ComponentID], [StartDate])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'INDEX', N'AK_BillOfMaterials_ProductAssemblyID_ComponentID_StartDate'
GO
CREATE NONCLUSTERED INDEX [IX_BillOfMaterials_UnitMeasureCode]
    ON [Production].[BillOfMaterials] ([UnitMeasureCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'INDEX', N'IX_BillOfMaterials_UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for BillOfMaterials records.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'BillOfMaterialsID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Indicates the depth the component is from its parent (AssemblyID).', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'BOMLevel'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Component identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'ComponentID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the component stopped being used in the assembly item.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity of the component needed to create the assembly.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'PerAssemblyQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Parent product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'ProductAssemblyID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the component started being used in the assembly item.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Standard code identifying the unit of measure for the quantity.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', 'COLUMN', N'UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Items required to make bicycles and bicycle subassemblies. It identifies the heirarchical relationship between a parent product and its components.', 'SCHEMA', N'Production', 'TABLE', N'BillOfMaterials', NULL, NULL
GO

Collapse image See also

List of tables


Culture

Table: AdventureWorks2016CTP3.Production.Culture

Collapse image Description

Lookup table containing the languages in which some AdventureWorks data is stored.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1221579390
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 8
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Culture_CultureID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | CultureID | Primary key for Culture records. |  | nchar | 6 |  |  |  |
 | Name | Culture description. |  | Name | 50 |  |  |  |
 | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CultureID | nchar(6) | 2 | 0 | 6 | 0.50000000000000
Name | nvarchar(50) | 10 | 4 | 38 | 0.38000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Culture_CultureID | CultureID | Primary key (clustered) constraint |  |  | 32 | 0
AK_Culture_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductModelProductDescriptionCulture | FK_ProductModelProductDescriptionCulture_Culture_CultureID | PK_Culture_CultureID
Total: 1 table(s)

Collapse image Objects that depend on Production.Culture

Object name | Object type | Dep level
Production.ProductModelProductDescriptionCulture | Table | 1
Total 1 object(s)

Collapse image Objects that Production.Culture depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table containing the languages in which some AdventureWorks data is stored.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Culture] (
        [CultureID]        [nchar](6) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_Culture_CultureID]
        PRIMARY KEY
        CLUSTERED
        ([CultureID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'CONSTRAINT', N'PK_Culture_CultureID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'INDEX', N'PK_Culture_CultureID'
GO
ALTER TABLE [Production].[Culture]
    ADD
    CONSTRAINT [DF_Culture_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'CONSTRAINT', N'DF_Culture_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Culture_Name]
    ON [Production].[Culture] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'INDEX', N'AK_Culture_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Culture records.', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'COLUMN', N'CultureID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Culture description.', 'SCHEMA', N'Production', 'TABLE', N'Culture', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table containing the languages in which some AdventureWorks data is stored.', 'SCHEMA', N'Production', 'TABLE', N'Culture', NULL, NULL
GO

Collapse image See also

List of tables


Document

Table: AdventureWorks2016CTP3.Production.Document

Collapse image Description

Product maintenance documents.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1397580017
Located on | PRIMARY
Data size KB | 336 KB
Index size KB | 176 KB
Rows | 13
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Document_DocumentNode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | DocumentNode | Primary key for Document records. |  | hierarchyid | 892 |  |  |  |  |
 |  | DocumentLevel | Depth in the document hierarchy. | True | smallint | 2 |  |  |  |  | ([DocumentNode].[GetLevel]())
 |  | Title | Title of the document. |  | nvarchar | 50 |  |  |  |  |
 | Foreign key | Owner | Employee who controls the document. Foreign key to Employee.BusinessEntityID |  | int | 4 |  |  |  |  |
 |  | FolderFlag | 0 = This is a folder, 1 = This is a document. |  | bit | 1 |  | ((0)) |  |  |
 |  | FileName | File name of the document |  | nvarchar | 400 |  |  |  |  |
 |  | FileExtension | File extension indicating the document type. For example, .doc or .txt. |  | nvarchar | 8 |  |  |  |  |
 |  | Revision | Revision number of the document. |  | nchar | 5 |  |  |  |  |
 |  | ChangeNumber | Engineering change approval number. |  | int | 4 |  | ((0)) |  |  |
 |  | Status | 1 = Pending approval, 2 = Approved, 3 = Obsolete |  | tinyint | 1 |  |  |  |  |
 |  | DocumentSummary | Document abstract. |  | nvarchar | 1073741823 |  |  |  |  |
 |  | Document | Complete document. |  | varbinary | 2147483647 |  |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Required for FileStream. |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 14 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Title | nvarchar(50) | 21 | 8 | 48 | 0.48000000000000
FileName | nvarchar(400) | 23 | 8 | 52 | 0.06500000000000
FileExtension | nvarchar(8) | 2 | 0 | 4 | 0.25000000000000
Revision | nchar(5) | 1 | 1 | 1 | 0.10000000000000
DocumentSummary | nvarchar(max) | 110 | 206 | 393 | -393.00000000000000
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Document_DocumentNode | DocumentNode | Primary key (clustered) constraint |  |  | 80 | 0
UQ__Document__F73921F79196878C | rowguid |  |  |  | 16 | 0
AK_Document_DocumentLevel_DocumentNode | DocumentLevel | Unique nonclustered index. |  |  | 16 | 0
AK_Document_rowguid | rowguid | Unique nonclustered index. Used to support FileStream. |  |  | 16 | 0
IX_Document_FileName_Revision | FileName | Unique nonclustered index. |  |  | 16 | 0
Total: 5 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Fulltext index

Fulltext index | Description | Size KB
FULLTEXT_INDEX_Document |  | 0

Collapse image Check constraints

Name | Expression
CK_Document_Status | ([Status]>=(1) AND [Status]<=(3))

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductDocument | FK_ProductDocument_Document_DocumentNode | PK_Document_DocumentNode
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_Document_Employee_Owner
Total: 1 table(s)

Collapse image Objects that depend on Production.Document

Object name | Object type | Dep level
Production.ProductDocument | Table | 1
Total 1 object(s)

Collapse image Objects that Production.Document depends on

Object name | Object type | Dep level
AW2014FullTextCatalog | Fulltext Catalog | 1
Production | Schema | 1
HumanResources.Employee | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product maintenance documents.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Document] (
        [DocumentNode]        [hierarchyid] NOT NULL,
        [DocumentLevel]       AS ([DocumentNode].[GetLevel]()),
        [Title]               [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Owner]               [int] NOT NULL,
        [FolderFlag]          [bit] NOT NULL,
        [FileName]            [nvarchar](400) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [FileExtension]       [nvarchar](8) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Revision]            [nchar](5) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ChangeNumber]        [int] NOT NULL,
        [Status]              [tinyint] NOT NULL,
        [DocumentSummary]     [nvarchar](max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Document]            [varbinary](max) NULL,
        [rowguid]             [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [UQ__Document__F73921F79196878C]
        UNIQUE
        NONCLUSTERED
        ([rowguid])
        ON [PRIMARY],
        CONSTRAINT [PK_Document_DocumentNode]
        PRIMARY KEY
        CLUSTERED
        ([DocumentNode])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'PK_Document_DocumentNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'INDEX', N'PK_Document_DocumentNode'
GO
ALTER TABLE [Production].[Document]
    ADD
    CONSTRAINT [CK_Document_Status]
    CHECK
    ([Status]>=(1) AND [Status]<=(3))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Status] BETWEEN (1) AND (3)', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'CK_Document_Status'
GO
ALTER TABLE [Production].[Document]
CHECK CONSTRAINT [CK_Document_Status]
GO
ALTER TABLE [Production].[Document]
    ADD
    CONSTRAINT [DF_Document_ChangeNumber]
    DEFAULT ((0)) FOR [ChangeNumber]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'DF_Document_ChangeNumber'
GO
ALTER TABLE [Production].[Document]
    ADD
    CONSTRAINT [DF_Document_FolderFlag]
    DEFAULT ((0)) FOR [FolderFlag]
GO
ALTER TABLE [Production].[Document]
    ADD
    CONSTRAINT [DF_Document_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'DF_Document_ModifiedDate'
GO
ALTER TABLE [Production].[Document]
    ADD
    CONSTRAINT [DF_Document_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'DF_Document_rowguid'
GO
ALTER TABLE [Production].[Document]
    WITH CHECK
    ADD CONSTRAINT [FK_Document_Employee_Owner]
    FOREIGN KEY ([Owner]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [Production].[Document]
    CHECK CONSTRAINT [FK_Document_Employee_Owner]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.BusinessEntityID.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'CONSTRAINT', N'FK_Document_Employee_Owner'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Document_DocumentLevel_DocumentNode]
    ON [Production].[Document] ([DocumentLevel], [DocumentNode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'INDEX', N'AK_Document_DocumentLevel_DocumentNode'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Document_rowguid]
    ON [Production].[Document] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support FileStream.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'INDEX', N'AK_Document_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_Document_FileName_Revision]
    ON [Production].[Document] ([FileName], [Revision])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'INDEX', N'IX_Document_FileName_Revision'
GO
CREATE FULLTEXT INDEX ON [Production].[Document]
    ([DocumentSummary] LANGUAGE 1033, [Document] TYPE COLUMN [FileExtension] LANGUAGE 1033)
    KEY INDEX [PK_Document_DocumentNode]
    ON (FILEGROUP [PRIMARY], [AW2014FullTextCatalog])
    WITH CHANGE_TRACKING AUTO, STOPLIST SYSTEM
GO
EXEC sp_addextendedproperty N'MS_Description', N'Engineering change approval number.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'ChangeNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Complete document.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'Document'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Depth in the document hierarchy.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'DocumentLevel'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Document records.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'DocumentNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Document abstract.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'DocumentSummary'
GO
EXEC sp_addextendedproperty N'MS_Description', N'File extension indicating the document type. For example, .doc or .txt.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'FileExtension'
GO
EXEC sp_addextendedproperty N'MS_Description', N'File name of the document', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'FileName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = This is a folder, 1 = This is a document.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'FolderFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee who controls the document.  Foreign key to Employee.BusinessEntityID', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'Owner'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Revision number of the document. ', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'Revision'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Required for FileStream.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'1 = Pending approval, 2 = Approved, 3 = Obsolete', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'Status'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Title of the document.', 'SCHEMA', N'Production', 'TABLE', N'Document', 'COLUMN', N'Title'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product maintenance documents.', 'SCHEMA', N'Production', 'TABLE', N'Document', NULL, NULL
GO

Collapse image See also

List of tables


Illustration

Table: AdventureWorks2016CTP3.Production.Illustration

Collapse image Description

Bicycle assembly diagrams.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1877581727
Located on | PRIMARY
Data size KB | 240 KB
Index size KB | 8 KB
Rows | 5
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Illustration_IllustrationID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | IllustrationID | Primary key for Illustration records. |  | int | 4 |  |  |  |
 |  | Diagram | Illustrations used in manufacturing instructions. Stored as XML. |  | xml | 2147483647 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Illustration_IllustrationID | IllustrationID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
IllustrationID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductModelIllustration | FK_ProductModelIllustration_Illustration_IllustrationID | PK_Illustration_IllustrationID
Total: 1 table(s)

Collapse image Objects that depend on Production.Illustration

Object name | Object type | Dep level
Production.ProductModelIllustration | Table | 1
Total 1 object(s)

Collapse image Objects that Production.Illustration depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Bicycle assembly diagrams.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[Illustration] (
        [IllustrationID]     [int] IDENTITY(1, 1) NOT NULL,
        [Diagram]            [xml] NULL,
        [ModifiedDate]       [datetime] NOT NULL,
        CONSTRAINT [PK_Illustration_IllustrationID]
        PRIMARY KEY
        CLUSTERED
        ([IllustrationID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'CONSTRAINT', N'PK_Illustration_IllustrationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'INDEX', N'PK_Illustration_IllustrationID'
GO
ALTER TABLE [Production].[Illustration]
    ADD
    CONSTRAINT [DF_Illustration_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'CONSTRAINT', N'DF_Illustration_ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Illustrations used in manufacturing instructions. Stored as XML.', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'COLUMN', N'Diagram'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Illustration records.', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'COLUMN', N'IllustrationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'Illustration', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Bicycle assembly diagrams.', 'SCHEMA', N'Production', 'TABLE', N'Illustration', NULL, NULL
GO

Collapse image See also

List of tables


Location

Table: AdventureWorks2016CTP3.Production.Location

Collapse image Description

Product inventory and manufacturing locations.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1941581955
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 14
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Location_LocationID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | LocationID | Primary key for Location records. |  | smallint | 2 |  |  |  |
 |  | Name | Location description. |  | Name | 50 |  |  |  |
 |  | CostRate | Standard hourly cost of the manufacturing location. |  | smallmoney | 4 |  | ((0.00)) |  |
 |  | Availability | Work capacity (in hours) of the manufacturing location. |  | decimal | 5 |  | ((0.00)) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 13 | 5 | 22 | 0.22000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Location_LocationID | LocationID | Primary key (clustered) constraint |  |  | 32 | 0
AK_Location_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_Location_Availability | ([Availability]>=(0.00))
CK_Location_CostRate | ([CostRate]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
LocationID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductInventory | FK_ProductInventory_Location_LocationID | PK_Location_LocationID
Production.WorkOrderRouting | FK_WorkOrderRouting_Location_LocationID | PK_Location_LocationID
Total: 2 table(s)

Collapse image Objects that depend on Production.Location

Object name | Object type | Dep level
Production.ProductInventory | Table | 1
Production.WorkOrderRouting | Table | 1
Total 2 object(s)

Collapse image Objects that Production.Location depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product inventory and manufacturing locations.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Location] (
        [LocationID]       [smallint] IDENTITY(1, 1) NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [CostRate]         [smallmoney] NOT NULL,
        [Availability]     [decimal](8, 2) NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_Location_LocationID]
        PRIMARY KEY
        CLUSTERED
        ([LocationID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'PK_Location_LocationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'INDEX', N'PK_Location_LocationID'
GO
ALTER TABLE [Production].[Location]
    ADD
    CONSTRAINT [CK_Location_Availability]
    CHECK
    ([Availability]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Availability] >= (0.00)', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'CK_Location_Availability'
GO
ALTER TABLE [Production].[Location]
CHECK CONSTRAINT [CK_Location_Availability]
GO
ALTER TABLE [Production].[Location]
    ADD
    CONSTRAINT [CK_Location_CostRate]
    CHECK
    ([CostRate]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [CostRate] >= (0.00)', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'CK_Location_CostRate'
GO
ALTER TABLE [Production].[Location]
CHECK CONSTRAINT [CK_Location_CostRate]
GO
ALTER TABLE [Production].[Location]
    ADD
    CONSTRAINT [DF_Location_Availability]
    DEFAULT ((0.00)) FOR [Availability]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.00', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'DF_Location_Availability'
GO
ALTER TABLE [Production].[Location]
    ADD
    CONSTRAINT [DF_Location_CostRate]
    DEFAULT ((0.00)) FOR [CostRate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'DF_Location_CostRate'
GO
ALTER TABLE [Production].[Location]
    ADD
    CONSTRAINT [DF_Location_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'Location', 'CONSTRAINT', N'DF_Location_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Location_Name]
    ON [Production].[Location] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'INDEX', N'AK_Location_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work capacity (in hours) of the manufacturing location.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'COLUMN', N'Availability'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Standard hourly cost of the manufacturing location.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'COLUMN', N'CostRate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Location records.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'COLUMN', N'LocationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Location description.', 'SCHEMA', N'Production', 'TABLE', N'Location', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product inventory and manufacturing locations.', 'SCHEMA', N'Production', 'TABLE', N'Location', NULL, NULL
GO

Collapse image See also

List of tables


Product

Table: AdventureWorks2016CTP3.Production.Product

Collapse image Description

Products sold or used in the manfacturing of sold products.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 146099561
Located on | PRIMARY
Data size KB | 104 KB
Index size KB | 128 KB
Rows | 504
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Product_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | ProductID | Primary key for Product records. |  | int | 4 |  |  |  |
 |  |  | Name | Name of the product. |  | Name | 50 |  |  |  |
 |  |  | ProductNumber | Unique product identification number. |  | nvarchar | 25 |  |  |  |
 |  |  | MakeFlag | 0 = Product is purchased, 1 = Product is manufactured in-house. |  | Flag | 1 |  | ((1)) |  |
 |  |  | FinishedGoodsFlag | 0 = Product is not a salable item. 1 = Product is salable. |  | Flag | 1 |  | ((1)) |  |
 |  |  | Color | Product color. |  | nvarchar | 15 |  |  |  |
 |  |  | SafetyStockLevel | Minimum inventory quantity. |  | smallint | 2 |  |  |  |
 |  |  | ReorderPoint | Inventory level that triggers a purchase order or work order. |  | smallint | 2 |  |  |  |
 |  |  | StandardCost | Standard cost of the product. |  | money | 8 |  |  |  |
 |  |  | ListPrice | Selling price. |  | money | 8 |  |  |  |
 |  |  | Size | Product size. |  | nvarchar | 5 |  |  |  |
 |  | Foreign key | SizeUnitMeasureCode | Unit of measure for Size column. |  | nchar | 3 |  |  |  |
 |  | Foreign key | WeightUnitMeasureCode | Unit of measure for Weight column. |  | nchar | 3 |  |  |  |
 |  |  | Weight | Product weight. |  | decimal | 5 |  |  |  |
 |  |  | DaysToManufacture | Number of days required to manufacture the product. |  | int | 4 |  |  |  |
 |  |  | ProductLine | R = Road, M = Mountain, T = Touring, S = Standard |  | nchar | 2 |  |  |  |
 |  |  | Class | H = High, M = Medium, L = Low |  | nchar | 2 |  |  |  |
 |  |  | Style | W = Womens, M = Mens, U = Universal |  | nchar | 2 |  |  |  |
 |  | Foreign key | ProductSubcategoryID | Product is a member of this product subcategory. Foreign key to ProductSubCategory.ProductSubCategoryID. |  | int | 4 |  |  |  |
 |  | Foreign key | ProductModelID | Product is a member of this product model. Foreign key to ProductModel.ProductModelID. |  | int | 4 |  |  |  |
 |  |  | SellStartDate | Date the product was available for sale. |  | datetime | 8 |  |  |  |
 |  |  | SellEndDate | Date the product was no longer available for sale. |  | datetime | 8 |  |  |  |
 |  |  | DiscontinuedDate | Date the product was discontinued. |  | datetime | 8 |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 25 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 18 | 4 | 32 | 0.32000000000000
ProductNumber | nvarchar(25) | 8 | 7 | 10 | 0.20000000000000
Color | nvarchar(15) | 2 | 3 | 12 | 0.40000000000000
Size | nvarchar(5) | 0 | 1 | 2 | 0.20000000000000
SizeUnitMeasureCode | nchar(3) | 0 | 2 | 2 | 0.33333333333333
WeightUnitMeasureCode | nchar(3) | 0 | 1 | 2 | 0.33333333333333
ProductLine | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Class | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Style | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Total: 9 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Product_ProductID | ProductID | Primary key (clustered) constraint |  |  | 232 | 0
AK_Product_Name | Name | Unique nonclustered index. |  |  | 48 | 0
AK_Product_ProductNumber | ProductNumber | Unique nonclustered index. |  |  | 32 | 0
AK_Product_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 32 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_Product_Class | (upper([Class])='H' OR upper([Class])='M' OR upper([Class])='L' OR [Class] IS NULL)
CK_Product_DaysToManufacture | ([DaysToManufacture]>=(0))
CK_Product_ListPrice | ([ListPrice]>=(0.00))
CK_Product_ProductLine | (upper([ProductLine])='R' OR upper([ProductLine])='M' OR upper([ProductLine])='T' OR upper([ProductLine])='S' OR [ProductLine] IS NULL)
CK_Product_ReorderPoint | ([ReorderPoint]>(0))
CK_Product_SafetyStockLevel | ([SafetyStockLevel]>(0))
CK_Product_SellEndDate | ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
CK_Product_StandardCost | ([StandardCost]>=(0.00))
CK_Product_Style | (upper([Style])='U' OR upper([Style])='M' OR upper([Style])='W' OR [Style] IS NULL)
CK_Product_Weight | ([Weight]>(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.BillOfMaterials | FK_BillOfMaterials_Product_ComponentID | PK_Product_ProductID
Production.BillOfMaterials | FK_BillOfMaterials_Product_ProductAssemblyID | PK_Product_ProductID
Production.ProductCostHistory | FK_ProductCostHistory_Product_ProductID | PK_Product_ProductID
Production.ProductDocument | FK_ProductDocument_Product_ProductID | PK_Product_ProductID
Production.ProductInventory | FK_ProductInventory_Product_ProductID | PK_Product_ProductID
Production.ProductListPriceHistory | FK_ProductListPriceHistory_Product_ProductID | PK_Product_ProductID
Production.ProductProductPhoto | FK_ProductProductPhoto_Product_ProductID | PK_Product_ProductID
Production.ProductReview | FK_ProductReview_Product_ProductID | PK_Product_ProductID
Production.TransactionHistory | FK_TransactionHistory_Product_ProductID | PK_Product_ProductID
Production.WorkOrder | FK_WorkOrder_Product_ProductID | PK_Product_ProductID
Purchasing.ProductVendor | FK_ProductVendor_Product_ProductID | PK_Product_ProductID
Purchasing.PurchaseOrderDetail | FK_PurchaseOrderDetail_Product_ProductID | PK_Product_ProductID
Sales.ShoppingCartItem | FK_ShoppingCartItem_Product_ProductID | PK_Product_ProductID
Sales.SpecialOfferProduct | FK_SpecialOfferProduct_Product_ProductID | PK_Product_ProductID
Total: 14 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.ProductModel | PK_ProductModel_ProductModelID | FK_Product_ProductModel_ProductModelID
Production.ProductSubcategory | PK_ProductSubcategory_ProductSubcategoryID | FK_Product_ProductSubcategory_ProductSubcategoryID
Production.UnitMeasure | PK_UnitMeasure_UnitMeasureCode | FK_Product_UnitMeasure_SizeUnitMeasureCode
Production.UnitMeasure | PK_UnitMeasure_UnitMeasureCode | FK_Product_UnitMeasure_WeightUnitMeasureCode
Total: 4 table(s)

Collapse image Objects that depend on Production.Product

Object name | Object type | Dep level
uspGetBillOfMaterials | Procedure | 1
uspGetWhereUsedProductID | Procedure | 1
Production.BillOfMaterials | Table | 1
Production.ProductCostHistory | Table | 1
Production.ProductDocument | Table | 1
Production.ProductInventory | Table | 1
Production.ProductListPriceHistory | Table | 1
Production.ProductProductPhoto | Table | 1
Production.ProductReview | Table | 1
Purchasing.ProductVendor | Table | 1
Purchasing.PurchaseOrderDetail | Table | 1
Sales.ShoppingCartItem | Table | 1
Sales.SpecialOfferProduct | Table | 1
Production.TransactionHistory | Table | 1
Production.WorkOrder | Table | 1
ufnGetProductDealerPrice | Function | 1
ufnGetProductListPrice | Function | 1
ufnGetProductStandardCost | Function | 1
Production.vProductAndDescription | View | 1
Total 19 object(s)

Collapse image Objects that Production.Product depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.ProductModel | Table | 1
Production.ProductSubcategory | Table | 1
Production.UnitMeasure | Table | 1
Flag | Datatype | 1
Name | Datatype | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Products sold or used in the manfacturing of sold products.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Product] (
        [ProductID]                 [int] IDENTITY(1, 1) NOT NULL,
        [Name]                      [dbo].[Name] NOT NULL,
        [ProductNumber]             [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MakeFlag]                  [dbo].[Flag] NOT NULL,
        [FinishedGoodsFlag]         [dbo].[Flag] NOT NULL,
        [Color]                     [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SafetyStockLevel]          [smallint] NOT NULL,
        [ReorderPoint]              [smallint] NOT NULL,
        [StandardCost]              [money] NOT NULL,
        [ListPrice]                 [money] NOT NULL,
        [Size]                      [nvarchar](5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SizeUnitMeasureCode]       [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [WeightUnitMeasureCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Weight]                    [decimal](8, 2) NULL,
        [DaysToManufacture]         [int] NOT NULL,
        [ProductLine]               [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Class]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Style]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ProductSubcategoryID]      [int] NULL,
        [ProductModelID]            [int] NULL,
        [SellStartDate]             [datetime] NOT NULL,
        [SellEndDate]               [datetime] NULL,
        [DiscontinuedDate]          [datetime] NULL,
        [rowguid]                   [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]              [datetime] NOT NULL,
        CONSTRAINT [PK_Product_ProductID]
        PRIMARY KEY
        CLUSTERED
        ([ProductID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'PK_Product_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'INDEX', N'PK_Product_ProductID'
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_Class]
    CHECK
    (upper([Class])='H' OR upper([Class])='M' OR upper([Class])='L' OR [Class] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Class]=''h'' OR [Class]=''m'' OR [Class]=''l'' OR [Class]=''H'' OR [Class]=''M'' OR [Class]=''L'' OR [Class] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_Class'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_Class]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_DaysToManufacture]
    CHECK
    ([DaysToManufacture]>=(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [DaysToManufacture] >= (0)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_DaysToManufacture'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_DaysToManufacture]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_ListPrice]
    CHECK
    ([ListPrice]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ListPrice] >= (0.00)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_ListPrice'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_ListPrice]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_ProductLine]
    CHECK
    (upper([ProductLine])='R' OR upper([ProductLine])='M' OR upper([ProductLine])='T' OR upper([ProductLine])='S' OR [ProductLine] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ProductLine]=''r'' OR [ProductLine]=''m'' OR [ProductLine]=''t'' OR [ProductLine]=''s'' OR [ProductLine]=''R'' OR [ProductLine]=''M'' OR [ProductLine]=''T'' OR [ProductLine]=''S'' OR [ProductLine] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_ProductLine'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_ProductLine]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_ReorderPoint]
    CHECK
    ([ReorderPoint]>(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ReorderPoint] > (0)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_ReorderPoint'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_ReorderPoint]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_SafetyStockLevel]
    CHECK
    ([SafetyStockLevel]>(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SafetyStockLevel] > (0)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_SafetyStockLevel'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_SafetyStockLevel]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_SellEndDate]
    CHECK
    ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SellEndDate] >= [SellStartDate] OR [SellEndDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_SellEndDate'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_SellEndDate]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_StandardCost]
    CHECK
    ([StandardCost]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SafetyStockLevel] > (0)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_StandardCost'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_StandardCost]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_Style]
    CHECK
    (upper([Style])='U' OR upper([Style])='M' OR upper([Style])='W' OR [Style] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Style]=''u'' OR [Style]=''m'' OR [Style]=''w'' OR [Style]=''U'' OR [Style]=''M'' OR [Style]=''W'' OR [Style] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_Style'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_Style]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [CK_Product_Weight]
    CHECK
    ([Weight]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Weight] > (0.00)', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'CK_Product_Weight'
GO
ALTER TABLE [Production].[Product]
CHECK CONSTRAINT [CK_Product_Weight]
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [DF_Product_FinishedGoodsFlag]
    DEFAULT ((1)) FOR [FinishedGoodsFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of  1', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'DF_Product_FinishedGoodsFlag'
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [DF_Product_MakeFlag]
    DEFAULT ((1)) FOR [MakeFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of  1', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'DF_Product_MakeFlag'
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [DF_Product_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'DF_Product_ModifiedDate'
GO
ALTER TABLE [Production].[Product]
    ADD
    CONSTRAINT [DF_Product_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'DF_Product_rowguid'
GO
ALTER TABLE [Production].[Product]
    WITH CHECK
    ADD CONSTRAINT [FK_Product_ProductModel_ProductModelID]
    FOREIGN KEY ([ProductModelID]) REFERENCES [Production].[ProductModel] ([ProductModelID])
ALTER TABLE [Production].[Product]
    CHECK CONSTRAINT [FK_Product_ProductModel_ProductModelID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'FK_Product_ProductModel_ProductModelID'
GO
ALTER TABLE [Production].[Product]
    WITH CHECK
    ADD CONSTRAINT [FK_Product_ProductSubcategory_ProductSubcategoryID]
    FOREIGN KEY ([ProductSubcategoryID]) REFERENCES [Production].[ProductSubcategory] ([ProductSubcategoryID])
ALTER TABLE [Production].[Product]
    CHECK CONSTRAINT [FK_Product_ProductSubcategory_ProductSubcategoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductSubcategory.ProductSubcategoryID.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'FK_Product_ProductSubcategory_ProductSubcategoryID'
GO
ALTER TABLE [Production].[Product]
    WITH CHECK
    ADD CONSTRAINT [FK_Product_UnitMeasure_SizeUnitMeasureCode]
    FOREIGN KEY ([SizeUnitMeasureCode]) REFERENCES [Production].[UnitMeasure] ([UnitMeasureCode])
ALTER TABLE [Production].[Product]
    CHECK CONSTRAINT [FK_Product_UnitMeasure_SizeUnitMeasureCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing UnitMeasure.UnitMeasureCode.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'FK_Product_UnitMeasure_SizeUnitMeasureCode'
GO
ALTER TABLE [Production].[Product]
    WITH CHECK
    ADD CONSTRAINT [FK_Product_UnitMeasure_WeightUnitMeasureCode]
    FOREIGN KEY ([WeightUnitMeasureCode]) REFERENCES [Production].[UnitMeasure] ([UnitMeasureCode])
ALTER TABLE [Production].[Product]
    CHECK CONSTRAINT [FK_Product_UnitMeasure_WeightUnitMeasureCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing UnitMeasure.UnitMeasureCode.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'CONSTRAINT', N'FK_Product_UnitMeasure_WeightUnitMeasureCode'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Product_Name]
    ON [Production].[Product] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'INDEX', N'AK_Product_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Product_ProductNumber]
    ON [Production].[Product] ([ProductNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'INDEX', N'AK_Product_ProductNumber'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Product_rowguid]
    ON [Production].[Product] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'INDEX', N'AK_Product_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'H = High, M = Medium, L = Low', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Class'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product color.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Color'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Number of days required to manufacture the product.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'DaysToManufacture'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the product was discontinued.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'DiscontinuedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Product is not a salable item. 1 = Product is salable.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'FinishedGoodsFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Selling price.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ListPrice'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Product is purchased, 1 = Product is manufactured in-house.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'MakeFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the product.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Product records.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'R = Road, M = Mountain, T = Touring, S = Standard', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ProductLine'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product is a member of this product model. Foreign key to ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique product identification number.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ProductNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product is a member of this product subcategory. Foreign key to ProductSubCategory.ProductSubCategoryID. ', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ProductSubcategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Inventory level that triggers a purchase order or work order. ', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'ReorderPoint'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Minimum inventory quantity. ', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'SafetyStockLevel'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the product was no longer available for sale.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'SellEndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the product was available for sale.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'SellStartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product size.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Size'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unit of measure for Size column.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'SizeUnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Standard cost of the product.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'StandardCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'W = Womens, M = Mens, U = Universal', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Style'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product weight.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'Weight'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unit of measure for Weight column.', 'SCHEMA', N'Production', 'TABLE', N'Product', 'COLUMN', N'WeightUnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Products sold or used in the manfacturing of sold products.', 'SCHEMA', N'Production', 'TABLE', N'Product', NULL, NULL
GO

Collapse image See also

List of tables


Product_inmem

Table: AdventureWorks2016CTP3.Production.Product_inmem

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 2039678314
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [IMPK_Product_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductID |  |  | int | 4 |  |  |  |
 |  | Name |  |  | nvarchar | 50 |  |  |  |
 |  | ProductNumber |  |  | nvarchar | 25 |  |  |  |
 |  | MakeFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | FinishedGoodsFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | Color |  |  | nvarchar | 15 |  |  |  |
 |  | SafetyStockLevel |  |  | smallint | 2 |  |  |  |
 |  | ReorderPoint |  |  | smallint | 2 |  |  |  |
 |  | StandardCost |  |  | money | 8 |  |  |  |
 |  | ListPrice |  |  | money | 8 |  |  |  |
 |  | Size |  |  | nvarchar | 5 |  |  |  |
 |  | SizeUnitMeasureCode |  |  | nchar | 3 |  |  |  |
 |  | WeightUnitMeasureCode |  |  | nchar | 3 |  |  |  |
 |  | Weight |  |  | decimal | 5 |  |  |  |
 |  | DaysToManufacture |  |  | int | 4 |  |  |  |
 |  | ProductLine |  |  | nchar | 2 |  |  |  |
 |  | Class |  |  | nchar | 2 |  |  |  |
 |  | Style |  |  | nchar | 2 |  |  |  |
 |  | ProductSubcategoryID |  |  | int | 4 |  |  |  |
 |  | ProductModelID |  |  | int | 4 |  |  |  |
 |  | SellStartDate |  |  | datetime2 | 8 |  |  |  |
 |  | SellEndDate |  |  | datetime2 | 8 |  |  |  |
 |  | DiscontinuedDate |  |  | datetime2 | 8 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 24 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 18 | 4 | 32 | 0.32000000000000
ProductNumber | nvarchar(25) | 8 | 7 | 10 | 0.20000000000000
Color | nvarchar(15) | 2 | 3 | 12 | 0.40000000000000
Size | nvarchar(5) | 0 | 1 | 2 | 0.20000000000000
SizeUnitMeasureCode | nchar(3) | 0 | 2 | 2 | 0.33333333333333
WeightUnitMeasureCode | nchar(3) | 0 | 1 | 2 | 0.33333333333333
ProductLine | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Class | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Style | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Total: 9 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
IMPK_Product_ProductID | ProductID |  |  |  | 0 | 0
IX_Name | Name |  |  |  | 0 | 0
IX_ProductNumber | ProductNumber |  |  |  | 0 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
IMCK_Product_Class | ([Class]='H' OR [Class]='h' OR [Class]='M' OR [Class]='m' OR [Class]='L' OR [Class]='l' OR [Class] IS NULL)
IMCK_Product_DaysToManufacture | ([DaysToManufacture]>=(0))
IMCK_Product_ListPrice | ([ListPrice]>=(0.00))
IMCK_Product_ProductLine | ([ProductLine]='R' OR [ProductLine]='r' OR [ProductLine]='M' OR [ProductLine]='m' OR [ProductLine]='T' OR [ProductLine]='t' OR [ProductLine]='S' OR [ProductLine]='s' OR [ProductLine] IS NULL)
IMCK_Product_ReorderPoint | ([ReorderPoint]>(0))
IMCK_Product_SafetyStockLevel | ([SafetyStockLevel]>(0))
IMCK_Product_SellEndDate | ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
IMCK_Product_StandardCost | ([StandardCost]>=(0.00))
IMCK_Product_Style | ([Style]='U' OR [Style]='u' OR [Style]='M' OR [Style]='m' OR [Style]='W' OR [Style]='w' OR [Style] IS NULL)
IMCK_Product_Weight | ([Weight]>(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SpecialOfferProduct_inmem | IMFK_SpecialOfferProduct_Product_ProductID | IMPK_Product_ProductID
Total: 1 table(s)

Collapse image Objects that depend on Production.Product_inmem

Object name | Object type | Dep level
Sales.SpecialOfferProduct_inmem | Table | 1
Total 1 object(s)

Collapse image Objects that Production.Product_inmem depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Product_inmem] (
        [ProductID]                 [int] IDENTITY(1, 1) NOT NULL,
        [Name]                      [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ProductNumber]             [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MakeFlag]                  [bit] NOT NULL,
        [FinishedGoodsFlag]         [bit] NOT NULL,
        [Color]                     [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SafetyStockLevel]          [smallint] NOT NULL,
        [ReorderPoint]              [smallint] NOT NULL,
        [StandardCost]              [money] NOT NULL,
        [ListPrice]                 [money] NOT NULL,
        [Size]                      [nvarchar](5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SizeUnitMeasureCode]       [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [WeightUnitMeasureCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Weight]                    [decimal](8, 2) NULL,
        [DaysToManufacture]         [int] NOT NULL,
        [ProductLine]               [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Class]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Style]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ProductSubcategoryID]      [int] NULL,
        [ProductModelID]            [int] NULL,
        [SellStartDate]             [datetime2](7) NOT NULL,
        [SellEndDate]               [datetime2](7) NULL,
        [DiscontinuedDate]          [datetime2](7) NULL,
        [ModifiedDate]              [datetime2](7) NOT NULL,
        CONSTRAINT [IMPK_Product_ProductID]
        PRIMARY KEY
        NONCLUSTERED HASH
        ([ProductID])
        WITH (BUCKET_COUNT=1048576)
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_Class]
    CHECK
    ([Class]='H' OR [Class]='h' OR [Class]='M' OR [Class]='m' OR [Class]='L' OR [Class]='l' OR [Class] IS NULL)
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_Class]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_DaysToManufacture]
    CHECK
    ([DaysToManufacture]>=(0))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_DaysToManufacture]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_ListPrice]
    CHECK
    ([ListPrice]>=(0.00))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_ListPrice]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_ProductLine]
    CHECK
    ([ProductLine]='R' OR [ProductLine]='r' OR [ProductLine]='M' OR [ProductLine]='m' OR [ProductLine]='T' OR [ProductLine]='t' OR [ProductLine]='S' OR [ProductLine]='s' OR [ProductLine] IS NULL)
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_ProductLine]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_ReorderPoint]
    CHECK
    ([ReorderPoint]>(0))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_ReorderPoint]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_SafetyStockLevel]
    CHECK
    ([SafetyStockLevel]>(0))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_SafetyStockLevel]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_SellEndDate]
    CHECK
    ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_SellEndDate]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_StandardCost]
    CHECK
    ([StandardCost]>=(0.00))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_StandardCost]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_Style]
    CHECK
    ([Style]='U' OR [Style]='u' OR [Style]='M' OR [Style]='m' OR [Style]='W' OR [Style]='w' OR [Style] IS NULL)
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_Style]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMCK_Product_Weight]
    CHECK
    ([Weight]>(0.00))
GO
ALTER TABLE [Production].[Product_inmem]
CHECK CONSTRAINT [IMCK_Product_Weight]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMDF_Product_FinishedGoodsFlag]
    DEFAULT ((1)) FOR [FinishedGoodsFlag]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMDF_Product_MakeFlag]
    DEFAULT ((1)) FOR [MakeFlag]
GO
ALTER TABLE [Production].[Product_inmem]
    ADD
    CONSTRAINT [IMDF_Product_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO
CREATE NONCLUSTERED INDEX [IX_Name]
    ON [Production].[Product_inmem] ([Name])
    WITH ( STATISTICS_NORECOMPUTE = ON, ALLOW_ROW_LOCKS = OFF, ALLOW_PAGE_LOCKS = OFF)
GO
CREATE NONCLUSTERED INDEX [IX_ProductNumber]
    ON [Production].[Product_inmem] ([ProductNumber])
    WITH ( STATISTICS_NORECOMPUTE = ON, ALLOW_ROW_LOCKS = OFF, ALLOW_PAGE_LOCKS = OFF)
GO

Collapse image See also

List of tables


Product_ondisk

Table: AdventureWorks2016CTP3.Production.Product_ondisk

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 772197801
Located on | PRIMARY
Data size KB | 96 KB
Index size KB | 96 KB
Rows | 504
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [ODPK_Product_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductID |  |  | int | 4 |  |  |  |
 |  | Name |  |  | nvarchar | 50 |  |  |  |
 |  | ProductNumber |  |  | nvarchar | 25 |  |  |  |
 |  | MakeFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | FinishedGoodsFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | Color |  |  | nvarchar | 15 |  |  |  |
 |  | SafetyStockLevel |  |  | smallint | 2 |  |  |  |
 |  | ReorderPoint |  |  | smallint | 2 |  |  |  |
 |  | StandardCost |  |  | money | 8 |  |  |  |
 |  | ListPrice |  |  | money | 8 |  |  |  |
 |  | Size |  |  | nvarchar | 5 |  |  |  |
 |  | SizeUnitMeasureCode |  |  | nchar | 3 |  |  |  |
 |  | WeightUnitMeasureCode |  |  | nchar | 3 |  |  |  |
 |  | Weight |  |  | decimal | 5 |  |  |  |
 |  | DaysToManufacture |  |  | int | 4 |  |  |  |
 |  | ProductLine |  |  | nchar | 2 |  |  |  |
 |  | Class |  |  | nchar | 2 |  |  |  |
 |  | Style |  |  | nchar | 2 |  |  |  |
 |  | ProductSubcategoryID |  |  | int | 4 |  |  |  |
 |  | ProductModelID |  |  | int | 4 |  |  |  |
 |  | SellStartDate |  |  | datetime2 | 8 |  |  |  |
 |  | SellEndDate |  |  | datetime2 | 8 |  |  |  |
 |  | DiscontinuedDate |  |  | datetime2 | 8 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 24 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 18 | 4 | 32 | 0.32000000000000
ProductNumber | nvarchar(25) | 8 | 7 | 10 | 0.20000000000000
Color | nvarchar(15) | 2 | 3 | 12 | 0.40000000000000
Size | nvarchar(5) | 0 | 1 | 2 | 0.20000000000000
SizeUnitMeasureCode | nchar(3) | 0 | 2 | 2 | 0.33333333333333
WeightUnitMeasureCode | nchar(3) | 0 | 1 | 2 | 0.33333333333333
ProductLine | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Class | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Style | nchar(2) | 0 | 1 | 1 | 0.25000000000000
Total: 9 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ODPK_Product_ProductID | ProductID |  |  |  | 192 | 0
IX_Name | Name |  |  |  | 48 | 0
IX_ProductNumber | ProductNumber |  |  |  | 32 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
ODCK_Product_Class | (upper([Class])='H' OR upper([Class])='M' OR upper([Class])='L' OR [Class] IS NULL)
ODCK_Product_DaysToManufacture | ([DaysToManufacture]>=(0))
ODCK_Product_ListPrice | ([ListPrice]>=(0.00))
ODCK_Product_ProductLine | (upper([ProductLine])='R' OR upper([ProductLine])='M' OR upper([ProductLine])='T' OR upper([ProductLine])='S' OR [ProductLine] IS NULL)
ODCK_Product_ReorderPoint | ([ReorderPoint]>(0))
ODCK_Product_SafetyStockLevel | ([SafetyStockLevel]>(0))
ODCK_Product_SellEndDate | ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
ODCK_Product_StandardCost | ([StandardCost]>=(0.00))
ODCK_Product_Style | (upper([Style])='U' OR upper([Style])='M' OR upper([Style])='W' OR [Style] IS NULL)
ODCK_Product_Weight | ([Weight]>(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SpecialOfferProduct_ondisk | ODFK_SpecialOfferProduct_Product_ProductID | ODPK_Product_ProductID
Total: 1 table(s)

Collapse image Objects that depend on Production.Product_ondisk

Object name | Object type | Dep level
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Sales.SpecialOfferProduct_ondisk | Table | 1
Total 2 object(s)

Collapse image Objects that Production.Product_ondisk depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[Product_ondisk] (
        [ProductID]                 [int] IDENTITY(1, 1) NOT NULL,
        [Name]                      [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ProductNumber]             [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [MakeFlag]                  [bit] NOT NULL,
        [FinishedGoodsFlag]         [bit] NOT NULL,
        [Color]                     [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SafetyStockLevel]          [smallint] NOT NULL,
        [ReorderPoint]              [smallint] NOT NULL,
        [StandardCost]              [money] NOT NULL,
        [ListPrice]                 [money] NOT NULL,
        [Size]                      [nvarchar](5) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [SizeUnitMeasureCode]       [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [WeightUnitMeasureCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Weight]                    [decimal](8, 2) NULL,
        [DaysToManufacture]         [int] NOT NULL,
        [ProductLine]               [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Class]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [Style]                     [nchar](2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ProductSubcategoryID]      [int] NULL,
        [ProductModelID]            [int] NULL,
        [SellStartDate]             [datetime2](7) NOT NULL,
        [SellEndDate]               [datetime2](7) NULL,
        [DiscontinuedDate]          [datetime2](7) NULL,
        [ModifiedDate]              [datetime2](7) NOT NULL,
        CONSTRAINT [ODPK_Product_ProductID]
        PRIMARY KEY
        CLUSTERED
        ([ProductID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_Class]
    CHECK
    (upper([Class])='H' OR upper([Class])='M' OR upper([Class])='L' OR [Class] IS NULL)
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_Class]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_DaysToManufacture]
    CHECK
    ([DaysToManufacture]>=(0))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_DaysToManufacture]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_ListPrice]
    CHECK
    ([ListPrice]>=(0.00))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_ListPrice]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_ProductLine]
    CHECK
    (upper([ProductLine])='R' OR upper([ProductLine])='M' OR upper([ProductLine])='T' OR upper([ProductLine])='S' OR [ProductLine] IS NULL)
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_ProductLine]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_ReorderPoint]
    CHECK
    ([ReorderPoint]>(0))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_ReorderPoint]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_SafetyStockLevel]
    CHECK
    ([SafetyStockLevel]>(0))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_SafetyStockLevel]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_SellEndDate]
    CHECK
    ([SellEndDate]>=[SellStartDate] OR [SellEndDate] IS NULL)
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_SellEndDate]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_StandardCost]
    CHECK
    ([StandardCost]>=(0.00))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_StandardCost]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_Style]
    CHECK
    (upper([Style])='U' OR upper([Style])='M' OR upper([Style])='W' OR [Style] IS NULL)
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_Style]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODCK_Product_Weight]
    CHECK
    ([Weight]>(0.00))
GO
ALTER TABLE [Production].[Product_ondisk]
CHECK CONSTRAINT [ODCK_Product_Weight]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODDF_Product_FinishedGoodsFlag]
    DEFAULT ((1)) FOR [FinishedGoodsFlag]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODDF_Product_MakeFlag]
    DEFAULT ((1)) FOR [MakeFlag]
GO
ALTER TABLE [Production].[Product_ondisk]
    ADD
    CONSTRAINT [ODDF_Product_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO
CREATE NONCLUSTERED INDEX [IX_Name]
    ON [Production].[Product_ondisk] ([Name])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IX_ProductNumber]
    ON [Production].[Product_ondisk] ([ProductNumber])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


ProductCategory

Table: AdventureWorks2016CTP3.Production.ProductCategory

Collapse image Description

High-level product categorization.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 386100416
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 4
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductCategory_ProductCategoryID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductCategoryID | Primary key for ProductCategory records. |  | int | 4 |  |  |  |
 |  | Name | Category description. |  | Name | 50 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 8 | 5 | 11 | 0.11000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductCategory_ProductCategoryID | ProductCategoryID | Primary key (clustered) constraint |  |  | 48 | 0
AK_ProductCategory_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_ProductCategory_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductCategoryID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductSubcategory | FK_ProductSubcategory_ProductCategory_ProductCategoryID | PK_ProductCategory_ProductCategoryID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductCategory

Object name | Object type | Dep level
Production.ProductSubcategory | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ProductCategory depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | High-level product categorization.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductCategory] (
        [ProductCategoryID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]                  [dbo].[Name] NOT NULL,
        [rowguid]               [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_ProductCategory_ProductCategoryID]
        PRIMARY KEY
        CLUSTERED
        ([ProductCategoryID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'CONSTRAINT', N'PK_ProductCategory_ProductCategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'INDEX', N'PK_ProductCategory_ProductCategoryID'
GO
ALTER TABLE [Production].[ProductCategory]
    ADD
    CONSTRAINT [DF_ProductCategory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'CONSTRAINT', N'DF_ProductCategory_ModifiedDate'
GO
ALTER TABLE [Production].[ProductCategory]
    ADD
    CONSTRAINT [DF_ProductCategory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()()', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'CONSTRAINT', N'DF_ProductCategory_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductCategory_Name]
    ON [Production].[ProductCategory] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'INDEX', N'AK_ProductCategory_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductCategory_rowguid]
    ON [Production].[ProductCategory] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'INDEX', N'AK_ProductCategory_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Category description.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductCategory records.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'COLUMN', N'ProductCategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'High-level product categorization.', 'SCHEMA', N'Production', 'TABLE', N'ProductCategory', NULL, NULL
GO

Collapse image See also

List of tables


ProductCostHistory

Table: AdventureWorks2016CTP3.Production.ProductCostHistory

Collapse image Description

Changes in the cost of a product over time.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 434100587
Located on | PRIMARY
Data size KB | 24 KB
Index size KB | 16 KB
Rows | 395
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductCostHistory_ProductID_StartDate]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID |  | int | 4 |  |  |  |
Primary key |  | StartDate | Product cost start date. |  | datetime | 8 |  |  |  |
 |  | EndDate | Product cost end date. |  | datetime | 8 |  |  |  |
 |  | StandardCost | Standard cost of the product. |  | money | 8 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductCostHistory_ProductID_StartDate | ProductID | Primary key (clustered) constraint |  |  | 40 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ProductCostHistory_EndDate | ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
CK_ProductCostHistory_StandardCost | ([StandardCost]>=(0.00))

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ProductCostHistory_Product_ProductID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductCostHistory

Object name | Object type | Dep level
ufnGetProductStandardCost | Function | 1
Total 1 object(s)

Collapse image Objects that Production.ProductCostHistory depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Changes in the cost of a product over time.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[ProductCostHistory] (
        [ProductID]        [int] NOT NULL,
        [StartDate]        [datetime] NOT NULL,
        [EndDate]          [datetime] NULL,
        [StandardCost]     [money] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_ProductCostHistory_ProductID_StartDate]
        PRIMARY KEY
        CLUSTERED
        ([ProductID], [StartDate])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'CONSTRAINT', N'PK_ProductCostHistory_ProductID_StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'INDEX', N'PK_ProductCostHistory_ProductID_StartDate'
GO
ALTER TABLE [Production].[ProductCostHistory]
    ADD
    CONSTRAINT [CK_ProductCostHistory_EndDate]
    CHECK
    ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate] OR [EndDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'CONSTRAINT', N'CK_ProductCostHistory_EndDate'
GO
ALTER TABLE [Production].[ProductCostHistory]
CHECK CONSTRAINT [CK_ProductCostHistory_EndDate]
GO
ALTER TABLE [Production].[ProductCostHistory]
    ADD
    CONSTRAINT [CK_ProductCostHistory_StandardCost]
    CHECK
    ([StandardCost]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [StandardCost] >= (0.00)', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'CONSTRAINT', N'CK_ProductCostHistory_StandardCost'
GO
ALTER TABLE [Production].[ProductCostHistory]
CHECK CONSTRAINT [CK_ProductCostHistory_StandardCost]
GO
ALTER TABLE [Production].[ProductCostHistory]
    ADD
    CONSTRAINT [DF_ProductCostHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'CONSTRAINT', N'DF_ProductCostHistory_ModifiedDate'
GO
ALTER TABLE [Production].[ProductCostHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductCostHistory_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductCostHistory]
    CHECK CONSTRAINT [FK_ProductCostHistory_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'CONSTRAINT', N'FK_ProductCostHistory_Product_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product cost end date.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Standard cost of the product.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'COLUMN', N'StandardCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product cost start date.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Changes in the cost of a product over time.', 'SCHEMA', N'Production', 'TABLE', N'ProductCostHistory', NULL, NULL
GO

Collapse image See also

List of tables


ProductDescription

Table: AdventureWorks2016CTP3.Production.ProductDescription

Collapse image Description

Product descriptions in several languages.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 498100815
Located on | PRIMARY
Data size KB | 144 KB
Index size KB | 56 KB
Rows | 762
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductDescription_ProductDescriptionID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductDescriptionID | Primary key for ProductDescription records. |  | int | 4 |  |  |  |
 |  | Description | Description of the product. |  | nvarchar | 400 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Description | nvarchar(400) | 68 | 3 | 269 | 0.33625000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductDescription_ProductDescriptionID | ProductDescriptionID | Primary key (clustered) constraint |  |  | 200 | 0
AK_ProductDescription_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 40 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductDescriptionID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductModelProductDescriptionCulture | FK_ProductModelProductDescriptionCulture_ProductDescription_ProductDescriptionID | PK_ProductDescription_ProductDescriptionID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductDescription

Object name | Object type | Dep level
Production.ProductModelProductDescriptionCulture | Table | 1
Production.vProductAndDescription | View | 1
Total 2 object(s)

Collapse image Objects that Production.ProductDescription depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product descriptions in several languages.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductDescription] (
        [ProductDescriptionID]     [int] IDENTITY(1, 1) NOT NULL,
        [Description]              [nvarchar](400) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [rowguid]                  [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]             [datetime] NOT NULL,
        CONSTRAINT [PK_ProductDescription_ProductDescriptionID]
        PRIMARY KEY
        CLUSTERED
        ([ProductDescriptionID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'CONSTRAINT', N'PK_ProductDescription_ProductDescriptionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'INDEX', N'PK_ProductDescription_ProductDescriptionID'
GO
ALTER TABLE [Production].[ProductDescription]
    ADD
    CONSTRAINT [DF_ProductDescription_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'CONSTRAINT', N'DF_ProductDescription_ModifiedDate'
GO
ALTER TABLE [Production].[ProductDescription]
    ADD
    CONSTRAINT [DF_ProductDescription_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'CONSTRAINT', N'DF_ProductDescription_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductDescription_rowguid]
    ON [Production].[ProductDescription] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'INDEX', N'AK_ProductDescription_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Description of the product.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'COLUMN', N'Description'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductDescription records.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'COLUMN', N'ProductDescriptionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product descriptions in several languages.', 'SCHEMA', N'Production', 'TABLE', N'ProductDescription', NULL, NULL
GO

Collapse image See also

List of tables


ProductDocument

Table: AdventureWorks2016CTP3.Production.ProductDocument

Collapse image Description

Cross-reference table mapping products to related product documents.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 546100986
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 32
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductDocument_ProductID_DocumentNode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
Primary key | Foreign key | DocumentNode | Document identification number. Foreign key to Document.DocumentNode. |  | hierarchyid | 892 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductDocument_ProductID_DocumentNode | ProductID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Document | PK_Document_DocumentNode | FK_ProductDocument_Document_DocumentNode
Production.Product | PK_Product_ProductID | FK_ProductDocument_Product_ProductID
Total: 2 table(s)

Collapse image Objects that Production.ProductDocument depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Document | Table | 1
Production.Product | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping products to related product documents.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[ProductDocument] (
        [ProductID]        [int] NOT NULL,
        [DocumentNode]     [hierarchyid] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_ProductDocument_ProductID_DocumentNode]
        PRIMARY KEY
        CLUSTERED
        ([ProductID], [DocumentNode])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'CONSTRAINT', N'PK_ProductDocument_ProductID_DocumentNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'INDEX', N'PK_ProductDocument_ProductID_DocumentNode'
GO
ALTER TABLE [Production].[ProductDocument]
    ADD
    CONSTRAINT [DF_ProductDocument_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'CONSTRAINT', N'DF_ProductDocument_ModifiedDate'
GO
ALTER TABLE [Production].[ProductDocument]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductDocument_Document_DocumentNode]
    FOREIGN KEY ([DocumentNode]) REFERENCES [Production].[Document] ([DocumentNode])
ALTER TABLE [Production].[ProductDocument]
    CHECK CONSTRAINT [FK_ProductDocument_Document_DocumentNode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Document.DocumentNode.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'CONSTRAINT', N'FK_ProductDocument_Document_DocumentNode'
GO
ALTER TABLE [Production].[ProductDocument]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductDocument_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductDocument]
    CHECK CONSTRAINT [FK_ProductDocument_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'CONSTRAINT', N'FK_ProductDocument_Product_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Document identification number. Foreign key to Document.DocumentNode.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'COLUMN', N'DocumentNode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping products to related product documents.', 'SCHEMA', N'Production', 'TABLE', N'ProductDocument', NULL, NULL
GO

Collapse image See also

List of tables


ProductInventory

Table: AdventureWorks2016CTP3.Production.ProductInventory

Collapse image Description

Product inventory information.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 578101100
Located on | PRIMARY
Data size KB | 56 KB
Index size KB | 16 KB
Rows | 1069
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductInventory_ProductID_LocationID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
Primary key | Foreign key | LocationID | Inventory location identification number. Foreign key to Location.LocationID. |  | smallint | 2 |  |  |  |
 |  | Shelf | Storage compartment within an inventory location. |  | nvarchar | 10 |  |  |  |
 |  | Bin | Storage container on a shelf in an inventory location. |  | tinyint | 1 |  |  |  |
 |  | Quantity | Quantity of products in the inventory location. |  | smallint | 2 |  | ((0)) |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 7 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Shelf | nvarchar(10) | 1 | 1 | 3 | 0.15000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductInventory_ProductID_LocationID | ProductID | Primary key (clustered) constraint |  |  | 72 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ProductInventory_Bin | ([Bin]>=(0) AND [Bin]<=(100))
CK_ProductInventory_Shelf | ([Shelf] like '[A-Za-z]' OR [Shelf]='N/A')

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Location | PK_Location_LocationID | FK_ProductInventory_Location_LocationID
Production.Product | PK_Product_ProductID | FK_ProductInventory_Product_ProductID
Total: 2 table(s)

Collapse image Objects that depend on Production.ProductInventory

Object name | Object type | Dep level
ufnGetStock | Function | 1
Total 1 object(s)

Collapse image Objects that Production.ProductInventory depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Location | Table | 1
Production.Product | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product inventory information.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductInventory] (
        [ProductID]        [int] NOT NULL,
        [LocationID]       [smallint] NOT NULL,
        [Shelf]            [nvarchar](10) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Bin]              [tinyint] NOT NULL,
        [Quantity]         [smallint] NOT NULL,
        [rowguid]          [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_ProductInventory_ProductID_LocationID]
        PRIMARY KEY
        CLUSTERED
        ([ProductID], [LocationID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'PK_ProductInventory_ProductID_LocationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'INDEX', N'PK_ProductInventory_ProductID_LocationID'
GO
ALTER TABLE [Production].[ProductInventory]
    ADD
    CONSTRAINT [CK_ProductInventory_Bin]
    CHECK
    ([Bin]>=(0) AND [Bin]<=(100))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Bin] BETWEEN (0) AND (100)', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'CK_ProductInventory_Bin'
GO
ALTER TABLE [Production].[ProductInventory]
CHECK CONSTRAINT [CK_ProductInventory_Bin]
GO
ALTER TABLE [Production].[ProductInventory]
    ADD
    CONSTRAINT [CK_ProductInventory_Shelf]
    CHECK
    ([Shelf] like '[A-Za-z]' OR [Shelf]='N/A')
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Shelf] like ''[A-Za-z]'' OR [Shelf]=''N/A''', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'CK_ProductInventory_Shelf'
GO
ALTER TABLE [Production].[ProductInventory]
CHECK CONSTRAINT [CK_ProductInventory_Shelf]
GO
ALTER TABLE [Production].[ProductInventory]
    ADD
    CONSTRAINT [DF_ProductInventory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'DF_ProductInventory_ModifiedDate'
GO
ALTER TABLE [Production].[ProductInventory]
    ADD
    CONSTRAINT [DF_ProductInventory_Quantity]
    DEFAULT ((0)) FOR [Quantity]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'DF_ProductInventory_Quantity'
GO
ALTER TABLE [Production].[ProductInventory]
    ADD
    CONSTRAINT [DF_ProductInventory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'DF_ProductInventory_rowguid'
GO
ALTER TABLE [Production].[ProductInventory]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductInventory_Location_LocationID]
    FOREIGN KEY ([LocationID]) REFERENCES [Production].[Location] ([LocationID])
ALTER TABLE [Production].[ProductInventory]
    CHECK CONSTRAINT [FK_ProductInventory_Location_LocationID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Location.LocationID.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'FK_ProductInventory_Location_LocationID'
GO
ALTER TABLE [Production].[ProductInventory]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductInventory_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductInventory]
    CHECK CONSTRAINT [FK_ProductInventory_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'CONSTRAINT', N'FK_ProductInventory_Product_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Storage container on a shelf in an inventory location.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'Bin'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Inventory location identification number. Foreign key to Location.LocationID. ', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'LocationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity of products in the inventory location.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'Quantity'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Storage compartment within an inventory location.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', 'COLUMN', N'Shelf'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product inventory information.', 'SCHEMA', N'Production', 'TABLE', N'ProductInventory', NULL, NULL
GO

Collapse image See also

List of tables


ProductListPriceHistory

Table: AdventureWorks2016CTP3.Production.ProductListPriceHistory

CollapseAll image

Collapse image Description

Changes in the list price of a product over time.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 674101442
Located on | PRIMARY
Data size KB | 24 KB
Index size KB | 16 KB
Rows | 395
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductListPriceHistory_ProductID_StartDate]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID |  | int | 4 |  |  |  |
Primary key |  | StartDate | List price start date. |  | datetime | 8 |  |  |  |
 |  | EndDate | List price end date |  | datetime | 8 |  |  |  |
 |  | ListPrice | Product list price. |  | money | 8 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductListPriceHistory_ProductID_StartDate | ProductID | Primary key (clustered) constraint |  |  | 40 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ProductListPriceHistory_EndDate | ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
CK_ProductListPriceHistory_ListPrice | ([ListPrice]>(0.00))

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ProductListPriceHistory_Product_ProductID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductListPriceHistory

Object name | Object type | Dep level
ufnGetProductDealerPrice | Function | 1
ufnGetProductListPrice | Function | 1
Total 2 object(s)

Collapse image Objects that Production.ProductListPriceHistory depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Changes in the list price of a product over time.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[ProductListPriceHistory] (
        [ProductID]        [int] NOT NULL,
        [StartDate]        [datetime] NOT NULL,
        [EndDate]          [datetime] NULL,
        [ListPrice]        [money] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_ProductListPriceHistory_ProductID_StartDate]
        PRIMARY KEY
        CLUSTERED
        ([ProductID], [StartDate])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'CONSTRAINT', N'PK_ProductListPriceHistory_ProductID_StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'INDEX', N'PK_ProductListPriceHistory_ProductID_StartDate'
GO
ALTER TABLE [Production].[ProductListPriceHistory]
    ADD
    CONSTRAINT [CK_ProductListPriceHistory_EndDate]
    CHECK
    ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate] OR [EndDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'CONSTRAINT', N'CK_ProductListPriceHistory_EndDate'
GO
ALTER TABLE [Production].[ProductListPriceHistory]
CHECK CONSTRAINT [CK_ProductListPriceHistory_EndDate]
GO
ALTER TABLE [Production].[ProductListPriceHistory]
    ADD
    CONSTRAINT [CK_ProductListPriceHistory_ListPrice]
    CHECK
    ([ListPrice]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ListPrice] > (0.00)', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'CONSTRAINT', N'CK_ProductListPriceHistory_ListPrice'
GO
ALTER TABLE [Production].[ProductListPriceHistory]
CHECK CONSTRAINT [CK_ProductListPriceHistory_ListPrice]
GO
ALTER TABLE [Production].[ProductListPriceHistory]
    ADD
    CONSTRAINT [DF_ProductListPriceHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'CONSTRAINT', N'DF_ProductListPriceHistory_ModifiedDate'
GO
ALTER TABLE [Production].[ProductListPriceHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductListPriceHistory_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductListPriceHistory]
    CHECK CONSTRAINT [FK_ProductListPriceHistory_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'CONSTRAINT', N'FK_ProductListPriceHistory_Product_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'List price end date', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product list price.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'COLUMN', N'ListPrice'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'List price start date.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Changes in the list price of a product over time.', 'SCHEMA', N'Production', 'TABLE', N'ProductListPriceHistory', NULL, NULL
GO

Collapse image See also

List of tables


ProductModel

Table: AdventureWorks2016CTP3.Production.ProductModel

Collapse image Description

Product model classification.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 738101670
Located on | PRIMARY
Data size KB | 144 KB
Index size KB | 216 KB
Rows | 128
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductModel_ProductModelID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductModelID | Primary key for ProductModel records. |  | int | 4 |  |  |  |
 |  | Name | Product model description. |  | Name | 50 |  |  |  |
 |  | CatalogDescription | Detailed product catalog information in xml format. |  | xml(Production.ProductDescriptionSchemaCollection) | 2147483647 |  |  |  |
 |  | Instructions | Manufacturing instructions in xml format. |  | xml(Production.ManuInstructionsSchemaCollection) | 2147483647 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 15 | 5 | 27 | 0.27000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductModel_ProductModelID | ProductModelID | Primary key (clustered) constraint |  |  | 144 | 0
AK_ProductModel_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_ProductModel_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
PXML_ProductModel_CatalogDescription |  | Primary XML index. |  |  | 56 | 0
PXML_ProductModel_Instructions |  | Primary XML index. |  |  | 112 | 0
Total: 5 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductModelID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.Product | FK_Product_ProductModel_ProductModelID | PK_ProductModel_ProductModelID
Production.ProductModelIllustration | FK_ProductModelIllustration_ProductModel_ProductModelID | PK_ProductModel_ProductModelID
Production.ProductModelProductDescriptionCulture | FK_ProductModelProductDescriptionCulture_ProductModel_ProductModelID | PK_ProductModel_ProductModelID
Total: 3 table(s)

Collapse image Objects that depend on Production.ProductModel

Object name | Object type | Dep level
Production.Product | Table | 1
Production.ProductModelIllustration | Table | 1
Production.ProductModelProductDescriptionCulture | Table | 1
Production.vProductAndDescription | View | 1
Production.vProductModelCatalogDescription | View | 1
Production.vProductModelInstructions | View | 1
Total 6 object(s)

Collapse image Objects that Production.ProductModel depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Production.ManuInstructionsSchemaCollection | XML Schema Collection | 1
Production.ProductDescriptionSchemaCollection | XML Schema Collection | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product model classification.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductModel] (
        [ProductModelID]         [int] IDENTITY(1, 1) NOT NULL,
        [Name]                   [dbo].[Name] NOT NULL,
        [CatalogDescription]     [xml](CONTENT [Production].[ProductDescriptionSchemaCollection]) NULL,
        [Instructions]           [xml](CONTENT [Production].[ManuInstructionsSchemaCollection]) NULL,
        [rowguid]                [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]           [datetime] NOT NULL,
        CONSTRAINT [PK_ProductModel_ProductModelID]
        PRIMARY KEY
        CLUSTERED
        ([ProductModelID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'CONSTRAINT', N'PK_ProductModel_ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'INDEX', N'PK_ProductModel_ProductModelID'
GO
ALTER TABLE [Production].[ProductModel]
    ADD
    CONSTRAINT [DF_ProductModel_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'CONSTRAINT', N'DF_ProductModel_ModifiedDate'
GO
ALTER TABLE [Production].[ProductModel]
    ADD
    CONSTRAINT [DF_ProductModel_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'CONSTRAINT', N'DF_ProductModel_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductModel_Name]
    ON [Production].[ProductModel] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'INDEX', N'AK_ProductModel_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductModel_rowguid]
    ON [Production].[ProductModel] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'INDEX', N'AK_ProductModel_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Detailed product catalog information in xml format.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'CatalogDescription'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Manufacturing instructions in xml format.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'Instructions'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product model description.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductModel records.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product model classification.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', NULL, NULL
GO
SET ANSI_PADDING ON
GO
CREATE PRIMARY XML INDEX [PXML_ProductModel_CatalogDescription]
    ON [Production].[ProductModel] ([CatalogDescription])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary XML index.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'INDEX', N'PXML_ProductModel_CatalogDescription'
GO
SET ANSI_PADDING ON
GO
CREATE PRIMARY XML INDEX [PXML_ProductModel_Instructions]
    ON [Production].[ProductModel] ([Instructions])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary XML index.', 'SCHEMA', N'Production', 'TABLE', N'ProductModel', 'INDEX', N'PXML_ProductModel_Instructions'
GO

Collapse image See also

List of tables


ProductModelIllustration

Table: AdventureWorks2016CTP3.Production.ProductModelIllustration

CollapseAll image

Collapse image Description

Cross-reference table mapping product models and illustrations.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 786101841
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 7
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductModelIllustration_ProductModelID_IllustrationID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductModelID | Primary key. Foreign key to ProductModel.ProductModelID. |  | int | 4 |  |  |  |
Primary key | Foreign key | IllustrationID | Primary key. Foreign key to Illustration.IllustrationID. |  | int | 4 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductModelIllustration_ProductModelID_IllustrationID | ProductModelID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Illustration | PK_Illustration_IllustrationID | FK_ProductModelIllustration_Illustration_IllustrationID
Production.ProductModel | PK_ProductModel_ProductModelID | FK_ProductModelIllustration_ProductModel_ProductModelID
Total: 2 table(s)

Collapse image Objects that Production.ProductModelIllustration depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Illustration | Table | 1
Production.ProductModel | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping product models and illustrations.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[ProductModelIllustration] (
        [ProductModelID]     [int] NOT NULL,
        [IllustrationID]     [int] NOT NULL,
        [ModifiedDate]       [datetime] NOT NULL,
        CONSTRAINT [PK_ProductModelIllustration_ProductModelID_IllustrationID]
        PRIMARY KEY
        CLUSTERED
        ([ProductModelID], [IllustrationID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'CONSTRAINT', N'PK_ProductModelIllustration_ProductModelID_IllustrationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'INDEX', N'PK_ProductModelIllustration_ProductModelID_IllustrationID'
GO
ALTER TABLE [Production].[ProductModelIllustration]
    ADD
    CONSTRAINT [DF_ProductModelIllustration_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'CONSTRAINT', N'DF_ProductModelIllustration_ModifiedDate'
GO
ALTER TABLE [Production].[ProductModelIllustration]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductModelIllustration_Illustration_IllustrationID]
    FOREIGN KEY ([IllustrationID]) REFERENCES [Production].[Illustration] ([IllustrationID])
ALTER TABLE [Production].[ProductModelIllustration]
    CHECK CONSTRAINT [FK_ProductModelIllustration_Illustration_IllustrationID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Illustration.IllustrationID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'CONSTRAINT', N'FK_ProductModelIllustration_Illustration_IllustrationID'
GO
ALTER TABLE [Production].[ProductModelIllustration]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductModelIllustration_ProductModel_ProductModelID]
    FOREIGN KEY ([ProductModelID]) REFERENCES [Production].[ProductModel] ([ProductModelID])
ALTER TABLE [Production].[ProductModelIllustration]
    CHECK CONSTRAINT [FK_ProductModelIllustration_ProductModel_ProductModelID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'CONSTRAINT', N'FK_ProductModelIllustration_ProductModel_ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Illustration.IllustrationID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'COLUMN', N'IllustrationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', 'COLUMN', N'ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping product models and illustrations.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelIllustration', NULL, NULL
GO

Collapse image See also

List of tables


ProductModelProductDescriptionCulture

Table: AdventureWorks2016CTP3.Production.ProductModelProductDescriptionCulture

CollapseAll image

Collapse image Description

Cross-reference table mapping product descriptions and the language the description is written in.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 818101955
Located on | PRIMARY
Data size KB | 32 KB
Index size KB | 16 KB
Rows | 762
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductModelProductDescriptionCulture_ProductModelID_ProductDescriptionID_CultureID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductModelID | Primary key. Foreign key to ProductModel.ProductModelID. |  | int | 4 |  |  |  |
Primary key | Foreign key | ProductDescriptionID | Primary key. Foreign key to ProductDescription.ProductDescriptionID. |  | int | 4 |  |  |  |
Primary key | Foreign key | CultureID | Culture identification number. Foreign key to Culture.CultureID. |  | nchar | 6 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CultureID | nchar(6) | 2 | 2 | 6 | 0.50000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductModelProductDescriptionCulture_ProductModelID_ProductDescriptionID_CultureID | ProductModelID | Primary key (clustered) constraint |  |  | 48 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Culture | PK_Culture_CultureID | FK_ProductModelProductDescriptionCulture_Culture_CultureID
Production.ProductDescription | PK_ProductDescription_ProductDescriptionID | FK_ProductModelProductDescriptionCulture_ProductDescription_ProductDescriptionID
Production.ProductModel | PK_ProductModel_ProductModelID | FK_ProductModelProductDescriptionCulture_ProductModel_ProductModelID
Total: 3 table(s)

Collapse image Objects that depend on Production.ProductModelProductDescriptionCulture

Object name | Object type | Dep level
Production.vProductAndDescription | View | 1
Total 1 object(s)

Collapse image Objects that Production.ProductModelProductDescriptionCulture depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Culture | Table | 1
Production.ProductDescription | Table | 1
Production.ProductModel | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping product descriptions and the language the description is written in.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductModelProductDescriptionCulture] (
        [ProductModelID]           [int] NOT NULL,
        [ProductDescriptionID]     [int] NOT NULL,
        [CultureID]                [nchar](6) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ModifiedDate]             [datetime] NOT NULL,
        CONSTRAINT [PK_ProductModelProductDescriptionCulture_ProductModelID_ProductDescriptionID_CultureID]
        PRIMARY KEY
        CLUSTERED
        ([ProductModelID], [ProductDescriptionID], [CultureID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'CONSTRAINT', N'PK_ProductModelProductDescriptionCulture_ProductModelID_ProductDescriptionID_CultureID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'INDEX', N'PK_ProductModelProductDescriptionCulture_ProductModelID_ProductDescriptionID_CultureID'
GO
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    ADD
    CONSTRAINT [DF_ProductModelProductDescriptionCulture_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'CONSTRAINT', N'DF_ProductModelProductDescriptionCulture_ModifiedDate'
GO
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductModelProductDescriptionCulture_Culture_CultureID]
    FOREIGN KEY ([CultureID]) REFERENCES [Production].[Culture] ([CultureID])
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    CHECK CONSTRAINT [FK_ProductModelProductDescriptionCulture_Culture_CultureID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Culture.CultureID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'CONSTRAINT', N'FK_ProductModelProductDescriptionCulture_Culture_CultureID'
GO
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductModelProductDescriptionCulture_ProductDescription_ProductDescriptionID]
    FOREIGN KEY ([ProductDescriptionID]) REFERENCES [Production].[ProductDescription] ([ProductDescriptionID])
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    CHECK CONSTRAINT [FK_ProductModelProductDescriptionCulture_ProductDescription_ProductDescriptionID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductDescription.ProductDescriptionID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'CONSTRAINT', N'FK_ProductModelProductDescriptionCulture_ProductDescription_ProductDescriptionID'
GO
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductModelProductDescriptionCulture_ProductModel_ProductModelID]
    FOREIGN KEY ([ProductModelID]) REFERENCES [Production].[ProductModel] ([ProductModelID])
ALTER TABLE [Production].[ProductModelProductDescriptionCulture]
    CHECK CONSTRAINT [FK_ProductModelProductDescriptionCulture_ProductModel_ProductModelID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'CONSTRAINT', N'FK_ProductModelProductDescriptionCulture_ProductModel_ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Culture identification number. Foreign key to Culture.CultureID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'COLUMN', N'CultureID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to ProductDescription.ProductDescriptionID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'COLUMN', N'ProductDescriptionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to ProductModel.ProductModelID.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', 'COLUMN', N'ProductModelID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping product descriptions and the language the description is written in.', 'SCHEMA', N'Production', 'TABLE', N'ProductModelProductDescriptionCulture', NULL, NULL
GO

Collapse image See also

List of tables


ProductPhoto

Table: AdventureWorks2016CTP3.Production.ProductPhoto

Collapse image Description

Product images.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 850102069
Located on | PRIMARY
Data size KB | 2280 KB
Index size KB | 16 KB
Rows | 101
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductPhoto_ProductPhotoID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ProductPhotoID | Primary key for ProductPhoto records. |  | int | 4 |  |  |  |
 |  | ThumbNailPhoto | Small image of the product. |  | varbinary | 2147483647 |  |  |  |
 |  | ThumbnailPhotoFileName | Small image file name. |  | nvarchar | 50 |  |  |  |
 |  | LargePhoto | Large image of the product. |  | varbinary | 2147483647 |  |  |  |
 |  | LargePhotoFileName | Large image file name. |  | nvarchar | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
ThumbnailPhotoFileName | nvarchar(50) | 23 | 14 | 35 | 0.35000000000000
LargePhotoFileName | nvarchar(50) | 23 | 14 | 35 | 0.35000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductPhoto_ProductPhotoID | ProductPhotoID | Primary key (clustered) constraint |  |  | 416 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductPhotoID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.ProductProductPhoto | FK_ProductProductPhoto_ProductPhoto_ProductPhotoID | PK_ProductPhoto_ProductPhotoID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductPhoto

Object name | Object type | Dep level
Production.ProductProductPhoto | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ProductPhoto depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product images.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductPhoto] (
        [ProductPhotoID]             [int] IDENTITY(1, 1) NOT NULL,
        [ThumbNailPhoto]             [varbinary](max) NULL,
        [ThumbnailPhotoFileName]     [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [LargePhoto]                 [varbinary](max) NULL,
        [LargePhotoFileName]         [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ModifiedDate]               [datetime] NOT NULL,
        CONSTRAINT [PK_ProductPhoto_ProductPhotoID]
        PRIMARY KEY
        CLUSTERED
        ([ProductPhotoID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'CONSTRAINT', N'PK_ProductPhoto_ProductPhotoID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'INDEX', N'PK_ProductPhoto_ProductPhotoID'
GO
ALTER TABLE [Production].[ProductPhoto]
    ADD
    CONSTRAINT [DF_ProductPhoto_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'CONSTRAINT', N'DF_ProductPhoto_ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Large image of the product.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'LargePhoto'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Large image file name.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'LargePhotoFileName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductPhoto records.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'ProductPhotoID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Small image of the product.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'ThumbNailPhoto'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Small image file name.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', 'COLUMN', N'ThumbnailPhotoFileName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product images.', 'SCHEMA', N'Production', 'TABLE', N'ProductPhoto', NULL, NULL
GO

Collapse image See also

List of tables


ProductProductPhoto

Table: AdventureWorks2016CTP3.Production.ProductProductPhoto

Collapse image Description

Cross-reference table mapping products and product photos.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 882102183
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 40 KB
Rows | 504
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductProductPhoto_ProductID_ProductPhotoID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
Primary key | Foreign key | ProductPhotoID | Product photo identification number. Foreign key to ProductPhoto.ProductPhotoID. |  | int | 4 |  |  |  |
 |  | Primary | 0 = Photo is not the principal image. 1 = Photo is the principal image. |  | Flag | 1 |  | ((0)) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductProductPhoto_ProductID_ProductPhotoID | ProductID | Primary key (clustered) constraint |  |  | 32 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ProductProductPhoto_Product_ProductID
Production.ProductPhoto | PK_ProductPhoto_ProductPhotoID | FK_ProductProductPhoto_ProductPhoto_ProductPhotoID
Total: 2 table(s)

Collapse image Objects that Production.ProductProductPhoto depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Production.ProductPhoto | Table | 1
Flag | Datatype | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping products and product photos.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[ProductProductPhoto] (
        [ProductID]          [int] NOT NULL,
        [ProductPhotoID]     [int] NOT NULL,
        [Primary]            [dbo].[Flag] NOT NULL,
        [ModifiedDate]       [datetime] NOT NULL,
        CONSTRAINT [PK_ProductProductPhoto_ProductID_ProductPhotoID]
        PRIMARY KEY
        NONCLUSTERED
        ([ProductID], [ProductPhotoID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'CONSTRAINT', N'PK_ProductProductPhoto_ProductID_ProductPhotoID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'INDEX', N'PK_ProductProductPhoto_ProductID_ProductPhotoID'
GO
ALTER TABLE [Production].[ProductProductPhoto]
    ADD
    CONSTRAINT [DF_ProductProductPhoto_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'CONSTRAINT', N'DF_ProductProductPhoto_ModifiedDate'
GO
ALTER TABLE [Production].[ProductProductPhoto]
    ADD
    CONSTRAINT [DF_ProductProductPhoto_Primary]
    DEFAULT ((0)) FOR [Primary]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0 (FALSE)', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'CONSTRAINT', N'DF_ProductProductPhoto_Primary'
GO
ALTER TABLE [Production].[ProductProductPhoto]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductProductPhoto_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductProductPhoto]
    CHECK CONSTRAINT [FK_ProductProductPhoto_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'CONSTRAINT', N'FK_ProductProductPhoto_Product_ProductID'
GO
ALTER TABLE [Production].[ProductProductPhoto]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductProductPhoto_ProductPhoto_ProductPhotoID]
    FOREIGN KEY ([ProductPhotoID]) REFERENCES [Production].[ProductPhoto] ([ProductPhotoID])
ALTER TABLE [Production].[ProductProductPhoto]
    CHECK CONSTRAINT [FK_ProductProductPhoto_ProductPhoto_ProductPhotoID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductPhoto.ProductPhotoID.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'CONSTRAINT', N'FK_ProductProductPhoto_ProductPhoto_ProductPhotoID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Photo is not the principal image. 1 = Photo is the principal image.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'COLUMN', N'Primary'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product photo identification number. Foreign key to ProductPhoto.ProductPhotoID.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', 'COLUMN', N'ProductPhotoID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping products and product photos.', 'SCHEMA', N'Production', 'TABLE', N'ProductProductPhoto', NULL, NULL
GO

Collapse image See also

List of tables


ProductReview

Table: AdventureWorks2016CTP3.Production.ProductReview

Collapse image Description

Customer reviews of products they have purchased.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 930102354
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 120 KB
Rows | 4
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductReview_ProductReviewID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | ProductReviewID | Primary key for ProductReview records. |  | int | 4 |  |  |  |
 |  | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  |  | ReviewerName | Name of the reviewer. |  | Name | 50 |  |  |  |
 |  |  | ReviewDate | Date review was submitted. |  | datetime | 8 |  | (getdate()) |  |
 |  |  | EmailAddress | Reviewer's e-mail address. |  | nvarchar | 50 |  |  |  |
 |  |  | Rating | Product rating given by the reviewer. Scale is 1 to 5 with 5 as the highest rating. |  | int | 4 |  |  |  |
 |  |  | Comments | Reviewer's comments |  | nvarchar | 3850 |  |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 8 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
ReviewerName | nvarchar(50) | 7 | 4 | 12 | 0.12000000000000
EmailAddress | nvarchar(50) | 24 | 21 | 32 | 0.32000000000000
Comments | nvarchar(3850) | 1230 | 254 | 3812 | 0.49506493506493
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductReview_ProductReviewID | ProductReviewID | Primary key (clustered) constraint |  |  | 72 | 0
IX_ProductReview_ProductID_Name | ProductID | Nonclustered index. |  |  | 40 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Fulltext index

Fulltext index | Description | Size KB
FULLTEXT_INDEX_ProductReview |  | 0

Collapse image Check constraints

Name | Expression
CK_ProductReview_Rating | ([Rating]>=(1) AND [Rating]<=(5))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductReviewID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ProductReview_Product_ProductID
Total: 1 table(s)

Collapse image Objects that Production.ProductReview depends on

Object name | Object type | Dep level
AW2014FullTextCatalog | Fulltext Catalog | 1
Production | Schema | 1
Production.Product | Table | 1
Name | Datatype | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Customer reviews of products they have purchased.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductReview] (
        [ProductReviewID]     [int] IDENTITY(1, 1) NOT NULL,
        [ProductID]           [int] NOT NULL,
        [ReviewerName]        [dbo].[Name] NOT NULL,
        [ReviewDate]          [datetime] NOT NULL,
        [EmailAddress]        [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Rating]              [int] NOT NULL,
        [Comments]            [nvarchar](3850) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [PK_ProductReview_ProductReviewID]
        PRIMARY KEY
        CLUSTERED
        ([ProductReviewID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'CONSTRAINT', N'PK_ProductReview_ProductReviewID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'INDEX', N'PK_ProductReview_ProductReviewID'
GO
ALTER TABLE [Production].[ProductReview]
    ADD
    CONSTRAINT [CK_ProductReview_Rating]
    CHECK
    ([Rating]>=(1) AND [Rating]<=(5))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Rating] BETWEEN (1) AND (5)', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'CONSTRAINT', N'CK_ProductReview_Rating'
GO
ALTER TABLE [Production].[ProductReview]
CHECK CONSTRAINT [CK_ProductReview_Rating]
GO
ALTER TABLE [Production].[ProductReview]
    ADD
    CONSTRAINT [DF_ProductReview_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'CONSTRAINT', N'DF_ProductReview_ModifiedDate'
GO
ALTER TABLE [Production].[ProductReview]
    ADD
    CONSTRAINT [DF_ProductReview_ReviewDate]
    DEFAULT (getdate()) FOR [ReviewDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'CONSTRAINT', N'DF_ProductReview_ReviewDate'
GO
ALTER TABLE [Production].[ProductReview]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductReview_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[ProductReview]
    CHECK CONSTRAINT [FK_ProductReview_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'CONSTRAINT', N'FK_ProductReview_Product_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_ProductReview_ProductID_Name]
    ON [Production].[ProductReview] ([ProductID], [ReviewerName])
    INCLUDE ([Comments])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'INDEX', N'IX_ProductReview_ProductID_Name'
GO
CREATE FULLTEXT INDEX ON [Production].[ProductReview]
    ([Comments] LANGUAGE 1033)
    KEY INDEX [PK_ProductReview_ProductReviewID]
    ON (FILEGROUP [PRIMARY], [AW2014FullTextCatalog])
    WITH CHANGE_TRACKING AUTO, STOPLIST SYSTEM
GO
EXEC sp_addextendedproperty N'MS_Description', N'Reviewer''s comments', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'Comments'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Reviewer''s e-mail address.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'EmailAddress'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductReview records.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'ProductReviewID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product rating given by the reviewer. Scale is 1 to 5 with 5 as the highest rating.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'Rating'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date review was submitted.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'ReviewDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the reviewer.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', 'COLUMN', N'ReviewerName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer reviews of products they have purchased.', 'SCHEMA', N'Production', 'TABLE', N'ProductReview', NULL, NULL
GO

Collapse image See also

List of tables


ProductSubcategory

Table: AdventureWorks2016CTP3.Production.ProductSubcategory

Collapse image Description

Product subcategories. See ProductCategory table.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 994102582
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 37
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductSubcategory_ProductSubcategoryID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | ProductSubcategoryID | Primary key for ProductSubcategory records. |  | int | 4 |  |  |  |
 |  | Foreign key | ProductCategoryID | Product category identification number. Foreign key to ProductCategory.ProductCategoryID. |  | int | 4 |  |  |  |
 |  |  | Name | Subcategory description. |  | Name | 50 |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 8 | 4 | 17 | 0.17000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductSubcategory_ProductSubcategoryID | ProductSubcategoryID | Primary key (clustered) constraint |  |  | 48 | 0
AK_ProductSubcategory_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_ProductSubcategory_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ProductSubcategoryID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.Product | FK_Product_ProductSubcategory_ProductSubcategoryID | PK_ProductSubcategory_ProductSubcategoryID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.ProductCategory | PK_ProductCategory_ProductCategoryID | FK_ProductSubcategory_ProductCategory_ProductCategoryID
Total: 1 table(s)

Collapse image Objects that depend on Production.ProductSubcategory

Object name | Object type | Dep level
Production.Product | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ProductSubcategory depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.ProductCategory | Table | 1
Name | Datatype | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product subcategories. See ProductCategory table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ProductSubcategory] (
        [ProductSubcategoryID]     [int] IDENTITY(1, 1) NOT NULL,
        [ProductCategoryID]        [int] NOT NULL,
        [Name]                     [dbo].[Name] NOT NULL,
        [rowguid]                  [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]             [datetime] NOT NULL,
        CONSTRAINT [PK_ProductSubcategory_ProductSubcategoryID]
        PRIMARY KEY
        CLUSTERED
        ([ProductSubcategoryID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'CONSTRAINT', N'PK_ProductSubcategory_ProductSubcategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'INDEX', N'PK_ProductSubcategory_ProductSubcategoryID'
GO
ALTER TABLE [Production].[ProductSubcategory]
    ADD
    CONSTRAINT [DF_ProductSubcategory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'CONSTRAINT', N'DF_ProductSubcategory_ModifiedDate'
GO
ALTER TABLE [Production].[ProductSubcategory]
    ADD
    CONSTRAINT [DF_ProductSubcategory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'CONSTRAINT', N'DF_ProductSubcategory_rowguid'
GO
ALTER TABLE [Production].[ProductSubcategory]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductSubcategory_ProductCategory_ProductCategoryID]
    FOREIGN KEY ([ProductCategoryID]) REFERENCES [Production].[ProductCategory] ([ProductCategoryID])
ALTER TABLE [Production].[ProductSubcategory]
    CHECK CONSTRAINT [FK_ProductSubcategory_ProductCategory_ProductCategoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ProductCategory.ProductCategoryID.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'CONSTRAINT', N'FK_ProductSubcategory_ProductCategory_ProductCategoryID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductSubcategory_Name]
    ON [Production].[ProductSubcategory] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'INDEX', N'AK_ProductSubcategory_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ProductSubcategory_rowguid]
    ON [Production].[ProductSubcategory] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'INDEX', N'AK_ProductSubcategory_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Subcategory description.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product category identification number. Foreign key to ProductCategory.ProductCategoryID.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'COLUMN', N'ProductCategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ProductSubcategory records.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'COLUMN', N'ProductSubcategoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product subcategories. See ProductCategory table.', 'SCHEMA', N'Production', 'TABLE', N'ProductSubcategory', NULL, NULL
GO

Collapse image See also

List of tables


ScrapReason

Table: AdventureWorks2016CTP3.Production.ScrapReason

Collapse image Description

Manufacturing failure reasons lookup table.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 334624235
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 16
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ScrapReason_ScrapReasonID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ScrapReasonID | Primary key for ScrapReason records. |  | smallint | 2 |  |  |  |
 |  | Name | Failure description. |  | Name | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 21 | 14 | 31 | 0.31000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ScrapReason_ScrapReasonID | ScrapReasonID | Primary key (clustered) constraint |  |  | 32 | 0
AK_ScrapReason_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
ScrapReasonID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.WorkOrder | FK_WorkOrder_ScrapReason_ScrapReasonID | PK_ScrapReason_ScrapReasonID
Total: 1 table(s)

Collapse image Objects that depend on Production.ScrapReason

Object name | Object type | Dep level
Production.WorkOrder | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ScrapReason depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Manufacturing failure reasons lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[ScrapReason] (
        [ScrapReasonID]     [smallint] IDENTITY(1, 1) NOT NULL,
        [Name]              [dbo].[Name] NOT NULL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_ScrapReason_ScrapReasonID]
        PRIMARY KEY
        CLUSTERED
        ([ScrapReasonID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'CONSTRAINT', N'PK_ScrapReason_ScrapReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'INDEX', N'PK_ScrapReason_ScrapReasonID'
GO
ALTER TABLE [Production].[ScrapReason]
    ADD
    CONSTRAINT [DF_ScrapReason_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'CONSTRAINT', N'DF_ScrapReason_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ScrapReason_Name]
    ON [Production].[ScrapReason] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'INDEX', N'AK_ScrapReason_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Failure description.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ScrapReason records.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', 'COLUMN', N'ScrapReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Manufacturing failure reasons lookup table.', 'SCHEMA', N'Production', 'TABLE', N'ScrapReason', NULL, NULL
GO

Collapse image See also

List of tables


TransactionHistory

Table: AdventureWorks2016CTP3.Production.TransactionHistory

Collapse image Description

Record of each purchase order, sales order, or work order transaction year to date.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 894626230
Located on | PRIMARY
Data size KB | 6344 KB
Index size KB | 4448 KB
Rows | 113443
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_TransactionHistory_TransactionID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | TransactionID | Primary key for TransactionHistory records. |  | int | 4 |  |  |  |
 |  | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  |  | ReferenceOrderID | Purchase order, sales order, or work order identification number. |  | int | 4 |  |  |  |
 |  |  | ReferenceOrderLineID | Line number associated with the purchase order, sales order, or work order. |  | int | 4 |  | ((0)) |  |
 |  |  | TransactionDate | Date and time of the transaction. |  | datetime | 8 |  | (getdate()) |  |
 |  |  | TransactionType | W = WorkOrder, S = SalesOrder, P = PurchaseOrder |  | nchar | 1 |  |  |  |
 |  |  | Quantity | Product quantity. |  | int | 4 |  |  |  |
 |  |  | ActualCost | Product cost. |  | money | 8 |  |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
TransactionType | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_TransactionHistory_TransactionID | TransactionID | Primary key (clustered) constraint |  |  | 10792 | 0
IX_TransactionHistory_ProductID | ProductID | Nonclustered index. |  |  | 1864 | 0
IX_TransactionHistory_ReferenceOrderID_ReferenceOrderLineID | ReferenceOrderID | Nonclustered index. |  |  | 2320 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_TransactionHistory_TransactionType | (upper([TransactionType])='P' OR upper([TransactionType])='S' OR upper([TransactionType])='W')

Collapse image Identity column

Name | Seed | Increment | Not for replication
TransactionID | 100000 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_TransactionHistory_Product_ProductID
Total: 1 table(s)

Collapse image Objects that depend on Production.TransactionHistory

Object name | Object type | Dep level
Sales.iduSalesOrderDetail | Trigger | 1
Purchasing.iPurchaseOrderDetail | Trigger | 1
Production.iWorkOrder | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Production.uWorkOrder | Trigger | 1
Total 5 object(s)

Collapse image Objects that Production.TransactionHistory depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Record of each purchase order, sales order, or work order transaction year to date.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[TransactionHistory] (
        [TransactionID]            [int] IDENTITY(100000, 1) NOT NULL,
        [ProductID]                [int] NOT NULL,
        [ReferenceOrderID]         [int] NOT NULL,
        [ReferenceOrderLineID]     [int] NOT NULL,
        [TransactionDate]          [datetime] NOT NULL,
        [TransactionType]          [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Quantity]                 [int] NOT NULL,
        [ActualCost]               [money] NOT NULL,
        [ModifiedDate]             [datetime] NOT NULL,
        CONSTRAINT [PK_TransactionHistory_TransactionID]
        PRIMARY KEY
        CLUSTERED
        ([TransactionID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'PK_TransactionHistory_TransactionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'INDEX', N'PK_TransactionHistory_TransactionID'
GO
ALTER TABLE [Production].[TransactionHistory]
    ADD
    CONSTRAINT [CK_TransactionHistory_TransactionType]
    CHECK
    (upper([TransactionType])='P' OR upper([TransactionType])='S' OR upper([TransactionType])='W')
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [TransactionType]=''p'' OR [TransactionType]=''s'' OR [TransactionType]=''w'' OR [TransactionType]=''P'' OR [TransactionType]=''S'' OR [TransactionType]=''W'')', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'CK_TransactionHistory_TransactionType'
GO
ALTER TABLE [Production].[TransactionHistory]
CHECK CONSTRAINT [CK_TransactionHistory_TransactionType]
GO
ALTER TABLE [Production].[TransactionHistory]
    ADD
    CONSTRAINT [DF_TransactionHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'DF_TransactionHistory_ModifiedDate'
GO
ALTER TABLE [Production].[TransactionHistory]
    ADD
    CONSTRAINT [DF_TransactionHistory_ReferenceOrderLineID]
    DEFAULT ((0)) FOR [ReferenceOrderLineID]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'DF_TransactionHistory_ReferenceOrderLineID'
GO
ALTER TABLE [Production].[TransactionHistory]
    ADD
    CONSTRAINT [DF_TransactionHistory_TransactionDate]
    DEFAULT (getdate()) FOR [TransactionDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'DF_TransactionHistory_TransactionDate'
GO
ALTER TABLE [Production].[TransactionHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_TransactionHistory_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[TransactionHistory]
    CHECK CONSTRAINT [FK_TransactionHistory_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'CONSTRAINT', N'FK_TransactionHistory_Product_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_TransactionHistory_ProductID]
    ON [Production].[TransactionHistory] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'INDEX', N'IX_TransactionHistory_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_TransactionHistory_ReferenceOrderID_ReferenceOrderLineID]
    ON [Production].[TransactionHistory] ([ReferenceOrderID], [ReferenceOrderLineID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'INDEX', N'IX_TransactionHistory_ReferenceOrderID_ReferenceOrderLineID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product cost.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'ActualCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product quantity.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'Quantity'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Purchase order, sales order, or work order identification number.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'ReferenceOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Line number associated with the purchase order, sales order, or work order.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'ReferenceOrderLineID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time of the transaction.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'TransactionDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for TransactionHistory records.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'TransactionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'W = WorkOrder, S = SalesOrder, P = PurchaseOrder', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', 'COLUMN', N'TransactionType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Record of each purchase order, sales order, or work order transaction year to date.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistory', NULL, NULL
GO

Collapse image See also

List of tables


TransactionHistoryArchive

Table: AdventureWorks2016CTP3.Production.TransactionHistoryArchive

CollapseAll image

Collapse image Description

Transactions for previous years.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 974626515
Located on | PRIMARY
Data size KB | 5000 KB
Index size KB | 3680 KB
Rows | 89253
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_TransactionHistoryArchive_TransactionID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | TransactionID | Primary key for TransactionHistoryArchive records. |  | int | 4 |  |  |  |
 | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 | ReferenceOrderID | Purchase order, sales order, or work order identification number. |  | int | 4 |  |  |  |
 | ReferenceOrderLineID | Line number associated with the purchase order, sales order, or work order. |  | int | 4 |  | ((0)) |  |
 | TransactionDate | Date and time of the transaction. |  | datetime | 8 |  | (getdate()) |  |
 | TransactionType | W = Work Order, S = Sales Order, P = Purchase Order |  | nchar | 1 |  |  |  |
 | Quantity | Product quantity. |  | int | 4 |  |  |  |
 | ActualCost | Product cost. |  | money | 8 |  |  |  |
 | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
TransactionType | nchar(1) | 1 | 1 | 1 | 0.50000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_TransactionHistoryArchive_TransactionID | TransactionID | Primary key (clustered) constraint |  |  | 8680 | 0
IX_TransactionHistoryArchive_ProductID | ProductID | Nonclustered index. |  |  | 1536 | 0
IX_TransactionHistoryArchive_ReferenceOrderID_ReferenceOrderLineID | ReferenceOrderID | Nonclustered index. |  |  | 1920 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_TransactionHistoryArchive_TransactionType | (upper([TransactionType])='P' OR upper([TransactionType])='S' OR upper([TransactionType])='W')

Collapse image Objects that Production.TransactionHistoryArchive depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Transactions for previous years.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[TransactionHistoryArchive] (
        [TransactionID]            [int] NOT NULL,
        [ProductID]                [int] NOT NULL,
        [ReferenceOrderID]         [int] NOT NULL,
        [ReferenceOrderLineID]     [int] NOT NULL,
        [TransactionDate]          [datetime] NOT NULL,
        [TransactionType]          [nchar](1) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Quantity]                 [int] NOT NULL,
        [ActualCost]               [money] NOT NULL,
        [ModifiedDate]             [datetime] NOT NULL,
        CONSTRAINT [PK_TransactionHistoryArchive_TransactionID]
        PRIMARY KEY
        CLUSTERED
        ([TransactionID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'CONSTRAINT', N'PK_TransactionHistoryArchive_TransactionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'INDEX', N'PK_TransactionHistoryArchive_TransactionID'
GO
ALTER TABLE [Production].[TransactionHistoryArchive]
    ADD
    CONSTRAINT [CK_TransactionHistoryArchive_TransactionType]
    CHECK
    (upper([TransactionType])='P' OR upper([TransactionType])='S' OR upper([TransactionType])='W')
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [TransactionType]=''p'' OR [TransactionType]=''s'' OR [TransactionType]=''w'' OR [TransactionType]=''P'' OR [TransactionType]=''S'' OR [TransactionType]=''W''', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'CONSTRAINT', N'CK_TransactionHistoryArchive_TransactionType'
GO
ALTER TABLE [Production].[TransactionHistoryArchive]
CHECK CONSTRAINT [CK_TransactionHistoryArchive_TransactionType]
GO
ALTER TABLE [Production].[TransactionHistoryArchive]
    ADD
    CONSTRAINT [DF_TransactionHistoryArchive_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'CONSTRAINT', N'DF_TransactionHistoryArchive_ModifiedDate'
GO
ALTER TABLE [Production].[TransactionHistoryArchive]
    ADD
    CONSTRAINT [DF_TransactionHistoryArchive_ReferenceOrderLineID]
    DEFAULT ((0)) FOR [ReferenceOrderLineID]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'CONSTRAINT', N'DF_TransactionHistoryArchive_ReferenceOrderLineID'
GO
ALTER TABLE [Production].[TransactionHistoryArchive]
    ADD
    CONSTRAINT [DF_TransactionHistoryArchive_TransactionDate]
    DEFAULT (getdate()) FOR [TransactionDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'CONSTRAINT', N'DF_TransactionHistoryArchive_TransactionDate'
GO
CREATE NONCLUSTERED INDEX [IX_TransactionHistoryArchive_ProductID]
    ON [Production].[TransactionHistoryArchive] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'INDEX', N'IX_TransactionHistoryArchive_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_TransactionHistoryArchive_ReferenceOrderID_ReferenceOrderLineID]
    ON [Production].[TransactionHistoryArchive] ([ReferenceOrderID], [ReferenceOrderLineID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'INDEX', N'IX_TransactionHistoryArchive_ReferenceOrderID_ReferenceOrderLineID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product cost.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'ActualCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product quantity.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'Quantity'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Purchase order, sales order, or work order identification number.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'ReferenceOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Line number associated with the purchase order, sales order, or work order.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'ReferenceOrderLineID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time of the transaction.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'TransactionDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for TransactionHistoryArchive records.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'TransactionID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'W = Work Order, S = Sales Order, P = Purchase Order', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', 'COLUMN', N'TransactionType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Transactions for previous years.', 'SCHEMA', N'Production', 'TABLE', N'TransactionHistoryArchive', NULL, NULL
GO

Collapse image See also

List of tables


UnitMeasure

Table: AdventureWorks2016CTP3.Production.UnitMeasure

Collapse image Description

Unit of measure lookup table.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1054626800
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 38
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_UnitMeasure_UnitMeasureCode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | UnitMeasureCode | Primary key. |  | nchar | 3 |  |  |  |
 | Name | Unit of measure description. |  | Name | 50 |  |  |  |
 | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
UnitMeasureCode | nchar(3) | 2 | 1 | 3 | 0.50000000000000
Name | nvarchar(50) | 8 | 4 | 20 | 0.20000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_UnitMeasure_UnitMeasureCode | UnitMeasureCode | Primary key (clustered) constraint |  |  | 32 | 0
AK_UnitMeasure_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.BillOfMaterials | FK_BillOfMaterials_UnitMeasure_UnitMeasureCode | PK_UnitMeasure_UnitMeasureCode
Production.Product | FK_Product_UnitMeasure_SizeUnitMeasureCode | PK_UnitMeasure_UnitMeasureCode
Production.Product | FK_Product_UnitMeasure_WeightUnitMeasureCode | PK_UnitMeasure_UnitMeasureCode
Purchasing.ProductVendor | FK_ProductVendor_UnitMeasure_UnitMeasureCode | PK_UnitMeasure_UnitMeasureCode
Total: 4 table(s)

Collapse image Objects that depend on Production.UnitMeasure

Object name | Object type | Dep level
Production.BillOfMaterials | Table | 1
Production.Product | Table | 1
Purchasing.ProductVendor | Table | 1
Total 3 object(s)

Collapse image Objects that Production.UnitMeasure depends on

Object name | Object type | Dep level
Production | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Unit of measure lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[UnitMeasure] (
        [UnitMeasureCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Name]                [dbo].[Name] NOT NULL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [PK_UnitMeasure_UnitMeasureCode]
        PRIMARY KEY
        CLUSTERED
        ([UnitMeasureCode])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'CONSTRAINT', N'PK_UnitMeasure_UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'INDEX', N'PK_UnitMeasure_UnitMeasureCode'
GO
ALTER TABLE [Production].[UnitMeasure]
    ADD
    CONSTRAINT [DF_UnitMeasure_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'CONSTRAINT', N'DF_UnitMeasure_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_UnitMeasure_Name]
    ON [Production].[UnitMeasure] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'INDEX', N'AK_UnitMeasure_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unit of measure description.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', 'COLUMN', N'UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unit of measure lookup table.', 'SCHEMA', N'Production', 'TABLE', N'UnitMeasure', NULL, NULL
GO

Collapse image See also

List of tables


WorkOrder

Table: AdventureWorks2016CTP3.Production.WorkOrder

Collapse image Description

Manufacturing work orders.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1166627199
Located on | PRIMARY
Data size KB | 4232 KB
Index size KB | 2408 KB
Rows | 72591
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_WorkOrder_WorkOrderID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | WorkOrderID | Primary key for WorkOrder records. |  | int | 4 |  |  |  |  |
 |  | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |  |
 |  |  | OrderQty | Product quantity to build. |  | int | 4 |  |  |  |  |
 |  |  | StockedQty | Quantity built and put in inventory. | True | int | 4 |  |  |  |  | (isnull([OrderQty]-[ScrappedQty],(0)))
 |  |  | ScrappedQty | Quantity that failed inspection. |  | smallint | 2 |  |  |  |  |
 |  |  | StartDate | Work order start date. |  | datetime | 8 |  |  |  |  |
 |  |  | EndDate | Work order end date. |  | datetime | 8 |  |  |  |  |
 |  |  | DueDate | Work order due date. |  | datetime | 8 |  |  |  |  |
 |  | Foreign key | ScrapReasonID | Reason for inspection failure. |  | smallint | 2 |  |  |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 10 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_WorkOrder_WorkOrderID | WorkOrderID | Primary key (clustered) constraint |  |  | 6640 | 0
IX_WorkOrder_ProductID | ProductID | Nonclustered index. |  |  | 1320 | 0
IX_WorkOrder_ScrapReasonID | ScrapReasonID | Nonclustered index. |  |  | 880 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_WorkOrder_EndDate | ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
CK_WorkOrder_OrderQty | ([OrderQty]>(0))
CK_WorkOrder_ScrappedQty | ([ScrappedQty]>=(0))

Collapse image Identity column

Name | Seed | Increment | Not for replication
WorkOrderID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Production.WorkOrderRouting | FK_WorkOrderRouting_WorkOrder_WorkOrderID | PK_WorkOrder_WorkOrderID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_WorkOrder_Product_ProductID
Production.ScrapReason | PK_ScrapReason_ScrapReasonID | FK_WorkOrder_ScrapReason_ScrapReasonID
Total: 2 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Production.iWorkOrder | Production |  |  | For Insert |  |  | Production.WorkOrder
Production.uWorkOrder | Production |  |  |  | For Update |  | Production.WorkOrder
Total: 2 triggers(s)

Collapse image Objects that depend on Production.WorkOrder

Object name | Object type | Dep level
Production.WorkOrderRouting | Table | 1
Production.iWorkOrder | Trigger | 1
Production.uWorkOrder | Trigger | 1
Total 3 object(s)

Collapse image Objects that Production.WorkOrder depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Production.ScrapReason | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Manufacturing work orders.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Production].[WorkOrder] (
        [WorkOrderID]       [int] IDENTITY(1, 1) NOT NULL,
        [ProductID]         [int] NOT NULL,
        [OrderQty]          [int] NOT NULL,
        [StockedQty]        AS (isnull([OrderQty]-[ScrappedQty],(0))),
        [ScrappedQty]       [smallint] NOT NULL,
        [StartDate]         [datetime] NOT NULL,
        [EndDate]           [datetime] NULL,
        [DueDate]           [datetime] NOT NULL,
        [ScrapReasonID]     [smallint] NULL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_WorkOrder_WorkOrderID]
        PRIMARY KEY
        CLUSTERED
        ([WorkOrderID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'PK_WorkOrder_WorkOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'INDEX', N'PK_WorkOrder_WorkOrderID'
GO
ALTER TABLE [Production].[WorkOrder]
    ADD
    CONSTRAINT [CK_WorkOrder_EndDate]
    CHECK
    ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate] OR [EndDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'CK_WorkOrder_EndDate'
GO
ALTER TABLE [Production].[WorkOrder]
CHECK CONSTRAINT [CK_WorkOrder_EndDate]
GO
ALTER TABLE [Production].[WorkOrder]
    ADD
    CONSTRAINT [CK_WorkOrder_OrderQty]
    CHECK
    ([OrderQty]>(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [OrderQty] > (0)', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'CK_WorkOrder_OrderQty'
GO
ALTER TABLE [Production].[WorkOrder]
CHECK CONSTRAINT [CK_WorkOrder_OrderQty]
GO
ALTER TABLE [Production].[WorkOrder]
    ADD
    CONSTRAINT [CK_WorkOrder_ScrappedQty]
    CHECK
    ([ScrappedQty]>=(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ScrappedQty] >= (0)', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'CK_WorkOrder_ScrappedQty'
GO
ALTER TABLE [Production].[WorkOrder]
CHECK CONSTRAINT [CK_WorkOrder_ScrappedQty]
GO
ALTER TABLE [Production].[WorkOrder]
    ADD
    CONSTRAINT [DF_WorkOrder_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'DF_WorkOrder_ModifiedDate'
GO
ALTER TABLE [Production].[WorkOrder]
    WITH CHECK
    ADD CONSTRAINT [FK_WorkOrder_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Production].[WorkOrder]
    CHECK CONSTRAINT [FK_WorkOrder_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'FK_WorkOrder_Product_ProductID'
GO
ALTER TABLE [Production].[WorkOrder]
    WITH CHECK
    ADD CONSTRAINT [FK_WorkOrder_ScrapReason_ScrapReasonID]
    FOREIGN KEY ([ScrapReasonID]) REFERENCES [Production].[ScrapReason] ([ScrapReasonID])
ALTER TABLE [Production].[WorkOrder]
    CHECK CONSTRAINT [FK_WorkOrder_ScrapReason_ScrapReasonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ScrapReason.ScrapReasonID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'CONSTRAINT', N'FK_WorkOrder_ScrapReason_ScrapReasonID'
GO
CREATE NONCLUSTERED INDEX [IX_WorkOrder_ProductID]
    ON [Production].[WorkOrder] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'INDEX', N'IX_WorkOrder_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_WorkOrder_ScrapReasonID]
    ON [Production].[WorkOrder] ([ScrapReasonID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'INDEX', N'IX_WorkOrder_ScrapReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work order due date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'DueDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work order end date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product quantity to build.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'OrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity that failed inspection.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'ScrappedQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Reason for inspection failure.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'ScrapReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work order start date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity built and put in inventory.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'StockedQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for WorkOrder records.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'COLUMN', N'WorkOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Manufacturing work orders.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', NULL, NULL
GO

Collapse image See also

List of tables


WorkOrderRouting

Table: AdventureWorks2016CTP3.Production.WorkOrderRouting

Collapse image Description

Work order details.

Collapse image Table properties

Name | Value
Schema | Production
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1246627484
Located on | PRIMARY
Data size KB | 5600 KB
Index size KB | 1648 KB
Rows | 67131
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_WorkOrderRouting_WorkOrderID_ProductID_OperationSequence]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | WorkOrderID | Primary key. Foreign key to WorkOrder.WorkOrderID. |  | int | 4 |  |  |  |
Primary key |  | ProductID | Primary key. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
Primary key |  | OperationSequence | Primary key. Indicates the manufacturing process sequence. |  | smallint | 2 |  |  |  |
 | Foreign key | LocationID | Manufacturing location where the part is processed. Foreign key to Location.LocationID. |  | smallint | 2 |  |  |  |
 |  | ScheduledStartDate | Planned manufacturing start date. |  | datetime | 8 |  |  |  |
 |  | ScheduledEndDate | Planned manufacturing end date. |  | datetime | 8 |  |  |  |
 |  | ActualStartDate | Actual start date. |  | datetime | 8 |  |  |  |
 |  | ActualEndDate | Actual end date. |  | datetime | 8 |  |  |  |
 |  | ActualResourceHrs | Number of manufacturing hours used. |  | decimal | 5 |  |  |  |
 |  | PlannedCost | Estimated manufacturing cost. |  | money | 8 |  |  |  |
 |  | ActualCost | Actual manufacturing cost. |  | money | 8 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 12 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_WorkOrderRouting_WorkOrderID_ProductID_OperationSequence | WorkOrderID | Primary key (clustered) constraint |  |  | 7248 | 0
IX_WorkOrderRouting_ProductID | ProductID | Nonclustered index. |  |  | 1352 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_WorkOrderRouting_ActualCost | ([ActualCost]>(0.00))
CK_WorkOrderRouting_ActualEndDate | ([ActualEndDate]>=[ActualStartDate] OR [ActualEndDate] IS NULL OR [ActualStartDate] IS NULL)
CK_WorkOrderRouting_ActualResourceHrs | ([ActualResourceHrs]>=(0.0000))
CK_WorkOrderRouting_PlannedCost | ([PlannedCost]>(0.00))
CK_WorkOrderRouting_ScheduledEndDate | ([ScheduledEndDate]>=[ScheduledStartDate])

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Location | PK_Location_LocationID | FK_WorkOrderRouting_Location_LocationID
Production.WorkOrder | PK_WorkOrder_WorkOrderID | FK_WorkOrderRouting_WorkOrder_WorkOrderID
Total: 2 table(s)

Collapse image Objects that Production.WorkOrderRouting depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Location | Table | 1
Production.WorkOrder | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Work order details.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Production].[WorkOrderRouting] (
        [WorkOrderID]            [int] NOT NULL,
        [ProductID]              [int] NOT NULL,
        [OperationSequence]      [smallint] NOT NULL,
        [LocationID]             [smallint] NOT NULL,
        [ScheduledStartDate]     [datetime] NOT NULL,
        [ScheduledEndDate]       [datetime] NOT NULL,
        [ActualStartDate]        [datetime] NULL,
        [ActualEndDate]          [datetime] NULL,
        [ActualResourceHrs]      [decimal](9, 4) NULL,
        [PlannedCost]            [money] NOT NULL,
        [ActualCost]             [money] NULL,
        [ModifiedDate]           [datetime] NOT NULL,
        CONSTRAINT [PK_WorkOrderRouting_WorkOrderID_ProductID_OperationSequence]
        PRIMARY KEY
        CLUSTERED
        ([WorkOrderID], [ProductID], [OperationSequence])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'PK_WorkOrderRouting_WorkOrderID_ProductID_OperationSequence'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'INDEX', N'PK_WorkOrderRouting_WorkOrderID_ProductID_OperationSequence'
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [CK_WorkOrderRouting_ActualCost]
    CHECK
    ([ActualCost]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ActualCost] > (0.00)', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'CK_WorkOrderRouting_ActualCost'
GO
ALTER TABLE [Production].[WorkOrderRouting]
CHECK CONSTRAINT [CK_WorkOrderRouting_ActualCost]
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [CK_WorkOrderRouting_ActualEndDate]
    CHECK
    ([ActualEndDate]>=[ActualStartDate] OR [ActualEndDate] IS NULL OR [ActualStartDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ActualEndDate] >= [ActualStartDate] OR [ActualEndDate] IS NULL OR [ActualStartDate] IS NULL', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'CK_WorkOrderRouting_ActualEndDate'
GO
ALTER TABLE [Production].[WorkOrderRouting]
CHECK CONSTRAINT [CK_WorkOrderRouting_ActualEndDate]
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [CK_WorkOrderRouting_ActualResourceHrs]
    CHECK
    ([ActualResourceHrs]>=(0.0000))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ActualResourceHrs] >= (0.0000)', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'CK_WorkOrderRouting_ActualResourceHrs'
GO
ALTER TABLE [Production].[WorkOrderRouting]
CHECK CONSTRAINT [CK_WorkOrderRouting_ActualResourceHrs]
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [CK_WorkOrderRouting_PlannedCost]
    CHECK
    ([PlannedCost]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [PlannedCost] > (0.00)', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'CK_WorkOrderRouting_PlannedCost'
GO
ALTER TABLE [Production].[WorkOrderRouting]
CHECK CONSTRAINT [CK_WorkOrderRouting_PlannedCost]
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [CK_WorkOrderRouting_ScheduledEndDate]
    CHECK
    ([ScheduledEndDate]>=[ScheduledStartDate])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ScheduledEndDate] >= [ScheduledStartDate]', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'CK_WorkOrderRouting_ScheduledEndDate'
GO
ALTER TABLE [Production].[WorkOrderRouting]
CHECK CONSTRAINT [CK_WorkOrderRouting_ScheduledEndDate]
GO
ALTER TABLE [Production].[WorkOrderRouting]
    ADD
    CONSTRAINT [DF_WorkOrderRouting_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'DF_WorkOrderRouting_ModifiedDate'
GO
ALTER TABLE [Production].[WorkOrderRouting]
    WITH CHECK
    ADD CONSTRAINT [FK_WorkOrderRouting_Location_LocationID]
    FOREIGN KEY ([LocationID]) REFERENCES [Production].[Location] ([LocationID])
ALTER TABLE [Production].[WorkOrderRouting]
    CHECK CONSTRAINT [FK_WorkOrderRouting_Location_LocationID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Location.LocationID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'FK_WorkOrderRouting_Location_LocationID'
GO
ALTER TABLE [Production].[WorkOrderRouting]
    WITH CHECK
    ADD CONSTRAINT [FK_WorkOrderRouting_WorkOrder_WorkOrderID]
    FOREIGN KEY ([WorkOrderID]) REFERENCES [Production].[WorkOrder] ([WorkOrderID])
ALTER TABLE [Production].[WorkOrderRouting]
    CHECK CONSTRAINT [FK_WorkOrderRouting_WorkOrder_WorkOrderID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing WorkOrder.WorkOrderID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'CONSTRAINT', N'FK_WorkOrderRouting_WorkOrder_WorkOrderID'
GO
CREATE NONCLUSTERED INDEX [IX_WorkOrderRouting_ProductID]
    ON [Production].[WorkOrderRouting] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'INDEX', N'IX_WorkOrderRouting_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Actual manufacturing cost.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ActualCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Actual end date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ActualEndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Number of manufacturing hours used.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ActualResourceHrs'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Actual start date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ActualStartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Manufacturing location where the part is processed. Foreign key to Location.LocationID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'LocationID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Indicates the manufacturing process sequence.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'OperationSequence'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Estimated manufacturing cost.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'PlannedCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Product.ProductID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Planned manufacturing end date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ScheduledEndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Planned manufacturing start date.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'ScheduledStartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to WorkOrder.WorkOrderID.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', 'COLUMN', N'WorkOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Work order details.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrderRouting', NULL, NULL
GO

Collapse image See also

List of tables


ProductVendor

Table: AdventureWorks2016CTP3.Purchasing.ProductVendor

Collapse image Description

Cross-reference table mapping vendors with the products they supply.

Collapse image Table properties

Name | Value
Schema | Purchasing
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1042102753
Located on | PRIMARY
Data size KB | 40 KB
Index size KB | 64 KB
Rows | 460
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ProductVendor_ProductID_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | ProductID | Primary key. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
Primary key | Foreign key | BusinessEntityID | Primary key. Foreign key to Vendor.BusinessEntityID. |  | int | 4 |  |  |  |
 |  | AverageLeadTime | The average span of time (in days) between placing an order with the vendor and receiving the purchased product. |  | int | 4 |  |  |  |
 |  | StandardPrice | The vendor's usual selling price. |  | money | 8 |  |  |  |
 |  | LastReceiptCost | The selling price when last purchased. |  | money | 8 |  |  |  |
 |  | LastReceiptDate | Date the product was last received by the vendor. |  | datetime | 8 |  |  |  |
 |  | MinOrderQty | The maximum quantity that should be ordered. |  | int | 4 |  |  |  |
 |  | MaxOrderQty | The minimum quantity that should be ordered. |  | int | 4 |  |  |  |
 |  | OnOrderQty | The quantity currently on order. |  | int | 4 |  |  |  |
 | Foreign key | UnitMeasureCode | The product's unit of measure. |  | nchar | 3 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
UnitMeasureCode | nchar(3) | 2 | 2 | 3 | 0.50000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ProductVendor_ProductID_BusinessEntityID | ProductID | Primary key (clustered) constraint |  |  | 104 | 0
IX_ProductVendor_BusinessEntityID | BusinessEntityID | Nonclustered index. |  |  | 16 | 0
IX_ProductVendor_UnitMeasureCode | UnitMeasureCode | Nonclustered index. |  |  | 32 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ProductVendor_AverageLeadTime | ([AverageLeadTime]>=(1))
CK_ProductVendor_LastReceiptCost | ([LastReceiptCost]>(0.00))
CK_ProductVendor_MaxOrderQty | ([MaxOrderQty]>=(1))
CK_ProductVendor_MinOrderQty | ([MinOrderQty]>=(1))
CK_ProductVendor_OnOrderQty | ([OnOrderQty]>=(0))
CK_ProductVendor_StandardPrice | ([StandardPrice]>(0.00))

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ProductVendor_Product_ProductID
Production.UnitMeasure | PK_UnitMeasure_UnitMeasureCode | FK_ProductVendor_UnitMeasure_UnitMeasureCode
Purchasing.Vendor | PK_Vendor_BusinessEntityID | FK_ProductVendor_Vendor_BusinessEntityID
Total: 3 table(s)

Collapse image Objects that Purchasing.ProductVendor depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Production.Product | Table | 1
Production.UnitMeasure | Table | 1
Purchasing.Vendor | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping vendors with the products they supply.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Purchasing].[ProductVendor] (
        [ProductID]            [int] NOT NULL,
        [BusinessEntityID]     [int] NOT NULL,
        [AverageLeadTime]      [int] NOT NULL,
        [StandardPrice]        [money] NOT NULL,
        [LastReceiptCost]      [money] NULL,
        [LastReceiptDate]      [datetime] NULL,
        [MinOrderQty]          [int] NOT NULL,
        [MaxOrderQty]          [int] NOT NULL,
        [OnOrderQty]           [int] NULL,
        [UnitMeasureCode]      [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_ProductVendor_ProductID_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([ProductID], [BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'PK_ProductVendor_ProductID_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'INDEX', N'PK_ProductVendor_ProductID_BusinessEntityID'
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_AverageLeadTime]
    CHECK
    ([AverageLeadTime]>=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [AverageLeadTime] >= (1)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_AverageLeadTime'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_AverageLeadTime]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_LastReceiptCost]
    CHECK
    ([LastReceiptCost]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [LastReceiptCost] > (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_LastReceiptCost'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_LastReceiptCost]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_MaxOrderQty]
    CHECK
    ([MaxOrderQty]>=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [MaxOrderQty] >= (1)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_MaxOrderQty'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_MaxOrderQty]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_MinOrderQty]
    CHECK
    ([MinOrderQty]>=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [MinOrderQty] >= (1)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_MinOrderQty'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_MinOrderQty]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_OnOrderQty]
    CHECK
    ([OnOrderQty]>=(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [OnOrderQty] >= (0)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_OnOrderQty'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_OnOrderQty]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [CK_ProductVendor_StandardPrice]
    CHECK
    ([StandardPrice]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [StandardPrice] > (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'CK_ProductVendor_StandardPrice'
GO
ALTER TABLE [Purchasing].[ProductVendor]
CHECK CONSTRAINT [CK_ProductVendor_StandardPrice]
GO
ALTER TABLE [Purchasing].[ProductVendor]
    ADD
    CONSTRAINT [DF_ProductVendor_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'DF_ProductVendor_ModifiedDate'
GO
ALTER TABLE [Purchasing].[ProductVendor]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductVendor_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Purchasing].[ProductVendor]
    CHECK CONSTRAINT [FK_ProductVendor_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'FK_ProductVendor_Product_ProductID'
GO
ALTER TABLE [Purchasing].[ProductVendor]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductVendor_UnitMeasure_UnitMeasureCode]
    FOREIGN KEY ([UnitMeasureCode]) REFERENCES [Production].[UnitMeasure] ([UnitMeasureCode])
ALTER TABLE [Purchasing].[ProductVendor]
    CHECK CONSTRAINT [FK_ProductVendor_UnitMeasure_UnitMeasureCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing UnitMeasure.UnitMeasureCode.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'FK_ProductVendor_UnitMeasure_UnitMeasureCode'
GO
ALTER TABLE [Purchasing].[ProductVendor]
    WITH CHECK
    ADD CONSTRAINT [FK_ProductVendor_Vendor_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Purchasing].[Vendor] ([BusinessEntityID])
ALTER TABLE [Purchasing].[ProductVendor]
    CHECK CONSTRAINT [FK_ProductVendor_Vendor_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Vendor.BusinessEntityID.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'CONSTRAINT', N'FK_ProductVendor_Vendor_BusinessEntityID'
GO
CREATE NONCLUSTERED INDEX [IX_ProductVendor_BusinessEntityID]
    ON [Purchasing].[ProductVendor] ([BusinessEntityID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'INDEX', N'IX_ProductVendor_BusinessEntityID'
GO
CREATE NONCLUSTERED INDEX [IX_ProductVendor_UnitMeasureCode]
    ON [Purchasing].[ProductVendor] ([UnitMeasureCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'INDEX', N'IX_ProductVendor_UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The average span of time (in days) between placing an order with the vendor and receiving the purchased product.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'AverageLeadTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Vendor.BusinessEntityID.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The selling price when last purchased.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'LastReceiptCost'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the product was last received by the vendor.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'LastReceiptDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The minimum quantity that should be ordered.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'MaxOrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The maximum quantity that should be ordered.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'MinOrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The quantity currently on order.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'OnOrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Product.ProductID.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The vendor''s usual selling price.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'StandardPrice'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The product''s unit of measure.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', 'COLUMN', N'UnitMeasureCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping vendors with the products they supply.', 'SCHEMA', N'Purchasing', 'TABLE', N'ProductVendor', NULL, NULL
GO

Collapse image See also

List of tables


PurchaseOrderDetail

Table: AdventureWorks2016CTP3.Purchasing.PurchaseOrderDetail

Collapse image Description

Individual products associated with a specific purchase order. See PurchaseOrderHeader.

Collapse image Table properties

Name | Value
Schema | Purchasing
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1170103209
Located on | PRIMARY
Data size KB | 512 KB
Index size KB | 192 KB
Rows | 8845
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_PurchaseOrderDetail_PurchaseOrderID_PurchaseOrderDetailID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | Foreign key | PurchaseOrderID | Primary key. Foreign key to PurchaseOrderHeader.PurchaseOrderID. |  | int | 4 |  |  |  |  |
Primary key | Identity |  | PurchaseOrderDetailID | Primary key. One line number per purchased product. |  | int | 4 |  |  |  |  |
 |  |  | DueDate | Date the product is expected to be received. |  | datetime | 8 |  |  |  |  |
 |  |  | OrderQty | Quantity ordered. |  | smallint | 2 |  |  |  |  |
 |  | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |  |
 |  |  | UnitPrice | Vendor's selling price of a single product. |  | money | 8 |  |  |  |  |
 |  |  | LineTotal | Per product subtotal. Computed as OrderQty * UnitPrice. | True | money | 8 |  |  |  |  | (isnull([OrderQty]*[UnitPrice],(0.00)))
 |  |  | ReceivedQty | Quantity actually received from the vendor. |  | decimal | 5 |  |  |  |  |
 |  |  | RejectedQty | Quantity rejected during inspection. |  | decimal | 5 |  |  |  |  |
 |  |  | StockedQty | Quantity accepted into inventory. Computed as ReceivedQty - RejectedQty. | True | decimal | 5 |  |  |  |  | (isnull([ReceivedQty]-[RejectedQty],(0.00)))
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 11 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_PurchaseOrderDetail_PurchaseOrderID_PurchaseOrderDetailID | PurchaseOrderID | Primary key (clustered) constraint |  |  | 704 | 0
IX_PurchaseOrderDetail_ProductID | ProductID | Nonclustered index. |  |  | 176 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_PurchaseOrderDetail_OrderQty | ([OrderQty]>(0))
CK_PurchaseOrderDetail_ReceivedQty | ([ReceivedQty]>=(0.00))
CK_PurchaseOrderDetail_RejectedQty | ([RejectedQty]>=(0.00))
CK_PurchaseOrderDetail_UnitPrice | ([UnitPrice]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
PurchaseOrderDetailID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_PurchaseOrderDetail_Product_ProductID
Purchasing.PurchaseOrderHeader | PK_PurchaseOrderHeader_PurchaseOrderID | FK_PurchaseOrderDetail_PurchaseOrderHeader_PurchaseOrderID
Total: 2 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Purchasing.iPurchaseOrderDetail | Purchasing |  |  | For Insert |  |  | Purchasing.PurchaseOrderDetail
Purchasing.uPurchaseOrderDetail | Purchasing |  |  |  | For Update |  | Purchasing.PurchaseOrderDetail
Total: 2 triggers(s)

Collapse image Objects that depend on Purchasing.PurchaseOrderDetail

Object name | Object type | Dep level
Purchasing.iPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Total 2 object(s)

Collapse image Objects that Purchasing.PurchaseOrderDetail depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Production.Product | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Individual products associated with a specific purchase order. See PurchaseOrderHeader.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Purchasing].[PurchaseOrderDetail] (
        [PurchaseOrderID]           [int] NOT NULL,
        [PurchaseOrderDetailID]     [int] IDENTITY(1, 1) NOT NULL,
        [DueDate]                   [datetime] NOT NULL,
        [OrderQty]                  [smallint] NOT NULL,
        [ProductID]                 [int] NOT NULL,
        [UnitPrice]                 [money] NOT NULL,
        [LineTotal]                 AS (isnull([OrderQty]*[UnitPrice],(0.00))),
        [ReceivedQty]               [decimal](8, 2) NOT NULL,
        [RejectedQty]               [decimal](8, 2) NOT NULL,
        [StockedQty]                AS (isnull([ReceivedQty]-[RejectedQty],(0.00))),
        [ModifiedDate]              [datetime] NOT NULL,
        CONSTRAINT [PK_PurchaseOrderDetail_PurchaseOrderID_PurchaseOrderDetailID]
        PRIMARY KEY
        CLUSTERED
        ([PurchaseOrderID], [PurchaseOrderDetailID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'PK_PurchaseOrderDetail_PurchaseOrderID_PurchaseOrderDetailID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'INDEX', N'PK_PurchaseOrderDetail_PurchaseOrderID_PurchaseOrderDetailID'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    ADD
    CONSTRAINT [CK_PurchaseOrderDetail_OrderQty]
    CHECK
    ([OrderQty]>(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [OrderQty] > (0)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'CK_PurchaseOrderDetail_OrderQty'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
CHECK CONSTRAINT [CK_PurchaseOrderDetail_OrderQty]
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    ADD
    CONSTRAINT [CK_PurchaseOrderDetail_ReceivedQty]
    CHECK
    ([ReceivedQty]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ReceivedQty] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'CK_PurchaseOrderDetail_ReceivedQty'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
CHECK CONSTRAINT [CK_PurchaseOrderDetail_ReceivedQty]
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    ADD
    CONSTRAINT [CK_PurchaseOrderDetail_RejectedQty]
    CHECK
    ([RejectedQty]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [RejectedQty] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'CK_PurchaseOrderDetail_RejectedQty'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
CHECK CONSTRAINT [CK_PurchaseOrderDetail_RejectedQty]
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    ADD
    CONSTRAINT [CK_PurchaseOrderDetail_UnitPrice]
    CHECK
    ([UnitPrice]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [UnitPrice] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'CK_PurchaseOrderDetail_UnitPrice'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
CHECK CONSTRAINT [CK_PurchaseOrderDetail_UnitPrice]
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    ADD
    CONSTRAINT [DF_PurchaseOrderDetail_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'DF_PurchaseOrderDetail_ModifiedDate'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    WITH CHECK
    ADD CONSTRAINT [FK_PurchaseOrderDetail_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    CHECK CONSTRAINT [FK_PurchaseOrderDetail_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'FK_PurchaseOrderDetail_Product_ProductID'
GO
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    WITH CHECK
    ADD CONSTRAINT [FK_PurchaseOrderDetail_PurchaseOrderHeader_PurchaseOrderID]
    FOREIGN KEY ([PurchaseOrderID]) REFERENCES [Purchasing].[PurchaseOrderHeader] ([PurchaseOrderID])
ALTER TABLE [Purchasing].[PurchaseOrderDetail]
    CHECK CONSTRAINT [FK_PurchaseOrderDetail_PurchaseOrderHeader_PurchaseOrderID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing PurchaseOrderHeader.PurchaseOrderID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'CONSTRAINT', N'FK_PurchaseOrderDetail_PurchaseOrderHeader_PurchaseOrderID'
GO
CREATE NONCLUSTERED INDEX [IX_PurchaseOrderDetail_ProductID]
    ON [Purchasing].[PurchaseOrderDetail] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'INDEX', N'IX_PurchaseOrderDetail_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the product is expected to be received.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'DueDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Per product subtotal. Computed as OrderQty * UnitPrice.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'LineTotal'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity ordered.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'OrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. One line number per purchased product.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'PurchaseOrderDetailID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to PurchaseOrderHeader.PurchaseOrderID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'PurchaseOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity actually received from the vendor.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'ReceivedQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity rejected during inspection.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'RejectedQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity accepted into inventory. Computed as ReceivedQty - RejectedQty.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'StockedQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor''s selling price of a single product.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'COLUMN', N'UnitPrice'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Individual products associated with a specific purchase order. See PurchaseOrderHeader.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', NULL, NULL
GO

Collapse image See also

List of tables


PurchaseOrderHeader

Table: AdventureWorks2016CTP3.Purchasing.PurchaseOrderHeader

Collapse image Description

General purchase order information. See PurchaseOrderDetail.

Collapse image Table properties

Name | Value
Schema | Purchasing
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1266103551
Located on | PRIMARY
Data size KB | 336 KB
Index size KB | 160 KB
Rows | 4012
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_PurchaseOrderHeader_PurchaseOrderID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | PurchaseOrderID | Primary key. |  | int | 4 |  |  |  |  |
 |  |  | RevisionNumber | Incremental number to track changes to the purchase order over time. |  | tinyint | 1 |  | ((0)) |  |  |
 |  |  | Status | Order current status. 1 = Pending; 2 = Approved; 3 = Rejected; 4 = Complete |  | tinyint | 1 |  | ((1)) |  |  |
 |  | Foreign key | EmployeeID | Employee who created the purchase order. Foreign key to Employee.BusinessEntityID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | VendorID | Vendor with whom the purchase order is placed. Foreign key to Vendor.BusinessEntityID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | ShipMethodID | Shipping method. Foreign key to ShipMethod.ShipMethodID. |  | int | 4 |  |  |  |  |
 |  |  | OrderDate | Purchase order creation date. |  | datetime | 8 |  | (getdate()) |  |  |
 |  |  | ShipDate | Estimated shipment date from the vendor. |  | datetime | 8 |  |  |  |  |
 |  |  | SubTotal | Purchase order subtotal. Computed as SUM(PurchaseOrderDetail.LineTotal)for the appropriate PurchaseOrderID. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | TaxAmt | Tax amount. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | Freight | Shipping cost. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | TotalDue | Total due to vendor. Computed as Subtotal + TaxAmt + Freight. | True | money | 8 |  |  |  |  | (isnull(([SubTotal]+[TaxAmt])+[Freight],(0)))
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 13 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_PurchaseOrderHeader_PurchaseOrderID | PurchaseOrderID | Primary key (clustered) constraint |  |  | 496 | 0
IX_PurchaseOrderHeader_EmployeeID | EmployeeID | Nonclustered index. |  |  | 72 | 0
IX_PurchaseOrderHeader_VendorID | VendorID | Nonclustered index. |  |  | 72 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_PurchaseOrderHeader_Freight | ([Freight]>=(0.00))
CK_PurchaseOrderHeader_ShipDate | ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
CK_PurchaseOrderHeader_Status | ([Status]>=(1) AND [Status]<=(4))
CK_PurchaseOrderHeader_SubTotal | ([SubTotal]>=(0.00))
CK_PurchaseOrderHeader_TaxAmt | ([TaxAmt]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
PurchaseOrderID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Purchasing.PurchaseOrderDetail | FK_PurchaseOrderDetail_PurchaseOrderHeader_PurchaseOrderID | PK_PurchaseOrderHeader_PurchaseOrderID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_PurchaseOrderHeader_Employee_EmployeeID
Purchasing.ShipMethod | PK_ShipMethod_ShipMethodID | FK_PurchaseOrderHeader_ShipMethod_ShipMethodID
Purchasing.Vendor | PK_Vendor_BusinessEntityID | FK_PurchaseOrderHeader_Vendor_VendorID
Total: 3 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Purchasing.uPurchaseOrderHeader | Purchasing |  |  |  | For Update |  | Purchasing.PurchaseOrderHeader
Total: 1 triggers(s)

Collapse image Objects that depend on Purchasing.PurchaseOrderHeader

Object name | Object type | Dep level
Purchasing.PurchaseOrderDetail | Table | 1
Purchasing.iPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderDetail | Trigger | 1
Purchasing.uPurchaseOrderHeader | Trigger | 1
Total 4 object(s)

Collapse image Objects that Purchasing.PurchaseOrderHeader depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
HumanResources.Employee | Table | 1
Purchasing.ShipMethod | Table | 1
Purchasing.Vendor | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | General purchase order information. See PurchaseOrderDetail.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Purchasing].[PurchaseOrderHeader] (
        [PurchaseOrderID]     [int] IDENTITY(1, 1) NOT NULL,
        [RevisionNumber]      [tinyint] NOT NULL,
        [Status]              [tinyint] NOT NULL,
        [EmployeeID]          [int] NOT NULL,
        [VendorID]            [int] NOT NULL,
        [ShipMethodID]        [int] NOT NULL,
        [OrderDate]           [datetime] NOT NULL,
        [ShipDate]            [datetime] NULL,
        [SubTotal]            [money] NOT NULL,
        [TaxAmt]              [money] NOT NULL,
        [Freight]             [money] NOT NULL,
        [TotalDue]            AS (isnull(([SubTotal]+[TaxAmt])+[Freight],(0))) PERSISTED NOT NULL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [PK_PurchaseOrderHeader_PurchaseOrderID]
        PRIMARY KEY
        CLUSTERED
        ([PurchaseOrderID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'PK_PurchaseOrderHeader_PurchaseOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'INDEX', N'PK_PurchaseOrderHeader_PurchaseOrderID'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [CK_PurchaseOrderHeader_Freight]
    CHECK
    ([Freight]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Freight] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'CK_PurchaseOrderHeader_Freight'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
CHECK CONSTRAINT [CK_PurchaseOrderHeader_Freight]
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [CK_PurchaseOrderHeader_ShipDate]
    CHECK
    ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ShipDate] >= [OrderDate] OR [ShipDate] IS NULL', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'CK_PurchaseOrderHeader_ShipDate'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
CHECK CONSTRAINT [CK_PurchaseOrderHeader_ShipDate]
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [CK_PurchaseOrderHeader_Status]
    CHECK
    ([Status]>=(1) AND [Status]<=(4))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Status] BETWEEN (1) AND (4)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'CK_PurchaseOrderHeader_Status'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
CHECK CONSTRAINT [CK_PurchaseOrderHeader_Status]
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [CK_PurchaseOrderHeader_SubTotal]
    CHECK
    ([SubTotal]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SubTotal] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'CK_PurchaseOrderHeader_SubTotal'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
CHECK CONSTRAINT [CK_PurchaseOrderHeader_SubTotal]
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [CK_PurchaseOrderHeader_TaxAmt]
    CHECK
    ([TaxAmt]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [TaxAmt] >= (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'CK_PurchaseOrderHeader_TaxAmt'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
CHECK CONSTRAINT [CK_PurchaseOrderHeader_TaxAmt]
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_Freight]
    DEFAULT ((0.00)) FOR [Freight]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_Freight'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_ModifiedDate'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_OrderDate]
    DEFAULT (getdate()) FOR [OrderDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_OrderDate'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_RevisionNumber]
    DEFAULT ((0)) FOR [RevisionNumber]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_RevisionNumber'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_Status]
    DEFAULT ((1)) FOR [Status]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_Status'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_SubTotal]
    DEFAULT ((0.00)) FOR [SubTotal]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_SubTotal'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    ADD
    CONSTRAINT [DF_PurchaseOrderHeader_TaxAmt]
    DEFAULT ((0.00)) FOR [TaxAmt]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'DF_PurchaseOrderHeader_TaxAmt'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_PurchaseOrderHeader_Employee_EmployeeID]
    FOREIGN KEY ([EmployeeID]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    CHECK CONSTRAINT [FK_PurchaseOrderHeader_Employee_EmployeeID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.EmployeeID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'FK_PurchaseOrderHeader_Employee_EmployeeID'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_PurchaseOrderHeader_ShipMethod_ShipMethodID]
    FOREIGN KEY ([ShipMethodID]) REFERENCES [Purchasing].[ShipMethod] ([ShipMethodID])
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    CHECK CONSTRAINT [FK_PurchaseOrderHeader_ShipMethod_ShipMethodID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ShipMethod.ShipMethodID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'FK_PurchaseOrderHeader_ShipMethod_ShipMethodID'
GO
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_PurchaseOrderHeader_Vendor_VendorID]
    FOREIGN KEY ([VendorID]) REFERENCES [Purchasing].[Vendor] ([BusinessEntityID])
ALTER TABLE [Purchasing].[PurchaseOrderHeader]
    CHECK CONSTRAINT [FK_PurchaseOrderHeader_Vendor_VendorID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Vendor.VendorID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'CONSTRAINT', N'FK_PurchaseOrderHeader_Vendor_VendorID'
GO
CREATE NONCLUSTERED INDEX [IX_PurchaseOrderHeader_EmployeeID]
    ON [Purchasing].[PurchaseOrderHeader] ([EmployeeID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'INDEX', N'IX_PurchaseOrderHeader_EmployeeID'
GO
CREATE NONCLUSTERED INDEX [IX_PurchaseOrderHeader_VendorID]
    ON [Purchasing].[PurchaseOrderHeader] ([VendorID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'INDEX', N'IX_PurchaseOrderHeader_VendorID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee who created the purchase order. Foreign key to Employee.BusinessEntityID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'EmployeeID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping cost.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'Freight'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Purchase order creation date.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'OrderDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'PurchaseOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Incremental number to track changes to the purchase order over time.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'RevisionNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Estimated shipment date from the vendor.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'ShipDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping method. Foreign key to ShipMethod.ShipMethodID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'ShipMethodID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Order current status. 1 = Pending; 2 = Approved; 3 = Rejected; 4 = Complete', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'Status'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Purchase order subtotal. Computed as SUM(PurchaseOrderDetail.LineTotal)for the appropriate PurchaseOrderID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'SubTotal'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tax amount.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'TaxAmt'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Total due to vendor. Computed as Subtotal + TaxAmt + Freight.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'TotalDue'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor with whom the purchase order is placed. Foreign key to Vendor.BusinessEntityID.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'COLUMN', N'VendorID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'General purchase order information. See PurchaseOrderDetail.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', NULL, NULL
GO

Collapse image See also

List of tables


ShipMethod

Table: AdventureWorks2016CTP3.Purchasing.ShipMethod

Collapse image Description

Shipping company lookup table.

Collapse image Table properties

Name | Value
Schema | Purchasing
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 398624463
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 5
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ShipMethod_ShipMethodID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | ShipMethodID | Primary key for ShipMethod records. |  | int | 4 |  |  |  |
 |  | Name | Shipping company name. |  | Name | 50 |  |  |  |
 |  | ShipBase | Minimum shipping charge. |  | money | 8 |  | ((0.00)) |  |
 |  | ShipRate | Shipping charge per pound. |  | money | 8 |  | ((0.00)) |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 16 | 12 | 18 | 0.18000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ShipMethod_ShipMethodID | ShipMethodID | Primary key (clustered) constraint |  |  | 48 | 0
AK_ShipMethod_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_ShipMethod_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ShipMethod_ShipBase | ([ShipBase]>(0.00))
CK_ShipMethod_ShipRate | ([ShipRate]>(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ShipMethodID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Purchasing.PurchaseOrderHeader | FK_PurchaseOrderHeader_ShipMethod_ShipMethodID | PK_ShipMethod_ShipMethodID
Sales.SalesOrderHeader | FK_SalesOrderHeader_ShipMethod_ShipMethodID | PK_ShipMethod_ShipMethodID
Total: 2 table(s)

Collapse image Objects that depend on Purchasing.ShipMethod

Object name | Object type | Dep level
Purchasing.PurchaseOrderHeader | Table | 1
Sales.SalesOrderHeader | Table | 1
Total 2 object(s)

Collapse image Objects that Purchasing.ShipMethod depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Shipping company lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Purchasing].[ShipMethod] (
        [ShipMethodID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [ShipBase]         [money] NOT NULL,
        [ShipRate]         [money] NOT NULL,
        [rowguid]          [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_ShipMethod_ShipMethodID]
        PRIMARY KEY
        CLUSTERED
        ([ShipMethodID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'PK_ShipMethod_ShipMethodID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'INDEX', N'PK_ShipMethod_ShipMethodID'
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [CK_ShipMethod_ShipBase]
    CHECK
    ([ShipBase]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ShipBase] > (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'CK_ShipMethod_ShipBase'
GO
ALTER TABLE [Purchasing].[ShipMethod]
CHECK CONSTRAINT [CK_ShipMethod_ShipBase]
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [CK_ShipMethod_ShipRate]
    CHECK
    ([ShipRate]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ShipRate] > (0.00)', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'CK_ShipMethod_ShipRate'
GO
ALTER TABLE [Purchasing].[ShipMethod]
CHECK CONSTRAINT [CK_ShipMethod_ShipRate]
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [DF_ShipMethod_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'DF_ShipMethod_ModifiedDate'
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [DF_ShipMethod_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'DF_ShipMethod_rowguid'
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [DF_ShipMethod_ShipBase]
    DEFAULT ((0.00)) FOR [ShipBase]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'DF_ShipMethod_ShipBase'
GO
ALTER TABLE [Purchasing].[ShipMethod]
    ADD
    CONSTRAINT [DF_ShipMethod_ShipRate]
    DEFAULT ((0.00)) FOR [ShipRate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'CONSTRAINT', N'DF_ShipMethod_ShipRate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ShipMethod_Name]
    ON [Purchasing].[ShipMethod] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'INDEX', N'AK_ShipMethod_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_ShipMethod_rowguid]
    ON [Purchasing].[ShipMethod] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'INDEX', N'AK_ShipMethod_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping company name.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Minimum shipping charge.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'ShipBase'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ShipMethod records.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'ShipMethodID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping charge per pound.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', 'COLUMN', N'ShipRate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping company lookup table.', 'SCHEMA', N'Purchasing', 'TABLE', N'ShipMethod', NULL, NULL
GO

Collapse image See also

List of tables


Vendor

Table: AdventureWorks2016CTP3.Purchasing.Vendor

Collapse image Description

Companies from whom Adventure Works Cycles purchases parts or other goods.

Collapse image Table properties

Name | Value
Schema | Purchasing
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1086626914
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 32 KB
Rows | 104
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Vendor_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key for Vendor records. Foreign key to BusinessEntity.BusinessEntityID |  | int | 4 |  |  |  |
 |  | AccountNumber | Vendor account (identification) number. |  | AccountNumber | 15 |  |  |  |
 |  | Name | Company name. |  | Name | 50 |  |  |  |
 |  | CreditRating | 1 = Superior, 2 = Excellent, 3 = Above average, 4 = Average, 5 = Below average |  | tinyint | 1 |  |  |  |
 |  | PreferredVendorStatus | 0 = Do not use if another vendor is available. 1 = Preferred over other vendors supplying the same product. |  | Flag | 1 |  | ((1)) |  |
 |  | ActiveFlag | 0 = Vendor no longer used. 1 = Vendor is actively used. |  | Flag | 1 |  | ((1)) |  |
 |  | PurchasingWebServiceURL | Vendor URL. |  | nvarchar | 1024 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 8 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
AccountNumber | nvarchar(15) | 11 | 9 | 12 | 0.40000000000000
Name | nvarchar(50) | 18 | 5 | 33 | 0.33000000000000
PurchasingWebServiceURL | nvarchar(1024) | 1 | 15 | 27 | 0.01318359375000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Vendor_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 48 | 0
AK_Vendor_AccountNumber | AccountNumber | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_Vendor_CreditRating | ([CreditRating]>=(1) AND [CreditRating]<=(5))

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Purchasing.ProductVendor | FK_ProductVendor_Vendor_BusinessEntityID | PK_Vendor_BusinessEntityID
Purchasing.PurchaseOrderHeader | FK_PurchaseOrderHeader_Vendor_VendorID | PK_Vendor_BusinessEntityID
Total: 2 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.BusinessEntity | PK_BusinessEntity_BusinessEntityID | FK_Vendor_BusinessEntity_BusinessEntityID
Total: 1 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Purchasing.dVendor | Purchasing |  |  |  |  | For Delete | Purchasing.Vendor
Total: 1 triggers(s)

Collapse image Objects that depend on Purchasing.Vendor

Object name | Object type | Dep level
Purchasing.ProductVendor | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Purchasing.dVendor | Trigger | 1
ufnGetContactInformation | Function | 1
Purchasing.vVendorWithAddresses | View | 1
Purchasing.vVendorWithContacts | View | 1
Total 6 object(s)

Collapse image Objects that Purchasing.Vendor depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Person.BusinessEntity | Table | 1
AccountNumber | Datatype | 1
Flag | Datatype | 1
Name | Datatype | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Companies from whom Adventure Works Cycles purchases parts or other goods.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Purchasing].[Vendor] (
        [BusinessEntityID]            [int] NOT NULL,
        [AccountNumber]               [dbo].[AccountNumber] NOT NULL,
        [Name]                        [dbo].[Name] NOT NULL,
        [CreditRating]                [tinyint] NOT NULL,
        [PreferredVendorStatus]       [dbo].[Flag] NOT NULL,
        [ActiveFlag]                  [dbo].[Flag] NOT NULL,
        [PurchasingWebServiceURL]     [nvarchar](1024) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ModifiedDate]                [datetime] NOT NULL,
        CONSTRAINT [PK_Vendor_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'PK_Vendor_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'INDEX', N'PK_Vendor_BusinessEntityID'
GO
ALTER TABLE [Purchasing].[Vendor]
    ADD
    CONSTRAINT [CK_Vendor_CreditRating]
    CHECK
    ([CreditRating]>=(1) AND [CreditRating]<=(5))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [CreditRating] BETWEEN (1) AND (5)', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'CK_Vendor_CreditRating'
GO
ALTER TABLE [Purchasing].[Vendor]
CHECK CONSTRAINT [CK_Vendor_CreditRating]
GO
ALTER TABLE [Purchasing].[Vendor]
    ADD
    CONSTRAINT [DF_Vendor_ActiveFlag]
    DEFAULT ((1)) FOR [ActiveFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1 (TRUE)', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'DF_Vendor_ActiveFlag'
GO
ALTER TABLE [Purchasing].[Vendor]
    ADD
    CONSTRAINT [DF_Vendor_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'DF_Vendor_ModifiedDate'
GO
ALTER TABLE [Purchasing].[Vendor]
    ADD
    CONSTRAINT [DF_Vendor_PreferredVendorStatus]
    DEFAULT ((1)) FOR [PreferredVendorStatus]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1 (TRUE)', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'DF_Vendor_PreferredVendorStatus'
GO
ALTER TABLE [Purchasing].[Vendor]
    WITH CHECK
    ADD CONSTRAINT [FK_Vendor_BusinessEntity_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[BusinessEntity] ([BusinessEntityID])
ALTER TABLE [Purchasing].[Vendor]
    CHECK CONSTRAINT [FK_Vendor_BusinessEntity_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing BusinessEntity.BusinessEntityID', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'CONSTRAINT', N'FK_Vendor_BusinessEntity_BusinessEntityID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Vendor_AccountNumber]
    ON [Purchasing].[Vendor] ([AccountNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'INDEX', N'AK_Vendor_AccountNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor account (identification) number.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'AccountNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Vendor no longer used. 1 = Vendor is actively used.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'ActiveFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for Vendor records.  Foreign key to BusinessEntity.BusinessEntityID', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'1 = Superior, 2 = Excellent, 3 = Above average, 4 = Average, 5 = Below average', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'CreditRating'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Company name.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Do not use if another vendor is available. 1 = Preferred over other vendors supplying the same product.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'PreferredVendorStatus'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor URL.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'COLUMN', N'PurchasingWebServiceURL'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Companies from whom Adventure Works Cycles purchases parts or other goods.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', NULL, NULL
GO

Collapse image See also

List of tables


CountryRegionCurrency

Table: AdventureWorks2016CTP3.Sales.CountryRegionCurrency

Collapse image Description

Cross-reference table mapping ISO currency codes to a country or region.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1125579048
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 109
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_CountryRegionCurrency_CountryRegionCode_CurrencyCode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | CountryRegionCode | ISO code for countries and regions. Foreign key to CountryRegion.CountryRegionCode. |  | nvarchar | 3 |  |  |  |
Primary key | Foreign key | CurrencyCode | ISO standard currency code. Foreign key to Currency.CurrencyCode. |  | nchar | 3 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CountryRegionCode | nvarchar(3) | 2 | 2 | 2 | 0.33333333333333
CurrencyCode | nchar(3) | 3 | 3 | 3 | 0.50000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_CountryRegionCurrency_CountryRegionCode_CurrencyCode | CountryRegionCode | Primary key (clustered) constraint |  |  | 32 | 0
IX_CountryRegionCurrency_CurrencyCode | CurrencyCode | Nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.CountryRegion | PK_CountryRegion_CountryRegionCode | FK_CountryRegionCurrency_CountryRegion_CountryRegionCode
Sales.Currency | PK_Currency_CurrencyCode | FK_CountryRegionCurrency_Currency_CurrencyCode
Total: 2 table(s)

Collapse image Objects that Sales.CountryRegionCurrency depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.CountryRegion | Table | 1
Sales.Currency | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping ISO currency codes to a country or region.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[CountryRegionCurrency] (
        [CountryRegionCode]     [nvarchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [CurrencyCode]          [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_CountryRegionCurrency_CountryRegionCode_CurrencyCode]
        PRIMARY KEY
        CLUSTERED
        ([CountryRegionCode], [CurrencyCode])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'CONSTRAINT', N'PK_CountryRegionCurrency_CountryRegionCode_CurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'INDEX', N'PK_CountryRegionCurrency_CountryRegionCode_CurrencyCode'
GO
ALTER TABLE [Sales].[CountryRegionCurrency]
    ADD
    CONSTRAINT [DF_CountryRegionCurrency_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'CONSTRAINT', N'DF_CountryRegionCurrency_ModifiedDate'
GO
ALTER TABLE [Sales].[CountryRegionCurrency]
    WITH CHECK
    ADD CONSTRAINT [FK_CountryRegionCurrency_CountryRegion_CountryRegionCode]
    FOREIGN KEY ([CountryRegionCode]) REFERENCES [Person].[CountryRegion] ([CountryRegionCode])
ALTER TABLE [Sales].[CountryRegionCurrency]
    CHECK CONSTRAINT [FK_CountryRegionCurrency_CountryRegion_CountryRegionCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CountryRegion.CountryRegionCode.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'CONSTRAINT', N'FK_CountryRegionCurrency_CountryRegion_CountryRegionCode'
GO
ALTER TABLE [Sales].[CountryRegionCurrency]
    WITH CHECK
    ADD CONSTRAINT [FK_CountryRegionCurrency_Currency_CurrencyCode]
    FOREIGN KEY ([CurrencyCode]) REFERENCES [Sales].[Currency] ([CurrencyCode])
ALTER TABLE [Sales].[CountryRegionCurrency]
    CHECK CONSTRAINT [FK_CountryRegionCurrency_Currency_CurrencyCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Currency.CurrencyCode.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'CONSTRAINT', N'FK_CountryRegionCurrency_Currency_CurrencyCode'
GO
CREATE NONCLUSTERED INDEX [IX_CountryRegionCurrency_CurrencyCode]
    ON [Sales].[CountryRegionCurrency] ([CurrencyCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'INDEX', N'IX_CountryRegionCurrency_CurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO code for countries and regions. Foreign key to CountryRegion.CountryRegionCode.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'COLUMN', N'CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO standard currency code. Foreign key to Currency.CurrencyCode.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'COLUMN', N'CurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping ISO currency codes to a country or region.', 'SCHEMA', N'Sales', 'TABLE', N'CountryRegionCurrency', NULL, NULL
GO

Collapse image See also

List of tables


CreditCard

Table: AdventureWorks2016CTP3.Sales.CreditCard

Collapse image Description

Customer credit card information.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1189579276
Located on | PRIMARY
Data size KB | 1496 KB
Index size KB | 832 KB
Rows | 19118
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_CreditCard_CreditCardID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | CreditCardID | Primary key for CreditCard records. |  | int | 4 |  |  |  |
 |  | CardType | Credit card name. |  | nvarchar | 50 |  |  |  |
 |  | CardNumber | Credit card number. |  | nvarchar | 25 |  |  |  |
 |  | ExpMonth | Credit card expiration month. |  | tinyint | 1 |  |  |  |
 |  | ExpYear | Credit card expiration year. |  | smallint | 2 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CardType | nvarchar(50) | 10 | 5 | 13 | 0.13000000000000
CardNumber | nvarchar(25) | 14 | 14 | 14 | 0.28000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_CreditCard_CreditCardID | CreditCardID | Primary key (clustered) constraint |  |  | 2328 | 0
AK_CreditCard_CardNumber | CardNumber | Unique nonclustered index. |  |  | 816 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
CreditCardID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.PersonCreditCard | FK_PersonCreditCard_CreditCard_CreditCardID | PK_CreditCard_CreditCardID
Sales.SalesOrderHeader | FK_SalesOrderHeader_CreditCard_CreditCardID | PK_CreditCard_CreditCardID
Total: 2 table(s)

Collapse image Objects that depend on Sales.CreditCard

Object name | Object type | Dep level
Sales.PersonCreditCard | Table | 1
Sales.SalesOrderHeader | Table | 1
Total 2 object(s)

Collapse image Objects that Sales.CreditCard depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Customer credit card information.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[CreditCard] (
        [CreditCardID]     [int] IDENTITY(1, 1) NOT NULL,
        [CardType]         [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [CardNumber]       [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ExpMonth]         [tinyint] NOT NULL,
        [ExpYear]          [smallint] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_CreditCard_CreditCardID]
        PRIMARY KEY
        CLUSTERED
        ([CreditCardID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'CONSTRAINT', N'PK_CreditCard_CreditCardID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'INDEX', N'PK_CreditCard_CreditCardID'
GO
ALTER TABLE [Sales].[CreditCard]
    ADD
    CONSTRAINT [DF_CreditCard_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'CONSTRAINT', N'DF_CreditCard_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_CreditCard_CardNumber]
    ON [Sales].[CreditCard] ([CardNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'INDEX', N'AK_CreditCard_CardNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card number.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'CardNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card name.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'CardType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for CreditCard records.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'CreditCardID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card expiration month.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'ExpMonth'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card expiration year.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'ExpYear'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer credit card information.', 'SCHEMA', N'Sales', 'TABLE', N'CreditCard', NULL, NULL
GO

Collapse image See also

List of tables


Currency

Table: AdventureWorks2016CTP3.Sales.Currency

Collapse image Description

Lookup table containing standard ISO currencies.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1253579504
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 105
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Currency_CurrencyCode]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | CurrencyCode | The ISO code for the Currency. |  | nchar | 3 |  |  |  |
 | Name | Currency name. |  | Name | 50 |  |  |  |
 | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CurrencyCode | nchar(3) | 3 | 3 | 3 | 0.50000000000000
Name | nvarchar(50) | 12 | 3 | 29 | 0.29000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Currency_CurrencyCode | CurrencyCode | Primary key (clustered) constraint |  |  | 32 | 0
AK_Currency_Name | Name | Unique nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.CountryRegionCurrency | FK_CountryRegionCurrency_Currency_CurrencyCode | PK_Currency_CurrencyCode
Sales.CurrencyRate | FK_CurrencyRate_Currency_FromCurrencyCode | PK_Currency_CurrencyCode
Sales.CurrencyRate | FK_CurrencyRate_Currency_ToCurrencyCode | PK_Currency_CurrencyCode
Total: 3 table(s)

Collapse image Objects that depend on Sales.Currency

Object name | Object type | Dep level
Sales.CountryRegionCurrency | Table | 1
Sales.CurrencyRate | Table | 1
Total 2 object(s)

Collapse image Objects that Sales.Currency depends on

Object name | Object type | Dep level
Sales | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table containing standard ISO currencies.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[Currency] (
        [CurrencyCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Name]             [dbo].[Name] NOT NULL,
        [ModifiedDate]     [datetime] NOT NULL,
        CONSTRAINT [PK_Currency_CurrencyCode]
        PRIMARY KEY
        CLUSTERED
        ([CurrencyCode])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'CONSTRAINT', N'PK_Currency_CurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'INDEX', N'PK_Currency_CurrencyCode'
GO
ALTER TABLE [Sales].[Currency]
    ADD
    CONSTRAINT [DF_Currency_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'CONSTRAINT', N'DF_Currency_ModifiedDate'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Currency_Name]
    ON [Sales].[Currency] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'INDEX', N'AK_Currency_Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The ISO code for the Currency.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'COLUMN', N'CurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Currency name.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table containing standard ISO currencies.', 'SCHEMA', N'Sales', 'TABLE', N'Currency', NULL, NULL
GO

Collapse image See also

List of tables


CurrencyRate

Table: AdventureWorks2016CTP3.Sales.CurrencyRate

Collapse image Description

Currency exchange rates.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1285579618
Located on | PRIMARY
Data size KB | 768 KB
Index size KB | 440 KB
Rows | 13532
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_CurrencyRate_CurrencyRateID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | CurrencyRateID | Primary key for CurrencyRate records. |  | int | 4 |  |  |  |
 |  |  | CurrencyRateDate | Date and time the exchange rate was obtained. |  | datetime | 8 |  |  |  |
 |  | Foreign key | FromCurrencyCode | Exchange rate was converted from this currency code. |  | nchar | 3 |  |  |  |
 |  | Foreign key | ToCurrencyCode | Exchange rate was converted to this currency code. |  | nchar | 3 |  |  |  |
 |  |  | AverageRate | Average exchange rate for the day. |  | money | 8 |  |  |  |
 |  |  | EndOfDayRate | Final exchange rate for the day. |  | money | 8 |  |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 7 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
FromCurrencyCode | nchar(3) | 3 | 3 | 3 | 0.50000000000000
ToCurrencyCode | nchar(3) | 3 | 3 | 3 | 0.50000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_CurrencyRate_CurrencyRateID | CurrencyRateID | Primary key (clustered) constraint |  |  | 1208 | 0
AK_CurrencyRate_CurrencyRateDate_FromCurrencyCode_ToCurrencyCode | CurrencyRateDate | Unique nonclustered index. |  |  | 424 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
CurrencyRateID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderHeader | FK_SalesOrderHeader_CurrencyRate_CurrencyRateID | PK_CurrencyRate_CurrencyRateID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.Currency | PK_Currency_CurrencyCode | FK_CurrencyRate_Currency_FromCurrencyCode
Sales.Currency | PK_Currency_CurrencyCode | FK_CurrencyRate_Currency_ToCurrencyCode
Total: 2 table(s)

Collapse image Objects that depend on Sales.CurrencyRate

Object name | Object type | Dep level
Sales.SalesOrderHeader | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.CurrencyRate depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.Currency | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Currency exchange rates.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[CurrencyRate] (
        [CurrencyRateID]       [int] IDENTITY(1, 1) NOT NULL,
        [CurrencyRateDate]     [datetime] NOT NULL,
        [FromCurrencyCode]     [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [ToCurrencyCode]       [nchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [AverageRate]          [money] NOT NULL,
        [EndOfDayRate]         [money] NOT NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_CurrencyRate_CurrencyRateID]
        PRIMARY KEY
        CLUSTERED
        ([CurrencyRateID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'CONSTRAINT', N'PK_CurrencyRate_CurrencyRateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'INDEX', N'PK_CurrencyRate_CurrencyRateID'
GO
ALTER TABLE [Sales].[CurrencyRate]
    ADD
    CONSTRAINT [DF_CurrencyRate_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'CONSTRAINT', N'DF_CurrencyRate_ModifiedDate'
GO
ALTER TABLE [Sales].[CurrencyRate]
    WITH CHECK
    ADD CONSTRAINT [FK_CurrencyRate_Currency_FromCurrencyCode]
    FOREIGN KEY ([FromCurrencyCode]) REFERENCES [Sales].[Currency] ([CurrencyCode])
ALTER TABLE [Sales].[CurrencyRate]
    CHECK CONSTRAINT [FK_CurrencyRate_Currency_FromCurrencyCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Currency.FromCurrencyCode.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'CONSTRAINT', N'FK_CurrencyRate_Currency_FromCurrencyCode'
GO
ALTER TABLE [Sales].[CurrencyRate]
    WITH CHECK
    ADD CONSTRAINT [FK_CurrencyRate_Currency_ToCurrencyCode]
    FOREIGN KEY ([ToCurrencyCode]) REFERENCES [Sales].[Currency] ([CurrencyCode])
ALTER TABLE [Sales].[CurrencyRate]
    CHECK CONSTRAINT [FK_CurrencyRate_Currency_ToCurrencyCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Currency.ToCurrencyCode.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'CONSTRAINT', N'FK_CurrencyRate_Currency_ToCurrencyCode'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_CurrencyRate_CurrencyRateDate_FromCurrencyCode_ToCurrencyCode]
    ON [Sales].[CurrencyRate] ([CurrencyRateDate], [FromCurrencyCode], [ToCurrencyCode])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'INDEX', N'AK_CurrencyRate_CurrencyRateDate_FromCurrencyCode_ToCurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Average exchange rate for the day.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'AverageRate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the exchange rate was obtained.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'CurrencyRateDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for CurrencyRate records.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'CurrencyRateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Final exchange rate for the day.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'EndOfDayRate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Exchange rate was converted from this currency code.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'FromCurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Exchange rate was converted to this currency code.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', 'COLUMN', N'ToCurrencyCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Currency exchange rates.', 'SCHEMA', N'Sales', 'TABLE', N'CurrencyRate', NULL, NULL
GO

Collapse image See also

List of tables


Customer

Table: AdventureWorks2016CTP3.Sales.Customer

Collapse image Description

Current customer information. Also see the Person and Store tables.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1317579732
Located on | PRIMARY
Data size KB | 968 KB
Index size KB | 1328 KB
Rows | 19820
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Customer_CustomerID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | CustomerID | Primary key. |  | int | 4 |  |  |  |  |
 |  | Foreign key | PersonID | Foreign key to Person.BusinessEntityID |  | int | 4 |  |  |  |  |
 |  | Foreign key | StoreID | Foreign key to Store.BusinessEntityID |  | int | 4 |  |  |  |  |
 |  | Foreign key | TerritoryID | ID of the territory in which the customer is located. Foreign key to SalesTerritory.SalesTerritoryID. |  | int | 4 |  |  |  |  |
 |  |  | AccountNumber | Unique number identifying the customer assigned by the accounting system. | True | varchar | 10 |  |  |  |  | (isnull('AW'+[dbo].[ufnLeadingZeros]([CustomerID]),''))
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 7 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
AccountNumber | varchar(10) | 10 | 10 | 10 | 1.00000000000000 | (isnull('AW'+[dbo].[ufnLeadingZeros]([CustomerID]),''))
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Customer_CustomerID | CustomerID | Primary key (clustered) constraint |  |  | 2296 | 0
AK_Customer_AccountNumber | AccountNumber | Unique nonclustered index. |  |  | 488 | 0
AK_Customer_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 528 | 0
IX_Customer_TerritoryID | TerritoryID | Nonclustered index. |  |  | 296 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
CustomerID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderHeader | FK_SalesOrderHeader_Customer_CustomerID | PK_Customer_CustomerID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Person | PK_Person_BusinessEntityID | FK_Customer_Person_PersonID
Sales.SalesTerritory | PK_SalesTerritory_TerritoryID | FK_Customer_SalesTerritory_TerritoryID
Sales.Store | PK_Store_BusinessEntityID | FK_Customer_Store_StoreID
Total: 3 table(s)

Collapse image Objects that depend on Sales.Customer

Object name | Object type | Dep level
Sales.SalesOrderHeader | Table | 1
Sales.iduSalesOrderDetail | Trigger | 1
ufnGetContactInformation | Function | 1
Sales.vIndividualCustomer | View | 1
Total 4 object(s)

Collapse image Objects that Sales.Customer depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Person | Table | 1
Sales.SalesTerritory | Table | 1
Sales.Store | Table | 1
ufnLeadingZeros | Function | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Current customer information. Also see the Person and Store tables.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[Customer] (
        [CustomerID]        [int] IDENTITY(1, 1) NOT FOR REPLICATION NOT NULL,
        [PersonID]          [int] NULL,
        [StoreID]           [int] NULL,
        [TerritoryID]       [int] NULL,
        [AccountNumber]     AS (isnull('AW'+[dbo].[ufnLeadingZeros]([CustomerID]),'')),
        [rowguid]           [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_Customer_CustomerID]
        PRIMARY KEY
        CLUSTERED
        ([CustomerID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'PK_Customer_CustomerID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'INDEX', N'PK_Customer_CustomerID'
GO
ALTER TABLE [Sales].[Customer]
    ADD
    CONSTRAINT [DF_Customer_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'DF_Customer_ModifiedDate'
GO
ALTER TABLE [Sales].[Customer]
    ADD
    CONSTRAINT [DF_Customer_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'DF_Customer_rowguid'
GO
ALTER TABLE [Sales].[Customer]
    WITH CHECK
    ADD CONSTRAINT [FK_Customer_Person_PersonID]
    FOREIGN KEY ([PersonID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Sales].[Customer]
    CHECK CONSTRAINT [FK_Customer_Person_PersonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'FK_Customer_Person_PersonID'
GO
ALTER TABLE [Sales].[Customer]
    WITH CHECK
    ADD CONSTRAINT [FK_Customer_SalesTerritory_TerritoryID]
    FOREIGN KEY ([TerritoryID]) REFERENCES [Sales].[SalesTerritory] ([TerritoryID])
ALTER TABLE [Sales].[Customer]
    CHECK CONSTRAINT [FK_Customer_SalesTerritory_TerritoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesTerritory.TerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'FK_Customer_SalesTerritory_TerritoryID'
GO
ALTER TABLE [Sales].[Customer]
    WITH CHECK
    ADD CONSTRAINT [FK_Customer_Store_StoreID]
    FOREIGN KEY ([StoreID]) REFERENCES [Sales].[Store] ([BusinessEntityID])
ALTER TABLE [Sales].[Customer]
    CHECK CONSTRAINT [FK_Customer_Store_StoreID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Store.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'CONSTRAINT', N'FK_Customer_Store_StoreID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Customer_AccountNumber]
    ON [Sales].[Customer] ([AccountNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'INDEX', N'AK_Customer_AccountNumber'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Customer_rowguid]
    ON [Sales].[Customer] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'INDEX', N'AK_Customer_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_Customer_TerritoryID]
    ON [Sales].[Customer] ([TerritoryID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'INDEX', N'IX_Customer_TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique number identifying the customer assigned by the accounting system.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'AccountNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'CustomerID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key to Person.BusinessEntityID', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'PersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key to Store.BusinessEntityID', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'StoreID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ID of the territory in which the customer is located. Foreign key to SalesTerritory.SalesTerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Current customer information. Also see the Person and Store tables.', 'SCHEMA', N'Sales', 'TABLE', N'Customer', NULL, NULL
GO

Collapse image See also

List of tables


CustomerPII

Table: AdventureWorks2016CTP3.Sales.CustomerPII

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1748201278
Located on | PRIMARY
Data size KB | 7992 KB
Index size KB | 8 KB
Rows | 19118
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key |
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
CustomerID |  |  | int | 4 |  |  |  |
FirstName |  |  | Name | 50 |  |  |  |
LastName |  |  | Name | 50 |  |  |  |
SSN |  |  | nvarchar | 11 |  |  |  |
CreditCardNumber |  |  | nvarchar | 25 |  |  |  |
EmailAddress |  |  | nvarchar | 50 |  |  |  |
PhoneNumber |  |  | nvarchar | 25 |  |  |  |
TerritoryID |  |  | int | 4 |  |  |  |
Total: 8 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
FirstName | nvarchar(50) | 5 | 2 | 24 | 0.24000000000000
LastName | nvarchar(50) | 5 | 2 | 22 | 0.22000000000000
EmailAddress | nvarchar(50) | 27 | 22 | 43 | 0.43000000000000
PhoneNumber | nvarchar(25) | 15 | 12 | 19 | 0.38000000000000
Total: 4 text column(s)

Collapse image Objects that Sales.CustomerPII depends on

Object name | Object type | Dep level
SalesManagers | Role | 1
SalesPersons | Role | 1
Sales | Schema | 1
Name | Datatype | 1
Total 4 object(s)

Collapse image Permissions

User/role | Alter | Control | Select | Insert | Update | Delete | DRI | Take ownership | View definition | Columns
SalesManagers |  |  |  |  |  |  |  |  |  |  | Columns
SalesPersons |  |  |  |  |  |  |  |  |  |  | Columns

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[CustomerPII] (
        [CustomerID]           [int] NOT NULL,
        [FirstName]            [dbo].[Name] NOT NULL,
        [LastName]             [dbo].[Name] NOT NULL,
        [SSN]                  [nvarchar](11) COLLATE Latin1_General_BIN2 NULL,
        [CreditCardNumber]     [nvarchar](25) COLLATE Latin1_General_BIN2 NULL,
        [EmailAddress]         [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS MASKED WITH (FUNCTION = 'email()') NULL,
        [PhoneNumber]          [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS MASKED WITH (FUNCTION = 'default()') NULL,
        [TerritoryID]          [int] NULL
) ON [PRIMARY]
GO
GRANT DELETE
    ON [Sales].[CustomerPII]
    TO [SalesManagers]
GO
GRANT DELETE
    ON [Sales].[CustomerPII]
    TO [SalesPersons]
GO
GRANT INSERT
    ON [Sales].[CustomerPII]
    TO [SalesManagers]
GO
GRANT INSERT
    ON [Sales].[CustomerPII]
    TO [SalesPersons]
GO
GRANT SELECT
    ON [Sales].[CustomerPII]
    TO [SalesManagers]
GO
GRANT SELECT
    ON [Sales].[CustomerPII]
    TO [SalesPersons]
GO
GRANT UPDATE
    ON [Sales].[CustomerPII]
    TO [SalesManagers]
GO
GRANT UPDATE
    ON [Sales].[CustomerPII]
    TO [SalesPersons]
GO

Collapse image See also

List of tables


OrderTracking

Table: AdventureWorks2016CTP3.Sales.OrderTracking

Collapse image Description

Individual tracking events associated with a specific sales order.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 16.11.2015
ID | 1997250170
Located on | PRIMARY
Data size KB | 35352 KB
Index size KB | 19056 KB
Rows | 188790
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_OrderTracking]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | OrderTrackingID | Primary key. |  | int | 4 |  |  |  |
 |  | SalesOrderID | Sales order identification number. Foreign key to SalesOrderHeader.SalesOrderID. |  | int | 4 |  |  |  |
 |  | CarrierTrackingNumber | Shipment tracking number supplied by the shipper. |  | nvarchar | 25 |  |  |  |
 |  | TrackingEventID | Tracking delivery event for Order shipped to customer. Foreign key to TrackingEvent.TrackingEventID. |  | int | 4 |  |  |  |
 |  | EventDetails | Details for a delivery tracking event. |  | nvarchar | 2000 |  |  |  |
 |  | EventDateTime | The date and time that a tracking event has occurred. |  | datetime2 | 8 |  |  |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CarrierTrackingNumber | nvarchar(25) | 23 | 12 | 25 | 0.50000000000000
EventDetails | nvarchar(2000) | 52 | 42 | 64 | 0.01600000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_OrderTracking | OrderTrackingID | Primary key (clustered) constraint |  |  | 54408 | 0
IX_OrderTracking_CarrierTrackingNumber | CarrierTrackingNumber |  |  |  | 15408 | 0
IX_OrderTracking_SalesOrderID | SalesOrderID |  |  |  | 3504 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
OrderTrackingID | 1 | 1 |

Collapse image Objects that depend on Sales.OrderTracking

Object name | Object type | Dep level
uspAddOrderTrackingEvent | Procedure | 1
uspGetOrderTrackingBySalesOrderID | Procedure | 1
uspGetOrderTrackingByTrackingNumber | Procedure | 1
Total 3 object(s)

Collapse image Objects that Sales.OrderTracking depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Individual tracking events associated with a specific sales order.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[OrderTracking] (
        [OrderTrackingID]           [int] IDENTITY(1, 1) NOT NULL,
        [SalesOrderID]              [int] NOT NULL,
        [CarrierTrackingNumber]     [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [TrackingEventID]           [int] NOT NULL,
        [EventDetails]              [nvarchar](2000) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [EventDateTime]             [datetime2](7) NOT NULL,
        CONSTRAINT [PK_OrderTracking]
        PRIMARY KEY
        CLUSTERED
        ([OrderTrackingID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'CONSTRAINT', N'PK_OrderTracking'
GO
CREATE NONCLUSTERED INDEX [IX_OrderTracking_CarrierTrackingNumber]
    ON [Sales].[OrderTracking] ([CarrierTrackingNumber])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IX_OrderTracking_SalesOrderID]
    ON [Sales].[OrderTracking] ([SalesOrderID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipment tracking number supplied by the shipper.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'CarrierTrackingNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'The date and time that a tracking event has occurred.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'EventDateTime'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Details for a delivery tracking event.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'EventDetails'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'OrderTrackingID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales order identification number.  Foreign key to SalesOrderHeader.SalesOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'SalesOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tracking delivery event for Order shipped to customer. Foreign key to TrackingEvent.TrackingEventID.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', 'COLUMN', N'TrackingEventID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Individual tracking events associated with a specific sales order.', 'SCHEMA', N'Sales', 'TABLE', N'OrderTracking', NULL, NULL
GO

Collapse image See also

List of tables


PersonCreditCard

Table: AdventureWorks2016CTP3.Sales.PersonCreditCard

Collapse image Description

Cross-reference table mapping people to their credit card information in the CreditCard table.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 50099219
Located on | PRIMARY
Data size KB | 480 KB
Index size KB | 16 KB
Rows | 19118
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_PersonCreditCard_BusinessEntityID_CreditCardID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Business entity identification number. Foreign key to Person.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | CreditCardID | Credit card identification number. Foreign key to CreditCard.CreditCardID. |  | int | 4 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_PersonCreditCard_BusinessEntityID_CreditCardID | BusinessEntityID | Primary key (clustered) constraint |  |  | 496 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.CreditCard | PK_CreditCard_CreditCardID | FK_PersonCreditCard_CreditCard_CreditCardID
Person.Person | PK_Person_BusinessEntityID | FK_PersonCreditCard_Person_BusinessEntityID
Total: 2 table(s)

Collapse image Objects that Sales.PersonCreditCard depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.CreditCard | Table | 1
Person.Person | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping people to their credit card information in the CreditCard table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[PersonCreditCard] (
        [BusinessEntityID]     [int] NOT NULL,
        [CreditCardID]         [int] NOT NULL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_PersonCreditCard_BusinessEntityID_CreditCardID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [CreditCardID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'CONSTRAINT', N'PK_PersonCreditCard_BusinessEntityID_CreditCardID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'INDEX', N'PK_PersonCreditCard_BusinessEntityID_CreditCardID'
GO
ALTER TABLE [Sales].[PersonCreditCard]
    ADD
    CONSTRAINT [DF_PersonCreditCard_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'CONSTRAINT', N'DF_PersonCreditCard_ModifiedDate'
GO
ALTER TABLE [Sales].[PersonCreditCard]
    WITH CHECK
    ADD CONSTRAINT [FK_PersonCreditCard_CreditCard_CreditCardID]
    FOREIGN KEY ([CreditCardID]) REFERENCES [Sales].[CreditCard] ([CreditCardID])
ALTER TABLE [Sales].[PersonCreditCard]
    CHECK CONSTRAINT [FK_PersonCreditCard_CreditCard_CreditCardID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CreditCard.CreditCardID.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'CONSTRAINT', N'FK_PersonCreditCard_CreditCard_CreditCardID'
GO
ALTER TABLE [Sales].[PersonCreditCard]
    WITH CHECK
    ADD CONSTRAINT [FK_PersonCreditCard_Person_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[Person] ([BusinessEntityID])
ALTER TABLE [Sales].[PersonCreditCard]
    CHECK CONSTRAINT [FK_PersonCreditCard_Person_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Person.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'CONSTRAINT', N'FK_PersonCreditCard_Person_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Business entity identification number. Foreign key to Person.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card identification number. Foreign key to CreditCard.CreditCardID.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'COLUMN', N'CreditCardID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping people to their credit card information in the CreditCard table. ', 'SCHEMA', N'Sales', 'TABLE', N'PersonCreditCard', NULL, NULL
GO

Collapse image See also

List of tables


SalesOrder_json

Table: AdventureWorks2016CTP3.Sales.SalesOrder_json

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1358627883
Located on | PRIMARY
Data size KB | 5456 KB
Index size KB | 32 KB
Rows | 31465
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesOrder__json_SalesOrderID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | SalesOrderID |  |  | int | 4 |  |  |  |  |
 | RevisionNumber |  |  | tinyint | 1 |  | ((0)) |  |  |
 | OrderDate |  |  | datetime | 8 |  | (getdate()) |  |  |
 | DueDate |  |  | datetime | 8 |  |  |  |  |
 | ShipDate |  |  | datetime | 8 |  |  |  |  |
 | Status |  |  | tinyint | 1 |  | ((1)) |  |  |
 | OnlineOrderFlag |  |  | Flag | 1 |  | ((1)) |  |  |
 | SalesOrderNumber |  | True | nvarchar | 25 |  |  |  |  | (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***'))
 | PurchaseOrderNumber |  |  | OrderNumber | 25 |  |  |  |  |
 | AccountNumber |  |  | AccountNumber | 15 |  |  |  |  |
 | CustomerID |  |  | int | 4 |  |  |  |  |
 | SalesPersonID |  |  | int | 4 |  |  |  |  |
 | TerritoryID |  |  | int | 4 |  |  |  |  |
 | BillToAddressID |  |  | int | 4 |  |  |  |  |
 | ShipToAddressID |  |  | int | 4 |  |  |  |  |
 | ShipMethodID |  |  | int | 4 |  |  |  |  |
 | CreditCardID |  |  | int | 4 |  |  |  |  |
 | CreditCardApprovalCode |  |  | varchar | 15 |  |  |  |  |
 | CurrencyRateID |  |  | int | 4 |  |  |  |  |
 | SubTotal |  |  | money | 8 |  | ((0.00)) |  |  |
 | TaxAmt |  |  | money | 8 |  | ((0.00)) |  |  |
 | Freight |  |  | money | 8 |  | ((0.00)) |  |  |
 | TotalDue |  | True | money | 8 |  |  |  |  | (isnull(([SubTotal]+[TaxAmt])+[Freight],(0)))
 | Comment |  |  | nvarchar | 128 |  |  |  |  |
 | rowguid |  |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 | ModifiedDate |  |  | datetime | 8 |  | (getdate()) |  |  |
Total: 26 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
SalesOrderNumber | nvarchar(25) | 7 | 7 | 7 | 0.14000000000000 | (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***'))
PurchaseOrderNumber | nvarchar(25) | 1 | 10 | 13 | 0.26000000000000 |
AccountNumber | nvarchar(15) | 14 | 14 | 14 | 0.46666666666666 |
CreditCardApprovalCode | varchar(15) | 12 | 9 | 15 | 1.00000000000000 |
Comment | nvarchar(128) | 0 | 0 | 0 | 0 |
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesOrder__json_SalesOrderID | SalesOrderID |  |  |  | 5488 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Objects that Sales.SalesOrder_json depends on

Object name | Object type | Dep level
Sales | Schema | 1
AccountNumber | Datatype | 1
Flag | Datatype | 1
OrderNumber | Datatype | 1
Total 4 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrder_json] (
        [SalesOrderID]               [int] NOT NULL,
        [RevisionNumber]             [tinyint] NOT NULL,
        [OrderDate]                  [datetime] NOT NULL,
        [DueDate]                    [datetime] NOT NULL,
        [ShipDate]                   [datetime] NULL,
        [Status]                     [tinyint] NOT NULL,
        [OnlineOrderFlag]            [dbo].[Flag] NOT NULL,
        [SalesOrderNumber]           AS (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***')),
        [PurchaseOrderNumber]        [dbo].[OrderNumber] NULL,
        [AccountNumber]              [dbo].[AccountNumber] NULL,
        [CustomerID]                 [int] NOT NULL,
        [SalesPersonID]              [int] NULL,
        [TerritoryID]                [int] NULL,
        [BillToAddressID]            [int] NULL,
        [ShipToAddressID]            [int] NULL,
        [ShipMethodID]               [int] NULL,
        [CreditCardID]               [int] NULL,
        [CreditCardApprovalCode]     [varchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CurrencyRateID]             [int] NULL,
        [SubTotal]                   [money] NOT NULL,
        [TaxAmt]                     [money] NOT NULL,
        [Freight]                    [money] NOT NULL,
        [TotalDue]                   AS (isnull(([SubTotal]+[TaxAmt])+[Freight],(0))),
        [Comment]                    [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [rowguid]                    [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]               [datetime] NOT NULL,
        CONSTRAINT [PK_SalesOrder__json_SalesOrderID]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_Freight]
    DEFAULT ((0.00)) FOR [Freight]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_OnlineOrderFlag]
    DEFAULT ((1)) FOR [OnlineOrderFlag]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_OrderDate]
    DEFAULT (getdate()) FOR [OrderDate]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_RevisionNumber]
    DEFAULT ((0)) FOR [RevisionNumber]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_Status]
    DEFAULT ((1)) FOR [Status]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_SubTotal]
    DEFAULT ((0.00)) FOR [SubTotal]
GO
ALTER TABLE [Sales].[SalesOrder_json]
    ADD
    CONSTRAINT [DF_SalesOrder_TaxAmt]
    DEFAULT ((0.00)) FOR [TaxAmt]
GO

Collapse image See also

List of tables


SalesOrderDetail

Table: AdventureWorks2016CTP3.Sales.SalesOrderDetail

Collapse image Description

Individual products associated with a specific sales order. See SalesOrderHeader.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1474104292
Located on | PRIMARY
Data size KB | 9968 KB
Index size KB | 6776 KB
Rows | 121317
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | Foreign key | SalesOrderID | Primary key. Foreign key to SalesOrderHeader.SalesOrderID. |  | int | 4 |  |  |  |  |
Primary key | Identity |  | SalesOrderDetailID | Primary key. One incremental unique number per product sold. |  | int | 4 |  |  |  |  |
 |  |  | CarrierTrackingNumber | Shipment tracking number supplied by the shipper. |  | nvarchar | 25 |  |  |  |  |
 |  |  | OrderQty | Quantity ordered per product. |  | smallint | 2 |  |  |  |  |
 |  | Foreign key | ProductID | Product sold to customer. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | SpecialOfferID | Promotional code. Foreign key to SpecialOffer.SpecialOfferID. |  | int | 4 |  |  |  |  |
 |  |  | UnitPrice | Selling price of a single product. |  | money | 8 |  |  |  |  |
 |  |  | UnitPriceDiscount | Discount amount. |  | money | 8 |  | ((0.0)) |  |  |
 |  |  | LineTotal | Per product subtotal. Computed as UnitPrice * (1 - UnitPriceDiscount) * OrderQty. | True | numeric | 17 |  |  |  |  | (isnull(([UnitPrice]*((1.0)-[UnitPriceDiscount]))*[OrderQty],(0.0)))
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CarrierTrackingNumber | nvarchar(25) | 6 | 12 | 12 | 0.24000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID | SalesOrderID | Primary key (clustered) constraint |  |  | 16744 | 0
AK_SalesOrderDetail_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 3960 | 0
IX_SalesOrderDetail_ProductID | ProductID | Nonclustered index. |  |  | 2464 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesOrderDetail_OrderQty | ([OrderQty]>(0))
CK_SalesOrderDetail_UnitPrice | ([UnitPrice]>=(0.00))
CK_SalesOrderDetail_UnitPriceDiscount | ([UnitPriceDiscount]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderDetailID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesOrderHeader | PK_SalesOrderHeader_SalesOrderID | FK_SalesOrderDetail_SalesOrderHeader_SalesOrderID
Sales.SpecialOfferProduct | PK_SpecialOfferProduct_SpecialOfferID_ProductID | FK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID
Total: 2 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Sales.iduSalesOrderDetail | Sales |  |  | For Insert | For Update | For Delete | Sales.SalesOrderDetail
Total: 1 triggers(s)

Collapse image Objects that depend on Sales.SalesOrderDetail

Object name | Object type | Dep level
Demo.usp_DemoReset | Procedure | 1
Sales.iduSalesOrderDetail | Trigger | 1
Total 2 object(s)

Collapse image Objects that Sales.SalesOrderDetail depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderHeader | Table | 1
Sales.SpecialOfferProduct | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Individual products associated with a specific sales order. See SalesOrderHeader.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderDetail] (
        [SalesOrderID]              [int] NOT NULL,
        [SalesOrderDetailID]        [int] IDENTITY(1, 1) NOT NULL,
        [CarrierTrackingNumber]     [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [OrderQty]                  [smallint] NOT NULL,
        [ProductID]                 [int] NOT NULL,
        [SpecialOfferID]            [int] NOT NULL,
        [UnitPrice]                 [money] NOT NULL,
        [UnitPriceDiscount]         [money] NOT NULL,
        [LineTotal]                 AS (isnull(([UnitPrice]*((1.0)-[UnitPriceDiscount]))*[OrderQty],(0.0))),
        [rowguid]                   [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]              [datetime] NOT NULL,
        CONSTRAINT [PK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID], [SalesOrderDetailID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'PK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'INDEX', N'PK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [CK_SalesOrderDetail_OrderQty]
    CHECK
    ([OrderQty]>(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [OrderQty] > (0)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'CK_SalesOrderDetail_OrderQty'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
CHECK CONSTRAINT [CK_SalesOrderDetail_OrderQty]
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [CK_SalesOrderDetail_UnitPrice]
    CHECK
    ([UnitPrice]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [UnitPrice] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'CK_SalesOrderDetail_UnitPrice'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
CHECK CONSTRAINT [CK_SalesOrderDetail_UnitPrice]
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [CK_SalesOrderDetail_UnitPriceDiscount]
    CHECK
    ([UnitPriceDiscount]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [UnitPriceDiscount] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'CK_SalesOrderDetail_UnitPriceDiscount'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
CHECK CONSTRAINT [CK_SalesOrderDetail_UnitPriceDiscount]
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [DF_SalesOrderDetail_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'DF_SalesOrderDetail_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [DF_SalesOrderDetail_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'DF_SalesOrderDetail_rowguid'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    ADD
    CONSTRAINT [DF_SalesOrderDetail_UnitPriceDiscount]
    DEFAULT ((0.0)) FOR [UnitPriceDiscount]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'DF_SalesOrderDetail_UnitPriceDiscount'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]
    FOREIGN KEY ([SalesOrderID]) REFERENCES [Sales].[SalesOrderHeader] ([SalesOrderID])
    ON DELETE CASCADE
ALTER TABLE [Sales].[SalesOrderDetail]
    CHECK CONSTRAINT [FK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesOrderHeader.PurchaseOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'FK_SalesOrderDetail_SalesOrderHeader_SalesOrderID'
GO
ALTER TABLE [Sales].[SalesOrderDetail]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]
    FOREIGN KEY ([SpecialOfferID], [ProductID]) REFERENCES [Sales].[SpecialOfferProduct] ([SpecialOfferID], [ProductID])
ALTER TABLE [Sales].[SalesOrderDetail]
    CHECK CONSTRAINT [FK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SpecialOfferProduct.SpecialOfferIDProductID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'CONSTRAINT', N'FK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesOrderDetail_rowguid]
    ON [Sales].[SalesOrderDetail] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'INDEX', N'AK_SalesOrderDetail_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_SalesOrderDetail_ProductID]
    ON [Sales].[SalesOrderDetail] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'INDEX', N'IX_SalesOrderDetail_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipment tracking number supplied by the shipper.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'CarrierTrackingNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Per product subtotal. Computed as UnitPrice * (1 - UnitPriceDiscount) * OrderQty.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'LineTotal'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Quantity ordered per product.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'OrderQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product sold to customer. Foreign key to Product.ProductID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. One incremental unique number per product sold.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'SalesOrderDetailID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to SalesOrderHeader.SalesOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'SalesOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Promotional code. Foreign key to SpecialOffer.SpecialOfferID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'SpecialOfferID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Selling price of a single product.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'UnitPrice'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount amount.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'COLUMN', N'UnitPriceDiscount'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Individual products associated with a specific sales order. See SalesOrderHeader.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', NULL, NULL
GO

Collapse image See also

List of tables


SalesOrderDetail_inmem

Table: AdventureWorks2016CTP3.Sales.SalesOrderDetail_inmem

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 468196718
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [imPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | Foreign key | SalesOrderID |  |  | int | 4 |  |  |  |
Primary key | Identity |  | SalesOrderDetailID |  |  | bigint | 8 |  |  |  |
 |  |  | CarrierTrackingNumber |  |  | nvarchar | 25 |  |  |  |
 |  |  | OrderQty |  |  | smallint | 2 |  |  |  |
 |  | Foreign key | ProductID |  |  | int | 4 |  |  |  |
 |  | Foreign key | SpecialOfferID |  |  | int | 4 |  |  |  |
 |  |  | UnitPrice |  |  | money | 8 |  |  |  |
 |  |  | UnitPriceDiscount |  |  | money | 8 |  | ((0.0)) |  |
 |  |  | ModifiedDate |  |  | datetime2 | 8 |  |  |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CarrierTrackingNumber | nvarchar(25) | 6 | 12 | 12 | 0.24000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
imPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID | SalesOrderID |  |  |  | 0 | 0
IX_ProductID | ProductID |  |  |  | 0 | 0
IX_SalesOrderID | SalesOrderID |  |  |  | 0 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
IMCK_SalesOrderDetail_OrderQty | ([OrderQty]>(0))
IMCK_SalesOrderDetail_UnitPrice | ([UnitPrice]>=(0.00))
IMCK_SalesOrderDetail_UnitPriceDiscount | ([UnitPriceDiscount]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderDetailID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesOrderHeader_inmem | PK__SalesOrd__B14003C3270C320B | IMFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID
Sales.SpecialOfferProduct_inmem | IMPK_SpecialOfferProduct_SpecialOfferID_ProductID | IMFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SalesOrderDetail_inmem

Object name | Object type | Dep level
Demo.usp_DemoReset | Procedure | 1
Sales.vSalesOrderDetail_extended_inmem | Function | 1
Total 2 object(s)

Collapse image Objects that Sales.SalesOrderDetail_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderHeader_inmem | Table | 1
Sales.SpecialOfferProduct_inmem | Table | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderDetail_inmem] (
        [SalesOrderID]              [int] NOT NULL,
        [SalesOrderDetailID]        [bigint] IDENTITY(1, 1) NOT NULL,
        [CarrierTrackingNumber]     [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [OrderQty]                  [smallint] NOT NULL,
        [ProductID]                 [int] NOT NULL,
        [SpecialOfferID]            [int] NOT NULL,
        [UnitPrice]                 [money] NOT NULL,
        [UnitPriceDiscount]         [money] NOT NULL,
        [ModifiedDate]              [datetime2](7) NOT NULL,
        CONSTRAINT [imPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
        PRIMARY KEY
        NONCLUSTERED HASH
        ([SalesOrderID], [SalesOrderDetailID])
        WITH (BUCKET_COUNT=67108864),
INDEX [IX_ProductID] NONCLUSTERED HASH  ([ProductID])
    WITH ( BUCKET_COUNT=1048576),
INDEX [IX_SalesOrderID] NONCLUSTERED HASH  ([SalesOrderID])
    WITH ( BUCKET_COUNT=16777216)
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderDetail_OrderQty]
    CHECK
    ([OrderQty]>(0))
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderDetail_OrderQty]
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderDetail_UnitPrice]
    CHECK
    ([UnitPrice]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderDetail_UnitPrice]
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderDetail_UnitPriceDiscount]
    CHECK
    ([UnitPriceDiscount]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderDetail_UnitPriceDiscount]
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderDetail_UnitPriceDiscount]
    DEFAULT ((0.0)) FOR [UnitPriceDiscount]
GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    WITH CHECK
    ADD CONSTRAINT [IMFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]
    FOREIGN KEY ([SalesOrderID]) REFERENCES [Sales].[SalesOrderHeader_inmem] ([SalesOrderID])
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    CHECK CONSTRAINT [IMFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]

GO
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    WITH CHECK
    ADD CONSTRAINT [IMFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]
    FOREIGN KEY ([SpecialOfferID], [ProductID]) REFERENCES [Sales].[SpecialOfferProduct_inmem] ([SpecialOfferID], [ProductID])
ALTER TABLE [Sales].[SalesOrderDetail_inmem]
    CHECK CONSTRAINT [IMFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]

GO

Collapse image See also

List of tables


SalesOrderDetail_ondisk

Table: AdventureWorks2016CTP3.Sales.SalesOrderDetail_ondisk

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1332199796
Located on | PRIMARY
Data size KB | 8432 KB
Index size KB | 2728 KB
Rows | 121317
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [ODPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key |  | Foreign key | SalesOrderID |  |  | int | 4 |  |  |  |
Primary key | Identity |  | SalesOrderDetailID |  |  | bigint | 8 |  |  |  |
 |  |  | CarrierTrackingNumber |  |  | nvarchar | 25 |  |  |  |
 |  |  | OrderQty |  |  | smallint | 2 |  |  |  |
 |  | Foreign key | ProductID |  |  | int | 4 |  |  |  |
 |  | Foreign key | SpecialOfferID |  |  | int | 4 |  |  |  |
 |  |  | UnitPrice |  |  | money | 8 |  |  |  |
 |  |  | UnitPriceDiscount |  |  | money | 8 |  | ((0.0)) |  |
 |  |  | ModifiedDate |  |  | datetime2 | 8 |  |  |  |
Total: 9 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
CarrierTrackingNumber | nvarchar(25) | 6 | 12 | 12 | 0.24000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ODPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID | SalesOrderID |  |  |  | 11160 | 0
IX_ProductID | ProductID |  |  |  | 2672 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
ODCK_SalesOrderDetail_OrderQty | ([OrderQty]>(0))
ODCK_SalesOrderDetail_UnitPrice | ([UnitPrice]>=(0.00))
ODCK_SalesOrderDetail_UnitPriceDiscount | ([UnitPriceDiscount]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderDetailID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesOrderHeader_ondisk | PK__SalesOrd__B14003C2B181FB70 | ODFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID
Sales.SpecialOfferProduct_ondisk | ODPK_SpecialOfferProduct_SpecialOfferID_ProductID | ODFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SalesOrderDetail_ondisk

Object name | Object type | Dep level
Demo.usp_DemoReset | Procedure | 1
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure | 1
Total 3 object(s)

Collapse image Objects that Sales.SalesOrderDetail_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderHeader_ondisk | Table | 1
Sales.SpecialOfferProduct_ondisk | Table | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderDetail_ondisk] (
        [SalesOrderID]              [int] NOT NULL,
        [SalesOrderDetailID]        [bigint] IDENTITY(1, 1) NOT NULL,
        [CarrierTrackingNumber]     [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [OrderQty]                  [smallint] NOT NULL,
        [ProductID]                 [int] NOT NULL,
        [SpecialOfferID]            [int] NOT NULL,
        [UnitPrice]                 [money] NOT NULL,
        [UnitPriceDiscount]         [money] NOT NULL,
        [ModifiedDate]              [datetime2](7) NOT NULL,
        CONSTRAINT [ODPK_SalesOrderDetail_SalesOrderID_SalesOrderDetailID]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID], [SalesOrderDetailID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderDetail_OrderQty]
    CHECK
    ([OrderQty]>(0))
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderDetail_OrderQty]
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderDetail_UnitPrice]
    CHECK
    ([UnitPrice]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderDetail_UnitPrice]
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderDetail_UnitPriceDiscount]
    CHECK
    ([UnitPriceDiscount]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderDetail_UnitPriceDiscount]
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderDetail_UnitPriceDiscount]
    DEFAULT ((0.0)) FOR [UnitPriceDiscount]
GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    WITH CHECK
    ADD CONSTRAINT [ODFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]
    FOREIGN KEY ([SalesOrderID]) REFERENCES [Sales].[SalesOrderHeader_ondisk] ([SalesOrderID])
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    CHECK CONSTRAINT [ODFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID]

GO
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    WITH CHECK
    ADD CONSTRAINT [ODFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]
    FOREIGN KEY ([SpecialOfferID], [ProductID]) REFERENCES [Sales].[SpecialOfferProduct_ondisk] ([SpecialOfferID], [ProductID])
ALTER TABLE [Sales].[SalesOrderDetail_ondisk]
    CHECK CONSTRAINT [ODFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID]

GO
CREATE NONCLUSTERED INDEX [IX_ProductID]
    ON [Sales].[SalesOrderDetail_ondisk] ([ProductID])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


SalesOrderHeader

Table: AdventureWorks2016CTP3.Sales.SalesOrderHeader

Collapse image Description

General sales order information.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1586104691
Located on | PRIMARY
Data size KB | 5536 KB
Index size KB | 2872 KB
Rows | 31465
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesOrderHeader_SalesOrderID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | SalesOrderID | Primary key. |  | int | 4 |  |  |  |  |
 |  |  | RevisionNumber | Incremental number to track changes to the sales order over time. |  | tinyint | 1 |  | ((0)) |  |  |
 |  |  | OrderDate | Dates the sales order was created. |  | datetime | 8 |  | (getdate()) |  |  |
 |  |  | DueDate | Date the order is due to the customer. |  | datetime | 8 |  |  |  |  |
 |  |  | ShipDate | Date the order was shipped to the customer. |  | datetime | 8 |  |  |  |  |
 |  |  | Status | Order current status. 1 = In process; 2 = Approved; 3 = Backordered; 4 = Rejected; 5 = Shipped; 6 = Cancelled |  | tinyint | 1 |  | ((1)) |  |  |
 |  |  | OnlineOrderFlag | 0 = Order placed by sales person. 1 = Order placed online by customer. |  | Flag | 1 |  | ((1)) |  |  |
 |  |  | SalesOrderNumber | Unique sales order identification number. | True | nvarchar | 25 |  |  |  |  | (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***'))
 |  |  | PurchaseOrderNumber | Customer purchase order number reference. |  | OrderNumber | 25 |  |  |  |  |
 |  |  | AccountNumber | Financial accounting number reference. |  | AccountNumber | 15 |  |  |  |  |
 |  | Foreign key | CustomerID | Customer identification number. Foreign key to Customer.BusinessEntityID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | SalesPersonID | Sales person who created the sales order. Foreign key to SalesPerson.BusinessEntityID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | TerritoryID | Territory in which the sale was made. Foreign key to SalesTerritory.SalesTerritoryID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | BillToAddressID | Customer billing address. Foreign key to Address.AddressID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | ShipToAddressID | Customer shipping address. Foreign key to Address.AddressID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | ShipMethodID | Shipping method. Foreign key to ShipMethod.ShipMethodID. |  | int | 4 |  |  |  |  |
 |  | Foreign key | CreditCardID | Credit card identification number. Foreign key to CreditCard.CreditCardID. |  | int | 4 |  |  |  |  |
 |  |  | CreditCardApprovalCode | Approval code provided by the credit card company. |  | varchar | 15 |  |  |  |  |
 |  | Foreign key | CurrencyRateID | Currency exchange rate used. Foreign key to CurrencyRate.CurrencyRateID. |  | int | 4 |  |  |  |  |
 |  |  | SubTotal | Sales subtotal. Computed as SUM(SalesOrderDetail.LineTotal)for the appropriate SalesOrderID. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | TaxAmt | Tax amount. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | Freight | Shipping cost. |  | money | 8 |  | ((0.00)) |  |  |
 |  |  | TotalDue | Total due from customer. Computed as Subtotal + TaxAmt + Freight. | True | money | 8 |  |  |  |  | (isnull(([SubTotal]+[TaxAmt])+[Freight],(0)))
 |  |  | Comment | Sales representative comments. |  | nvarchar | 128 |  |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |  |
Total: 26 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
SalesOrderNumber | nvarchar(25) | 7 | 7 | 7 | 0.14000000000000 | (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***'))
PurchaseOrderNumber | nvarchar(25) | 1 | 10 | 13 | 0.26000000000000 |
AccountNumber | nvarchar(15) | 14 | 14 | 14 | 0.46666666666666 |
CreditCardApprovalCode | varchar(15) | 12 | 9 | 15 | 1.00000000000000 |
Comment | nvarchar(128) | 0 | 0 | 0 | 0 |
Total: 5 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesOrderHeader_SalesOrderID | SalesOrderID | Primary key (clustered) constraint |  |  | 8408 | 0
AK_SalesOrderHeader_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 832 | 0
AK_SalesOrderHeader_SalesOrderNumber | SalesOrderNumber | Unique nonclustered index. |  |  | 888 | 0
IX_SalesOrderHeader_CustomerID | CustomerID | Nonclustered index. |  |  | 456 | 0
IX_SalesOrderHeader_SalesPersonID | SalesPersonID | Nonclustered index. |  |  | 456 | 0
Total: 5 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesOrderHeader_DueDate | ([DueDate]>=[OrderDate])
CK_SalesOrderHeader_Freight | ([Freight]>=(0.00))
CK_SalesOrderHeader_ShipDate | ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
CK_SalesOrderHeader_Status | ([Status]>=(0) AND [Status]<=(8))
CK_SalesOrderHeader_SubTotal | ([SubTotal]>=(0.00))
CK_SalesOrderHeader_TaxAmt | ([TaxAmt]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail | FK_SalesOrderDetail_SalesOrderHeader_SalesOrderID | PK_SalesOrderHeader_SalesOrderID
Sales.SalesOrderHeaderSalesReason | FK_SalesOrderHeaderSalesReason_SalesOrderHeader_SalesOrderID | PK_SalesOrderHeader_SalesOrderID
Total: 2 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.Address | PK_Address_AddressID | FK_SalesOrderHeader_Address_BillToAddressID
Person.Address | PK_Address_AddressID | FK_SalesOrderHeader_Address_ShipToAddressID
Sales.CreditCard | PK_CreditCard_CreditCardID | FK_SalesOrderHeader_CreditCard_CreditCardID
Sales.CurrencyRate | PK_CurrencyRate_CurrencyRateID | FK_SalesOrderHeader_CurrencyRate_CurrencyRateID
Sales.Customer | PK_Customer_CustomerID | FK_SalesOrderHeader_Customer_CustomerID
Sales.SalesPerson | PK_SalesPerson_BusinessEntityID | FK_SalesOrderHeader_SalesPerson_SalesPersonID
Sales.SalesTerritory | PK_SalesTerritory_TerritoryID | FK_SalesOrderHeader_SalesTerritory_TerritoryID
Purchasing.ShipMethod | PK_ShipMethod_ShipMethodID | FK_SalesOrderHeader_ShipMethod_ShipMethodID
Total: 8 table(s)

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
Sales.uSalesOrderHeader | Sales |  |  |  | For Update |  | Sales.SalesOrderHeader
Total: 1 triggers(s)

Collapse image Objects that depend on Sales.SalesOrderHeader

Object name | Object type | Dep level
Demo.usp_DemoReset | Procedure | 1
Sales.SalesOrderDetail | Table | 1
Sales.SalesOrderHeaderSalesReason | Table | 1
Sales.iduSalesOrderDetail | Trigger | 1
Sales.uSalesOrderHeader | Trigger | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Total 6 object(s)

Collapse image Objects that Sales.SalesOrderHeader depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Address | Table | 1
Sales.CreditCard | Table | 1
Sales.CurrencyRate | Table | 1
Sales.Customer | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritory | Table | 1
Purchasing.ShipMethod | Table | 1
AccountNumber | Datatype | 1
Flag | Datatype | 1
OrderNumber | Datatype | 1
Total 11 object(s)

Collapse image Extended properties

Name | Value
MS_Description | General sales order information.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderHeader] (
        [SalesOrderID]               [int] IDENTITY(1, 1) NOT FOR REPLICATION NOT NULL,
        [RevisionNumber]             [tinyint] NOT NULL,
        [OrderDate]                  [datetime] NOT NULL,
        [DueDate]                    [datetime] NOT NULL,
        [ShipDate]                   [datetime] NULL,
        [Status]                     [tinyint] NOT NULL,
        [OnlineOrderFlag]            [dbo].[Flag] NOT NULL,
        [SalesOrderNumber]           AS (isnull(N'SO'+CONVERT([nvarchar](23),[SalesOrderID]),N'*** ERROR ***')),
        [PurchaseOrderNumber]        [dbo].[OrderNumber] NULL,
        [AccountNumber]              [dbo].[AccountNumber] NULL,
        [CustomerID]                 [int] NOT NULL,
        [SalesPersonID]              [int] NULL,
        [TerritoryID]                [int] NULL,
        [BillToAddressID]            [int] NOT NULL,
        [ShipToAddressID]            [int] NOT NULL,
        [ShipMethodID]               [int] NOT NULL,
        [CreditCardID]               [int] NULL,
        [CreditCardApprovalCode]     [varchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CurrencyRateID]             [int] NULL,
        [SubTotal]                   [money] NOT NULL,
        [TaxAmt]                     [money] NOT NULL,
        [Freight]                    [money] NOT NULL,
        [TotalDue]                   AS (isnull(([SubTotal]+[TaxAmt])+[Freight],(0))),
        [Comment]                    [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [rowguid]                    [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]               [datetime] NOT NULL,
        CONSTRAINT [PK_SalesOrderHeader_SalesOrderID]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'PK_SalesOrderHeader_SalesOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'INDEX', N'PK_SalesOrderHeader_SalesOrderID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_DueDate]
    CHECK
    ([DueDate]>=[OrderDate])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [DueDate] >= [OrderDate]', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_DueDate'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_DueDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_Freight]
    CHECK
    ([Freight]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Freight] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_Freight'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_Freight]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_ShipDate]
    CHECK
    ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [ShipDate] >= [OrderDate] OR [ShipDate] IS NULL', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_ShipDate'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_ShipDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_Status]
    CHECK
    ([Status]>=(0) AND [Status]<=(8))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Status] BETWEEN (0) AND (8)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_Status'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_Status]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_SubTotal]
    CHECK
    ([SubTotal]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SubTotal] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_SubTotal'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_SubTotal]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [CK_SalesOrderHeader_TaxAmt]
    CHECK
    ([TaxAmt]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [TaxAmt] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'CK_SalesOrderHeader_TaxAmt'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
CHECK CONSTRAINT [CK_SalesOrderHeader_TaxAmt]
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_Freight]
    DEFAULT ((0.00)) FOR [Freight]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_Freight'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_OnlineOrderFlag]
    DEFAULT ((1)) FOR [OnlineOrderFlag]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1 (TRUE)', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_OnlineOrderFlag'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_OrderDate]
    DEFAULT (getdate()) FOR [OrderDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_OrderDate'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_RevisionNumber]
    DEFAULT ((0)) FOR [RevisionNumber]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_RevisionNumber'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_rowguid'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_Status]
    DEFAULT ((1)) FOR [Status]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_Status'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_SubTotal]
    DEFAULT ((0.00)) FOR [SubTotal]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_SubTotal'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    ADD
    CONSTRAINT [DF_SalesOrderHeader_TaxAmt]
    DEFAULT ((0.00)) FOR [TaxAmt]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'DF_SalesOrderHeader_TaxAmt'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_Address_BillToAddressID]
    FOREIGN KEY ([BillToAddressID]) REFERENCES [Person].[Address] ([AddressID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_Address_BillToAddressID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Address.AddressID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_Address_BillToAddressID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_Address_ShipToAddressID]
    FOREIGN KEY ([ShipToAddressID]) REFERENCES [Person].[Address] ([AddressID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_Address_ShipToAddressID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Address.AddressID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_Address_ShipToAddressID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_CreditCard_CreditCardID]
    FOREIGN KEY ([CreditCardID]) REFERENCES [Sales].[CreditCard] ([CreditCardID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_CreditCard_CreditCardID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CreditCard.CreditCardID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_CreditCard_CreditCardID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_CurrencyRate_CurrencyRateID]
    FOREIGN KEY ([CurrencyRateID]) REFERENCES [Sales].[CurrencyRate] ([CurrencyRateID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_CurrencyRate_CurrencyRateID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CurrencyRate.CurrencyRateID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_CurrencyRate_CurrencyRateID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_Customer_CustomerID]
    FOREIGN KEY ([CustomerID]) REFERENCES [Sales].[Customer] ([CustomerID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_Customer_CustomerID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Customer.CustomerID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_Customer_CustomerID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_SalesPerson_SalesPersonID]
    FOREIGN KEY ([SalesPersonID]) REFERENCES [Sales].[SalesPerson] ([BusinessEntityID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_SalesPerson_SalesPersonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesPerson.SalesPersonID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_SalesPerson_SalesPersonID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_SalesTerritory_TerritoryID]
    FOREIGN KEY ([TerritoryID]) REFERENCES [Sales].[SalesTerritory] ([TerritoryID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_SalesTerritory_TerritoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesTerritory.TerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_SalesTerritory_TerritoryID'
GO
ALTER TABLE [Sales].[SalesOrderHeader]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeader_ShipMethod_ShipMethodID]
    FOREIGN KEY ([ShipMethodID]) REFERENCES [Purchasing].[ShipMethod] ([ShipMethodID])
ALTER TABLE [Sales].[SalesOrderHeader]
    CHECK CONSTRAINT [FK_SalesOrderHeader_ShipMethod_ShipMethodID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing ShipMethod.ShipMethodID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'CONSTRAINT', N'FK_SalesOrderHeader_ShipMethod_ShipMethodID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesOrderHeader_rowguid]
    ON [Sales].[SalesOrderHeader] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'INDEX', N'AK_SalesOrderHeader_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesOrderHeader_SalesOrderNumber]
    ON [Sales].[SalesOrderHeader] ([SalesOrderNumber])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'INDEX', N'AK_SalesOrderHeader_SalesOrderNumber'
GO
CREATE NONCLUSTERED INDEX [IX_SalesOrderHeader_CustomerID]
    ON [Sales].[SalesOrderHeader] ([CustomerID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'INDEX', N'IX_SalesOrderHeader_CustomerID'
GO
CREATE NONCLUSTERED INDEX [IX_SalesOrderHeader_SalesPersonID]
    ON [Sales].[SalesOrderHeader] ([SalesPersonID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'INDEX', N'IX_SalesOrderHeader_SalesPersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Financial accounting number reference.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'AccountNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer billing address. Foreign key to Address.AddressID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'BillToAddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales representative comments.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'Comment'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Approval code provided by the credit card company.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'CreditCardApprovalCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Credit card identification number. Foreign key to CreditCard.CreditCardID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'CreditCardID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Currency exchange rate used. Foreign key to CurrencyRate.CurrencyRateID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'CurrencyRateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer identification number. Foreign key to Customer.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'CustomerID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the order is due to the customer.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'DueDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping cost.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'Freight'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'0 = Order placed by sales person. 1 = Order placed online by customer.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'OnlineOrderFlag'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Dates the sales order was created.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'OrderDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer purchase order number reference. ', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'PurchaseOrderNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Incremental number to track changes to the sales order over time.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'RevisionNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'SalesOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique sales order identification number.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'SalesOrderNumber'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales person who created the sales order. Foreign key to SalesPerson.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'SalesPersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the order was shipped to the customer.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'ShipDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shipping method. Foreign key to ShipMethod.ShipMethodID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'ShipMethodID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customer shipping address. Foreign key to Address.AddressID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'ShipToAddressID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Order current status. 1 = In process; 2 = Approved; 3 = Backordered; 4 = Rejected; 5 = Shipped; 6 = Cancelled', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'Status'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales subtotal. Computed as SUM(SalesOrderDetail.LineTotal)for the appropriate SalesOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'SubTotal'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tax amount.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'TaxAmt'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Territory in which the sale was made. Foreign key to SalesTerritory.SalesTerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Total due from customer. Computed as Subtotal + TaxAmt + Freight.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'COLUMN', N'TotalDue'
GO
EXEC sp_addextendedproperty N'MS_Description', N'General sales order information.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', NULL, NULL
GO

Collapse image See also

List of tables


SalesOrderHeader_inmem

Table: AdventureWorks2016CTP3.Sales.SalesOrderHeader_inmem

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 212195806
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__SalesOrd__B14003C3270C320B]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SalesOrderID |  |  | int | 4 |  |  |  |
 |  | RevisionNumber |  |  | tinyint | 1 |  | ((0)) |  |
 |  | OrderDate |  |  | datetime2 | 8 |  |  |  |
 |  | DueDate |  |  | datetime2 | 8 |  |  |  |
 |  | ShipDate |  |  | datetime2 | 8 |  |  |  |
 |  | Status |  |  | tinyint | 1 |  | ((1)) |  |
 |  | OnlineOrderFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | PurchaseOrderNumber |  |  | nvarchar | 25 |  |  |  |
 |  | AccountNumber |  |  | nvarchar | 15 |  |  |  |
 |  | CustomerID |  |  | int | 4 |  |  |  |
 |  | SalesPersonID |  |  | int | 4 |  | ((-1)) |  |
 |  | TerritoryID |  |  | int | 4 |  |  |  |
 |  | BillToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipMethodID |  |  | int | 4 |  |  |  |
 |  | CreditCardID |  |  | int | 4 |  |  |  |
 |  | CreditCardApprovalCode |  |  | varchar | 15 |  |  |  |
 |  | CurrencyRateID |  |  | int | 4 |  |  |  |
 |  | SubTotal |  |  | money | 8 |  | ((0.00)) |  |
 |  | TaxAmt |  |  | money | 8 |  | ((0.00)) |  |
 |  | Freight |  |  | money | 8 |  | ((0.00)) |  |
 |  | Comment |  |  | nvarchar | 128 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  |  |  |
Total: 23 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PurchaseOrderNumber | nvarchar(25) | 1 | 10 | 13 | 0.26000000000000
AccountNumber | nvarchar(15) | 14 | 14 | 14 | 0.46666666666666
CreditCardApprovalCode | varchar(15) | 12 | 9 | 15 | 1.00000000000000
Comment | nvarchar(128) | 0 | 0 | 0 | 0
Total: 4 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__SalesOrd__B14003C3270C320B | SalesOrderID |  |  |  | 0 | 0
IX_CustomerID | CustomerID |  |  |  | 0 | 0
IX_SalesPersonID | SalesPersonID |  |  |  | 0 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
IMCK_SalesOrderHeader_DueDate | ([DueDate]>=[OrderDate])
IMCK_SalesOrderHeader_Freight | ([Freight]>=(0.00))
IMCK_SalesOrderHeader_ShipDate | ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
IMCK_SalesOrderHeader_Status | ([Status]>=(0) AND [Status]<=(8))
IMCK_SalesOrderHeader_SubTotal | ([SubTotal]>=(0.00))
IMCK_SalesOrderHeader_TaxAmt | ([TaxAmt]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail_inmem | IMFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID | PK__SalesOrd__B14003C3270C320B
Total: 1 table(s)

Collapse image Objects that depend on Sales.SalesOrderHeader_inmem

Object name | Object type | Dep level
Demo.usp_DemoInitSeed | Procedure | 1
Demo.usp_DemoReset | Procedure | 1
Sales.SalesOrderDetail_inmem | Table | 1
Sales.vSalesOrderHeader_extended_inmem | Function | 1
Total 4 object(s)

Collapse image Objects that Sales.SalesOrderHeader_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderHeader_inmem] (
        [SalesOrderID]               [int] IDENTITY(1, 1) NOT NULL,
        [RevisionNumber]             [tinyint] NOT NULL,
        [OrderDate]                  [datetime2](7) NOT NULL,
        [DueDate]                    [datetime2](7) NOT NULL,
        [ShipDate]                   [datetime2](7) NULL,
        [Status]                     [tinyint] NOT NULL,
        [OnlineOrderFlag]            [bit] NOT NULL,
        [PurchaseOrderNumber]        [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [AccountNumber]              [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CustomerID]                 [int] NOT NULL,
        [SalesPersonID]              [int] NOT NULL,
        [TerritoryID]                [int] NULL,
        [BillToAddressID]            [int] NOT NULL,
        [ShipToAddressID]            [int] NOT NULL,
        [ShipMethodID]               [int] NOT NULL,
        [CreditCardID]               [int] NULL,
        [CreditCardApprovalCode]     [varchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CurrencyRateID]             [int] NULL,
        [SubTotal]                   [money] NOT NULL,
        [TaxAmt]                     [money] NOT NULL,
        [Freight]                    [money] NOT NULL,
        [Comment]                    [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ModifiedDate]               [datetime2](7) NOT NULL,
        CONSTRAINT [PK__SalesOrd__B14003C3270C320B]
        PRIMARY KEY
        NONCLUSTERED HASH
        ([SalesOrderID])
        WITH (BUCKET_COUNT=16777216),
INDEX [IX_CustomerID] NONCLUSTERED HASH  ([CustomerID])
    WITH ( BUCKET_COUNT=1048576),
INDEX [IX_SalesPersonID] NONCLUSTERED HASH  ([SalesPersonID])
    WITH ( BUCKET_COUNT=1048576)
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_DueDate]
    CHECK
    ([DueDate]>=[OrderDate])
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_DueDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_Freight]
    CHECK
    ([Freight]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_Freight]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_ShipDate]
    CHECK
    ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_ShipDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_Status]
    CHECK
    ([Status]>=(0) AND [Status]<=(8))
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_Status]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_SubTotal]
    CHECK
    ([SubTotal]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_SubTotal]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMCK_SalesOrderHeader_TaxAmt]
    CHECK
    ([TaxAmt]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
CHECK CONSTRAINT [IMCK_SalesOrderHeader_TaxAmt]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_Freight]
    DEFAULT ((0.00)) FOR [Freight]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_OnlineOrderFlag]
    DEFAULT ((1)) FOR [OnlineOrderFlag]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_RevisionNumber]
    DEFAULT ((0)) FOR [RevisionNumber]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_SalesPersonID]
    DEFAULT ((-1)) FOR [SalesPersonID]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_Status]
    DEFAULT ((1)) FOR [Status]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_SubTotal]
    DEFAULT ((0.00)) FOR [SubTotal]
GO
ALTER TABLE [Sales].[SalesOrderHeader_inmem]
    ADD
    CONSTRAINT [IMDF_SalesOrderHeader_TaxAmt]
    DEFAULT ((0.00)) FOR [TaxAmt]
GO

Collapse image See also

List of tables


SalesOrderHeader_ondisk

Table: AdventureWorks2016CTP3.Sales.SalesOrderHeader_ondisk

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1092198941
Located on | PRIMARY
Data size KB | 4936 KB
Index size KB | 928 KB
Rows | 31465
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK__SalesOrd__B14003C2B181FB70]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SalesOrderID |  |  | int | 4 |  |  |  |
 |  | RevisionNumber |  |  | tinyint | 1 |  | ((0)) |  |
 |  | OrderDate |  |  | datetime2 | 8 |  |  |  |
 |  | DueDate |  |  | datetime2 | 8 |  |  |  |
 |  | ShipDate |  |  | datetime2 | 8 |  |  |  |
 |  | Status |  |  | tinyint | 1 |  | ((1)) |  |
 |  | OnlineOrderFlag |  |  | bit | 1 |  | ((1)) |  |
 |  | PurchaseOrderNumber |  |  | nvarchar | 25 |  |  |  |
 |  | AccountNumber |  |  | nvarchar | 15 |  |  |  |
 |  | CustomerID |  |  | int | 4 |  |  |  |
 |  | SalesPersonID |  |  | int | 4 |  | ((-1)) |  |
 |  | TerritoryID |  |  | int | 4 |  |  |  |
 |  | BillToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipToAddressID |  |  | int | 4 |  |  |  |
 |  | ShipMethodID |  |  | int | 4 |  |  |  |
 |  | CreditCardID |  |  | int | 4 |  |  |  |
 |  | CreditCardApprovalCode |  |  | varchar | 15 |  |  |  |
 |  | CurrencyRateID |  |  | int | 4 |  |  |  |
 |  | SubTotal |  |  | money | 8 |  | ((0.00)) |  |
 |  | TaxAmt |  |  | money | 8 |  | ((0.00)) |  |
 |  | Freight |  |  | money | 8 |  | ((0.00)) |  |
 |  | Comment |  |  | nvarchar | 128 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  |  |  |
Total: 23 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
PurchaseOrderNumber | nvarchar(25) | 1 | 10 | 13 | 0.26000000000000
AccountNumber | nvarchar(15) | 14 | 14 | 14 | 0.46666666666666
CreditCardApprovalCode | varchar(15) | 12 | 9 | 15 | 1.00000000000000
Comment | nvarchar(128) | 0 | 0 | 0 | 0
Total: 4 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK__SalesOrd__B14003C2B181FB70 | SalesOrderID |  |  |  | 5864 | 0
IX_CustomerID | CustomerID |  |  |  | 456 | 0
IX_SalesPersonID | SalesPersonID |  |  |  | 456 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
ODCK_SalesOrderHeader_DueDate | ([DueDate]>=[OrderDate])
ODCK_SalesOrderHeader_Freight | ([Freight]>=(0.00))
ODCK_SalesOrderHeader_ShipDate | ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
ODCK_SalesOrderHeader_Status | ([Status]>=(0) AND [Status]<=(8))
ODCK_SalesOrderHeader_SubTotal | ([SubTotal]>=(0.00))
ODCK_SalesOrderHeader_TaxAmt | ([TaxAmt]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesOrderID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail_ondisk | ODFK_SalesOrderDetail_SalesOrderHeader_SalesOrderID | PK__SalesOrd__B14003C2B181FB70
Total: 1 table(s)

Collapse image Objects that depend on Sales.SalesOrderHeader_ondisk

Object name | Object type | Dep level
Demo.usp_DemoReset | Procedure | 1
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure | 1
Sales.SalesOrderDetail_ondisk | Table | 1
Total 4 object(s)

Collapse image Objects that Sales.SalesOrderHeader_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesOrderHeader_ondisk] (
        [SalesOrderID]               [int] IDENTITY(1, 1) NOT NULL,
        [RevisionNumber]             [tinyint] NOT NULL,
        [OrderDate]                  [datetime2](7) NOT NULL,
        [DueDate]                    [datetime2](7) NOT NULL,
        [ShipDate]                   [datetime2](7) NULL,
        [Status]                     [tinyint] NOT NULL,
        [OnlineOrderFlag]            [bit] NOT NULL,
        [PurchaseOrderNumber]        [nvarchar](25) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [AccountNumber]              [nvarchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CustomerID]                 [int] NOT NULL,
        [SalesPersonID]              [int] NOT NULL,
        [TerritoryID]                [int] NULL,
        [BillToAddressID]            [int] NOT NULL,
        [ShipToAddressID]            [int] NOT NULL,
        [ShipMethodID]               [int] NOT NULL,
        [CreditCardID]               [int] NULL,
        [CreditCardApprovalCode]     [varchar](15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [CurrencyRateID]             [int] NULL,
        [SubTotal]                   [money] NOT NULL,
        [TaxAmt]                     [money] NOT NULL,
        [Freight]                    [money] NOT NULL,
        [Comment]                    [nvarchar](128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
        [ModifiedDate]               [datetime2](7) NOT NULL,
        CONSTRAINT [PK__SalesOrd__B14003C2B181FB70]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_DueDate]
    CHECK
    ([DueDate]>=[OrderDate])
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_DueDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_Freight]
    CHECK
    ([Freight]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_Freight]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_ShipDate]
    CHECK
    ([ShipDate]>=[OrderDate] OR [ShipDate] IS NULL)
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_ShipDate]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_Status]
    CHECK
    ([Status]>=(0) AND [Status]<=(8))
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_Status]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_SubTotal]
    CHECK
    ([SubTotal]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_SubTotal]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODCK_SalesOrderHeader_TaxAmt]
    CHECK
    ([TaxAmt]>=(0.00))
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
CHECK CONSTRAINT [ODCK_SalesOrderHeader_TaxAmt]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_Freight]
    DEFAULT ((0.00)) FOR [Freight]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_OnlineOrderFlag]
    DEFAULT ((1)) FOR [OnlineOrderFlag]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_RevisionNumber]
    DEFAULT ((0)) FOR [RevisionNumber]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_SalesPersonID]
    DEFAULT ((-1)) FOR [SalesPersonID]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_Status]
    DEFAULT ((1)) FOR [Status]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_SubTotal]
    DEFAULT ((0.00)) FOR [SubTotal]
GO
ALTER TABLE [Sales].[SalesOrderHeader_ondisk]
    ADD
    CONSTRAINT [ODDF_SalesOrderHeader_TaxAmt]
    DEFAULT ((0.00)) FOR [TaxAmt]
GO
CREATE NONCLUSTERED INDEX [IX_CustomerID]
    ON [Sales].[SalesOrderHeader_ondisk] ([CustomerID])
    ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [IX_SalesPersonID]
    ON [Sales].[SalesOrderHeader_ondisk] ([SalesPersonID])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


SalesOrderHeaderSalesReason

Table: AdventureWorks2016CTP3.Sales.SalesOrderHeaderSalesReason

CollapseAll image

Collapse image Description

Cross-reference table mapping sales orders to sales reason codes.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1842105603
Located on | PRIMARY
Data size KB | 688 KB
Index size KB | 16 KB
Rows | 27647
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesOrderHeaderSalesReason_SalesOrderID_SalesReasonID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | SalesOrderID | Primary key. Foreign key to SalesOrderHeader.SalesOrderID. |  | int | 4 |  |  |  |
Primary key | Foreign key | SalesReasonID | Primary key. Foreign key to SalesReason.SalesReasonID. |  | int | 4 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesOrderHeaderSalesReason_SalesOrderID_SalesReasonID | SalesOrderID | Primary key (clustered) constraint |  |  | 704 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesOrderHeader | PK_SalesOrderHeader_SalesOrderID | FK_SalesOrderHeaderSalesReason_SalesOrderHeader_SalesOrderID
Sales.SalesReason | PK_SalesReason_SalesReasonID | FK_SalesOrderHeaderSalesReason_SalesReason_SalesReasonID
Total: 2 table(s)

Collapse image Objects that Sales.SalesOrderHeaderSalesReason depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesReason | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping sales orders to sales reason codes.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SalesOrderHeaderSalesReason] (
        [SalesOrderID]      [int] NOT NULL,
        [SalesReasonID]     [int] NOT NULL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_SalesOrderHeaderSalesReason_SalesOrderID_SalesReasonID]
        PRIMARY KEY
        CLUSTERED
        ([SalesOrderID], [SalesReasonID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'CONSTRAINT', N'PK_SalesOrderHeaderSalesReason_SalesOrderID_SalesReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'INDEX', N'PK_SalesOrderHeaderSalesReason_SalesOrderID_SalesReasonID'
GO
ALTER TABLE [Sales].[SalesOrderHeaderSalesReason]
    ADD
    CONSTRAINT [DF_SalesOrderHeaderSalesReason_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'CONSTRAINT', N'DF_SalesOrderHeaderSalesReason_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesOrderHeaderSalesReason]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeaderSalesReason_SalesOrderHeader_SalesOrderID]
    FOREIGN KEY ([SalesOrderID]) REFERENCES [Sales].[SalesOrderHeader] ([SalesOrderID])
    ON DELETE CASCADE
ALTER TABLE [Sales].[SalesOrderHeaderSalesReason]
    CHECK CONSTRAINT [FK_SalesOrderHeaderSalesReason_SalesOrderHeader_SalesOrderID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesOrderHeader.SalesOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'CONSTRAINT', N'FK_SalesOrderHeaderSalesReason_SalesOrderHeader_SalesOrderID'
GO
ALTER TABLE [Sales].[SalesOrderHeaderSalesReason]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesOrderHeaderSalesReason_SalesReason_SalesReasonID]
    FOREIGN KEY ([SalesReasonID]) REFERENCES [Sales].[SalesReason] ([SalesReasonID])
ALTER TABLE [Sales].[SalesOrderHeaderSalesReason]
    CHECK CONSTRAINT [FK_SalesOrderHeaderSalesReason_SalesReason_SalesReasonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesReason.SalesReasonID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'CONSTRAINT', N'FK_SalesOrderHeaderSalesReason_SalesReason_SalesReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to SalesOrderHeader.SalesOrderID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'COLUMN', N'SalesOrderID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to SalesReason.SalesReasonID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', 'COLUMN', N'SalesReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping sales orders to sales reason codes.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeaderSalesReason', NULL, NULL
GO

Collapse image See also

List of tables


SalesPerson

Table: AdventureWorks2016CTP3.Sales.SalesPerson

Collapse image Description

Sales representative current information.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1874105717
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 17
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesPerson_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key for SalesPerson records. Foreign key to Employee.BusinessEntityID |  | int | 4 |  |  |  |
 | Foreign key | TerritoryID | Territory currently assigned to. Foreign key to SalesTerritory.SalesTerritoryID. |  | int | 4 |  |  |  |
 |  | SalesQuota | Projected yearly sales. |  | money | 8 |  |  |  |
 |  | Bonus | Bonus due if quota is met. |  | money | 8 |  | ((0.00)) |  |
 |  | CommissionPct | Commision percent received per sale. |  | smallmoney | 4 |  | ((0.00)) |  |
 |  | SalesYTD | Sales total year to date. |  | money | 8 |  | ((0.00)) |  |
 |  | SalesLastYear | Sales total of previous year. |  | money | 8 |  | ((0.00)) |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 9 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesPerson_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 32 | 0
AK_SalesPerson_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesPerson_Bonus | ([Bonus]>=(0.00))
CK_SalesPerson_CommissionPct | ([CommissionPct]>=(0.00))
CK_SalesPerson_SalesLastYear | ([SalesLastYear]>=(0.00))
CK_SalesPerson_SalesQuota | ([SalesQuota]>(0.00))
CK_SalesPerson_SalesYTD | ([SalesYTD]>=(0.00))

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderHeader | FK_SalesOrderHeader_SalesPerson_SalesPersonID | PK_SalesPerson_BusinessEntityID
Sales.SalesPersonQuotaHistory | FK_SalesPersonQuotaHistory_SalesPerson_BusinessEntityID | PK_SalesPerson_BusinessEntityID
Sales.SalesTerritoryHistory | FK_SalesTerritoryHistory_SalesPerson_BusinessEntityID | PK_SalesPerson_BusinessEntityID
Sales.Store | FK_Store_SalesPerson_SalesPersonID | PK_SalesPerson_BusinessEntityID
Total: 4 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
HumanResources.Employee | PK_Employee_BusinessEntityID | FK_SalesPerson_Employee_BusinessEntityID
Sales.SalesTerritory | PK_SalesTerritory_TerritoryID | FK_SalesPerson_SalesTerritory_TerritoryID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SalesPerson

Object name | Object type | Dep level
Sales.SalesOrderHeader | Table | 1
Sales.SalesPersonQuotaHistory | Table | 1
Sales.SalesTerritoryHistory | Table | 1
Sales.Store | Table | 1
Sales.uSalesOrderHeader | Trigger | 1
Security.customerAccessPredicate | Function | 1
Sales.vSalesPerson | View | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Total 8 object(s)

Collapse image Objects that Sales.SalesPerson depends on

Object name | Object type | Dep level
Sales | Schema | 1
HumanResources.Employee | Table | 1
Sales.SalesTerritory | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sales representative current information.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SalesPerson] (
        [BusinessEntityID]     [int] NOT NULL,
        [TerritoryID]          [int] NULL,
        [SalesQuota]           [money] NULL,
        [Bonus]                [money] NOT NULL,
        [CommissionPct]        [smallmoney] NOT NULL,
        [SalesYTD]             [money] NOT NULL,
        [SalesLastYear]        [money] NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_SalesPerson_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'PK_SalesPerson_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'INDEX', N'PK_SalesPerson_BusinessEntityID'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [CK_SalesPerson_Bonus]
    CHECK
    ([Bonus]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Bonus] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'CK_SalesPerson_Bonus'
GO
ALTER TABLE [Sales].[SalesPerson]
CHECK CONSTRAINT [CK_SalesPerson_Bonus]
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [CK_SalesPerson_CommissionPct]
    CHECK
    ([CommissionPct]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [CommissionPct] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'CK_SalesPerson_CommissionPct'
GO
ALTER TABLE [Sales].[SalesPerson]
CHECK CONSTRAINT [CK_SalesPerson_CommissionPct]
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [CK_SalesPerson_SalesLastYear]
    CHECK
    ([SalesLastYear]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesLastYear] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'CK_SalesPerson_SalesLastYear'
GO
ALTER TABLE [Sales].[SalesPerson]
CHECK CONSTRAINT [CK_SalesPerson_SalesLastYear]
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [CK_SalesPerson_SalesQuota]
    CHECK
    ([SalesQuota]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesQuota] > (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'CK_SalesPerson_SalesQuota'
GO
ALTER TABLE [Sales].[SalesPerson]
CHECK CONSTRAINT [CK_SalesPerson_SalesQuota]
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [CK_SalesPerson_SalesYTD]
    CHECK
    ([SalesYTD]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesYTD] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'CK_SalesPerson_SalesYTD'
GO
ALTER TABLE [Sales].[SalesPerson]
CHECK CONSTRAINT [CK_SalesPerson_SalesYTD]
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_Bonus]
    DEFAULT ((0.00)) FOR [Bonus]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_Bonus'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_CommissionPct]
    DEFAULT ((0.00)) FOR [CommissionPct]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_CommissionPct'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_rowguid'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_SalesLastYear]
    DEFAULT ((0.00)) FOR [SalesLastYear]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_SalesLastYear'
GO
ALTER TABLE [Sales].[SalesPerson]
    ADD
    CONSTRAINT [DF_SalesPerson_SalesYTD]
    DEFAULT ((0.00)) FOR [SalesYTD]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'DF_SalesPerson_SalesYTD'
GO
ALTER TABLE [Sales].[SalesPerson]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesPerson_Employee_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [HumanResources].[Employee] ([BusinessEntityID])
ALTER TABLE [Sales].[SalesPerson]
    CHECK CONSTRAINT [FK_SalesPerson_Employee_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Employee.EmployeeID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'FK_SalesPerson_Employee_BusinessEntityID'
GO
ALTER TABLE [Sales].[SalesPerson]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesPerson_SalesTerritory_TerritoryID]
    FOREIGN KEY ([TerritoryID]) REFERENCES [Sales].[SalesTerritory] ([TerritoryID])
ALTER TABLE [Sales].[SalesPerson]
    CHECK CONSTRAINT [FK_SalesPerson_SalesTerritory_TerritoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesTerritory.TerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'CONSTRAINT', N'FK_SalesPerson_SalesTerritory_TerritoryID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesPerson_rowguid]
    ON [Sales].[SalesPerson] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'INDEX', N'AK_SalesPerson_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Bonus due if quota is met.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'Bonus'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SalesPerson records. Foreign key to Employee.BusinessEntityID', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Commision percent received per sale.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'CommissionPct'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales total of previous year.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'SalesLastYear'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Projected yearly sales.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'SalesQuota'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales total year to date.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'SalesYTD'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Territory currently assigned to. Foreign key to SalesTerritory.SalesTerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales representative current information.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPerson', NULL, NULL
GO

Collapse image See also

List of tables


SalesPersonQuotaHistory

Table: AdventureWorks2016CTP3.Sales.SalesPersonQuotaHistory

Collapse image Description

Sales performance tracking.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 2066106401
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 32 KB
Rows | 163
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesPersonQuotaHistory_BusinessEntityID_QuotaDate]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Sales person identification number. Foreign key to SalesPerson.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key |  | QuotaDate | Sales quota date. |  | datetime | 8 |  |  |  |
 |  | SalesQuota | Sales quota amount. |  | money | 8 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesPersonQuotaHistory_BusinessEntityID_QuotaDate | BusinessEntityID | Primary key (clustered) constraint |  |  | 48 | 0
AK_SalesPersonQuotaHistory_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesPersonQuotaHistory_SalesQuota | ([SalesQuota]>(0.00))

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesPerson | PK_SalesPerson_BusinessEntityID | FK_SalesPersonQuotaHistory_SalesPerson_BusinessEntityID
Total: 1 table(s)

Collapse image Objects that Sales.SalesPersonQuotaHistory depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesPerson | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sales performance tracking.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SalesPersonQuotaHistory] (
        [BusinessEntityID]     [int] NOT NULL,
        [QuotaDate]            [datetime] NOT NULL,
        [SalesQuota]           [money] NOT NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_SalesPersonQuotaHistory_BusinessEntityID_QuotaDate]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [QuotaDate])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'CONSTRAINT', N'PK_SalesPersonQuotaHistory_BusinessEntityID_QuotaDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'INDEX', N'PK_SalesPersonQuotaHistory_BusinessEntityID_QuotaDate'
GO
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
    ADD
    CONSTRAINT [CK_SalesPersonQuotaHistory_SalesQuota]
    CHECK
    ([SalesQuota]>(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesQuota] > (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'CONSTRAINT', N'CK_SalesPersonQuotaHistory_SalesQuota'
GO
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
CHECK CONSTRAINT [CK_SalesPersonQuotaHistory_SalesQuota]
GO
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
    ADD
    CONSTRAINT [DF_SalesPersonQuotaHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'CONSTRAINT', N'DF_SalesPersonQuotaHistory_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
    ADD
    CONSTRAINT [DF_SalesPersonQuotaHistory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'CONSTRAINT', N'DF_SalesPersonQuotaHistory_rowguid'
GO
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesPersonQuotaHistory_SalesPerson_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Sales].[SalesPerson] ([BusinessEntityID])
ALTER TABLE [Sales].[SalesPersonQuotaHistory]
    CHECK CONSTRAINT [FK_SalesPersonQuotaHistory_SalesPerson_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesPerson.SalesPersonID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'CONSTRAINT', N'FK_SalesPersonQuotaHistory_SalesPerson_BusinessEntityID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesPersonQuotaHistory_rowguid]
    ON [Sales].[SalesPersonQuotaHistory] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'INDEX', N'AK_SalesPersonQuotaHistory_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales person identification number. Foreign key to SalesPerson.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales quota date.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'COLUMN', N'QuotaDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales quota amount.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', 'COLUMN', N'SalesQuota'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales performance tracking.', 'SCHEMA', N'Sales', 'TABLE', N'SalesPersonQuotaHistory', NULL, NULL
GO

Collapse image See also

List of tables


SalesReason

Table: AdventureWorks2016CTP3.Sales.SalesReason

Collapse image Description

Lookup table of customer purchase reasons.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 2130106629
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 10
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesReason_SalesReasonID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SalesReasonID | Primary key for SalesReason records. |  | int | 4 |  |  |  |
 |  | Name | Sales reason description. |  | Name | 50 |  |  |  |
 |  | ReasonType | Category the sales reason belongs to. |  | Name | 50 |  |  |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 11 | 5 | 25 | 0.25000000000000
ReasonType | nvarchar(50) | 7 | 5 | 9 | 0.09000000000000
Total: 2 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesReason_SalesReasonID | SalesReasonID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesReasonID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderHeaderSalesReason | FK_SalesOrderHeaderSalesReason_SalesReason_SalesReasonID | PK_SalesReason_SalesReasonID
Total: 1 table(s)

Collapse image Objects that depend on Sales.SalesReason

Object name | Object type | Dep level
Sales.SalesOrderHeaderSalesReason | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.SalesReason depends on

Object name | Object type | Dep level
Sales | Schema | 1
Name | Datatype | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Lookup table of customer purchase reasons.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesReason] (
        [SalesReasonID]     [int] IDENTITY(1, 1) NOT NULL,
        [Name]              [dbo].[Name] NOT NULL,
        [ReasonType]        [dbo].[Name] NOT NULL,
        [ModifiedDate]      [datetime] NOT NULL,
        CONSTRAINT [PK_SalesReason_SalesReasonID]
        PRIMARY KEY
        CLUSTERED
        ([SalesReasonID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'CONSTRAINT', N'PK_SalesReason_SalesReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'INDEX', N'PK_SalesReason_SalesReasonID'
GO
ALTER TABLE [Sales].[SalesReason]
    ADD
    CONSTRAINT [DF_SalesReason_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'CONSTRAINT', N'DF_SalesReason_ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales reason description.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Category the sales reason belongs to.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'COLUMN', N'ReasonType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SalesReason records.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', 'COLUMN', N'SalesReasonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Lookup table of customer purchase reasons.', 'SCHEMA', N'Sales', 'TABLE', N'SalesReason', NULL, NULL
GO

Collapse image See also

List of tables


SalesTaxRate

Table: AdventureWorks2016CTP3.Sales.SalesTaxRate

Collapse image Description

Tax rate lookup table.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 14623095
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 29
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesTaxRate_SalesTaxRateID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | SalesTaxRateID | Primary key for SalesTaxRate records. |  | int | 4 |  |  |  |
 |  | Foreign key | StateProvinceID | State, province, or country/region the sales tax applies to. |  | int | 4 |  |  |  |
 |  |  | TaxType | 1 = Tax applied to retail transactions, 2 = Tax applied to wholesale transactions, 3 = Tax applied to all sales (retail and wholesale) transactions. |  | tinyint | 1 |  |  |  |
 |  |  | TaxRate | Tax rate amount. |  | smallmoney | 4 |  | ((0.00)) |  |
 |  |  | Name | Tax rate description. |  | Name | 50 |  |  |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 7 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 19 | 12 | 37 | 0.37000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesTaxRate_SalesTaxRateID | SalesTaxRateID | Primary key (clustered) constraint |  |  | 48 | 0
AK_SalesTaxRate_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
AK_SalesTaxRate_StateProvinceID_TaxType | StateProvinceID | Unique nonclustered index. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesTaxRate_TaxType | ([TaxType]>=(1) AND [TaxType]<=(3))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SalesTaxRateID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.StateProvince | PK_StateProvince_StateProvinceID | FK_SalesTaxRate_StateProvince_StateProvinceID
Total: 1 table(s)

Collapse image Objects that Sales.SalesTaxRate depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.StateProvince | Table | 1
Name | Datatype | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Tax rate lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesTaxRate] (
        [SalesTaxRateID]      [int] IDENTITY(1, 1) NOT NULL,
        [StateProvinceID]     [int] NOT NULL,
        [TaxType]             [tinyint] NOT NULL,
        [TaxRate]             [smallmoney] NOT NULL,
        [Name]                [dbo].[Name] NOT NULL,
        [rowguid]             [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]        [datetime] NOT NULL,
        CONSTRAINT [PK_SalesTaxRate_SalesTaxRateID]
        PRIMARY KEY
        CLUSTERED
        ([SalesTaxRateID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'PK_SalesTaxRate_SalesTaxRateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'INDEX', N'PK_SalesTaxRate_SalesTaxRateID'
GO
ALTER TABLE [Sales].[SalesTaxRate]
    ADD
    CONSTRAINT [CK_SalesTaxRate_TaxType]
    CHECK
    ([TaxType]>=(1) AND [TaxType]<=(3))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [TaxType] BETWEEN (1) AND (3)', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'CK_SalesTaxRate_TaxType'
GO
ALTER TABLE [Sales].[SalesTaxRate]
CHECK CONSTRAINT [CK_SalesTaxRate_TaxType]
GO
ALTER TABLE [Sales].[SalesTaxRate]
    ADD
    CONSTRAINT [DF_SalesTaxRate_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'DF_SalesTaxRate_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesTaxRate]
    ADD
    CONSTRAINT [DF_SalesTaxRate_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'DF_SalesTaxRate_rowguid'
GO
ALTER TABLE [Sales].[SalesTaxRate]
    ADD
    CONSTRAINT [DF_SalesTaxRate_TaxRate]
    DEFAULT ((0.00)) FOR [TaxRate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'DF_SalesTaxRate_TaxRate'
GO
ALTER TABLE [Sales].[SalesTaxRate]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesTaxRate_StateProvince_StateProvinceID]
    FOREIGN KEY ([StateProvinceID]) REFERENCES [Person].[StateProvince] ([StateProvinceID])
ALTER TABLE [Sales].[SalesTaxRate]
    CHECK CONSTRAINT [FK_SalesTaxRate_StateProvince_StateProvinceID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing StateProvince.StateProvinceID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'CONSTRAINT', N'FK_SalesTaxRate_StateProvince_StateProvinceID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesTaxRate_rowguid]
    ON [Sales].[SalesTaxRate] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'INDEX', N'AK_SalesTaxRate_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesTaxRate_StateProvinceID_TaxType]
    ON [Sales].[SalesTaxRate] ([StateProvinceID], [TaxType])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'INDEX', N'AK_SalesTaxRate_StateProvinceID_TaxType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tax rate description.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SalesTaxRate records.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'SalesTaxRateID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'State, province, or country/region the sales tax applies to.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'StateProvinceID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tax rate amount.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'TaxRate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'1 = Tax applied to retail transactions, 2 = Tax applied to wholesale transactions, 3 = Tax applied to all sales (retail and wholesale) transactions.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', 'COLUMN', N'TaxType'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tax rate lookup table.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTaxRate', NULL, NULL
GO

Collapse image See also

List of tables


SalesTerritory

Table: AdventureWorks2016CTP3.Sales.SalesTerritory

Collapse image Description

Sales territory lookup table.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 94623380
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 40 KB
Rows | 10
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesTerritory_TerritoryID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | TerritoryID | Primary key for SalesTerritory records. |  | int | 4 |  |  |  |
 |  |  | Name | Sales territory description |  | Name | 50 |  |  |  |
 |  | Foreign key | CountryRegionCode | ISO standard country or region code. Foreign key to CountryRegion.CountryRegionCode. |  | nvarchar | 3 |  |  |  |
 |  |  | Group | Geographic area to which the sales territory belong. |  | nvarchar | 50 |  |  |  |
 |  |  | SalesYTD | Sales in the territory year to date. |  | money | 8 |  | ((0.00)) |  |
 |  |  | SalesLastYear | Sales in the territory the previous year. |  | money | 8 |  | ((0.00)) |  |
 |  |  | CostYTD | Business costs in the territory year to date. |  | money | 8 |  | ((0.00)) |  |
 |  |  | CostLastYear | Business costs in the territory the previous year. |  | money | 8 |  | ((0.00)) |  |
 |  |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 10 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 8 | 6 | 14 | 0.14000000000000
CountryRegionCode | nvarchar(3) | 2 | 2 | 2 | 0.33333333333333
Group | nvarchar(50) | 10 | 6 | 13 | 0.13000000000000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesTerritory_TerritoryID | TerritoryID | Primary key (clustered) constraint |  |  | 48 | 0
AK_SalesTerritory_Name | Name | Unique nonclustered index. |  |  | 16 | 0
AK_SalesTerritory_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesTerritory_CostLastYear | ([CostLastYear]>=(0.00))
CK_SalesTerritory_CostYTD | ([CostYTD]>=(0.00))
CK_SalesTerritory_SalesLastYear | ([SalesLastYear]>=(0.00))
CK_SalesTerritory_SalesYTD | ([SalesYTD]>=(0.00))

Collapse image Identity column

Name | Seed | Increment | Not for replication
TerritoryID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Person.StateProvince | FK_StateProvince_SalesTerritory_TerritoryID | PK_SalesTerritory_TerritoryID
Sales.Customer | FK_Customer_SalesTerritory_TerritoryID | PK_SalesTerritory_TerritoryID
Sales.SalesOrderHeader | FK_SalesOrderHeader_SalesTerritory_TerritoryID | PK_SalesTerritory_TerritoryID
Sales.SalesPerson | FK_SalesPerson_SalesTerritory_TerritoryID | PK_SalesTerritory_TerritoryID
Sales.SalesTerritoryHistory | FK_SalesTerritoryHistory_SalesTerritory_TerritoryID | PK_SalesTerritory_TerritoryID
Total: 5 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.CountryRegion | PK_CountryRegion_CountryRegionCode | FK_SalesTerritory_CountryRegion_CountryRegionCode
Total: 1 table(s)

Collapse image Objects that depend on Sales.SalesTerritory

Object name | Object type | Dep level
Sales.Customer | Table | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritoryHistory | Table | 1
Person.StateProvince | Table | 1
Sales.uSalesOrderHeader | Trigger | 1
Sales.vSalesPerson | View | 1
Sales.vSalesPersonSalesByFiscalYears | View | 1
Total 8 object(s)

Collapse image Objects that Sales.SalesTerritory depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.CountryRegion | Table | 1
Name | Datatype | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sales territory lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SalesTerritory] (
        [TerritoryID]           [int] IDENTITY(1, 1) NOT NULL,
        [Name]                  [dbo].[Name] NOT NULL,
        [CountryRegionCode]     [nvarchar](3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Group]                 [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [SalesYTD]              [money] NOT NULL,
        [SalesLastYear]         [money] NOT NULL,
        [CostYTD]               [money] NOT NULL,
        [CostLastYear]          [money] NOT NULL,
        [rowguid]               [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]          [datetime] NOT NULL,
        CONSTRAINT [PK_SalesTerritory_TerritoryID]
        PRIMARY KEY
        CLUSTERED
        ([TerritoryID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'PK_SalesTerritory_TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'INDEX', N'PK_SalesTerritory_TerritoryID'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [CK_SalesTerritory_CostLastYear]
    CHECK
    ([CostLastYear]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [CostLastYear] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'CK_SalesTerritory_CostLastYear'
GO
ALTER TABLE [Sales].[SalesTerritory]
CHECK CONSTRAINT [CK_SalesTerritory_CostLastYear]
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [CK_SalesTerritory_CostYTD]
    CHECK
    ([CostYTD]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [CostYTD] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'CK_SalesTerritory_CostYTD'
GO
ALTER TABLE [Sales].[SalesTerritory]
CHECK CONSTRAINT [CK_SalesTerritory_CostYTD]
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [CK_SalesTerritory_SalesLastYear]
    CHECK
    ([SalesLastYear]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesLastYear] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'CK_SalesTerritory_SalesLastYear'
GO
ALTER TABLE [Sales].[SalesTerritory]
CHECK CONSTRAINT [CK_SalesTerritory_SalesLastYear]
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [CK_SalesTerritory_SalesYTD]
    CHECK
    ([SalesYTD]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [SalesYTD] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'CK_SalesTerritory_SalesYTD'
GO
ALTER TABLE [Sales].[SalesTerritory]
CHECK CONSTRAINT [CK_SalesTerritory_SalesYTD]
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_CostLastYear]
    DEFAULT ((0.00)) FOR [CostLastYear]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_CostLastYear'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_CostYTD]
    DEFAULT ((0.00)) FOR [CostYTD]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_CostYTD'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_rowguid'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_SalesLastYear]
    DEFAULT ((0.00)) FOR [SalesLastYear]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_SalesLastYear'
GO
ALTER TABLE [Sales].[SalesTerritory]
    ADD
    CONSTRAINT [DF_SalesTerritory_SalesYTD]
    DEFAULT ((0.00)) FOR [SalesYTD]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'DF_SalesTerritory_SalesYTD'
GO
ALTER TABLE [Sales].[SalesTerritory]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesTerritory_CountryRegion_CountryRegionCode]
    FOREIGN KEY ([CountryRegionCode]) REFERENCES [Person].[CountryRegion] ([CountryRegionCode])
ALTER TABLE [Sales].[SalesTerritory]
    CHECK CONSTRAINT [FK_SalesTerritory_CountryRegion_CountryRegionCode]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing CountryRegion.CountryRegionCode.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'CONSTRAINT', N'FK_SalesTerritory_CountryRegion_CountryRegionCode'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesTerritory_Name]
    ON [Sales].[SalesTerritory] ([Name])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'INDEX', N'AK_SalesTerritory_Name'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesTerritory_rowguid]
    ON [Sales].[SalesTerritory] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'INDEX', N'AK_SalesTerritory_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Business costs in the territory the previous year.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'CostLastYear'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Business costs in the territory year to date.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'CostYTD'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ISO standard country or region code. Foreign key to CountryRegion.CountryRegionCode. ', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'CountryRegionCode'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Geographic area to which the sales territory belong.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'Group'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales territory description', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales in the territory the previous year.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'SalesLastYear'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales in the territory year to date.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'SalesYTD'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SalesTerritory records.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales territory lookup table.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritory', NULL, NULL
GO

Collapse image See also

List of tables


SalesTerritoryHistory

Table: AdventureWorks2016CTP3.Sales.SalesTerritoryHistory

Collapse image Description

Sales representative transfers to other sales territories.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 270624007
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 17
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SalesTerritoryHistory_BusinessEntityID_StartDate_TerritoryID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key. The sales rep. Foreign key to SalesPerson.BusinessEntityID. |  | int | 4 |  |  |  |
Primary key | Foreign key | TerritoryID | Primary key. Territory identification number. Foreign key to SalesTerritory.SalesTerritoryID. |  | int | 4 |  |  |  |
Primary key |  | StartDate | Primary key. Date the sales representive started work in the territory. |  | datetime | 8 |  |  |  |
 |  | EndDate | Date the sales representative left work in the territory. |  | datetime | 8 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SalesTerritoryHistory_BusinessEntityID_StartDate_TerritoryID | BusinessEntityID | Primary key (clustered) constraint |  |  | 32 | 0
AK_SalesTerritoryHistory_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SalesTerritoryHistory_EndDate | ([EndDate]>=[StartDate] OR [EndDate] IS NULL)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Sales.SalesPerson | PK_SalesPerson_BusinessEntityID | FK_SalesTerritoryHistory_SalesPerson_BusinessEntityID
Sales.SalesTerritory | PK_SalesTerritory_TerritoryID | FK_SalesTerritoryHistory_SalesTerritory_TerritoryID
Total: 2 table(s)

Collapse image Objects that Sales.SalesTerritoryHistory depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritory | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sales representative transfers to other sales territories.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SalesTerritoryHistory] (
        [BusinessEntityID]     [int] NOT NULL,
        [TerritoryID]          [int] NOT NULL,
        [StartDate]            [datetime] NOT NULL,
        [EndDate]              [datetime] NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_SalesTerritoryHistory_BusinessEntityID_StartDate_TerritoryID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID], [StartDate], [TerritoryID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'PK_SalesTerritoryHistory_BusinessEntityID_StartDate_TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'INDEX', N'PK_SalesTerritoryHistory_BusinessEntityID_StartDate_TerritoryID'
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
    ADD
    CONSTRAINT [CK_SalesTerritoryHistory_EndDate]
    CHECK
    ([EndDate]>=[StartDate] OR [EndDate] IS NULL)
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate] OR [EndDate] IS NULL', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'CK_SalesTerritoryHistory_EndDate'
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
CHECK CONSTRAINT [CK_SalesTerritoryHistory_EndDate]
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
    ADD
    CONSTRAINT [DF_SalesTerritoryHistory_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'DF_SalesTerritoryHistory_ModifiedDate'
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
    ADD
    CONSTRAINT [DF_SalesTerritoryHistory_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'DF_SalesTerritoryHistory_rowguid'
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesTerritoryHistory_SalesPerson_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Sales].[SalesPerson] ([BusinessEntityID])
ALTER TABLE [Sales].[SalesTerritoryHistory]
    CHECK CONSTRAINT [FK_SalesTerritoryHistory_SalesPerson_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesPerson.SalesPersonID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'FK_SalesTerritoryHistory_SalesPerson_BusinessEntityID'
GO
ALTER TABLE [Sales].[SalesTerritoryHistory]
    WITH CHECK
    ADD CONSTRAINT [FK_SalesTerritoryHistory_SalesTerritory_TerritoryID]
    FOREIGN KEY ([TerritoryID]) REFERENCES [Sales].[SalesTerritory] ([TerritoryID])
ALTER TABLE [Sales].[SalesTerritoryHistory]
    CHECK CONSTRAINT [FK_SalesTerritoryHistory_SalesTerritory_TerritoryID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesTerritory.TerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'CONSTRAINT', N'FK_SalesTerritoryHistory_SalesTerritory_TerritoryID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SalesTerritoryHistory_rowguid]
    ON [Sales].[SalesTerritoryHistory] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'INDEX', N'AK_SalesTerritoryHistory_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. The sales rep.  Foreign key to SalesPerson.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the sales representative left work in the territory.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Date the sales representive started work in the territory.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Territory identification number. Foreign key to SalesTerritory.SalesTerritoryID.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', 'COLUMN', N'TerritoryID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales representative transfers to other sales territories.', 'SCHEMA', N'Sales', 'TABLE', N'SalesTerritoryHistory', NULL, NULL
GO

Collapse image See also

List of tables


ShoppingCartItem

Table: AdventureWorks2016CTP3.Sales.ShoppingCartItem

Collapse image Description

Contains online customer orders until the order is submitted or cancelled.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 510624862
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 3
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_ShoppingCartItem_ShoppingCartItemID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity |  | ShoppingCartItemID | Primary key for ShoppingCartItem records. |  | int | 4 |  |  |  |
 |  |  | ShoppingCartID | Shopping cart identification number. |  | nvarchar | 50 |  |  |  |
 |  |  | Quantity | Product quantity ordered. |  | int | 4 |  | ((1)) |  |
 |  | Foreign key | ProductID | Product ordered. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  |  | DateCreated | Date the time the record was created. |  | datetime | 8 |  | (getdate()) |  |
 |  |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
ShoppingCartID | nvarchar(50) | 5 | 5 | 5 | 0.05000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_ShoppingCartItem_ShoppingCartItemID | ShoppingCartItemID | Primary key (clustered) constraint |  |  | 32 | 0
IX_ShoppingCartItem_ShoppingCartID_ProductID | ShoppingCartID | Nonclustered index. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_ShoppingCartItem_Quantity | ([Quantity]>=(1))

Collapse image Identity column

Name | Seed | Increment | Not for replication
ShoppingCartItemID | 1 | 1 |

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_ShoppingCartItem_Product_ProductID
Total: 1 table(s)

Collapse image Objects that Sales.ShoppingCartItem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Production.Product | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Contains online customer orders until the order is submitted or cancelled.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[ShoppingCartItem] (
        [ShoppingCartItemID]     [int] IDENTITY(1, 1) NOT NULL,
        [ShoppingCartID]         [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Quantity]               [int] NOT NULL,
        [ProductID]              [int] NOT NULL,
        [DateCreated]            [datetime] NOT NULL,
        [ModifiedDate]           [datetime] NOT NULL,
        CONSTRAINT [PK_ShoppingCartItem_ShoppingCartItemID]
        PRIMARY KEY
        CLUSTERED
        ([ShoppingCartItemID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'PK_ShoppingCartItem_ShoppingCartItemID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'INDEX', N'PK_ShoppingCartItem_ShoppingCartItemID'
GO
ALTER TABLE [Sales].[ShoppingCartItem]
    ADD
    CONSTRAINT [CK_ShoppingCartItem_Quantity]
    CHECK
    ([Quantity]>=(1))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [Quantity] >= (1)', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'CK_ShoppingCartItem_Quantity'
GO
ALTER TABLE [Sales].[ShoppingCartItem]
CHECK CONSTRAINT [CK_ShoppingCartItem_Quantity]
GO
ALTER TABLE [Sales].[ShoppingCartItem]
    ADD
    CONSTRAINT [DF_ShoppingCartItem_DateCreated]
    DEFAULT (getdate()) FOR [DateCreated]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'DF_ShoppingCartItem_DateCreated'
GO
ALTER TABLE [Sales].[ShoppingCartItem]
    ADD
    CONSTRAINT [DF_ShoppingCartItem_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'DF_ShoppingCartItem_ModifiedDate'
GO
ALTER TABLE [Sales].[ShoppingCartItem]
    ADD
    CONSTRAINT [DF_ShoppingCartItem_Quantity]
    DEFAULT ((1)) FOR [Quantity]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 1', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'DF_ShoppingCartItem_Quantity'
GO
ALTER TABLE [Sales].[ShoppingCartItem]
    WITH CHECK
    ADD CONSTRAINT [FK_ShoppingCartItem_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Sales].[ShoppingCartItem]
    CHECK CONSTRAINT [FK_ShoppingCartItem_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'CONSTRAINT', N'FK_ShoppingCartItem_Product_ProductID'
GO
CREATE NONCLUSTERED INDEX [IX_ShoppingCartItem_ShoppingCartID_ProductID]
    ON [Sales].[ShoppingCartItem] ([ShoppingCartID], [ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'INDEX', N'IX_ShoppingCartItem_ShoppingCartID_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date the time the record was created.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'DateCreated'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product ordered. Foreign key to Product.ProductID.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product quantity ordered.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'Quantity'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Shopping cart identification number.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'ShoppingCartID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for ShoppingCartItem records.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', 'COLUMN', N'ShoppingCartItemID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Contains online customer orders until the order is submitted or cancelled.', 'SCHEMA', N'Sales', 'TABLE', N'ShoppingCartItem', NULL, NULL
GO

Collapse image See also

List of tables


SpecialOffer

Table: AdventureWorks2016CTP3.Sales.SpecialOffer

Collapse image Description

Sale discounts lookup table.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 590625147
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 24 KB
Rows | 16
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SpecialOffer_SpecialOfferID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SpecialOfferID | Primary key for SpecialOffer records. |  | int | 4 |  |  |  |
 |  | Description | Discount description. |  | nvarchar | 255 |  |  |  |
 |  | DiscountPct | Discount precentage. |  | smallmoney | 4 |  | ((0.00)) |  |
 |  | Type | Discount type category. |  | nvarchar | 50 |  |  |  |
 |  | Category | Group the discount applies to such as Reseller or Customer. |  | nvarchar | 50 |  |  |  |
 |  | StartDate | Discount start date. |  | datetime | 8 |  |  |  |
 |  | EndDate | Discount end date. |  | datetime | 8 |  |  |  |
 |  | MinQty | Minimum discount percent allowed. |  | int | 4 |  | ((0)) |  |
 |  | MaxQty | Maximum discount percent allowed. |  | int | 4 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 11 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Description | nvarchar(255) | 22 | 11 | 34 | 0.06666666666666
Type | nvarchar(50) | 15 | 11 | 20 | 0.20000000000000
Category | nvarchar(50) | 8 | 8 | 11 | 0.11000000000000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SpecialOffer_SpecialOfferID | SpecialOfferID | Primary key (clustered) constraint |  |  | 32 | 0
AK_SpecialOffer_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 16 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
CK_SpecialOffer_DiscountPct | ([DiscountPct]>=(0.00))
CK_SpecialOffer_EndDate | ([EndDate]>=[StartDate])
CK_SpecialOffer_MaxQty | ([MaxQty]>=(0))
CK_SpecialOffer_MinQty | ([MinQty]>=(0))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SpecialOfferID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SpecialOfferProduct | FK_SpecialOfferProduct_SpecialOffer_SpecialOfferID | PK_SpecialOffer_SpecialOfferID
Total: 1 table(s)

Collapse image Objects that depend on Sales.SpecialOffer

Object name | Object type | Dep level
Sales.SpecialOfferProduct | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.SpecialOffer depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sale discounts lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SpecialOffer] (
        [SpecialOfferID]     [int] IDENTITY(1, 1) NOT NULL,
        [Description]        [nvarchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [DiscountPct]        [smallmoney] NOT NULL,
        [Type]               [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Category]           [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [StartDate]          [datetime] NOT NULL,
        [EndDate]            [datetime] NOT NULL,
        [MinQty]             [int] NOT NULL,
        [MaxQty]             [int] NULL,
        [rowguid]            [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]       [datetime] NOT NULL,
        CONSTRAINT [PK_SpecialOffer_SpecialOfferID]
        PRIMARY KEY
        CLUSTERED
        ([SpecialOfferID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'PK_SpecialOffer_SpecialOfferID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'INDEX', N'PK_SpecialOffer_SpecialOfferID'
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [CK_SpecialOffer_DiscountPct]
    CHECK
    ([DiscountPct]>=(0.00))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [DiscountPct] >= (0.00)', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'CK_SpecialOffer_DiscountPct'
GO
ALTER TABLE [Sales].[SpecialOffer]
CHECK CONSTRAINT [CK_SpecialOffer_DiscountPct]
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [CK_SpecialOffer_EndDate]
    CHECK
    ([EndDate]>=[StartDate])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [EndDate] >= [StartDate]', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'CK_SpecialOffer_EndDate'
GO
ALTER TABLE [Sales].[SpecialOffer]
CHECK CONSTRAINT [CK_SpecialOffer_EndDate]
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [CK_SpecialOffer_MaxQty]
    CHECK
    ([MaxQty]>=(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [MaxQty] >= (0)', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'CK_SpecialOffer_MaxQty'
GO
ALTER TABLE [Sales].[SpecialOffer]
CHECK CONSTRAINT [CK_SpecialOffer_MaxQty]
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [CK_SpecialOffer_MinQty]
    CHECK
    ([MinQty]>=(0))
GO
EXEC sp_addextendedproperty N'MS_Description', N'Check constraint [MinQty] >= (0)', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'CK_SpecialOffer_MinQty'
GO
ALTER TABLE [Sales].[SpecialOffer]
CHECK CONSTRAINT [CK_SpecialOffer_MinQty]
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [DF_SpecialOffer_DiscountPct]
    DEFAULT ((0.00)) FOR [DiscountPct]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'DF_SpecialOffer_DiscountPct'
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [DF_SpecialOffer_MinQty]
    DEFAULT ((0)) FOR [MinQty]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of 0.0', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'DF_SpecialOffer_MinQty'
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [DF_SpecialOffer_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'DF_SpecialOffer_ModifiedDate'
GO
ALTER TABLE [Sales].[SpecialOffer]
    ADD
    CONSTRAINT [DF_SpecialOffer_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'CONSTRAINT', N'DF_SpecialOffer_rowguid'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SpecialOffer_rowguid]
    ON [Sales].[SpecialOffer] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'INDEX', N'AK_SpecialOffer_rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Group the discount applies to such as Reseller or Customer.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'Category'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount description.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'Description'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount precentage.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'DiscountPct'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount end date.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'EndDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Maximum discount percent allowed.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'MaxQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Minimum discount percent allowed.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'MinQty'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SpecialOffer records.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'SpecialOfferID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount start date.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'StartDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Discount type category.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', 'COLUMN', N'Type'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sale discounts lookup table.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOffer', NULL, NULL
GO

Collapse image See also

List of tables


SpecialOffer_inmem

Table: AdventureWorks2016CTP3.Sales.SpecialOffer_inmem

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1895677801
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [IMPK_SpecialOffer_SpecialOfferID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SpecialOfferID |  |  | int | 4 |  |  |  |
 |  | Description |  |  | nvarchar | 255 |  |  |  |
 |  | DiscountPct |  |  | smallmoney | 4 |  | ((0.00)) |  |
 |  | Type |  |  | nvarchar | 50 |  |  |  |
 |  | Category |  |  | nvarchar | 50 |  |  |  |
 |  | StartDate |  |  | datetime2 | 8 |  |  |  |
 |  | EndDate |  |  | datetime2 | 8 |  |  |  |
 |  | MinQty |  |  | int | 4 |  | ((0)) |  |
 |  | MaxQty |  |  | int | 4 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 10 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Description | nvarchar(255) | 22 | 11 | 34 | 0.06666666666666
Type | nvarchar(50) | 15 | 11 | 20 | 0.20000000000000
Category | nvarchar(50) | 8 | 8 | 11 | 0.11000000000000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
IMPK_SpecialOffer_SpecialOfferID | SpecialOfferID |  |  |  | 0 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
IMCK_SpecialOffer_DiscountPct | ([DiscountPct]>=(0.00))
IMCK_SpecialOffer_EndDate | ([EndDate]>=[StartDate])
IMCK_SpecialOffer_MaxQty | ([MaxQty]>=(0))
IMCK_SpecialOffer_MinQty | ([MinQty]>=(0))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SpecialOfferID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SpecialOfferProduct_inmem | IMFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID | IMPK_SpecialOffer_SpecialOfferID
Total: 1 table(s)

Collapse image Objects that depend on Sales.SpecialOffer_inmem

Object name | Object type | Dep level
Sales.SpecialOfferProduct_inmem | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.SpecialOffer_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SpecialOffer_inmem] (
        [SpecialOfferID]     [int] IDENTITY(1, 1) NOT NULL,
        [Description]        [nvarchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [DiscountPct]        [smallmoney] NOT NULL,
        [Type]               [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Category]           [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [StartDate]          [datetime2](7) NOT NULL,
        [EndDate]            [datetime2](7) NOT NULL,
        [MinQty]             [int] NOT NULL,
        [MaxQty]             [int] NULL,
        [ModifiedDate]       [datetime2](7) NOT NULL,
        CONSTRAINT [IMPK_SpecialOffer_SpecialOfferID]
        PRIMARY KEY
        NONCLUSTERED HASH
        ([SpecialOfferID])
        WITH (BUCKET_COUNT=1048576)
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMCK_SpecialOffer_DiscountPct]
    CHECK
    ([DiscountPct]>=(0.00))
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
CHECK CONSTRAINT [IMCK_SpecialOffer_DiscountPct]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMCK_SpecialOffer_EndDate]
    CHECK
    ([EndDate]>=[StartDate])
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
CHECK CONSTRAINT [IMCK_SpecialOffer_EndDate]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMCK_SpecialOffer_MaxQty]
    CHECK
    ([MaxQty]>=(0))
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
CHECK CONSTRAINT [IMCK_SpecialOffer_MaxQty]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMCK_SpecialOffer_MinQty]
    CHECK
    ([MinQty]>=(0))
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
CHECK CONSTRAINT [IMCK_SpecialOffer_MinQty]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMDF_SpecialOffer_DiscountPct]
    DEFAULT ((0.00)) FOR [DiscountPct]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMDF_SpecialOffer_MinQty]
    DEFAULT ((0)) FOR [MinQty]
GO
ALTER TABLE [Sales].[SpecialOffer_inmem]
    ADD
    CONSTRAINT [IMDF_SpecialOffer_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO

Collapse image See also

List of tables


SpecialOffer_ondisk

Table: AdventureWorks2016CTP3.Sales.SpecialOffer_ondisk

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 628197288
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 16
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [ODPK_SpecialOffer_SpecialOfferID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | SpecialOfferID |  |  | int | 4 |  |  |  |
 |  | Description |  |  | nvarchar | 255 |  |  |  |
 |  | DiscountPct |  |  | smallmoney | 4 |  | ((0.00)) |  |
 |  | Type |  |  | nvarchar | 50 |  |  |  |
 |  | Category |  |  | nvarchar | 50 |  |  |  |
 |  | StartDate |  |  | datetime2 | 8 |  |  |  |
 |  | EndDate |  |  | datetime2 | 8 |  |  |  |
 |  | MinQty |  |  | int | 4 |  | ((0)) |  |
 |  | MaxQty |  |  | int | 4 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 10 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Description | nvarchar(255) | 22 | 11 | 34 | 0.06666666666666
Type | nvarchar(50) | 15 | 11 | 20 | 0.20000000000000
Category | nvarchar(50) | 8 | 8 | 11 | 0.11000000000000
Total: 3 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ODPK_SpecialOffer_SpecialOfferID | SpecialOfferID |  |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Check constraints

Name | Expression
ODCK_SpecialOffer_DiscountPct | ([DiscountPct]>=(0.00))
ODCK_SpecialOffer_EndDate | ([EndDate]>=[StartDate])
ODCK_SpecialOffer_MaxQty | ([MaxQty]>=(0))
ODCK_SpecialOffer_MinQty | ([MinQty]>=(0))

Collapse image Identity column

Name | Seed | Increment | Not for replication
SpecialOfferID | 1 | 1 |

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SpecialOfferProduct_ondisk | ODFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID | ODPK_SpecialOffer_SpecialOfferID
Total: 1 table(s)

Collapse image Objects that depend on Sales.SpecialOffer_ondisk

Object name | Object type | Dep level
Sales.usp_InsertSalesOrder_ondisk | Procedure | 1
Sales.SpecialOfferProduct_ondisk | Table | 1
Total 2 object(s)

Collapse image Objects that Sales.SpecialOffer_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SpecialOffer_ondisk] (
        [SpecialOfferID]     [int] IDENTITY(1, 1) NOT NULL,
        [Description]        [nvarchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [DiscountPct]        [smallmoney] NOT NULL,
        [Type]               [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [Category]           [nvarchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        [StartDate]          [datetime2](7) NOT NULL,
        [EndDate]            [datetime2](7) NOT NULL,
        [MinQty]             [int] NOT NULL,
        [MaxQty]             [int] NULL,
        [ModifiedDate]       [datetime2](7) NOT NULL,
        CONSTRAINT [ODPK_SpecialOffer_SpecialOfferID]
        PRIMARY KEY
        CLUSTERED
        ([SpecialOfferID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODCK_SpecialOffer_DiscountPct]
    CHECK
    ([DiscountPct]>=(0.00))
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
CHECK CONSTRAINT [ODCK_SpecialOffer_DiscountPct]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODCK_SpecialOffer_EndDate]
    CHECK
    ([EndDate]>=[StartDate])
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
CHECK CONSTRAINT [ODCK_SpecialOffer_EndDate]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODCK_SpecialOffer_MaxQty]
    CHECK
    ([MaxQty]>=(0))
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
CHECK CONSTRAINT [ODCK_SpecialOffer_MaxQty]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODCK_SpecialOffer_MinQty]
    CHECK
    ([MinQty]>=(0))
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
CHECK CONSTRAINT [ODCK_SpecialOffer_MinQty]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODDF_SpecialOffer_DiscountPct]
    DEFAULT ((0.00)) FOR [DiscountPct]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODDF_SpecialOffer_MinQty]
    DEFAULT ((0)) FOR [MinQty]
GO
ALTER TABLE [Sales].[SpecialOffer_ondisk]
    ADD
    CONSTRAINT [ODDF_SpecialOffer_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO

Collapse image See also

List of tables


SpecialOfferProduct

Table: AdventureWorks2016CTP3.Sales.SpecialOfferProduct

Collapse image Description

Cross-reference table mapping products to special offer discounts.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 734625660
Located on | PRIMARY
Data size KB | 24 KB
Index size KB | 64 KB
Rows | 538
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_SpecialOfferProduct_SpecialOfferID_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | SpecialOfferID | Primary key for SpecialOfferProduct records. |  | int | 4 |  |  |  |
Primary key | Foreign key | ProductID | Product identification number. Foreign key to Product.ProductID. |  | int | 4 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 4 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_SpecialOfferProduct_SpecialOfferID_ProductID | SpecialOfferID | Primary key (clustered) constraint |  |  | 88 | 0
AK_SpecialOfferProduct_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 32 | 0
IX_SpecialOfferProduct_ProductID | ProductID | Nonclustered index. |  |  | 16 | 0
Total: 3 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail | FK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID | PK_SpecialOfferProduct_SpecialOfferID_ProductID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product | PK_Product_ProductID | FK_SpecialOfferProduct_Product_ProductID
Sales.SpecialOffer | PK_SpecialOffer_SpecialOfferID | FK_SpecialOfferProduct_SpecialOffer_SpecialOfferID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SpecialOfferProduct

Object name | Object type | Dep level
Sales.SalesOrderDetail | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.SpecialOfferProduct depends on

Object name | Object type | Dep level
Sales | Schema | 1
Production.Product | Table | 1
Sales.SpecialOffer | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Cross-reference table mapping products to special offer discounts.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SpecialOfferProduct] (
        [SpecialOfferID]     [int] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [rowguid]            [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]       [datetime] NOT NULL,
        CONSTRAINT [PK_SpecialOfferProduct_SpecialOfferID_ProductID]
        PRIMARY KEY
        CLUSTERED
        ([SpecialOfferID], [ProductID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'CONSTRAINT', N'PK_SpecialOfferProduct_SpecialOfferID_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'INDEX', N'PK_SpecialOfferProduct_SpecialOfferID_ProductID'
GO
ALTER TABLE [Sales].[SpecialOfferProduct]
    ADD
    CONSTRAINT [DF_SpecialOfferProduct_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'CONSTRAINT', N'DF_SpecialOfferProduct_ModifiedDate'
GO
ALTER TABLE [Sales].[SpecialOfferProduct]
    ADD
    CONSTRAINT [DF_SpecialOfferProduct_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'CONSTRAINT', N'DF_SpecialOfferProduct_rowguid'
GO
ALTER TABLE [Sales].[SpecialOfferProduct]
    WITH CHECK
    ADD CONSTRAINT [FK_SpecialOfferProduct_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product] ([ProductID])
ALTER TABLE [Sales].[SpecialOfferProduct]
    CHECK CONSTRAINT [FK_SpecialOfferProduct_Product_ProductID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing Product.ProductID.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'CONSTRAINT', N'FK_SpecialOfferProduct_Product_ProductID'
GO
ALTER TABLE [Sales].[SpecialOfferProduct]
    WITH CHECK
    ADD CONSTRAINT [FK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]
    FOREIGN KEY ([SpecialOfferID]) REFERENCES [Sales].[SpecialOffer] ([SpecialOfferID])
ALTER TABLE [Sales].[SpecialOfferProduct]
    CHECK CONSTRAINT [FK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SpecialOffer.SpecialOfferID.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'CONSTRAINT', N'FK_SpecialOfferProduct_SpecialOffer_SpecialOfferID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_SpecialOfferProduct_rowguid]
    ON [Sales].[SpecialOfferProduct] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'INDEX', N'AK_SpecialOfferProduct_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_SpecialOfferProduct_ProductID]
    ON [Sales].[SpecialOfferProduct] ([ProductID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'INDEX', N'IX_SpecialOfferProduct_ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product identification number. Foreign key to Product.ProductID.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'COLUMN', N'ProductID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key for SpecialOfferProduct records.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', 'COLUMN', N'SpecialOfferID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Cross-reference table mapping products to special offer discounts.', 'SCHEMA', N'Sales', 'TABLE', N'SpecialOfferProduct', NULL, NULL
GO

Collapse image See also

List of tables


SpecialOfferProduct_inmem

Table: AdventureWorks2016CTP3.Sales.SpecialOfferProduct_inmem

CollapseAll image

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 132195521
Located on |
Data size KB | 0 KB
Index size KB | 0 KB
Rows | 0
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [IMPK_SpecialOfferProduct_SpecialOfferID_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | SpecialOfferID |  |  | int | 4 |  |  |  |
Primary key | Foreign key | ProductID |  |  | int | 4 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
IMPK_SpecialOfferProduct_SpecialOfferID_ProductID | SpecialOfferID |  |  |  | 0 | 0
ix_ProductID | ProductID |  |  |  | 0 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail_inmem | IMFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID | IMPK_SpecialOfferProduct_SpecialOfferID_ProductID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product_inmem | IMPK_Product_ProductID | IMFK_SpecialOfferProduct_Product_ProductID
Sales.SpecialOffer_inmem | IMPK_SpecialOffer_SpecialOfferID | IMFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SpecialOfferProduct_inmem

Object name | Object type | Dep level
Demo.usp_DemoInitSeed | Procedure | 1
Sales.SalesOrderDetail_inmem | Table | 1
Total 2 object(s)

Collapse image Objects that Sales.SpecialOfferProduct_inmem depends on

Object name | Object type | Dep level
Sales | Schema | 1
Production.Product_inmem | Table | 1
Sales.SpecialOffer_inmem | Table | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[SpecialOfferProduct_inmem] (
        [SpecialOfferID]     [int] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [ModifiedDate]       [datetime2](7) NOT NULL,
        CONSTRAINT [IMPK_SpecialOfferProduct_SpecialOfferID_ProductID]
        PRIMARY KEY
        NONCLUSTERED
        ([SpecialOfferID], [ProductID])
)
WITH (MEMORY_OPTIMIZED=ON, DURABILITY=SCHEMA_AND_DATA)
GO
ALTER TABLE [Sales].[SpecialOfferProduct_inmem]
    ADD
    CONSTRAINT [IMDF_SpecialOfferProduct_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO
ALTER TABLE [Sales].[SpecialOfferProduct_inmem]
    WITH CHECK
    ADD CONSTRAINT [IMFK_SpecialOfferProduct_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product_inmem] ([ProductID])
ALTER TABLE [Sales].[SpecialOfferProduct_inmem]
    CHECK CONSTRAINT [IMFK_SpecialOfferProduct_Product_ProductID]

GO
ALTER TABLE [Sales].[SpecialOfferProduct_inmem]
    WITH CHECK
    ADD CONSTRAINT [IMFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]
    FOREIGN KEY ([SpecialOfferID]) REFERENCES [Sales].[SpecialOffer_inmem] ([SpecialOfferID])
ALTER TABLE [Sales].[SpecialOfferProduct_inmem]
    CHECK CONSTRAINT [IMFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]

GO
CREATE NONCLUSTERED INDEX [ix_ProductID]
    ON [Sales].[SpecialOfferProduct_inmem] ([ProductID])
    WITH ( STATISTICS_NORECOMPUTE = ON, ALLOW_ROW_LOCKS = OFF, ALLOW_PAGE_LOCKS = OFF)
GO

Collapse image See also

List of tables


SpecialOfferProduct_ondisk

Table: AdventureWorks2016CTP3.Sales.SpecialOfferProduct_ondisk

CollapseAll image

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 1012198656
Located on | PRIMARY
Data size KB | 16 KB
Index size KB | 72 KB
Rows | 538
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [ODPK_SpecialOfferProduct_SpecialOfferID_ProductID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | OFF

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | SpecialOfferID |  |  | int | 4 |  |  |  |
Primary key | Foreign key | ProductID |  |  | int | 4 |  |  |  |
 |  | ModifiedDate |  |  | datetime2 | 8 |  | (sysdatetime()) |  |
Total: 3 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
ODPK_SpecialOfferProduct_SpecialOfferID_ProductID | SpecialOfferID |  |  |  | 32 | 0
ix_ProductID | ProductID |  |  |  | 32 | 0
Total: 2 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.SalesOrderDetail_ondisk | ODFK_SalesOrderDetail_SpecialOfferProduct_SpecialOfferIDProductID | ODPK_SpecialOfferProduct_SpecialOfferID_ProductID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Production.Product_ondisk | ODPK_Product_ProductID | ODFK_SpecialOfferProduct_Product_ProductID
Sales.SpecialOffer_ondisk | ODPK_SpecialOffer_SpecialOfferID | ODFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID
Total: 2 table(s)

Collapse image Objects that depend on Sales.SpecialOfferProduct_ondisk

Object name | Object type | Dep level
Sales.SalesOrderDetail_ondisk | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.SpecialOfferProduct_ondisk depends on

Object name | Object type | Dep level
Sales | Schema | 1
Production.Product_ondisk | Table | 1
Sales.SpecialOffer_ondisk | Table | 1
Total 3 object(s)

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING OFF
GO
CREATE TABLE [Sales].[SpecialOfferProduct_ondisk] (
        [SpecialOfferID]     [int] NOT NULL,
        [ProductID]          [int] NOT NULL,
        [ModifiedDate]       [datetime2](7) NOT NULL,
        CONSTRAINT [ODPK_SpecialOfferProduct_SpecialOfferID_ProductID]
        PRIMARY KEY
        NONCLUSTERED
        ([SpecialOfferID], [ProductID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
ALTER TABLE [Sales].[SpecialOfferProduct_ondisk]
    ADD
    CONSTRAINT [ODDF_SpecialOfferProduct_ModifiedDate]
    DEFAULT (sysdatetime()) FOR [ModifiedDate]
GO
ALTER TABLE [Sales].[SpecialOfferProduct_ondisk]
    WITH CHECK
    ADD CONSTRAINT [ODFK_SpecialOfferProduct_Product_ProductID]
    FOREIGN KEY ([ProductID]) REFERENCES [Production].[Product_ondisk] ([ProductID])
ALTER TABLE [Sales].[SpecialOfferProduct_ondisk]
    CHECK CONSTRAINT [ODFK_SpecialOfferProduct_Product_ProductID]

GO
ALTER TABLE [Sales].[SpecialOfferProduct_ondisk]
    WITH CHECK
    ADD CONSTRAINT [ODFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]
    FOREIGN KEY ([SpecialOfferID]) REFERENCES [Sales].[SpecialOffer_ondisk] ([SpecialOfferID])
ALTER TABLE [Sales].[SpecialOfferProduct_ondisk]
    CHECK CONSTRAINT [ODFK_SpecialOfferProduct_SpecialOffer_SpecialOfferID]

GO
CREATE NONCLUSTERED INDEX [ix_ProductID]
    ON [Sales].[SpecialOfferProduct_ondisk] ([ProductID])
    ON [PRIMARY]
GO

Collapse image See also

List of tables


Store

Table: AdventureWorks2016CTP3.Sales.Store

Collapse image Description

Customers (resellers) of Adventure Works products.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 23.10.2015
ID | 846626059
Located on | PRIMARY
Data size KB | 808 KB
Index size KB | 616 KB
Rows | 701
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_Store_BusinessEntityID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Foreign key | BusinessEntityID | Primary key. Foreign key to Customer.BusinessEntityID. |  | int | 4 |  |  |  |
 |  | Name | Name of the store. |  | Name | 50 |  |  |  |
 | Foreign key | SalesPersonID | ID of the sales person assigned to the customer. Foreign key to SalesPerson.BusinessEntityID. |  | int | 4 |  |  |  |
 |  | Demographics | Demographic informationg about the store such as the number of employees, annual sales and store type. |  | xml(Sales.StoreSurveySchemaCollection) | 2147483647 |  |  |  |
 |  | rowguid | ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample. |  | uniqueidentifier | 16 |  | (newid()) |  |
 |  | ModifiedDate | Date and time the record was last updated. |  | datetime | 8 |  | (getdate()) |  |
Total: 6 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
Name | nvarchar(50) | 20 | 9 | 41 | 0.41000000000000
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_Store_BusinessEntityID | BusinessEntityID | Primary key (clustered) constraint |  |  | 896 | 0
AK_Store_rowguid | rowguid | Unique nonclustered index. Used to support replication samples. |  |  | 40 | 0
IX_Store_SalesPersonID | SalesPersonID | Nonclustered index. |  |  | 32 | 0
PXML_Store_Demographics |  | Primary XML index. |  |  | 528 | 0
Total: 4 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Referencing tables

Table | Foreign key | Primary key or unique constraint
Sales.Customer | FK_Customer_Store_StoreID | PK_Store_BusinessEntityID
Total: 1 table(s)

Collapse image Referenced tables

Table | Primary key or unique constraint | Foreign key
Person.BusinessEntity | PK_BusinessEntity_BusinessEntityID | FK_Store_BusinessEntity_BusinessEntityID
Sales.SalesPerson | PK_SalesPerson_BusinessEntityID | FK_Store_SalesPerson_SalesPersonID
Total: 2 table(s)

Collapse image Objects that depend on Sales.Store

Object name | Object type | Dep level
Sales.Customer | Table | 1
ufnGetContactInformation | Function | 1
Sales.vStoreWithAddresses | View | 1
Sales.vStoreWithContacts | View | 1
Sales.vStoreWithDemographics | View | 1
Total 5 object(s)

Collapse image Objects that Sales.Store depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.BusinessEntity | Table | 1
Sales.SalesPerson | Table | 1
Name | Datatype | 1
Sales.StoreSurveySchemaCollection | XML Schema Collection | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Customers (resellers) of Adventure Works products.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[Store] (
        [BusinessEntityID]     [int] NOT NULL,
        [Name]                 [dbo].[Name] NOT NULL,
        [SalesPersonID]        [int] NULL,
        [Demographics]         [xml](CONTENT [Sales].[StoreSurveySchemaCollection]) NULL,
        [rowguid]              [uniqueidentifier] NOT NULL ROWGUIDCOL,
        [ModifiedDate]         [datetime] NOT NULL,
        CONSTRAINT [PK_Store_BusinessEntityID]
        PRIMARY KEY
        CLUSTERED
        ([BusinessEntityID])
    ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'CONSTRAINT', N'PK_Store_BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index created by a primary key constraint.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'INDEX', N'PK_Store_BusinessEntityID'
GO
ALTER TABLE [Sales].[Store]
    ADD
    CONSTRAINT [DF_Store_ModifiedDate]
    DEFAULT (getdate()) FOR [ModifiedDate]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of GETDATE()', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'CONSTRAINT', N'DF_Store_ModifiedDate'
GO
ALTER TABLE [Sales].[Store]
    ADD
    CONSTRAINT [DF_Store_rowguid]
    DEFAULT (newid()) FOR [rowguid]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Default constraint value of NEWID()', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'CONSTRAINT', N'DF_Store_rowguid'
GO
ALTER TABLE [Sales].[Store]
    WITH CHECK
    ADD CONSTRAINT [FK_Store_BusinessEntity_BusinessEntityID]
    FOREIGN KEY ([BusinessEntityID]) REFERENCES [Person].[BusinessEntity] ([BusinessEntityID])
ALTER TABLE [Sales].[Store]
    CHECK CONSTRAINT [FK_Store_BusinessEntity_BusinessEntityID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing BusinessEntity.BusinessEntityID', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'CONSTRAINT', N'FK_Store_BusinessEntity_BusinessEntityID'
GO
ALTER TABLE [Sales].[Store]
    WITH CHECK
    ADD CONSTRAINT [FK_Store_SalesPerson_SalesPersonID]
    FOREIGN KEY ([SalesPersonID]) REFERENCES [Sales].[SalesPerson] ([BusinessEntityID])
ALTER TABLE [Sales].[Store]
    CHECK CONSTRAINT [FK_Store_SalesPerson_SalesPersonID]

GO
EXEC sp_addextendedproperty N'MS_Description', N'Foreign key constraint referencing SalesPerson.SalesPersonID', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'CONSTRAINT', N'FK_Store_SalesPerson_SalesPersonID'
GO
CREATE UNIQUE NONCLUSTERED INDEX [AK_Store_rowguid]
    ON [Sales].[Store] ([rowguid])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Unique nonclustered index. Used to support replication samples.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'INDEX', N'AK_Store_rowguid'
GO
CREATE NONCLUSTERED INDEX [IX_Store_SalesPersonID]
    ON [Sales].[Store] ([SalesPersonID])
    ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Nonclustered index.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'INDEX', N'IX_Store_SalesPersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key. Foreign key to Customer.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'BusinessEntityID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Demographic informationg about the store such as the number of employees, annual sales and store type.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'Demographics'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Date and time the record was last updated.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'ModifiedDate'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Name of the store.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'Name'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ROWGUIDCOL number uniquely identifying the record. Used to support a merge replication sample.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'rowguid'
GO
EXEC sp_addextendedproperty N'MS_Description', N'ID of the sales person assigned to the customer. Foreign key to SalesPerson.BusinessEntityID.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'COLUMN', N'SalesPersonID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Customers (resellers) of Adventure Works products.', 'SCHEMA', N'Sales', 'TABLE', N'Store', NULL, NULL
GO
SET ANSI_PADDING ON
GO
CREATE PRIMARY XML INDEX [PXML_Store_Demographics]
    ON [Sales].[Store] ([Demographics])
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary XML index.', 'SCHEMA', N'Sales', 'TABLE', N'Store', 'INDEX', N'PXML_Store_Demographics'
GO

Collapse image See also

List of tables


TrackingEvent

Table: AdventureWorks2016CTP3.Sales.TrackingEvent

Collapse image Description

Tracking event lookup table.

Collapse image Table properties

Name | Value
Schema | Sales
Owner | dbo
Table is replicated |
Creation date | 16.11.2015
ID | 1965250056
Located on | PRIMARY
Data size KB | 8 KB
Index size KB | 8 KB
Rows | 7
ChangeTrackingEnabled |
FileStreamFileGroup |
FileStreamPartitionScheme |
LockEscalation | TABLE
TrackColumnsUpdatedEnabled |
Table is filetable |
Filetable directory |
Filetable collate |
Filetable primary key | [PK_TrackingEvent_TrackingEventID]
Filetable streamid unique |
Filetable fullpath unique |
Filetable is enabled |
Is memory optimized |
Durability | SCHEMA_AND_DATA

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON
ANSI_PADDING | ON

Collapse image Columns

 |  | Name | Description | Data type | Max length | Nullable | Default | IsGUID | SPARSE | Computed value
Primary key | Identity | TrackingEventID | Primary key. |  | int | 4 |  |  |  |
 |  | EventName | Tracking event name. |  | nvarchar | 255 |  |  |  |
Total: 2 column(s)

Collapse image Text column statistics

Name | Data type | Avg. length | Min. length | Max. length | Usage rating
EventName | nvarchar(255) | 18 | 10 | 33 | 0.06470588235294
Total: 1 text column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
PK_TrackingEvent_TrackingEventID | TrackingEventID | Primary key (clustered) constraint |  |  | 16 | 0
Total: 1 Index/indexes

Collapse image Columnstore indexes

No columnstore indexes exist

Collapse image Identity column

Name | Seed | Increment | Not for replication
TrackingEventID | 1 | 1 |

Collapse image Objects that depend on Sales.TrackingEvent

Object name | Object type | Dep level
uspGetOrderTrackingBySalesOrderID | Procedure | 1
uspGetOrderTrackingByTrackingNumber | Procedure | 1
Total 2 object(s)

Collapse image Objects that Sales.TrackingEvent depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Tracking event lookup table.

Collapse image Table options

Name | Value
Pintable | OFF
Table lock on bulk load | OFF
Insert row lock | OFF
Text in row | 0
Large value types out of row | OFF

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
SET ANSI_PADDING ON
GO
CREATE TABLE [Sales].[TrackingEvent] (
        [TrackingEventID]     [int] IDENTITY(1, 1) NOT NULL,
        [EventName]           [nvarchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
        CONSTRAINT [PK_TrackingEvent_TrackingEventID]
        PRIMARY KEY
        CLUSTERED
        ([TrackingEventID])
    ON [PRIMARY]
) ON [PRIMARY]
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key (clustered) constraint', 'SCHEMA', N'Sales', 'TABLE', N'TrackingEvent', 'CONSTRAINT', N'PK_TrackingEvent_TrackingEventID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tracking event name.', 'SCHEMA', N'Sales', 'TABLE', N'TrackingEvent', 'COLUMN', N'EventName'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Primary key.', 'SCHEMA', N'Sales', 'TABLE', N'TrackingEvent', 'COLUMN', N'TrackingEventID'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Tracking event lookup table.', 'SCHEMA', N'Sales', 'TABLE', N'TrackingEvent', NULL, NULL
GO

Collapse image See also

List of tables


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
tr_d_AUDIT_AWBuildVersion | dbo |  |  |  |  | For Delete | AWBuildVersion
tr_d_AUDIT_DatabaseLog | dbo |  |  |  |  | For Delete | DatabaseLog
tr_d_AUDIT_ErrorLog | dbo |  |  |  |  | For Delete | ErrorLog
tr_i_AUDIT_DatabaseLog | dbo |  |  | For Insert |  |  | DatabaseLog
tr_i_AUDIT_ErrorLog | dbo |  |  | For Insert |  |  | ErrorLog
tr_u_AUDIT_AWBuildVersion | dbo |  |  |  | For Update |  | AWBuildVersion
tr_u_AUDIT_DatabaseLog | dbo |  |  |  | For Update |  | DatabaseLog
dEmployee | HumanResources | INSTEAD OF DELETE trigger which keeps Employees from being deleted. |  |  |  | For Delete | HumanResources.Employee
tr_d_AUDIT_Department | HumanResources |  |  |  |  | For Delete | HumanResources.Department
tr_d_AUDIT_Employee | HumanResources |  |  |  |  | For Delete | HumanResources.Employee
tr_d_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeeDepartmentHistory
tr_d_AUDIT_EmployeePayHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeePayHistory
tr_i_AUDIT_Department | HumanResources |  |  | For Insert |  |  | HumanResources.Department
tr_i_AUDIT_Employee | HumanResources |  |  | For Insert |  |  | HumanResources.Employee
tr_i_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeeDepartmentHistory
tr_i_AUDIT_EmployeePayHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeePayHistory
tr_u_AUDIT_Department | HumanResources |  |  |  | For Update |  | HumanResources.Department
tr_u_AUDIT_Employee_Temporal | HumanResources |  |  |  | For Update |  | HumanResources.Employee_Temporal
tr_u_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeeDepartmentHistory
tr_u_AUDIT_EmployeePayHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeePayHistory
iuPerson | Person | AFTER INSERT, UPDATE trigger inserting Individual only if the Customer does not exist in the Store table and setting the ModifiedDate column in the Person table to the current date. |  | For Insert | For Update |  | Person.Person
iWorkOrder | Production | AFTER INSERT trigger that inserts a row in the TransactionHistory table. |  | For Insert |  |  | Production.WorkOrder
uWorkOrder | Production | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in the WorkOrder table. |  |  | For Update |  | Production.WorkOrder
dVendor | Purchasing | INSTEAD OF DELETE trigger which keeps Vendors from being deleted. |  |  |  | For Delete | Purchasing.Vendor
iPurchaseOrderDetail | Purchasing | AFTER INSERT trigger that inserts a row in the TransactionHistory table and updates the PurchaseOrderHeader.SubTotal column. |  | For Insert |  |  | Purchasing.PurchaseOrderDetail
uPurchaseOrderDetail | Purchasing | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in PurchaseOrderDetail and updates the PurchaseOrderHeader.SubTotal column. |  |  | For Update |  | Purchasing.PurchaseOrderDetail
uPurchaseOrderHeader | Purchasing | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the PurchaseOrderHeader table. |  |  | For Update |  | Purchasing.PurchaseOrderHeader
iduSalesOrderDetail | Sales | AFTER INSERT, DELETE, UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in SalesOrderDetail and updates the SalesOrderHeader.SubTotal column. |  | For Insert | For Update | For Delete | Sales.SalesOrderDetail
uSalesOrderHeader | Sales | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the SalesOrderHeader table.Updates the SalesYTD column in the SalesPerson and SalesTerritory tables. |  |  | For Update |  | Sales.SalesOrderHeader
Total: 29 trigger(s)

Collapse image See also

Tables

Views

Database overview


tr_d_AUDIT_AWBuildVersion

Trigger: AdventureWorks2016CTP3.dbo.tr_d_AUDIT_AWBuildVersion on Table AWBuildVersion

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1883869778
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_d_AUDIT_AWBuildVersion depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
AWBuildVersion | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_d_AUDIT_AWBuildVersion]
ON [dbo].[AWBuildVersion]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [dbo].[AWBuildVersion]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:23 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(3000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[AWBuildVersion]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'AWBuildVersion',
        'dbo',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0), '[SystemInformationID] Is Null')),
        'SystemInformationID',
        CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0))
    FROM deleted OLD
    WHERE
        OLD.[SystemInformationID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0), '[SystemInformationID] Is Null')),
        'Database Version',
        CONVERT(nvarchar(4000), OLD.[Database Version], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Database Version] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0), '[SystemInformationID] Is Null')),
        'VersionDate',
        CONVERT(nvarchar(4000), OLD.[VersionDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0))
    FROM deleted OLD
    WHERE
        OLD.[VersionDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0), '[SystemInformationID] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END

GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_d_AUDIT_AWBuildVersion]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

AWBuildVersion


tr_d_AUDIT_DatabaseLog

Trigger: AdventureWorks2016CTP3.dbo.tr_d_AUDIT_DatabaseLog on Table DatabaseLog

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1931869949
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_d_AUDIT_DatabaseLog depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
DatabaseLog | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_d_AUDIT_DatabaseLog]
ON [dbo].[DatabaseLog]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [dbo].[DatabaseLog]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:23 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[DatabaseLog]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'DatabaseLog',
        'dbo',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'DatabaseLogID',
        CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[DatabaseLogID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'PostTime',
        CONVERT(nvarchar(4000), OLD.[PostTime], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[PostTime] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'DatabaseUser',
        CONVERT(nvarchar(4000), OLD.[DatabaseUser], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[DatabaseUser] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Event',
        CONVERT(nvarchar(4000), OLD.[Event], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Event] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Schema',
        CONVERT(nvarchar(4000), OLD.[Schema], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Schema] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Object',
        CONVERT(nvarchar(4000), OLD.[Object], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Object] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'TSQL',
        CONVERT(nvarchar(4000), OLD.[TSQL], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[TSQL] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'XmlEvent',
        CONVERT(nvarchar(max), CONVERT(nvarchar(max), OLD.[XmlEvent])),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[XmlEvent] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_d_AUDIT_DatabaseLog]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

DatabaseLog


tr_d_AUDIT_ErrorLog

Trigger: AdventureWorks2016CTP3.dbo.tr_d_AUDIT_ErrorLog on Table ErrorLog

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1963870063
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_d_AUDIT_ErrorLog depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
ErrorLog | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_d_AUDIT_ErrorLog]
ON [dbo].[ErrorLog]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [dbo].[ErrorLog]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[ErrorLog]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'ErrorLog',
        'dbo',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorLogID',
        CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorLogID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorTime',
        CONVERT(nvarchar(4000), OLD.[ErrorTime], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorTime] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'UserName',
        CONVERT(nvarchar(4000), OLD.[UserName], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[UserName] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorNumber',
        CONVERT(nvarchar(4000), OLD.[ErrorNumber], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorNumber] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorSeverity',
        CONVERT(nvarchar(4000), OLD.[ErrorSeverity], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorSeverity] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorState',
        CONVERT(nvarchar(4000), OLD.[ErrorState], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorState] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorProcedure',
        CONVERT(nvarchar(4000), OLD.[ErrorProcedure], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorProcedure] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorLine',
        CONVERT(nvarchar(4000), OLD.[ErrorLine], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorLine] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorMessage',
        CONVERT(nvarchar(4000), OLD.[ErrorMessage], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ErrorLogID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ErrorMessage] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_d_AUDIT_ErrorLog]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

ErrorLog


tr_i_AUDIT_DatabaseLog

Trigger: AdventureWorks2016CTP3.dbo.tr_i_AUDIT_DatabaseLog on Table DatabaseLog

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1899869835
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_i_AUDIT_DatabaseLog depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
DatabaseLog | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_i_AUDIT_DatabaseLog]
ON [dbo].[DatabaseLog]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [dbo].[DatabaseLog]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:23 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[DatabaseLog]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'DatabaseLog',
        'dbo',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'DatabaseLogID',
        CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[DatabaseLogID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'PostTime',
        CONVERT(nvarchar(4000), NEW.[PostTime], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[PostTime] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'DatabaseUser',
        CONVERT(nvarchar(4000), NEW.[DatabaseUser], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[DatabaseUser] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Event',
        CONVERT(nvarchar(4000), NEW.[Event], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[Event] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Schema',
        CONVERT(nvarchar(4000), NEW.[Schema], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[Schema] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'Object',
        CONVERT(nvarchar(4000), NEW.[Object], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[Object] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'TSQL',
        CONVERT(nvarchar(4000), NEW.[TSQL], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[TSQL] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0), '[DatabaseLogID] Is Null')),
        'XmlEvent',
        CONVERT(nvarchar(max), CONVERT(nvarchar(max), NEW.[XmlEvent])),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0))
    FROM inserted NEW
    WHERE NEW.[XmlEvent] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_i_AUDIT_DatabaseLog]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

DatabaseLog


tr_i_AUDIT_ErrorLog

Trigger: AdventureWorks2016CTP3.dbo.tr_i_AUDIT_ErrorLog on Table ErrorLog

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1947870006
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_i_AUDIT_ErrorLog depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
ErrorLog | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_i_AUDIT_ErrorLog]
ON [dbo].[ErrorLog]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [dbo].[ErrorLog]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[ErrorLog]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'ErrorLog',
        'dbo',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorLogID',
        CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorLogID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorTime',
        CONVERT(nvarchar(4000), NEW.[ErrorTime], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorTime] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'UserName',
        CONVERT(nvarchar(4000), NEW.[UserName], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[UserName] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorNumber',
        CONVERT(nvarchar(4000), NEW.[ErrorNumber], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorNumber] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorSeverity',
        CONVERT(nvarchar(4000), NEW.[ErrorSeverity], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorSeverity] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorState',
        CONVERT(nvarchar(4000), NEW.[ErrorState], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorState] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorProcedure',
        CONVERT(nvarchar(4000), NEW.[ErrorProcedure], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorProcedure] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorLine',
        CONVERT(nvarchar(4000), NEW.[ErrorLine], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorLine] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[ErrorLogID]='+CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0), '[ErrorLogID] Is Null')),
        'ErrorMessage',
        CONVERT(nvarchar(4000), NEW.[ErrorMessage], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ErrorLogID], 0))
    FROM inserted NEW
    WHERE NEW.[ErrorMessage] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_i_AUDIT_ErrorLog]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

ErrorLog


tr_u_AUDIT_AWBuildVersion

Trigger: AdventureWorks2016CTP3.dbo.tr_u_AUDIT_AWBuildVersion on Table AWBuildVersion

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1867869721
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_u_AUDIT_AWBuildVersion depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
AWBuildVersion | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_u_AUDIT_AWBuildVersion]
ON [dbo].[AWBuildVersion]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [dbo].[AWBuildVersion]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:23 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[AWBuildVersion]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'AWBuildVersion',
        'dbo',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([SystemInformationID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), IsNull(OLD.[SystemInformationID], NEW.[SystemInformationID]), 0), '[SystemInformationID] Is Null')),
            'SystemInformationID',
            CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0),
            CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)=CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0) or (NEW.[SystemInformationID] Is Null and OLD.[SystemInformationID] Is Null))
            WHERE (

                (
                    NEW.[SystemInformationID] <>
                    OLD.[SystemInformationID]
                ) Or

                (
                    NEW.[SystemInformationID] Is Null And
                    OLD.[SystemInformationID] Is Not Null
                ) Or
                (
                    NEW.[SystemInformationID] Is Not Null And
                    OLD.[SystemInformationID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Database Version])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), IsNull(OLD.[SystemInformationID], NEW.[SystemInformationID]), 0), '[SystemInformationID] Is Null')),
            'Database Version',
            CONVERT(nvarchar(4000), OLD.[Database Version], 0),
            CONVERT(nvarchar(4000), NEW.[Database Version], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)=CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0) or (NEW.[SystemInformationID] Is Null and OLD.[SystemInformationID] Is Null))
            where (

                (
                    NEW.[Database Version] <>
                    OLD.[Database Version]
                ) Or

                (
                    NEW.[Database Version] Is Null And
                    OLD.[Database Version] Is Not Null
                ) Or
                (
                    NEW.[Database Version] Is Not Null And
                    OLD.[Database Version] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([VersionDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), IsNull(OLD.[SystemInformationID], NEW.[SystemInformationID]), 0), '[SystemInformationID] Is Null')),
            'VersionDate',
            CONVERT(nvarchar(4000), OLD.[VersionDate], 121),
            CONVERT(nvarchar(4000), NEW.[VersionDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)=CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0) or (NEW.[SystemInformationID] Is Null and OLD.[SystemInformationID] Is Null))
            where (

                (
                    NEW.[VersionDate] <>
                    OLD.[VersionDate]
                ) Or

                (
                    NEW.[VersionDate] Is Null And
                    OLD.[VersionDate] Is Not Null
                ) Or
                (
                    NEW.[VersionDate] Is Not Null And
                    OLD.[VersionDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ModifiedDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[SystemInformationID]='+CONVERT(nvarchar(4000), IsNull(OLD.[SystemInformationID], NEW.[SystemInformationID]), 0), '[SystemInformationID] Is Null')),
            'ModifiedDate',
            CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
            CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[SystemInformationID], 0)=CONVERT(nvarchar(4000), OLD.[SystemInformationID], 0) or (NEW.[SystemInformationID] Is Null and OLD.[SystemInformationID] Is Null))
            where (

                (
                    NEW.[ModifiedDate] <>
                    OLD.[ModifiedDate]
                ) Or

                (
                    NEW.[ModifiedDate] Is Null And
                    OLD.[ModifiedDate] Is Not Null
                ) Or
                (
                    NEW.[ModifiedDate] Is Not Null And
                    OLD.[ModifiedDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_u_AUDIT_AWBuildVersion]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

AWBuildVersion


tr_u_AUDIT_DatabaseLog

Trigger: AdventureWorks2016CTP3.dbo.tr_u_AUDIT_DatabaseLog on Table DatabaseLog

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1915869892
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that tr_u_AUDIT_DatabaseLog depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
DatabaseLog | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [dbo].[tr_u_AUDIT_DatabaseLog]
ON [dbo].[DatabaseLog]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [dbo].[DatabaseLog]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:23 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[dbo].[DatabaseLog]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'DatabaseLog',
        'dbo',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([DatabaseLogID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'DatabaseLogID',
            CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0),
            CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            WHERE (

                (
                    NEW.[DatabaseLogID] <>
                    OLD.[DatabaseLogID]
                ) Or

                (
                    NEW.[DatabaseLogID] Is Null And
                    OLD.[DatabaseLogID] Is Not Null
                ) Or
                (
                    NEW.[DatabaseLogID] Is Not Null And
                    OLD.[DatabaseLogID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([PostTime])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'PostTime',
            CONVERT(nvarchar(4000), OLD.[PostTime], 121),
            CONVERT(nvarchar(4000), NEW.[PostTime], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[PostTime] <>
                    OLD.[PostTime]
                ) Or

                (
                    NEW.[PostTime] Is Null And
                    OLD.[PostTime] Is Not Null
                ) Or
                (
                    NEW.[PostTime] Is Not Null And
                    OLD.[PostTime] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([DatabaseUser])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'DatabaseUser',
            CONVERT(nvarchar(4000), OLD.[DatabaseUser], 0),
            CONVERT(nvarchar(4000), NEW.[DatabaseUser], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[DatabaseUser] <>
                    OLD.[DatabaseUser]
                ) Or

                (
                    NEW.[DatabaseUser] Is Null And
                    OLD.[DatabaseUser] Is Not Null
                ) Or
                (
                    NEW.[DatabaseUser] Is Not Null And
                    OLD.[DatabaseUser] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Event])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'Event',
            CONVERT(nvarchar(4000), OLD.[Event], 0),
            CONVERT(nvarchar(4000), NEW.[Event], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[Event] <>
                    OLD.[Event]
                ) Or

                (
                    NEW.[Event] Is Null And
                    OLD.[Event] Is Not Null
                ) Or
                (
                    NEW.[Event] Is Not Null And
                    OLD.[Event] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Schema])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'Schema',
            CONVERT(nvarchar(4000), OLD.[Schema], 0),
            CONVERT(nvarchar(4000), NEW.[Schema], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[Schema] <>
                    OLD.[Schema]
                ) Or

                (
                    NEW.[Schema] Is Null And
                    OLD.[Schema] Is Not Null
                ) Or
                (
                    NEW.[Schema] Is Not Null And
                    OLD.[Schema] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Object])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'Object',
            CONVERT(nvarchar(4000), OLD.[Object], 0),
            CONVERT(nvarchar(4000), NEW.[Object], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[Object] <>
                    OLD.[Object]
                ) Or

                (
                    NEW.[Object] Is Null And
                    OLD.[Object] Is Not Null
                ) Or
                (
                    NEW.[Object] Is Not Null And
                    OLD.[Object] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([TSQL])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'TSQL',
            CONVERT(nvarchar(4000), OLD.[TSQL], 0),
            CONVERT(nvarchar(4000), NEW.[TSQL], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    NEW.[TSQL] <>
                    OLD.[TSQL]
                ) Or

                (
                    NEW.[TSQL] Is Null And
                    OLD.[TSQL] Is Not Null
                ) Or
                (
                    NEW.[TSQL] Is Not Null And
                    OLD.[TSQL] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([XmlEvent])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DatabaseLogID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DatabaseLogID], NEW.[DatabaseLogID]), 0), '[DatabaseLogID] Is Null')),
            'XmlEvent',
            CONVERT(nvarchar(max), CONVERT(nvarchar(max), OLD.[XmlEvent])),
            CONVERT(nvarchar(max), CONVERT(nvarchar(max), NEW.[XmlEvent])),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DatabaseLogID], 0)=CONVERT(nvarchar(4000), OLD.[DatabaseLogID], 0) or (NEW.[DatabaseLogID] Is Null and OLD.[DatabaseLogID] Is Null))
            where (

                (
                    CONVERT(nvarchar(max), NEW.[XmlEvent]) <>
                    CONVERT(nvarchar(max), OLD.[XmlEvent])
                ) Or

                (
                    NEW.[XmlEvent] Is Null And
                    OLD.[XmlEvent] Is Not Null
                ) Or
                (
                    NEW.[XmlEvent] Is Not Null And
                    OLD.[XmlEvent] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[dbo].[tr_u_AUDIT_DatabaseLog]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

DatabaseLog


dEmployee

Trigger: AdventureWorks2016CTP3.HumanResources.dEmployee on Table Employee

CollapseAll image

Collapse image Description

INSTEAD OF DELETE trigger which keeps Employees from being deleted.

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 861246123
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.dEmployee depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Employee | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | INSTEAD OF DELETE trigger which keeps Employees from being deleted.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [HumanResources].[dEmployee] ON [HumanResources].[Employee]
INSTEAD OF DELETE NOT FOR REPLICATION AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN
        RAISERROR
            (N'Employees cannot be deleted. They can only be marked as not current.', -- Message
            10, -- Severity.
            1); -- State.

        -- Rollback any active or uncommittable transactions
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END
    END;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'INSTEAD OF DELETE trigger which keeps Employees from being deleted.', 'SCHEMA', N'HumanResources', 'TABLE', N'Employee', 'TRIGGER', N'dEmployee'
GO

Collapse image See also

List of triggers

HumanResources.Employee


tr_d_AUDIT_Department

Trigger: AdventureWorks2016CTP3.HumanResources.tr_d_AUDIT_Department on Table Department

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2011870234
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_d_AUDIT_Department depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Department | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_d_AUDIT_Department]
ON [HumanResources].[Department]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [HumanResources].[Department]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Department]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Department',
        'HumanResources',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'DepartmentID',
        CONVERT(nvarchar(4000), OLD.[DepartmentID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0))
    FROM deleted OLD
    WHERE
        OLD.[DepartmentID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'Name',
        CONVERT(nvarchar(4000), OLD.[Name], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Name] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'GroupName',
        CONVERT(nvarchar(4000), OLD.[GroupName], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0))
    FROM deleted OLD
    WHERE
        OLD.[GroupName] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_d_AUDIT_Department]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

HumanResources.Department


tr_d_AUDIT_Employee

Trigger: AdventureWorks2016CTP3.HumanResources.tr_d_AUDIT_Employee on Table Employee

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2043870348
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_d_AUDIT_Employee depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Employee | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_d_AUDIT_Employee]
ON [HumanResources].[Employee]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [HumanResources].[Employee]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Employee]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Employee',
        'HumanResources',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[BusinessEntityID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'NationalIDNumber',
        CONVERT(nvarchar(4000), OLD.[NationalIDNumber], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[NationalIDNumber] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'LoginID',
        CONVERT(nvarchar(4000), OLD.[LoginID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[LoginID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'OrganizationNode',
        CONVERT(nvarchar(max), CONVERT(nvarchar(max), OLD.[OrganizationNode])),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[OrganizationNode] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'JobTitle',
        CONVERT(nvarchar(4000), OLD.[JobTitle], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[JobTitle] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'BirthDate',
        CONVERT(nvarchar(4000), OLD.[BirthDate], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[BirthDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'MaritalStatus',
        CONVERT(nvarchar(4000), OLD.[MaritalStatus], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[MaritalStatus] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'Gender',
        CONVERT(nvarchar(4000), OLD.[Gender], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[Gender] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'HireDate',
        CONVERT(nvarchar(4000), OLD.[HireDate], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[HireDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'SalariedFlag',
        CONVERT(nvarchar(4000), OLD.[SalariedFlag], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[SalariedFlag] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'VacationHours',
        CONVERT(nvarchar(4000), OLD.[VacationHours], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[VacationHours] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'SickLeaveHours',
        CONVERT(nvarchar(4000), OLD.[SickLeaveHours], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[SickLeaveHours] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'CurrentFlag',
        CONVERT(nvarchar(4000), OLD.[CurrentFlag], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[CurrentFlag] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'rowguid',
        CONVERT(nvarchar(4000), OLD.[rowguid], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[rowguid] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0))
    FROM deleted OLD
    WHERE
        OLD.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_d_AUDIT_Employee]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

HumanResources.Employee


tr_d_AUDIT_EmployeeDepartmentHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory on Table EmployeeDepartmentHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2107870576
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_d_AUDIT_EmployeeDepartmentHistory]
ON [HumanResources].[EmployeeDepartmentHistory]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [HumanResources].[EmployeeDepartmentHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeeDepartmentHistory]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeeDepartmentHistory',
        'HumanResources',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[BusinessEntityID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'DepartmentID',
        CONVERT(nvarchar(4000), OLD.[DepartmentID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[DepartmentID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'ShiftID',
        CONVERT(nvarchar(4000), OLD.[ShiftID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[ShiftID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'StartDate',
        CONVERT(nvarchar(4000), OLD.[StartDate], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[StartDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'EndDate',
        CONVERT(nvarchar(4000), OLD.[EndDate], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[EndDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), OLD.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), OLD.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0))
    FROM deleted OLD
    WHERE
        OLD.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_d_AUDIT_EmployeeDepartmentHistory]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

HumanResources.EmployeeDepartmentHistory


tr_d_AUDIT_EmployeePayHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_d_AUDIT_EmployeePayHistory on Table EmployeePayHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 8387099
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_d_AUDIT_EmployeePayHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeePayHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_d_AUDIT_EmployeePayHistory]
ON [HumanResources].[EmployeePayHistory]
FOR DELETE

    NOT FOR REPLICATION

AS
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  DELETE TRIGGER for Table:  [HumanResources].[EmployeePayHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeePayHistory]'
    Select @ROWS_COUNT=count(*) from deleted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeePayHistory',
        'HumanResources',
        3,    --    ACTION ID For DELETE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121))
    FROM deleted OLD
    WHERE
        OLD.[BusinessEntityID] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'RateChangeDate',
        CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121))
    FROM deleted OLD
    WHERE
        OLD.[RateChangeDate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'Rate',
        CONVERT(nvarchar(4000), OLD.[Rate], 2),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121))
    FROM deleted OLD
    WHERE
        OLD.[Rate] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'PayFrequency',
        CONVERT(nvarchar(4000), OLD.[PayFrequency], 0),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121))
    FROM deleted OLD
    WHERE
        OLD.[PayFrequency] Is Not Null

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        OLD_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
        'A'
        ,  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)),  CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121))
    FROM deleted OLD
    WHERE
        OLD.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

END
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_d_AUDIT_EmployeePayHistory]', @order='Last', @stmttype='DELETE'
GO

Collapse image See also

List of triggers

HumanResources.EmployeePayHistory


tr_i_AUDIT_Department

Trigger: AdventureWorks2016CTP3.HumanResources.tr_i_AUDIT_Department on Table Department

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1979870120
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_i_AUDIT_Department depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Department | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_i_AUDIT_Department]
ON [HumanResources].[Department]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [HumanResources].[Department]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Department]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Department',
        'HumanResources',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'DepartmentID',
        CONVERT(nvarchar(4000), NEW.[DepartmentID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))
    FROM inserted NEW
    WHERE NEW.[DepartmentID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'Name',
        CONVERT(nvarchar(4000), NEW.[Name], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))
    FROM inserted NEW
    WHERE NEW.[Name] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'GroupName',
        CONVERT(nvarchar(4000), NEW.[GroupName], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))
    FROM inserted NEW
    WHERE NEW.[GroupName] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))
    FROM inserted NEW
    WHERE NEW.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_i_AUDIT_Department]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

HumanResources.Department


tr_i_AUDIT_Employee

Trigger: AdventureWorks2016CTP3.HumanResources.tr_i_AUDIT_Employee on Table Employee

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2027870291
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_i_AUDIT_Employee depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Employee | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_i_AUDIT_Employee]
ON [HumanResources].[Employee]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [HumanResources].[Employee]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Employee]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Employee',
        'HumanResources',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[BusinessEntityID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'NationalIDNumber',
        CONVERT(nvarchar(4000), NEW.[NationalIDNumber], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[NationalIDNumber] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'LoginID',
        CONVERT(nvarchar(4000), NEW.[LoginID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[LoginID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'OrganizationNode',
        CONVERT(nvarchar(max), CONVERT(nvarchar(max), NEW.[OrganizationNode])),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[OrganizationNode] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'JobTitle',
        CONVERT(nvarchar(4000), NEW.[JobTitle], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[JobTitle] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'BirthDate',
        CONVERT(nvarchar(4000), NEW.[BirthDate], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[BirthDate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'MaritalStatus',
        CONVERT(nvarchar(4000), NEW.[MaritalStatus], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[MaritalStatus] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'Gender',
        CONVERT(nvarchar(4000), NEW.[Gender], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[Gender] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'HireDate',
        CONVERT(nvarchar(4000), NEW.[HireDate], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[HireDate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'SalariedFlag',
        CONVERT(nvarchar(4000), NEW.[SalariedFlag], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[SalariedFlag] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'VacationHours',
        CONVERT(nvarchar(4000), NEW.[VacationHours], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[VacationHours] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'SickLeaveHours',
        CONVERT(nvarchar(4000), NEW.[SickLeaveHours], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[SickLeaveHours] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'CurrentFlag',
        CONVERT(nvarchar(4000), NEW.[CurrentFlag], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[CurrentFlag] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'rowguid',
        CONVERT(nvarchar(4000), NEW.[rowguid], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[rowguid] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))
    FROM inserted NEW
    WHERE NEW.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_i_AUDIT_Employee]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

HumanResources.Employee


tr_i_AUDIT_EmployeeDepartmentHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory on Table EmployeeDepartmentHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2075870462
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_i_AUDIT_EmployeeDepartmentHistory]
ON [HumanResources].[EmployeeDepartmentHistory]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [HumanResources].[EmployeeDepartmentHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeeDepartmentHistory]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeeDepartmentHistory',
        'HumanResources',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[BusinessEntityID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'DepartmentID',
        CONVERT(nvarchar(4000), NEW.[DepartmentID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[DepartmentID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'ShiftID',
        CONVERT(nvarchar(4000), NEW.[ShiftID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[ShiftID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'StartDate',
        CONVERT(nvarchar(4000), NEW.[StartDate], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[StartDate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'EndDate',
        CONVERT(nvarchar(4000), NEW.[EndDate], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[EndDate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2, KEY3, KEY4
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), NEW.[DepartmentID], 0), '[DepartmentID] Is Null') + ' AND ' + IsNull('[ShiftID]='+CONVERT(nvarchar(4000), NEW.[ShiftID], 0), '[ShiftID] Is Null') + ' AND ' + IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[StartDate], 0), '''', '''''')+'''', '[StartDate] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0))
    FROM inserted NEW
    WHERE NEW.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_i_AUDIT_EmployeeDepartmentHistory]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

HumanResources.EmployeeDepartmentHistory


tr_i_AUDIT_EmployeePayHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_i_AUDIT_EmployeePayHistory on Table EmployeePayHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2123870633
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_i_AUDIT_EmployeePayHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeePayHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_i_AUDIT_EmployeePayHistory]
ON [HumanResources].[EmployeePayHistory]
FOR INSERT

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  INSERT TRIGGER for Table:  [HumanResources].[EmployeePayHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE                varchar(50),
        @AUDIT_LOG_TRANSACTION_ID        Int,
        @PRIM_KEY                nvarchar(4000),
        --@TABLE_NAME                nvarchar(4000),
        @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeePayHistory]'
    Select @ROWS_COUNT=count(*) from inserted
    Set @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeePayHistory',
        'HumanResources',
        2,    --    ACTION ID For INSERT
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'BusinessEntityID',
        CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121))
    FROM inserted NEW
    WHERE NEW.[BusinessEntityID] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'RateChangeDate',
        CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121))
    FROM inserted NEW
    WHERE NEW.[RateChangeDate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'Rate',
        CONVERT(nvarchar(4000), NEW.[Rate], 2),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121))
    FROM inserted NEW
    WHERE NEW.[Rate] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'PayFrequency',
        CONVERT(nvarchar(4000), NEW.[PayFrequency], 0),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121))
    FROM inserted NEW
    WHERE NEW.[PayFrequency] Is Not Null

    INSERT INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
    (
        AUDIT_LOG_TRANSACTION_ID,
        PRIMARY_KEY_DATA,
        COL_NAME,
        NEW_VALUE_LONG,
        DATA_TYPE
        , KEY1, KEY2
    )
    SELECT
        @AUDIT_LOG_TRANSACTION_ID,
        convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0), '[BusinessEntityID] Is Null') + ' AND ' + IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121), '''', '''''')+'''', '[RateChangeDate] Is Null')),
        'ModifiedDate',
        CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
        'A'
        , CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121))
    FROM inserted NEW
    WHERE NEW.[ModifiedDate] Is Not Null

    -- Lookup

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_i_AUDIT_EmployeePayHistory]', @order='Last', @stmttype='INSERT'
GO

Collapse image See also

List of triggers

HumanResources.EmployeePayHistory


tr_u_AUDIT_Department

Trigger: AdventureWorks2016CTP3.HumanResources.tr_u_AUDIT_Department on Table Department

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 1995870177
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_u_AUDIT_Department depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Department | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_u_AUDIT_Department]
ON [HumanResources].[Department]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [HumanResources].[Department]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Department]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Department',
        'HumanResources',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([DepartmentID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')),
            'DepartmentID',
            CONVERT(nvarchar(4000), OLD.[DepartmentID], 0),
            CONVERT(nvarchar(4000), NEW.[DepartmentID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null))
            WHERE (

                (
                    NEW.[DepartmentID] <>
                    OLD.[DepartmentID]
                ) Or

                (
                    NEW.[DepartmentID] Is Null And
                    OLD.[DepartmentID] Is Not Null
                ) Or
                (
                    NEW.[DepartmentID] Is Not Null And
                    OLD.[DepartmentID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Name])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')),
            'Name',
            CONVERT(nvarchar(4000), OLD.[Name], 0),
            CONVERT(nvarchar(4000), NEW.[Name], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null))
            where (

                (
                    NEW.[Name] <>
                    OLD.[Name]
                ) Or

                (
                    NEW.[Name] Is Null And
                    OLD.[Name] Is Not Null
                ) Or
                (
                    NEW.[Name] Is Not Null And
                    OLD.[Name] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([GroupName])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')),
            'GroupName',
            CONVERT(nvarchar(4000), OLD.[GroupName], 0),
            CONVERT(nvarchar(4000), NEW.[GroupName], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null))
            where (

                (
                    NEW.[GroupName] <>
                    OLD.[GroupName]
                ) Or

                (
                    NEW.[GroupName] Is Null And
                    OLD.[GroupName] Is Not Null
                ) Or
                (
                    NEW.[GroupName] Is Not Null And
                    OLD.[GroupName] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ModifiedDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')),
            'ModifiedDate',
            CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
            CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null))
            where (

                (
                    NEW.[ModifiedDate] <>
                    OLD.[ModifiedDate]
                ) Or

                (
                    NEW.[ModifiedDate] Is Null And
                    OLD.[ModifiedDate] Is Not Null
                ) Or
                (
                    NEW.[ModifiedDate] Is Not Null And
                    OLD.[ModifiedDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_u_AUDIT_Department]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

HumanResources.Department


tr_u_AUDIT_Employee_Temporal

Trigger: AdventureWorks2016CTP3.HumanResources.tr_u_AUDIT_Employee_Temporal on Table Employee_Temporal

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2059870405
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_u_AUDIT_Employee_Temporal depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.Employee_Temporal | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_u_AUDIT_Employee_Temporal]
ON [HumanResources].[Employee_Temporal]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [HumanResources].[Employee_Temporal]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:23:24 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[Employee_Temporal]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'Employee_Temporal',
        'HumanResources',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([BusinessEntityID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'BusinessEntityID',
            CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
            CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            WHERE (

                (
                    NEW.[BusinessEntityID] <>
                    OLD.[BusinessEntityID]
                ) Or

                (
                    NEW.[BusinessEntityID] Is Null And
                    OLD.[BusinessEntityID] Is Not Null
                ) Or
                (
                    NEW.[BusinessEntityID] Is Not Null And
                    OLD.[BusinessEntityID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([NationalIDNumber])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'NationalIDNumber',
            CONVERT(nvarchar(4000), OLD.[NationalIDNumber], 0),
            CONVERT(nvarchar(4000), NEW.[NationalIDNumber], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[NationalIDNumber] <>
                    OLD.[NationalIDNumber]
                ) Or

                (
                    NEW.[NationalIDNumber] Is Null And
                    OLD.[NationalIDNumber] Is Not Null
                ) Or
                (
                    NEW.[NationalIDNumber] Is Not Null And
                    OLD.[NationalIDNumber] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([LoginID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'LoginID',
            CONVERT(nvarchar(4000), OLD.[LoginID], 0),
            CONVERT(nvarchar(4000), NEW.[LoginID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[LoginID] <>
                    OLD.[LoginID]
                ) Or

                (
                    NEW.[LoginID] Is Null And
                    OLD.[LoginID] Is Not Null
                ) Or
                (
                    NEW.[LoginID] Is Not Null And
                    OLD.[LoginID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([OrganizationNode])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'OrganizationNode',
            CONVERT(nvarchar(max), CONVERT(nvarchar(max), OLD.[OrganizationNode])),
            CONVERT(nvarchar(max), CONVERT(nvarchar(max), NEW.[OrganizationNode])),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    CONVERT(nvarchar(max), NEW.[OrganizationNode]) <>
                    CONVERT(nvarchar(max), OLD.[OrganizationNode])
                ) Or

                (
                    NEW.[OrganizationNode] Is Null And
                    OLD.[OrganizationNode] Is Not Null
                ) Or
                (
                    NEW.[OrganizationNode] Is Not Null And
                    OLD.[OrganizationNode] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([JobTitle])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'JobTitle',
            CONVERT(nvarchar(4000), OLD.[JobTitle], 0),
            CONVERT(nvarchar(4000), NEW.[JobTitle], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[JobTitle] <>
                    OLD.[JobTitle]
                ) Or

                (
                    NEW.[JobTitle] Is Null And
                    OLD.[JobTitle] Is Not Null
                ) Or
                (
                    NEW.[JobTitle] Is Not Null And
                    OLD.[JobTitle] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([BirthDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'BirthDate',
            CONVERT(nvarchar(4000), OLD.[BirthDate], 0),
            CONVERT(nvarchar(4000), NEW.[BirthDate], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[BirthDate] <>
                    OLD.[BirthDate]
                ) Or

                (
                    NEW.[BirthDate] Is Null And
                    OLD.[BirthDate] Is Not Null
                ) Or
                (
                    NEW.[BirthDate] Is Not Null And
                    OLD.[BirthDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([MaritalStatus])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'MaritalStatus',
            CONVERT(nvarchar(4000), OLD.[MaritalStatus], 0),
            CONVERT(nvarchar(4000), NEW.[MaritalStatus], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[MaritalStatus] <>
                    OLD.[MaritalStatus]
                ) Or

                (
                    NEW.[MaritalStatus] Is Null And
                    OLD.[MaritalStatus] Is Not Null
                ) Or
                (
                    NEW.[MaritalStatus] Is Not Null And
                    OLD.[MaritalStatus] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Gender])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'Gender',
            CONVERT(nvarchar(4000), OLD.[Gender], 0),
            CONVERT(nvarchar(4000), NEW.[Gender], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[Gender] <>
                    OLD.[Gender]
                ) Or

                (
                    NEW.[Gender] Is Null And
                    OLD.[Gender] Is Not Null
                ) Or
                (
                    NEW.[Gender] Is Not Null And
                    OLD.[Gender] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([HireDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'HireDate',
            CONVERT(nvarchar(4000), OLD.[HireDate], 0),
            CONVERT(nvarchar(4000), NEW.[HireDate], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[HireDate] <>
                    OLD.[HireDate]
                ) Or

                (
                    NEW.[HireDate] Is Null And
                    OLD.[HireDate] Is Not Null
                ) Or
                (
                    NEW.[HireDate] Is Not Null And
                    OLD.[HireDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([VacationHours])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'VacationHours',
            CONVERT(nvarchar(4000), OLD.[VacationHours], 0),
            CONVERT(nvarchar(4000), NEW.[VacationHours], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[VacationHours] <>
                    OLD.[VacationHours]
                ) Or

                (
                    NEW.[VacationHours] Is Null And
                    OLD.[VacationHours] Is Not Null
                ) Or
                (
                    NEW.[VacationHours] Is Not Null And
                    OLD.[VacationHours] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([SickLeaveHours])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'SickLeaveHours',
            CONVERT(nvarchar(4000), OLD.[SickLeaveHours], 0),
            CONVERT(nvarchar(4000), NEW.[SickLeaveHours], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[SickLeaveHours] <>
                    OLD.[SickLeaveHours]
                ) Or

                (
                    NEW.[SickLeaveHours] Is Null And
                    OLD.[SickLeaveHours] Is Not Null
                ) Or
                (
                    NEW.[SickLeaveHours] Is Not Null And
                    OLD.[SickLeaveHours] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ValidFrom])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'ValidFrom',
            CONVERT(nvarchar(4000), OLD.[ValidFrom], 121),
            CONVERT(nvarchar(4000), NEW.[ValidFrom], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[ValidFrom] <>
                    OLD.[ValidFrom]
                ) Or

                (
                    NEW.[ValidFrom] Is Null And
                    OLD.[ValidFrom] Is Not Null
                ) Or
                (
                    NEW.[ValidFrom] Is Not Null And
                    OLD.[ValidFrom] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ValidTo])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')),
            'ValidTo',
            CONVERT(nvarchar(4000), OLD.[ValidTo], 121),
            CONVERT(nvarchar(4000), NEW.[ValidTo], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null))
            where (

                (
                    NEW.[ValidTo] <>
                    OLD.[ValidTo]
                ) Or

                (
                    NEW.[ValidTo] Is Null And
                    OLD.[ValidTo] Is Not Null
                ) Or
                (
                    NEW.[ValidTo] Is Not Null And
                    OLD.[ValidTo] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_u_AUDIT_Employee_Temporal]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

HumanResources.Employee_Temporal


tr_u_AUDIT_EmployeeDepartmentHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory on Table EmployeeDepartmentHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2091870519
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_u_AUDIT_EmployeeDepartmentHistory]
ON [HumanResources].[EmployeeDepartmentHistory]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [HumanResources].[EmployeeDepartmentHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeeDepartmentHistory]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeeDepartmentHistory',
        'HumanResources',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([BusinessEntityID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'BusinessEntityID',
            CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
            CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            WHERE (

                (
                    NEW.[BusinessEntityID] <>
                    OLD.[BusinessEntityID]
                ) Or

                (
                    NEW.[BusinessEntityID] Is Null And
                    OLD.[BusinessEntityID] Is Not Null
                ) Or
                (
                    NEW.[BusinessEntityID] Is Not Null And
                    OLD.[BusinessEntityID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([DepartmentID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'DepartmentID',
            CONVERT(nvarchar(4000), OLD.[DepartmentID], 0),
            CONVERT(nvarchar(4000), NEW.[DepartmentID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            WHERE (

                (
                    NEW.[DepartmentID] <>
                    OLD.[DepartmentID]
                ) Or

                (
                    NEW.[DepartmentID] Is Null And
                    OLD.[DepartmentID] Is Not Null
                ) Or
                (
                    NEW.[DepartmentID] Is Not Null And
                    OLD.[DepartmentID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ShiftID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'ShiftID',
            CONVERT(nvarchar(4000), OLD.[ShiftID], 0),
            CONVERT(nvarchar(4000), NEW.[ShiftID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            WHERE (

                (
                    NEW.[ShiftID] <>
                    OLD.[ShiftID]
                ) Or

                (
                    NEW.[ShiftID] Is Null And
                    OLD.[ShiftID] Is Not Null
                ) Or
                (
                    NEW.[ShiftID] Is Not Null And
                    OLD.[ShiftID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([StartDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'StartDate',
            CONVERT(nvarchar(4000), OLD.[StartDate], 0),
            CONVERT(nvarchar(4000), NEW.[StartDate], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            WHERE (

                (
                    NEW.[StartDate] <>
                    OLD.[StartDate]
                ) Or

                (
                    NEW.[StartDate] Is Null And
                    OLD.[StartDate] Is Not Null
                ) Or
                (
                    NEW.[StartDate] Is Not Null And
                    OLD.[StartDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([EndDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'EndDate',
            CONVERT(nvarchar(4000), OLD.[EndDate], 0),
            CONVERT(nvarchar(4000), NEW.[EndDate], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            where (

                (
                    NEW.[EndDate] <>
                    OLD.[EndDate]
                ) Or

                (
                    NEW.[EndDate] Is Null And
                    OLD.[EndDate] Is Not Null
                ) Or
                (
                    NEW.[EndDate] Is Not Null And
                    OLD.[EndDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ModifiedDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2, KEY3, KEY4
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[DepartmentID]='+CONVERT(nvarchar(4000), IsNull(OLD.[DepartmentID], NEW.[DepartmentID]), 0), '[DepartmentID] Is Null')+' AND '+IsNull('[ShiftID]='+CONVERT(nvarchar(4000), IsNull(OLD.[ShiftID], NEW.[ShiftID]), 0), '[ShiftID] Is Null')+' AND '+IsNull('[StartDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[StartDate], NEW.[StartDate]), 0),'''' ,'''''')+'''', '[StartDate] Is Null')),
            'ModifiedDate',
            CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
            CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[DepartmentID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[DepartmentID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[ShiftID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[ShiftID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[StartDate], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[StartDate], 0)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[DepartmentID], 0)=CONVERT(nvarchar(4000), OLD.[DepartmentID], 0) or (NEW.[DepartmentID] Is Null and OLD.[DepartmentID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[ShiftID], 0)=CONVERT(nvarchar(4000), OLD.[ShiftID], 0) or (NEW.[ShiftID] Is Null and OLD.[ShiftID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[StartDate], 0)=CONVERT(nvarchar(4000), OLD.[StartDate], 0) or (NEW.[StartDate] Is Null and OLD.[StartDate] Is Null))
            where (

                (
                    NEW.[ModifiedDate] <>
                    OLD.[ModifiedDate]
                ) Or

                (
                    NEW.[ModifiedDate] Is Null And
                    OLD.[ModifiedDate] Is Not Null
                ) Or
                (
                    NEW.[ModifiedDate] Is Not Null And
                    OLD.[ModifiedDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_u_AUDIT_EmployeeDepartmentHistory]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

HumanResources.EmployeeDepartmentHistory


tr_u_AUDIT_EmployeePayHistory

Trigger: AdventureWorks2016CTP3.HumanResources.tr_u_AUDIT_EmployeePayHistory on Table EmployeePayHistory

CollapseAll image

Collapse image Trigger properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 21.09.2016
Encrypted |
Disabled |
ID | 2139870690
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that HumanResources.tr_u_AUDIT_EmployeePayHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
HumanResources.EmployeePayHistory | Table | 1
Total 4 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE TRIGGER [HumanResources].[tr_u_AUDIT_EmployeePayHistory]
ON [HumanResources].[EmployeePayHistory]
FOR UPDATE

    NOT FOR REPLICATION

As
-- "<TAG>SQLAUDIT GENERATED - DO NOT REMOVE</TAG>"
-- --------------------------------------------------------------------------------------------------------------
-- Legal:        You may freely edit and modify this template and make copies of it.
-- Description:  UPDATE TRIGGER for Table:  [HumanResources].[EmployeePayHistory]
-- Author:       ApexSQL Software
-- Date:         9/21/2016 1:25:02 AM
-- --------------------------------------------------------------------------------------------------------------
BEGIN
    DECLARE
        @IDENTITY_SAVE            varchar(50),
        @AUDIT_LOG_TRANSACTION_ID    Int,
        @PRIM_KEY            nvarchar(4000),
        @Inserted                bit,
        --@TABLE_NAME                nvarchar(4000),
         @ROWS_COUNT                int

    SET NOCOUNT ON

    --Set @TABLE_NAME = '[HumanResources].[EmployeePayHistory]'
    Select @ROWS_COUNT=count(*) from inserted
    SET @IDENTITY_SAVE = CAST(IsNull(@@IDENTITY,1) AS varchar(50))

    INSERT
    INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS
    (
        TABLE_NAME,
        TABLE_SCHEMA,
        AUDIT_ACTION_ID,
        HOST_NAME,
        APP_NAME,
        MODIFIED_BY,
        MODIFIED_DATE,
        AFFECTED_ROWS,
        [DATABASE]
    )
    values(
        'EmployeePayHistory',
        'HumanResources',
        1,    --    ACTION ID For UPDATE
        CASE
          WHEN LEN(HOST_NAME()) < 1 THEN ' '
          ELSE HOST_NAME()
        END,
        CASE
          WHEN LEN(APP_NAME()) < 1 THEN ' '
          ELSE APP_NAME()
        END,
        SUSER_SNAME(),
        GETDATE(),
        @ROWS_COUNT,
        'AdventureWorks2016CTP3'
    )

    Set @AUDIT_LOG_TRANSACTION_ID = SCOPE_IDENTITY()

    SET @Inserted = 0

    If UPDATE([BusinessEntityID])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[RateChangeDate], NEW.[RateChangeDate]), 121),'''' ,'''''')+'''', '[RateChangeDate] Is Null')),
            'BusinessEntityID',
            CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0),
            CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)=CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121) or (NEW.[RateChangeDate] Is Null and OLD.[RateChangeDate] Is Null))
            WHERE (

                (
                    NEW.[BusinessEntityID] <>
                    OLD.[BusinessEntityID]
                ) Or

                (
                    NEW.[BusinessEntityID] Is Null And
                    OLD.[BusinessEntityID] Is Not Null
                ) Or
                (
                    NEW.[BusinessEntityID] Is Not Null And
                    OLD.[BusinessEntityID] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([RateChangeDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[RateChangeDate], NEW.[RateChangeDate]), 121),'''' ,'''''')+'''', '[RateChangeDate] Is Null')),
            'RateChangeDate',
            CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121),
            CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)))

        FROM deleted OLD Full Outer Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)=CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121) or (NEW.[RateChangeDate] Is Null and OLD.[RateChangeDate] Is Null))
            WHERE (

                (
                    NEW.[RateChangeDate] <>
                    OLD.[RateChangeDate]
                ) Or

                (
                    NEW.[RateChangeDate] Is Null And
                    OLD.[RateChangeDate] Is Not Null
                ) Or
                (
                    NEW.[RateChangeDate] Is Not Null And
                    OLD.[RateChangeDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([Rate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[RateChangeDate], NEW.[RateChangeDate]), 121),'''' ,'''''')+'''', '[RateChangeDate] Is Null')),
            'Rate',
            CONVERT(nvarchar(4000), OLD.[Rate], 2),
            CONVERT(nvarchar(4000), NEW.[Rate], 2),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)=CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121) or (NEW.[RateChangeDate] Is Null and OLD.[RateChangeDate] Is Null))
            where (

                (
                    NEW.[Rate] <>
                    OLD.[Rate]
                ) Or

                (
                    NEW.[Rate] Is Null And
                    OLD.[Rate] Is Not Null
                ) Or
                (
                    NEW.[Rate] Is Not Null And
                    OLD.[Rate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([PayFrequency])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[RateChangeDate], NEW.[RateChangeDate]), 121),'''' ,'''''')+'''', '[RateChangeDate] Is Null')),
            'PayFrequency',
            CONVERT(nvarchar(4000), OLD.[PayFrequency], 0),
            CONVERT(nvarchar(4000), NEW.[PayFrequency], 0),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)=CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121) or (NEW.[RateChangeDate] Is Null and OLD.[RateChangeDate] Is Null))
            where (

                (
                    NEW.[PayFrequency] <>
                    OLD.[PayFrequency]
                ) Or

                (
                    NEW.[PayFrequency] Is Null And
                    OLD.[PayFrequency] Is Not Null
                ) Or
                (
                    NEW.[PayFrequency] Is Not Null And
                    OLD.[PayFrequency] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    If UPDATE([ModifiedDate])
    BEGIN

        INSERT
        INTO [AdventureWorks2016CTP3].dbo.AUDIT_LOG_DATA
        (
            AUDIT_LOG_TRANSACTION_ID,
            PRIMARY_KEY_DATA,
            COL_NAME,
            OLD_VALUE_LONG,
            NEW_VALUE_LONG,
            DATA_TYPE
            , KEY1, KEY2
        )
        SELECT
            @AUDIT_LOG_TRANSACTION_ID,
            convert(nvarchar(1500), IsNull('[BusinessEntityID]='+CONVERT(nvarchar(4000), IsNull(OLD.[BusinessEntityID], NEW.[BusinessEntityID]), 0), '[BusinessEntityID] Is Null')+' AND '+IsNull('[RateChangeDate]=N'''+replace(CONVERT(nvarchar(4000), IsNull(OLD.[RateChangeDate], NEW.[RateChangeDate]), 121),'''' ,'''''')+'''', '[RateChangeDate] Is Null')),
            'ModifiedDate',
            CONVERT(nvarchar(4000), OLD.[ModifiedDate], 121),
            CONVERT(nvarchar(4000), NEW.[ModifiedDate], 121),
            'A'
            , IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0))), IsNULL( CONVERT(nvarchar(500), CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121)), CONVERT(nvarchar(500), CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)))

        FROM deleted OLD Inner Join inserted NEW On
            (CONVERT(nvarchar(4000), NEW.[BusinessEntityID], 0)=CONVERT(nvarchar(4000), OLD.[BusinessEntityID], 0) or (NEW.[BusinessEntityID] Is Null and OLD.[BusinessEntityID] Is Null)) AND (CONVERT(nvarchar(4000), NEW.[RateChangeDate], 121)=CONVERT(nvarchar(4000), OLD.[RateChangeDate], 121) or (NEW.[RateChangeDate] Is Null and OLD.[RateChangeDate] Is Null))
            where (

                (
                    NEW.[ModifiedDate] <>
                    OLD.[ModifiedDate]
                ) Or

                (
                    NEW.[ModifiedDate] Is Null And
                    OLD.[ModifiedDate] Is Not Null
                ) Or
                (
                    NEW.[ModifiedDate] Is Not Null And
                    OLD.[ModifiedDate] Is Null
                )
                )

        SET @Inserted = CASE WHEN @@ROWCOUNT > 0 Then 1 Else @Inserted End
    END

    -- Watch

    -- Lookup

    IF @Inserted = 0
    BEGIN
        DELETE FROM [AdventureWorks2016CTP3].dbo.AUDIT_LOG_TRANSACTIONS WHERE AUDIT_LOG_TRANSACTION_ID = @AUDIT_LOG_TRANSACTION_ID
    END

  -- Restore @@IDENTITY Value

    DECLARE @maxprec AS varchar(2)
    SET @maxprec=CAST(@@MAX_PRECISION as varchar(2))
    EXEC('SELECT IDENTITY(decimal('+@maxprec+',0),'+@IDENTITY_SAVE+',1) id INTO #tmp')

End
GO
EXEC sp_settriggerorder @triggername= '[HumanResources].[tr_u_AUDIT_EmployeePayHistory]', @order='Last', @stmttype='UPDATE'
GO

Collapse image See also

List of triggers

HumanResources.EmployeePayHistory


iuPerson

Trigger: AdventureWorks2016CTP3.Person.iuPerson on Table Person

CollapseAll image

Collapse image Description

AFTER INSERT, UPDATE trigger inserting Individual only if the Customer does not exist in the Store table and setting the ModifiedDate column in the Person table to the current date.

Collapse image Trigger properties

Name | Value
Schema | Person
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 877246180
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Person.iuPerson depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER INSERT, UPDATE trigger inserting Individual only if the Customer does not exist in the Store table and setting the ModifiedDate column in the Person table to the current date.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Person].[iuPerson] ON [Person].[Person]
AFTER INSERT, UPDATE NOT FOR REPLICATION AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    IF UPDATE([BusinessEntityID]) OR UPDATE([Demographics])
    BEGIN
        UPDATE [Person].[Person]
        SET [Person].[Person].[Demographics] = N'<IndividualSurvey xmlns="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey">
            <TotalPurchaseYTD>0.00</TotalPurchaseYTD>
            </IndividualSurvey>'
        FROM inserted
        WHERE [Person].[Person].[BusinessEntityID] = inserted.[BusinessEntityID]
            AND inserted.[Demographics] IS NULL;

        UPDATE [Person].[Person]
        SET [Demographics].modify(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
            insert <TotalPurchaseYTD>0.00</TotalPurchaseYTD>
            as first
            into (/IndividualSurvey)[1]')
        FROM inserted
        WHERE [Person].[Person].[BusinessEntityID] = inserted.[BusinessEntityID]
            AND inserted.[Demographics] IS NOT NULL
            AND inserted.[Demographics].exist(N'declare default element namespace
                "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
                /IndividualSurvey/TotalPurchaseYTD') <> 1;
    END;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER INSERT, UPDATE trigger inserting Individual only if the Customer does not exist in the Store table and setting the ModifiedDate column in the Person table to the current date.', 'SCHEMA', N'Person', 'TABLE', N'Person', 'TRIGGER', N'iuPerson'
GO

Collapse image See also

List of triggers

Person.Person


iWorkOrder

Trigger: AdventureWorks2016CTP3.Production.iWorkOrder on Table WorkOrder

CollapseAll image

Collapse image Description

AFTER INSERT trigger that inserts a row in the TransactionHistory table.

Collapse image Trigger properties

Name | Value
Schema | Production
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 989246579
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Production.iWorkOrder depends on

Object name | Object type | Dep level
Production | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Production.TransactionHistory | Table | 1
Production.WorkOrder | Table | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER INSERT trigger that inserts a row in the TransactionHistory table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Production].[iWorkOrder] ON [Production].[WorkOrder]
AFTER INSERT AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        INSERT INTO [Production].[TransactionHistory](
            [ProductID]
            ,[ReferenceOrderID]
            ,[TransactionType]
            ,[TransactionDate]
            ,[Quantity]
            ,[ActualCost])
        SELECT
            inserted.[ProductID]
            ,inserted.[WorkOrderID]
            ,'W'
            ,GETDATE()
            ,inserted.[OrderQty]
            ,0
        FROM inserted;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER INSERT trigger that inserts a row in the TransactionHistory table.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'TRIGGER', N'iWorkOrder'
GO

Collapse image See also

List of triggers

Production.WorkOrder


uWorkOrder

Trigger: AdventureWorks2016CTP3.Production.uWorkOrder on Table WorkOrder

CollapseAll image

Collapse image Description

AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in the WorkOrder table.

Collapse image Trigger properties

Name | Value
Schema | Production
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 1005246636
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Production.uWorkOrder depends on

Object name | Object type | Dep level
Production | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Production.TransactionHistory | Table | 1
Production.WorkOrder | Table | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in the WorkOrder table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Production].[uWorkOrder] ON [Production].[WorkOrder]
AFTER UPDATE AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        IF UPDATE([ProductID]) OR UPDATE([OrderQty])
        BEGIN
            INSERT INTO [Production].[TransactionHistory](
                [ProductID]
                ,[ReferenceOrderID]
                ,[TransactionType]
                ,[TransactionDate]
                ,[Quantity])
            SELECT
                inserted.[ProductID]
                ,inserted.[WorkOrderID]
                ,'W'
                ,GETDATE()
                ,inserted.[OrderQty]
            FROM inserted;
        END;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in the WorkOrder table.', 'SCHEMA', N'Production', 'TABLE', N'WorkOrder', 'TRIGGER', N'uWorkOrder'
GO

Collapse image See also

List of triggers

Production.WorkOrder


dVendor

Trigger: AdventureWorks2016CTP3.Purchasing.dVendor on Table Vendor

CollapseAll image

Collapse image Description

INSTEAD OF DELETE trigger which keeps Vendors from being deleted.

Collapse image Trigger properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 973246522
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Purchasing.dVendor depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Purchasing.Vendor | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | INSTEAD OF DELETE trigger which keeps Vendors from being deleted.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Purchasing].[dVendor] ON [Purchasing].[Vendor]
INSTEAD OF DELETE NOT FOR REPLICATION AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        DECLARE @DeleteCount int;

        SELECT @DeleteCount = COUNT(*) FROM deleted;
        IF @DeleteCount > 0
        BEGIN
            RAISERROR
                (N'Vendors cannot be deleted. They can only be marked as not active.', -- Message
                10, -- Severity.
                1); -- State.

        -- Rollback any active or uncommittable transactions
            IF @@TRANCOUNT > 0
            BEGIN
                ROLLBACK TRANSACTION;
            END
        END;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'INSTEAD OF DELETE trigger which keeps Vendors from being deleted.', 'SCHEMA', N'Purchasing', 'TABLE', N'Vendor', 'TRIGGER', N'dVendor'
GO

Collapse image See also

List of triggers

Purchasing.Vendor


iPurchaseOrderDetail

Trigger: AdventureWorks2016CTP3.Purchasing.iPurchaseOrderDetail on Table PurchaseOrderDetail

CollapseAll image

Collapse image Description

AFTER INSERT trigger that inserts a row in the TransactionHistory table and updates the PurchaseOrderHeader.SubTotal column.

Collapse image Trigger properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 893246237
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Purchasing.iPurchaseOrderDetail depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Purchasing.PurchaseOrderDetail | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Production.TransactionHistory | Table | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER INSERT trigger that inserts a row in the TransactionHistory table and updates the PurchaseOrderHeader.SubTotal column.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Purchasing].[iPurchaseOrderDetail] ON [Purchasing].[PurchaseOrderDetail]
AFTER INSERT AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        INSERT INTO [Production].[TransactionHistory]
            ([ProductID]
            ,[ReferenceOrderID]
            ,[ReferenceOrderLineID]
            ,[TransactionType]
            ,[TransactionDate]
            ,[Quantity]
            ,[ActualCost])
        SELECT
            inserted.[ProductID]
            ,inserted.[PurchaseOrderID]
            ,inserted.[PurchaseOrderDetailID]
            ,'P'
            ,GETDATE()
            ,inserted.[OrderQty]
            ,inserted.[UnitPrice]
        FROM inserted
            INNER JOIN [Purchasing].[PurchaseOrderHeader]
            ON inserted.[PurchaseOrderID] = [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID];

        -- Update SubTotal in PurchaseOrderHeader record. Note that this causes the
        -- PurchaseOrderHeader trigger to fire which will update the RevisionNumber.
        UPDATE [Purchasing].[PurchaseOrderHeader]
        SET [Purchasing].[PurchaseOrderHeader].[SubTotal] =
            (SELECT SUM([Purchasing].[PurchaseOrderDetail].[LineTotal])
                FROM [Purchasing].[PurchaseOrderDetail]
                WHERE [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID] = [Purchasing].[PurchaseOrderDetail].[PurchaseOrderID])
        WHERE [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID] IN (SELECT inserted.[PurchaseOrderID] FROM inserted);
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER INSERT trigger that inserts a row in the TransactionHistory table and updates the PurchaseOrderHeader.SubTotal column.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'TRIGGER', N'iPurchaseOrderDetail'
GO

Collapse image See also

List of triggers

Purchasing.PurchaseOrderDetail


uPurchaseOrderDetail

Trigger: AdventureWorks2016CTP3.Purchasing.uPurchaseOrderDetail on Table PurchaseOrderDetail

CollapseAll image

Collapse image Description

AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in PurchaseOrderDetail and updates the PurchaseOrderHeader.SubTotal column.

Collapse image Trigger properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 909246294
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Purchasing.uPurchaseOrderDetail depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Purchasing.PurchaseOrderDetail | Table | 1
Purchasing.PurchaseOrderHeader | Table | 1
Production.TransactionHistory | Table | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in PurchaseOrderDetail and updates the PurchaseOrderHeader.SubTotal column.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Purchasing].[uPurchaseOrderDetail] ON [Purchasing].[PurchaseOrderDetail]
AFTER UPDATE AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        IF UPDATE([ProductID]) OR UPDATE([OrderQty]) OR UPDATE([UnitPrice])
        -- Insert record into TransactionHistory
        BEGIN
            INSERT INTO [Production].[TransactionHistory]
                ([ProductID]
                ,[ReferenceOrderID]
                ,[ReferenceOrderLineID]
                ,[TransactionType]
                ,[TransactionDate]
                ,[Quantity]
                ,[ActualCost])
            SELECT
                inserted.[ProductID]
                ,inserted.[PurchaseOrderID]
                ,inserted.[PurchaseOrderDetailID]
                ,'P'
                ,GETDATE()
                ,inserted.[OrderQty]
                ,inserted.[UnitPrice]
            FROM inserted
                INNER JOIN [Purchasing].[PurchaseOrderDetail]
                ON inserted.[PurchaseOrderID] = [Purchasing].[PurchaseOrderDetail].[PurchaseOrderID];

            -- Update SubTotal in PurchaseOrderHeader record. Note that this causes the
            -- PurchaseOrderHeader trigger to fire which will update the RevisionNumber.
            UPDATE [Purchasing].[PurchaseOrderHeader]
            SET [Purchasing].[PurchaseOrderHeader].[SubTotal] =
                (SELECT SUM([Purchasing].[PurchaseOrderDetail].[LineTotal])
                    FROM [Purchasing].[PurchaseOrderDetail]
                    WHERE [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID]
                        = [Purchasing].[PurchaseOrderDetail].[PurchaseOrderID])
            WHERE [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID]
                IN (SELECT inserted.[PurchaseOrderID] FROM inserted);

            UPDATE [Purchasing].[PurchaseOrderDetail]
            SET [Purchasing].[PurchaseOrderDetail].[ModifiedDate] = GETDATE()
            FROM inserted
            WHERE inserted.[PurchaseOrderID] = [Purchasing].[PurchaseOrderDetail].[PurchaseOrderID]
                AND inserted.[PurchaseOrderDetailID] = [Purchasing].[PurchaseOrderDetail].[PurchaseOrderDetailID];
        END;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in PurchaseOrderDetail and updates the PurchaseOrderHeader.SubTotal column.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderDetail', 'TRIGGER', N'uPurchaseOrderDetail'
GO

Collapse image See also

List of triggers

Purchasing.PurchaseOrderDetail


uPurchaseOrderHeader

Trigger: AdventureWorks2016CTP3.Purchasing.uPurchaseOrderHeader on Table PurchaseOrderHeader

CollapseAll image

Collapse image Description

AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the PurchaseOrderHeader table.

Collapse image Trigger properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 925246351
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Purchasing.uPurchaseOrderHeader depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Purchasing.PurchaseOrderHeader | Table | 1
Total 4 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the PurchaseOrderHeader table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Purchasing].[uPurchaseOrderHeader] ON [Purchasing].[PurchaseOrderHeader]
AFTER UPDATE AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        -- Update RevisionNumber for modification of any field EXCEPT the Status.
        IF NOT UPDATE([Status])
        BEGIN
            UPDATE [Purchasing].[PurchaseOrderHeader]
            SET [Purchasing].[PurchaseOrderHeader].[RevisionNumber] =
                [Purchasing].[PurchaseOrderHeader].[RevisionNumber] + 1
            WHERE [Purchasing].[PurchaseOrderHeader].[PurchaseOrderID] IN
                (SELECT inserted.[PurchaseOrderID] FROM inserted);
        END;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the PurchaseOrderHeader table.', 'SCHEMA', N'Purchasing', 'TABLE', N'PurchaseOrderHeader', 'TRIGGER', N'uPurchaseOrderHeader'
GO

Collapse image See also

List of triggers

Purchasing.PurchaseOrderHeader


iduSalesOrderDetail

Trigger: AdventureWorks2016CTP3.Sales.iduSalesOrderDetail on Table SalesOrderDetail

CollapseAll image

Collapse image Description

AFTER INSERT, DELETE, UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in SalesOrderDetail and updates the SalesOrderHeader.SubTotal column.

Collapse image Trigger properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 941246408
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Sales.iduSalesOrderDetail depends on

Object name | Object type | Dep level
Sales | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Sales.Customer | Table | 1
Person.Person | Table | 1
Sales.SalesOrderDetail | Table | 1
Sales.SalesOrderHeader | Table | 1
Production.TransactionHistory | Table | 1
Total 8 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER INSERT, DELETE, UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in SalesOrderDetail and updates the SalesOrderHeader.SubTotal column.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Sales].[iduSalesOrderDetail] ON [Sales].[SalesOrderDetail]
AFTER INSERT, DELETE, UPDATE AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        -- If inserting or updating these columns
        IF UPDATE([ProductID]) OR UPDATE([OrderQty]) OR UPDATE([UnitPrice]) OR UPDATE([UnitPriceDiscount])
        -- Insert record into TransactionHistory
        BEGIN
            INSERT INTO [Production].[TransactionHistory]
                ([ProductID]
                ,[ReferenceOrderID]
                ,[ReferenceOrderLineID]
                ,[TransactionType]
                ,[TransactionDate]
                ,[Quantity]
                ,[ActualCost])
            SELECT
                inserted.[ProductID]
                ,inserted.[SalesOrderID]
                ,inserted.[SalesOrderDetailID]
                ,'S'
                ,GETDATE()
                ,inserted.[OrderQty]
                ,inserted.[UnitPrice]
            FROM inserted
                INNER JOIN [Sales].[SalesOrderHeader]
                ON inserted.[SalesOrderID] = [Sales].[SalesOrderHeader].[SalesOrderID];

            UPDATE [Person].[Person]
            SET [Demographics].modify('declare default element namespace
                "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
                replace value of (/IndividualSurvey/TotalPurchaseYTD)[1]
                with data(/IndividualSurvey/TotalPurchaseYTD)[1] + sql:column ("inserted.LineTotal")')
            FROM inserted
                INNER JOIN [Sales].[SalesOrderHeader] AS SOH
                ON inserted.[SalesOrderID] = SOH.[SalesOrderID]
                INNER JOIN [Sales].[Customer] AS C
                ON SOH.[CustomerID] = C.[CustomerID]
            WHERE C.[PersonID] = [Person].[Person].[BusinessEntityID];
        END;

        -- Update SubTotal in SalesOrderHeader record. Note that this causes the
        -- SalesOrderHeader trigger to fire which will update the RevisionNumber.
        UPDATE [Sales].[SalesOrderHeader]
        SET [Sales].[SalesOrderHeader].[SubTotal] =
            (SELECT SUM([Sales].[SalesOrderDetail].[LineTotal])
                FROM [Sales].[SalesOrderDetail]
                WHERE [Sales].[SalesOrderHeader].[SalesOrderID] = [Sales].[SalesOrderDetail].[SalesOrderID])
        WHERE [Sales].[SalesOrderHeader].[SalesOrderID] IN (SELECT inserted.[SalesOrderID] FROM inserted);

        UPDATE [Person].[Person]
        SET [Demographics].modify('declare default element namespace
            "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
            replace value of (/IndividualSurvey/TotalPurchaseYTD)[1]
            with data(/IndividualSurvey/TotalPurchaseYTD)[1] - sql:column("deleted.LineTotal")')
        FROM deleted
            INNER JOIN [Sales].[SalesOrderHeader]
            ON deleted.[SalesOrderID] = [Sales].[SalesOrderHeader].[SalesOrderID]
            INNER JOIN [Sales].[Customer]
            ON [Sales].[Customer].[CustomerID] = [Sales].[SalesOrderHeader].[CustomerID]
        WHERE [Sales].[Customer].[PersonID] = [Person].[Person].[BusinessEntityID];
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER INSERT, DELETE, UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in SalesOrderDetail and updates the SalesOrderHeader.SubTotal column.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderDetail', 'TRIGGER', N'iduSalesOrderDetail'
GO

Collapse image See also

List of triggers

Sales.SalesOrderDetail


uSalesOrderHeader

Trigger: AdventureWorks2016CTP3.Sales.uSalesOrderHeader on Table SalesOrderHeader

CollapseAll image

Collapse image Description

AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the SalesOrderHeader table.Updates the SalesYTD column in the SalesPerson and SalesTerritory tables.

Collapse image Trigger properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Encrypted |
Disabled |
ID | 957246465
Implementation type | Transact SQL

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Type

Instead of | Insert | Update | Delete

Collapse image Objects that Sales.uSalesOrderHeader depends on

Object name | Object type | Dep level
Sales | Schema | 1
uspLogError | Procedure | 1
uspPrintError | Procedure | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritory | Table | 1
ufnGetAccountingEndDate | Function | 1
ufnGetAccountingStartDate | Function | 1
Total 8 object(s)

Collapse image Extended properties

Name | Value
MS_Description | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the SalesOrderHeader table.Updates the SalesYTD column in the SalesPerson and SalesTerritory tables.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE TRIGGER [Sales].[uSalesOrderHeader] ON [Sales].[SalesOrderHeader]
AFTER UPDATE NOT FOR REPLICATION AS
BEGIN
    DECLARE @Count int;

    SET @Count = @@ROWCOUNT;
    IF @Count = 0
        RETURN;

    SET NOCOUNT ON;

    BEGIN TRY
        -- Update RevisionNumber for modification of any field EXCEPT the Status.
        IF NOT UPDATE([Status])
        BEGIN
            UPDATE [Sales].[SalesOrderHeader]
            SET [Sales].[SalesOrderHeader].[RevisionNumber] =
                [Sales].[SalesOrderHeader].[RevisionNumber] + 1
            WHERE [Sales].[SalesOrderHeader].[SalesOrderID] IN
                (SELECT inserted.[SalesOrderID] FROM inserted);
        END;

        -- Update the SalesPerson SalesYTD when SubTotal is updated
        IF UPDATE([SubTotal])
        BEGIN
            DECLARE @StartDate datetime,
                    @EndDate datetime

            SET @StartDate = [dbo].[ufnGetAccountingStartDate]();
            SET @EndDate = [dbo].[ufnGetAccountingEndDate]();

            UPDATE [Sales].[SalesPerson]
            SET [Sales].[SalesPerson].[SalesYTD] =
                (SELECT SUM([Sales].[SalesOrderHeader].[SubTotal])
                FROM [Sales].[SalesOrderHeader]
                WHERE [Sales].[SalesPerson].[BusinessEntityID] = [Sales].[SalesOrderHeader].[SalesPersonID]
                    AND ([Sales].[SalesOrderHeader].[Status] = 5) -- Shipped
                    AND [Sales].[SalesOrderHeader].[OrderDate] BETWEEN @StartDate AND @EndDate)
            WHERE [Sales].[SalesPerson].[BusinessEntityID]
                IN (SELECT DISTINCT inserted.[SalesPersonID] FROM inserted
                    WHERE inserted.[OrderDate] BETWEEN @StartDate AND @EndDate);

            -- Update the SalesTerritory SalesYTD when SubTotal is updated
            UPDATE [Sales].[SalesTerritory]
            SET [Sales].[SalesTerritory].[SalesYTD] =
                (SELECT SUM([Sales].[SalesOrderHeader].[SubTotal])
                FROM [Sales].[SalesOrderHeader]
                WHERE [Sales].[SalesTerritory].[TerritoryID] = [Sales].[SalesOrderHeader].[TerritoryID]
                    AND ([Sales].[SalesOrderHeader].[Status] = 5) -- Shipped
                    AND [Sales].[SalesOrderHeader].[OrderDate] BETWEEN @StartDate AND @EndDate)
            WHERE [Sales].[SalesTerritory].[TerritoryID]
                IN (SELECT DISTINCT inserted.[TerritoryID] FROM inserted
                    WHERE inserted.[OrderDate] BETWEEN @StartDate AND @EndDate);
        END;
    END TRY
    BEGIN CATCH
        EXECUTE [dbo].[uspPrintError];

        -- Rollback any active or uncommittable transactions before
        -- inserting information in the ErrorLog
        IF @@TRANCOUNT > 0
        BEGIN
            ROLLBACK TRANSACTION;
        END

        EXECUTE [dbo].[uspLogError];
    END CATCH;
END;
GO
EXEC sp_addextendedproperty N'MS_Description', N'AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the SalesOrderHeader table.Updates the SalesYTD column in the SalesPerson and SalesTerritory tables.', 'SCHEMA', N'Sales', 'TABLE', N'SalesOrderHeader', 'TRIGGER', N'uSalesOrderHeader'
GO

Collapse image See also

List of triggers

Sales.SalesOrderHeader


Users

list of users

Collapse image Users

Name | Login | Description | Assigned roles
amy0 |  |  | SalesManagers, public
brian3 |  |  | SalesManagers, public
david8 |  |  | SalesPersons, public
dbo |  |  | db_owner, public
garrett1 |  |  | SalesPersons, public
guest |  |  | public
jae0 |  |  | SalesPersons, public
jillian0 |  |  | SalesPersons, public
josé1 |  |  | SalesPersons, public
linda3 |  |  | SalesPersons, public
lynn0 |  |  | SalesPersons, public
michael9 |  |  | SalesPersons, public
pamela0 |  |  | SalesPersons, public
rachel0 |  |  | SalesPersons, public
ranjit0 |  |  | SalesPersons, public
shu0 |  |  | SalesPersons, public
stephen0 |  |  | SalesManagers, public
syed0 |  |  | SalesManagers, public
tete0 |  |  | SalesPersons, public
tsvi0 |  |  | SalesPersons, public
Total: 20 user(s)

Collapse image See also

Roles

Database overview


amy0

User: AdventureWorks2016CTP3.amy0

Collapse image User properties

Name | Value
Name | amy0
Login |
ID | 21
Authentication type | SQL Server

Collapse image Roles

Role
SalesManagers
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on amy0

Object name | Object type | Dep level
SalesManagers | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [amy0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


brian3

User: AdventureWorks2016CTP3.brian3

Collapse image User properties

Name | Value
Name | brian3
Login |
ID | 7
Authentication type | SQL Server

Collapse image Roles

Role
SalesManagers
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on brian3

Object name | Object type | Dep level
SalesManagers | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [brian3]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


david8

User: AdventureWorks2016CTP3.david8

Collapse image User properties

Name | Value
Name | david8
Login |
ID | 17
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on david8

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [david8]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


dbo

User: AdventureWorks2016CTP3.dbo

Collapse image User properties

Name | Value
Name | dbo
Login |
ID | 1
Authentication type | Windows

Collapse image Roles

Role
db_owner
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image SQL

NA

Collapse image See also

List of users


garrett1

User: AdventureWorks2016CTP3.garrett1

Collapse image User properties

Name | Value
Name | garrett1
Login |
ID | 12
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on garrett1

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [garrett1]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


guest

User: AdventureWorks2016CTP3.guest

Collapse image User properties

Name | Value
Name | guest
Login |
ID | 2
Authentication type | SQL Server

Collapse image Roles

Role
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image SQL

CREATE USER [guest]
    WITH DEFAULT_SCHEMA = [guest]
GO

Collapse image See also

List of users


jae0

User: AdventureWorks2016CTP3.jae0

Collapse image User properties

Name | Value
Name | jae0
Login |
ID | 23
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on jae0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [jae0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


jillian0

User: AdventureWorks2016CTP3.jillian0

Collapse image User properties

Name | Value
Name | jillian0
Login |
ID | 11
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on jillian0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [jillian0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


josé1

User: AdventureWorks2016CTP3.josé1

Collapse image User properties

Name | Value
Name | josé1
Login |
ID | 16
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on josé1

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [josé1]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


linda3

User: AdventureWorks2016CTP3.linda3

Collapse image User properties

Name | Value
Name | linda3
Login |
ID | 10
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on linda3

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [linda3]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


lynn0

User: AdventureWorks2016CTP3.lynn0

Collapse image User properties

Name | Value
Name | lynn0
Login |
ID | 20
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on lynn0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [lynn0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


michael9

User: AdventureWorks2016CTP3.michael9

Collapse image User properties

Name | Value
Name | michael9
Login |
ID | 9
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on michael9

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [michael9]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


pamela0

User: AdventureWorks2016CTP3.pamela0

Collapse image User properties

Name | Value
Name | pamela0
Login |
ID | 14
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on pamela0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [pamela0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


rachel0

User: AdventureWorks2016CTP3.rachel0

Collapse image User properties

Name | Value
Name | rachel0
Login |
ID | 22
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on rachel0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [rachel0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


ranjit0

User: AdventureWorks2016CTP3.ranjit0

Collapse image User properties

Name | Value
Name | ranjit0
Login |
ID | 24
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on ranjit0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [ranjit0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


shu0

User: AdventureWorks2016CTP3.shu0

Collapse image User properties

Name | Value
Name | shu0
Login |
ID | 15
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on shu0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [shu0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


stephen0

User: AdventureWorks2016CTP3.stephen0

Collapse image User properties

Name | Value
Name | stephen0
Login |
ID | 8
Authentication type | SQL Server

Collapse image Roles

Role
SalesManagers
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on stephen0

Object name | Object type | Dep level
SalesManagers | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [stephen0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


syed0

User: AdventureWorks2016CTP3.syed0

Collapse image User properties

Name | Value
Name | syed0
Login |
ID | 19
Authentication type | SQL Server

Collapse image Roles

Role
SalesManagers
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on syed0

Object name | Object type | Dep level
SalesManagers | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [syed0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


tete0

User: AdventureWorks2016CTP3.tete0

Collapse image User properties

Name | Value
Name | tete0
Login |
ID | 18
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on tete0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [tete0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


tsvi0

User: AdventureWorks2016CTP3.tsvi0

Collapse image User properties

Name | Value
Name | tsvi0
Login |
ID | 13
Authentication type | SQL Server

Collapse image Roles

Role
SalesPersons
public

Collapse image Objects

Name | Type
AccountNumber | Datatype
Flag | Datatype
Name | Datatype
NameStyle | Datatype
OrderNumber | Datatype
Phone | Datatype
Sales.SalesOrderDetailType_inmem | Datatype
Sales.SalesOrderDetailType_ondisk | Datatype
AW2014FullTextCatalog | Fulltext Catalog
AUDIT_fn_HexToStr | Function
AUDIT_fn_SqlVariantToString | Function
ufnGetAccountingEndDate | Function
ufnGetAccountingEndDate_native | Function
ufnGetAccountingStartDate | Function
ufnGetAccountingStartDate_native | Function
ufnGetContactInformation | Function
ufnGetDocumentStatusText | Function
ufnGetDocumentStatusText_native | Function
ufnGetProductDealerPrice | Function
ufnGetProductListPrice | Function
ufnGetProductStandardCost | Function
ufnGetPurchaseOrderStatusText | Function
ufnGetPurchaseOrderStatusText_native | Function
ufnGetSalesOrderStatusText | Function
ufnGetSalesOrderStatusText_native | Function
ufnGetStock | Function
ufnLeadingZeros | Function
ufnLeadingZeros_native | Function
Sales.vSalesOrderDetail_extended_inmem | Function
Sales.vSalesOrderHeader_extended_inmem | Function
Security.customerAccessPredicate | Function
AUDIT_prc_AggregateReport | Procedure
AUDIT_prc_Analyze | Procedure
AUDIT_prc_DDLReport | Procedure
AUDIT_prc_DeleteArchitecture | Procedure
AUDIT_prc_Purge_AUDIT_LOG | Procedure
AUDIT_prc_ReportingAddFilterValue | Procedure
AUDIT_prc_ReportingEnd | Procedure
AUDIT_prc_ReportingStart | Procedure
AUDIT_prc_StandardReport | Procedure
uspAddOrderTrackingEvent | Procedure
uspGetBillOfMaterials | Procedure
uspGetEmployeeManagers | Procedure
uspGetManagerEmployees | Procedure
uspGetOrderTrackingBySalesOrderID | Procedure
uspGetOrderTrackingByTrackingNumber | Procedure
uspGetWhereUsedProductID | Procedure
uspLogError | Procedure
uspPrintError | Procedure
uspSearchCandidateResumes | Procedure
Demo.usp_DemoInitSeed | Procedure
Demo.usp_DemoReset | Procedure
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure
HumanResources.sp_UpdateEmployee_Temporal | Procedure
HumanResources.uspUpdateEmployeeHireInfo | Procedure
HumanResources.uspUpdateEmployeeLogin | Procedure
HumanResources.uspUpdateEmployeePersonalInfo | Procedure
Person.sp_DeletePerson_Temporal | Procedure
Person.sp_UpdatePerson_Temporal | Procedure
Sales.usp_InsertSalesOrder_inmem | Procedure
Sales.usp_InsertSalesOrder_ondisk | Procedure
Sales.usp_UpdateSalesOrderShipInfo_inmem | Procedure
Sales.usp_UpdateSalesOrderShipInfo_native | Procedure
Sales.usp_UpdateSalesOrderShipInfo_ondisk | Procedure
SQLCop.test | Procedure
SQLCop.[test Ad hoc distributed queries] | Procedure
SQLCop.[test Agent Service] | Procedure
SQLCop.[test Auto close] | Procedure
SQLCop.[test Auto create statistics] | Procedure
SQLCop.[test Auto Shrink] | Procedure
SQLCop.[test Auto update statistics] | Procedure
SQLCop.[test Buffer cache hit ratio] | Procedure
SQLCop.[test Column collation does not match database default] | Procedure
SQLCop.[test Column data types (Numeric vs. Int)] | Procedure
SQLCop.[test Column Name Problems] | Procedure
SQLCop.[test Columns of data type Text/nText] | Procedure
SQLCop.[test Columns with float data type] | Procedure
SQLCop.[test Columns with image data type] | Procedure
SQLCop.[test Compatibility Level] | Procedure
SQLCop.[test Database and Log files on the same disk] | Procedure
SQLCop.[test Database collation] | Procedure
SQLCop.[test Database Mail] | Procedure
SQLCop.[test Decimal Size Problem] | Procedure
SQLCop.[test Forwarded Records] | Procedure
SQLCop.[test Fragmented Indexes] | Procedure
SQLCop.[test Instant File Initialization] | Procedure
SQLCop.[test Login Language] | Procedure
SQLCop.[test Max degree of parallelism] | Procedure
SQLCop.[test Missing Foreign Key Indexes] | Procedure
SQLCop.[test Missing Foreign Keys] | Procedure
SQLCop.[test Old Backups] | Procedure
SQLCop.[test Ole Automation Procedures] | Procedure
SQLCop.[test Orphaned Users] | Procedure
SQLCop.[test Page life expectancy] | Procedure
SQLCop.[test Procedures Named SP_] | Procedure
SQLCop.[test Procedures that call undocumented procedures] | Procedure
SQLCop.[test Procedures using dynamic SQL without sp_executesql] | Procedure
SQLCop.[test Procedures with @@Identity] | Procedure
SQLCop.[test Procedures With SET ROWCOUNT] | Procedure
SQLCop.[test Procedures without SET NOCOUNT ON] | Procedure
SQLCop.[test Service Account] | Procedure
SQLCop.[test SMO and DMO] | Procedure
SQLCop.[test Table name problems] | Procedure
SQLCop.[test Tables that start with tbl] | Procedure
SQLCop.[test Tables without a primary key] | Procedure
SQLCop.[test Tables without any data] | Procedure
SQLCop.[test UniqueIdentifier with NewId] | Procedure
SQLCop.[test Unnamed Constraints] | Procedure
SQLCop.[test User Aliases] | Procedure
SQLCop.[test Varchar Size Problem] | Procedure
SQLCop.[test Views with order by] | Procedure
SQLCop.[test Wide Table] | Procedure
SQLCop.[test xp_cmdshell is enabled] | Procedure
db_accessadmin | Role
db_backupoperator | Role
db_datareader | Role
db_datawriter | Role
db_ddladmin | Role
db_denydatareader | Role
db_denydatawriter | Role
db_owner | Role
db_securityadmin | Role
public | Role
SalesManagers | Role
SalesPersons | Role
AUDIT_LOG_DATA | Table
AUDIT_LOG_DDL | Table
AUDIT_LOG_TRANSACTIONS | Table
AWBuildVersion | Table
DatabaseLog | Table
ErrorLog | Table
Demo.DemoSalesOrderDetailSeed | Table
Demo.DemoSalesOrderHeaderSeed | Table
HumanResources.Department | Table
HumanResources.Employee | Table
HumanResources.Employee_Temporal | Table
HumanResources.Employee_Temporal_History | Table
HumanResources.EmployeeDepartmentHistory | Table
HumanResources.EmployeePayHistory | Table
HumanResources.JobCandidate | Table
HumanResources.Shift | Table
Person.Address | Table
Person.AddressType | Table
Person.BusinessEntity | Table
Person.BusinessEntityAddress | Table
Person.BusinessEntityContact | Table
Person.ContactType | Table
Person.CountryRegion | Table
Person.EmailAddress | Table
Person.Password | Table
Person.Person | Table
Person.Person_json | Table
Person.Person_Temporal | Table
Person.Person_Temporal_History | Table
Person.PersonPhone | Table
Person.PhoneNumberType | Table
Person.StateProvince | Table
Production.BillOfMaterials | Table
Production.Culture | Table
Production.Document | Table
Production.Illustration | Table
Production.Location | Table
Production.Product | Table
Production.Product_inmem | Table
Production.Product_ondisk | Table
Production.ProductCategory | Table
Production.ProductCostHistory | Table
Production.ProductDescription | Table
Production.ProductDocument | Table
Production.ProductInventory | Table
Production.ProductListPriceHistory | Table
Production.ProductModel | Table
Production.ProductModelIllustration | Table
Production.ProductModelProductDescriptionCulture | Table
Production.ProductPhoto | Table
Production.ProductProductPhoto | Table
Production.ProductReview | Table
Production.ProductSubcategory | Table
Production.ScrapReason | Table
Production.TransactionHistory | Table
Production.TransactionHistoryArchive | Table
Production.UnitMeasure | Table
Production.WorkOrder | Table
Production.WorkOrderRouting | Table
Purchasing.ProductVendor | Table
Purchasing.PurchaseOrderDetail | Table
Purchasing.PurchaseOrderHeader | Table
Purchasing.ShipMethod | Table
Purchasing.Vendor | Table
Sales.CountryRegionCurrency | Table
Sales.CreditCard | Table
Sales.Currency | Table
Sales.CurrencyRate | Table
Sales.Customer | Table
Sales.CustomerPII | Table
Sales.OrderTracking | Table
Sales.PersonCreditCard | Table
Sales.SalesOrder_json | Table
Sales.SalesOrderDetail | Table
Sales.SalesOrderDetail_inmem | Table
Sales.SalesOrderDetail_ondisk | Table
Sales.SalesOrderHeader | Table
Sales.SalesOrderHeader_inmem | Table
Sales.SalesOrderHeader_ondisk | Table
Sales.SalesOrderHeaderSalesReason | Table
Sales.SalesPerson | Table
Sales.SalesPersonQuotaHistory | Table
Sales.SalesReason | Table
Sales.SalesTaxRate | Table
Sales.SalesTerritory | Table
Sales.SalesTerritoryHistory | Table
Sales.ShoppingCartItem | Table
Sales.SpecialOffer | Table
Sales.SpecialOffer_inmem | Table
Sales.SpecialOffer_ondisk | Table
Sales.SpecialOfferProduct | Table
Sales.SpecialOfferProduct_inmem | Table
Sales.SpecialOfferProduct_ondisk | Table
Sales.Store | Table
Sales.TrackingEvent | Table
tr_d_AUDIT_AWBuildVersion | Trigger
tr_d_AUDIT_DatabaseLog | Trigger
tr_d_AUDIT_ErrorLog | Trigger
tr_i_AUDIT_DatabaseLog | Trigger
tr_i_AUDIT_ErrorLog | Trigger
tr_u_AUDIT_AWBuildVersion | Trigger
tr_u_AUDIT_DatabaseLog | Trigger
HumanResources.dEmployee | Trigger
HumanResources.tr_d_AUDIT_Department | Trigger
HumanResources.tr_d_AUDIT_Employee | Trigger
HumanResources.tr_d_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_d_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_i_AUDIT_Department | Trigger
HumanResources.tr_i_AUDIT_Employee | Trigger
HumanResources.tr_i_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_i_AUDIT_EmployeePayHistory | Trigger
HumanResources.tr_u_AUDIT_Department | Trigger
HumanResources.tr_u_AUDIT_Employee_Temporal | Trigger
HumanResources.tr_u_AUDIT_EmployeeDepartmentHistory | Trigger
HumanResources.tr_u_AUDIT_EmployeePayHistory | Trigger
Person.iuPerson | Trigger
Production.iWorkOrder | Trigger
Production.uWorkOrder | Trigger
Purchasing.dVendor | Trigger
Purchasing.iPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderDetail | Trigger
Purchasing.uPurchaseOrderHeader | Trigger
Sales.iduSalesOrderDetail | Trigger
Sales.uSalesOrderHeader | Trigger
amy0 | User
brian3 | User
david8 | User
dbo | User
garrett1 | User
guest | User
jae0 | User
jillian0 | User
josé1 | User
linda3 | User
lynn0 | User
michael9 | User
pamela0 | User
rachel0 | User
ranjit0 | User
shu0 | User
stephen0 | User
syed0 | User
tete0 | User
tsvi0 | User
AUDIT_UNDO | View
AUDIT_VIEW | View
HumanResources.vEmployee | View
HumanResources.vEmployeeDepartment | View
HumanResources.vEmployeeDepartmentHistory | View
HumanResources.vEmployeePersonTemporalInfo | View
HumanResources.vJobCandidate | View
HumanResources.vJobCandidateEducation | View
HumanResources.vJobCandidateEmployment | View
Person.vAdditionalContactInfo | View
Person.vStateProvinceCountryRegion | View
Production.vProductAndDescription | View
Production.vProductModelCatalogDescription | View
Production.vProductModelInstructions | View
Purchasing.vVendorWithAddresses | View
Purchasing.vVendorWithContacts | View
Sales.vIndividualCustomer | View
Sales.vPersonDemographics | View
Sales.vSalesPerson | View
Sales.vSalesPersonSalesByFiscalYears | View
Sales.vStoreWithAddresses | View
Sales.vStoreWithContacts | View
Sales.vStoreWithDemographics | View
tr_ddl_AUDIT | DDL Trigger
db_accessadmin | Schema
db_backupoperator | Schema
db_datareader | Schema
db_datawriter | Schema
db_ddladmin | Schema
db_denydatareader | Schema
db_denydatawriter | Schema
db_owner | Schema
db_securityadmin | Schema
dbo | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
Production | Schema
Purchasing | Schema
Sales | Schema
Security | Schema
SQLCop | Schema
guest | Schema
INFORMATION_SCHEMA | Schema
sys | Schema
HumanResources.HRResumeSchemaCollection | XML Schema Collection
Person.AdditionalContactInfoSchemaCollection | XML Schema Collection
Person.IndividualSurveySchemaCollection | XML Schema Collection
Production.ManuInstructionsSchemaCollection | XML Schema Collection
Production.ProductDescriptionSchemaCollection | XML Schema Collection
Sales.StoreSurveySchemaCollection | XML Schema Collection
Total: 320 object(s)

Collapse image Objects that depend on tsvi0

Object name | Object type | Dep level
SalesPersons | Role | 1
Total 1 object(s)

Collapse image SQL

CREATE USER [tsvi0]
    WITHOUT LOGIN
    WITH DEFAULT_SCHEMA = [dbo]
GO

Collapse image See also

List of users


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
AUDIT_UNDO | dbo |  |  |  | 21.09.2016
AUDIT_VIEW | dbo |  |  |  | 21.09.2016
vEmployee | HumanResources | Employee names and addresses. |  |  | 16.11.2015
vEmployeeDepartment | HumanResources | Returns employee name, title, and current department. |  |  | 16.11.2015
vEmployeeDepartmentHistory | HumanResources | Returns employee name and current and previous departments. |  |  | 16.11.2015
vEmployeePersonTemporalInfo | HumanResources |  |  |  | 23.10.2015
vJobCandidate | HumanResources | Job candidate names and resumes. |  |  | 16.11.2015
vJobCandidateEducation | HumanResources | Displays the content from each education related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed. |  |  | 16.11.2015
vJobCandidateEmployment | HumanResources | Displays the content from each employement history related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed. |  |  | 16.11.2015
vAdditionalContactInfo | Person | Displays the contact name and content from each element in the xml column AdditionalContactInfo for that person. |  |  | 16.11.2015
vStateProvinceCountryRegion | Person | Joins StateProvince table with CountryRegion table. |  |  | 16.11.2015
vProductAndDescription | Production | Product names and descriptions. Product descriptions are provided in multiple languages. |  |  | 16.11.2015
vProductModelCatalogDescription | Production | Displays the content from each element in the xml column CatalogDescription for each product in the Production.ProductModel table that has catalog data. |  |  | 16.11.2015
vProductModelInstructions | Production | Displays the content from each element in the xml column Instructions for each product in the Production.ProductModel table that has manufacturing instructions. |  |  | 16.11.2015
vVendorWithAddresses | Purchasing | Vendor (company) names and addresses . |  |  | 16.11.2015
vVendorWithContacts | Purchasing | Vendor (company) names and the names of vendor employees to contact. |  |  | 16.11.2015
vIndividualCustomer | Sales | Individual customers (names and addresses) that purchase Adventure Works Cycles products online. |  |  | 16.11.2015
vPersonDemographics | Sales | Displays the content from each element in the xml column Demographics for each customer in the Person.Person table. |  |  | 16.11.2015
vSalesPerson | Sales | Sales representiatives (names and addresses) and their sales-related information. |  |  | 16.11.2015
vSalesPersonSalesByFiscalYears | Sales | Uses PIVOT to return aggregated sales information for each sales representative. |  |  | 16.11.2015
vStoreWithAddresses | Sales | Stores (including store addresses) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
vStoreWithContacts | Sales | Stores (including store contacts) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
vStoreWithDemographics | Sales | Stores (including demographics) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
Total: 23 view(s)

Collapse image See also

Tables

Database overview


AUDIT_UNDO

View: AdventureWorks2016CTP3.dbo.AUDIT_UNDO

Collapse image View properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Is schema bound |
Encrypted |
ID | 1323867783

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
AUDIT_LOG_TRANSACTION_ID |  | int | 4
TABLE_NAME |  | nvarchar | 261
TABLE_SCHEMA |  | nvarchar | 261
ACTION_NAME |  | varchar | 6
HOST_NAME |  | varchar | 128
APP_NAME |  | varchar | 128
MODIFIED_BY |  | varchar | 128
MODIFIED_DATE |  | datetime | 8
AFFECTED_ROWS |  | int | 4
AUDIT_LOG_DATA_ID |  | int | 4
PRIMARY_KEY |  | nvarchar | 1500
COL_NAME |  | nvarchar | 128
OLD_VALUE |  | nvarchar | 4000
NEW_VALUE |  | nvarchar | 4000
DATA_TYPE |  | char | 1
Total: 15 column(s)

Collapse image Objects that depend on AUDIT_UNDO

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image Objects that AUDIT_UNDO depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE VIEW dbo.AUDIT_UNDO AS
/* ------------------------------------------------------------
VIEW:          AUDIT_UNDO
DESCRIPTION:   Selects Audit Log records and returns all rows from the
               AUDIT_LOG_TRANSACTIONS ALT, with the matching rows in the AUDIT_LOG_DATA AD.
   ------------------------------------------------------------ */
SELECT
    ALT.AUDIT_LOG_TRANSACTION_ID,
    TABLE_NAME = ALT.TABLE_NAME,
    TABLE_SCHEMA = ALT.TABLE_SCHEMA,
    CASE
        WHEN ALT.AUDIT_ACTION_ID = 3 THEN 'Delete'
        WHEN ALT.AUDIT_ACTION_ID = 2 THEN 'Insert'
        WHEN ALT.AUDIT_ACTION_ID = 1 THEN 'Update'
    END AS ACTION_NAME,
    ALT.HOST_NAME,
    ALT.APP_NAME,
    ALT.MODIFIED_BY,
    ALT.MODIFIED_DATE,
    ALT.AFFECTED_ROWS,
    AUDIT_LOG_DATA_ID,
    PRIMARY_KEY,
    COL_NAME,
    OLD_VALUE,
    NEW_VALUE,
    DATA_TYPE
FROM AUDIT_LOG_TRANSACTIONS ALT
    LEFT JOIN  AUDIT_LOG_DATA AD
        ON AD.AUDIT_LOG_TRANSACTION_ID = ALT.AUDIT_LOG_TRANSACTION_ID
GO

Collapse image See also

List of views


AUDIT_VIEW

View: AdventureWorks2016CTP3.dbo.AUDIT_VIEW

Collapse image View properties

Name | Value
Schema | dbo
Owner | dbo
Creation date | 21.09.2016
Is schema bound |
Encrypted |
ID | 1307867726

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
TABLE_NAME |  | nvarchar | 261
ACTION |  | varchar | 6
MODIFIED_BY |  | varchar | 128
PRIMARY_KEY |  | nvarchar | 1500
REC_COUNT |  | int | 4
MODIFIED_DATE |  | varchar | 20
COMPUTER |  | varchar | 128
APPLICATION |  | varchar | 128
Total: 8 column(s)

Collapse image Objects that depend on AUDIT_VIEW

Object name | Object type | Dep level
AUDIT_prc_DeleteArchitecture | Procedure | 1
Total 1 object(s)

Collapse image Objects that AUDIT_VIEW depends on

Object name | Object type | Dep level
AUDIT_LOG_DATA | Table | 1
AUDIT_LOG_TRANSACTIONS | Table | 1
Total 2 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
CREATE VIEW dbo.AUDIT_VIEW AS
/* ------------------------------------------------------------
VIEW:          AUDIT_VIEW
DESCRIPTION:   Selects Audit Log records and groups by MODIFIED_DATE and PK
               effectively grouping audit data by Audit transaction
   ------------------------------------------------------------ */
SELECT MAX(t.TABLE_NAME) AS TABLE_NAME,
    CASE MAX(t.AUDIT_ACTION_ID)
    WHEN 1 THEN 'UPDATE'
    WHEN 2 THEN 'INSERT'
    WHEN 3 THEN 'DELETE'
    END AS ACTION,
    MAX(t.MODIFIED_BY) AS MODIFIED_BY,
    MAX(PRIMARY_KEY_DATA) AS PRIMARY_KEY,
    COUNT(DISTINCT PRIMARY_KEY_DATA) AS REC_COUNT,
    CONVERT(varchar(20), MODIFIED_DATE, 113) AS MODIFIED_DATE,
    Max(HOST_NAME) AS COMPUTER,
    Max(APP_NAME) as APPLICATION
FROM dbo.AUDIT_LOG_TRANSACTIONS t
INNER JOIN dbo.AUDIT_LOG_DATA r ON r.AUDIT_LOG_TRANSACTION_ID = t.AUDIT_LOG_TRANSACTION_ID
GROUP BY MODIFIED_DATE, PRIMARY_KEY_DATA
GO

Collapse image See also

List of views


vEmployee

View: AdventureWorks2016CTP3.HumanResources.vEmployee

Collapse image Description

Employee names and addresses.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1037246750

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
JobTitle |  | nvarchar | 50
PhoneNumber |  | Phone | 25
PhoneNumberType |  | Name | 50
EmailAddress |  | nvarchar | 50
EmailPromotion |  | int | 4
AddressLine1 |  | nvarchar | 60
AddressLine2 |  | nvarchar | 60
City |  | nvarchar | 30
StateProvinceName |  | Name | 50
PostalCode |  | nvarchar | 15
CountryRegionName |  | Name | 50
AdditionalContactInfo |  | xml | 2147483647
Total: 18 column(s)

Collapse image Objects that HumanResources.vEmployee depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Person.Address | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.CountryRegion | Table | 1
Person.EmailAddress | Table | 1
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Person.StateProvince | Table | 1
Total 10 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Employee names and addresses.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vEmployee]
AS
SELECT
    e.[BusinessEntityID]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,e.[JobTitle]
    ,pp.[PhoneNumber]
    ,pnt.[Name] AS [PhoneNumberType]
    ,ea.[EmailAddress]
    ,p.[EmailPromotion]
    ,a.[AddressLine1]
    ,a.[AddressLine2]
    ,a.[City]
    ,sp.[Name] AS [StateProvinceName]
    ,a.[PostalCode]
    ,cr.[Name] AS [CountryRegionName]
    ,p.[AdditionalContactInfo]
FROM [HumanResources].[Employee] e
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = e.[BusinessEntityID]
    INNER JOIN [Person].[BusinessEntityAddress] bea
    ON bea.[BusinessEntityID] = e.[BusinessEntityID]
    INNER JOIN [Person].[Address] a
    ON a.[AddressID] = bea.[AddressID]
    INNER JOIN [Person].[StateProvince] sp
    ON sp.[StateProvinceID] = a.[StateProvinceID]
    INNER JOIN [Person].[CountryRegion] cr
    ON cr.[CountryRegionCode] = sp.[CountryRegionCode]
    LEFT OUTER JOIN [Person].[PersonPhone] pp
    ON pp.BusinessEntityID = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PhoneNumberType] pnt
    ON pp.[PhoneNumberTypeID] = pnt.[PhoneNumberTypeID]
    LEFT OUTER JOIN [Person].[EmailAddress] ea
    ON p.[BusinessEntityID] = ea.[BusinessEntityID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Employee names and addresses.', 'SCHEMA', N'HumanResources', 'VIEW', N'vEmployee', NULL, NULL
GO

Collapse image See also

List of views


vEmployeeDepartment

View: AdventureWorks2016CTP3.HumanResources.vEmployeeDepartment

CollapseAll image

Collapse image Description

Returns employee name, title, and current department.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1053246807

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
JobTitle |  | nvarchar | 50
Department |  | Name | 50
GroupName |  | Name | 50
StartDate |  | date | 3
Total: 10 column(s)

Collapse image Objects that HumanResources.vEmployeeDepartment depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Department | Table | 1
HumanResources.Employee | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
Person.Person | Table | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Returns employee name, title, and current department.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vEmployeeDepartment]
AS
SELECT
    e.[BusinessEntityID]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,e.[JobTitle]
    ,d.[Name] AS [Department]
    ,d.[GroupName]
    ,edh.[StartDate]
FROM [HumanResources].[Employee] e
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = e.[BusinessEntityID]
    INNER JOIN [HumanResources].[EmployeeDepartmentHistory] edh
    ON e.[BusinessEntityID] = edh.[BusinessEntityID]
    INNER JOIN [HumanResources].[Department] d
    ON edh.[DepartmentID] = d.[DepartmentID]
WHERE edh.EndDate IS NULL
GO
EXEC sp_addextendedproperty N'MS_Description', N'Returns employee name, title, and current department.', 'SCHEMA', N'HumanResources', 'VIEW', N'vEmployeeDepartment', NULL, NULL
GO

Collapse image See also

List of views


vEmployeeDepartmentHistory

View: AdventureWorks2016CTP3.HumanResources.vEmployeeDepartmentHistory

CollapseAll image

Collapse image Description

Returns employee name and current and previous departments.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1069246864

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
Shift |  | Name | 50
Department |  | Name | 50
GroupName |  | Name | 50
StartDate |  | date | 3
EndDate |  | date | 3
Total: 11 column(s)

Collapse image Objects that HumanResources.vEmployeeDepartmentHistory depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Department | Table | 1
HumanResources.Employee | Table | 1
HumanResources.EmployeeDepartmentHistory | Table | 1
Person.Person | Table | 1
HumanResources.Shift | Table | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Returns employee name and current and previous departments.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vEmployeeDepartmentHistory]
AS
SELECT
    e.[BusinessEntityID]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,s.[Name] AS [Shift]
    ,d.[Name] AS [Department]
    ,d.[GroupName]
    ,edh.[StartDate]
    ,edh.[EndDate]
FROM [HumanResources].[Employee] e
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = e.[BusinessEntityID]
    INNER JOIN [HumanResources].[EmployeeDepartmentHistory] edh
    ON e.[BusinessEntityID] = edh.[BusinessEntityID]
    INNER JOIN [HumanResources].[Department] d
    ON edh.[DepartmentID] = d.[DepartmentID]
    INNER JOIN [HumanResources].[Shift] s
    ON s.[ShiftID] = edh.[ShiftID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Returns employee name and current and previous departments.', 'SCHEMA', N'HumanResources', 'VIEW', N'vEmployeeDepartmentHistory', NULL, NULL
GO

Collapse image See also

List of views


vEmployeePersonTemporalInfo

View: AdventureWorks2016CTP3.HumanResources.vEmployeePersonTemporalInfo

CollapseAll image

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 23.10.2015
Is schema bound |
Encrypted |
ID | 1918629878

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
LastName |  | Name | 50
MiddleName |  | Name | 50
JobTitle |  | nvarchar | 50
MaritalStatus |  | nchar | 1
Gender |  | nchar | 1
VacationHours |  | smallint | 2
SickLeaveHours |  | smallint | 2
Total: 10 column(s)

Collapse image Objects that depend on HumanResources.vEmployeePersonTemporalInfo

Object name | Object type | Dep level
HumanResources.sp_GetEmployee_Person_Info_AsOf | Procedure | 1
Total 1 object(s)

Collapse image Objects that HumanResources.vEmployeePersonTemporalInfo depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.Employee_Temporal | Table | 1
Person.Person_Temporal | Table | 1
Total 3 object(s)

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

/*
    View that joins [Person].[Person_Temporal] [HumanResources].[Employee_Temporal]
    This view can be later used in temporal querying which is extremely flexible and convenient
    given that participating tables are temporal and can be changed independently
*/
CREATE VIEW [HumanResources].[vEmployeePersonTemporalInfo]
AS
SELECT P.BusinessEntityID, P.Title, P. FirstName, P.LastName, P.MiddleName
, E.JobTitle, E.MaritalStatus, E.Gender, E.VacationHours, E.SickLeaveHours
FROM [Person].Person_Temporal P
JOIN  [HumanResources].[Employee_Temporal] E
ON P.[BusinessEntityID] = E.[BusinessEntityID]

GO

Collapse image See also

List of views


vJobCandidate

View: AdventureWorks2016CTP3.HumanResources.vJobCandidate

Collapse image Description

Job candidate names and resumes.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1117247035

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
JobCandidateID |  | int | 4
BusinessEntityID |  | int | 4
Name.Prefix |  | nvarchar | 30
Name.First |  | nvarchar | 30
Name.Middle |  | nvarchar | 30
Name.Last |  | nvarchar | 30
Name.Suffix |  | nvarchar | 30
Skills |  | nvarchar | 1073741823
Addr.Type |  | nvarchar | 30
Addr.Loc.CountryRegion |  | nvarchar | 100
Addr.Loc.State |  | nvarchar | 100
Addr.Loc.City |  | nvarchar | 100
Addr.PostalCode |  | nvarchar | 20
EMail |  | nvarchar | 1073741823
WebSite |  | nvarchar | 1073741823
ModifiedDate |  | datetime | 8
Total: 16 column(s)

Collapse image Objects that HumanResources.vJobCandidate depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.JobCandidate | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Job candidate names and resumes.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vJobCandidate]
AS
SELECT
    jc.[JobCandidateID]
    ,jc.[BusinessEntityID]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Name/Name.Prefix)[1]', 'nvarchar(30)') AS [Name.Prefix]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Name/Name.First)[1]', 'nvarchar(30)') AS [Name.First]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Name/Name.Middle)[1]', 'nvarchar(30)') AS [Name.Middle]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Name/Name.Last)[1]', 'nvarchar(30)') AS [Name.Last]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Name/Name.Suffix)[1]', 'nvarchar(30)') AS [Name.Suffix]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/Skills)[1]', 'nvarchar(max)') AS [Skills]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Address/Addr.Type)[1]', 'nvarchar(30)') AS [Addr.Type]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Address/Addr.Location/Location/Loc.CountryRegion)[1]', 'nvarchar(100)') AS [Addr.Loc.CountryRegion]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Address/Addr.Location/Location/Loc.State)[1]', 'nvarchar(100)') AS [Addr.Loc.State]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Address/Addr.Location/Location/Loc.City)[1]', 'nvarchar(100)') AS [Addr.Loc.City]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Address/Addr.PostalCode)[1]', 'nvarchar(20)') AS [Addr.PostalCode]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/EMail)[1]', 'nvarchar(max)') AS [EMail]
    ,[Resume].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (/Resume/WebSite)[1]', 'nvarchar(max)') AS [WebSite]
    ,jc.[ModifiedDate]
FROM [HumanResources].[JobCandidate] jc
CROSS APPLY jc.[Resume].nodes(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
    /Resume') AS Resume(ref);
GO
EXEC sp_addextendedproperty N'MS_Description', N'Job candidate names and resumes.', 'SCHEMA', N'HumanResources', 'VIEW', N'vJobCandidate', NULL, NULL
GO

Collapse image See also

List of views


vJobCandidateEducation

View: AdventureWorks2016CTP3.HumanResources.vJobCandidateEducation

CollapseAll image

Collapse image Description

Displays the content from each education related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1149247149

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
JobCandidateID |  | int | 4
Edu.Level |  | nvarchar | 1073741823
Edu.StartDate |  | datetime | 8
Edu.EndDate |  | datetime | 8
Edu.Degree |  | nvarchar | 50
Edu.Major |  | nvarchar | 50
Edu.Minor |  | nvarchar | 50
Edu.GPA |  | nvarchar | 5
Edu.GPAScale |  | nvarchar | 5
Edu.School |  | nvarchar | 100
Edu.Loc.CountryRegion |  | nvarchar | 100
Edu.Loc.State |  | nvarchar | 100
Edu.Loc.City |  | nvarchar | 100
Total: 13 column(s)

Collapse image Objects that HumanResources.vJobCandidateEducation depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.JobCandidate | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the content from each education related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vJobCandidateEducation]
AS
SELECT
    jc.[JobCandidateID]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Level)[1]', 'nvarchar(max)') AS [Edu.Level]
    ,CONVERT(datetime, REPLACE([Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.StartDate)[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [Edu.StartDate]
    ,CONVERT(datetime, REPLACE([Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.EndDate)[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [Edu.EndDate]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Degree)[1]', 'nvarchar(50)') AS [Edu.Degree]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Major)[1]', 'nvarchar(50)') AS [Edu.Major]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Minor)[1]', 'nvarchar(50)') AS [Edu.Minor]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.GPA)[1]', 'nvarchar(5)') AS [Edu.GPA]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.GPAScale)[1]', 'nvarchar(5)') AS [Edu.GPAScale]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.School)[1]', 'nvarchar(100)') AS [Edu.School]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Location/Location/Loc.CountryRegion)[1]', 'nvarchar(100)') AS [Edu.Loc.CountryRegion]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Location/Location/Loc.State)[1]', 'nvarchar(100)') AS [Edu.Loc.State]
    ,[Education].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Edu.Location/Location/Loc.City)[1]', 'nvarchar(100)') AS [Edu.Loc.City]
FROM [HumanResources].[JobCandidate] jc
CROSS APPLY jc.[Resume].nodes(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
    /Resume/Education') AS [Education](ref);
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the content from each education related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.', 'SCHEMA', N'HumanResources', 'VIEW', N'vJobCandidateEducation', NULL, NULL
GO

Collapse image See also

List of views


vJobCandidateEmployment

View: AdventureWorks2016CTP3.HumanResources.vJobCandidateEmployment

CollapseAll image

Collapse image Description

Displays the content from each employement history related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.

Collapse image View properties

Name | Value
Schema | HumanResources
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1133247092

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
JobCandidateID |  | int | 4
Emp.StartDate |  | datetime | 8
Emp.EndDate |  | datetime | 8
Emp.OrgName |  | nvarchar | 100
Emp.JobTitle |  | nvarchar | 100
Emp.Responsibility |  | nvarchar | 1073741823
Emp.FunctionCategory |  | nvarchar | 1073741823
Emp.IndustryCategory |  | nvarchar | 1073741823
Emp.Loc.CountryRegion |  | nvarchar | 1073741823
Emp.Loc.State |  | nvarchar | 1073741823
Emp.Loc.City |  | nvarchar | 1073741823
Total: 11 column(s)

Collapse image Objects that HumanResources.vJobCandidateEmployment depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
HumanResources.JobCandidate | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the content from each employement history related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [HumanResources].[vJobCandidateEmployment]
AS
SELECT
    jc.[JobCandidateID]
    ,CONVERT(datetime, REPLACE([Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.StartDate)[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [Emp.StartDate]
    ,CONVERT(datetime, REPLACE([Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.EndDate)[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [Emp.EndDate]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.OrgName)[1]', 'nvarchar(100)') AS [Emp.OrgName]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.JobTitle)[1]', 'nvarchar(100)') AS [Emp.JobTitle]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.Responsibility)[1]', 'nvarchar(max)') AS [Emp.Responsibility]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.FunctionCategory)[1]', 'nvarchar(max)') AS [Emp.FunctionCategory]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.IndustryCategory)[1]', 'nvarchar(max)') AS [Emp.IndustryCategory]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.Location/Location/Loc.CountryRegion)[1]', 'nvarchar(max)') AS [Emp.Loc.CountryRegion]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.Location/Location/Loc.State)[1]', 'nvarchar(max)') AS [Emp.Loc.State]
    ,[Employment].ref.value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
        (Emp.Location/Location/Loc.City)[1]', 'nvarchar(max)') AS [Emp.Loc.City]
FROM [HumanResources].[JobCandidate] jc
CROSS APPLY jc.[Resume].nodes(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume";
    /Resume/Employment') AS Employment(ref);
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the content from each employement history related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed.', 'SCHEMA', N'HumanResources', 'VIEW', N'vJobCandidateEmployment', NULL, NULL
GO

Collapse image See also

List of views


vAdditionalContactInfo

View: AdventureWorks2016CTP3.Person.vAdditionalContactInfo

Collapse image Description

Displays the contact name and content from each element in the xml column AdditionalContactInfo for that person.

Collapse image View properties

Name | Value
Schema | Person
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1021246693

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
TelephoneNumber |  | nvarchar | 50
TelephoneSpecialInstructions |  | nvarchar | 1073741823
Street |  | nvarchar | 50
City |  | nvarchar | 50
StateProvince |  | nvarchar | 50
PostalCode |  | nvarchar | 50
CountryRegion |  | nvarchar | 50
HomeAddressSpecialInstructions |  | nvarchar | 1073741823
EMailAddress |  | nvarchar | 128
EMailSpecialInstructions |  | nvarchar | 1073741823
EMailTelephoneNumber |  | nvarchar | 50
rowguid |  | uniqueidentifier | 16
ModifiedDate |  | datetime | 8
Total: 17 column(s)

Collapse image Objects that Person.vAdditionalContactInfo depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the contact name and content from each element in the xml column AdditionalContactInfo for that person.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Person].[vAdditionalContactInfo]
AS
SELECT
    [BusinessEntityID]
    ,[FirstName]
    ,[MiddleName]
    ,[LastName]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:telephoneNumber)[1]/act:number', 'nvarchar(50)') AS [TelephoneNumber]
    ,LTRIM(RTRIM([ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:telephoneNumber/act:SpecialInstructions/text())[1]', 'nvarchar(max)'))) AS [TelephoneSpecialInstructions]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:Street)[1]', 'nvarchar(50)') AS [Street]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:City)[1]', 'nvarchar(50)') AS [City]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:StateProvince)[1]', 'nvarchar(50)') AS [StateProvince]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:PostalCode)[1]', 'nvarchar(50)') AS [PostalCode]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:CountryRegion)[1]', 'nvarchar(50)') AS [CountryRegion]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:homePostalAddress/act:SpecialInstructions/text())[1]', 'nvarchar(max)') AS [HomeAddressSpecialInstructions]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:eMail/act:eMailAddress)[1]', 'nvarchar(128)') AS [EMailAddress]
    ,LTRIM(RTRIM([ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:eMail/act:SpecialInstructions/text())[1]', 'nvarchar(max)'))) AS [EMailSpecialInstructions]
    ,[ContactInfo].ref.value(N'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
        declare namespace act="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes";
        (act:eMail/act:SpecialInstructions/act:telephoneNumber/act:number)[1]', 'nvarchar(50)') AS [EMailTelephoneNumber]
    ,[rowguid]
    ,[ModifiedDate]
FROM [Person].[Person]
OUTER APPLY [AdditionalContactInfo].nodes(
    'declare namespace ci="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo";
    /ci:AdditionalContactInfo') AS ContactInfo(ref)
WHERE [AdditionalContactInfo] IS NOT NULL;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the contact name and content from each element in the xml column AdditionalContactInfo for that person.', 'SCHEMA', N'Person', 'VIEW', N'vAdditionalContactInfo', NULL, NULL
GO

Collapse image See also

List of views


vStateProvinceCountryRegion

View: AdventureWorks2016CTP3.Person.vStateProvinceCountryRegion

CollapseAll image

Collapse image Description

Joins StateProvince table with CountryRegion table.

Collapse image View properties

Name | Value
Schema | Person
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1245247491

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
StateProvinceID |  | int | 4
StateProvinceCode |  | nchar | 3
IsOnlyStateProvinceFlag |  | Flag | 1
StateProvinceName |  | Name | 50
TerritoryID |  | int | 4
CountryRegionCode |  | nvarchar | 3
CountryRegionName |  | Name | 50
Total: 7 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
IX_vStateProvinceCountryRegion | Clustered index on the view vStateProvinceCountryRegion. | StateProvinceID, CountryRegionCode |  |  | 32 | 0

Collapse image Objects that Person.vStateProvinceCountryRegion depends on

Object name | Object type | Dep level
Person | Schema | 1
Person.CountryRegion | Table | 1
Person.StateProvince | Table | 1
Total 3 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Joins StateProvince table with CountryRegion table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
SET ANSI_PADDING ON
GO

CREATE VIEW [Person].[vStateProvinceCountryRegion]
WITH SCHEMABINDING
AS
SELECT
    sp.[StateProvinceID]
    ,sp.[StateProvinceCode]
    ,sp.[IsOnlyStateProvinceFlag]
    ,sp.[Name] AS [StateProvinceName]
    ,sp.[TerritoryID]
    ,cr.[CountryRegionCode]
    ,cr.[Name] AS [CountryRegionName]
FROM [Person].[StateProvince] sp
    INNER JOIN [Person].[CountryRegion] cr
    ON sp.[CountryRegionCode] = cr.[CountryRegionCode];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Joins StateProvince table with CountryRegion table.', 'SCHEMA', N'Person', 'VIEW', N'vStateProvinceCountryRegion', NULL, NULL
GO
SET ANSI_PADDING ON
GO
CREATE UNIQUE CLUSTERED INDEX [IX_vStateProvinceCountryRegion]
    ON [Person].[vStateProvinceCountryRegion] ([StateProvinceID], [CountryRegionCode])
    ON [PRIMARY]
GO
SET ANSI_PADDING OFF
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index on the view vStateProvinceCountryRegion.', 'SCHEMA', N'Person', 'VIEW', N'vStateProvinceCountryRegion', 'INDEX', N'IX_vStateProvinceCountryRegion'
GO

Collapse image See also

List of views


vProductAndDescription

View: AdventureWorks2016CTP3.Production.vProductAndDescription

CollapseAll image

Collapse image Description

Product names and descriptions. Product descriptions are provided in multiple languages.

Collapse image View properties

Name | Value
Schema | Production
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1165247206

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
ProductID |  | int | 4
Name |  | Name | 50
ProductModel |  | Name | 50
CultureID |  | nchar | 6
Description |  | nvarchar | 400
Total: 5 column(s)

Collapse image Indexes

Index | Description | Primary | Unique | Size KB
IX_vProductAndDescription | Clustered index on the view vProductAndDescription. | CultureID, ProductID |  |  | 576 | 0

Collapse image Objects that Production.vProductAndDescription depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.Product | Table | 1
Production.ProductDescription | Table | 1
Production.ProductModel | Table | 1
Production.ProductModelProductDescriptionCulture | Table | 1
Total 5 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Product names and descriptions. Product descriptions are provided in multiple languages.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO
SET ANSI_PADDING ON
GO

CREATE VIEW [Production].[vProductAndDescription]
WITH SCHEMABINDING
AS
-- View (indexed or standard) to display products and product descriptions by language.
SELECT
    p.[ProductID]
    ,p.[Name]
    ,pm.[Name] AS [ProductModel]
    ,pmx.[CultureID]
    ,pd.[Description]
FROM [Production].[Product] p
    INNER JOIN [Production].[ProductModel] pm
    ON p.[ProductModelID] = pm.[ProductModelID]
    INNER JOIN [Production].[ProductModelProductDescriptionCulture] pmx
    ON pm.[ProductModelID] = pmx.[ProductModelID]
    INNER JOIN [Production].[ProductDescription] pd
    ON pmx.[ProductDescriptionID] = pd.[ProductDescriptionID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Product names and descriptions. Product descriptions are provided in multiple languages.', 'SCHEMA', N'Production', 'VIEW', N'vProductAndDescription', NULL, NULL
GO
SET ANSI_PADDING ON
GO
CREATE UNIQUE CLUSTERED INDEX [IX_vProductAndDescription]
    ON [Production].[vProductAndDescription] ([CultureID], [ProductID])
    ON [PRIMARY]
GO
SET ANSI_PADDING OFF
GO
EXEC sp_addextendedproperty N'MS_Description', N'Clustered index on the view vProductAndDescription.', 'SCHEMA', N'Production', 'VIEW', N'vProductAndDescription', 'INDEX', N'IX_vProductAndDescription'
GO

Collapse image See also

List of views


vProductModelCatalogDescription

View: AdventureWorks2016CTP3.Production.vProductModelCatalogDescription

CollapseAll image

Collapse image Description

Displays the content from each element in the xml column CatalogDescription for each product in the Production.ProductModel table that has catalog data.

Collapse image View properties

Name | Value
Schema | Production
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1181247263

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
ProductModelID |  | int | 4
Name |  | Name | 50
Summary |  | nvarchar | 1073741823
Manufacturer |  | nvarchar | 1073741823
Copyright |  | nvarchar | 30
ProductURL |  | nvarchar | 256
WarrantyPeriod |  | nvarchar | 256
WarrantyDescription |  | nvarchar | 256
NoOfYears |  | nvarchar | 256
MaintenanceDescription |  | nvarchar | 256
Wheel |  | nvarchar | 256
Saddle |  | nvarchar | 256
Pedal |  | nvarchar | 256
BikeFrame |  | nvarchar | 1073741823
Crankset |  | nvarchar | 256
PictureAngle |  | nvarchar | 256
PictureSize |  | nvarchar | 256
ProductPhotoID |  | nvarchar | 256
Material |  | nvarchar | 256
Color |  | nvarchar | 256
ProductLine |  | nvarchar | 256
Style |  | nvarchar | 256
RiderExperience |  | nvarchar | 1024
rowguid |  | uniqueidentifier | 16
ModifiedDate |  | datetime | 8
Total: 25 column(s)

Collapse image Objects that Production.vProductModelCatalogDescription depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.ProductModel | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the content from each element in the xml column CatalogDescription for each product in the Production.ProductModel table that has catalog data.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Production].[vProductModelCatalogDescription]
AS
SELECT
    [ProductModelID]
    ,[Name]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace html="http://www.w3.org/1999/xhtml";
        (/p1:ProductDescription/p1:Summary/html:p)[1]', 'nvarchar(max)') AS [Summary]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Manufacturer/p1:Name)[1]', 'nvarchar(max)') AS [Manufacturer]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Manufacturer/p1:Copyright)[1]', 'nvarchar(30)') AS [Copyright]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Manufacturer/p1:ProductURL)[1]', 'nvarchar(256)') AS [ProductURL]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wm="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain";
        (/p1:ProductDescription/p1:Features/wm:Warranty/wm:WarrantyPeriod)[1]', 'nvarchar(256)') AS [WarrantyPeriod]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wm="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain";
        (/p1:ProductDescription/p1:Features/wm:Warranty/wm:Description)[1]', 'nvarchar(256)') AS [WarrantyDescription]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wm="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain";
        (/p1:ProductDescription/p1:Features/wm:Maintenance/wm:NoOfYears)[1]', 'nvarchar(256)') AS [NoOfYears]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wm="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain";
        (/p1:ProductDescription/p1:Features/wm:Maintenance/wm:Description)[1]', 'nvarchar(256)') AS [MaintenanceDescription]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wf="http://www.adventure-works.com/schemas/OtherFeatures";
        (/p1:ProductDescription/p1:Features/wf:wheel)[1]', 'nvarchar(256)') AS [Wheel]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wf="http://www.adventure-works.com/schemas/OtherFeatures";
        (/p1:ProductDescription/p1:Features/wf:saddle)[1]', 'nvarchar(256)') AS [Saddle]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wf="http://www.adventure-works.com/schemas/OtherFeatures";
        (/p1:ProductDescription/p1:Features/wf:pedal)[1]', 'nvarchar(256)') AS [Pedal]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wf="http://www.adventure-works.com/schemas/OtherFeatures";
        (/p1:ProductDescription/p1:Features/wf:BikeFrame)[1]', 'nvarchar(max)') AS [BikeFrame]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        declare namespace wf="http://www.adventure-works.com/schemas/OtherFeatures";
        (/p1:ProductDescription/p1:Features/wf:crankset)[1]', 'nvarchar(256)') AS [Crankset]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Picture/p1:Angle)[1]', 'nvarchar(256)') AS [PictureAngle]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Picture/p1:Size)[1]', 'nvarchar(256)') AS [PictureSize]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Picture/p1:ProductPhotoID)[1]', 'nvarchar(256)') AS [ProductPhotoID]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Specifications/Material)[1]', 'nvarchar(256)') AS [Material]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Specifications/Color)[1]', 'nvarchar(256)') AS [Color]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Specifications/ProductLine)[1]', 'nvarchar(256)') AS [ProductLine]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Specifications/Style)[1]', 'nvarchar(256)') AS [Style]
    ,[CatalogDescription].value(N'declare namespace p1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription";
        (/p1:ProductDescription/p1:Specifications/RiderExperience)[1]', 'nvarchar(1024)') AS [RiderExperience]
    ,[rowguid]
    ,[ModifiedDate]
FROM [Production].[ProductModel]
WHERE [CatalogDescription] IS NOT NULL;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the content from each element in the xml column CatalogDescription for each product in the Production.ProductModel table that has catalog data.', 'SCHEMA', N'Production', 'VIEW', N'vProductModelCatalogDescription', NULL, NULL
GO

Collapse image See also

List of views


vProductModelInstructions

View: AdventureWorks2016CTP3.Production.vProductModelInstructions

CollapseAll image

Collapse image Description

Displays the content from each element in the xml column Instructions for each product in the Production.ProductModel table that has manufacturing instructions.

Collapse image View properties

Name | Value
Schema | Production
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1197247320

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
ProductModelID |  | int | 4
Name |  | Name | 50
Instructions |  | nvarchar | 1073741823
LocationID |  | int | 4
SetupHours |  | decimal | 5
MachineHours |  | decimal | 5
LaborHours |  | decimal | 5
LotSize |  | int | 4
Step |  | nvarchar | 1024
rowguid |  | uniqueidentifier | 16
ModifiedDate |  | datetime | 8
Total: 11 column(s)

Collapse image Objects that Production.vProductModelInstructions depends on

Object name | Object type | Dep level
Production | Schema | 1
Production.ProductModel | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the content from each element in the xml column Instructions for each product in the Production.ProductModel table that has manufacturing instructions.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Production].[vProductModelInstructions]
AS
SELECT
    [ProductModelID]
    ,[Name]
    ,[Instructions].value(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelManuInstructions";
        (/root/text())[1]', 'nvarchar(max)') AS [Instructions]
    ,[MfgInstructions].ref.value('@LocationID[1]', 'int') AS [LocationID]
    ,[MfgInstructions].ref.value('@SetupHours[1]', 'decimal(9, 4)') AS [SetupHours]
    ,[MfgInstructions].ref.value('@MachineHours[1]', 'decimal(9, 4)') AS [MachineHours]
    ,[MfgInstructions].ref.value('@LaborHours[1]', 'decimal(9, 4)') AS [LaborHours]
    ,[MfgInstructions].ref.value('@LotSize[1]', 'int') AS [LotSize]
    ,[Steps].ref.value('string(.)[1]', 'nvarchar(1024)') AS [Step]
    ,[rowguid]
    ,[ModifiedDate]
FROM [Production].[ProductModel]
CROSS APPLY [Instructions].nodes(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelManuInstructions";
    /root/Location') MfgInstructions(ref)
CROSS APPLY [MfgInstructions].ref.nodes('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelManuInstructions";
    step') Steps(ref);
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the content from each element in the xml column Instructions for each product in the Production.ProductModel table that has manufacturing instructions.', 'SCHEMA', N'Production', 'VIEW', N'vProductModelInstructions', NULL, NULL
GO

Collapse image See also

List of views


vVendorWithAddresses

View: AdventureWorks2016CTP3.Purchasing.vVendorWithAddresses

Collapse image Description

Vendor (company) names and addresses .

Collapse image View properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1325247776

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Name |  | Name | 50
AddressType |  | Name | 50
AddressLine1 |  | nvarchar | 60
AddressLine2 |  | nvarchar | 60
City |  | nvarchar | 30
StateProvinceName |  | Name | 50
PostalCode |  | nvarchar | 15
CountryRegionName |  | Name | 50
Total: 9 column(s)

Collapse image Objects that Purchasing.vVendorWithAddresses depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Person.Address | Table | 1
Person.AddressType | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.CountryRegion | Table | 1
Person.StateProvince | Table | 1
Purchasing.Vendor | Table | 1
Total 7 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Vendor (company) names and addresses .

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Purchasing].[vVendorWithAddresses] AS
SELECT
    v.[BusinessEntityID]
    ,v.[Name]
    ,at.[Name] AS [AddressType]
    ,a.[AddressLine1]
    ,a.[AddressLine2]
    ,a.[City]
    ,sp.[Name] AS [StateProvinceName]
    ,a.[PostalCode]
    ,cr.[Name] AS [CountryRegionName]
FROM [Purchasing].[Vendor] v
    INNER JOIN [Person].[BusinessEntityAddress] bea
    ON bea.[BusinessEntityID] = v.[BusinessEntityID]
    INNER JOIN [Person].[Address] a
    ON a.[AddressID] = bea.[AddressID]
    INNER JOIN [Person].[StateProvince] sp
    ON sp.[StateProvinceID] = a.[StateProvinceID]
    INNER JOIN [Person].[CountryRegion] cr
    ON cr.[CountryRegionCode] = sp.[CountryRegionCode]
    INNER JOIN [Person].[AddressType] at
    ON at.[AddressTypeID] = bea.[AddressTypeID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor (company) names and addresses .', 'SCHEMA', N'Purchasing', 'VIEW', N'vVendorWithAddresses', NULL, NULL
GO

Collapse image See also

List of views


vVendorWithContacts

View: AdventureWorks2016CTP3.Purchasing.vVendorWithContacts

Collapse image Description

Vendor (company) names and the names of vendor employees to contact.

Collapse image View properties

Name | Value
Schema | Purchasing
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1309247719

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Name |  | Name | 50
ContactType |  | Name | 50
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
PhoneNumber |  | Phone | 25
PhoneNumberType |  | Name | 50
EmailAddress |  | nvarchar | 50
EmailPromotion |  | int | 4
Total: 12 column(s)

Collapse image Objects that Purchasing.vVendorWithContacts depends on

Object name | Object type | Dep level
Purchasing | Schema | 1
Person.BusinessEntityContact | Table | 1
Person.ContactType | Table | 1
Person.EmailAddress | Table | 1
Person.Person | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Purchasing.Vendor | Table | 1
Total 8 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Vendor (company) names and the names of vendor employees to contact.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Purchasing].[vVendorWithContacts] AS
SELECT
    v.[BusinessEntityID]
    ,v.[Name]
    ,ct.[Name] AS [ContactType]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,pp.[PhoneNumber]
    ,pnt.[Name] AS [PhoneNumberType]
    ,ea.[EmailAddress]
    ,p.[EmailPromotion]
FROM [Purchasing].[Vendor] v
    INNER JOIN [Person].[BusinessEntityContact] bec
    ON bec.[BusinessEntityID] = v.[BusinessEntityID]
    INNER JOIN [Person].ContactType ct
    ON ct.[ContactTypeID] = bec.[ContactTypeID]
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = bec.[PersonID]
    LEFT OUTER JOIN [Person].[EmailAddress] ea
    ON ea.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PersonPhone] pp
    ON pp.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PhoneNumberType] pnt
    ON pnt.[PhoneNumberTypeID] = pp.[PhoneNumberTypeID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Vendor (company) names  and the names of vendor employees to contact.', 'SCHEMA', N'Purchasing', 'VIEW', N'vVendorWithContacts', NULL, NULL
GO

Collapse image See also

List of views


vIndividualCustomer

View: AdventureWorks2016CTP3.Sales.vIndividualCustomer

Collapse image Description

Individual customers (names and addresses) that purchase Adventure Works Cycles products online.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1085246921

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
PhoneNumber |  | Phone | 25
PhoneNumberType |  | Name | 50
EmailAddress |  | nvarchar | 50
EmailPromotion |  | int | 4
AddressType |  | Name | 50
AddressLine1 |  | nvarchar | 60
AddressLine2 |  | nvarchar | 60
City |  | nvarchar | 30
StateProvinceName |  | Name | 50
PostalCode |  | nvarchar | 15
CountryRegionName |  | Name | 50
Demographics |  | xml | 2147483647
Total: 18 column(s)

Collapse image Objects that Sales.vIndividualCustomer depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Address | Table | 1
Person.AddressType | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.CountryRegion | Table | 1
Sales.Customer | Table | 1
Person.EmailAddress | Table | 1
Person.Person | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Person.StateProvince | Table | 1
Total 11 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Individual customers (names and addresses) that purchase Adventure Works Cycles products online.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vIndividualCustomer]
AS
SELECT
    p.[BusinessEntityID]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,pp.[PhoneNumber]
    ,pnt.[Name] AS [PhoneNumberType]
    ,ea.[EmailAddress]
    ,p.[EmailPromotion]
    ,at.[Name] AS [AddressType]
    ,a.[AddressLine1]
    ,a.[AddressLine2]
    ,a.[City]
    ,[StateProvinceName] = sp.[Name]
    ,a.[PostalCode]
    ,[CountryRegionName] = cr.[Name]
    ,p.[Demographics]
FROM [Person].[Person] p
    INNER JOIN [Person].[BusinessEntityAddress] bea
    ON bea.[BusinessEntityID] = p.[BusinessEntityID]
    INNER JOIN [Person].[Address] a
    ON a.[AddressID] = bea.[AddressID]
    INNER JOIN [Person].[StateProvince] sp
    ON sp.[StateProvinceID] = a.[StateProvinceID]
    INNER JOIN [Person].[CountryRegion] cr
    ON cr.[CountryRegionCode] = sp.[CountryRegionCode]
    INNER JOIN [Person].[AddressType] at
    ON at.[AddressTypeID] = bea.[AddressTypeID]
    INNER JOIN [Sales].[Customer] c
    ON c.[PersonID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[EmailAddress] ea
    ON ea.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PersonPhone] pp
    ON pp.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PhoneNumberType] pnt
    ON pnt.[PhoneNumberTypeID] = pp.[PhoneNumberTypeID]
WHERE c.StoreID IS NULL;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Individual customers (names and addresses) that purchase Adventure Works Cycles products online.', 'SCHEMA', N'Sales', 'VIEW', N'vIndividualCustomer', NULL, NULL
GO

Collapse image See also

List of views


vPersonDemographics

View: AdventureWorks2016CTP3.Sales.vPersonDemographics

Collapse image Description

Displays the content from each element in the xml column Demographics for each customer in the Person.Person table.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1101246978

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
TotalPurchaseYTD |  | money | 8
DateFirstPurchase |  | datetime | 8
BirthDate |  | datetime | 8
MaritalStatus |  | nvarchar | 1
YearlyIncome |  | nvarchar | 30
Gender |  | nvarchar | 1
TotalChildren |  | int | 4
NumberChildrenAtHome |  | int | 4
Education |  | nvarchar | 30
Occupation |  | nvarchar | 30
HomeOwnerFlag |  | bit | 1
NumberCarsOwned |  | int | 4
Total: 13 column(s)

Collapse image Objects that Sales.vPersonDemographics depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Person | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Displays the content from each element in the xml column Demographics for each customer in the Person.Person table.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vPersonDemographics]
AS
SELECT
    p.[BusinessEntityID]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        TotalPurchaseYTD[1]', 'money') AS [TotalPurchaseYTD]
    ,CONVERT(datetime, REPLACE([IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        DateFirstPurchase[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [DateFirstPurchase]
    ,CONVERT(datetime, REPLACE([IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        BirthDate[1]', 'nvarchar(20)') ,'Z', ''), 101) AS [BirthDate]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        MaritalStatus[1]', 'nvarchar(1)') AS [MaritalStatus]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        YearlyIncome[1]', 'nvarchar(30)') AS [YearlyIncome]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        Gender[1]', 'nvarchar(1)') AS [Gender]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        TotalChildren[1]', 'integer') AS [TotalChildren]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        NumberChildrenAtHome[1]', 'integer') AS [NumberChildrenAtHome]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        Education[1]', 'nvarchar(30)') AS [Education]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        Occupation[1]', 'nvarchar(30)') AS [Occupation]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        HomeOwnerFlag[1]', 'bit') AS [HomeOwnerFlag]
    ,[IndividualSurvey].[ref].[value](N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
        NumberCarsOwned[1]', 'integer') AS [NumberCarsOwned]
FROM [Person].[Person] p
CROSS APPLY p.[Demographics].nodes(N'declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey";
    /IndividualSurvey') AS [IndividualSurvey](ref)
WHERE [Demographics] IS NOT NULL;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Displays the content from each element in the xml column Demographics for each customer in the Person.Person table.', 'SCHEMA', N'Sales', 'VIEW', N'vPersonDemographics', NULL, NULL
GO

Collapse image See also

List of views


vSalesPerson

View: AdventureWorks2016CTP3.Sales.vSalesPerson

Collapse image Description

Sales representiatives (names and addresses) and their sales-related information.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1213247377

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
JobTitle |  | nvarchar | 50
PhoneNumber |  | Phone | 25
PhoneNumberType |  | Name | 50
EmailAddress |  | nvarchar | 50
EmailPromotion |  | int | 4
AddressLine1 |  | nvarchar | 60
AddressLine2 |  | nvarchar | 60
City |  | nvarchar | 30
StateProvinceName |  | Name | 50
PostalCode |  | nvarchar | 15
CountryRegionName |  | Name | 50
TerritoryName |  | Name | 50
TerritoryGroup |  | nvarchar | 50
SalesQuota |  | money | 8
SalesYTD |  | money | 8
SalesLastYear |  | money | 8
Total: 22 column(s)

Collapse image Objects that Sales.vSalesPerson depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Address | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.CountryRegion | Table | 1
Person.EmailAddress | Table | 1
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritory | Table | 1
Person.StateProvince | Table | 1
Total 12 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Sales representiatives (names and addresses) and their sales-related information.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vSalesPerson]
AS
SELECT
    s.[BusinessEntityID]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,e.[JobTitle]
    ,pp.[PhoneNumber]
    ,pnt.[Name] AS [PhoneNumberType]
    ,ea.[EmailAddress]
    ,p.[EmailPromotion]
    ,a.[AddressLine1]
    ,a.[AddressLine2]
    ,a.[City]
    ,[StateProvinceName] = sp.[Name]
    ,a.[PostalCode]
    ,[CountryRegionName] = cr.[Name]
    ,[TerritoryName] = st.[Name]
    ,[TerritoryGroup] = st.[Group]
    ,s.[SalesQuota]
    ,s.[SalesYTD]
    ,s.[SalesLastYear]
FROM [Sales].[SalesPerson] s
    INNER JOIN [HumanResources].[Employee] e
    ON e.[BusinessEntityID] = s.[BusinessEntityID]
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = s.[BusinessEntityID]
    INNER JOIN [Person].[BusinessEntityAddress] bea
    ON bea.[BusinessEntityID] = s.[BusinessEntityID]
    INNER JOIN [Person].[Address] a
    ON a.[AddressID] = bea.[AddressID]
    INNER JOIN [Person].[StateProvince] sp
    ON sp.[StateProvinceID] = a.[StateProvinceID]
    INNER JOIN [Person].[CountryRegion] cr
    ON cr.[CountryRegionCode] = sp.[CountryRegionCode]
    LEFT OUTER JOIN [Sales].[SalesTerritory] st
    ON st.[TerritoryID] = s.[TerritoryID]
    LEFT OUTER JOIN [Person].[EmailAddress] ea
    ON ea.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PersonPhone] pp
    ON pp.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PhoneNumberType] pnt
    ON pnt.[PhoneNumberTypeID] = pp.[PhoneNumberTypeID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Sales representiatives (names and addresses) and their sales-related information.', 'SCHEMA', N'Sales', 'VIEW', N'vSalesPerson', NULL, NULL
GO

Collapse image See also

List of views


vSalesPersonSalesByFiscalYears

View: AdventureWorks2016CTP3.Sales.vSalesPersonSalesByFiscalYears

CollapseAll image

Collapse image Description

Uses PIVOT to return aggregated sales information for each sales representative.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1229247434

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
SalesPersonID |  | int | 4
FullName |  | nvarchar | 152
JobTitle |  | nvarchar | 50
SalesTerritory |  | Name | 50
2002 |  | money | 8
2003 |  | money | 8
2004 |  | money | 8
Total: 7 column(s)

Collapse image Objects that Sales.vSalesPersonSalesByFiscalYears depends on

Object name | Object type | Dep level
Sales | Schema | 1
HumanResources.Employee | Table | 1
Person.Person | Table | 1
Sales.SalesOrderHeader | Table | 1
Sales.SalesPerson | Table | 1
Sales.SalesTerritory | Table | 1
Total 6 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Uses PIVOT to return aggregated sales information for each sales representative.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vSalesPersonSalesByFiscalYears]
AS
SELECT
    pvt.[SalesPersonID]
    ,pvt.[FullName]
    ,pvt.[JobTitle]
    ,pvt.[SalesTerritory]
    ,pvt.[2002]
    ,pvt.[2003]
    ,pvt.[2004]
FROM (SELECT
        soh.[SalesPersonID]
        ,p.[FirstName] + ' ' + COALESCE(p.[MiddleName], '') + ' ' + p.[LastName] AS [FullName]
        ,e.[JobTitle]
        ,st.[Name] AS [SalesTerritory]
        ,soh.[SubTotal]
        ,YEAR(DATEADD(m, 6, soh.[OrderDate])) AS [FiscalYear]
    FROM [Sales].[SalesPerson] sp
        INNER JOIN [Sales].[SalesOrderHeader] soh
        ON sp.[BusinessEntityID] = soh.[SalesPersonID]
        INNER JOIN [Sales].[SalesTerritory] st
        ON sp.[TerritoryID] = st.[TerritoryID]
        INNER JOIN [HumanResources].[Employee] e
        ON soh.[SalesPersonID] = e.[BusinessEntityID]
        INNER JOIN [Person].[Person] p
        ON p.[BusinessEntityID] = sp.[BusinessEntityID]
     ) AS soh
PIVOT
(
    SUM([SubTotal])
    FOR [FiscalYear]
    IN ([2002], [2003], [2004])
) AS pvt;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Uses PIVOT to return aggregated sales information for each sales representative.', 'SCHEMA', N'Sales', 'VIEW', N'vSalesPersonSalesByFiscalYears', NULL, NULL
GO

Collapse image See also

List of views


vStoreWithAddresses

View: AdventureWorks2016CTP3.Sales.vStoreWithAddresses

Collapse image Description

Stores (including store addresses) that sell Adventure Works Cycles products to consumers.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1293247662

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Name |  | Name | 50
AddressType |  | Name | 50
AddressLine1 |  | nvarchar | 60
AddressLine2 |  | nvarchar | 60
City |  | nvarchar | 30
StateProvinceName |  | Name | 50
PostalCode |  | nvarchar | 15
CountryRegionName |  | Name | 50
Total: 9 column(s)

Collapse image Objects that Sales.vStoreWithAddresses depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.Address | Table | 1
Person.AddressType | Table | 1
Person.BusinessEntityAddress | Table | 1
Person.CountryRegion | Table | 1
Person.StateProvince | Table | 1
Sales.Store | Table | 1
Total 7 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stores (including store addresses) that sell Adventure Works Cycles products to consumers.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vStoreWithAddresses] AS
SELECT
    s.[BusinessEntityID]
    ,s.[Name]
    ,at.[Name] AS [AddressType]
    ,a.[AddressLine1]
    ,a.[AddressLine2]
    ,a.[City]
    ,sp.[Name] AS [StateProvinceName]
    ,a.[PostalCode]
    ,cr.[Name] AS [CountryRegionName]
FROM [Sales].[Store] s
    INNER JOIN [Person].[BusinessEntityAddress] bea
    ON bea.[BusinessEntityID] = s.[BusinessEntityID]
    INNER JOIN [Person].[Address] a
    ON a.[AddressID] = bea.[AddressID]
    INNER JOIN [Person].[StateProvince] sp
    ON sp.[StateProvinceID] = a.[StateProvinceID]
    INNER JOIN [Person].[CountryRegion] cr
    ON cr.[CountryRegionCode] = sp.[CountryRegionCode]
    INNER JOIN [Person].[AddressType] at
    ON at.[AddressTypeID] = bea.[AddressTypeID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stores (including store addresses) that sell Adventure Works Cycles products to consumers.', 'SCHEMA', N'Sales', 'VIEW', N'vStoreWithAddresses', NULL, NULL
GO

Collapse image See also

List of views


vStoreWithContacts

View: AdventureWorks2016CTP3.Sales.vStoreWithContacts

Collapse image Description

Stores (including store contacts) that sell Adventure Works Cycles products to consumers.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1277247605

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Name |  | Name | 50
ContactType |  | Name | 50
Title |  | nvarchar | 8
FirstName |  | Name | 50
MiddleName |  | Name | 50
LastName |  | Name | 50
Suffix |  | nvarchar | 10
PhoneNumber |  | Phone | 25
PhoneNumberType |  | Name | 50
EmailAddress |  | nvarchar | 50
EmailPromotion |  | int | 4
Total: 12 column(s)

Collapse image Objects that Sales.vStoreWithContacts depends on

Object name | Object type | Dep level
Sales | Schema | 1
Person.BusinessEntityContact | Table | 1
Person.ContactType | Table | 1
Person.EmailAddress | Table | 1
Person.Person | Table | 1
Person.PersonPhone | Table | 1
Person.PhoneNumberType | Table | 1
Sales.Store | Table | 1
Total 8 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stores (including store contacts) that sell Adventure Works Cycles products to consumers.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vStoreWithContacts] AS
SELECT
    s.[BusinessEntityID]
    ,s.[Name]
    ,ct.[Name] AS [ContactType]
    ,p.[Title]
    ,p.[FirstName]
    ,p.[MiddleName]
    ,p.[LastName]
    ,p.[Suffix]
    ,pp.[PhoneNumber]
    ,pnt.[Name] AS [PhoneNumberType]
    ,ea.[EmailAddress]
    ,p.[EmailPromotion]
FROM [Sales].[Store] s
    INNER JOIN [Person].[BusinessEntityContact] bec
    ON bec.[BusinessEntityID] = s.[BusinessEntityID]
    INNER JOIN [Person].[ContactType] ct
    ON ct.[ContactTypeID] = bec.[ContactTypeID]
    INNER JOIN [Person].[Person] p
    ON p.[BusinessEntityID] = bec.[PersonID]
    LEFT OUTER JOIN [Person].[EmailAddress] ea
    ON ea.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PersonPhone] pp
    ON pp.[BusinessEntityID] = p.[BusinessEntityID]
    LEFT OUTER JOIN [Person].[PhoneNumberType] pnt
    ON pnt.[PhoneNumberTypeID] = pp.[PhoneNumberTypeID];
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stores (including store contacts) that sell Adventure Works Cycles products to consumers.', 'SCHEMA', N'Sales', 'VIEW', N'vStoreWithContacts', NULL, NULL
GO

Collapse image See also

List of views


vStoreWithDemographics

View: AdventureWorks2016CTP3.Sales.vStoreWithDemographics

Collapse image Description

Stores (including demographics) that sell Adventure Works Cycles products to consumers.

Collapse image View properties

Name | Value
Schema | Sales
Owner | dbo
Creation date | 16.11.2015
Is schema bound |
Encrypted |
ID | 1261247548

Collapse image Creation options

Name | Value
QUOTED_IDENTIFIER | ON
ANSI_NULLS | ON

Collapse image Resultset

Name | Description | Data type | Max length
BusinessEntityID |  | int | 4
Name |  | Name | 50
AnnualSales |  | money | 8
AnnualRevenue |  | money | 8
BankName |  | nvarchar | 50
BusinessType |  | nvarchar | 5
YearOpened |  | int | 4
Specialty |  | nvarchar | 50
SquareFeet |  | int | 4
Brands |  | nvarchar | 30
Internet |  | nvarchar | 30
NumberEmployees |  | int | 4
Total: 12 column(s)

Collapse image Objects that Sales.vStoreWithDemographics depends on

Object name | Object type | Dep level
Sales | Schema | 1
Sales.Store | Table | 1
Total 2 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Stores (including demographics) that sell Adventure Works Cycles products to consumers.

Collapse image SQL

SET ANSI_NULLS ON
SET QUOTED_IDENTIFIER ON
GO

CREATE VIEW [Sales].[vStoreWithDemographics] AS
SELECT
    s.[BusinessEntityID]
    ,s.[Name]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/AnnualSales)[1]', 'money') AS [AnnualSales]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/AnnualRevenue)[1]', 'money') AS [AnnualRevenue]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/BankName)[1]', 'nvarchar(50)') AS [BankName]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/BusinessType)[1]', 'nvarchar(5)') AS [BusinessType]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/YearOpened)[1]', 'integer') AS [YearOpened]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/Specialty)[1]', 'nvarchar(50)') AS [Specialty]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/SquareFeet)[1]', 'integer') AS [SquareFeet]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/Brands)[1]', 'nvarchar(30)') AS [Brands]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/Internet)[1]', 'nvarchar(30)') AS [Internet]
    ,s.[Demographics].value('declare default element namespace "http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey";
        (/StoreSurvey/NumberEmployees)[1]', 'integer') AS [NumberEmployees]
FROM [Sales].[Store] s;
GO
EXEC sp_addextendedproperty N'MS_Description', N'Stores (including demographics) that sell Adventure Works Cycles products to consumers.', 'SCHEMA', N'Sales', 'VIEW', N'vStoreWithDemographics', NULL, NULL
GO

Collapse image See also

List of views


XML schema collections

List of XML schema collections

Collapse image XML schema collections

Name | Schema | Description
HRResumeSchemaCollection | HumanResources | Collection of XML schemas for the Resume column in the HumanResources.JobCandidate table.
AdditionalContactInfoSchemaCollection | Person | Collection of XML schemas for the AdditionalContactInfo column in the Person.Contact table.
IndividualSurveySchemaCollection | Person | Collection of XML schemas for the Demographics column in the Person.Person table.
ManuInstructionsSchemaCollection | Production | Collection of XML schemas for the Instructions column in the Production.ProductModel table.
ProductDescriptionSchemaCollection | Production | Collection of XML schemas for the CatalogDescription column in the Production.ProductModel table.
StoreSurveySchemaCollection | Sales | Collection of XML schemas for the Demographics column in the Sales.Store table.
Total: 6 XML schema collection(s)

Collapse image See also

Database overview


HRResumeSchemaCollection

XML schema collection: AdventureWorks2016CTP3.HumanResources.HRResumeSchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the Resume column in the HumanResources.JobCandidate table.

Collapse image XML schema collection properties

Name | Value
Schema | HumanResources
Owner | dbo
ID | 65538

Collapse image Objects that depend on HumanResources.HRResumeSchemaCollection

Object name | Object type | Dep level
HumanResources.JobCandidate | Table | 1
Total 1 object(s)

Collapse image Objects that HumanResources.HRResumeSchemaCollection depends on

Object name | Object type | Dep level
HumanResources | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the Resume column in the HumanResources.JobCandidate table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [HumanResources].[HRResumeSchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume"
     targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/Resume" elementFormDefault="qualified"><xsd:element
     name="Address" type="t:AddressType" /><xsd:element name="Education" type="t:EducationType" /><xsd:element name="Employment" type="t:EmploymentType"
     /><xsd:element name="Location" type="t:LocationType" /><xsd:element name="Name" type="t:NameType" /><xsd:element name="Resume"
     type="t:ResumeType" /><xsd:element name="Telephone" type="t:TelephoneType" /><xsd:complexType name="AddressType"><xsd:complexContent><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element name="Addr.Type" type="xsd:string" /><xsd:element name="Addr.OrgName" type="xsd:string"
     minOccurs="0" /><xsd:element name="Addr.Street" type="xsd:string" maxOccurs="unbounded" /><xsd:element name="Addr.Location"><xsd:co
    mplexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element ref="t:Location" /></xsd:sequence></xsd:rest
    riction></xsd:complexContent></xsd:complexType></xsd:element><xsd:element name="Addr.PostalCode" type="xsd:string" /><xsd:element
     name="Addr.Telephone" minOccurs="0"><xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element
     ref="t:Telephone" maxOccurs="unbounded" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:sequence></
    xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="EducationType"><xsd:complexContent><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element name="Edu.Level" type="xsd:string" /><xsd:element name="Edu.StartDate" type="xsd:date" /><xsd:element
     name="Edu.EndDate" type="xsd:date" /><xsd:element name="Edu.Degree" type="xsd:string" minOccurs="0" /><xsd:element name="Edu.Major"
     type="xsd:string" minOccurs="0" /><xsd:element name="Edu.Minor" type="xsd:string" minOccurs="0" /><xsd:element name="Edu.GPA" type="xsd:string"
     minOccurs="0" /><xsd:element name="Edu.GPAAlternate" type="xsd:decimal" minOccurs="0" /><xsd:element name="Edu.GPAScale" type="xsd:decimal"
     minOccurs="0" /><xsd:element name="Edu.School" type="xsd:string" minOccurs="0" /><xsd:element name="Edu.Location" minOccurs="0">
    <xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element ref="t:Location" /></xsd:sequence></x
    sd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexTy
    pe><xsd:complexType name="EmploymentType"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Emp.StartDate"
     type="xsd:date" minOccurs="0" /><xsd:element name="Emp.EndDate" type="xsd:date" minOccurs="0" /><xsd:element name="Emp.OrgName"
     type="xsd:string" /><xsd:element name="Emp.JobTitle" type="xsd:string" /><xsd:element name="Emp.Responsibility" type="xsd:string"
     /><xsd:element name="Emp.FunctionCategory" type="xsd:string" minOccurs="0" /><xsd:element name="Emp.IndustryCategory" type="xsd:string"
     minOccurs="0" /><xsd:element name="Emp.Location" minOccurs="0"><xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequ
    ence><xsd:element ref="t:Location" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:sequence
    ></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="LocationType"><xsd:complexContent><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element name="Loc.CountryRegion" type="xsd:string" /><xsd:element name="Loc.State" type="xsd:string"
     minOccurs="0" /><xsd:element name="Loc.City" type="xsd:string" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:c
    omplexType><xsd:complexType name="NameType"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Name.Prefix"
     type="xsd:string" minOccurs="0" /><xsd:element name="Name.First" type="xsd:string" /><xsd:element name="Name.Middle" type="xsd:string"
     minOccurs="0" /><xsd:element name="Name.Last" type="xsd:string" /><xsd:element name="Name.Suffix" type="xsd:string" minOccurs="0"
     /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="ResumeType"><xsd:complexContent><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element ref="t:Name" /><xsd:element name="Skills" type="xsd:string" minOccurs="0"
     /><xsd:element ref="t:Employment" maxOccurs="unbounded" /><xsd:element ref="t:Education" maxOccurs="unbounded" /><xsd:element ref="t:Address"
     maxOccurs="unbounded" /><xsd:element ref="t:Telephone" minOccurs="0" /><xsd:element name="EMail" type="xsd:string" minOccurs="0" /><xsd:element
     name="WebSite" type="xsd:string" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType
     name="TelephoneType"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Tel.Type" type="xsd:anyType"
     minOccurs="0" /><xsd:element name="Tel.IntlCode" type="xsd:int" minOccurs="0" /><xsd:element name="Tel.AreaCode" type="xsd:int"
     minOccurs="0" /><xsd:element name="Tel.Number" type="xsd:string" /><xsd:element name="Tel.Extension" type="xsd:int" minOccurs="0"
     /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:schema>'
GO
EXEC sp_addextendedproperty N'MS_Description',
     N'Collection of XML schemas for the Resume column in the HumanResources.JobCandidate table.', 'SCHEMA', N'HumanResources', 'XML SCHEMA
     COLLECTION', N'HRResumeSchemaCollection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


AdditionalContactInfoSchemaCollection

XML schema collection: AdventureWorks2016CTP3.Person.AdditionalContactInfoSchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the AdditionalContactInfo column in the Person.Contact table.

Collapse image XML schema collection properties

Name | Value
Schema | Person
Owner | dbo
ID | 65536

Collapse image Objects that depend on Person.AdditionalContactInfoSchemaCollection

Object name | Object type | Dep level
Person.Person | Table | 1
Total 1 object(s)

Collapse image Objects that Person.AdditionalContactInfoSchemaCollection depends on

Object name | Object type | Dep level
Person | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the AdditionalContactInfo column in the Person.Contact table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [Person].[AdditionalContactInfoSchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo"
     targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactInfo"><xsd:element name="AdditionalContactInf
    o"><xsd:complexType mixed="true"><xsd:complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:any namespace="h
    ttp://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactRecord http://schemas.microsoft.com/sqlserver/2004/07/adventure-work
    s/ContactTypes" minOccurs="0" maxOccurs="unbounded" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:eleme
    nt></xsd:schema><xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventur
    e-works/ContactRecord" targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactRecord"><xsd:element
     name="ContactRecord"><xsd:complexType mixed="true"><xsd:complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:choice minOccurs="0"
     maxOccurs="unbounded"><xsd:any namespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes" /></xsd:choice>
    <xsd:attribute name="date" type="xsd:date" /></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:schema><xsd:schema
     xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes"
     targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes" elementFormDefault="qualified"><xsd:element
     name="eMail" type="t:eMailType" /><xsd:element name="facsimileTelephoneNumber" type="t:phoneNumberType" /><xsd:element name="homePostalAddress"
     type="t:addressType" /><xsd:element name="internationaliSDNNumber" type="t:phoneNumberType" /><xsd:element name="mobile" type="t:ph
    oneNumberType" /><xsd:element name="pager" type="t:phoneNumberType" /><xsd:element name="physicalDeliveryOfficeName" type="t:addressType"
     /><xsd:element name="registeredAddress" type="t:addressType" /><xsd:element name="telephoneNumber" type="t:phoneNumberType" /><xsd:element
     name="telexNumber" type="t:phoneNumberType" /><xsd:complexType name="addressType"><xsd:complexContent><xsd:restriction base="xsd:anyTy
    pe"><xsd:sequence><xsd:element name="Street" type="xsd:string" maxOccurs="2" /><xsd:element name="City" type="xsd:string" /><xsd:element
     name="StateProvince" type="xsd:string" /><xsd:element name="PostalCode" type="xsd:string" minOccurs="0" /><xsd:element name="CountryRegion"
     type="xsd:string" /><xsd:element name="SpecialInstructions" type="t:specialInstructionsType" minOccurs="0" /></xsd:sequence></xsd:rest
    riction></xsd:complexContent></xsd:complexType><xsd:complexType name="eMailType"><xsd:complexContent><xsd:restriction base="xsd:anyType">
    <xsd:sequence><xsd:element name="eMailAddress" type="xsd:string" /><xsd:element name="SpecialInstructions" type="t:specialInstructionsType"
     minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="phoneNumberType"><xsd:c
    omplexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="number"><xsd:simpleType><xsd:restriction base="xsd:str
    ing"><xsd:pattern value="[0-9\(\)\-]*" /></xsd:restriction></xsd:simpleType></xsd:element><xsd:element name="SpecialInstructions"
     type="t:specialInstructionsType" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType
     name="specialInstructionsType" mixed="true"><xsd:complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:any
     namespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ContactTypes" minOccurs="0" maxOccurs="unbounded" /></xsd:sequence></x
    sd:restriction></xsd:complexContent></xsd:complexType></xsd:schema>'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Collection
     of XML schemas for the AdditionalContactInfo column in the Person.Contact table.', 'SCHEMA', N'Person', 'XML SCHEMA COLLECTION', N'Additiona
    lContactInfoSchemaCollection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


IndividualSurveySchemaCollection

XML schema collection: AdventureWorks2016CTP3.Person.IndividualSurveySchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the Demographics column in the Person.Person table.

Collapse image XML schema collection properties

Name | Value
Schema | Person
Owner | dbo
ID | 65537

Collapse image Objects that depend on Person.IndividualSurveySchemaCollection

Object name | Object type | Dep level
Person.Person | Table | 1
Total 1 object(s)

Collapse image Objects that Person.IndividualSurveySchemaCollection depends on

Object name | Object type | Dep level
Person | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the Demographics column in the Person.Person table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [Person].[IndividualSurveySchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey"
     targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey" elementFormDefault="qualified
    "><xsd:element name="IndividualSurvey"><xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element
     name="TotalPurchaseYTD" type="xsd:decimal" minOccurs="0" /><xsd:element name="DateFirstPurchase" type="xsd:date" minOccurs="0"
     /><xsd:element name="BirthDate" type="xsd:date" minOccurs="0" /><xsd:element name="MaritalStatus" type="xsd:string" minOccurs="0" /><xsd:element
     name="YearlyIncome" type="t:SalaryType" minOccurs="0" /><xsd:element name="Gender" type="xsd:string" minOccurs="0" /><xsd:element
     name="TotalChildren" type="xsd:int" minOccurs="0" /><xsd:element name="NumberChildrenAtHome" type="xsd:int" minOccurs="0" /><xsd:element
     name="Education" type="xsd:string" minOccurs="0" /><xsd:element name="Occupation" type="xsd:string" minOccurs="0" /><xsd:element name="HomeOwnerFlag"
     type="xsd:string" minOccurs="0" /><xsd:element name="NumberCarsOwned" type="xsd:int" minOccurs="0" /><xsd:element name="Hobby"
     type="xsd:string" minOccurs="0" maxOccurs="unbounded" /><xsd:element name="CommuteDistance" type="t:MileRangeType" minOccurs="0" /><xsd:element
     name="Comments" type="xsd:string" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:elemen
    t><xsd:simpleType name="MileRangeType"><xsd:restriction base="xsd:string"><xsd:enumeration value="0-1 Miles" /><xsd:enumeration
     value="1-2 Miles" /><xsd:enumeration value="2-5 Miles" /><xsd:enumeration value="5-10 Miles" /><xsd:enumeration value="10+ Miles" /></xsd:restrict
    ion></xsd:simpleType><xsd:simpleType name="SalaryType"><xsd:restriction base="xsd:string"><xsd:enumeration value="0-25000" /><xsd:enumeration
     value="25001-50000" /><xsd:enumeration value="50001-75000" /><xsd:enumeration value="75001-100000" /><xsd:enumeration value="greater
     than 100000" /></xsd:restriction></xsd:simpleType></xsd:schema>'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Collection
     of XML schemas for the Demographics column in the Person.Person table.', 'SCHEMA', N'Person', 'XML SCHEMA COLLECTION', N'IndividualSurveySchema
    Collection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


ManuInstructionsSchemaCollection

XML schema collection: AdventureWorks2016CTP3.Production.ManuInstructionsSchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the Instructions column in the Production.ProductModel table.

Collapse image XML schema collection properties

Name | Value
Schema | Production
Owner | dbo
ID | 65540

Collapse image Objects that depend on Production.ManuInstructionsSchemaCollection

Object name | Object type | Dep level
Production.ProductModel | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ManuInstructionsSchemaCollection depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the Instructions column in the Production.ProductModel table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [Production].[ManuInstructionsSchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductM
    odelManuInstructions" targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelManuInstructions"
     elementFormDefault="qualified"><xsd:element name="root"><xsd:complexType mixed="true"><xsd:complexContent mixed="true"><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element name="Location" maxOccurs="unbounded"><xsd:complexType mixed="true"><xsd:complexContent
     mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="step" type="t:StepType" maxOccurs="unbounded" /></xsd:sequence><
    xsd:attribute name="LocationID" type="xsd:integer" use="required" /><xsd:attribute name="SetupHours" type="xsd:decimal" /><xsd:attribute
     name="MachineHours" type="xsd:decimal" /><xsd:attribute name="LaborHours" type="xsd:decimal" /><xsd:attribute name="LotSize" type="xsd:decimal"
     /></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:sequence></xsd:restriction></xsd:complexContent></x
    sd:complexType></xsd:element><xsd:complexType name="StepType" mixed="true"><xsd:complexContent mixed="true"><xsd:restriction base="xsd:an
    yType"><xsd:choice minOccurs="0" maxOccurs="unbounded"><xsd:element name="tool" type="xsd:string" /><xsd:element name="material"
     type="xsd:string" /><xsd:element name="blueprint" type="xsd:string" /><xsd:element name="specs" type="xsd:string" /><xsd:element name="diag"
     type="xsd:string" /></xsd:choice></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:schema>'
GO
EXEC sp_addextendedproperty
     N'MS_Description', N'Collection of XML schemas for the Instructions column in the Production.ProductModel table.', 'SCHEMA', N'Production',
     'XML SCHEMA COLLECTION', N'ManuInstructionsSchemaCollection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


ProductDescriptionSchemaCollection

XML schema collection: AdventureWorks2016CTP3.Production.ProductDescriptionSchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the CatalogDescription column in the Production.ProductModel table.

Collapse image XML schema collection properties

Name | Value
Schema | Production
Owner | dbo
ID | 65539

Collapse image Objects that depend on Production.ProductDescriptionSchemaCollection

Object name | Object type | Dep level
Production.ProductModel | Table | 1
Total 1 object(s)

Collapse image Objects that Production.ProductDescriptionSchemaCollection depends on

Object name | Object type | Dep level
Production | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the CatalogDescription column in the Production.ProductModel table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [Production].[ProductDescriptionSchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductM
    odelWarrAndMain" targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain" elementFormDefa
    ult="qualified"><xsd:element name="Maintenance"><xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element
     name="NoOfYears" type="xsd:string" /><xsd:element name="Description" type="xsd:string" /></xsd:sequence></xsd:restriction></xs
    d:complexContent></xsd:complexType></xsd:element><xsd:element name="Warranty"><xsd:complexType><xsd:complexContent><xsd:restriction
     base="xsd:anyType"><xsd:sequence><xsd:element name="WarrantyPeriod" type="xsd:string" /><xsd:element name="Description" type="xsd:string"
     /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element></xsd:schema><xsd:schema xmlns:xsd="http://www.w3.org
    /2001/XMLSchema" xmlns:ns1="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelWarrAndMain" xmlns:t="http://schem
    as.microsoft.com/sqlserver/2004/07/adventure-works/ProductModelDescription" targetNamespace="http://schemas.microsoft.com/sqlserver/2004/
    07/adventure-works/ProductModelDescription" elementFormDefault="qualified"><xsd:import namespace="http://schemas.microsoft.com/sqlserver/
    2004/07/adventure-works/ProductModelWarrAndMain" /><xsd:element name="Code" type="xsd:string" /><xsd:element name="Description"
     type="xsd:string" /><xsd:element name="ProductDescription" type="t:ProductDescription" /><xsd:element name="Taxonomy" type="xsd:string" /><xsd:complexType
     name="Category"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element ref="t:Taxonomy" /><xsd:element
     ref="t:Code" /><xsd:element ref="t:Description" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexTyp
    e><xsd:complexType name="Features" mixed="true"><xsd:complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element
     ref="ns1:Warranty" /><xsd:element ref="ns1:Maintenance" /><xsd:any namespace="##other" processContents="skip" minOccurs="0"
     maxOccurs="unbounded" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="Manufacturer"><xsd:compl
    exContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Name" type="xsd:string" minOccurs="0" /><xsd:element
     name="CopyrightURL" type="xsd:string" minOccurs="0" /><xsd:element name="Copyright" type="xsd:string" minOccurs="0" /><xsd:element name="ProductURL"
     type="xsd:string" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType
     name="Picture"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Name" type="xsd:string" minOccurs="0"
     /><xsd:element name="Angle" type="xsd:string" minOccurs="0" /><xsd:element name="Size" type="xsd:string" minOccurs="0" /><xsd:element
     name="ProductPhotoID" type="xsd:integer" minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType
     name="ProductDescription"><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="Summary"
     type="t:Summary" minOccurs="0" /><xsd:element name="Manufacturer" type="t:Manufacturer" minOccurs="0" /><xsd:element name="Features" type="t:Features"
     minOccurs="0" maxOccurs="unbounded" /><xsd:element name="Picture" type="t:Picture" minOccurs="0" maxOccurs="unbounded" /><xsd:element
     name="Category" type="t:Category" minOccurs="0" maxOccurs="unbounded" /><xsd:element name="Specifications" type="t:Specifications"
     minOccurs="0" maxOccurs="unbounded" /></xsd:sequence><xsd:attribute name="ProductModelID" type="xsd:string" /><xsd:attribute name="ProductModelName"
     type="xsd:string" /></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="Specifications" mixed="true">
    <xsd:complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:any processContents="skip" minOccurs="0"
     maxOccurs="unbounded" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType><xsd:complexType name="Summary" mixed="true"><xsd
    :complexContent mixed="true"><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:any namespace="http://www.w3.org/1999/xhtml"
     processContents="skip" minOccurs="0" maxOccurs="unbounded" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:schema
    >'
GO
EXEC sp_addextendedproperty N'MS_Description', N'Collection of XML schemas for the CatalogDescription column in the Production.ProductModel
     table.', 'SCHEMA', N'Production', 'XML SCHEMA COLLECTION', N'ProductDescriptionSchemaCollection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


StoreSurveySchemaCollection

XML schema collection: AdventureWorks2016CTP3.Sales.StoreSurveySchemaCollection

CollapseAll image

Collapse image Description

Collection of XML schemas for the Demographics column in the Sales.Store table.

Collapse image XML schema collection properties

Name | Value
Schema | Sales
Owner | dbo
ID | 65541

Collapse image Objects that depend on Sales.StoreSurveySchemaCollection

Object name | Object type | Dep level
Sales.Store | Table | 1
Total 1 object(s)

Collapse image Objects that Sales.StoreSurveySchemaCollection depends on

Object name | Object type | Dep level
Sales | Schema | 1
Total 1 object(s)

Collapse image Extended properties

Name | Value
MS_Description | Collection of XML schemas for the Demographics column in the Sales.Store table.

Collapse image SQL

CREATE XML SCHEMA COLLECTION [Sales].[StoreSurveySchemaCollection] AS
N'<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:t="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey"
     targetNamespace="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/StoreSurvey" elementFormDefault="qualified"><xsd:element
     name="StoreSurvey"><xsd:complexType><xsd:complexContent><xsd:restriction base="xsd:anyType"><xsd:sequence><xsd:element name="ContactName"
     type="xsd:string" minOccurs="0" /><xsd:element name="JobTitle" type="xsd:string" minOccurs="0" /><xsd:element name="AnnualSales"
     type="xsd:decimal" minOccurs="0" /><xsd:element name="AnnualRevenue" type="xsd:decimal" minOccurs="0" /><xsd:element name="BankName"
     type="xsd:string" minOccurs="0" /><xsd:element name="BusinessType" type="t:BusinessType" minOccurs="0" /><xsd:element name="YearOpened"
     type="xsd:gYear" minOccurs="0" /><xsd:element name="Specialty" type="t:SpecialtyType" minOccurs="0" /><xsd:element name="SquareFeet" type="xsd:float"
     minOccurs="0" /><xsd:element name="Brands" type="t:BrandType" minOccurs="0" /><xsd:element name="Internet" type="t:InternetType"
     minOccurs="0" /><xsd:element name="NumberEmployees" type="xsd:int" minOccurs="0" /><xsd:element name="Comments" type="xsd:string"
     minOccurs="0" /></xsd:sequence></xsd:restriction></xsd:complexContent></xsd:complexType></xsd:element><xsd:simpleType name="BrandType"><xsd:restriction
     base="xsd:string"><xsd:enumeration value="AW" /><xsd:enumeration value="2" /><xsd:enumeration value="3" /><xsd:enumeration
     value="4+" /></xsd:restriction></xsd:simpleType><xsd:simpleType name="BusinessType"><xsd:restriction base="xsd:string"><xsd:enumeration
     value="BM" /><xsd:enumeration value="BS" /><xsd:enumeration value="D" /><xsd:enumeration value="OS" /><xsd:enumeration value="SGS" /></xsd:restric
    tion></xsd:simpleType><xsd:simpleType name="InternetType"><xsd:restriction base="xsd:string"><xsd:enumeration value="56kb" /><xsd:enumeration
     value="ISDN" /><xsd:enumeration value="DSL" /><xsd:enumeration value="T1" /><xsd:enumeration value="T2" /><xsd:enumeration
     value="T3" /></xsd:restriction></xsd:simpleType><xsd:simpleType name="SpecialtyType"><xsd:restriction base="xsd:string"><xsd:enumeration
     value="Family" /><xsd:enumeration value="Kids" /><xsd:enumeration value="BMX" /><xsd:enumeration value="Touring" /><xsd:enumeration value="Road"
     /><xsd:enumeration value="Mountain" /><xsd:enumeration value="All" /></xsd:restriction></xsd:simpleType></xsd:schema>'
GO
EXEC
     sp_addextendedproperty N'MS_Description', N'Collection of XML schemas for the Demographics column in the Sales.Store table.', 'SCHEMA', N'Sales',
     'XML SCHEMA COLLECTION', N'StoreSurveySchemaCollection', NULL, NULL
GO

Collapse image See also

List of XML schema collections


Shemas Index

AdventureWorks2016CTP3

Collapse image Shemas

Name | Type
dbo | Schema
Sales | Schema
Security | Schema
Demo | Schema
HumanResources | Schema
Person | Schema
SQLCop | Schema
Production | Schema
Purchasing | Schema

Collapse image See also

Database overview


Schema: 'dbo'

AdventureWorks2016CTP3

Collapse image Schema: 'dbo'

Objects | Total
Datatypes | 6
Functions | 19
Procedures | 19
Tables | 6
Triggers | 7
Views | 2

Collapse image See also

Database overview


List of datatypes

Collapse image Datatypes

Name | Schema | Description | Storage type | Allow nulls | Rule | Default
AccountNumber | dbo |  | nvarchar |  |  |
Flag | dbo |  | bit |  |  |
Name | dbo |  | nvarchar |  |  |
NameStyle | dbo |  | bit |  |  |
OrderNumber | dbo |  | nvarchar |  |  |
Phone | dbo |  | nvarchar |  |  |
Total: 6 datatype(s)

Collapse image See also

Rules

Database overview


Functions

List of functions

Collapse image Functions

Name | Schema | Description | Type | Schema bound | Deterministic | Encrypted | Creation date
AUDIT_fn_HexToStr | dbo |  | Scalar |  |  |  | 21.09.2016
AUDIT_fn_SqlVariantToString | dbo |  | Scalar |  |  |  | 21.09.2016
ufnGetAccountingEndDate | dbo | Scalar function used in the uSalesOrderHeader trigger to set the starting account date. | Scalar |  |  |  | 16.11.2015
ufnGetAccountingEndDate_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetAccountingStartDate | dbo | Scalar function used in the uSalesOrderHeader trigger to set the ending account date. | Scalar |  |  |  | 16.11.2015
ufnGetAccountingStartDate_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetContactInformation | dbo | Table value function returning the first name, last name, job title and contact type for a given contact. | Table |  |  |  | 16.11.2015
ufnGetDocumentStatusText | dbo | Scalar function returning the text representation of the Status column in the Document table. | Scalar |  |  |  | 16.11.2015
ufnGetDocumentStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetProductDealerPrice | dbo | Scalar function returning the dealer price for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetProductListPrice | dbo | Scalar function returning the list price for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetProductStandardCost | dbo | Scalar function returning the standard cost for a given product on a particular order date. | Scalar |  |  |  | 16.11.2015
ufnGetPurchaseOrderStatusText | dbo | Scalar function returning the text representation of the Status column in the PurchaseOrderHeader table. | Scalar |  |  |  | 16.11.2015
ufnGetPurchaseOrderStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetSalesOrderStatusText | dbo | Scalar function returning the text representation of the Status column in the SalesOrderHeader table. | Scalar |  |  |  | 16.11.2015
ufnGetSalesOrderStatusText_native | dbo |  | Scalar |  |  |  | 23.10.2015
ufnGetStock | dbo | Scalar function returning the quantity of inventory in LocationID 6 (Miscellaneous Storage)for a specified ProductID. | Scalar |  |  |  | 16.11.2015
ufnLeadingZeros | dbo | Scalar function used by the Sales.Customer table to help set the account number. | Scalar |  |  |  | 23.10.2015
ufnLeadingZeros_native | dbo |  | Scalar |  |  |  | 23.10.2015
Total: 19 Function(s)

Collapse image See also

Procedures

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
AUDIT_prc_AggregateReport | dbo |  | 10 | 0 |  | 21.09.2016
AUDIT_prc_Analyze | dbo |  | 0 | 10 |  | 21.09.2016
AUDIT_prc_DDLReport | dbo |  | 6 | 0 |  | 21.09.2016
AUDIT_prc_DeleteArchitecture | dbo |  | 1 | 0 |  | 21.09.2016
AUDIT_prc_Purge_AUDIT_LOG | dbo |  | 4 | 0 |  | 21.09.2016
AUDIT_prc_ReportingAddFilterValue | dbo |  | 2 | 0 |  | 21.09.2016
AUDIT_prc_ReportingEnd | dbo |  | 0 | 0 |  | 21.09.2016
AUDIT_prc_ReportingStart | dbo |  | 0 | 0 |  | 21.09.2016
AUDIT_prc_StandardReport | dbo |  | 6 | 0 |  | 21.09.2016
uspAddOrderTrackingEvent | dbo |  | 3 | 0 |  | 16.11.2015
uspGetBillOfMaterials | dbo | Stored procedure using a recursive query to return a multi-level bill of material for the specified ProductID. | 2 | 0 |  | 16.11.2015
uspGetEmployeeManagers | dbo | Stored procedure using a recursive query to return the direct and indirect managers of the specified employee. | 1 | 0 |  | 16.11.2015
uspGetManagerEmployees | dbo | Stored procedure using a recursive query to return the direct and indirect employees of the specified manager. | 1 | 0 |  | 16.11.2015
uspGetOrderTrackingBySalesOrderID | dbo |  | 1 | 0 |  | 16.11.2015
uspGetOrderTrackingByTrackingNumber | dbo |  | 1 | 0 |  | 16.11.2015
uspGetWhereUsedProductID | dbo | Stored procedure using a recursive query to return all components or assemblies that directly or indirectly use the specified ProductID. | 2 | 0 |  | 16.11.2015
uspLogError | dbo | Logs error information in the ErrorLog table about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without inserting error information. | 0 | 1 |  | 23.10.2015
uspPrintError | dbo | Prints error information about the error that caused execution to jump to the CATCH block of a TRY...CATCH construct. Should be executed from within the scope of a CATCH block otherwise it will return without printing any error information. | 0 | 0 |  | 23.10.2015
uspSearchCandidateResumes | dbo |  | 4 | 0 |  | 16.11.2015
Total: 19 procedure(s)

Collapse image See also

Functions

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
AUDIT_LOG_DATA | dbo |  | 0 KB | 0 KB | 21.09.2016 | 15 | 0
AUDIT_LOG_DDL | dbo |  | 312 KB | 32 KB | 21.09.2016 | 13 | 714
AUDIT_LOG_TRANSACTIONS | dbo |  | 0 KB | 0 KB | 21.09.2016 | 11 | 0
AWBuildVersion | dbo | Current version number of the AdventureWorks 2014 sample database. | 8 KB | 8 KB | 23.10.2015 | 6 | 1
DatabaseLog | dbo | Audit table tracking all DDL changes made to the AdventureWorks database. Data is captured by the database trigger ddlDatabaseTriggerLog. | 808 KB | 24 KB | 23.10.2015 | 8 | 179
ErrorLog | dbo | Audit table tracking errors in the the AdventureWorks database that are caught by the CATCH block of a TRY...CATCH construct. Data is inserted by stored procedure dbo.uspLogError when it is executed from inside the CATCH block of a TRY...CATCH construct. | 0 KB | 0 KB | 23.10.2015 | 9 | 0
Total: 6 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
tr_d_AUDIT_AWBuildVersion | dbo |  |  |  |  | For Delete | AWBuildVersion
tr_d_AUDIT_DatabaseLog | dbo |  |  |  |  | For Delete | DatabaseLog
tr_d_AUDIT_ErrorLog | dbo |  |  |  |  | For Delete | ErrorLog
tr_i_AUDIT_DatabaseLog | dbo |  |  | For Insert |  |  | DatabaseLog
tr_i_AUDIT_ErrorLog | dbo |  |  | For Insert |  |  | ErrorLog
tr_u_AUDIT_AWBuildVersion | dbo |  |  |  | For Update |  | AWBuildVersion
tr_u_AUDIT_DatabaseLog | dbo |  |  |  | For Update |  | DatabaseLog
Total: 7 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
AUDIT_UNDO | dbo |  |  |  | 21.09.2016
AUDIT_VIEW | dbo |  |  |  | 21.09.2016
Total: 2 view(s)

Collapse image See also

Tables

Database overview


Schema: 'Sales'

AdventureWorks2016CTP3

Collapse image Schema: 'Sales'

Objects | Total
Datatypes | 2
Functions | 2
Procedures | 5
Tables | 31
Triggers | 2
Views | 7
XML schema collections | 1

Collapse image See also

Database overview


List of datatypes

Collapse image Datatypes

Name | Schema | Description | Storage type | Allow nulls | Rule | Default
SalesOrderDetailType_inmem | Sales |  | table type |  |  |
SalesOrderDetailType_ondisk | Sales |  | table type |  |  |
Total: 2 datatype(s)

Collapse image See also

Rules

Database overview


Functions

List of functions

Collapse image Functions

Name | Schema | Description | Type | Schema bound | Deterministic | Encrypted | Creation date
vSalesOrderDetail_extended_inmem | Sales |  | Inline |  |  |  | 23.10.2015
vSalesOrderHeader_extended_inmem | Sales |  | Inline |  |  |  | 23.10.2015
Total: 2 Function(s)

Collapse image See also

Procedures

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
usp_InsertSalesOrder_inmem | Sales |  | 16 | 1 |  | 23.10.2015
usp_InsertSalesOrder_ondisk | Sales |  | 16 | 1 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_inmem | Sales |  | 7 | 0 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_native | Sales |  | 7 | 0 |  | 23.10.2015
usp_UpdateSalesOrderShipInfo_ondisk | Sales |  | 7 | 0 |  | 23.10.2015
Total: 5 procedure(s)

Collapse image See also

Functions

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
CountryRegionCurrency | Sales | Cross-reference table mapping ISO currency codes to a country or region. | 8 KB | 24 KB | 23.10.2015 | 3 | 109
CreditCard | Sales | Customer credit card information. | 1496 KB | 832 KB | 23.10.2015 | 6 | 19118
Currency | Sales | Lookup table containing standard ISO currencies. | 8 KB | 24 KB | 23.10.2015 | 3 | 105
CurrencyRate | Sales | Currency exchange rates. | 768 KB | 440 KB | 23.10.2015 | 7 | 13532
Customer | Sales | Current customer information. Also see the Person and Store tables. | 968 KB | 1328 KB | 23.10.2015 | 7 | 19820
CustomerPII | Sales |  | 7992 KB | 8 KB | 23.10.2015 | 8 | 19118
OrderTracking | Sales | Individual tracking events associated with a specific sales order. | 35352 KB | 19056 KB | 16.11.2015 | 6 | 188790
PersonCreditCard | Sales | Cross-reference table mapping people to their credit card information in the CreditCard table. | 480 KB | 16 KB | 23.10.2015 | 3 | 19118
SalesOrder_json | Sales |  | 5456 KB | 32 KB | 23.10.2015 | 26 | 31465
SalesOrderDetail | Sales | Individual products associated with a specific sales order. See SalesOrderHeader. | 9968 KB | 6776 KB | 23.10.2015 | 11 | 121317
SalesOrderDetail_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 9 | 0
SalesOrderDetail_ondisk | Sales |  | 8432 KB | 2728 KB | 23.10.2015 | 9 | 121317
SalesOrderHeader | Sales | General sales order information. | 5536 KB | 2872 KB | 23.10.2015 | 26 | 31465
SalesOrderHeader_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 23 | 0
SalesOrderHeader_ondisk | Sales |  | 4936 KB | 928 KB | 23.10.2015 | 23 | 31465
SalesOrderHeaderSalesReason | Sales | Cross-reference table mapping sales orders to sales reason codes. | 688 KB | 16 KB | 23.10.2015 | 3 | 27647
SalesPerson | Sales | Sales representative current information. | 8 KB | 24 KB | 23.10.2015 | 9 | 17
SalesPersonQuotaHistory | Sales | Sales performance tracking. | 16 KB | 32 KB | 23.10.2015 | 5 | 163
SalesReason | Sales | Lookup table of customer purchase reasons. | 8 KB | 8 KB | 23.10.2015 | 4 | 10
SalesTaxRate | Sales | Tax rate lookup table. | 8 KB | 40 KB | 23.10.2015 | 7 | 29
SalesTerritory | Sales | Sales territory lookup table. | 8 KB | 40 KB | 23.10.2015 | 10 | 10
SalesTerritoryHistory | Sales | Sales representative transfers to other sales territories. | 8 KB | 24 KB | 23.10.2015 | 6 | 17
ShoppingCartItem | Sales | Contains online customer orders until the order is submitted or cancelled. | 8 KB | 24 KB | 23.10.2015 | 6 | 3
SpecialOffer | Sales | Sale discounts lookup table. | 8 KB | 24 KB | 23.10.2015 | 11 | 16
SpecialOffer_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 10 | 0
SpecialOffer_ondisk | Sales |  | 8 KB | 8 KB | 23.10.2015 | 10 | 16
SpecialOfferProduct | Sales | Cross-reference table mapping products to special offer discounts. | 24 KB | 64 KB | 23.10.2015 | 4 | 538
SpecialOfferProduct_inmem | Sales |  | 0 KB | 0 KB | 23.10.2015 | 3 | 0
SpecialOfferProduct_ondisk | Sales |  | 16 KB | 72 KB | 23.10.2015 | 3 | 538
Store | Sales | Customers (resellers) of Adventure Works products. | 808 KB | 616 KB | 23.10.2015 | 6 | 701
TrackingEvent | Sales | Tracking event lookup table. | 8 KB | 8 KB | 16.11.2015 | 2 | 7
Total: 31 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
iduSalesOrderDetail | Sales | AFTER INSERT, DELETE, UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in SalesOrderDetail and updates the SalesOrderHeader.SubTotal column. |  | For Insert | For Update | For Delete | Sales.SalesOrderDetail
uSalesOrderHeader | Sales | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the SalesOrderHeader table.Updates the SalesYTD column in the SalesPerson and SalesTerritory tables. |  |  | For Update |  | Sales.SalesOrderHeader
Total: 2 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
vIndividualCustomer | Sales | Individual customers (names and addresses) that purchase Adventure Works Cycles products online. |  |  | 16.11.2015
vPersonDemographics | Sales | Displays the content from each element in the xml column Demographics for each customer in the Person.Person table. |  |  | 16.11.2015
vSalesPerson | Sales | Sales representiatives (names and addresses) and their sales-related information. |  |  | 16.11.2015
vSalesPersonSalesByFiscalYears | Sales | Uses PIVOT to return aggregated sales information for each sales representative. |  |  | 16.11.2015
vStoreWithAddresses | Sales | Stores (including store addresses) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
vStoreWithContacts | Sales | Stores (including store contacts) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
vStoreWithDemographics | Sales | Stores (including demographics) that sell Adventure Works Cycles products to consumers. |  |  | 16.11.2015
Total: 7 view(s)

Collapse image See also

Tables

Database overview


XML schema collections

List of XML schema collections

Collapse image XML schema collections

Name | Schema | Description
StoreSurveySchemaCollection | Sales | Collection of XML schemas for the Demographics column in the Sales.Store table.
Total: 1 XML schema collection(s)

Collapse image See also

Database overview


Schema: 'Security'

AdventureWorks2016CTP3

Collapse image Schema: 'Security'

Objects | Total
Functions | 1

Collapse image See also

Database overview


Functions

List of functions

Collapse image Functions

Name | Schema | Description | Type | Schema bound | Deterministic | Encrypted | Creation date
customerAccessPredicate | Security |  | Inline |  |  |  | 23.10.2015
Total: 1 Function(s)

Collapse image See also

Procedures

Database overview


Schema: 'Demo'

AdventureWorks2016CTP3

Collapse image Schema: 'Demo'

Objects | Total
Procedures | 2
Tables | 2

Collapse image See also

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
usp_DemoInitSeed | Demo |  | 1 | 0 |  | 23.10.2015
usp_DemoReset | Demo |  | 0 | 0 |  | 23.10.2015
Total: 2 procedure(s)

Collapse image See also

Functions

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
DemoSalesOrderDetailSeed | Demo |  | 0 KB | 0 KB | 23.10.2015 | 5 | 0
DemoSalesOrderHeaderSeed | Demo |  | 0 KB | 0 KB | 23.10.2015 | 7 | 0
Total: 2 table(s)

Collapse image See also

Table statistics summary

Database overview


Schema: 'HumanResources'

AdventureWorks2016CTP3

Collapse image Schema: 'HumanResources'

Objects | Total
Procedures | 5
Tables | 8
Triggers | 13
Views | 7
XML schema collections | 1

Collapse image See also

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
sp_GetEmployee_Person_Info_AsOf | HumanResources |  | 1 | 0 |  | 23.10.2015
sp_UpdateEmployee_Temporal | HumanResources |  | 7 | 0 |  | 23.10.2015
uspUpdateEmployeeHireInfo | HumanResources | Updates the Employee table and inserts a new row in the EmployeePayHistory table with the values specified in the input parameters. | 7 | 0 |  | 16.11.2015
uspUpdateEmployeeLogin | HumanResources | Updates the Employee table with the values specified in the input parameters for the given BusinessEntityID. | 6 | 0 |  | 16.11.2015
uspUpdateEmployeePersonalInfo | HumanResources | Updates the Employee table with the values specified in the input parameters for the given EmployeeID. | 5 | 0 |  | 16.11.2015
Total: 5 procedure(s)

Collapse image See also

Functions

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
Department | HumanResources | Lookup table containing the departments within the Adventure Works Cycles company. | 8 KB | 24 KB | 23.10.2015 | 4 | 16
Employee | HumanResources | Employee information such as salary, department, and title. | 56 KB | 136 KB | 23.10.2015 | 18 | 290
Employee_Temporal | HumanResources |  | 56 KB | 16 KB | 23.10.2015 | 14 | 290
Employee_Temporal_History | HumanResources |  | 0 KB | 0 KB | 23.10.2015 | 14 | 0
EmployeeDepartmentHistory | HumanResources | Employee department transfers. | 16 KB | 48 KB | 23.10.2015 | 6 | 296
EmployeePayHistory | HumanResources | Employee pay history. | 16 KB | 16 KB | 23.10.2015 | 5 | 316
JobCandidate | HumanResources | Résumés submitted to Human Resources by job applicants. | 128 KB | 152 KB | 23.10.2015 | 4 | 13
Shift | HumanResources | Work shift lookup table. | 8 KB | 40 KB | 23.10.2015 | 5 | 3
Total: 8 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
dEmployee | HumanResources | INSTEAD OF DELETE trigger which keeps Employees from being deleted. |  |  |  | For Delete | HumanResources.Employee
tr_d_AUDIT_Department | HumanResources |  |  |  |  | For Delete | HumanResources.Department
tr_d_AUDIT_Employee | HumanResources |  |  |  |  | For Delete | HumanResources.Employee
tr_d_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeeDepartmentHistory
tr_d_AUDIT_EmployeePayHistory | HumanResources |  |  |  |  | For Delete | HumanResources.EmployeePayHistory
tr_i_AUDIT_Department | HumanResources |  |  | For Insert |  |  | HumanResources.Department
tr_i_AUDIT_Employee | HumanResources |  |  | For Insert |  |  | HumanResources.Employee
tr_i_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeeDepartmentHistory
tr_i_AUDIT_EmployeePayHistory | HumanResources |  |  | For Insert |  |  | HumanResources.EmployeePayHistory
tr_u_AUDIT_Department | HumanResources |  |  |  | For Update |  | HumanResources.Department
tr_u_AUDIT_Employee_Temporal | HumanResources |  |  |  | For Update |  | HumanResources.Employee_Temporal
tr_u_AUDIT_EmployeeDepartmentHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeeDepartmentHistory
tr_u_AUDIT_EmployeePayHistory | HumanResources |  |  |  | For Update |  | HumanResources.EmployeePayHistory
Total: 13 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
vEmployee | HumanResources | Employee names and addresses. |  |  | 16.11.2015
vEmployeeDepartment | HumanResources | Returns employee name, title, and current department. |  |  | 16.11.2015
vEmployeeDepartmentHistory | HumanResources | Returns employee name and current and previous departments. |  |  | 16.11.2015
vEmployeePersonTemporalInfo | HumanResources |  |  |  | 23.10.2015
vJobCandidate | HumanResources | Job candidate names and resumes. |  |  | 16.11.2015
vJobCandidateEducation | HumanResources | Displays the content from each education related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed. |  |  | 16.11.2015
vJobCandidateEmployment | HumanResources | Displays the content from each employement history related element in the xml column Resume in the HumanResources.JobCandidate table. The content has been localized into French, Simplified Chinese and Thai. Some data may not display correctly unless supplemental language support is installed. |  |  | 16.11.2015
Total: 7 view(s)

Collapse image See also

Tables

Database overview


XML schema collections

List of XML schema collections

Collapse image XML schema collections

Name | Schema | Description
HRResumeSchemaCollection | HumanResources | Collection of XML schemas for the Resume column in the HumanResources.JobCandidate table.
Total: 1 XML schema collection(s)

Collapse image See also

Database overview


Schema: 'Person'

AdventureWorks2016CTP3

Collapse image Schema: 'Person'

Objects | Total
Procedures | 2
Tables | 16
Triggers | 1
Views | 2
XML schema collections | 2

Collapse image See also

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
sp_DeletePerson_Temporal | Person |  | 1 | 0 |  | 23.10.2015
sp_UpdatePerson_Temporal | Person |  | 8 | 0 |  | 23.10.2015
Total: 2 procedure(s)

Collapse image See also

Functions

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
Address | Person | Street address information for customers, employees, and vendors. | 2904 KB | 2752 KB | 23.10.2015 | 9 | 19614
AddressType | Person | Types of addresses stored in the Address table. | 8 KB | 40 KB | 23.10.2015 | 4 | 6
BusinessEntity | Person | Source of the ID that connects vendors, customers, and employees with address and contact information. | 768 KB | 568 KB | 23.10.2015 | 3 | 20777
BusinessEntityAddress | Person | Cross-reference table mapping customers, vendors, and employees to their addresses. | 880 KB | 1432 KB | 23.10.2015 | 5 | 19614
BusinessEntityContact | Person | Cross-reference table mapping stores, vendors, and employees to people | 48 KB | 144 KB | 23.10.2015 | 5 | 909
ContactType | Person | Lookup table containing the types of business entity contacts. | 8 KB | 24 KB | 23.10.2015 | 3 | 20
CountryRegion | Person | Lookup table containing the ISO standard codes for countries and regions. | 16 KB | 48 KB | 23.10.2015 | 3 | 238
EmailAddress | Person | Where to send a person email. | 1992 KB | 1504 KB | 23.10.2015 | 5 | 19972
Password | Person | One way hashed authentication information | 1880 KB | 16 KB | 23.10.2015 | 5 | 19972
Person | Person | Human beings involved with AdventureWorks: employees, customer contacts, and vendor contacts. | 30552 KB | 53896 KB | 23.10.2015 | 13 | 19972
Person_json | Person |  | 1624 KB | 16 KB | 23.10.2015 | 13 | 19972
Person_Temporal | Person |  | 1464 KB | 16 KB | 23.10.2015 | 11 | 19972
Person_Temporal_History | Person |  | 0 KB | 0 KB | 23.10.2015 | 11 | 0
PersonPhone | Person | Telephone number and type of a person. | 1184 KB | 992 KB | 23.10.2015 | 4 | 19972
PhoneNumberType | Person | Type of phone number of a person. | 8 KB | 8 KB | 16.11.2015 | 3 | 3
StateProvince | Person | State and province lookup table. | 16 KB | 64 KB | 23.10.2015 | 8 | 181
Total: 16 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
iuPerson | Person | AFTER INSERT, UPDATE trigger inserting Individual only if the Customer does not exist in the Store table and setting the ModifiedDate column in the Person table to the current date. |  | For Insert | For Update |  | Person.Person
Total: 1 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
vAdditionalContactInfo | Person | Displays the contact name and content from each element in the xml column AdditionalContactInfo for that person. |  |  | 16.11.2015
vStateProvinceCountryRegion | Person | Joins StateProvince table with CountryRegion table. |  |  | 16.11.2015
Total: 2 view(s)

Collapse image See also

Tables

Database overview


XML schema collections

List of XML schema collections

Collapse image XML schema collections

Name | Schema | Description
AdditionalContactInfoSchemaCollection | Person | Collection of XML schemas for the AdditionalContactInfo column in the Person.Contact table.
IndividualSurveySchemaCollection | Person | Collection of XML schemas for the Demographics column in the Person.Person table.
Total: 2 XML schema collection(s)

Collapse image See also

Database overview


Schema: 'SQLCop'

AdventureWorks2016CTP3

Collapse image Schema: 'SQLCop'

Objects | Total
Procedures | 49

Collapse image See also

Database overview


Procedures

List of procedures

Collapse image Procedures

Name | Schema | Description | Input | Output | Encrypted | Creation date
test | SQLCop |  | 0 | 0 |  | 21.09.2016
[test Ad hoc distributed queries] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Agent Service] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto close] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto create statistics] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto Shrink] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Auto update statistics] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Buffer cache hit ratio] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column collation does not match database default] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column data types (Numeric vs. Int)] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Column Name Problems] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns of data type Text/nText] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns with float data type] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Columns with image data type] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Compatibility Level] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database and Log files on the same disk] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database collation] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Database Mail] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Decimal Size Problem] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Forwarded Records] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Fragmented Indexes] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Instant File Initialization] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Login Language] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Max degree of parallelism] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Missing Foreign Key Indexes] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Missing Foreign Keys] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Old Backups] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Ole Automation Procedures] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Orphaned Users] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Page life expectancy] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures Named SP_] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures that call undocumented procedures] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures using dynamic SQL without sp_executesql] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures with @@Identity] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures With SET ROWCOUNT] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Procedures without SET NOCOUNT ON] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Service Account] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test SMO and DMO] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Table name problems] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables that start with tbl] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables without a primary key] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Tables without any data] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test UniqueIdentifier with NewId] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Unnamed Constraints] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test User Aliases] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Varchar Size Problem] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Views with order by] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test Wide Table] | SQLCop |  | 0 | 0 |  | 19.09.2016
[test xp_cmdshell is enabled] | SQLCop |  | 0 | 0 |  | 19.09.2016
Total: 49 procedure(s)

Collapse image See also

Functions

Database overview


Schema: 'Production'

AdventureWorks2016CTP3

Collapse image Schema: 'Production'

Objects | Total
Tables | 27
Triggers | 2
Views | 3
XML schema collections | 2

Collapse image See also

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
BillOfMaterials | Production | Items required to make bicycles and bicycle subassemblies. It identifies the heirarchical relationship between a parent product and its components. | 160 KB | 200 KB | 23.10.2015 | 9 | 2679
Culture | Production | Lookup table containing the languages in which some AdventureWorks data is stored. | 8 KB | 24 KB | 23.10.2015 | 3 | 8
Document | Production | Product maintenance documents. | 336 KB | 176 KB | 23.10.2015 | 14 | 13
Illustration | Production | Bicycle assembly diagrams. | 240 KB | 8 KB | 23.10.2015 | 3 | 5
Location | Production | Product inventory and manufacturing locations. | 8 KB | 24 KB | 23.10.2015 | 5 | 14
Product | Production | Products sold or used in the manfacturing of sold products. | 104 KB | 128 KB | 23.10.2015 | 25 | 504
Product_inmem | Production |  | 0 KB | 0 KB | 23.10.2015 | 24 | 0
Product_ondisk | Production |  | 96 KB | 96 KB | 23.10.2015 | 24 | 504
ProductCategory | Production | High-level product categorization. | 8 KB | 40 KB | 23.10.2015 | 4 | 4
ProductCostHistory | Production | Changes in the cost of a product over time. | 24 KB | 16 KB | 23.10.2015 | 5 | 395
ProductDescription | Production | Product descriptions in several languages. | 144 KB | 56 KB | 23.10.2015 | 4 | 762
ProductDocument | Production | Cross-reference table mapping products to related product documents. | 8 KB | 8 KB | 23.10.2015 | 3 | 32
ProductInventory | Production | Product inventory information. | 56 KB | 16 KB | 23.10.2015 | 7 | 1069
ProductListPriceHistory | Production | Changes in the list price of a product over time. | 24 KB | 16 KB | 23.10.2015 | 5 | 395
ProductModel | Production | Product model classification. | 144 KB | 216 KB | 23.10.2015 | 6 | 128
ProductModelIllustration | Production | Cross-reference table mapping product models and illustrations. | 8 KB | 8 KB | 23.10.2015 | 3 | 7
ProductModelProductDescriptionCulture | Production | Cross-reference table mapping product descriptions and the language the description is written in. | 32 KB | 16 KB | 23.10.2015 | 4 | 762
ProductPhoto | Production | Product images. | 2280 KB | 16 KB | 23.10.2015 | 6 | 101
ProductProductPhoto | Production | Cross-reference table mapping products and product photos. | 16 KB | 40 KB | 23.10.2015 | 4 | 504
ProductReview | Production | Customer reviews of products they have purchased. | 16 KB | 120 KB | 23.10.2015 | 8 | 4
ProductSubcategory | Production | Product subcategories. See ProductCategory table. | 8 KB | 40 KB | 23.10.2015 | 5 | 37
ScrapReason | Production | Manufacturing failure reasons lookup table. | 8 KB | 24 KB | 23.10.2015 | 3 | 16
TransactionHistory | Production | Record of each purchase order, sales order, or work order transaction year to date. | 6344 KB | 4448 KB | 23.10.2015 | 9 | 113443
TransactionHistoryArchive | Production | Transactions for previous years. | 5000 KB | 3680 KB | 23.10.2015 | 9 | 89253
UnitMeasure | Production | Unit of measure lookup table. | 8 KB | 24 KB | 23.10.2015 | 3 | 38
WorkOrder | Production | Manufacturing work orders. | 4232 KB | 2408 KB | 23.10.2015 | 10 | 72591
WorkOrderRouting | Production | Work order details. | 5600 KB | 1648 KB | 23.10.2015 | 12 | 67131
Total: 27 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
iWorkOrder | Production | AFTER INSERT trigger that inserts a row in the TransactionHistory table. |  | For Insert |  |  | Production.WorkOrder
uWorkOrder | Production | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in the WorkOrder table. |  |  | For Update |  | Production.WorkOrder
Total: 2 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
vProductAndDescription | Production | Product names and descriptions. Product descriptions are provided in multiple languages. |  |  | 16.11.2015
vProductModelCatalogDescription | Production | Displays the content from each element in the xml column CatalogDescription for each product in the Production.ProductModel table that has catalog data. |  |  | 16.11.2015
vProductModelInstructions | Production | Displays the content from each element in the xml column Instructions for each product in the Production.ProductModel table that has manufacturing instructions. |  |  | 16.11.2015
Total: 3 view(s)

Collapse image See also

Tables

Database overview


XML schema collections

List of XML schema collections

Collapse image XML schema collections

Name | Schema | Description
ManuInstructionsSchemaCollection | Production | Collection of XML schemas for the Instructions column in the Production.ProductModel table.
ProductDescriptionSchemaCollection | Production | Collection of XML schemas for the CatalogDescription column in the Production.ProductModel table.
Total: 2 XML schema collection(s)

Collapse image See also

Database overview


Schema: 'Purchasing'

AdventureWorks2016CTP3

Collapse image Schema: 'Purchasing'

Objects | Total
Tables | 5
Triggers | 4
Views | 2

Collapse image See also

Database overview


Tables

List of tables

Collapse image Tables

Name | Schema | Description | Columns | Rows
ProductVendor | Purchasing | Cross-reference table mapping vendors with the products they supply. | 40 KB | 64 KB | 23.10.2015 | 11 | 460
PurchaseOrderDetail | Purchasing | Individual products associated with a specific purchase order. See PurchaseOrderHeader. | 512 KB | 192 KB | 23.10.2015 | 11 | 8845
PurchaseOrderHeader | Purchasing | General purchase order information. See PurchaseOrderDetail. | 336 KB | 160 KB | 23.10.2015 | 13 | 4012
ShipMethod | Purchasing | Shipping company lookup table. | 8 KB | 40 KB | 23.10.2015 | 6 | 5
Vendor | Purchasing | Companies from whom Adventure Works Cycles purchases parts or other goods. | 16 KB | 32 KB | 23.10.2015 | 8 | 104
Total: 5 table(s)

Collapse image See also

Table statistics summary

Database overview


Triggers

List of triggers

Collapse image Triggers

Name | Schema | Description | Instead of | For insert | For update | For delete | Table/view
dVendor | Purchasing | INSTEAD OF DELETE trigger which keeps Vendors from being deleted. |  |  |  | For Delete | Purchasing.Vendor
iPurchaseOrderDetail | Purchasing | AFTER INSERT trigger that inserts a row in the TransactionHistory table and updates the PurchaseOrderHeader.SubTotal column. |  | For Insert |  |  | Purchasing.PurchaseOrderDetail
uPurchaseOrderDetail | Purchasing | AFTER UPDATE trigger that inserts a row in the TransactionHistory table, updates ModifiedDate in PurchaseOrderDetail and updates the PurchaseOrderHeader.SubTotal column. |  |  | For Update |  | Purchasing.PurchaseOrderDetail
uPurchaseOrderHeader | Purchasing | AFTER UPDATE trigger that updates the RevisionNumber and ModifiedDate columns in the PurchaseOrderHeader table. |  |  | For Update |  | Purchasing.PurchaseOrderHeader
Total: 4 trigger(s)

Collapse image See also

Tables

Views

Database overview


Views

List of views

Collapse image Views

Name | Schema | Description | Schema bound | Encrypted | Creation date
vVendorWithAddresses | Purchasing | Vendor (company) names and addresses . |  |  | 16.11.2015
vVendorWithContacts | Purchasing | Vendor (company) names and the names of vendor employees to contact. |  |  | 16.11.2015
Total: 2 view(s)

Collapse image See also

Tables

Database overview


BookStore

AdventureWorks2016CTP3

Collapse image Description

AdventureWorks 2014 Sample OLTP Database

Collapse image Database information

Name | Value
Name | AdventureWorks2016CTP3
Owner | Alen-PC\Alen
ID | 11
Creation Date | 13.06.2016
Current Compatibility Level | Database compatibility level 130
Status | Normal
Collation | SQL_Latin1_General_CP1_CI_AS
Total Size | 1748.31 MB
Data Space in Use and Reserved for Use | 175240 KB
Index Space Usage | 115248 KB
Allocated and Unused Space | 27600 KB
Full Text Search Enabled |
Primary File Path | C:\Program Files\Microsoft SQL Server\MSSQL13.SQLSERVER2016\MSSQL\DATA\AdventureWorks2016CTP3_Data.mdf
On Disk Structure Version | 852
Recovery Model | SIMPLE
Containment | NONE
File Stream Non-Transacted Access | Off

Collapse image Database options

Name | Value
Access: Members of db_owner, dbcreator or sysadmin |
Access: Read Only |
Access: Single User |
Cursor Close On Commit |
Cursors in a Batch are with Local Scope |
Select Into/Bulkcopy |
Settings: ANSI NULL default |
Settings: Auto Close |
Settings: Auto Create Statistics |
Settings: Auto Shrink |
Settings: Auto Update Statistics |
Settings: Recursive Triggers |
Settings: Torn Page Detection |
Settings: Use Quoted Identifiers |
Truncate Log On Checkpoint |

Collapse image Data files

File name | Location | Space allocated | FileGroup | AutoGrow | Growth | Maximum file size
AdventureWorks2016CTP3_Data | C:\Program Files\Microsoft SQL Server\MSSQL13.SQLSERVER2016\MSSQL\DATA\AdventureWorks2016CTP3_Data.mdf | 330048 KB | PRIMARY |  | 16384 KB | Unlimited

Collapse image Transaction log files

File name | Location | Space allocated | AutoGrow | Growth | Maximum file size
AdventureWorks2016CTP3_Log | C:\Program Files\Microsoft SQL Server\MSSQL13.SQLSERVER2016\MSSQL\DATA\AdventureWorks2016CTP3_Log.ldf | 1460224 KB |  | 16384 KB | 2147483648 KB

Collapse image Extended properties

Name | Value
MS_Description | AdventureWorks 2014 Sample OLTP Database

Collapse image See also

Database object index


Server object index

ALEN-PC\SQLSERVER2016

Collapse image Server object index

Objects | Total
Jobs | 2
Logins | 21
Server roles | 9

Collapse image See also

Server overview


Jobs

List of jobs

Collapse image Jobs

Name | Description | Category
[SSIS Server Maintenance Job] | Runs every day. The job removes operation records from the database that are outside the retention window and maintains a maximum number of versions per project. | [Uncategorized (Local)]
syspolicy_purge_history | No description available. | [Uncategorized (Local)]
Total: 2 job(s)

Collapse image See also

Server overview


Job

Job: [SSIS Server Maintenance Job]

CollapseAll image

Collapse image Job properties

Name | Value
Name | [SSIS Server Maintenance Job]
Description | Runs every day. The job removes operation records from the database that are outside the retention window and maintains a maximum number of versions per project.
Category | [Uncategorized (Local)]
Type | Local job
Owner | ##MS_SSISServerCleanupJobLogin##
Enabled |
Version number | 3
Creation date | 28.07.2016
Last modified date | 28.07.2016
Last run date | 25.10.2016
Last run status | Succeeded
Originating server | ALEN-PC\SQLSERVER2016
Has schedule |
ID | 3aff5278-fb7d-4381-9eaa-2e6088a29c8f
Start step ID | 1

Collapse image Notification properties

Name | Value
Delete on completion | Default. Ignore any completion status. Do not delete
E-mail notification on completion | Ignore any completion status. Do not send e-mail when the job completes
Log entry on completion | Log failed job completion
Network message notification on completion | Ignore any completion status. Do not send network message to operator
Page notification on completion | Ignore any completion status. Do not page operator
Operator receiving e-mail notification | (unknown)
Operator receiving net send notification | (unknown)
Operator receiving page notification | (unknown)

Collapse image Schedules

Name | Creation Date
SSISDB Scheduler | 28.07.2016

Collapse image Steps

 | Name | Type
1 | SSIS Server Operation Records Maintenance | TSQL
2 | SSIS Server Max Version Per Project Maintenance | TSQL

Collapse image See also

Jobs


Schedules on job SSIS Server Maintenance Job

List of schedules on job SSIS Server Maintenance Job

Collapse image Schedules

Name | Creation date
SSISDB Scheduler | 28.07.2016
Total:1 schedule(s)

Collapse image See also

[SSIS Server Maintenance Job]


SSISDB Scheduler

Schedule: SSISDB Scheduler

Collapse image Schedule properties

Name | Creation date
Name | SSISDB Scheduler
Id | 9
Is enabled |
Description | Every day at 12:00:00 AM
Schedule type | Daily
Recurs every | 1 day(s)
Occurs once at | 12:00:00 AM
Duration start date | 31.12.2000
Duration end date | No date

Collapse image See also

[SSIS Server Maintenance Job]


Steps on job SSIS Server Maintenance Job

List of steps on job SSIS Server Maintenance Job

Collapse image Steps

 | Name | Type
1 | SSIS Server Operation Records Maintenance | TSQL
2 | SSIS Server Max Version Per Project Maintenance | TSQL
Total:2 step(s)

Collapse image See also

[SSIS Server Maintenance Job]


SSIS Server Operation Records Maintenance

Job step: SSIS Server Operation Records Maintenance

Collapse image Job step properties

Id | Name
Name | SSIS Server Operation Records Maintenance
ID | 1
Type | TSQL
Run as user |
Database | msdb
On success action | 3 (goto next step)
Retry attempts | 3
Retry interval(minutes) | 3
On fail action | 2 (quit with failure)
Output file |

Collapse image Command

    DECLARE @role int
    SET @role = (SELECT [role] FROM [sys].[dm_hadr_availability_replica_states] hars INNER JOIN [sys].[availability_databases_cluster] adc ON hars.[group_id] = adc.[group_id] WHERE hars.[is_local] = 1 AND adc.[database_name] ='SSISDB')
    IF DB_ID('SSISDB') IS NOT NULL AND (@role IS NULL OR @role = 1)
        EXEC [SSISDB].[internal].[cleanup_server_retention_window]

Collapse image See also

[SSIS Server Maintenance Job]


SSIS Server Max Version Per Project Maintenance

Job step: SSIS Server Max Version Per Project Maintenance

Collapse image Job step properties

Id | Name
Name | SSIS Server Max Version Per Project Maintenance
ID | 2
Type | TSQL
Run as user |
Database | msdb
On success action | 1 (quit with success)
Retry attempts | 3
Retry interval(minutes) | 3
On fail action | 2 (quit with failure)
Output file |

Collapse image Command

    DECLARE @role int
    SET @role = (SELECT [role] FROM [sys].[dm_hadr_availability_replica_states] hars INNER JOIN [sys].[availability_databases_cluster] adc ON hars.[group_id] = adc.[group_id] WHERE hars.[is_local] = 1 AND adc.[database_name] ='SSISDB')
    IF DB_ID('SSISDB') IS NOT NULL AND (@role IS NULL OR @role = 1)
        EXEC [SSISDB].[internal].[cleanup_server_project_version]

Collapse image See also

[SSIS Server Maintenance Job]


Job

Job: syspolicy_purge_history

Collapse image Job properties

Name | Value
Name | syspolicy_purge_history
Description | No description available.
Category | [Uncategorized (Local)]
Type | Local job
Owner | sa
Enabled |
Version number | 5
Creation date | 01.06.2016
Last modified date | 01.06.2016
Last run date | 25.10.2016
Last run status | Succeeded
Originating server | ALEN-PC\SQLSERVER2016
Has schedule |
ID | 52a6ef85-fe28-47ca-8952-f64bf949ba41
Start step ID | 1

Collapse image Notification properties

Name | Value
Delete on completion | Default. Ignore any completion status. Do not delete
E-mail notification on completion | Ignore any completion status. Do not send e-mail when the job completes
Log entry on completion | Ignore any completion status. Do not log completion
Network message notification on completion | Ignore any completion status. Do not send network message to operator
Page notification on completion | Ignore any completion status. Do not page operator
Operator receiving e-mail notification | (unknown)
Operator receiving net send notification | (unknown)
Operator receiving page notification | (unknown)

Collapse image Schedules

Name | Creation Date
syspolicy_purge_history_schedule | 01.06.2016

Collapse image Steps

 | Name | Type
1 | Verify that automation is enabled. | TSQL
2 | Purge history. | TSQL
3 | Erase Phantom System Health Records. | PowerShell

Collapse image See also

Jobs


Schedules on job syspolicy_purge_history

List of schedules on job syspolicy_purge_history

Collapse image Schedules

Name | Creation date
syspolicy_purge_history_schedule | 01.06.2016
Total:1 schedule(s)

Collapse image See also

syspolicy_purge_history


syspolicy_purge_history_schedule

Schedule: syspolicy_purge_history_schedule

Collapse image Schedule properties

Name | Creation date
Name | syspolicy_purge_history_schedule
Id | 8
Is enabled |
Description | Every day at 2:00:00 AM
Schedule type | Daily
Recurs every | 1 day(s)
Occurs once at | 2:00:00 AM
Duration start date | 01.01.2008
Duration end date | No date

Collapse image See also

syspolicy_purge_history


Steps on job syspolicy_purge_history

List of steps on job syspolicy_purge_history

Collapse image Steps

 | Name | Type
1 | Verify that automation is enabled. | TSQL
2 | Purge history. | TSQL
3 | Erase Phantom System Health Records. | PowerShell
Total:3 step(s)

Collapse image See also

syspolicy_purge_history


Verify that automation is enabled.

Job step: Verify that automation is enabled.

CollapseAll image

Collapse image Job step properties

Id | Name
Name | Verify that automation is enabled.
ID | 1
Type | TSQL
Run as user |
Database | master
On success action | 3 (goto next step)
Retry attempts | 0
Retry interval(minutes) | 0
On fail action | 1 (quit with success)
Output file |

Collapse image Command

IF (msdb.dbo.fn_syspolicy_is_automation_enabled() != 1)
        BEGIN
            RAISERROR(34022, 16, 1)
        END

Collapse image See also

syspolicy_purge_history


Purge history.

Job step: Purge history.

CollapseAll image

Collapse image Job step properties

Id | Name
Name | Purge history.
ID | 2
Type | TSQL
Run as user |
Database | master
On success action | 3 (goto next step)
Retry attempts | 0
Retry interval(minutes) | 0
On fail action | 2 (quit with failure)
Output file |

Collapse image Command

EXEC msdb.dbo.sp_syspolicy_purge_history

Collapse image See also

syspolicy_purge_history


Erase Phantom System Health Records.

Job step: Erase Phantom System Health Records.

CollapseAll image

Collapse image Job step properties

Id | Name
Name | Erase Phantom System Health Records.
ID | 3
Type | PowerShell
Run as user |
Database | master
On success action | 1 (quit with success)
Retry attempts | 0
Retry interval(minutes) | 0
On fail action | 2 (quit with failure)
Output file |

Collapse image Command

if ('$(ESCAPE_SQUOTE(INST))' -eq 'MSSQLSERVER') {$a = '\DEFAULT'} ELSE {$a = ''}; (Get-Item SQLSERVER:\SQLPolicy\$(ESCAPE_NONE(SRVR))$a).EraseSystemHealthPhantomRecords()

Collapse image See also

syspolicy_purge_history


Logins

List of logins

Collapse image Logins

Name | Login type | Default database
[##MS_AgentSigningCertificate##] | Certificate-based SQL Server Logins | master
[##MS_PolicyEventProcessingLogin##] | SQL Server standard login | master
[##MS_PolicySigningCertificate##] | Certificate-based SQL Server Logins | master
[##MS_PolicyTsqlExecutionLogin##] | SQL Server standard login | master
[##MS_SmoExtendedSigningCertificate##] | Certificate-based SQL Server Logins | master
[##MS_SQLAuthenticatorCertificate##] | Certificate-based SQL Server Logins | master
[##MS_SQLEnableSystemAssemblyLoadingUser##] | SQL Server standard login | master
[##MS_SQLReplicationSigningCertificate##] | Certificate-based SQL Server Logins | master
[##MS_SQLResourceSigningCertificate##] | Certificate-based SQL Server Logins | master
[##MS_SSISServerCleanupJobLogin##] | SQL Server standard login | master
[Alen-PC\Alen] | Windows user | master
l_certSignSmDetach | Certificate-based SQL Server Logins | master
[NT AUTHORITY\NETWORK SERVICE] | Windows user | master
[NT AUTHORITY\SYSTEM] | Windows user | master
[NT Service\MSSQL$SQLSERVER2016] | Windows user | master
[NT SERVICE\ReportServer$SQLSERVER2016] | Windows user | master
[NT SERVICE\SQLAgent$SQLSERVER2016] | Windows user | master
[NT SERVICE\SQLTELEMETRY$SQLSERVER2016] | Windows user | master
[NT SERVICE\SQLWriter] | Windows user | master
[NT SERVICE\Winmgmt] | Windows user | master
sa | SQL Server standard login | master
Total: 21 login(s)

Collapse image See also

Server overview


Login

Login: [##MS_AgentSigningCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_AgentSigningCertificate##]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_AgentSigningCertificate##] FROM CERTIFICATE [##MS_AgentSigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_PolicyEventProcessingLogin##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_PolicyEventProcessingLogin##]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | SQL Server standard login
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_PolicyEventProcessingLogin##] WITH
    PASSWORD = 'p@ssw0rd',
    SID = 0xFB5AEBF3BC377A40801246AC531302F7,
    DEFAULT_DATABASE = [master],
    DEFAULT_LANGUAGE = [us_english],
    CHECK_EXPIRATION = OFF,
    CHECK_POLICY = ON
GO

Collapse image See also

Logins


Login

Login: [##MS_PolicySigningCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_PolicySigningCertificate##]
Friendly name |
Language |
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_PolicySigningCertificate##] FROM CERTIFICATE [##MS_PolicySigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_PolicyTsqlExecutionLogin##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_PolicyTsqlExecutionLogin##]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | SQL Server standard login
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_PolicyTsqlExecutionLogin##] WITH
    PASSWORD = 'p@ssw0rd',
    SID = 0xB5BA3F49077DF14C95D37EBB67C49F8F,
    DEFAULT_DATABASE = [master],
    DEFAULT_LANGUAGE = [us_english],
    CHECK_EXPIRATION = OFF,
    CHECK_POLICY = ON
GO

Collapse image See also

Logins


Login

Login: [##MS_SmoExtendedSigningCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SmoExtendedSigningCertificate##]
Friendly name |
Language |
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SmoExtendedSigningCertificate##] FROM CERTIFICATE [##MS_SmoExtendedSigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_SQLAuthenticatorCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SQLAuthenticatorCertificate##]
Friendly name |
Language |
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SQLAuthenticatorCertificate##] FROM CERTIFICATE [##MS_SQLAuthenticatorCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_SQLEnableSystemAssemblyLoadingUser##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SQLEnableSystemAssemblyLoadingUser##]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | SQL Server standard login
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SQLEnableSystemAssemblyLoadingUser##] WITH
    PASSWORD = 'p@ssw0rd',
    SID = 0x01030000000000090200000089845DCD8080CC91,
    DEFAULT_DATABASE = [master],
    DEFAULT_LANGUAGE = [us_english],
    CHECK_EXPIRATION = OFF,
    CHECK_POLICY = OFF
GO

Collapse image See also

Logins


Login

Login: [##MS_SQLReplicationSigningCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SQLReplicationSigningCertificate##]
Friendly name |
Language |
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SQLReplicationSigningCertificate##] FROM CERTIFICATE [##MS_SQLReplicationSigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_SQLResourceSigningCertificate##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SQLResourceSigningCertificate##]
Friendly name |
Language |
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SQLResourceSigningCertificate##] FROM CERTIFICATE [##MS_SQLResourceSigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [##MS_SSISServerCleanupJobLogin##]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [##MS_SSISServerCleanupJobLogin##]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | SQL Server standard login
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [##MS_SSISServerCleanupJobLogin##] WITH
    PASSWORD = 'p@ssw0rd',
    SID = 0xE261041226D0B64CA4A8FFC862767842,
    DEFAULT_DATABASE = [master],
    DEFAULT_LANGUAGE = [us_english],
    CHECK_EXPIRATION = OFF,
    CHECK_POLICY = OFF
GO

Collapse image See also

Logins


Login

Login: [Alen-PC\Alen]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [Alen-PC\Alen]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [Alen-PC\Alen] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: l_certSignSmDetach

Collapse image Login properties

Name | Value
Name | l_certSignSmDetach
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Certificate-based SQL Server Logins
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [l_certSignSmDetach] FROM CERTIFICATE [_##PDW_SmDetachSigningCertificate##]
GO

Collapse image See also

Logins


Login

Login: [NT AUTHORITY\NETWORK SERVICE]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT AUTHORITY\NETWORK SERVICE]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [NT AUTHORITY\NETWORK SERVICE] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT AUTHORITY\SYSTEM]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT AUTHORITY\SYSTEM]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [NT AUTHORITY\SYSTEM] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT Service\MSSQL$SQLSERVER2016]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT Service\MSSQL$SQLSERVER2016]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [NT Service\MSSQL$SQLSERVER2016] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT SERVICE\ReportServer$SQLSERVER2016]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT SERVICE\ReportServer$SQLSERVER2016]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [NT SERVICE\ReportServer$SQLSERVER2016] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT SERVICE\SQLAgent$SQLSERVER2016]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT SERVICE\SQLAgent$SQLSERVER2016]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [NT SERVICE\SQLAgent$SQLSERVER2016] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT SERVICE\SQLTELEMETRY$SQLSERVER2016]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT SERVICE\SQLTELEMETRY$SQLSERVER2016]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image SQL

CREATE LOGIN [NT SERVICE\SQLTELEMETRY$SQLSERVER2016] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT SERVICE\SQLWriter]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT SERVICE\SQLWriter]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [NT SERVICE\SQLWriter] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: [NT SERVICE\Winmgmt]

CollapseAll image

Collapse image Login properties

Name | Value
Name | [NT SERVICE\Winmgmt]
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | Windows user
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [NT SERVICE\Winmgmt] FROM WINDOWS WITH
    DEFAULT_DATABASE=[master],
    DEFAULT_LANGUAGE=[us_english]
GO

Collapse image See also

Logins


Login

Login: sa

Collapse image Login properties

Name | Value
Name | sa
Friendly name | English
Language | us_english
System |
Default database | master
Deny Windows Security Authenticated Connections |
Type | SQL Server standard login
Permissions to access the server | Explicit grant
Enabled |

Collapse image Roles with this login

Role
sysadmin

Collapse image SQL

CREATE LOGIN [sa] WITH
    PASSWORD = 'p@ssw0rd',
    SID = 0x01,
    DEFAULT_DATABASE = [master],
    DEFAULT_LANGUAGE = [us_english],
    CHECK_EXPIRATION = OFF,
    CHECK_POLICY = ON
GO

Collapse image See also

Logins


Server roles

List of server roles

Collapse image Server roles

Name
[bulkadmin]
[dbcreator]
[diskadmin]
[processadmin]
[public]
[securityadmin]
[serveradmin]
[setupadmin]
[sysadmin]
Total: 9 server role(s)

Collapse image See also

Server overview


Server role

Server role: [bulkadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [bulkadmin]
Description | Bulk Insert Administrators

Collapse image See also

Server roles


Server role

Server role: [dbcreator]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [dbcreator]
Description | Database Creators

Collapse image See also

Server roles


Server role

Server role: [diskadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [diskadmin]
Description | Disk Administrators

Collapse image See also

Server roles


Server role

Server role: [processadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [processadmin]
Description | Process Administrators

Collapse image See also

Server roles


Server role

Server role: [public]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [public]
Description |

Collapse image See also

Server roles


Server role

Server role: [securityadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [securityadmin]
Description | Security Administrators

Collapse image See also

Server roles


Server role

Server role: [serveradmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [serveradmin]
Description | Server Administrators

Collapse image See also

Server roles


Server role

Server role: [setupadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [setupadmin]
Description | Setup Administrators

Collapse image See also

Server roles


Server role

Server role: [sysadmin]

CollapseAll image

Collapse image Server role properties

Name | Value
Name | [sysadmin]
Description | System Administrators

Collapse image Server role membership

Role members
sa
Alen-PC\Alen
NT SERVICE\SQLWriter
NT SERVICE\Winmgmt
NT Service\MSSQL$SQLSERVER2016
NT SERVICE\SQLAgent$SQLSERVER2016
l_certSignSmDetach

Collapse image See also

Server roles


BookStore

Server ALEN-PC\SQLSERVER2016

Collapse image Server properties

Name | Value
Code page | 1252
Network name | ALEN-PC
Language | us_english
Maximum degree of parallelism | 0
Service name | MSSQL$SQLSERVER2016
Instance name | SQLSERVER2016
Collation | Latin1_General_CI_AI
Is clustered |
Is full text search installed |

Collapse image Version

Microsoft SQL Server 2016 (RTM-GDR) (KB3179258) - 13.0.1711.0 (X64)
Jul 29 2016 16:16:44
Copyright (c) Microsoft Corporation
Enterprise Evaluation Edition (64-bit) on Windows 10 Pro 6.3 (Build 14393: )

Collapse image Databases

Database | Owner | System
AdventureWorks2016CTP3 | Alen-PC\Alen |
iFileTransferV2 | Alen-PC\Alen |
IntradeHarvard2011 | Alen-PC\Alen |
JankoMaster | Alen-PC\Alen |
master | sa |
model | sa |
msdb | sa |
pubs | Alen-PC\Alen |
SSISDB | Alen-PC\Alen |
sysdb1 | Alen-PC\Alen |
sysdb2 | Alen-PC\Alen |
tempdb | sa |
tSQLt_Example | Alen-PC\Alen |
Total: 13 database(s)

Collapse image Server configuration

Parameter name | Value
affinity I/O mask | 0
affinity mask | 0
affinity64 I/O mask | 0
affinity64 mask | 0
Allow cross db ownership chaining | 0
Allow INSERT into a Hadoop external table | 0
Allow recursion for server level triggers | 1
Allow remote access | 1
Allow the use of the REMOTE_DATA_ARCHIVE data access for databases | 0
Allow triggers to be invoked within triggers | 1
Allow updates to system tables | 0
Allows execution of external scripts | 0
Automatic soft-NUMA is enabled by default | 0
Blocked process reporting threshold | 0
c2 audit mode | 0
CLR user code execution enabled in the server | 1
Common Criteria compliance mode enabled | 0
Configure SQL Server to connect to external Hadoop or Microsoft Azure storage blob data sources through PolyBase | 7
Configure SQL Server to encrypt control and data channels when using PolyBase | 1
cost threshold for parallelism | 5
Create DTC transaction for remote procedures | 0
cursor threshold | -1
DB connection timeout for full-text protocol handler (s) | 60
Dedicated Admin Connections are allowed from remote clients | 0
Default fill factor percentage | 0
default full-text language | 1033
Default hash bucket count for the access check result security cache | 0
default language | 0
Default quota for the access check result security cache | 0
Disallow returning results from triggers | 0
Enable checksum of backups by default | 0
Enable compression of backups by default | 0
Enable or disable Ad Hoc Distributed Queries | 0
Enable or disable Agent XPs | 1
Enable or disable command shell | 0
Enable or disable Database Mail XPs | 0
Enable or disable EKM provider | 0
Enable or disable Ole Automation Procedures | 0
Enable or disable Replication XPs | 0
Enable or disable SMO and DMO XPs | 1
Enable or disable the default trace | 1
Enables contained databases and contained authentication | 1
Max number of full-text crawl buffers | 100
Max number of full-text notifications buffers | 100
Maximum crawl ranges allowed in full-text indexing | 4
maximum degree of parallelism | 0
Maximum estimated cost allowed by query governor | 0
Maximum recovery interval in minutes | 0
Maximum size of a text field in replication. | 65536
Maximum size of server memory (MB) | 2147483647
maximum time to wait for query memory (s) | -1
Maximum worker threads | 0
Memory for index create sorts (kBytes) | 0
minimum memory per query (kBytes) | 1024
Minimum size of server memory (MB) | 0
Network packet size | 4096
Number of locks for all users | 0
Number of open database objects | 0
Number of reserved full-text crawl buffers | 0
Number of reserved full-text notifications buffers | 0
Number of user connections allowed | 0
Priority boost | 0
Recovery policy for DTC transactions with unknown outcome | 0
remote login timeout | 10
remote query timeout | 600
scan for startup stored procedures | 0
set working set size | 0
Sets the FILESTREAM access level | 0
show advanced options | 0
Tape retention period in days | 0
Transform noise words for full-text query | 0
two digit year cutoff | 2049
Use precomputed rank for full-text query | 0
User mode scheduler uses lightweight pooling | 0
user options | 0
When this option is set, plan cache size is further reduced for single-use adhoc OLTP workload. | 0

Collapse image See also

Jobs

Logins

Server roles


Package index

Collapse image Package index

Package | Package path
AnalysisProcessingPackage | C:\Users\Alen\Desktop\SSIS packages\AnalysisProcessingPackage.dtsx
BackUpDBTaskPackage | C:\Users\Alen\Desktop\SSIS packages\BackUpDBTaskPackage.dtsx

Collapse image See also

About this documentation


Package

Package: AnalysisProcessingPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 12:12:27 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {BC323BDF-DECC-48C2-980F-346D490B0B06}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | AnalysisProcessingPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\AnalysisProcessingPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\AnalysisProcessingPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 3
VersionComments |
VersionGUID | {B6615261-2475-412E-A702-FC3F041D0D6D}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
localhost |

Collapse image Executables

Name | Description
Analysis Services Processing Task | Analysis Services Processing Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: AnalysisProcessingPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: AnalysisProcessingPackage

Collapse image Connection managers

Name | Description
localhost |

Collapse image System variables

No items exist
Name Description


Package element

Package element: localhost

Collapse image Properties

Name | Value
ConnectionString | Data Source=localhost;PROVIDER=MSOLAP.6;Impersonation Level=Impersonate;
CreationName | MSOLAP100
DelayValidation | False
Description |
HasExpressions | False
HostType | ConnectionManager
ID | {07B5452E-D0E6-44A5-836F-303564321DDE}
InitialCatalog |
Name | localhost
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | localhost
SupportsDTCTransactions | False
UserName |


Package

Package: AnalysisProcessingPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: AnalysisProcessingPackage

Collapse image Executables

Name | Description
Analysis Services Processing Task | Analysis Services Processing Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Analysis Services Processing Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
ConnectionName | localhost
CreationName | Microsoft.DataTransformationServices.Tasks.DTSProcessingTask.DTSProcessingTask, Microsoft.SqlServer.ASTasks, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Analysis Services Processing Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7763345C-6C11-4F18-A525-DB85260726C7}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Analysis Services Processing Task
ProcessingCommands | <Batch xmlns="http://schemas.microsoft.com/analysisservices/2003/engine">{LF} <Process xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">{LF} <Object>{LF} <DatabaseID>TestDB</DatabaseID>{LF} </Object>{LF} <Type>ProcessFull</Type>{LF} <WriteBackTableCreation>UseExisting</WriteBackTableCreation>{LF} </Process>{LF}</Batch>
SuspendRequired | False
TaskDescription | Provides ability to process Analysis Services objects such as cubes and dimensions.
TaskDisplayName | Analysis Services Processing Task
TransactionOption | Supported
Version | 0


Package

Package: AnalysisProcessingPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package element

Package element: Diagnostic

Collapse image Properties

Name | Value
CreationName |
Description | Logs package diagnostics information, e.g. maximum concurrent executables
FrequencyHint | Consistent
Name | Diagnostic


Package element

Package element: DiagnosticEx

Collapse image Properties

Name | Value
CreationName |
Description | Logs more information on package execution with XML format
FrequencyHint | Consistent
Name | DiagnosticEx


Package

Package: AnalysisProcessingPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: AnalysisProcessingPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: AnalysisProcessingPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: AnalysisProcessingPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 12:12:27 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{BC323BDF-DECC-48C2-980F-346D490B0B06}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="AnalysisProcessingPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="3" DTS:VersionGUID="{973E25C3-522E-49DD-8DDB-79A2BAA329A3}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[localhost]" DTS:CreationName="MSOLAP100" DTS:DTSID="{07B5452E-D0E6-44A5-836F-303564321DDE}" DTS:ObjectName="localhost">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=localhost;PROVIDER=MSOLAP.6;Impersonation Level=Impersonate;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Analysis Services Processing Task" DTS:CreationName="Microsoft.DTSProcessingTask" DTS:Description="Analysis Services Processing Task" DTS:DTSID="{7763345C-6C11-4F18-A525-DB85260726C7}" DTS:ExecutableType="Microsoft.DTSProcessingTask" DTS:LocaleID="-1" DTS:ObjectName="Analysis Services Processing Task" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<ASProcessingData ConnectionName="localhost" ProcessingCommands="<Batch xmlns="http://schemas.microsoft.com/analysisservices/2003/engine"> <Process xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <Object> <DatabaseID>TestDB</DatabaseID> </Object> <Type>ProcessFull</Type> <WriteBackTableCreation>UseExisting</WriteBackTableCreation> </Process> </Batch>"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{BC1A9AC6-64F8-4C78-9DB3-23C48C6F7807}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{5FA6F440-C113-4CDF-8866-F8897D986F6F}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7763345C-6C11-4F18-A525-DB85260726C7}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{90CB4199-14F7-4BED-BFD3-B2671C97E9CF}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7763345C-6C11-4F18-A525-DB85260726C7}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: BackUpDBTaskPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 2:28:51 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {95AA7996-CCE3-4446-95BF-C96381D1C00F}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | BackUpDBTaskPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\BackUpDBTaskPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\BackUpDBTaskPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 2
VersionComments |
VersionGUID | {6F04C8B5-FE1F-424F-9FB1-AC7567488FD1}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
serverbackup |

Collapse image Executables

Name | Description
Back Up Database Task | Back Up Database Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: BackUpDBTaskPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image Connection managers

Name | Description
serverbackup |

Collapse image System variables

No items exist
Name Description


Package element

Package element: serverbackup

Collapse image Properties

Name | Value
ConnectionString | Data Source=server;Integrated Security=SSPI;Connect Timeout=30;
CreationName | ADO.NET:SQL
DelayValidation | False
Description |
HasExpressions | False
HostType | ConnectionManager
ID | {A10C314B-E039-4D96-AD03-200C8439C2C3}
InitialCatalog |
Name | serverbackup
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier | SQL
RetainSameConnection | False
Scope | Package
ServerName | server
SupportsDTCTransactions | True
UserName |


Package

Package: BackUpDBTaskPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image Executables

Name | Description
Back Up Database Task | Back Up Database Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Back Up Database Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
BackupAction | 0
BackupCompressionOption | 0
BackupDeviceType | 2
BackupEncryptionAlgorithm | 0
BackupEncryptorName
BackupEncryptorType | 0
BackupFileExtension | bak
BackupIsIncremental | False
BackupPhysicalDestinationType | 2
BypassPrepare | True
CodePage | 1252
Connection | serverbackup
ContainerName
CopyOnlyBackup | False
CreateSubFolder | False
CreationName | Microsoft.SqlServer.Management.DatabaseMaintenance.DbMaintenanceBackupTask, Microsoft.SqlServer.MaintenancePlanTasks, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
CredentialName
DatabaseSelectionType | 4
DebugMode | False
DelayValidation | False
Description | Back Up Database Task
DestinationAutoFolderPath | C:\Program Files\Microsoft SQL Server\MSSQL\BACKUP
DestinationCreationType | 0
DestinationManualList
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
ExistingBackupsAction | 0
ExpireDate | 9/12/2100 12:00:00 AM
ExtendedLogging | True
FailPackageOnFailure | False
FailParentOnFailure | False
FileGroupsFiles
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {67643D28-0F1D-4144-87BE-1CFCA6A37B02}
IgnoreDatabasesInNotOnlineState | False
IgnoreReplicaType | False
InDays | True
IsBackupEncrypted | False
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocalConnectionForLogging
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Back Up Database Task
ObjectTypeSelection | 0
ResultSetType | 1
RetainDays | 14
RunId | {00000000-0000-0000-0000-000000000000}
SelectedDatabases | System.Collections.ArrayList
SelectedTables
ServerVersion | 9
SqlStatementSource

  SqlStatementSourceType
   | Direct Input

  SuspendRequired
   | False

  TableSelectionType
   | 0

  TaskAllowesDatbaseSelection
   | True

  TaskAllowesTableSelection
   | False

  TaskConnectionName
   | serverbackup

  TaskName

  TaskNameWasModified
   | False

  TimeOut
   | 0

  TransactionOption
   | Supported

  TypeConversionMode
   | 2

  UrlPrefix

  UseExpiration
   | False

  VerifyIntegrity
   | False

  Version
   | 0

      Collapse image

            Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos

      Collapse image

            See also

Package index


Package element

Package element: ExecuteSQLExecutingQuery

Collapse image Properties

Name | Value
CreationName |
Description | Provides information about executing an SQL query.
FrequencyHint | Consistent
Name | ExecuteSQLExecutingQuery


Package

Package: BackUpDBTaskPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BackUpDBTaskPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 2:28:51 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{95AA7996-CCE3-4446-95BF-C96381D1C00F}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="BackUpDBTaskPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="2" DTS:VersionGUID="{43F3CEAD-957F-47EE-BD11-558855F2C534}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[serverbackup]" DTS:CreationName="ADO.NET:SQL" DTS:DTSID="{A10C314B-E039-4D96-AD03-200C8439C2C3}" DTS:ObjectName="serverbackup">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=server;Integrated Security=SSPI;Connect Timeout=30;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Back Up Database Task" DTS:CreationName="Microsoft.DbMaintenanceBackupTask" DTS:Description="Back Up Database Task" DTS:DTSID="{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" DTS:ExecutableType="Microsoft.DbMaintenanceBackupTask" DTS:LocaleID="-1" DTS:ObjectName="Back Up Database Task" DTS:TaskContact="Back Up Database Task; Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{A10C314B-E039-4D96-AD03-200C8439C2C3}" SQLTask:DatabaseSelectionType="4" SQLTask:ServerVersion="9" SQLTask:ExtendedLogging="True" SQLTask:LocalConnectionForLogging="" SQLTask:TaskName="" SQLTask:IgnoreDatabasesInNotOnlineState="False" SQLTask:BackupAction="0" SQLTask:BackupIsIncremental="False" SQLTask:BackupFileGroupsFiles="" SQLTask:BackupDeviceType="2" SQLTask:BackupPhysicalDestinationType="2" SQLTask:BackupDestinationType="0" SQLTask:BackupDestinationAutoFolderPath="C:\Program Files\Microsoft SQL Server\MSSQL\BACKUP" SQLTask:BackupActionForExistingBackups="0" SQLTask:BackupCreateSubFolder="False" SQLTask:BackupFileExtension="bak" SQLTask:BackupVerifyIntegrity="False" SQLTask:ExpireDate="2100-09-12T00:00:00" SQLTask:RetainDays="14" SQLTask:InDays="True" SQLTask:UseExpiration="False" SQLTask:BackupCompressionAction="0" SQLTask:CopyOnlyBackup="False" SQLTask:IgnoreReplicaType="False" SQLTask:CredentialName="" SQLTask:ContainerName="" SQLTask:UrlPrefix="" SQLTask:IsBackupEncrypted="False" SQLTask:BackupEncryptionAlgorithm="0" SQLTask:BackupEncryptorType="0" SQLTask:BackupEncryptorName="">
<SQLTask:SelectedDatabases SQLTask:DatabaseName="ANCSA"/>
<SQLTask:SelectedDatabases SQLTask:DatabaseName="New_Pizza_Project"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{AF1DE1D0-E6CD-4ABE-88F4-1FEE960DB6A8}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{B03C6F40-49BE-4D8A-A749-19AF50A650BA}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{29FA9056-6247-46C6-A89C-26C261617A35}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Integration services

Collapse image Server index

Server
ALEN-PC

Collapse image See also

About this documentation


Package index

Collapse image Package index

Package | Package path
PerfCountersCollect | MSDB\Data Collector\PerfCountersCollect
PerfCountersUpload | MSDB\Data Collector\PerfCountersUpload
QueryActivityCollect | MSDB\Data Collector\QueryActivityCollect
QueryActivityUpload | MSDB\Data Collector\QueryActivityUpload
SqlTraceCollect | MSDB\Data Collector\SqlTraceCollect
SqlTraceUpload | MSDB\Data Collector\SqlTraceUpload

Collapse image See also

About this documentation


Package

Package: PerfCountersCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/23/2007 1:05:21 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {C2EAABC1-5BF3-4127-BEB3-26E94D026E7D}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | 2
MaximumErrorCount | 0
Name | PerfCountersCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\PerfCountersCollect
PackagePath | MSDB\Data Collector\PerfCountersCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 250
VersionComments |
VersionGUID | {18D1B8E2-6F88-4A06-931F-468BFC86E0A4}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.

Collapse image Executables

Name | Description
LOOP - Aquire performance counters @ collection item frequency | Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilename |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
RowCountOut |
TargetConnectionString |
TargetProcessID |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: PerfCountersCollect

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {2DF91A21-DC08-404B-B537-367F20F72E42}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {B360CA6A-D82F-4B4E-81DB-7A8F702574F6}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {FB8C290D-145C-46CE-BB73-10BB2385175F}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {5490BC46-3D1A-4F9A-8776-CF1BE3D41469}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {DDD6841A-31D4-4A59-8532-F9790E901171}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {EBE7AA26-55D4-4F72-B489-B55945E6019B}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {F9014B9C-BC8F-489C-B99F-097E18F9BC23}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C24EF892-429F-4B3C-A111-13DB7A494FCB}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {27D818B0-33C7-43D0-8EF2-5977B4196718}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E47A5D19-3066-4CB4-BBE5-FA97F105AFC3}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {2D172908-BD61-4ABF-9F82-27F51E6C1DA0}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E5363D05-5772-4597-88B3-326AF26B3C85}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {361B3E87-706B-4AD0-9EC1-006A44B38233}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3669A456-6321-4100-AC8E-FB1A95859A8E}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {FDCAFA60-9772-42E4-BBEF-7385D5D59B6F}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {27797092-0D53-4ED5-88B7-0C7B76E726BD}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package

Package: PerfCountersCollect

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: ConnectionString

Collapse image Properties

Name | Value
Expression | @[User::ConfigConnectionString]
Name | ConnectionString


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CacheDirectory
Namespace | User
QualifiedName | User::CacheDirectory
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs
VariablePath | \Package.Variables[User::CacheDirectory]


Package element

Package element: CacheFilename

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"
IncludeInDebugDump | False
Name | CacheFilename
Namespace | User
QualifiedName | User::CacheFilename
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache
VariablePath | \Package.Variables[User::CacheFilename]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | CacheWindow
Namespace | User
QualifiedName | User::CacheWindow
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 1
VariablePath | \Package.Variables[User::CacheWindow]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectionSetUID
Namespace | User
QualifiedName | User::CollectionSetUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 640012b7-4ed0-4865-a636-4946d73c425f
VariablePath | \Package.Variables[User::CollectionSetUID]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectorTypeUID
Namespace | User
QualifiedName | User::CollectorTypeUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 294605dd-21de-40b2-b20f-f3e170ea1ec3
VariablePath | \Package.Variables[User::CollectorTypeUID]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | ConfigConnectionString
Namespace | User
QualifiedName | User::ConfigConnectionString
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector
VariablePath | \Package.Variables[User::ConfigConnectionString]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | ExitEventName
Namespace | User
QualifiedName | User::ExitEventName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | EXITEVENT
VariablePath | \Package.Variables[User::ExitEventName]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InputParameters
Namespace | User
QualifiedName | User::InputParameters
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | <PerformanceCountersCollector><PerformanceCounters Objects="Process" Counters="*" Instances="*" /><PerformanceCounters Objects="Processor" Counters="*" Instances="*" /><PerformanceCounters Objects="Paging File" Counters="*" Instances="*" /><PerformanceCounters Objects="PhysicalDisk" Counters="*" Instances="*" /><PerformanceCounters Objects="Server" Counters="*" Instances="" /></PerformanceCountersCollector>
VariablePath | \Package.Variables[User::InputParameters]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InstanceID
Namespace | User
QualifiedName | User::InstanceID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | MSSQL.1
VariablePath | \Package.Variables[User::InstanceID]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InstanceName
Namespace | User
QualifiedName | User::InstanceName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | (local)
VariablePath | \Package.Variables[User::InstanceName]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | ItemID
Namespace | User
QualifiedName | User::ItemID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::ItemID]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | LoggingLevel
Namespace | User
QualifiedName | User::LoggingLevel
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 2
VariablePath | \Package.Variables[User::LoggingLevel]


Package element

Package element: LogID

Collapse image Properties

Name | Value
CreationName |
DataType | Int64
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | LogID
Namespace | User
QualifiedName | User::LogID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::LogID]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int64
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::LoopDuration]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | LoopEventName
Namespace | User
QualifiedName | User::LoopEventName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | LOOPEVENT
VariablePath | \Package.Variables[User::LoopEventName]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | MDWConnectionString
Namespace | User
QualifiedName | User::MDWConnectionString
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector
VariablePath | \Package.Variables[User::MDWConnectionString]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
CreationName |
DataType | Int64
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | ParentLogID
Namespace | User
QualifiedName | User::ParentLogID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::ParentLogID]


Package element

Package element: RowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountIn
Namespace | User
QualifiedName | User::RowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::RowCountIn]


Package element

Package element: RowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountOut
Namespace | User
QualifiedName | User::RowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::RowCountOut]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TargetConnectionString
Namespace | User
QualifiedName | User::TargetConnectionString
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector
VariablePath | \Package.Variables[User::TargetConnectionString]


Package element

Package element: TargetProcessID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TargetProcessID
Namespace | User
QualifiedName | User::TargetProcessID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | -1
VariablePath | \Package.Variables[User::TargetProcessID]


Package

Package: PerfCountersCollect

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersCollect

Collapse image Executables

Name | Description
LOOP - Aquire performance counters @ collection item frequency | Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)

Collapse image System variables

No items exist
Name Description


Package element

Package element: LOOP - Aquire performance counters @ collection item frequency

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | True
Description | Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {72e40adc-49ee-4175-b503-4f26f85912fc}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | LOOP - Aquire performance counters @ collection item frequency
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Collect Upload Package Sync Sequence Container | Sequence Container | Executables
Get SQL Process ID | Execute SQL Task | Executables
No-Op Sequence Container | Sequence Container | Executables
SQL - Log Package Iteration | Execute SQL Task | Executables
SQL - Log Package Stats | Execute SQL Task | Executables
{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2} |  | ForEachEnumerator
Constraint | Target Process ID Unknown | PrecedenceConstraints
Constraint 1 | Target Process ID Known | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
Constraint 3 |  | PrecedenceConstraints
Constraint 4 |  | PrecedenceConstraints
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: Collect Upload Package Sync Sequence Container

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | True
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {926A1F57-89A9-423A-8A68-151BE44CE956}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | Collect Upload Package Sync Sequence Container
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Retrieve Performance Counters | Data Flow Task | Executables
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: DFT - Retrieve Performance Counters

Collapse image Properties

Name | Value
[Perfomance Counters Source].[InputParameters] |
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 500
DefaultBufferSize | 1048576
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 2
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {C54F50A1-B2B5-4E92-9B84-4FAEDBF89FFF}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Retrieve Performance Counters
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Perfomance Counters Source |  | ComponentMetaDataCollection
RC - Number of counters collected | Counts the rows in a dataset. | ComponentMetaDataCollection
RFD - Write to cache | Loads raw data into a file. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Row Count Output 1 |  | PathCollection
TxPerfCounters Output |  | PathCollection
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables
SSIS diagram is missing


Package element

Package element: Perfomance Counters Source

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {6C124659-105F-4631-B6FB-9E185BB1FF15}
ContactInfo |
Description |
ID | 2
IdentificationString | Perfomance Counters Source
IsDefaultLocale | True
LocaleID | English (United States)
Name | Perfomance Counters Source
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
InputParameters | Provides XML input for the Performance Counter source component | CustomPropertyCollection
TxPerfCounters Output |  | OutputCollection


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ContainsID | False
Description | Provides XML input for the Performance Counter source component
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 3
IdentificationString | Perfomance Counters Source.Properties[InputParameters]
Name | InputParameters
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: TxPerfCounters Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 4
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | TxPerfCounters Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
path |  | OutputColumnCollection
formatted_value |  | OutputColumnCollection
raw_value_first |  | OutputColumnCollection
raw_value_second |  | OutputColumnCollection
counter_type |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
object_name |  | OutputColumnCollection
counter_name |  | OutputColumnCollection
instance_name |  | OutputColumnCollection


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 5
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]
Length | 2048
LineageID | 5
MappedColumnID | 0
Name | path
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_R8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 6
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]
Length | 0
LineageID | 6
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 7
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]
Length | 0
LineageID | 7
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 8
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]
Length | 0
LineageID | 8
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]
Length | 0
LineageID | 9
MappedColumnID | 0
Name | counter_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 10
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]
Length | 0
LineageID | 10
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 11
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]
Length | 2048
LineageID | 11
MappedColumnID | 0
Name | object_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 12
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]
Length | 2048
LineageID | 12
MappedColumnID | 0
Name | counter_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 13
IdentificationString | Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]
Length | 2048
LineageID | 13
MappedColumnID | 0
Name | instance_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of counters collected

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 14
IdentificationString | RC - Number of counters collected
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of counters collected
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | RC - Number of counters collected.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 16
IdentificationString | RC - Number of counters collected.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 17
IdentificationString | RC - Number of counters collected.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RFD - Write to cache

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {953B7879-214C-4AB8-AA79-AEA630F35C46}
ContactInfo | Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Loads raw data into a file.
ID | 18
IdentificationString | RFD - Write to cache
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFD - Write to cache
ObjectType | 10
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 2

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
WriteOption | Indicates what option is used to write to the file. | CustomPropertyCollection
Raw File Destination Input |  | InputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | RFD - Write to cache.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 20
IdentificationString | RFD - Write to cache.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 21
IdentificationString | RFD - Write to cache.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CacheFilename


Package element

Package element: WriteOption

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates what option is used to write to the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | RFD - Write to cache.Properties[WriteOption]
Name | WriteOption
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | WriteOption
UITypeEditor |
Value | 2


Package element

Package element: Raw File Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 23
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input]
IsAttached | True
IsSorted | False
Name | Raw File Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
collection_time |  | ExternalMetadataColumnCollection
path |  | ExternalMetadataColumnCollection
formatted_value |  | ExternalMetadataColumnCollection
raw_value_first |  | ExternalMetadataColumnCollection
raw_value_second |  | ExternalMetadataColumnCollection
counter_type |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
instance_name |  | ExternalMetadataColumnCollection
counter_name |  | ExternalMetadataColumnCollection
path |  | InputColumnCollection
formatted_value |  | InputColumnCollection
raw_value_first |  | InputColumnCollection
raw_value_second |  | InputColumnCollection
counter_type |  | InputColumnCollection
collection_time |  | InputColumnCollection
object_name |  | InputColumnCollection
counter_name |  | InputColumnCollection
instance_name |  | InputColumnCollection


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 33
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 34
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[path]
Length | 2048
MappedColumnID | 0
Name | path
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_R8
Description |
ID | 35
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[formatted_value]
Length | 0
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 36
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_first]
Length | 0
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 37
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_second]
Length | 0
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 38
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_type]
Length | 0
MappedColumnID | 0
Name | counter_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 39
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[object_name]
Length | 2048
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 40
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[instance_name]
Length | 2048
MappedColumnID | 0
Name | instance_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 41
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_name]
Length | 2048
MappedColumnID | 0
Name | counter_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 34
ID | 24
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[path]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 5
MappedColumnID | 0
Name | path
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_R8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 35
ID | 25
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[formatted_value]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 6
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 36
ID | 26
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_first]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 7
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 37
ID | 27
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_second]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 8
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 38
ID | 28
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 9
MappedColumnID | 0
Name | counter_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 33
ID | 29
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 10
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 39
ID | 30
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[object_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 11
MappedColumnID | 0
Name | object_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 41
ID | 31
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 12
MappedColumnID | 0
Name | counter_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 40
ID | 32
IdentificationString | RFD - Write to cache.Inputs[Raw File Destination Input].Columns[instance_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 13
MappedColumnID | 0
Name | instance_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Perfomance Counters Source
UsageType | UT_READONLY


Package element

Package element: BufferSizeTuning

Collapse image Properties

Name | Value
CreationName |
Description | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons.
FrequencyHint | Proportional
Name | BufferSizeTuning


Package element

Package element: PipelineBufferLeak

Collapse image Properties

Name | Value
CreationName |
Description | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer.
FrequencyHint | Proportional
Name | PipelineBufferLeak


Package element

Package element: PipelineComponentTime

Collapse image Properties

Name | Value
CreationName |
Description | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified.
FrequencyHint | Proportional
Name | PipelineComponentTime


Package element

Package element: PipelineExecutionPlan

Collapse image Properties

Name | Value
CreationName |
Description | The execution plan of the data flow.
FrequencyHint | Proportional
Name | PipelineExecutionPlan


Package element

Package element: PipelineExecutionTrees

Collapse image Properties

Name | Value
CreationName |
Description | The input the scheduler had when forming the execution plan.
FrequencyHint | Proportional
Name | PipelineExecutionTrees


Package element

Package element: PipelineInitialization

Collapse image Properties

Name | Value
CreationName |
Description | Various information from Data Flow initialization.
FrequencyHint | Proportional
Name | PipelineInitialization


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Raw File Destination Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: TxPerfCounters Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | TxPerfCounters Output
ObjectType | OT_PATH
StartPoint | TxPerfCounters Output


Package element

Package element: SyncRoot

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | SyncRoot
Namespace | User
QualifiedName | User::SyncRoot
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | PerfCountersLock
VariablePath | \Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container.Variables[User::SyncRoot]


Package element

Package element: Get SQL Process ID

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {8399b51b-c73c-4eb5-a314-447211237d45}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Get SQL Process ID
ResultSetType | 1
SqlStatementSource
SELECT ? = CONVERT (int, SERVERPROPERTY ('ProcessID'))
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
SqlProcessID |  | Variables
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: SqlProcessID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlProcessID
Namespace | User
QualifiedName | User::SqlProcessID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID.Variables[User::SqlProcessID]


Package element

Package element: No-Op Sequence Container

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | False
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {3C4A6AEF-9248-43F4-9428-9A90D2180467}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | No-Op Sequence Container
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: SQL - Log Package Iteration

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {81cbca02-95ea-4634-95ed-6ddd61802257}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log Package Iteration
ResultSetType | 1
SqlStatementSource
EXEC dbo.sp_syscollector_event_onpackageupdate ?
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: SQL - Log Package Stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {584e45b8-9755-4fa7-b8b7-f5c1d000603d}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log Package Stats
ResultSetType | 1
SqlStatementSource
{call dbo.sp_syscollector_event_onstatsupdate(?, N'PerfCountersCollect - Main Collect Loop', ?, ?, 0, ?)}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheFilename |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
TargetConnectionString |  | Variables
TargetProcessID |  | Variables


Package element

Package element: {710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DC.ForEachEventEnumerator.4
DelayValidation | False
Description |
ExitEventName | EXITEVENT
HasExpressions | True
HostType | ForEachEnumerator
ID | {6a2ecbd1-4348-4274-a8be-ea7c86bd0581}
LoopEventName | LOOPEVENT
Name | {710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}

Collapse image Elements

Name | Description | Type
ExitEventName |  | Expressions
LoopEventName |  | Expressions
ExitEventName |  | Expressions
LoopEventName |  | Expressions


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
Expression | @[User::ExitEventName]
Name | ExitEventName


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
Expression | @[User::LoopEventName]
Name | LoopEventName


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | Get SQL Process ID
CreationName |
Description | Target Process ID Unknown
EvalOp | Expression
EvaluatesTrue | True
Expression | @TargetProcessID == -1
ID | {A8FA1F46-2B02-4F55-A49E-4DD5C75C5F91}
LogicalAnd | False
Name | Constraint
PrecedenceExecutable | No-Op Sequence Container
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | Collect Upload Package Sync Sequence Container
CreationName |
Description | Target Process ID Known
EvalOp | Expression
EvaluatesTrue | False
Expression | @TargetProcessID != -1
ID | {7CCBF793-8783-41F4-ADC2-5E71B809CF51}
LogicalAnd | False
Name | Constraint 1
PrecedenceExecutable | No-Op Sequence Container
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel] >= 1
ID | {9F2FBB1A-FACF-4FC4-B755-A53DC3403F70}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | Collect Upload Package Sync Sequence Container
Value | Completion


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Iteration
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {71196d3d-021d-447d-973a-4c23d217cd1c}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | SQL - Log Package Stats
Value | Completion


Package element

Package element: Constraint 4

Collapse image Properties

Name | Value
ConstrainedExecutable | Collect Upload Package Sync Sequence Container
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {0610DCB9-BB0C-4B26-BE90-D0DEFF3CC36A}
LogicalAnd | False
Name | Constraint 4
PrecedenceExecutable | Get SQL Process ID
Value | Completion


Package

Package: PerfCountersCollect

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersCollect

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersCollect

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersCollect

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersCollect

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilename |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
RowCountOut |
TargetConnectionString |
TargetProcessID |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/23/2007 1:05:21 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{C2EAABC1-5BF3-4127-BEB3-26E94D026E7D}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxConcurrentExecutables="2" DTS:MaxErrorCount="0" DTS:ObjectName="PerfCountersCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="250" DTS:VersionGUID="{197DA2BF-EA76-4B95-A78C-06689218D0A0}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DF91A21-DC08-404B-B537-367F20F72E42}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B360CA6A-D82F-4B4E-81DB-7A8F702574F6}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FB8C290D-145C-46CE-BB73-10BB2385175F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5490BC46-3D1A-4F9A-8776-CF1BE3D41469}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{DDD6841A-31D4-4A59-8532-F9790E901171}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EBE7AA26-55D4-4F72-B489-B55945E6019B}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{F9014B9C-BC8F-489C-B99F-097E18F9BC23}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C24EF892-429F-4B3C-A111-13DB7A494FCB}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{27D818B0-33C7-43D0-8EF2-5977B4196718}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E47A5D19-3066-4CB4-BBE5-FA97F105AFC3}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2D172908-BD61-4ABF-9F82-27F51E6C1DA0}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E5363D05-5772-4597-88B3-326AF26B3C85}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{361B3E87-706B-4AD0-9EC1-006A44B38233}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3669A456-6321-4100-AC8E-FB1A95859A8E}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FDCAFA60-9772-42E4-BBEF-7385D5D59B6F}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{27797092-0D53-4ED5-88B7-0C7B76E726BD}" DTS:ObjectName="ParentLogID"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{29F8E7BD-603A-476F-9B2D-6C92119CE553}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{967E7E54-C796-4A22-995E-AAF61BB36173}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFilename">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF1ADEC8-05A4-4885-AE2E-F5F40EDF145A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C5042E47-57C6-42FF-B65A-36AA2F808656}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">640012b7-4ed0-4865-a636-4946d73c425f</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2E115FC3-AB18-4468-BF2D-74C84CFFF849}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">294605dd-21de-40b2-b20f-f3e170ea1ec3</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{64459284-6B94-45DB-A58B-50D48D02C473}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E988E92E-8FC0-4097-8AA4-CD14BD52783F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3EB44CAF-64FC-4F6A-A7BE-4160AEE20B34}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><PerformanceCountersCollector><PerformanceCounters Objects="Process" Counters="*" Instances="*" /><PerformanceCounters Objects="Processor" Counters="*" Instances="*" /><PerformanceCounters Objects="Paging File" Counters="*" Instances="*" /><PerformanceCounters Objects="PhysicalDisk" Counters="*" Instances="*" /><PerformanceCounters Objects="Server" Counters="*" Instances="" /></PerformanceCountersCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{928007D1-B14A-4D77-8204-80390F5FB6CB}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{43C71C34-F794-427C-92E6-D395182A0EA9}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4BE8D57B-5002-4B3E-B43A-50F76AF58148}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AA31DAA1-078D-4091-8B9F-1E74D4A51FA1}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D05C5D8C-82BF-4C78-AB42-47C01FF782BF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9C7C5068-DBAC-42CB-A94E-FA5EB1FAEE4A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9AA16C7F-334A-4F2C-9F11-CC3719DB3722}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2E6EF4C5-555E-4955-B8BD-22F04E37EB47}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B87950A5-F6B0-4944-957B-943E41BD4A9C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{610F0141-9C2A-427B-8774-BCA4C0B51F30}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5795944D-0E69-4702-9997-D9BA10D59589}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{44A62538-C3D0-4BFD-9216-9CF8B520D3FF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B5CE21C4-35D9-4861-B04C-7FFD03436B28}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TargetProcessID">
<DTS:VariableValue DTS:DataType="3">-1</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)" DTS:DTSID="{72e40adc-49ee-4175-b503-4f26f85912fc}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="LOOP - Aquire performance counters @ collection item frequency">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{6a2ecbd1-4348-4274-a8be-ea7c86bd0581}" DTS:ObjectName="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{926A1F57-89A9-423A-8A68-151BE44CE956}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Collect Upload Package Sync Sequence Container">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2C3410CF-ED28-49FC-B178-5A5D81706A6D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">PerfCountersLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{C54F50A1-B2B5-4E92-9B84-4FAEDBF89FFF}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Retrieve Performance Counters" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="500" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source" componentClassID="Microsoft.TxPerfCounters" name="Perfomance Counters Source" version="1">
-<properties>
<property dataType="System.String" description="Provides XML input for the Performance Counter source component" expressionType="Notify" name="InputParameters"/>
</properties>
-<outputs>
-<output refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output]" name="TxPerfCounters Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]" name="path"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]" dataType="r8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]" dataType="i8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]" dataType="i8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]" dataType="i4" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]" name="counter_name"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]" name="instance_name"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of counters collected" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write to cache" validateExternalMetadata="False" version="2">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFilename</property>
<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">2</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">
-<inputColumns>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[path]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[formatted_value]" cachedDataType="r8" cachedName="formatted_value" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[formatted_value]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_first]" cachedDataType="i8" cachedName="raw_value_first" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_first]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_second]" cachedDataType="i8" cachedName="raw_value_second" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_second]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_type]" cachedDataType="i4" cachedName="counter_type" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_type]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[object_name]" cachedDataType="wstr" cachedLength="2048" cachedName="object_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[object_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_name]" cachedDataType="wstr" cachedLength="2048" cachedName="counter_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[instance_name]" cachedDataType="wstr" cachedLength="2048" cachedName="instance_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[instance_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</input>
</inputs>
</component>
</components>
-<paths>
<path refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters.Paths[Row Count Output 1]" endId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input]" name="Row Count Output 1" startId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Outputs[Row Count Output 1]"/>
<path refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters.Paths[TxPerfCounters Output]" endId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]" name="TxPerfCounters Output" startId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{8399b51b-c73c-4eb5-a314-447211237d45}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="Get SQL Process ID" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8f6a0f37-d2f3-4cba-8dba-24bc965aa726}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlProcessID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="SELECT ? = CONVERT (int, SERVERPROPERTY ('ProcessID'))">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TargetProcessID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{3C4A6AEF-9248-43F4-9428-9A90D2180467}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:LocaleID="-1" DTS:ObjectName="No-Op Sequence Container">
<DTS:Variables/>
<DTS:Executables/>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{81cbca02-95ea-4634-95ed-6ddd61802257}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="EXEC dbo.sp_syscollector_event_onpackageupdate ?">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{584e45b8-9755-4fa7-b8b7-f5c1d000603d}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="{call dbo.sp_syscollector_event_onstatsupdate(?, N'PerfCountersCollect - Main Collect Loop', ?, ?, 0, ?)}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:Description="Target Process ID Unknown" DTS:DTSID="{A8FA1F46-2B02-4F55-A49E-4DD5C75C5F91}" DTS:EvalOp="1" DTS:Expression="@TargetProcessID == -1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:ObjectName="Constraint" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:Description="Target Process ID Known" DTS:DTSID="{7CCBF793-8783-41F4-ADC2-5E71B809CF51}" DTS:EvalOp="1" DTS:Expression="@TargetProcessID != -1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:ObjectName="Constraint 1" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{9F2FBB1A-FACF-4FC4-B755-A53DC3403F70}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{71196d3d-021d-447d-973a-4c23d217cd1c}" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Iteration" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{0610DCB9-BB0C-4B26-BE90-D0DEFF3CC36A}" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID" DTS:ObjectName="Constraint 4" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{A54A1B17-9B8C-435D-8F32-D034B664E27C}" DTS:ObjectName="{A54A1B17-9B8C-435D-8F32-D034B664E27C}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>


Package

Package: PerfCountersUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/23/2007 1:06:13 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {08D854CB-0D45-4E96-92C6-227A5DCD7066}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | 2
MaximumErrorCount | 0
Name | PerfCountersUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\PerfCountersUpload
PackagePath | MSDB\Data Collector\PerfCountersUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 305
VersionComments |
VersionGUID | {5A16B36F-15D1-4F67-A065-0C1E1AA2545A}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
CWM - Delete Old Cache Files | Cache Window Maintainance Task
FEF - For Each Collected Cache File Remaining, Try to Upload | Foreach Loop Container
Sequence Container | Sequence Container
SQL - Create snapshot ID in MDW | Execute SQL Task
SQL - Register collection set to MDW | Execute SQL Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint 2 |
Constraint 3 |
Constraint 4 |
Constraint 5 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFileName |
CacheOutput |
CacheUploadFilesPrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotID |
SourceID |
TargetConnectionString |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: PerfCountersUpload

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {767DBF63-6589-4A47-92B6-83B7FE6C3F88}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {8F817CE9-10DB-45C1-9F64-78474C992FAA}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {10D13CA8-84F9-41CF-A09D-8D3158B0243B}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {28F4286B-9D00-4269-AC22-C247150E220B}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {6893D265-3DAF-4111-9601-754CB28CF15D}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {D425A728-7408-4EE7-993B-46EFDC11947F}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {B1E74B02-0F02-41C7-A9D7-7612EADE9BD4}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {9ADFDA9C-89B3-460E-83EC-C123E92768AC}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E6BB8D08-A42F-480E-B74D-5764B102E229}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E6AB7F85-7160-4A06-A6AF-7A845BDED62B}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {333F5E0C-65B8-4430-8E6B-014393E50641}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3630A5D4-5D8A-4717-8F10-9287946862DC}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {AFA614B3-B990-404B-8186-7238F5089A5B}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {710AD3B8-3D9A-4ACA-A0AD-C95665519570}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {D88542C7-EBB5-4A03-87BB-DF54B345A295}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {90B244E1-CD1E-483B-AE10-D2E0C1319450}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package element

Package element: DaysUntilExpiration

Collapse image Properties

Name | Value
ConfigurationString | User::DaysUntilExpiration
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {F2ABCCBA-9B7C-4C1E-B5C5-A52ACE6475C3}
Name | DaysUntilExpiration
PackagePath | \Package.Variables[User::DaysUntilExpiration].Properties[Value]


Package

Package: PerfCountersUpload

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {2AEF0133-FEA0-472B-B12D-89F60FF1CBCD}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression | @[User::CacheDirectory] + "\\" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".csv"
IncludeInDebugDump | False
Name | CacheDirectory
Namespace | User
QualifiedName | User::CacheDirectory
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC
VariablePath | \Package.Variables[User::CacheDirectory]


Package element

Package element: CacheFileName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"
IncludeInDebugDump | False
Name | CacheFileName
Namespace | User
QualifiedName | User::CacheFileName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache
VariablePath | \Package.Variables[User::CacheFileName]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-46.644000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheUploadFilesPrefixPattern

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + "_upload_copyat_"{LF}
IncludeInDebugDump | False
Name | CacheUploadFilesPrefixPattern
Namespace | User
QualifiedName | User::CacheUploadFilesPrefixPattern
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_
VariablePath | \Package.Variables[User::CacheUploadFilesPrefixPattern]


Package element

Package element: DaysUntilExpiration

Collapse image Properties

Name | Value
CreationName |
DataType | Int16
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | DaysUntilExpiration
Namespace | User
QualifiedName | User::DaysUntilExpiration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::DaysUntilExpiration]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InputParameters
Namespace | User
QualifiedName | User::InputParameters
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::InputParameters]


Package element

Package element: SnapshotID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SnapshotID
Namespace | User
QualifiedName | User::SnapshotID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 6
VariablePath | \Package.Variables[User::SnapshotID]


Package element

Package element: SourceID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SourceID
Namespace | User
QualifiedName | User::SourceID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::SourceID]


Package element

Package element: MdwConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to upload collected data to a warehouse.
HasExpressions | True
HostType | ConnectionManager
ID | {68AAF105-9266-4AA6-A164-CD0A512B42D3}
InitialCatalog | MDW
Name | MdwConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: ConnectionString

Collapse image Properties

Name | Value
Expression | @[User::MDWConnectionString]
Name | ConnectionString


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-46.666000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: TargetConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information from the monitored (target) instance.
HasExpressions | True
HostType | ConnectionManager
ID | {132C9722-DFF5-4B1E-8335-113AB9B72B8B}
InitialCatalog |
Name | TargetConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: ConnectionString

Collapse image Properties

Name | Value
Expression | @[User::TargetConnectionString]
Name | ConnectionString


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-46.687000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package

Package: PerfCountersUpload

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersUpload

Collapse image Executables

Name | Description
CWM - Delete Old Cache Files | Cache Window Maintainance Task
FEF - For Each Collected Cache File Remaining, Try to Upload | Foreach Loop Container
Sequence Container | Sequence Container
SQL - Create snapshot ID in MDW | Execute SQL Task
SQL - Register collection set to MDW | Execute SQL Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: CWM - Delete Old Cache Files

Collapse image Properties

Name | Value
ApartmentThreaded | True
CacheFileNamePrefixVarName | User::CacheUploadFilesPrefixPattern
CacheWindow | 0
CollectionSetUID |
CollectorTempDir |
CollectorTypeUID |
ConfigConnectionString |
CreationName | Microsoft.SqlServer.Management.Collector.Tasks.CacheWindowMaintainanceTask, Microsoft.SqlServer.Management.CollectorTasks, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Cache Window Maintainance Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
ExitEventName |
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {884A53D3-672D-42BF-A6D4-A96E27430985}
InstanceName |
IsDefaultLocaleID | True
IsolationLevel | Serializable
ItemID | 0
LocaleID | English (United States)
LoggingLevel | 0
LoggingMode | Disabled
LoopEventName |
MaximumErrorCount | 0
MdwConnectionString |
Name | CWM - Delete Old Cache Files
SuspendRequired | False
TargetConnectionString |
TargetServerVersion | 130
TaskDisplayName | Cache Window Maintainance Task
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
CacheFileNamePrefixVarName |  | Expressions
LoopDuration |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheFileNamePrefixVarName

Collapse image Properties

Name | Value
Expression | "User::CacheUploadFilesPrefixPattern"
Name | CacheFileNamePrefixVarName


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\CWM - Delete Old Cache Files.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-46.870000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: FEF - For Each Collected Cache File Remaining, Try to Upload

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | True
Description | Foreach Loop Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {2B763872-7CE3-4CFF-88F9-5A1EDFA05BC8}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FEF - For Each Collected Cache File Remaining, Try to Upload
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Bulk Insert Collected data into MDW | Data Flow Task | Executables
DFT - Update perf_counters_instances table with newly discovered instances | Data Flow Task | Executables
FST - Cleanup | File System Task | Executables
SQL - Log Package Stats | Execute SQL Task | Executables
{EE8E4F57-1623-455B-B0B2-ABCCA165FFB5} |  | ForEachEnumerator
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
CacheFileToUpload |  | Variables
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
RowCountOutFinal |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: DFT - Bulk Insert Collected data into MDW

Collapse image Properties

Name | Value
[DRV - Add snapshot id].[Derived Column Output].[collect_time_convert].[FriendlyExpression] | (DT_DBTIMESTAMP2,1)collection_time
[DRV - Add snapshot id].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotID]
[LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted].[SqlCommand] | SELECT path, performance_counter_id FROM snapshots.performance_counter_instances
[LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted].[SqlCommandParam] | SELECT [path], [performance_counter_id] FROM [snapshots].[performance_counter_instances] WHERE [path] = ?
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 1000
DefaultBufferSize | 1048576
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 2
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {E0D31BC6-173F-4DB9-BBD1-941BFE618005}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | DFT - Bulk Insert Collected data into MDW
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DRV - Add snapshot id | Updates column values using expressions | ComponentMetaDataCollection
LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted | Looks up values in a reference dataset by using exact matching. | ComponentMetaDataCollection
ODB - Fast upload data to performance_counter_values | OLE DB Destination | ComponentMetaDataCollection
RAW - Read current tempoary storage | Extracts data from a raw file. | ComponentMetaDataCollection
RC - Number of rows failed to insert | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Number of rows from cache | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Number of rows inserted | Counts the rows in a dataset. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Derived Column Output |  | PathCollection
Failed Rows |  | PathCollection
Lookup Match Output |  | PathCollection
Raw File Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
CacheFileToUpload |  | Variables
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
RowCountOutFinal |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
SSIS diagram is missing


Package element

Package element: DRV - Add snapshot id

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 2
IdentificationString | DRV - Add snapshot id
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add snapshot id
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 3
IdentificationString | DRV - Add snapshot id.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
collection_time |  | InputColumnCollection


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 4
IdentificationString | DRV - Add snapshot id.Inputs[Derived Column Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 74
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage
UsageType | UT_READONLY


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 5
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | OutputColumnCollection
collect_time_convert |  | OutputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 6
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 6
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotID]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 8
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotID]


Package element

Package element: collect_time_convert

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP2
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]
Length | 0
LineageID | 9
MappedColumnID | 0
Name | collect_time_convert
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 1
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_IgnoreFailure

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 10
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (DT_DBTIMESTAMP2,1)#74


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 11
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (DT_DBTIMESTAMP2,1)collection_time


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 12
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 13
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 13
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 14
IdentificationString | DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 14
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EDED6488-9C19-496D-9F1D-99E1DB55AF77}
ContactInfo | Lookup;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | Looks up values in a reference dataset by using exact matching.
ID | 15
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted
IsDefaultLocale | True
LocaleID | English (United States)
Name | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 6

Collapse image Elements

Name | Description | Type
SqlCommand | Specifies the SQL statement that generates the lookup table. | CustomPropertyCollection
SqlCommandParam | Specifies a SQL statement that uses parameters to generate the lookup table. | CustomPropertyCollection
CacheType | Specifies the cache type of the lookup table. | CustomPropertyCollection
MaxMemoryUsage | Maximum Memory Usage for Reference Cache on a 32 bit platform. | CustomPropertyCollection
MaxMemoryUsage64 | Maximum Memory Usage for Reference Cache on a 64 bit platform. | CustomPropertyCollection
ReferenceMetadataXml | Indicates whether to reference metadata in an XML format. | CustomPropertyCollection
ParameterMap | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
ConnectionType | Specifies the type of connection used to access the reference dataset. | CustomPropertyCollection
NoMatchBehavior | Specifies how the Lookup transformation handles rows without matching entries in the reference data set. | CustomPropertyCollection
NoMatchCachePercentage | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset. | CustomPropertyCollection
TreatDuplicateKeysAsError | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used. | CustomPropertyCollection
Lookup Input |  | InputCollection
Lookup Match Output |  | OutputCollection
Lookup No Match Output | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output." | OutputCollection
Lookup Error Output |  | OutputCollection
OleDbConnection | Connection manager used to access lookup data. | RuntimeConnectionCollection


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the SQL statement that generates the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 16
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | SELECT path, performance_counter_id FROM snapshots.performance_counter_instances


Package element

Package element: SqlCommandParam

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies a SQL statement that uses parameters to generate the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 17
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[SqlCommandParam]
Name | SqlCommandParam
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | SELECT [path], [performance_counter_id] FROM [snapshots].[performance_counter_instances] WHERE [path] = ?


Package element

Package element: CacheType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the cache type of the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[CacheType]
Name | CacheType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | CacheType
UITypeEditor |
Value | 0


Package element

Package element: MaxMemoryUsage

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 32 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[MaxMemoryUsage]
Name | MaxMemoryUsage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: MaxMemoryUsage64

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 64 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 20
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[MaxMemoryUsage64]
Name | MaxMemoryUsage64
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: ReferenceMetadataXml

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether to reference metadata in an XML format.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 21
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[ReferenceMetadataXml]
Name | ReferenceMetadataXml
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | <referenceMetadata><referenceColumns><referenceColumn name="path" dataType="DT_WSTR" length="2048" precision="0" scale="0" codePage="0"/><referenceColumn name="performance_counter_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata>


Package element

Package element: ParameterMap

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[ParameterMap]
Name | ParameterMap
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | #75;


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 23
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: ConnectionType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of connection used to access the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 24
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[ConnectionType]
Name | ConnectionType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupConnectionType
UITypeEditor |
Value | 0


Package element

Package element: NoMatchBehavior

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies how the Lookup transformation handles rows without matching entries in the reference data set.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 25
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[NoMatchBehavior]
Name | NoMatchBehavior
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupNoMatchBehavior
UITypeEditor |
Value | 1


Package element

Package element: NoMatchCachePercentage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 26
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[NoMatchCachePercentage]
Name | NoMatchCachePercentage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: TreatDuplicateKeysAsError

Collapse image Properties

Name | Value
ContainsID | False
Description | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 27
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Properties[TreatDuplicateKeysAsError]
Name | TreatDuplicateKeysAsError
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: Lookup Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 29
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]
IsAttached | True
IsSorted | False
Name | Lookup Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
path |  | InputColumnCollection


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 30
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input].Columns[path]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 75
MappedColumnID | 0
Name | path
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
JoinToReferenceColumn | Specifies the column in the reference table that a column joins. | CustomPropertyCollection
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: JoinToReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table that a column joins.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 31
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input].Columns[path].Properties[JoinToReferenceColumn]
Name | JoinToReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | path


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 32
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input].Columns[path].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: Lookup Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation | Lookup
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 33
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Lookup Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 29
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
performance_counter_id |  | OutputColumnCollection


Package element

Package element: performance_counter_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 34
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]
Length | 0
LineageID | 34
MappedColumnID | 0
Name | performance_counter_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 35
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | performance_counter_id


Package element

Package element: Lookup No Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 36
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup No Match Output]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Lookup No Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 29
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Lookup Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 37
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Lookup Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 29
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 38
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorCode]
Length | 0
LineageID | 38
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 39
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 39
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {68AAF105-9266-4AA6-A164-CD0A512B42D3}
Description | Connection manager used to access lookup data.
ID | 28
IdentificationString | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODB - Fast upload data to performance_counter_values

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 40
IdentificationString | ODB - Fast upload data to performance_counter_values
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODB - Fast upload data to performance_counter_values
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 41
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 42
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[performance_counter_values]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 43
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 44
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 45
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 46
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 47
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 48
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 49
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 50
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 51
IdentificationString | ODB - Fast upload data to performance_counter_values.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1000


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_RedirectRow
HasSideEffects | True
ID | 53
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | False
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
performance_counter_instance_id |  | ExternalMetadataColumnCollection
snapshot_id |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
formatted_value |  | ExternalMetadataColumnCollection
raw_value_first |  | ExternalMetadataColumnCollection
raw_value_second |  | ExternalMetadataColumnCollection
snapshot_id |  | InputColumnCollection
raw_value_second |  | InputColumnCollection
raw_value_first |  | InputColumnCollection
formatted_value |  | InputColumnCollection
performance_counter_id |  | InputColumnCollection
collect_time_convert |  | InputColumnCollection


Package element

Package element: performance_counter_instance_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 60
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_instance_id]
Length | 0
MappedColumnID | 0
Name | performance_counter_instance_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 61
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]
Length | 0
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 62
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_R8
Description |
ID | 63
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[formatted_value]
Length | 0
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 64
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_first]
Length | 0
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 65
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_second]
Length | 0
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 61
ID | 54
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 6
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add snapshot id
UsageType | UT_READONLY


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 65
ID | 55
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_second]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 78
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage
UsageType | UT_READONLY


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 64
ID | 56
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_first]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 77
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage
UsageType | UT_READONLY


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_R8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 63
ID | 57
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[formatted_value]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 76
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage
UsageType | UT_READONLY


Package element

Package element: performance_counter_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 60
ID | 58
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[performance_counter_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 34
MappedColumnID | 0
Name | performance_counter_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted
UsageType | UT_READONLY


Package element

Package element: collect_time_convert

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 62
ID | 59
IdentificationString | ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[collect_time_convert]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 9
MappedColumnID | 0
Name | collect_time_convert
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 1
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add snapshot id
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 66
IdentificationString | ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output]
IsAttached | True
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 53
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 67
IdentificationString | ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 67
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 68
IdentificationString | ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 68
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {68AAF105-9266-4AA6-A164-CD0A512B42D3}
Description | The OLE DB runtime connection used to access the database.
ID | 52
IdentificationString | ODB - Fast upload data to performance_counter_values.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RAW - Read current tempoary storage

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {036C7941-58DF-4CD3-BF13-E5373258D001}
ContactInfo | Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Extracts data from a raw file.
ID | 69
IdentificationString | RAW - Read current tempoary storage
IsDefaultLocale | True
LocaleID | English (United States)
Name | RAW - Read current tempoary storage
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 1

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
Raw File Source Output |  | OutputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 70
IdentificationString | RAW - Read current tempoary storage.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 71
IdentificationString | RAW - Read current tempoary storage.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 72
IdentificationString | RAW - Read current tempoary storage.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CacheFileToUpload


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 73
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Raw File Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
collection_time |  | ExternalMetadataColumnCollection
path |  | ExternalMetadataColumnCollection
formatted_value |  | ExternalMetadataColumnCollection
raw_value_first |  | ExternalMetadataColumnCollection
raw_value_second |  | ExternalMetadataColumnCollection
counter_type |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
instance_name |  | ExternalMetadataColumnCollection
counter_name |  | ExternalMetadataColumnCollection
collection_time |  | OutputColumnCollection
path |  | OutputColumnCollection
formatted_value |  | OutputColumnCollection
raw_value_first |  | OutputColumnCollection
raw_value_second |  | OutputColumnCollection
counter_type |  | OutputColumnCollection
object_name |  | OutputColumnCollection
instance_name |  | OutputColumnCollection
counter_name |  | OutputColumnCollection


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 83
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 84
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[path]
Length | 2048
MappedColumnID | 0
Name | path
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_R8
Description |
ID | 85
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[formatted_value]
Length | 0
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 86
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]
Length | 0
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 87
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]
Length | 0
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 88
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_type]
Length | 0
MappedColumnID | 0
Name | counter_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 89
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[object_name]
Length | 2048
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 90
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[instance_name]
Length | 2048
MappedColumnID | 0
Name | instance_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 91
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_name]
Length | 2048
MappedColumnID | 0
Name | counter_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 83
ID | 74
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]
Length | 0
LineageID | 74
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 84
ID | 75
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]
Length | 2048
LineageID | 75
MappedColumnID | 0
Name | path
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_R8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 85
ID | 76
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]
Length | 0
LineageID | 76
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 86
ID | 77
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]
Length | 0
LineageID | 77
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 87
ID | 78
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]
Length | 0
LineageID | 78
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 88
ID | 79
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_type]
Length | 0
LineageID | 79
MappedColumnID | 0
Name | counter_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 89
ID | 80
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[object_name]
Length | 2048
LineageID | 80
MappedColumnID | 0
Name | object_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 90
ID | 81
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[instance_name]
Length | 2048
LineageID | 81
MappedColumnID | 0
Name | instance_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 91
ID | 82
IdentificationString | RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_name]
Length | 2048
LineageID | 82
MappedColumnID | 0
Name | counter_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of rows failed to insert

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 92
IdentificationString | RC - Number of rows failed to insert
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of rows failed to insert
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 93
IdentificationString | RC - Number of rows failed to insert.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 94
IdentificationString | RC - Number of rows failed to insert.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 95
IdentificationString | RC - Number of rows failed to insert.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 94
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of rows from cache

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 96
IdentificationString | RC - Number of rows from cache
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of rows from cache
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 97
IdentificationString | RC - Number of rows from cache.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 98
IdentificationString | RC - Number of rows from cache.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 99
IdentificationString | RC - Number of rows from cache.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 98
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of rows inserted

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 100
IdentificationString | RC - Number of rows inserted
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of rows inserted
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 101
IdentificationString | RC - Number of rows inserted.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 102
IdentificationString | RC - Number of rows inserted.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 103
IdentificationString | RC - Number of rows inserted.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 102
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Failed Rows

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Failed Rows
ObjectType | OT_PATH
StartPoint | OLE DB Destination Error Output


Package element

Package element: Lookup Match Output

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Lookup Match Output
ObjectType | OT_PATH
StartPoint | Lookup Match Output


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Raw File Source Output
ObjectType | OT_PATH
StartPoint | Raw File Source Output


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Lookup Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Destination Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: CacheFileToUpload

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CacheFileToUpload
Namespace | User
QualifiedName | User::CacheFileToUpload
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\MACIES4_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::CacheFileToUpload]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 83136
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: RowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountError
Namespace | User
QualifiedName | User::RowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::RowCountError]


Package element

Package element: RowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountIn
Namespace | User
QualifiedName | User::RowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::RowCountIn]


Package element

Package element: RowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountOut
Namespace | User
QualifiedName | User::RowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::RowCountOut]


Package element

Package element: RowCountOutFinal

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | @[User::RowCountOut] - @[User::RowCountError]
IncludeInDebugDump | False
Name | RowCountOutFinal
Namespace | User
QualifiedName | User::RowCountOutFinal
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::RowCountOutFinal]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.153000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: DFT - Update perf_counters_instances table with newly discovered instances

CollapseAll image

Collapse image Properties

Name | Value
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 1000
DefaultBufferSize | 1048576
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 2
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {E24F9238-4DE6-4DFE-97B9-35990020B45A}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | DFT - Update perf_counters_instances table with newly discovered instances
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type) | OLE DB Destination | ComponentMetaDataCollection
RAW - Read current tempoary storage - purpose - obtain counter paths | Extracts data from a raw file. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Raw File Source Output |  | PathCollection
CacheFileToUpload |  | Variables
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
RowCountOutFinal |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
SSIS diagram is missing


Package element

Package element: ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 2
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)
IsDefaultLocale | False
LocaleID | English (United States)
Name | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | False
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 3
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 4
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[performance_counter_instances]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 5
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 8
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 9
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 10
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1000


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_IgnoreFailure
HasSideEffects | True
ID | 15
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | False
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
performance_counter_id |  | ExternalMetadataColumnCollection
path |  | ExternalMetadataColumnCollection
counter_type |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
counter_name |  | ExternalMetadataColumnCollection
instance_name |  | ExternalMetadataColumnCollection
path |  | InputColumnCollection
counter_type |  | InputColumnCollection
object_name |  | InputColumnCollection
counter_name |  | InputColumnCollection
instance_name |  | InputColumnCollection


Package element

Package element: performance_counter_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 21
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_id]
Length | 0
MappedColumnID | 0
Name | performance_counter_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 22
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[path]
Length | 2048
MappedColumnID | 0
Name | path
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 23
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_type]
Length | 0
MappedColumnID | 0
Name | counter_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 24
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[object_name]
Length | 2048
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 25
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_name]
Length | 2048
MappedColumnID | 0
Name | counter_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 26
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[instance_name]
Length | 2048
MappedColumnID | 0
Name | instance_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 22
ID | 16
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[path]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 36
MappedColumnID | 0
Name | path
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage - purpose - obtain counter paths
UsageType | UT_READONLY


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 23
ID | 17
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 40
MappedColumnID | 0
Name | counter_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage - purpose - obtain counter paths
UsageType | UT_READONLY


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 24
ID | 18
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[object_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 41
MappedColumnID | 0
Name | object_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage - purpose - obtain counter paths
UsageType | UT_READONLY


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 25
ID | 19
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 43
MappedColumnID | 0
Name | counter_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage - purpose - obtain counter paths
UsageType | UT_READONLY


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 26
ID | 20
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[instance_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 2048
LineageID | 42
MappedColumnID | 0
Name | instance_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RAW - Read current tempoary storage - purpose - obtain counter paths
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 27
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 15
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 28
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 28
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 29
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 29
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {68AAF105-9266-4AA6-A164-CD0A512B42D3}
Description | The OLE DB runtime connection used to access the database.
ID | 14
IdentificationString | ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RAW - Read current tempoary storage - purpose - obtain counter paths

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {036C7941-58DF-4CD3-BF13-E5373258D001}
ContactInfo | Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Extracts data from a raw file.
ID | 30
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths
IsDefaultLocale | False
LocaleID | English (United States)
Name | RAW - Read current tempoary storage - purpose - obtain counter paths
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 1

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
Raw File Source Output |  | OutputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 31
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 32
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 33
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CacheFileToUpload


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 34
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Raw File Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
collection_time |  | ExternalMetadataColumnCollection
path |  | ExternalMetadataColumnCollection
formatted_value |  | ExternalMetadataColumnCollection
raw_value_first |  | ExternalMetadataColumnCollection
raw_value_second |  | ExternalMetadataColumnCollection
counter_type |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
instance_name |  | ExternalMetadataColumnCollection
counter_name |  | ExternalMetadataColumnCollection
collection_time |  | OutputColumnCollection
path |  | OutputColumnCollection
formatted_value |  | OutputColumnCollection
raw_value_first |  | OutputColumnCollection
raw_value_second |  | OutputColumnCollection
counter_type |  | OutputColumnCollection
object_name |  | OutputColumnCollection
instance_name |  | OutputColumnCollection
counter_name |  | OutputColumnCollection


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 44
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 45
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[path]
Length | 2048
MappedColumnID | 0
Name | path
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_R8
Description |
ID | 46
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[formatted_value]
Length | 0
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 47
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]
Length | 0
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 48
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]
Length | 0
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 49
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_type]
Length | 0
MappedColumnID | 0
Name | counter_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 50
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[object_name]
Length | 2048
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 51
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[instance_name]
Length | 2048
MappedColumnID | 0
Name | instance_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 52
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_name]
Length | 2048
MappedColumnID | 0
Name | counter_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 44
ID | 35
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[collection_time]
Length | 0
LineageID | 35
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: path

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 45
ID | 36
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]
Length | 2048
LineageID | 36
MappedColumnID | 0
Name | path
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: formatted_value

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_R8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 46
ID | 37
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[formatted_value]
Length | 0
LineageID | 37
MappedColumnID | 0
Name | formatted_value
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_first

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 47
ID | 38
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_first]
Length | 0
LineageID | 38
MappedColumnID | 0
Name | raw_value_first
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: raw_value_second

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 48
ID | 39
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_second]
Length | 0
LineageID | 39
MappedColumnID | 0
Name | raw_value_second
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 49
ID | 40
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]
Length | 0
LineageID | 40
MappedColumnID | 0
Name | counter_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 50
ID | 41
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]
Length | 2048
LineageID | 41
MappedColumnID | 0
Name | object_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: instance_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 51
ID | 42
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]
Length | 2048
LineageID | 42
MappedColumnID | 0
Name | instance_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: counter_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 52
ID | 43
IdentificationString | RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]
Length | 2048
LineageID | 43
MappedColumnID | 0
Name | counter_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Destination Input
Name | Raw File Source Output
ObjectType | OT_PATH
StartPoint | Raw File Source Output


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 83303
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.309000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: FST - Cleanup

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | File System Task
Destination |
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {2665570b-6fcf-43a3-b8ba-5f3d5bd99357}
IsDefaultLocaleID | True
IsDestinationPathVariable | False
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FST - Cleanup
Operation | 2
OperationName |
OverwriteDestinationFile | False
PreservedAttributes | 0
Source | User::CacheFileToUpload
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
CacheFileToUpload |  | Variables
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
RowCountOutFinal |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: FileSystemOperation

Collapse image Properties

Name | Value
CreationName |
Description | Provides information about running file system operations.
FrequencyHint | Consistent
Name | FileSystemOperation


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 83416
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.431000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: SQL - Log Package Stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {CD4E0504-1536-4071-A070-9A7D8A6D7B32}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | SQL - Log Package Stats
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onstatsupdate (?, N'PerfCountersUpload - Main Upload Loop', ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheFileToUpload |  | Variables
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
RowCountOutFinal |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 83536
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.543000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: {EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DTS.ForEachFileEnumerator.5
DelayValidation | False
Description |
Directory | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC
FileNameRetrieval | 0
FileSpec | ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_*.cache
HasExpressions | True
HostType | ForEachEnumerator
ID | {EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}
Name | {EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}
Recurse | False

Collapse image Elements

Name | Description | Type
Directory |  | Expressions
FileSpec |  | Expressions
Directory |  | Expressions
FileSpec |  | Expressions


Package element

Package element: Directory

Collapse image Properties

Name | Value
Expression | @[User::CacheDirectory]
Name | Directory


Package element

Package element: FileSpec

Collapse image Properties

Name | Value
Expression | @[User::CacheUploadFilesPrefixPattern] + "*.cache"
Name | FileSpec


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel] >= 1
ID | {17CA7F5E-10A1-41B3-9F5F-FD4CCB15FB8D}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | DFT - Bulk Insert Collected data into MDW
Value | Completion


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | FST - Cleanup
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {649D8163-D3B7-4998-A29D-ABDE0EAAEA77}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | DFT - Bulk Insert Collected data into MDW
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Bulk Insert Collected data into MDW
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {96006738-B053-493C-95AD-64168C63BA4C}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | DFT - Update perf_counters_instances table with newly discovered instances
Value | Completion


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 83596
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.603000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: Sequence Container

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | True
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {A7035C8A-5219-42B8-BDE6-365F3240D4B2}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | Sequence Container
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FAT - Check Current Cache File Exists | File Access Task | Executables
FST - Rename Current Cache File | File System Task | Executables
Constraint |  | PrecedenceConstraints
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: FAT - Check Current Cache File Exists

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.FileAccessTask.4
DebugMode | False
DelayValidation | False
Description | File Access Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FilePath | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {B737D089-54D7-40A4-9F46-A1B8AA87FF57}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Mode | 0
Name | FAT - Check Current Cache File Exists
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FilePath |  | Expressions
Mode |  | Expressions
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: FilePath

Collapse image Properties

Name | Value
Expression | @[User::CacheFileName]
Name | FilePath


Package element

Package element: Mode

Collapse image Properties

Name | Value
Expression | 0
Name | Mode


Package element

Package element: SyncRoot

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | SyncRoot
Namespace | User
QualifiedName | User::SyncRoot
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | PerfCountersLock
VariablePath | \Package\Sequence Container.Variables[User::SyncRoot]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.743000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: FST - Rename Current Cache File

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | File System Task
Destination | User::CacheOutput
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {609f9d36-aad4-4395-8b31-0c27b6ffefdd}
IsDefaultLocaleID | True
IsDestinationPathVariable | True
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FST - Rename Current Cache File
Operation | 3
OperationName |
OverwriteDestinationFile | True
PreservedAttributes | 0
Source | User::CacheFileName
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.845000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | FST - Rename Current Cache File
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {B5B398D6-E5AB-4742-ABD1-AD95B984F0AF}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | FAT - Check Current Cache File Exists
Value | Success


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-47.900000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: SQL - Create snapshot ID in MDW

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {02641DDC-5CDC-4BD2-8112-1FA7BE3A488C}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Create snapshot ID in MDW
ResultSetType | 1
SqlStatementSource
execute [core].[sp_create_snapshot]
  @collection_set_uid=?
, @collector_type_uid=?
, @machine_name=?
, @named_instance=?
, @log_id=?
, @snapshot_id=? OUTPUT
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-48.004000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: SQL - Register collection set to MDW

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {a3667210-4432-41f0-8d04-d53b10574f52}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Register collection set to MDW
ResultSetType | 1
SqlStatementSource
execute [core].[sp_update_data_source]
  @collection_set_uid=?
, @machine_name=?
, @named_instance=?
, @days_until_expiration=?
, @source_id=? OUTPUT
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheFileName |  | Variables
CacheOutput |  | Variables
CacheUploadFilesPrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-48.087000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package

Package: PerfCountersUpload

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersUpload

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersUpload

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: PerfCountersUpload

Collapse image Precedence constraints

Name | Description
Constraint 2 |
Constraint 3 |
Constraint 4 |
Constraint 5 |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Create snapshot ID in MDW
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {3E8C2FDE-1E6D-4C61-A58B-D114921193FC}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | SQL - Register collection set to MDW
Value | Completion


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | CWM - Delete Old Cache Files
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {E0BDAD4D-63EC-4C7B-B392-48D799204549}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | Sequence Container
Value | Success


Package element

Package element: Constraint 4

Collapse image Properties

Name | Value
ConstrainedExecutable | FEF - For Each Collected Cache File Remaining, Try to Upload
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {5B5E777C-2E3A-453F-91F2-6E28C7BC6B13}
LogicalAnd | True
Name | Constraint 4
PrecedenceExecutable | SQL - Create snapshot ID in MDW
Value | Success


Package element

Package element: Constraint 5

Collapse image Properties

Name | Value
ConstrainedExecutable | FEF - For Each Collected Cache File Remaining, Try to Upload
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {766AFD21-4197-496F-90A8-2C9B25E85D3C}
LogicalAnd | True
Name | Constraint 5
PrecedenceExecutable | CWM - Delete Old Cache Files
Value | Success


Package

Package: PerfCountersUpload

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFileName |
CacheOutput |
CacheUploadFilesPrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotID |
SourceID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-48.141000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/23/2007 1:06:13 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{08D854CB-0D45-4E96-92C6-227A5DCD7066}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxConcurrentExecutables="2" DTS:MaxErrorCount="0" DTS:ObjectName="PerfCountersUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="305" DTS:VersionGUID="{59445182-B898-4C9B-8897-B1792CAE313C}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{2AEF0133-FEA0-472B-B12D-89F60FF1CBCD}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{132C9722-DFF5-4B1E-8335-113AB9B72B8B}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{767DBF63-6589-4A47-92B6-83B7FE6C3F88}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8F817CE9-10DB-45C1-9F64-78474C992FAA}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{10D13CA8-84F9-41CF-A09D-8D3158B0243B}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{28F4286B-9D00-4269-AC22-C247150E220B}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{6893D265-3DAF-4111-9601-754CB28CF15D}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D425A728-7408-4EE7-993B-46EFDC11947F}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B1E74B02-0F02-41C7-A9D7-7612EADE9BD4}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9ADFDA9C-89B3-460E-83EC-C123E92768AC}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E6BB8D08-A42F-480E-B74D-5764B102E229}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E6AB7F85-7160-4A06-A6AF-7A845BDED62B}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{333F5E0C-65B8-4430-8E6B-014393E50641}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3630A5D4-5D8A-4717-8F10-9287946862DC}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{AFA614B3-B990-404B-8186-7238F5089A5B}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{710AD3B8-3D9A-4ACA-A0AD-C95665519570}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D88542C7-EBB5-4A03-87BB-DF54B345A295}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{90B244E1-CD1E-483B-AE10-D2E0C1319450}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{F2ABCCBA-9B7C-4C1E-B5C5-A52ACE6475C3}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4C443096-5A0D-4CB6-BD3F-6610BE9905E8}" DTS:Expression="@[User::CacheDirectory] + "\\" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".csv"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{63E3032E-054F-412B-B853-7538BDAAFE3B}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileName">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{940C99E7-EF6F-40B0-982C-9553759C2414}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache" " DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheOutput">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-58-57.206000000.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F81B33AE-4244-4889-BF12-8E6BFB11030F}" DTS:EvaluateAsExpression="True" DTS:Expression="@[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + "_upload_copyat_" " DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheUploadFilesPrefixPattern">
<DTS:VariableValue DTS:DataType="8">ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F220B51D-1FFB-4003-9EC0-2285752F310B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D0868A36-C135-49D0-A8F1-13542A84B573}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">640012b7-4ed0-4865-a636-4946d73c425f</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CBF24B5A-C8CF-48E8-9509-D3204867FCC7}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">294605dd-21de-40b2-b20f-f3e170ea1ec3</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F04807FB-804D-4425-81AF-F7CB457826A5}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{888B7540-0785-4F57-A56D-D58BBF911921}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E3526FDC-CCDB-4346-8948-14B54720A63F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EE554175-B0CA-4786-AFB9-D0253F3C39A6}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C0E00118-2CAF-4F3C-9E53-A1E2CE30AB7C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{38EFEA28-38F1-4ED1-8DBC-AAB0E2265EE5}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{39074E00-5D29-4CBF-9105-C3A346061C04}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E15C61FE-2988-4503-8A17-1F01F9D5E2D4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{98D987AA-CF36-4316-933A-05D4B96743E5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CEFF4763-688B-466E-A1E7-E290014294EF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7017ED52-3782-4E8C-9165-776BD4BF407F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7012C6A3-A799-452D-A88F-F82FEBE5B864}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C51017D6-9981-46D1-8375-EBCE6B57EC9C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotID">
<DTS:VariableValue DTS:DataType="3">6</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{82A4097B-17D7-4B24-B70A-D548BA812BC8}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0EA15FE2-50C0-41A8-AD04-B859D38EA993}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\CWM - Delete Old Cache Files" DTS:CreationName="Microsoft.CacheWindowMaintainanceTask" DTS:DelayValidation="True" DTS:Description="Cache Window Maintainance Task" DTS:DTSID="{884A53D3-672D-42BF-A6D4-A96E27430985}" DTS:ExecutableType="Microsoft.CacheWindowMaintainanceTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="CWM - Delete Old Cache Files" DTS:TaskContact="Cache Window Maintainance Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7EDAF031-506D-45CA-A56C-7597EB330B4C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
<DTS:PropertyExpression DTS:Name="CacheFileNamePrefixVarName">"User::CacheUploadFilesPrefixPattern"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<InnerObject>
<CacheFileNamePrefixVarName Type="8" Value="User::CacheUploadFilesPrefixPattern"/>
<CacheWindow Type="3" Value="0"/>
<CollectionSetUID Type="8" Value=""/>
<CollectorTempDir Type="8" Value=""/>
<CollectorTypeUID Type="8" Value=""/>
<ConfigConnectionString Type="8" Value=""/>
<ExitEventName Type="8" Value=""/>
<InstanceName Type="8" Value=""/>
<ItemID Type="3" Value="0"/>
<LoggingLevel Type="3" Value="0"/>
<LoopEventName Type="8" Value=""/>
<MdwConnectionString Type="8" Value=""/>
<TargetConnectionString Type="8" Value=""/>
<TargetServerVersion Type="3" Value="130"/>
<TaskDisplayName Type="8" Value="Cache Window Maintainance Task"/>
</InnerObject>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop Container" DTS:DTSID="{2B763872-7CE3-4CFF-88F9-5A1EDFA05BC8}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For Each Collected Cache File Remaining, Try to Upload">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}" DTS:ObjectName="{EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}">
<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="FileSpec">@[User::CacheUploadFilesPrefixPattern] + "*.cache"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachFileEnumeratorProperties>
<FEFEProperty Folder="C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC"/>
<FEFEProperty FileSpec="ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_*.cache"/>
<FEFEProperty FileNameRetrievalType="0"/>
<FEFEProperty Recurse="0"/>
</ForEachFileEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F36AAF41-4971-4431-B175-E6DEE50CE8A6}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileToUpload">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\MACIES4_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F7E27146-0A15-485B-8BD1-9A4327B9CEF6}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">93213</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{05DBC8DD-D393-4E0E-8A8D-97EC37B1C527}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F5DD1F52-8D07-4E99-8435-35B4ECBBE28A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A3990693-0E65-44C7-BF35-1AD1F08EDCB0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{03FCCBFD-6016-428F-A0DF-294876A9D2B1}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::RowCountOut] - @[User::RowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="RowCountOutFinal">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{E0D31BC6-173F-4DB9-BBD1-941BFE618005}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Bulk Insert Collected data into MDW" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="1000" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot id" usesDispositions="true">
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]" dataType="dbTimeStamp2" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]" name="collect_time_convert" scale="1" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">(DT_DBTIMESTAMP2,1)#{Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">(DT_DBTIMESTAMP2,1)collection_time</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="Looks up values in a reference dataset by using exact matching." name="LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted" usesDispositions="true" version="6">
-<properties>
<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">SELECT path, performance_counter_id FROM snapshots.performance_counter_instances</property>
<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam">SELECT [path], [performance_counter_id] FROM [snapshots].[performance_counter_instances] WHERE [path] = ?</property>
<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">0</property>
<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">5</property>
<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">5</property>
<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="path" dataType="DT_WSTR" length="2048" precision="0" scale="0" codePage="0"/><referenceColumn name="performance_counter_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>
<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]};</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>
<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>
<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>
<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="Connection manager used to access lookup data." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]" name="Lookup Input">
-<inputColumns>
-<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]">
-<properties>
<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">path</property>
<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>
</properties>
</inputColumn>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
-<outputColumns>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]" name="performance_counter_id" truncationRowDisposition="FailComponent">
-<properties>
<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">performance_counter_id</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Fast upload data to performance_counter_values" usesDispositions="true" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[performance_counter_values]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_second]" cachedDataType="i8" cachedName="raw_value_second" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_first]" cachedDataType="i8" cachedName="raw_value_first" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[formatted_value]" cachedDataType="r8" cachedName="formatted_value" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[performance_counter_id]" cachedDataType="i4" cachedName="performance_counter_id" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_instance_id]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[collect_time_convert]" cachedDataType="dbTimeStamp2" cachedName="collect_time_convert" cachedScale="1" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_instance_id]" dataType="i4" name="performance_counter_instance_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RAW - Read current tempoary storage" validateExternalMetadata="False" version="1">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileToUpload</property>
</properties>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output]" name="Raw File Source Output">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[path]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]" name="path"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]" dataType="r8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_type]" dataType="i4" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[object_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[object_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[instance_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[instance_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[instance_name]" name="instance_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_name]" name="counter_name"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows failed to insert">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows from cache" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows inserted" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Derived Column Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Failed Rows]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]" name="Failed Rows" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Lookup Match Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]" name="Lookup Match Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Raw File Source Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]" name="Raw File Source Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Row Count Output 1]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Outputs[Row Count Output 1]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Row Count Output 11]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{E24F9238-4DE6-4DFE-97B9-35990020B45A}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Update perf_counters_instances table with newly discovered instances" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="1000" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" localeId="1033" name="ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[performance_counter_instances]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions"/>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[path]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_type]" cachedDataType="i4" cachedName="counter_type" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[object_name]" cachedDataType="wstr" cachedLength="2048" cachedName="object_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[object_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_name]" cachedDataType="wstr" cachedLength="2048" cachedName="counter_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[instance_name]" cachedDataType="wstr" cachedLength="2048" cachedName="instance_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[instance_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_id]" dataType="i4" name="performance_counter_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." localeId="1033" name="RAW - Read current tempoary storage - purpose - obtain counter paths" validateExternalMetadata="False" version="1">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileToUpload</property>
</properties>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output]" name="Raw File Source Output">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[path]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]" name="path"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[formatted_value]" dataType="r8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_first]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_second]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]" dataType="i4" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[object_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[instance_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]" name="instance_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]" name="counter_name"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances.Paths[Raw File Source Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]" name="Raw File Source Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\FST - Cleanup" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{2665570b-6fcf-43a3-b8ba-5f3d5bd99357}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Cleanup" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::CacheFileToUpload" TaskIsSourceVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{CD4E0504-1536-4071-A070-9A7D8A6D7B32}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{2AEF0133-FEA0-472B-B12D-89F60FF1CBCD}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'PerfCountersUpload - Main Upload Loop', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOutFinal" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{17CA7F5E-10A1-41B3-9F5F-FD4CCB15FB8D}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{649D8163-D3B7-4998-A29D-ABDE0EAAEA77}" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\FST - Cleanup"/>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{96006738-B053-493C-95AD-64168C63BA4C}" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{EF918497-3946-428A-9BF3-D32E69048E5A}" DTS:ObjectName="{EF918497-3946-428A-9BF3-D32E69048E5A}" DTS:ValueIndex="0" DTS:VariableName="User::CacheFileToUpload"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{A7035C8A-5219-42B8-BDE6-365F3240D4B2}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Sequence Container">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A0DA22EB-F905-466C-B115-716E3F49FA5D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">PerfCountersLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Sequence Container\FAT - Check Current Cache File Exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{B737D089-54D7-40A4-9F46-A1B8AA87FF57}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:ObjectName="FAT - Check Current Cache File Exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::CacheFileName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">0</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>0</Mode>
<FilePath>C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Sequence Container\FST - Rename Current Cache File" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{609f9d36-aad4-4395-8b31-0c27b6ffefdd}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Current Cache File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::CacheFileName" TaskIsSourceVariable="True" TaskDestinationPath="User::CacheOutput" TaskIsDestinationVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\Sequence Container.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{B5B398D6-E5AB-4742-ABD1-AD95B984F0AF}" DTS:From="Package\Sequence Container\FAT - Check Current Cache File Exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Sequence Container\FST - Rename Current Cache File"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Create snapshot ID in MDW" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{02641DDC-5CDC-4BD2-8112-1FA7BE3A488C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Create snapshot ID in MDW" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" SQLTask:SqlStatementSource="execute [core].[sp_create_snapshot] @collection_set_uid=? , @collector_type_uid=? , @machine_name=? , @named_instance=? , @log_id=? , @snapshot_id=? OUTPUT ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Register collection set to MDW" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{a3667210-4432-41f0-8d04-d53b10574f52}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Register collection set to MDW" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" SQLTask:SqlStatementSource="execute [core].[sp_update_data_source] @collection_set_uid=? , @machine_name=? , @named_instance=? , @days_until_expiration=? , @source_id=? OUTPUT ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="2" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{3E8C2FDE-1E6D-4C61-A58B-D114921193FC}" DTS:From="Package\SQL - Register collection set to MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Create snapshot ID in MDW" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{E0BDAD4D-63EC-4C7B-B392-48D799204549}" DTS:From="Package\Sequence Container" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\CWM - Delete Old Cache Files"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{5B5E777C-2E3A-453F-91F2-6E28C7BC6B13}" DTS:From="Package\SQL - Create snapshot ID in MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 4" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{766AFD21-4197-496F-90A8-2C9B25E85D3C}" DTS:From="Package\CWM - Delete Old Cache Files" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


Package

Package: QueryActivityCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 7/10/2007 4:26:36 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {0B68FC9D-23DC-48F3-A937-90A0A8943D0E}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | QueryActivityCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\QueryActivityCollect
PackagePath | MSDB\Data Collector\QueryActivityCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 110
VersionComments |
VersionGUID | {317607A1-01CF-47D9-B2F3-98AF8311BC8B}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
LOOP - Query the query statitics DMV at collection frequency | Foreach Loop Container

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilePrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotExecRequestQuery |
TargetConnectionString |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: QueryActivityCollect

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {4BEFF4AE-6E6A-45EA-9DA2-0CDFFEE962C4}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {465410C0-791E-4D35-8366-A4CD30A3C75C}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1AF8E4B6-CDEA-4CF1-A6CD-BBA7C598217F}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {B2C54FDF-F78F-4065-8214-54B55A7A245A}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {D7651A0A-C75C-4F0C-A5A2-4B51878A0C71}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {9AFF7A64-3CE4-4518-B865-7077072A391D}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {54F38A44-3932-4198-8648-B0A244751041}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {39CD184D-90DF-4393-97EC-FABC1183F10C}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {8614A7F4-3E3F-4314-9887-C88F2FB0F189}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {86ABBBA3-E60E-4CDF-861A-8476A6707570}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {509D0615-B505-4276-B8BC-7603D3877C04}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {289870D1-804D-45B2-9743-D8786F99F678}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3CB7F214-4B4E-4BF8-842E-BADD0B85E77D}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {71DE2249-F71B-452E-8C93-4652129EBD8B}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E62807FC-8321-4152-9495-11F889D7A544}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {328041A5-FC96-43B1-B07E-16BBFE3C44E0}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package element

Package element: DaysUntilExpiration

Collapse image Properties

Name | Value
ConfigurationString | User::DaysUntilExpiration
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1FE8F866-6F84-4A05-88CD-CED5D86D85CF}
Name | DaysUntilExpiration
PackagePath | \Package.Variables[User::DaysUntilExpiration].Properties[Value]


Package

Package: QueryActivityCollect

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: CacheFilePrefixPattern

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"
IncludeInDebugDump | False
Name | CacheFilePrefixPattern
Namespace | User
QualifiedName | User::CacheFilePrefixPattern
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity
VariablePath | \Package.Variables[User::CacheFilePrefixPattern]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectionSetUID
Namespace | User
QualifiedName | User::CollectionSetUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 2DC02BD6-E230-4C05-8516-4E8C0EF21F95
VariablePath | \Package.Variables[User::CollectionSetUID]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectorTypeUID
Namespace | User
QualifiedName | User::CollectorTypeUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 1d24f966-c63c-497c-a6bc-df2369b8ebdf
VariablePath | \Package.Variables[User::CollectorTypeUID]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InstanceName
Namespace | User
QualifiedName | User::InstanceName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | MSSQLSERVER
VariablePath | \Package.Variables[User::InstanceName]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | ItemID
Namespace | User
QualifiedName | User::ItemID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 100
VariablePath | \Package.Variables[User::ItemID]


Package element

Package element: SnapshotExecRequestQuery

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] " + (DT_WSTR,10) (@[User::ItemID])
IncludeInDebugDump | False
Name | SnapshotExecRequestQuery
Namespace | User
QualifiedName | User::SnapshotExecRequestQuery
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] 100
VariablePath | \Package.Variables[User::SnapshotExecRequestQuery]


Package element

Package element: MdwConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to upload collected data to a warehouse.
HasExpressions | True
HostType | ConnectionManager
ID | {ACB4A0B0-94FF-473B-BB76-72DFB239DBC6}
InitialCatalog | MDW
Name | MdwConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: TargetConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information from the monitored (target) instance.
HasExpressions | True
HostType | ConnectionManager
ID | {1906A00E-7676-4664-9159-0B790DF483C2}
InitialCatalog |
Name | TargetConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package

Package: QueryActivityCollect

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityCollect

Collapse image Executables

Name | Description
LOOP - Query the query statitics DMV at collection frequency | Foreach Loop Container

Collapse image System variables

No items exist
Name Description


Package element

Package element: LOOP - Query the query statitics DMV at collection frequency

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | False
Description | Foreach Loop Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {3728E9CD-A948-47F5-B2A9-26BC486A8CD8}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | LOOP - Query the query statitics DMV at collection frequency
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
SEQ - Synchronize Access to Cache File | Sequence Container | Executables
SQL - Log Package Iteration | Execute SQL Task | Executables
SQL - Log Package Stats | Execute SQL Task | Executables
{7283E196-D60C-438F-A58A-0EA1F41BBCF4} |  | ForEachEnumerator
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
DMVErrorRowCount |  | Variables
DMVInOutRowCount |  | Variables
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: SEQ - Synchronize Access to Cache File

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | False
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {95CCF408-6AAD-4742-B85E-7627D7D72418}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SEQ - Synchronize Access to Cache File
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Collect DMV Data | Data Flow Task | Executables
SyncRoot |  | Variables
DMVErrorRowCount |  | Variables
DMVInOutRowCount |  | Variables
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: DFT - Collect DMV Data

Collapse image Properties

Name | Value
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | False
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {CA0ED25A-27F6-4388-8E38-1F26D1A55878}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Collect DMV Data
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
CNT - Error row count | Counts the rows in a dataset. | ComponentMetaDataCollection
CNT - Input row count | Counts the rows in a dataset. | ComponentMetaDataCollection
ODS - Get snapshot of dm_exec_requests | OLE DB Source | ComponentMetaDataCollection
RFD - Write data to a cache | Loads raw data into a file. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
OLE DB Source Error Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
CacheFileName |  | Variables
SyncRoot |  | Variables
DMVErrorRowCount |  | Variables
DMVInOutRowCount |  | Variables
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables
SSIS diagram is missing


Package element

Package element: CNT - Error row count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 2
IdentificationString | CNT - Error row count
IsDefaultLocale | True
LocaleID | English (United States)
Name | CNT - Error row count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 3
IdentificationString | CNT - Error row count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::DMVErrorRowCount


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 4
IdentificationString | CNT - Error row count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 5
IdentificationString | CNT - Error row count.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 4
TruncationRowDisposition | RD_NotUsed


Package element

Package element: CNT - Input row count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 6
IdentificationString | CNT - Input row count
IsDefaultLocale | True
LocaleID | English (United States)
Name | CNT - Input row count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | CNT - Input row count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::DMVInOutRowCount


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 8
IdentificationString | CNT - Input row count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 9
IdentificationString | CNT - Input row count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 8
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ODS - Get snapshot of dm_exec_requests

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 10
IdentificationString | ODS - Get snapshot of dm_exec_requests
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Get snapshot of dm_exec_requests
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | SET NOCOUNT ON{LF}{LF}-- Get the collection time as UTC time{LF}DECLARE @collection_time datetime{LF}SET @collection_time = GETDATE(){LF}{LF}SELECT{LF}CONVERT(int, ROW_NUMBER() OVER (ORDER BY sess.session_id, ISNULL (req.request_id, -1), ISNULL (tasks.exec_context_id, -1)) ) AS row_id,{LF}-- IDs and Blocking IDs{LF}sess.session_id, {LF}ISNULL (req.request_id, -1) AS request_id, {LF}ISNULL (tasks.exec_context_id, -1) AS exec_context_id, {LF}ISNULL (req.blocking_session_id, 0) AS blocking_session_id,{LF}CONVERT (bit, CASE {LF} WHEN EXISTS (SELECT TOP 1 session_id FROM sys.dm_exec_requests bl WHERE bl.blocking_session_id = req.session_id) THEN 1{LF} ELSE 0{LF} END) AS is_blocking,{LF}ISNULL (waits.blocking_exec_context_id, 0) AS blocking_exec_context_id, {LF}tasks.scheduler_id, {LF}DB_NAME(req.database_id) as database_name, {LF}req.[user_id], {LF}{LF}-- State information{LF}LEFT (tasks.task_state, 10) AS task_state, {LF}LEFT (req.status, 15) AS request_status, {LF}LEFT (sess.status, 15) AS session_status,{LF}req.executing_managed_code, {LF}{LF}-- Session information{LF}sess.login_time, {LF}sess.is_user_process, {LF}LEFT (ISNULL (sess.[host_name], ''), 20) AS [host_name], {LF}LEFT (ISNULL (sess.[program_name], ''), 50) AS [program_name], {LF}LEFT (ISNULL (sess.login_name, ''), 30) AS login_name, {LF}{LF}-- Waits information{LF}LEFT (ISNULL (req.wait_type, ''), 45) AS wait_type, {LF}LEFT (ISNULL (req.last_wait_type, ''), 45) AS last_wait_type, {LF}ISNULL (waits.wait_duration_ms, 0) AS wait_duration_ms, {LF}LEFT (ISNULL (req.wait_resource, ''), 50) AS wait_resource, {LF}LEFT (ISNULL (waits.resource_description, ''), 140) AS resource_description,{LF}{LF}-- Transaction information{LF}req.transaction_id, {LF}ISNULL(req.open_transaction_count, 0) AS open_transaction_count,{LF}COALESCE(req.transaction_isolation_level, sess.transaction_isolation_level) AS transaction_isolation_level,{LF}{LF}-- Request stats{LF}req.cpu_time AS request_cpu_time, {LF}req.logical_reads AS request_logical_reads, {LF}req.reads AS request_reads, {LF}req.writes AS request_writes, {LF}req.total_elapsed_time AS request_total_elapsed_time, {LF}req.start_time AS request_start_time, {LF}{LF}-- Session stats{LF}sess.memory_usage, {LF}sess.cpu_time AS session_cpu_time, {LF}sess.reads AS session_reads, {LF}sess.writes AS session_writes, {LF}sess.logical_reads AS session_logical_reads, {LF}sess.total_scheduled_time AS session_total_scheduled_time, {LF}sess.total_elapsed_time AS session_total_elapsed_time, {LF}sess.last_request_start_time, {LF}sess.last_request_end_time, {LF}req.open_resultset_count AS open_resultsets, {LF}sess.row_count AS session_row_count, {LF}sess.prev_error, {LF}tasks.pending_io_count, {LF}{LF}-- Text/Plan handles{LF}ISNULL (req.command, 'AWAITING COMMAND') AS command, {LF}req.plan_handle, {LF}req.sql_handle, {LF}req.statement_start_offset, {LF}req.statement_end_offset,{LF}@collection_time AS collection_time{LF}FROM sys.dm_exec_sessions sess {LF}LEFT OUTER MERGE JOIN sys.dm_exec_requests req ON sess.session_id = req.session_id{LF}LEFT OUTER MERGE JOIN sys.dm_os_tasks tasks ON tasks.session_id = sess.session_id AND tasks.request_id = req.request_id AND tasks.task_address = req.task_address{LF}LEFT OUTER MERGE JOIN sys.dm_os_waiting_tasks waits ON waits.session_id = sess.session_id AND waits.waiting_task_address = req.task_address{LF}WHERE {LF} sess.session_id <> @@SPID{LF} AND{LF} ({LF} (req.session_id IS NOT NULL AND (sess.is_user_process = 1 OR req.status COLLATE Latin1_General_BIN NOT IN ('background', 'sleeping'))){TAB}-- active request{LF} OR {LF} (sess.session_id IN (SELECT DISTINCT blocking_session_id FROM sys.dm_exec_requests WHERE blocking_session_id != 0)){TAB}{TAB} -- not active, but head blocker{LF} ){LF}OPTION (FORCE ORDER)


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SnapshotExecRequestQuery


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 16
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 17
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | ODS - Get snapshot of dm_exec_requests.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 21
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
row_id |  | ExternalMetadataColumnCollection
session_id |  | ExternalMetadataColumnCollection
request_id |  | ExternalMetadataColumnCollection
exec_context_id |  | ExternalMetadataColumnCollection
blocking_session_id |  | ExternalMetadataColumnCollection
is_blocking |  | ExternalMetadataColumnCollection
blocking_exec_context_id |  | ExternalMetadataColumnCollection
scheduler_id |  | ExternalMetadataColumnCollection
database_name |  | ExternalMetadataColumnCollection
user_id |  | ExternalMetadataColumnCollection
task_state |  | ExternalMetadataColumnCollection
request_status |  | ExternalMetadataColumnCollection
session_status |  | ExternalMetadataColumnCollection
executing_managed_code |  | ExternalMetadataColumnCollection
login_time |  | ExternalMetadataColumnCollection
is_user_process |  | ExternalMetadataColumnCollection
host_name |  | ExternalMetadataColumnCollection
program_name |  | ExternalMetadataColumnCollection
login_name |  | ExternalMetadataColumnCollection
wait_type |  | ExternalMetadataColumnCollection
last_wait_type |  | ExternalMetadataColumnCollection
wait_duration_ms |  | ExternalMetadataColumnCollection
wait_resource |  | ExternalMetadataColumnCollection
resource_description |  | ExternalMetadataColumnCollection
transaction_id |  | ExternalMetadataColumnCollection
open_transaction_count |  | ExternalMetadataColumnCollection
transaction_isolation_level |  | ExternalMetadataColumnCollection
request_cpu_time |  | ExternalMetadataColumnCollection
request_logical_reads |  | ExternalMetadataColumnCollection
request_reads |  | ExternalMetadataColumnCollection
request_writes |  | ExternalMetadataColumnCollection
request_total_elapsed_time |  | ExternalMetadataColumnCollection
request_start_time |  | ExternalMetadataColumnCollection
memory_usage |  | ExternalMetadataColumnCollection
session_cpu_time |  | ExternalMetadataColumnCollection
session_reads |  | ExternalMetadataColumnCollection
session_writes |  | ExternalMetadataColumnCollection
session_logical_reads |  | ExternalMetadataColumnCollection
session_total_scheduled_time |  | ExternalMetadataColumnCollection
session_total_elapsed_time |  | ExternalMetadataColumnCollection
open_resultsets |  | ExternalMetadataColumnCollection
session_row_count |  | ExternalMetadataColumnCollection
prev_error |  | ExternalMetadataColumnCollection
pending_io_count |  | ExternalMetadataColumnCollection
command |  | ExternalMetadataColumnCollection
last_request_start_time |  | ExternalMetadataColumnCollection
last_request_end_time |  | ExternalMetadataColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
row_id |  | OutputColumnCollection
session_id |  | OutputColumnCollection
request_id |  | OutputColumnCollection
exec_context_id |  | OutputColumnCollection
blocking_session_id |  | OutputColumnCollection
is_blocking |  | OutputColumnCollection
blocking_exec_context_id |  | OutputColumnCollection
scheduler_id |  | OutputColumnCollection
database_name |  | OutputColumnCollection
user_id |  | OutputColumnCollection
task_state |  | OutputColumnCollection
request_status |  | OutputColumnCollection
session_status |  | OutputColumnCollection
executing_managed_code |  | OutputColumnCollection
login_time |  | OutputColumnCollection
is_user_process |  | OutputColumnCollection
host_name |  | OutputColumnCollection
program_name |  | OutputColumnCollection
login_name |  | OutputColumnCollection
wait_type |  | OutputColumnCollection
last_wait_type |  | OutputColumnCollection
wait_duration_ms |  | OutputColumnCollection
wait_resource |  | OutputColumnCollection
resource_description |  | OutputColumnCollection
transaction_id |  | OutputColumnCollection
open_transaction_count |  | OutputColumnCollection
transaction_isolation_level |  | OutputColumnCollection
request_cpu_time |  | OutputColumnCollection
request_logical_reads |  | OutputColumnCollection
request_reads |  | OutputColumnCollection
request_writes |  | OutputColumnCollection
request_total_elapsed_time |  | OutputColumnCollection
request_start_time |  | OutputColumnCollection
memory_usage |  | OutputColumnCollection
session_cpu_time |  | OutputColumnCollection
session_reads |  | OutputColumnCollection
session_writes |  | OutputColumnCollection
session_logical_reads |  | OutputColumnCollection
session_total_scheduled_time |  | OutputColumnCollection
session_total_elapsed_time |  | OutputColumnCollection
open_resultsets |  | OutputColumnCollection
session_row_count |  | OutputColumnCollection
prev_error |  | OutputColumnCollection
pending_io_count |  | OutputColumnCollection
command |  | OutputColumnCollection
last_request_start_time |  | OutputColumnCollection
last_request_end_time |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 74
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 75
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 76
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 77
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 78
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 79
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[row_id]
Length | 0
MappedColumnID | 0
Name | row_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 80
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_id]
Length | 0
MappedColumnID | 0
Name | session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 81
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_id]
Length | 0
MappedColumnID | 0
Name | request_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 82
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[exec_context_id]
Length | 0
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 83
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_session_id]
Length | 0
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 84
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_blocking]
Length | 0
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 85
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_exec_context_id]
Length | 0
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 86
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[scheduler_id]
Length | 0
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 87
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[database_name]
Length | 128
MappedColumnID | 0
Name | database_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 88
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[user_id]
Length | 0
MappedColumnID | 0
Name | user_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 89
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[task_state]
Length | 10
MappedColumnID | 0
Name | task_state
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 90
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_status]
Length | 15
MappedColumnID | 0
Name | request_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 91
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_status]
Length | 15
MappedColumnID | 0
Name | session_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 92
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[executing_managed_code]
Length | 0
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 93
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_time]
Length | 0
MappedColumnID | 0
Name | login_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 94
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_user_process]
Length | 0
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 95
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[host_name]
Length | 20
MappedColumnID | 0
Name | host_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 96
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[program_name]
Length | 50
MappedColumnID | 0
Name | program_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 97
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_name]
Length | 30
MappedColumnID | 0
Name | login_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 98
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_type]
Length | 45
MappedColumnID | 0
Name | wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 99
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_wait_type]
Length | 45
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 100
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_duration_ms]
Length | 0
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 101
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_resource]
Length | 50
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 102
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[resource_description]
Length | 140
MappedColumnID | 0
Name | resource_description
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 103
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_id]
Length | 0
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 104
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_transaction_count]
Length | 0
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 105
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_isolation_level]
Length | 0
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 106
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_cpu_time]
Length | 0
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 107
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_logical_reads]
Length | 0
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 108
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_reads]
Length | 0
MappedColumnID | 0
Name | request_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 109
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_writes]
Length | 0
MappedColumnID | 0
Name | request_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 110
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 111
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_start_time]
Length | 0
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 112
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[memory_usage]
Length | 0
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 113
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_cpu_time]
Length | 0
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 114
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_reads]
Length | 0
MappedColumnID | 0
Name | session_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 115
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_writes]
Length | 0
MappedColumnID | 0
Name | session_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 116
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_logical_reads]
Length | 0
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 117
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_scheduled_time]
Length | 0
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 118
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 119
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_resultsets]
Length | 0
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 120
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_row_count]
Length | 0
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 121
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[prev_error]
Length | 0
MappedColumnID | 0
Name | prev_error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 122
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[pending_io_count]
Length | 0
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 123
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[command]
Length | 32
MappedColumnID | 0
Name | command
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 124
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_start_time]
Length | 0
MappedColumnID | 0
Name | last_request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 125
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_end_time]
Length | 0
MappedColumnID | 0
Name | last_request_end_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 75
ID | 22
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 22
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 76
ID | 23
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 23
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 78
ID | 24
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]
Length | 0
LineageID | 24
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 74
ID | 25
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]
Length | 64
LineageID | 25
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 77
ID | 26
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]
Length | 64
LineageID | 26
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 79
ID | 27
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]
Length | 0
LineageID | 27
MappedColumnID | 0
Name | row_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 80
ID | 28
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]
Length | 0
LineageID | 28
MappedColumnID | 0
Name | session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 81
ID | 29
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]
Length | 0
LineageID | 29
MappedColumnID | 0
Name | request_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 82
ID | 30
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]
Length | 0
LineageID | 30
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 83
ID | 31
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]
Length | 0
LineageID | 31
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 84
ID | 32
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]
Length | 0
LineageID | 32
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 85
ID | 33
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]
Length | 0
LineageID | 33
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 86
ID | 34
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]
Length | 0
LineageID | 34
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 87
ID | 35
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]
Length | 128
LineageID | 35
MappedColumnID | 0
Name | database_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 88
ID | 36
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]
Length | 0
LineageID | 36
MappedColumnID | 0
Name | user_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 89
ID | 37
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]
Length | 10
LineageID | 37
MappedColumnID | 0
Name | task_state
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 90
ID | 38
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]
Length | 15
LineageID | 38
MappedColumnID | 0
Name | request_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 91
ID | 39
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]
Length | 15
LineageID | 39
MappedColumnID | 0
Name | session_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 92
ID | 40
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]
Length | 0
LineageID | 40
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 93
ID | 41
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]
Length | 0
LineageID | 41
MappedColumnID | 0
Name | login_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 94
ID | 42
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]
Length | 0
LineageID | 42
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 95
ID | 43
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]
Length | 20
LineageID | 43
MappedColumnID | 0
Name | host_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 96
ID | 44
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]
Length | 50
LineageID | 44
MappedColumnID | 0
Name | program_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 97
ID | 45
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]
Length | 30
LineageID | 45
MappedColumnID | 0
Name | login_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 98
ID | 46
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]
Length | 45
LineageID | 46
MappedColumnID | 0
Name | wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 99
ID | 47
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]
Length | 45
LineageID | 47
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 100
ID | 48
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]
Length | 0
LineageID | 48
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 101
ID | 49
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]
Length | 50
LineageID | 49
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 102
ID | 50
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]
Length | 140
LineageID | 50
MappedColumnID | 0
Name | resource_description
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 103
ID | 51
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]
Length | 0
LineageID | 51
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 104
ID | 52
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]
Length | 0
LineageID | 52
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 105
ID | 53
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]
Length | 0
LineageID | 53
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 106
ID | 54
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]
Length | 0
LineageID | 54
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 107
ID | 55
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]
Length | 0
LineageID | 55
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 108
ID | 56
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]
Length | 0
LineageID | 56
MappedColumnID | 0
Name | request_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 109
ID | 57
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]
Length | 0
LineageID | 57
MappedColumnID | 0
Name | request_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 110
ID | 58
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]
Length | 0
LineageID | 58
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 111
ID | 59
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]
Length | 0
LineageID | 59
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 112
ID | 60
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]
Length | 0
LineageID | 60
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 113
ID | 61
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]
Length | 0
LineageID | 61
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 114
ID | 62
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]
Length | 0
LineageID | 62
MappedColumnID | 0
Name | session_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 115
ID | 63
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]
Length | 0
LineageID | 63
MappedColumnID | 0
Name | session_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 116
ID | 64
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]
Length | 0
LineageID | 64
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 117
ID | 65
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]
Length | 0
LineageID | 65
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 118
ID | 66
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]
Length | 0
LineageID | 66
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 119
ID | 67
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]
Length | 0
LineageID | 67
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 120
ID | 68
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]
Length | 0
LineageID | 68
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 121
ID | 69
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]
Length | 0
LineageID | 69
MappedColumnID | 0
Name | prev_error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 122
ID | 70
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]
Length | 0
LineageID | 70
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 123
ID | 71
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]
Length | 32
LineageID | 71
MappedColumnID | 0
Name | command
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 124
ID | 72
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]
Length | 0
LineageID | 72
MappedColumnID | 0
Name | last_request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 125
ID | 73
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]
Length | 0
LineageID | 73
MappedColumnID | 0
Name | last_request_end_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 126
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output]
IsAttached | True
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
row_id |  | OutputColumnCollection
session_id |  | OutputColumnCollection
request_id |  | OutputColumnCollection
exec_context_id |  | OutputColumnCollection
blocking_session_id |  | OutputColumnCollection
is_blocking |  | OutputColumnCollection
blocking_exec_context_id |  | OutputColumnCollection
scheduler_id |  | OutputColumnCollection
database_name |  | OutputColumnCollection
user_id |  | OutputColumnCollection
task_state |  | OutputColumnCollection
request_status |  | OutputColumnCollection
session_status |  | OutputColumnCollection
executing_managed_code |  | OutputColumnCollection
login_time |  | OutputColumnCollection
is_user_process |  | OutputColumnCollection
host_name |  | OutputColumnCollection
program_name |  | OutputColumnCollection
login_name |  | OutputColumnCollection
wait_type |  | OutputColumnCollection
last_wait_type |  | OutputColumnCollection
wait_duration_ms |  | OutputColumnCollection
wait_resource |  | OutputColumnCollection
resource_description |  | OutputColumnCollection
transaction_id |  | OutputColumnCollection
open_transaction_count |  | OutputColumnCollection
transaction_isolation_level |  | OutputColumnCollection
request_cpu_time |  | OutputColumnCollection
request_logical_reads |  | OutputColumnCollection
request_reads |  | OutputColumnCollection
request_writes |  | OutputColumnCollection
request_total_elapsed_time |  | OutputColumnCollection
request_start_time |  | OutputColumnCollection
memory_usage |  | OutputColumnCollection
session_cpu_time |  | OutputColumnCollection
session_reads |  | OutputColumnCollection
session_writes |  | OutputColumnCollection
session_logical_reads |  | OutputColumnCollection
session_total_scheduled_time |  | OutputColumnCollection
session_total_elapsed_time |  | OutputColumnCollection
last_request_start_time |  | OutputColumnCollection
last_request_end_time |  | OutputColumnCollection
open_resultsets |  | OutputColumnCollection
session_row_count |  | OutputColumnCollection
prev_error |  | OutputColumnCollection
pending_io_count |  | OutputColumnCollection
command |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 127
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[row_id]
Length | 0
LineageID | 127
MappedColumnID | 0
Name | row_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 128
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_id]
Length | 0
LineageID | 128
MappedColumnID | 0
Name | session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 129
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_id]
Length | 0
LineageID | 129
MappedColumnID | 0
Name | request_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 130
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[exec_context_id]
Length | 0
LineageID | 130
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 131
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_session_id]
Length | 0
LineageID | 131
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 132
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_blocking]
Length | 0
LineageID | 132
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 133
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_exec_context_id]
Length | 0
LineageID | 133
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 134
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[scheduler_id]
Length | 0
LineageID | 134
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 135
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[database_name]
Length | 128
LineageID | 135
MappedColumnID | 0
Name | database_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 136
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[user_id]
Length | 0
LineageID | 136
MappedColumnID | 0
Name | user_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 137
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[task_state]
Length | 10
LineageID | 137
MappedColumnID | 0
Name | task_state
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 138
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_status]
Length | 15
LineageID | 138
MappedColumnID | 0
Name | request_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 139
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_status]
Length | 15
LineageID | 139
MappedColumnID | 0
Name | session_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 140
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[executing_managed_code]
Length | 0
LineageID | 140
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 141
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_time]
Length | 0
LineageID | 141
MappedColumnID | 0
Name | login_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 142
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_user_process]
Length | 0
LineageID | 142
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 143
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[host_name]
Length | 20
LineageID | 143
MappedColumnID | 0
Name | host_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 144
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[program_name]
Length | 50
LineageID | 144
MappedColumnID | 0
Name | program_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 145
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_name]
Length | 30
LineageID | 145
MappedColumnID | 0
Name | login_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 146
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_type]
Length | 45
LineageID | 146
MappedColumnID | 0
Name | wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 147
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_wait_type]
Length | 45
LineageID | 147
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 148
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_duration_ms]
Length | 0
LineageID | 148
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 149
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_resource]
Length | 50
LineageID | 149
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 150
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[resource_description]
Length | 140
LineageID | 150
MappedColumnID | 0
Name | resource_description
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 151
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_id]
Length | 0
LineageID | 151
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 152
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_transaction_count]
Length | 0
LineageID | 152
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 153
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_isolation_level]
Length | 0
LineageID | 153
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 154
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_cpu_time]
Length | 0
LineageID | 154
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 155
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_logical_reads]
Length | 0
LineageID | 155
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 156
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_reads]
Length | 0
LineageID | 156
MappedColumnID | 0
Name | request_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 157
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_writes]
Length | 0
LineageID | 157
MappedColumnID | 0
Name | request_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 158
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_total_elapsed_time]
Length | 0
LineageID | 158
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 159
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_start_time]
Length | 0
LineageID | 159
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 160
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[memory_usage]
Length | 0
LineageID | 160
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 161
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_cpu_time]
Length | 0
LineageID | 161
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 162
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_reads]
Length | 0
LineageID | 162
MappedColumnID | 0
Name | session_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 163
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_writes]
Length | 0
LineageID | 163
MappedColumnID | 0
Name | session_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 164
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_logical_reads]
Length | 0
LineageID | 164
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 165
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_scheduled_time]
Length | 0
LineageID | 165
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 166
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_elapsed_time]
Length | 0
LineageID | 166
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 167
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_start_time]
Length | 0
LineageID | 167
MappedColumnID | 0
Name | last_request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 168
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_end_time]
Length | 0
LineageID | 168
MappedColumnID | 0
Name | last_request_end_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 169
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_resultsets]
Length | 0
LineageID | 169
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 170
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_row_count]
Length | 0
LineageID | 170
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 171
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[prev_error]
Length | 0
LineageID | 171
MappedColumnID | 0
Name | prev_error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 172
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[pending_io_count]
Length | 0
LineageID | 172
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 173
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[command]
Length | 32
LineageID | 173
MappedColumnID | 0
Name | command
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 174
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]
Length | 0
LineageID | 174
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 175
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]
Length | 0
LineageID | 175
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 176
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[collection_time]
Length | 0
LineageID | 176
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 177
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 177
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 178
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 178
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 179
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[sql_handle]
Length | 64
LineageID | 179
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 180
IdentificationString | ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[plan_handle]
Length | 64
LineageID | 180
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {1906A00E-7676-4664-9159-0B790DF483C2}
Description | The OLE DB runtime connection used to access the database.
ID | 20
IdentificationString | ODS - Get snapshot of dm_exec_requests.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RFD - Write data to a cache

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {953B7879-214C-4AB8-AA79-AEA630F35C46}
ContactInfo | Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Loads raw data into a file.
ID | 181
IdentificationString | RFD - Write data to a cache
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFD - Write data to a cache
ObjectType | 10
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | False
Version | 2

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
WriteOption | Indicates what option is used to write to the file. | CustomPropertyCollection
Raw File Destination Input |  | InputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 182
IdentificationString | RFD - Write data to a cache.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 183
IdentificationString | RFD - Write data to a cache.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 184
IdentificationString | RFD - Write data to a cache.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CacheFileName


Package element

Package element: WriteOption

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates what option is used to write to the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 185
IdentificationString | RFD - Write data to a cache.Properties[WriteOption]
Name | WriteOption
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | WriteOption
UITypeEditor |
Value | 2


Package element

Package element: Raw File Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 186
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input]
IsAttached | True
IsSorted | False
Name | Raw File Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
sql_handle |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
row_id |  | ExternalMetadataColumnCollection
session_id |  | ExternalMetadataColumnCollection
request_id |  | ExternalMetadataColumnCollection
exec_context_id |  | ExternalMetadataColumnCollection
blocking_session_id |  | ExternalMetadataColumnCollection
is_blocking |  | ExternalMetadataColumnCollection
blocking_exec_context_id |  | ExternalMetadataColumnCollection
scheduler_id |  | ExternalMetadataColumnCollection
database_name |  | ExternalMetadataColumnCollection
user_id |  | ExternalMetadataColumnCollection
task_state |  | ExternalMetadataColumnCollection
request_status |  | ExternalMetadataColumnCollection
session_status |  | ExternalMetadataColumnCollection
executing_managed_code |  | ExternalMetadataColumnCollection
login_time |  | ExternalMetadataColumnCollection
is_user_process |  | ExternalMetadataColumnCollection
host_name |  | ExternalMetadataColumnCollection
program_name |  | ExternalMetadataColumnCollection
login_name |  | ExternalMetadataColumnCollection
wait_type |  | ExternalMetadataColumnCollection
last_wait_type |  | ExternalMetadataColumnCollection
wait_duration_ms |  | ExternalMetadataColumnCollection
wait_resource |  | ExternalMetadataColumnCollection
resource_description |  | ExternalMetadataColumnCollection
transaction_id |  | ExternalMetadataColumnCollection
open_transaction_count |  | ExternalMetadataColumnCollection
transaction_isolation_level |  | ExternalMetadataColumnCollection
request_cpu_time |  | ExternalMetadataColumnCollection
request_logical_reads |  | ExternalMetadataColumnCollection
request_reads |  | ExternalMetadataColumnCollection
request_writes |  | ExternalMetadataColumnCollection
request_total_elapsed_time |  | ExternalMetadataColumnCollection
request_start_time |  | ExternalMetadataColumnCollection
memory_usage |  | ExternalMetadataColumnCollection
session_cpu_time |  | ExternalMetadataColumnCollection
session_reads |  | ExternalMetadataColumnCollection
session_writes |  | ExternalMetadataColumnCollection
session_logical_reads |  | ExternalMetadataColumnCollection
session_total_scheduled_time |  | ExternalMetadataColumnCollection
session_total_elapsed_time |  | ExternalMetadataColumnCollection
session_last_request_start_time |  | ExternalMetadataColumnCollection
session_last_request_end_time |  | ExternalMetadataColumnCollection
open_resultsets |  | ExternalMetadataColumnCollection
session_row_count |  | ExternalMetadataColumnCollection
prev_error |  | ExternalMetadataColumnCollection
pending_io_count |  | ExternalMetadataColumnCollection
command |  | ExternalMetadataColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
row_id |  | InputColumnCollection
session_id |  | InputColumnCollection
request_id |  | InputColumnCollection
exec_context_id |  | InputColumnCollection
blocking_session_id |  | InputColumnCollection
is_blocking |  | InputColumnCollection
blocking_exec_context_id |  | InputColumnCollection
scheduler_id |  | InputColumnCollection
database_name |  | InputColumnCollection
user_id |  | InputColumnCollection
task_state |  | InputColumnCollection
request_status |  | InputColumnCollection
session_status |  | InputColumnCollection
executing_managed_code |  | InputColumnCollection
login_time |  | InputColumnCollection
is_user_process |  | InputColumnCollection
host_name |  | InputColumnCollection
program_name |  | InputColumnCollection
login_name |  | InputColumnCollection
wait_type |  | InputColumnCollection
last_wait_type |  | InputColumnCollection
wait_duration_ms |  | InputColumnCollection
wait_resource |  | InputColumnCollection
resource_description |  | InputColumnCollection
transaction_id |  | InputColumnCollection
open_transaction_count |  | InputColumnCollection
transaction_isolation_level |  | InputColumnCollection
request_cpu_time |  | InputColumnCollection
request_logical_reads |  | InputColumnCollection
request_reads |  | InputColumnCollection
request_writes |  | InputColumnCollection
request_total_elapsed_time |  | InputColumnCollection
request_start_time |  | InputColumnCollection
memory_usage |  | InputColumnCollection
session_cpu_time |  | InputColumnCollection
session_reads |  | InputColumnCollection
session_writes |  | InputColumnCollection
session_logical_reads |  | InputColumnCollection
session_total_scheduled_time |  | InputColumnCollection
session_total_elapsed_time |  | InputColumnCollection
last_request_start_time |  | InputColumnCollection
last_request_end_time |  | InputColumnCollection
open_resultsets |  | InputColumnCollection
session_row_count |  | InputColumnCollection
prev_error |  | InputColumnCollection
pending_io_count |  | InputColumnCollection
command |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 239
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 240
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 241
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 242
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 243
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 244
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[row_id]
Length | 0
MappedColumnID | 0
Name | row_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 245
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_id]
Length | 0
MappedColumnID | 0
Name | session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 246
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_id]
Length | 0
MappedColumnID | 0
Name | request_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 247
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[exec_context_id]
Length | 0
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 248
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_session_id]
Length | 0
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 249
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_blocking]
Length | 0
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 250
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_exec_context_id]
Length | 0
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 251
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[scheduler_id]
Length | 0
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 252
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[database_name]
Length | 128
MappedColumnID | 0
Name | database_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 253
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[user_id]
Length | 0
MappedColumnID | 0
Name | user_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 254
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[task_state]
Length | 10
MappedColumnID | 0
Name | task_state
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 255
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_status]
Length | 15
MappedColumnID | 0
Name | request_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 256
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_status]
Length | 15
MappedColumnID | 0
Name | session_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 257
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[executing_managed_code]
Length | 0
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 258
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_time]
Length | 0
MappedColumnID | 0
Name | login_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 259
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_user_process]
Length | 0
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 260
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[host_name]
Length | 20
MappedColumnID | 0
Name | host_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 261
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[program_name]
Length | 50
MappedColumnID | 0
Name | program_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 262
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_name]
Length | 30
MappedColumnID | 0
Name | login_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 263
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_type]
Length | 45
MappedColumnID | 0
Name | wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 264
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[last_wait_type]
Length | 45
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 265
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_duration_ms]
Length | 0
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 266
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_resource]
Length | 50
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 267
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[resource_description]
Length | 140
MappedColumnID | 0
Name | resource_description
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 268
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_id]
Length | 0
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 269
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_transaction_count]
Length | 0
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 270
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_isolation_level]
Length | 0
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 271
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_cpu_time]
Length | 0
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 272
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_logical_reads]
Length | 0
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 273
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_reads]
Length | 0
MappedColumnID | 0
Name | request_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 274
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_writes]
Length | 0
MappedColumnID | 0
Name | request_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 275
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 276
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_start_time]
Length | 0
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 277
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[memory_usage]
Length | 0
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 278
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_cpu_time]
Length | 0
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 279
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_reads]
Length | 0
MappedColumnID | 0
Name | session_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 280
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_writes]
Length | 0
MappedColumnID | 0
Name | session_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 281
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_logical_reads]
Length | 0
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 282
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_scheduled_time]
Length | 0
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 283
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 284
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_start_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 285
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_end_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 286
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_resultsets]
Length | 0
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 287
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_row_count]
Length | 0
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 288
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[prev_error]
Length | 0
MappedColumnID | 0
Name | prev_error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 289
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[pending_io_count]
Length | 0
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 290
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[command]
Length | 32
MappedColumnID | 0
Name | command
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 239
ID | 187
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 22
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 240
ID | 188
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 23
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 241
ID | 189
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 24
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 242
ID | 190
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 25
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 243
ID | 191
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 26
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 244
ID | 192
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[row_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 27
MappedColumnID | 0
Name | row_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 245
ID | 193
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 28
MappedColumnID | 0
Name | session_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 246
ID | 194
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 29
MappedColumnID | 0
Name | request_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 247
ID | 195
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[exec_context_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 30
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 248
ID | 196
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_session_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 31
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 249
ID | 197
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_blocking]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 32
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 250
ID | 198
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_exec_context_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 33
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 251
ID | 199
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[scheduler_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 34
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 252
ID | 200
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[database_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 128
LineageID | 35
MappedColumnID | 0
Name | database_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 253
ID | 201
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[user_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 36
MappedColumnID | 0
Name | user_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 254
ID | 202
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[task_state]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 10
LineageID | 37
MappedColumnID | 0
Name | task_state
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 255
ID | 203
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_status]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 15
LineageID | 38
MappedColumnID | 0
Name | request_status
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 256
ID | 204
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_status]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 15
LineageID | 39
MappedColumnID | 0
Name | session_status
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 257
ID | 205
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[executing_managed_code]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 40
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 258
ID | 206
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 41
MappedColumnID | 0
Name | login_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 259
ID | 207
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_user_process]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 42
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 260
ID | 208
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[host_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 20
LineageID | 43
MappedColumnID | 0
Name | host_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 261
ID | 209
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[program_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 50
LineageID | 44
MappedColumnID | 0
Name | program_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 262
ID | 210
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 30
LineageID | 45
MappedColumnID | 0
Name | login_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 263
ID | 211
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 45
LineageID | 46
MappedColumnID | 0
Name | wait_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 264
ID | 212
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_wait_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 45
LineageID | 47
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 265
ID | 213
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_duration_ms]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 48
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 266
ID | 214
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_resource]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 50
LineageID | 49
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 267
ID | 215
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[resource_description]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 140
LineageID | 50
MappedColumnID | 0
Name | resource_description
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 268
ID | 216
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 51
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 269
ID | 217
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_transaction_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 52
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 270
ID | 218
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_isolation_level]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 53
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 271
ID | 219
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_cpu_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 54
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 272
ID | 220
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 55
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 273
ID | 221
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 56
MappedColumnID | 0
Name | request_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 274
ID | 222
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 57
MappedColumnID | 0
Name | request_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 275
ID | 223
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 58
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 276
ID | 224
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_start_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 59
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 277
ID | 225
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[memory_usage]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 60
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 278
ID | 226
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_cpu_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 61
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 279
ID | 227
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 62
MappedColumnID | 0
Name | session_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 280
ID | 228
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 63
MappedColumnID | 0
Name | session_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 281
ID | 229
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 64
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 282
ID | 230
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_scheduled_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 65
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 283
ID | 231
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 66
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 284
ID | 232
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_start_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 72
MappedColumnID | 0
Name | last_request_start_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 285
ID | 233
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_end_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 73
MappedColumnID | 0
Name | last_request_end_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 286
ID | 234
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_resultsets]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 67
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 287
ID | 235
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_row_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 68
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 288
ID | 236
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[prev_error]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 69
MappedColumnID | 0
Name | prev_error
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 289
ID | 237
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[pending_io_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 70
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 290
ID | 238
IdentificationString | RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[command]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 32
LineageID | 71
MappedColumnID | 0
Name | command
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get snapshot of dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | OLE DB Source Error Output
ObjectType | OT_PATH
StartPoint | OLE DB Source Error Output


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | OLE DB Source Output
ObjectType | OT_PATH
StartPoint | OLE DB Source Output


Package element

Package element: CacheFileName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheFilePrefixPattern] + ".cache"
IncludeInDebugDump | False
Name | CacheFileName
Namespace | User
QualifiedName | User::CacheFileName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache
VariablePath | \Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Variables[User::CacheFileName]


Package element

Package element: SyncRoot

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | SyncRoot
Namespace | User
QualifiedName | User::SyncRoot
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | QueryActivityLock
VariablePath | \Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File.Variables[User::SyncRoot]


Package element

Package element: DMVErrorRowCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | DMVErrorRowCount
Namespace | User
QualifiedName | User::DMVErrorRowCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\LOOP - Query the query statitics DMV at collection frequency.Variables[User::DMVErrorRowCount]


Package element

Package element: DMVInOutRowCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | DMVInOutRowCount
Namespace | User
QualifiedName | User::DMVInOutRowCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\LOOP - Query the query statitics DMV at collection frequency.Variables[User::DMVInOutRowCount]


Package element

Package element: SQL - Log Package Iteration

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {F9DBCB6D-CA5E-49E5-8C4D-5AD6A9EEBBBF}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log Package Iteration
ResultSetType | 1
SqlStatementSource
{ call [dbo].[sp_syscollector_event_onpackageupdate]( ? )}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
DMVErrorRowCount |  | Variables
DMVInOutRowCount |  | Variables
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: SQL - Log Package Stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {85357745-D02F-4BB7-ABBC-28E41047CD03}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log Package Stats
ResultSetType | 1
SqlStatementSource
{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'active_sessions_and_request collection', ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
DMVErrorRowCount |  | Variables
DMVInOutRowCount |  | Variables
CacheDirectory |  | Variables
CacheFilePrefixPattern |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotExecRequestQuery |  | Variables
TargetConnectionString |  | Variables


Package element

Package element: {7283E196-D60C-438F-A58A-0EA1F41BBCF4}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DC.ForEachEventEnumerator.4
DelayValidation | False
Description |
ExitEventName | EXITEVENT
HasExpressions | True
HostType | ForEachEnumerator
ID | {7283E196-D60C-438F-A58A-0EA1F41BBCF4}
LoopEventName | LOOPEVENT
Name | {7283E196-D60C-438F-A58A-0EA1F41BBCF4}

Collapse image Elements

Name | Description | Type
ExitEventName |  | Expressions
LoopEventName |  | Expressions
ExitEventName |  | Expressions
LoopEventName |  | Expressions


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel]>=1
ID | {047084C2-63B9-4720-8815-1F2E55687ED8}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | SEQ - Synchronize Access to Cache File
Value | Completion


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Iteration
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {CAC2C69F-AA7D-4F74-902D-96E5F8052C76}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | SQL - Log Package Stats
Value | Completion


Package

Package: QueryActivityCollect

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityCollect

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityCollect

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityCollect

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityCollect

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilePrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotExecRequestQuery |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="7/10/2007 4:26:36 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{0B68FC9D-23DC-48F3-A937-90A0A8943D0E}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:ObjectName="QueryActivityCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="110" DTS:VersionGUID="{35BD5142-748A-48D7-9D65-E0E11BC48864}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{ACB4A0B0-94FF-473B-BB76-72DFB239DBC6}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{1906A00E-7676-4664-9159-0B790DF483C2}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{4BEFF4AE-6E6A-45EA-9DA2-0CDFFEE962C4}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{465410C0-791E-4D35-8366-A4CD30A3C75C}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1AF8E4B6-CDEA-4CF1-A6CD-BBA7C598217F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B2C54FDF-F78F-4065-8214-54B55A7A245A}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D7651A0A-C75C-4F0C-A5A2-4B51878A0C71}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9AFF7A64-3CE4-4518-B865-7077072A391D}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{54F38A44-3932-4198-8648-B0A244751041}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{39CD184D-90DF-4393-97EC-FABC1183F10C}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8614A7F4-3E3F-4314-9887-C88F2FB0F189}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{86ABBBA3-E60E-4CDF-861A-8476A6707570}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{509D0615-B505-4276-B8BC-7603D3877C04}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{289870D1-804D-45B2-9743-D8786F99F678}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3CB7F214-4B4E-4BF8-842E-BADD0B85E77D}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{71DE2249-F71B-452E-8C93-4652129EBD8B}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E62807FC-8321-4152-9495-11F889D7A544}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{328041A5-FC96-43B1-B07E-16BBFE3C44E0}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1FE8F866-6F84-4A05-88CD-CED5D86D85CF}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C87BA532-AEF2-4EC6-B57A-7F7A9BEF9C61}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0E1AD59F-85FB-4E34-8486-69AF746D75D9}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFilePrefixPattern">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CA75BAEE-7C40-4FA9-9183-6BE94457C296}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2C5BB3B2-7EE6-4359-9E7E-296FC3770D20}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">2DC02BD6-E230-4C05-8516-4E8C0EF21F95</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{83DD0AAF-E215-415D-93DD-B63A01D5C8B0}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">1d24f966-c63c-497c-a6bc-df2369b8ebdf</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{484186DB-81BF-42F2-BF2C-20FFADB17A36}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{474EEC5A-EA57-48C2-B537-05B0164EAB64}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C7FA4E99-F45A-4451-8428-FC8615BC6C14}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{662ECBEC-5F7E-4CBF-A1DE-BDF16646F7C3}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B8ACA1AD-1727-48D0-8B6E-A4D0EB233D64}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2DE6E9FB-CB6C-49DD-9735-5D10F9398F4B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AFA803CE-AB90-4D25-B80E-70DD09511550}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">100</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EBF4D97C-3B7D-4F65-800B-6231ECBE84B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A179515E-5B32-4638-85E7-93CD9BD6C5AE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1C0855D9-136A-4238-A669-4A67D43F74FC}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B8EE89B9-BD07-4CB6-B433-479BE117AD40}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AA7932C5-254A-4801-B462-BD5F0634FAD4}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{DBA8418D-EF68-460C-8038-9C9EC8AB1C69}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0EBF4C04-68F9-4CAA-B279-E0A07EDD3769}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] " + (DT_WSTR,10) (@[User::ItemID])" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SnapshotExecRequestQuery">
<DTS:VariableValue DTS:DataType="8">EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] 100</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{48649ACA-E498-43C0-84A4-06ED1F0FE3FA}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{3728E9CD-A948-47F5-B2A9-26BC486A8CD8}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="LOOP - Query the query statitics DMV at collection frequency">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{7283E196-D60C-438F-A58A-0EA1F41BBCF4}" DTS:ObjectName="{7283E196-D60C-438F-A58A-0EA1F41BBCF4}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6740CB1C-8A65-4578-8BC3-0664C060D59B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DMVErrorRowCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CAE88196-8281-42E5-BC3A-D3447C5C4836}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DMVInOutRowCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{95CCF408-6AAD-4742-B85E-7627D7D72418}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Synchronize Access to Cache File">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4DDEBC48-3AAC-4260-BAFC-4DFEFB97AD05}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">QueryActivityLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{CA0ED25A-27F6-4388-8E38-1F26D1A55878}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Collect DMV Data" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0BA11DB3-CA68-4BDF-AD2D-96D43C03584F}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheFilePrefixPattern] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileName">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::DMVErrorRowCount</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::DMVInOutRowCount</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get snapshot of dm_exec_requests" usesDispositions="true" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">SET NOCOUNT ON
-- Get the collection time as UTC time
DECLARE @collection_time datetime
SET @collection_time = GETDATE()
SELECT
CONVERT(int, ROW_NUMBER() OVER (ORDER BY sess.session_id, ISNULL (req.request_id, -1), ISNULL (tasks.exec_context_id, -1)) ) AS row_id,
-- IDs and Blocking IDs
sess.session_id,
ISNULL (req.request_id, -1) AS request_id,
ISNULL (tasks.exec_context_id, -1) AS exec_context_id,
ISNULL (req.blocking_session_id, 0) AS blocking_session_id,
CONVERT (bit, CASE
WHEN EXISTS (SELECT TOP 1 session_id FROM sys.dm_exec_requests bl WHERE bl.blocking_session_id = req.session_id) THEN 1
ELSE 0
END) AS is_blocking,
ISNULL (waits.blocking_exec_context_id, 0) AS blocking_exec_context_id,
tasks.scheduler_id,
DB_NAME(req.database_id) as database_name,
req.[user_id],
-- State information
LEFT (tasks.task_state, 10) AS task_state,
LEFT (req.status, 15) AS request_status,
LEFT (sess.status, 15) AS session_status,
req.executing_managed_code,
-- Session information
sess.login_time,
sess.is_user_process,
LEFT (ISNULL (sess.[host_name], ''), 20) AS [host_name],
LEFT (ISNULL (sess.[program_name], ''), 50) AS [program_name],
LEFT (ISNULL (sess.login_name, ''), 30) AS login_name,
-- Waits information
LEFT (ISNULL (req.wait_type, ''), 45) AS wait_type,
LEFT (ISNULL (req.last_wait_type, ''), 45) AS last_wait_type,
ISNULL (waits.wait_duration_ms, 0) AS wait_duration_ms,
LEFT (ISNULL (req.wait_resource, ''), 50) AS wait_resource,
LEFT (ISNULL (waits.resource_description, ''), 140) AS resource_description,
-- Transaction information
req.transaction_id,
ISNULL(req.open_transaction_count, 0) AS open_transaction_count,
COALESCE(req.transaction_isolation_level, sess.transaction_isolation_level) AS transaction_isolation_level,
-- Request stats
req.cpu_time AS request_cpu_time,
req.logical_reads AS request_logical_reads,
req.reads AS request_reads,
req.writes AS request_writes,
req.total_elapsed_time AS request_total_elapsed_time,
req.start_time AS request_start_time,
-- Session stats
sess.memory_usage,
sess.cpu_time AS session_cpu_time,
sess.reads AS session_reads,
sess.writes AS session_writes,
sess.logical_reads AS session_logical_reads,
sess.total_scheduled_time AS session_total_scheduled_time,
sess.total_elapsed_time AS session_total_elapsed_time,
sess.last_request_start_time,
sess.last_request_end_time,
req.open_resultset_count AS open_resultsets,
sess.row_count AS session_row_count,
sess.prev_error,
tasks.pending_io_count,
-- Text/Plan handles
ISNULL (req.command, 'AWAITING COMMAND') AS command,
req.plan_handle,
req.sql_handle,
req.statement_start_offset,
req.statement_end_offset,
@collection_time AS collection_time
FROM sys.dm_exec_sessions sess
LEFT OUTER MERGE JOIN sys.dm_exec_requests req ON sess.session_id = req.session_id
LEFT OUTER MERGE JOIN sys.dm_os_tasks tasks ON tasks.session_id = sess.session_id AND tasks.request_id = req.request_id AND tasks.task_address = req.task_address
LEFT OUTER MERGE JOIN sys.dm_os_waiting_tasks waits ON waits.session_id = sess.session_id AND waits.waiting_task_address = req.task_address
WHERE
sess.session_id <> @@SPID
AND
(
(req.session_id IS NOT NULL AND (sess.is_user_process = 1 OR req.status COLLATE Latin1_General_BIN NOT IN ('background', 'sleeping'))) -- active request
OR
(sess.session_id IN (SELECT DISTINCT blocking_session_id FROM sys.dm_exec_requests WHERE blocking_session_id != 0)) -- not active, but head blocker
)
OPTION (FORCE ORDER)</property>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotExecRequestQuery</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[row_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]" name="row_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]" name="session_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]" name="request_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]" name="exec_context_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]" name="blocking_session_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_blocking]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]" name="is_blocking" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[scheduler_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]" name="scheduler_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]" name="database_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[user_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]" name="user_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]" name="task_state" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]" name="request_status" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]" name="session_status" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]" name="executing_managed_code" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]" name="login_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_user_process]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]" name="is_user_process" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]" name="host_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]" name="program_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]" name="login_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]" name="wait_type" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]" name="last_wait_type" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]" name="wait_duration_ms" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]" name="wait_resource" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]" name="resource_description" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]" name="transaction_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]" name="open_transaction_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]" name="request_cpu_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]" name="request_logical_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]" name="request_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]" name="request_writes" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]" name="request_start_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[memory_usage]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]" name="memory_usage" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]" name="session_cpu_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]" name="session_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]" name="session_writes" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]" name="session_logical_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_resultsets]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]" name="open_resultsets" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_row_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]" name="session_row_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[prev_error]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]" name="prev_error" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[pending_io_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]" name="pending_io_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[command]" length="32" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]" name="command" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]" name="last_request_start_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_end_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]" name="last_request_end_time" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_start_time]" dataType="dbTimeStamp" name="last_request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_end_time]" dataType="dbTimeStamp" name="last_request_end_time"/>
</externalMetadataColumns>
</output>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[row_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[row_id]" name="row_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_id]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_id]" name="session_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_id]" name="request_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[exec_context_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[exec_context_id]" name="exec_context_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_session_id]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_session_id]" name="blocking_session_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_blocking]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_blocking]" name="is_blocking"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_exec_context_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[scheduler_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[scheduler_id]" name="scheduler_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[database_name]" dataType="wstr" length="128" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[database_name]" name="database_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[user_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[user_id]" name="user_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[task_state]" dataType="wstr" length="10" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[task_state]" name="task_state"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_status]" dataType="wstr" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_status]" name="request_status"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_status]" dataType="wstr" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_status]" name="session_status"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[executing_managed_code]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[executing_managed_code]" name="executing_managed_code"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_time]" name="login_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_user_process]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_user_process]" name="is_user_process"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[host_name]" dataType="wstr" length="20" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[host_name]" name="host_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[program_name]" dataType="wstr" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[program_name]" name="program_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_name]" dataType="wstr" length="30" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_name]" name="login_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_type]" dataType="wstr" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_type]" name="wait_type"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_wait_type]" dataType="wstr" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_wait_type]" name="last_wait_type"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_duration_ms]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_resource]" dataType="wstr" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_resource]" name="wait_resource"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[resource_description]" dataType="wstr" length="140" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[resource_description]" name="resource_description"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_id]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_id]" name="transaction_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_transaction_count]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_transaction_count]" name="open_transaction_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_isolation_level]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_cpu_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_cpu_time]" name="request_cpu_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_logical_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_logical_reads]" name="request_logical_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_reads]" name="request_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_writes]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_writes]" name="request_writes"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_total_elapsed_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_start_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_start_time]" name="request_start_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[memory_usage]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[memory_usage]" name="memory_usage"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_cpu_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_cpu_time]" name="session_cpu_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_reads]" name="session_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_writes]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_writes]" name="session_writes"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_logical_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_logical_reads]" name="session_logical_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_scheduled_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_elapsed_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_start_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_start_time]" name="last_request_start_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_end_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_end_time]" name="last_request_end_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_resultsets]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_resultsets]" name="open_resultsets"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_row_count]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_row_count]" name="session_row_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[prev_error]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[prev_error]" name="prev_error"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[pending_io_count]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[pending_io_count]" name="pending_io_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[command]" dataType="wstr" length="32" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[command]" name="command"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write data to a cache" validateExternalMetadata="False" version="2">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileName</property>
<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">2</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">
-<inputColumns>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[sql_handle]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[plan_handle]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[row_id]" cachedDataType="i4" cachedName="row_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[row_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_id]" cachedDataType="i2" cachedName="session_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_id]" cachedDataType="i4" cachedName="request_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[exec_context_id]" cachedDataType="i4" cachedName="exec_context_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_blocking]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_exec_context_id]" cachedDataType="i4" cachedName="blocking_exec_context_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[scheduler_id]" cachedDataType="i4" cachedName="scheduler_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[scheduler_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[database_name]" cachedDataType="wstr" cachedLength="128" cachedName="database_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[database_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[user_id]" cachedDataType="i4" cachedName="user_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[user_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[task_state]" cachedDataType="wstr" cachedLength="10" cachedName="task_state" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[task_state]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_status]" cachedDataType="wstr" cachedLength="15" cachedName="request_status" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_status]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_status]" cachedDataType="wstr" cachedLength="15" cachedName="session_status" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_status]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[executing_managed_code]" cachedDataType="bool" cachedName="executing_managed_code" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[executing_managed_code]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_time]" cachedDataType="dbTimeStamp" cachedName="login_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_user_process]" cachedDataType="bool" cachedName="is_user_process" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_user_process]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[host_name]" cachedDataType="wstr" cachedLength="20" cachedName="host_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[host_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[program_name]" cachedDataType="wstr" cachedLength="50" cachedName="program_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[program_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_name]" cachedDataType="wstr" cachedLength="30" cachedName="login_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="wait_type" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_type]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="last_wait_type" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[last_wait_type]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_duration_ms]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_resource]" cachedDataType="wstr" cachedLength="50" cachedName="wait_resource" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_resource]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[resource_description]" cachedDataType="wstr" cachedLength="140" cachedName="resource_description" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[resource_description]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_id]" cachedDataType="i8" cachedName="transaction_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_transaction_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_isolation_level]" cachedDataType="i2" cachedName="transaction_isolation_level" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_isolation_level]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_logical_reads]" cachedDataType="i8" cachedName="request_logical_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_reads]" cachedDataType="i8" cachedName="request_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_writes]" cachedDataType="i8" cachedName="request_writes" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_start_time]" cachedDataType="dbTimeStamp" cachedName="request_start_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[memory_usage]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_cpu_time]" cachedDataType="i4" cachedName="session_cpu_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_reads]" cachedDataType="i8" cachedName="session_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_writes]" cachedDataType="i8" cachedName="session_writes" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_logical_reads]" cachedDataType="i8" cachedName="session_logical_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_scheduled_time]" cachedDataType="i4" cachedName="session_total_scheduled_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_scheduled_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_elapsed_time]" cachedDataType="i4" cachedName="session_total_elapsed_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_start_time]" cachedDataType="dbTimeStamp" cachedName="last_request_start_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_end_time]" cachedDataType="dbTimeStamp" cachedName="last_request_end_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_end_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_resultsets]" cachedDataType="i4" cachedName="open_resultsets" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_resultsets]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_row_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[prev_error]" cachedDataType="i4" cachedName="prev_error" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[prev_error]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[pending_io_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[command]" cachedDataType="wstr" cachedLength="32" cachedName="command" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[command]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[row_id]" dataType="i4" name="row_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_id]" dataType="i2" name="session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_id]" dataType="i4" name="request_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[user_id]" dataType="i4" name="user_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>
</externalMetadataColumns>
</input>
</inputs>
</component>
</components>
-<paths>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[OLE DB Source Error Output]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[OLE DB Source Output]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output]"/>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[Row Count Output 1]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input]" name="Row Count Output 1" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{F9DBCB6D-CA5E-49E5-8C4D-5AD6A9EEBBBF}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onpackageupdate]( ? )}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{85357745-D02F-4BB7-ABBC-28E41047CD03}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'active_sessions_and_request collection', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::DMVInOutRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::DMVInOutRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DMVErrorRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{047084C2-63B9-4720-8815-1F2E55687ED8}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{CAC2C69F-AA7D-4F74-902D-96E5F8052C76}" DTS:From="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Iteration" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{ECAA643C-0A8B-446A-B97F-56D6E682773B}" DTS:ObjectName="{ECAA643C-0A8B-446A-B97F-56D6E682773B}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>


Package

Package: QueryActivityUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 7/10/2007 4:27:11 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {833DB628-8E19-47A3-92C5-FB1779B52E76}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.200.2131
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | QueryActivityUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\QueryActivityUpload
PackagePath | MSDB\Data Collector\QueryActivityUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 347
VersionComments |
VersionGUID | {A6F7BA9C-B80D-4942-9733-2CC3AC1D1111}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
ConfigConnection2 |
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
CWM - Remove Upload Snapshots Older Than CacheWindow | Cache Window Maintainance Task
FAT - Check Cache File Exists | File Access Task
FEF - For each collected cache file try upload | Foreach Loop Container
SEQ - Capture and analyze query statistics and query plan and text | Sequence Container
SEQ - Rename Collection Cache File | Sequence Container
SQL - Get SnapshotId | Execute SQL Task
SQL - Get SourceId | Execute SQL Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 12 |
Constraint 3 |
Constraint 6 |
Constraint 7 |
Constraint 8 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionCacheFileName | Stores snapshots of dm_exec_requests
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload.
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
InterestingQueries_HighCpuUsage |
InterestingQueries_HighIoCount |
InterestingQueries_HighMemoryUsage |
InterestingQueries_HighTransactionCount |
InterestingQueries_LargeResultset |
InterestingQueries_LongRunningRequest |
InterestingQueries_LongWaitingRequest |
InterestingQueriesCount |
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package.
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection.
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotId |
SnapshotQueryStatsQuery |
SourceId |
TargetConnectionString |
TopThreshold |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: QueryActivityUpload

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C47DA731-2DE9-4003-BEEA-DC9FEC0CB4FF}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {95F90B41-195A-485B-83A7-532CBE784B9B}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E2ABAEA8-8EDF-467A-8868-02D9DA214213}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {2DE58D9D-88EC-4EF1-BC5D-198E4A4D242B}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C0D122E4-3E93-4B7D-9D73-BD30523C5E1E}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {EAF8B0C8-D595-4C33-996B-05EC441AD7F3}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1F3E0B39-EFD8-46CB-A717-293C31799271}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {9A80FE73-FF5C-4E2C-AD8D-33F22D356AC2}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1371FF37-F2B5-4FDE-B5A5-536068DF92FA}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {82ABCEE4-E26E-4CD2-B58D-6C06867D0721}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {33F8AB16-E8C2-4E91-BD5B-8069298F752D}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C93D74BA-06D2-4D87-A4EA-D77FB294581B}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {42BF5414-6ED3-4173-A1AE-AF65B489397D}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {A1115DE1-DAC0-4E1D-9D41-B711F105082D}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1F89599A-D740-49C6-86F3-81E31F2AC5DB}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {9C690C28-5612-417C-B1A7-885E173AAA83}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package element

Package element: DaysUntilExpiration

Collapse image Properties

Name | Value
ConfigurationString | User::DaysUntilExpiration
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {1D6E40B7-426D-48E8-9BEB-A21586CBDE14}
Name | DaysUntilExpiration
PackagePath | \Package.Variables[User::DaysUntilExpiration].Properties[Value]


Package

Package: QueryActivityUpload

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
ConfigConnection2 |
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {39FB064F-9853-4718-880F-C97853E29875}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: CollectionCacheFileName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Stores snapshots of dm_exec_requests
EvaluateAsExpression | True
Expression | @[User::CollectionCacheFilePrefixPattern] + ".cache"
IncludeInDebugDump | False
Name | CollectionCacheFileName
Namespace | User
QualifiedName | User::CollectionCacheFileName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache
VariablePath | \Package.Variables[User::CollectionCacheFileName]


Package element

Package element: CollectionCacheFileNameOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload.
EvaluateAsExpression | True
Expression | @[User::CollectionCacheFilePrefixPattern] + @[System::ExecutionInstanceGUID] + ".temp.cache"
IncludeInDebugDump | False
Name | CollectionCacheFileNameOutput
Namespace | User
QualifiedName | User::CollectionCacheFileNameOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity{4F6F76C7-C0B1-4843-A5E2-293415B3D055}.temp.cache
VariablePath | \Package.Variables[User::CollectionCacheFileNameOutput]


Package element

Package element: CollectionCacheFilePrefixPattern

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Prefix for files related to dm_exec_requets collection
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"
IncludeInDebugDump | False
Name | CollectionCacheFilePrefixPattern
Namespace | User
QualifiedName | User::CollectionCacheFilePrefixPattern
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity
VariablePath | \Package.Variables[User::CollectionCacheFilePrefixPattern]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectorTypeUID
Namespace | User
QualifiedName | User::CollectorTypeUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 14AF3C12-38E6-4155-BD29-F33E7966BA23
VariablePath | \Package.Variables[User::CollectorTypeUID]


Package element

Package element: InterestingQueries_HighCpuUsage

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_HighCpuUsage
Namespace | User
QualifiedName | User::InterestingQueries_HighCpuUsage
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 5000
VariablePath | \Package.Variables[User::InterestingQueries_HighCpuUsage]


Package element

Package element: InterestingQueries_HighIoCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_HighIoCount
Namespace | User
QualifiedName | User::InterestingQueries_HighIoCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 500
VariablePath | \Package.Variables[User::InterestingQueries_HighIoCount]


Package element

Package element: InterestingQueries_HighMemoryUsage

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_HighMemoryUsage
Namespace | User
QualifiedName | User::InterestingQueries_HighMemoryUsage
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 12800
VariablePath | \Package.Variables[User::InterestingQueries_HighMemoryUsage]


Package element

Package element: InterestingQueries_HighTransactionCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_HighTransactionCount
Namespace | User
QualifiedName | User::InterestingQueries_HighTransactionCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 8
VariablePath | \Package.Variables[User::InterestingQueries_HighTransactionCount]


Package element

Package element: InterestingQueries_LargeResultset

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_LargeResultset
Namespace | User
QualifiedName | User::InterestingQueries_LargeResultset
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 1000000
VariablePath | \Package.Variables[User::InterestingQueries_LargeResultset]


Package element

Package element: InterestingQueries_LongRunningRequest

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_LongRunningRequest
Namespace | User
QualifiedName | User::InterestingQueries_LongRunningRequest
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 25000
VariablePath | \Package.Variables[User::InterestingQueries_LongRunningRequest]


Package element

Package element: InterestingQueries_LongWaitingRequest

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueries_LongWaitingRequest
Namespace | User
QualifiedName | User::InterestingQueries_LongWaitingRequest
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 500
VariablePath | \Package.Variables[User::InterestingQueries_LongWaitingRequest]


Package element

Package element: InterestingQueriesCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueriesCount
Namespace | User
QualifiedName | User::InterestingQueriesCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::InterestingQueriesCount]


Package element

Package element: InterestingQueriesLastSnapshotFileName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package.
EvaluateAsExpression | True
Expression | @[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.cache"
IncludeInDebugDump | False
Name | InterestingQueriesLastSnapshotFileName
Namespace | User
QualifiedName | User::InterestingQueriesLastSnapshotFileName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache
VariablePath | \Package.Variables[User::InterestingQueriesLastSnapshotFileName]


Package element

Package element: InterestingQueriesLastSnapshotFileNameOutput

CollapseAll image

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Stores temporary copy of the most recent snapshot of dm_exec_query_stats
EvaluateAsExpression | True
Expression | @[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.temp.cache"
IncludeInDebugDump | False
Name | InterestingQueriesLastSnapshotFileNameOutput
Namespace | User
QualifiedName | User::InterestingQueriesLastSnapshotFileNameOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.temp.cache
VariablePath | \Package.Variables[User::InterestingQueriesLastSnapshotFileNameOutput]


Package element

Package element: InterestingQueriesSnapshotFileNamePrefixPattern

CollapseAll image

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Prefix for files related to dm_exec_query_stats collection.
EvaluateAsExpression | True
Expression | @[User::CollectionCacheFilePrefixPattern] + "_QueryStats_"
IncludeInDebugDump | False
Name | InterestingQueriesSnapshotFileNamePrefixPattern
Namespace | User
QualifiedName | User::InterestingQueriesSnapshotFileNamePrefixPattern
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_
VariablePath | \Package.Variables[User::InterestingQueriesSnapshotFileNamePrefixPattern]


Package element

Package element: SnapshotId

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SnapshotId
Namespace | User
QualifiedName | User::SnapshotId
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 200
VariablePath | \Package.Variables[User::SnapshotId]


Package element

Package element: SnapshotQueryStatsQuery

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] " + (DT_WSTR,10) (@[User::ItemID])
IncludeInDebugDump | False
Name | SnapshotQueryStatsQuery
Namespace | User
QualifiedName | User::SnapshotQueryStatsQuery
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] 100
VariablePath | \Package.Variables[User::SnapshotQueryStatsQuery]


Package element

Package element: SourceId

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SourceId
Namespace | User
QualifiedName | User::SourceId
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 1
VariablePath | \Package.Variables[User::SourceId]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TargetConnectionString
Namespace | User
QualifiedName | User::TargetConnectionString
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | Provider=SQLNCLI11;Initial Catalog=master;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector
VariablePath | \Package.Variables[User::TargetConnectionString]


Package element

Package element: TopThreshold

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TopThreshold
Namespace | User
QualifiedName | User::TopThreshold
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 5
VariablePath | \Package.Variables[User::TopThreshold]


Package element

Package element: ConfigConnection2

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description |
HasExpressions | True
HostType | ConnectionManager
ID | {92804B88-CB2F-4FEE-8EFF-64901F67CBBB}
InitialCatalog | msdb
Name | ConfigConnection2
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: MdwConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to upload collected data to a warehouse.
HasExpressions | True
HostType | ConnectionManager
ID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
InitialCatalog | MDW
Name | MdwConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: TargetConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=master;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information from the monitored (target) instance.
HasExpressions | True
HostType | ConnectionManager
ID | {15DDC5A3-5645-4BAA-BCC8-B0AF18FDE25D}
InitialCatalog | master
Name | TargetConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package

Package: QueryActivityUpload

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityUpload

Collapse image Executables

Name | Description
CWM - Remove Upload Snapshots Older Than CacheWindow | Cache Window Maintainance Task
FAT - Check Cache File Exists | File Access Task
FEF - For each collected cache file try upload | Foreach Loop Container
SEQ - Capture and analyze query statistics and query plan and text | Sequence Container
SEQ - Rename Collection Cache File | Sequence Container
SQL - Get SnapshotId | Execute SQL Task
SQL - Get SourceId | Execute SQL Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: CWM - Remove Upload Snapshots Older Than CacheWindow

CollapseAll image

Collapse image Properties

Name | Value
ApartmentThreaded | True
CacheFileNamePrefixVarName | User::InterestingQueriesSnapshotFileNamePrefixPattern
CacheWindow | 0
CollectionSetUID |
CollectorTempDir |
CollectorTypeUID |
ConfigConnectionString |
CreationName | Microsoft.SqlServer.Management.Collector.Tasks.CacheWindowMaintainanceTask, Microsoft.SqlServer.Management.CollectorTasks, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Cache Window Maintainance Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
ExitEventName |
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {C8B1E699-7A73-4ECD-A317-B9E91002738D}
InstanceName |
IsDefaultLocaleID | True
IsolationLevel | Serializable
ItemID | 0
LocaleID | English (United States)
LoggingLevel | 0
LoggingMode | Disabled
LoopEventName |
MaximumErrorCount | 0
MdwConnectionString |
Name | CWM - Remove Upload Snapshots Older Than CacheWindow
SuspendRequired | False
TargetConnectionString |
TargetServerVersion | 130
TaskDisplayName | Cache Window Maintainance Task
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
CacheFileNamePrefixVarName |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: CacheFileNamePrefixVarName

Collapse image Properties

Name | Value
Expression | "User::InterestingQueriesSnapshotFileNamePrefixPattern"
Name | CacheFileNamePrefixVarName


Package element

Package element: FAT - Check Cache File Exists

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.FileAccessTask.4
DebugMode | False
DelayValidation | False
Description | File Access Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FilePath | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {94132A74-FB8C-4E52-B247-D2B4FCD589D9}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Mode | 0
Name | FAT - Check Cache File Exists
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FilePath |  | Expressions
Mode |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: FilePath

Collapse image Properties

Name | Value
Expression | @[User::CollectionCacheFileName]
Name | FilePath


Package element

Package element: FEF - For each collected cache file try upload

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | False
Description | Foreach Loop Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {91A4B7F7-385C-47C2-AA89-08B832F71599}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FEF - For each collected cache file try upload
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Upload collection snapshot | Data Flow Task | Executables
FST - Delete uploaded cache file | File System Task | Executables
SQL - Log Package Iteration | Execute SQL Task | Executables
SQL - Log Package Stats | Execute SQL Task | Executables
{BB52AFAE-60A1-42A7-9C13-52B21293D219} |  | ForEachEnumerator
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
CurrentCollectionCacheFileName |  | Variables
RowCount |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: DFT - Upload collection snapshot

Collapse image Properties

Name | Value
[DRV - Add snapshot_id column].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotId]
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | False
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {FE775FB9-E8B7-4171-9DFB-544E7CCA7809}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Upload collection snapshot
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DRV - Add snapshot_id column | Updates column values using expressions | ComponentMetaDataCollection
ODS - Upload snapshots into active_sessions_and_requests table | OLE DB Destination | ComponentMetaDataCollection
RC - Count output rows | Counts the rows in a dataset. | ComponentMetaDataCollection
RFS - Read Current Upload Data | Extracts data from a raw file. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Derived Column Output |  | PathCollection
Raw File Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
CurrentCollectionCacheFileName |  | Variables
RowCount |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables
SSIS diagram is missing


Package element

Package element: DRV - Add snapshot_id column

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 2
IdentificationString | DRV - Add snapshot_id column
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add snapshot_id column
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 3
IdentificationString | DRV - Add snapshot_id column.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 4
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | OutputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 5
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 7
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 8
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 9
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 10
IdentificationString | DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 10
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ODS - Upload snapshots into active_sessions_and_requests table

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 11
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Upload snapshots into active_sessions_and_requests table
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[active_sessions_and_requests]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 16
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 17
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 20
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 21
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 24
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | False
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
row_id |  | ExternalMetadataColumnCollection
session_id |  | ExternalMetadataColumnCollection
request_id |  | ExternalMetadataColumnCollection
exec_context_id |  | ExternalMetadataColumnCollection
blocking_session_id |  | ExternalMetadataColumnCollection
is_blocking |  | ExternalMetadataColumnCollection
blocking_exec_context_id |  | ExternalMetadataColumnCollection
scheduler_id |  | ExternalMetadataColumnCollection
database_name |  | ExternalMetadataColumnCollection
user_id |  | ExternalMetadataColumnCollection
task_state |  | ExternalMetadataColumnCollection
request_status |  | ExternalMetadataColumnCollection
session_status |  | ExternalMetadataColumnCollection
executing_managed_code |  | ExternalMetadataColumnCollection
login_time |  | ExternalMetadataColumnCollection
is_user_process |  | ExternalMetadataColumnCollection
host_name |  | ExternalMetadataColumnCollection
program_name |  | ExternalMetadataColumnCollection
login_name |  | ExternalMetadataColumnCollection
wait_type |  | ExternalMetadataColumnCollection
last_wait_type |  | ExternalMetadataColumnCollection
wait_duration_ms |  | ExternalMetadataColumnCollection
wait_resource |  | ExternalMetadataColumnCollection
resource_description |  | ExternalMetadataColumnCollection
transaction_id |  | ExternalMetadataColumnCollection
open_transaction_count |  | ExternalMetadataColumnCollection
transaction_isolation_level |  | ExternalMetadataColumnCollection
request_cpu_time |  | ExternalMetadataColumnCollection
request_logical_reads |  | ExternalMetadataColumnCollection
request_reads |  | ExternalMetadataColumnCollection
request_writes |  | ExternalMetadataColumnCollection
request_total_elapsed_time |  | ExternalMetadataColumnCollection
request_start_time |  | ExternalMetadataColumnCollection
memory_usage |  | ExternalMetadataColumnCollection
session_cpu_time |  | ExternalMetadataColumnCollection
session_reads |  | ExternalMetadataColumnCollection
session_writes |  | ExternalMetadataColumnCollection
session_logical_reads |  | ExternalMetadataColumnCollection
session_total_scheduled_time |  | ExternalMetadataColumnCollection
session_total_elapsed_time |  | ExternalMetadataColumnCollection
session_last_request_start_time |  | ExternalMetadataColumnCollection
session_last_request_end_time |  | ExternalMetadataColumnCollection
open_resultsets |  | ExternalMetadataColumnCollection
session_row_count |  | ExternalMetadataColumnCollection
prev_error |  | ExternalMetadataColumnCollection
pending_io_count |  | ExternalMetadataColumnCollection
command |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
snapshot_id |  | ExternalMetadataColumnCollection
sql_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_handle |  | InputColumnCollection
collection_time |  | InputColumnCollection
row_id |  | InputColumnCollection
session_id |  | InputColumnCollection
request_id |  | InputColumnCollection
exec_context_id |  | InputColumnCollection
blocking_session_id |  | InputColumnCollection
is_blocking |  | InputColumnCollection
blocking_exec_context_id |  | InputColumnCollection
scheduler_id |  | InputColumnCollection
database_name |  | InputColumnCollection
user_id |  | InputColumnCollection
task_state |  | InputColumnCollection
request_status |  | InputColumnCollection
session_status |  | InputColumnCollection
executing_managed_code |  | InputColumnCollection
login_time |  | InputColumnCollection
is_user_process |  | InputColumnCollection
host_name |  | InputColumnCollection
program_name |  | InputColumnCollection
login_name |  | InputColumnCollection
wait_type |  | InputColumnCollection
last_wait_type |  | InputColumnCollection
wait_duration_ms |  | InputColumnCollection
wait_resource |  | InputColumnCollection
resource_description |  | InputColumnCollection
transaction_id |  | InputColumnCollection
open_transaction_count |  | InputColumnCollection
transaction_isolation_level |  | InputColumnCollection
request_cpu_time |  | InputColumnCollection
request_logical_reads |  | InputColumnCollection
request_reads |  | InputColumnCollection
request_writes |  | InputColumnCollection
request_total_elapsed_time |  | InputColumnCollection
request_start_time |  | InputColumnCollection
memory_usage |  | InputColumnCollection
session_cpu_time |  | InputColumnCollection
session_reads |  | InputColumnCollection
session_writes |  | InputColumnCollection
session_logical_reads |  | InputColumnCollection
session_total_scheduled_time |  | InputColumnCollection
session_total_elapsed_time |  | InputColumnCollection
session_last_request_start_time |  | InputColumnCollection
session_last_request_end_time |  | InputColumnCollection
open_resultsets |  | InputColumnCollection
session_row_count |  | InputColumnCollection
prev_error |  | InputColumnCollection
pending_io_count |  | InputColumnCollection
command |  | InputColumnCollection
snapshot_id |  | InputColumnCollection


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 78
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[row_id]
Length | 0
MappedColumnID | 0
Name | row_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 79
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_id]
Length | 0
MappedColumnID | 0
Name | session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 80
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_id]
Length | 0
MappedColumnID | 0
Name | request_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 81
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[exec_context_id]
Length | 0
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 82
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_session_id]
Length | 0
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 83
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_blocking]
Length | 0
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 84
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_exec_context_id]
Length | 0
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 85
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[scheduler_id]
Length | 0
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 86
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[database_name]
Length | 128
MappedColumnID | 0
Name | database_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 87
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[user_id]
Length | 0
MappedColumnID | 0
Name | user_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 88
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[task_state]
Length | 10
MappedColumnID | 0
Name | task_state
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 89
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_status]
Length | 15
MappedColumnID | 0
Name | request_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 90
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_status]
Length | 15
MappedColumnID | 0
Name | session_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 91
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[executing_managed_code]
Length | 0
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 92
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_time]
Length | 0
MappedColumnID | 0
Name | login_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 93
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_user_process]
Length | 0
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 94
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[host_name]
Length | 20
MappedColumnID | 0
Name | host_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 95
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[program_name]
Length | 50
MappedColumnID | 0
Name | program_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 96
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_name]
Length | 30
MappedColumnID | 0
Name | login_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 97
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_type]
Length | 45
MappedColumnID | 0
Name | wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 98
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[last_wait_type]
Length | 45
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 99
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_duration_ms]
Length | 0
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 100
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_resource]
Length | 50
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 101
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[resource_description]
Length | 140
MappedColumnID | 0
Name | resource_description
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 102
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_id]
Length | 0
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 103
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_transaction_count]
Length | 0
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 104
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_isolation_level]
Length | 0
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 105
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_cpu_time]
Length | 0
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 106
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_logical_reads]
Length | 0
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 107
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_reads]
Length | 0
MappedColumnID | 0
Name | request_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 108
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_writes]
Length | 0
MappedColumnID | 0
Name | request_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 109
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 110
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_start_time]
Length | 0
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 111
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[memory_usage]
Length | 0
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 112
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_cpu_time]
Length | 0
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 113
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_reads]
Length | 0
MappedColumnID | 0
Name | session_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 114
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_writes]
Length | 0
MappedColumnID | 0
Name | session_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 115
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_logical_reads]
Length | 0
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 116
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_scheduled_time]
Length | 0
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 117
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 118
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_start_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 119
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_end_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 120
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_resultsets]
Length | 0
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 121
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_row_count]
Length | 0
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 122
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[prev_error]
Length | 0
MappedColumnID | 0
Name | prev_error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 123
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[pending_io_count]
Length | 0
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 124
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[command]
Length | 32
MappedColumnID | 0
Name | command
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 125
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 126
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 127
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 128
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 129
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 130
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]
Length | 0
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 126
ID | 25
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 143
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 127
ID | 26
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 144
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 128
ID | 27
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 145
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 125
ID | 28
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 146
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 129
ID | 29
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 147
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 78
ID | 30
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[row_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 148
MappedColumnID | 0
Name | row_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 79
ID | 31
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 149
MappedColumnID | 0
Name | session_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 80
ID | 32
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 150
MappedColumnID | 0
Name | request_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 81
ID | 33
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[exec_context_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 151
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 82
ID | 34
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_session_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 152
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 83
ID | 35
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_blocking]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 153
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 84
ID | 36
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_exec_context_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 154
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 85
ID | 37
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[scheduler_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 155
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 86
ID | 38
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[database_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 128
LineageID | 156
MappedColumnID | 0
Name | database_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 87
ID | 39
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[user_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 157
MappedColumnID | 0
Name | user_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 88
ID | 40
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[task_state]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 10
LineageID | 158
MappedColumnID | 0
Name | task_state
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 89
ID | 41
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_status]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 15
LineageID | 159
MappedColumnID | 0
Name | request_status
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 90
ID | 42
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_status]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 15
LineageID | 160
MappedColumnID | 0
Name | session_status
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 91
ID | 43
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[executing_managed_code]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 161
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 92
ID | 44
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 162
MappedColumnID | 0
Name | login_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 93
ID | 45
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_user_process]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 163
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 94
ID | 46
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[host_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 20
LineageID | 164
MappedColumnID | 0
Name | host_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 95
ID | 47
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[program_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 50
LineageID | 165
MappedColumnID | 0
Name | program_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 96
ID | 48
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 30
LineageID | 166
MappedColumnID | 0
Name | login_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 97
ID | 49
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 45
LineageID | 167
MappedColumnID | 0
Name | wait_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 98
ID | 50
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[last_wait_type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 45
LineageID | 168
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 99
ID | 51
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_duration_ms]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 169
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 100
ID | 52
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_resource]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 50
LineageID | 170
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 101
ID | 53
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[resource_description]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 140
LineageID | 171
MappedColumnID | 0
Name | resource_description
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 102
ID | 54
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 172
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 103
ID | 55
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_transaction_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 173
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 104
ID | 56
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_isolation_level]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 174
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 105
ID | 57
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_cpu_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 175
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 106
ID | 58
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 176
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 107
ID | 59
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 177
MappedColumnID | 0
Name | request_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 108
ID | 60
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 178
MappedColumnID | 0
Name | request_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 109
ID | 61
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 179
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 110
ID | 62
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_start_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 180
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 111
ID | 63
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[memory_usage]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 181
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 112
ID | 64
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_cpu_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 182
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 113
ID | 65
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 183
MappedColumnID | 0
Name | session_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 114
ID | 66
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 184
MappedColumnID | 0
Name | session_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 115
ID | 67
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 185
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 116
ID | 68
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_scheduled_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 186
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 117
ID | 69
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 187
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 118
ID | 70
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_start_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 188
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 119
ID | 71
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_end_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 189
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 120
ID | 72
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_resultsets]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 190
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 121
ID | 73
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_row_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 191
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 122
ID | 74
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[prev_error]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 192
MappedColumnID | 0
Name | prev_error
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 123
ID | 75
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[pending_io_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 193
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 124
ID | 76
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[command]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 32
LineageID | 194
MappedColumnID | 0
Name | command
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read Current Upload Data
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 130
ID | 77
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add snapshot_id column
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 131
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 24
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 132
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 132
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 133
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 133
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 23
IdentificationString | ODS - Upload snapshots into active_sessions_and_requests table.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RC - Count output rows

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 134
IdentificationString | RC - Count output rows
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Count output rows
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 135
IdentificationString | RC - Count output rows.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCount


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 136
IdentificationString | RC - Count output rows.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 137
IdentificationString | RC - Count output rows.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 136
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RFS - Read Current Upload Data

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {036C7941-58DF-4CD3-BF13-E5373258D001}
ContactInfo | Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Extracts data from a raw file.
ID | 138
IdentificationString | RFS - Read Current Upload Data
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFS - Read Current Upload Data
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
Raw File Source Output |  | OutputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 139
IdentificationString | RFS - Read Current Upload Data.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 140
IdentificationString | RFS - Read Current Upload Data.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 141
IdentificationString | RFS - Read Current Upload Data.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CurrentCollectionCacheFileName


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 142
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Raw File Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
row_id |  | ExternalMetadataColumnCollection
session_id |  | ExternalMetadataColumnCollection
request_id |  | ExternalMetadataColumnCollection
exec_context_id |  | ExternalMetadataColumnCollection
blocking_session_id |  | ExternalMetadataColumnCollection
is_blocking |  | ExternalMetadataColumnCollection
blocking_exec_context_id |  | ExternalMetadataColumnCollection
scheduler_id |  | ExternalMetadataColumnCollection
database_name |  | ExternalMetadataColumnCollection
user_id |  | ExternalMetadataColumnCollection
task_state |  | ExternalMetadataColumnCollection
request_status |  | ExternalMetadataColumnCollection
session_status |  | ExternalMetadataColumnCollection
executing_managed_code |  | ExternalMetadataColumnCollection
login_time |  | ExternalMetadataColumnCollection
is_user_process |  | ExternalMetadataColumnCollection
host_name |  | ExternalMetadataColumnCollection
program_name |  | ExternalMetadataColumnCollection
login_name |  | ExternalMetadataColumnCollection
wait_type |  | ExternalMetadataColumnCollection
last_wait_type |  | ExternalMetadataColumnCollection
wait_duration_ms |  | ExternalMetadataColumnCollection
wait_resource |  | ExternalMetadataColumnCollection
resource_description |  | ExternalMetadataColumnCollection
transaction_id |  | ExternalMetadataColumnCollection
open_transaction_count |  | ExternalMetadataColumnCollection
transaction_isolation_level |  | ExternalMetadataColumnCollection
request_cpu_time |  | ExternalMetadataColumnCollection
request_logical_reads |  | ExternalMetadataColumnCollection
request_reads |  | ExternalMetadataColumnCollection
request_writes |  | ExternalMetadataColumnCollection
request_total_elapsed_time |  | ExternalMetadataColumnCollection
request_start_time |  | ExternalMetadataColumnCollection
memory_usage |  | ExternalMetadataColumnCollection
session_cpu_time |  | ExternalMetadataColumnCollection
session_reads |  | ExternalMetadataColumnCollection
session_writes |  | ExternalMetadataColumnCollection
session_logical_reads |  | ExternalMetadataColumnCollection
session_total_scheduled_time |  | ExternalMetadataColumnCollection
session_total_elapsed_time |  | ExternalMetadataColumnCollection
session_last_request_start_time |  | ExternalMetadataColumnCollection
session_last_request_end_time |  | ExternalMetadataColumnCollection
open_resultsets |  | ExternalMetadataColumnCollection
session_row_count |  | ExternalMetadataColumnCollection
prev_error |  | ExternalMetadataColumnCollection
pending_io_count |  | ExternalMetadataColumnCollection
command |  | ExternalMetadataColumnCollection
sql_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
row_id |  | OutputColumnCollection
session_id |  | OutputColumnCollection
request_id |  | OutputColumnCollection
exec_context_id |  | OutputColumnCollection
blocking_session_id |  | OutputColumnCollection
is_blocking |  | OutputColumnCollection
blocking_exec_context_id |  | OutputColumnCollection
scheduler_id |  | OutputColumnCollection
database_name |  | OutputColumnCollection
user_id |  | OutputColumnCollection
task_state |  | OutputColumnCollection
request_status |  | OutputColumnCollection
session_status |  | OutputColumnCollection
executing_managed_code |  | OutputColumnCollection
login_time |  | OutputColumnCollection
is_user_process |  | OutputColumnCollection
host_name |  | OutputColumnCollection
program_name |  | OutputColumnCollection
login_name |  | OutputColumnCollection
wait_type |  | OutputColumnCollection
last_wait_type |  | OutputColumnCollection
wait_duration_ms |  | OutputColumnCollection
wait_resource |  | OutputColumnCollection
resource_description |  | OutputColumnCollection
transaction_id |  | OutputColumnCollection
open_transaction_count |  | OutputColumnCollection
transaction_isolation_level |  | OutputColumnCollection
request_cpu_time |  | OutputColumnCollection
request_logical_reads |  | OutputColumnCollection
request_reads |  | OutputColumnCollection
request_writes |  | OutputColumnCollection
request_total_elapsed_time |  | OutputColumnCollection
request_start_time |  | OutputColumnCollection
memory_usage |  | OutputColumnCollection
session_cpu_time |  | OutputColumnCollection
session_reads |  | OutputColumnCollection
session_writes |  | OutputColumnCollection
session_logical_reads |  | OutputColumnCollection
session_total_scheduled_time |  | OutputColumnCollection
session_total_elapsed_time |  | OutputColumnCollection
session_last_request_start_time |  | OutputColumnCollection
session_last_request_end_time |  | OutputColumnCollection
open_resultsets |  | OutputColumnCollection
session_row_count |  | OutputColumnCollection
prev_error |  | OutputColumnCollection
pending_io_count |  | OutputColumnCollection
command |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 195
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 196
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 197
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 198
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 199
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 200
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[row_id]
Length | 0
MappedColumnID | 0
Name | row_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 201
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_id]
Length | 0
MappedColumnID | 0
Name | session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 202
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_id]
Length | 0
MappedColumnID | 0
Name | request_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 203
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]
Length | 0
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 204
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]
Length | 0
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 205
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_blocking]
Length | 0
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 206
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]
Length | 0
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 207
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]
Length | 0
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 208
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[database_name]
Length | 128
MappedColumnID | 0
Name | database_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 209
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[user_id]
Length | 0
MappedColumnID | 0
Name | user_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 210
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[task_state]
Length | 10
MappedColumnID | 0
Name | task_state
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 211
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_status]
Length | 15
MappedColumnID | 0
Name | request_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 212
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_status]
Length | 15
MappedColumnID | 0
Name | session_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 213
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]
Length | 0
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 214
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_time]
Length | 0
MappedColumnID | 0
Name | login_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 215
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_user_process]
Length | 0
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 216
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[host_name]
Length | 20
MappedColumnID | 0
Name | host_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 217
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[program_name]
Length | 50
MappedColumnID | 0
Name | program_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 218
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_name]
Length | 30
MappedColumnID | 0
Name | login_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 219
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_type]
Length | 45
MappedColumnID | 0
Name | wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 220
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]
Length | 45
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 221
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]
Length | 0
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 222
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_resource]
Length | 50
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 223
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[resource_description]
Length | 140
MappedColumnID | 0
Name | resource_description
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 224
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_id]
Length | 0
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 225
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]
Length | 0
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 226
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]
Length | 0
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 227
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]
Length | 0
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 228
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]
Length | 0
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 229
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_reads]
Length | 0
MappedColumnID | 0
Name | request_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 230
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_writes]
Length | 0
MappedColumnID | 0
Name | request_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 231
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 232
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_start_time]
Length | 0
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 233
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[memory_usage]
Length | 0
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 234
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]
Length | 0
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 235
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_reads]
Length | 0
MappedColumnID | 0
Name | session_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 236
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_writes]
Length | 0
MappedColumnID | 0
Name | session_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 237
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]
Length | 0
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 238
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]
Length | 0
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 239
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 240
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 241
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 242
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]
Length | 0
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 243
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_row_count]
Length | 0
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 244
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[prev_error]
Length | 0
MappedColumnID | 0
Name | prev_error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 245
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]
Length | 0
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 246
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[command]
Length | 32
MappedColumnID | 0
Name | command
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 195
ID | 143
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]
Length | 64
LineageID | 143
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 196
ID | 144
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 144
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 197
ID | 145
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 145
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 198
ID | 146
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]
Length | 64
LineageID | 146
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 199
ID | 147
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]
Length | 0
LineageID | 147
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 200
ID | 148
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]
Length | 0
LineageID | 148
MappedColumnID | 0
Name | row_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 201
ID | 149
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]
Length | 0
LineageID | 149
MappedColumnID | 0
Name | session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 202
ID | 150
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]
Length | 0
LineageID | 150
MappedColumnID | 0
Name | request_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 203
ID | 151
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]
Length | 0
LineageID | 151
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 204
ID | 152
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]
Length | 0
LineageID | 152
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 205
ID | 153
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]
Length | 0
LineageID | 153
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 206
ID | 154
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]
Length | 0
LineageID | 154
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 207
ID | 155
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]
Length | 0
LineageID | 155
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 208
ID | 156
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]
Length | 128
LineageID | 156
MappedColumnID | 0
Name | database_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 209
ID | 157
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]
Length | 0
LineageID | 157
MappedColumnID | 0
Name | user_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 210
ID | 158
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]
Length | 10
LineageID | 158
MappedColumnID | 0
Name | task_state
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 211
ID | 159
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]
Length | 15
LineageID | 159
MappedColumnID | 0
Name | request_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 212
ID | 160
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]
Length | 15
LineageID | 160
MappedColumnID | 0
Name | session_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 213
ID | 161
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]
Length | 0
LineageID | 161
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 214
ID | 162
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]
Length | 0
LineageID | 162
MappedColumnID | 0
Name | login_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 215
ID | 163
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]
Length | 0
LineageID | 163
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 216
ID | 164
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]
Length | 20
LineageID | 164
MappedColumnID | 0
Name | host_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 217
ID | 165
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]
Length | 50
LineageID | 165
MappedColumnID | 0
Name | program_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 218
ID | 166
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]
Length | 30
LineageID | 166
MappedColumnID | 0
Name | login_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 219
ID | 167
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]
Length | 45
LineageID | 167
MappedColumnID | 0
Name | wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 220
ID | 168
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]
Length | 45
LineageID | 168
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 221
ID | 169
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]
Length | 0
LineageID | 169
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 222
ID | 170
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]
Length | 50
LineageID | 170
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 223
ID | 171
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]
Length | 140
LineageID | 171
MappedColumnID | 0
Name | resource_description
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 224
ID | 172
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]
Length | 0
LineageID | 172
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 225
ID | 173
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]
Length | 0
LineageID | 173
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 226
ID | 174
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]
Length | 0
LineageID | 174
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 227
ID | 175
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]
Length | 0
LineageID | 175
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 228
ID | 176
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]
Length | 0
LineageID | 176
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 229
ID | 177
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]
Length | 0
LineageID | 177
MappedColumnID | 0
Name | request_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 230
ID | 178
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]
Length | 0
LineageID | 178
MappedColumnID | 0
Name | request_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 231
ID | 179
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]
Length | 0
LineageID | 179
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 232
ID | 180
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]
Length | 0
LineageID | 180
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 233
ID | 181
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]
Length | 0
LineageID | 181
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 234
ID | 182
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]
Length | 0
LineageID | 182
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 235
ID | 183
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]
Length | 0
LineageID | 183
MappedColumnID | 0
Name | session_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 236
ID | 184
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]
Length | 0
LineageID | 184
MappedColumnID | 0
Name | session_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 237
ID | 185
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]
Length | 0
LineageID | 185
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 238
ID | 186
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]
Length | 0
LineageID | 186
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 239
ID | 187
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]
Length | 0
LineageID | 187
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 240
ID | 188
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]
Length | 0
LineageID | 188
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 241
ID | 189
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]
Length | 0
LineageID | 189
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 242
ID | 190
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]
Length | 0
LineageID | 190
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 243
ID | 191
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]
Length | 0
LineageID | 191
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 244
ID | 192
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]
Length | 0
LineageID | 192
MappedColumnID | 0
Name | prev_error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 245
ID | 193
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]
Length | 0
LineageID | 193
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 246
ID | 194
IdentificationString | RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]
Length | 32
LineageID | 194
MappedColumnID | 0
Name | command
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Destination Input
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: CurrentCollectionCacheFileName

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CurrentCollectionCacheFileName
Namespace | User
QualifiedName | User::CurrentCollectionCacheFileName
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\Users\macies\AppData\Local\Temp\ecodePerfWH\MACIES4_MSSQL.1_{{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}}_100_QueryActivity.cache
VariablePath | \Package\FEF - For each collected cache file try upload.Variables[User::CurrentCollectionCacheFileName]


Package element

Package element: RowCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCount
Namespace | User
QualifiedName | User::RowCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\FEF - For each collected cache file try upload.Variables[User::RowCount]


Package element

Package element: FST - Delete uploaded cache file

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | File System Task
Destination |
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {F370098D-B959-45DB-8581-AC43E7A4A5EA}
IsDefaultLocaleID | True
IsDestinationPathVariable | False
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | FST - Delete uploaded cache file
Operation | 2
OperationName |
OverwriteDestinationFile | False
PreservedAttributes | 0
Source | User::CurrentCollectionCacheFileName
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
CurrentCollectionCacheFileName |  | Variables
RowCount |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Log Package Iteration

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {CCDA711D-7E0F-481E-A1FE-AA1AEC068E6C}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log Package Iteration
ResultSetType | 1
SqlStatementSource
{call dbo.sp_syscollector_event_onpackageupdate (?)}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CurrentCollectionCacheFileName |  | Variables
RowCount |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Log Package Stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {DCB25C00-0DCE-4376-9794-23A25E011403}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log Package Stats
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onstatsupdate (?, N'active_sessions_and_requests upload', ?, ?, NULL, 0) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CurrentCollectionCacheFileName |  | Variables
RowCount |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: {BB52AFAE-60A1-42A7-9C13-52B21293D219}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DTS.ForEachFileEnumerator.5
DelayValidation | False
Description |
Directory | c:\perflogs
FileNameRetrieval | 0
FileSpec | ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity*.temp.cache
HasExpressions | True
HostType | ForEachEnumerator
ID | {BB52AFAE-60A1-42A7-9C13-52B21293D219}
Name | {BB52AFAE-60A1-42A7-9C13-52B21293D219}
Recurse | False

Collapse image Elements

Name | Description | Type
Directory |  | Expressions
FileSpec |  | Expressions
Directory |  | Expressions
FileSpec |  | Expressions


Package element

Package element: FileSpec

Collapse image Properties

Name | Value
Expression | @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity*.temp.cache"
Name | FileSpec


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Iteration
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel]>=1
ID | {4AAAB275-D665-406D-876D-23789851D864}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | DFT - Upload collection snapshot
Value | Completion


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {FC05D77F-6096-43D9-A97D-6DD93198E115}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | SQL - Log Package Iteration
Value | Completion


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | FST - Delete uploaded cache file
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {ABD0C1A0-A52B-4AB3-BD5A-6CF3F23AD1EA}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | DFT - Upload collection snapshot
Value | Success


Package element

Package element: SEQ - Capture and analyze query statistics and query plan and text

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | False
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {5D4817CD-0B0D-4F38-9BD7-6D5FEE0A1D6C}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SEQ - Capture and analyze query statistics and query plan and text
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Create Interesting Queries Last Snapshot | Data Flow Task | Executables
DFT - Create Interesting Queries Upload Batch | Data Flow Task | Executables
DFT - Find and save plan text | Data Flow Task | Executables
DFT - Find and save sql text | Data Flow Task | Executables
FAT - Check Interesting Queries Last Snapshot exists | File Access Task | Executables
FST - Rename Current Snapshot File as Last Snapshot File | File System Task | Executables
SQL - Log stats for Interesting Queries | Execute SQL Task | Executables
SQL - Log stats for sql plan | Execute SQL Task | Executables
SQL - Log stats for sql text | Execute SQL Task | Executables
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
Constraint 3 |  | PrecedenceConstraints
Constraint 5 |  | PrecedenceConstraints
Constraint 6 |  | PrecedenceConstraints
Constraint 7 |  | PrecedenceConstraints
Constraint 8 |  | PrecedenceConstraints
Last Snapshot Missing |  | PrecedenceConstraints
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: DFT - Create Interesting Queries Last Snapshot

CollapseAll image

Collapse image Properties

Name | Value
[DC - Add the SnapshotId Column].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotId]
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | False
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {1D99392A-5650-4BDC-9ACB-7CF7D8E1CEF7}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Create Interesting Queries Last Snapshot
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DC - Add the SnapshotId Column | Updates column values using expressions | ComponentMetaDataCollection
OLE DB Source | OLE DB Source | ComponentMetaDataCollection
RC - Row count from dm_exec_query_stats | Counts the rows in a dataset. | ComponentMetaDataCollection
RFD - Write Last Snapshot | Loads raw data into a file. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Derived Column Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables
SSIS diagram is missing


Package element

Package element: DC - Add the SnapshotId Column

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 2
IdentificationString | DC - Add the SnapshotId Column
IsDefaultLocale | True
LocaleID | English (United States)
Name | DC - Add the SnapshotId Column
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 3
IdentificationString | DC - Add the SnapshotId Column.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 4
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | OutputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 5
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 7
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 8
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 9
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 10
IdentificationString | DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 10
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OLE DB Source

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 11
IdentificationString | OLE DB Source
IsDefaultLocale | True
LocaleID | English (United States)
Name | OLE DB Source
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | OLE DB Source.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | OLE DB Source.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | OLE DB Source.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | OLE DB Source.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 16
IdentificationString | OLE DB Source.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SnapshotQueryStatsQuery


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 17
IdentificationString | OLE DB Source.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | OLE DB Source.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | OLE DB Source.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 20
IdentificationString | OLE DB Source.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 22
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
creation_time |  | ExternalMetadataColumnCollection
last_execution_time |  | ExternalMetadataColumnCollection
execution_count |  | ExternalMetadataColumnCollection
total_worker_time |  | ExternalMetadataColumnCollection
min_worker_time |  | ExternalMetadataColumnCollection
max_worker_time |  | ExternalMetadataColumnCollection
total_physical_reads |  | ExternalMetadataColumnCollection
min_physical_reads |  | ExternalMetadataColumnCollection
max_physical_reads |  | ExternalMetadataColumnCollection
total_logical_writes |  | ExternalMetadataColumnCollection
min_logical_writes |  | ExternalMetadataColumnCollection
max_logical_writes |  | ExternalMetadataColumnCollection
total_logical_reads |  | ExternalMetadataColumnCollection
min_logical_reads |  | ExternalMetadataColumnCollection
max_logical_reads |  | ExternalMetadataColumnCollection
total_clr_time |  | ExternalMetadataColumnCollection
min_clr_time |  | ExternalMetadataColumnCollection
max_clr_time |  | ExternalMetadataColumnCollection
total_elapsed_time |  | ExternalMetadataColumnCollection
min_elapsed_time |  | ExternalMetadataColumnCollection
max_elapsed_time |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
sql_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 50
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 51
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 52
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 53
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 54
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 55
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[creation_time]
Length | 0
MappedColumnID | 0
Name | creation_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 56
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]
Length | 0
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 57
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[execution_count]
Length | 0
MappedColumnID | 0
Name | execution_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 58
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]
Length | 0
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 59
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]
Length | 0
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 60
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]
Length | 0
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 61
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]
Length | 0
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 62
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]
Length | 0
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 63
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]
Length | 0
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 64
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]
Length | 0
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 65
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]
Length | 0
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 66
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]
Length | 0
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 67
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]
Length | 0
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 68
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]
Length | 0
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 69
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]
Length | 0
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 70
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]
Length | 0
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 71
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]
Length | 0
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 72
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]
Length | 0
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 73
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 74
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]
Length | 0
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 75
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]
Length | 0
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 76
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 50
ID | 23
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]
Length | 64
LineageID | 23
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 51
ID | 24
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 24
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 52
ID | 25
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 25
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 53
ID | 26
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]
Length | 0
LineageID | 26
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 54
ID | 27
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]
Length | 64
LineageID | 27
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 55
ID | 28
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]
Length | 0
LineageID | 28
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 56
ID | 29
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]
Length | 0
LineageID | 29
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 57
ID | 30
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]
Length | 0
LineageID | 30
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 58
ID | 31
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]
Length | 0
LineageID | 31
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 59
ID | 32
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]
Length | 0
LineageID | 32
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 60
ID | 33
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]
Length | 0
LineageID | 33
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 61
ID | 34
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]
Length | 0
LineageID | 34
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 62
ID | 35
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]
Length | 0
LineageID | 35
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 63
ID | 36
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]
Length | 0
LineageID | 36
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 64
ID | 37
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]
Length | 0
LineageID | 37
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 65
ID | 38
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]
Length | 0
LineageID | 38
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 66
ID | 39
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]
Length | 0
LineageID | 39
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 67
ID | 40
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]
Length | 0
LineageID | 40
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 68
ID | 41
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]
Length | 0
LineageID | 41
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 69
ID | 42
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]
Length | 0
LineageID | 42
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 70
ID | 43
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]
Length | 0
LineageID | 43
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 71
ID | 44
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]
Length | 0
LineageID | 44
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 72
ID | 45
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]
Length | 0
LineageID | 45
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 73
ID | 46
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]
Length | 0
LineageID | 46
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 74
ID | 47
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]
Length | 0
LineageID | 47
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 75
ID | 48
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]
Length | 0
LineageID | 48
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 76
ID | 49
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]
Length | 0
LineageID | 49
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 77
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 78
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[sql_handle]
Length | 64
LineageID | 78
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 79
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]
Length | 0
LineageID | 79
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 80
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]
Length | 0
LineageID | 80
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 81
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]
Length | 0
LineageID | 81
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 82
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_handle]
Length | 64
LineageID | 82
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 83
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[creation_time]
Length | 0
LineageID | 83
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 84
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[last_execution_time]
Length | 0
LineageID | 84
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 85
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[execution_count]
Length | 0
LineageID | 85
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 86
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_worker_time]
Length | 0
LineageID | 86
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 87
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_worker_time]
Length | 0
LineageID | 87
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 88
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_worker_time]
Length | 0
LineageID | 88
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 89
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]
Length | 0
LineageID | 89
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 90
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]
Length | 0
LineageID | 90
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 91
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]
Length | 0
LineageID | 91
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 92
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]
Length | 0
LineageID | 92
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 93
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]
Length | 0
LineageID | 93
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 94
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]
Length | 0
LineageID | 94
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 95
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]
Length | 0
LineageID | 95
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 96
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]
Length | 0
LineageID | 96
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 97
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]
Length | 0
LineageID | 97
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 98
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_clr_time]
Length | 0
LineageID | 98
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 99
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_clr_time]
Length | 0
LineageID | 99
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 100
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_clr_time]
Length | 0
LineageID | 100
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 101
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]
Length | 0
LineageID | 101
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 102
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]
Length | 0
LineageID | 102
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 103
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]
Length | 0
LineageID | 103
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 104
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[collection_time]
Length | 0
LineageID | 104
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 105
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 105
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 106
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 106
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {15DDC5A3-5645-4BAA-BCC8-B0AF18FDE25D}
Description | The OLE DB runtime connection used to access the database.
ID | 21
IdentificationString | OLE DB Source.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RC - Row count from dm_exec_query_stats

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 107
IdentificationString | RC - Row count from dm_exec_query_stats
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Row count from dm_exec_query_stats
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 108
IdentificationString | RC - Row count from dm_exec_query_stats.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 109
IdentificationString | RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 110
IdentificationString | RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 109
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RFD - Write Last Snapshot

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {953B7879-214C-4AB8-AA79-AEA630F35C46}
ContactInfo | Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Loads raw data into a file.
ID | 111
IdentificationString | RFD - Write Last Snapshot
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFD - Write Last Snapshot
ObjectType | 10
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 2

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
WriteOption | Indicates what option is used to write to the file. | CustomPropertyCollection
Raw File Destination Input |  | InputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 112
IdentificationString | RFD - Write Last Snapshot.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 113
IdentificationString | RFD - Write Last Snapshot.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 114
IdentificationString | RFD - Write Last Snapshot.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesLastSnapshotFileName


Package element

Package element: WriteOption

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates what option is used to write to the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 115
IdentificationString | RFD - Write Last Snapshot.Properties[WriteOption]
Name | WriteOption
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | WriteOption
UITypeEditor |
Value | 0


Package element

Package element: Raw File Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 116
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input]
IsAttached | True
IsSorted | True
Name | Raw File Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
plan_handle |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
collection_time |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 117
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 23
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 118
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 24
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 119
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 25
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 120
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 26
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 121
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 27
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 122
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 28
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 123
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 29
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 124
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 30
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 125
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 31
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 126
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 34
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 127
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 37
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 128
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 40
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 129
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 43
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 130
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 46
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 131
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 33
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 132
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 32
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 133
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 35
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 134
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 36
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 135
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 38
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 136
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 39
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 137
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 41
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 138
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 42
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 139
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 44
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 140
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 45
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 141
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 47
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 142
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 48
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 143
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DC - Add the SnapshotId Column
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 144
IdentificationString | RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 49
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | OLE DB Source
UsageType | UT_READONLY


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | Raw File Destination Input
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: InterestingQueriesRowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueriesRowCountIn
Namespace | User
QualifiedName | User::InterestingQueriesRowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::InterestingQueriesRowCountIn]


Package element

Package element: InterestingQueriesRowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | InterestingQueriesRowCountOut
Namespace | User
QualifiedName | User::InterestingQueriesRowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::InterestingQueriesRowCountOut]


Package element

Package element: SqlPlanRowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlPlanRowCountError
Namespace | User
QualifiedName | User::SqlPlanRowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanRowCountError]


Package element

Package element: SqlPlanRowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlPlanRowCountIn
Namespace | User
QualifiedName | User::SqlPlanRowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanRowCountIn]


Package element

Package element: SqlPlanRowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | @[User::SqlPlanRowCountIn] - @[User::SqlPlanRowCountError]
IncludeInDebugDump | False
Name | SqlPlanRowCountOut
Namespace | User
QualifiedName | User::SqlPlanRowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanRowCountOut]


Package element

Package element: SqlPlanUpdateRowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlPlanUpdateRowCountError
Namespace | User
QualifiedName | User::SqlPlanUpdateRowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanUpdateRowCountError]


Package element

Package element: SqlPlanUpdateRowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlPlanUpdateRowCountIn
Namespace | User
QualifiedName | User::SqlPlanUpdateRowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanUpdateRowCountIn]


Package element

Package element: SqlPlanUpdateRowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlPlanUpdateRowCountOut
Namespace | User
QualifiedName | User::SqlPlanUpdateRowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlPlanUpdateRowCountOut]


Package element

Package element: SqlTextRowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlTextRowCountError
Namespace | User
QualifiedName | User::SqlTextRowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextRowCountError]


Package element

Package element: SqlTextRowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlTextRowCountIn
Namespace | User
QualifiedName | User::SqlTextRowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextRowCountIn]


Package element

Package element: SqlTextRowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | @[User::SqlTextRowCountIn] - @[User::SqlTextRowCountError]
IncludeInDebugDump | False
Name | SqlTextRowCountOut
Namespace | User
QualifiedName | User::SqlTextRowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextRowCountOut]


Package element

Package element: SqlTextUpdateRowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlTextUpdateRowCountError
Namespace | User
QualifiedName | User::SqlTextUpdateRowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextUpdateRowCountError]


Package element

Package element: SqlTextUpdateRowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlTextUpdateRowCountIn
Namespace | User
QualifiedName | User::SqlTextUpdateRowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextUpdateRowCountIn]


Package element

Package element: SqlTextUpdateRowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SqlTextUpdateRowCountOut
Namespace | User
QualifiedName | User::SqlTextUpdateRowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text.Variables[User::SqlTextUpdateRowCountOut]


Package element

Package element: DFT - Create Interesting Queries Upload Batch

CollapseAll image

Collapse image Properties

Name | Value
[DRC - Add SnapshotId column to current snapshot].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotId]
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_clr_time].[FriendlyExpression] | ISNULL(old_total_clr_time) ? total_clr_time : total_clr_time - old_total_clr_time
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_elapsed_time].[FriendlyExpression] | ISNULL(old_total_elapsed_time) ? total_elapsed_time : total_elapsed_time - old_total_elapsed_time
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_execution_count].[FriendlyExpression] | ISNULL(old_execution_count) ? execution_count : execution_count - old_execution_count
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_logical_reads].[FriendlyExpression] | ISNULL(old_total_logical_reads) ? total_logical_reads : total_logical_reads - old_total_logical_reads
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_logical_writes].[FriendlyExpression] | ISNULL(old_total_logical_writes) ? total_logical_writes : total_logical_writes - old_total_logical_writes
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_physical_reads].[FriendlyExpression] | ISNULL(old_total_physical_reads) ? total_physical_reads : total_physical_reads - old_total_physical_reads
[DRC - Calculate delta value between last snapshot and current snapshot for every metric].[Derived Column Output].[snapshot_worker_time].[FriendlyExpression] | ISNULL(old_total_worker_time) ? total_worker_time : total_worker_time - old_total_worker_time
[DRV - Add plan_generation_num column].[Derived Column Output].[creation_time].[FriendlyExpression] | GETDATE()
[DRV - Add plan_generation_num column].[Derived Column Output].[plan_generation_num].[FriendlyExpression] | (DT_I8)1
[DRV - Add source_id (1)].[Derived Column Output].[source_id].[FriendlyExpression] | @[User::SourceId]
[DRV - Add source_id (2)].[Derived Column Output].[source_id].[FriendlyExpression] | @[User::SourceId]
[SPLT - Identify interesting running requests].[Interesting Requests].[FriendlyExpression] | (wait_duration_ms > @[User::InterestingQueries_LongWaitingRequest]) || (blocking_session_id == 0 && is_blocking == TRUE ) || (open_transaction_count > @[User::InterestingQueries_HighTransactionCount]) || (request_total_elapsed_time > @[User::InterestingQueries_LongRunningRequest]) || (request_cpu_time > @[User::InterestingQueries_HighCpuUsage]) || (pending_io_count > @[User::InterestingQueries_HighIoCount]) || (memory_usage > @[User::InterestingQueries_HighMemoryUsage]) || (session_row_count > @[User::InterestingQueries_LargeResultset])
[SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order].[MaximumThreads] | -1
[SRT - Find unique sql_handle and plan_handle combinations].[MaximumThreads] | -1
[SRT - Find unique sql_handle values].[MaximumThreads] | -1
[SRT - Sort columns by sql_handle, plan_handle].[MaximumThreads] | -1
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | False
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7CC524DD-0334-41D0-8E7C-A6AA943F156C}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Create Interesting Queries Upload Batch
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DRC - Add SnapshotId column to current snapshot | Updates column values using expressions | ComponentMetaDataCollection
DRC - Calculate delta value between last snapshot and current snapshot for every metric | Updates column values using expressions | ComponentMetaDataCollection
DRV - Add plan_generation_num column | Updates column values using expressions | ComponentMetaDataCollection
DRV - Add source_id (1) | Updates column values using expressions | ComponentMetaDataCollection
DRV - Add source_id (2) | Updates column values using expressions | ComponentMetaDataCollection
MLTCST - split current snapshot | Creates copies of a dataset. | ComponentMetaDataCollection
MLTCST - Split interesting queries | Creates copies of a dataset. | ComponentMetaDataCollection
MLTCST - split last snapshot | Creates copies of a dataset. | ComponentMetaDataCollection
MLTCST - Split to upload sql_handle and plan_handle | Creates copies of a dataset. | ComponentMetaDataCollection
MRG - Append current stats on interesting queries | Merges data from two datasets by using a join. | ComponentMetaDataCollection
MRG - Append last stats on interesting queries | Merges data from two datasets by using a join. | ComponentMetaDataCollection
ODD - Save statistics for interesting queries | OLE DB Destination | ComponentMetaDataCollection
ODD - Upload interesting plan handles | OLE DB Destination | ComponentMetaDataCollection
ODD - Upload interesting sql handles | OLE DB Destination | ComponentMetaDataCollection
ODS - Get current snapshot of dm_exec_query_stats | OLE DB Source | ComponentMetaDataCollection
RC - Number of interesting plan handles | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Number of interesting sql handles | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Number of not inserted plan handles | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Number of not inserted sql handles | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Row count after TopN queries | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Row count from dm_exec_query_stats | Counts the rows in a dataset. | ComponentMetaDataCollection
RFD - Save current snapshot in temp file | Loads raw data into a file. | ComponentMetaDataCollection
RFS - Read current cache with dm_exec_requests | Extracts data from a raw file. | ComponentMetaDataCollection
RFS - Read last snapshot of dm_exec_query_stats | Extracts data from a raw file. | ComponentMetaDataCollection
SPLT - Identify interesting running requests | Evaluates and directs rows in a dataset. | ComponentMetaDataCollection
SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order | Sorts data. | ComponentMetaDataCollection
SRT - Find unique sql_handle and plan_handle combinations | Sorts data. | ComponentMetaDataCollection
SRT - Find unique sql_handle values | Sorts data. | ComponentMetaDataCollection
SRT - Sort columns by sql_handle, plan_handle | Sorts data. | ComponentMetaDataCollection
TPQ - Analyze Interesting Queries |  | ComponentMetaDataCollection
UNION - Combine interesting requests and interesting stats | Merges multiple datasets. | ComponentMetaDataCollection
UNION - Combine last and current snapshots for TopN processing | Merges multiple datasets. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Calculate TopN stats |  | PathCollection
Calculate TopN stats |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Interesting Requests |  | PathCollection
Merge Join Output |  | PathCollection
Merge Join Output |  | PathCollection
Multicast Output 2 |  | PathCollection
Multicast Output 3 |  | PathCollection
Multicast Output 4 |  | PathCollection
OLE DB Destination Error Output |  | PathCollection
OLE DB Destination Error Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Process TopN |  | PathCollection
Process TopN |  | PathCollection
Raw File Source Output |  | PathCollection
Raw File Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
Save |  | PathCollection
Save |  | PathCollection
Sort Output |  | PathCollection
Sort Output |  | PathCollection
Sort Output |  | PathCollection
Sort Output |  | PathCollection
TxTopQueries Only Output |  | PathCollection
Union All Output 1 |  | PathCollection
Union All Output 1 |  | PathCollection
NotableQueryPlan |  | Variables
NotableQueryText |  | Variables
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables
SSIS diagram is missing


Package element

Package element: DRC - Add SnapshotId column to current snapshot

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 2
IdentificationString | DRC - Add SnapshotId column to current snapshot
IsDefaultLocale | False
LocaleID | English (United States)
Name | DRC - Add SnapshotId column to current snapshot
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 3
IdentificationString | DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 4
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | OutputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 5
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 7
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotId]


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 8
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 3
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 9
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 10
IdentificationString | DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 10
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRC - Calculate delta value between last snapshot and current snapshot for every metric

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 11
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRC - Calculate delta value between last snapshot and current snapshot for every metric
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 12
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
old_total_worker_time |  | InputColumnCollection
old_total_physical_reads |  | InputColumnCollection
old_total_logical_writes |  | InputColumnCollection
old_total_logical_reads |  | InputColumnCollection
old_total_clr_time |  | InputColumnCollection
old_total_elapsed_time |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
old_execution_count |  | InputColumnCollection


Package element

Package element: old_total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 13
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 301
MappedColumnID | 0
Name | old_total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 14
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 303
MappedColumnID | 0
Name | old_total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 15
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 305
MappedColumnID | 0
Name | old_total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 16
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 307
MappedColumnID | 0
Name | old_total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 17
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 309
MappedColumnID | 0
Name | old_total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 18
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 311
MappedColumnID | 0
Name | old_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 19
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 257
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 20
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 259
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 21
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 261
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 22
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 263
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 23
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 265
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 24
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 267
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 25
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 255
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: old_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 26
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 313
MappedColumnID | 0
Name | old_execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 27
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 12
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_worker_time |  | OutputColumnCollection
snapshot_physical_reads |  | OutputColumnCollection
snapshot_logical_reads |  | OutputColumnCollection
snapshot_logical_writes |  | OutputColumnCollection
snapshot_clr_time |  | OutputColumnCollection
snapshot_elapsed_time |  | OutputColumnCollection
snapshot_execution_count |  | OutputColumnCollection


Package element

Package element: snapshot_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 28
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]
Length | 0
LineageID | 28
MappedColumnID | 0
Name | snapshot_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 29
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#301) ? #257 : #257 - #301


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 30
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_worker_time) ? total_worker_time : total_worker_time - old_total_worker_time


Package element

Package element: snapshot_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 31
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]
Length | 0
LineageID | 31
MappedColumnID | 0
Name | snapshot_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 32
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#303) ? #259 : #259 - #303


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 33
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_physical_reads) ? total_physical_reads : total_physical_reads - old_total_physical_reads


Package element

Package element: snapshot_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 34
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]
Length | 0
LineageID | 34
MappedColumnID | 0
Name | snapshot_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 35
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#307) ? #263 : #263 - #307


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 36
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_logical_reads) ? total_logical_reads : total_logical_reads - old_total_logical_reads


Package element

Package element: snapshot_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 37
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]
Length | 0
LineageID | 37
MappedColumnID | 0
Name | snapshot_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 38
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#305) ? #261 : #261 - #305


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 39
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_logical_writes) ? total_logical_writes : total_logical_writes - old_total_logical_writes


Package element

Package element: snapshot_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 40
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]
Length | 0
LineageID | 40
MappedColumnID | 0
Name | snapshot_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 41
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#309) ? #265 : #265 - #309


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 42
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_clr_time) ? total_clr_time : total_clr_time - old_total_clr_time


Package element

Package element: snapshot_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 43
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]
Length | 0
LineageID | 43
MappedColumnID | 0
Name | snapshot_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 44
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#311) ? #267 : #267 - #311


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 45
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_total_elapsed_time) ? total_elapsed_time : total_elapsed_time - old_total_elapsed_time


Package element

Package element: snapshot_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 46
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]
Length | 0
LineageID | 46
MappedColumnID | 0
Name | snapshot_execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 47
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#313) ? #255 : #255 - #313


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 48
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(old_execution_count) ? execution_count : execution_count - old_execution_count


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 49
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 12
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 50
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 50
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 51
IdentificationString | DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 51
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRV - Add plan_generation_num column

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 52
IdentificationString | DRV - Add plan_generation_num column
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add plan_generation_num column
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 53
IdentificationString | DRV - Add plan_generation_num column.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 54
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 53
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 55
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]
Length | 0
LineageID | 55
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 56
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (DT_I8)1


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 57
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (DT_I8)1


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 58
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]
Length | 0
LineageID | 58
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 59
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [GETDATE]()


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 60
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | GETDATE()


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 61
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 53
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 62
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 62
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 63
IdentificationString | DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 63
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRV - Add source_id (1)

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 64
IdentificationString | DRV - Add source_id (1)
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add source_id (1)
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 65
IdentificationString | DRV - Add source_id (1).Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 66
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 65
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 67
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]
Length | 0
LineageID | 67
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 68
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SourceId]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 69
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SourceId]


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 70
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 65
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 71
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 71
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 72
IdentificationString | DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 72
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRV - Add source_id (2)

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 73
IdentificationString | DRV - Add source_id (2)
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add source_id (2)
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 74
IdentificationString | DRV - Add source_id (2).Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 75
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 74
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 76
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]
Length | 0
LineageID | 76
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 77
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SourceId]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 78
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SourceId]


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 79
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 74
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 80
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 80
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 81
IdentificationString | DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 81
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MLTCST - split current snapshot

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EFE6B902-7646-42C1-96BB-21D1AB56DD74}
ContactInfo | Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Creates copies of a dataset.
ID | 82
IdentificationString | MLTCST - split current snapshot
IsDefaultLocale | True
LocaleID | English (United States)
Name | MLTCST - split current snapshot
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Multicast Input 1 |  | InputCollection
Multicast Output 3 |  | OutputCollection
Multicast Output 2 |  | OutputCollection
Multicast Output 1 |  | OutputCollection
Multicast Output 4 |  | OutputCollection


Package element

Package element: Multicast Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 83
IdentificationString | MLTCST - split current snapshot.Inputs[Multicast Input 1]
IsAttached | True
IsSorted | False
Name | Multicast Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 3

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 84
IdentificationString | MLTCST - split current snapshot.Outputs[Multicast Output 3]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 3
ObjectType | OT_OUTPUT
SynchronousInputID | 83
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 85
IdentificationString | MLTCST - split current snapshot.Outputs[Multicast Output 2]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 2
ObjectType | OT_OUTPUT
SynchronousInputID | 83
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 86
IdentificationString | MLTCST - split current snapshot.Outputs[Multicast Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 83
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 4

Collapse image Properties

Name | Value
Dangling | True
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 87
IdentificationString | MLTCST - split current snapshot.Outputs[Multicast Output 4]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Multicast Output 4
ObjectType | OT_OUTPUT
SynchronousInputID | 83
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MLTCST - Split interesting queries

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EFE6B902-7646-42C1-96BB-21D1AB56DD74}
ContactInfo | Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Creates copies of a dataset.
ID | 88
IdentificationString | MLTCST - Split interesting queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | MLTCST - Split interesting queries
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Multicast Input 1 |  | InputCollection
Multicast Output 2 |  | OutputCollection
Multicast Output 3 |  | OutputCollection
Multicast Output 1 |  | OutputCollection


Package element

Package element: Multicast Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 89
IdentificationString | MLTCST - Split interesting queries.Inputs[Multicast Input 1]
IsAttached | True
IsSorted | False
Name | Multicast Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 90
IdentificationString | MLTCST - Split interesting queries.Outputs[Multicast Output 2]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 2
ObjectType | OT_OUTPUT
SynchronousInputID | 89
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 3

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 91
IdentificationString | MLTCST - Split interesting queries.Outputs[Multicast Output 3]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 3
ObjectType | OT_OUTPUT
SynchronousInputID | 89
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Dangling | True
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 92
IdentificationString | MLTCST - Split interesting queries.Outputs[Multicast Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Multicast Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 89
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MLTCST - split last snapshot

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EFE6B902-7646-42C1-96BB-21D1AB56DD74}
ContactInfo | Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Creates copies of a dataset.
ID | 93
IdentificationString | MLTCST - split last snapshot
IsDefaultLocale | True
LocaleID | English (United States)
Name | MLTCST - split last snapshot
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Multicast Input 1 |  | InputCollection
Multicast Output 1 |  | OutputCollection
Multicast Output 2 |  | OutputCollection
Multicast Output 3 |  | OutputCollection


Package element

Package element: Multicast Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 94
IdentificationString | MLTCST - split last snapshot.Inputs[Multicast Input 1]
IsAttached | True
IsSorted | False
Name | Multicast Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 95
IdentificationString | MLTCST - split last snapshot.Outputs[Multicast Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 94
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 96
IdentificationString | MLTCST - split last snapshot.Outputs[Multicast Output 2]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 2
ObjectType | OT_OUTPUT
SynchronousInputID | 94
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 3

Collapse image Properties

Name | Value
Dangling | True
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 97
IdentificationString | MLTCST - split last snapshot.Outputs[Multicast Output 3]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Multicast Output 3
ObjectType | OT_OUTPUT
SynchronousInputID | 94
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MLTCST - Split to upload sql_handle and plan_handle

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EFE6B902-7646-42C1-96BB-21D1AB56DD74}
ContactInfo | Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Creates copies of a dataset.
ID | 98
IdentificationString | MLTCST - Split to upload sql_handle and plan_handle
IsDefaultLocale | True
LocaleID | English (United States)
Name | MLTCST - Split to upload sql_handle and plan_handle
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Multicast Input 1 |  | InputCollection
Multicast Output 4 |  | OutputCollection
Multicast Output 2 |  | OutputCollection
Multicast Output 1 |  | OutputCollection


Package element

Package element: Multicast Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 99
IdentificationString | MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]
IsAttached | True
IsSorted | False
Name | Multicast Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 4

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 100
IdentificationString | MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 4]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 4
ObjectType | OT_OUTPUT
SynchronousInputID | 99
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 101
IdentificationString | MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 2]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 2
ObjectType | OT_OUTPUT
SynchronousInputID | 99
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Dangling | True
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 102
IdentificationString | MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Multicast Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 99
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MRG - Append current stats on interesting queries

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {9AC07C48-96C6-4981-9080-9FD157B79F27}
ContactInfo | Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Merges data from two datasets by using a join.
ID | 103
IdentificationString | MRG - Append current stats on interesting queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | MRG - Append current stats on interesting queries
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
JoinType | Specifies the type of join to perform. | CustomPropertyCollection
NumKeyColumns | Specifies the number of columns in the ordering key. | CustomPropertyCollection
TreatNullsAsEqual | Indicates whether the null values are treated as equal values. | CustomPropertyCollection
MaxBuffersPerInput | Indicates the requested maximum buffers per input before blocking. | CustomPropertyCollection
Merge Join Left Input |  | InputCollection
Merge Join Right Input |  | InputCollection
Merge Join Output |  | OutputCollection


Package element

Package element: JoinType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of join to perform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 104
IdentificationString | MRG - Append current stats on interesting queries.Properties[JoinType]
Name | JoinType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | JoinType
UITypeEditor |
Value | 2


Package element

Package element: NumKeyColumns

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the number of columns in the ordering key.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 105
IdentificationString | MRG - Append current stats on interesting queries.Properties[NumKeyColumns]
Name | NumKeyColumns
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 2


Package element

Package element: TreatNullsAsEqual

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the null values are treated as equal values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 106
IdentificationString | MRG - Append current stats on interesting queries.Properties[TreatNullsAsEqual]
Name | TreatNullsAsEqual
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: MaxBuffersPerInput

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates the requested maximum buffers per input before blocking.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 107
IdentificationString | MRG - Append current stats on interesting queries.Properties[MaxBuffersPerInput]
Name | MaxBuffersPerInput
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: Merge Join Left Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 108
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input]
IsAttached | True
IsSorted | True
Name | Merge Join Left Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
Top SQL Handle |  | InputColumnCollection
Top Plan Handle |  | InputColumnCollection


Package element

Package element: Top SQL Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 109
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top SQL Handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 44
LineageID | 1012
MappedColumnID | 0
Name | Top SQL Handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Sort columns by sql_handle, plan_handle
UsageType | UT_READONLY


Package element

Package element: Top Plan Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 110
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top Plan Handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 44
LineageID | 1014
MappedColumnID | 0
Name | Top Plan Handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Sort columns by sql_handle, plan_handle
UsageType | UT_READONLY


Package element

Package element: Merge Join Right Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 111
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input]
IsAttached | True
IsSorted | True
Name | Merge Join Right Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
snapshot_id |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 112
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 474
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 113
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 478
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 114
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 475
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 115
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 476
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 116
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 477
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 117
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 479
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 118
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 480
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 119
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 481
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 120
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 482
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 121
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 485
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 122
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 488
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 123
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 491
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 124
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 494
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 125
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 497
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 126
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 484
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 127
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 483
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 128
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 486
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 129
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 487
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 130
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 489
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 131
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 490
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 132
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 492
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 133
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 493
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 134
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 495
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 135
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 496
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 136
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 498
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 137
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 499
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 138
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 500
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 139
IdentificationString | MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Add SnapshotId column to current snapshot
UsageType | UT_READONLY


Package element

Package element: Merge Join Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 140
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Merge Join Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 141
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]
Length | 0
LineageID | 141
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 142
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 114


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 143
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]
Length | 0
LineageID | 143
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 144
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 115


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 145
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]
Length | 0
LineageID | 145
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 146
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 116


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 147
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]
Length | 0
LineageID | 147
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 148
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 117


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 149
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]
Length | 0
LineageID | 149
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 150
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 118


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 151
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]
Length | 0
LineageID | 151
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 152
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 119


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 153
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]
Length | 0
LineageID | 153
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 154
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 120


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 155
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]
Length | 0
LineageID | 155
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 156
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 121


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 157
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]
Length | 0
LineageID | 157
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 158
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 122


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 159
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]
Length | 0
LineageID | 159
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 160
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 123


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 161
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]
Length | 0
LineageID | 161
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 162
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 124


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 163
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]
Length | 0
LineageID | 163
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 164
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 125


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 165
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]
Length | 0
LineageID | 165
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 166
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 126


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 167
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]
Length | 0
LineageID | 167
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 168
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 127


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 169
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]
Length | 0
LineageID | 169
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 170
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 128


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 171
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]
Length | 0
LineageID | 171
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 172
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 129


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 173
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]
Length | 0
LineageID | 173
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 174
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 130


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 175
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]
Length | 0
LineageID | 175
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 176
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 131


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 177
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]
Length | 0
LineageID | 177
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 178
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 132


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 179
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]
Length | 0
LineageID | 179
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 180
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 133


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 181
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]
Length | 0
LineageID | 181
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 182
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 134


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 183
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]
Length | 0
LineageID | 183
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 184
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 135


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 185
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]
Length | 0
LineageID | 185
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 186
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 136


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 187
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]
Length | 0
LineageID | 187
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 188
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 137


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 189
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]
Length | 0
LineageID | 189
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 190
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 138


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 191
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]
Length | 64
LineageID | 191
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 192
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 112


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 193
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]
Length | 64
LineageID | 193
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 194
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 113


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 195
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]
Length | 0
LineageID | 195
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 196
IdentificationString | MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 139


Package element

Package element: MRG - Append last stats on interesting queries

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {9AC07C48-96C6-4981-9080-9FD157B79F27}
ContactInfo | Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Merges data from two datasets by using a join.
ID | 197
IdentificationString | MRG - Append last stats on interesting queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | MRG - Append last stats on interesting queries
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
JoinType | Specifies the type of join to perform. | CustomPropertyCollection
NumKeyColumns | Specifies the number of columns in the ordering key. | CustomPropertyCollection
TreatNullsAsEqual | Indicates whether the null values are treated as equal values. | CustomPropertyCollection
MaxBuffersPerInput | Indicates the requested maximum buffers per input before blocking. | CustomPropertyCollection
Merge Join Left Input |  | InputCollection
Merge Join Right Input |  | InputCollection
Merge Join Output |  | OutputCollection


Package element

Package element: JoinType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of join to perform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 198
IdentificationString | MRG - Append last stats on interesting queries.Properties[JoinType]
Name | JoinType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | JoinType
UITypeEditor |
Value | 2


Package element

Package element: NumKeyColumns

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the number of columns in the ordering key.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 199
IdentificationString | MRG - Append last stats on interesting queries.Properties[NumKeyColumns]
Name | NumKeyColumns
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: TreatNullsAsEqual

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the null values are treated as equal values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 200
IdentificationString | MRG - Append last stats on interesting queries.Properties[TreatNullsAsEqual]
Name | TreatNullsAsEqual
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: MaxBuffersPerInput

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates the requested maximum buffers per input before blocking.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 201
IdentificationString | MRG - Append last stats on interesting queries.Properties[MaxBuffersPerInput]
Name | MaxBuffersPerInput
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: Merge Join Left Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 202
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input]
IsAttached | True
IsSorted | True
Name | Merge Join Left Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
snapshot_id |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 203
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 895
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 204
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 897
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 205
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 899
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 206
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 945
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 207
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 947
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 208
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 901
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 209
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 903
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 210
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 905
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 211
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 907
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 212
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 909
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 213
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 911
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 214
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 913
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 215
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 915
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 216
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 917
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 217
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 919
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 218
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 921
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 219
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 923
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 220
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 925
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 221
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 927
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 222
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 929
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 223
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 931
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 224
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 933
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 225
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 935
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 226
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 937
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 227
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 939
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 228
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 941
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 229
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 943
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 230
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 949
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
UsageType | UT_READONLY


Package element

Package element: Merge Join Right Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 231
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input]
IsAttached | True
IsSorted | True
Name | Merge Join Right Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
execution_count |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 232
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 730
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 233
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 731
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 234
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 732
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 235
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 756
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 236
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 757
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 237
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 736
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 238
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 737
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 239
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 738
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 240
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 739
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 241
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 740
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 242
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 741
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 243
IdentificationString | MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 735
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: Merge Join Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 244
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Merge Join Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection
old_total_worker_time |  | OutputColumnCollection
old_total_physical_reads |  | OutputColumnCollection
old_total_logical_writes |  | OutputColumnCollection
old_total_logical_reads |  | OutputColumnCollection
old_total_clr_time |  | OutputColumnCollection
old_total_elapsed_time |  | OutputColumnCollection
old_execution_count |  | OutputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 245
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]
Length | 0
LineageID | 245
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 246
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 203


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 247
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]
Length | 0
LineageID | 247
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 248
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 204


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 249
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]
Length | 0
LineageID | 249
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 250
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 205


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 251
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]
Length | 0
LineageID | 251
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 252
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 208


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 253
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]
Length | 0
LineageID | 253
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 254
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 209


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 255
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]
Length | 0
LineageID | 255
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 256
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 210


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 257
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]
Length | 0
LineageID | 257
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 258
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 211


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 259
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]
Length | 0
LineageID | 259
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 260
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 212


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 261
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]
Length | 0
LineageID | 261
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 262
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 213


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 263
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]
Length | 0
LineageID | 263
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 264
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 214


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 265
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]
Length | 0
LineageID | 265
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 266
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 215


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 267
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]
Length | 0
LineageID | 267
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 268
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 216


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 269
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]
Length | 0
LineageID | 269
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 270
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 217


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 271
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]
Length | 0
LineageID | 271
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 272
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 218


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 273
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]
Length | 0
LineageID | 273
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 274
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 219


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 275
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]
Length | 0
LineageID | 275
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 276
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 220


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 277
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]
Length | 0
LineageID | 277
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 278
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 221


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 279
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]
Length | 0
LineageID | 279
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 280
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 222


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 281
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]
Length | 0
LineageID | 281
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 282
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 223


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 283
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]
Length | 0
LineageID | 283
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 284
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 224


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 285
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]
Length | 0
LineageID | 285
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 286
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 225


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 287
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]
Length | 0
LineageID | 287
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 288
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 226


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 289
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]
Length | 0
LineageID | 289
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 290
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 227


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 291
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]
Length | 0
LineageID | 291
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 292
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 228


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 293
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]
Length | 0
LineageID | 293
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 294
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 229


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 295
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]
Length | 64
LineageID | 295
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 296
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 206


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 297
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]
Length | 64
LineageID | 297
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 298
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 207


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 299
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]
Length | 0
LineageID | 299
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 300
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 230


Package element

Package element: old_total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 301
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]
Length | 0
LineageID | 301
MappedColumnID | 0
Name | old_total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 302
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 237


Package element

Package element: old_total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 303
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]
Length | 0
LineageID | 303
MappedColumnID | 0
Name | old_total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 304
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 238


Package element

Package element: old_total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 305
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]
Length | 0
LineageID | 305
MappedColumnID | 0
Name | old_total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 306
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 239


Package element

Package element: old_total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 307
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]
Length | 0
LineageID | 307
MappedColumnID | 0
Name | old_total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 308
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 240


Package element

Package element: old_total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 309
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]
Length | 0
LineageID | 309
MappedColumnID | 0
Name | old_total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 310
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 241


Package element

Package element: old_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 311
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]
Length | 0
LineageID | 311
MappedColumnID | 0
Name | old_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 312
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 242


Package element

Package element: old_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 313
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]
Length | 0
LineageID | 313
MappedColumnID | 0
Name | old_execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
InputColumnID | The input column associated with this output column | CustomPropertyCollection


Package element

Package element: InputColumnID

Collapse image Properties

Name | Value
ContainsID | True
Description | The input column associated with this output column
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 314
IdentificationString | MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count].Properties[InputColumnID]
Name | InputColumnID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 243


Package element

Package element: ODD - Save statistics for interesting queries

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 315
IdentificationString | ODD - Save statistics for interesting queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODD - Save statistics for interesting queries
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 316
IdentificationString | ODD - Save statistics for interesting queries.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 317
IdentificationString | ODD - Save statistics for interesting queries.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[query_stats]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 318
IdentificationString | ODD - Save statistics for interesting queries.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 319
IdentificationString | ODD - Save statistics for interesting queries.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 320
IdentificationString | ODD - Save statistics for interesting queries.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 321
IdentificationString | ODD - Save statistics for interesting queries.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 322
IdentificationString | ODD - Save statistics for interesting queries.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 323
IdentificationString | ODD - Save statistics for interesting queries.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 324
IdentificationString | ODD - Save statistics for interesting queries.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 325
IdentificationString | ODD - Save statistics for interesting queries.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 326
IdentificationString | ODD - Save statistics for interesting queries.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 328
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | True
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
creation_time |  | ExternalMetadataColumnCollection
last_execution_time |  | ExternalMetadataColumnCollection
execution_count |  | ExternalMetadataColumnCollection
total_worker_time |  | ExternalMetadataColumnCollection
snapshot_worker_time |  | ExternalMetadataColumnCollection
min_worker_time |  | ExternalMetadataColumnCollection
max_worker_time |  | ExternalMetadataColumnCollection
total_physical_reads |  | ExternalMetadataColumnCollection
snapshot_physical_reads |  | ExternalMetadataColumnCollection
min_physical_reads |  | ExternalMetadataColumnCollection
max_physical_reads |  | ExternalMetadataColumnCollection
total_logical_writes |  | ExternalMetadataColumnCollection
snapshot_logical_writes |  | ExternalMetadataColumnCollection
min_logical_writes |  | ExternalMetadataColumnCollection
max_logical_writes |  | ExternalMetadataColumnCollection
total_logical_reads |  | ExternalMetadataColumnCollection
snapshot_logical_reads |  | ExternalMetadataColumnCollection
min_logical_reads |  | ExternalMetadataColumnCollection
max_logical_reads |  | ExternalMetadataColumnCollection
total_clr_time |  | ExternalMetadataColumnCollection
snapshot_clr_time |  | ExternalMetadataColumnCollection
min_clr_time |  | ExternalMetadataColumnCollection
max_clr_time |  | ExternalMetadataColumnCollection
total_elapsed_time |  | ExternalMetadataColumnCollection
snapshot_elapsed_time |  | ExternalMetadataColumnCollection
min_elapsed_time |  | ExternalMetadataColumnCollection
max_elapsed_time |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
snapshot_id |  | ExternalMetadataColumnCollection
snapshot_execution_count |  | ExternalMetadataColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
creation_time |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
snapshot_worker_time |  | InputColumnCollection
snapshot_physical_reads |  | InputColumnCollection
snapshot_logical_reads |  | InputColumnCollection
snapshot_logical_writes |  | InputColumnCollection
snapshot_clr_time |  | InputColumnCollection
snapshot_elapsed_time |  | InputColumnCollection
snapshot_execution_count |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 364
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 365
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 366
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 367
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 368
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 369
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]
Length | 0
MappedColumnID | 0
Name | creation_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 370
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[last_execution_time]
Length | 0
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 371
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[execution_count]
Length | 0
MappedColumnID | 0
Name | execution_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 372
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_worker_time]
Length | 0
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 373
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_worker_time]
Length | 0
MappedColumnID | 0
Name | snapshot_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 374
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_worker_time]
Length | 0
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 375
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_worker_time]
Length | 0
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 376
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_physical_reads]
Length | 0
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 377
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_physical_reads]
Length | 0
MappedColumnID | 0
Name | snapshot_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 378
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_physical_reads]
Length | 0
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 379
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_physical_reads]
Length | 0
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 380
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_writes]
Length | 0
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 381
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_writes]
Length | 0
MappedColumnID | 0
Name | snapshot_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 382
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_writes]
Length | 0
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 383
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_writes]
Length | 0
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 384
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_reads]
Length | 0
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 385
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_reads]
Length | 0
MappedColumnID | 0
Name | snapshot_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 386
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_reads]
Length | 0
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 387
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_reads]
Length | 0
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 388
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_clr_time]
Length | 0
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 389
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_clr_time]
Length | 0
MappedColumnID | 0
Name | snapshot_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 390
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_clr_time]
Length | 0
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 391
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_clr_time]
Length | 0
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 392
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 393
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_elapsed_time]
Length | 0
MappedColumnID | 0
Name | snapshot_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 394
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_elapsed_time]
Length | 0
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 395
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_elapsed_time]
Length | 0
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 396
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 397
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]
Length | 0
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_execution_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 398
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_execution_count]
Length | 0
MappedColumnID | 0
Name | snapshot_execution_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 365
ID | 329
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 245
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 366
ID | 330
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 247
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 369
ID | 331
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 251
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 367
ID | 332
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 249
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 370
ID | 333
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 253
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 371
ID | 334
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 255
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 372
ID | 335
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 257
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 376
ID | 336
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 259
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 380
ID | 337
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 261
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 384
ID | 338
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 263
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 388
ID | 339
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 265
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 392
ID | 340
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 267
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 375
ID | 341
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 269
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 374
ID | 342
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 271
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 378
ID | 343
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 273
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 379
ID | 344
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 275
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 382
ID | 345
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 277
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 383
ID | 346
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 279
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 386
ID | 347
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 281
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 387
ID | 348
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 283
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 390
ID | 349
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 285
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 391
ID | 350
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 287
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 394
ID | 351
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 289
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 395
ID | 352
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 291
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 396
ID | 353
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 293
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 364
ID | 354
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 295
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 368
ID | 355
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 297
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 397
ID | 356
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 299
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY


Package element

Package element: snapshot_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 373
ID | 357
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 28
MappedColumnID | 0
Name | snapshot_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 377
ID | 358
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 31
MappedColumnID | 0
Name | snapshot_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 385
ID | 359
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 34
MappedColumnID | 0
Name | snapshot_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 381
ID | 360
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 37
MappedColumnID | 0
Name | snapshot_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 389
ID | 361
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 40
MappedColumnID | 0
Name | snapshot_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 393
ID | 362
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 43
MappedColumnID | 0
Name | snapshot_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: snapshot_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 398
ID | 363
IdentificationString | ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 46
MappedColumnID | 0
Name | snapshot_execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 399
IdentificationString | ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 328
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 400
IdentificationString | ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 400
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 401
IdentificationString | ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 401
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 327
IdentificationString | ODD - Save statistics for interesting queries.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODD - Upload interesting plan handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 402
IdentificationString | ODD - Upload interesting plan handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODD - Upload interesting plan handles
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 403
IdentificationString | ODD - Upload interesting plan handles.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 404
IdentificationString | ODD - Upload interesting plan handles.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[notable_query_plan]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 405
IdentificationString | ODD - Upload interesting plan handles.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 406
IdentificationString | ODD - Upload interesting plan handles.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 407
IdentificationString | ODD - Upload interesting plan handles.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 408
IdentificationString | ODD - Upload interesting plan handles.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 409
IdentificationString | ODD - Upload interesting plan handles.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 410
IdentificationString | ODD - Upload interesting plan handles.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 411
IdentificationString | ODD - Upload interesting plan handles.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 412
IdentificationString | ODD - Upload interesting plan handles.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 413
IdentificationString | ODD - Upload interesting plan handles.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1000


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_RedirectRow
HasSideEffects | True
ID | 415
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | True
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
creation_time |  | ExternalMetadataColumnCollection
database_id |  | ExternalMetadataColumnCollection
object_id |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
query_plan |  | ExternalMetadataColumnCollection
source_id |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
creation_time |  | InputColumnCollection
source_id |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 423
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 424
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 425
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 426
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMPOFFSET
Description |
ID | 427
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]
Length | 0
MappedColumnID | 0
Name | creation_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 7


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 428
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]
Length | 0
MappedColumnID | 0
Name | database_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 429
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]
Length | 0
MappedColumnID | 0
Name | object_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 430
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]
Length | 128
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: query_plan

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 431
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[query_plan]
Length | 0
MappedColumnID | 0
Name | query_plan
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 432
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]
Length | 0
MappedColumnID | 0
Name | source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 433
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 423
ID | 416
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 974
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 424
ID | 417
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 976
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 425
ID | 418
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 978
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 426
ID | 419
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 980
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 427
ID | 420
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 982
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 432
ID | 421
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[source_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 67
MappedColumnID | 0
Name | source_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add source_id (1)
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 433
ID | 422
IdentificationString | ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 984
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 434
IdentificationString | ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output]
IsAttached | True
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 415
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 435
IdentificationString | ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 435
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 436
IdentificationString | ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 436
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 414
IdentificationString | ODD - Upload interesting plan handles.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODD - Upload interesting sql handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 437
IdentificationString | ODD - Upload interesting sql handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODD - Upload interesting sql handles
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 438
IdentificationString | ODD - Upload interesting sql handles.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 439
IdentificationString | ODD - Upload interesting sql handles.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[notable_query_text]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 440
IdentificationString | ODD - Upload interesting sql handles.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 441
IdentificationString | ODD - Upload interesting sql handles.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 442
IdentificationString | ODD - Upload interesting sql handles.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 443
IdentificationString | ODD - Upload interesting sql handles.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 444
IdentificationString | ODD - Upload interesting sql handles.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 445
IdentificationString | ODD - Upload interesting sql handles.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 446
IdentificationString | ODD - Upload interesting sql handles.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 447
IdentificationString | ODD - Upload interesting sql handles.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 448
IdentificationString | ODD - Upload interesting sql handles.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1000


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_RedirectRow
HasSideEffects | True
ID | 450
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | True
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
database_id |  | ExternalMetadataColumnCollection
object_id |  | ExternalMetadataColumnCollection
object_name |  | ExternalMetadataColumnCollection
sql_text |  | ExternalMetadataColumnCollection
source_id |  | ExternalMetadataColumnCollection
sql_handle |  | InputColumnCollection
source_id |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 453
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 454
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]
Length | 0
MappedColumnID | 0
Name | database_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 455
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]
Length | 0
MappedColumnID | 0
Name | object_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 456
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]
Length | 128
MappedColumnID | 0
Name | object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_text

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 457
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_text]
Length | 0
MappedColumnID | 0
Name | sql_text
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 458
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]
Length | 0
MappedColumnID | 0
Name | source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 453
ID | 451
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 994
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle values
UsageType | UT_READONLY


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 458
ID | 452
IdentificationString | ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[source_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 76
MappedColumnID | 0
Name | source_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add source_id (2)
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 459
IdentificationString | ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output]
IsAttached | True
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 450
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 460
IdentificationString | ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 460
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 461
IdentificationString | ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 461
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 449
IdentificationString | ODD - Upload interesting sql handles.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODS - Get current snapshot of dm_exec_query_stats

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 462
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Get current snapshot of dm_exec_query_stats
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 463
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 464
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 465
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 466
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 467
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SnapshotQueryStatsQuery


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 468
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 469
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 470
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 471
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 473
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
creation_time |  | ExternalMetadataColumnCollection
last_execution_time |  | ExternalMetadataColumnCollection
execution_count |  | ExternalMetadataColumnCollection
total_worker_time |  | ExternalMetadataColumnCollection
min_worker_time |  | ExternalMetadataColumnCollection
max_worker_time |  | ExternalMetadataColumnCollection
total_physical_reads |  | ExternalMetadataColumnCollection
min_physical_reads |  | ExternalMetadataColumnCollection
max_physical_reads |  | ExternalMetadataColumnCollection
total_logical_writes |  | ExternalMetadataColumnCollection
min_logical_writes |  | ExternalMetadataColumnCollection
max_logical_writes |  | ExternalMetadataColumnCollection
total_logical_reads |  | ExternalMetadataColumnCollection
min_logical_reads |  | ExternalMetadataColumnCollection
max_logical_reads |  | ExternalMetadataColumnCollection
total_clr_time |  | ExternalMetadataColumnCollection
min_clr_time |  | ExternalMetadataColumnCollection
max_clr_time |  | ExternalMetadataColumnCollection
total_elapsed_time |  | ExternalMetadataColumnCollection
min_elapsed_time |  | ExternalMetadataColumnCollection
max_elapsed_time |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
sql_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 501
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 502
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 503
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 504
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 505
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 506
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[creation_time]
Length | 0
MappedColumnID | 0
Name | creation_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 507
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]
Length | 0
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 508
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[execution_count]
Length | 0
MappedColumnID | 0
Name | execution_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 509
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]
Length | 0
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 510
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]
Length | 0
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 511
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]
Length | 0
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 512
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]
Length | 0
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 513
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]
Length | 0
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 514
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]
Length | 0
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 515
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]
Length | 0
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 516
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]
Length | 0
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 517
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]
Length | 0
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 518
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]
Length | 0
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 519
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]
Length | 0
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 520
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]
Length | 0
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 521
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]
Length | 0
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 522
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]
Length | 0
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 523
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]
Length | 0
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 524
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 525
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]
Length | 0
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 526
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]
Length | 0
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 527
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 501
ID | 474
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]
Length | 64
LineageID | 474
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 502
ID | 475
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 475
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 503
ID | 476
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 476
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 504
ID | 477
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]
Length | 0
LineageID | 477
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 505
ID | 478
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]
Length | 64
LineageID | 478
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 506
ID | 479
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]
Length | 0
LineageID | 479
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 507
ID | 480
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]
Length | 0
LineageID | 480
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 508
ID | 481
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]
Length | 0
LineageID | 481
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 509
ID | 482
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]
Length | 0
LineageID | 482
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 510
ID | 483
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]
Length | 0
LineageID | 483
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 511
ID | 484
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]
Length | 0
LineageID | 484
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 512
ID | 485
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]
Length | 0
LineageID | 485
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 513
ID | 486
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]
Length | 0
LineageID | 486
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 514
ID | 487
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]
Length | 0
LineageID | 487
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 515
ID | 488
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]
Length | 0
LineageID | 488
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 516
ID | 489
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]
Length | 0
LineageID | 489
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 517
ID | 490
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]
Length | 0
LineageID | 490
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 518
ID | 491
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]
Length | 0
LineageID | 491
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 519
ID | 492
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]
Length | 0
LineageID | 492
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 520
ID | 493
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]
Length | 0
LineageID | 493
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 521
ID | 494
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]
Length | 0
LineageID | 494
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 522
ID | 495
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]
Length | 0
LineageID | 495
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 523
ID | 496
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]
Length | 0
LineageID | 496
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 524
ID | 497
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]
Length | 0
LineageID | 497
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 525
ID | 498
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]
Length | 0
LineageID | 498
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 526
ID | 499
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]
Length | 0
LineageID | 499
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 527
ID | 500
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]
Length | 0
LineageID | 500
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 528
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 529
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[sql_handle]
Length | 64
LineageID | 529
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 530
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]
Length | 0
LineageID | 530
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 531
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]
Length | 0
LineageID | 531
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 532
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]
Length | 0
LineageID | 532
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 533
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_handle]
Length | 64
LineageID | 533
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 534
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[creation_time]
Length | 0
LineageID | 534
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 535
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[last_execution_time]
Length | 0
LineageID | 535
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 536
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[execution_count]
Length | 0
LineageID | 536
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 537
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_worker_time]
Length | 0
LineageID | 537
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 538
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_worker_time]
Length | 0
LineageID | 538
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 539
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_worker_time]
Length | 0
LineageID | 539
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 540
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]
Length | 0
LineageID | 540
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 541
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]
Length | 0
LineageID | 541
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 542
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]
Length | 0
LineageID | 542
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 543
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]
Length | 0
LineageID | 543
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 544
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]
Length | 0
LineageID | 544
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 545
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]
Length | 0
LineageID | 545
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 546
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]
Length | 0
LineageID | 546
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 547
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]
Length | 0
LineageID | 547
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 548
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]
Length | 0
LineageID | 548
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 549
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_clr_time]
Length | 0
LineageID | 549
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 550
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_clr_time]
Length | 0
LineageID | 550
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 551
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_clr_time]
Length | 0
LineageID | 551
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 552
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]
Length | 0
LineageID | 552
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 553
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]
Length | 0
LineageID | 553
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 554
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]
Length | 0
LineageID | 554
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 555
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[collection_time]
Length | 0
LineageID | 555
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 556
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 556
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 557
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 557
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {15DDC5A3-5645-4BAA-BCC8-B0AF18FDE25D}
Description | The OLE DB runtime connection used to access the database.
ID | 472
IdentificationString | ODS - Get current snapshot of dm_exec_query_stats.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RC - Number of interesting plan handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 558
IdentificationString | RC - Number of interesting plan handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of interesting plan handles
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 559
IdentificationString | RC - Number of interesting plan handles.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlPlanRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 560
IdentificationString | RC - Number of interesting plan handles.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 561
IdentificationString | RC - Number of interesting plan handles.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 560
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of interesting sql handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 562
IdentificationString | RC - Number of interesting sql handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of interesting sql handles
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 563
IdentificationString | RC - Number of interesting sql handles.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlTextRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 564
IdentificationString | RC - Number of interesting sql handles.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 565
IdentificationString | RC - Number of interesting sql handles.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 564
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of not inserted plan handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 566
IdentificationString | RC - Number of not inserted plan handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of not inserted plan handles
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 567
IdentificationString | RC - Number of not inserted plan handles.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlPlanRowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 568
IdentificationString | RC - Number of not inserted plan handles.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 569
IdentificationString | RC - Number of not inserted plan handles.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 568
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Number of not inserted sql handles

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 570
IdentificationString | RC - Number of not inserted sql handles
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Number of not inserted sql handles
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 571
IdentificationString | RC - Number of not inserted sql handles.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlTextRowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 572
IdentificationString | RC - Number of not inserted sql handles.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 573
IdentificationString | RC - Number of not inserted sql handles.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 572
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Row count after TopN queries

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 574
IdentificationString | RC - Row count after TopN queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Row count after TopN queries
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 575
IdentificationString | RC - Row count after TopN queries.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesRowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 576
IdentificationString | RC - Row count after TopN queries.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 577
IdentificationString | RC - Row count after TopN queries.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 576
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Row count from dm_exec_query_stats

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 578
IdentificationString | RC - Row count from dm_exec_query_stats
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Row count from dm_exec_query_stats
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 579
IdentificationString | RC - Row count from dm_exec_query_stats.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 580
IdentificationString | RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 581
IdentificationString | RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 580
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RFD - Save current snapshot in temp file

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {953B7879-214C-4AB8-AA79-AEA630F35C46}
ContactInfo | Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Loads raw data into a file.
ID | 582
IdentificationString | RFD - Save current snapshot in temp file
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFD - Save current snapshot in temp file
ObjectType | 10
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 2

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
WriteOption | Indicates what option is used to write to the file. | CustomPropertyCollection
Raw File Destination Input |  | InputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 583
IdentificationString | RFD - Save current snapshot in temp file.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 584
IdentificationString | RFD - Save current snapshot in temp file.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 585
IdentificationString | RFD - Save current snapshot in temp file.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesLastSnapshotFileNameOutput


Package element

Package element: WriteOption

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates what option is used to write to the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 586
IdentificationString | RFD - Save current snapshot in temp file.Properties[WriteOption]
Name | WriteOption
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | WriteOption
UITypeEditor |
Value | 0


Package element

Package element: Raw File Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 587
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input]
IsAttached | True
IsSorted | True
Name | Raw File Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
plan_handle |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
collection_time |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 588
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 474
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 589
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 475
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 590
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 476
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 591
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 477
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 592
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 478
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 593
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 479
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 594
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 480
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 595
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 481
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 596
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 482
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 597
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 485
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 598
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 488
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 599
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 491
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 600
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 494
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 601
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 497
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 602
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 484
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 603
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 483
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 604
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 486
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 605
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 487
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 606
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 489
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 607
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 490
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 608
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 492
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 609
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 493
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 610
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 495
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 611
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 496
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 612
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 498
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 613
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 499
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 614
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Add SnapshotId column to current snapshot
UsageType | UT_READONLY


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 615
IdentificationString | RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 500
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY


Package element

Package element: RFS - Read current cache with dm_exec_requests

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {036C7941-58DF-4CD3-BF13-E5373258D001}
ContactInfo | Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Extracts data from a raw file.
ID | 616
IdentificationString | RFS - Read current cache with dm_exec_requests
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFS - Read current cache with dm_exec_requests
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
Raw File Source Output |  | OutputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 617
IdentificationString | RFS - Read current cache with dm_exec_requests.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 618
IdentificationString | RFS - Read current cache with dm_exec_requests.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 619
IdentificationString | RFS - Read current cache with dm_exec_requests.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::CollectionCacheFileNameOutput


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 620
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Raw File Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
sql_handle |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
row_id |  | ExternalMetadataColumnCollection
session_id |  | ExternalMetadataColumnCollection
request_id |  | ExternalMetadataColumnCollection
exec_context_id |  | ExternalMetadataColumnCollection
blocking_session_id |  | ExternalMetadataColumnCollection
is_blocking |  | ExternalMetadataColumnCollection
blocking_exec_context_id |  | ExternalMetadataColumnCollection
scheduler_id |  | ExternalMetadataColumnCollection
database_name |  | ExternalMetadataColumnCollection
user_id |  | ExternalMetadataColumnCollection
task_state |  | ExternalMetadataColumnCollection
request_status |  | ExternalMetadataColumnCollection
session_status |  | ExternalMetadataColumnCollection
executing_managed_code |  | ExternalMetadataColumnCollection
login_time |  | ExternalMetadataColumnCollection
is_user_process |  | ExternalMetadataColumnCollection
host_name |  | ExternalMetadataColumnCollection
program_name |  | ExternalMetadataColumnCollection
login_name |  | ExternalMetadataColumnCollection
wait_type |  | ExternalMetadataColumnCollection
last_wait_type |  | ExternalMetadataColumnCollection
wait_duration_ms |  | ExternalMetadataColumnCollection
wait_resource |  | ExternalMetadataColumnCollection
resource_description |  | ExternalMetadataColumnCollection
transaction_id |  | ExternalMetadataColumnCollection
open_transaction_count |  | ExternalMetadataColumnCollection
transaction_isolation_level |  | ExternalMetadataColumnCollection
request_cpu_time |  | ExternalMetadataColumnCollection
request_logical_reads |  | ExternalMetadataColumnCollection
request_reads |  | ExternalMetadataColumnCollection
request_writes |  | ExternalMetadataColumnCollection
request_total_elapsed_time |  | ExternalMetadataColumnCollection
request_start_time |  | ExternalMetadataColumnCollection
memory_usage |  | ExternalMetadataColumnCollection
session_cpu_time |  | ExternalMetadataColumnCollection
session_reads |  | ExternalMetadataColumnCollection
session_writes |  | ExternalMetadataColumnCollection
session_logical_reads |  | ExternalMetadataColumnCollection
session_total_scheduled_time |  | ExternalMetadataColumnCollection
session_total_elapsed_time |  | ExternalMetadataColumnCollection
session_last_request_start_time |  | ExternalMetadataColumnCollection
session_last_request_end_time |  | ExternalMetadataColumnCollection
open_resultsets |  | ExternalMetadataColumnCollection
session_row_count |  | ExternalMetadataColumnCollection
prev_error |  | ExternalMetadataColumnCollection
pending_io_count |  | ExternalMetadataColumnCollection
command |  | ExternalMetadataColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
row_id |  | OutputColumnCollection
session_id |  | OutputColumnCollection
request_id |  | OutputColumnCollection
exec_context_id |  | OutputColumnCollection
blocking_session_id |  | OutputColumnCollection
is_blocking |  | OutputColumnCollection
blocking_exec_context_id |  | OutputColumnCollection
scheduler_id |  | OutputColumnCollection
database_name |  | OutputColumnCollection
user_id |  | OutputColumnCollection
task_state |  | OutputColumnCollection
request_status |  | OutputColumnCollection
session_status |  | OutputColumnCollection
executing_managed_code |  | OutputColumnCollection
login_time |  | OutputColumnCollection
is_user_process |  | OutputColumnCollection
host_name |  | OutputColumnCollection
program_name |  | OutputColumnCollection
login_name |  | OutputColumnCollection
wait_type |  | OutputColumnCollection
last_wait_type |  | OutputColumnCollection
wait_duration_ms |  | OutputColumnCollection
wait_resource |  | OutputColumnCollection
resource_description |  | OutputColumnCollection
transaction_id |  | OutputColumnCollection
open_transaction_count |  | OutputColumnCollection
transaction_isolation_level |  | OutputColumnCollection
request_cpu_time |  | OutputColumnCollection
request_logical_reads |  | OutputColumnCollection
request_reads |  | OutputColumnCollection
request_writes |  | OutputColumnCollection
request_total_elapsed_time |  | OutputColumnCollection
request_start_time |  | OutputColumnCollection
memory_usage |  | OutputColumnCollection
session_cpu_time |  | OutputColumnCollection
session_reads |  | OutputColumnCollection
session_writes |  | OutputColumnCollection
session_logical_reads |  | OutputColumnCollection
session_total_scheduled_time |  | OutputColumnCollection
session_total_elapsed_time |  | OutputColumnCollection
session_last_request_start_time |  | OutputColumnCollection
session_last_request_end_time |  | OutputColumnCollection
open_resultsets |  | OutputColumnCollection
session_row_count |  | OutputColumnCollection
prev_error |  | OutputColumnCollection
pending_io_count |  | OutputColumnCollection
command |  | OutputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 673
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 674
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 675
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 676
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 677
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 678
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[row_id]
Length | 0
MappedColumnID | 0
Name | row_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 679
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_id]
Length | 0
MappedColumnID | 0
Name | session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 680
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_id]
Length | 0
MappedColumnID | 0
Name | request_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 681
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]
Length | 0
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 682
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]
Length | 0
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 683
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_blocking]
Length | 0
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 684
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]
Length | 0
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 685
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]
Length | 0
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 686
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[database_name]
Length | 128
MappedColumnID | 0
Name | database_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 687
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[user_id]
Length | 0
MappedColumnID | 0
Name | user_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 688
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[task_state]
Length | 10
MappedColumnID | 0
Name | task_state
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 689
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_status]
Length | 15
MappedColumnID | 0
Name | request_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 690
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_status]
Length | 15
MappedColumnID | 0
Name | session_status
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 691
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]
Length | 0
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 692
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_time]
Length | 0
MappedColumnID | 0
Name | login_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 693
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_user_process]
Length | 0
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 694
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[host_name]
Length | 20
MappedColumnID | 0
Name | host_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 695
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[program_name]
Length | 50
MappedColumnID | 0
Name | program_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 696
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_name]
Length | 30
MappedColumnID | 0
Name | login_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 697
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_type]
Length | 45
MappedColumnID | 0
Name | wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 698
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]
Length | 45
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 699
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]
Length | 0
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 700
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_resource]
Length | 50
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 701
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[resource_description]
Length | 140
MappedColumnID | 0
Name | resource_description
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 702
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_id]
Length | 0
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 703
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]
Length | 0
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 704
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]
Length | 0
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 705
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]
Length | 0
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 706
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]
Length | 0
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 707
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_reads]
Length | 0
MappedColumnID | 0
Name | request_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 708
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_writes]
Length | 0
MappedColumnID | 0
Name | request_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 709
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 710
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_start_time]
Length | 0
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 711
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[memory_usage]
Length | 0
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 712
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]
Length | 0
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 713
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_reads]
Length | 0
MappedColumnID | 0
Name | session_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 714
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_writes]
Length | 0
MappedColumnID | 0
Name | session_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 715
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]
Length | 0
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 716
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]
Length | 0
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 717
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 718
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 719
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]
Length | 0
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 720
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]
Length | 0
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 721
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_row_count]
Length | 0
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 722
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[prev_error]
Length | 0
MappedColumnID | 0
Name | prev_error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 723
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]
Length | 0
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 724
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[command]
Length | 32
MappedColumnID | 0
Name | command
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 673
ID | 621
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 621
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 674
ID | 622
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 622
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 675
ID | 623
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]
Length | 0
LineageID | 623
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 676
ID | 624
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]
Length | 64
LineageID | 624
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 677
ID | 625
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]
Length | 64
LineageID | 625
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: row_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 678
ID | 626
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[row_id]
Length | 0
LineageID | 626
MappedColumnID | 0
Name | row_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 679
ID | 627
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_id]
Length | 0
LineageID | 627
MappedColumnID | 0
Name | session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 680
ID | 628
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_id]
Length | 0
LineageID | 628
MappedColumnID | 0
Name | request_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 681
ID | 629
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[exec_context_id]
Length | 0
LineageID | 629
MappedColumnID | 0
Name | exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 682
ID | 630
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]
Length | 0
LineageID | 630
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 683
ID | 631
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]
Length | 0
LineageID | 631
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: blocking_exec_context_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 684
ID | 632
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]
Length | 0
LineageID | 632
MappedColumnID | 0
Name | blocking_exec_context_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: scheduler_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 685
ID | 633
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[scheduler_id]
Length | 0
LineageID | 633
MappedColumnID | 0
Name | scheduler_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: database_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 686
ID | 634
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[database_name]
Length | 128
LineageID | 634
MappedColumnID | 0
Name | database_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: user_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 687
ID | 635
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[user_id]
Length | 0
LineageID | 635
MappedColumnID | 0
Name | user_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: task_state

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 688
ID | 636
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[task_state]
Length | 10
LineageID | 636
MappedColumnID | 0
Name | task_state
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 689
ID | 637
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_status]
Length | 15
LineageID | 637
MappedColumnID | 0
Name | request_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_status

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 690
ID | 638
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_status]
Length | 15
LineageID | 638
MappedColumnID | 0
Name | session_status
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: executing_managed_code

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 691
ID | 639
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[executing_managed_code]
Length | 0
LineageID | 639
MappedColumnID | 0
Name | executing_managed_code
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 692
ID | 640
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_time]
Length | 0
LineageID | 640
MappedColumnID | 0
Name | login_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: is_user_process

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 693
ID | 641
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_user_process]
Length | 0
LineageID | 641
MappedColumnID | 0
Name | is_user_process
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: host_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 694
ID | 642
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[host_name]
Length | 20
LineageID | 642
MappedColumnID | 0
Name | host_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: program_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 695
ID | 643
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[program_name]
Length | 50
LineageID | 643
MappedColumnID | 0
Name | program_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: login_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 696
ID | 644
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_name]
Length | 30
LineageID | 644
MappedColumnID | 0
Name | login_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 697
ID | 645
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_type]
Length | 45
LineageID | 645
MappedColumnID | 0
Name | wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_wait_type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 698
ID | 646
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[last_wait_type]
Length | 45
LineageID | 646
MappedColumnID | 0
Name | last_wait_type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 699
ID | 647
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]
Length | 0
LineageID | 647
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: wait_resource

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 700
ID | 648
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_resource]
Length | 50
LineageID | 648
MappedColumnID | 0
Name | wait_resource
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: resource_description

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 701
ID | 649
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[resource_description]
Length | 140
LineageID | 649
MappedColumnID | 0
Name | resource_description
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 702
ID | 650
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_id]
Length | 0
LineageID | 650
MappedColumnID | 0
Name | transaction_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 703
ID | 651
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]
Length | 0
LineageID | 651
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: transaction_isolation_level

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 704
ID | 652
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_isolation_level]
Length | 0
LineageID | 652
MappedColumnID | 0
Name | transaction_isolation_level
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 705
ID | 653
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]
Length | 0
LineageID | 653
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 706
ID | 654
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_logical_reads]
Length | 0
LineageID | 654
MappedColumnID | 0
Name | request_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 707
ID | 655
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_reads]
Length | 0
LineageID | 655
MappedColumnID | 0
Name | request_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 708
ID | 656
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_writes]
Length | 0
LineageID | 656
MappedColumnID | 0
Name | request_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 709
ID | 657
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]
Length | 0
LineageID | 657
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 710
ID | 658
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_start_time]
Length | 0
LineageID | 658
MappedColumnID | 0
Name | request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 711
ID | 659
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]
Length | 0
LineageID | 659
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 712
ID | 660
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_cpu_time]
Length | 0
LineageID | 660
MappedColumnID | 0
Name | session_cpu_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 713
ID | 661
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_reads]
Length | 0
LineageID | 661
MappedColumnID | 0
Name | session_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 714
ID | 662
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_writes]
Length | 0
LineageID | 662
MappedColumnID | 0
Name | session_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 715
ID | 663
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_logical_reads]
Length | 0
LineageID | 663
MappedColumnID | 0
Name | session_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_scheduled_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 716
ID | 664
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]
Length | 0
LineageID | 664
MappedColumnID | 0
Name | session_total_scheduled_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 717
ID | 665
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]
Length | 0
LineageID | 665
MappedColumnID | 0
Name | session_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_last_request_start_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 718
ID | 666
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_start_time]
Length | 0
LineageID | 666
MappedColumnID | 0
Name | session_last_request_start_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_last_request_end_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 719
ID | 667
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_end_time]
Length | 0
LineageID | 667
MappedColumnID | 0
Name | session_last_request_end_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: open_resultsets

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 720
ID | 668
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_resultsets]
Length | 0
LineageID | 668
MappedColumnID | 0
Name | open_resultsets
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 721
ID | 669
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]
Length | 0
LineageID | 669
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: prev_error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 722
ID | 670
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[prev_error]
Length | 0
LineageID | 670
MappedColumnID | 0
Name | prev_error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 723
ID | 671
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]
Length | 0
LineageID | 671
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: command

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 724
ID | 672
IdentificationString | RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[command]
Length | 32
LineageID | 672
MappedColumnID | 0
Name | command
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RFS - Read last snapshot of dm_exec_query_stats

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {036C7941-58DF-4CD3-BF13-E5373258D001}
ContactInfo | Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Extracts data from a raw file.
ID | 725
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats
IsDefaultLocale | True
LocaleID | English (United States)
Name | RFS - Read last snapshot of dm_exec_query_stats
ObjectType | 9
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
AccessMode | Specifies the mode used to access the file. | CustomPropertyCollection
FileName | Output file name | CustomPropertyCollection
FileNameVariable | Name of the variable that contains the file name | CustomPropertyCollection
Raw File Source Output |  | OutputCollection


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the file.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 726
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 1


Package element

Package element: FileName

Collapse image Properties

Name | Value
ContainsID | False
Description | Output file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 727
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Properties[FileName]
Name | FileName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: FileNameVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Name of the variable that contains the file name
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 728
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Properties[FileNameVariable]
Name | FileNameVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::InterestingQueriesLastSnapshotFileName


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 729
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Raw File Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
creation_time |  | ExternalMetadataColumnCollection
last_execution_time |  | ExternalMetadataColumnCollection
execution_count |  | ExternalMetadataColumnCollection
total_worker_time |  | ExternalMetadataColumnCollection
total_physical_reads |  | ExternalMetadataColumnCollection
total_logical_writes |  | ExternalMetadataColumnCollection
total_logical_reads |  | ExternalMetadataColumnCollection
total_clr_time |  | ExternalMetadataColumnCollection
total_elapsed_time |  | ExternalMetadataColumnCollection
max_worker_time |  | ExternalMetadataColumnCollection
min_worker_time |  | ExternalMetadataColumnCollection
min_physical_reads |  | ExternalMetadataColumnCollection
max_physical_reads |  | ExternalMetadataColumnCollection
min_logical_writes |  | ExternalMetadataColumnCollection
max_logical_writes |  | ExternalMetadataColumnCollection
min_logical_reads |  | ExternalMetadataColumnCollection
max_logical_reads |  | ExternalMetadataColumnCollection
min_clr_time |  | ExternalMetadataColumnCollection
max_clr_time |  | ExternalMetadataColumnCollection
min_elapsed_time |  | ExternalMetadataColumnCollection
max_elapsed_time |  | ExternalMetadataColumnCollection
snapshot_id |  | ExternalMetadataColumnCollection
collection_time |  | ExternalMetadataColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 758
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 759
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 760
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 761
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 762
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 763
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[creation_time]
Length | 0
MappedColumnID | 0
Name | creation_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 764
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[last_execution_time]
Length | 0
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 765
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[execution_count]
Length | 0
MappedColumnID | 0
Name | execution_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 766
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_worker_time]
Length | 0
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 767
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_physical_reads]
Length | 0
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 768
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_writes]
Length | 0
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 769
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_reads]
Length | 0
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 770
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_clr_time]
Length | 0
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 771
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_elapsed_time]
Length | 0
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 772
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_worker_time]
Length | 0
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 773
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_worker_time]
Length | 0
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 774
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_physical_reads]
Length | 0
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 775
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_physical_reads]
Length | 0
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 776
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_writes]
Length | 0
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 777
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_writes]
Length | 0
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 778
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_reads]
Length | 0
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 779
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_reads]
Length | 0
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 780
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_clr_time]
Length | 0
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 781
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_clr_time]
Length | 0
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 782
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_elapsed_time]
Length | 0
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 783
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_elapsed_time]
Length | 0
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 784
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[snapshot_id]
Length | 0
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 785
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[collection_time]
Length | 0
MappedColumnID | 0
Name | collection_time
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 759
ID | 730
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 730
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 760
ID | 731
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 731
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 761
ID | 732
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]
Length | 0
LineageID | 732
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 763
ID | 733
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]
Length | 0
LineageID | 733
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 764
ID | 734
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]
Length | 0
LineageID | 734
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 765
ID | 735
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]
Length | 0
LineageID | 735
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 766
ID | 736
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]
Length | 0
LineageID | 736
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 767
ID | 737
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]
Length | 0
LineageID | 737
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 768
ID | 738
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]
Length | 0
LineageID | 738
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 769
ID | 739
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]
Length | 0
LineageID | 739
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 770
ID | 740
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]
Length | 0
LineageID | 740
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 771
ID | 741
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]
Length | 0
LineageID | 741
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 772
ID | 742
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]
Length | 0
LineageID | 742
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 773
ID | 743
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]
Length | 0
LineageID | 743
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 774
ID | 744
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]
Length | 0
LineageID | 744
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 775
ID | 745
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]
Length | 0
LineageID | 745
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 776
ID | 746
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]
Length | 0
LineageID | 746
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 777
ID | 747
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]
Length | 0
LineageID | 747
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 778
ID | 748
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]
Length | 0
LineageID | 748
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 779
ID | 749
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]
Length | 0
LineageID | 749
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 780
ID | 750
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]
Length | 0
LineageID | 750
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 781
ID | 751
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]
Length | 0
LineageID | 751
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 782
ID | 752
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]
Length | 0
LineageID | 752
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 783
ID | 753
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]
Length | 0
LineageID | 753
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 784
ID | 754
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]
Length | 0
LineageID | 754
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 785
ID | 755
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]
Length | 0
LineageID | 755
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 758
ID | 756
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]
Length | 64
LineageID | 756
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 762
ID | 757
IdentificationString | RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]
Length | 64
LineageID | 757
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SPLT - Identify interesting running requests

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7A2B9683-FF48-4927-8B2B-72B6A6AF92C1}
ContactInfo | Conditional Split;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Evaluates and directs rows in a dataset.
ID | 786
IdentificationString | SPLT - Identify interesting running requests
IsDefaultLocale | True
LocaleID | English (United States)
Name | SPLT - Identify interesting running requests
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Conditional Split Input | Input to the Conditional Split Transformation | InputCollection
Interesting Requests | Output 1 of the Conditional Split Transformation | OutputCollection
Conditional Split Default Output | Default Output of the Conditional Split Transformation | OutputCollection
Conditional Split Error Output | Error Output of the Conditional Split Transformation | OutputCollection


Package element

Package element: Conditional Split Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Conditional Split Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 787
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input]
IsAttached | True
IsSorted | False
Name | Conditional Split Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
blocking_session_id |  | InputColumnCollection
is_blocking |  | InputColumnCollection
wait_duration_ms |  | InputColumnCollection
open_transaction_count |  | InputColumnCollection
request_total_elapsed_time |  | InputColumnCollection
request_cpu_time |  | InputColumnCollection
memory_usage |  | InputColumnCollection
session_row_count |  | InputColumnCollection
pending_io_count |  | InputColumnCollection


Package element

Package element: blocking_session_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 788
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[blocking_session_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 630
MappedColumnID | 0
Name | blocking_session_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: is_blocking

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 789
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[is_blocking]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 631
MappedColumnID | 0
Name | is_blocking
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: wait_duration_ms

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 790
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[wait_duration_ms]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 647
MappedColumnID | 0
Name | wait_duration_ms
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: open_transaction_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 791
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[open_transaction_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 651
MappedColumnID | 0
Name | open_transaction_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 792
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 657
MappedColumnID | 0
Name | request_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: request_cpu_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 793
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_cpu_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 653
MappedColumnID | 0
Name | request_cpu_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: memory_usage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 794
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[memory_usage]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 659
MappedColumnID | 0
Name | memory_usage
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: session_row_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 795
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[session_row_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 669
MappedColumnID | 0
Name | session_row_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: pending_io_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 796
IdentificationString | SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[pending_io_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 671
MappedColumnID | 0
Name | pending_io_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY


Package element

Package element: Interesting Requests

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Output 1 of the Conditional Split Transformation
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_IgnoreFailure
ExclusionGroup | 1
HasSideEffects | False
ID | 797
IdentificationString | SPLT - Identify interesting running requests.Outputs[Interesting Requests]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Interesting Requests
ObjectType | OT_OUTPUT
SynchronousInputID | 787
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Specifies the expression. This expression version uses lineage identifiers instead of column names. | CustomPropertyCollection
FriendlyExpression | Specifies the friendly version of the expression. This expression version uses column names. | CustomPropertyCollection
EvaluationOrder | Specifies the position of the condition in the list of conditions that the transformation evaluates. The evaluation order is from the lowest to the highest value. | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the expression. This expression version uses lineage identifiers instead of column names.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 798
IdentificationString | SPLT - Identify interesting running requests.Outputs[Interesting Requests].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (#647 > @[User::InterestingQueries_LongWaitingRequest]) || (#630 == 0 && #631 == TRUE ) || (#651 > @[User::InterestingQueries_HighTransactionCount]) || (#657 > @[User::InterestingQueries_LongRunningRequest]) || (#653 > @[User::InterestingQueries_HighCpuUsage]) || (#671 > @[User::InterestingQueries_HighIoCount]) || (#659 > @[User::InterestingQueries_HighMemoryUsage]) || (#669 > @[User::InterestingQueries_LargeResultset])


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the friendly version of the expression. This expression version uses column names.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 799
IdentificationString | SPLT - Identify interesting running requests.Outputs[Interesting Requests].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | (wait_duration_ms > @[User::InterestingQueries_LongWaitingRequest]) || (blocking_session_id == 0 && is_blocking == TRUE ) || (open_transaction_count > @[User::InterestingQueries_HighTransactionCount]) || (request_total_elapsed_time > @[User::InterestingQueries_LongRunningRequest]) || (request_cpu_time > @[User::InterestingQueries_HighCpuUsage]) || (pending_io_count > @[User::InterestingQueries_HighIoCount]) || (memory_usage > @[User::InterestingQueries_HighMemoryUsage]) || (session_row_count > @[User::InterestingQueries_LargeResultset])


Package element

Package element: EvaluationOrder

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the position of the condition in the list of conditions that the transformation evaluates. The evaluation order is from the lowest to the highest value.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 800
IdentificationString | SPLT - Identify interesting running requests.Outputs[Interesting Requests].Properties[EvaluationOrder]
Name | EvaluationOrder
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: Conditional Split Default Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Conditional Split Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 801
IdentificationString | SPLT - Identify interesting running requests.Outputs[Conditional Split Default Output]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Conditional Split Default Output
ObjectType | OT_OUTPUT
SynchronousInputID | 787
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
IsDefaultOut |  | CustomPropertyCollection


Package element

Package element: IsDefaultOut

Collapse image Properties

Name | Value
ContainsID | False
Description |
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 802
IdentificationString | SPLT - Identify interesting running requests.Outputs[Conditional Split Default Output].Properties[IsDefaultOut]
Name | IsDefaultOut
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: Conditional Split Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Conditional Split Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 803
IdentificationString | SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Conditional Split Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 787
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 804
IdentificationString | SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorCode]
Length | 0
LineageID | 804
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 805
IdentificationString | SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 805
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B0346D5-E62D-4F79-AB19-688D05FA0444}
ContactInfo | Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Sorts data.
ID | 806
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
IsDefaultLocale | True
LocaleID | English (United States)
Name | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
EliminateDuplicates | Indicates whether the Sort transformation removes rows with duplicate sort values. | CustomPropertyCollection
MaximumThreads | Specifies the maximum number of threads to use for sorting. | CustomPropertyCollection
Sort Input |  | InputCollection
Sort Output |  | OutputCollection


Package element

Package element: EliminateDuplicates

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the Sort transformation removes rows with duplicate sort values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 807
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Properties[EliminateDuplicates]
Name | EliminateDuplicates
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: MaximumThreads

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the maximum number of threads to use for sorting.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 808
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Properties[MaximumThreads]
Name | MaximumThreads
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | -1


Package element

Package element: Sort Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 809
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input]
IsAttached | True
IsSorted | True
Name | Sort Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
snapshot_id |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 810
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 141
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 811
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_start_offset].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 812
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_start_offset].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 3


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 813
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 143
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 814
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_end_offset].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 815
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_end_offset].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 4


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 816
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 145
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 817
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_generation_num].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 818
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_generation_num].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 819
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 147
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 820
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[creation_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 821
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[creation_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 822
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 149
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 823
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[last_execution_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 824
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[last_execution_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 825
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 151
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 826
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[execution_count].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 827
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[execution_count].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 828
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 153
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 829
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_worker_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 830
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_worker_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 831
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 155
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 832
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_physical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 833
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_physical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 834
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 157
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 835
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_writes].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 836
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_writes].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 837
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 159
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 838
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 839
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 840
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 161
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 841
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_clr_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 842
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_clr_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 843
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 163
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 844
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_elapsed_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 845
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_elapsed_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 846
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 165
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 847
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_worker_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 848
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_worker_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 849
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 167
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 850
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_worker_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 851
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_worker_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 852
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 169
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 853
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_physical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 854
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_physical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 855
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 171
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 856
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_physical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 857
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_physical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 858
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 173
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 859
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_writes].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 860
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_writes].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 861
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 175
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 862
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_writes].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 863
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_writes].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 864
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 177
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 865
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 866
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 867
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 179
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 868
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_reads].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 869
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_reads].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 870
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 181
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 871
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_clr_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 872
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_clr_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 873
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 183
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 874
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_clr_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 875
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_clr_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 876
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 185
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 877
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_elapsed_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 878
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_elapsed_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 879
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 187
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 880
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_elapsed_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 881
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_elapsed_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 882
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 189
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 883
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[collection_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 884
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[collection_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 885
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 191
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 886
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[sql_handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 887
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[sql_handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 888
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 193
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 889
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 890
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 2


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 891
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 195
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append current stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 892
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[snapshot_id].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 893
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[snapshot_id].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 894
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Sort Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 895
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]
Length | 0
LineageID | 895
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 896
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 141


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 897
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]
Length | 0
LineageID | 897
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 898
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 143


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 899
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]
Length | 0
LineageID | 899
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 900
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 145


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 901
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]
Length | 0
LineageID | 901
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 902
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 147


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 903
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]
Length | 0
LineageID | 903
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 904
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 149


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 905
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]
Length | 0
LineageID | 905
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 906
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 151


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 907
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]
Length | 0
LineageID | 907
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 908
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 153


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 909
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]
Length | 0
LineageID | 909
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 910
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 155


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 911
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]
Length | 0
LineageID | 911
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 912
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 157


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 913
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]
Length | 0
LineageID | 913
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 914
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 159


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 915
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]
Length | 0
LineageID | 915
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 916
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 161


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 917
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]
Length | 0
LineageID | 917
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 918
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 163


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 919
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]
Length | 0
LineageID | 919
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 920
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 165


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 921
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]
Length | 0
LineageID | 921
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 922
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 167


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 923
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]
Length | 0
LineageID | 923
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 924
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 169


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 925
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]
Length | 0
LineageID | 925
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 926
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 171


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 927
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]
Length | 0
LineageID | 927
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 928
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 173


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 929
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]
Length | 0
LineageID | 929
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 930
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 175


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 931
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]
Length | 0
LineageID | 931
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 932
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 177


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 933
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]
Length | 0
LineageID | 933
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 934
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 179


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 935
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]
Length | 0
LineageID | 935
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 936
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 181


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 937
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]
Length | 0
LineageID | 937
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 938
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 183


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 939
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]
Length | 0
LineageID | 939
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 940
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 185


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 941
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]
Length | 0
LineageID | 941
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 942
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 187


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 943
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]
Length | 0
LineageID | 943
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 944
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 189


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 945
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]
Length | 64
LineageID | 945
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 946
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 191


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 947
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]
Length | 64
LineageID | 947
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 948
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 193


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 949
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]
Length | 0
LineageID | 949
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 950
IdentificationString | SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 195


Package element

Package element: SRT - Find unique sql_handle and plan_handle combinations

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B0346D5-E62D-4F79-AB19-688D05FA0444}
ContactInfo | Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Sorts data.
ID | 951
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations
IsDefaultLocale | True
LocaleID | English (United States)
Name | SRT - Find unique sql_handle and plan_handle combinations
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
EliminateDuplicates | Indicates whether the Sort transformation removes rows with duplicate sort values. | CustomPropertyCollection
MaximumThreads | Specifies the maximum number of threads to use for sorting. | CustomPropertyCollection
Sort Input |  | InputCollection
Sort Output |  | OutputCollection


Package element

Package element: EliminateDuplicates

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the Sort transformation removes rows with duplicate sort values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 952
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Properties[EliminateDuplicates]
Name | EliminateDuplicates
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: MaximumThreads

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the maximum number of threads to use for sorting.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 953
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Properties[MaximumThreads]
Name | MaximumThreads
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | -1


Package element

Package element: Sort Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 954
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input]
IsAttached | True
IsSorted | False
Name | Sort Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
creation_time |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 955
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 1179
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 956
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[sql_handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 957
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[sql_handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 958
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 1180
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 959
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 960
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 2


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 961
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1154
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 962
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_start_offset].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 963
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_start_offset].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 3


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 964
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1155
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 965
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_end_offset].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 966
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_end_offset].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 4


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 967
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1156
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 968
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[creation_time].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 969
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[creation_time].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 970
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1157
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine interesting requests and interesting stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 971
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_generation_num].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 972
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_generation_num].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 5


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 973
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Sort Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 974
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]
Length | 64
LineageID | 974
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 975
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1179


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 976
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]
Length | 64
LineageID | 976
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 977
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1180


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 978
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]
Length | 0
LineageID | 978
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 979
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1154


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 980
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]
Length | 0
LineageID | 980
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 981
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1155


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 982
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]
Length | 0
LineageID | 982
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 983
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1156


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 984
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]
Length | 0
LineageID | 984
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 985
IdentificationString | SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1157


Package element

Package element: SRT - Find unique sql_handle values

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B0346D5-E62D-4F79-AB19-688D05FA0444}
ContactInfo | Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Sorts data.
ID | 986
IdentificationString | SRT - Find unique sql_handle values
IsDefaultLocale | True
LocaleID | English (United States)
Name | SRT - Find unique sql_handle values
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
EliminateDuplicates | Indicates whether the Sort transformation removes rows with duplicate sort values. | CustomPropertyCollection
MaximumThreads | Specifies the maximum number of threads to use for sorting. | CustomPropertyCollection
Sort Input |  | InputCollection
Sort Output |  | OutputCollection


Package element

Package element: EliminateDuplicates

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the Sort transformation removes rows with duplicate sort values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 987
IdentificationString | SRT - Find unique sql_handle values.Properties[EliminateDuplicates]
Name | EliminateDuplicates
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: MaximumThreads

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the maximum number of threads to use for sorting.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 988
IdentificationString | SRT - Find unique sql_handle values.Properties[MaximumThreads]
Name | MaximumThreads
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | -1


Package element

Package element: Sort Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 989
IdentificationString | SRT - Find unique sql_handle values.Inputs[Sort Input]
IsAttached | True
IsSorted | True
Name | Sort Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 990
IdentificationString | SRT - Find unique sql_handle values.Inputs[Sort Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 974
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | SRT - Find unique sql_handle and plan_handle combinations
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 991
IdentificationString | SRT - Find unique sql_handle values.Inputs[Sort Input].Columns[sql_handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 992
IdentificationString | SRT - Find unique sql_handle values.Inputs[Sort Input].Columns[sql_handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 993
IdentificationString | SRT - Find unique sql_handle values.Outputs[Sort Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Sort Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | OutputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 994
IdentificationString | SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]
Length | 64
LineageID | 994
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 995
IdentificationString | SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 974


Package element

Package element: SRT - Sort columns by sql_handle, plan_handle

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B0346D5-E62D-4F79-AB19-688D05FA0444}
ContactInfo | Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Sorts data.
ID | 996
IdentificationString | SRT - Sort columns by sql_handle, plan_handle
IsDefaultLocale | True
LocaleID | English (United States)
Name | SRT - Sort columns by sql_handle, plan_handle
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
EliminateDuplicates | Indicates whether the Sort transformation removes rows with duplicate sort values. | CustomPropertyCollection
MaximumThreads | Specifies the maximum number of threads to use for sorting. | CustomPropertyCollection
Sort Input |  | InputCollection
Sort Output |  | OutputCollection


Package element

Package element: EliminateDuplicates

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the Sort transformation removes rows with duplicate sort values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 997
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Properties[EliminateDuplicates]
Name | EliminateDuplicates
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | True


Package element

Package element: MaximumThreads

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the maximum number of threads to use for sorting.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 998
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Properties[MaximumThreads]
Name | MaximumThreads
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | -1


Package element

Package element: Sort Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 999
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input]
IsAttached | True
IsSorted | False
Name | Sort Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
Top Reason |  | InputColumnCollection
Top SQL Handle |  | InputColumnCollection
Top Plan Handle |  | InputColumnCollection


Package element

Package element: Top Reason

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1000
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Reason]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 128
LineageID | 1042
MappedColumnID | 0
Name | Top Reason
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | TPQ - Analyze Interesting Queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1001
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Reason].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1002
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Reason].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: Top SQL Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1003
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top SQL Handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 44
LineageID | 1043
MappedColumnID | 0
Name | Top SQL Handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | TPQ - Analyze Interesting Queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1004
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top SQL Handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1005
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top SQL Handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: Top Plan Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1006
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Plan Handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 44
LineageID | 1044
MappedColumnID | 0
Name | Top Plan Handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | TPQ - Analyze Interesting Queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
NewComparisonFlags | Specifies the comparison options for character data. | CustomPropertyCollection
NewSortKeyPosition | Specifies the sort order of the column. | CustomPropertyCollection


Package element

Package element: NewComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the comparison options for character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1007
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Plan Handle].Properties[NewComparisonFlags]
Name | NewComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: NewSortKeyPosition

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the sort order of the column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1008
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Plan Handle].Properties[NewSortKeyPosition]
Name | NewSortKeyPosition
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 2


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 1009
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output]
IsAttached | True
IsErrorOut | False
IsSorted | True
Name | Sort Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
Top Reason |  | OutputColumnCollection
Top SQL Handle |  | OutputColumnCollection
Top Plan Handle |  | OutputColumnCollection


Package element

Package element: Top Reason

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1010
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason]
Length | 128
LineageID | 1010
MappedColumnID | 0
Name | Top Reason
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1011
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1042


Package element

Package element: Top SQL Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1012
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]
Length | 44
LineageID | 1012
MappedColumnID | 0
Name | Top SQL Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1013
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1043


Package element

Package element: Top Plan Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1014
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]
Length | 44
LineageID | 1014
MappedColumnID | 0
Name | Top Plan Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SortColumnId | Specifies the lineage identifier of the input column that is associated with this output column. | CustomPropertyCollection


Package element

Package element: SortColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the lineage identifier of the input column that is associated with this output column.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1015
IdentificationString | SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle].Properties[SortColumnId]
Name | SortColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1044


Package element

Package element: TPQ - Analyze Interesting Queries

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {98CF38E4-7B22-4C17-A78E-2FB9A44AC706}
ContactInfo |
Description |
ID | 1016
IdentificationString | TPQ - Analyze Interesting Queries
IsDefaultLocale | True
LocaleID | English (United States)
Name | TPQ - Analyze Interesting Queries
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
TxTopQueries Only Input |  | InputCollection
TxTopQueries Only Output |  | OutputCollection


Package element

Package element: TxTopQueries Only Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 1017
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input]
IsAttached | True
IsSorted | False
Name | TxTopQueries Only Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1018
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1331
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1019
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 1333
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1020
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 1334
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1021
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1309
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1022
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1312
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1023
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1313
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1024
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1320
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1025
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1319
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1026
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1314
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1027
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1321
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1028
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1322
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1029
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1315
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1030
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1323
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1031
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1324
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1032
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1316
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1033
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1325
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1034
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1326
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1035
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1317
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1036
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1327
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1037
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1328
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1038
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1318
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1039
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1329
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1040
IdentificationString | TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 1330
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | UNION - Combine last and current snapshots for TopN processing
UsageType | UT_READONLY


Package element

Package element: TxTopQueries Only Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 1041
IdentificationString | TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | TxTopQueries Only Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
Top Reason |  | OutputColumnCollection
Top SQL Handle |  | OutputColumnCollection
Top Plan Handle |  | OutputColumnCollection


Package element

Package element: Top Reason

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1042
IdentificationString | TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]
Length | 128
LineageID | 1042
MappedColumnID | 0
Name | Top Reason
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Top SQL Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1043
IdentificationString | TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]
Length | 44
LineageID | 1043
MappedColumnID | 0
Name | Top SQL Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Top Plan Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1044
IdentificationString | TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]
Length | 44
LineageID | 1044
MappedColumnID | 0
Name | Top Plan Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: UNION - Combine interesting requests and interesting stats

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {074239CC-EBF1-47E5-B8CA-0E0250A5E189}
ContactInfo | Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Merges multiple datasets.
ID | 1045
IdentificationString | UNION - Combine interesting requests and interesting stats
IsDefaultLocale | True
LocaleID | English (United States)
Name | UNION - Combine interesting requests and interesting stats
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
Union All Input 1 |  | InputCollection
Union All Input 3 |  | InputCollection
Union All Input 2 |  | InputCollection
Union All Output 1 |  | OutputCollection


Package element

Package element: Union All Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 1046
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1]
IsAttached | True
IsSorted | True
Name | Union All Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
old_total_worker_time |  | InputColumnCollection
old_total_physical_reads |  | InputColumnCollection
old_total_logical_writes |  | InputColumnCollection
old_total_logical_reads |  | InputColumnCollection
old_total_clr_time |  | InputColumnCollection
old_total_elapsed_time |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
creation_time |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
snapshot_worker_time |  | InputColumnCollection
snapshot_physical_reads |  | InputColumnCollection
snapshot_logical_reads |  | InputColumnCollection
snapshot_logical_writes |  | InputColumnCollection
snapshot_clr_time |  | InputColumnCollection
snapshot_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
snapshot_execution_count |  | InputColumnCollection
old_execution_count |  | InputColumnCollection


Package element

Package element: old_total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1047
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 301
MappedColumnID | 0
Name | old_total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1048
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1148


Package element

Package element: old_total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1049
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 303
MappedColumnID | 0
Name | old_total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1050
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1149


Package element

Package element: old_total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1051
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 305
MappedColumnID | 0
Name | old_total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1052
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1150


Package element

Package element: old_total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1053
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 307
MappedColumnID | 0
Name | old_total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1054
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1151


Package element

Package element: old_total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1055
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 309
MappedColumnID | 0
Name | old_total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1056
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1152


Package element

Package element: old_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1057
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 311
MappedColumnID | 0
Name | old_total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1058
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1153


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1059
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 245
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1060
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_start_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1154


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1061
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 247
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1062
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_end_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1155


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1063
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 251
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1064
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[creation_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1156


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1065
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 249
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1066
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_generation_num].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1157


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1067
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 253
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1068
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[last_execution_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1158


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1069
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 255
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1070
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[execution_count].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1159


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1071
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 257
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1072
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1160


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1073
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 259
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1074
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1161


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1075
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 261
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1076
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1162


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1077
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 263
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1078
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1163


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1079
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 265
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1080
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1164


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1081
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 267
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1082
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1165


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1083
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 269
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1084
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1166


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1085
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 271
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1086
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1167


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1087
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 273
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1088
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1168


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1089
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 275
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1090
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1169


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1091
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 277
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1092
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1170


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1093
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 279
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1094
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1171


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1095
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 281
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1096
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1172


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1097
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 283
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1098
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1173


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1099
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 285
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1100
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1174


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1101
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 287
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1102
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1175


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1103
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 289
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1104
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1176


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1105
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 291
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1106
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1177


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1107
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 295
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1108
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[sql_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1179


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1109
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 297
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1110
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1180


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1111
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 299
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1112
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_id].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1181


Package element

Package element: snapshot_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1113
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 28
MappedColumnID | 0
Name | snapshot_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1114
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1182


Package element

Package element: snapshot_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1115
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 31
MappedColumnID | 0
Name | snapshot_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1116
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1183


Package element

Package element: snapshot_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1117
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 34
MappedColumnID | 0
Name | snapshot_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1118
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1184


Package element

Package element: snapshot_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1119
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 37
MappedColumnID | 0
Name | snapshot_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1120
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1185


Package element

Package element: snapshot_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1121
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 40
MappedColumnID | 0
Name | snapshot_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1122
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1186


Package element

Package element: snapshot_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1123
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 43
MappedColumnID | 0
Name | snapshot_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1124
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1187


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1125
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 293
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1126
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[collection_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1178


Package element

Package element: snapshot_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1127
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 46
MappedColumnID | 0
Name | snapshot_execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Calculate delta value between last snapshot and current snapshot for every metric
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1128
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_execution_count].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1188


Package element

Package element: old_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1129
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 313
MappedColumnID | 0
Name | old_execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | MRG - Append last stats on interesting queries
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1130
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_execution_count].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1189


Package element

Package element: Union All Input 3

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 1131
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3]
IsAttached | True
IsSorted | False
Name | Union All Input 3
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
creation_time |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1132
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 621
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1133
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_start_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1154


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1134
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 622
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1135
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_end_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1155


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1136
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 623
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1137
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[collection_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1178


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1138
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 624
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1139
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[sql_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1179


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1140
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 625
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read current cache with dm_exec_requests
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1141
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1180


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1142
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 55
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add plan_generation_num column
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1143
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_generation_num].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1157


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1144
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 58
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add plan_generation_num column
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1145
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[creation_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1156


Package element

Package element: Union All Input 2

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 1146
IdentificationString | UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 2]
IsAttached | False
IsSorted | False
Name | Union All Input 2
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Union All Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 1147
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Union All Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
old_total_worker_time |  | OutputColumnCollection
old_total_physical_reads |  | OutputColumnCollection
old_total_logical_writes |  | OutputColumnCollection
old_total_logical_reads |  | OutputColumnCollection
old_total_clr_time |  | OutputColumnCollection
old_total_elapsed_time |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection
snapshot_worker_time |  | OutputColumnCollection
snapshot_physical_reads |  | OutputColumnCollection
snapshot_logical_reads |  | OutputColumnCollection
snapshot_logical_writes |  | OutputColumnCollection
snapshot_clr_time |  | OutputColumnCollection
snapshot_elapsed_time |  | OutputColumnCollection
snapshot_execution_count |  | OutputColumnCollection
old_execution_count |  | OutputColumnCollection


Package element

Package element: old_total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1148
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]
Length | 0
LineageID | 1148
MappedColumnID | 0
Name | old_total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1149
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]
Length | 0
LineageID | 1149
MappedColumnID | 0
Name | old_total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1150
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]
Length | 0
LineageID | 1150
MappedColumnID | 0
Name | old_total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1151
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]
Length | 0
LineageID | 1151
MappedColumnID | 0
Name | old_total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1152
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]
Length | 0
LineageID | 1152
MappedColumnID | 0
Name | old_total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1153
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]
Length | 0
LineageID | 1153
MappedColumnID | 0
Name | old_total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1154
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]
Length | 0
LineageID | 1154
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1155
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]
Length | 0
LineageID | 1155
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1156
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]
Length | 0
LineageID | 1156
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1157
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]
Length | 0
LineageID | 1157
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1158
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]
Length | 0
LineageID | 1158
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1159
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]
Length | 0
LineageID | 1159
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1160
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]
Length | 0
LineageID | 1160
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1161
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]
Length | 0
LineageID | 1161
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1162
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]
Length | 0
LineageID | 1162
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1163
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]
Length | 0
LineageID | 1163
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1164
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]
Length | 0
LineageID | 1164
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1165
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]
Length | 0
LineageID | 1165
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1166
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]
Length | 0
LineageID | 1166
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1167
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]
Length | 0
LineageID | 1167
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1168
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]
Length | 0
LineageID | 1168
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1169
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]
Length | 0
LineageID | 1169
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1170
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]
Length | 0
LineageID | 1170
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1171
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]
Length | 0
LineageID | 1171
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1172
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]
Length | 0
LineageID | 1172
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1173
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]
Length | 0
LineageID | 1173
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1174
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]
Length | 0
LineageID | 1174
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1175
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]
Length | 0
LineageID | 1175
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1176
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]
Length | 0
LineageID | 1176
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1177
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]
Length | 0
LineageID | 1177
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1178
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]
Length | 0
LineageID | 1178
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1179
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]
Length | 64
LineageID | 1179
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1180
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]
Length | 64
LineageID | 1180
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1181
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]
Length | 0
LineageID | 1181
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1182
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]
Length | 0
LineageID | 1182
MappedColumnID | 0
Name | snapshot_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1183
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]
Length | 0
LineageID | 1183
MappedColumnID | 0
Name | snapshot_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1184
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]
Length | 0
LineageID | 1184
MappedColumnID | 0
Name | snapshot_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1185
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]
Length | 0
LineageID | 1185
MappedColumnID | 0
Name | snapshot_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1186
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]
Length | 0
LineageID | 1186
MappedColumnID | 0
Name | snapshot_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1187
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]
Length | 0
LineageID | 1187
MappedColumnID | 0
Name | snapshot_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1188
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]
Length | 0
LineageID | 1188
MappedColumnID | 0
Name | snapshot_execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: old_execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1189
IdentificationString | UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]
Length | 0
LineageID | 1189
MappedColumnID | 0
Name | old_execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: UNION - Combine last and current snapshots for TopN processing

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {074239CC-EBF1-47E5-B8CA-0E0250A5E189}
ContactInfo | Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1
Description | Merges multiple datasets.
ID | 1190
IdentificationString | UNION - Combine last and current snapshots for TopN processing
IsDefaultLocale | True
LocaleID | English (United States)
Name | UNION - Combine last and current snapshots for TopN processing
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 1

Collapse image Elements

Name | Description | Type
Union All Input 2 |  | InputCollection
Union All Input 3 |  | InputCollection
Union All Input 1 |  | InputCollection
Union All Output 1 |  | OutputCollection


Package element

Package element: Union All Input 2

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 1191
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2]
IsAttached | True
IsSorted | True
Name | Union All Input 2
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
snapshot_id |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1192
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 5
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRC - Add SnapshotId column to current snapshot
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1193
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[snapshot_id].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1331


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1194
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 475
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1195
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_start_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1307


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1196
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 476
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1197
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_end_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1308


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1198
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 477
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1199
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_generation_num].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1309


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1200
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 479
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1201
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[creation_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1310


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1202
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 480
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1203
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[last_execution_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1311


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1204
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 481
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1205
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[execution_count].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1312


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1206
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 482
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1207
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1313


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1208
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 485
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1209
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1314


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1210
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 488
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1211
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1315


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1212
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 491
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1213
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1316


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1214
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 494
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1215
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1317


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1216
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 497
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1217
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1318


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1218
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 484
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1219
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1319


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1220
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 483
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1221
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1320


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1222
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 486
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1223
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1321


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1224
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 487
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1225
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1322


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1226
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 489
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1227
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1323


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1228
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 490
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1229
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1324


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1230
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 492
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1231
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1325


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1232
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 493
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1233
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1326


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1234
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 495
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1235
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1327


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1236
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 496
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1237
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1328


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1238
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 498
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1239
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1329


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1240
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 499
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1241
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1330


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1242
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 500
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1243
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[collection_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1332


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1244
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 474
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1245
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[sql_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1333


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1246
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 478
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get current snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1247
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1334


Package element

Package element: Union All Input 3

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 1248
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3]
IsAttached | True
IsSorted | True
Name | Union All Input 3
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
creation_time |  | InputColumnCollection
last_execution_time |  | InputColumnCollection
execution_count |  | InputColumnCollection
total_worker_time |  | InputColumnCollection
total_physical_reads |  | InputColumnCollection
total_logical_writes |  | InputColumnCollection
total_logical_reads |  | InputColumnCollection
total_clr_time |  | InputColumnCollection
total_elapsed_time |  | InputColumnCollection
max_worker_time |  | InputColumnCollection
min_worker_time |  | InputColumnCollection
min_physical_reads |  | InputColumnCollection
max_physical_reads |  | InputColumnCollection
min_logical_writes |  | InputColumnCollection
max_logical_writes |  | InputColumnCollection
min_logical_reads |  | InputColumnCollection
max_logical_reads |  | InputColumnCollection
min_clr_time |  | InputColumnCollection
max_clr_time |  | InputColumnCollection
min_elapsed_time |  | InputColumnCollection
max_elapsed_time |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
collection_time |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1249
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 730
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 3
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1250
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_start_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1307


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1251
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 731
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 4
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1252
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_end_offset].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1308


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1253
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 732
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 5
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1254
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_generation_num].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1309


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1255
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[creation_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 733
MappedColumnID | 0
Name | creation_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1256
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[creation_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1310


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1257
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[last_execution_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 734
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1258
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[last_execution_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1311


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1259
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[execution_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 735
MappedColumnID | 0
Name | execution_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1260
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[execution_count].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1312


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1261
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 736
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1262
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1313


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1263
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 737
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1264
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1314


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1265
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 738
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1266
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1315


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1267
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 739
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1268
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1316


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1269
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 740
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1270
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1317


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1271
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 741
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1272
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1318


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1273
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 742
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1274
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1319


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1275
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_worker_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 743
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1276
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_worker_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1320


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1277
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 744
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1278
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1321


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1279
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_physical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 745
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1280
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_physical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1322


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1281
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 746
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1282
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1323


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1283
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 747
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1284
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_writes].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1324


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1285
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 748
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1286
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1325


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1287
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 749
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1288
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_reads].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1326


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1289
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 750
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1290
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1327


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1291
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_clr_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 751
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1292
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_clr_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1328


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1293
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 752
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1294
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1329


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1295
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_elapsed_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 753
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1296
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_elapsed_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1330


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1297
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 754
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1298
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[snapshot_id].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1331


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1299
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[collection_time]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 755
MappedColumnID | 0
Name | collection_time
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1300
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[collection_time].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1332


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1301
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 756
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 1
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1302
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[sql_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1333


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1303
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 757
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 2
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | RFS - Read last snapshot of dm_exec_query_stats
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
OutputColumnLineageID | Output column lineage ID | CustomPropertyCollection


Package element

Package element: OutputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Output column lineage ID
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 1304
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_handle].Properties[OutputColumnLineageID]
Name | OutputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1334


Package element

Package element: Union All Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 1305
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 1]
IsAttached | False
IsSorted | False
Name | Union All Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Union All Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 1306
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Union All Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
creation_time |  | OutputColumnCollection
last_execution_time |  | OutputColumnCollection
execution_count |  | OutputColumnCollection
total_worker_time |  | OutputColumnCollection
total_physical_reads |  | OutputColumnCollection
total_logical_writes |  | OutputColumnCollection
total_logical_reads |  | OutputColumnCollection
total_clr_time |  | OutputColumnCollection
total_elapsed_time |  | OutputColumnCollection
max_worker_time |  | OutputColumnCollection
min_worker_time |  | OutputColumnCollection
min_physical_reads |  | OutputColumnCollection
max_physical_reads |  | OutputColumnCollection
min_logical_writes |  | OutputColumnCollection
max_logical_writes |  | OutputColumnCollection
min_logical_reads |  | OutputColumnCollection
max_logical_reads |  | OutputColumnCollection
min_clr_time |  | OutputColumnCollection
max_clr_time |  | OutputColumnCollection
min_elapsed_time |  | OutputColumnCollection
max_elapsed_time |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection
collection_time |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1307
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]
Length | 0
LineageID | 1307
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1308
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]
Length | 0
LineageID | 1308
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1309
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]
Length | 0
LineageID | 1309
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: creation_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1310
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]
Length | 0
LineageID | 1310
MappedColumnID | 0
Name | creation_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: last_execution_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1311
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]
Length | 0
LineageID | 1311
MappedColumnID | 0
Name | last_execution_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: execution_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1312
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]
Length | 0
LineageID | 1312
MappedColumnID | 0
Name | execution_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1313
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]
Length | 0
LineageID | 1313
MappedColumnID | 0
Name | total_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1314
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]
Length | 0
LineageID | 1314
MappedColumnID | 0
Name | total_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1315
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]
Length | 0
LineageID | 1315
MappedColumnID | 0
Name | total_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1316
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]
Length | 0
LineageID | 1316
MappedColumnID | 0
Name | total_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1317
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]
Length | 0
LineageID | 1317
MappedColumnID | 0
Name | total_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: total_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1318
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]
Length | 0
LineageID | 1318
MappedColumnID | 0
Name | total_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1319
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]
Length | 0
LineageID | 1319
MappedColumnID | 0
Name | max_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_worker_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1320
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]
Length | 0
LineageID | 1320
MappedColumnID | 0
Name | min_worker_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1321
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]
Length | 0
LineageID | 1321
MappedColumnID | 0
Name | min_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_physical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1322
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]
Length | 0
LineageID | 1322
MappedColumnID | 0
Name | max_physical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1323
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]
Length | 0
LineageID | 1323
MappedColumnID | 0
Name | min_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1324
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]
Length | 0
LineageID | 1324
MappedColumnID | 0
Name | max_logical_writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1325
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]
Length | 0
LineageID | 1325
MappedColumnID | 0
Name | min_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_logical_reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1326
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]
Length | 0
LineageID | 1326
MappedColumnID | 0
Name | max_logical_reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1327
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]
Length | 0
LineageID | 1327
MappedColumnID | 0
Name | min_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_clr_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1328
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]
Length | 0
LineageID | 1328
MappedColumnID | 0
Name | max_clr_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: min_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1329
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]
Length | 0
LineageID | 1329
MappedColumnID | 0
Name | min_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: max_elapsed_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1330
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]
Length | 0
LineageID | 1330
MappedColumnID | 0
Name | max_elapsed_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1331
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]
Length | 0
LineageID | 1331
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: collection_time

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1332
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]
Length | 0
LineageID | 1332
MappedColumnID | 0
Name | collection_time
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1333
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]
Length | 64
LineageID | 1333
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 1334
IdentificationString | UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]
Length | 64
LineageID | 1334
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Calculate TopN stats

Collapse image Properties

Name | Value
Description |
EndPoint | Merge Join Right Input
Name | Calculate TopN stats
ObjectType | OT_PATH
StartPoint | Multicast Output 2


Package element

Package element: Calculate TopN stats

Collapse image Properties

Name | Value
Description |
EndPoint | Merge Join Right Input
Name | Calculate TopN stats
ObjectType | OT_PATH
StartPoint | Multicast Output 1


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | Multicast Input 1
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | Union All Input 3
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Interesting Requests

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Interesting Requests
ObjectType | OT_PATH
StartPoint | Interesting Requests


Package element

Package element: Merge Join Output

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Merge Join Output
ObjectType | OT_PATH
StartPoint | Merge Join Output


Package element

Package element: Merge Join Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Merge Join Output
ObjectType | OT_PATH
StartPoint | Merge Join Output


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Multicast Output 2
ObjectType | OT_PATH
StartPoint | Multicast Output 2


Package element

Package element: Multicast Output 3

Collapse image Properties

Name | Value
Description |
EndPoint | Union All Input 1
Name | Multicast Output 3
ObjectType | OT_PATH
StartPoint | Multicast Output 3


Package element

Package element: Multicast Output 4

Collapse image Properties

Name | Value
Description |
EndPoint | Sort Input
Name | Multicast Output 4
ObjectType | OT_PATH
StartPoint | Multicast Output 4


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | OLE DB Destination Error Output
ObjectType | OT_PATH
StartPoint | OLE DB Destination Error Output


Package element

Package element: Process TopN

Collapse image Properties

Name | Value
Description |
EndPoint | Union All Input 2
Name | Process TopN
ObjectType | OT_PATH
StartPoint | Multicast Output 2


Package element

Package element: Process TopN

Collapse image Properties

Name | Value
Description |
EndPoint | Union All Input 3
Name | Process TopN
ObjectType | OT_PATH
StartPoint | Multicast Output 1


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | Multicast Input 1
Name | Raw File Source Output
ObjectType | OT_PATH
StartPoint | Raw File Source Output


Package element

Package element: Raw File Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | Conditional Split Input
Name | Raw File Source Output
ObjectType | OT_PATH
StartPoint | Raw File Source Output


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Sort Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: Save

Collapse image Properties

Name | Value
Description |
EndPoint | Raw File Destination Input
Name | Save
ObjectType | OT_PATH
StartPoint | Multicast Output 3


Package element

Package element: Save

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Destination Input
Name | Save
ObjectType | OT_PATH
StartPoint | Multicast Output 2


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Description |
EndPoint | Multicast Input 1
Name | Sort Output
ObjectType | OT_PATH
StartPoint | Sort Output


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Description |
EndPoint | Merge Join Left Input
Name | Sort Output
ObjectType | OT_PATH
StartPoint | Sort Output


Package element

Package element: Sort Output

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Sort Output
ObjectType | OT_PATH
StartPoint | Sort Output


Package element

Package element: TxTopQueries Only Output

Collapse image Properties

Name | Value
Description |
EndPoint | Sort Input
Name | TxTopQueries Only Output
ObjectType | OT_PATH
StartPoint | TxTopQueries Only Output


Package element

Package element: Union All Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Sort Input
Name | Union All Output 1
ObjectType | OT_PATH
StartPoint | Union All Output 1


Package element

Package element: Union All Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | TxTopQueries Only Input
Name | Union All Output 1
ObjectType | OT_PATH
StartPoint | Union All Output 1


Package element

Package element: NotableQueryPlan

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "SELECT [sql_handle],{LF} [plan_handle],{LF} [statement_start_offset],{LF} [statement_end_offset],{LF} [creation_time]{LF}FROM [snapshots].[fn_get_notable_query_plans](" + (DT_WSTR, 10) @[User::SourceId] + ")"
IncludeInDebugDump | False
Name | NotableQueryPlan
Namespace | User
QualifiedName | User::NotableQueryPlan
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | SELECT [sql_handle],{LF} [plan_handle],{LF} [statement_start_offset],{LF} [statement_end_offset],{LF} [creation_time]{LF}FROM [snapshots].[fn_get_notable_query_plans](1)
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Variables[User::NotableQueryPlan]


Package element

Package element: NotableQueryText

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "SELECT [sql_handle]{LF}FROM [snapshots].[fn_get_notable_query_text](" + (DT_WSTR, 10) @[User::SourceId] + ")"
IncludeInDebugDump | False
Name | NotableQueryText
Namespace | User
QualifiedName | User::NotableQueryText
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | SELECT [sql_handle]{LF}FROM [snapshots].[fn_get_notable_query_text](1)
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Variables[User::NotableQueryText]


Package element

Package element: DFT - Find and save plan text

Collapse image Properties

Name | Value
[LKUP - Look up query plans on target server].[SqlCommand] | [dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?
[LKUP - Look up query plans on target server].[SqlCommandParam] | [dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?
[ODC - Save known plans to warehouse].[SqlCommand] | EXEC snapshots.sp_update_query_plan ?,?,?,?,?,?,?,?,?,?
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {06401E14-2D8B-4F21-AEF7-BDBD02C9C408}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Find and save plan text
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
LKUP - Look up query plans on target server | Looks up values in a reference dataset by using exact matching. | ComponentMetaDataCollection
ODC - Save known plans to warehouse | Executes an SQL command for each row in a dataset. | ComponentMetaDataCollection
ODS - Get all plan handles without saved plan | OLE DB Source | ComponentMetaDataCollection
RC - Identified query plans count | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Unidentified query plans count | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Unknown query plans count | Counts the rows in a dataset. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Lookup Match Output |  | PathCollection
Lookup No Match Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
SourceSqlQuery |  | Variables
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables
SSIS diagram is missing


Package element

Package element: LKUP - Look up query plans on target server

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EDED6488-9C19-496D-9F1D-99E1DB55AF77}
ContactInfo | Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5
Description | Looks up values in a reference dataset by using exact matching.
ID | 2
IdentificationString | LKUP - Look up query plans on target server
IsDefaultLocale | True
LocaleID | English (United States)
Name | LKUP - Look up query plans on target server
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 6

Collapse image Elements

Name | Description | Type
SqlCommand | Specifies the SQL statement that generates the lookup table. | CustomPropertyCollection
SqlCommandParam | Specifies a SQL statement that uses parameters to generate the lookup table. | CustomPropertyCollection
ConnectionType | Specifies the type of connection used to access the reference dataset. | CustomPropertyCollection
CacheType | Specifies the cache type of the lookup table. | CustomPropertyCollection
NoMatchBehavior | Specifies how the Lookup transformation handles rows without matching entries in the reference data set. | CustomPropertyCollection
NoMatchCachePercentage | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset. | CustomPropertyCollection
MaxMemoryUsage | Maximum Memory Usage for Reference Cache on a 32 bit platform. | CustomPropertyCollection
MaxMemoryUsage64 | Maximum Memory Usage for Reference Cache on a 64 bit platform. | CustomPropertyCollection
ReferenceMetadataXml | Indicates whether to reference metadata in an XML format. | CustomPropertyCollection
ParameterMap | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
TreatDuplicateKeysAsError | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used. | CustomPropertyCollection
Lookup Input |  | InputCollection
Lookup Match Output |  | OutputCollection
Lookup No Match Output | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output." | OutputCollection
Lookup Error Output |  | OutputCollection
OleDbConnection | Connection manager used to access lookup data. | RuntimeConnectionCollection


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the SQL statement that generates the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 3
IdentificationString | LKUP - Look up query plans on target server.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | [dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?


Package element

Package element: SqlCommandParam

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies a SQL statement that uses parameters to generate the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 4
IdentificationString | LKUP - Look up query plans on target server.Properties[SqlCommandParam]
Name | SqlCommandParam
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | [dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?


Package element

Package element: ConnectionType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of connection used to access the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 5
IdentificationString | LKUP - Look up query plans on target server.Properties[ConnectionType]
Name | ConnectionType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupConnectionType
UITypeEditor |
Value | 0


Package element

Package element: CacheType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the cache type of the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | LKUP - Look up query plans on target server.Properties[CacheType]
Name | CacheType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | CacheType
UITypeEditor |
Value | 2


Package element

Package element: NoMatchBehavior

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies how the Lookup transformation handles rows without matching entries in the reference data set.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | LKUP - Look up query plans on target server.Properties[NoMatchBehavior]
Name | NoMatchBehavior
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupNoMatchBehavior
UITypeEditor |
Value | 1


Package element

Package element: NoMatchCachePercentage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 8
IdentificationString | LKUP - Look up query plans on target server.Properties[NoMatchCachePercentage]
Name | NoMatchCachePercentage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: MaxMemoryUsage

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 32 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 9
IdentificationString | LKUP - Look up query plans on target server.Properties[MaxMemoryUsage]
Name | MaxMemoryUsage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 25


Package element

Package element: MaxMemoryUsage64

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 64 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 10
IdentificationString | LKUP - Look up query plans on target server.Properties[MaxMemoryUsage64]
Name | MaxMemoryUsage64
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 25


Package element

Package element: ReferenceMetadataXml

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether to reference metadata in an XML format.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | LKUP - Look up query plans on target server.Properties[ReferenceMetadataXml]
Name | ReferenceMetadataXml
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | <referenceMetadata><referenceColumns><referenceColumn name="plan_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_start_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_end_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="query_plan" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata>


Package element

Package element: ParameterMap

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | LKUP - Look up query plans on target server.Properties[ParameterMap]
Name | ParameterMap
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | #93;#94;#95;


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | LKUP - Look up query plans on target server.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: TreatDuplicateKeysAsError

Collapse image Properties

Name | Value
ContainsID | False
Description | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | LKUP - Look up query plans on target server.Properties[TreatDuplicateKeysAsError]
Name | TreatDuplicateKeysAsError
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: Lookup Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 16
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input]
IsAttached | True
IsSorted | False
Name | Lookup Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_handle |  | InputColumnCollection


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 17
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 94
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
JoinToReferenceColumn | Specifies the column in the reference table that a column joins. | CustomPropertyCollection
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: JoinToReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table that a column joins.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_start_offset].Properties[JoinToReferenceColumn]
Name | JoinToReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | statement_start_offset


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_start_offset].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 20
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 95
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
JoinToReferenceColumn | Specifies the column in the reference table that a column joins. | CustomPropertyCollection
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: JoinToReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table that a column joins.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 21
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_end_offset].Properties[JoinToReferenceColumn]
Name | JoinToReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | statement_end_offset


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_end_offset].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 23
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 93
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
JoinToReferenceColumn | Specifies the column in the reference table that a column joins. | CustomPropertyCollection
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: JoinToReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table that a column joins.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 24
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[plan_handle].Properties[JoinToReferenceColumn]
Name | JoinToReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | plan_handle


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 25
IdentificationString | LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[plan_handle].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: Lookup Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation | Lookup
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 26
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Lookup Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
database_id |  | OutputColumnCollection
object_id |  | OutputColumnCollection
object_name |  | OutputColumnCollection
query_plan |  | OutputColumnCollection


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 27
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]
Length | 0
LineageID | 27
MappedColumnID | 0
Name | database_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 28
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | database_id


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 29
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]
Length | 0
LineageID | 29
MappedColumnID | 0
Name | object_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 30
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | object_id


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 31
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]
Length | 128
LineageID | 31
MappedColumnID | 0
Name | object_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 32
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | object_name


Package element

Package element: query_plan

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 33
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]
Length | 0
LineageID | 33
MappedColumnID | 0
Name | query_plan
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 34
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | query_plan


Package element

Package element: Lookup No Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 35
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup No Match Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Lookup No Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Lookup Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 36
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Lookup Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 37
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorCode]
Length | 0
LineageID | 37
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 38
IdentificationString | LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 38
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {92804B88-CB2F-4FEE-8EFF-64901F67CBBB}
Description | Connection manager used to access lookup data.
ID | 15
IdentificationString | LKUP - Look up query plans on target server.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODC - Save known plans to warehouse

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {97720936-CE0C-4D46-8CEC-89977421806C}
ContactInfo | OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Executes an SQL command for each row in a dataset.
ID | 39
IdentificationString | ODC - Save known plans to warehouse
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODC - Save known plans to warehouse
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 2

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
OLE DB Command Input |  | InputCollection
OLE DB Command Output |  | OutputCollection
OLE DB Command Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 40
IdentificationString | ODC - Save known plans to warehouse.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 41
IdentificationString | ODC - Save known plans to warehouse.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | EXEC snapshots.sp_update_query_plan ?,?,?,?,?,?,?,?,?,?


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 42
IdentificationString | ODC - Save known plans to warehouse.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: OLE DB Command Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Command Execution
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 44
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]
IsAttached | True
IsSorted | False
Name | OLE DB Command Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
@source_id |  | ExternalMetadataColumnCollection
@sql_handle |  | ExternalMetadataColumnCollection
@plan_handle |  | ExternalMetadataColumnCollection
@statement_start_offset |  | ExternalMetadataColumnCollection
@statement_end_offset |  | ExternalMetadataColumnCollection
@plan_generation_num |  | ExternalMetadataColumnCollection
@database_id |  | ExternalMetadataColumnCollection
@object_id |  | ExternalMetadataColumnCollection
@object_name |  | ExternalMetadataColumnCollection
@query_plan |  | ExternalMetadataColumnCollection
source_id |  | InputColumnCollection
sql_handle |  | InputColumnCollection
plan_handle |  | InputColumnCollection
statement_start_offset |  | InputColumnCollection
statement_end_offset |  | InputColumnCollection
plan_generation_num |  | InputColumnCollection
database_id |  | InputColumnCollection
object_id |  | InputColumnCollection
object_name |  | InputColumnCollection
query_plan |  | InputColumnCollection


Package element

Package element: @source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 55
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]
Length | 0
MappedColumnID | 0
Name | @source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 56
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 57
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]
Length | 64
MappedColumnID | 0
Name | @sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 58
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 59
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle]
Length | 64
MappedColumnID | 0
Name | @plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 60
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 61
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset]
Length | 0
MappedColumnID | 0
Name | @statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 62
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 63
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset]
Length | 0
MappedColumnID | 0
Name | @statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 64
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 65
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num]
Length | 0
MappedColumnID | 0
Name | @plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 66
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @database_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 67
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]
Length | 0
MappedColumnID | 0
Name | @database_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 68
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @object_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 69
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]
Length | 0
MappedColumnID | 0
Name | @object_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 70
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 71
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]
Length | 128
MappedColumnID | 0
Name | @object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 72
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @query_plan

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 73
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan]
Length | 0
MappedColumnID | 0
Name | @query_plan
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 74
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 193


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 55
ID | 45
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[source_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 91
MappedColumnID | 0
Name | source_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 57
ID | 46
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 92
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 59
ID | 47
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 93
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 61
ID | 48
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_start_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 94
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 63
ID | 49
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_end_offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 95
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 65
ID | 50
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_generation_num]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 96
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all plan handles without saved plan
UsageType | UT_READONLY


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 67
ID | 51
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[database_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 27
MappedColumnID | 0
Name | database_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query plans on target server
UsageType | UT_READONLY


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 69
ID | 52
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 29
MappedColumnID | 0
Name | object_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query plans on target server
UsageType | UT_READONLY


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 71
ID | 53
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 128
LineageID | 31
MappedColumnID | 0
Name | object_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query plans on target server
UsageType | UT_READONLY


Package element

Package element: query_plan

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 73
ID | 54
IdentificationString | ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[query_plan]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 33
MappedColumnID | 0
Name | query_plan
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query plans on target server
UsageType | UT_READONLY


Package element

Package element: OLE DB Command Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 75
IdentificationString | ODC - Save known plans to warehouse.Outputs[OLE DB Command Output]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | OLE DB Command Output
ObjectType | OT_OUTPUT
SynchronousInputID | 44
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OLE DB Command Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 76
IdentificationString | ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Command Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 44
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 77
IdentificationString | ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]
Length | 0
LineageID | 77
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 78
IdentificationString | ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 78
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 43
IdentificationString | ODC - Save known plans to warehouse.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODS - Get all plan handles without saved plan

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 79
IdentificationString | ODS - Get all plan handles without saved plan
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Get all plan handles without saved plan
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 80
IdentificationString | ODS - Get all plan handles without saved plan.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 81
IdentificationString | ODS - Get all plan handles without saved plan.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 82
IdentificationString | ODS - Get all plan handles without saved plan.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 83
IdentificationString | ODS - Get all plan handles without saved plan.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 84
IdentificationString | ODS - Get all plan handles without saved plan.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SourceSqlQuery


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 85
IdentificationString | ODS - Get all plan handles without saved plan.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 86
IdentificationString | ODS - Get all plan handles without saved plan.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 87
IdentificationString | ODS - Get all plan handles without saved plan.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 88
IdentificationString | ODS - Get all plan handles without saved plan.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 90
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | ExternalMetadataColumnCollection
sql_handle |  | ExternalMetadataColumnCollection
plan_handle |  | ExternalMetadataColumnCollection
statement_start_offset |  | ExternalMetadataColumnCollection
statement_end_offset |  | ExternalMetadataColumnCollection
plan_generation_num |  | ExternalMetadataColumnCollection
source_id |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 97
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[source_id]
Length | 0
MappedColumnID | 0
Name | source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 98
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 99
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]
Length | 64
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 100
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]
Length | 0
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 101
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]
Length | 0
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 102
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]
Length | 0
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 97
ID | 91
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]
Length | 0
LineageID | 91
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 98
ID | 92
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]
Length | 64
LineageID | 92
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 99
ID | 93
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]
Length | 64
LineageID | 93
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 100
ID | 94
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]
Length | 0
LineageID | 94
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 101
ID | 95
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]
Length | 0
LineageID | 95
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 102
ID | 96
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]
Length | 0
LineageID | 96
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 103
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
plan_handle |  | OutputColumnCollection
statement_start_offset |  | OutputColumnCollection
statement_end_offset |  | OutputColumnCollection
plan_generation_num |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 104
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[source_id]
Length | 0
LineageID | 104
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 105
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[sql_handle]
Length | 64
LineageID | 105
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 106
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_handle]
Length | 64
LineageID | 106
MappedColumnID | 0
Name | plan_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_start_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 107
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]
Length | 0
LineageID | 107
MappedColumnID | 0
Name | statement_start_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: statement_end_offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 108
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]
Length | 0
LineageID | 108
MappedColumnID | 0
Name | statement_end_offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: plan_generation_num

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 109
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]
Length | 0
LineageID | 109
MappedColumnID | 0
Name | plan_generation_num
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 110
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 110
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 111
IdentificationString | ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 111
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 89
IdentificationString | ODS - Get all plan handles without saved plan.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RC - Identified query plans count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 112
IdentificationString | RC - Identified query plans count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Identified query plans count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 113
IdentificationString | RC - Identified query plans count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlPlanUpdateRowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 114
IdentificationString | RC - Identified query plans count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 115
IdentificationString | RC - Identified query plans count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 114
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Unidentified query plans count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 116
IdentificationString | RC - Unidentified query plans count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Unidentified query plans count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 117
IdentificationString | RC - Unidentified query plans count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlPlanUpdateRowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 118
IdentificationString | RC - Unidentified query plans count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 119
IdentificationString | RC - Unidentified query plans count.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 118
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Unknown query plans count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 120
IdentificationString | RC - Unknown query plans count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Unknown query plans count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 121
IdentificationString | RC - Unknown query plans count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlPlanUpdateRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 122
IdentificationString | RC - Unknown query plans count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 123
IdentificationString | RC - Unknown query plans count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 122
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Lookup Match Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Lookup Match Output
ObjectType | OT_PATH
StartPoint | Lookup Match Output


Package element

Package element: Lookup No Match Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Lookup No Match Output
ObjectType | OT_PATH
StartPoint | Lookup No Match Output


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Command Input
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: SourceSqlQuery

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = " + (DT_WSTR,50) @[User::SourceId]
IncludeInDebugDump | False
Name | SourceSqlQuery
Namespace | User
QualifiedName | User::SourceSqlQuery
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = 1
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Variables[User::SourceSqlQuery]


Package element

Package element: DFT - Find and save sql text

Collapse image Properties

Name | Value
[LKUP - Look up query text on target server].[SqlCommand] | [dbo].[sp_syscollector_sql_text_lookup] ?
[LKUP - Look up query text on target server].[SqlCommandParam] | [dbo].[sp_syscollector_sql_text_lookup] ?
[ODS - Save query text to warehouse].[SqlCommand] | EXEC snapshots.sp_update_query_text ?, ?, ?, ?, ?, ?
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {A8B89CFB-EAB7-418D-ABA6-B0653CFF73B2}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | DFT - Find and save sql text
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
LKUP - Look up query text on target server | Looks up values in a reference dataset by using exact matching. | ComponentMetaDataCollection
ODS - Get all sql handles without saved sql text | OLE DB Source | ComponentMetaDataCollection
ODS - Save query text to warehouse | Executes an SQL command for each row in a dataset. | ComponentMetaDataCollection
RC - Identified query text count | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Unidentified query text count | Counts the rows in a dataset. | ComponentMetaDataCollection
RC - Unknown query text count | Counts the rows in a dataset. | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Lookup Match Output |  | PathCollection
Lookup No Match Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
SourceSqlQuery |  | Variables
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables
SSIS diagram is missing


Package element

Package element: LKUP - Look up query text on target server

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EDED6488-9C19-496D-9F1D-99E1DB55AF77}
ContactInfo | Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5
Description | Looks up values in a reference dataset by using exact matching.
ID | 2
IdentificationString | LKUP - Look up query text on target server
IsDefaultLocale | True
LocaleID | English (United States)
Name | LKUP - Look up query text on target server
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 6

Collapse image Elements

Name | Description | Type
SqlCommand | Specifies the SQL statement that generates the lookup table. | CustomPropertyCollection
SqlCommandParam | Specifies a SQL statement that uses parameters to generate the lookup table. | CustomPropertyCollection
ConnectionType | Specifies the type of connection used to access the reference dataset. | CustomPropertyCollection
CacheType | Specifies the cache type of the lookup table. | CustomPropertyCollection
NoMatchBehavior | Specifies how the Lookup transformation handles rows without matching entries in the reference data set. | CustomPropertyCollection
NoMatchCachePercentage | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset. | CustomPropertyCollection
MaxMemoryUsage | Maximum Memory Usage for Reference Cache on a 32 bit platform. | CustomPropertyCollection
MaxMemoryUsage64 | Maximum Memory Usage for Reference Cache on a 64 bit platform. | CustomPropertyCollection
ReferenceMetadataXml | Indicates whether to reference metadata in an XML format. | CustomPropertyCollection
ParameterMap | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
TreatDuplicateKeysAsError | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used. | CustomPropertyCollection
Lookup Input |  | InputCollection
Lookup Match Output |  | OutputCollection
Lookup No Match Output | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output." | OutputCollection
Lookup Error Output |  | OutputCollection
OleDbConnection | Connection manager used to access lookup data. | RuntimeConnectionCollection


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the SQL statement that generates the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 3
IdentificationString | LKUP - Look up query text on target server.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | [dbo].[sp_syscollector_sql_text_lookup] ?


Package element

Package element: SqlCommandParam

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies a SQL statement that uses parameters to generate the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 4
IdentificationString | LKUP - Look up query text on target server.Properties[SqlCommandParam]
Name | SqlCommandParam
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | [dbo].[sp_syscollector_sql_text_lookup] ?


Package element

Package element: ConnectionType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of connection used to access the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 5
IdentificationString | LKUP - Look up query text on target server.Properties[ConnectionType]
Name | ConnectionType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupConnectionType
UITypeEditor |
Value | 0


Package element

Package element: CacheType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the cache type of the lookup table.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | LKUP - Look up query text on target server.Properties[CacheType]
Name | CacheType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | CacheType
UITypeEditor |
Value | 2


Package element

Package element: NoMatchBehavior

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies how the Lookup transformation handles rows without matching entries in the reference data set.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | LKUP - Look up query text on target server.Properties[NoMatchBehavior]
Name | NoMatchBehavior
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | LookupNoMatchBehavior
UITypeEditor |
Value | 1


Package element

Package element: NoMatchCachePercentage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 8
IdentificationString | LKUP - Look up query text on target server.Properties[NoMatchCachePercentage]
Name | NoMatchCachePercentage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: MaxMemoryUsage

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 32 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 9
IdentificationString | LKUP - Look up query text on target server.Properties[MaxMemoryUsage]
Name | MaxMemoryUsage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 25


Package element

Package element: MaxMemoryUsage64

Collapse image Properties

Name | Value
ContainsID | False
Description | Maximum Memory Usage for Reference Cache on a 64 bit platform.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 10
IdentificationString | LKUP - Look up query text on target server.Properties[MaxMemoryUsage64]
Name | MaxMemoryUsage64
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 25


Package element

Package element: ReferenceMetadataXml

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether to reference metadata in an XML format.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | LKUP - Look up query text on target server.Properties[ReferenceMetadataXml]
Name | ReferenceMetadataXml
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | <referenceMetadata><referenceColumns><referenceColumn name="sql_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="sql_text" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata>


Package element

Package element: ParameterMap

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | LKUP - Look up query text on target server.Properties[ParameterMap]
Name | ParameterMap
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | #46;


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | LKUP - Look up query text on target server.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: TreatDuplicateKeysAsError

Collapse image Properties

Name | Value
ContainsID | False
Description | Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | LKUP - Look up query text on target server.Properties[TreatDuplicateKeysAsError]
Name | TreatDuplicateKeysAsError
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: Lookup Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 16
IdentificationString | LKUP - Look up query text on target server.Inputs[Lookup Input]
IsAttached | True
IsSorted | False
Name | Lookup Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
sql_handle |  | InputColumnCollection


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 17
IdentificationString | LKUP - Look up query text on target server.Inputs[Lookup Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 46
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all sql handles without saved sql text
UsageType | UT_READONLY

Collapse image Elements

Name | Description | Type
JoinToReferenceColumn | Specifies the column in the reference table that a column joins. | CustomPropertyCollection
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: JoinToReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table that a column joins.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | LKUP - Look up query text on target server.Inputs[Lookup Input].Columns[sql_handle].Properties[JoinToReferenceColumn]
Name | JoinToReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | sql_handle


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | LKUP - Look up query text on target server.Inputs[Lookup Input].Columns[sql_handle].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: Lookup Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation | Lookup
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 20
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Lookup Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
database_id |  | OutputColumnCollection
object_id |  | OutputColumnCollection
object_name |  | OutputColumnCollection
sql_text |  | OutputColumnCollection


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 21
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]
Length | 0
LineageID | 21
MappedColumnID | 0
Name | database_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | database_id


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 23
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]
Length | 0
LineageID | 23
MappedColumnID | 0
Name | object_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 24
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | object_id


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 25
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]
Length | 128
LineageID | 25
MappedColumnID | 0
Name | object_name
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 26
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | object_name


Package element

Package element: sql_text

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation | Copy Column
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 27
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]
Length | 0
LineageID | 27
MappedColumnID | 0
Name | sql_text
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
CopyFromReferenceColumn | Specifies the column in the reference table from which a column is copied. | CustomPropertyCollection


Package element

Package element: CopyFromReferenceColumn

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column in the reference table from which a column is copied.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 28
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text].Properties[CopyFromReferenceColumn]
Name | CopyFromReferenceColumn
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | sql_text


Package element

Package element: Lookup No Match Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 29
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup No Match Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Lookup No Match Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Lookup Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 30
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Lookup Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 16
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 31
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorCode]
Length | 0
LineageID | 31
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 32
IdentificationString | LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 32
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {92804B88-CB2F-4FEE-8EFF-64901F67CBBB}
Description | Connection manager used to access lookup data.
ID | 15
IdentificationString | LKUP - Look up query text on target server.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODS - Get all sql handles without saved sql text

CollapseAll image

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 33
IdentificationString | ODS - Get all sql handles without saved sql text
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Get all sql handles without saved sql text
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 34
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 35
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 36
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 37
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | snapshots.sp_get_unknown_query_text @source_id = 3


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 38
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SourceSqlQuery


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 39
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 40
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 41
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 42
IdentificationString | ODS - Get all sql handles without saved sql text.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 44
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | ExternalMetadataColumnCollection
sql_handle |  | ExternalMetadataColumnCollection
source_id |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 47
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[source_id]
Length | 0
MappedColumnID | 0
Name | source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 48
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]
Length | 64
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 47
ID | 45
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]
Length | 0
LineageID | 45
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 48
ID | 46
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]
Length | 64
LineageID | 46
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 49
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
source_id |  | OutputColumnCollection
sql_handle |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 50
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[source_id]
Length | 0
LineageID | 50
MappedColumnID | 0
Name | source_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 51
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[sql_handle]
Length | 64
LineageID | 51
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 52
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 52
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 53
IdentificationString | ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 53
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 43
IdentificationString | ODS - Get all sql handles without saved sql text.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODS - Save query text to warehouse

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {97720936-CE0C-4D46-8CEC-89977421806C}
ContactInfo | OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Executes an SQL command for each row in a dataset.
ID | 54
IdentificationString | ODS - Save query text to warehouse
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODS - Save query text to warehouse
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 2

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
OLE DB Command Input |  | InputCollection
OLE DB Command Output |  | OutputCollection
OLE DB Command Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 55
IdentificationString | ODS - Save query text to warehouse.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 56
IdentificationString | ODS - Save query text to warehouse.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | EXEC snapshots.sp_update_query_text ?, ?, ?, ?, ?, ?


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 57
IdentificationString | ODS - Save query text to warehouse.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: OLE DB Command Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Command Execution
ErrorRowDisposition | RD_IgnoreFailure
HasSideEffects | True
ID | 59
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input]
IsAttached | True
IsSorted | False
Name | OLE DB Command Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
@sql_handle |  | ExternalMetadataColumnCollection
@source_id |  | ExternalMetadataColumnCollection
@database_id |  | ExternalMetadataColumnCollection
@object_id |  | ExternalMetadataColumnCollection
@object_name |  | ExternalMetadataColumnCollection
@sql_text |  | ExternalMetadataColumnCollection
sql_handle |  | InputColumnCollection
source_id |  | InputColumnCollection
database_id |  | InputColumnCollection
object_id |  | InputColumnCollection
object_name |  | InputColumnCollection
sql_text |  | InputColumnCollection


Package element

Package element: @sql_handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 66
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]
Length | 64
MappedColumnID | 0
Name | @sql_handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 67
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @source_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 68
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]
Length | 0
MappedColumnID | 0
Name | @source_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 69
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @database_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I2
Description |
ID | 70
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]
Length | 0
MappedColumnID | 0
Name | @database_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 71
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @object_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 72
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]
Length | 0
MappedColumnID | 0
Name | @object_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 73
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @object_name

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 74
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]
Length | 128
MappedColumnID | 0
Name | @object_name
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 75
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @sql_text

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 76
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text]
Length | 0
MappedColumnID | 0
Name | @sql_text
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 77
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 193


Package element

Package element: sql_handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 66
ID | 60
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 46
MappedColumnID | 0
Name | sql_handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all sql handles without saved sql text
UsageType | UT_READONLY


Package element

Package element: source_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 68
ID | 61
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[source_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 45
MappedColumnID | 0
Name | source_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODS - Get all sql handles without saved sql text
UsageType | UT_READONLY


Package element

Package element: database_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I2
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 70
ID | 62
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[database_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 21
MappedColumnID | 0
Name | database_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query text on target server
UsageType | UT_READONLY


Package element

Package element: object_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 72
ID | 63
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 23
MappedColumnID | 0
Name | object_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query text on target server
UsageType | UT_READONLY


Package element

Package element: object_name

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 74
ID | 64
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_name]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 128
LineageID | 25
MappedColumnID | 0
Name | object_name
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query text on target server
UsageType | UT_READONLY


Package element

Package element: sql_text

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 76
ID | 65
IdentificationString | ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_text]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 27
MappedColumnID | 0
Name | sql_text
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | LKUP - Look up query text on target server
UsageType | UT_READONLY


Package element

Package element: OLE DB Command Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 78
IdentificationString | ODS - Save query text to warehouse.Outputs[OLE DB Command Output]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | OLE DB Command Output
ObjectType | OT_OUTPUT
SynchronousInputID | 59
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OLE DB Command Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 79
IdentificationString | ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Command Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 59
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 80
IdentificationString | ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]
Length | 0
LineageID | 80
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 81
IdentificationString | ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 81
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6638AF14-9580-4671-8B14-1E28ADAD9B72}
Description | The OLE DB runtime connection used to access the database.
ID | 58
IdentificationString | ODS - Save query text to warehouse.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: RC - Identified query text count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft Sql Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 82
IdentificationString | RC - Identified query text count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Identified query text count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 83
IdentificationString | RC - Identified query text count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlTextUpdateRowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 84
IdentificationString | RC - Identified query text count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 85
IdentificationString | RC - Identified query text count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 84
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Unidentified query text count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 86
IdentificationString | RC - Unidentified query text count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Unidentified query text count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 87
IdentificationString | RC - Unidentified query text count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlTextUpdateRowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 88
IdentificationString | RC - Unidentified query text count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 89
IdentificationString | RC - Unidentified query text count.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 88
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RC - Unknown query text count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 90
IdentificationString | RC - Unknown query text count
IsDefaultLocale | True
LocaleID | English (United States)
Name | RC - Unknown query text count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 91
IdentificationString | RC - Unknown query text count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::SqlTextUpdateRowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 92
IdentificationString | RC - Unknown query text count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 93
IdentificationString | RC - Unknown query text count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 92
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SourceSqlQuery

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | "EXEC [snapshots].[sp_get_unknown_query_text] @source_id = " + (DT_WSTR,50) @[User::SourceId]
IncludeInDebugDump | False
Name | SourceSqlQuery
Namespace | User
QualifiedName | User::SourceSqlQuery
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | EXEC [snapshots].[sp_get_unknown_query_text] @source_id = 1
VariablePath | \Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Variables[User::SourceSqlQuery]


Package element

Package element: FAT - Check Interesting Queries Last Snapshot exists

CollapseAll image

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.FileAccessTask.4
DebugMode | False
DelayValidation | False
Description | File Access Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FilePath | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {C2C219D8-0B35-4D01-A732-72489975921A}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Mode | 0
Name | FAT - Check Interesting Queries Last Snapshot exists
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FilePath |  | Expressions
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: FilePath

Collapse image Properties

Name | Value
Expression | @[User::InterestingQueriesLastSnapshotFileName]
Name | FilePath


Package element

Package element: FST - Rename Current Snapshot File as Last Snapshot File

CollapseAll image

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | File System Task
Destination | User::InterestingQueriesLastSnapshotFileName
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {6CF195E1-8563-46F2-9500-A52AEB3306F0}
IsDefaultLocaleID | True
IsDestinationPathVariable | True
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | FST - Rename Current Snapshot File as Last Snapshot File
Operation | 3
OperationName |
OverwriteDestinationFile | True
PreservedAttributes | 0
Source | User::InterestingQueriesLastSnapshotFileNameOutput
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Log stats for Interesting Queries

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {6F36C159-874B-4351-A291-8AC691098328}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log stats for Interesting Queries
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onstatsupdate (?, N'query_stats upload', ?, ?, NULL, 0) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Log stats for sql plan

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {90BFBAF6-A08D-4BCB-B1E0-EE493CAA80E0}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log stats for sql plan
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql plan upload', ?, ?, ?, 0) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Log stats for sql text

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {02284097-190E-4435-84BE-F5E14956A1F0}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SQL - Log stats for sql text
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql text upload', ?, ?, ?, 0) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
InterestingQueriesRowCountIn |  | Variables
InterestingQueriesRowCountOut |  | Variables
SqlPlanRowCountError |  | Variables
SqlPlanRowCountIn |  | Variables
SqlPlanRowCountOut |  | Variables
SqlPlanUpdateRowCountError |  | Variables
SqlPlanUpdateRowCountIn |  | Variables
SqlPlanUpdateRowCountOut |  | Variables
SqlTextRowCountError |  | Variables
SqlTextRowCountIn |  | Variables
SqlTextRowCountOut |  | Variables
SqlTextUpdateRowCountError |  | Variables
SqlTextUpdateRowCountIn |  | Variables
SqlTextUpdateRowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Find and save sql text
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {B8D3087D-11C1-4B00-997B-6067A6579AEF}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | FST - Rename Current Snapshot File as Last Snapshot File
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Create Interesting Queries Upload Batch
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {B5171C94-F537-4E05-B026-6F1733778AED}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | FAT - Check Interesting Queries Last Snapshot exists
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Find and save plan text
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {188F2E10-1D32-4CB6-8F1B-39300F9DC592}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | DFT - Find and save sql text
Value | Success


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log stats for Interesting Queries
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel]>=1
ID | {0CA4D80A-739D-48A7-9F2B-A2F18810434B}
LogicalAnd | False
Name | Constraint 3
PrecedenceExecutable | DFT - Find and save plan text
Value | Completion


Package element

Package element: Constraint 5

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log stats for Interesting Queries
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel]>=1
ID | {80BB971B-FD09-4237-8119-D90654587E64}
LogicalAnd | False
Name | Constraint 5
PrecedenceExecutable | DFT - Create Interesting Queries Last Snapshot
Value | Completion


Package element

Package element: Constraint 6

Collapse image Properties

Name | Value
ConstrainedExecutable | FST - Rename Current Snapshot File as Last Snapshot File
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {CCEACE44-4FBD-4796-90ED-B1AE560BE3B4}
LogicalAnd | True
Name | Constraint 6
PrecedenceExecutable | DFT - Create Interesting Queries Upload Batch
Value | Success


Package element

Package element: Constraint 7

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log stats for sql plan
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {84EC6C5C-B6F8-41FC-8FC3-12E6B722BFFF}
LogicalAnd | True
Name | Constraint 7
PrecedenceExecutable | SQL - Log stats for Interesting Queries
Value | Completion


Package element

Package element: Constraint 8

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log stats for sql text
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {D7CB327F-A818-4D93-855C-11473FBE4AEC}
LogicalAnd | True
Name | Constraint 8
PrecedenceExecutable | SQL - Log stats for sql plan
Value | Completion


Package element

Package element: Last Snapshot Missing

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Create Interesting Queries Last Snapshot
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | False
Expression |
ID | {FBDCF942-3540-45E2-AAD6-A425973C01E8}
LogicalAnd | True
Name | Last Snapshot Missing
PrecedenceExecutable | FAT - Check Interesting Queries Last Snapshot exists
Value | Failure


Package element

Package element: SEQ - Rename Collection Cache File

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | False
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {8C70D6CD-D74A-4349-BB8A-8917BC91A5B6}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SEQ - Rename Collection Cache File
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FST - Rename Cache File | File System Task | Executables
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: FST - Rename Cache File

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | File System Task
Destination | User::CollectionCacheFileNameOutput
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {C5533AC9-9896-43CA-A46C-DD7D9A396B12}
IsDefaultLocaleID | True
IsDestinationPathVariable | True
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | FST - Rename Cache File
Operation | 3
OperationName |
OverwriteDestinationFile | True
PreservedAttributes | 0
Source | User::CollectionCacheFileName
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
SyncRoot |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SyncRoot

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | SyncRoot
Namespace | User
QualifiedName | User::SyncRoot
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | QueryActivityLock
VariablePath | \Package\SEQ - Rename Collection Cache File.Variables[User::SyncRoot]


Package element

Package element: SQL - Get SnapshotId

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {DD0170D6-186A-437B-8F7D-E909F437A16F}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get SnapshotId
ResultSetType | 1
SqlStatementSource
{call [core].[sp_create_snapshot](?, ?, ?, ?, ?, ?)}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package element

Package element: SQL - Get SourceId

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {E05B5850-7B98-4C33-95AC-EC191C7334F5}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get SourceId
ResultSetType | 1
SqlStatementSource
{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionCacheFileName | Stores snapshots of dm_exec_requests | Variables
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload. | Variables
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
InterestingQueries_HighCpuUsage |  | Variables
InterestingQueries_HighIoCount |  | Variables
InterestingQueries_HighMemoryUsage |  | Variables
InterestingQueries_HighTransactionCount |  | Variables
InterestingQueries_LargeResultset |  | Variables
InterestingQueries_LongRunningRequest |  | Variables
InterestingQueries_LongWaitingRequest |  | Variables
InterestingQueriesCount |  | Variables
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package. | Variables
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats | Variables
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection. | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
SnapshotId |  | Variables
SnapshotQueryStatsQuery |  | Variables
SourceId |  | Variables
TargetConnectionString |  | Variables
TopThreshold |  | Variables


Package

Package: QueryActivityUpload

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityUpload

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityUpload

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: QueryActivityUpload

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 12 |
Constraint 3 |
Constraint 6 |
Constraint 7 |
Constraint 8 |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | CWM - Remove Upload Snapshots Older Than CacheWindow
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {6FDD2D34-4BAD-42B5-9E71-E135532FB590}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | SEQ - Rename Collection Cache File
Value | Success


Package element

Package element: Constraint 12

Collapse image Properties

Name | Value
ConstrainedExecutable | SEQ - Rename Collection Cache File
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {54C3C3CA-67A4-4B87-A5CE-A8679A5E5116}
LogicalAnd | True
Name | Constraint 12
PrecedenceExecutable | FAT - Check Cache File Exists
Value | Success


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Get SnapshotId
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {AAA44A20-51D1-42FE-9656-41A1DBAC347A}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | SQL - Get SourceId
Value | Success


Package element

Package element: Constraint 6

Collapse image Properties

Name | Value
ConstrainedExecutable | SEQ - Capture and analyze query statistics and query plan and text
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {1B9D6AD9-FDDE-4443-AA9B-2688E595DC2B}
LogicalAnd | True
Name | Constraint 6
PrecedenceExecutable | SQL - Get SnapshotId
Value | Success


Package element

Package element: Constraint 7

Collapse image Properties

Name | Value
ConstrainedExecutable | SEQ - Capture and analyze query statistics and query plan and text
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {53381062-0490-4018-98B1-EF24A1C0E052}
LogicalAnd | True
Name | Constraint 7
PrecedenceExecutable | CWM - Remove Upload Snapshots Older Than CacheWindow
Value | Success


Package element

Package element: Constraint 8

Collapse image Properties

Name | Value
ConstrainedExecutable | FEF - For each collected cache file try upload
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {4D376995-07A3-41A5-B3EE-01FA251AA113}
LogicalAnd | True
Name | Constraint 8
PrecedenceExecutable | SEQ - Capture and analyze query statistics and query plan and text
Value | Success


Package

Package: QueryActivityUpload

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionCacheFileName | Stores snapshots of dm_exec_requests
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload.
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
InterestingQueries_HighCpuUsage |
InterestingQueries_HighIoCount |
InterestingQueries_HighMemoryUsage |
InterestingQueries_HighTransactionCount |
InterestingQueries_LargeResultset |
InterestingQueries_LongRunningRequest |
InterestingQueries_LongWaitingRequest |
InterestingQueriesCount |
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package.
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection.
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotId |
SnapshotQueryStatsQuery |
SourceId |
TargetConnectionString |
TopThreshold |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="7/10/2007 4:27:11 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{833DB628-8E19-47A3-92C5-FB1779B52E76}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:ObjectName="QueryActivityUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="347" DTS:VersionGUID="{6234BEE9-C5C0-4055-846F-65A730A60CA0}">

<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>

-<DTS:ConnectionManagers>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{39FB064F-9853-4718-880F-C97853E29875}" DTS:ObjectName="ConfigConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection2]" DTS:CreationName="OLEDB" DTS:DTSID="{92804B88-CB2F-4FEE-8EFF-64901F67CBBB}" DTS:ObjectName="ConfigConnection2">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" DTS:ObjectName="MdwConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{15DDC5A3-5645-4BAA-BCC8-B0AF18FDE25D}" DTS:ObjectName="TargetConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=master;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

</DTS:ConnectionManagers>

-<DTS:Configurations>

<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C47DA731-2DE9-4003-BEEA-DC9FEC0CB4FF}" DTS:ObjectName="CacheDirectory"/>

<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{95F90B41-195A-485B-83A7-532CBE784B9B}" DTS:ObjectName="CacheWindow"/>

<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E2ABAEA8-8EDF-467A-8868-02D9DA214213}" DTS:ObjectName="InputParameters"/>

<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DE58D9D-88EC-4EF1-BC5D-198E4A4D242B}" DTS:ObjectName="MDWConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C0D122E4-3E93-4B7D-9D73-BD30523C5E1E}" DTS:ObjectName="ConfigConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EAF8B0C8-D595-4C33-996B-05EC441AD7F3}" DTS:ObjectName="TargetConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1F3E0B39-EFD8-46CB-A717-293C31799271}" DTS:ObjectName="LoopEventName"/>

<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9A80FE73-FF5C-4E2C-AD8D-33F22D356AC2}" DTS:ObjectName="ExitEventName"/>

<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1371FF37-F2B5-4FDE-B5A5-536068DF92FA}" DTS:ObjectName="CollectorTypeUID"/>

<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{82ABCEE4-E26E-4CD2-B58D-6C06867D0721}" DTS:ObjectName="CollectionSetUID"/>

<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{33F8AB16-E8C2-4E91-BD5B-8069298F752D}" DTS:ObjectName="ItemID"/>

<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C93D74BA-06D2-4D87-A4EA-D77FB294581B}" DTS:ObjectName="InstanceID"/>

<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{42BF5414-6ED3-4173-A1AE-AF65B489397D}" DTS:ObjectName="InstanceName"/>

<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{A1115DE1-DAC0-4E1D-9D41-B711F105082D}" DTS:ObjectName="LoggingLevel"/>

<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1F89599A-D740-49C6-86F3-81E31F2AC5DB}" DTS:ObjectName="LogID"/>

<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9C690C28-5612-417C-B1A7-885E173AAA83}" DTS:ObjectName="ParentLogID"/>

<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1D6E40B7-426D-48E8-9BEB-A21586CBDE14}" DTS:ObjectName="DaysUntilExpiration"/>

</DTS:Configurations>

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{07E49628-99E0-4460-9F0B-DBE28805907D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">

<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3F3D955A-0F9A-416E-A515-1204CE48AEDD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">

<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores snapshots of dm_exec_requests" DTS:DTSID="{4C986A4F-170A-45A1-839E-410F1E8E93F4}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFileName">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload." DTS:DTSID="{750F2248-3251-4890-B913-1F4B810089AE}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + @[System::ExecutionInstanceGUID] + ".temp.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFileNameOutput">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity{4F6F76C7-C0B1-4843-A5E2-293415B3D055}.temp.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Prefix for files related to dm_exec_requets collection" DTS:DTSID="{DA251B8D-03B0-45AC-AF6F-3207856FB975}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFilePrefixPattern">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF62F5F8-BEC3-4343-B835-E4DF248FF89B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">

<DTS:VariableValue DTS:DataType="8">2DC02BD6-E230-4C05-8516-4E8C0EF21F95</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{71ED53D3-47FE-4D9F-92A6-11ABBB977C9F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">

<DTS:VariableValue DTS:DataType="8">14AF3C12-38E6-4155-BD29-F33E7966BA23</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B70DF8DA-1D12-4C98-95AA-DF577D4F2161}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{81C400C8-74B8-428F-91D1-BBEDADDE50DF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">

<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CCFA1ABE-72CA-4887-BE94-31B97C475499}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">

<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0C4F2FE7-49AF-457C-BE70-748867279428}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">

<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C7CAE80E-91B3-4C58-B895-79F074CCC337}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">

<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9EB9C248-6B73-4C6A-9028-6804497A8990}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">

<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F0B8F428-BF6B-4162-89E6-8648343D10B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesCount">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package." DTS:DTSID="{1855D9D6-5694-4820-B3B6-5B4A1A53A4E1}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesLastSnapshotFileName">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores temporary copy of the most recent snapshot of dm_exec_query_stats" DTS:DTSID="{6AB778DB-F067-45EA-998D-AFF5F92365E4}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.temp.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesLastSnapshotFileNameOutput">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.temp.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Prefix for files related to dm_exec_query_stats collection." DTS:DTSID="{8318285A-D945-48DB-B745-C7F6F566BCEC}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + "_QueryStats_"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesSnapshotFileNamePrefixPattern">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{77178EEF-9088-493F-81B0-222FAFC2DCB5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighCpuUsage">

<DTS:VariableValue DTS:DataType="3">5000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{688988F2-B8CD-4016-B862-72BF28A26C66}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighIoCount">

<DTS:VariableValue DTS:DataType="3">500</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F829A6C7-E1D0-4F5A-BC99-256D75480092}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighMemoryUsage">

<DTS:VariableValue DTS:DataType="3">12800</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9591E8A2-8342-4345-A44D-11378CC0E352}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighTransactionCount">

<DTS:VariableValue DTS:DataType="3">8</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1A974E9C-D435-495B-860C-8C4444C3E213}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LargeResultset">

<DTS:VariableValue DTS:DataType="3">1000000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E8AEB8A7-2C49-4224-9DE9-68BBD915B8BE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LongRunningRequest">

<DTS:VariableValue DTS:DataType="3">25000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{45912C54-0480-417E-B67A-82873FC3E423}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LongWaitingRequest">

<DTS:VariableValue DTS:DataType="3">500</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E704315E-7219-4865-99F2-E97AC9D8D398}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">

<DTS:VariableValue DTS:DataType="3">100</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{33312621-3000-41AE-BB85-EB7315DC928C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">

<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{96B03221-F068-41EE-8ED3-783D0F66E06E}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1301DE1B-D5A1-44AA-BAC3-F172053B6B29}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D734BFC1-B87B-4283-89D6-45DBBAC19429}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">

<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8E74FC82-9E1D-4234-9CC3-1A597FB89FD2}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1E505F14-3F9D-407E-B462-601B20F27EDE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{16ED5012-857B-45A9-BF91-C14B440732F1}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotId">

<DTS:VariableValue DTS:DataType="3">200</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{772BB2B0-4FE9-4DF6-8A8E-52ED84133F83}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] " + (DT_WSTR,10) (@[User::ItemID])" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SnapshotQueryStatsQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] 100</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{146FDF3A-DC44-41E8-B463-C373ADEA494D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceId">

<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{93174E52-58FA-4C6B-9BC1-A7190ABE976D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Initial Catalog=master;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{255AA40E-7F7B-4462-97A5-1DC4A84A7475}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TopThreshold">

<DTS:VariableValue DTS:DataType="3">5</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">

<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>

-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">

<DTS:Property DTS:Name="Computer">-1</DTS:Property>

<DTS:Property DTS:Name="Operator">-1</DTS:Property>

<DTS:Property DTS:Name="SourceName">-1</DTS:Property>

<DTS:Property DTS:Name="SourceID">-1</DTS:Property>

<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>

<DTS:Property DTS:Name="MessageText">-1</DTS:Property>

<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>

</DTS:Property>

-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">

<DTS:Property DTS:Name="Computer">-1</DTS:Property>

<DTS:Property DTS:Name="Operator">-1</DTS:Property>

<DTS:Property DTS:Name="SourceName">-1</DTS:Property>

<DTS:Property DTS:Name="SourceID">-1</DTS:Property>

<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>

<DTS:Property DTS:Name="MessageText">-1</DTS:Property>

<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>

</DTS:Property>

</DTS:LoggingOptions>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:CreationName="Microsoft.CacheWindowMaintainanceTask" DTS:Description="Cache Window Maintainance Task" DTS:DTSID="{C8B1E699-7A73-4ECD-A317-B9E91002738D}" DTS:ExecutableType="Microsoft.CacheWindowMaintainanceTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:TaskContact="Cache Window Maintainance Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

<DTS:PropertyExpression DTS:Name="CacheFileNamePrefixVarName">"User::InterestingQueriesSnapshotFileNamePrefixPattern"</DTS:PropertyExpression>

-<DTS:ObjectData>

-<InnerObject>

<CacheFileNamePrefixVarName Type="8" Value="User::InterestingQueriesSnapshotFileNamePrefixPattern"/>

<CacheWindow Type="3" Value="0"/>

<CollectionSetUID Type="8" Value=""/>

<CollectorTempDir Type="8" Value=""/>

<CollectorTypeUID Type="8" Value=""/>

<ConfigConnectionString Type="8" Value=""/>

<ExitEventName Type="8" Value=""/>

<InstanceName Type="8" Value=""/>

<ItemID Type="3" Value="0"/>

<LoggingLevel Type="3" Value="0"/>

<LoopEventName Type="8" Value=""/>

<MdwConnectionString Type="8" Value=""/>

<TargetConnectionString Type="8" Value=""/>

<TargetServerVersion Type="3" Value="130"/>

<TaskDisplayName Type="8" Value="Cache Window Maintainance Task"/>

</InnerObject>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FAT - Check Cache File Exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{94132A74-FB8C-4E52-B247-D2B4FCD589D9}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:ObjectName="FAT - Check Cache File Exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:PropertyExpression DTS:Name="FilePath">@[User::CollectionCacheFileName]</DTS:PropertyExpression>

<DTS:PropertyExpression DTS:Name="Mode">0</DTS:PropertyExpression>

-<DTS:ObjectData>

-<FileAccessTask>

<Mode>0</Mode>

<FilePath>c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</FilePath>

</FileAccessTask>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{91A4B7F7-385C-47C2-AA89-08B832F71599}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For each collected cache file try upload">

-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{BB52AFAE-60A1-42A7-9C13-52B21293D219}" DTS:ObjectName="{BB52AFAE-60A1-42A7-9C13-52B21293D219}">

<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>

<DTS:PropertyExpression DTS:Name="FileSpec">@[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity*.temp.cache"</DTS:PropertyExpression>

-<DTS:ObjectData>

-<ForEachFileEnumeratorProperties>

<FEFEProperty Folder="c:\perflogs"/>

<FEFEProperty FileSpec="ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity*.temp.cache"/>

<FEFEProperty FileNameRetrievalType="0"/>

<FEFEProperty Recurse="0"/>

</ForEachFileEnumeratorProperties>

</DTS:ObjectData>

</DTS:ForEachEnumerator>

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4B66AE21-EAF9-462C-BFA2-FF90EBE034BE}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CurrentCollectionCacheFileName">

<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodePerfWH\MACIES4_MSSQL.1_{{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}}_100_QueryActivity.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AD000A5D-D997-4362-A5CB-23DE5C023D17}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCount">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{FE775FB9-E8B7-4171-9DFB-544E7CCA7809}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload collection snapshot" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id column" usesDispositions="true">

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODS - Upload snapshots into active_sessions_and_requests table" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[active_sessions_and_requests]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>

</properties>

-<connections>

<connection refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[row_id]" cachedDataType="i4" cachedName="row_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[row_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_id]" cachedDataType="i2" cachedName="session_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_id]" cachedDataType="i4" cachedName="request_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[exec_context_id]" cachedDataType="i4" cachedName="exec_context_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_blocking]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_exec_context_id]" cachedDataType="i4" cachedName="blocking_exec_context_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[scheduler_id]" cachedDataType="i4" cachedName="scheduler_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[scheduler_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[database_name]" cachedDataType="wstr" cachedLength="128" cachedName="database_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[database_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[user_id]" cachedDataType="i4" cachedName="user_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[user_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[task_state]" cachedDataType="wstr" cachedLength="10" cachedName="task_state" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[task_state]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_status]" cachedDataType="wstr" cachedLength="15" cachedName="request_status" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_status]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_status]" cachedDataType="wstr" cachedLength="15" cachedName="session_status" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_status]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[executing_managed_code]" cachedDataType="bool" cachedName="executing_managed_code" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[executing_managed_code]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_time]" cachedDataType="dbTimeStamp" cachedName="login_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_user_process]" cachedDataType="bool" cachedName="is_user_process" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_user_process]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[host_name]" cachedDataType="wstr" cachedLength="20" cachedName="host_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[host_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[program_name]" cachedDataType="wstr" cachedLength="50" cachedName="program_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[program_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_name]" cachedDataType="wstr" cachedLength="30" cachedName="login_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="wait_type" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_type]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[last_wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="last_wait_type" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[last_wait_type]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_duration_ms]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_resource]" cachedDataType="wstr" cachedLength="50" cachedName="wait_resource" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_resource]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[resource_description]" cachedDataType="wstr" cachedLength="140" cachedName="resource_description" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[resource_description]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_id]" cachedDataType="i8" cachedName="transaction_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_transaction_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_isolation_level]" cachedDataType="i2" cachedName="transaction_isolation_level" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_isolation_level]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_logical_reads]" cachedDataType="i8" cachedName="request_logical_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_reads]" cachedDataType="i8" cachedName="request_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_writes]" cachedDataType="i8" cachedName="request_writes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_start_time]" cachedDataType="dbTimeStamp" cachedName="request_start_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[memory_usage]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_cpu_time]" cachedDataType="i4" cachedName="session_cpu_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_reads]" cachedDataType="i8" cachedName="session_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_writes]" cachedDataType="i8" cachedName="session_writes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_logical_reads]" cachedDataType="i8" cachedName="session_logical_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_scheduled_time]" cachedDataType="i4" cachedName="session_total_scheduled_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_scheduled_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_elapsed_time]" cachedDataType="i4" cachedName="session_total_elapsed_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_start_time]" cachedDataType="dbTimeStamp" cachedName="session_last_request_start_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_end_time]" cachedDataType="dbTimeStamp" cachedName="session_last_request_end_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_end_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_resultsets]" cachedDataType="i4" cachedName="open_resultsets" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_resultsets]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_row_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[prev_error]" cachedDataType="i4" cachedName="prev_error" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[prev_error]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[pending_io_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[command]" cachedDataType="wstr" cachedLength="32" cachedName="command" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[command]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_time]" dataType="dbTimeStampOffset" name="login_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_start_time]" dataType="dbTimeStampOffset" name="request_start_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStampOffset" name="session_last_request_start_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStampOffset" name="session_last_request_end_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Count output rows">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCount</property>

</properties>

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read Current Upload Data" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CurrentCollectionCacheFileName</property>

</properties>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output]" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[row_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]" name="row_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]" name="session_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]" name="request_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]" name="exec_context_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]" name="blocking_session_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]" name="is_blocking"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]" name="scheduler_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]" name="database_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[user_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]" name="user_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]" name="task_state"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]" name="request_status"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]" name="session_status"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]" name="executing_managed_code"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]" name="login_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]" name="is_user_process"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]" name="host_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]" name="program_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]" name="login_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]" name="wait_type"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]" name="last_wait_type"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]" name="wait_resource"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]" name="resource_description"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]" name="transaction_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]" name="open_transaction_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]" name="request_cpu_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]" name="request_logical_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]" name="request_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]" name="request_writes"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]" name="request_start_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]" name="memory_usage"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]" name="session_cpu_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]" name="session_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]" name="session_writes"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]" name="session_logical_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" name="session_last_request_start_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" name="session_last_request_end_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]" name="open_resultsets"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]" name="session_row_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[prev_error]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]" name="prev_error"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]" name="pending_io_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[command]" length="32" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]" name="command"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Derived Column Output]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]" name="Derived Column Output" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output]"/>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Raw File Source Output]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]" name="Raw File Source Output" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output]"/>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Row Count Output 1]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\FST - Delete uploaded cache file" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{F370098D-B959-45DB-8581-AC43E7A4A5EA}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Delete uploaded cache file" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::CurrentCollectionCacheFileName" TaskIsSourceVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{CCDA711D-7E0F-481E-A1FE-AA1AEC068E6C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{call dbo.sp_syscollector_event_onpackageupdate (?)}">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{DCB25C00-0DCE-4376-9794-23A25E011403}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'active_sessions_and_requests upload', ?, ?, NULL, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{4AAAB275-D665-406D-876D-23789851D864}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{FC05D77F-6096-43D9-A97D-6DD93198E115}" DTS:From="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\FEF - For each collected cache file try upload\SQL - Log Package Stats" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{ABD0C1A0-A52B-4AB3-BD5A-6CF3F23AD1EA}" DTS:From="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\FEF - For each collected cache file try upload\FST - Delete uploaded cache file"/>

</DTS:PrecedenceConstraints>

-<DTS:ForEachVariableMappings>

<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{81C3FFAC-C46B-4201-8CDA-7A558C8721AE}" DTS:ObjectName="{81C3FFAC-C46B-4201-8CDA-7A558C8721AE}" DTS:ValueIndex="0" DTS:VariableName="User::CurrentCollectionCacheFileName"/>

</DTS:ForEachVariableMappings>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{5D4817CD-0B0D-4F38-9BD7-6D5FEE0A1D6C}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Capture and analyze query statistics and query plan and text">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8D1D47FB-6B2A-46A6-A2B1-E2CB4B3DDA9D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8454FCD8-DA75-459B-A56E-8F51D1BC796B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{453C58A2-8847-4201-B90D-2AEF5FCB05CB}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C6251F49-EA70-40BE-AAC2-6A4908D1B460}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{867071FA-A5D7-4D5D-BC84-3C2FEB1C296B}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::SqlPlanRowCountIn] - @[User::SqlPlanRowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B73F494D-448D-4506-B872-AB814D29CF07}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8669D2FC-EAF4-4517-B700-3482BE6C3351}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{87585C9C-52B3-4595-8FB9-3F0F5423D5E0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{602B7F33-1865-4742-A02A-5DD42320E93E}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{059BA908-AB13-4165-BAFA-22436434FEF0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5F8CFCF6-0B44-41F1-9B17-6C426AB5C38C}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::SqlTextRowCountIn] - @[User::SqlTextRowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{399341DC-5D14-48B8-83E2-5F73FEEB5A49}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2AE94340-6F9F-44F9-A0CB-965A6C23E8B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{54D9A666-FDE3-4E3B-AA17-B21F9BDCDB38}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{1D99392A-5650-4BDC-9ACB-7CF7D8E1CEF7}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Create Interesting Queries Last Snapshot" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DC - Add the SnapshotId Column" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="OLE DB Source" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotQueryStatsQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output]" isSorted="true" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]" name="creation_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]" name="last_execution_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]" name="execution_count" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]" name="total_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]" name="min_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]" name="max_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]" name="total_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]" name="min_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]" name="max_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]" name="total_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]" name="min_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]" name="max_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]" name="total_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]" name="min_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]" name="max_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]" name="total_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]" name="min_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]" name="max_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" name="total_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" name="min_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" name="max_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count from dm_exec_query_stats">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write Last Snapshot" version="2">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileName</property>

<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">0</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[Derived Column Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{7CC524DD-0334-41D0-8E7C-A6AA943F156C}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Create Interesting Queries Upload Batch" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B6625EA4-05D1-4892-9AA7-631D7865E6EC}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [sql_handle], [plan_handle], [statement_start_offset], [statement_end_offset], [creation_time] FROM [snapshots].[fn_get_notable_query_plans](" + (DT_WSTR, 10) @[User::SourceId] + ")"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="NotableQueryPlan">

<DTS:VariableValue DTS:DataType="8">SELECT [sql_handle],

[plan_handle],

[statement_start_offset],

[statement_end_offset],

[creation_time]

FROM [snapshots].[fn_get_notable_query_plans](1)</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6528EF32-60E9-4771-AEDD-60FD8B2F0559}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [sql_handle] FROM [snapshots].[fn_get_notable_query_text](" + (DT_WSTR, 10) @[User::SourceId] + ")"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="NotableQueryText">

<DTS:VariableValue DTS:DataType="8">SELECT [sql_handle]

FROM [snapshots].[fn_get_notable_query_text](1)</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" localeId="1033" name="DRC - Add SnapshotId column to current snapshot" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRC - Calculate delta value between last snapshot and current snapshot for every metric" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_worker_time]" cachedDataType="i8" cachedName="old_total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_physical_reads]" cachedDataType="i8" cachedName="old_total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_writes]" cachedDataType="i8" cachedName="old_total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_reads]" cachedDataType="i8" cachedName="old_total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_clr_time]" cachedDataType="i8" cachedName="old_total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_elapsed_time]" cachedDataType="i8" cachedName="old_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_execution_count]" cachedDataType="i8" cachedName="old_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]" name="snapshot_worker_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_worker_time) ? total_worker_time : total_worker_time - old_total_worker_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]" name="snapshot_physical_reads" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_physical_reads) ? total_physical_reads : total_physical_reads - old_total_physical_reads</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]" name="snapshot_logical_reads" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_logical_reads) ? total_logical_reads : total_logical_reads - old_total_logical_reads</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]" name="snapshot_logical_writes" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_logical_writes) ? total_logical_writes : total_logical_writes - old_total_logical_writes</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]" name="snapshot_clr_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_clr_time) ? total_clr_time : total_clr_time - old_total_clr_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]" name="snapshot_elapsed_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_elapsed_time) ? total_elapsed_time : total_elapsed_time - old_total_elapsed_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]" name="snapshot_execution_count" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_execution_count) ? execution_count : execution_count - old_execution_count</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add plan_generation_num column" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">(DT_I8)1</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">(DT_I8)1</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]" name="creation_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[GETDATE]()</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">GETDATE()</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1)" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add source_id (1)" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SourceId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SourceId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2)" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add source_id (2)" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SourceId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SourceId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - split current snapshot">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 3]" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 4]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 4" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - Split interesting queries">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 3]" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 1]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - split last snapshot">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - Split to upload sql_handle and plan_handle">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 4]" deleteOutputOnPathDetached="true" name="Multicast Output 4" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 1]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries" componentClassID="Microsoft.MergeJoin" contactInfo="Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges data from two datasets by using a join." name="MRG - Append current stats on interesting queries" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the type of join to perform." name="JoinType" typeConverter="JoinType">2</property>

<property dataType="System.Int32" description="Specifies the number of columns in the ordering key." name="NumKeyColumns">2</property>

<property dataType="System.Boolean" description="Indicates whether the null values are treated as equal values." name="TreatNullsAsEqual">true</property>

<property dataType="System.Int32" description="Indicates the requested maximum buffers per input before blocking." name="MaxBuffersPerInput">5</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input]" hasSideEffects="true" name="Merge Join Left Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top SQL Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top SQL Handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top Plan Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top Plan Handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input]" hasSideEffects="true" name="Merge Join Right Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output]" isSorted="true" name="Merge Join Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" name="statement_start_offset">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" name="statement_end_offset">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" name="plan_generation_num">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries" componentClassID="Microsoft.MergeJoin" contactInfo="Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges data from two datasets by using a join." name="MRG - Append last stats on interesting queries" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the type of join to perform." name="JoinType" typeConverter="JoinType">2</property>

<property dataType="System.Int32" description="Specifies the number of columns in the ordering key." name="NumKeyColumns">5</property>

<property dataType="System.Boolean" description="Indicates whether the null values are treated as equal values." name="TreatNullsAsEqual">true</property>

<property dataType="System.Int32" description="Indicates the requested maximum buffers per input before blocking." name="MaxBuffersPerInput">5</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input]" hasSideEffects="true" name="Merge Join Left Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input]" hasSideEffects="true" name="Merge Join Right Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output]" isSorted="true" name="Merge Join Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]" name="old_total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]" name="old_total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]" name="old_total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]" name="old_total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]" name="old_total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]" name="old_total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]" name="old_execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Save statistics for interesting queries" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[query_stats]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_worker_time]" cachedDataType="i8" cachedName="snapshot_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_physical_reads]" cachedDataType="i8" cachedName="snapshot_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_reads]" cachedDataType="i8" cachedName="snapshot_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_writes]" cachedDataType="i8" cachedName="snapshot_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_clr_time]" cachedDataType="i8" cachedName="snapshot_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_elapsed_time]" cachedDataType="i8" cachedName="snapshot_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_execution_count]" cachedDataType="i8" cachedName="snapshot_execution_count" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" dataType="dbTimeStampOffset" name="creation_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[last_execution_time]" dataType="dbTimeStampOffset" name="last_execution_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_worker_time]" dataType="i8" name="snapshot_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_physical_reads]" dataType="i8" name="snapshot_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_writes]" dataType="i8" name="snapshot_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_reads]" dataType="i8" name="snapshot_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_clr_time]" dataType="i8" name="snapshot_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_elapsed_time]" dataType="i8" name="snapshot_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_execution_count]" dataType="i8" name="snapshot_execution_count"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Upload interesting plan handles" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[notable_query_plan]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" dataType="dbTimeStampOffset" name="creation_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]" dataType="i2" name="database_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]" dataType="i4" name="object_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="128" name="object_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[query_plan]" dataType="nText" name="query_plan"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Upload interesting sql handles" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[notable_query_text]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]" dataType="i2" name="database_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]" dataType="i4" name="object_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="128" name="object_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_text]" dataType="nText" name="sql_text"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get current snapshot of dm_exec_query_stats" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotQueryStatsQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output]" isSorted="true" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]" name="creation_time" sortKeyPosition="5" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]" name="last_execution_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]" name="execution_count" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]" name="total_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]" name="min_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]" name="max_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]" name="total_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]" name="min_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]" name="max_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]" name="total_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]" name="min_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]" name="max_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]" name="total_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]" name="min_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]" name="max_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]" name="total_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]" name="min_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]" name="max_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" name="total_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" name="min_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" name="max_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of interesting plan handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of interesting sql handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of not inserted plan handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of not inserted sql handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count after TopN queries">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count from dm_exec_query_stats">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Save current snapshot in temp file" version="2">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileNameOutput</property>

<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">0</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read current cache with dm_exec_requests" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CollectionCacheFileNameOutput</property>

</properties>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output]" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[row_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[row_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[row_id]" name="row_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_id]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_id]" name="session_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_id]" name="request_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[exec_context_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[exec_context_id]" name="exec_context_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]" name="blocking_session_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]" name="is_blocking"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[scheduler_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[scheduler_id]" name="scheduler_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[database_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[database_name]" name="database_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[user_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[user_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[user_id]" name="user_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[task_state]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[task_state]" name="task_state"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_status]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_status]" name="request_status"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_status]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_status]" name="session_status"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[executing_managed_code]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[executing_managed_code]" name="executing_managed_code"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_time]" name="login_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_user_process]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_user_process]" name="is_user_process"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[host_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[host_name]" name="host_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[program_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[program_name]" name="program_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_name]" name="login_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_type]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_type]" name="wait_type"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[last_wait_type]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[last_wait_type]" name="last_wait_type"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_resource]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_resource]" name="wait_resource"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[resource_description]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[resource_description]" name="resource_description"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_id]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_id]" name="transaction_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]" name="open_transaction_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]" name="request_cpu_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_logical_reads]" name="request_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_reads]" name="request_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_writes]" name="request_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_start_time]" name="request_start_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]" name="memory_usage"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_cpu_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_cpu_time]" name="session_cpu_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_reads]" name="session_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_writes]" name="session_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_logical_reads]" name="session_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" name="session_last_request_start_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" name="session_last_request_end_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_resultsets]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_resultsets]" name="open_resultsets"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]" name="session_row_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[prev_error]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[prev_error]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[prev_error]" name="prev_error"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]" name="pending_io_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[command]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[command]" length="32" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[command]" name="command"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read last snapshot of dm_exec_query_stats" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileName</property>

</properties>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output]" isSorted="true" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests" componentClassID="Microsoft.ConditionalSplit" contactInfo="Conditional Split;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Evaluates and directs rows in a dataset." name="SPLT - Identify interesting running requests" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" description="Input to the Conditional Split Transformation" name="Conditional Split Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Interesting Requests]" description="Output 1 of the Conditional Split Transformation" errorOrTruncationOperation="Computation" errorRowDisposition="IgnoreFailure" exclusionGroup="1" name="Interesting Requests" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Specifies the expression. This expression version uses lineage identifiers instead of column names." name="Expression">(#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]} > @[User::InterestingQueries_LongWaitingRequest]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]} == 0 && #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]} == TRUE ) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]} > @[User::InterestingQueries_HighTransactionCount]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]} > @[User::InterestingQueries_LongRunningRequest]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]} > @[User::InterestingQueries_HighCpuUsage]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]} > @[User::InterestingQueries_HighIoCount]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]} > @[User::InterestingQueries_HighMemoryUsage]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]} > @[User::InterestingQueries_LargeResultset])</property>

<property containsID="true" dataType="System.String" description="Specifies the friendly version of the expression. This expression version uses column names." expressionType="Notify" name="FriendlyExpression">(wait_duration_ms > @[User::InterestingQueries_LongWaitingRequest]) || (blocking_session_id == 0 && is_blocking == TRUE ) || (open_transaction_count > @[User::InterestingQueries_HighTransactionCount]) || (request_total_elapsed_time > @[User::InterestingQueries_LongRunningRequest]) || (request_cpu_time > @[User::InterestingQueries_HighCpuUsage]) || (pending_io_count > @[User::InterestingQueries_HighIoCount]) || (memory_usage > @[User::InterestingQueries_HighMemoryUsage]) || (session_row_count > @[User::InterestingQueries_LargeResultset])</property>

<property dataType="System.Int32" description="Specifies the position of the condition in the list of conditions that the transformation evaluates. The evaluation order is from the lowest to the highest value." name="EvaluationOrder">0</property>

</properties>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Default Output]" description="Default Output of the Conditional Split Transformation" exclusionGroup="1" name="Conditional Split Default Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]">

-<properties>

<property dataType="System.Boolean" name="IsDefaultOut">true</property>

</properties>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output]" description="Error Output of the Conditional Split Transformation" exclusionGroup="1" isErrorOut="true" name="Conditional Split Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">false</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">3</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">4</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">5</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Find unique sql_handle and plan_handle combinations" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">3</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">4</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">5</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Find unique sql_handle values" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Sort columns by sql_handle, plan_handle" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Reason]" cachedDataType="wstr" cachedLength="128" cachedName="Top Reason" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top SQL Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top SQL Handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Plan Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top Plan Handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason]" dataType="wstr" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason]" name="Top Reason">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]" name="Top SQL Handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]" name="Top Plan Handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries" componentClassID="Microsoft.TxTopQueries" name="TPQ - Analyze Interesting Queries" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input]" name="TxTopQueries Only Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output]" name="TxTopQueries Only Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]" dataType="wstr" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]" name="Top Reason"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]" name="Top SQL Handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]" name="Top Plan Handle"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats" componentClassID="Microsoft.UnionAll" contactInfo="Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges multiple datasets." name="UNION - Combine interesting requests and interesting stats" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1]" name="Union All Input 1">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_worker_time]" cachedDataType="i8" cachedName="old_total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_physical_reads]" cachedDataType="i8" cachedName="old_total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_writes]" cachedDataType="i8" cachedName="old_total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_reads]" cachedDataType="i8" cachedName="old_total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_clr_time]" cachedDataType="i8" cachedName="old_total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_elapsed_time]" cachedDataType="i8" cachedName="old_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_worker_time]" cachedDataType="i8" cachedName="snapshot_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_physical_reads]" cachedDataType="i8" cachedName="snapshot_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_reads]" cachedDataType="i8" cachedName="snapshot_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_writes]" cachedDataType="i8" cachedName="snapshot_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_clr_time]" cachedDataType="i8" cachedName="snapshot_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_elapsed_time]" cachedDataType="i8" cachedName="snapshot_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_execution_count]" cachedDataType="i8" cachedName="snapshot_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_execution_count]" cachedDataType="i8" cachedName="old_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3]" hasSideEffects="true" name="Union All Input 3">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 2]" dangling="true" hasSideEffects="true" name="Union All Input 2">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1]" name="Union All Output 1">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]" name="old_total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]" name="old_total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]" name="old_total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]" name="old_total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]" name="old_total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]" name="old_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]" name="snapshot_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]" name="snapshot_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]" name="snapshot_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]" name="snapshot_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]" name="snapshot_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]" name="snapshot_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]" name="snapshot_execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]" name="old_execution_count"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing" componentClassID="Microsoft.UnionAll" contactInfo="Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges multiple datasets." name="UNION - Combine last and current snapshots for TopN processing" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2]" hasSideEffects="true" name="Union All Input 2">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3]" hasSideEffects="true" name="Union All Input 3">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 1]" dangling="true" hasSideEffects="true" name="Union All Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1]" name="Union All Output 1">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]" name="plan_handle"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Calculate TopN stats]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input]" name="Calculate TopN stats" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Calculate TopN stats1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input]" name="Calculate TopN stats" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output4]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Interesting Requests]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]" name="Interesting Requests" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Interesting Requests]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Merge Join Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]" name="Merge Join Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Merge Join Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]" name="Merge Join Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]" name="Multicast Output 2" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1]" name="Multicast Output 3" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 3]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 4]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input]" name="Multicast Output 4" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 4]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Destination Error Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]" name="OLE DB Destination Error Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Destination Error Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]" name="OLE DB Destination Error Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Process TopN1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3]" name="Process TopN" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Process TopN]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2]" name="Process TopN" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Raw File Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]" name="Raw File Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Raw File Source Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" name="Raw File Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 12]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 13]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Save]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input]" name="Save" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 3]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Save1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]" name="Save" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[TxTopQueries Only Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input]" name="TxTopQueries Only Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Union All Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input]" name="Union All Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Union All Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input]" name="Union All Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{06401E14-2D8B-4F21-AEF7-BDBD02C9C408}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Find and save plan text" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B2DB683D-A481-4324-9E1D-141AA674A545}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = " + (DT_WSTR,50) @[User::SourceId]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SourceSqlQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = 1</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5" description="Looks up values in a reference dataset by using exact matching." name="LKUP - Look up query plans on target server" usesDispositions="true" version="6">

-<properties>

<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?</property>

<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?</property>

<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>

<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">2</property>

<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>

<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>

<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">25</property>

<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">25</property>

<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="plan_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_start_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_end_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="query_plan" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>

<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]};#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]};#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]};</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[ConfigConnection2]" connectionManagerRefId="Package.ConnectionManagers[ConfigConnection2]" description="Connection manager used to access lookup data." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]" name="Lookup Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">statement_start_offset</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">statement_end_offset</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">plan_handle</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]" dataType="i2" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]" name="database_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">database_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]" name="object_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]" dataType="wstr" errorOrTruncationOperation="Copy Column" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]" name="object_name" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_name</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]" dataType="nText" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]" name="query_plan" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">query_plan</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODC - Save known plans to warehouse" usesDispositions="true" version="2">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">EXEC snapshots.sp_update_query_plan ?,?,?,?,?,?,?,?,?,?</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[database_id]" cachedDataType="i2" cachedName="database_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_id]" cachedDataType="i4" cachedName="object_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_name]" cachedDataType="wstr" cachedLength="128" cachedName="object_name" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[query_plan]" cachedDataType="nText" cachedName="query_plan" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" dataType="i4" name="@source_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" dataType="bytes" length="64" name="@sql_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle]" dataType="bytes" length="64" name="@plan_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset]" dataType="i4" name="@statement_start_offset">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset]" dataType="i4" name="@statement_end_offset">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num]" dataType="i8" name="@plan_generation_num">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" dataType="i2" name="@database_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" dataType="i4" name="@object_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" dataType="wstr" length="128" name="@object_name">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan]" dataType="nText" name="@query_plan">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">193</property>

</properties>

</externalMetadataColumn>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get all plan handles without saved plan" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SourceSqlQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output]" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[source_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[source_id]" name="source_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Identified query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unidentified query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unknown query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Lookup Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]" name="Lookup Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Lookup No Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]" name="Lookup No Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup No Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{A8B89CFB-EAB7-418D-ABA6-B0653CFF73B2}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Find and save sql text" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3B4FCEE9-FA8B-4F72-804B-4BE4019A2BF4}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [snapshots].[sp_get_unknown_query_text] @source_id = " + (DT_WSTR,50) @[User::SourceId]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SourceSqlQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [snapshots].[sp_get_unknown_query_text] @source_id = 1</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5" description="Looks up values in a reference dataset by using exact matching." name="LKUP - Look up query text on target server" usesDispositions="true" version="6">

-<properties>

<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_sql_text_lookup] ?</property>

<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_sql_text_lookup] ?</property>

<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>

<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">2</property>

<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>

<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>

<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">25</property>

<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">25</property>

<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="sql_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="sql_text" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>

<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]};</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[ConfigConnection2]" connectionManagerRefId="Package.ConnectionManagers[ConfigConnection2]" description="Connection manager used to access lookup data." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]" name="Lookup Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">sql_handle</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]" dataType="i2" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]" name="database_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">database_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]" name="object_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]" dataType="wstr" errorOrTruncationOperation="Copy Column" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]" name="object_name" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_name</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]" dataType="nText" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]" name="sql_text" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">sql_text</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get all sql handles without saved sql text" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">snapshots.sp_get_unknown_query_text @source_id = 3</property>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SourceSqlQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output]" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[source_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[source_id]" name="source_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODS - Save query text to warehouse" usesDispositions="true" version="2">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">EXEC snapshots.sp_update_query_text ?, ?, ?, ?, ?, ?</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Command Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[database_id]" cachedDataType="i2" cachedName="database_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_id]" cachedDataType="i4" cachedName="object_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_name]" cachedDataType="wstr" cachedLength="128" cachedName="object_name" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_text]" cachedDataType="nText" cachedName="sql_text" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" dataType="bytes" length="64" name="@sql_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" dataType="i4" name="@source_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" dataType="i2" name="@database_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" dataType="i4" name="@object_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" dataType="wstr" length="128" name="@object_name">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text]" dataType="nText" name="@sql_text">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">193</property>

</properties>

</externalMetadataColumn>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft Sql Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Identified query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unidentified query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unknown query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Lookup Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]" name="Lookup Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Lookup No Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]" name="Lookup No Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup No Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{C2C219D8-0B35-4D01-A732-72489975921A}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Check Interesting Queries Last Snapshot exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

<DTS:PropertyExpression DTS:Name="FilePath">@[User::InterestingQueriesLastSnapshotFileName]</DTS:PropertyExpression>

-<DTS:ObjectData>

-<FileAccessTask>

<Mode>0</Mode>

<FilePath>c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache</FilePath>

</FileAccessTask>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{6CF195E1-8563-46F2-9500-A52AEB3306F0}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Current Snapshot File as Last Snapshot File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::InterestingQueriesLastSnapshotFileNameOutput" TaskIsSourceVariable="True" TaskDestinationPath="User::InterestingQueriesLastSnapshotFileName" TaskIsDestinationVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{6F36C159-874B-4351-A291-8AC691098328}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for Interesting Queries" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'query_stats upload', ?, ?, NULL, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::InterestingQueriesRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InterestingQueriesRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{90BFBAF6-A08D-4BCB-B1E0-EE493CAA80E0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for sql plan" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql plan upload', ?, ?, ?, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::SqlPlanRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::SqlPlanRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::SqlPlanRowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql text" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{02284097-190E-4435-84BE-F5E14956A1F0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for sql text" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql text upload', ?, ?, ?, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::SqlTextRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::SqlTextRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::SqlTextRowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{B8D3087D-11C1-4B00-997B-6067A6579AEF}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{B5171C94-F537-4E05-B026-6F1733778AED}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{188F2E10-1D32-4CB6-8F1B-39300F9DC592}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{0CA4D80A-739D-48A7-9F2B-A2F18810434B}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text" DTS:ObjectName="Constraint 3" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{80BB971B-FD09-4237-8119-D90654587E64}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:ObjectName="Constraint 5" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{CCEACE44-4FBD-4796-90ED-B1AE560BE3B4}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 7]" DTS:CreationName="" DTS:DTSID="{84EC6C5C-B6F8-41FC-8FC3-12E6B722BFFF}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 7" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{D7CB327F-A818-4D93-855C-11473FBE4AEC}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql text" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Last Snapshot Missing]" DTS:CreationName="" DTS:DTSID="{FBDCF942-3540-45E2-AAD6-A425973C01E8}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:LogicalAnd="True" DTS:ObjectName="Last Snapshot Missing" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:Value="1"/>

</DTS:PrecedenceConstraints>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Rename Collection Cache File" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{8C70D6CD-D74A-4349-BB8A-8917BC91A5B6}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Rename Collection Cache File">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{48719FEE-0780-458C-AE72-3B398DDA4A24}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">

<DTS:VariableValue DTS:DataType="8">QueryActivityLock</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\SEQ - Rename Collection Cache File\FST - Rename Cache File" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{C5533AC9-9896-43CA-A46C-DD7D9A396B12}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Cache File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::CollectionCacheFileName" TaskIsSourceVariable="True" TaskDestinationPath="User::CollectionCacheFileNameOutput" TaskIsDestinationVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SQL - Get SnapshotId" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{DD0170D6-186A-437B-8F7D-E909F437A16F}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get SnapshotId" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" SQLTask:SqlStatementSource="{call [core].[sp_create_snapshot](?, ?, ?, ?, ?, ?)}">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotId" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SQL - Get SourceId" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{E05B5850-7B98-4C33-95AC-EC191C7334F5}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get SourceId" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" SQLTask:SqlStatementSource="{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="2" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceId" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{6FDD2D34-4BAD-42B5-9E71-E135532FB590}" DTS:From="Package\SEQ - Rename Collection Cache File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\CWM - Remove Upload Snapshots Older Than CacheWindow"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 12]" DTS:CreationName="" DTS:DTSID="{54C3C3CA-67A4-4B87-A5CE-A8679A5E5116}" DTS:From="Package\FAT - Check Cache File Exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 12" DTS:To="Package\SEQ - Rename Collection Cache File"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{AAA44A20-51D1-42FE-9656-41A1DBAC347A}" DTS:From="Package\SQL - Get SourceId" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\SQL - Get SnapshotId"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{1B9D6AD9-FDDE-4443-AA9B-2688E595DC2B}" DTS:From="Package\SQL - Get SnapshotId" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 7]" DTS:CreationName="" DTS:DTSID="{53381062-0490-4018-98B1-EF24A1C0E052}" DTS:From="Package\CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 7" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{4D376995-07A3-41A5-B3EE-01FA251AA113}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\FEF - For each collected cache file try upload"/>

</DTS:PrecedenceConstraints>

</DTS:Executable>


Package

Package: SqlTraceCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/14/2007 3:06:05 PM
CreationName | Microsoft.Package
CreatorComputerName | MACIES4
CreatorName | REDMOND\macies
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {0E149FC9-1046-4DE6-98BF-4B22ED6F6C42}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 0
Name | SqlTraceCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\SqlTraceCollect
PackagePath | MSDB\Data Collector\SqlTraceCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | True
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 87
VersionComments |
VersionGUID | {149519E7-B008-4BE2-9408-766D8CC64951}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
Foreach Loop - Monitor Trace | Foreach Loop Container
SQL - Close trace if running | Execute SQL Task
SQL - Execute Trace Start Script | Execute SQL Task
SQL - Stop Trace | Execute SQL Task
TRC - Generate Trace Start Script | Trace Start Script

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 5 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |
TraceErrorCode |
TraceID |
TraceLocation |
TraceScript |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: SqlTraceCollect

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {72F1EE8A-126D-4918-8358-55FD82DCDA58}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {5EF6C061-FFAD-45CF-BEDC-170C206A9774}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {62E3B07F-C5B7-4897-B347-74EF91DE84EA}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {EBB9F538-F06D-4E25-803F-DA3786931A72}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {D435F04D-45EE-4705-9F59-37B75F4695BB}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {175B22A1-7B3C-4C7C-9F27-8BA255CE806D}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {349BCBAD-ABF2-4639-93A2-E7E6474E2C69}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {264D4120-D107-4880-A7FA-5BEAE2BB05B8}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {E46A25A3-1DB8-4F06-93F5-700D9FF3D8DB}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {DA667ED7-E83E-4E8F-AF0B-90B784E51E4D}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {4D42DA00-DC8B-442A-AE96-18DB1C38D3E7}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {8AFB1B11-7206-4A95-AED3-631969E75CE9}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {7B439C62-C6E2-4961-B885-8F19CA71B18B}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3FB4BC97-FCA6-457F-BEFA-A22645B7824C}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C5B0F2F8-E34E-41C6-879A-85CAD34E4ED8}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {2DF60C47-E413-4E07-9EC1-F06F888B6143}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package

Package: SqlTraceCollect

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {9BE08268-DCA3-4834-8711-29EB7B34AC16}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CacheDirectory
Namespace | User
QualifiedName | User::CacheDirectory
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\Users\macies\AppData\Local\Temp\ecodedc
VariablePath | \Package.Variables[User::CacheDirectory]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectionSetUID
Namespace | User
QualifiedName | User::CollectionSetUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | f37780d4-fea7-4271-90b2-fa553ad4ca91
VariablePath | \Package.Variables[User::CollectionSetUID]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectorTypeUID
Namespace | User
QualifiedName | User::CollectorTypeUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0e218cf8-ecb5-417b-b533-d851c0251271
VariablePath | \Package.Variables[User::CollectorTypeUID]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
CreationName
DataType | String
Description
EvaluateAsExpression | False
Expression
IncludeInDebugDump | False
Name | InputParameters
Namespace | User
QualifiedName | User::InputParameters
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | <?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector>
VariablePath | \Package.Variables[User::InputParameters]


Package element

Package element: TraceErrorCode

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TraceErrorCode
Namespace | User
QualifiedName | User::TraceErrorCode
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceErrorCode]


Package element

Package element: TraceID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TraceID
Namespace | User
QualifiedName | User::TraceID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceID]


Package element

Package element: TraceLocation

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]
IncludeInDebugDump | False
Name | TraceLocation
Namespace | User
QualifiedName | User::TraceLocation
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0
VariablePath | \Package.Variables[User::TraceLocation]


Package element

Package element: TraceScript

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceScript
Namespace | User
QualifiedName | User::TraceScript
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::TraceScript]


Package element

Package element: MdwConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to upload collected data to a warehouse.
HasExpressions | True
HostType | ConnectionManager
ID | {B2336E2F-4946-4B14-9A6C-BF6059132E81}
InitialCatalog | MDW
Name | MdwConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: TargetConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information from the monitored (target) instance.
HasExpressions | True
HostType | ConnectionManager
ID | {BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}
InitialCatalog |
Name | TargetConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package

Package: SqlTraceCollect

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceCollect

Collapse image Executables

Name | Description
Foreach Loop - Monitor Trace | Foreach Loop Container
SQL - Close trace if running | Execute SQL Task
SQL - Execute Trace Start Script | Execute SQL Task
SQL - Stop Trace | Execute SQL Task
TRC - Generate Trace Start Script | Trace Start Script

Collapse image System variables

No items exist
Name Description


Package element

Package element: Foreach Loop - Monitor Trace

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | True
Description | Foreach Loop Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {AC652D98-8CD6-4256-BEB0-7B937A9F6EFC}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | Foreach Loop - Monitor Trace
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
SQL - Check if Trace is Running | Execute SQL Task | Executables
SQL - Log Package Iteration | Execute SQL Task | Executables
SQL - Log Package Stats | Execute SQL Task | Executables
SQL - Recreate Trace | Execute SQL Task | Executables
{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2} |  | ForEachEnumerator
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
Constraint 3 |  | PrecedenceConstraints
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Check if Trace is Running

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {DDDFF39B-578A-4DFB-B194-0723500C3565}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Check if Trace is Running
ResultSetType | 1
SqlStatementSource
DECLARE @TraceStatus INT
DECLARE @TraceID INT

SELECT
 @TraceID = id ,
 @TraceStatus = status
FROM sys.traces
WHERE
 [id] = ?
 AND ([path] LIKE ? + N'%.trc' OR is_default=1)

IF @TraceID IS NULL
BEGIN
 RAISERROR(14678, 16, -1, @TraceID)
END
ELSE
BEGIN
 IF @TraceStatus <> 1
  EXEC sp_trace_setstatus @TraceID, 1
END
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Log Package Iteration

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {6287158D-7570-43DF-9D6E-9D9191345709}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log Package Iteration
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_syscollector_event_onpackageupdate( ? )}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Log Package Stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {A96C46EC-F328-44A1-BE6B-0FA1A2E4267E}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log Package Stats
ResultSetType | 1
SqlStatementSource
{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Monitor trace', 0, 0, 0, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Recreate Trace

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {972327c3-db40-4180-9f20-b5696bb14eb2}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Recreate Trace
ResultSetType | 2
SqlStatementSource
User::TraceScript
SqlStatementSourceType | Variable
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: {710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DC.ForEachEventEnumerator.4
DelayValidation | False
Description |
ExitEventName | EXITEVENT
HasExpressions | True
HostType | ForEachEnumerator
ID | {710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}
LoopEventName | LOOPEVENT
Name | {710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}

Collapse image Elements

Name | Description | Type
ExitEventName |  | Expressions
LoopEventName |  | Expressions
ExitEventName |  | Expressions
LoopEventName |  | Expressions


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Recreate Trace
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | False
Expression |
ID | {717FFE6B-71FE-4F0A-B934-916A64CFA375}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | SQL - Check if Trace is Running
Value | Failure


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel] >= 1
ID | {C8B2863D-73FC-49A9-A730-03681768D7A4}
LogicalAnd | False
Name | Constraint 1
PrecedenceExecutable | SQL - Check if Trace is Running
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::LoggingLevel] >= 1
ID | {43AC0421-D367-442B-852C-1C8C10E392AE}
LogicalAnd | False
Name | Constraint 2
PrecedenceExecutable | SQL - Recreate Trace
Value | Completion


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log Package Iteration
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {DCF85D96-5446-432D-8CCB-976768E873D3}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | SQL - Log Package Stats
Value | Completion


Package element

Package element: SQL - Close trace if running

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {22a8654c-00d2-41ea-8273-a98f925bca5a}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Close trace if running
ResultSetType | 1
SqlStatementSource
DECLARE @TraceStatus INT
DECLARE @TraceID INT

SELECT
 @TraceID = id ,
 @TraceStatus = status
FROM sys.traces
WHERE
 [path] LIKE ? + N'%.trc'
 AND is_default=0

IF NOT @TraceID IS NULL
BEGIN
  EXEC sp_trace_setstatus @TraceID, 0
  EXEC sp_trace_setstatus @TraceID, 2
END
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Execute Trace Start Script

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {B5D9B002-1927-4CCA-84AE-F291C7E5F613}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Execute Trace Start Script
ResultSetType | 2
SqlStatementSource
User::TraceScript
SqlStatementSourceType | Variable
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: SQL - Stop Trace

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {B4EFD1D8-5EA4-4E54-AA01-905A01982D39}
IsDefaultLocaleID | True
IsolationLevel | ReadCommitted
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Stop Trace
ResultSetType | 1
SqlStatementSource
DECLARE @TraceID INT
SELECT @TraceID = ?

IF EXISTS (SELECT id FROM sys.traces WHERE id = @TraceID AND is_default = 0)
BEGIN
    EXEC sp_trace_setstatus @TraceID, 0
END
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: TRC - Generate Trace Start Script

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.TraceStartScriptTask.4
DebugMode | False
DelayValidation | True
Description | Trace Start Script
Destination | TraceScript
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {A1508E93-DDD6-4E3D-BE78-46B59503E7AF}
InputParameters | <?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector>
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaxFileSize | 10
MaximumErrorCount | 0
MaxNumberOfFiles | 10
Name | TRC - Generate Trace Start Script
SuspendRequired | False
TraceFileLocation | C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0
TransactionOption | NotSupported

Collapse image Elements

Name | Description | Type
InputParameters |  | Expressions
TraceFileLocation |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopDuration |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
TargetConnectionString |  | Variables
TraceErrorCode |  | Variables
TraceID |  | Variables
TraceLocation |  | Variables
TraceScript |  | Variables


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
Expression | @[User::InputParameters]
Name | InputParameters


Package element

Package element: TraceFileLocation

Collapse image Properties

Name | Value
Expression | @[User::TraceLocation]
Name | TraceFileLocation


Package

Package: SqlTraceCollect

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceCollect

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceCollect

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceCollect

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 5 |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Execute Trace Start Script
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {0AA76CCC-2FE2-4634-B3D2-A667800C2970}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | SQL - Close trace if running
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | Foreach Loop - Monitor Trace
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | False
Expression | @[User::TraceID] > 0
ID | {173BDAB9-B91C-41D7-900D-9983E6C67B72}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | SQL - Execute Trace Start Script
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Stop Trace
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {CDB85B45-DF66-4F48-9171-B6E4D3CC1A2D}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | Foreach Loop - Monitor Trace
Value | Completion


Package element

Package element: Constraint 5

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Close trace if running
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {2D5D63DF-D075-4A13-BFA3-A73ECE38EB69}
LogicalAnd | True
Name | Constraint 5
PrecedenceExecutable | TRC - Generate Trace Start Script
Value | Success


Package

Package: SqlTraceCollect

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |
TraceErrorCode |
TraceID |
TraceLocation |
TraceScript |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/14/2007 3:06:05 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="MACIES4" DTS:CreatorName="REDMOND\macies" DTS:DelayValidation="True" DTS:DTSID="{0E149FC9-1046-4DE6-98BF-4B22ED6F6C42}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxErrorCount="0" DTS:ObjectName="SqlTraceCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:SuppressConfigurationWarnings="True" DTS:VersionBuild="87" DTS:VersionGUID="{2C49377B-0586-4782-ADEA-D276388B6516}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{B2336E2F-4946-4B14-9A6C-BF6059132E81}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{72F1EE8A-126D-4918-8358-55FD82DCDA58}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5EF6C061-FFAD-45CF-BEDC-170C206A9774}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{62E3B07F-C5B7-4897-B347-74EF91DE84EA}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EBB9F538-F06D-4E25-803F-DA3786931A72}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D435F04D-45EE-4705-9F59-37B75F4695BB}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{175B22A1-7B3C-4C7C-9F27-8BA255CE806D}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{349BCBAD-ABF2-4639-93A2-E7E6474E2C69}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{264D4120-D107-4880-A7FA-5BEAE2BB05B8}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E46A25A3-1DB8-4F06-93F5-700D9FF3D8DB}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{DA667ED7-E83E-4E8F-AF0B-90B784E51E4D}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{4D42DA00-DC8B-442A-AE96-18DB1C38D3E7}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8AFB1B11-7206-4A95-AED3-631969E75CE9}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{7B439C62-C6E2-4961-B885-8F19CA71B18B}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3FB4BC97-FCA6-457F-BEFA-A22645B7824C}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C5B0F2F8-E34E-41C6-879A-85CAD34E4ED8}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DF60C47-E413-4E07-9EC1-F06F888B6143}" DTS:ObjectName="ParentLogID"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E13D738-CEC0-4537-93A7-7926142F274B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E40806B1-6B8D-4381-AD2B-1C44067588E4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B902EBEC-969B-42D4-81BE-C5149B8E1750}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">f37780d4-fea7-4271-90b2-fa553ad4ca91</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{998E9C65-6E29-46CD-845E-AFA5D5C6E75E}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">0e218cf8-ecb5-417b-b533-d851c0251271</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9B1A5823-2F9A-4589-B15F-CDB60E89CDAF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{46738D8F-C9D8-45DC-95C2-F7BD6CB95C13}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A3701456-096F-4A45-A8CC-E5473ECFE075}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{91086B11-E37A-419D-B9F2-05807790111F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{20041AC6-1B78-4A75-8F50-D4DAA6EDF964}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0C688D7F-6BFB-4018-BA62-78AF00876D5D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9FF8E1B3-7D2A-43BD-894D-F27FEBC3275C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D13402E2-2FD2-4FF8-8873-93D5A999FCE5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2DF4BAA6-D6A8-4230-9007-A1CD3E5AF1CF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF24B339-0DAC-42AC-A490-CD53827688F7}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A506924A-C3E2-41E2-8C9D-1EE5E4792051}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{58FC505F-AC84-4F90-834C-E27CC8478D0B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E925F74-02D2-4B08-8C55-BABE20B84168}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{549EEAA7-88DB-4FCB-9548-BBE7077559F9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceErrorCode">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{05CEC9A6-14B2-4B68-8EF7-7825CC7622D4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1FDF1A88-F491-496C-BB22-26F2DB314498}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLocation">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6BCBC2C4-F895-4B8C-A793-EB71AFF0AF2A}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceScript">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop Container" DTS:DTSID="{AC652D98-8CD6-4256-BEB0-7B937A9F6EFC}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Foreach Loop - Monitor Trace">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}" DTS:ObjectName="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{DDDFF39B-578A-4DFB-B194-0723500C3565}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Check if Trace is Running" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceStatus INT DECLARE @TraceID INT SELECT @TraceID = id , @TraceStatus = status FROM sys.traces WHERE [id] = ? AND ([path] LIKE ? + N'%.trc' OR is_default=1) IF @TraceID IS NULL BEGIN RAISERROR(14678, 16, -1, @TraceID) END ELSE BEGIN IF @TraceStatus <> 1 EXEC sp_trace_setstatus @TraceID, 1 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{6287158D-7570-43DF-9D6E-9D9191345709}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onpackageupdate( ? )}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{A96C46EC-F328-44A1-BE6B-0FA1A2E4267E}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Monitor trace', 0, 0, 0, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{972327c3-db40-4180-9f20-b5696bb14eb2}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Recreate Trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStmtSourceType="Variable" SQLTask:SqlStatementSource="User::TraceScript" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="trace_id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ResultBinding SQLTask:ResultName="error_code" SQLTask:DtsVariableName="User::TraceErrorCode"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{717FFE6B-71FE-4F0A-B934-916A64CFA375}" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:Value="1"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{C8B2863D-73FC-49A9-A730-03681768D7A4}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:ObjectName="Constraint 1" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{43AC0421-D367-442B-852C-1C8C10E392AE}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:ObjectName="Constraint 2" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{DCF85D96-5446-432D-8CCB-976768E873D3}" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Iteration" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{20400B93-3704-4726-ADCC-73457B916283}" DTS:ObjectName="{20400B93-3704-4726-ADCC-73457B916283}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Close trace if running" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{22a8654c-00d2-41ea-8273-a98f925bca5a}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace if running" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceStatus INT DECLARE @TraceID INT SELECT @TraceID = id , @TraceStatus = status FROM sys.traces WHERE [path] LIKE ? + N'%.trc' AND is_default=0 IF NOT @TraceID IS NULL BEGIN EXEC sp_trace_setstatus @TraceID, 0 EXEC sp_trace_setstatus @TraceID, 2 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Execute Trace Start Script" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{B5D9B002-1927-4CCA-84AE-F291C7E5F613}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Execute Trace Start Script" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStmtSourceType="Variable" SQLTask:SqlStatementSource="User::TraceScript" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="trace_id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ResultBinding SQLTask:ResultName="error_code" SQLTask:DtsVariableName="User::TraceErrorCode"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Stop Trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{B4EFD1D8-5EA4-4E54-AA01-905A01982D39}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Stop Trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceID INT SELECT @TraceID = ? IF EXISTS (SELECT id FROM sys.traces WHERE id = @TraceID AND is_default = 0) BEGIN EXEC sp_trace_setstatus @TraceID, 0 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\TRC - Generate Trace Start Script" DTS:CreationName="Microsoft.TraceStartScriptTask" DTS:DelayValidation="True" DTS:Description="Trace Start Script" DTS:DTSID="{A1508E93-DDD6-4E3D-BE78-46B59503E7AF}" DTS:ExecutableType="Microsoft.TraceStartScriptTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="TRC - Generate Trace Start Script" DTS:TaskContact="Trace Start Script Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:TransactionOption="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
<DTS:PropertyExpression DTS:Name="InputParameters">@[User::InputParameters]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="TraceFileLocation">@[User::TraceLocation]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<TraceStartScriptTask>
<InputParameters><?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector></InputParameters>
<TraceFileLocation>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0</TraceFileLocation>
<MaxFileSize>10</MaxFileSize>
<MaxNumberOfFiles>10</MaxNumberOfFiles>
<Destination>TraceScript</Destination>
</TraceStartScriptTask>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{0AA76CCC-2FE2-4634-B3D2-A667800C2970}" DTS:From="Package\SQL - Close trace if running" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SQL - Execute Trace Start Script"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{173BDAB9-B91C-41D7-900D-9983E6C67B72}" DTS:EvalOp="3" DTS:Expression="@[User::TraceID] > 0" DTS:From="Package\SQL - Execute Trace Start Script" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\Foreach Loop - Monitor Trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{CDB85B45-DF66-4F48-9171-B6E4D3CC1A2D}" DTS:From="Package\Foreach Loop - Monitor Trace" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Stop Trace" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{2D5D63DF-D075-4A13-BFA3-A73ECE38EB69}" DTS:From="Package\TRC - Generate Trace Start Script" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\SQL - Close trace if running"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


Package

Package: SqlTraceUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 3/6/2007 4:18:14 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {F389A8E6-5A17-4056-ABFD-C8B823F2092E}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 0
Name | SqlTraceUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | dtsserver:MSDB\Data Collector\SqlTraceUpload
PackagePath | MSDB\Data Collector\SqlTraceUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 219
VersionComments |
VersionGUID | {2B249201-CD59-40B8-97CA-C7FD482FE09C}
VersionMajor | 10
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
For Loop Container | For Loop Container
SEQ - Default trace upload | Sequence Container
SQL - Close trace | Execute SQL Task
SQL - Get last upload time | Execute SQL Task
SQL - Get snapshot id | Execute SQL Task
SQL - Get trace info | Execute SQL Task
SQL - Update data source | Execute SQL Task
XML - Check use_default attribute | XML Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 3 |
Constraint 5 |
Constraint 6 |
Constraint 8 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
Counter |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
SnapshotID |
SourceID |
TargetConnectionString |
TraceCurrentEventTime |
TraceCurrentFile |
TraceDroppedEventCount |
TraceID |
TraceInfoID |
TraceIsRunning |
TraceLastEventSequence |
TraceLocation |
TraceStartTime |
TraceUseDefault |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: SqlTraceUpload

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image System variables

No items exist
Name Description


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
ConfigurationString | User::CacheDirectory
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {C32CCDDF-1CB6-4E64-806E-193762452CA6}
Name | CacheDirectory
PackagePath | \Package.Variables[User::CacheDirectory].Properties[Value]


Package element

Package element: CacheWindow

Collapse image Properties

Name | Value
ConfigurationString | User::CacheWindow
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {5A111CDB-34FB-47A2-8307-96D7C3BB49CA}
Name | CacheWindow
PackagePath | \Package.Variables[User::CacheWindow].Properties[Value]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
ConfigurationString | User::InputParameters
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {AC2982C3-5B39-4514-B50D-092C15857C1F}
Name | InputParameters
PackagePath | \Package.Variables[User::InputParameters].Properties[Value]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::MDWConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3B823989-622C-484E-A927-E0C211588865}
Name | MDWConnectionString
PackagePath | \Package.Variables[User::MDWConnectionString].Properties[Value]


Package element

Package element: ConfigConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::ConfigConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {BD6C4FE9-3BCB-447C-A897-0DA27695E684}
Name | ConfigConnectionString
PackagePath | \Package.Variables[User::ConfigConnectionString].Properties[Value]


Package element

Package element: TargetConnectionString

Collapse image Properties

Name | Value
ConfigurationString | User::TargetConnectionString
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {7A1F3609-4C0F-4BFA-A979-4AF89D61F160}
Name | TargetConnectionString
PackagePath | \Package.Variables[User::TargetConnectionString].Properties[Value]


Package element

Package element: LoopEventName

Collapse image Properties

Name | Value
ConfigurationString | User::LoopEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {5C370D78-5CD2-427F-B461-BF36DDAFF7F6}
Name | LoopEventName
PackagePath | \Package.Variables[User::LoopEventName].Properties[Value]


Package element

Package element: ExitEventName

Collapse image Properties

Name | Value
ConfigurationString | User::ExitEventName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {8EDCACD7-00DF-40EC-A8C0-B24F1E7D926B}
Name | ExitEventName
PackagePath | \Package.Variables[User::ExitEventName].Properties[Value]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectorTypeUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {EDC66214-7B5A-479C-9F8A-4F1A3DE80C93}
Name | CollectorTypeUID
PackagePath | \Package.Variables[User::CollectorTypeUID].Properties[Value]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
ConfigurationString | User::CollectionSetUID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {FF327F2E-CCC8-4F10-A2D0-38603D037E2C}
Name | CollectionSetUID
PackagePath | \Package.Variables[User::CollectionSetUID].Properties[Value]


Package element

Package element: ItemID

Collapse image Properties

Name | Value
ConfigurationString | User::ItemID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {01BD5F34-840B-4D65-8BF9-969DAE6CF738}
Name | ItemID
PackagePath | \Package.Variables[User::ItemID].Properties[Value]


Package element

Package element: InstanceID

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {FD17D526-ED20-412C-8410-FA25A5F46BAC}
Name | InstanceID
PackagePath | \Package.Variables[User::InstanceID].Properties[Value]


Package element

Package element: InstanceName

Collapse image Properties

Name | Value
ConfigurationString | User::InstanceName
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {D3DD404F-F408-420C-A9EA-A20AAB672DBB}
Name | InstanceName
PackagePath | \Package.Variables[User::InstanceName].Properties[Value]


Package element

Package element: LoggingLevel

Collapse image Properties

Name | Value
ConfigurationString | User::LoggingLevel
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {3F16CD83-89C9-4318-A8AD-16A99DB6A766}
Name | LoggingLevel
PackagePath | \Package.Variables[User::LoggingLevel].Properties[Value]


Package element

Package element: LogID

Collapse image Properties

Name | Value
ConfigurationString | User::LogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {B4A38B6C-953A-42F8-8BF4-56631E8D7614}
Name | LogID
PackagePath | \Package.Variables[User::LogID].Properties[Value]


Package element

Package element: ParentLogID

Collapse image Properties

Name | Value
ConfigurationString | User::ParentLogID
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {8406BEC6-5D17-457B-BD92-714F0CF97EB5}
Name | ParentLogID
PackagePath | \Package.Variables[User::ParentLogID].Properties[Value]


Package element

Package element: DaysUntilExpiration

Collapse image Properties

Name | Value
ConfigurationString | User::DaysUntilExpiration
ConfigurationType | ParentVariable
CreationName |
Description |
ID | {6F51BB50-9D79-4BA5-A519-6EF540C17B67}
Name | DaysUntilExpiration
PackagePath | \Package.Variables[User::DaysUntilExpiration].Properties[Value]


Package

Package: SqlTraceUpload

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image System variables

No items exist
Name Description


Package element

Package element: ConfigConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information about collection configuration and for logging purposes.
HasExpressions | True
HostType | ConnectionManager
ID | {C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}
InitialCatalog | msdb
Name | ConfigConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: CacheDirectory

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CacheDirectory
Namespace | User
QualifiedName | User::CacheDirectory
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::CacheDirectory]


Package element

Package element: CollectionSetUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectionSetUID
Namespace | User
QualifiedName | User::CollectionSetUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::CollectionSetUID]


Package element

Package element: CollectorTypeUID

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | CollectorTypeUID
Namespace | User
QualifiedName | User::CollectorTypeUID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | {0E218CF8-ECB5-417B-B533-D851C0251271}
VariablePath | \Package.Variables[User::CollectorTypeUID]


Package element

Package element: Counter

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | Counter
Namespace | User
QualifiedName | User::Counter
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::Counter]


Package element

Package element: InputParameters

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | InputParameters
Namespace | User
QualifiedName | User::InputParameters
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | <ns:SqlTraceCollector xmlns:ns="DataCollectorType" use_default="1"><Events/><Filters/></ns:SqlTraceCollector>
VariablePath | \Package.Variables[User::InputParameters]


Package element

Package element: MDWConnectionString

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | MDWConnectionString
Namespace | User
QualifiedName | User::MDWConnectionString
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=myMDW;APP=SQL Server Data Collector
VariablePath | \Package.Variables[User::MDWConnectionString]


Package element

Package element: RowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | RowCountIn
Namespace | User
QualifiedName | User::RowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::RowCountIn]


Package element

Package element: SnapshotID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | SnapshotID
Namespace | User
QualifiedName | User::SnapshotID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::SnapshotID]


Package element

Package element: TraceCurrentEventTime

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceCurrentEventTime
Namespace | User
QualifiedName | User::TraceCurrentEventTime
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 2007-03-13 14:28:51.820
VariablePath | \Package.Variables[User::TraceCurrentEventTime]


Package element

Package element: TraceCurrentFile

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceCurrentFile
Namespace | User
QualifiedName | User::TraceCurrentFile
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc
VariablePath | \Package.Variables[User::TraceCurrentFile]


Package element

Package element: TraceDroppedEventCount

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TraceDroppedEventCount
Namespace | User
QualifiedName | User::TraceDroppedEventCount
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceDroppedEventCount]


Package element

Package element: TraceInfoID

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TraceInfoID
Namespace | User
QualifiedName | User::TraceInfoID
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceInfoID]


Package element

Package element: TraceIsRunning

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | TraceIsRunning
Namespace | User
QualifiedName | User::TraceIsRunning
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceIsRunning]


Package element

Package element: TraceLastEventSequence

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceLastEventSequence
Namespace | User
QualifiedName | User::TraceLastEventSequence
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceLastEventSequence]


Package element

Package element: TraceLocation

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]
IncludeInDebugDump | False
Name | TraceLocation
Namespace | User
QualifiedName | User::TraceLocation
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | \DC_Trace_ALEN-PC.MSSQL.1..0
VariablePath | \Package.Variables[User::TraceLocation]


Package element

Package element: TraceStartTime

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceStartTime
Namespace | User
QualifiedName | User::TraceStartTime
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 2007-03-13 14:24:40.000
VariablePath | \Package.Variables[User::TraceStartTime]


Package element

Package element: TraceUseDefault

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | TraceUseDefault
Namespace | User
QualifiedName | User::TraceUseDefault
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package.Variables[User::TraceUseDefault]


Package element

Package element: MdwConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Initial Catalog=myMDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to upload collected data to a warehouse.
HasExpressions | True
HostType | ConnectionManager
ID | {6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}
InitialCatalog | myMDW
Name | MdwConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: TargetConnection

Collapse image Properties

Name | Value
ConnectionString | Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;
CreationName | OLEDB
DelayValidation | False
Description | Connection used to get information from the monitored (target) instance.
HasExpressions | True
HostType | ConnectionManager
ID | {607D54DC-E752-4779-9BB2-B3D19CAD0C76}
InitialCatalog |
Name | TargetConnection
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | True
Scope | Package
ServerName | (local)
SupportsDTCTransactions | True
UserName |

Collapse image Elements

Name | Description | Type
ConnectionString |  | Expressions
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package

Package: SqlTraceUpload

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceUpload

Collapse image Executables

Name | Description
For Loop Container | For Loop Container
SEQ - Default trace upload | Sequence Container
SQL - Close trace | Execute SQL Task
SQL - Get last upload time | Execute SQL Task
SQL - Get snapshot id | Execute SQL Task
SQL - Get trace info | Execute SQL Task
SQL - Update data source | Execute SQL Task
XML - Check use_default attribute | XML Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: For Loop Container

Collapse image Properties

Name | Value
AssignExpression | @Counter = @Counter + 1
CreationName | STOCK:FORLOOP
DebugMode | False
DelayValidation | False
Description | For Loop Container
Disable | False
DisableEventHandlers | False
EvalExpression | @Counter < 2
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {ECC401D1-FE83-46E6-AD37-0E1F711F0C62}
InitExpression | @Counter = 0
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | For Loop Container
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FEF - For each trace file - regular trace upload | Foreach Loop Container | Executables
SQL - Check trace info | Execute SQL Task | Executables
SQL - Close trace | Execute SQL Task | Executables
SQL - Get Last_Event_Sequence | Execute SQL Task | Executables
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: FEF - For each trace file - regular trace upload

CollapseAll image

Collapse image Properties

Name | Value
CreationName | STOCK:FOREACHLOOP
DebugMode | False
DelayValidation | False
Description | Foreach Loop Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
ID | {26A8C112-8CCB-4C21-BADC-77E438246248}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FEF - For each trace file - regular trace upload
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Upload trace file | Data Flow Task | Executables
FAT - Check if trace file is accessible | File Access Task | Executables
FAT - Precheck if trace file is accessible | File Access Task | Executables
FST - Delete trace file | File System Task | Executables
SQL - Log package stats | Logs statistics about the most recent Data Flow Task | Executables
SQL - logs uploaded file name | SQL - logs uploaded file name | Executables
{821B0536-E431-458F-8EAE-028BE667F142} |  | ForEachEnumerator
Constraint |  | PrecedenceConstraints
Constraint 1 |  | PrecedenceConstraints
Constraint 2 |  | PrecedenceConstraints
Constraint 3 |  | PrecedenceConstraints
Constraint 4 |  | PrecedenceConstraints
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: DFT - Upload trace file

Collapse image Properties

Name | Value
[DRV - Add columns].[Derived Column Output].[dropped_event_count].[FriendlyExpression] | @[User::TraceDroppedEventCount]
[DRV - Add columns].[Derived Column Output].[is_running].[FriendlyExpression] | @[User::TraceIsRunning]
[DRV - Add columns].[Derived Column Output].[last_event_sequence].[FriendlyExpression] | ISNULL(EventSequence_Max) ? 0 : EventSequence_Max
[DRV - Add columns].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotID]
[DRV - Add columns].[Derived Column Output].[trace_info_id].[FriendlyExpression] | @[User::TraceInfoID]
[DRV - Add snapshot_id and trace_info_id].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @SnapshotID
[DRV - Add snapshot_id and trace_info_id].[Derived Column Output].[trace_info_id].[FriendlyExpression] | @[User::TraceInfoID]
[ODB - Update trace_info].[SqlCommand] | {call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {96A9329D-379F-466F-970B-4A97A3FCF7A1}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | DFT - Upload trace file
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
AGG - Get max value of EventSequence | Aggregates and groups values in a dataset. | ComponentMetaDataCollection
CNT - Error row count source | Counts the rows in a dataset. | ComponentMetaDataCollection
CNT - Input row count | Counts the rows in a dataset. | ComponentMetaDataCollection
CNT - Output row count | Counts the rows in a dataset. | ComponentMetaDataCollection
Data Conversion | Data Conversion | ComponentMetaDataCollection
DRV - Add columns | Updates column values using expressions | ComponentMetaDataCollection
DRV - Add snapshot_id and trace_info_id | Updates column values using expressions | ComponentMetaDataCollection
MLT - Split two ways | Creates copies of a dataset. | ComponentMetaDataCollection
ODB - Read trace | OLE DB Source | ComponentMetaDataCollection
ODB - Update trace_info | Executes an SQL command for each row in a dataset. | ComponentMetaDataCollection
ODB - Write to output table | OLE DB Destination | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Aggregate Output 1 |  | PathCollection
Data Conversion Output |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Multicast Output 1 |  | PathCollection
Multicast Output 2 |  | PathCollection
OLE DB Source Error Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
TraceLoadScript |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables
SSIS diagram is missing


Package element

Package element: AGG - Get max value of EventSequence

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {C0FF41D9-3C8A-479F-A931-ECF1BF3587AB}
ContactInfo | Aggregate;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;3
Description | Aggregates and groups values in a dataset.
ID | 2
IdentificationString | AGG - Get max value of EventSequence
IsDefaultLocale | True
LocaleID | English (United States)
Name | AGG - Get max value of EventSequence
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 3

Collapse image Elements

Name | Description | Type
KeyScale | Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used. | CustomPropertyCollection
Keys | Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence. | CustomPropertyCollection
CountDistinctScale | Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used. | CustomPropertyCollection
CountDistinctKeys | Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence. | CustomPropertyCollection
AutoExtendFactor | Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100. | CustomPropertyCollection
Aggregate Input 1 |  | InputCollection
Aggregate Output 1 |  | OutputCollection


Package element

Package element: KeyScale

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 3
IdentificationString | AGG - Get max value of EventSequence.Properties[KeyScale]
Name | KeyScale
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | KeyScaleType
UITypeEditor |
Value | 0


Package element

Package element: Keys

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 4
IdentificationString | AGG - Get max value of EventSequence.Properties[Keys]
Name | Keys
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: CountDistinctScale

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 5
IdentificationString | AGG - Get max value of EventSequence.Properties[CountDistinctScale]
Name | CountDistinctScale
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | KeyScaleType
UITypeEditor |
Value | 0


Package element

Package element: CountDistinctKeys

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 6
IdentificationString | AGG - Get max value of EventSequence.Properties[CountDistinctKeys]
Name | CountDistinctKeys
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: AutoExtendFactor

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 7
IdentificationString | AGG - Get max value of EventSequence.Properties[AutoExtendFactor]
Name | AutoExtendFactor
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 25


Package element

Package element: Aggregate Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 8
IdentificationString | AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]
IsAttached | True
IsSorted | False
Name | Aggregate Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
EventSequence |  | InputColumnCollection


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 9
IdentificationString | AGG - Get max value of EventSequence.Inputs[Aggregate Input 1].Columns[EventSequence]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 150
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Aggregate Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 10
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Aggregate Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
KeyScale | Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used. | CustomPropertyCollection
Keys | Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence. | CustomPropertyCollection
EventSequence_Max |  | OutputColumnCollection
event_count |  | OutputColumnCollection


Package element

Package element: KeyScale

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Properties[KeyScale]
Name | KeyScale
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | KeyScaleType
UITypeEditor |
Value | 0


Package element

Package element: Keys

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Properties[Keys]
Name | Keys
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: EventSequence_Max

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 13
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]
Length | 0
LineageID | 13
MappedColumnID | 0
Name | EventSequence_Max
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
AggregationColumnId | Specifies the ID of the input column used in the aggregation. | CustomPropertyCollection
AggregationType | Specifies the type of aggregation. | CustomPropertyCollection
IsBig | Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type. | CustomPropertyCollection
AggregationComparisonFlags | Specifies the string comparison options. | CustomPropertyCollection


Package element

Package element: AggregationColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the ID of the input column used in the aggregation.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max].Properties[AggregationColumnId]
Name | AggregationColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 150


Package element

Package element: AggregationType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of aggregation.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max].Properties[AggregationType]
Name | AggregationType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AggregationType
UITypeEditor |
Value | 7


Package element

Package element: IsBig

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 16
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max].Properties[IsBig]
Name | IsBig
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: AggregationComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the string comparison options.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 17
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max].Properties[AggregationComparisonFlags]
Name | AggregationComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: event_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_UI8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 18
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]
Length | 0
LineageID | 18
MappedColumnID | 0
Name | event_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
AggregationColumnId | Specifies the ID of the input column used in the aggregation. | CustomPropertyCollection
AggregationType | Specifies the type of aggregation. | CustomPropertyCollection
IsBig | Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type. | CustomPropertyCollection
AggregationComparisonFlags | Specifies the string comparison options. | CustomPropertyCollection


Package element

Package element: AggregationColumnId

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the ID of the input column used in the aggregation.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count].Properties[AggregationColumnId]
Name | AggregationColumnId
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: AggregationType

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the type of aggregation.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 20
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count].Properties[AggregationType]
Name | AggregationType
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AggregationType
UITypeEditor |
Value | 2


Package element

Package element: IsBig

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 21
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count].Properties[IsBig]
Name | IsBig
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1


Package element

Package element: AggregationComparisonFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the string comparison options.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 22
IdentificationString | AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count].Properties[AggregationComparisonFlags]
Name | AggregationComparisonFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: CNT - Error row count source

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 23
IdentificationString | CNT - Error row count source
IsDefaultLocale | True
LocaleID | English (United States)
Name | CNT - Error row count source
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 24
IdentificationString | CNT - Error row count source.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountError


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 25
IdentificationString | CNT - Error row count source.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 26
IdentificationString | CNT - Error row count source.Outputs[Row Count Output 1]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 25
TruncationRowDisposition | RD_NotUsed


Package element

Package element: CNT - Input row count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 27
IdentificationString | CNT - Input row count
IsDefaultLocale | True
LocaleID | English (United States)
Name | CNT - Input row count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 28
IdentificationString | CNT - Input row count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountIn


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 29
IdentificationString | CNT - Input row count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 30
IdentificationString | CNT - Input row count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 29
TruncationRowDisposition | RD_NotUsed


Package element

Package element: CNT - Output row count

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A5CACDE5-7E68-46E3-82D0-583132BF7538}
ContactInfo | Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Counts the rows in a dataset.
ID | 31
IdentificationString | CNT - Output row count
IsDefaultLocale | True
LocaleID | English (United States)
Name | CNT - Output row count
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
VariableName | Specifies the variable to hold the row count. | CustomPropertyCollection
Row Count Input 1 |  | InputCollection
Row Count Output 1 |  | OutputCollection


Package element

Package element: VariableName

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable to hold the row count.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 32
IdentificationString | CNT - Output row count.Properties[VariableName]
Name | VariableName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::RowCountOut


Package element

Package element: Row Count Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | True
ID | 33
IdentificationString | CNT - Output row count.Inputs[Row Count Input 1]
IsAttached | True
IsSorted | False
Name | Row Count Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 34
IdentificationString | CNT - Output row count.Outputs[Row Count Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Row Count Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 33
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Data Conversion

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {600C47E0-558E-483B-9B86-5FB4328433D1}
ContactInfo | Data Conversion;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Data Conversion
ID | 35
IdentificationString | Data Conversion
IsDefaultLocale | True
LocaleID | English (United States)
Name | Data Conversion
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Data Conversion Input |  | InputCollection
Data Conversion Output |  | OutputCollection
Data Conversion Error Output |  | OutputCollection


Package element

Package element: Data Conversion Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 36
IdentificationString | Data Conversion.Inputs[Data Conversion Input]
IsAttached | True
IsSorted | False
Name | Data Conversion Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SqlHandle |  | InputColumnCollection
PlanHandle |  | InputColumnCollection


Package element

Package element: SqlHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 37
IdentificationString | Data Conversion.Inputs[Data Conversion Input].Columns[SqlHandle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 162
MappedColumnID | 0
Name | SqlHandle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: PlanHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 38
IdentificationString | Data Conversion.Inputs[Data Conversion Input].Columns[PlanHandle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 164
MappedColumnID | 0
Name | PlanHandle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Data Conversion Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 39
IdentificationString | Data Conversion.Outputs[Data Conversion Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Data Conversion Output
ObjectType | OT_OUTPUT
SynchronousInputID | 36
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
SqlHandle64 |  | OutputColumnCollection
PlanHandle64 |  | OutputColumnCollection


Package element

Package element: SqlHandle64

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_IgnoreFailure
ExternalMetadataColumnID | 0
ID | 40
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]
Length | 64
LineageID | 40
MappedColumnID | 0
Name | SqlHandle64
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_IgnoreFailure

Collapse image Elements

Name | Description | Type
SourceInputColumnLineageID | Specifies the input column used as the source of data for the conversion. | CustomPropertyCollection
FastParse | Indicates whether the column uses the faster, locale-neutral parsing routines. | CustomPropertyCollection


Package element

Package element: SourceInputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the input column used as the source of data for the conversion.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 41
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64].Properties[SourceInputColumnLineageID]
Name | SourceInputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 162


Package element

Package element: FastParse

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the column uses the faster, locale-neutral parsing routines.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 42
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64].Properties[FastParse]
Name | FastParse
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: PlanHandle64

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_IgnoreFailure
ExternalMetadataColumnID | 0
ID | 43
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]
Length | 64
LineageID | 43
MappedColumnID | 0
Name | PlanHandle64
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_IgnoreFailure

Collapse image Elements

Name | Description | Type
SourceInputColumnLineageID | Specifies the input column used as the source of data for the conversion. | CustomPropertyCollection
FastParse | Indicates whether the column uses the faster, locale-neutral parsing routines. | CustomPropertyCollection


Package element

Package element: SourceInputColumnLineageID

Collapse image Properties

Name | Value
ContainsID | True
Description | Specifies the input column used as the source of data for the conversion.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 44
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64].Properties[SourceInputColumnLineageID]
Name | SourceInputColumnLineageID
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 164


Package element

Package element: FastParse

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the column uses the faster, locale-neutral parsing routines.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 45
IdentificationString | Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64].Properties[FastParse]
Name | FastParse
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: Data Conversion Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 46
IdentificationString | Data Conversion.Outputs[Data Conversion Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Data Conversion Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 36
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 47
IdentificationString | Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]
Length | 0
LineageID | 47
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 48
IdentificationString | Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 48
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRV - Add columns

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 49
IdentificationString | DRV - Add columns
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add columns
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 50
IdentificationString | DRV - Add columns.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
EventSequence_Max |  | InputColumnCollection


Package element

Package element: EventSequence_Max

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 51
IdentificationString | DRV - Add columns.Inputs[Derived Column Input].Columns[EventSequence_Max]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 13
MappedColumnID | 0
Name | EventSequence_Max
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | AGG - Get max value of EventSequence
UsageType | UT_READONLY


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 52
IdentificationString | DRV - Add columns.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 50
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
trace_info_id |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection
is_running |  | OutputColumnCollection
dropped_event_count |  | OutputColumnCollection
last_event_sequence |  | OutputColumnCollection


Package element

Package element: trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 53
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]
Length | 0
LineageID | 53
MappedColumnID | 0
Name | trace_info_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 54
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceInfoID]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 55
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceInfoID]


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 56
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 56
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 57
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotID]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 58
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::SnapshotID]


Package element

Package element: is_running

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 59
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]
Length | 0
LineageID | 59
MappedColumnID | 0
Name | is_running
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 60
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[is_running].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceIsRunning]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 61
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[is_running].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceIsRunning]


Package element

Package element: dropped_event_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 62
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]
Length | 0
LineageID | 62
MappedColumnID | 0
Name | dropped_event_count
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 63
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceDroppedEventCount]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 64
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceDroppedEventCount]


Package element

Package element: last_event_sequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 65
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]
Length | 0
LineageID | 65
MappedColumnID | 0
Name | last_event_sequence
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 66
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [ISNULL](#13) ? 0 : #13


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 67
IdentificationString | DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | ISNULL(EventSequence_Max) ? 0 : EventSequence_Max


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 68
IdentificationString | DRV - Add columns.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 50
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 69
IdentificationString | DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 69
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 70
IdentificationString | DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 70
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DRV - Add snapshot_id and trace_info_id

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {A2034F5D-D283-4218-A4AF-AE11AD34B886}
ContactInfo | Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Updates column values using expressions
ID | 71
IdentificationString | DRV - Add snapshot_id and trace_info_id
IsDefaultLocale | True
LocaleID | English (United States)
Name | DRV - Add snapshot_id and trace_info_id
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | False
Version | 0

Collapse image Elements

Name | Description | Type
Derived Column Input | Input to the Derived Column Transformation | InputCollection
Derived Column Output | Default Output of the Derived Column Transformation | OutputCollection
Derived Column Error Output | Error Output of the Derived Column Transformation | OutputCollection


Package element

Package element: Derived Column Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description | Input to the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 72
IdentificationString | DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]
IsAttached | True
IsSorted | False
Name | Derived Column Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Default Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 73
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Derived Column Output
ObjectType | OT_OUTPUT
SynchronousInputID | 72
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
trace_info_id |  | OutputColumnCollection
snapshot_id |  | OutputColumnCollection


Package element

Package element: trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 74
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]
Length | 0
LineageID | 74
MappedColumnID | 0
Name | trace_info_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 75
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceInfoID]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 76
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[User::TraceInfoID]


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Computation
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 0
ID | 77
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]
Length | 0
LineageID | 77
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent

Collapse image Elements

Name | Description | Type
Expression | Derived Column Expression | CustomPropertyCollection
FriendlyExpression | Derived Column Friendly Expression | CustomPropertyCollection


Package element

Package element: Expression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Expression
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 78
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id].Properties[Expression]
Name | Expression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @[SnapshotID]


Package element

Package element: FriendlyExpression

Collapse image Properties

Name | Value
ContainsID | True
Description | Derived Column Friendly Expression
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 79
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id].Properties[FriendlyExpression]
Name | FriendlyExpression
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | @SnapshotID


Package element

Package element: Derived Column Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description | Error Output of the Derived Column Transformation
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 80
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | Derived Column Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 72
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 81
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]
Length | 0
LineageID | 81
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 82
IdentificationString | DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 82
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MLT - Split two ways

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {EFE6B902-7646-42C1-96BB-21D1AB56DD74}
ContactInfo | Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0
Description | Creates copies of a dataset.
ID | 83
IdentificationString | MLT - Split two ways
IsDefaultLocale | True
LocaleID | English (United States)
Name | MLT - Split two ways
ObjectType | 12
PipelineVersion | 0
UsesDispositions | False
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
Multicast Input 1 |  | InputCollection
Multicast Output 1 |  | OutputCollection
Multicast Output 2 |  | OutputCollection
Multicast Output 3 |  | OutputCollection


Package element

Package element: Multicast Input 1

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
HasSideEffects | False
ID | 84
IdentificationString | MLT - Split two ways.Inputs[Multicast Input 1]
IsAttached | True
IsSorted | False
Name | Multicast Input 1
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 85
IdentificationString | MLT - Split two ways.Outputs[Multicast Output 1]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 1
ObjectType | OT_OUTPUT
SynchronousInputID | 84
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 86
IdentificationString | MLT - Split two ways.Outputs[Multicast Output 2]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Multicast Output 2
ObjectType | OT_OUTPUT
SynchronousInputID | 84
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Multicast Output 3

Collapse image Properties

Name | Value
Dangling | True
DeleteOutputOnPathDetached | True
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 87
IdentificationString | MLT - Split two ways.Outputs[Multicast Output 3]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | Multicast Output 3
ObjectType | OT_OUTPUT
SynchronousInputID | 84
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ODB - Read trace

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {657B7EBE-0A54-4C0E-A80E-7A5BD9886C25}
ContactInfo | OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 88
IdentificationString | ODB - Read trace
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODB - Read trace
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | False
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 89
IdentificationString | ODB - Read trace.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 90
IdentificationString | ODB - Read trace.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 91
IdentificationString | ODB - Read trace.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 92
IdentificationString | ODB - Read trace.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 93
IdentificationString | ODB - Read trace.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | User::TraceLoadScript


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 94
IdentificationString | ODB - Read trace.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 95
IdentificationString | ODB - Read trace.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 96
IdentificationString | ODB - Read trace.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 97
IdentificationString | ODB - Read trace.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 99
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
TextData |  | ExternalMetadataColumnCollection
BinaryData |  | ExternalMetadataColumnCollection
DatabaseID |  | ExternalMetadataColumnCollection
TransactionID |  | ExternalMetadataColumnCollection
LineNumber |  | ExternalMetadataColumnCollection
NTUserName |  | ExternalMetadataColumnCollection
NTDomainName |  | ExternalMetadataColumnCollection
HostName |  | ExternalMetadataColumnCollection
ClientProcessID |  | ExternalMetadataColumnCollection
ApplicationName |  | ExternalMetadataColumnCollection
LoginName |  | ExternalMetadataColumnCollection
SPID |  | ExternalMetadataColumnCollection
Duration |  | ExternalMetadataColumnCollection
StartTime |  | ExternalMetadataColumnCollection
EndTime |  | ExternalMetadataColumnCollection
Reads |  | ExternalMetadataColumnCollection
Writes |  | ExternalMetadataColumnCollection
CPU |  | ExternalMetadataColumnCollection
Permissions |  | ExternalMetadataColumnCollection
Severity |  | ExternalMetadataColumnCollection
EventSubClass |  | ExternalMetadataColumnCollection
ObjectID |  | ExternalMetadataColumnCollection
Success |  | ExternalMetadataColumnCollection
IndexID |  | ExternalMetadataColumnCollection
IntegerData |  | ExternalMetadataColumnCollection
ServerName |  | ExternalMetadataColumnCollection
EventClass |  | ExternalMetadataColumnCollection
ObjectType |  | ExternalMetadataColumnCollection
NestLevel |  | ExternalMetadataColumnCollection
State |  | ExternalMetadataColumnCollection
Error |  | ExternalMetadataColumnCollection
Mode |  | ExternalMetadataColumnCollection
Handle |  | ExternalMetadataColumnCollection
ObjectName |  | ExternalMetadataColumnCollection
DatabaseName |  | ExternalMetadataColumnCollection
FileName |  | ExternalMetadataColumnCollection
OwnerName |  | ExternalMetadataColumnCollection
RoleName |  | ExternalMetadataColumnCollection
TargetUserName |  | ExternalMetadataColumnCollection
DBUserName |  | ExternalMetadataColumnCollection
LoginSid |  | ExternalMetadataColumnCollection
TargetLoginName |  | ExternalMetadataColumnCollection
TargetLoginSid |  | ExternalMetadataColumnCollection
ColumnPermissions |  | ExternalMetadataColumnCollection
LinkedServerName |  | ExternalMetadataColumnCollection
ProviderName |  | ExternalMetadataColumnCollection
MethodName |  | ExternalMetadataColumnCollection
RowCounts |  | ExternalMetadataColumnCollection
RequestID |  | ExternalMetadataColumnCollection
XactSequence |  | ExternalMetadataColumnCollection
EventSequence |  | ExternalMetadataColumnCollection
BigintData1 |  | ExternalMetadataColumnCollection
BigintData2 |  | ExternalMetadataColumnCollection
GUID |  | ExternalMetadataColumnCollection
IntegerData2 |  | ExternalMetadataColumnCollection
ObjectID2 |  | ExternalMetadataColumnCollection
Type |  | ExternalMetadataColumnCollection
OwnerID |  | ExternalMetadataColumnCollection
ParentName |  | ExternalMetadataColumnCollection
IsSystem |  | ExternalMetadataColumnCollection
Offset |  | ExternalMetadataColumnCollection
SourceDatabaseID |  | ExternalMetadataColumnCollection
SqlHandle |  | ExternalMetadataColumnCollection
SessionLoginName |  | ExternalMetadataColumnCollection
PlanHandle |  | ExternalMetadataColumnCollection
GroupID |  | ExternalMetadataColumnCollection
TextData |  | OutputColumnCollection
BinaryData |  | OutputColumnCollection
DatabaseID |  | OutputColumnCollection
TransactionID |  | OutputColumnCollection
LineNumber |  | OutputColumnCollection
NTUserName |  | OutputColumnCollection
NTDomainName |  | OutputColumnCollection
HostName |  | OutputColumnCollection
ClientProcessID |  | OutputColumnCollection
ApplicationName |  | OutputColumnCollection
LoginName |  | OutputColumnCollection
SPID |  | OutputColumnCollection
Duration |  | OutputColumnCollection
StartTime |  | OutputColumnCollection
EndTime |  | OutputColumnCollection
Reads |  | OutputColumnCollection
Writes |  | OutputColumnCollection
CPU |  | OutputColumnCollection
Permissions |  | OutputColumnCollection
Severity |  | OutputColumnCollection
EventSubClass |  | OutputColumnCollection
ObjectID |  | OutputColumnCollection
Success |  | OutputColumnCollection
IndexID |  | OutputColumnCollection
IntegerData |  | OutputColumnCollection
ServerName |  | OutputColumnCollection
EventClass |  | OutputColumnCollection
ObjectType |  | OutputColumnCollection
NestLevel |  | OutputColumnCollection
State |  | OutputColumnCollection
Error |  | OutputColumnCollection
Mode |  | OutputColumnCollection
Handle |  | OutputColumnCollection
ObjectName |  | OutputColumnCollection
DatabaseName |  | OutputColumnCollection
FileName |  | OutputColumnCollection
OwnerName |  | OutputColumnCollection
RoleName |  | OutputColumnCollection
TargetUserName |  | OutputColumnCollection
DBUserName |  | OutputColumnCollection
LoginSid |  | OutputColumnCollection
TargetLoginName |  | OutputColumnCollection
TargetLoginSid |  | OutputColumnCollection
ColumnPermissions |  | OutputColumnCollection
LinkedServerName |  | OutputColumnCollection
ProviderName |  | OutputColumnCollection
MethodName |  | OutputColumnCollection
RowCounts |  | OutputColumnCollection
RequestID |  | OutputColumnCollection
XactSequence |  | OutputColumnCollection
EventSequence |  | OutputColumnCollection
BigintData1 |  | OutputColumnCollection
BigintData2 |  | OutputColumnCollection
GUID |  | OutputColumnCollection
IntegerData2 |  | OutputColumnCollection
ObjectID2 |  | OutputColumnCollection
Type |  | OutputColumnCollection
OwnerID |  | OutputColumnCollection
ParentName |  | OutputColumnCollection
IsSystem |  | OutputColumnCollection
Offset |  | OutputColumnCollection
SourceDatabaseID |  | OutputColumnCollection
SqlHandle |  | OutputColumnCollection
SessionLoginName |  | OutputColumnCollection
PlanHandle |  | OutputColumnCollection
GroupID |  | OutputColumnCollection


Package element

Package element: TextData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 166
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]
Length | 0
MappedColumnID | 0
Name | TextData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BinaryData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 167
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]
Length | 0
MappedColumnID | 0
Name | BinaryData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DatabaseID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 168
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]
Length | 0
MappedColumnID | 0
Name | DatabaseID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TransactionID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 169
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]
Length | 0
MappedColumnID | 0
Name | TransactionID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LineNumber

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 170
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]
Length | 0
MappedColumnID | 0
Name | LineNumber
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NTUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 171
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]
Length | 256
MappedColumnID | 0
Name | NTUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NTDomainName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 172
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]
Length | 256
MappedColumnID | 0
Name | NTDomainName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: HostName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 173
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]
Length | 256
MappedColumnID | 0
Name | HostName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ClientProcessID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 174
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]
Length | 0
MappedColumnID | 0
Name | ClientProcessID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ApplicationName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 175
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]
Length | 256
MappedColumnID | 0
Name | ApplicationName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 176
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]
Length | 256
MappedColumnID | 0
Name | LoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SPID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 177
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]
Length | 0
MappedColumnID | 0
Name | SPID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Duration

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 178
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]
Length | 0
MappedColumnID | 0
Name | Duration
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: StartTime

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 179
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]
Length | 0
MappedColumnID | 0
Name | StartTime
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EndTime

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 180
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]
Length | 0
MappedColumnID | 0
Name | EndTime
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 181
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]
Length | 0
MappedColumnID | 0
Name | Reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 182
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]
Length | 0
MappedColumnID | 0
Name | Writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: CPU

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 183
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]
Length | 0
MappedColumnID | 0
Name | CPU
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Permissions

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 184
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]
Length | 0
MappedColumnID | 0
Name | Permissions
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Severity

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 185
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]
Length | 0
MappedColumnID | 0
Name | Severity
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventSubClass

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 186
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]
Length | 0
MappedColumnID | 0
Name | EventSubClass
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 187
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]
Length | 0
MappedColumnID | 0
Name | ObjectID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Success

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 188
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]
Length | 0
MappedColumnID | 0
Name | Success
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IndexID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 189
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]
Length | 0
MappedColumnID | 0
Name | IndexID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IntegerData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 190
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]
Length | 0
MappedColumnID | 0
Name | IntegerData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ServerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 191
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]
Length | 256
MappedColumnID | 0
Name | ServerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventClass

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 192
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]
Length | 0
MappedColumnID | 0
Name | EventClass
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectType

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 193
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]
Length | 0
MappedColumnID | 0
Name | ObjectType
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NestLevel

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 194
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]
Length | 0
MappedColumnID | 0
Name | NestLevel
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: State

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 195
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]
Length | 0
MappedColumnID | 0
Name | State
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 196
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]
Length | 0
MappedColumnID | 0
Name | Error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Mode

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 197
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]
Length | 0
MappedColumnID | 0
Name | Mode
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 198
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]
Length | 0
MappedColumnID | 0
Name | Handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 199
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]
Length | 256
MappedColumnID | 0
Name | ObjectName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DatabaseName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 200
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]
Length | 256
MappedColumnID | 0
Name | DatabaseName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: FileName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 201
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]
Length | 256
MappedColumnID | 0
Name | FileName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: OwnerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 202
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]
Length | 256
MappedColumnID | 0
Name | OwnerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RoleName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 203
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]
Length | 256
MappedColumnID | 0
Name | RoleName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 204
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]
Length | 256
MappedColumnID | 0
Name | TargetUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DBUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 205
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]
Length | 256
MappedColumnID | 0
Name | DBUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LoginSid

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 206
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]
Length | 0
MappedColumnID | 0
Name | LoginSid
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetLoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 207
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]
Length | 256
MappedColumnID | 0
Name | TargetLoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetLoginSid

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 208
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]
Length | 0
MappedColumnID | 0
Name | TargetLoginSid
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ColumnPermissions

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 209
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]
Length | 0
MappedColumnID | 0
Name | ColumnPermissions
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LinkedServerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 210
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]
Length | 256
MappedColumnID | 0
Name | LinkedServerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ProviderName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 211
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]
Length | 256
MappedColumnID | 0
Name | ProviderName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: MethodName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 212
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]
Length | 256
MappedColumnID | 0
Name | MethodName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RowCounts

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 213
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]
Length | 0
MappedColumnID | 0
Name | RowCounts
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RequestID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 214
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]
Length | 0
MappedColumnID | 0
Name | RequestID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: XactSequence

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 215
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]
Length | 0
MappedColumnID | 0
Name | XactSequence
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 216
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]
Length | 0
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BigintData1

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 217
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]
Length | 0
MappedColumnID | 0
Name | BigintData1
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BigintData2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 218
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]
Length | 0
MappedColumnID | 0
Name | BigintData2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: GUID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_GUID
Description |
ID | 219
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]
Length | 0
MappedColumnID | 0
Name | GUID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IntegerData2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 220
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]
Length | 0
MappedColumnID | 0
Name | IntegerData2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectID2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 221
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]
Length | 0
MappedColumnID | 0
Name | ObjectID2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 222
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]
Length | 0
MappedColumnID | 0
Name | Type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: OwnerID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 223
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]
Length | 0
MappedColumnID | 0
Name | OwnerID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ParentName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 224
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]
Length | 256
MappedColumnID | 0
Name | ParentName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IsSystem

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 225
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]
Length | 0
MappedColumnID | 0
Name | IsSystem
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 226
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]
Length | 0
MappedColumnID | 0
Name | Offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SourceDatabaseID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 227
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]
Length | 0
MappedColumnID | 0
Name | SourceDatabaseID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SqlHandle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 228
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]
Length | 0
MappedColumnID | 0
Name | SqlHandle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SessionLoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 229
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]
Length | 256
MappedColumnID | 0
Name | SessionLoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: PlanHandle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 230
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]
Length | 0
MappedColumnID | 0
Name | PlanHandle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: GroupID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 231
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]
Length | 0
MappedColumnID | 0
Name | GroupID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TextData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 166
ID | 100
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]
Length | 0
LineageID | 100
MappedColumnID | 0
Name | TextData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: BinaryData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 167
ID | 101
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]
Length | 0
LineageID | 101
MappedColumnID | 0
Name | BinaryData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: DatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 168
ID | 102
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]
Length | 0
LineageID | 102
MappedColumnID | 0
Name | DatabaseID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: TransactionID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 169
ID | 103
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]
Length | 0
LineageID | 103
MappedColumnID | 0
Name | TransactionID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: LineNumber

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 170
ID | 104
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]
Length | 0
LineageID | 104
MappedColumnID | 0
Name | LineNumber
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: NTUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 171
ID | 105
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]
Length | 256
LineageID | 105
MappedColumnID | 0
Name | NTUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: NTDomainName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 172
ID | 106
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]
Length | 256
LineageID | 106
MappedColumnID | 0
Name | NTDomainName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: HostName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 173
ID | 107
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]
Length | 256
LineageID | 107
MappedColumnID | 0
Name | HostName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ClientProcessID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 174
ID | 108
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]
Length | 0
LineageID | 108
MappedColumnID | 0
Name | ClientProcessID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ApplicationName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 175
ID | 109
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]
Length | 256
LineageID | 109
MappedColumnID | 0
Name | ApplicationName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: LoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 176
ID | 110
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]
Length | 256
LineageID | 110
MappedColumnID | 0
Name | LoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: SPID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 177
ID | 111
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]
Length | 0
LineageID | 111
MappedColumnID | 0
Name | SPID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Duration

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 178
ID | 112
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]
Length | 0
LineageID | 112
MappedColumnID | 0
Name | Duration
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: StartTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 179
ID | 113
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]
Length | 0
LineageID | 113
MappedColumnID | 0
Name | StartTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: EndTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 180
ID | 114
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]
Length | 0
LineageID | 114
MappedColumnID | 0
Name | EndTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 181
ID | 115
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]
Length | 0
LineageID | 115
MappedColumnID | 0
Name | Reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 182
ID | 116
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]
Length | 0
LineageID | 116
MappedColumnID | 0
Name | Writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: CPU

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 183
ID | 117
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]
Length | 0
LineageID | 117
MappedColumnID | 0
Name | CPU
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Permissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 184
ID | 118
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]
Length | 0
LineageID | 118
MappedColumnID | 0
Name | Permissions
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Severity

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 185
ID | 119
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]
Length | 0
LineageID | 119
MappedColumnID | 0
Name | Severity
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: EventSubClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 186
ID | 120
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]
Length | 0
LineageID | 120
MappedColumnID | 0
Name | EventSubClass
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ObjectID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 187
ID | 121
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]
Length | 0
LineageID | 121
MappedColumnID | 0
Name | ObjectID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Success

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 188
ID | 122
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]
Length | 0
LineageID | 122
MappedColumnID | 0
Name | Success
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: IndexID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 189
ID | 123
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]
Length | 0
LineageID | 123
MappedColumnID | 0
Name | IndexID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: IntegerData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 190
ID | 124
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]
Length | 0
LineageID | 124
MappedColumnID | 0
Name | IntegerData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 191
ID | 125
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]
Length | 256
LineageID | 125
MappedColumnID | 0
Name | ServerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: EventClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 192
ID | 126
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]
Length | 0
LineageID | 126
MappedColumnID | 0
Name | EventClass
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ObjectType

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 193
ID | 127
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]
Length | 0
LineageID | 127
MappedColumnID | 0
Name | ObjectType
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: NestLevel

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 194
ID | 128
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]
Length | 0
LineageID | 128
MappedColumnID | 0
Name | NestLevel
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: State

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 195
ID | 129
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]
Length | 0
LineageID | 129
MappedColumnID | 0
Name | State
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 196
ID | 130
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]
Length | 0
LineageID | 130
MappedColumnID | 0
Name | Error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Mode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 197
ID | 131
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]
Length | 0
LineageID | 131
MappedColumnID | 0
Name | Mode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 198
ID | 132
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]
Length | 0
LineageID | 132
MappedColumnID | 0
Name | Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ObjectName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 199
ID | 133
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]
Length | 256
LineageID | 133
MappedColumnID | 0
Name | ObjectName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: DatabaseName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 200
ID | 134
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]
Length | 256
LineageID | 134
MappedColumnID | 0
Name | DatabaseName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: FileName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 201
ID | 135
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]
Length | 256
LineageID | 135
MappedColumnID | 0
Name | FileName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: OwnerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 202
ID | 136
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]
Length | 256
LineageID | 136
MappedColumnID | 0
Name | OwnerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: RoleName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 203
ID | 137
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]
Length | 256
LineageID | 137
MappedColumnID | 0
Name | RoleName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: TargetUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 204
ID | 138
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]
Length | 256
LineageID | 138
MappedColumnID | 0
Name | TargetUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: DBUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 205
ID | 139
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]
Length | 256
LineageID | 139
MappedColumnID | 0
Name | DBUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: LoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 206
ID | 140
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]
Length | 0
LineageID | 140
MappedColumnID | 0
Name | LoginSid
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: TargetLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 207
ID | 141
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]
Length | 256
LineageID | 141
MappedColumnID | 0
Name | TargetLoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: TargetLoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 208
ID | 142
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]
Length | 0
LineageID | 142
MappedColumnID | 0
Name | TargetLoginSid
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ColumnPermissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 209
ID | 143
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]
Length | 0
LineageID | 143
MappedColumnID | 0
Name | ColumnPermissions
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: LinkedServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 210
ID | 144
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]
Length | 256
LineageID | 144
MappedColumnID | 0
Name | LinkedServerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ProviderName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 211
ID | 145
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]
Length | 256
LineageID | 145
MappedColumnID | 0
Name | ProviderName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: MethodName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 212
ID | 146
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]
Length | 256
LineageID | 146
MappedColumnID | 0
Name | MethodName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: RowCounts

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 213
ID | 147
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]
Length | 0
LineageID | 147
MappedColumnID | 0
Name | RowCounts
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: RequestID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 214
ID | 148
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]
Length | 0
LineageID | 148
MappedColumnID | 0
Name | RequestID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: XactSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 215
ID | 149
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]
Length | 0
LineageID | 149
MappedColumnID | 0
Name | XactSequence
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 216
ID | 150
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]
Length | 0
LineageID | 150
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: BigintData1

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 217
ID | 151
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]
Length | 0
LineageID | 151
MappedColumnID | 0
Name | BigintData1
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: BigintData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 218
ID | 152
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]
Length | 0
LineageID | 152
MappedColumnID | 0
Name | BigintData2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: GUID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_GUID
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 219
ID | 153
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]
Length | 0
LineageID | 153
MappedColumnID | 0
Name | GUID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: IntegerData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 220
ID | 154
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]
Length | 0
LineageID | 154
MappedColumnID | 0
Name | IntegerData2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ObjectID2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 221
ID | 155
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]
Length | 0
LineageID | 155
MappedColumnID | 0
Name | ObjectID2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 222
ID | 156
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]
Length | 0
LineageID | 156
MappedColumnID | 0
Name | Type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: OwnerID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 223
ID | 157
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]
Length | 0
LineageID | 157
MappedColumnID | 0
Name | OwnerID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: ParentName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 224
ID | 158
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]
Length | 256
LineageID | 158
MappedColumnID | 0
Name | ParentName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: IsSystem

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 225
ID | 159
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]
Length | 0
LineageID | 159
MappedColumnID | 0
Name | IsSystem
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: Offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 226
ID | 160
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]
Length | 0
LineageID | 160
MappedColumnID | 0
Name | Offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: SourceDatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 227
ID | 161
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]
Length | 0
LineageID | 161
MappedColumnID | 0
Name | SourceDatabaseID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: SqlHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 228
ID | 162
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]
Length | 0
LineageID | 162
MappedColumnID | 0
Name | SqlHandle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: SessionLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 229
ID | 163
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]
Length | 256
LineageID | 163
MappedColumnID | 0
Name | SessionLoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: PlanHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_RedirectRow
ExternalMetadataColumnID | 230
ID | 164
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]
Length | 0
LineageID | 164
MappedColumnID | 0
Name | PlanHandle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_RedirectRow


Package element

Package element: GroupID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 231
ID | 165
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]
Length | 0
LineageID | 165
MappedColumnID | 0
Name | GroupID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 232
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output]
IsAttached | True
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
TextData |  | OutputColumnCollection
BinaryData |  | OutputColumnCollection
DatabaseID |  | OutputColumnCollection
TransactionID |  | OutputColumnCollection
LineNumber |  | OutputColumnCollection
NTUserName |  | OutputColumnCollection
NTDomainName |  | OutputColumnCollection
HostName |  | OutputColumnCollection
ClientProcessID |  | OutputColumnCollection
ApplicationName |  | OutputColumnCollection
LoginName |  | OutputColumnCollection
SPID |  | OutputColumnCollection
Duration |  | OutputColumnCollection
StartTime |  | OutputColumnCollection
EndTime |  | OutputColumnCollection
Reads |  | OutputColumnCollection
Writes |  | OutputColumnCollection
CPU |  | OutputColumnCollection
Permissions |  | OutputColumnCollection
Severity |  | OutputColumnCollection
EventSubClass |  | OutputColumnCollection
ObjectID |  | OutputColumnCollection
Success |  | OutputColumnCollection
IndexID |  | OutputColumnCollection
IntegerData |  | OutputColumnCollection
ServerName |  | OutputColumnCollection
EventClass |  | OutputColumnCollection
ObjectType |  | OutputColumnCollection
NestLevel |  | OutputColumnCollection
State |  | OutputColumnCollection
Error |  | OutputColumnCollection
Mode |  | OutputColumnCollection
Handle |  | OutputColumnCollection
ObjectName |  | OutputColumnCollection
DatabaseName |  | OutputColumnCollection
FileName |  | OutputColumnCollection
OwnerName |  | OutputColumnCollection
RoleName |  | OutputColumnCollection
TargetUserName |  | OutputColumnCollection
DBUserName |  | OutputColumnCollection
LoginSid |  | OutputColumnCollection
TargetLoginName |  | OutputColumnCollection
TargetLoginSid |  | OutputColumnCollection
ColumnPermissions |  | OutputColumnCollection
LinkedServerName |  | OutputColumnCollection
ProviderName |  | OutputColumnCollection
MethodName |  | OutputColumnCollection
RowCounts |  | OutputColumnCollection
RequestID |  | OutputColumnCollection
XactSequence |  | OutputColumnCollection
EventSequence |  | OutputColumnCollection
BigintData1 |  | OutputColumnCollection
BigintData2 |  | OutputColumnCollection
GUID |  | OutputColumnCollection
IntegerData2 |  | OutputColumnCollection
ObjectID2 |  | OutputColumnCollection
Type |  | OutputColumnCollection
OwnerID |  | OutputColumnCollection
ParentName |  | OutputColumnCollection
IsSystem |  | OutputColumnCollection
Offset |  | OutputColumnCollection
SourceDatabaseID |  | OutputColumnCollection
SqlHandle |  | OutputColumnCollection
SessionLoginName |  | OutputColumnCollection
PlanHandle |  | OutputColumnCollection
GroupID |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: TextData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 233
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]
Length | 0
LineageID | 233
MappedColumnID | 0
Name | TextData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: BinaryData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 234
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]
Length | 0
LineageID | 234
MappedColumnID | 0
Name | BinaryData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 235
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]
Length | 0
LineageID | 235
MappedColumnID | 0
Name | DatabaseID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: TransactionID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 236
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]
Length | 0
LineageID | 236
MappedColumnID | 0
Name | TransactionID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: LineNumber

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 237
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]
Length | 0
LineageID | 237
MappedColumnID | 0
Name | LineNumber
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: NTUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 238
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]
Length | 256
LineageID | 238
MappedColumnID | 0
Name | NTUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: NTDomainName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 239
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]
Length | 256
LineageID | 239
MappedColumnID | 0
Name | NTDomainName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: HostName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 240
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]
Length | 256
LineageID | 240
MappedColumnID | 0
Name | HostName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ClientProcessID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 241
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]
Length | 0
LineageID | 241
MappedColumnID | 0
Name | ClientProcessID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ApplicationName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 242
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]
Length | 256
LineageID | 242
MappedColumnID | 0
Name | ApplicationName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: LoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 243
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]
Length | 256
LineageID | 243
MappedColumnID | 0
Name | LoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SPID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 244
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]
Length | 0
LineageID | 244
MappedColumnID | 0
Name | SPID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Duration

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 245
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]
Length | 0
LineageID | 245
MappedColumnID | 0
Name | Duration
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: StartTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 246
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]
Length | 0
LineageID | 246
MappedColumnID | 0
Name | StartTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: EndTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 247
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]
Length | 0
LineageID | 247
MappedColumnID | 0
Name | EndTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 248
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]
Length | 0
LineageID | 248
MappedColumnID | 0
Name | Reads
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 249
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]
Length | 0
LineageID | 249
MappedColumnID | 0
Name | Writes
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: CPU

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 250
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]
Length | 0
LineageID | 250
MappedColumnID | 0
Name | CPU
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Permissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 251
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]
Length | 0
LineageID | 251
MappedColumnID | 0
Name | Permissions
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Severity

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 252
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]
Length | 0
LineageID | 252
MappedColumnID | 0
Name | Severity
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: EventSubClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 253
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]
Length | 0
LineageID | 253
MappedColumnID | 0
Name | EventSubClass
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ObjectID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 254
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]
Length | 0
LineageID | 254
MappedColumnID | 0
Name | ObjectID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Success

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 255
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]
Length | 0
LineageID | 255
MappedColumnID | 0
Name | Success
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: IndexID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 256
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]
Length | 0
LineageID | 256
MappedColumnID | 0
Name | IndexID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: IntegerData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 257
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]
Length | 0
LineageID | 257
MappedColumnID | 0
Name | IntegerData
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 258
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]
Length | 256
LineageID | 258
MappedColumnID | 0
Name | ServerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: EventClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 259
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]
Length | 0
LineageID | 259
MappedColumnID | 0
Name | EventClass
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ObjectType

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 260
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]
Length | 0
LineageID | 260
MappedColumnID | 0
Name | ObjectType
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: NestLevel

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 261
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]
Length | 0
LineageID | 261
MappedColumnID | 0
Name | NestLevel
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: State

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 262
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]
Length | 0
LineageID | 262
MappedColumnID | 0
Name | State
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 263
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]
Length | 0
LineageID | 263
MappedColumnID | 0
Name | Error
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Mode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 264
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]
Length | 0
LineageID | 264
MappedColumnID | 0
Name | Mode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 265
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]
Length | 0
LineageID | 265
MappedColumnID | 0
Name | Handle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ObjectName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 266
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]
Length | 256
LineageID | 266
MappedColumnID | 0
Name | ObjectName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DatabaseName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 267
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]
Length | 256
LineageID | 267
MappedColumnID | 0
Name | DatabaseName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: FileName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 268
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]
Length | 256
LineageID | 268
MappedColumnID | 0
Name | FileName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OwnerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 269
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]
Length | 256
LineageID | 269
MappedColumnID | 0
Name | OwnerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RoleName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 270
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]
Length | 256
LineageID | 270
MappedColumnID | 0
Name | RoleName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: TargetUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 271
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]
Length | 256
LineageID | 271
MappedColumnID | 0
Name | TargetUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: DBUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 272
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]
Length | 256
LineageID | 272
MappedColumnID | 0
Name | DBUserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: LoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 273
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]
Length | 0
LineageID | 273
MappedColumnID | 0
Name | LoginSid
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: TargetLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 274
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]
Length | 256
LineageID | 274
MappedColumnID | 0
Name | TargetLoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: TargetLoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 275
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]
Length | 0
LineageID | 275
MappedColumnID | 0
Name | TargetLoginSid
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ColumnPermissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 276
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]
Length | 0
LineageID | 276
MappedColumnID | 0
Name | ColumnPermissions
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: LinkedServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 277
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]
Length | 256
LineageID | 277
MappedColumnID | 0
Name | LinkedServerName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ProviderName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 278
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]
Length | 256
LineageID | 278
MappedColumnID | 0
Name | ProviderName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: MethodName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 279
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]
Length | 256
LineageID | 279
MappedColumnID | 0
Name | MethodName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RowCounts

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 280
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]
Length | 0
LineageID | 280
MappedColumnID | 0
Name | RowCounts
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: RequestID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 281
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]
Length | 0
LineageID | 281
MappedColumnID | 0
Name | RequestID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: XactSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 282
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]
Length | 0
LineageID | 282
MappedColumnID | 0
Name | XactSequence
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 283
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]
Length | 0
LineageID | 283
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: BigintData1

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 284
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]
Length | 0
LineageID | 284
MappedColumnID | 0
Name | BigintData1
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: BigintData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 285
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]
Length | 0
LineageID | 285
MappedColumnID | 0
Name | BigintData2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: GUID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_GUID
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 286
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]
Length | 0
LineageID | 286
MappedColumnID | 0
Name | GUID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: IntegerData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 287
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]
Length | 0
LineageID | 287
MappedColumnID | 0
Name | IntegerData2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ObjectID2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 288
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]
Length | 0
LineageID | 288
MappedColumnID | 0
Name | ObjectID2
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 289
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]
Length | 0
LineageID | 289
MappedColumnID | 0
Name | Type
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OwnerID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 290
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]
Length | 0
LineageID | 290
MappedColumnID | 0
Name | OwnerID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ParentName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 291
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]
Length | 256
LineageID | 291
MappedColumnID | 0
Name | ParentName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: IsSystem

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 292
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]
Length | 0
LineageID | 292
MappedColumnID | 0
Name | IsSystem
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 293
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]
Length | 0
LineageID | 293
MappedColumnID | 0
Name | Offset
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SourceDatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 294
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]
Length | 0
LineageID | 294
MappedColumnID | 0
Name | SourceDatabaseID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SqlHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 295
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]
Length | 0
LineageID | 295
MappedColumnID | 0
Name | SqlHandle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: SessionLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 296
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]
Length | 256
LineageID | 296
MappedColumnID | 0
Name | SessionLoginName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: PlanHandle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 297
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]
Length | 0
LineageID | 297
MappedColumnID | 0
Name | PlanHandle
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: GroupID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 298
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]
Length | 0
LineageID | 298
MappedColumnID | 0
Name | GroupID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 299
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 299
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 300
IdentificationString | ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 300
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {607D54DC-E752-4779-9BB2-B3D19CAD0C76}
Description | The OLE DB runtime connection used to access the database.
ID | 98
IdentificationString | ODB - Read trace.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODB - Update trace_info

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {97720936-CE0C-4D46-8CEC-89977421806C}
ContactInfo | OLE DB Command;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2
Description | Executes an SQL command for each row in a dataset.
ID | 301
IdentificationString | ODB - Update trace_info
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODB - Update trace_info
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 2

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
OLE DB Command Input |  | InputCollection
OLE DB Command Output |  | OutputCollection
OLE DB Command Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 302
IdentificationString | ODB - Update trace_info.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NOTIFY
ID | 303
IdentificationString | ODB - Update trace_info.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value | {call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 304
IdentificationString | ODB - Update trace_info.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: OLE DB Command Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Command Execution
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 306
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input]
IsAttached | True
IsSorted | False
Name | OLE DB Command Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
@trace_info_id |  | ExternalMetadataColumnCollection
@snapshot_id |  | ExternalMetadataColumnCollection
@is_running |  | ExternalMetadataColumnCollection
@event_count |  | ExternalMetadataColumnCollection
@dropped_event_count |  | ExternalMetadataColumnCollection
@last_event_sequence |  | ExternalMetadataColumnCollection
trace_info_id |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
is_running |  | InputColumnCollection
event_count |  | InputColumnCollection
dropped_event_count |  | InputColumnCollection
last_event_sequence |  | InputColumnCollection


Package element

Package element: @trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 313
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]
Length | 0
MappedColumnID | 0
Name | @trace_info_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 314
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 315
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]
Length | 0
MappedColumnID | 0
Name | @snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 316
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @is_running

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 317
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]
Length | 0
MappedColumnID | 0
Name | @is_running
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 318
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 65


Package element

Package element: @event_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 319
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]
Length | 0
MappedColumnID | 0
Name | @event_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 320
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @dropped_event_count

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 321
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]
Length | 0
MappedColumnID | 0
Name | @dropped_event_count
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 322
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: @last_event_sequence

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 323
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]
Length | 0
MappedColumnID | 0
Name | @last_event_sequence
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0

Collapse image Elements

Name | Description | Type
DBParamInfoFlags | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values. | CustomPropertyCollection


Package element

Package element: DBParamInfoFlags

Collapse image Properties

Name | Value
ContainsID | False
Description | Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 324
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence].Properties[DBParamInfoFlags]
Name | DBParamInfoFlags
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 81


Package element

Package element: trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 313
ID | 307
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[trace_info_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 53
MappedColumnID | 0
Name | trace_info_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add columns
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 315
ID | 308
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 56
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add columns
UsageType | UT_READONLY


Package element

Package element: is_running

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 317
ID | 309
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[is_running]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 59
MappedColumnID | 0
Name | is_running
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add columns
UsageType | UT_READONLY


Package element

Package element: event_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_UI8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 319
ID | 310
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[event_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 18
MappedColumnID | 0
Name | event_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | AGG - Get max value of EventSequence
UsageType | UT_READONLY


Package element

Package element: dropped_event_count

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 321
ID | 311
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[dropped_event_count]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 62
MappedColumnID | 0
Name | dropped_event_count
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add columns
UsageType | UT_READONLY


Package element

Package element: last_event_sequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 323
ID | 312
IdentificationString | ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[last_event_sequence]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 65
MappedColumnID | 0
Name | last_event_sequence
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add columns
UsageType | UT_READONLY


Package element

Package element: OLE DB Command Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 325
IdentificationString | ODB - Update trace_info.Outputs[OLE DB Command Output]
IsAttached | False
IsErrorOut | False
IsSorted | False
Name | OLE DB Command Output
ObjectType | OT_OUTPUT
SynchronousInputID | 306
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OLE DB Command Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 326
IdentificationString | ODB - Update trace_info.Outputs[OLE DB Command Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Command Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 306
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 327
IdentificationString | ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]
Length | 0
LineageID | 327
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 328
IdentificationString | ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 328
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}
Description | The OLE DB runtime connection used to access the database.
ID | 305
IdentificationString | ODB - Update trace_info.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: ODB - Write to output table

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {7B729B0A-4EA5-4A0D-871A-B6E7618E9CFB}
ContactInfo | OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 329
IdentificationString | ODB - Write to output table
IsDefaultLocale | True
LocaleID | English (United States)
Name | ODB - Write to output table
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | False
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 330
IdentificationString | ODB - Write to output table.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 331
IdentificationString | ODB - Write to output table.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [snapshots].[trace_data]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 332
IdentificationString | ODB - Write to output table.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 333
IdentificationString | ODB - Write to output table.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 334
IdentificationString | ODB - Write to output table.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 335
IdentificationString | ODB - Write to output table.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 336
IdentificationString | ODB - Write to output table.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 337
IdentificationString | ODB - Write to output table.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 338
IdentificationString | ODB - Write to output table.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 339
IdentificationString | ODB - Write to output table.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 340
IdentificationString | ODB - Write to output table.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_IgnoreFailure
HasSideEffects | True
ID | 342
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | False
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
trace_info_id |  | ExternalMetadataColumnCollection
snapshot_id |  | ExternalMetadataColumnCollection
TextData |  | ExternalMetadataColumnCollection
BinaryData |  | ExternalMetadataColumnCollection
DatabaseID |  | ExternalMetadataColumnCollection
TransactionID |  | ExternalMetadataColumnCollection
LineNumber |  | ExternalMetadataColumnCollection
NTUserName |  | ExternalMetadataColumnCollection
NTDomainName |  | ExternalMetadataColumnCollection
HostName |  | ExternalMetadataColumnCollection
ClientProcessID |  | ExternalMetadataColumnCollection
ApplicationName |  | ExternalMetadataColumnCollection
LoginName |  | ExternalMetadataColumnCollection
SPID |  | ExternalMetadataColumnCollection
Duration |  | ExternalMetadataColumnCollection
StartTime |  | ExternalMetadataColumnCollection
EndTime |  | ExternalMetadataColumnCollection
Reads |  | ExternalMetadataColumnCollection
Writes |  | ExternalMetadataColumnCollection
CPU |  | ExternalMetadataColumnCollection
Permissions |  | ExternalMetadataColumnCollection
Severity |  | ExternalMetadataColumnCollection
EventSubClass |  | ExternalMetadataColumnCollection
ObjectID |  | ExternalMetadataColumnCollection
Success |  | ExternalMetadataColumnCollection
IndexID |  | ExternalMetadataColumnCollection
IntegerData |  | ExternalMetadataColumnCollection
ServerName |  | ExternalMetadataColumnCollection
EventClass |  | ExternalMetadataColumnCollection
ObjectType |  | ExternalMetadataColumnCollection
NestLevel |  | ExternalMetadataColumnCollection
State |  | ExternalMetadataColumnCollection
Error |  | ExternalMetadataColumnCollection
Mode |  | ExternalMetadataColumnCollection
Handle |  | ExternalMetadataColumnCollection
ObjectName |  | ExternalMetadataColumnCollection
DatabaseName |  | ExternalMetadataColumnCollection
FileName |  | ExternalMetadataColumnCollection
OwnerName |  | ExternalMetadataColumnCollection
RoleName |  | ExternalMetadataColumnCollection
TargetUserName |  | ExternalMetadataColumnCollection
DBUserName |  | ExternalMetadataColumnCollection
LoginSid |  | ExternalMetadataColumnCollection
TargetLoginName |  | ExternalMetadataColumnCollection
TargetLoginSid |  | ExternalMetadataColumnCollection
ColumnPermissions |  | ExternalMetadataColumnCollection
LinkedServerName |  | ExternalMetadataColumnCollection
ProviderName |  | ExternalMetadataColumnCollection
MethodName |  | ExternalMetadataColumnCollection
RowCounts |  | ExternalMetadataColumnCollection
RequestID |  | ExternalMetadataColumnCollection
XactSequence |  | ExternalMetadataColumnCollection
EventSequence |  | ExternalMetadataColumnCollection
BigintData1 |  | ExternalMetadataColumnCollection
BigintData2 |  | ExternalMetadataColumnCollection
GUID |  | ExternalMetadataColumnCollection
IntegerData2 |  | ExternalMetadataColumnCollection
ObjectID2 |  | ExternalMetadataColumnCollection
Type |  | ExternalMetadataColumnCollection
OwnerID |  | ExternalMetadataColumnCollection
ParentName |  | ExternalMetadataColumnCollection
IsSystem |  | ExternalMetadataColumnCollection
Offset |  | ExternalMetadataColumnCollection
SourceDatabaseID |  | ExternalMetadataColumnCollection
SqlHandle |  | ExternalMetadataColumnCollection
SessionLoginName |  | ExternalMetadataColumnCollection
PlanHandle |  | ExternalMetadataColumnCollection
GroupID |  | ExternalMetadataColumnCollection
TextData |  | InputColumnCollection
BinaryData |  | InputColumnCollection
DatabaseID |  | InputColumnCollection
TransactionID |  | InputColumnCollection
LineNumber |  | InputColumnCollection
NTUserName |  | InputColumnCollection
NTDomainName |  | InputColumnCollection
HostName |  | InputColumnCollection
ClientProcessID |  | InputColumnCollection
ApplicationName |  | InputColumnCollection
LoginName |  | InputColumnCollection
SPID |  | InputColumnCollection
Duration |  | InputColumnCollection
StartTime |  | InputColumnCollection
EndTime |  | InputColumnCollection
Reads |  | InputColumnCollection
Writes |  | InputColumnCollection
CPU |  | InputColumnCollection
Permissions |  | InputColumnCollection
Severity |  | InputColumnCollection
EventSubClass |  | InputColumnCollection
ObjectID |  | InputColumnCollection
Success |  | InputColumnCollection
IndexID |  | InputColumnCollection
IntegerData |  | InputColumnCollection
ServerName |  | InputColumnCollection
EventClass |  | InputColumnCollection
ObjectType |  | InputColumnCollection
NestLevel |  | InputColumnCollection
State |  | InputColumnCollection
Error |  | InputColumnCollection
Mode |  | InputColumnCollection
Handle |  | InputColumnCollection
ObjectName |  | InputColumnCollection
DatabaseName |  | InputColumnCollection
FileName |  | InputColumnCollection
OwnerName |  | InputColumnCollection
RoleName |  | InputColumnCollection
TargetUserName |  | InputColumnCollection
DBUserName |  | InputColumnCollection
LoginSid |  | InputColumnCollection
TargetLoginName |  | InputColumnCollection
TargetLoginSid |  | InputColumnCollection
ColumnPermissions |  | InputColumnCollection
LinkedServerName |  | InputColumnCollection
ProviderName |  | InputColumnCollection
MethodName |  | InputColumnCollection
RowCounts |  | InputColumnCollection
RequestID |  | InputColumnCollection
XactSequence |  | InputColumnCollection
EventSequence |  | InputColumnCollection
BigintData1 |  | InputColumnCollection
BigintData2 |  | InputColumnCollection
GUID |  | InputColumnCollection
IntegerData2 |  | InputColumnCollection
ObjectID2 |  | InputColumnCollection
Type |  | InputColumnCollection
OwnerID |  | InputColumnCollection
ParentName |  | InputColumnCollection
IsSystem |  | InputColumnCollection
Offset |  | InputColumnCollection
SourceDatabaseID |  | InputColumnCollection
SessionLoginName |  | InputColumnCollection
trace_info_id |  | InputColumnCollection
snapshot_id |  | InputColumnCollection
GroupID |  | InputColumnCollection
SqlHandle64 |  | InputColumnCollection
PlanHandle64 |  | InputColumnCollection


Package element

Package element: trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 411
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]
Length | 0
MappedColumnID | 0
Name | trace_info_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 412
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]
Length | 0
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TextData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 413
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]
Length | 0
MappedColumnID | 0
Name | TextData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BinaryData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 414
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]
Length | 0
MappedColumnID | 0
Name | BinaryData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DatabaseID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 415
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]
Length | 0
MappedColumnID | 0
Name | DatabaseID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TransactionID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 416
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]
Length | 0
MappedColumnID | 0
Name | TransactionID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LineNumber

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 417
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]
Length | 0
MappedColumnID | 0
Name | LineNumber
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NTUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 418
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]
Length | 256
MappedColumnID | 0
Name | NTUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NTDomainName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 419
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]
Length | 256
MappedColumnID | 0
Name | NTDomainName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: HostName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 420
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]
Length | 256
MappedColumnID | 0
Name | HostName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ClientProcessID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 421
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]
Length | 0
MappedColumnID | 0
Name | ClientProcessID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ApplicationName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 422
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]
Length | 256
MappedColumnID | 0
Name | ApplicationName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 423
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]
Length | 256
MappedColumnID | 0
Name | LoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SPID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 424
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]
Length | 0
MappedColumnID | 0
Name | SPID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Duration

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 425
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]
Length | 0
MappedColumnID | 0
Name | Duration
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: StartTime

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 426
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]
Length | 0
MappedColumnID | 0
Name | StartTime
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EndTime

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 427
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]
Length | 0
MappedColumnID | 0
Name | EndTime
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Reads

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 428
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]
Length | 0
MappedColumnID | 0
Name | Reads
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Writes

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 429
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]
Length | 0
MappedColumnID | 0
Name | Writes
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: CPU

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 430
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]
Length | 0
MappedColumnID | 0
Name | CPU
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Permissions

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 431
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]
Length | 0
MappedColumnID | 0
Name | Permissions
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Severity

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 432
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]
Length | 0
MappedColumnID | 0
Name | Severity
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventSubClass

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 433
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]
Length | 0
MappedColumnID | 0
Name | EventSubClass
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 434
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]
Length | 0
MappedColumnID | 0
Name | ObjectID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Success

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 435
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]
Length | 0
MappedColumnID | 0
Name | Success
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IndexID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 436
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]
Length | 0
MappedColumnID | 0
Name | IndexID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IntegerData

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 437
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]
Length | 0
MappedColumnID | 0
Name | IntegerData
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ServerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 438
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]
Length | 256
MappedColumnID | 0
Name | ServerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventClass

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 439
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]
Length | 0
MappedColumnID | 0
Name | EventClass
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectType

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 440
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]
Length | 0
MappedColumnID | 0
Name | ObjectType
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NestLevel

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 441
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]
Length | 0
MappedColumnID | 0
Name | NestLevel
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: State

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 442
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]
Length | 0
MappedColumnID | 0
Name | State
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Error

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 443
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]
Length | 0
MappedColumnID | 0
Name | Error
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Mode

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 444
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]
Length | 0
MappedColumnID | 0
Name | Mode
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Handle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 445
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]
Length | 0
MappedColumnID | 0
Name | Handle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 446
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]
Length | 256
MappedColumnID | 0
Name | ObjectName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DatabaseName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 447
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]
Length | 256
MappedColumnID | 0
Name | DatabaseName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: FileName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 448
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]
Length | 256
MappedColumnID | 0
Name | FileName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: OwnerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 449
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]
Length | 256
MappedColumnID | 0
Name | OwnerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RoleName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 450
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]
Length | 256
MappedColumnID | 0
Name | RoleName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 451
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]
Length | 256
MappedColumnID | 0
Name | TargetUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: DBUserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 452
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]
Length | 256
MappedColumnID | 0
Name | DBUserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LoginSid

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 453
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]
Length | 0
MappedColumnID | 0
Name | LoginSid
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetLoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 454
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]
Length | 256
MappedColumnID | 0
Name | TargetLoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TargetLoginSid

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_IMAGE
Description |
ID | 455
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]
Length | 0
MappedColumnID | 0
Name | TargetLoginSid
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ColumnPermissions

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 456
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]
Length | 0
MappedColumnID | 0
Name | ColumnPermissions
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LinkedServerName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 457
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]
Length | 256
MappedColumnID | 0
Name | LinkedServerName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ProviderName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 458
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]
Length | 256
MappedColumnID | 0
Name | ProviderName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: MethodName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 459
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]
Length | 256
MappedColumnID | 0
Name | MethodName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RowCounts

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 460
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]
Length | 0
MappedColumnID | 0
Name | RowCounts
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: RequestID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 461
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]
Length | 0
MappedColumnID | 0
Name | RequestID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: XactSequence

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 462
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]
Length | 0
MappedColumnID | 0
Name | XactSequence
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 463
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]
Length | 0
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BigintData1

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 464
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]
Length | 0
MappedColumnID | 0
Name | BigintData1
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BigintData2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 465
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]
Length | 0
MappedColumnID | 0
Name | BigintData2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: GUID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_GUID
Description |
ID | 466
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]
Length | 0
MappedColumnID | 0
Name | GUID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IntegerData2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 467
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]
Length | 0
MappedColumnID | 0
Name | IntegerData2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ObjectID2

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I8
Description |
ID | 468
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]
Length | 0
MappedColumnID | 0
Name | ObjectID2
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Type

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 469
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]
Length | 0
MappedColumnID | 0
Name | Type
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: OwnerID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 470
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]
Length | 0
MappedColumnID | 0
Name | OwnerID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ParentName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 471
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]
Length | 256
MappedColumnID | 0
Name | ParentName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IsSystem

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 472
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]
Length | 0
MappedColumnID | 0
Name | IsSystem
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Offset

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 473
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]
Length | 0
MappedColumnID | 0
Name | Offset
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SourceDatabaseID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 474
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]
Length | 0
MappedColumnID | 0
Name | SourceDatabaseID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SqlHandle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 475
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]
Length | 64
MappedColumnID | 0
Name | SqlHandle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: SessionLoginName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 476
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]
Length | 256
MappedColumnID | 0
Name | SessionLoginName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: PlanHandle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BYTES
Description |
ID | 477
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]
Length | 64
MappedColumnID | 0
Name | PlanHandle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: GroupID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 478
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]
Length | 0
MappedColumnID | 0
Name | GroupID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: TextData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_NTEXT
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 413
ID | 343
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TextData]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 100
MappedColumnID | 0
Name | TextData
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: BinaryData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 414
ID | 344
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BinaryData]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 101
MappedColumnID | 0
Name | BinaryData
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: DatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 415
ID | 345
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 102
MappedColumnID | 0
Name | DatabaseID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: TransactionID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 416
ID | 346
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TransactionID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 103
MappedColumnID | 0
Name | TransactionID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: LineNumber

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 417
ID | 347
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LineNumber]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 104
MappedColumnID | 0
Name | LineNumber
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: NTUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 418
ID | 348
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTUserName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 105
MappedColumnID | 0
Name | NTUserName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: NTDomainName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 419
ID | 349
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTDomainName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 106
MappedColumnID | 0
Name | NTDomainName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: HostName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 420
ID | 350
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[HostName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 107
MappedColumnID | 0
Name | HostName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ClientProcessID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 421
ID | 351
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ClientProcessID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 108
MappedColumnID | 0
Name | ClientProcessID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ApplicationName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 422
ID | 352
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ApplicationName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 109
MappedColumnID | 0
Name | ApplicationName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: LoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 423
ID | 353
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 110
MappedColumnID | 0
Name | LoginName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: SPID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 424
ID | 354
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SPID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 111
MappedColumnID | 0
Name | SPID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Duration

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 425
ID | 355
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Duration]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 112
MappedColumnID | 0
Name | Duration
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: StartTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 426
ID | 356
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[StartTime]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 113
MappedColumnID | 0
Name | StartTime
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: EndTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 427
ID | 357
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EndTime]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 114
MappedColumnID | 0
Name | EndTime
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Reads

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 428
ID | 358
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Reads]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 115
MappedColumnID | 0
Name | Reads
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Writes

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 429
ID | 359
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Writes]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 116
MappedColumnID | 0
Name | Writes
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: CPU

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 430
ID | 360
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[CPU]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 117
MappedColumnID | 0
Name | CPU
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Permissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 431
ID | 361
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Permissions]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 118
MappedColumnID | 0
Name | Permissions
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Severity

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 432
ID | 362
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Severity]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 119
MappedColumnID | 0
Name | Severity
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: EventSubClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 433
ID | 363
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSubClass]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 120
MappedColumnID | 0
Name | EventSubClass
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ObjectID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 434
ID | 364
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 121
MappedColumnID | 0
Name | ObjectID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Success

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 435
ID | 365
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Success]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 122
MappedColumnID | 0
Name | Success
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: IndexID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 436
ID | 366
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IndexID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 123
MappedColumnID | 0
Name | IndexID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: IntegerData

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 437
ID | 367
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 124
MappedColumnID | 0
Name | IntegerData
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 438
ID | 368
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ServerName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 125
MappedColumnID | 0
Name | ServerName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: EventClass

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 439
ID | 369
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventClass]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 126
MappedColumnID | 0
Name | EventClass
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ObjectType

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 440
ID | 370
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectType]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 127
MappedColumnID | 0
Name | ObjectType
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: NestLevel

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 441
ID | 371
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NestLevel]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 128
MappedColumnID | 0
Name | NestLevel
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: State

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 442
ID | 372
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[State]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 129
MappedColumnID | 0
Name | State
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Error

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 443
ID | 373
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Error]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 130
MappedColumnID | 0
Name | Error
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Mode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 444
ID | 374
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Mode]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 131
MappedColumnID | 0
Name | Mode
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Handle

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 445
ID | 375
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Handle]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 132
MappedColumnID | 0
Name | Handle
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ObjectName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 446
ID | 376
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 133
MappedColumnID | 0
Name | ObjectName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: DatabaseName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 447
ID | 377
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 134
MappedColumnID | 0
Name | DatabaseName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: FileName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 448
ID | 378
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[FileName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 135
MappedColumnID | 0
Name | FileName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: OwnerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 449
ID | 379
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 136
MappedColumnID | 0
Name | OwnerName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: RoleName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 450
ID | 380
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RoleName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 137
MappedColumnID | 0
Name | RoleName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: TargetUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 451
ID | 381
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetUserName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 138
MappedColumnID | 0
Name | TargetUserName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: DBUserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 452
ID | 382
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DBUserName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 139
MappedColumnID | 0
Name | DBUserName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: LoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 453
ID | 383
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginSid]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 140
MappedColumnID | 0
Name | LoginSid
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: TargetLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 454
ID | 384
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 141
MappedColumnID | 0
Name | TargetLoginName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: TargetLoginSid

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_IMAGE
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 455
ID | 385
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginSid]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 142
MappedColumnID | 0
Name | TargetLoginSid
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ColumnPermissions

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 456
ID | 386
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ColumnPermissions]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 143
MappedColumnID | 0
Name | ColumnPermissions
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: LinkedServerName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 457
ID | 387
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LinkedServerName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 144
MappedColumnID | 0
Name | LinkedServerName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ProviderName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 458
ID | 388
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ProviderName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 145
MappedColumnID | 0
Name | ProviderName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: MethodName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 459
ID | 389
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[MethodName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 146
MappedColumnID | 0
Name | MethodName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: RowCounts

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 460
ID | 390
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RowCounts]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 147
MappedColumnID | 0
Name | RowCounts
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: RequestID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 461
ID | 391
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RequestID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 148
MappedColumnID | 0
Name | RequestID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: XactSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 462
ID | 392
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[XactSequence]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 149
MappedColumnID | 0
Name | XactSequence
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: EventSequence

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 463
ID | 393
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSequence]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 150
MappedColumnID | 0
Name | EventSequence
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: BigintData1

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 464
ID | 394
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData1]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 151
MappedColumnID | 0
Name | BigintData1
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: BigintData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 465
ID | 395
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData2]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 152
MappedColumnID | 0
Name | BigintData2
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: GUID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_GUID
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 466
ID | 396
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GUID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 153
MappedColumnID | 0
Name | GUID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: IntegerData2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 467
ID | 397
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData2]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 154
MappedColumnID | 0
Name | IntegerData2
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ObjectID2

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I8
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 468
ID | 398
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID2]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 155
MappedColumnID | 0
Name | ObjectID2
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Type

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 469
ID | 399
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Type]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 156
MappedColumnID | 0
Name | Type
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: OwnerID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 470
ID | 400
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 157
MappedColumnID | 0
Name | OwnerID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: ParentName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 471
ID | 401
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ParentName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 158
MappedColumnID | 0
Name | ParentName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: IsSystem

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 472
ID | 402
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IsSystem]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 159
MappedColumnID | 0
Name | IsSystem
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: Offset

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 473
ID | 403
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Offset]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 160
MappedColumnID | 0
Name | Offset
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: SourceDatabaseID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 474
ID | 404
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SourceDatabaseID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 161
MappedColumnID | 0
Name | SourceDatabaseID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: SessionLoginName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 476
ID | 405
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SessionLoginName]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 256
LineageID | 163
MappedColumnID | 0
Name | SessionLoginName
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: trace_info_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 411
ID | 406
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[trace_info_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 74
MappedColumnID | 0
Name | trace_info_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add snapshot_id and trace_info_id
UsageType | UT_READONLY


Package element

Package element: snapshot_id

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 412
ID | 407
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[snapshot_id]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 77
MappedColumnID | 0
Name | snapshot_id
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | DRV - Add snapshot_id and trace_info_id
UsageType | UT_READONLY


Package element

Package element: GroupID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 478
ID | 408
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GroupID]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 165
MappedColumnID | 0
Name | GroupID
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | ODB - Read trace
UsageType | UT_READONLY


Package element

Package element: SqlHandle64

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 475
ID | 409
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SqlHandle64]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 40
MappedColumnID | 0
Name | SqlHandle64
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Data Conversion
UsageType | UT_READONLY


Package element

Package element: PlanHandle64

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BYTES
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 477
ID | 410
IdentificationString | ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[PlanHandle64]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 64
LineageID | 43
MappedColumnID | 0
Name | PlanHandle64
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Data Conversion
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 479
IdentificationString | ODB - Write to output table.Outputs[OLE DB Destination Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 342
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 480
IdentificationString | ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 480
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 481
IdentificationString | ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 481
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}
Description | The OLE DB runtime connection used to access the database.
ID | 341
IdentificationString | ODB - Write to output table.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: Aggregate Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Aggregate Output 1
ObjectType | OT_PATH
StartPoint | Aggregate Output 1


Package element

Package element: Data Conversion Output

Collapse image Properties

Name | Value
Description |
EndPoint | Row Count Input 1
Name | Data Conversion Output
ObjectType | OT_PATH
StartPoint | Data Conversion Output


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | Data Conversion Input
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Derived Column Output

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Command Input
Name | Derived Column Output
ObjectType | OT_PATH
StartPoint | Derived Column Output


Package element

Package element: Multicast Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Derived Column Input
Name | Multicast Output 1
ObjectType | OT_PATH
StartPoint | Multicast Output 1


Package element

Package element: Multicast Output 2

Collapse image Properties

Name | Value
Description |
EndPoint | Aggregate Input 1
Name | Multicast Output 2
ObjectType | OT_PATH
StartPoint | Multicast Output 2


Package element

Package element: Row Count Output 1

Collapse image Properties

Name | Value
Description |
EndPoint | Multicast Input 1
Name | Row Count Output 1
ObjectType | OT_PATH
StartPoint | Row Count Output 1


Package element

Package element: TraceLoadScript

Collapse image Properties

Name | Value
CreationName
DataType | String
Description
EvaluateAsExpression | True
Expression | "SELECT {LF} [TextData], {LF} [BinaryData], {LF} [DatabaseID], {LF} [TransactionID], {LF} [LineNumber], {LF} [NTUserName], {LF} [NTDomainName], {LF} [HostName], {LF} [ClientProcessID], {LF} [ApplicationName], {LF} [LoginName], {LF} [SPID], {LF} [Duration], {LF} [StartTime], {LF} [EndTime], {LF} [Reads], {LF} [Writes], {LF} [CPU], {LF} [Permissions], {LF} [Severity], {LF} [EventSubClass], {LF} [ObjectID], {LF} [Success], {LF} [IndexID], {LF} [IntegerData], {LF} [ServerName], {LF} [EventClass], {LF} [ObjectType], {LF} [NestLevel], {LF} [State], {LF} [Error], {LF} [Mode], {LF} [Handle], {LF} [ObjectName], {LF} [DatabaseName], {LF} [FileName], {LF} [OwnerName], {LF} [RoleName], {LF} [TargetUserName], {LF} [DBUserName], {LF} [LoginSid], {LF} [TargetLoginName], {LF} [TargetLoginSid], {LF} [ColumnPermissions], {LF} [LinkedServerName], {LF} [ProviderName], {LF} [MethodName], {LF} [RowCounts], {LF} [RequestID], {LF} [XactSequence], {LF} [EventSequence], {LF} [BigintData1], {LF} [BigintData2], {LF} [GUID], {LF} [IntegerData2], {LF} [ObjectID2], {LF} [Type], {LF} [OwnerID], {LF} [ParentName], {LF} [IsSystem], {LF} [Offset], {LF} [SourceDatabaseID], {LF} [SqlHandle], {LF} [SessionLoginName], {LF} [PlanHandle]{LF}, [GroupID] FROM{LF} ::fn_trace_gettable(N'" + @[User::TraceCurrentFile] + "', 1){LF} WHERE{LF} [EventSequence] > " + @[User::TraceLastEventSequence]
IncludeInDebugDump | False
Name | TraceLoadScript
Namespace | User
QualifiedName | User::TraceLoadScript
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | SELECT {LF} [TextData], {LF} [BinaryData], {LF} [DatabaseID], {LF} [TransactionID], {LF} [LineNumber], {LF} [NTUserName], {LF} [NTDomainName], {LF} [HostName], {LF} [ClientProcessID], {LF} [ApplicationName], {LF} [LoginName], {LF} [SPID], {LF} [Duration], {LF} [StartTime], {LF} [EndTime], {LF} [Reads], {LF} [Writes], {LF} [CPU], {LF} [Permissions], {LF} [Severity], {LF} [EventSubClass], {LF} [ObjectID], {LF} [Success], {LF} [IndexID], {LF} [IntegerData], {LF} [ServerName], {LF} [EventClass], {LF} [ObjectType], {LF} [NestLevel], {LF} [State], {LF} [Error], {LF} [Mode], {LF} [Handle], {LF} [ObjectName], {LF} [DatabaseName], {LF} [FileName], {LF} [OwnerName], {LF} [RoleName], {LF} [TargetUserName], {LF} [DBUserName], {LF} [LoginSid], {LF} [TargetLoginName], {LF} [TargetLoginSid], {LF} [ColumnPermissions], {LF} [LinkedServerName], {LF} [ProviderName], {LF} [MethodName], {LF} [RowCounts], {LF} [RequestID], {LF} [XactSequence], {LF} [EventSequence], {LF} [BigintData1], {LF} [BigintData2], {LF} [GUID], {LF} [IntegerData2], {LF} [ObjectID2], {LF} [Type], {LF} [OwnerID], {LF} [ParentName], {LF} [IsSystem], {LF} [Offset], {LF} [SourceDatabaseID], {LF} [SqlHandle], {LF} [SessionLoginName], {LF} [PlanHandle]{LF}, [GroupID] FROM{LF} ::fn_trace_gettable(N'C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc', 1){LF} WHERE{LF} [EventSequence] > 0
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Variables[User::TraceLoadScript]


Package element

Package element: RowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountError
Namespace | User
QualifiedName | User::RowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload.Variables[User::RowCountError]


Package element

Package element: RowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountIn
Namespace | User
QualifiedName | User::RowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload.Variables[User::RowCountIn]


Package element

Package element: RowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountOut
Namespace | User
QualifiedName | User::RowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload.Variables[User::RowCountOut]


Package element

Package element: FAT - Check if trace file is accessible

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.FileAccessTask.4
DebugMode | False
DelayValidation | True
Description | File Access Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FilePath | C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {679134AC-EFFB-4A28-B2C2-4247D71FEE23}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Mode | 6
Name | FAT - Check if trace file is accessible
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FilePath |  | Expressions
Mode |  | Expressions
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: FilePath

Collapse image Properties

Name | Value
Expression | @[User::TraceCurrentFile]
Name | FilePath


Package element

Package element: Mode

Collapse image Properties

Name | Value
Expression | 6
Name | Mode


Package element

Package element: FAT - Precheck if trace file is accessible

Collapse image Properties

Name | Value
ApartmentThreaded | False
CreationName | DTS.FileAccessTask.4
DebugMode | False
DelayValidation | False
Description | File Access Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FilePath | C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | True
HostType | Task
ID | {BCAA70EC-FD75-4E75-9698-7459FF0FB8BB}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Mode | 4
Name | FAT - Precheck if trace file is accessible
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
FilePath |  | Expressions
Mode |  | Expressions
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: Mode

Collapse image Properties

Name | Value
Expression | 4
Name | Mode


Package element

Package element: FST - Delete trace file

Collapse image Properties

Name | Value
ApartmentThreaded | True
Attributes | 0
CreationName | Microsoft.SqlServer.Dts.Tasks.FileSystemTask.FileSystemTask, Microsoft.SqlServer.FileSystemTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | File System Task
Destination |
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | Success
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {5EE7C74E-CD4E-40E2-8D32-7475CF6457B1}
IsDefaultLocaleID | True
IsDestinationPathVariable | False
IsolationLevel | Serializable
IsSourcePathVariable | True
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | FST - Delete trace file
Operation | 2
OperationName |
OverwriteDestinationFile | False
PreservedAttributes | 0
Source | User::TraceCurrentFile
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
Version | 0

Collapse image Elements

Name | Description | Type
OnError |  | EventHandlers
FileSystemOperation | Provides information about running file system operations. | LogEntryInfos
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: OnError

Collapse image Properties

Name | Value
CreationName | OnError
DebugMode | False
DelayValidation | False
Description |
Disable | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {582131DF-655C-41F3-B0E7-5D7E8FDBB56F}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | OnError
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Log package stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Logs statistics about the most recent Data Flow Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7FE278CC-D8C4-4CCD-B884-D4FD9790D5A0}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log package stats
ResultSetType | 1
SqlStatementSource
{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 89983
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats.Variables[User::LoopDuration]


Package element

Package element: SQL - logs uploaded file name

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | SQL - logs uploaded file name
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {36601F9F-22D5-41EB-AC7D-0CBF2756CC8C}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | SQL - logs uploaded file name
ResultSetType | 1
SqlStatementSource
{ call dbo.sp_ssis_addlogentry (N'UploadTraceFile',?, ?, ?, ?, ?, ?, ?, 0, 0x00, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: {821B0536-E431-458F-8EAE-028BE667F142}

CollapseAll image

Collapse image Properties

Name | Value
CollectionEnumerator | False
CreationName | DTS.ForEachFileEnumerator.5
DelayValidation | False
Description |
Directory |
FileNameRetrieval | 0
FileSpec | DC_Trace_ALEN-PC.MSSQL.1..0*.trc
HasExpressions | True
HostType | ForEachEnumerator
ID | {821B0536-E431-458F-8EAE-028BE667F142}
Name | {821B0536-E431-458F-8EAE-028BE667F142}
Recurse | False

Collapse image Elements

Name | Description | Type
Directory |  | Expressions
FileSpec |  | Expressions
Directory |  | Expressions
FileSpec |  | Expressions


Package element

Package element: FileSpec

Collapse image Properties

Name | Value
Expression | "DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID] + "*.trc"
Name | FileSpec


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | FAT - Check if trace file is accessible
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {4184AC42-F94B-469C-A49E-EE793CB1D245}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | DFT - Upload trace file
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log package stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[LoggingLevel] >= 1
ID | {41B4AC86-833E-417B-A00D-2259D0C87E35}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | DFT - Upload trace file
Value | Completion


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | FST - Delete trace file
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {0957B7CD-F748-44F6-BD2F-9A5B335C4F16}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | FAT - Check if trace file is accessible
Value | Success


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - logs uploaded file name
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[LoggingLevel] > 1
ID | {A52A42F1-5767-464E-AEBC-F8FB69B7BAC4}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | FST - Delete trace file
Value | Completion


Package element

Package element: Constraint 4

Collapse image Properties

Name | Value
ConstrainedExecutable | DFT - Upload trace file
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {1963E80B-FFFB-425B-AEF5-0F6F5BE8FFA2}
LogicalAnd | True
Name | Constraint 4
PrecedenceExecutable | FAT - Precheck if trace file is accessible
Value | Success


Package element

Package element: SQL - Check trace info

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {782c9195-15b2-4260-bff9-6d85b486e50f}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Check trace info
ResultSetType | 2
SqlStatementSource
DECLARE @status INT
SET @status = 2
SELECT  @status = CASE t.status                                      WHEN 1 THEN 1 ELSE 0 END
FROM sys.traces t
WHERE t.path LIKE (? + N'%.trc')
SELECT @status
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Close trace

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {0b304887-a5f5-48be-a81e-48ab362bfe41}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Close trace
ResultSetType | 1
SqlStatementSource
{ call [sp_trace_setstatus] (?, 2) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Get Last_Event_Sequence

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {1fe772eb-42ae-4641-af91-138c98b8fcba}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get Last_Event_Sequence
ResultSetType | 2
SqlStatementSource
DECLARE @lastEventSequence BIGINT
SET @lastEventSequence = -1
SELECT        @lastEventSequence = [last_event_sequence]
FROM            [snapshots].[trace_info]
WHERE        [trace_info_id] = ?
SELECT @lastEventSequence
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Get Last_Event_Sequence
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {3392402A-8EDF-40CA-B868-CE800491C3A4}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | FEF - For each trace file - regular trace upload
Value | Completion


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Close trace
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::TraceIsRunning] == 0
ID | {77861B0E-1726-4FE2-BEC6-4CAB5CEE2AFA}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | SQL - Check trace info
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Check trace info
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {0B57ACB1-DDFE-4E1F-909A-36BF193C6D15}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | SQL - Get Last_Event_Sequence
Value | Success


Package element

Package element: SEQ - Default trace upload

Collapse image Properties

Name | Value
CreationName | STOCK:SEQUENCE
DebugMode | False
DelayValidation | True
Description | Sequence Container
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {38B4A79F-D07D-418D-BA5A-2AF603D6620F}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | SEQ - Default trace upload
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
DFT - Upload default trace file | Data Flow Task | Executables
SQL - Log package stats | Logs statistics about the most recent Data Flow Task | Executables
Constraint |  | PrecedenceConstraints
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: DFT - Upload default trace file

Collapse image Properties

Name | Value
[DRV - Add columns].[Derived Column Output].[dropped_event_count].[FriendlyExpression] | @[User::TraceDroppedEventCount]
[DRV - Add columns].[Derived Column Output].[is_running].[FriendlyExpression] | @[User::TraceIsRunning]
[DRV - Add columns].[Derived Column Output].[last_event_sequence].[FriendlyExpression] | ISNULL(EventSequence_Max) ? 0 : EventSequence_Max
[DRV - Add columns].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @[User::SnapshotID]
[DRV - Add columns].[Derived Column Output].[trace_info_id].[FriendlyExpression] | @[User::TraceInfoID]
[DRV - Add snapshot_id and trace_info_id].[Derived Column Output].[snapshot_id].[FriendlyExpression] | @SnapshotID
[DRV - Add snapshot_id and trace_info_id].[Derived Column Output].[trace_info_id].[FriendlyExpression] | @[User::TraceInfoID]
[ODB - Update trace_info].[SqlCommand] | {call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}
ApartmentThreaded | False
AutoAdjustBufferSize | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.5
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | True
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {ed5bc122-e2d0-47fe-9a21-91b4d462f083}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | DFT - Upload default trace file
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
AGG - Get max value of EventSequence | Aggregates and groups values in a dataset. | ComponentMetaDataCollection
CNT - Error row count source | Counts the rows in a dataset. | ComponentMetaDataCollection
CNT - Input row count | Counts the rows in a dataset. | ComponentMetaDataCollection
CNT - Output row count | Counts the rows in a dataset. | ComponentMetaDataCollection
Data Conversion | Data Conversion | ComponentMetaDataCollection
DRV - Add columns | Updates column values using expressions | ComponentMetaDataCollection
DRV - Add snapshot_id and trace_info_id | Updates column values using expressions | ComponentMetaDataCollection
MLT - Split two ways | Creates copies of a dataset. | ComponentMetaDataCollection
ODB - Read trace | OLE DB Source | ComponentMetaDataCollection
ODB - Update trace_info | Executes an SQL command for each row in a dataset. | ComponentMetaDataCollection
ODB - Write to output table | OLE DB Destination | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Aggregate Output 1 |  | PathCollection
Data Conversion Output |  | PathCollection
Derived Column Output |  | PathCollection
Derived Column Output |  | PathCollection
Multicast Output 1 |  | PathCollection
Multicast Output 2 |  | PathCollection
OLE DB Source Error Output |  | PathCollection
OLE DB Source Output |  | PathCollection
Row Count Output 1 |  | PathCollection
Row Count Output 1 |  | PathCollection
TraceLoadScript |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables
SSIS diagram is missing


Package element

Package element: TraceLoadScript

Collapse image Properties

Name | Value
CreationName
DataType | String
Description
EvaluateAsExpression | True
Expression | "DECLARE @trace_file_name nvarchar(512){LF}SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1{LF}{LF}SELECT {LF} [TextData], {LF} [BinaryData], {LF} [DatabaseID], {LF} [TransactionID], {LF} [LineNumber], {LF} [NTUserName], {LF} [NTDomainName], {LF} [HostName], {LF} [ClientProcessID], {LF} [ApplicationName], {LF} [LoginName], {LF} [SPID], {LF} [Duration], {LF} [StartTime], {LF} [EndTime], {LF} [Reads], {LF} [Writes], {LF} [CPU], {LF} [Permissions], {LF} [Severity], {LF} [EventSubClass], {LF} [ObjectID], {LF} [Success], {LF} [IndexID], {LF} [IntegerData], {LF} [ServerName], {LF} [EventClass], {LF} [ObjectType], {LF} [NestLevel], {LF} [State], {LF} [Error], {LF} [Mode], {LF} [Handle], {LF} [ObjectName], {LF} [DatabaseName], {LF} [FileName], {LF} [OwnerName], {LF} [RoleName], {LF} [TargetUserName], {LF} [DBUserName], {LF} [LoginSid], {LF} [TargetLoginName], {LF} [TargetLoginSid], {LF} [ColumnPermissions], {LF} [LinkedServerName], {LF} [ProviderName], {LF} [MethodName], {LF} [RowCounts], {LF} [RequestID], {LF} [XactSequence], {LF} [EventSequence], {LF} [BigintData1], {LF} [BigintData2], {LF} [GUID], {LF} [IntegerData2], {LF} [ObjectID2], {LF} [Type], {LF} [OwnerID], {LF} [ParentName], {LF} [IsSystem], {LF} [Offset], {LF} [SourceDatabaseID], {LF} [SqlHandle], {LF} [SessionLoginName], {LF} [PlanHandle]{LF}, [GroupID] FROM{LF} ::fn_trace_gettable(@trace_file_name, default){LF} WHERE{LF} [EventSequence] > " + @[User::TraceLastEventSequence]
IncludeInDebugDump | False
Name | TraceLoadScript
Namespace | User
QualifiedName | User::TraceLoadScript
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | DECLARE @trace_file_name nvarchar(512){LF}SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1{LF}{LF}SELECT {LF} [TextData], {LF} [BinaryData], {LF} [DatabaseID], {LF} [TransactionID], {LF} [LineNumber], {LF} [NTUserName], {LF} [NTDomainName], {LF} [HostName], {LF} [ClientProcessID], {LF} [ApplicationName], {LF} [LoginName], {LF} [SPID], {LF} [Duration], {LF} [StartTime], {LF} [EndTime], {LF} [Reads], {LF} [Writes], {LF} [CPU], {LF} [Permissions], {LF} [Severity], {LF} [EventSubClass], {LF} [ObjectID], {LF} [Success], {LF} [IndexID], {LF} [IntegerData], {LF} [ServerName], {LF} [EventClass], {LF} [ObjectType], {LF} [NestLevel], {LF} [State], {LF} [Error], {LF} [Mode], {LF} [Handle], {LF} [ObjectName], {LF} [DatabaseName], {LF} [FileName], {LF} [OwnerName], {LF} [RoleName], {LF} [TargetUserName], {LF} [DBUserName], {LF} [LoginSid], {LF} [TargetLoginName], {LF} [TargetLoginSid], {LF} [ColumnPermissions], {LF} [LinkedServerName], {LF} [ProviderName], {LF} [MethodName], {LF} [RowCounts], {LF} [RequestID], {LF} [XactSequence], {LF} [EventSequence], {LF} [BigintData1], {LF} [BigintData2], {LF} [GUID], {LF} [IntegerData2], {LF} [ObjectID2], {LF} [Type], {LF} [OwnerID], {LF} [ParentName], {LF} [IsSystem], {LF} [Offset], {LF} [SourceDatabaseID], {LF} [SqlHandle], {LF} [SessionLoginName], {LF} [PlanHandle]{LF}, [GroupID] FROM{LF} ::fn_trace_gettable(@trace_file_name, default){LF} WHERE{LF} [EventSequence] > 0
VariablePath | \Package\SEQ - Default trace upload\DFT - Upload default trace file.Variables[User::TraceLoadScript]


Package element

Package element: RowCountError

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountError
Namespace | User
QualifiedName | User::RowCountError
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Default trace upload.Variables[User::RowCountError]


Package element

Package element: RowCountIn

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountIn
Namespace | User
QualifiedName | User::RowCountIn
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Default trace upload.Variables[User::RowCountIn]


Package element

Package element: RowCountOut

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | True
Name | RowCountOut
Namespace | User
QualifiedName | User::RowCountOut
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 0
VariablePath | \Package\SEQ - Default trace upload.Variables[User::RowCountOut]


Package element

Package element: SQL - Log package stats

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | True
Description | Logs statistics about the most recent Data Flow Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {147f8f7a-f829-4ac7-a038-03943f58ee3b}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Log package stats
ResultSetType | 1
SqlStatementSource
{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
LoopDuration |  | Variables
RowCountError |  | Variables
RowCountIn |  | Variables
RowCountOut |  | Variables
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 90980
VariablePath | \Package\SEQ - Default trace upload\SQL - Log package stats.Variables[User::LoopDuration]


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Log package stats
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[LoggingLevel] >= 1
ID | {AEDEEA80-FB4F-4737-B938-B2909C835D5A}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | DFT - Upload default trace file
Value | Completion


Package element

Package element: SQL - Close trace

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | TargetConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {EAA2093E-36E6-4EA8-A5E9-E568C5A46516}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Close trace
ResultSetType | 1
SqlStatementSource
{ call [sp_trace_setstatus] (?, 2) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Get last upload time

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {0F29500B-BB42-4603-AB36-A6C75CFC649B}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get last upload time
ResultSetType | 1
SqlStatementSource
{ call [snapshots].[sp_trace_get_info] (?, ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Get snapshot id

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {C316D13F-2EEE-42A1-B307-924555587091}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get snapshot id
ResultSetType | 1
SqlStatementSource
{ call [core].[sp_create_snapshot] (?, ?, ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Get trace info

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | ConfigConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {33CFBECB-7DAD-4256-811D-FED4E423755D}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Get trace info
ResultSetType | 2
SqlStatementSource
{call [dbo].[sp_syscollector_get_trace_info](?, ?)}
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: SQL - Update data source

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | MdwConnection
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute SQL Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {D8732C3C-BF2D-40C6-BA2E-AF18493924AC}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocaleID | English (United States)
LoggingMode | Disabled
MaximumErrorCount | 0
Name | SQL - Update data source
ResultSetType | 1
SqlStatementSource
{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }
SqlStatementSourceType | Direct Input
SuspendRequired | False
TargetServerVersion | 130
TimeOut | 0
TransactionOption | Supported
TypeConversionMode | 2
Version | 0

Collapse image Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: XML - Check use_default attribute

Collapse image Properties

Name | Value
ApartmentThreaded | True
CreationName | Microsoft.SqlServer.Dts.Tasks.XMLTask.XMLTask, Microsoft.SqlServer.XMLTask, Version=13.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | XML Task
Destination | User::TraceUseDefault
DestinationType | 1
DiffAlgorithm | 0
DiffGramDestination |
DiffGramDestinationType | 0
DiffOptions | 0
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailOnDifference | False
FailOnValidationFail | False
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {DB542074-1D89-441B-BA2B-E1E55527C2B8}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 0
Name | XML - Check use_default attribute
Namespaces | System.Collections.ArrayList
NodeList | System.Collections.ArrayList
OperationType | 2
OverwriteDestination | True
PutResultInOneNode | False
SaveDiffGram | False
SaveOperationResult | True
SecondOperand | *[local-name() = 'SqlTraceCollector']/@use_default
SecondOperandType | 2
Source | User::InputParameters
SourceType | 1
SuspendRequired | False
TargetServerVersion | 130
TransactionOption | Supported
ValidationDetails | False
ValidationType | 1
Version | 0
XPathOperation | 1
XPathStringSource |
XPathStringSourceType | 2

Collapse image Elements

Name | Description | Type
XMLOperation | Provides information regarding running an XML operation | LogEntryInfos
CacheDirectory |  | Variables
CacheWindow |  | Variables
CollectionSetUID |  | Variables
CollectorTypeUID |  | Variables
ConfigConnectionString |  | Variables
Counter |  | Variables
DaysUntilExpiration |  | Variables
ExitEventName |  | Variables
InputParameters |  | Variables
InstanceID |  | Variables
InstanceName |  | Variables
ItemID |  | Variables
LoggingLevel |  | Variables
LogID |  | Variables
LoopEventName |  | Variables
MDWConnectionString |  | Variables
ParentLogID |  | Variables
RowCountIn |  | Variables
SnapshotID |  | Variables
SourceID |  | Variables
TargetConnectionString |  | Variables
TraceCurrentEventTime |  | Variables
TraceCurrentFile |  | Variables
TraceDroppedEventCount |  | Variables
TraceID |  | Variables
TraceInfoID |  | Variables
TraceIsRunning |  | Variables
TraceLastEventSequence |  | Variables
TraceLocation |  | Variables
TraceStartTime |  | Variables
TraceUseDefault |  | Variables


Package element

Package element: XMLOperation

Collapse image Properties

Name | Value
CreationName |
Description | Provides information regarding running an XML operation
FrequencyHint | Consistent
Name | XMLOperation


Package

Package: SqlTraceUpload

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceUpload

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceUpload

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: SqlTraceUpload

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 3 |
Constraint 5 |
Constraint 6 |
Constraint 8 |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Update data source
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {2DBE8AE5-8C75-44A9-8C57-D571678FF149}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | SQL - Get trace info
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Get last upload time
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {9C582F44-453F-431A-80FE-D79155C6E519}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | SQL - Update data source
Value | Success


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Get snapshot id
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {8D136BE7-D0D6-486D-85E9-D64DB633850E}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | SQL - Get last upload time
Value | Success


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | For Loop Container
CreationName |
Description |
EvalOp | Expression
EvaluatesTrue | False
Expression | @[User::SnapshotID] != 0 && @[User::TraceUseDefault] != "1"
ID | {0E7EF1B1-B857-44B2-87BF-CA42682C6354}
LogicalAnd | False
Name | Constraint 3
PrecedenceExecutable | SQL - Get snapshot id
Value | Success


Package element

Package element: Constraint 5

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Close trace
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | True
Expression | @[User::TraceIsRunning] == 0
ID | {285C2E0E-D5D3-467A-8237-E0B32D55C912}
LogicalAnd | True
Name | Constraint 5
PrecedenceExecutable | SQL - Get trace info
Value | Success


Package element

Package element: Constraint 6

Collapse image Properties

Name | Value
ConstrainedExecutable | SQL - Get trace info
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {5545F925-D433-4F90-93FD-D3E432AE1D83}
LogicalAnd | True
Name | Constraint 6
PrecedenceExecutable | XML - Check use_default attribute
Value | Success


Package element

Package element: Constraint 8

Collapse image Properties

Name | Value
ConstrainedExecutable | SEQ - Default trace upload
CreationName |
Description |
EvalOp | ExpressionAndConstraint
EvaluatesTrue | False
Expression | @[User::TraceUseDefault] == "1"
ID | {58C2147A-C7A3-4809-95AB-F70A1F1C57BF}
LogicalAnd | True
Name | Constraint 8
PrecedenceExecutable | SQL - Get snapshot id
Value | Success


Package

Package: SqlTraceUpload

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
Counter |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
SnapshotID |
SourceID |
TargetConnectionString |
TraceCurrentEventTime |
TraceCurrentFile |
TraceDroppedEventCount |
TraceID |
TraceInfoID |
TraceIsRunning |
TraceLastEventSequence |
TraceLocation |
TraceStartTime |
TraceUseDefault |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="3/6/2007 4:18:14 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DTSID="{F389A8E6-5A17-4056-ABFD-C8B823F2092E}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxErrorCount="0" DTS:ObjectName="SqlTraceUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="219" DTS:VersionGUID="{9C0CD4F7-1926-41D0-BEC0-AE81AAA718FB}" DTS:VersionMajor="10">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=myMDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C32CCDDF-1CB6-4E64-806E-193762452CA6}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5A111CDB-34FB-47A2-8307-96D7C3BB49CA}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{AC2982C3-5B39-4514-B50D-092C15857C1F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3B823989-622C-484E-A927-E0C211588865}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{BD6C4FE9-3BCB-447C-A897-0DA27695E684}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{7A1F3609-4C0F-4BFA-A979-4AF89D61F160}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5C370D78-5CD2-427F-B461-BF36DDAFF7F6}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8EDCACD7-00DF-40EC-A8C0-B24F1E7D926B}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EDC66214-7B5A-479C-9F8A-4F1A3DE80C93}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FF327F2E-CCC8-4F10-A2D0-38603D037E2C}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{01BD5F34-840B-4D65-8BF9-969DAE6CF738}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FD17D526-ED20-412C-8410-FA25A5F46BAC}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D3DD404F-F408-420C-A9EA-A20AAB672DBB}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3F16CD83-89C9-4318-A8AD-16A99DB6A766}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B4A38B6C-953A-42F8-8BF4-56631E8D7614}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8406BEC6-5D17-457B-BD92-714F0CF97EB5}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{6F51BB50-9D79-4BA5-A519-6EF540C17B67}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E34CB8FD-CBD7-4A2E-B4E0-738BC079307C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9251F22F-29AD-41BA-B38F-E50534BD4E12}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{55DA9900-29F0-48FE-B856-2F7CAACA67E1}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{BDB5BAD1-EF93-4D54-9722-7994B328EB88}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">{0E218CF8-ECB5-417B-B533-D851C0251271}</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D803253-0D98-4C29-90AE-84E720B07657}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8934324A-007D-49FB-A1FF-F92608513E4D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="Counter">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1EF6EE6B-FED9-4B60-8FC3-05A59E7667B0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1FC5CE71-C336-452D-8E10-BFAE5569C2CE}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C2B0D6E3-585D-4357-9C80-12E7B8000299}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><ns:SqlTraceCollector xmlns:ns="DataCollectorType" use_default="1"><Events/><Filters/></ns:SqlTraceCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E6FBB1C-469F-44CC-839D-A0B5EE84CEF4}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8BFB15C6-3D9A-4C4D-B1F4-B4EBF49B8D65}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{43E08441-AEAE-4004-87B5-B11D2507FCF6}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B7F59CF4-A8A0-4E82-93A0-E52E8E859904}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E466E841-5C40-48CB-8CFC-E678F9967C80}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{049D5A2B-A19C-4F1B-8036-0392BC42CE3A}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A6803296-75B6-41BC-B261-1EA8C279A888}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=myMDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F21C218D-AA71-457B-99D0-CE63B7012CA4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{59D1463F-2A4E-4399-BFE9-814648EBDB91}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B649CEEE-C1E3-4434-A3BC-86FC468A9EDD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9D4E5F6C-F05E-42AD-8E32-8D215CBC25DD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D48AFDE-B6ED-4AD2-A721-030A19BBB2BB}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D57E938-0D8F-4C71-959A-C20D0BAD5C09}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceCurrentEventTime">
<DTS:VariableValue DTS:DataType="8">2007-03-13 14:28:51.820</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{72FDA754-43D5-4AAC-930C-6074C64CE825}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceCurrentFile">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7B00BCC4-67F6-4480-8034-2836E0929FE8}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceDroppedEventCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{00FC8CA7-8D41-4099-9A78-865E9CB964A4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E9DB8444-2521-4213-8DDE-2F19885D8E74}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceInfoID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{39F34FBD-911E-4F15-847D-577DC76049CA}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceIsRunning">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0D1478BA-31B7-42AD-8762-50342593C49C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLastEventSequence">
<DTS:VariableValue DTS:DataType="8">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7C0FFEA0-C638-49F3-AA0D-9DCA4A372559}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLocation">
<DTS:VariableValue DTS:DataType="8">\DC_Trace_ALEN-PC.MSSQL.1..0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E5277DAE-C666-41F7-B34E-3B58DC087855}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceStartTime">
<DTS:VariableValue DTS:DataType="8">2007-03-13 14:24:40.000</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8F4EF19C-F61E-4CEE-BE5A-A73B4EA5A710}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceUseDefault">
<DTS:VariableValue DTS:DataType="8">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container" DTS:AssignExpression="@Counter = @Counter + 1" DTS:CreationName="STOCK:FORLOOP" DTS:Description="For Loop Container" DTS:DTSID="{ECC401D1-FE83-46E6-AD37-0E1F711F0C62}" DTS:EvalExpression="@Counter < 2" DTS:ExecutableType="STOCK:FORLOOP" DTS:InitExpression="@Counter = 0" DTS:LocaleID="-1" DTS:MaxConcurrent="1" DTS:ObjectName="For Loop Container">
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{26A8C112-8CCB-4C21-BADC-77E438246248}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For each trace file - regular trace upload">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{821B0536-E431-458F-8EAE-028BE667F142}" DTS:ObjectName="{821B0536-E431-458F-8EAE-028BE667F142}">
<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="FileSpec">"DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID] + "*.trc"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachFileEnumeratorProperties>
<FEFEProperty Folder=""/>
<FEFEProperty FileSpec="DC_Trace_ALEN-PC.MSSQL.1..0*.trc"/>
<FEFEProperty FileNameRetrievalType="0"/>
<FEFEProperty Recurse="0"/>
</ForEachFileEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3D6F8AD1-3C96-4920-B28C-F360CA77AEFD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3ED87BA4-E9D0-4FC4-A1A1-47A19C6EDF3B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{491029A7-AEDE-4DAC-B07E-7C134EF63963}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{96A9329D-379F-466F-970B-4A97A3FCF7A1}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload trace file">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{76E0DEBC-BF6A-45D2-A30B-EB6746BEB47B}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [TextData], [BinaryData], [DatabaseID], [TransactionID], [LineNumber], [NTUserName], [NTDomainName], [HostName], [ClientProcessID], [ApplicationName], [LoginName], [SPID], [Duration], [StartTime], [EndTime], [Reads], [Writes], [CPU], [Permissions], [Severity], [EventSubClass], [ObjectID], [Success], [IndexID], [IntegerData], [ServerName], [EventClass], [ObjectType], [NestLevel], [State], [Error], [Mode], [Handle], [ObjectName], [DatabaseName], [FileName], [OwnerName], [RoleName], [TargetUserName], [DBUserName], [LoginSid], [TargetLoginName], [TargetLoginSid], [ColumnPermissions], [LinkedServerName], [ProviderName], [MethodName], [RowCounts], [RequestID], [XactSequence], [EventSequence], [BigintData1], [BigintData2], [GUID], [IntegerData2], [ObjectID2], [Type], [OwnerID], [ParentName], [IsSystem], [Offset], [SourceDatabaseID], [SqlHandle], [SessionLoginName], [PlanHandle] , [GroupID] FROM ::fn_trace_gettable(N'" + @[User::TraceCurrentFile] + "', 1) WHERE [EventSequence] > " + @[User::TraceLastEventSequence]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLoadScript">
<DTS:VariableValue DTS:DataType="8">SELECT
[TextData],
[BinaryData],
[DatabaseID],
[TransactionID],
[LineNumber],
[NTUserName],
[NTDomainName],
[HostName],
[ClientProcessID],
[ApplicationName],
[LoginName],
[SPID],
[Duration],
[StartTime],
[EndTime],
[Reads],
[Writes],
[CPU],
[Permissions],
[Severity],
[EventSubClass],
[ObjectID],
[Success],
[IndexID],
[IntegerData],
[ServerName],
[EventClass],
[ObjectType],
[NestLevel],
[State],
[Error],
[Mode],
[Handle],
[ObjectName],
[DatabaseName],
[FileName],
[OwnerName],
[RoleName],
[TargetUserName],
[DBUserName],
[LoginSid],
[TargetLoginName],
[TargetLoginSid],
[ColumnPermissions],
[LinkedServerName],
[ProviderName],
[MethodName],
[RowCounts],
[RequestID],
[XactSequence],
[EventSequence],
[BigintData1],
[BigintData2],
[GUID],
[IntegerData2],
[ObjectID2],
[Type],
[OwnerID],
[ParentName],
[IsSystem],
[Offset],
[SourceDatabaseID],
[SqlHandle],
[SessionLoginName],
[PlanHandle]
, [GroupID] FROM
::fn_trace_gettable(N'C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc', 1)
WHERE
[EventSequence] > 0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence" componentClassID="Microsoft.Aggregate" contactInfo="Aggregate;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;3" description="Aggregates and groups values in a dataset." name="AGG - Get max value of EventSequence" version="3">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
<property dataType="System.Int32" description="Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used." name="CountDistinctScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence." name="CountDistinctKeys"/>
<property dataType="System.Int32" description="Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100." name="AutoExtendFactor">25</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Aggregate Input 1">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]" name="Aggregate Output 1">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
</properties>
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" name="EventSequence_Max">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">7</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" dataType="ui8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" name="event_count">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\0:invalid}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">2</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count source">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Output row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion" componentClassID="Microsoft.DataConvert" contactInfo="Data Conversion;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Data Conversion" name="Data Conversion" usesDispositions="true">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]" name="Data Conversion Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input].Columns[SqlHandle]" cachedDataType="image" cachedName="SqlHandle" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input].Columns[PlanHandle]" cachedDataType="image" cachedName="PlanHandle" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output]" exclusionGroup="1" name="Data Conversion Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" name="SqlHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" name="PlanHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output]" exclusionGroup="1" isErrorOut="true" name="Data Conversion Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add columns" usesDispositions="true">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input].Columns[EventSequence_Max]" cachedDataType="i8" cachedName="EventSequence_Max" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" name="is_running" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceIsRunning]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceIsRunning]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" name="dropped_event_count" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceDroppedEventCount]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceDroppedEventCount]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" name="last_event_sequence" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}) ? 0 : #{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(EventSequence_Max) ? 0 : EventSequence_Max</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id and trace_info_id" usesDispositions="true" validateExternalMetadata="False">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@SnapshotID</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLT - Split two ways">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Multicast Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODB - Read trace" usesDispositions="true" validateExternalMetadata="False" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::TraceLoadScript</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" dataType="nText" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" name="TextData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" name="BinaryData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" name="DatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" name="TransactionID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" name="LineNumber" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" name="NTUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" name="NTDomainName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" name="HostName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" name="ClientProcessID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" name="ApplicationName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" name="LoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" name="SPID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" name="Duration" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" name="StartTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" name="EndTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" name="Reads" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" name="Writes" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" name="CPU" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" name="Permissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" name="Severity" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" name="EventSubClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" name="ObjectID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" name="Success" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" name="IndexID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" name="IntegerData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" name="ServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" name="EventClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" name="ObjectType" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" name="NestLevel" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" name="State" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" name="Error" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" name="Mode" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" name="Handle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" name="ObjectName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" name="DatabaseName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" name="FileName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" name="OwnerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" name="RoleName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" name="TargetUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" name="DBUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" name="LoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" name="TargetLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" name="TargetLoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" name="ColumnPermissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" name="LinkedServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" name="ProviderName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" name="MethodName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" name="RowCounts" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" name="RequestID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" name="XactSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" name="EventSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" name="BigintData1" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" name="BigintData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" dataType="guid" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" name="GUID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" name="IntegerData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" name="ObjectID2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" name="Type" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" name="OwnerID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" name="ParentName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" name="IsSystem" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" name="Offset" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" name="SourceDatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" name="SqlHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" name="SessionLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" name="PlanHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" name="GroupID" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" dataType="image" name="SqlHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" dataType="image" name="PlanHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" dataType="nText" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" name="TextData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" name="BinaryData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" name="DatabaseID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" name="TransactionID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" name="LineNumber"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" name="NTUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" name="NTDomainName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" name="HostName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" name="ClientProcessID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" name="ApplicationName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" name="LoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" name="SPID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" name="Duration"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" dataType="dbTimeStamp" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" name="StartTime"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" dataType="dbTimeStamp" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" name="EndTime"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" name="Reads"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" name="Writes"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" name="CPU"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" name="Permissions"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" name="Severity"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" name="EventSubClass"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" name="ObjectID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" name="Success"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" name="IndexID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" name="IntegerData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" name="ServerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" name="EventClass"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" name="ObjectType"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" name="NestLevel"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" name="State"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" name="Error"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" name="Mode"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" name="Handle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" name="ObjectName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" name="DatabaseName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" name="FileName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" name="OwnerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" name="RoleName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" name="TargetUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" name="DBUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" name="LoginSid"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" name="TargetLoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" name="TargetLoginSid"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" name="ColumnPermissions"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" name="LinkedServerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" name="ProviderName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" name="MethodName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" name="RowCounts"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" name="RequestID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" name="XactSequence"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" name="EventSequence"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" name="BigintData1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" name="BigintData2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" dataType="guid" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" name="GUID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" name="IntegerData2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" name="ObjectID2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" name="Type"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" name="OwnerID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" name="ParentName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" name="IsSystem"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" name="Offset"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" name="SourceDatabaseID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" name="SqlHandle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" name="SessionLoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" name="PlanHandle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" name="GroupID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODB - Update trace_info" usesDispositions="true" version="2">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">{call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[is_running]" cachedDataType="i4" cachedName="is_running" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[event_count]" cachedDataType="ui8" cachedName="event_count" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[dropped_event_count]" cachedDataType="i4" cachedName="dropped_event_count" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[last_event_sequence]" cachedDataType="i8" cachedName="last_event_sequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" dataType="i4" name="@trace_info_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" dataType="i4" name="@snapshot_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" dataType="bool" name="@is_running">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" dataType="i8" name="@event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" dataType="i4" name="@dropped_event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" dataType="i8" name="@last_event_sequence">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Write to output table" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[trace_data]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TextData]" cachedDataType="nText" cachedName="TextData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BinaryData]" cachedDataType="image" cachedName="BinaryData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseID]" cachedDataType="i4" cachedName="DatabaseID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TransactionID]" cachedDataType="i8" cachedName="TransactionID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LineNumber]" cachedDataType="i4" cachedName="LineNumber" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTUserName]" cachedDataType="wstr" cachedLength="256" cachedName="NTUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTDomainName]" cachedDataType="wstr" cachedLength="256" cachedName="NTDomainName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[HostName]" cachedDataType="wstr" cachedLength="256" cachedName="HostName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ClientProcessID]" cachedDataType="i4" cachedName="ClientProcessID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ApplicationName]" cachedDataType="wstr" cachedLength="256" cachedName="ApplicationName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginName]" cachedDataType="wstr" cachedLength="256" cachedName="LoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SPID]" cachedDataType="i4" cachedName="SPID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Duration]" cachedDataType="i8" cachedName="Duration" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[StartTime]" cachedDataType="dbTimeStamp" cachedName="StartTime" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EndTime]" cachedDataType="dbTimeStamp" cachedName="EndTime" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Reads]" cachedDataType="i8" cachedName="Reads" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Writes]" cachedDataType="i8" cachedName="Writes" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[CPU]" cachedDataType="i4" cachedName="CPU" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Permissions]" cachedDataType="i8" cachedName="Permissions" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Severity]" cachedDataType="i4" cachedName="Severity" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSubClass]" cachedDataType="i4" cachedName="EventSubClass" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID]" cachedDataType="i4" cachedName="ObjectID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Success]" cachedDataType="i4" cachedName="Success" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IndexID]" cachedDataType="i4" cachedName="IndexID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData]" cachedDataType="i4" cachedName="IntegerData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ServerName]" cachedDataType="wstr" cachedLength="256" cachedName="ServerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventClass]" cachedDataType="i4" cachedName="EventClass" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectType]" cachedDataType="i4" cachedName="ObjectType" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NestLevel]" cachedDataType="i4" cachedName="NestLevel" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[State]" cachedDataType="i4" cachedName="State" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Error]" cachedDataType="i4" cachedName="Error" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Mode]" cachedDataType="i4" cachedName="Mode" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Handle]" cachedDataType="i4" cachedName="Handle" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectName]" cachedDataType="wstr" cachedLength="256" cachedName="ObjectName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseName]" cachedDataType="wstr" cachedLength="256" cachedName="DatabaseName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[FileName]" cachedDataType="wstr" cachedLength="256" cachedName="FileName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerName]" cachedDataType="wstr" cachedLength="256" cachedName="OwnerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RoleName]" cachedDataType="wstr" cachedLength="256" cachedName="RoleName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetUserName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DBUserName]" cachedDataType="wstr" cachedLength="256" cachedName="DBUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginSid]" cachedDataType="image" cachedName="LoginSid" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetLoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginSid]" cachedDataType="image" cachedName="TargetLoginSid" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ColumnPermissions]" cachedDataType="i4" cachedName="ColumnPermissions" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LinkedServerName]" cachedDataType="wstr" cachedLength="256" cachedName="LinkedServerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ProviderName]" cachedDataType="wstr" cachedLength="256" cachedName="ProviderName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[MethodName]" cachedDataType="wstr" cachedLength="256" cachedName="MethodName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RowCounts]" cachedDataType="i8" cachedName="RowCounts" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RequestID]" cachedDataType="i4" cachedName="RequestID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[XactSequence]" cachedDataType="i8" cachedName="XactSequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData1]" cachedDataType="i8" cachedName="BigintData1" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData2]" cachedDataType="i8" cachedName="BigintData2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GUID]" cachedDataType="guid" cachedName="GUID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData2]" cachedDataType="i4" cachedName="IntegerData2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID2]" cachedDataType="i8" cachedName="ObjectID2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Type]" cachedDataType="i4" cachedName="Type" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerID]" cachedDataType="i4" cachedName="OwnerID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ParentName]" cachedDataType="wstr" cachedLength="256" cachedName="ParentName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IsSystem]" cachedDataType="i4" cachedName="IsSystem" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Offset]" cachedDataType="i4" cachedName="Offset" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SourceDatabaseID]" cachedDataType="i4" cachedName="SourceDatabaseID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SessionLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="SessionLoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GroupID]" cachedDataType="i4" cachedName="GroupID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SqlHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="SqlHandle64" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[PlanHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="PlanHandle64" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" dataType="i4" name="trace_info_id"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" dataType="bytes" length="64" name="SqlHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" dataType="bytes" length="64" name="PlanHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Aggregate Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]" name="Aggregate Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Data Conversion Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]" name="Data Conversion Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Derived Column Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]" name="Derived Column Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Derived Column Output1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" name="Derived Column Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Multicast Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" name="Multicast Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Multicast Output 2]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Multicast Output 2" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 2]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[OLE DB Source Error Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[OLE DB Source Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Row Count Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Outputs[Row Count Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Row Count Output 11]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Row Count Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible" DTS:CreationName="Microsoft.FileAccessTask" DTS:DelayValidation="True" DTS:Description="File Access Task" DTS:DTSID="{679134AC-EFFB-4A28-B2C2-4247D71FEE23}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Check if trace file is accessible" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::TraceCurrentFile]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">6</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>6</Mode>
<FilePath>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Precheck if trace file is accessible" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{BCAA70EC-FD75-4E75-9698-7459FF0FB8BB}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Precheck if trace file is accessible" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::TraceCurrentFile]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">4</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>4</Mode>
<FilePath>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{5EE7C74E-CD4E-40E2-8D32-7475CF6457B1}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:ForceExecutionResult="0" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Delete trace file" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:EventHandlers>
-<DTS:EventHandler DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file.EventHandlers[OnError]" DTS:CreationName="OnError" DTS:DTSID="{582131DF-655C-41F3-B0E7-5D7E8FDBB56F}" DTS:EventID="-454761244" DTS:EventName="OnError" DTS:LocaleID="-1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:Description="The propagate property of the event" DTS:DTSID="{6C9DBDD1-7561-4A92-87F2-521B9881BB19}" DTS:Expression="@[System::ErrorCode] != -1073548540" DTS:IncludeInDebugDump="6789" DTS:Namespace="System" DTS:ObjectName="Propagate">
<DTS:VariableValue DTS:DataType="11">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:Executables/>
</DTS:EventHandler>
</DTS:EventHandlers>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::TraceCurrentFile" TaskIsSourceVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Logs statistics about the most recent Data Flow Task" DTS:DTSID="{7FE278CC-D8C4-4CCD-B884-D4FD9790D5A0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log package stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B2278345-853A-4BC7-BC04-346F236BE117}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">92790</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - logs uploaded file name" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="SQL - logs uploaded file name" DTS:DTSID="{36601F9F-22D5-41EB-AC7D-0CBF2756CC8C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="SQL - logs uploaded file name" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call dbo.sp_ssis_addlogentry (N'UploadTraceFile',?, ?, ?, ?, ?, ?, ?, 0, 0x00, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::UserName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::PackageName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="System::PackageID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="System::ExecutionInstanceGUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="System::StartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="7" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="6" SQLTask:DtsVariableName="System::StartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="7" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="7" SQLTask:DtsVariableName="User::TraceCurrentFile" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{4184AC42-F94B-469C-A49E-EE793CB1D245}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{41B4AC86-833E-417B-A00D-2259D0C87E35}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] >= 1" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{0957B7CD-F748-44F6-BD2F-9A5B335C4F16}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{A52A42F1-5767-464E-AEBC-F8FB69B7BAC4}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] > 1" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - logs uploaded file name" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{1963E80B-FFFB-425B-AEF5-0F6F5BE8FFA2}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Precheck if trace file is accessible" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 4" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{2FE5FF29-A973-47A2-AAF5-B529588DB38B}" DTS:ObjectName="{2FE5FF29-A973-47A2-AAF5-B529588DB38B}" DTS:ValueIndex="0" DTS:VariableName="User::TraceCurrentFile"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Check trace info" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{782c9195-15b2-4260-bff9-6d85b486e50f}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Check trace info" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="DECLARE @status INT SET @status = 2 SELECT @status = CASE t.status WHEN 1 THEN 1 ELSE 0 END FROM sys.traces t WHERE t.path LIKE (? + N'%.trc') SELECT @status" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="0" SQLTask:DtsVariableName="User::TraceIsRunning"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Close trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{0b304887-a5f5-48be-a81e-48ab362bfe41}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" SQLTask:SqlStatementSource="{ call [sp_trace_setstatus] (?, 2) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{1fe772eb-42ae-4641-af91-138c98b8fcba}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get Last_Event_Sequence" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="DECLARE @lastEventSequence BIGINT SET @lastEventSequence = -1 SELECT @lastEventSequence = [last_event_sequence] FROM [snapshots].[trace_info] WHERE [trace_info_id] = ? SELECT @lastEventSequence" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="0" SQLTask:DtsVariableName="User::TraceLastEventSequence"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceInfoID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{3392402A-8EDF-40CA-B868-CE800491C3A4}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{77861B0E-1726-4FE2-BEC6-4CAB5CEE2AFA}" DTS:EvalOp="3" DTS:Expression="@[User::TraceIsRunning] == 0" DTS:From="Package\For Loop Container\SQL - Check trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\For Loop Container\SQL - Close trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{0B57ACB1-DDFE-4E1F-909A-36BF193C6D15}" DTS:From="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\For Loop Container\SQL - Check trace info"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{38B4A79F-D07D-418D-BA5A-2AF603D6620F}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Default trace upload">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AD706893-04C6-4F6A-851B-6E8961A23D59}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CCB242CF-14BC-4978-B629-AC8BDA3637AA}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F61B5459-D245-44A4-8FFF-694915DE1C25}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload\DFT - Upload default trace file" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{ed5bc122-e2d0-47fe-9a21-91b4d462f083}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload default trace file">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{a2d94ca5-a845-4067-8951-906992367f42}" DTS:EvaluateAsExpression="True" DTS:Expression=""DECLARE @trace_file_name nvarchar(512) SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1 SELECT [TextData], [BinaryData], [DatabaseID], [TransactionID], [LineNumber], [NTUserName], [NTDomainName], [HostName], [ClientProcessID], [ApplicationName], [LoginName], [SPID], [Duration], [StartTime], [EndTime], [Reads], [Writes], [CPU], [Permissions], [Severity], [EventSubClass], [ObjectID], [Success], [IndexID], [IntegerData], [ServerName], [EventClass], [ObjectType], [NestLevel], [State], [Error], [Mode], [Handle], [ObjectName], [DatabaseName], [FileName], [OwnerName], [RoleName], [TargetUserName], [DBUserName], [LoginSid], [TargetLoginName], [TargetLoginSid], [ColumnPermissions], [LinkedServerName], [ProviderName], [MethodName], [RowCounts], [RequestID], [XactSequence], [EventSequence], [BigintData1], [BigintData2], [GUID], [IntegerData2], [ObjectID2], [Type], [OwnerID], [ParentName], [IsSystem], [Offset], [SourceDatabaseID], [SqlHandle], [SessionLoginName], [PlanHandle] , [GroupID] FROM ::fn_trace_gettable(@trace_file_name, default) WHERE [EventSequence] > " + @[User::TraceLastEventSequence]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLoadScript">
<DTS:VariableValue DTS:DataType="8">DECLARE @trace_file_name nvarchar(512)
SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1
SELECT
[TextData],
[BinaryData],
[DatabaseID],
[TransactionID],
[LineNumber],
[NTUserName],
[NTDomainName],
[HostName],
[ClientProcessID],
[ApplicationName],
[LoginName],
[SPID],
[Duration],
[StartTime],
[EndTime],
[Reads],
[Writes],
[CPU],
[Permissions],
[Severity],
[EventSubClass],
[ObjectID],
[Success],
[IndexID],
[IntegerData],
[ServerName],
[EventClass],
[ObjectType],
[NestLevel],
[State],
[Error],
[Mode],
[Handle],
[ObjectName],
[DatabaseName],
[FileName],
[OwnerName],
[RoleName],
[TargetUserName],
[DBUserName],
[LoginSid],
[TargetLoginName],
[TargetLoginSid],
[ColumnPermissions],
[LinkedServerName],
[ProviderName],
[MethodName],
[RowCounts],
[RequestID],
[XactSequence],
[EventSequence],
[BigintData1],
[BigintData2],
[GUID],
[IntegerData2],
[ObjectID2],
[Type],
[OwnerID],
[ParentName],
[IsSystem],
[Offset],
[SourceDatabaseID],
[SqlHandle],
[SessionLoginName],
[PlanHandle]
, [GroupID] FROM
::fn_trace_gettable(@trace_file_name, default)
WHERE
[EventSequence] > 0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence" componentClassID="Microsoft.Aggregate" contactInfo="Aggregate;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;3" description="Aggregates and groups values in a dataset." name="AGG - Get max value of EventSequence" version="3">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
<property dataType="System.Int32" description="Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used." name="CountDistinctScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence." name="CountDistinctKeys"/>
<property dataType="System.Int32" description="Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100." name="AutoExtendFactor">25</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Aggregate Input 1">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]" name="Aggregate Output 1">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
</properties>
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" name="EventSequence_Max">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">7</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" dataType="ui8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" name="event_count">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\0:invalid}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">2</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count source">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Output row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion" componentClassID="Microsoft.DataConvert" contactInfo="Data Conversion;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Data Conversion" name="Data Conversion" usesDispositions="true">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]" name="Data Conversion Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input].Columns[SqlHandle]" cachedDataType="image" cachedName="SqlHandle" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input].Columns[PlanHandle]" cachedDataType="image" cachedName="PlanHandle" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output]" exclusionGroup="1" name="Data Conversion Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" name="SqlHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" name="PlanHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output]" exclusionGroup="1" isErrorOut="true" name="Data Conversion Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add columns" usesDispositions="true">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input].Columns[EventSequence_Max]" cachedDataType="i8" cachedName="EventSequence_Max" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" name="is_running" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceIsRunning]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceIsRunning]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" name="dropped_event_count" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceDroppedEventCount]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceDroppedEventCount]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" name="last_event_sequence" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}) ? 0 : #{Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(EventSequence_Max) ? 0 : EventSequence_Max</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id and trace_info_id" usesDispositions="true" validateExternalMetadata="False">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@SnapshotID</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLT - Split two ways">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Multicast Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODB - Read trace" usesDispositions="true" validateExternalMetadata="False" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::TraceLoadScript</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" dataType="nText" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" name="TextData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" name="BinaryData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" name="DatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" name="TransactionID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" name="LineNumber" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" name="NTUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" name="NTDomainName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" name="HostName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" name="ClientProcessID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" name="ApplicationName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" name="LoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" name="SPID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" name="Duration" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" name="StartTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" name="EndTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" name="Reads" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" name="Writes" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" name="CPU" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" name="Permissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" name="Severity" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" name="EventSubClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" name="ObjectID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" name="Success" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" name="IndexID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" name="IntegerData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" name="ServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" name="EventClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" name="ObjectType" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" name="NestLevel" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" name="State" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" name="Error" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" name="Mode" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" name="Handle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" name="ObjectName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" name="DatabaseName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" name="FileName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" name="OwnerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" name="RoleName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" name="TargetUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" name="DBUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" name="LoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" name="TargetLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" name="TargetLoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" name="ColumnPermissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" name="LinkedServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" name="ProviderName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" name="MethodName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" name="RowCounts" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" name="RequestID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" name="XactSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" name="EventSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" name="BigintData1" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" name="BigintData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" dataType="guid" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" name="GUID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" name="IntegerData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" name="ObjectID2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" name="Type" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" name="OwnerID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" name="ParentName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" name="IsSystem" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" name="Offset" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" name="SourceDatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" name="SqlHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" name="SessionLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" name="PlanHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" name="GroupID" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" dataType="image" name="SqlHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" dataType="image" name="PlanHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" dataType="nText" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" name="TextData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" name="BinaryData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" name="DatabaseID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" name="TransactionID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" name="LineNumber"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" name="NTUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" name="NTDomainName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" name="HostName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" name="ClientProcessID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" name="ApplicationName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" name="LoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" name="SPID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" name="Duration"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" dataType="dbTimeStamp" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" name="StartTime"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" dataType="dbTimeStamp" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" name="EndTime"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" name="Reads"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" name="Writes"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" name="CPU"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" name="Permissions"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" name="Severity"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" name="EventSubClass"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" name="ObjectID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" name="Success"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" name="IndexID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" name="IntegerData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" name="ServerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" name="EventClass"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" name="ObjectType"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" name="NestLevel"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" name="State"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" name="Error"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" name="Mode"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" name="Handle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" name="ObjectName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" name="DatabaseName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" name="FileName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" name="OwnerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" name="RoleName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" name="TargetUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" name="DBUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" name="LoginSid"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" name="TargetLoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" name="TargetLoginSid"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" name="ColumnPermissions"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" name="LinkedServerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" name="ProviderName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" name="MethodName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" name="RowCounts"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" name="RequestID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" name="XactSequence"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" name="EventSequence"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" name="BigintData1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" name="BigintData2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" dataType="guid" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" name="GUID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" name="IntegerData2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" name="ObjectID2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" name="Type"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" name="OwnerID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" name="ParentName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" name="IsSystem"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" name="Offset"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" name="SourceDatabaseID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" name="SqlHandle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" name="SessionLoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" name="PlanHandle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" name="GroupID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODB - Update trace_info" usesDispositions="true" version="2">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">{call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[is_running]" cachedDataType="i4" cachedName="is_running" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[event_count]" cachedDataType="ui8" cachedName="event_count" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[dropped_event_count]" cachedDataType="i4" cachedName="dropped_event_count" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[last_event_sequence]" cachedDataType="i8" cachedName="last_event_sequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" dataType="i4" name="@trace_info_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" dataType="i4" name="@snapshot_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" dataType="bool" name="@is_running">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" dataType="i8" name="@event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" dataType="i4" name="@dropped_event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" dataType="i8" name="@last_event_sequence">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Write to output table" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[trace_data]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TextData]" cachedDataType="nText" cachedName="TextData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BinaryData]" cachedDataType="image" cachedName="BinaryData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseID]" cachedDataType="i4" cachedName="DatabaseID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TransactionID]" cachedDataType="i8" cachedName="TransactionID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LineNumber]" cachedDataType="i4" cachedName="LineNumber" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTUserName]" cachedDataType="wstr" cachedLength="256" cachedName="NTUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTDomainName]" cachedDataType="wstr" cachedLength="256" cachedName="NTDomainName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[HostName]" cachedDataType="wstr" cachedLength="256" cachedName="HostName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ClientProcessID]" cachedDataType="i4" cachedName="ClientProcessID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ApplicationName]" cachedDataType="wstr" cachedLength="256" cachedName="ApplicationName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginName]" cachedDataType="wstr" cachedLength="256" cachedName="LoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SPID]" cachedDataType="i4" cachedName="SPID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Duration]" cachedDataType="i8" cachedName="Duration" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[StartTime]" cachedDataType="dbTimeStamp" cachedName="StartTime" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EndTime]" cachedDataType="dbTimeStamp" cachedName="EndTime" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Reads]" cachedDataType="i8" cachedName="Reads" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Writes]" cachedDataType="i8" cachedName="Writes" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[CPU]" cachedDataType="i4" cachedName="CPU" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Permissions]" cachedDataType="i8" cachedName="Permissions" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Severity]" cachedDataType="i4" cachedName="Severity" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSubClass]" cachedDataType="i4" cachedName="EventSubClass" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID]" cachedDataType="i4" cachedName="ObjectID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Success]" cachedDataType="i4" cachedName="Success" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IndexID]" cachedDataType="i4" cachedName="IndexID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData]" cachedDataType="i4" cachedName="IntegerData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ServerName]" cachedDataType="wstr" cachedLength="256" cachedName="ServerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventClass]" cachedDataType="i4" cachedName="EventClass" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectType]" cachedDataType="i4" cachedName="ObjectType" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NestLevel]" cachedDataType="i4" cachedName="NestLevel" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[State]" cachedDataType="i4" cachedName="State" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Error]" cachedDataType="i4" cachedName="Error" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Mode]" cachedDataType="i4" cachedName="Mode" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Handle]" cachedDataType="i4" cachedName="Handle" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectName]" cachedDataType="wstr" cachedLength="256" cachedName="ObjectName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseName]" cachedDataType="wstr" cachedLength="256" cachedName="DatabaseName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[FileName]" cachedDataType="wstr" cachedLength="256" cachedName="FileName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerName]" cachedDataType="wstr" cachedLength="256" cachedName="OwnerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RoleName]" cachedDataType="wstr" cachedLength="256" cachedName="RoleName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetUserName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DBUserName]" cachedDataType="wstr" cachedLength="256" cachedName="DBUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginSid]" cachedDataType="image" cachedName="LoginSid" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetLoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginSid]" cachedDataType="image" cachedName="TargetLoginSid" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ColumnPermissions]" cachedDataType="i4" cachedName="ColumnPermissions" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LinkedServerName]" cachedDataType="wstr" cachedLength="256" cachedName="LinkedServerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ProviderName]" cachedDataType="wstr" cachedLength="256" cachedName="ProviderName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[MethodName]" cachedDataType="wstr" cachedLength="256" cachedName="MethodName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RowCounts]" cachedDataType="i8" cachedName="RowCounts" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RequestID]" cachedDataType="i4" cachedName="RequestID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[XactSequence]" cachedDataType="i8" cachedName="XactSequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData1]" cachedDataType="i8" cachedName="BigintData1" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData2]" cachedDataType="i8" cachedName="BigintData2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GUID]" cachedDataType="guid" cachedName="GUID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData2]" cachedDataType="i4" cachedName="IntegerData2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID2]" cachedDataType="i8" cachedName="ObjectID2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Type]" cachedDataType="i4" cachedName="Type" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerID]" cachedDataType="i4" cachedName="OwnerID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ParentName]" cachedDataType="wstr" cachedLength="256" cachedName="ParentName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IsSystem]" cachedDataType="i4" cachedName="IsSystem" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Offset]" cachedDataType="i4" cachedName="Offset" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SourceDatabaseID]" cachedDataType="i4" cachedName="SourceDatabaseID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SessionLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="SessionLoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GroupID]" cachedDataType="i4" cachedName="GroupID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SqlHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="SqlHandle64" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[PlanHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="PlanHandle64" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" dataType="i4" name="trace_info_id"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" dataType="bytes" length="64" name="SqlHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" dataType="bytes" length="64" name="PlanHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Aggregate Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]" name="Aggregate Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Data Conversion Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]" name="Data Conversion Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Derived Column Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]" name="Derived Column Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Derived Column Output1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" name="Derived Column Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Multicast Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" name="Multicast Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Multicast Output 2]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Multicast Output 2" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 2]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[OLE DB Source Error Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[OLE DB Source Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Row Count Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Outputs[Row Count Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Row Count Output 11]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Row Count Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload\SQL - Log package stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Logs statistics about the most recent Data Flow Task" DTS:DTSID="{147f8f7a-f829-4ac7-a038-03943f58ee3b}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log package stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{74950c5e-3a60-494f-83a3-e04e64e1217f}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">92813</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Default trace upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{AEDEEA80-FB4F-4737-B938-B2909C835D5A}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] >= 1" DTS:From="Package\SEQ - Default trace upload\DFT - Upload default trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SEQ - Default trace upload\SQL - Log package stats" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Close trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{EAA2093E-36E6-4EA8-A5E9-E568C5A46516}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="3">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" SQLTask:SqlStatementSource="{ call [sp_trace_setstatus] (?, 2) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get last upload time" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{0F29500B-BB42-4603-AB36-A6C75CFC649B}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get last upload time" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [snapshots].[sp_trace_get_info] (?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::ItemID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::TraceStartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::TraceLastEventSequence" SQLTask:ParameterDirection="Output" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::TraceInfoID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get snapshot id" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{C316D13F-2EEE-42A1-B307-924555587091}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get snapshot id" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [core].[sp_create_snapshot] (?, ?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get trace info" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{33CFBECB-7DAD-4256-811D-FED4E423755D}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get trace info" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{call [dbo].[sp_syscollector_get_trace_info](?, ?)}" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="start_time" SQLTask:DtsVariableName="User::TraceStartTime"/>
<SQLTask:ResultBinding SQLTask:ResultName="is_running" SQLTask:DtsVariableName="User::TraceIsRunning"/>
<SQLTask:ResultBinding SQLTask:ResultName="dropped_event_count" SQLTask:DtsVariableName="User::TraceDroppedEventCount"/>
<SQLTask:ResultBinding SQLTask:ResultName="id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::TraceUseDefault" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Update data source" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{D8732C3C-BF2D-40C6-BA2E-AF18493924AC}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Update data source" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\XML - Check use_default attribute" DTS:CreationName="Microsoft.XMLTask" DTS:Description="XML Task" DTS:DTSID="{DB542074-1D89-441B-BA2B-E1E55527C2B8}" DTS:ExecutableType="Microsoft.XMLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="XML - Check use_default attribute" DTS:TaskContact="XML Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<XMLTaskData OperationType="XPATH" SourceType="Variable" Source="User::InputParameters" SecondOperand="*[local-name() = 'SqlTraceCollector']/@use_default" SaveOperationResult="True" DestinationType="Variable" Destination="User::TraceUseDefault" OverwriteDestination="True" XPathOperation="Values"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{2DBE8AE5-8C75-44A9-8C57-D571678FF149}" DTS:From="Package\SQL - Get trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SQL - Update data source"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{9C582F44-453F-431A-80FE-D79155C6E519}" DTS:From="Package\SQL - Update data source" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\SQL - Get last upload time"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{8D136BE7-D0D6-486D-85E9-D64DB633850E}" DTS:From="Package\SQL - Get last upload time" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Get snapshot id"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{0E7EF1B1-B857-44B2-87BF-CA42682C6354}" DTS:EvalOp="1" DTS:Expression="@[User::SnapshotID] != 0 && @[User::TraceUseDefault] != "1"" DTS:From="Package\SQL - Get snapshot id" DTS:ObjectName="Constraint 3" DTS:To="Package\For Loop Container"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{285C2E0E-D5D3-467A-8237-E0B32D55C912}" DTS:EvalOp="3" DTS:Expression="@[User::TraceIsRunning] == 0" DTS:From="Package\SQL - Get trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\SQL - Close trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{5545F925-D433-4F90-93FD-D3E432AE1D83}" DTS:From="Package\XML - Check use_default attribute" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SQL - Get trace info"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{58C2147A-C7A3-4809-95AB-F70A1F1C57BF}" DTS:EvalOp="3" DTS:Expression="@[User::TraceUseDefault] == "1"" DTS:From="Package\SQL - Get snapshot id" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\SEQ - Default trace upload"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


SQL Server storages

Collapse image Server index

Server
ALEN-PC\SQLSERVER2016

Collapse image See also

About this documentation


Package index

Collapse image Package index

Package | Package path
PerfCountersCollect | Data Collector\PerfCountersCollect
PerfCountersUpload | Data Collector\PerfCountersUpload
QueryActivityCollect | Data Collector\QueryActivityCollect
QueryActivityUpload | Data Collector\QueryActivityUpload
SqlTraceCollect | Data Collector\SqlTraceCollect
SqlTraceUpload | Data Collector\SqlTraceUpload

Collapse image See also

About this documentation


Package

Package: PerfCountersCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/23/2007 1:05:21 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {C2EAABC1-5BF3-4127-BEB3-26E94D026E7D}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | 2
MaximumErrorCount | 0
Name | PerfCountersCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\PerfCountersCollect
PackagePath | Data Collector\PerfCountersCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 250
VersionComments |
VersionGUID | {18D1B8E2-6F88-4A06-931F-468BFC86E0A4}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.

Collapse image Executables

Name | Description
LOOP - Aquire performance counters @ collection item frequency | Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilename |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
RowCountOut |
TargetConnectionString |
TargetProcessID |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/23/2007 1:05:21 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{C2EAABC1-5BF3-4127-BEB3-26E94D026E7D}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxConcurrentExecutables="2" DTS:MaxErrorCount="0" DTS:ObjectName="PerfCountersCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="250" DTS:VersionGUID="{A558D853-E09F-4B0F-A56F-C9E4033366AE}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DF91A21-DC08-404B-B537-367F20F72E42}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B360CA6A-D82F-4B4E-81DB-7A8F702574F6}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FB8C290D-145C-46CE-BB73-10BB2385175F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5490BC46-3D1A-4F9A-8776-CF1BE3D41469}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{DDD6841A-31D4-4A59-8532-F9790E901171}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EBE7AA26-55D4-4F72-B489-B55945E6019B}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{F9014B9C-BC8F-489C-B99F-097E18F9BC23}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C24EF892-429F-4B3C-A111-13DB7A494FCB}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{27D818B0-33C7-43D0-8EF2-5977B4196718}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E47A5D19-3066-4CB4-BBE5-FA97F105AFC3}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2D172908-BD61-4ABF-9F82-27F51E6C1DA0}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E5363D05-5772-4597-88B3-326AF26B3C85}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{361B3E87-706B-4AD0-9EC1-006A44B38233}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3669A456-6321-4100-AC8E-FB1A95859A8E}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FDCAFA60-9772-42E4-BBEF-7385D5D59B6F}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{27797092-0D53-4ED5-88B7-0C7B76E726BD}" DTS:ObjectName="ParentLogID"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{29F8E7BD-603A-476F-9B2D-6C92119CE553}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{967E7E54-C796-4A22-995E-AAF61BB36173}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFilename">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF1ADEC8-05A4-4885-AE2E-F5F40EDF145A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C5042E47-57C6-42FF-B65A-36AA2F808656}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">640012b7-4ed0-4865-a636-4946d73c425f</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2E115FC3-AB18-4468-BF2D-74C84CFFF849}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">294605dd-21de-40b2-b20f-f3e170ea1ec3</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{64459284-6B94-45DB-A58B-50D48D02C473}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E988E92E-8FC0-4097-8AA4-CD14BD52783F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3EB44CAF-64FC-4F6A-A7BE-4160AEE20B34}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><PerformanceCountersCollector><PerformanceCounters Objects="Process" Counters="*" Instances="*" /><PerformanceCounters Objects="Processor" Counters="*" Instances="*" /><PerformanceCounters Objects="Paging File" Counters="*" Instances="*" /><PerformanceCounters Objects="PhysicalDisk" Counters="*" Instances="*" /><PerformanceCounters Objects="Server" Counters="*" Instances="" /></PerformanceCountersCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{928007D1-B14A-4D77-8204-80390F5FB6CB}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{43C71C34-F794-427C-92E6-D395182A0EA9}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4BE8D57B-5002-4B3E-B43A-50F76AF58148}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AA31DAA1-078D-4091-8B9F-1E74D4A51FA1}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D05C5D8C-82BF-4C78-AB42-47C01FF782BF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9C7C5068-DBAC-42CB-A94E-FA5EB1FAEE4A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9AA16C7F-334A-4F2C-9F11-CC3719DB3722}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2E6EF4C5-555E-4955-B8BD-22F04E37EB47}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B87950A5-F6B0-4944-957B-943E41BD4A9C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{610F0141-9C2A-427B-8774-BCA4C0B51F30}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5795944D-0E69-4702-9997-D9BA10D59589}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{44A62538-C3D0-4BFD-9216-9CF8B520D3FF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B5CE21C4-35D9-4861-B04C-7FFD03436B28}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TargetProcessID">
<DTS:VariableValue DTS:DataType="3">-1</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop - Aquire performance counters snapshot (Collector Item Frequency)" DTS:DTSID="{72e40adc-49ee-4175-b503-4f26f85912fc}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="LOOP - Aquire performance counters @ collection item frequency">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{6a2ecbd1-4348-4274-a8be-ea7c86bd0581}" DTS:ObjectName="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{926A1F57-89A9-423A-8A68-151BE44CE956}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Collect Upload Package Sync Sequence Container">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2C3410CF-ED28-49FC-B178-5A5D81706A6D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">PerfCountersLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{C54F50A1-B2B5-4E92-9B84-4FAEDBF89FFF}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Retrieve Performance Counters" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="500" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source" componentClassID="Microsoft.TxPerfCounters" name="Perfomance Counters Source" version="1">
-<properties>
<property dataType="System.String" description="Provides XML input for the Performance Counter source component" expressionType="Notify" name="InputParameters"/>
</properties>
-<outputs>
-<output refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output]" name="TxPerfCounters Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]" name="path"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]" dataType="r8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]" dataType="i8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]" dataType="i8" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]" dataType="i4" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]" name="counter_name"/>
<outputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]" dataType="wstr" length="2048" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]" name="instance_name"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of counters collected" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write to cache" validateExternalMetadata="False" version="2">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFilename</property>
<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">2</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">
-<inputColumns>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[path]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[path]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[formatted_value]" cachedDataType="r8" cachedName="formatted_value" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[formatted_value]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[formatted_value]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_first]" cachedDataType="i8" cachedName="raw_value_first" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_first]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_first]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[raw_value_second]" cachedDataType="i8" cachedName="raw_value_second" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_second]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[raw_value_second]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_type]" cachedDataType="i4" cachedName="counter_type" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_type]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_type]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[collection_time]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[object_name]" cachedDataType="wstr" cachedLength="2048" cachedName="object_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[object_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[object_name]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[counter_name]" cachedDataType="wstr" cachedLength="2048" cachedName="counter_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[counter_name]"/>
<inputColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].Columns[instance_name]" cachedDataType="wstr" cachedLength="2048" cachedName="instance_name" externalMetadataColumnId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[instance_name]" lineageId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output].Columns[instance_name]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</input>
</inputs>
</component>
</components>
-<paths>
<path refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters.Paths[Row Count Output 1]" endId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RFD - Write to cache.Inputs[Raw File Destination Input]" name="Row Count Output 1" startId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Outputs[Row Count Output 1]"/>
<path refId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters.Paths[TxPerfCounters Output]" endId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\RC - Number of counters collected.Inputs[Row Count Input 1]" name="TxPerfCounters Output" startId="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container\DFT - Retrieve Performance Counters\Perfomance Counters Source.Outputs[TxPerfCounters Output]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{8399b51b-c73c-4eb5-a314-447211237d45}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="Get SQL Process ID" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8f6a0f37-d2f3-4cba-8dba-24bc965aa726}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlProcessID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="SELECT ? = CONVERT (int, SERVERPROPERTY ('ProcessID'))">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TargetProcessID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{3C4A6AEF-9248-43F4-9428-9A90D2180467}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:LocaleID="-1" DTS:ObjectName="No-Op Sequence Container">
<DTS:Variables/>
<DTS:Executables/>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{81cbca02-95ea-4634-95ed-6ddd61802257}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="EXEC dbo.sp_syscollector_event_onpackageupdate ?">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{584e45b8-9755-4fa7-b8b7-f5c1d000603d}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{4E94A5E2-F3FC-4BE3-A517-51510D6C61A0}" SQLTask:SqlStatementSource="{call dbo.sp_syscollector_event_onstatsupdate(?, N'PerfCountersCollect - Main Collect Loop', ?, ?, 0, ?)}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:Description="Target Process ID Unknown" DTS:DTSID="{A8FA1F46-2B02-4F55-A49E-4DD5C75C5F91}" DTS:EvalOp="1" DTS:Expression="@TargetProcessID == -1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:ObjectName="Constraint" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:Description="Target Process ID Known" DTS:DTSID="{7CCBF793-8783-41F4-ADC2-5E71B809CF51}" DTS:EvalOp="1" DTS:Expression="@TargetProcessID != -1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\No-Op Sequence Container" DTS:ObjectName="Constraint 1" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{9F2FBB1A-FACF-4FC4-B755-A53DC3403F70}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{71196d3d-021d-447d-973a-4c23d217cd1c}" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\SQL - Log Package Iteration" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Aquire performance counters @ collection item frequency.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{0610DCB9-BB0C-4B26-BE90-D0DEFF3CC36A}" DTS:From="Package\LOOP - Aquire performance counters @ collection item frequency\Get SQL Process ID" DTS:ObjectName="Constraint 4" DTS:To="Package\LOOP - Aquire performance counters @ collection item frequency\Collect Upload Package Sync Sequence Container" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{A54A1B17-9B8C-435D-8F32-D034B664E27C}" DTS:ObjectName="{A54A1B17-9B8C-435D-8F32-D034B664E27C}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>


Package

Package: PerfCountersUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/23/2007 1:06:13 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {08D854CB-0D45-4E96-92C6-227A5DCD7066}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | 2
MaximumErrorCount | 0
Name | PerfCountersUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\PerfCountersUpload
PackagePath | Data Collector\PerfCountersUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 305
VersionComments |
VersionGUID | {5A16B36F-15D1-4F67-A065-0C1E1AA2545A}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
CWM - Delete Old Cache Files | Cache Window Maintainance Task
FEF - For Each Collected Cache File Remaining, Try to Upload | Foreach Loop Container
Sequence Container | Sequence Container
SQL - Create snapshot ID in MDW | Execute SQL Task
SQL - Register collection set to MDW | Execute SQL Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint 2 |
Constraint 3 |
Constraint 4 |
Constraint 5 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFileName |
CacheOutput |
CacheUploadFilesPrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotID |
SourceID |
TargetConnectionString |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-48.918000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-48.938000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-48.959000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.074000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 146326
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.342000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 146493
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.499000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 146610
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.618000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 146723
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.738000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 146793
VariablePath | \Package\FEF - For Each Collected Cache File Remaining, Try to Upload.Variables[User::LoopDuration]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.802000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-49.948000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-50.048000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-50.093000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-50.195000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-50.296000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package element

Package element: CacheOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | True
Expression | @[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache"{LF}
IncludeInDebugDump | False
Name | CacheOutput
Namespace | User
QualifiedName | User::CacheOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-50.357000000.cache
VariablePath | \Package.Variables[User::CacheOutput]


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/23/2007 1:06:13 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{08D854CB-0D45-4E96-92C6-227A5DCD7066}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxConcurrentExecutables="2" DTS:MaxErrorCount="0" DTS:ObjectName="PerfCountersUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="305" DTS:VersionGUID="{069E8ADB-EBA0-40E1-96A6-CDA67E9A913F}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{2AEF0133-FEA0-472B-B12D-89F60FF1CBCD}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{132C9722-DFF5-4B1E-8335-113AB9B72B8B}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{767DBF63-6589-4A47-92B6-83B7FE6C3F88}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8F817CE9-10DB-45C1-9F64-78474C992FAA}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{10D13CA8-84F9-41CF-A09D-8D3158B0243B}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{28F4286B-9D00-4269-AC22-C247150E220B}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{6893D265-3DAF-4111-9601-754CB28CF15D}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D425A728-7408-4EE7-993B-46EFDC11947F}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B1E74B02-0F02-41C7-A9D7-7612EADE9BD4}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9ADFDA9C-89B3-460E-83EC-C123E92768AC}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E6BB8D08-A42F-480E-B74D-5764B102E229}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E6AB7F85-7160-4A06-A6AF-7A845BDED62B}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{333F5E0C-65B8-4430-8E6B-014393E50641}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3630A5D4-5D8A-4717-8F10-9287946862DC}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{AFA614B3-B990-404B-8186-7238F5089A5B}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{710AD3B8-3D9A-4ACA-A0AD-C95665519570}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D88542C7-EBB5-4A03-87BB-DF54B345A295}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{90B244E1-CD1E-483B-AE10-D2E0C1319450}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{F2ABCCBA-9B7C-4C1E-B5C5-A52ACE6475C3}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4C443096-5A0D-4CB6-BD3F-6610BE9905E8}" DTS:Expression="@[User::CacheDirectory] + "\\" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".csv"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{63E3032E-054F-412B-B853-7538BDAAFE3B}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileName">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{940C99E7-EF6F-40B0-982C-9553759C2414}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\"+ @[User::CacheUploadFilesPrefixPattern] + REPLACE( REPLACE( (DT_WSTR, 40) GETDATE(), " ", "-" ), ":", "-" ) + ".cache" " DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheOutput">
<DTS:VariableValue DTS:DataType="8">C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_2016-10-26-11-59-59.213000000.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F81B33AE-4244-4889-BF12-8E6BFB11030F}" DTS:EvaluateAsExpression="True" DTS:Expression="@[System::MachineName] + "_" + @[User::InstanceID] + "_" + @[User::CollectionSetUID] + "_" + (DT_WSTR, 255) @[User::ItemID] + "_upload_copyat_" " DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheUploadFilesPrefixPattern">
<DTS:VariableValue DTS:DataType="8">ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F220B51D-1FFB-4003-9EC0-2285752F310B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D0868A36-C135-49D0-A8F1-13542A84B573}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">640012b7-4ed0-4865-a636-4946d73c425f</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CBF24B5A-C8CF-48E8-9509-D3204867FCC7}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">294605dd-21de-40b2-b20f-f3e170ea1ec3</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F04807FB-804D-4425-81AF-F7CB457826A5}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{888B7540-0785-4F57-A56D-D58BBF911921}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E3526FDC-CCDB-4346-8948-14B54720A63F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EE554175-B0CA-4786-AFB9-D0253F3C39A6}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C0E00118-2CAF-4F3C-9E53-A1E2CE30AB7C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{38EFEA28-38F1-4ED1-8DBC-AAB0E2265EE5}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{39074E00-5D29-4CBF-9105-C3A346061C04}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E15C61FE-2988-4503-8A17-1F01F9D5E2D4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{98D987AA-CF36-4316-933A-05D4B96743E5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CEFF4763-688B-466E-A1E7-E290014294EF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7017ED52-3782-4E8C-9165-776BD4BF407F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7012C6A3-A799-452D-A88F-F82FEBE5B864}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C51017D6-9981-46D1-8375-EBCE6B57EC9C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotID">
<DTS:VariableValue DTS:DataType="3">6</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{82A4097B-17D7-4B24-B70A-D548BA812BC8}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0EA15FE2-50C0-41A8-AD04-B859D38EA993}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\CWM - Delete Old Cache Files" DTS:CreationName="Microsoft.CacheWindowMaintainanceTask" DTS:DelayValidation="True" DTS:Description="Cache Window Maintainance Task" DTS:DTSID="{884A53D3-672D-42BF-A6D4-A96E27430985}" DTS:ExecutableType="Microsoft.CacheWindowMaintainanceTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="CWM - Delete Old Cache Files" DTS:TaskContact="Cache Window Maintainance Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7EDAF031-506D-45CA-A56C-7597EB330B4C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
<DTS:PropertyExpression DTS:Name="CacheFileNamePrefixVarName">"User::CacheUploadFilesPrefixPattern"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<InnerObject>
<CacheFileNamePrefixVarName Type="8" Value="User::CacheUploadFilesPrefixPattern"/>
<CacheWindow Type="3" Value="0"/>
<CollectionSetUID Type="8" Value=""/>
<CollectorTempDir Type="8" Value=""/>
<CollectorTypeUID Type="8" Value=""/>
<ConfigConnectionString Type="8" Value=""/>
<ExitEventName Type="8" Value=""/>
<InstanceName Type="8" Value=""/>
<ItemID Type="3" Value="0"/>
<LoggingLevel Type="3" Value="0"/>
<LoopEventName Type="8" Value=""/>
<MdwConnectionString Type="8" Value=""/>
<TargetConnectionString Type="8" Value=""/>
<TargetServerVersion Type="3" Value="130"/>
<TaskDisplayName Type="8" Value="Cache Window Maintainance Task"/>
</InnerObject>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop Container" DTS:DTSID="{2B763872-7CE3-4CFF-88F9-5A1EDFA05BC8}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For Each Collected Cache File Remaining, Try to Upload">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}" DTS:ObjectName="{EE8E4F57-1623-455B-B0B2-ABCCA165FFB5}">
<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="FileSpec">@[User::CacheUploadFilesPrefixPattern] + "*.cache"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachFileEnumeratorProperties>
<FEFEProperty Folder="C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC"/>
<FEFEProperty FileSpec="ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0_upload_copyat_*.cache"/>
<FEFEProperty FileNameRetrievalType="0"/>
<FEFEProperty Recurse="0"/>
</ForEachFileEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F36AAF41-4971-4431-B175-E6DEE50CE8A6}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileToUpload">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\MACIES4_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F7E27146-0A15-485B-8BD1-9A4327B9CEF6}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("ms", @[System::ContainerStartTime], GETDATE())" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">156220</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{05DBC8DD-D393-4E0E-8A8D-97EC37B1C527}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F5DD1F52-8D07-4E99-8435-35B4ECBBE28A}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A3990693-0E65-44C7-BF35-1AD1F08EDCB0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{03FCCBFD-6016-428F-A0DF-294876A9D2B1}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::RowCountOut] - @[User::RowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="RowCountOutFinal">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{E0D31BC6-173F-4DB9-BBD1-941BFE618005}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Bulk Insert Collected data into MDW" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="1000" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot id" usesDispositions="true">
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]" dataType="dbTimeStamp2" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]" name="collect_time_convert" scale="1" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">(DT_DBTIMESTAMP2,1)#{Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">(DT_DBTIMESTAMP2,1)collection_time</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="Looks up values in a reference dataset by using exact matching." name="LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted" usesDispositions="true" version="6">
-<properties>
<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">SELECT path, performance_counter_id FROM snapshots.performance_counter_instances</property>
<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam">SELECT [path], [performance_counter_id] FROM [snapshots].[performance_counter_instances] WHERE [path] = ?</property>
<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">0</property>
<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">5</property>
<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">5</property>
<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="path" dataType="DT_WSTR" length="2048" precision="0" scale="0" codePage="0"/><referenceColumn name="performance_counter_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>
<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]};</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>
<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>
<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>
<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="Connection manager used to access lookup data." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]" name="Lookup Input">
-<inputColumns>
-<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]">
-<properties>
<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">path</property>
<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>
</properties>
</inputColumn>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
-<outputColumns>
-<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]" name="performance_counter_id" truncationRowDisposition="FailComponent">
-<properties>
<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">performance_counter_id</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Fast upload data to performance_counter_values" usesDispositions="true" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[performance_counter_values]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_second]" cachedDataType="i8" cachedName="raw_value_second" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[raw_value_first]" cachedDataType="i8" cachedName="raw_value_first" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[formatted_value]" cachedDataType="r8" cachedName="formatted_value" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[performance_counter_id]" cachedDataType="i4" cachedName="performance_counter_id" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_instance_id]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output].Columns[performance_counter_id]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].Columns[collect_time_convert]" cachedDataType="dbTimeStamp2" cachedName="collect_time_convert" cachedScale="1" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output].Columns[collect_time_convert]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_instance_id]" dataType="i4" name="performance_counter_instance_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RAW - Read current tempoary storage" validateExternalMetadata="False" version="1">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileToUpload</property>
</properties>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output]" name="Raw File Source Output">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[path]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[path]" name="path"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]" dataType="r8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_type]" dataType="i4" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[object_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[object_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[instance_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[instance_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[instance_name]" name="instance_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].Columns[counter_name]" name="counter_name"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows failed to insert">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows from cache" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of rows inserted" validateExternalMetadata="False">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Derived Column Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Outputs[Derived Column Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Failed Rows]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows failed to insert.Inputs[Row Count Input 1]" name="Failed Rows" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Outputs[OLE DB Destination Error Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Lookup Match Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\DRV - Add snapshot id.Inputs[Derived Column Input]" name="Lookup Match Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Outputs[Lookup Match Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Raw File Source Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Inputs[Row Count Input 1]" name="Raw File Source Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RAW - Read current tempoary storage.Outputs[Raw File Source Output]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Row Count Output 1]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\LKU - Lookup into performance_counter_instances to obtain performance_counter_id for all counter paths that get inserted.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows from cache.Outputs[Row Count Output 1]"/>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW.Paths[Row Count Output 11]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\ODB - Fast upload data to performance_counter_values.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW\RC - Number of rows inserted.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{E24F9238-4DE6-4DFE-97B9-35990020B45A}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Update perf_counters_instances table with newly discovered instances" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" defaultBufferMaxRows="1000" defaultBufferSize="1048576" engineThreads="2" version="1">
-<components>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" localeId="1033" name="ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type)" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[performance_counter_instances]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions"/>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>
</properties>
-<connections>
<connection refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[path]" cachedDataType="wstr" cachedLength="2048" cachedName="path" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[path]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_type]" cachedDataType="i4" cachedName="counter_type" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[object_name]" cachedDataType="wstr" cachedLength="2048" cachedName="object_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[object_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[counter_name]" cachedDataType="wstr" cachedLength="2048" cachedName="counter_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]"/>
<inputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].Columns[instance_name]" cachedDataType="wstr" cachedLength="2048" cachedName="instance_name" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[instance_name]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[performance_counter_id]" dataType="i4" name="performance_counter_id"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." localeId="1033" name="RAW - Read current tempoary storage - purpose - obtain counter paths" validateExternalMetadata="False" version="1">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileToUpload</property>
</properties>
-<outputs>
-<output refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output]" name="Raw File Source Output">
-<outputColumns>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[path]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[path]" name="path"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[formatted_value]" dataType="r8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[formatted_value]" name="formatted_value"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_first]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_first]" name="raw_value_first"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_second]" dataType="i8" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[raw_value_second]" name="raw_value_second"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]" dataType="i4" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_type]" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_type]" name="counter_type"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[object_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[object_name]" name="object_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[instance_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[instance_name]" name="instance_name"/>
<outputColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_name]" length="2048" lineageId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].Columns[counter_name]" name="counter_name"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[path]" dataType="wstr" length="2048" name="path"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[formatted_value]" dataType="r8" name="formatted_value"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_first]" dataType="i8" name="raw_value_first"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[raw_value_second]" dataType="i8" name="raw_value_second"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_type]" dataType="i4" name="counter_type"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[object_name]" dataType="wstr" length="2048" name="object_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[instance_name]" dataType="wstr" length="2048" name="instance_name"/>
<externalMetadataColumn refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output].ExternalColumns[counter_name]" dataType="wstr" length="2048" name="counter_name"/>
</externalMetadataColumns>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances.Paths[Raw File Source Output]" endId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\ODB - Fast upload data to performance_counters_instances for the new instance path-s that we discovered (together with thier type).Inputs[OLE DB Destination Input]" name="Raw File Source Output" startId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances\RAW - Read current tempoary storage - purpose - obtain counter paths.Outputs[Raw File Source Output]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\FST - Cleanup" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{2665570b-6fcf-43a3-b8ba-5f3d5bd99357}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Cleanup" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::CacheFileToUpload" TaskIsSourceVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{CD4E0504-1536-4071-A070-9A7D8A6D7B32}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{2AEF0133-FEA0-472B-B12D-89F60FF1CBCD}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'PerfCountersUpload - Main Upload Loop', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOutFinal" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{17CA7F5E-10A1-41B3-9F5F-FD4CCB15FB8D}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{649D8163-D3B7-4998-A29D-ABDE0EAAEA77}" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\FST - Cleanup"/>
<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For Each Collected Cache File Remaining, Try to Upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{96006738-B053-493C-95AD-64168C63BA4C}" DTS:From="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Update perf_counters_instances table with newly discovered instances" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload\DFT - Bulk Insert Collected data into MDW" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{EF918497-3946-428A-9BF3-D32E69048E5A}" DTS:ObjectName="{EF918497-3946-428A-9BF3-D32E69048E5A}" DTS:ValueIndex="0" DTS:VariableName="User::CacheFileToUpload"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Sequence Container" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{A7035C8A-5219-42B8-BDE6-365F3240D4B2}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Sequence Container">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A0DA22EB-F905-466C-B115-716E3F49FA5D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">PerfCountersLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Sequence Container\FAT - Check Current Cache File Exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{B737D089-54D7-40A4-9F46-A1B8AA87FF57}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:ObjectName="FAT - Check Current Cache File Exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::CacheFileName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">0</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>0</Mode>
<FilePath>C:\DOCUME~1\apred\LOCALS~1\Temp\eKatmai_DC\ALEN-PC_MSSQL.1_640012b7-4ed0-4865-a636-4946d73c425f_0.cache</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Sequence Container\FST - Rename Current Cache File" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{609f9d36-aad4-4395-8b31-0c27b6ffefdd}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Current Cache File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::CacheFileName" TaskIsSourceVariable="True" TaskDestinationPath="User::CacheOutput" TaskIsDestinationVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\Sequence Container.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{B5B398D6-E5AB-4742-ABD1-AD95B984F0AF}" DTS:From="Package\Sequence Container\FAT - Check Current Cache File Exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Sequence Container\FST - Rename Current Cache File"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Create snapshot ID in MDW" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{02641DDC-5CDC-4BD2-8112-1FA7BE3A488C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Create snapshot ID in MDW" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" SQLTask:SqlStatementSource="execute [core].[sp_create_snapshot] @collection_set_uid=? , @collector_type_uid=? , @machine_name=? , @named_instance=? , @log_id=? , @snapshot_id=? OUTPUT ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Register collection set to MDW" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{a3667210-4432-41f0-8d04-d53b10574f52}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Register collection set to MDW" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{68AAF105-9266-4AA6-A164-CD0A512B42D3}" SQLTask:SqlStatementSource="execute [core].[sp_update_data_source] @collection_set_uid=? , @machine_name=? , @named_instance=? , @days_until_expiration=? , @source_id=? OUTPUT ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="2" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{3E8C2FDE-1E6D-4C61-A58B-D114921193FC}" DTS:From="Package\SQL - Register collection set to MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Create snapshot ID in MDW" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{E0BDAD4D-63EC-4C7B-B392-48D799204549}" DTS:From="Package\Sequence Container" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\CWM - Delete Old Cache Files"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{5B5E777C-2E3A-453F-91F2-6E28C7BC6B13}" DTS:From="Package\SQL - Create snapshot ID in MDW" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 4" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{766AFD21-4197-496F-90A8-2C9B25E85D3C}" DTS:From="Package\CWM - Delete Old Cache Files" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\FEF - For Each Collected Cache File Remaining, Try to Upload"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


Package

Package: QueryActivityCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 7/10/2007 4:26:36 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {0B68FC9D-23DC-48F3-A937-90A0A8943D0E}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | QueryActivityCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\QueryActivityCollect
PackagePath | Data Collector\QueryActivityCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 110
VersionComments |
VersionGUID | {317607A1-01CF-47D9-B2F3-98AF8311BC8B}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
LOOP - Query the query statitics DMV at collection frequency | Foreach Loop Container

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheFilePrefixPattern |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotExecRequestQuery |
TargetConnectionString |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="7/10/2007 4:26:36 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{0B68FC9D-23DC-48F3-A937-90A0A8943D0E}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:ObjectName="QueryActivityCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="110" DTS:VersionGUID="{DBB97E2E-B7CC-4206-933B-EE65B90BDF07}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{ACB4A0B0-94FF-473B-BB76-72DFB239DBC6}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{1906A00E-7676-4664-9159-0B790DF483C2}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{4BEFF4AE-6E6A-45EA-9DA2-0CDFFEE962C4}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{465410C0-791E-4D35-8366-A4CD30A3C75C}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1AF8E4B6-CDEA-4CF1-A6CD-BBA7C598217F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B2C54FDF-F78F-4065-8214-54B55A7A245A}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D7651A0A-C75C-4F0C-A5A2-4B51878A0C71}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9AFF7A64-3CE4-4518-B865-7077072A391D}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{54F38A44-3932-4198-8648-B0A244751041}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{39CD184D-90DF-4393-97EC-FABC1183F10C}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8614A7F4-3E3F-4314-9887-C88F2FB0F189}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{86ABBBA3-E60E-4CDF-861A-8476A6707570}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{509D0615-B505-4276-B8BC-7603D3877C04}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{289870D1-804D-45B2-9743-D8786F99F678}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3CB7F214-4B4E-4BF8-842E-BADD0B85E77D}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{71DE2249-F71B-452E-8C93-4652129EBD8B}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E62807FC-8321-4152-9495-11F889D7A544}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{328041A5-FC96-43B1-B07E-16BBFE3C44E0}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1FE8F866-6F84-4A05-88CD-CED5D86D85CF}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C87BA532-AEF2-4EC6-B57A-7F7A9BEF9C61}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0E1AD59F-85FB-4E34-8486-69AF746D75D9}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFilePrefixPattern">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CA75BAEE-7C40-4FA9-9183-6BE94457C296}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2C5BB3B2-7EE6-4359-9E7E-296FC3770D20}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">2DC02BD6-E230-4C05-8516-4E8C0EF21F95</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{83DD0AAF-E215-415D-93DD-B63A01D5C8B0}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">1d24f966-c63c-497c-a6bc-df2369b8ebdf</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{484186DB-81BF-42F2-BF2C-20FFADB17A36}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{474EEC5A-EA57-48C2-B537-05B0164EAB64}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C7FA4E99-F45A-4451-8428-FC8615BC6C14}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{662ECBEC-5F7E-4CBF-A1DE-BDF16646F7C3}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B8ACA1AD-1727-48D0-8B6E-A4D0EB233D64}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2DE6E9FB-CB6C-49DD-9735-5D10F9398F4B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AFA803CE-AB90-4D25-B80E-70DD09511550}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">100</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EBF4D97C-3B7D-4F65-800B-6231ECBE84B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A179515E-5B32-4638-85E7-93CD9BD6C5AE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1C0855D9-136A-4238-A669-4A67D43F74FC}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B8EE89B9-BD07-4CB6-B433-479BE117AD40}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AA7932C5-254A-4801-B462-BD5F0634FAD4}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{DBA8418D-EF68-460C-8038-9C9EC8AB1C69}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0EBF4C04-68F9-4CAA-B279-E0A07EDD3769}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] " + (DT_WSTR,10) (@[User::ItemID])" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SnapshotExecRequestQuery">
<DTS:VariableValue DTS:DataType="8">EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_requests] 100</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{48649ACA-E498-43C0-84A4-06ED1F0FE3FA}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{3728E9CD-A948-47F5-B2A9-26BC486A8CD8}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="LOOP - Query the query statitics DMV at collection frequency">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{7283E196-D60C-438F-A58A-0EA1F41BBCF4}" DTS:ObjectName="{7283E196-D60C-438F-A58A-0EA1F41BBCF4}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6740CB1C-8A65-4578-8BC3-0664C060D59B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DMVErrorRowCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CAE88196-8281-42E5-BC3A-D3447C5C4836}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DMVInOutRowCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{95CCF408-6AAD-4742-B85E-7627D7D72418}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Synchronize Access to Cache File">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4DDEBC48-3AAC-4260-BAFC-4DFEFB97AD05}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">
<DTS:VariableValue DTS:DataType="8">QueryActivityLock</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{CA0ED25A-27F6-4388-8E38-1F26D1A55878}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Collect DMV Data" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0BA11DB3-CA68-4BDF-AD2D-96D43C03584F}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheFilePrefixPattern] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheFileName">
<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::DMVErrorRowCount</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::DMVInOutRowCount</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get snapshot of dm_exec_requests" usesDispositions="true" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">SET NOCOUNT ON
-- Get the collection time as UTC time
DECLARE @collection_time datetime
SET @collection_time = GETDATE()
SELECT
CONVERT(int, ROW_NUMBER() OVER (ORDER BY sess.session_id, ISNULL (req.request_id, -1), ISNULL (tasks.exec_context_id, -1)) ) AS row_id,
-- IDs and Blocking IDs
sess.session_id,
ISNULL (req.request_id, -1) AS request_id,
ISNULL (tasks.exec_context_id, -1) AS exec_context_id,
ISNULL (req.blocking_session_id, 0) AS blocking_session_id,
CONVERT (bit, CASE
WHEN EXISTS (SELECT TOP 1 session_id FROM sys.dm_exec_requests bl WHERE bl.blocking_session_id = req.session_id) THEN 1
ELSE 0
END) AS is_blocking,
ISNULL (waits.blocking_exec_context_id, 0) AS blocking_exec_context_id,
tasks.scheduler_id,
DB_NAME(req.database_id) as database_name,
req.[user_id],
-- State information
LEFT (tasks.task_state, 10) AS task_state,
LEFT (req.status, 15) AS request_status,
LEFT (sess.status, 15) AS session_status,
req.executing_managed_code,
-- Session information
sess.login_time,
sess.is_user_process,
LEFT (ISNULL (sess.[host_name], ''), 20) AS [host_name],
LEFT (ISNULL (sess.[program_name], ''), 50) AS [program_name],
LEFT (ISNULL (sess.login_name, ''), 30) AS login_name,
-- Waits information
LEFT (ISNULL (req.wait_type, ''), 45) AS wait_type,
LEFT (ISNULL (req.last_wait_type, ''), 45) AS last_wait_type,
ISNULL (waits.wait_duration_ms, 0) AS wait_duration_ms,
LEFT (ISNULL (req.wait_resource, ''), 50) AS wait_resource,
LEFT (ISNULL (waits.resource_description, ''), 140) AS resource_description,
-- Transaction information
req.transaction_id,
ISNULL(req.open_transaction_count, 0) AS open_transaction_count,
COALESCE(req.transaction_isolation_level, sess.transaction_isolation_level) AS transaction_isolation_level,
-- Request stats
req.cpu_time AS request_cpu_time,
req.logical_reads AS request_logical_reads,
req.reads AS request_reads,
req.writes AS request_writes,
req.total_elapsed_time AS request_total_elapsed_time,
req.start_time AS request_start_time,
-- Session stats
sess.memory_usage,
sess.cpu_time AS session_cpu_time,
sess.reads AS session_reads,
sess.writes AS session_writes,
sess.logical_reads AS session_logical_reads,
sess.total_scheduled_time AS session_total_scheduled_time,
sess.total_elapsed_time AS session_total_elapsed_time,
sess.last_request_start_time,
sess.last_request_end_time,
req.open_resultset_count AS open_resultsets,
sess.row_count AS session_row_count,
sess.prev_error,
tasks.pending_io_count,
-- Text/Plan handles
ISNULL (req.command, 'AWAITING COMMAND') AS command,
req.plan_handle,
req.sql_handle,
req.statement_start_offset,
req.statement_end_offset,
@collection_time AS collection_time
FROM sys.dm_exec_sessions sess
LEFT OUTER MERGE JOIN sys.dm_exec_requests req ON sess.session_id = req.session_id
LEFT OUTER MERGE JOIN sys.dm_os_tasks tasks ON tasks.session_id = sess.session_id AND tasks.request_id = req.request_id AND tasks.task_address = req.task_address
LEFT OUTER MERGE JOIN sys.dm_os_waiting_tasks waits ON waits.session_id = sess.session_id AND waits.waiting_task_address = req.task_address
WHERE
sess.session_id <> @@SPID
AND
(
(req.session_id IS NOT NULL AND (sess.is_user_process = 1 OR req.status COLLATE Latin1_General_BIN NOT IN ('background', 'sleeping'))) -- active request
OR
(sess.session_id IN (SELECT DISTINCT blocking_session_id FROM sys.dm_exec_requests WHERE blocking_session_id != 0)) -- not active, but head blocker
)
OPTION (FORCE ORDER)</property>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotExecRequestQuery</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[row_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]" name="row_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]" name="session_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]" name="request_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]" name="exec_context_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]" name="blocking_session_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_blocking]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]" name="is_blocking" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[scheduler_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]" name="scheduler_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]" name="database_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[user_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]" name="user_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]" name="task_state" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]" name="request_status" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]" name="session_status" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]" name="executing_managed_code" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]" name="login_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]" dataType="bool" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_user_process]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]" name="is_user_process" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]" name="host_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]" name="program_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]" name="login_name" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]" name="wait_type" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]" name="last_wait_type" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]" name="wait_duration_ms" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]" name="wait_resource" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]" name="resource_description" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]" name="transaction_id" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]" name="open_transaction_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]" dataType="i2" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]" name="request_cpu_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]" name="request_logical_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]" name="request_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]" name="request_writes" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]" name="request_start_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[memory_usage]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]" name="memory_usage" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]" name="session_cpu_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]" name="session_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]" name="session_writes" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]" name="session_logical_reads" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_resultsets]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]" name="open_resultsets" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_row_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]" name="session_row_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[prev_error]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]" name="prev_error" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[pending_io_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]" name="pending_io_count" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[command]" length="32" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]" name="command" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]" name="last_request_start_time" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_end_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]" name="last_request_end_time" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_start_time]" dataType="dbTimeStamp" name="last_request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].ExternalColumns[last_request_end_time]" dataType="dbTimeStamp" name="last_request_end_time"/>
</externalMetadataColumns>
</output>
-<output refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[row_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[row_id]" name="row_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_id]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_id]" name="session_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_id]" name="request_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[exec_context_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[exec_context_id]" name="exec_context_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_session_id]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_session_id]" name="blocking_session_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_blocking]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_blocking]" name="is_blocking"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_exec_context_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[scheduler_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[scheduler_id]" name="scheduler_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[database_name]" dataType="wstr" length="128" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[database_name]" name="database_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[user_id]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[user_id]" name="user_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[task_state]" dataType="wstr" length="10" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[task_state]" name="task_state"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_status]" dataType="wstr" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_status]" name="request_status"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_status]" dataType="wstr" length="15" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_status]" name="session_status"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[executing_managed_code]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[executing_managed_code]" name="executing_managed_code"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_time]" name="login_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_user_process]" dataType="bool" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[is_user_process]" name="is_user_process"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[host_name]" dataType="wstr" length="20" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[host_name]" name="host_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[program_name]" dataType="wstr" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[program_name]" name="program_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_name]" dataType="wstr" length="30" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[login_name]" name="login_name"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_type]" dataType="wstr" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_type]" name="wait_type"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_wait_type]" dataType="wstr" length="45" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_wait_type]" name="last_wait_type"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_duration_ms]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_resource]" dataType="wstr" length="50" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[wait_resource]" name="wait_resource"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[resource_description]" dataType="wstr" length="140" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[resource_description]" name="resource_description"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_id]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_id]" name="transaction_id"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_transaction_count]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_transaction_count]" name="open_transaction_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_isolation_level]" dataType="i2" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_cpu_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_cpu_time]" name="request_cpu_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_logical_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_logical_reads]" name="request_logical_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_reads]" name="request_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_writes]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_writes]" name="request_writes"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_total_elapsed_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_start_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[request_start_time]" name="request_start_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[memory_usage]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[memory_usage]" name="memory_usage"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_cpu_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_cpu_time]" name="session_cpu_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_reads]" name="session_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_writes]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_writes]" name="session_writes"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_logical_reads]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_logical_reads]" name="session_logical_reads"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_scheduled_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_elapsed_time]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_start_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_start_time]" name="last_request_start_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_end_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[last_request_end_time]" name="last_request_end_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_resultsets]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[open_resultsets]" name="open_resultsets"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_row_count]" dataType="i8" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[session_row_count]" name="session_row_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[prev_error]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[prev_error]" name="prev_error"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[pending_io_count]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[pending_io_count]" name="pending_io_count"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[command]" dataType="wstr" length="32" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[command]" name="command"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>
<outputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write data to a cache" validateExternalMetadata="False" version="2">
-<properties>
<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>
<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>
<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CacheFileName</property>
<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">2</property>
</properties>
-<inputs>
-<input refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">
-<inputColumns>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[collection_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[sql_handle]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[sql_handle]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[plan_handle]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[plan_handle]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[row_id]" cachedDataType="i4" cachedName="row_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[row_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[row_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_id]" cachedDataType="i2" cachedName="session_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_id]" cachedDataType="i4" cachedName="request_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[exec_context_id]" cachedDataType="i4" cachedName="exec_context_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[exec_context_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_session_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_session_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_blocking]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_blocking]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[blocking_exec_context_id]" cachedDataType="i4" cachedName="blocking_exec_context_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_exec_context_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[blocking_exec_context_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[scheduler_id]" cachedDataType="i4" cachedName="scheduler_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[scheduler_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[scheduler_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[database_name]" cachedDataType="wstr" cachedLength="128" cachedName="database_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[database_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[database_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[user_id]" cachedDataType="i4" cachedName="user_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[user_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[user_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[task_state]" cachedDataType="wstr" cachedLength="10" cachedName="task_state" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[task_state]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[task_state]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_status]" cachedDataType="wstr" cachedLength="15" cachedName="request_status" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_status]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_status]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_status]" cachedDataType="wstr" cachedLength="15" cachedName="session_status" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_status]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_status]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[executing_managed_code]" cachedDataType="bool" cachedName="executing_managed_code" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[executing_managed_code]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[executing_managed_code]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_time]" cachedDataType="dbTimeStamp" cachedName="login_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[is_user_process]" cachedDataType="bool" cachedName="is_user_process" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_user_process]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[is_user_process]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[host_name]" cachedDataType="wstr" cachedLength="20" cachedName="host_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[host_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[host_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[program_name]" cachedDataType="wstr" cachedLength="50" cachedName="program_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[program_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[program_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[login_name]" cachedDataType="wstr" cachedLength="30" cachedName="login_name" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_name]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[login_name]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="wait_type" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_type]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_type]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="last_wait_type" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[last_wait_type]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_wait_type]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_duration_ms]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_duration_ms]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[wait_resource]" cachedDataType="wstr" cachedLength="50" cachedName="wait_resource" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_resource]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[wait_resource]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[resource_description]" cachedDataType="wstr" cachedLength="140" cachedName="resource_description" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[resource_description]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[resource_description]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_id]" cachedDataType="i8" cachedName="transaction_id" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_id]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_id]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_transaction_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_transaction_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[transaction_isolation_level]" cachedDataType="i2" cachedName="transaction_isolation_level" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_isolation_level]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[transaction_isolation_level]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_cpu_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_logical_reads]" cachedDataType="i8" cachedName="request_logical_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_logical_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_reads]" cachedDataType="i8" cachedName="request_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_writes]" cachedDataType="i8" cachedName="request_writes" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_writes]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_total_elapsed_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[request_start_time]" cachedDataType="dbTimeStamp" cachedName="request_start_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[request_start_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[memory_usage]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[memory_usage]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_cpu_time]" cachedDataType="i4" cachedName="session_cpu_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_cpu_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_cpu_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_reads]" cachedDataType="i8" cachedName="session_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_writes]" cachedDataType="i8" cachedName="session_writes" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_writes]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_writes]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_logical_reads]" cachedDataType="i8" cachedName="session_logical_reads" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_logical_reads]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_logical_reads]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_scheduled_time]" cachedDataType="i4" cachedName="session_total_scheduled_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_scheduled_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_scheduled_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_total_elapsed_time]" cachedDataType="i4" cachedName="session_total_elapsed_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_elapsed_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_total_elapsed_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_start_time]" cachedDataType="dbTimeStamp" cachedName="last_request_start_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_start_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_start_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[last_request_end_time]" cachedDataType="dbTimeStamp" cachedName="last_request_end_time" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_end_time]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[last_request_end_time]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[open_resultsets]" cachedDataType="i4" cachedName="open_resultsets" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_resultsets]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[open_resultsets]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_row_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[session_row_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[prev_error]" cachedDataType="i4" cachedName="prev_error" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[prev_error]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[prev_error]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[pending_io_count]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[pending_io_count]"/>
<inputColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].Columns[command]" cachedDataType="wstr" cachedLength="32" cachedName="command" externalMetadataColumnId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[command]" lineageId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output].Columns[command]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[row_id]" dataType="i4" name="row_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_id]" dataType="i2" name="session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_id]" dataType="i4" name="request_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[user_id]" dataType="i4" name="user_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>
<externalMetadataColumn refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>
</externalMetadataColumns>
</input>
</inputs>
</component>
</components>
-<paths>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[OLE DB Source Error Output]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Error row count.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[OLE DB Source Output]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\ODS - Get snapshot of dm_exec_requests.Outputs[OLE DB Source Output]"/>
<path refId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data.Paths[Row Count Output 1]" endId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\RFD - Write data to a cache.Inputs[Raw File Destination Input]" name="Row Count Output 1" startId="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File\DFT - Collect DMV Data\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{F9DBCB6D-CA5E-49E5-8C4D-5AD6A9EEBBBF}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onpackageupdate]( ? )}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{85357745-D02F-4BB7-ABBC-28E41047CD03}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{EB751A21-60C6-4BD9-AF00-8F743F8FA2FD}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'active_sessions_and_request collection', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::DMVInOutRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::DMVInOutRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DMVErrorRowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{047084C2-63B9-4720-8815-1F2E55687ED8}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\LOOP - Query the query statitics DMV at collection frequency\SEQ - Synchronize Access to Cache File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\LOOP - Query the query statitics DMV at collection frequency.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{CAC2C69F-AA7D-4F74-902D-96E5F8052C76}" DTS:From="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\LOOP - Query the query statitics DMV at collection frequency\SQL - Log Package Iteration" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{ECAA643C-0A8B-446A-B97F-56D6E682773B}" DTS:ObjectName="{ECAA643C-0A8B-446A-B97F-56D6E682773B}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
</DTS:Executables>
</DTS:Executable>


Package

Package: QueryActivityUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 7/10/2007 4:27:11 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {833DB628-8E19-47A3-92C5-FB1779B52E76}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.200.2131
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | QueryActivityUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\QueryActivityUpload
PackagePath | Data Collector\QueryActivityUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 347
VersionComments |
VersionGUID | {A6F7BA9C-B80D-4942-9733-2CC3AC1D1111}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
ConfigConnection2 |
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
CWM - Remove Upload Snapshots Older Than CacheWindow | Cache Window Maintainance Task
FAT - Check Cache File Exists | File Access Task
FEF - For each collected cache file try upload | Foreach Loop Container
SEQ - Capture and analyze query statistics and query plan and text | Sequence Container
SEQ - Rename Collection Cache File | Sequence Container
SQL - Get SnapshotId | Execute SQL Task
SQL - Get SourceId | Execute SQL Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 12 |
Constraint 3 |
Constraint 6 |
Constraint 7 |
Constraint 8 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionCacheFileName | Stores snapshots of dm_exec_requests
CollectionCacheFileNameOutput | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload.
CollectionCacheFilePrefixPattern | Prefix for files related to dm_exec_requets collection
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
InterestingQueries_HighCpuUsage |
InterestingQueries_HighIoCount |
InterestingQueries_HighMemoryUsage |
InterestingQueries_HighTransactionCount |
InterestingQueries_LargeResultset |
InterestingQueries_LongRunningRequest |
InterestingQueries_LongWaitingRequest |
InterestingQueriesCount |
InterestingQueriesLastSnapshotFileName | Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package.
InterestingQueriesLastSnapshotFileNameOutput | Stores temporary copy of the most recent snapshot of dm_exec_query_stats
InterestingQueriesSnapshotFileNamePrefixPattern | Prefix for files related to dm_exec_query_stats collection.
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
SnapshotId |
SnapshotQueryStatsQuery |
SourceId |
TargetConnectionString |
TopThreshold |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package element

Package element: CollectionCacheFileNameOutput

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description | Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload.
EvaluateAsExpression | True
Expression | @[User::CollectionCacheFilePrefixPattern] + @[System::ExecutionInstanceGUID] + ".temp.cache"
IncludeInDebugDump | False
Name | CollectionCacheFileNameOutput
Namespace | User
QualifiedName | User::CollectionCacheFileNameOutput
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity{5C30354C-706B-4266-A6E6-77A3E8AE2ABA}.temp.cache
VariablePath | \Package.Variables[User::CollectionCacheFileNameOutput]


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="7/10/2007 4:27:11 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DelayValidation="True" DTS:DTSID="{833DB628-8E19-47A3-92C5-FB1779B52E76}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:ObjectName="QueryActivityUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="347" DTS:VersionGUID="{977E775D-A106-4C0E-AC49-00FFEE703631}">

<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>

-<DTS:ConnectionManagers>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{39FB064F-9853-4718-880F-C97853E29875}" DTS:ObjectName="ConfigConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection2]" DTS:CreationName="OLEDB" DTS:DTSID="{92804B88-CB2F-4FEE-8EFF-64901F67CBBB}" DTS:ObjectName="ConfigConnection2">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" DTS:ObjectName="MdwConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{15DDC5A3-5645-4BAA-BCC8-B0AF18FDE25D}" DTS:ObjectName="TargetConnection">

<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>

-<DTS:ObjectData>

<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=master;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>

</DTS:ObjectData>

</DTS:ConnectionManager>

</DTS:ConnectionManagers>

-<DTS:Configurations>

<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C47DA731-2DE9-4003-BEEA-DC9FEC0CB4FF}" DTS:ObjectName="CacheDirectory"/>

<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{95F90B41-195A-485B-83A7-532CBE784B9B}" DTS:ObjectName="CacheWindow"/>

<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E2ABAEA8-8EDF-467A-8868-02D9DA214213}" DTS:ObjectName="InputParameters"/>

<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DE58D9D-88EC-4EF1-BC5D-198E4A4D242B}" DTS:ObjectName="MDWConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C0D122E4-3E93-4B7D-9D73-BD30523C5E1E}" DTS:ObjectName="ConfigConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EAF8B0C8-D595-4C33-996B-05EC441AD7F3}" DTS:ObjectName="TargetConnectionString"/>

<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1F3E0B39-EFD8-46CB-A717-293C31799271}" DTS:ObjectName="LoopEventName"/>

<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9A80FE73-FF5C-4E2C-AD8D-33F22D356AC2}" DTS:ObjectName="ExitEventName"/>

<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1371FF37-F2B5-4FDE-B5A5-536068DF92FA}" DTS:ObjectName="CollectorTypeUID"/>

<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{82ABCEE4-E26E-4CD2-B58D-6C06867D0721}" DTS:ObjectName="CollectionSetUID"/>

<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{33F8AB16-E8C2-4E91-BD5B-8069298F752D}" DTS:ObjectName="ItemID"/>

<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C93D74BA-06D2-4D87-A4EA-D77FB294581B}" DTS:ObjectName="InstanceID"/>

<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{42BF5414-6ED3-4173-A1AE-AF65B489397D}" DTS:ObjectName="InstanceName"/>

<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{A1115DE1-DAC0-4E1D-9D41-B711F105082D}" DTS:ObjectName="LoggingLevel"/>

<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1F89599A-D740-49C6-86F3-81E31F2AC5DB}" DTS:ObjectName="LogID"/>

<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{9C690C28-5612-417C-B1A7-885E173AAA83}" DTS:ObjectName="ParentLogID"/>

<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{1D6E40B7-426D-48E8-9BEB-A21586CBDE14}" DTS:ObjectName="DaysUntilExpiration"/>

</DTS:Configurations>

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{07E49628-99E0-4460-9F0B-DBE28805907D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">

<DTS:VariableValue DTS:DataType="8">c:\perflogs</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3F3D955A-0F9A-416E-A515-1204CE48AEDD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">

<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores snapshots of dm_exec_requests" DTS:DTSID="{4C986A4F-170A-45A1-839E-410F1E8E93F4}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + ".cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFileName">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores snpashots of dm_exec_requests. This variable is used as temporary cached file name during the upload." DTS:DTSID="{750F2248-3251-4890-B913-1F4B810089AE}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + @[System::ExecutionInstanceGUID] + ".temp.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFileNameOutput">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity{5C30354C-706B-4266-A6E6-77A3E8AE2ABA}.temp.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Prefix for files related to dm_exec_requets collection" DTS:DTSID="{DA251B8D-03B0-45AC-AF6F-3207856FB975}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\" + @[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionCacheFilePrefixPattern">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF62F5F8-BEC3-4343-B835-E4DF248FF89B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">

<DTS:VariableValue DTS:DataType="8">2DC02BD6-E230-4C05-8516-4E8C0EF21F95</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{71ED53D3-47FE-4D9F-92A6-11ABBB977C9F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">

<DTS:VariableValue DTS:DataType="8">14AF3C12-38E6-4155-BD29-F33E7966BA23</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B70DF8DA-1D12-4C98-95AA-DF577D4F2161}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{81C400C8-74B8-428F-91D1-BBEDADDE50DF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">

<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CCFA1ABE-72CA-4887-BE94-31B97C475499}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">

<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0C4F2FE7-49AF-457C-BE70-748867279428}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">

<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C7CAE80E-91B3-4C58-B895-79F074CCC337}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">

<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9EB9C248-6B73-4C6A-9028-6804497A8990}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">

<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F0B8F428-BF6B-4162-89E6-8648343D10B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesCount">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores the most recent copy of snapshot of dm_exec_query_stats saved from the previous execution of this package." DTS:DTSID="{1855D9D6-5694-4820-B3B6-5B4A1A53A4E1}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesLastSnapshotFileName">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Stores temporary copy of the most recent snapshot of dm_exec_query_stats" DTS:DTSID="{6AB778DB-F067-45EA-998D-AFF5F92365E4}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::InterestingQueriesSnapshotFileNamePrefixPattern] + "LastSnapshot.temp.cache"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesLastSnapshotFileNameOutput">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.temp.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:Description="Prefix for files related to dm_exec_query_stats collection." DTS:DTSID="{8318285A-D945-48DB-B745-C7F6F566BCEC}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CollectionCacheFilePrefixPattern] + "_QueryStats_"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesSnapshotFileNamePrefixPattern">

<DTS:VariableValue DTS:DataType="8">c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{77178EEF-9088-493F-81B0-222FAFC2DCB5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighCpuUsage">

<DTS:VariableValue DTS:DataType="3">5000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{688988F2-B8CD-4016-B862-72BF28A26C66}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighIoCount">

<DTS:VariableValue DTS:DataType="3">500</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F829A6C7-E1D0-4F5A-BC99-256D75480092}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighMemoryUsage">

<DTS:VariableValue DTS:DataType="3">12800</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9591E8A2-8342-4345-A44D-11378CC0E352}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_HighTransactionCount">

<DTS:VariableValue DTS:DataType="3">8</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1A974E9C-D435-495B-860C-8C4444C3E213}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LargeResultset">

<DTS:VariableValue DTS:DataType="3">1000000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E8AEB8A7-2C49-4224-9DE9-68BBD915B8BE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LongRunningRequest">

<DTS:VariableValue DTS:DataType="3">25000</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{45912C54-0480-417E-B67A-82873FC3E423}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueries_LongWaitingRequest">

<DTS:VariableValue DTS:DataType="3">500</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E704315E-7219-4865-99F2-E97AC9D8D398}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">

<DTS:VariableValue DTS:DataType="3">100</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{33312621-3000-41AE-BB85-EB7315DC928C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">

<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{96B03221-F068-41EE-8ED3-783D0F66E06E}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1301DE1B-D5A1-44AA-BAC3-F172053B6B29}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D734BFC1-B87B-4283-89D6-45DBBAC19429}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">

<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8E74FC82-9E1D-4234-9CC3-1A597FB89FD2}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1E505F14-3F9D-407E-B462-601B20F27EDE}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">

<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{16ED5012-857B-45A9-BF91-C14B440732F1}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotId">

<DTS:VariableValue DTS:DataType="3">200</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{772BB2B0-4FE9-4DF6-8A8E-52ED84133F83}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] " + (DT_WSTR,10) (@[User::ItemID])" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SnapshotQueryStatsQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [msdb].[dbo].[sp_syscollector_snapshot_dm_exec_query_stats] 100</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{146FDF3A-DC44-41E8-B463-C373ADEA494D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceId">

<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{93174E52-58FA-4C6B-9BC1-A7190ABE976D}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">

<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Initial Catalog=master;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{255AA40E-7F7B-4462-97A5-1DC4A84A7475}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TopThreshold">

<DTS:VariableValue DTS:DataType="3">5</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">

<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>

-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">

<DTS:Property DTS:Name="Computer">-1</DTS:Property>

<DTS:Property DTS:Name="Operator">-1</DTS:Property>

<DTS:Property DTS:Name="SourceName">-1</DTS:Property>

<DTS:Property DTS:Name="SourceID">-1</DTS:Property>

<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>

<DTS:Property DTS:Name="MessageText">-1</DTS:Property>

<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>

</DTS:Property>

-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">

<DTS:Property DTS:Name="Computer">-1</DTS:Property>

<DTS:Property DTS:Name="Operator">-1</DTS:Property>

<DTS:Property DTS:Name="SourceName">-1</DTS:Property>

<DTS:Property DTS:Name="SourceID">-1</DTS:Property>

<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>

<DTS:Property DTS:Name="MessageText">-1</DTS:Property>

<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>

</DTS:Property>

</DTS:LoggingOptions>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:CreationName="Microsoft.CacheWindowMaintainanceTask" DTS:Description="Cache Window Maintainance Task" DTS:DTSID="{C8B1E699-7A73-4ECD-A317-B9E91002738D}" DTS:ExecutableType="Microsoft.CacheWindowMaintainanceTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:TaskContact="Cache Window Maintainance Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

<DTS:PropertyExpression DTS:Name="CacheFileNamePrefixVarName">"User::InterestingQueriesSnapshotFileNamePrefixPattern"</DTS:PropertyExpression>

-<DTS:ObjectData>

-<InnerObject>

<CacheFileNamePrefixVarName Type="8" Value="User::InterestingQueriesSnapshotFileNamePrefixPattern"/>

<CacheWindow Type="3" Value="0"/>

<CollectionSetUID Type="8" Value=""/>

<CollectorTempDir Type="8" Value=""/>

<CollectorTypeUID Type="8" Value=""/>

<ConfigConnectionString Type="8" Value=""/>

<ExitEventName Type="8" Value=""/>

<InstanceName Type="8" Value=""/>

<ItemID Type="3" Value="0"/>

<LoggingLevel Type="3" Value="0"/>

<LoopEventName Type="8" Value=""/>

<MdwConnectionString Type="8" Value=""/>

<TargetConnectionString Type="8" Value=""/>

<TargetServerVersion Type="3" Value="130"/>

<TaskDisplayName Type="8" Value="Cache Window Maintainance Task"/>

</InnerObject>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FAT - Check Cache File Exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{94132A74-FB8C-4E52-B247-D2B4FCD589D9}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:ObjectName="FAT - Check Cache File Exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:PropertyExpression DTS:Name="FilePath">@[User::CollectionCacheFileName]</DTS:PropertyExpression>

<DTS:PropertyExpression DTS:Name="Mode">0</DTS:PropertyExpression>

-<DTS:ObjectData>

-<FileAccessTask>

<Mode>0</Mode>

<FilePath>c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity.cache</FilePath>

</FileAccessTask>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{91A4B7F7-385C-47C2-AA89-08B832F71599}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For each collected cache file try upload">

-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{BB52AFAE-60A1-42A7-9C13-52B21293D219}" DTS:ObjectName="{BB52AFAE-60A1-42A7-9C13-52B21293D219}">

<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>

<DTS:PropertyExpression DTS:Name="FileSpec">@[System::MachineName] + "_" + @[User::InstanceID] + "_{" + @[User::CollectionSetUID] + "}_" + (DT_WSTR, 10) @[User::ItemID] + "_QueryActivity*.temp.cache"</DTS:PropertyExpression>

-<DTS:ObjectData>

-<ForEachFileEnumeratorProperties>

<FEFEProperty Folder="c:\perflogs"/>

<FEFEProperty FileSpec="ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity*.temp.cache"/>

<FEFEProperty FileNameRetrievalType="0"/>

<FEFEProperty Recurse="0"/>

</ForEachFileEnumeratorProperties>

</DTS:ObjectData>

</DTS:ForEachEnumerator>

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{4B66AE21-EAF9-462C-BFA2-FF90EBE034BE}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CurrentCollectionCacheFileName">

<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodePerfWH\MACIES4_MSSQL.1_{{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}}_100_QueryActivity.cache</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AD000A5D-D997-4362-A5CB-23DE5C023D17}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCount">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{FE775FB9-E8B7-4171-9DFB-544E7CCA7809}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload collection snapshot" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id column" usesDispositions="true">

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODS - Upload snapshots into active_sessions_and_requests table" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[active_sessions_and_requests]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>

</properties>

-<connections>

<connection refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[row_id]" cachedDataType="i4" cachedName="row_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[row_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_id]" cachedDataType="i2" cachedName="session_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_id]" cachedDataType="i4" cachedName="request_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[exec_context_id]" cachedDataType="i4" cachedName="exec_context_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_blocking]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[blocking_exec_context_id]" cachedDataType="i4" cachedName="blocking_exec_context_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[scheduler_id]" cachedDataType="i4" cachedName="scheduler_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[scheduler_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[database_name]" cachedDataType="wstr" cachedLength="128" cachedName="database_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[database_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[user_id]" cachedDataType="i4" cachedName="user_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[user_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[task_state]" cachedDataType="wstr" cachedLength="10" cachedName="task_state" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[task_state]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_status]" cachedDataType="wstr" cachedLength="15" cachedName="request_status" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_status]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_status]" cachedDataType="wstr" cachedLength="15" cachedName="session_status" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_status]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[executing_managed_code]" cachedDataType="bool" cachedName="executing_managed_code" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[executing_managed_code]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_time]" cachedDataType="dbTimeStamp" cachedName="login_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[is_user_process]" cachedDataType="bool" cachedName="is_user_process" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_user_process]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[host_name]" cachedDataType="wstr" cachedLength="20" cachedName="host_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[host_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[program_name]" cachedDataType="wstr" cachedLength="50" cachedName="program_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[program_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[login_name]" cachedDataType="wstr" cachedLength="30" cachedName="login_name" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_name]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="wait_type" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_type]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[last_wait_type]" cachedDataType="wstr" cachedLength="45" cachedName="last_wait_type" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[last_wait_type]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_duration_ms]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[wait_resource]" cachedDataType="wstr" cachedLength="50" cachedName="wait_resource" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_resource]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[resource_description]" cachedDataType="wstr" cachedLength="140" cachedName="resource_description" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[resource_description]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_id]" cachedDataType="i8" cachedName="transaction_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_transaction_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[transaction_isolation_level]" cachedDataType="i2" cachedName="transaction_isolation_level" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_isolation_level]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_logical_reads]" cachedDataType="i8" cachedName="request_logical_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_reads]" cachedDataType="i8" cachedName="request_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_writes]" cachedDataType="i8" cachedName="request_writes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[request_start_time]" cachedDataType="dbTimeStamp" cachedName="request_start_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[memory_usage]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_cpu_time]" cachedDataType="i4" cachedName="session_cpu_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_reads]" cachedDataType="i8" cachedName="session_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_writes]" cachedDataType="i8" cachedName="session_writes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_logical_reads]" cachedDataType="i8" cachedName="session_logical_reads" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_scheduled_time]" cachedDataType="i4" cachedName="session_total_scheduled_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_scheduled_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_total_elapsed_time]" cachedDataType="i4" cachedName="session_total_elapsed_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_start_time]" cachedDataType="dbTimeStamp" cachedName="session_last_request_start_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_last_request_end_time]" cachedDataType="dbTimeStamp" cachedName="session_last_request_end_time" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_end_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[open_resultsets]" cachedDataType="i4" cachedName="open_resultsets" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_resultsets]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_row_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[prev_error]" cachedDataType="i4" cachedName="prev_error" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[prev_error]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[pending_io_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[command]" cachedDataType="wstr" cachedLength="32" cachedName="command" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[command]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]"/>

<inputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output].Columns[snapshot_id]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_time]" dataType="dbTimeStampOffset" name="login_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[request_start_time]" dataType="dbTimeStampOffset" name="request_start_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStampOffset" name="session_last_request_start_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStampOffset" name="session_last_request_end_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Count output rows">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCount</property>

</properties>

-<inputs>

-<input refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read Current Upload Data" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CurrentCollectionCacheFileName</property>

</properties>

-<outputs>

-<output refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output]" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[row_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[row_id]" name="row_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_id]" name="session_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_id]" name="request_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[exec_context_id]" name="exec_context_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_session_id]" name="blocking_session_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_blocking]" name="is_blocking"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[scheduler_id]" name="scheduler_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[database_name]" name="database_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[user_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[user_id]" name="user_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[task_state]" name="task_state"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_status]" name="request_status"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_status]" name="session_status"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[executing_managed_code]" name="executing_managed_code"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_time]" name="login_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]" dataType="bool" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[is_user_process]" name="is_user_process"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[host_name]" name="host_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[program_name]" name="program_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[login_name]" name="login_name"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_type]" name="wait_type"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[last_wait_type]" name="last_wait_type"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[wait_resource]" name="wait_resource"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[resource_description]" name="resource_description"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_id]" name="transaction_id"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_transaction_count]" name="open_transaction_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" dataType="i2" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_cpu_time]" name="request_cpu_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_logical_reads]" name="request_logical_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_reads]" name="request_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_writes]" name="request_writes"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[request_start_time]" name="request_start_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[memory_usage]" name="memory_usage"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_cpu_time]" name="session_cpu_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_reads]" name="session_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_writes]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_writes]" name="session_writes"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_logical_reads]" name="session_logical_reads"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" name="session_last_request_start_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" name="session_last_request_end_time"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[open_resultsets]" name="open_resultsets"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]" dataType="i8" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[session_row_count]" name="session_row_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[prev_error]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[prev_error]" name="prev_error"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]" dataType="i4" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[pending_io_count]" name="pending_io_count"/>

<outputColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]" dataType="wstr" externalMetadataColumnId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[command]" length="32" lineageId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].Columns[command]" name="command"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Derived Column Output]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\ODS - Upload snapshots into active_sessions_and_requests table.Inputs[OLE DB Destination Input]" name="Derived Column Output" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Outputs[Derived Column Output]"/>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Raw File Source Output]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Inputs[Row Count Input 1]" name="Raw File Source Output" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RFS - Read Current Upload Data.Outputs[Raw File Source Output]"/>

<path refId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot.Paths[Row Count Output 1]" endId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\DRV - Add snapshot_id column.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot\RC - Count output rows.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\FST - Delete uploaded cache file" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{F370098D-B959-45DB-8581-AC43E7A4A5EA}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Delete uploaded cache file" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::CurrentCollectionCacheFileName" TaskIsSourceVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{CCDA711D-7E0F-481E-A1FE-AA1AEC068E6C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{call dbo.sp_syscollector_event_onpackageupdate (?)}">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\FEF - For each collected cache file try upload\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{DCB25C00-0DCE-4376-9794-23A25E011403}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2015; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'active_sessions_and_requests upload', ?, ?, NULL, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCount" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{4AAAB275-D665-406D-876D-23789851D864}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{FC05D77F-6096-43D9-A97D-6DD93198E115}" DTS:From="Package\FEF - For each collected cache file try upload\SQL - Log Package Iteration" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\FEF - For each collected cache file try upload\SQL - Log Package Stats" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\FEF - For each collected cache file try upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{ABD0C1A0-A52B-4AB3-BD5A-6CF3F23AD1EA}" DTS:From="Package\FEF - For each collected cache file try upload\DFT - Upload collection snapshot" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\FEF - For each collected cache file try upload\FST - Delete uploaded cache file"/>

</DTS:PrecedenceConstraints>

-<DTS:ForEachVariableMappings>

<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{81C3FFAC-C46B-4201-8CDA-7A558C8721AE}" DTS:ObjectName="{81C3FFAC-C46B-4201-8CDA-7A558C8721AE}" DTS:ValueIndex="0" DTS:VariableName="User::CurrentCollectionCacheFileName"/>

</DTS:ForEachVariableMappings>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{5D4817CD-0B0D-4F38-9BD7-6D5FEE0A1D6C}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Capture and analyze query statistics and query plan and text">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8D1D47FB-6B2A-46A6-A2B1-E2CB4B3DDA9D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8454FCD8-DA75-459B-A56E-8F51D1BC796B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="InterestingQueriesRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{453C58A2-8847-4201-B90D-2AEF5FCB05CB}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C6251F49-EA70-40BE-AAC2-6A4908D1B460}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{867071FA-A5D7-4D5D-BC84-3C2FEB1C296B}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::SqlPlanRowCountIn] - @[User::SqlPlanRowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SqlPlanRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B73F494D-448D-4506-B872-AB814D29CF07}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8669D2FC-EAF4-4517-B700-3482BE6C3351}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{87585C9C-52B3-4595-8FB9-3F0F5423D5E0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlPlanUpdateRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{602B7F33-1865-4742-A02A-5DD42320E93E}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{059BA908-AB13-4165-BAFA-22436434FEF0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5F8CFCF6-0B44-41F1-9B17-6C426AB5C38C}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::SqlTextRowCountIn] - @[User::SqlTextRowCountError]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SqlTextRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{399341DC-5D14-48B8-83E2-5F73FEEB5A49}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountError">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2AE94340-6F9F-44F9-A0CB-965A6C23E8B9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountIn">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{54D9A666-FDE3-4E3B-AA17-B21F9BDCDB38}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SqlTextUpdateRowCountOut">

<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{1D99392A-5650-4BDC-9ACB-7CF7D8E1CEF7}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Create Interesting Queries Last Snapshot" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DC - Add the SnapshotId Column" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="OLE DB Source" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotQueryStatsQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output]" isSorted="true" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]" name="creation_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]" name="last_execution_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]" name="execution_count" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]" name="total_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]" name="min_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]" name="max_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]" name="total_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]" name="min_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]" name="max_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]" name="total_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]" name="min_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]" name="max_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]" name="total_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]" name="min_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]" name="max_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]" name="total_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]" name="min_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]" name="max_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" name="total_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" name="min_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" name="max_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count from dm_exec_query_stats">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Write Last Snapshot" version="2">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileName</property>

<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">0</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output].Columns[collection_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[Derived Column Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RFD - Write Last Snapshot.Inputs[Raw File Destination Input]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\OLE DB Source.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\DC - Add the SnapshotId Column.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{7CC524DD-0334-41D0-8E7C-A6AA943F156C}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Create Interesting Queries Upload Batch" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B6625EA4-05D1-4892-9AA7-631D7865E6EC}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [sql_handle], [plan_handle], [statement_start_offset], [statement_end_offset], [creation_time] FROM [snapshots].[fn_get_notable_query_plans](" + (DT_WSTR, 10) @[User::SourceId] + ")"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="NotableQueryPlan">

<DTS:VariableValue DTS:DataType="8">SELECT [sql_handle],

[plan_handle],

[statement_start_offset],

[statement_end_offset],

[creation_time]

FROM [snapshots].[fn_get_notable_query_plans](1)</DTS:VariableValue>

</DTS:Variable>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6528EF32-60E9-4771-AEDD-60FD8B2F0559}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [sql_handle] FROM [snapshots].[fn_get_notable_query_text](" + (DT_WSTR, 10) @[User::SourceId] + ")"" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="NotableQueryText">

<DTS:VariableValue DTS:DataType="8">SELECT [sql_handle]

FROM [snapshots].[fn_get_notable_query_text](1)</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" localeId="1033" name="DRC - Add SnapshotId column to current snapshot" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRC - Calculate delta value between last snapshot and current snapshot for every metric" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_worker_time]" cachedDataType="i8" cachedName="old_total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_physical_reads]" cachedDataType="i8" cachedName="old_total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_writes]" cachedDataType="i8" cachedName="old_total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_logical_reads]" cachedDataType="i8" cachedName="old_total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_clr_time]" cachedDataType="i8" cachedName="old_total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_total_elapsed_time]" cachedDataType="i8" cachedName="old_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input].Columns[old_execution_count]" cachedDataType="i8" cachedName="old_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]" name="snapshot_worker_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_worker_time) ? total_worker_time : total_worker_time - old_total_worker_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]" name="snapshot_physical_reads" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_physical_reads) ? total_physical_reads : total_physical_reads - old_total_physical_reads</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]" name="snapshot_logical_reads" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_logical_reads) ? total_logical_reads : total_logical_reads - old_total_logical_reads</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]" name="snapshot_logical_writes" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_logical_writes) ? total_logical_writes : total_logical_writes - old_total_logical_writes</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]" name="snapshot_clr_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_clr_time) ? total_clr_time : total_clr_time - old_total_clr_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]" name="snapshot_elapsed_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_total_elapsed_time) ? total_elapsed_time : total_elapsed_time - old_total_elapsed_time</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]" name="snapshot_execution_count" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]}) ? #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]} : #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]} - #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]}</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(old_execution_count) ? execution_count : execution_count - old_execution_count</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add plan_generation_num column" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">(DT_I8)1</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">(DT_I8)1</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]" name="creation_time" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[GETDATE]()</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">GETDATE()</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1)" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add source_id (1)" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SourceId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SourceId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2)" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add source_id (2)" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SourceId]</property>

<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SourceId]</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - split current snapshot">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 3]" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 4]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 4" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - Split interesting queries">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 3]" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 1]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - split last snapshot">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLTCST - Split to upload sql_handle and plan_handle">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]" name="Multicast Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 4]" deleteOutputOnPathDetached="true" name="Multicast Output 4" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 1]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries" componentClassID="Microsoft.MergeJoin" contactInfo="Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges data from two datasets by using a join." name="MRG - Append current stats on interesting queries" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the type of join to perform." name="JoinType" typeConverter="JoinType">2</property>

<property dataType="System.Int32" description="Specifies the number of columns in the ordering key." name="NumKeyColumns">2</property>

<property dataType="System.Boolean" description="Indicates whether the null values are treated as equal values." name="TreatNullsAsEqual">true</property>

<property dataType="System.Int32" description="Indicates the requested maximum buffers per input before blocking." name="MaxBuffersPerInput">5</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input]" hasSideEffects="true" name="Merge Join Left Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top SQL Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top SQL Handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input].Columns[Top Plan Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top Plan Handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input]" hasSideEffects="true" name="Merge Join Right Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output]" isSorted="true" name="Merge Join Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" name="statement_start_offset">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" name="statement_end_offset">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" name="plan_generation_num">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries" componentClassID="Microsoft.MergeJoin" contactInfo="Merge Join;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges data from two datasets by using a join." name="MRG - Append last stats on interesting queries" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the type of join to perform." name="JoinType" typeConverter="JoinType">2</property>

<property dataType="System.Int32" description="Specifies the number of columns in the ordering key." name="NumKeyColumns">5</property>

<property dataType="System.Boolean" description="Indicates whether the null values are treated as equal values." name="TreatNullsAsEqual">true</property>

<property dataType="System.Int32" description="Indicates the requested maximum buffers per input before blocking." name="MaxBuffersPerInput">5</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input]" hasSideEffects="true" name="Merge Join Left Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input]" hasSideEffects="true" name="Merge Join Right Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output]" isSorted="true" name="Merge Join Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]" name="old_total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]" name="old_total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]" name="old_total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]" name="old_total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]" name="old_total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]" name="old_total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]" name="old_execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="The input column associated with this output column" name="InputColumnID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input].Columns[execution_count]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Save statistics for interesting queries" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[query_stats]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_worker_time]" cachedDataType="i8" cachedName="snapshot_worker_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_physical_reads]" cachedDataType="i8" cachedName="snapshot_physical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_reads]" cachedDataType="i8" cachedName="snapshot_logical_reads" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_logical_writes]" cachedDataType="i8" cachedName="snapshot_logical_writes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_clr_time]" cachedDataType="i8" cachedName="snapshot_clr_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_elapsed_time]" cachedDataType="i8" cachedName="snapshot_elapsed_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].Columns[snapshot_execution_count]" cachedDataType="i8" cachedName="snapshot_execution_count" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" dataType="dbTimeStampOffset" name="creation_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[last_execution_time]" dataType="dbTimeStampOffset" name="last_execution_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_worker_time]" dataType="i8" name="snapshot_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_physical_reads]" dataType="i8" name="snapshot_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_writes]" dataType="i8" name="snapshot_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_logical_reads]" dataType="i8" name="snapshot_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_clr_time]" dataType="i8" name="snapshot_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_elapsed_time]" dataType="i8" name="snapshot_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[collection_time]" dataType="dbTimeStampOffset" name="collection_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_execution_count]" dataType="i8" name="snapshot_execution_count"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Upload interesting plan handles" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[notable_query_plan]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[creation_time]" dataType="dbTimeStampOffset" name="creation_time" scale="7"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]" dataType="i2" name="database_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]" dataType="i4" name="object_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="128" name="object_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[query_plan]" dataType="nText" name="query_plan"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODD - Upload interesting sql handles" usesDispositions="true" version="4">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[notable_query_text]</property>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>

<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>

<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>

<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">1000</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="RedirectRow" hasSideEffects="true" name="OLE DB Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output].Columns[source_id]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[database_id]" dataType="i2" name="database_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_id]" dataType="i4" name="object_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[object_name]" dataType="wstr" length="128" name="object_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[sql_text]" dataType="nText" name="sql_text"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get current snapshot of dm_exec_query_stats" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SnapshotQueryStatsQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output]" isSorted="true" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]" name="creation_time" sortKeyPosition="5" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]" name="last_execution_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]" name="execution_count" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]" name="total_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]" name="min_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]" name="max_worker_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]" name="total_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]" name="min_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]" name="max_physical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]" name="total_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]" name="min_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]" name="max_logical_writes" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]" name="total_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]" name="min_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]" name="max_logical_reads" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]" name="total_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]" name="min_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]" name="max_clr_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]" name="total_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]" name="min_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]" name="max_elapsed_time" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]" name="collection_time" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of interesting plan handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of interesting sql handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of not inserted plan handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Number of not inserted sql handles">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count after TopN queries">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Row count from dm_exec_query_stats">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::InterestingQueriesRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file" componentClassID="Microsoft.RawDestination" contactInfo="Loads raw data into a file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Loads raw data into a file." name="RFD - Save current snapshot in temp file" version="2">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileNameOutput</property>

<property dataType="System.Int32" description="Indicates what option is used to write to the file." name="WriteOption" typeConverter="WriteOption">0</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input]" hasSideEffects="true" name="Raw File Destination Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read current cache with dm_exec_requests" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::CollectionCacheFileNameOutput</property>

</properties>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output]" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[row_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[row_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[row_id]" name="row_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_id]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_id]" name="session_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_id]" name="request_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[exec_context_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[exec_context_id]" name="exec_context_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]" name="blocking_session_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]" name="is_blocking"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_exec_context_id]" name="blocking_exec_context_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[scheduler_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[scheduler_id]" name="scheduler_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[database_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[database_name]" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[database_name]" name="database_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[user_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[user_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[user_id]" name="user_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[task_state]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[task_state]" length="10" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[task_state]" name="task_state"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_status]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_status]" length="15" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_status]" name="request_status"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_status]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_status]" length="15" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_status]" name="session_status"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[executing_managed_code]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[executing_managed_code]" name="executing_managed_code"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_time]" name="login_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_user_process]" dataType="bool" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_user_process]" name="is_user_process"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[host_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[host_name]" length="20" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[host_name]" name="host_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[program_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[program_name]" length="50" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[program_name]" name="program_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_name]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_name]" length="30" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[login_name]" name="login_name"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_type]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_type]" length="45" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_type]" name="wait_type"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[last_wait_type]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" length="45" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[last_wait_type]" name="last_wait_type"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]" name="wait_duration_ms"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_resource]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" length="50" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_resource]" name="wait_resource"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[resource_description]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[resource_description]" length="140" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[resource_description]" name="resource_description"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_id]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_id]" name="transaction_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]" name="open_transaction_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" dataType="i2" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[transaction_isolation_level]" name="transaction_isolation_level"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]" name="request_cpu_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_logical_reads]" name="request_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_reads]" name="request_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_writes]" name="request_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]" name="request_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_start_time]" name="request_start_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]" name="memory_usage"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_cpu_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_cpu_time]" name="session_cpu_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_reads]" name="session_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_writes]" name="session_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_logical_reads]" name="session_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_scheduled_time]" name="session_total_scheduled_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_total_elapsed_time]" name="session_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_start_time]" name="session_last_request_start_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_last_request_end_time]" name="session_last_request_end_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_resultsets]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_resultsets]" name="open_resultsets"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]" name="session_row_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[prev_error]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[prev_error]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[prev_error]" name="prev_error"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]" name="pending_io_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[command]" dataType="wstr" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[command]" length="32" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[command]" name="command"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[row_id]" dataType="i4" name="row_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_id]" dataType="i2" name="session_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_id]" dataType="i4" name="request_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[exec_context_id]" dataType="i4" name="exec_context_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_session_id]" dataType="i2" name="blocking_session_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_blocking]" dataType="bool" name="is_blocking"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[blocking_exec_context_id]" dataType="i4" name="blocking_exec_context_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[scheduler_id]" dataType="i4" name="scheduler_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[database_name]" dataType="wstr" length="128" name="database_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[user_id]" dataType="i4" name="user_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[task_state]" dataType="wstr" length="10" name="task_state"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_status]" dataType="wstr" length="15" name="request_status"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_status]" dataType="wstr" length="15" name="session_status"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[executing_managed_code]" dataType="bool" name="executing_managed_code"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_time]" dataType="dbTimeStamp" name="login_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[is_user_process]" dataType="bool" name="is_user_process"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[host_name]" dataType="wstr" length="20" name="host_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[program_name]" dataType="wstr" length="50" name="program_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[login_name]" dataType="wstr" length="30" name="login_name"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_type]" dataType="wstr" length="45" name="wait_type"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[last_wait_type]" dataType="wstr" length="45" name="last_wait_type"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_duration_ms]" dataType="i8" name="wait_duration_ms"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[wait_resource]" dataType="wstr" length="50" name="wait_resource"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[resource_description]" dataType="wstr" length="140" name="resource_description"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_id]" dataType="i8" name="transaction_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_transaction_count]" dataType="i4" name="open_transaction_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[transaction_isolation_level]" dataType="i2" name="transaction_isolation_level"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_cpu_time]" dataType="i4" name="request_cpu_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_logical_reads]" dataType="i8" name="request_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_reads]" dataType="i8" name="request_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_writes]" dataType="i8" name="request_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_total_elapsed_time]" dataType="i4" name="request_total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[request_start_time]" dataType="dbTimeStamp" name="request_start_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[memory_usage]" dataType="i4" name="memory_usage"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_cpu_time]" dataType="i4" name="session_cpu_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_reads]" dataType="i8" name="session_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_writes]" dataType="i8" name="session_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_logical_reads]" dataType="i8" name="session_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_scheduled_time]" dataType="i4" name="session_total_scheduled_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_total_elapsed_time]" dataType="i4" name="session_total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_start_time]" dataType="dbTimeStamp" name="session_last_request_start_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_last_request_end_time]" dataType="dbTimeStamp" name="session_last_request_end_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[open_resultsets]" dataType="i4" name="open_resultsets"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[session_row_count]" dataType="i8" name="session_row_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[prev_error]" dataType="i4" name="prev_error"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[pending_io_count]" dataType="i4" name="pending_io_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].ExternalColumns[command]" dataType="wstr" length="32" name="command"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats" componentClassID="Microsoft.RawSource" contactInfo="Extracts data from a raw file.;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Extracts data from a raw file." name="RFS - Read last snapshot of dm_exec_query_stats" version="1">

-<properties>

<property dataType="System.Int32" description="Specifies the mode used to access the file." name="AccessMode" typeConverter="AccessMode">1</property>

<property dataType="System.Null" description="Output file name" name="FileName" UITypeEditor="Microsoft.DataTransformationServices.Controls.NonValidatingFileNameEditor"/>

<property dataType="System.String" description="Name of the variable that contains the file name" name="FileNameVariable">User::InterestingQueriesLastSnapshotFileName</property>

</properties>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output]" isSorted="true" name="Raw File Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[creation_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[last_execution_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[execution_count]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_worker_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_physical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_writes]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_reads]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_clr_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]" dataType="i8" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_elapsed_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]" dataType="i4" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]" dataType="dbTimeStamp" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[collection_time]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]" dataType="bytes" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[creation_time]" dataType="dbTimeStamp" name="creation_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[last_execution_time]" dataType="dbTimeStamp" name="last_execution_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[execution_count]" dataType="i8" name="execution_count"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_worker_time]" dataType="i8" name="total_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_physical_reads]" dataType="i8" name="total_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_writes]" dataType="i8" name="total_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_logical_reads]" dataType="i8" name="total_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_clr_time]" dataType="i8" name="total_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[total_elapsed_time]" dataType="i8" name="total_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_worker_time]" dataType="i8" name="max_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_worker_time]" dataType="i8" name="min_worker_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_physical_reads]" dataType="i8" name="min_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_physical_reads]" dataType="i8" name="max_physical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_writes]" dataType="i8" name="min_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_writes]" dataType="i8" name="max_logical_writes"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_logical_reads]" dataType="i8" name="min_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_logical_reads]" dataType="i8" name="max_logical_reads"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_clr_time]" dataType="i8" name="min_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_clr_time]" dataType="i8" name="max_clr_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[min_elapsed_time]" dataType="i8" name="min_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[max_elapsed_time]" dataType="i8" name="max_elapsed_time"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].ExternalColumns[collection_time]" dataType="dbTimeStamp" name="collection_time"/>

</externalMetadataColumns>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests" componentClassID="Microsoft.ConditionalSplit" contactInfo="Conditional Split;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Evaluates and directs rows in a dataset." name="SPLT - Identify interesting running requests" usesDispositions="true">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" description="Input to the Conditional Split Transformation" name="Conditional Split Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[blocking_session_id]" cachedDataType="i2" cachedName="blocking_session_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[is_blocking]" cachedDataType="bool" cachedName="is_blocking" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[wait_duration_ms]" cachedDataType="i8" cachedName="wait_duration_ms" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[open_transaction_count]" cachedDataType="i4" cachedName="open_transaction_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_total_elapsed_time]" cachedDataType="i4" cachedName="request_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[request_cpu_time]" cachedDataType="i4" cachedName="request_cpu_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[memory_usage]" cachedDataType="i4" cachedName="memory_usage" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[session_row_count]" cachedDataType="i8" cachedName="session_row_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input].Columns[pending_io_count]" cachedDataType="i4" cachedName="pending_io_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Interesting Requests]" description="Output 1 of the Conditional Split Transformation" errorOrTruncationOperation="Computation" errorRowDisposition="IgnoreFailure" exclusionGroup="1" name="Interesting Requests" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" truncationRowDisposition="FailComponent">

-<properties>

<property containsID="true" dataType="System.String" description="Specifies the expression. This expression version uses lineage identifiers instead of column names." name="Expression">(#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[wait_duration_ms]} > @[User::InterestingQueries_LongWaitingRequest]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[blocking_session_id]} == 0 && #{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[is_blocking]} == TRUE ) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[open_transaction_count]} > @[User::InterestingQueries_HighTransactionCount]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_total_elapsed_time]} > @[User::InterestingQueries_LongRunningRequest]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[request_cpu_time]} > @[User::InterestingQueries_HighCpuUsage]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[pending_io_count]} > @[User::InterestingQueries_HighIoCount]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[memory_usage]} > @[User::InterestingQueries_HighMemoryUsage]) || (#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[session_row_count]} > @[User::InterestingQueries_LargeResultset])</property>

<property containsID="true" dataType="System.String" description="Specifies the friendly version of the expression. This expression version uses column names." expressionType="Notify" name="FriendlyExpression">(wait_duration_ms > @[User::InterestingQueries_LongWaitingRequest]) || (blocking_session_id == 0 && is_blocking == TRUE ) || (open_transaction_count > @[User::InterestingQueries_HighTransactionCount]) || (request_total_elapsed_time > @[User::InterestingQueries_LongRunningRequest]) || (request_cpu_time > @[User::InterestingQueries_HighCpuUsage]) || (pending_io_count > @[User::InterestingQueries_HighIoCount]) || (memory_usage > @[User::InterestingQueries_HighMemoryUsage]) || (session_row_count > @[User::InterestingQueries_LargeResultset])</property>

<property dataType="System.Int32" description="Specifies the position of the condition in the list of conditions that the transformation evaluates. The evaluation order is from the lowest to the highest value." name="EvaluationOrder">0</property>

</properties>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Default Output]" description="Default Output of the Conditional Split Transformation" exclusionGroup="1" name="Conditional Split Default Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]">

-<properties>

<property dataType="System.Boolean" name="IsDefaultOut">true</property>

</properties>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output]" description="Error Output of the Conditional Split Transformation" exclusionGroup="1" isErrorOut="true" name="Conditional Split Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Conditional Split Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">false</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">3</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">4</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">5</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[last_execution_time]" name="last_execution_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[execution_count]" name="execution_count">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_worker_time]" name="total_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_physical_reads]" name="total_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_writes]" name="total_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_logical_reads]" name="total_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_clr_time]" name="total_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[total_elapsed_time]" name="total_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_worker_time]" name="max_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_worker_time]" name="min_worker_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_physical_reads]" name="min_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_physical_reads]" name="max_physical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_writes]" name="min_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_writes]" name="max_logical_writes">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_logical_reads]" name="min_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_logical_reads]" name="max_logical_reads">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_clr_time]" name="min_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_clr_time]" name="max_clr_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[min_elapsed_time]" name="min_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[max_elapsed_time]" name="max_elapsed_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[collection_time]" name="collection_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output].Columns[snapshot_id]" name="snapshot_id">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Find unique sql_handle and plan_handle combinations" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">3</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">4</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">5</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_handle]" name="plan_handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_start_offset]" name="statement_start_offset" sortKeyPosition="3">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[statement_end_offset]" name="statement_end_offset" sortKeyPosition="4">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[creation_time]" name="creation_time">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[plan_generation_num]" name="plan_generation_num" sortKeyPosition="5">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Find unique sql_handle values" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output].Columns[sql_handle]" name="sql_handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output].Columns[sql_handle]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle" componentClassID="Microsoft.Sort" contactInfo="Sort;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Sorts data." name="SRT - Sort columns by sql_handle, plan_handle" version="1">

-<properties>

<property dataType="System.Boolean" description="Indicates whether the Sort transformation removes rows with duplicate sort values." name="EliminateDuplicates">true</property>

<property dataType="System.Int32" description="Specifies the maximum number of threads to use for sorting." expressionType="Notify" name="MaximumThreads">-1</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input]" name="Sort Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Reason]" cachedDataType="wstr" cachedLength="128" cachedName="Top Reason" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">0</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top SQL Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top SQL Handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">1</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input].Columns[Top Plan Handle]" cachedDataType="bytes" cachedLength="44" cachedName="Top Plan Handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]">

-<properties>

<property dataType="System.Int32" description="Specifies the comparison options for character data." name="NewComparisonFlags">0</property>

<property dataType="System.Int32" description="Specifies the sort order of the column." name="NewSortKeyPosition">2</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output]" isSorted="true" name="Sort Output">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason]" dataType="wstr" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Reason]" name="Top Reason">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top SQL Handle]" name="Top SQL Handle" sortKeyPosition="1">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]}</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output].Columns[Top Plan Handle]" name="Top Plan Handle" sortKeyPosition="2">

-<properties>

<property containsID="true" dataType="System.Int32" description="Specifies the lineage identifier of the input column that is associated with this output column." name="SortColumnId">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]}</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries" componentClassID="Microsoft.TxTopQueries" name="TPQ - Analyze Interesting Queries" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input]" name="TxTopQueries Only Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]"/>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output]" name="TxTopQueries Only Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]" dataType="wstr" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Reason]" name="Top Reason"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top SQL Handle]" name="Top SQL Handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]" dataType="bytes" length="44" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output].Columns[Top Plan Handle]" name="Top Plan Handle"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats" componentClassID="Microsoft.UnionAll" contactInfo="Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges multiple datasets." name="UNION - Combine interesting requests and interesting stats" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1]" name="Union All Input 1">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_worker_time]" cachedDataType="i8" cachedName="old_total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_physical_reads]" cachedDataType="i8" cachedName="old_total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_writes]" cachedDataType="i8" cachedName="old_total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_logical_reads]" cachedDataType="i8" cachedName="old_total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_clr_time]" cachedDataType="i8" cachedName="old_total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_total_elapsed_time]" cachedDataType="i8" cachedName="old_total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_worker_time]" cachedDataType="i8" cachedName="snapshot_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_physical_reads]" cachedDataType="i8" cachedName="snapshot_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_reads]" cachedDataType="i8" cachedName="snapshot_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_logical_writes]" cachedDataType="i8" cachedName="snapshot_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_clr_time]" cachedDataType="i8" cachedName="snapshot_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_elapsed_time]" cachedDataType="i8" cachedName="snapshot_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[snapshot_execution_count]" cachedDataType="i8" cachedName="snapshot_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output].Columns[snapshot_execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1].Columns[old_execution_count]" cachedDataType="i8" cachedName="old_execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output].Columns[old_execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3]" hasSideEffects="true" name="Union All Input 3">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 2]" dangling="true" hasSideEffects="true" name="Union All Input 2">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1]" name="Union All Output 1">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_worker_time]" name="old_total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_physical_reads]" name="old_total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_writes]" name="old_total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_logical_reads]" name="old_total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_clr_time]" name="old_total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_total_elapsed_time]" name="old_total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_worker_time]" name="snapshot_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_physical_reads]" name="snapshot_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_reads]" name="snapshot_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_logical_writes]" name="snapshot_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_clr_time]" name="snapshot_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_elapsed_time]" name="snapshot_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[snapshot_execution_count]" name="snapshot_execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1].Columns[old_execution_count]" name="old_execution_count"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing" componentClassID="Microsoft.UnionAll" contactInfo="Union All;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;1" description="Merges multiple datasets." name="UNION - Combine last and current snapshots for TopN processing" version="1">

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2]" hasSideEffects="true" name="Union All Input 2">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3]" hasSideEffects="true" name="Union All Input 3">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" cachedSortKeyPosition="3" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_start_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" cachedSortKeyPosition="4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[statement_end_offset]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" cachedSortKeyPosition="5" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_generation_num]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[creation_time]" cachedDataType="dbTimeStamp" cachedName="creation_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[creation_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[last_execution_time]" cachedDataType="dbTimeStamp" cachedName="last_execution_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[last_execution_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[execution_count]" cachedDataType="i8" cachedName="execution_count" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[execution_count]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_worker_time]" cachedDataType="i8" cachedName="total_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_physical_reads]" cachedDataType="i8" cachedName="total_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_writes]" cachedDataType="i8" cachedName="total_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_logical_reads]" cachedDataType="i8" cachedName="total_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_clr_time]" cachedDataType="i8" cachedName="total_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[total_elapsed_time]" cachedDataType="i8" cachedName="total_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[total_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_worker_time]" cachedDataType="i8" cachedName="max_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_worker_time]" cachedDataType="i8" cachedName="min_worker_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_worker_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_physical_reads]" cachedDataType="i8" cachedName="min_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_physical_reads]" cachedDataType="i8" cachedName="max_physical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_physical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_writes]" cachedDataType="i8" cachedName="min_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_writes]" cachedDataType="i8" cachedName="max_logical_writes" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_writes]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_logical_reads]" cachedDataType="i8" cachedName="min_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_logical_reads]" cachedDataType="i8" cachedName="max_logical_reads" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_logical_reads]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_clr_time]" cachedDataType="i8" cachedName="min_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_clr_time]" cachedDataType="i8" cachedName="max_clr_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_clr_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[min_elapsed_time]" cachedDataType="i8" cachedName="min_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[min_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[max_elapsed_time]" cachedDataType="i8" cachedName="max_elapsed_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[max_elapsed_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[snapshot_id]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[collection_time]" cachedDataType="dbTimeStamp" cachedName="collection_time" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[collection_time]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" cachedSortKeyPosition="1" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[sql_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]}</property>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" cachedSortKeyPosition="2" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output].Columns[plan_handle]">

-<properties>

<property containsID="true" dataType="System.Int32" description="Output column lineage ID" name="OutputColumnLineageID">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]}</property>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 1]" dangling="true" hasSideEffects="true" name="Union All Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1]" name="Union All Output 1">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[creation_time]" name="creation_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[last_execution_time]" name="last_execution_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[execution_count]" name="execution_count"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_worker_time]" name="total_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_physical_reads]" name="total_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_writes]" name="total_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_logical_reads]" name="total_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_clr_time]" name="total_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[total_elapsed_time]" name="total_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_worker_time]" name="max_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_worker_time]" name="min_worker_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_physical_reads]" name="min_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_physical_reads]" name="max_physical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_writes]" name="min_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_writes]" name="max_logical_writes"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_logical_reads]" name="min_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_logical_reads]" name="max_logical_reads"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_clr_time]" name="min_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_clr_time]" name="max_clr_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[min_elapsed_time]" name="min_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[max_elapsed_time]" name="max_elapsed_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[snapshot_id]" name="snapshot_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]" dataType="dbTimeStamp" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[collection_time]" name="collection_time"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1].Columns[plan_handle]" name="plan_handle"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Calculate TopN stats]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Right Input]" name="Calculate TopN stats" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Calculate TopN stats1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Right Input]" name="Calculate TopN stats" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Inputs[Multicast Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Inputs[Row Count Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Inputs[Multicast Input 1]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Derived Column Output4]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 3]" name="Derived Column Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Outputs[Derived Column Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Interesting Requests]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add plan_generation_num column.Inputs[Derived Column Input]" name="Interesting Requests" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Outputs[Interesting Requests]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Merge Join Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Inputs[Row Count Input 1]" name="Merge Join Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Outputs[Merge Join Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Merge Join Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Calculate delta value between last snapshot and current snapshot for every metric.Inputs[Derived Column Input]" name="Merge Join Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Outputs[Merge Join Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (1).Inputs[Derived Column Input]" name="Multicast Output 2" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Inputs[Union All Input 1]" name="Multicast Output 3" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 3]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Multicast Output 4]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Inputs[Sort Input]" name="Multicast Output 4" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Outputs[Multicast Output 4]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Destination Error Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted sql handles.Inputs[Row Count Input 1]" name="OLE DB Destination Error Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Outputs[OLE DB Destination Error Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Destination Error Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of not inserted plan handles.Inputs[Row Count Input 1]" name="OLE DB Destination Error Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Outputs[OLE DB Destination Error Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODS - Get current snapshot of dm_exec_query_stats.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Process TopN1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 3]" name="Process TopN" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Outputs[Multicast Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Process TopN]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Inputs[Union All Input 2]" name="Process TopN" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Raw File Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split last snapshot.Inputs[Multicast Input 1]" name="Raw File Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read last snapshot of dm_exec_query_stats.Outputs[Raw File Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Raw File Source Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SPLT - Identify interesting running requests.Inputs[Conditional Split Input]" name="Raw File Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFS - Read current cache with dm_exec_requests.Outputs[Raw File Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting plan handles.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting plan handles.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Upload interesting sql handles.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Number of interesting sql handles.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 12]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Inputs[Sort Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count after TopN queries.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Row Count Output 13]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRC - Add SnapshotId column to current snapshot.Inputs[Derived Column Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RC - Row count from dm_exec_query_stats.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Save]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\RFD - Save current snapshot in temp file.Inputs[Raw File Destination Input]" name="Save" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - split current snapshot.Outputs[Multicast Output 3]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Save1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\ODD - Save statistics for interesting queries.Inputs[OLE DB Destination Input]" name="Save" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split interesting queries.Outputs[Multicast Output 2]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MLTCST - Split to upload sql_handle and plan_handle.Inputs[Multicast Input 1]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append last stats on interesting queries.Inputs[Merge Join Left Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Add statement_start_offset, statement_end_offset and creation_time to the sort order.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output2]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\DRV - Add source_id (2).Inputs[Derived Column Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle values.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Sort Output3]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\MRG - Append current stats on interesting queries.Inputs[Merge Join Left Input]" name="Sort Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Outputs[Sort Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[TxTopQueries Only Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Sort columns by sql_handle, plan_handle.Inputs[Sort Input]" name="TxTopQueries Only Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Outputs[TxTopQueries Only Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Union All Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\SRT - Find unique sql_handle and plan_handle combinations.Inputs[Sort Input]" name="Union All Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine interesting requests and interesting stats.Outputs[Union All Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch.Paths[Union All Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\TPQ - Analyze Interesting Queries.Inputs[TxTopQueries Only Input]" name="Union All Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch\UNION - Combine last and current snapshots for TopN processing.Outputs[Union All Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{06401E14-2D8B-4F21-AEF7-BDBD02C9C408}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Find and save plan text" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B2DB683D-A481-4324-9E1D-141AA674A545}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = " + (DT_WSTR,50) @[User::SourceId]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SourceSqlQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [snapshots].[sp_get_unknown_query_plan] @source_id = 1</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5" description="Looks up values in a reference dataset by using exact matching." name="LKUP - Look up query plans on target server" usesDispositions="true" version="6">

-<properties>

<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?</property>

<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_text_query_plan_lookpup] ?,?,?</property>

<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>

<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">2</property>

<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>

<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>

<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">25</property>

<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">25</property>

<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="plan_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_start_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="statement_end_offset" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="query_plan" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>

<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]};#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]};#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]};</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[ConfigConnection2]" connectionManagerRefId="Package.ConnectionManagers[ConfigConnection2]" description="Connection manager used to access lookup data." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]" name="Lookup Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">statement_start_offset</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">statement_end_offset</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">plan_handle</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]" dataType="i2" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]" name="database_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">database_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]" name="object_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]" dataType="wstr" errorOrTruncationOperation="Copy Column" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]" name="object_name" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_name</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]" dataType="nText" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]" name="query_plan" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">query_plan</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODC - Save known plans to warehouse" usesDispositions="true" version="2">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">EXEC snapshots.sp_update_query_plan ?,?,?,?,?,?,?,?,?,?</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_handle]" cachedDataType="bytes" cachedLength="64" cachedName="plan_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_start_offset]" cachedDataType="i4" cachedName="statement_start_offset" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[statement_end_offset]" cachedDataType="i4" cachedName="statement_end_offset" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[plan_generation_num]" cachedDataType="i8" cachedName="plan_generation_num" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[database_id]" cachedDataType="i2" cachedName="database_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[database_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_id]" cachedDataType="i4" cachedName="object_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[object_name]" cachedDataType="wstr" cachedLength="128" cachedName="object_name" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[object_name]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].Columns[query_plan]" cachedDataType="nText" cachedName="query_plan" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output].Columns[query_plan]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" dataType="i4" name="@source_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" dataType="bytes" length="64" name="@sql_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_handle]" dataType="bytes" length="64" name="@plan_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_start_offset]" dataType="i4" name="@statement_start_offset">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@statement_end_offset]" dataType="i4" name="@statement_end_offset">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@plan_generation_num]" dataType="i8" name="@plan_generation_num">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" dataType="i2" name="@database_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" dataType="i4" name="@object_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" dataType="wstr" length="128" name="@object_name">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@query_plan]" dataType="nText" name="@query_plan">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">193</property>

</properties>

</externalMetadataColumn>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get all plan handles without saved plan" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SourceSqlQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output]" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_handle]" name="plan_handle" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_start_offset]" name="statement_start_offset" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[statement_end_offset]" name="statement_end_offset" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].Columns[plan_generation_num]" name="plan_generation_num" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_handle]" dataType="bytes" length="64" name="plan_handle"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_start_offset]" dataType="i4" name="statement_start_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[statement_end_offset]" dataType="i4" name="statement_end_offset"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output].ExternalColumns[plan_generation_num]" dataType="i8" name="plan_generation_num"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[source_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[source_id]" name="source_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_handle]" name="plan_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_start_offset]" name="statement_start_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[statement_end_offset]" name="statement_end_offset"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" dataType="i8" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[plan_generation_num]" name="plan_generation_num"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Identified query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unidentified query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unknown query plans count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlPlanUpdateRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Lookup Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Inputs[Row Count Input 1]" name="Lookup Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Lookup No Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unidentified query plans count.Inputs[Row Count Input 1]" name="Lookup No Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Outputs[Lookup No Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODS - Get all plan handles without saved plan.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\ODC - Save known plans to warehouse.Inputs[OLE DB Command Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Identified query plans count.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\LKUP - Look up query plans on target server.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text\RC - Unknown query plans count.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{A8B89CFB-EAB7-418D-ABA6-B0653CFF73B2}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Find and save sql text" DTS:TaskContact="Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3B4FCEE9-FA8B-4F72-804B-4BE4019A2BF4}" DTS:EvaluateAsExpression="True" DTS:Expression=""EXEC [snapshots].[sp_get_unknown_query_text] @source_id = " + (DT_WSTR,50) @[User::SourceId]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SourceSqlQuery">

<DTS:VariableValue DTS:DataType="8">EXEC [snapshots].[sp_get_unknown_query_text] @source_id = 1</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

-<DTS:ObjectData>

-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">

-<components>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server" componentClassID="Microsoft.Lookup" contactInfo="Lookup;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;5" description="Looks up values in a reference dataset by using exact matching." name="LKUP - Look up query text on target server" usesDispositions="true" version="6">

-<properties>

<property dataType="System.String" description="Specifies the SQL statement that generates the lookup table." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_sql_text_lookup] ?</property>

<property dataType="System.String" description="Specifies a SQL statement that uses parameters to generate the lookup table." expressionType="Notify" name="SqlCommandParam" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">[dbo].[sp_syscollector_sql_text_lookup] ?</property>

<property dataType="System.Int32" description="Specifies the type of connection used to access the reference dataset." name="ConnectionType" typeConverter="LookupConnectionType">0</property>

<property dataType="System.Int32" description="Specifies the cache type of the lookup table." name="CacheType" typeConverter="CacheType">2</property>

<property dataType="System.Int32" description="Specifies how the Lookup transformation handles rows without matching entries in the reference data set." name="NoMatchBehavior" typeConverter="LookupNoMatchBehavior">1</property>

<property dataType="System.Int32" description="Specifies the percentage of the cache that is allocated for rows with no matching entries in the reference dataset." name="NoMatchCachePercentage">0</property>

<property dataType="System.Int32" description="Maximum Memory Usage for Reference Cache on a 32 bit platform." name="MaxMemoryUsage">25</property>

<property dataType="System.Int64" description="Maximum Memory Usage for Reference Cache on a 64 bit platform." name="MaxMemoryUsage64">25</property>

<property dataType="System.String" description="Indicates whether to reference metadata in an XML format." name="ReferenceMetadataXml"><referenceMetadata><referenceColumns><referenceColumn name="sql_handle" dataType="DT_BYTES" length="64" precision="0" scale="0" codePage="0"/><referenceColumn name="database_id" dataType="DT_I2" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_id" dataType="DT_I4" length="0" precision="0" scale="0" codePage="0"/><referenceColumn name="object_name" dataType="DT_WSTR" length="128" precision="0" scale="0" codePage="0"/><referenceColumn name="sql_text" dataType="DT_NTEXT" length="0" precision="0" scale="0" codePage="0"/></referenceColumns></referenceMetadata></property>

<property containsID="true" dataType="System.String" description="Specifies the list of lineage identifiers that map to the parameters that the SQL statement in the SQLCommand property uses. Entries in the list are separated by semicolons." name="ParameterMap">#{Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]};</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Determines whether duplicate keys in the reference data should be treated as errors when full cache mode is used." name="TreatDuplicateKeysAsError">false</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[ConfigConnection2]" connectionManagerRefId="Package.ConnectionManagers[ConfigConnection2]" description="Connection manager used to access lookup data." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]" name="Lookup Input">

-<inputColumns>

-<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table that a column joins." name="JoinToReferenceColumn">sql_handle</property>

<property dataType="System.Null" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn"/>

</properties>

</inputColumn>

</inputColumns>

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output]" errorOrTruncationOperation="Lookup" exclusionGroup="1" name="Lookup Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

-<outputColumns>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]" dataType="i2" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]" name="database_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">database_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]" dataType="i4" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]" name="object_id" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_id</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]" dataType="wstr" errorOrTruncationOperation="Copy Column" length="128" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]" name="object_name" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">object_name</property>

</properties>

</outputColumn>

-<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]" dataType="nText" errorOrTruncationOperation="Copy Column" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]" name="sql_text" truncationRowDisposition="FailComponent">

-<properties>

<property dataType="System.String" description="Specifies the column in the reference table from which a column is copied." name="CopyFromReferenceColumn">sql_text</property>

</properties>

</outputColumn>

</outputColumns>

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup No Match Output]" description="The Lookup output that handles rows with no matching entries in the reference dataset. Use this output when the NoMatchBehavior property is set to "Send rows with no matching entries to the no match output."" exclusionGroup="1" name="Lookup No Match Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output]" exclusionGroup="1" isErrorOut="true" name="Lookup Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODS - Get all sql handles without saved sql text" usesDispositions="true" version="7">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>

<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>

<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">snapshots.sp_get_unknown_query_text @source_id = 3</property>

<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::SourceSqlQuery</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>

<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>

<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output]" name="OLE DB Source Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]" name="source_id" truncationRowDisposition="FailComponent"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]" name="sql_handle" truncationRowDisposition="FailComponent"/>

</outputColumns>

-<externalMetadataColumns isUsed="True">

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[source_id]" dataType="i4" name="source_id"/>

<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].ExternalColumns[sql_handle]" dataType="bytes" length="64" name="sql_handle"/>

</externalMetadataColumns>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[source_id]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[source_id]" name="source_id"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[sql_handle]" dataType="bytes" length="64" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[sql_handle]" name="sql_handle"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODS - Save query text to warehouse" usesDispositions="true" version="2">

-<properties>

<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>

<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">EXEC snapshots.sp_update_query_text ?, ?, ?, ?, ?, ?</property>

<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>

</properties>

-<connections>

<connection refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>

</connections>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Command Input">

-<inputColumns>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_handle]" cachedDataType="bytes" cachedLength="64" cachedName="sql_handle" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[sql_handle]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[source_id]" cachedDataType="i4" cachedName="source_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output].Columns[source_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[database_id]" cachedDataType="i2" cachedName="database_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[database_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_id]" cachedDataType="i4" cachedName="object_id" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_id]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[object_name]" cachedDataType="wstr" cachedLength="128" cachedName="object_name" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[object_name]"/>

<inputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].Columns[sql_text]" cachedDataType="nText" cachedName="sql_text" externalMetadataColumnId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text]" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output].Columns[sql_text]"/>

</inputColumns>

-<externalMetadataColumns isUsed="True">

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_handle]" dataType="bytes" length="64" name="@sql_handle">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@source_id]" dataType="i4" name="@source_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@database_id]" dataType="i2" name="@database_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_id]" dataType="i4" name="@object_id">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@object_name]" dataType="wstr" length="128" name="@object_name">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>

</properties>

</externalMetadataColumn>

-<externalMetadataColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input].ExternalColumns[@sql_text]" dataType="nText" name="@sql_text">

-<properties>

<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">193</property>

</properties>

</externalMetadataColumn>

</externalMetadataColumns>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]">

<externalMetadataColumns/>

</output>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]">

-<outputColumns>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>

<outputColumn refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>

</outputColumns>

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft Sql Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Identified query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountOut</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unidentified query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountError</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

-<component refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer v9; (C) 2005 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="RC - Unknown query text count">

-<properties>

<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::SqlTextUpdateRowCountIn</property>

</properties>

-<inputs>

-<input refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">

<externalMetadataColumns/>

</input>

</inputs>

-<outputs>

-<output refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]">

<externalMetadataColumns/>

</output>

</outputs>

</component>

</components>

-<paths>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Lookup Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Inputs[Row Count Input 1]" name="Lookup Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Lookup No Match Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unidentified query text count.Inputs[Row Count Input 1]" name="Lookup No Match Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Outputs[Lookup No Match Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[OLE DB Source Output]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Get all sql handles without saved sql text.Outputs[OLE DB Source Output]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Row Count Output 1]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\ODS - Save query text to warehouse.Inputs[OLE DB Command Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Identified query text count.Outputs[Row Count Output 1]"/>

<path refId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text.Paths[Row Count Output 11]" endId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\LKUP - Look up query text on target server.Inputs[Lookup Input]" name="Row Count Output 1" startId="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text\RC - Unknown query text count.Outputs[Row Count Output 1]"/>

</paths>

</pipeline>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{C2C219D8-0B35-4D01-A732-72489975921A}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Check Interesting Queries Last Snapshot exists" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

<DTS:PropertyExpression DTS:Name="FilePath">@[User::InterestingQueriesLastSnapshotFileName]</DTS:PropertyExpression>

-<DTS:ObjectData>

-<FileAccessTask>

<Mode>0</Mode>

<FilePath>c:\perflogs\ALEN-PC_MSSQL.1_{2DC02BD6-E230-4C05-8516-4E8C0EF21F95}_100_QueryActivity_QueryStats_LastSnapshot.cache</FilePath>

</FileAccessTask>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{6CF195E1-8563-46F2-9500-A52AEB3306F0}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Current Snapshot File as Last Snapshot File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::InterestingQueriesLastSnapshotFileNameOutput" TaskIsSourceVariable="True" TaskDestinationPath="User::InterestingQueriesLastSnapshotFileName" TaskIsDestinationVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{6F36C159-874B-4351-A291-8AC691098328}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for Interesting Queries" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'query_stats upload', ?, ?, NULL, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::InterestingQueriesRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InterestingQueriesRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{90BFBAF6-A08D-4BCB-B1E0-EE493CAA80E0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for sql plan" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql plan upload', ?, ?, ?, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::SqlPlanRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::SqlPlanRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::SqlPlanRowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql text" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{02284097-190E-4435-84BE-F5E14956A1F0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log stats for sql text" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{39FB064F-9853-4718-880F-C97853E29875}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onstatsupdate (?, N'sql text upload', ?, ?, ?, 0) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::SqlTextRowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::SqlTextRowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::SqlTextRowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{B8D3087D-11C1-4B00-997B-6067A6579AEF}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{B5171C94-F537-4E05-B026-6F1733778AED}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{188F2E10-1D32-4CB6-8F1B-39300F9DC592}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save sql text" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{0CA4D80A-739D-48A7-9F2B-A2F18810434B}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Find and save plan text" DTS:ObjectName="Constraint 3" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{80BB971B-FD09-4237-8119-D90654587E64}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel]>=1" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:ObjectName="Constraint 5" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{CCEACE44-4FBD-4796-90ED-B1AE560BE3B4}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Upload Batch" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\FST - Rename Current Snapshot File as Last Snapshot File"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 7]" DTS:CreationName="" DTS:DTSID="{84EC6C5C-B6F8-41FC-8FC3-12E6B722BFFF}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for Interesting Queries" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 7" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{D7CB327F-A818-4D93-855C-11473FBE4AEC}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql plan" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\SQL - Log stats for sql text" DTS:Value="2"/>

<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Capture and analyze query statistics and query plan and text.PrecedenceConstraints[Last Snapshot Missing]" DTS:CreationName="" DTS:DTSID="{FBDCF942-3540-45E2-AAD6-A425973C01E8}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text\FAT - Check Interesting Queries Last Snapshot exists" DTS:LogicalAnd="True" DTS:ObjectName="Last Snapshot Missing" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text\DFT - Create Interesting Queries Last Snapshot" DTS:Value="1"/>

</DTS:PrecedenceConstraints>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SEQ - Rename Collection Cache File" DTS:CreationName="STOCK:SEQUENCE" DTS:Description="Sequence Container" DTS:DTSID="{8C70D6CD-D74A-4349-BB8A-8917BC91A5B6}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Rename Collection Cache File">

-<DTS:Variables>

-<DTS:Variable DTS:CreationName="" DTS:DTSID="{48719FEE-0780-458C-AE72-3B398DDA4A24}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="SyncRoot">

<DTS:VariableValue DTS:DataType="8">QueryActivityLock</DTS:VariableValue>

</DTS:Variable>

</DTS:Variables>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:Executables>

-<DTS:Executable DTS:refId="Package\SEQ - Rename Collection Cache File\FST - Rename Cache File" DTS:CreationName="Microsoft.FileSystemTask" DTS:Description="File System Task" DTS:DTSID="{C5533AC9-9896-43CA-A46C-DD7D9A396B12}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Rename Cache File" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0"/>

-<DTS:ObjectData>

<FileSystemData TaskOperationType="RenameFile" TaskOverwriteDestFile="True" TaskSourcePath="User::CollectionCacheFileName" TaskIsSourceVariable="True" TaskDestinationPath="User::CollectionCacheFileNameOutput" TaskIsDestinationVariable="True"/>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SQL - Get SnapshotId" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{DD0170D6-186A-437B-8F7D-E909F437A16F}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get SnapshotId" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" SQLTask:SqlStatementSource="{call [core].[sp_create_snapshot](?, ?, ?, ?, ?, ?)}">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotId" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

-<DTS:Executable DTS:refId="Package\SQL - Get SourceId" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{E05B5850-7B98-4C33-95AC-EC191C7334F5}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get SourceId" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server code name "Katmai"; Â© 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">

<DTS:Variables/>

<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>

-<DTS:ObjectData>

-<SQLTask:SqlTaskData SQLTask:Connection="{6638AF14-9580-4671-8B14-1E28ADAD9B72}" SQLTask:SqlStatementSource="{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }">

<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="2" SQLTask:ParameterSize="-1"/>

<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceId" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>

</SQLTask:SqlTaskData>

</DTS:ObjectData>

</DTS:Executable>

</DTS:Executables>

-<DTS:PrecedenceConstraints>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{6FDD2D34-4BAD-42B5-9E71-E135532FB590}" DTS:From="Package\SEQ - Rename Collection Cache File" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\CWM - Remove Upload Snapshots Older Than CacheWindow"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 12]" DTS:CreationName="" DTS:DTSID="{54C3C3CA-67A4-4B87-A5CE-A8679A5E5116}" DTS:From="Package\FAT - Check Cache File Exists" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 12" DTS:To="Package\SEQ - Rename Collection Cache File"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{AAA44A20-51D1-42FE-9656-41A1DBAC347A}" DTS:From="Package\SQL - Get SourceId" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\SQL - Get SnapshotId"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{1B9D6AD9-FDDE-4443-AA9B-2688E595DC2B}" DTS:From="Package\SQL - Get SnapshotId" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 7]" DTS:CreationName="" DTS:DTSID="{53381062-0490-4018-98B1-EF24A1C0E052}" DTS:From="Package\CWM - Remove Upload Snapshots Older Than CacheWindow" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 7" DTS:To="Package\SEQ - Capture and analyze query statistics and query plan and text"/>

<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{4D376995-07A3-41A5-B3EE-01FA251AA113}" DTS:From="Package\SEQ - Capture and analyze query statistics and query plan and text" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\FEF - For each collected cache file try upload"/>

</DTS:PrecedenceConstraints>

</DTS:Executable>


Package

Package: SqlTraceCollect

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 2/14/2007 3:06:05 PM
CreationName | Microsoft.Package
CreatorComputerName | MACIES4
CreatorName | REDMOND\macies
DebugMode | False
DelayValidation | True
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {0E149FC9-1046-4DE6-98BF-4B22ED6F6C42}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 0
Name | SqlTraceCollect
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\SqlTraceCollect
PackagePath | Data Collector\SqlTraceCollect
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | EncryptSensitiveWithUserKey
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | True
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 87
VersionComments |
VersionGUID | {149519E7-B008-4BE2-9408-766D8CC64951}
VersionMajor | 1
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
Foreach Loop - Monitor Trace | Foreach Loop Container
SQL - Close trace if running | Execute SQL Task
SQL - Execute Trace Start Script | Execute SQL Task
SQL - Stop Trace | Execute SQL Task
TRC - Generate Trace Start Script | Trace Start Script

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 5 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopDuration |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |
TraceErrorCode |
TraceID |
TraceLocation |
TraceScript |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="2/14/2007 3:06:05 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="MACIES4" DTS:CreatorName="REDMOND\macies" DTS:DelayValidation="True" DTS:DTSID="{0E149FC9-1046-4DE6-98BF-4B22ED6F6C42}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:FailParentOnFailure="True" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxErrorCount="0" DTS:ObjectName="SqlTraceCollect" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:SuppressConfigurationWarnings="True" DTS:VersionBuild="87" DTS:VersionGUID="{F07B5F92-5102-4B20-A226-174049FB7C2D}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{B2336E2F-4946-4B14-9A6C-BF6059132E81}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=MDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{72F1EE8A-126D-4918-8358-55FD82DCDA58}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5EF6C061-FFAD-45CF-BEDC-170C206A9774}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{62E3B07F-C5B7-4897-B347-74EF91DE84EA}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EBB9F538-F06D-4E25-803F-DA3786931A72}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D435F04D-45EE-4705-9F59-37B75F4695BB}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{175B22A1-7B3C-4C7C-9F27-8BA255CE806D}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{349BCBAD-ABF2-4639-93A2-E7E6474E2C69}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{264D4120-D107-4880-A7FA-5BEAE2BB05B8}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{E46A25A3-1DB8-4F06-93F5-700D9FF3D8DB}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{DA667ED7-E83E-4E8F-AF0B-90B784E51E4D}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{4D42DA00-DC8B-442A-AE96-18DB1C38D3E7}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8AFB1B11-7206-4A95-AED3-631969E75CE9}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{7B439C62-C6E2-4961-B885-8F19CA71B18B}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3FB4BC97-FCA6-457F-BEFA-A22645B7824C}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C5B0F2F8-E34E-41C6-879A-85CAD34E4ED8}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{2DF60C47-E413-4E07-9EC1-F06F888B6143}" DTS:ObjectName="ParentLogID"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E13D738-CEC0-4537-93A7-7926142F274B}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E40806B1-6B8D-4381-AD2B-1C44067588E4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B902EBEC-969B-42D4-81BE-C5149B8E1750}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8">f37780d4-fea7-4271-90b2-fa553ad4ca91</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{998E9C65-6E29-46CD-845E-AFA5D5C6E75E}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">0e218cf8-ecb5-417b-b533-d851c0251271</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9B1A5823-2F9A-4589-B15F-CDB60E89CDAF}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{46738D8F-C9D8-45DC-95C2-F7BD6CB95C13}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A3701456-096F-4A45-A8CC-E5473ECFE075}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{91086B11-E37A-419D-B9F2-05807790111F}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{20041AC6-1B78-4A75-8F50-D4DAA6EDF964}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">(local)</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0C688D7F-6BFB-4018-BA62-78AF00876D5D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9FF8E1B3-7D2A-43BD-894D-F27FEBC3275C}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{D13402E2-2FD2-4FF8-8873-93D5A999FCE5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{2DF4BAA6-D6A8-4230-9007-A1CD3E5AF1CF}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{EF24B339-0DAC-42AC-A490-CD53827688F7}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A506924A-C3E2-41E2-8C9D-1EE5E4792051}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=MDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{58FC505F-AC84-4F90-834C-E27CC8478D0B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E925F74-02D2-4B08-8C55-BABE20B84168}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{549EEAA7-88DB-4FCB-9548-BBE7077559F9}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceErrorCode">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{05CEC9A6-14B2-4B68-8EF7-7825CC7622D4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1FDF1A88-F491-496C-BB22-26F2DB314498}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLocation">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{6BCBC2C4-F895-4B8C-A793-EB71AFF0AF2A}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceScript">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace" DTS:CreationName="STOCK:FOREACHLOOP" DTS:DelayValidation="True" DTS:Description="Foreach Loop Container" DTS:DTSID="{AC652D98-8CD6-4256-BEB0-7B937A9F6EFC}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="Foreach Loop - Monitor Trace">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachEventEnumerator" DTS:DTSID="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}" DTS:ObjectName="{710AEAF2-45BD-4AB2-9EAF-FB6268AD10A2}">
<DTS:PropertyExpression DTS:Name="ExitEventName">@[User::ExitEventName]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="LoopEventName">@[User::LoopEventName]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachEventEnumeratorProperties>
<FEEEProperty LoopEventName="LOOPEVENT"/>
<FEEEProperty ExitEventName="EXITEVENT"/>
</ForEachEventEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{DDDFF39B-578A-4DFB-B194-0723500C3565}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Check if Trace is Running" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceStatus INT DECLARE @TraceID INT SELECT @TraceID = id , @TraceStatus = status FROM sys.traces WHERE [id] = ? AND ([path] LIKE ? + N'%.trc' OR is_default=1) IF @TraceID IS NULL BEGIN RAISERROR(14678, 16, -1, @TraceID) END ELSE BEGIN IF @TraceStatus <> 1 EXEC sp_trace_setstatus @TraceID, 1 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Log Package Iteration" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{6287158D-7570-43DF-9D6E-9D9191345709}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Iteration" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" SQLTask:SqlStatementSource="{ call dbo.sp_syscollector_event_onpackageupdate( ? )}">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{A96C46EC-F328-44A1-BE6B-0FA1A2E4267E}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log Package Stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{9BE08268-DCA3-4834-8711-29EB7B34AC16}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Monitor trace', 0, 0, 0, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{972327c3-db40-4180-9f20-b5696bb14eb2}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Recreate Trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStmtSourceType="Variable" SQLTask:SqlStatementSource="User::TraceScript" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="trace_id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ResultBinding SQLTask:ResultName="error_code" SQLTask:DtsVariableName="User::TraceErrorCode"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{717FFE6B-71FE-4F0A-B934-916A64CFA375}" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:Value="1"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{C8B2863D-73FC-49A9-A730-03681768D7A4}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Check if Trace is Running" DTS:ObjectName="Constraint 1" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{43AC0421-D367-442B-852C-1C8C10E392AE}" DTS:EvalOp="3" DTS:Expression="@[User::LoggingLevel] >= 1" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Recreate Trace" DTS:ObjectName="Constraint 2" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\Foreach Loop - Monitor Trace.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{DCF85D96-5446-432D-8CCB-976768E873D3}" DTS:From="Package\Foreach Loop - Monitor Trace\SQL - Log Package Stats" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\Foreach Loop - Monitor Trace\SQL - Log Package Iteration" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{20400B93-3704-4726-ADCC-73457B916283}" DTS:ObjectName="{20400B93-3704-4726-ADCC-73457B916283}" DTS:ValueIndex="0" DTS:VariableName="User::LoopDuration"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Close trace if running" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{22a8654c-00d2-41ea-8273-a98f925bca5a}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace if running" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceStatus INT DECLARE @TraceID INT SELECT @TraceID = id , @TraceStatus = status FROM sys.traces WHERE [path] LIKE ? + N'%.trc' AND is_default=0 IF NOT @TraceID IS NULL BEGIN EXEC sp_trace_setstatus @TraceID, 0 EXEC sp_trace_setstatus @TraceID, 2 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Execute Trace Start Script" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Execute SQL Task" DTS:DTSID="{B5D9B002-1927-4CCA-84AE-F291C7E5F613}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Execute Trace Start Script" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStmtSourceType="Variable" SQLTask:SqlStatementSource="User::TraceScript" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="trace_id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ResultBinding SQLTask:ResultName="error_code" SQLTask:DtsVariableName="User::TraceErrorCode"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Stop Trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{B4EFD1D8-5EA4-4E54-AA01-905A01982D39}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:ISOLevel="4096" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Stop Trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{BDD785A2-1226-44DB-B2B4-9D4AFF9CCB3A}" SQLTask:SqlStatementSource="DECLARE @TraceID INT SELECT @TraceID = ? IF EXISTS (SELECT id FROM sys.traces WHERE id = @TraceID AND is_default = 0) BEGIN EXEC sp_trace_setstatus @TraceID, 0 END ">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\TRC - Generate Trace Start Script" DTS:CreationName="Microsoft.TraceStartScriptTask" DTS:DelayValidation="True" DTS:Description="Trace Start Script" DTS:DTSID="{A1508E93-DDD6-4E3D-BE78-46B59503E7AF}" DTS:ExecutableType="Microsoft.TraceStartScriptTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="TRC - Generate Trace Start Script" DTS:TaskContact="Trace Start Script Task;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:TransactionOption="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
<DTS:PropertyExpression DTS:Name="InputParameters">@[User::InputParameters]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="TraceFileLocation">@[User::TraceLocation]</DTS:PropertyExpression>
-<DTS:ObjectData>
-<TraceStartScriptTask>
<InputParameters><?xml version="1.0" encoding="utf-8"?><ns:SqlTraceCollector xmlns:ns="DataCollectorType" normalize_sql="0" normalize_plans="0" normalize_procedures="0" normalize_connections="0" normalize_default="1"><Events><EventType id ="6" name="Performance"><Event id="58" name="Auto Stats" /><Event id="165" name="Performance statistics" /><Event id="146" name="Showplan XML Statistics Profile" /></EventType><EventType id="13" name="TSQL"><Event id="12" name="SQL:BatchCompleted" columnslist="1, 3, 9, 10, 13, 16, 17, 18" /><Event id="13" name="SQL:BatchStarting" /><Event id="41" name="SQL:StmtCompleted" /><Event id="166" name="SQL:StmtRecompile" /></EventType><EventType id="20" name="CLR"><Event id="196" name="Assembly Load" /></EventType><EventType id="1" name="Cursors"><Event id="53" name="CursorOpen" /><Event id="75" name="CursorRecompile" /><Event id="76" name="CursorImplicitConversion" /><Event id="78" name="CursorClose" /></EventType></Events><Filters><Filter columnid="13" columnname="Duration" logical_operator="AND" comparison_operator="GE" value="1000L"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="LIKE" value="Data Collector"/><Filter columnid="10" columnname="ApplicationName" logical_operator="AND" comparison_operator="EQ" value="NULL"/><Filter columnid="18" columnname="CPU" logical_operator="AND" comparison_operator="EQ" value="20"/><Filter columnid="14" columnname="StartTime" logical_operator="AND" comparison_operator="GT" value="2007-02-09 13:40:00"/></Filters></ns:SqlTraceCollector></InputParameters>
<TraceFileLocation>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_ALEN-PC.MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0</TraceFileLocation>
<MaxFileSize>10</MaxFileSize>
<MaxNumberOfFiles>10</MaxNumberOfFiles>
<Destination>TraceScript</Destination>
</TraceStartScriptTask>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{0AA76CCC-2FE2-4634-B3D2-A667800C2970}" DTS:From="Package\SQL - Close trace if running" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SQL - Execute Trace Start Script"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{173BDAB9-B91C-41D7-900D-9983E6C67B72}" DTS:EvalOp="3" DTS:Expression="@[User::TraceID] > 0" DTS:From="Package\SQL - Execute Trace Start Script" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\Foreach Loop - Monitor Trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{CDB85B45-DF66-4F48-9171-B6E4D3CC1A2D}" DTS:From="Package\Foreach Loop - Monitor Trace" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Stop Trace" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{2D5D63DF-D075-4A13-BFA3-A73ECE38EB69}" DTS:From="Package\TRC - Generate Trace Start Script" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\SQL - Close trace if running"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


Package

Package: SqlTraceUpload

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 3/6/2007 4:18:14 PM
CreationName | Microsoft.Package
CreatorComputerName |
CreatorName |
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | True
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {F389A8E6-5A17-4056-ABFD-C8B823F2092E}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.1.23
LocaleID | English (United States)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 0
Name | SqlTraceUpload
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | sql:Data Collector\SqlTraceUpload
PackagePath | Data Collector\SqlTraceUpload
PackagePriorityClass | Default
PackageServerName | ALEN-PC\SQLSERVER2016
PackageStorageType | MsSql
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | Data Collector
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 219
VersionComments |
VersionGUID | {2B249201-CD59-40B8-97CA-C7FD482FE09C}
VersionMajor | 10
VersionMinor | 0

Collapse image Configuration settings

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
TargetConnectionString |

Collapse image Connection managers

Name | Description
ConfigConnection | Connection used to get information about collection configuration and for logging purposes.
MdwConnection | Connection used to upload collected data to a warehouse.
TargetConnection | Connection used to get information from the monitored (target) instance.

Collapse image Executables

Name | Description
For Loop Container | For Loop Container
SEQ - Default trace upload | Sequence Container
SQL - Close trace | Execute SQL Task
SQL - Get last upload time | Execute SQL Task
SQL - Get snapshot id | Execute SQL Task
SQL - Get trace info | Execute SQL Task
SQL - Update data source | Execute SQL Task
XML - Check use_default attribute | XML Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 3 |
Constraint 5 |
Constraint 6 |
Constraint 8 |

Collapse image User defined variables

Name | Description
CacheDirectory |
CacheWindow |
CollectionSetUID |
CollectorTypeUID |
ConfigConnectionString |
Counter |
DaysUntilExpiration |
ExitEventName |
InputParameters |
InstanceID |
InstanceName |
ItemID |
LoggingLevel |
LogID |
LoopEventName |
MDWConnectionString |
ParentLogID |
RowCountIn |
SnapshotID |
SourceID |
TargetConnectionString |
TraceCurrentEventTime |
TraceCurrentFile |
TraceDroppedEventCount |
TraceID |
TraceInfoID |
TraceIsRunning |
TraceLastEventSequence |
TraceLocation |
TraceStartTime |
TraceUseDefault |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 153063
VariablePath | \Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats.Variables[User::LoopDuration]


Package element

Package element: LoopDuration

Collapse image Properties

Name | Value
CreationName |
DataType | Int32
Description |
EvaluateAsExpression | True
Expression | DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )
IncludeInDebugDump | False
Name | LoopDuration
Namespace | User
QualifiedName | User::LoopDuration
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value | 154036
VariablePath | \Package\SEQ - Default trace upload\SQL - Log package stats.Variables[User::LoopDuration]


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="3/6/2007 4:18:14 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="" DTS:CreatorName="" DTS:DTSID="{F389A8E6-5A17-4056-ABFD-C8B823F2092E}" DTS:EnableConfig="True" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="13.0.1601.5" DTS:LocaleID="1033" DTS:MaxErrorCount="0" DTS:ObjectName="SqlTraceUpload" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="219" DTS:VersionGUID="{A499A803-D7EA-4A7A-96DB-FAE436A608C3}" DTS:VersionMajor="10">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[ConfigConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information about collection configuration and for logging purposes." DTS:DTSID="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" DTS:ObjectName="ConfigConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::ConfigConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=(local);Initial Catalog=msdb;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[MdwConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to upload collected data to a warehouse." DTS:DTSID="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" DTS:ObjectName="MdwConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::MDWConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Initial Catalog=myMDW;Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[TargetConnection]" DTS:CreationName="OLEDB" DTS:Description="Connection used to get information from the monitored (target) instance." DTS:DTSID="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" DTS:ObjectName="TargetConnection">
<DTS:PropertyExpression DTS:Name="ConnectionString">@[User::TargetConnectionString]</DTS:PropertyExpression>
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:Retain="True" DTS:ConnectionString="Data Source=(local);Provider=SQLNCLI11;Integrated Security=SSPI;APP=SQL Server Data Collector;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:Configurations>
<DTS:Configuration DTS:ConfigurationString="User::CacheDirectory" DTS:ConfigurationVariable="\Package.Variables[User::CacheDirectory].Properties[Value]" DTS:CreationName="" DTS:DTSID="{C32CCDDF-1CB6-4E64-806E-193762452CA6}" DTS:ObjectName="CacheDirectory"/>
<DTS:Configuration DTS:ConfigurationString="User::CacheWindow" DTS:ConfigurationVariable="\Package.Variables[User::CacheWindow].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5A111CDB-34FB-47A2-8307-96D7C3BB49CA}" DTS:ObjectName="CacheWindow"/>
<DTS:Configuration DTS:ConfigurationString="User::InputParameters" DTS:ConfigurationVariable="\Package.Variables[User::InputParameters].Properties[Value]" DTS:CreationName="" DTS:DTSID="{AC2982C3-5B39-4514-B50D-092C15857C1F}" DTS:ObjectName="InputParameters"/>
<DTS:Configuration DTS:ConfigurationString="User::MDWConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::MDWConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3B823989-622C-484E-A927-E0C211588865}" DTS:ObjectName="MDWConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::ConfigConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::ConfigConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{BD6C4FE9-3BCB-447C-A897-0DA27695E684}" DTS:ObjectName="ConfigConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::TargetConnectionString" DTS:ConfigurationVariable="\Package.Variables[User::TargetConnectionString].Properties[Value]" DTS:CreationName="" DTS:DTSID="{7A1F3609-4C0F-4BFA-A979-4AF89D61F160}" DTS:ObjectName="TargetConnectionString"/>
<DTS:Configuration DTS:ConfigurationString="User::LoopEventName" DTS:ConfigurationVariable="\Package.Variables[User::LoopEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{5C370D78-5CD2-427F-B461-BF36DDAFF7F6}" DTS:ObjectName="LoopEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::ExitEventName" DTS:ConfigurationVariable="\Package.Variables[User::ExitEventName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8EDCACD7-00DF-40EC-A8C0-B24F1E7D926B}" DTS:ObjectName="ExitEventName"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectorTypeUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectorTypeUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{EDC66214-7B5A-479C-9F8A-4F1A3DE80C93}" DTS:ObjectName="CollectorTypeUID"/>
<DTS:Configuration DTS:ConfigurationString="User::CollectionSetUID" DTS:ConfigurationVariable="\Package.Variables[User::CollectionSetUID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FF327F2E-CCC8-4F10-A2D0-38603D037E2C}" DTS:ObjectName="CollectionSetUID"/>
<DTS:Configuration DTS:ConfigurationString="User::ItemID" DTS:ConfigurationVariable="\Package.Variables[User::ItemID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{01BD5F34-840B-4D65-8BF9-969DAE6CF738}" DTS:ObjectName="ItemID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceID" DTS:ConfigurationVariable="\Package.Variables[User::InstanceID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{FD17D526-ED20-412C-8410-FA25A5F46BAC}" DTS:ObjectName="InstanceID"/>
<DTS:Configuration DTS:ConfigurationString="User::InstanceName" DTS:ConfigurationVariable="\Package.Variables[User::InstanceName].Properties[Value]" DTS:CreationName="" DTS:DTSID="{D3DD404F-F408-420C-A9EA-A20AAB672DBB}" DTS:ObjectName="InstanceName"/>
<DTS:Configuration DTS:ConfigurationString="User::LoggingLevel" DTS:ConfigurationVariable="\Package.Variables[User::LoggingLevel].Properties[Value]" DTS:CreationName="" DTS:DTSID="{3F16CD83-89C9-4318-A8AD-16A99DB6A766}" DTS:ObjectName="LoggingLevel"/>
<DTS:Configuration DTS:ConfigurationString="User::LogID" DTS:ConfigurationVariable="\Package.Variables[User::LogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{B4A38B6C-953A-42F8-8BF4-56631E8D7614}" DTS:ObjectName="LogID"/>
<DTS:Configuration DTS:ConfigurationString="User::ParentLogID" DTS:ConfigurationVariable="\Package.Variables[User::ParentLogID].Properties[Value]" DTS:CreationName="" DTS:DTSID="{8406BEC6-5D17-457B-BD92-714F0CF97EB5}" DTS:ObjectName="ParentLogID"/>
<DTS:Configuration DTS:ConfigurationString="User::DaysUntilExpiration" DTS:ConfigurationVariable="\Package.Variables[User::DaysUntilExpiration].Properties[Value]" DTS:CreationName="" DTS:DTSID="{6F51BB50-9D79-4BA5-A519-6EF540C17B67}" DTS:ObjectName="DaysUntilExpiration"/>
</DTS:Configurations>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E34CB8FD-CBD7-4A2E-B4E0-738BC079307C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CacheDirectory">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9251F22F-29AD-41BA-B38F-E50534BD4E12}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="CacheWindow">
<DTS:VariableValue DTS:DataType="3">1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{55DA9900-29F0-48FE-B856-2F7CAACA67E1}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectionSetUID">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{BDB5BAD1-EF93-4D54-9722-7994B328EB88}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="CollectorTypeUID">
<DTS:VariableValue DTS:DataType="8">{0E218CF8-ECB5-417B-B533-D851C0251271}</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D803253-0D98-4C29-90AE-84E720B07657}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ConfigConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=msdb;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8934324A-007D-49FB-A1FF-F92608513E4D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="Counter">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1EF6EE6B-FED9-4B60-8FC3-05A59E7667B0}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="DaysUntilExpiration">
<DTS:VariableValue DTS:DataType="2">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{1FC5CE71-C336-452D-8E10-BFAE5569C2CE}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="ExitEventName">
<DTS:VariableValue DTS:DataType="8">EXITEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{C2B0D6E3-585D-4357-9C80-12E7B8000299}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InputParameters">
<DTS:VariableValue DTS:DataType="8"><ns:SqlTraceCollector xmlns:ns="DataCollectorType" use_default="1"><Events/><Filters/></ns:SqlTraceCollector></DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9E6FBB1C-469F-44CC-839D-A0B5EE84CEF4}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceID">
<DTS:VariableValue DTS:DataType="8">MSSQL.1</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8BFB15C6-3D9A-4C4D-B1F4-B4EBF49B8D65}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="InstanceName">
<DTS:VariableValue DTS:DataType="8">MSSQLSERVER</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{43E08441-AEAE-4004-87B5-B11D2507FCF6}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ItemID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B7F59CF4-A8A0-4E82-93A0-E52E8E859904}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LoggingLevel">
<DTS:VariableValue DTS:DataType="3">2</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E466E841-5C40-48CB-8CFC-E678F9967C80}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="LogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{049D5A2B-A19C-4F1B-8036-0392BC42CE3A}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopEventName">
<DTS:VariableValue DTS:DataType="8">LOOPEVENT</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{A6803296-75B6-41BC-B261-1EA8C279A888}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MDWConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;Initial Catalog=myMDW;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F21C218D-AA71-457B-99D0-CE63B7012CA4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="ParentLogID">
<DTS:VariableValue DTS:DataType="20">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{59D1463F-2A4E-4399-BFE9-814648EBDB91}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B649CEEE-C1E3-4434-A3BC-86FC468A9EDD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SnapshotID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{9D4E5F6C-F05E-42AD-8E32-8D215CBC25DD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="SourceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D48AFDE-B6ED-4AD2-A721-030A19BBB2BB}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TargetConnectionString">
<DTS:VariableValue DTS:DataType="8">Provider=SQLNCLI11;Data Source=(local);Integrated Security=SSPI;APP=SQL Server Data Collector</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{5D57E938-0D8F-4C71-959A-C20D0BAD5C09}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceCurrentEventTime">
<DTS:VariableValue DTS:DataType="8">2007-03-13 14:28:51.820</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{72FDA754-43D5-4AAC-930C-6074C64CE825}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceCurrentFile">
<DTS:VariableValue DTS:DataType="8">C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7B00BCC4-67F6-4480-8034-2836E0929FE8}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceDroppedEventCount">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{00FC8CA7-8D41-4099-9A78-865E9CB964A4}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E9DB8444-2521-4213-8DDE-2F19885D8E74}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceInfoID">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{39F34FBD-911E-4F15-847D-577DC76049CA}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="TraceIsRunning">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{0D1478BA-31B7-42AD-8762-50342593C49C}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLastEventSequence">
<DTS:VariableValue DTS:DataType="8">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{7C0FFEA0-C638-49F3-AA0D-9DCA4A372559}" DTS:EvaluateAsExpression="True" DTS:Expression="@[User::CacheDirectory] + "\\DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLocation">
<DTS:VariableValue DTS:DataType="8">\DC_Trace_ALEN-PC.MSSQL.1..0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{E5277DAE-C666-41F7-B34E-3B58DC087855}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceStartTime">
<DTS:VariableValue DTS:DataType="8">2007-03-13 14:24:40.000</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{8F4EF19C-F61E-4CEE-BE5A-A73B4EA5A710}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceUseDefault">
<DTS:VariableValue DTS:DataType="8">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container" DTS:AssignExpression="@Counter = @Counter + 1" DTS:CreationName="STOCK:FORLOOP" DTS:Description="For Loop Container" DTS:DTSID="{ECC401D1-FE83-46E6-AD37-0E1F711F0C62}" DTS:EvalExpression="@Counter < 2" DTS:ExecutableType="STOCK:FORLOOP" DTS:InitExpression="@Counter = 0" DTS:LocaleID="-1" DTS:MaxConcurrent="1" DTS:ObjectName="For Loop Container">
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload" DTS:CreationName="STOCK:FOREACHLOOP" DTS:Description="Foreach Loop Container" DTS:DTSID="{26A8C112-8CCB-4C21-BADC-77E438246248}" DTS:ExecutableType="STOCK:FOREACHLOOP" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FEF - For each trace file - regular trace upload">
-<DTS:ForEachEnumerator DTS:CreationName="Microsoft.ForEachFileEnumerator" DTS:DTSID="{821B0536-E431-458F-8EAE-028BE667F142}" DTS:ObjectName="{821B0536-E431-458F-8EAE-028BE667F142}">
<DTS:PropertyExpression DTS:Name="Directory">@[User::CacheDirectory]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="FileSpec">"DC_Trace_" + @[System::MachineName] + "." + @[User::InstanceID] + "." + @[User::CollectionSetUID] + "." + (DT_WSTR, 5) @[User::ItemID] + "*.trc"</DTS:PropertyExpression>
-<DTS:ObjectData>
-<ForEachFileEnumeratorProperties>
<FEFEProperty Folder=""/>
<FEFEProperty FileSpec="DC_Trace_ALEN-PC.MSSQL.1..0*.trc"/>
<FEFEProperty FileNameRetrievalType="0"/>
<FEFEProperty Recurse="0"/>
</ForEachFileEnumeratorProperties>
</DTS:ObjectData>
</DTS:ForEachEnumerator>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3D6F8AD1-3C96-4920-B28C-F360CA77AEFD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{3ED87BA4-E9D0-4FC4-A1A1-47A19C6EDF3B}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{491029A7-AEDE-4DAC-B07E-7C134EF63963}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{96A9329D-379F-466F-970B-4A97A3FCF7A1}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload trace file">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{76E0DEBC-BF6A-45D2-A30B-EB6746BEB47B}" DTS:EvaluateAsExpression="True" DTS:Expression=""SELECT [TextData], [BinaryData], [DatabaseID], [TransactionID], [LineNumber], [NTUserName], [NTDomainName], [HostName], [ClientProcessID], [ApplicationName], [LoginName], [SPID], [Duration], [StartTime], [EndTime], [Reads], [Writes], [CPU], [Permissions], [Severity], [EventSubClass], [ObjectID], [Success], [IndexID], [IntegerData], [ServerName], [EventClass], [ObjectType], [NestLevel], [State], [Error], [Mode], [Handle], [ObjectName], [DatabaseName], [FileName], [OwnerName], [RoleName], [TargetUserName], [DBUserName], [LoginSid], [TargetLoginName], [TargetLoginSid], [ColumnPermissions], [LinkedServerName], [ProviderName], [MethodName], [RowCounts], [RequestID], [XactSequence], [EventSequence], [BigintData1], [BigintData2], [GUID], [IntegerData2], [ObjectID2], [Type], [OwnerID], [ParentName], [IsSystem], [Offset], [SourceDatabaseID], [SqlHandle], [SessionLoginName], [PlanHandle] , [GroupID] FROM ::fn_trace_gettable(N'" + @[User::TraceCurrentFile] + "', 1) WHERE [EventSequence] > " + @[User::TraceLastEventSequence]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLoadScript">
<DTS:VariableValue DTS:DataType="8">SELECT
[TextData],
[BinaryData],
[DatabaseID],
[TransactionID],
[LineNumber],
[NTUserName],
[NTDomainName],
[HostName],
[ClientProcessID],
[ApplicationName],
[LoginName],
[SPID],
[Duration],
[StartTime],
[EndTime],
[Reads],
[Writes],
[CPU],
[Permissions],
[Severity],
[EventSubClass],
[ObjectID],
[Success],
[IndexID],
[IntegerData],
[ServerName],
[EventClass],
[ObjectType],
[NestLevel],
[State],
[Error],
[Mode],
[Handle],
[ObjectName],
[DatabaseName],
[FileName],
[OwnerName],
[RoleName],
[TargetUserName],
[DBUserName],
[LoginSid],
[TargetLoginName],
[TargetLoginSid],
[ColumnPermissions],
[LinkedServerName],
[ProviderName],
[MethodName],
[RowCounts],
[RequestID],
[XactSequence],
[EventSequence],
[BigintData1],
[BigintData2],
[GUID],
[IntegerData2],
[ObjectID2],
[Type],
[OwnerID],
[ParentName],
[IsSystem],
[Offset],
[SourceDatabaseID],
[SqlHandle],
[SessionLoginName],
[PlanHandle]
, [GroupID] FROM
::fn_trace_gettable(N'C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc', 1)
WHERE
[EventSequence] > 0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence" componentClassID="Microsoft.Aggregate" contactInfo="Aggregate;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;3" description="Aggregates and groups values in a dataset." name="AGG - Get max value of EventSequence" version="3">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
<property dataType="System.Int32" description="Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used." name="CountDistinctScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence." name="CountDistinctKeys"/>
<property dataType="System.Int32" description="Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100." name="AutoExtendFactor">25</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Aggregate Input 1">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]" name="Aggregate Output 1">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
</properties>
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" name="EventSequence_Max">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">7</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" dataType="ui8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" name="event_count">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\0:invalid}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">2</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count source">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Output row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion" componentClassID="Microsoft.DataConvert" contactInfo="Data Conversion;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Data Conversion" name="Data Conversion" usesDispositions="true">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]" name="Data Conversion Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input].Columns[SqlHandle]" cachedDataType="image" cachedName="SqlHandle" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input].Columns[PlanHandle]" cachedDataType="image" cachedName="PlanHandle" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output]" exclusionGroup="1" name="Data Conversion Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" name="SqlHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" name="PlanHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output]" exclusionGroup="1" isErrorOut="true" name="Data Conversion Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add columns" usesDispositions="true">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input].Columns[EventSequence_Max]" cachedDataType="i8" cachedName="EventSequence_Max" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" name="is_running" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceIsRunning]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceIsRunning]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" name="dropped_event_count" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceDroppedEventCount]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceDroppedEventCount]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" name="last_event_sequence" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}) ? 0 : #{Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(EventSequence_Max) ? 0 : EventSequence_Max</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id and trace_info_id" usesDispositions="true" validateExternalMetadata="False">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@SnapshotID</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLT - Split two ways">
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Multicast Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODB - Read trace" usesDispositions="true" validateExternalMetadata="False" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::TraceLoadScript</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" dataType="nText" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" name="TextData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" name="BinaryData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" name="DatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" name="TransactionID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" name="LineNumber" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" name="NTUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" name="NTDomainName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" name="HostName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" name="ClientProcessID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" name="ApplicationName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" name="LoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" name="SPID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" name="Duration" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" name="StartTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" name="EndTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" name="Reads" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" name="Writes" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" name="CPU" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" name="Permissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" name="Severity" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" name="EventSubClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" name="ObjectID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" name="Success" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" name="IndexID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" name="IntegerData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" name="ServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" name="EventClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" name="ObjectType" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" name="NestLevel" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" name="State" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" name="Error" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" name="Mode" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" name="Handle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" name="ObjectName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" name="DatabaseName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" name="FileName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" name="OwnerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" name="RoleName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" name="TargetUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" name="DBUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" name="LoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" name="TargetLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" name="TargetLoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" name="ColumnPermissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" name="LinkedServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" name="ProviderName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" name="MethodName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" name="RowCounts" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" name="RequestID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" name="XactSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" name="EventSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" name="BigintData1" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" name="BigintData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" dataType="guid" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" name="GUID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" name="IntegerData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" name="ObjectID2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" name="Type" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" name="OwnerID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" name="ParentName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" name="IsSystem" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" name="Offset" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" name="SourceDatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" name="SqlHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" name="SessionLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" name="PlanHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" name="GroupID" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" dataType="image" name="SqlHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" dataType="image" name="PlanHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" dataType="nText" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" name="TextData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" name="BinaryData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" name="DatabaseID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" name="TransactionID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" name="LineNumber"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" name="NTUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" name="NTDomainName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" name="HostName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" name="ClientProcessID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" name="ApplicationName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" name="LoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" name="SPID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" name="Duration"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" dataType="dbTimeStamp" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" name="StartTime"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" dataType="dbTimeStamp" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" name="EndTime"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" name="Reads"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" name="Writes"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" name="CPU"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" name="Permissions"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" name="Severity"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" name="EventSubClass"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" name="ObjectID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" name="Success"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" name="IndexID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" name="IntegerData"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" name="ServerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" name="EventClass"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" name="ObjectType"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" name="NestLevel"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" name="State"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" name="Error"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" name="Mode"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" name="Handle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" name="ObjectName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" name="DatabaseName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" name="FileName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" name="OwnerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" name="RoleName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" name="TargetUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" name="DBUserName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" name="LoginSid"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" name="TargetLoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" name="TargetLoginSid"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" name="ColumnPermissions"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" name="LinkedServerName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" name="ProviderName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" name="MethodName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" name="RowCounts"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" name="RequestID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" name="XactSequence"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" name="EventSequence"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" name="BigintData1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" name="BigintData2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" dataType="guid" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" name="GUID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" name="IntegerData2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" dataType="i8" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" name="ObjectID2"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" name="Type"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" name="OwnerID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" name="ParentName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" name="IsSystem"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" name="Offset"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" name="SourceDatabaseID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" name="SqlHandle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" dataType="wstr" length="256" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" name="SessionLoginName"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" dataType="image" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" name="PlanHandle"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" name="GroupID"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODB - Update trace_info" usesDispositions="true" version="2">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">{call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[is_running]" cachedDataType="i4" cachedName="is_running" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[event_count]" cachedDataType="ui8" cachedName="event_count" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[dropped_event_count]" cachedDataType="i4" cachedName="dropped_event_count" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[last_event_sequence]" cachedDataType="i8" cachedName="last_event_sequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" dataType="i4" name="@trace_info_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" dataType="i4" name="@snapshot_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" dataType="bool" name="@is_running">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" dataType="i8" name="@event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" dataType="i4" name="@dropped_event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" dataType="i8" name="@last_event_sequence">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Write to output table" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[trace_data]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>
</properties>
-<connections>
<connection refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TextData]" cachedDataType="nText" cachedName="TextData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BinaryData]" cachedDataType="image" cachedName="BinaryData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseID]" cachedDataType="i4" cachedName="DatabaseID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TransactionID]" cachedDataType="i8" cachedName="TransactionID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LineNumber]" cachedDataType="i4" cachedName="LineNumber" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTUserName]" cachedDataType="wstr" cachedLength="256" cachedName="NTUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTDomainName]" cachedDataType="wstr" cachedLength="256" cachedName="NTDomainName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[HostName]" cachedDataType="wstr" cachedLength="256" cachedName="HostName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ClientProcessID]" cachedDataType="i4" cachedName="ClientProcessID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ApplicationName]" cachedDataType="wstr" cachedLength="256" cachedName="ApplicationName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginName]" cachedDataType="wstr" cachedLength="256" cachedName="LoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SPID]" cachedDataType="i4" cachedName="SPID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Duration]" cachedDataType="i8" cachedName="Duration" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[StartTime]" cachedDataType="dbTimeStamp" cachedName="StartTime" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EndTime]" cachedDataType="dbTimeStamp" cachedName="EndTime" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Reads]" cachedDataType="i8" cachedName="Reads" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Writes]" cachedDataType="i8" cachedName="Writes" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[CPU]" cachedDataType="i4" cachedName="CPU" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Permissions]" cachedDataType="i8" cachedName="Permissions" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Severity]" cachedDataType="i4" cachedName="Severity" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSubClass]" cachedDataType="i4" cachedName="EventSubClass" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID]" cachedDataType="i4" cachedName="ObjectID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Success]" cachedDataType="i4" cachedName="Success" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IndexID]" cachedDataType="i4" cachedName="IndexID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData]" cachedDataType="i4" cachedName="IntegerData" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ServerName]" cachedDataType="wstr" cachedLength="256" cachedName="ServerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventClass]" cachedDataType="i4" cachedName="EventClass" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectType]" cachedDataType="i4" cachedName="ObjectType" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NestLevel]" cachedDataType="i4" cachedName="NestLevel" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[State]" cachedDataType="i4" cachedName="State" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Error]" cachedDataType="i4" cachedName="Error" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Mode]" cachedDataType="i4" cachedName="Mode" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Handle]" cachedDataType="i4" cachedName="Handle" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectName]" cachedDataType="wstr" cachedLength="256" cachedName="ObjectName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseName]" cachedDataType="wstr" cachedLength="256" cachedName="DatabaseName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[FileName]" cachedDataType="wstr" cachedLength="256" cachedName="FileName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerName]" cachedDataType="wstr" cachedLength="256" cachedName="OwnerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RoleName]" cachedDataType="wstr" cachedLength="256" cachedName="RoleName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetUserName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DBUserName]" cachedDataType="wstr" cachedLength="256" cachedName="DBUserName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginSid]" cachedDataType="image" cachedName="LoginSid" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetLoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginSid]" cachedDataType="image" cachedName="TargetLoginSid" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ColumnPermissions]" cachedDataType="i4" cachedName="ColumnPermissions" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LinkedServerName]" cachedDataType="wstr" cachedLength="256" cachedName="LinkedServerName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ProviderName]" cachedDataType="wstr" cachedLength="256" cachedName="ProviderName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[MethodName]" cachedDataType="wstr" cachedLength="256" cachedName="MethodName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RowCounts]" cachedDataType="i8" cachedName="RowCounts" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RequestID]" cachedDataType="i4" cachedName="RequestID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[XactSequence]" cachedDataType="i8" cachedName="XactSequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData1]" cachedDataType="i8" cachedName="BigintData1" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData2]" cachedDataType="i8" cachedName="BigintData2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GUID]" cachedDataType="guid" cachedName="GUID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData2]" cachedDataType="i4" cachedName="IntegerData2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID2]" cachedDataType="i8" cachedName="ObjectID2" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Type]" cachedDataType="i4" cachedName="Type" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerID]" cachedDataType="i4" cachedName="OwnerID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ParentName]" cachedDataType="wstr" cachedLength="256" cachedName="ParentName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IsSystem]" cachedDataType="i4" cachedName="IsSystem" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Offset]" cachedDataType="i4" cachedName="Offset" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SourceDatabaseID]" cachedDataType="i4" cachedName="SourceDatabaseID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SessionLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="SessionLoginName" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GroupID]" cachedDataType="i4" cachedName="GroupID" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SqlHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="SqlHandle64" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]"/>
<inputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[PlanHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="PlanHandle64" externalMetadataColumnId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" dataType="i4" name="trace_info_id"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" dataType="bytes" length="64" name="SqlHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" dataType="bytes" length="64" name="PlanHandle"/>
<externalMetadataColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Aggregate Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Inputs[Derived Column Input]" name="Aggregate Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Data Conversion Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Inputs[Row Count Input 1]" name="Data Conversion Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Outputs[Data Conversion Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Derived Column Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\Data Conversion.Inputs[Data Conversion Input]" name="Derived Column Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Derived Column Output1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" name="Derived Column Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add columns.Outputs[Derived Column Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Multicast Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" name="Multicast Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Multicast Output 2]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Multicast Output 2" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Outputs[Multicast Output 2]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[OLE DB Source Error Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Error row count source.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[OLE DB Source Output]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Read trace.Outputs[OLE DB Source Output]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Row Count Output 1]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Output row count.Outputs[Row Count Output 1]"/>
<path refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file.Paths[Row Count Output 11]" endId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Row Count Output 1" startId="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible" DTS:CreationName="Microsoft.FileAccessTask" DTS:DelayValidation="True" DTS:Description="File Access Task" DTS:DTSID="{679134AC-EFFB-4A28-B2C2-4247D71FEE23}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Check if trace file is accessible" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::TraceCurrentFile]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">6</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>6</Mode>
<FilePath>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Precheck if trace file is accessible" DTS:CreationName="Microsoft.FileAccessTask" DTS:Description="File Access Task" DTS:DTSID="{BCAA70EC-FD75-4E75-9698-7459FF0FB8BB}" DTS:ExecutableType="Microsoft.FileAccessTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FAT - Precheck if trace file is accessible" DTS:TaskContact="File Access;Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
<DTS:PropertyExpression DTS:Name="FilePath">@[User::TraceCurrentFile]</DTS:PropertyExpression>
<DTS:PropertyExpression DTS:Name="Mode">4</DTS:PropertyExpression>
-<DTS:ObjectData>
-<FileAccessTask>
<Mode>4</Mode>
<FilePath>C:\Users\macies\AppData\Local\Temp\ecodedc\DC_Trace_MSSQL.1.f37780d4-fea7-4271-90b2-fa553ad4ca91.0_1.trc</FilePath>
</FileAccessTask>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file" DTS:CreationName="Microsoft.FileSystemTask" DTS:DelayValidation="True" DTS:Description="File System Task" DTS:DTSID="{5EE7C74E-CD4E-40E2-8D32-7475CF6457B1}" DTS:ExecutableType="Microsoft.FileSystemTask" DTS:ForceExecutionResult="0" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="FST - Delete trace file" DTS:TaskContact="File System Task;Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">2,7,OnError,9,OnWarning</DTS:Property>
-<DTS:Property DTS:EventName="OnError" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:Property DTS:EventName="OnWarning" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
</DTS:LoggingOptions>
-<DTS:EventHandlers>
-<DTS:EventHandler DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file.EventHandlers[OnError]" DTS:CreationName="OnError" DTS:DTSID="{582131DF-655C-41F3-B0E7-5D7E8FDBB56F}" DTS:EventID="-454761244" DTS:EventName="OnError" DTS:LocaleID="-1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:Description="The propagate property of the event" DTS:DTSID="{6C9DBDD1-7561-4A92-87F2-521B9881BB19}" DTS:Expression="@[System::ErrorCode] != -1073548540" DTS:IncludeInDebugDump="6789" DTS:Namespace="System" DTS:ObjectName="Propagate">
<DTS:VariableValue DTS:DataType="11">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:Executables/>
</DTS:EventHandler>
</DTS:EventHandlers>
-<DTS:ObjectData>
<FileSystemData TaskOperationType="DeleteFile" TaskSourcePath="User::TraceCurrentFile" TaskIsSourceVariable="True"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Logs statistics about the most recent Data Flow Task" DTS:DTSID="{7FE278CC-D8C4-4CCD-B884-D4FD9790D5A0}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log package stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="3">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{B2278345-853A-4BC7-BC04-346F236BE117}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">155850</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - logs uploaded file name" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="SQL - logs uploaded file name" DTS:DTSID="{36601F9F-22D5-41EB-AC7D-0CBF2756CC8C}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:ObjectName="SQL - logs uploaded file name" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call dbo.sp_ssis_addlogentry (N'UploadTraceFile',?, ?, ?, ?, ?, ?, ?, 0, 0x00, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::UserName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::PackageName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="System::PackageID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="System::ExecutionInstanceGUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="System::StartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="7" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="6" SQLTask:DtsVariableName="System::StartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="7" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="7" SQLTask:DtsVariableName="User::TraceCurrentFile" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{4184AC42-F94B-469C-A49E-EE793CB1D245}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{41B4AC86-833E-417B-A00D-2259D0C87E35}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] >= 1" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - Log package stats" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{0957B7CD-F748-44F6-BD2F-9A5B335C4F16}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Check if trace file is accessible" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{A52A42F1-5767-464E-AEBC-F8FB69B7BAC4}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] > 1" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FST - Delete trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\SQL - logs uploaded file name" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container\FEF - For each trace file - regular trace upload.PrecedenceConstraints[Constraint 4]" DTS:CreationName="" DTS:DTSID="{1963E80B-FFFB-425B-AEF5-0F6F5BE8FFA2}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload\FAT - Precheck if trace file is accessible" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 4" DTS:To="Package\For Loop Container\FEF - For each trace file - regular trace upload\DFT - Upload trace file"/>
</DTS:PrecedenceConstraints>
-<DTS:ForEachVariableMappings>
<DTS:ForEachVariableMapping DTS:CreationName="" DTS:DTSID="{2FE5FF29-A973-47A2-AAF5-B529588DB38B}" DTS:ObjectName="{2FE5FF29-A973-47A2-AAF5-B529588DB38B}" DTS:ValueIndex="0" DTS:VariableName="User::TraceCurrentFile"/>
</DTS:ForEachVariableMappings>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Check trace info" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{782c9195-15b2-4260-bff9-6d85b486e50f}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Check trace info" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="DECLARE @status INT SET @status = 2 SELECT @status = CASE t.status WHEN 1 THEN 1 ELSE 0 END FROM sys.traces t WHERE t.path LIKE (? + N'%.trc') SELECT @status" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="0" SQLTask:DtsVariableName="User::TraceIsRunning"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Close trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{0b304887-a5f5-48be-a81e-48ab362bfe41}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" SQLTask:SqlStatementSource="{ call [sp_trace_setstatus] (?, 2) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{1fe772eb-42ae-4641-af91-138c98b8fcba}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get Last_Event_Sequence" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="DECLARE @lastEventSequence BIGINT SET @lastEventSequence = -1 SELECT @lastEventSequence = [last_event_sequence] FROM [snapshots].[trace_info] WHERE [trace_info_id] = ? SELECT @lastEventSequence" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="0" SQLTask:DtsVariableName="User::TraceLastEventSequence"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceInfoID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{3392402A-8EDF-40CA-B868-CE800491C3A4}" DTS:From="Package\For Loop Container\FEF - For each trace file - regular trace upload" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{77861B0E-1726-4FE2-BEC6-4CAB5CEE2AFA}" DTS:EvalOp="3" DTS:Expression="@[User::TraceIsRunning] == 0" DTS:From="Package\For Loop Container\SQL - Check trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\For Loop Container\SQL - Close trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package\For Loop Container.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{0B57ACB1-DDFE-4E1F-909A-36BF193C6D15}" DTS:From="Package\For Loop Container\SQL - Get Last_Event_Sequence" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\For Loop Container\SQL - Check trace info"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload" DTS:CreationName="STOCK:SEQUENCE" DTS:DelayValidation="True" DTS:Description="Sequence Container" DTS:DTSID="{38B4A79F-D07D-418D-BA5A-2AF603D6620F}" DTS:ExecutableType="STOCK:SEQUENCE" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SEQ - Default trace upload">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{AD706893-04C6-4F6A-851B-6E8961A23D59}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountError">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{CCB242CF-14BC-4978-B629-AC8BDA3637AA}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountIn">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{F61B5459-D245-44A4-8FFF-694915DE1C25}" DTS:IncludeInDebugDump="6789" DTS:Namespace="User" DTS:ObjectName="RowCountOut">
<DTS:VariableValue DTS:DataType="3">0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload\DFT - Upload default trace file" DTS:CreationName="Microsoft.Pipeline" DTS:DelayValidation="True" DTS:Description="Data Flow Task" DTS:DTSID="{ed5bc122-e2d0-47fe-9a21-91b4d462f083}" DTS:ExecutableType="Microsoft.Pipeline" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="DFT - Upload default trace file">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{a2d94ca5-a845-4067-8951-906992367f42}" DTS:EvaluateAsExpression="True" DTS:Expression=""DECLARE @trace_file_name nvarchar(512) SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1 SELECT [TextData], [BinaryData], [DatabaseID], [TransactionID], [LineNumber], [NTUserName], [NTDomainName], [HostName], [ClientProcessID], [ApplicationName], [LoginName], [SPID], [Duration], [StartTime], [EndTime], [Reads], [Writes], [CPU], [Permissions], [Severity], [EventSubClass], [ObjectID], [Success], [IndexID], [IntegerData], [ServerName], [EventClass], [ObjectType], [NestLevel], [State], [Error], [Mode], [Handle], [ObjectName], [DatabaseName], [FileName], [OwnerName], [RoleName], [TargetUserName], [DBUserName], [LoginSid], [TargetLoginName], [TargetLoginSid], [ColumnPermissions], [LinkedServerName], [ProviderName], [MethodName], [RowCounts], [RequestID], [XactSequence], [EventSequence], [BigintData1], [BigintData2], [GUID], [IntegerData2], [ObjectID2], [Type], [OwnerID], [ParentName], [IsSystem], [Offset], [SourceDatabaseID], [SqlHandle], [SessionLoginName], [PlanHandle] , [GroupID] FROM ::fn_trace_gettable(@trace_file_name, default) WHERE [EventSequence] > " + @[User::TraceLastEventSequence]" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="TraceLoadScript">
<DTS:VariableValue DTS:DataType="8">DECLARE @trace_file_name nvarchar(512)
SELECT @trace_file_name = path FROM sys.traces WHERE is_default=1
SELECT
[TextData],
[BinaryData],
[DatabaseID],
[TransactionID],
[LineNumber],
[NTUserName],
[NTDomainName],
[HostName],
[ClientProcessID],
[ApplicationName],
[LoginName],
[SPID],
[Duration],
[StartTime],
[EndTime],
[Reads],
[Writes],
[CPU],
[Permissions],
[Severity],
[EventSubClass],
[ObjectID],
[Success],
[IndexID],
[IntegerData],
[ServerName],
[EventClass],
[ObjectType],
[NestLevel],
[State],
[Error],
[Mode],
[Handle],
[ObjectName],
[DatabaseName],
[FileName],
[OwnerName],
[RoleName],
[TargetUserName],
[DBUserName],
[LoginSid],
[TargetLoginName],
[TargetLoginSid],
[ColumnPermissions],
[LinkedServerName],
[ProviderName],
[MethodName],
[RowCounts],
[RequestID],
[XactSequence],
[EventSequence],
[BigintData1],
[BigintData2],
[GUID],
[IntegerData2],
[ObjectID2],
[Type],
[OwnerID],
[ParentName],
[IsSystem],
[Offset],
[SourceDatabaseID],
[SqlHandle],
[SessionLoginName],
[PlanHandle]
, [GroupID] FROM
::fn_trace_gettable(@trace_file_name, default)
WHERE
[EventSequence] > 0</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence" componentClassID="Microsoft.Aggregate" contactInfo="Aggregate;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;3" description="Aggregates and groups values in a dataset." name="AGG - Get max value of EventSequence" version="3">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
<property dataType="System.Int32" description="Specifies the approximate number of distinct values in a column that the aggregation counts distinctly. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no CountDistinctScale value is used." name="CountDistinctScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of distinct values in a column that the aggregation counts distinctly. If a CountDistinctScale value is specified, the value in CountDistinctKeys takes precedence." name="CountDistinctKeys"/>
<property dataType="System.Int32" description="Specifies the percentage by which memory can be extended during the aggregation. Valid values are between 1 and 100." name="AutoExtendFactor">25</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Aggregate Input 1">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]" name="Aggregate Output 1">
-<properties>
<property dataType="System.Int32" description="Specifies the approximate number of group by keys that the aggregation produces. Low indicates 500,000 key values, Medium indicates 5 million key values, and High indicates more than 25 million key values. Unspecified indicates no KeyScale value is used." name="KeyScale" typeConverter="KeyScaleType">0</property>
<property dataType="System.Null" description="Specifies the exact number of group by keys that the aggregation produces. If a KeyScale value is specified, the value in Keys takes precedence." name="Keys"/>
</properties>
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]" name="EventSequence_Max">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">7</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" dataType="ui8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]" name="event_count">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the ID of the input column used in the aggregation." name="AggregationColumnId">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\0:invalid}</property>
<property dataType="System.Int32" description="Specifies the type of aggregation." name="AggregationType" typeConverter="AggregationType">2</property>
<property dataType="System.Int32" description="Indicates whether the column requires special handling because it may contain oversized data or it requires precision beyond a float data type." name="IsBig">1</property>
<property dataType="System.Int32" description="Specifies the string comparison options." name="AggregationComparisonFlags">0</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Error row count source">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountError</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Input row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountIn</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count" componentClassID="Microsoft.RowCount" contactInfo="Row Count;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Counts the rows in a dataset." name="CNT - Output row count">
-<properties>
<property dataType="System.String" description="Specifies the variable to hold the row count." name="VariableName">User::RowCountOut</property>
</properties>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]" hasSideEffects="true" name="Row Count Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Outputs[Row Count Output 1]" name="Row Count Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion" componentClassID="Microsoft.DataConvert" contactInfo="Data Conversion;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Data Conversion" name="Data Conversion" usesDispositions="true">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]" name="Data Conversion Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input].Columns[SqlHandle]" cachedDataType="image" cachedName="SqlHandle" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input].Columns[PlanHandle]" cachedDataType="image" cachedName="PlanHandle" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output]" exclusionGroup="1" name="Data Conversion Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]" name="SqlHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" dataType="bytes" errorOrTruncationOperation="Conversion" errorRowDisposition="IgnoreFailure" length="64" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]" name="PlanHandle64" truncationRowDisposition="IgnoreFailure">
-<properties>
<property containsID="true" dataType="System.Int32" description="Specifies the input column used as the source of data for the conversion." name="SourceInputColumnLineageID">#{Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]}</property>
<property dataType="System.Boolean" description="Indicates whether the column uses the faster, locale-neutral parsing routines." name="FastParse">false</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output]" exclusionGroup="1" isErrorOut="true" name="Data Conversion Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add columns" usesDispositions="true">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input].Columns[EventSequence_Max]" cachedDataType="i8" cachedName="EventSequence_Max" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]"/>
</inputColumns>
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::SnapshotID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]" name="is_running" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceIsRunning]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceIsRunning]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]" name="dropped_event_count" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceDroppedEventCount]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceDroppedEventCount]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" dataType="i8" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]" name="last_event_sequence" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">[ISNULL](#{Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}) ? 0 : #{Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[EventSequence_Max]}</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">ISNULL(EventSequence_Max) ? 0 : EventSequence_Max</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id" componentClassID="Microsoft.DerivedColumn" contactInfo="Derived Column;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Updates column values using expressions" name="DRV - Add snapshot_id and trace_info_id" usesDispositions="true" validateExternalMetadata="False">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" description="Input to the Derived Column Transformation" name="Derived Column Input">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]" description="Default Output of the Derived Column Transformation" exclusionGroup="1" name="Derived Column Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]" name="trace_info_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[User::TraceInfoID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@[User::TraceInfoID]</property>
</properties>
</outputColumn>
-<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" dataType="i4" errorOrTruncationOperation="Computation" errorRowDisposition="FailComponent" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]" name="snapshot_id" truncationRowDisposition="FailComponent">
-<properties>
<property containsID="true" dataType="System.String" description="Derived Column Expression" name="Expression">@[SnapshotID]</property>
<property containsID="true" dataType="System.String" description="Derived Column Friendly Expression" expressionType="Notify" name="FriendlyExpression">@SnapshotID</property>
</properties>
</outputColumn>
</outputColumns>
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output]" description="Error Output of the Derived Column Transformation" exclusionGroup="1" isErrorOut="true" name="Derived Column Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways" componentClassID="Microsoft.Multicast" contactInfo="Multicast;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;0" description="Creates copies of a dataset." name="MLT - Split two ways">
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Multicast Input 1">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 1]" deleteOutputOnPathDetached="true" name="Multicast Output 1" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 2]" deleteOutputOnPathDetached="true" name="Multicast Output 2" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 3]" dangling="true" deleteOutputOnPathDetached="true" name="Multicast Output 3" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]">
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="ODB - Read trace" usesDispositions="true" validateExternalMetadata="False" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset"/>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable">User::TraceLoadScript</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[TargetConnection]" connectionManagerRefId="Package.ConnectionManagers[TargetConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" dataType="nText" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]" name="TextData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]" name="BinaryData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]" name="DatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]" name="TransactionID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]" name="LineNumber" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]" name="NTUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]" name="NTDomainName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]" name="HostName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]" name="ClientProcessID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]" name="ApplicationName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]" name="LoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]" name="SPID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]" name="Duration" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]" name="StartTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]" name="EndTime" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]" name="Reads" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]" name="Writes" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]" name="CPU" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]" name="Permissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]" name="Severity" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]" name="EventSubClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]" name="ObjectID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]" name="Success" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]" name="IndexID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]" name="IntegerData" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]" name="ServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]" name="EventClass" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]" name="ObjectType" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]" name="NestLevel" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]" name="State" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]" name="Error" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]" name="Mode" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]" name="Handle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]" name="ObjectName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]" name="DatabaseName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]" name="FileName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]" name="OwnerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]" name="RoleName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]" name="TargetUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]" name="DBUserName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]" name="LoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]" name="TargetLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]" name="TargetLoginSid" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]" name="ColumnPermissions" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]" name="LinkedServerName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]" name="ProviderName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]" name="MethodName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]" name="RowCounts" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]" name="RequestID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]" name="XactSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]" name="EventSequence" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]" name="BigintData1" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]" name="BigintData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" dataType="guid" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]" name="GUID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]" name="IntegerData2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" dataType="i8" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]" name="ObjectID2" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]" name="Type" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]" name="OwnerID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]" name="ParentName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]" name="IsSystem" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]" name="Offset" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]" name="SourceDatabaseID" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SqlHandle]" name="SqlHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]" name="SessionLoginName" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" dataType="image" errorOrTruncationOperation="Conversion" errorRowDisposition="RedirectRow" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[PlanHandle]" name="PlanHandle" truncationRowDisposition="RedirectRow"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]" name="GroupID" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SqlHandle]" dataType="image" name="SqlHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[PlanHandle]" dataType="image" name="PlanHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" dataType="nText" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TextData]" name="TextData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BinaryData]" name="BinaryData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseID]" name="DatabaseID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TransactionID]" name="TransactionID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LineNumber]" name="LineNumber"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTUserName]" name="NTUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NTDomainName]" name="NTDomainName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[HostName]" name="HostName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ClientProcessID]" name="ClientProcessID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ApplicationName]" name="ApplicationName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginName]" name="LoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SPID]" name="SPID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Duration]" name="Duration"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" dataType="dbTimeStamp" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[StartTime]" name="StartTime"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" dataType="dbTimeStamp" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EndTime]" name="EndTime"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Reads]" name="Reads"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Writes]" name="Writes"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[CPU]" name="CPU"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Permissions]" name="Permissions"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Severity]" name="Severity"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSubClass]" name="EventSubClass"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID]" name="ObjectID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Success]" name="Success"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IndexID]" name="IndexID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData]" name="IntegerData"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ServerName]" name="ServerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventClass]" name="EventClass"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectType]" name="ObjectType"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[NestLevel]" name="NestLevel"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[State]" name="State"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Error]" name="Error"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Mode]" name="Mode"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Handle]" name="Handle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectName]" name="ObjectName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DatabaseName]" name="DatabaseName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[FileName]" name="FileName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerName]" name="OwnerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RoleName]" name="RoleName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetUserName]" name="TargetUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[DBUserName]" name="DBUserName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LoginSid]" name="LoginSid"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginName]" name="TargetLoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[TargetLoginSid]" name="TargetLoginSid"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ColumnPermissions]" name="ColumnPermissions"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[LinkedServerName]" name="LinkedServerName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ProviderName]" name="ProviderName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[MethodName]" name="MethodName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RowCounts]" name="RowCounts"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[RequestID]" name="RequestID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[XactSequence]" name="XactSequence"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[EventSequence]" name="EventSequence"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData1]" name="BigintData1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[BigintData2]" name="BigintData2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" dataType="guid" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GUID]" name="GUID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IntegerData2]" name="IntegerData2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" dataType="i8" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ObjectID2]" name="ObjectID2"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Type]" name="Type"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[OwnerID]" name="OwnerID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ParentName]" name="ParentName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[IsSystem]" name="IsSystem"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[Offset]" name="Offset"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SourceDatabaseID]" name="SourceDatabaseID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SqlHandle]" name="SqlHandle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" dataType="wstr" length="256" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[SessionLoginName]" name="SessionLoginName"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" dataType="image" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[PlanHandle]" name="PlanHandle"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[GroupID]" name="GroupID"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info" componentClassID="Microsoft.OLEDBCommand" contactInfo="OLE DB Command;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;2" description="Executes an SQL command for each row in a dataset." name="ODB - Update trace_info" usesDispositions="true" version="2">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="The SQL command to be executed." expressionType="Notify" name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor">{call snapshots.sp_trace_update_info(?, ?, ?, ?, ?, ?)}</property>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" errorOrTruncationOperation="Command Execution" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Command Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[is_running]" cachedDataType="i4" cachedName="is_running" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[is_running]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[event_count]" cachedDataType="ui8" cachedName="event_count" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1].Columns[event_count]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[dropped_event_count]" cachedDataType="i4" cachedName="dropped_event_count" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[dropped_event_count]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].Columns[last_event_sequence]" cachedDataType="i8" cachedName="last_event_sequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output].Columns[last_event_sequence]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@trace_info_id]" dataType="i4" name="@trace_info_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@snapshot_id]" dataType="i4" name="@snapshot_id">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@is_running]" dataType="bool" name="@is_running">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">65</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@event_count]" dataType="i8" name="@event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@dropped_event_count]" dataType="i4" name="@dropped_event_count">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
-<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input].ExternalColumns[@last_event_sequence]" dataType="i8" name="@last_event_sequence">
-<properties>
<property dataType="System.Int32" description="Parameter information. Matches OLE DB's DBPARAMFLAGSENUM values." name="DBParamInfoFlags">81</property>
</properties>
</externalMetadataColumn>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Output]" exclusionGroup="1" name="OLE DB Command Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
<externalMetadataColumns/>
</output>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Command Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Outputs[OLE DB Command Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation;Microsoft SqlServer 2015; (C) 2014 Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="ODB - Write to output table" usesDispositions="true" validateExternalMetadata="False" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[snapshots].[trace_data]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destinaton. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">0</property>
</properties>
-<connections>
<connection refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[MdwConnection]" connectionManagerRefId="Package.ConnectionManagers[MdwConnection]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="IgnoreFailure" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TextData]" cachedDataType="nText" cachedName="TextData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TextData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BinaryData]" cachedDataType="image" cachedName="BinaryData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BinaryData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseID]" cachedDataType="i4" cachedName="DatabaseID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TransactionID]" cachedDataType="i8" cachedName="TransactionID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TransactionID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LineNumber]" cachedDataType="i4" cachedName="LineNumber" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LineNumber]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTUserName]" cachedDataType="wstr" cachedLength="256" cachedName="NTUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NTDomainName]" cachedDataType="wstr" cachedLength="256" cachedName="NTDomainName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NTDomainName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[HostName]" cachedDataType="wstr" cachedLength="256" cachedName="HostName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[HostName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ClientProcessID]" cachedDataType="i4" cachedName="ClientProcessID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ClientProcessID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ApplicationName]" cachedDataType="wstr" cachedLength="256" cachedName="ApplicationName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ApplicationName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginName]" cachedDataType="wstr" cachedLength="256" cachedName="LoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SPID]" cachedDataType="i4" cachedName="SPID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SPID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Duration]" cachedDataType="i8" cachedName="Duration" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Duration]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[StartTime]" cachedDataType="dbTimeStamp" cachedName="StartTime" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[StartTime]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EndTime]" cachedDataType="dbTimeStamp" cachedName="EndTime" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EndTime]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Reads]" cachedDataType="i8" cachedName="Reads" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Reads]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Writes]" cachedDataType="i8" cachedName="Writes" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Writes]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[CPU]" cachedDataType="i4" cachedName="CPU" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[CPU]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Permissions]" cachedDataType="i8" cachedName="Permissions" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Permissions]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Severity]" cachedDataType="i4" cachedName="Severity" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Severity]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSubClass]" cachedDataType="i4" cachedName="EventSubClass" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSubClass]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID]" cachedDataType="i4" cachedName="ObjectID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Success]" cachedDataType="i4" cachedName="Success" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Success]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IndexID]" cachedDataType="i4" cachedName="IndexID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IndexID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData]" cachedDataType="i4" cachedName="IntegerData" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ServerName]" cachedDataType="wstr" cachedLength="256" cachedName="ServerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ServerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventClass]" cachedDataType="i4" cachedName="EventClass" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventClass]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectType]" cachedDataType="i4" cachedName="ObjectType" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectType]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[NestLevel]" cachedDataType="i4" cachedName="NestLevel" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[NestLevel]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[State]" cachedDataType="i4" cachedName="State" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[State]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Error]" cachedDataType="i4" cachedName="Error" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Error]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Mode]" cachedDataType="i4" cachedName="Mode" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Mode]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Handle]" cachedDataType="i4" cachedName="Handle" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Handle]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectName]" cachedDataType="wstr" cachedLength="256" cachedName="ObjectName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DatabaseName]" cachedDataType="wstr" cachedLength="256" cachedName="DatabaseName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DatabaseName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[FileName]" cachedDataType="wstr" cachedLength="256" cachedName="FileName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[FileName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerName]" cachedDataType="wstr" cachedLength="256" cachedName="OwnerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RoleName]" cachedDataType="wstr" cachedLength="256" cachedName="RoleName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RoleName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetUserName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[DBUserName]" cachedDataType="wstr" cachedLength="256" cachedName="DBUserName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[DBUserName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LoginSid]" cachedDataType="image" cachedName="LoginSid" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LoginSid]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="TargetLoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[TargetLoginSid]" cachedDataType="image" cachedName="TargetLoginSid" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[TargetLoginSid]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ColumnPermissions]" cachedDataType="i4" cachedName="ColumnPermissions" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ColumnPermissions]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[LinkedServerName]" cachedDataType="wstr" cachedLength="256" cachedName="LinkedServerName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[LinkedServerName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ProviderName]" cachedDataType="wstr" cachedLength="256" cachedName="ProviderName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ProviderName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[MethodName]" cachedDataType="wstr" cachedLength="256" cachedName="MethodName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[MethodName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RowCounts]" cachedDataType="i8" cachedName="RowCounts" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RowCounts]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[RequestID]" cachedDataType="i4" cachedName="RequestID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[RequestID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[XactSequence]" cachedDataType="i8" cachedName="XactSequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[XactSequence]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[EventSequence]" cachedDataType="i8" cachedName="EventSequence" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[EventSequence]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData1]" cachedDataType="i8" cachedName="BigintData1" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData1]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[BigintData2]" cachedDataType="i8" cachedName="BigintData2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[BigintData2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GUID]" cachedDataType="guid" cachedName="GUID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GUID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IntegerData2]" cachedDataType="i4" cachedName="IntegerData2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IntegerData2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ObjectID2]" cachedDataType="i8" cachedName="ObjectID2" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ObjectID2]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Type]" cachedDataType="i4" cachedName="Type" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Type]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[OwnerID]" cachedDataType="i4" cachedName="OwnerID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[OwnerID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[ParentName]" cachedDataType="wstr" cachedLength="256" cachedName="ParentName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[ParentName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[IsSystem]" cachedDataType="i4" cachedName="IsSystem" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[IsSystem]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[Offset]" cachedDataType="i4" cachedName="Offset" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[Offset]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SourceDatabaseID]" cachedDataType="i4" cachedName="SourceDatabaseID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SourceDatabaseID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SessionLoginName]" cachedDataType="wstr" cachedLength="256" cachedName="SessionLoginName" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[SessionLoginName]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[trace_info_id]" cachedDataType="i4" cachedName="trace_info_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[trace_info_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[snapshot_id]" cachedDataType="i4" cachedName="snapshot_id" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output].Columns[snapshot_id]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[GroupID]" cachedDataType="i4" cachedName="GroupID" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output].Columns[GroupID]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[SqlHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="SqlHandle64" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[SqlHandle64]"/>
<inputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].Columns[PlanHandle64]" cachedDataType="bytes" cachedLength="64" cachedName="PlanHandle64" externalMetadataColumnId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output].Columns[PlanHandle64]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[trace_info_id]" dataType="i4" name="trace_info_id"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[snapshot_id]" dataType="i4" name="snapshot_id"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TextData]" dataType="nText" name="TextData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BinaryData]" dataType="image" name="BinaryData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseID]" dataType="i4" name="DatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TransactionID]" dataType="i8" name="TransactionID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LineNumber]" dataType="i4" name="LineNumber"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTUserName]" dataType="wstr" length="256" name="NTUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NTDomainName]" dataType="wstr" length="256" name="NTDomainName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[HostName]" dataType="wstr" length="256" name="HostName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ClientProcessID]" dataType="i4" name="ClientProcessID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ApplicationName]" dataType="wstr" length="256" name="ApplicationName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginName]" dataType="wstr" length="256" name="LoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SPID]" dataType="i4" name="SPID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Duration]" dataType="i8" name="Duration"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[StartTime]" dataType="dbTimeStamp" name="StartTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EndTime]" dataType="dbTimeStamp" name="EndTime"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Reads]" dataType="i8" name="Reads"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Writes]" dataType="i8" name="Writes"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[CPU]" dataType="i4" name="CPU"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Permissions]" dataType="i8" name="Permissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Severity]" dataType="i4" name="Severity"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSubClass]" dataType="i4" name="EventSubClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID]" dataType="i4" name="ObjectID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Success]" dataType="i4" name="Success"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IndexID]" dataType="i4" name="IndexID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData]" dataType="i4" name="IntegerData"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ServerName]" dataType="wstr" length="256" name="ServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventClass]" dataType="i4" name="EventClass"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectType]" dataType="i4" name="ObjectType"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[NestLevel]" dataType="i4" name="NestLevel"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[State]" dataType="i4" name="State"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Error]" dataType="i4" name="Error"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Mode]" dataType="i4" name="Mode"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Handle]" dataType="i4" name="Handle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectName]" dataType="wstr" length="256" name="ObjectName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DatabaseName]" dataType="wstr" length="256" name="DatabaseName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[FileName]" dataType="wstr" length="256" name="FileName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerName]" dataType="wstr" length="256" name="OwnerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RoleName]" dataType="wstr" length="256" name="RoleName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetUserName]" dataType="wstr" length="256" name="TargetUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[DBUserName]" dataType="wstr" length="256" name="DBUserName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LoginSid]" dataType="image" name="LoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginName]" dataType="wstr" length="256" name="TargetLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[TargetLoginSid]" dataType="image" name="TargetLoginSid"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ColumnPermissions]" dataType="i4" name="ColumnPermissions"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[LinkedServerName]" dataType="wstr" length="256" name="LinkedServerName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ProviderName]" dataType="wstr" length="256" name="ProviderName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[MethodName]" dataType="wstr" length="256" name="MethodName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RowCounts]" dataType="i8" name="RowCounts"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[RequestID]" dataType="i4" name="RequestID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[XactSequence]" dataType="i8" name="XactSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[EventSequence]" dataType="i8" name="EventSequence"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData1]" dataType="i8" name="BigintData1"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[BigintData2]" dataType="i8" name="BigintData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GUID]" dataType="guid" name="GUID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IntegerData2]" dataType="i4" name="IntegerData2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ObjectID2]" dataType="i8" name="ObjectID2"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Type]" dataType="i4" name="Type"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[OwnerID]" dataType="i4" name="OwnerID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[ParentName]" dataType="wstr" length="256" name="ParentName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[IsSystem]" dataType="i4" name="IsSystem"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[Offset]" dataType="i4" name="Offset"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SourceDatabaseID]" dataType="i4" name="SourceDatabaseID"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SqlHandle]" dataType="bytes" length="64" name="SqlHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[SessionLoginName]" dataType="wstr" length="256" name="SessionLoginName"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[PlanHandle]" dataType="bytes" length="64" name="PlanHandle"/>
<externalMetadataColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input].ExternalColumns[GroupID]" dataType="i4" name="GroupID"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Aggregate Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Inputs[Derived Column Input]" name="Aggregate Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Outputs[Aggregate Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Data Conversion Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Inputs[Row Count Input 1]" name="Data Conversion Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Outputs[Data Conversion Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Derived Column Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\Data Conversion.Inputs[Data Conversion Input]" name="Derived Column Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Outputs[Derived Column Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Derived Column Output1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Update trace_info.Inputs[OLE DB Command Input]" name="Derived Column Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add columns.Outputs[Derived Column Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Multicast Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\DRV - Add snapshot_id and trace_info_id.Inputs[Derived Column Input]" name="Multicast Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Multicast Output 2]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\AGG - Get max value of EventSequence.Inputs[Aggregate Input 1]" name="Multicast Output 2" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Outputs[Multicast Output 2]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[OLE DB Source Error Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Error row count source.Inputs[Row Count Input 1]" name="OLE DB Source Error Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Error Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[OLE DB Source Output]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Inputs[Row Count Input 1]" name="OLE DB Source Output" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Read trace.Outputs[OLE DB Source Output]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Row Count Output 1]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\ODB - Write to output table.Inputs[OLE DB Destination Input]" name="Row Count Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Output row count.Outputs[Row Count Output 1]"/>
<path refId="Package\SEQ - Default trace upload\DFT - Upload default trace file.Paths[Row Count Output 11]" endId="Package\SEQ - Default trace upload\DFT - Upload default trace file\MLT - Split two ways.Inputs[Multicast Input 1]" name="Row Count Output 1" startId="Package\SEQ - Default trace upload\DFT - Upload default trace file\CNT - Input row count.Outputs[Row Count Output 1]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SEQ - Default trace upload\SQL - Log package stats" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:DelayValidation="True" DTS:Description="Logs statistics about the most recent Data Flow Task" DTS:DTSID="{147f8f7a-f829-4ac7-a038-03943f58ee3b}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Log package stats" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{74950c5e-3a60-494f-83a3-e04e64e1217f}" DTS:EvaluateAsExpression="True" DTS:Expression="DATEDIFF("millisecond", @[System::ContainerStartTime] , GETDATE() )" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="LoopDuration">
<DTS:VariableValue DTS:DataType="3">155826</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{ call [dbo].[sp_syscollector_event_onstatsupdate] (?, N'Upload trace file', ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::RowCountIn" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::RowCountOut" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::RowCountError" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LoopDuration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package\SEQ - Default trace upload.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{AEDEEA80-FB4F-4737-B938-B2909C835D5A}" DTS:EvalOp="3" DTS:Expression="@[LoggingLevel] >= 1" DTS:From="Package\SEQ - Default trace upload\DFT - Upload default trace file" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SEQ - Default trace upload\SQL - Log package stats" DTS:Value="2"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Close trace" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{EAA2093E-36E6-4EA8-A5E9-E568C5A46516}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Close trace" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{607D54DC-E752-4779-9BB2-B3D19CAD0C76}" SQLTask:SqlStatementSource="{ call [sp_trace_setstatus] (?, 2) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get last upload time" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{0F29500B-BB42-4603-AB36-A6C75CFC649B}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get last upload time" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [snapshots].[sp_trace_get_info] (?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::ItemID" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::TraceStartTime" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::TraceLastEventSequence" SQLTask:ParameterDirection="Output" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::TraceInfoID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get snapshot id" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{C316D13F-2EEE-42A1-B307-924555587091}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get snapshot id" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [core].[sp_create_snapshot] (?, ?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::CollectorTypeUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::LogID" SQLTask:ParameterDirection="Input" SQLTask:DataType="20" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="5" SQLTask:DtsVariableName="User::SnapshotID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Get trace info" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{33CFBECB-7DAD-4256-811D-FED4E423755D}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Get trace info" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{C9A06CAE-CFEE-4A26-BE59-A3A222474CCB}" SQLTask:SqlStatementSource="{call [dbo].[sp_syscollector_get_trace_info](?, ?)}" SQLTask:ResultType="ResultSetType_SingleRow">
<SQLTask:ResultBinding SQLTask:ResultName="start_time" SQLTask:DtsVariableName="User::TraceStartTime"/>
<SQLTask:ResultBinding SQLTask:ResultName="is_running" SQLTask:DtsVariableName="User::TraceIsRunning"/>
<SQLTask:ResultBinding SQLTask:ResultName="dropped_event_count" SQLTask:DtsVariableName="User::TraceDroppedEventCount"/>
<SQLTask:ResultBinding SQLTask:ResultName="id" SQLTask:DtsVariableName="User::TraceID"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::TraceLocation" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="User::TraceUseDefault" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\SQL - Update data source" DTS:CreationName="Microsoft.ExecuteSQLTask" DTS:Description="Execute SQL Task" DTS:DTSID="{D8732C3C-BF2D-40C6-BA2E-AF18493924AC}" DTS:ExecutableType="Microsoft.ExecuteSQLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="SQL - Update data source" DTS:TaskContact="Execute SQL Task; Microsoft Corporation; Microsoft SQL Server v9; Â© 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{6CE046ED-1A7E-4831-864D-EF6FCE30E5A9}" SQLTask:SqlStatementSource="{ call [core].[sp_update_data_source] (?, ?, ?, ?, ?) }">
<SQLTask:ParameterBinding SQLTask:ParameterName="0" SQLTask:DtsVariableName="User::CollectionSetUID" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="2" SQLTask:DtsVariableName="User::InstanceName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="3" SQLTask:DtsVariableName="User::DaysUntilExpiration" SQLTask:ParameterDirection="Input" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="4" SQLTask:DtsVariableName="User::SourceID" SQLTask:ParameterDirection="Output" SQLTask:DataType="3" SQLTask:ParameterSize="-1"/>
<SQLTask:ParameterBinding SQLTask:ParameterName="1" SQLTask:DtsVariableName="System::MachineName" SQLTask:ParameterDirection="Input" SQLTask:DataType="130" SQLTask:ParameterSize="-1"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\XML - Check use_default attribute" DTS:CreationName="Microsoft.XMLTask" DTS:Description="XML Task" DTS:DTSID="{DB542074-1D89-441B-BA2B-E1E55527C2B8}" DTS:ExecutableType="Microsoft.XMLTask" DTS:FailParentOnFailure="True" DTS:LocaleID="-1" DTS:MaxErrorCount="0" DTS:ObjectName="XML - Check use_default attribute" DTS:TaskContact="XML Task; Microsoft Corporation; Microsoft SQL Server 2014; Â© 2014 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<XMLTaskData OperationType="XPATH" SourceType="Variable" Source="User::InputParameters" SecondOperand="*[local-name() = 'SqlTraceCollector']/@use_default" SaveOperationResult="True" DestinationType="Variable" Destination="User::TraceUseDefault" OverwriteDestination="True" XPathOperation="Values"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{2DBE8AE5-8C75-44A9-8C57-D571678FF149}" DTS:From="Package\SQL - Get trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\SQL - Update data source"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{9C582F44-453F-431A-80FE-D79155C6E519}" DTS:From="Package\SQL - Update data source" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\SQL - Get last upload time"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{8D136BE7-D0D6-486D-85E9-D64DB633850E}" DTS:From="Package\SQL - Get last upload time" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\SQL - Get snapshot id"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{0E7EF1B1-B857-44B2-87BF-CA42682C6354}" DTS:EvalOp="1" DTS:Expression="@[User::SnapshotID] != 0 && @[User::TraceUseDefault] != "1"" DTS:From="Package\SQL - Get snapshot id" DTS:ObjectName="Constraint 3" DTS:To="Package\For Loop Container"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 5]" DTS:CreationName="" DTS:DTSID="{285C2E0E-D5D3-467A-8237-E0B32D55C912}" DTS:EvalOp="3" DTS:Expression="@[User::TraceIsRunning] == 0" DTS:From="Package\SQL - Get trace info" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 5" DTS:To="Package\SQL - Close trace"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 6]" DTS:CreationName="" DTS:DTSID="{5545F925-D433-4F90-93FD-D3E432AE1D83}" DTS:From="Package\XML - Check use_default attribute" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 6" DTS:To="Package\SQL - Get trace info"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 8]" DTS:CreationName="" DTS:DTSID="{58C2147A-C7A3-4809-95AB-F70A1F1C57BF}" DTS:EvalOp="3" DTS:Expression="@[User::TraceUseDefault] == "1"" DTS:From="Package\SQL - Get snapshot id" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 8" DTS:To="Package\SEQ - Default trace upload"/>
</DTS:PrecedenceConstraints>
</DTS:Executable>


SSIS Projects

Collapse image Project index

Project
OtherPackages.dtproj

Collapse image See also

About this documentation


SSIS projects

SSIS project: OtherPackages.dtproj

Collapse image Package index

Package | Path
AnalysisProcessingPackage | C:\Users\Alen\Desktop\SSIS packages\AnalysisProcessingPackage.dtsx
BackUpDBTaskPackage | C:\Users\Alen\Desktop\SSIS packages\BackUpDBTaskPackage.dtsx
BulkInsertPackage | C:\Users\Alen\Desktop\SSIS packages\BulkInsertPackage.dtsx
CheckDBIntegrityTaskPackage | C:\Users\Alen\Desktop\SSIS packages\CheckDBIntegrityTaskPackage.dtsx
CompareExecuteProcess1Package | C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess1Package.dtsx
CompareExecuteProcess2Package | C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess2Package.dtsx
ConstraintsPackage | C:\Users\Alen\Desktop\SSIS packages\ConstraintsPackage.dtsx
DataCorrectionPackage | C:\Users\Alen\Desktop\SSIS packages\DataCorrectionPackage.dtsx
EventHandlersPackage | C:\Users\Alen\Desktop\SSIS packages\EventHandlersPackage.dtsx

Collapse image See also

About this documentation


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 12:12:27 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{BC323BDF-DECC-48C2-980F-346D490B0B06}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="AnalysisProcessingPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="3" DTS:VersionGUID="{62FA2EDE-4908-4383-B87D-2256AB6C645D}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[localhost]" DTS:CreationName="MSOLAP100" DTS:DTSID="{07B5452E-D0E6-44A5-836F-303564321DDE}" DTS:ObjectName="localhost">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=localhost;PROVIDER=MSOLAP.6;Impersonation Level=Impersonate;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Analysis Services Processing Task" DTS:CreationName="Microsoft.DTSProcessingTask" DTS:Description="Analysis Services Processing Task" DTS:DTSID="{7763345C-6C11-4F18-A525-DB85260726C7}" DTS:ExecutableType="Microsoft.DTSProcessingTask" DTS:LocaleID="-1" DTS:ObjectName="Analysis Services Processing Task" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<ASProcessingData ConnectionName="localhost" ProcessingCommands="<Batch xmlns="http://schemas.microsoft.com/analysisservices/2003/engine"> <Process xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <Object> <DatabaseID>TestDB</DatabaseID> </Object> <Type>ProcessFull</Type> <WriteBackTableCreation>UseExisting</WriteBackTableCreation> </Process> </Batch>"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{BC1A9AC6-64F8-4C78-9DB3-23C48C6F7807}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{5FA6F440-C113-4CDF-8866-F8897D986F6F}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7763345C-6C11-4F18-A525-DB85260726C7}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{90CB4199-14F7-4BED-BFD3-B2671C97E9CF}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7763345C-6C11-4F18-A525-DB85260726C7}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 2:28:51 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{95AA7996-CCE3-4446-95BF-C96381D1C00F}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="BackUpDBTaskPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="2" DTS:VersionGUID="{6221C6C1-594F-4DC2-A5CF-EF4A55A4ABEB}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[serverbackup]" DTS:CreationName="ADO.NET:SQL" DTS:DTSID="{A10C314B-E039-4D96-AD03-200C8439C2C3}" DTS:ObjectName="serverbackup">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=server;Integrated Security=SSPI;Connect Timeout=30;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Back Up Database Task" DTS:CreationName="Microsoft.DbMaintenanceBackupTask" DTS:Description="Back Up Database Task" DTS:DTSID="{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" DTS:ExecutableType="Microsoft.DbMaintenanceBackupTask" DTS:LocaleID="-1" DTS:ObjectName="Back Up Database Task" DTS:TaskContact="Back Up Database Task; Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{A10C314B-E039-4D96-AD03-200C8439C2C3}" SQLTask:DatabaseSelectionType="4" SQLTask:ServerVersion="9" SQLTask:ExtendedLogging="True" SQLTask:LocalConnectionForLogging="" SQLTask:TaskName="" SQLTask:IgnoreDatabasesInNotOnlineState="False" SQLTask:BackupAction="0" SQLTask:BackupIsIncremental="False" SQLTask:BackupFileGroupsFiles="" SQLTask:BackupDeviceType="2" SQLTask:BackupPhysicalDestinationType="2" SQLTask:BackupDestinationType="0" SQLTask:BackupDestinationAutoFolderPath="C:\Program Files\Microsoft SQL Server\MSSQL\BACKUP" SQLTask:BackupActionForExistingBackups="0" SQLTask:BackupCreateSubFolder="False" SQLTask:BackupFileExtension="bak" SQLTask:BackupVerifyIntegrity="False" SQLTask:ExpireDate="2100-09-12T00:00:00" SQLTask:RetainDays="14" SQLTask:InDays="True" SQLTask:UseExpiration="False" SQLTask:BackupCompressionAction="0" SQLTask:CopyOnlyBackup="False" SQLTask:IgnoreReplicaType="False" SQLTask:CredentialName="" SQLTask:ContainerName="" SQLTask:UrlPrefix="" SQLTask:IsBackupEncrypted="False" SQLTask:BackupEncryptionAlgorithm="0" SQLTask:BackupEncryptorType="0" SQLTask:BackupEncryptorName="">
<SQLTask:SelectedDatabases SQLTask:DatabaseName="ANCSA"/>
<SQLTask:SelectedDatabases SQLTask:DatabaseName="New_Pizza_Project"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{AF1DE1D0-E6CD-4ABE-88F4-1FEE960DB6A8}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{B03C6F40-49BE-4D8A-A749-19AF50A650BA}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{29FA9056-6247-46C6-A89C-26C261617A35}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{67643D28-0F1D-4144-87BE-1CFCA6A37B02}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: BulkInsertPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 12:15:09 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {BEB2E066-E754-49C5-BEE2-F2DD3EC68AF7}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | BulkInsertPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\BulkInsertPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\BulkInsertPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 4
VersionComments |
VersionGUID | {863F38DB-5B4D-4AF5-8D54-F3DCFD49C39F}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
localhost.Test |
Package.xml |

Collapse image Executables

Name | Description
Bulk Insert Task | Bulk Insert Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: BulkInsertPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image Connection managers

Name | Description
localhost.Test |
Package.xml |

Collapse image System variables

No items exist
Name Description


Package element

Package element: localhost.Test

Collapse image Properties

Name | Value
ConnectionString | Data Source=localhost;Initial Catalog=Test;Provider=SQLNCLI11;Integrated Security=SSPI;Auto Translate=False;
CreationName | OLEDB
DelayValidation | False
Description |
HasExpressions | False
HostType | ConnectionManager
ID | {E733BFB9-6D0B-40D4-BAC0-3CD4011EAA34}
InitialCatalog | Test
Name | localhost.Test
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | localhost
SupportsDTCTransactions | True
UserName |


Package element

Package element: Package.xml

Collapse image Properties

Name | Value
ConnectionString | C:\Temp\Package.xml
CreationName | FILE
DelayValidation | False
Description |
FileUsageType | 0
HasExpressions | False
HostType | ConnectionManager
ID | {5883994C-51D7-415A-8019-E68B757B91E2}
Name | Package.xml
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
Scope | Package
SupportsDTCTransactions | False


Package

Package: BulkInsertPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image Executables

Name | Description
Bulk Insert Task | Bulk Insert Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Bulk Insert Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
BatchSize | 0
CheckConstraints | True
CodePage | RAW
CreationName | Microsoft.SqlServer.Dts.Tasks.BulkInsertTask.BulkInsertTask, Microsoft.SqlServer.BulkInsertTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DataFileType | 0
DebugMode | False
DelayValidation | False
Description | Bulk Insert Task
DestinationConnection | localhost.Test
DestinationTableName | [Test].[dbo].[TestTable]
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FieldTerminator | Tab
FireTriggers | False
FirstRow | 1
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
FormatFile |
HasExpressions | False
HostType | Task
ID | {E4D47AA2-9F96-41EF-8F77-0A85FC4FDBDA}
IsDefaultLocaleID | True
IsolationLevel | Serializable
KeepIdentity | False
KeepNulls | False
LastRow | 0
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
MaximumErrors | 0
Name | Bulk Insert Task
RowTerminator | {CR}{LF}
SortedData |
SourceConnection | Package.xml
SqlStatement | System.String[]
SuspendRequired | False
TableLock | False
TransactionOption | Supported
UseFormatFile | False
Version | 0

Collapse image Elements

Name | Description | Type
BulkInsertBegin | Invoked before the bulk insert statement is executed. | LogEntryInfos
BulkInsertEnd | Invoked after the bulk insert statement is executed. | LogEntryInfos
BulkInsertTaskInfo | Bulk Insert Task info | LogEntryInfos


Package element

Package element: BulkInsertBegin

Collapse image Properties

Name | Value
CreationName |
Description | Invoked before the bulk insert statement is executed.
FrequencyHint | Consistent
Name | BulkInsertBegin


Package element

Package element: BulkInsertEnd

Collapse image Properties

Name | Value
CreationName |
Description | Invoked after the bulk insert statement is executed.
FrequencyHint | Consistent
Name | BulkInsertEnd


Package element

Package element: BulkInsertTaskInfo

Collapse image Properties

Name | Value
CreationName |
Description | Bulk Insert Task info
FrequencyHint | Consistent
Name | BulkInsertTaskInfo


Package

Package: BulkInsertPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: BulkInsertPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 12:15:09 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{BEB2E066-E754-49C5-BEE2-F2DD3EC68AF7}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="BulkInsertPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="4" DTS:VersionGUID="{B9C918F2-C2DE-4183-9CC5-DDB02DC86D32}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[localhost.Test]" DTS:CreationName="OLEDB" DTS:DTSID="{E733BFB9-6D0B-40D4-BAC0-3CD4011EAA34}" DTS:ObjectName="localhost.Test">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=localhost;Initial Catalog=Test;Provider=SQLNCLI11;Integrated Security=SSPI;Auto Translate=False;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[Package.xml]" DTS:CreationName="FILE" DTS:DTSID="{5883994C-51D7-415A-8019-E68B757B91E2}" DTS:ObjectName="Package.xml">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="C:\Temp\Package.xml"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Bulk Insert Task" DTS:CreationName="Microsoft.BulkInsertTask" DTS:Description="Bulk Insert Task" DTS:DTSID="{E4D47AA2-9F96-41EF-8F77-0A85FC4FDBDA}" DTS:ExecutableType="Microsoft.BulkInsertTask" DTS:LocaleID="-1" DTS:ObjectName="Bulk Insert Task" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<BulkInsertTask:BulkInsertTaskData BulkInsertTask:SourceConnectionName="{5883994C-51D7-415A-8019-E68B757B91E2}" BulkInsertTask:DestinationConnectionName="{E733BFB9-6D0B-40D4-BAC0-3CD4011EAA34}" BulkInsertTask:DestinationTableName="[Test].[dbo].[TestTable]"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{DDAA2AA5-03B9-4C09-BA54-1791950A4793}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{25100A20-4210-44F0-AB98-4E7BD843CF5E}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{E4D47AA2-9F96-41EF-8F77-0A85FC4FDBDA}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{57D96458-0F3B-449A-8F36-C392A749DC84}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{E4D47AA2-9F96-41EF-8F77-0A85FC4FDBDA}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 2:46:26 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {69FFCDF0-2E96-4B19-A58E-79732E6AC669}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | CheckDBIntegrityTaskPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\CheckDBIntegrityTaskPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\CheckDBIntegrityTaskPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 3
VersionComments |
VersionGUID | {A9E0C55C-6C16-4A38-BB8E-D9C92918AE26}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
serverconn |

Collapse image Executables

Name | Description
Check Database Integrity Task | Check Database Integrity Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Connection managers

Name | Description
serverconn |

Collapse image System variables

No items exist
Name Description


Package element

Package element: serverconn

Collapse image Properties

Name | Value
ConnectionString | Data Source=server;Integrated Security=SSPI;Connect Timeout=30;
CreationName | ADO.NET:SQL
DelayValidation | False
Description |
HasExpressions | False
HostType | ConnectionManager
ID | {19F3D218-16A4-4B86-96AB-FF11882BC365}
InitialCatalog |
Name | serverconn
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier | SQL
RetainSameConnection | False
Scope | Package
ServerName | server
SupportsDTCTransactions | True
UserName |


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Executables

Name | Description
Check Database Integrity Task | Check Database Integrity Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Check Database Integrity Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
BypassPrepare | True
CodePage | 1252
Connection | serverconn
CreationName | Microsoft.SqlServer.Management.DatabaseMaintenance.DbMaintenanceCheckIntegrityTask, Microsoft.SqlServer.MaintenancePlanTasks, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DatabaseSelectionType | 4
DebugMode | False
DelayValidation | False
Description | Check Database Integrity Task
Disable | False
DisableEventHandlers | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
ExtendedLogging | True
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7171DDA6-8DE4-4173-8310-B115B8C9F641}
IgnoreDatabasesInNotOnlineState | False
IncludeIndexes | True
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsStoredProcedure | False
LocalConnectionForLogging
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Check Database Integrity Task
ObjectTypeSelection | 0
ResultSetType | 1
RunId | {00000000-0000-0000-0000-000000000000}
SelectedDatabases | System.Collections.ArrayList
SelectedTables
ServerVersion | 8
SqlStatementSource

  SqlStatementSourceType
   | Direct Input

  SuspendRequired
   | False

  TableSelectionType
   | 0

  TaskAllowesDatbaseSelection
   | True

  TaskAllowesTableSelection
   | False

  TaskConnectionName
   | serverconn

  TaskName

  TaskNameWasModified
   | False

  TimeOut
   | 0

  TransactionOption
   | Supported

  TypeConversionMode
   | 2

  Version
   | 0

      Collapse image

            Elements

Name | Description | Type
ExecuteSQLExecutingQuery | Provides information about executing an SQL query. | LogEntryInfos

      Collapse image

            See also

Package index


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CheckDBIntegrityTaskPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 2:46:26 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{69FFCDF0-2E96-4B19-A58E-79732E6AC669}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="CheckDBIntegrityTaskPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="3" DTS:VersionGUID="{9999CC8E-8FB3-438D-B744-A8CE413D4E60}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[serverconn]" DTS:CreationName="ADO.NET:SQL" DTS:DTSID="{19F3D218-16A4-4B86-96AB-FF11882BC365}" DTS:ObjectName="serverconn">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=server;Integrated Security=SSPI;Connect Timeout=30;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Check Database Integrity Task" DTS:CreationName="Microsoft.DbMaintenanceCheckIntegrityTask" DTS:Description="Check Database Integrity Task" DTS:DTSID="{7171DDA6-8DE4-4173-8310-B115B8C9F641}" DTS:ExecutableType="Microsoft.DbMaintenanceCheckIntegrityTask" DTS:LocaleID="-1" DTS:ObjectName="Check Database Integrity Task" DTS:TaskContact="Check Database Integrity Task; Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
-<SQLTask:SqlTaskData SQLTask:Connection="{19F3D218-16A4-4B86-96AB-FF11882BC365}" SQLTask:DatabaseSelectionType="4" SQLTask:ServerVersion="8" SQLTask:ExtendedLogging="True" SQLTask:LocalConnectionForLogging="" SQLTask:TaskName="" SQLTask:IgnoreDatabasesInNotOnlineState="False" SQLTask:IncludeIndexes="True">
<SQLTask:SelectedDatabases SQLTask:DatabaseName="ANCSA"/>
<SQLTask:SelectedDatabases SQLTask:DatabaseName="HouseLook"/>
</SQLTask:SqlTaskData>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{92BD1995-6F3E-4CA4-9068-8496F12D5948}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{9704BD8B-2642-4E19-ACB0-4429CE36AD30}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7171DDA6-8DE4-4173-8310-B115B8C9F641}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{5FE25B5D-01D6-41CF-8E14-790BA0B34384}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7171DDA6-8DE4-4173-8310-B115B8C9F641}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: CompareExecuteProcess1Package

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 5:37:36 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {02E4BA06-457E-40EB-B18B-548F4AFC8CA5}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | Disabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | CompareExecuteProcess1Package
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess1Package.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess1Package.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 2
VersionComments |
VersionGUID | {EF4C6BD5-D004-4E45-A678-ED960EEAC41E}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
log.txt |

Collapse image Event handlers

Name | Description
OnError |

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Log providers

Name | Description
SSIS log provider for Text files | Writes log entries for events to a CSV file

Collapse image Precedence constraints

Name | Description
Constraint |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: CompareExecuteProcess1Package

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess1Package

Collapse image Connection managers

Name | Description
log.txt |

Collapse image System variables

No items exist
Name Description


Package element

Package element: log.txt

Collapse image Properties

Name | Value
ConnectionString | c:\temp\log.txt
CreationName | FILE
DelayValidation | False
Description |
FileUsageType | 1
HasExpressions | False
HostType | ConnectionManager
ID | {B24698CA-0C18-4FF4-BDAE-F39E46F3CC6C}
Name | log.txt
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
Scope | Package
SupportsDTCTransactions | False


Package

Package: CompareExecuteProcess1Package

Collapse image Event handlers

Name | Description
OnError |

Collapse image System variables

No items exist
Name Description


Package element

Package element: OnError

Collapse image Properties

Name | Value
CreationName | OnError
DebugMode | False
DelayValidation | False
Description |
Disable | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {9A24F41E-51F3-426C-93D6-2EC1527B452D}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | OnError
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Execute Process Task | Execute Process Task | Executables


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | notepad.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7E7946D1-3E16-4866-868E-6153A23D7869}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: ExecuteProcessExecutingProcess

Collapse image Properties

Name | Value
CreationName |
Description | Provides information regarding executing the process
FrequencyHint | Consistent
Name | ExecuteProcessExecutingProcess


Package element

Package element: ExecuteProcessVariableRouting

Collapse image Properties

Name | Value
CreationName |
Description | Provides information regarding routing of variables
FrequencyHint | Consistent
Name | ExecuteProcessVariableRouting


Package

Package: CompareExecuteProcess1Package

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | calc.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {9B30176A-7175-4874-BE00-CB9C39342602}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: Execute Process Task 1

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | mspaint.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {3A00F380-1C97-4ECD-8677-D43AE1EB32E2}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 1
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package

Package: CompareExecuteProcess1Package

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess1Package

Collapse image Log providers

Name | Description
SSIS log provider for Text files | Writes log entries for events to a CSV file

Collapse image System variables

No items exist
Name Description


Package element

Package element: SSIS log provider for Text files

Collapse image Properties

Name | Value
ConfigString | log.txt
CreationName | Microsoft.LogProviderTextFile
DelayValidation | False
Description | Writes log entries for events to a CSV file
Enabled | True
HasExpressions | False
HostType | LogProvider
ID | {73191FD8-8D20-418F-9697-E032CBB67861}
Name | SSIS log provider for Text files


Package

Package: CompareExecuteProcess1Package

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess1Package

Collapse image Precedence constraints

Name | Description
Constraint |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {4851179E-EBF4-4F9D-A03D-35D8021FFA98}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | Execute Process Task 1
Value | Success


Package

Package: CompareExecuteProcess1Package

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 5:37:36 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{02E4BA06-457E-40EB-B18B-548F4AFC8CA5}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="CompareExecuteProcess1Package" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="2" DTS:VersionGUID="{4473471C-9E25-4FFD-9022-EAB93888804A}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[log.txt]" DTS:CreationName="FILE" DTS:DTSID="{B24698CA-0C18-4FF4-BDAE-F39E46F3CC6C}" DTS:ObjectName="log.txt">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:FileUsageType="1" DTS:ConnectionString="c:\temp\log.txt"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:LogProviders>
-<DTS:LogProvider DTS:ConfigString="log.txt" DTS:CreationName="Microsoft.LogProviderTextFile" DTS:Description="Writes log entries for events to a CSV file" DTS:DTSID="{73191FD8-8D20-418F-9697-E032CBB67861}" DTS:ObjectName="SSIS log provider for Text files">
-<DTS:ObjectData>
<InnerObject/>
</DTS:ObjectData>
</DTS:LogProvider>
</DTS:LogProviders>
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="2"/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{9B30176A-7175-4874-BE00-CB9C39342602}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="calc.exe"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 1" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{3A00F380-1C97-4ECD-8677-D43AE1EB32E2}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 1" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="mspaint.exe"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{4851179E-EBF4-4F9D-A03D-35D8021FFA98}" DTS:From="Package\Execute Process Task 1" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Execute Process Task"/>
</DTS:PrecedenceConstraints>
-<DTS:EventHandlers>
-<DTS:EventHandler DTS:refId="Package.EventHandlers[OnError]" DTS:CreationName="OnError" DTS:DTSID="{9A24F41E-51F3-426C-93D6-2EC1527B452D}" DTS:EventID="0" DTS:EventName="OnError" DTS:LocaleID="-1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:Description="The propagate property of the event" DTS:DTSID="{09D77A48-CACE-4A66-BCF1-07D08D0C254D}" DTS:IncludeInDebugDump="6789" DTS:Namespace="System" DTS:ObjectName="Propagate">
<DTS:VariableValue DTS:DataType="11">-1</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package.EventHandlers[OnError]\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{7E7946D1-3E16-4866-868E-6153A23D7869}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="notepad.exe"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:EventHandler>
</DTS:EventHandlers>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{C0F83B0B-5033-4763-AAAC-15AD43360D36}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{4851179E-EBF4-4F9D-A03D-35D8021FFA98}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Constraint</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{241F6042-6783-40C7-9EDA-91D7708C522D}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{8199645F-43D0-47C0-BD18-778104292E8B}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{9B30176A-7175-4874-BE00-CB9C39342602}" TopLeft="12.4811320754717,129.311320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{3A00F380-1C97-4ECD-8677-D43AE1EB32E2}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{4851179E-EBF4-4F9D-A03D-35D8021FFA98}" TopLeft="73.3867924528302,49.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="6.98113207547169,79.8867924528302" Start="0,0" End="6.98113207547169,72.3867924528302"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,72.3867924528302" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{0BD898E5-EC4F-4919-B082-9CEBBF45105C}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{9A24F41E-51F3-426C-93D6-2EC1527B452D}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><DtsEventHandler xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{7E7946D1-3E16-4866-868E-6153A23D7869}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></DtsEventHandler></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{EFAA96FD-185A-4235-B662-4BBBBC8BF911}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{9B30176A-7175-4874-BE00-CB9C39342602}" TopLeft="12.4811320754717,129.311320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{3A00F380-1C97-4ECD-8677-D43AE1EB32E2}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{4851179E-EBF4-4F9D-A03D-35D8021FFA98}" TopLeft="73.3867924528302,49.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="6.98113207547169,79.8867924528302" Start="0,0" End="6.98113207547169,72.3867924528302"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,72.3867924528302" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: CompareExecuteProcess2Package

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 5:37:36 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {D6584679-B9C0-4867-9FEF-EED37D051B07}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | Enabled
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | CompareExecuteProcess1Package
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess2Package.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\CompareExecuteProcess2Package.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 2
VersionComments |
VersionGUID | {4464CC73-DE54-46EC-A2D3-D52FE518B20F}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
log.txt |

Collapse image Event handlers

Name | Description
OnError |

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Log providers

Name | Description
SSIS log provider for Text files | Writes log entries for events to a CSV file

Collapse image Precedence constraints

Name | Description
Constraint |

Collapse image User defined variables

Name | Description
MyVariable |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: CompareExecuteProcess2Package

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess2Package

Collapse image Connection managers

Name | Description
log.txt |

Collapse image System variables

No items exist
Name Description


Package element

Package element: log.txt

Collapse image Properties

Name | Value
ConnectionString | c:\temp\log.txt
CreationName | FILE
DelayValidation | False
Description |
FileUsageType | 1
HasExpressions | False
HostType | ConnectionManager
ID | {EA56E60E-88CB-49E3-9AFE-FF49784507D0}
Name | log.txt
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
Scope | Package
SupportsDTCTransactions | False

Collapse image Elements

Name | Description | Type
MyVariable |  | Variables


Package element

Package element: MyVariable

Collapse image Properties

Name | Value
CreationName |
DataType | String
Description |
EvaluateAsExpression | False
Expression |
IncludeInDebugDump | False
Name | MyVariable
Namespace | User
QualifiedName | User::MyVariable
RaiseChangedEvent | False
ReadOnly | False
SystemVariable | False
Value |
VariablePath | \Package.Variables[User::MyVariable]


Package

Package: CompareExecuteProcess2Package

Collapse image Event handlers

Name | Description
OnError |

Collapse image System variables

No items exist
Name Description


Package element

Package element: OnError

Collapse image Properties

Name | Value
CreationName | OnError
DebugMode | False
DelayValidation | False
Description |
Disable | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {CACB2C66-35B6-4225-8F48-4243B72443CC}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | OnError
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Execute Process Task | Execute Process Task | Executables
MyVariable |  | Variables


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments | c:\temp\log.txt
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | notepad.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {DB23FB19-2CD3-4B3F-B128-8C9FE12CCF4E}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos
MyVariable |  | Variables


Package

Package: CompareExecuteProcess2Package

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | calc.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {1B265A0B-B0FE-42E4-9DB2-D6D9D1A880E0}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable | User::MyVariable
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory | c:\temp\

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos
MyVariable |  | Variables


Package element

Package element: Execute Process Task 1

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments | arg1
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | mspaint.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {10190D27-E095-4097-872B-5E6D144D2965}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 1
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory | c:\temp\

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos
MyVariable |  | Variables


Package

Package: CompareExecuteProcess2Package

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess2Package

Collapse image Log providers

Name | Description
SSIS log provider for Text files | Writes log entries for events to a CSV file

Collapse image System variables

No items exist
Name Description


Package element

Package element: SSIS log provider for Text files

Collapse image Properties

Name | Value
ConfigString | log.txt
CreationName | Microsoft.LogProviderTextFile
DelayValidation | False
Description | Writes log entries for events to a CSV file
Enabled | True
HasExpressions | False
HostType | LogProvider
ID | {71EEE11B-3B98-4AC2-915C-70E562CECDA9}
Name | SSIS log provider for Text files


Package

Package: CompareExecuteProcess2Package

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: CompareExecuteProcess2Package

Collapse image Precedence constraints

Name | Description
Constraint |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {6CECDDAD-80B9-4F88-B6C2-C9D7A683D2E8}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | Execute Process Task 1
Value | Success


Package

Package: CompareExecuteProcess2Package

Collapse image User defined variables

Name | Description
MyVariable |

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 5:37:36 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{D6584679-B9C0-4867-9FEF-EED37D051B07}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="CompareExecuteProcess1Package" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="2" DTS:VersionGUID="{7198A793-3C0F-49DF-AF92-8C4A67242896}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[log.txt]" DTS:CreationName="FILE" DTS:DTSID="{EA56E60E-88CB-49E3-9AFE-FF49784507D0}" DTS:ObjectName="log.txt">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:FileUsageType="1" DTS:ConnectionString="c:\temp\log.txt"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
-<DTS:LogProviders>
-<DTS:LogProvider DTS:ConfigString="log.txt" DTS:CreationName="Microsoft.LogProviderTextFile" DTS:Description="Writes log entries for events to a CSV file" DTS:DTSID="{71EEE11B-3B98-4AC2-915C-70E562CECDA9}" DTS:ObjectName="SSIS log provider for Text files">
-<DTS:ObjectData>
<InnerObject/>
</DTS:ObjectData>
</DTS:LogProvider>
</DTS:LogProviders>
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:DTSID="{995422A8-EA01-49AE-AD9D-F84AFEBE86EE}" DTS:IncludeInDebugDump="2345" DTS:Namespace="User" DTS:ObjectName="MyVariable">
<DTS:VariableValue DTS:DataType="8" xml:space="preserve"/>
</DTS:Variable>
</DTS:Variables>
-<DTS:LoggingOptions DTS:FilterKind="0" DTS:LoggingMode="1">
<DTS:Property DTS:DataType="8" DTS:Name="EventFilter">1,12,OnPreExecute</DTS:Property>
-<DTS:Property DTS:EventName="OnPreExecute" DTS:Name="ColumnFilter">
<DTS:Property DTS:Name="Computer">-1</DTS:Property>
<DTS:Property DTS:Name="Operator">-1</DTS:Property>
<DTS:Property DTS:Name="SourceName">-1</DTS:Property>
<DTS:Property DTS:Name="SourceID">-1</DTS:Property>
<DTS:Property DTS:Name="ExecutionID">-1</DTS:Property>
<DTS:Property DTS:Name="MessageText">-1</DTS:Property>
<DTS:Property DTS:Name="DataBytes">-1</DTS:Property>
</DTS:Property>
-<DTS:SelectedLogProviders>
<DTS:SelectedLogProvider DTS:InstanceID="{71EEE11B-3B98-4AC2-915C-70E562CECDA9}"/>
</DTS:SelectedLogProviders>
</DTS:LoggingOptions>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{1B265A0B-B0FE-42E4-9DB2-D6D9D1A880E0}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="calc.exe" WorkingDirectory="c:\temp\" StandardOutputVariable="User::MyVariable"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 1" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{10190D27-E095-4097-872B-5E6D144D2965}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 1" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
<DTS:LoggingOptions DTS:FilterKind="0"/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="mspaint.exe" Arguments="arg1" WorkingDirectory="c:\temp\"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{6CECDDAD-80B9-4F88-B6C2-C9D7A683D2E8}" DTS:From="Package\Execute Process Task 1" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Execute Process Task"/>
</DTS:PrecedenceConstraints>
-<DTS:EventHandlers>
-<DTS:EventHandler DTS:refId="Package.EventHandlers[OnError]" DTS:CreationName="OnError" DTS:DTSID="{CACB2C66-35B6-4225-8F48-4243B72443CC}" DTS:EventID="0" DTS:EventName="OnError" DTS:LocaleID="-1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:Description="The propagate property of the event" DTS:DTSID="{564761C1-6A20-4BB3-A5E7-7A8B556E58CD}" DTS:IncludeInDebugDump="6789" DTS:Namespace="System" DTS:ObjectName="Propagate">
<DTS:VariableValue DTS:DataType="11">-1</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package.EventHandlers[OnError]\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{DB23FB19-2CD3-4B3F-B128-8C9FE12CCF4E}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="notepad.exe" Arguments="c:\temp\log.txt"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:EventHandler>
</DTS:EventHandlers>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{E9FC4A81-451A-43EC-9132-0142CD8D46E8}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{6CECDDAD-80B9-4F88-B6C2-C9D7A683D2E8}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Constraint</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{C8627FD4-697E-4D0E-BA85-EE66A491AF83}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{8199645F-43D0-47C0-BD18-778104292E8B}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{1B265A0B-B0FE-42E4-9DB2-D6D9D1A880E0}" TopLeft="12.4811320754717,129.311320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{10190D27-E095-4097-872B-5E6D144D2965}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{6CECDDAD-80B9-4F88-B6C2-C9D7A683D2E8}" TopLeft="73.3867924528302,49.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="6.98113207547169,79.8867924528302" Start="0,0" End="6.98113207547169,72.3867924528302"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,72.3867924528302" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{3730C7FA-9F2F-4D71-9581-82756852E2A4}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{CACB2C66-35B6-4225-8F48-4243B72443CC}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><DtsEventHandler xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{DB23FB19-2CD3-4B3F-B128-8C9FE12CCF4E}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></DtsEventHandler></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{9FB1E184-DABD-46B4-8198-574D4F09391D}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{1B265A0B-B0FE-42E4-9DB2-D6D9D1A880E0}" TopLeft="12.4811320754717,129.311320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{10190D27-E095-4097-872B-5E6D144D2965}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{6CECDDAD-80B9-4F88-B6C2-C9D7A683D2E8}" TopLeft="73.3867924528302,49.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="6.98113207547169,79.8867924528302" Start="0,0" End="6.98113207547169,72.3867924528302"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,39.9245283018868" /&gt;&lt;mssgle:LineSegment End="6.98113207547169,72.3867924528302" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: ConstraintsPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 3:00:59 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {212F7CF2-D12F-4C5A-BFC6-17EAA67BEC99}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | ConstraintsPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\ConstraintsPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\ConstraintsPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 3
VersionComments |
VersionGUID | {C47A730A-3A5C-425D-B3C6-BC2699F24782}
VersionMajor | 1
VersionMinor | 0

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task
Execute Process Task 2 | Execute Process Task
Execute Process Task 3 | Execute Process Task
Execute Process Task 4 | Execute Process Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 3 |

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: ConstraintsPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Connection managers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task
Execute Process Task 1 | Execute Process Task
Execute Process Task 2 | Execute Process Task
Execute Process Task 3 | Execute Process Task
Execute Process Task 4 | Execute Process Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | calc.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {CA22653E-BCBF-463D-8F63-35AF79E59537}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: Execute Process Task 1

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | mspaint.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {C99760AE-E33C-42E3-94D0-DD8A96F4EF7F}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 1
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: Execute Process Task 2

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | notepad.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {C4C1B38B-C16D-4A30-8C21-729F77B9E25E}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 2
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: Execute Process Task 3

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | wordpad.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {84E02DF7-DA77-4F72-9216-FE75AA52200E}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 3
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: Execute Process Task 4

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | services.msc
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {077BAE32-396A-48E6-88DF-8A258B457988}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task 4
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package

Package: ConstraintsPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: ConstraintsPackage

Collapse image Precedence constraints

Name | Description
Constraint |
Constraint 1 |
Constraint 2 |
Constraint 3 |

Collapse image System variables

No items exist
Name Description


Package element

Package element: Constraint

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task 1
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {CEC73878-70E3-4287-A26D-8E2EB6D4EDEE}
LogicalAnd | True
Name | Constraint
PrecedenceExecutable | Execute Process Task
Value | Success


Package element

Package element: Constraint 1

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task 2
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | False
Expression |
ID | {C5B6BEFA-A564-4105-8652-70006AD0B526}
LogicalAnd | True
Name | Constraint 1
PrecedenceExecutable | Execute Process Task
Value | Failure


Package element

Package element: Constraint 2

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task 3
CreationName |
Description |
EvalOp | Constraint
EvaluatesTrue | True
Expression |
ID | {479745FA-EED2-4BDD-B170-590301EDB8B8}
LogicalAnd | True
Name | Constraint 2
PrecedenceExecutable | Execute Process Task
Value | Completion


Package element

Package element: Constraint 3

Collapse image Properties

Name | Value
ConstrainedExecutable | Execute Process Task 4
CreationName |
Description |
EvalOp | Expression
EvaluatesTrue | False
Expression | 1==2
ID | {DEA14827-CF22-43EC-AE59-D6CEC47EC54B}
LogicalAnd | True
Name | Constraint 3
PrecedenceExecutable | Execute Process Task
Value | Success


Package

Package: ConstraintsPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 3:00:59 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{212F7CF2-D12F-4C5A-BFC6-17EAA67BEC99}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="ConstraintsPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="3" DTS:VersionGUID="{C4142D77-D590-4EC8-ABED-7097D804E3FE}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{CA22653E-BCBF-463D-8F63-35AF79E59537}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="calc.exe"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 1" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{C99760AE-E33C-42E3-94D0-DD8A96F4EF7F}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 1" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="mspaint.exe"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 2" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{C4C1B38B-C16D-4A30-8C21-729F77B9E25E}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 2" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="3">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="notepad.exe"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 3" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{84E02DF7-DA77-4F72-9216-FE75AA52200E}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 3" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="1">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="wordpad.exe"/>
</DTS:ObjectData>
</DTS:Executable>
-<DTS:Executable DTS:refId="Package\Execute Process Task 4" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{077BAE32-396A-48E6-88DF-8A258B457988}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task 4" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="2">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="services.msc"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PrecedenceConstraints>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint]" DTS:CreationName="" DTS:DTSID="{CEC73878-70E3-4287-A26D-8E2EB6D4EDEE}" DTS:From="Package\Execute Process Task" DTS:LogicalAnd="True" DTS:ObjectName="Constraint" DTS:To="Package\Execute Process Task 1"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 1]" DTS:CreationName="" DTS:DTSID="{C5B6BEFA-A564-4105-8652-70006AD0B526}" DTS:From="Package\Execute Process Task" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 1" DTS:To="Package\Execute Process Task 2" DTS:Value="1"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 2]" DTS:CreationName="" DTS:DTSID="{479745FA-EED2-4BDD-B170-590301EDB8B8}" DTS:From="Package\Execute Process Task" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 2" DTS:To="Package\Execute Process Task 3" DTS:Value="2"/>
<DTS:PrecedenceConstraint DTS:refId="Package.PrecedenceConstraints[Constraint 3]" DTS:CreationName="" DTS:DTSID="{DEA14827-CF22-43EC-AE59-D6CEC47EC54B}" DTS:EvalOp="1" DTS:Expression="1==2" DTS:From="Package\Execute Process Task" DTS:LogicalAnd="True" DTS:ObjectName="Constraint 3" DTS:To="Package\Execute Process Task 4"/>
</DTS:PrecedenceConstraints>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{5515DF94-4791-4E9E-BC0B-C8120EDCE63F}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{479745FA-EED2-4BDD-B170-590301EDB8B8}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Constraint</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{A8C05C6F-65F5-4B55-A5DC-79637991B04E}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{7BDFED6C-DCDC-4CF0-98F5-751AD378C3B8}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="16" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:mssgm="clr-namespace:Microsoft.SqlServer.Graph.Model;assembly=Microsoft.SqlServer.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{CA22653E-BCBF-463D-8F63-35AF79E59537}" TopLeft="296.028301886792,7.5" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{C99760AE-E33C-42E3-94D0-DD8A96F4EF7F}" TopLeft="199.198113207547,134.292452830189" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{C4C1B38B-C16D-4A30-8C21-729F77B9E25E}" TopLeft="402.858490566038,136.292452830189" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{84E02DF7-DA77-4F72-9216-FE75AA52200E}" TopLeft="611.537735849057,14.4811320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{077BAE32-396A-48E6-88DF-8A258B457988}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{CEC73878-70E3-4287-A26D-8E2EB6D4EDEE}" TopLeft="363.915094339623,51.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="-96.8301886792453,82.8679245283019" Start="0,0" End="-96.8301886792453,75.3679245283019"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,41.433962264151" /&gt;&lt;mssgle:LineSegment End="-96.8301886792453,41.433962264151" /&gt;&lt;mssgle:LineSegment End="-96.8301886792453,75.3679245283019" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{C5B6BEFA-A564-4105-8652-70006AD0B526}" TopLeft="384.669811320755,51.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="86.0754716981132,84.8679245283019" Start="0,0" End="86.0754716981132,77.3679245283019"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,42.4150943396227" /&gt;&lt;mssgle:LineSegment End="86.0754716981132,42.4150943396227" /&gt;&lt;mssgle:LineSegment End="86.0754716981132,77.3679245283019" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{479745FA-EED2-4BDD-B170-590301EDB8B8}" TopLeft="431.801886792453,29.4622641509434"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="179.735849056604,6.98113207547172" Start="0,0" End="172.235849056604,6.98113207547172"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="89.8490566037736,0" /&gt;&lt;mssgle:LineSegment End="89.8490566037736,6.98113207547172" /&gt;&lt;mssgle:LineSegment End="172.235849056604,6.98113207547172" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{DEA14827-CF22-43EC-AE59-D6CEC47EC54B}" TopLeft="296.028301886792,29.4622641509434"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="-154.754716981132,-2" Start="0,0" End="-147.254716981132,-2"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="-77.3962264150944,0" /&gt;&lt;mssgle:LineSegment End="-77.3962264150944,-2" /&gt;&lt;mssgle:LineSegment End="-147.254716981132,-2" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;mssgm:EdgeLabel BoundingBox="-85.3962264150944,5,16,16" RelativePosition="Any" /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{D692D267-8531-4B83-906E-B6D15151B73A}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{C5B6BEFA-A564-4105-8652-70006AD0B526}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Constraint</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{0FE7B3A1-2972-49F6-85B4-DF5CA0C25AB6}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{CEC73878-70E3-4287-A26D-8E2EB6D4EDEE}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Constraint</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{6712065C-DE95-4B52-AD3A-6139D4921DD4}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{DEA14827-CF22-43EC-AE59-D6CEC47EC54B}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PrecedenceConstraint xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:EvalOp>Expression</dwd:EvalOp></PrecedenceConstraint></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{C4F08660-D1BB-4F4E-B946-C473511ACD42}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="16" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:mssgm="clr-namespace:Microsoft.SqlServer.Graph.Model;assembly=Microsoft.SqlServer.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{CA22653E-BCBF-463D-8F63-35AF79E59537}" TopLeft="296.028301886792,7.5" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{C99760AE-E33C-42E3-94D0-DD8A96F4EF7F}" TopLeft="199.198113207547,134.292452830189" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{C4C1B38B-C16D-4A30-8C21-729F77B9E25E}" TopLeft="402.858490566038,136.292452830189" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{84E02DF7-DA77-4F72-9216-FE75AA52200E}" TopLeft="611.537735849057,14.4811320754717" /&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{077BAE32-396A-48E6-88DF-8A258B457988}" TopLeft="5.5,5.5" /&gt;&lt;EdgeLayout Id="{}{CEC73878-70E3-4287-A26D-8E2EB6D4EDEE}" TopLeft="363.915094339623,51.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="-96.8301886792453,82.8679245283019" Start="0,0" End="-96.8301886792453,75.3679245283019"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,41.433962264151" /&gt;&lt;mssgle:LineSegment End="-96.8301886792453,41.433962264151" /&gt;&lt;mssgle:LineSegment End="-96.8301886792453,75.3679245283019" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{C5B6BEFA-A564-4105-8652-70006AD0B526}" TopLeft="384.669811320755,51.4245283018868"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="86.0754716981132,84.8679245283019" Start="0,0" End="86.0754716981132,77.3679245283019"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="0,42.4150943396227" /&gt;&lt;mssgle:LineSegment End="86.0754716981132,42.4150943396227" /&gt;&lt;mssgle:LineSegment End="86.0754716981132,77.3679245283019" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{479745FA-EED2-4BDD-B170-590301EDB8B8}" TopLeft="431.801886792453,29.4622641509434"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="179.735849056604,6.98113207547172" Start="0,0" End="172.235849056604,6.98113207547172"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="89.8490566037736,0" /&gt;&lt;mssgle:LineSegment End="89.8490566037736,6.98113207547172" /&gt;&lt;mssgle:LineSegment End="172.235849056604,6.98113207547172" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;EdgeLayout Id="{}{DEA14827-CF22-43EC-AE59-D6CEC47EC54B}" TopLeft="296.028301886792,29.4622641509434"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="-154.754716981132,-2" Start="0,0" End="-147.254716981132,-2"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="4"&gt;&lt;mssgle:LineSegment End="-77.3962264150944,0" /&gt;&lt;mssgle:LineSegment End="-77.3962264150944,-2" /&gt;&lt;mssgle:LineSegment End="-147.254716981132,-2" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;mssgm:EdgeLabel BoundingBox="-85.3962264150944,5,16,16" RelativePosition="Any" /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: DataCorrectionPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 12/13/2010 1:21:45 AM
CreationName | Microsoft.Package
CreatorComputerName | WIN-LSD6RQU6DTH
CreatorName | WIN-LSD6RQU6DTH\Administrator
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {7E21712B-D41D-47C6-9826-E41029098BE4}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | DataCorrectionPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\DataCorrectionPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\DataCorrectionPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 7
VersionComments |
VersionGUID | {EF3BF7A2-11BA-43A7-8A31-CB092B732F20}
VersionMajor | 1
VersionMinor | 0

Collapse image Connection managers

Name | Description
localhost.AdventureWorks |

Collapse image Executables

Name | Description
Data Flow Task | Data Flow Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: DataCorrectionPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image Connection managers

Name | Description
localhost.AdventureWorks |

Collapse image System variables

No items exist
Name Description


Package element

Package element: localhost.AdventureWorks

Collapse image Properties

Name | Value
ConnectionString | Data Source=localhost;Initial Catalog=AdventureWorks;Provider=SQLNCLI11.1;Integrated Security=SSPI;Auto Translate=False;
CreationName | OLEDB
DelayValidation | False
Description |
HasExpressions | False
HostType | ConnectionManager
ID | {10E377DE-C53D-45B3-B815-FF71ED7F2115}
InitialCatalog | AdventureWorks
Name | localhost.AdventureWorks
OfflineMode | False
ProtectionLevel | EncryptSensitiveWithUserKey
Qualifier |
RetainSameConnection | False
Scope | Package
ServerName | localhost
SupportsDTCTransactions | True
UserName |


Package

Package: DataCorrectionPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image Executables

Name | Description
Data Flow Task | Data Flow Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Data Flow Task

Collapse image Properties

Name | Value
ApartmentThreaded | False
AutoGenerateIDForNewObjects | True
BLOBTempStoragePath |
BufferTempStoragePath |
CreationName | SSIS.Pipeline.4
DebugMode | False
DefaultBufferMaxRows | 10000
DefaultBufferSize | 10485760
DelayValidation | False
Description | Data Flow Task
Disable | False
DisableEventHandlers | False
EnableCacheUpdate | True
EnableDisconnectedColumns | False
EngineThreads | 10
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {7D3A996B-E080-4A1B-B3E7-612104921CF5}
IsDefaultLocaleID | True
IsolationLevel | Serializable
IsSavingXml | False
LocaleID | English (United States)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Data Flow Task
RunInOptimizedMode | True
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Data Correction | SSDQS Data correction component | ComponentMetaDataCollection
OLE DB Destination | OLE DB Destination | ComponentMetaDataCollection
OLE DB Source | OLE DB Source | ComponentMetaDataCollection
BufferSizeTuning | The Data Flow changed the size of a buffer away from the default values. The event text includes the sizes and the reasons. | LogEntryInfos
PipelineBufferLeak | After execution, some buffers were left outstanding. Some transform is hanging onto buffer references and if it freed them we would use a lot less memory. The logged text includes information about the transform that owned the buffer, and the ID of the buffer. | LogEntryInfos
PipelineComponentTime | Information about each phase of validation and execution for each data flow component. The processing time of each phase is specified. | LogEntryInfos
PipelineExecutionPlan | The execution plan of the data flow. | LogEntryInfos
PipelineExecutionTrees | The input the scheduler had when forming the execution plan. | LogEntryInfos
PipelineInitialization | Various information from Data Flow initialization. | LogEntryInfos
Data Correction Output |  | PathCollection
OLE DB Source Output |  | PathCollection
SSIS diagram is missing


Package element

Package element: Data Correction

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {33D831DE-5DCF-48F0-B431-4D327B9E785D}
ContactInfo |
Description | SSDQS Data correction component
ID | 2
IdentificationString | Data Correction
IsDefaultLocale | True
LocaleID | English (United States)
Name | Data Correction
ObjectType | 12
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 0

Collapse image Elements

Name | Description | Type
DomainGroupName |  | CustomPropertyCollection
UserComponentTypeName |  | CustomPropertyCollection
Data Correction Input |  | InputCollection
Data Correction Output |  | OutputCollection


Package element

Package element: DomainGroupName

Collapse image Properties

Name | Value
ContainsID | False
Description |
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 3
IdentificationString | Data Correction.Properties[DomainGroupName]
Name | DomainGroupName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | NOTBROWSABLE
UITypeEditor |
Value | 0


Package element

Package element: UserComponentTypeName

Collapse image Properties

Name | Value
ContainsID | False
Description |
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 4
IdentificationString | Data Correction.Properties[UserComponentTypeName]
Name | UserComponentTypeName
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | Microsoft.Ssdqs.Component.DataCorrection.Logic.DataCorrectionComponent, Microsoft.Ssdqs.Component.DataCorrection, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91


Package element

Package element: Data Correction Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 5
IdentificationString | Data Correction.Inputs[Data Correction Input]
IsAttached | True
IsSorted | False
Name | Data Correction Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed


Package element

Package element: Data Correction Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 6
IdentificationString | Data Correction.Outputs[Data Correction Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | Data Correction Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
IsCorrected |  | OutputColumnCollection


Package element

Package element: IsCorrected

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 7
IdentificationString | Data Correction.Outputs[Data Correction Output].Columns[IsCorrected]
Length | 0
LineageID | 7
MappedColumnID | 0
Name | IsCorrected
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OLE DB Destination

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {63F60893-F24D-421A-A481-86C53A0ADBA8}
ContactInfo | OLE DB Destination;Microsoft Corporation; Microsoft SQL Server; (C) Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4
Description | OLE DB Destination
ID | 8
IdentificationString | OLE DB Destination
IsDefaultLocale | True
LocaleID | English (United States)
Name | OLE DB Destination
ObjectType | 10
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 4

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
FastLoadKeepIdentity | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadKeepNulls | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destination. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadOptions | Specifies options to be used with fast load. Applies only if fast load is turned on. | CustomPropertyCollection
FastLoadMaxInsertCommitSize | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on. | CustomPropertyCollection
OLE DB Destination Input |  | InputCollection
OLE DB Destination Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 9
IdentificationString | OLE DB Destination.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 10
IdentificationString | OLE DB Destination.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [Person].[Person]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 11
IdentificationString | OLE DB Destination.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 12
IdentificationString | OLE DB Destination.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 13
IdentificationString | OLE DB Destination.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 14
IdentificationString | OLE DB Destination.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 15
IdentificationString | OLE DB Destination.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 3


Package element

Package element: FastLoadKeepIdentity

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 16
IdentificationString | OLE DB Destination.Properties[FastLoadKeepIdentity]
Name | FastLoadKeepIdentity
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadKeepNulls

Collapse image Properties

Name | Value
ContainsID | False
Description | Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destination. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 17
IdentificationString | OLE DB Destination.Properties[FastLoadKeepNulls]
Name | FastLoadKeepNulls
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: FastLoadOptions

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies options to be used with fast load. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 18
IdentificationString | OLE DB Destination.Properties[FastLoadOptions]
Name | FastLoadOptions
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | TABLOCK,CHECK_CONSTRAINTS


Package element

Package element: FastLoadMaxInsertCommitSize

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 19
IdentificationString | OLE DB Destination.Properties[FastLoadMaxInsertCommitSize]
Name | FastLoadMaxInsertCommitSize
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 2147483647


Package element

Package element: OLE DB Destination Input

Collapse image Properties

Name | Value
AreInputColumnsAssociatedWithOutputColumns | True
BufferBase | 0
Dangling | False
Description |
ErrorOrTruncationOperation | Insert
ErrorRowDisposition | RD_FailComponent
HasSideEffects | True
ID | 21
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input]
IsAttached | True
IsSorted | False
Name | OLE DB Destination Input
ObjectType | OT_INPUT
SourceLocale | 1033
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
rowguid |  | ExternalMetadataColumnCollection
ModifiedDate |  | ExternalMetadataColumnCollection
BusinessEntityID |  | ExternalMetadataColumnCollection
PersonType |  | ExternalMetadataColumnCollection
NameStyle |  | ExternalMetadataColumnCollection
Title |  | ExternalMetadataColumnCollection
FirstName |  | ExternalMetadataColumnCollection
MiddleName |  | ExternalMetadataColumnCollection
LastName |  | ExternalMetadataColumnCollection
Suffix |  | ExternalMetadataColumnCollection
EmailPromotion |  | ExternalMetadataColumnCollection
AdditionalContactInfo |  | ExternalMetadataColumnCollection
Demographics |  | ExternalMetadataColumnCollection
IsCorrected |  | InputColumnCollection


Package element

Package element: rowguid

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_GUID
Description |
ID | 23
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[rowguid]
Length | 0
MappedColumnID | 0
Name | rowguid
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ModifiedDate

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 24
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[ModifiedDate]
Length | 0
MappedColumnID | 0
Name | ModifiedDate
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: BusinessEntityID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 25
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[BusinessEntityID]
Length | 0
MappedColumnID | 0
Name | BusinessEntityID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: PersonType

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 26
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[PersonType]
Length | 2
MappedColumnID | 0
Name | PersonType
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: NameStyle

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_BOOL
Description |
ID | 27
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[NameStyle]
Length | 0
MappedColumnID | 0
Name | NameStyle
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Title

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 28
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Title]
Length | 8
MappedColumnID | 0
Name | Title
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: FirstName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 29
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[FirstName]
Length | 50
MappedColumnID | 0
Name | FirstName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: MiddleName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 30
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[MiddleName]
Length | 50
MappedColumnID | 0
Name | MiddleName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: LastName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 31
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[LastName]
Length | 50
MappedColumnID | 0
Name | LastName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Suffix

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 32
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Suffix]
Length | 10
MappedColumnID | 0
Name | Suffix
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: EmailPromotion

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 33
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[EmailPromotion]
Length | 0
MappedColumnID | 0
Name | EmailPromotion
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: AdditionalContactInfo

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 34
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[AdditionalContactInfo]
Length | 0
MappedColumnID | 0
Name | AdditionalContactInfo
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: Demographics

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_NTEXT
Description |
ID | 35
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Demographics]
Length | 0
MappedColumnID | 0
Name | Demographics
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: IsCorrected

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_BOOL
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 27
ID | 22
IdentificationString | OLE DB Destination.Inputs[OLE DB Destination Input].Columns[IsCorrected]
IsAssociatedWithOutputColumn | True
IsValid | True
Length | 0
LineageID | 7
MappedColumnID | 0
Name | IsCorrected
ObjectType | OT_INPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
TruncationRowDisposition | RD_NotUsed
UpstreamComponentName | Data Correction
UsageType | UT_READONLY


Package element

Package element: OLE DB Destination Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 1
HasSideEffects | False
ID | 36
IdentificationString | OLE DB Destination.Outputs[OLE DB Destination Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Destination Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 21
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 37
IdentificationString | OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]
Length | 0
LineageID | 37
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 38
IdentificationString | OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 38
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {10E377DE-C53D-45B3-B815-FF71ED7F2115}
Description | The OLE DB runtime connection used to access the database.
ID | 20
IdentificationString | OLE DB Destination.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: OLE DB Source

Collapse image Properties

Name | Value
AreInputColumnsValid | True
ComponentClassID | {D1AA3237-CE07-40F9-AA7D-DB75A2552BAC}
ContactInfo | OLE DB Source;Microsoft Corporation; Microsoft SQL Server; (C) Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7
Description | OLE DB Source
ID | 39
IdentificationString | OLE DB Source
IsDefaultLocale | True
LocaleID | English (United States)
Name | OLE DB Source
ObjectType | 9
PipelineVersion | 0
UsesDispositions | True
ValidateExternalMetadata | True
Version | 7

Collapse image Elements

Name | Description | Type
CommandTimeout | The number of seconds before a command times out. A value of 0 indicates an infinite time-out. | CustomPropertyCollection
OpenRowset | Specifies the name of the database object used to open a rowset. | CustomPropertyCollection
OpenRowsetVariable | Specifies the variable that contains the name of the database object used to open a rowset. | CustomPropertyCollection
SqlCommand | The SQL command to be executed. | CustomPropertyCollection
SqlCommandVariable | The variable that contains the SQL command to be executed. | CustomPropertyCollection
DefaultCodePage | Specifies the column code page to use when code page information is unavailable from the data source. | CustomPropertyCollection
AlwaysUseDefaultCodePage | Forces the use of the DefaultCodePage property value when describing character data. | CustomPropertyCollection
AccessMode | Specifies the mode used to access the database. | CustomPropertyCollection
ParameterMapping | The mappings between the parameters in the SQL command and variables. | CustomPropertyCollection
OLE DB Source Output |  | OutputCollection
OLE DB Source Error Output |  | OutputCollection
OleDbConnection | The OLE DB runtime connection used to access the database. | RuntimeConnectionCollection


Package element

Package element: CommandTimeout

Collapse image Properties

Name | Value
ContainsID | False
Description | The number of seconds before a command times out. A value of 0 indicates an infinite time-out.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 40
IdentificationString | OLE DB Source.Properties[CommandTimeout]
Name | CommandTimeout
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 0


Package element

Package element: OpenRowset

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 41
IdentificationString | OLE DB Source.Properties[OpenRowset]
Name | OpenRowset
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | [dbo].[ErrorLog]


Package element

Package element: OpenRowsetVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the variable that contains the name of the database object used to open a rowset.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 42
IdentificationString | OLE DB Source.Properties[OpenRowsetVariable]
Name | OpenRowsetVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: SqlCommand

Collapse image Properties

Name | Value
ContainsID | False
Description | The SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 43
IdentificationString | OLE DB Source.Properties[SqlCommand]
Name | SqlCommand
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor | Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor, Microsoft.DataTransformationServices.Controls, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
Value |


Package element

Package element: SqlCommandVariable

Collapse image Properties

Name | Value
ContainsID | False
Description | The variable that contains the SQL command to be executed.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 44
IdentificationString | OLE DB Source.Properties[SqlCommandVariable]
Name | SqlCommandVariable
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: DefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the column code page to use when code page information is unavailable from the data source.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 45
IdentificationString | OLE DB Source.Properties[DefaultCodePage]
Name | DefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | 1252


Package element

Package element: AlwaysUseDefaultCodePage

Collapse image Properties

Name | Value
ContainsID | False
Description | Forces the use of the DefaultCodePage property value when describing character data.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 46
IdentificationString | OLE DB Source.Properties[AlwaysUseDefaultCodePage]
Name | AlwaysUseDefaultCodePage
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value | False


Package element

Package element: AccessMode

Collapse image Properties

Name | Value
ContainsID | False
Description | Specifies the mode used to access the database.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 47
IdentificationString | OLE DB Source.Properties[AccessMode]
Name | AccessMode
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter | AccessMode
UITypeEditor |
Value | 0


Package element

Package element: ParameterMapping

Collapse image Properties

Name | Value
ContainsID | False
Description | The mappings between the parameters in the SQL command and variables.
EncryptionRequired | False
ExpressionType | CPET_NONE
ID | 48
IdentificationString | OLE DB Source.Properties[ParameterMapping]
Name | ParameterMapping
ObjectType | OT_PROPERTY
State | PS_DEFAULT
TypeConverter |
UITypeEditor |
Value |


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 50
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output]
IsAttached | True
IsErrorOut | False
IsSorted | False
Name | OLE DB Source Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
UserName |  | ExternalMetadataColumnCollection
ErrorLogID |  | ExternalMetadataColumnCollection
ErrorTime |  | ExternalMetadataColumnCollection
ErrorNumber |  | ExternalMetadataColumnCollection
ErrorSeverity |  | ExternalMetadataColumnCollection
ErrorState |  | ExternalMetadataColumnCollection
ErrorProcedure |  | ExternalMetadataColumnCollection
ErrorLine |  | ExternalMetadataColumnCollection
ErrorMessage |  | ExternalMetadataColumnCollection
UserName |  | OutputColumnCollection
ErrorLogID |  | OutputColumnCollection
ErrorTime |  | OutputColumnCollection
ErrorNumber |  | OutputColumnCollection
ErrorSeverity |  | OutputColumnCollection
ErrorState |  | OutputColumnCollection
ErrorProcedure |  | OutputColumnCollection
ErrorLine |  | OutputColumnCollection
ErrorMessage |  | OutputColumnCollection


Package element

Package element: UserName

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 60
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[UserName]
Length | 128
MappedColumnID | 0
Name | UserName
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorLogID

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 61
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLogID]
Length | 0
MappedColumnID | 0
Name | ErrorLogID
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorTime

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_DBTIMESTAMP
Description |
ID | 62
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorTime]
Length | 0
MappedColumnID | 0
Name | ErrorTime
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorNumber

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 63
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorNumber]
Length | 0
MappedColumnID | 0
Name | ErrorNumber
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorSeverity

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 64
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorSeverity]
Length | 0
MappedColumnID | 0
Name | ErrorSeverity
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorState

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 65
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorState]
Length | 0
MappedColumnID | 0
Name | ErrorState
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorProcedure

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 66
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorProcedure]
Length | 126
MappedColumnID | 0
Name | ErrorProcedure
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorLine

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_I4
Description |
ID | 67
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLine]
Length | 0
MappedColumnID | 0
Name | ErrorLine
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: ErrorMessage

Collapse image Properties

Name | Value
CodePage | 0
DataType | DT_WSTR
Description |
ID | 68
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorMessage]
Length | 4000
MappedColumnID | 0
Name | ErrorMessage
ObjectType | OT_EXTERNALMETADATACOLUMN
Precision | 0
Scale | 0


Package element

Package element: UserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 60
ID | 51
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[UserName]
Length | 260
LineageID | 51
MappedColumnID | 0
Name | UserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorLogID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 61
ID | 52
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLogID]
Length | 0
LineageID | 52
MappedColumnID | 0
Name | ErrorLogID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 62
ID | 53
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorTime]
Length | 0
LineageID | 53
MappedColumnID | 0
Name | ErrorTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorNumber

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 63
ID | 54
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorNumber]
Length | 0
LineageID | 54
MappedColumnID | 0
Name | ErrorNumber
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorSeverity

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 64
ID | 55
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorSeverity]
Length | 0
LineageID | 55
MappedColumnID | 0
Name | ErrorSeverity
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorState

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 65
ID | 56
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorState]
Length | 0
LineageID | 56
MappedColumnID | 0
Name | ErrorState
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorProcedure

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 66
ID | 57
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorProcedure]
Length | 126
LineageID | 57
MappedColumnID | 0
Name | ErrorProcedure
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorLine

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 67
ID | 58
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLine]
Length | 0
LineageID | 58
MappedColumnID | 0
Name | ErrorLine
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: ErrorMessage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation | Conversion
ErrorRowDisposition | RD_FailComponent
ExternalMetadataColumnID | 68
ID | 59
IdentificationString | OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorMessage]
Length | 4000
LineageID | 59
MappedColumnID | 0
Name | ErrorMessage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_FailComponent


Package element

Package element: OLE DB Source Error Output

Collapse image Properties

Name | Value
Dangling | False
DeleteOutputOnPathDetached | False
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExclusionGroup | 0
HasSideEffects | False
ID | 69
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output]
IsAttached | False
IsErrorOut | True
IsSorted | False
Name | OLE DB Source Error Output
ObjectType | OT_OUTPUT
SynchronousInputID | 0
TruncationRowDisposition | RD_NotUsed

Collapse image Elements

Name | Description | Type
ErrorLogID |  | OutputColumnCollection
ErrorTime |  | OutputColumnCollection
UserName |  | OutputColumnCollection
ErrorNumber |  | OutputColumnCollection
ErrorSeverity |  | OutputColumnCollection
ErrorState |  | OutputColumnCollection
ErrorProcedure |  | OutputColumnCollection
ErrorLine |  | OutputColumnCollection
ErrorMessage |  | OutputColumnCollection
ErrorCode |  | OutputColumnCollection
ErrorColumn |  | OutputColumnCollection


Package element

Package element: ErrorLogID

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 70
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLogID]
Length | 0
LineageID | 70
MappedColumnID | 0
Name | ErrorLogID
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorTime

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_DBTIMESTAMP
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 71
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorTime]
Length | 0
LineageID | 71
MappedColumnID | 0
Name | ErrorTime
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: UserName

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 72
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[UserName]
Length | 128
LineageID | 72
MappedColumnID | 0
Name | UserName
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorNumber

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 73
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorNumber]
Length | 0
LineageID | 73
MappedColumnID | 0
Name | ErrorNumber
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorSeverity

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 74
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorSeverity]
Length | 0
LineageID | 74
MappedColumnID | 0
Name | ErrorSeverity
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorState

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 75
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorState]
Length | 0
LineageID | 75
MappedColumnID | 0
Name | ErrorState
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorProcedure

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 76
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorProcedure]
Length | 126
LineageID | 76
MappedColumnID | 0
Name | ErrorProcedure
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorLine

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 77
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLine]
Length | 0
LineageID | 77
MappedColumnID | 0
Name | ErrorLine
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorMessage

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_WSTR
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 78
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorMessage]
Length | 4000
LineageID | 78
MappedColumnID | 0
Name | ErrorMessage
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 0
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorCode

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 79
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]
Length | 0
LineageID | 79
MappedColumnID | 0
Name | ErrorCode
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 1
TruncationRowDisposition | RD_NotUsed


Package element

Package element: ErrorColumn

Collapse image Properties

Name | Value
CodePage | 0
ComparisonFlags | 0
DataType | DT_I4
Description |
ErrorOrTruncationOperation |
ErrorRowDisposition | RD_NotUsed
ExternalMetadataColumnID | 0
ID | 80
IdentificationString | OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]
Length | 0
LineageID | 80
MappedColumnID | 0
Name | ErrorColumn
ObjectType | OT_OUTPUTCOLUMN
Precision | 0
Scale | 0
SortKeyPosition | 0
SpecialFlags | 2
TruncationRowDisposition | RD_NotUsed


Package element

Package element: OleDbConnection

Collapse image Properties

Name | Value
ConnectionManager |
ConnectionManagerID | {10E377DE-C53D-45B3-B815-FF71ED7F2115}
Description | The OLE DB runtime connection used to access the database.
ID | 49
IdentificationString | OLE DB Source.Connections[OleDbConnection]
Name | OleDbConnection
ObjectType | OT_RUNTIMECONNECTION


Package element

Package element: Data Correction Output

Collapse image Properties

Name | Value
Description |
EndPoint | OLE DB Destination Input
Name | Data Correction Output
ObjectType | OT_PATH
StartPoint | Data Correction Output


Package element

Package element: OLE DB Source Output

Collapse image Properties

Name | Value
Description |
EndPoint | Data Correction Input
Name | OLE DB Source Output
ObjectType | OT_PATH
StartPoint | OLE DB Source Output


Package

Package: DataCorrectionPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: DataCorrectionPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="12/13/2010 1:21:45 AM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="WIN-LSD6RQU6DTH" DTS:CreatorName="WIN-LSD6RQU6DTH\Administrator" DTS:DTSID="{7E21712B-D41D-47C6-9826-E41029098BE4}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1033" DTS:ObjectName="DataCorrectionPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="7" DTS:VersionGUID="{C8425DFC-51E5-4933-B2A3-EF800B49E453}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
-<DTS:ConnectionManagers>
-<DTS:ConnectionManager DTS:refId="Package.ConnectionManagers[localhost.AdventureWorks]" DTS:CreationName="OLEDB" DTS:DTSID="{10E377DE-C53D-45B3-B815-FF71ED7F2115}" DTS:ObjectName="localhost.AdventureWorks">
-<DTS:ObjectData>
<DTS:ConnectionManager DTS:ConnectionString="Data Source=localhost;Initial Catalog=AdventureWorks;Provider=SQLNCLI11.1;Integrated Security=SSPI;Auto Translate=False;"/>
</DTS:ObjectData>
</DTS:ConnectionManager>
</DTS:ConnectionManagers>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Data Flow Task" DTS:CreationName="Microsoft.Pipeline" DTS:Description="Data Flow Task" DTS:DTSID="{7D3A996B-E080-4A1B-B3E7-612104921CF5}" DTS:ExecutableType="Microsoft.Pipeline" DTS:LocaleID="-1" DTS:ObjectName="Data Flow Task">
<DTS:Variables/>
-<DTS:ObjectData>
-<pipeline BLOBTempStoragePath="" bufferTempStoragePath="" version="1">
-<components>
-<component refId="Package\Data Flow Task\Data Correction" componentClassID="Microsoft.ManagedComponentHost" description="SSDQS Data correction component" name="Data Correction" usesDispositions="true">
-<properties>
<property dataType="System.Int64" name="DomainGroupName" typeConverter="NOTBROWSABLE">0</property>
<property dataType="System.String" name="UserComponentTypeName">Microsoft.DataCorrectionComponent</property>
</properties>
-<inputs>
-<input refId="Package\Data Flow Task\Data Correction.Inputs[Data Correction Input]" errorRowDisposition="FailComponent" hasSideEffects="true" name="Data Correction Input">
<externalMetadataColumns/>
</input>
</inputs>
-<outputs>
-<output refId="Package\Data Flow Task\Data Correction.Outputs[Data Correction Output]" name="Data Correction Output">
-<outputColumns>
<outputColumn refId="Package\Data Flow Task\Data Correction.Outputs[Data Correction Output].Columns[IsCorrected]" dataType="bool" lineageId="Package\Data Flow Task\Data Correction.Outputs[Data Correction Output].Columns[IsCorrected]" name="IsCorrected"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\Data Flow Task\OLE DB Destination" componentClassID="Microsoft.OLEDBDestination" contactInfo="OLE DB Destination;Microsoft Corporation; Microsoft SQL Server; (C) Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;4" description="OLE DB Destination" name="OLE DB Destination" usesDispositions="true" version="4">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[Person].[Person]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">3</property>
<property dataType="System.Boolean" description="Indicates whether the values supplied for identity columns will be copied to the destination. If false, values for identity columns will be auto-generated at the destination. Applies only if fast load is turned on." name="FastLoadKeepIdentity">false</property>
<property dataType="System.Boolean" description="Indicates whether the columns containing null will have null inserted in the destination. If false, columns containing null will have their default values inserted at the destination. Applies only if fast load is turned on." name="FastLoadKeepNulls">false</property>
<property dataType="System.String" description="Specifies options to be used with fast load. Applies only if fast load is turned on." name="FastLoadOptions">TABLOCK,CHECK_CONSTRAINTS</property>
<property dataType="System.Int32" description="Specifies when commits are issued during data insertion. A value of 0 specifies that one commit will be issued at the end of data insertion. Applies only if fast load is turned on." name="FastLoadMaxInsertCommitSize">2147483647</property>
</properties>
-<connections>
<connection refId="Package\Data Flow Task\OLE DB Destination.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[localhost.AdventureWorks]" connectionManagerRefId="Package.ConnectionManagers[localhost.AdventureWorks]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<inputs>
-<input refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input]" errorOrTruncationOperation="Insert" errorRowDisposition="FailComponent" hasSideEffects="true" name="OLE DB Destination Input">
-<inputColumns>
<inputColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].Columns[IsCorrected]" cachedDataType="bool" cachedName="IsCorrected" externalMetadataColumnId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[NameStyle]" lineageId="Package\Data Flow Task\Data Correction.Outputs[Data Correction Output].Columns[IsCorrected]"/>
</inputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[rowguid]" dataType="guid" name="rowguid"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[ModifiedDate]" dataType="dbTimeStamp" name="ModifiedDate"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[BusinessEntityID]" dataType="i4" name="BusinessEntityID"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[PersonType]" dataType="wstr" length="2" name="PersonType"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[NameStyle]" dataType="bool" name="NameStyle"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Title]" dataType="wstr" length="8" name="Title"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[FirstName]" dataType="wstr" length="50" name="FirstName"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[MiddleName]" dataType="wstr" length="50" name="MiddleName"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[LastName]" dataType="wstr" length="50" name="LastName"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Suffix]" dataType="wstr" length="10" name="Suffix"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[EmailPromotion]" dataType="i4" name="EmailPromotion"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[AdditionalContactInfo]" dataType="nText" name="AdditionalContactInfo"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input].ExternalColumns[Demographics]" dataType="nText" name="Demographics"/>
</externalMetadataColumns>
</input>
</inputs>
-<outputs>
-<output refId="Package\Data Flow Task\OLE DB Destination.Outputs[OLE DB Destination Error Output]" exclusionGroup="1" isErrorOut="true" name="OLE DB Destination Error Output" synchronousInputId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input]">
-<outputColumns>
<outputColumn refId="Package\Data Flow Task\OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Destination.Outputs[OLE DB Destination Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
-<component refId="Package\Data Flow Task\OLE DB Source" componentClassID="Microsoft.OLEDBSource" contactInfo="OLE DB Source;Microsoft Corporation; Microsoft SQL Server; (C) Microsoft Corporation; All Rights Reserved; http://www.microsoft.com/sql/support;7" description="OLE DB Source" name="OLE DB Source" usesDispositions="true" version="7">
-<properties>
<property dataType="System.Int32" description="The number of seconds before a command times out. A value of 0 indicates an infinite time-out." name="CommandTimeout">0</property>
<property dataType="System.String" description="Specifies the name of the database object used to open a rowset." name="OpenRowset">[dbo].[ErrorLog]</property>
<property dataType="System.String" description="Specifies the variable that contains the name of the database object used to open a rowset." name="OpenRowsetVariable"/>
<property dataType="System.String" description="The SQL command to be executed." name="SqlCommand" UITypeEditor="Microsoft.DataTransformationServices.Controls.ModalMultilineStringEditor"/>
<property dataType="System.String" description="The variable that contains the SQL command to be executed." name="SqlCommandVariable"/>
<property dataType="System.Int32" description="Specifies the column code page to use when code page information is unavailable from the data source." name="DefaultCodePage">1252</property>
<property dataType="System.Boolean" description="Forces the use of the DefaultCodePage property value when describing character data." name="AlwaysUseDefaultCodePage">false</property>
<property dataType="System.Int32" description="Specifies the mode used to access the database." name="AccessMode" typeConverter="AccessMode">0</property>
<property dataType="System.String" description="The mappings between the parameters in the SQL command and variables." name="ParameterMapping"/>
</properties>
-<connections>
<connection refId="Package\Data Flow Task\OLE DB Source.Connections[OleDbConnection]" connectionManagerID="Package.ConnectionManagers[localhost.AdventureWorks]" connectionManagerRefId="Package.ConnectionManagers[localhost.AdventureWorks]" description="The OLE DB runtime connection used to access the database." name="OleDbConnection"/>
</connections>
-<outputs>
-<output refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output]" name="OLE DB Source Output">
-<outputColumns>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[UserName]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[UserName]" length="260" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[UserName]" name="UserName" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLogID]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLogID]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLogID]" name="ErrorLogID" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorTime]" dataType="dbTimeStamp" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorTime]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorTime]" name="ErrorTime" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorNumber]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorNumber]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorNumber]" name="ErrorNumber" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorSeverity]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorSeverity]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorSeverity]" name="ErrorSeverity" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorState]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorState]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorState]" name="ErrorState" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorProcedure]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorProcedure]" length="126" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorProcedure]" name="ErrorProcedure" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLine]" dataType="i4" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLine]" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorLine]" name="ErrorLine" truncationRowDisposition="FailComponent"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorMessage]" dataType="wstr" errorOrTruncationOperation="Conversion" errorRowDisposition="FailComponent" externalMetadataColumnId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorMessage]" length="4000" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].Columns[ErrorMessage]" name="ErrorMessage" truncationRowDisposition="FailComponent"/>
</outputColumns>
-<externalMetadataColumns isUsed="True">
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[UserName]" dataType="wstr" length="128" name="UserName"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLogID]" dataType="i4" name="ErrorLogID"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorTime]" dataType="dbTimeStamp" name="ErrorTime"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorNumber]" dataType="i4" name="ErrorNumber"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorSeverity]" dataType="i4" name="ErrorSeverity"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorState]" dataType="i4" name="ErrorState"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorProcedure]" dataType="wstr" length="126" name="ErrorProcedure"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorLine]" dataType="i4" name="ErrorLine"/>
<externalMetadataColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output].ExternalColumns[ErrorMessage]" dataType="wstr" length="4000" name="ErrorMessage"/>
</externalMetadataColumns>
</output>
-<output refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output]" isErrorOut="true" name="OLE DB Source Error Output">
-<outputColumns>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLogID]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLogID]" name="ErrorLogID"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorTime]" dataType="dbTimeStamp" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorTime]" name="ErrorTime"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[UserName]" dataType="wstr" length="128" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[UserName]" name="UserName"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorNumber]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorNumber]" name="ErrorNumber"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorSeverity]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorSeverity]" name="ErrorSeverity"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorState]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorState]" name="ErrorState"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorProcedure]" dataType="wstr" length="126" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorProcedure]" name="ErrorProcedure"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLine]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorLine]" name="ErrorLine"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorMessage]" dataType="wstr" length="4000" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorMessage]" name="ErrorMessage"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorCode]" name="ErrorCode" specialFlags="1"/>
<outputColumn refId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" dataType="i4" lineageId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Error Output].Columns[ErrorColumn]" name="ErrorColumn" specialFlags="2"/>
</outputColumns>
<externalMetadataColumns/>
</output>
</outputs>
</component>
</components>
-<paths>
<path refId="Package\Data Flow Task.Paths[Data Correction Output]" endId="Package\Data Flow Task\OLE DB Destination.Inputs[OLE DB Destination Input]" name="Data Correction Output" startId="Package\Data Flow Task\Data Correction.Outputs[Data Correction Output]"/>
<path refId="Package\Data Flow Task.Paths[OLE DB Source Output]" endId="Package\Data Flow Task\Data Correction.Inputs[Data Correction Input]" name="OLE DB Source Output" startId="Package\Data Flow Task\OLE DB Source.Outputs[OLE DB Source Output]"/>
</paths>
</pipeline>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{3F50EB40-DF71-47FD-8908-CA6B1686F44B}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{681F98C2-6DB0-4A6C-98D9-E644478BC5F6}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="152.276666666667,42" Id="{}{7D3A996B-E080-4A1B-B3E7-612104921CF5}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{5AB104B6-1FBD-42FE-BFBA-09B6468F1980}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{7D3A996B-E080-4A1B-B3E7-612104921CF5}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><TaskHost xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:DtsComponentDesignerPropertiesList><dwd:DtsComponentDesignTimeProperty><dwd:key xsi:type="xsd:string">8 DataSourceViewID</dwd:key></dwd:DtsComponentDesignTimeProperty><dwd:DtsComponentDesignTimeProperty><dwd:key xsi:type="xsd:string">8 TableInfoObjectType</dwd:key><dwd:value xsi:type="xsd:string">Table</dwd:value></dwd:DtsComponentDesignTimeProperty><dwd:DtsComponentDesignTimeProperty><dwd:key xsi:type="xsd:string">25 TableInfoObjectType</dwd:key><dwd:value xsi:type="xsd:string">Table</dwd:value></dwd:DtsComponentDesignTimeProperty><dwd:DtsComponentDesignTimeProperty><dwd:key xsi:type="xsd:string">25 DataSourceViewID</dwd:key></dwd:DtsComponentDesignTimeProperty></dwd:DtsComponentDesignerPropertiesList><dwd:LayoutInfo>&lt;GraphLayout Capacity="8" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph" xmlns:mssgle="clr-namespace:Microsoft.SqlServer.Graph.LayoutEngine;assembly=Microsoft.SqlServer.Graph" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"&gt;&lt;NodeLayout Size="153.493333333334,42" Id="1" TopLeft="118,126" /&gt;&lt;NodeLayout Size="151.083333333334,42" Id="8" TopLeft="35.5,29.5" /&gt;&lt;EdgeLayout Id="23" TopLeft="111.041666666667,71.5"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="83.705,54.5" Start="0,0" End="83.705,47"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="8"&gt;&lt;mssgle:LineSegment End="0,23.25" /&gt;&lt;mssgle:CubicBezierSegment Point1="0,23.25" Point2="0,27.25" Point3="4,27.25" /&gt;&lt;mssgle:LineSegment End="79.705,27.25" /&gt;&lt;mssgle:CubicBezierSegment Point1="79.705,27.25" Point2="83.705,27.25" Point3="83.705,31.25" /&gt;&lt;mssgle:LineSegment End="83.705,47" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;NodeLayout Size="171.920000000001,42" Id="25" TopLeft="276,223" /&gt;&lt;EdgeLayout Id="42" TopLeft="194.746666666667,168"&gt;&lt;EdgeLayout.Curve&gt;&lt;mssgle:Curve StartConnector="{x:Null}" EndConnector="167.213333333333,55" Start="0,0" End="167.213333333333,47.5"&gt;&lt;mssgle:Curve.Segments&gt;&lt;mssgle:SegmentCollection Capacity="8"&gt;&lt;mssgle:LineSegment End="0,23.5" /&gt;&lt;mssgle:CubicBezierSegment Point1="0,23.5" Point2="0,27.5" Point3="4,27.5" /&gt;&lt;mssgle:LineSegment End="163.213333333333,27.5" /&gt;&lt;mssgle:CubicBezierSegment Point1="163.213333333333,27.5" Point2="167.213333333333,27.5" Point3="167.213333333333,31.5" /&gt;&lt;mssgle:LineSegment End="167.213333333333,47.5" /&gt;&lt;/mssgle:SegmentCollection&gt;&lt;/mssgle:Curve.Segments&gt;&lt;/mssgle:Curve&gt;&lt;/EdgeLayout.Curve&gt;&lt;EdgeLayout.Labels&gt;&lt;EdgeLabelCollection /&gt;&lt;/EdgeLayout.Labels&gt;&lt;/EdgeLayout&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></TaskHost></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{99F97A26-41BC-4F09-AD56-43FDE3C2186A}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{7D3A996B-E080-4A1B-B3E7-612104921CF5};23">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PipelinePath xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:DestinationName>Data Correction Input</dwd:DestinationName><dwd:SourceName>OLE DB Source Output</dwd:SourceName></PipelinePath></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{F78273AA-89DC-4E67-93A7-190C17214DD9}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{7D3A996B-E080-4A1B-B3E7-612104921CF5};42">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><PipelinePath xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:DestinationName>OLE DB Destination Input</dwd:DestinationName><dwd:SourceName>Data Correction Output</dwd:SourceName></PipelinePath></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{798A843F-CB9B-4F19-8497-398779F10118}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="152.276666666667,42" Id="{}{7D3A996B-E080-4A1B-B3E7-612104921CF5}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Package

Package: EventHandlersPackage

Collapse image Properties

Name | Value
CertificateContext | 0
CertificateObject |
CheckpointFileName |
CheckpointUsage | Never
CheckSignatureOnLoad | True
CreationDate | 10/30/2006 3:06:59 PM
CreationName | Microsoft.Package
CreatorComputerName | OLEG
CreatorName | DEVELOPERS\OldNick
DebugMode | False
DelayValidation | False
Description |
DesignEvents |
DesignTimeProperties |
Disable | False
DisableEventHandlers | False
DumpDescriptor |
DumpOnAnyError | False
EnableConfigurations | False
EnableDump | True
EncryptCheckpoints | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {00F4C0C7-B24F-4770-93C1-11234FD20162}
IgnoreConfigurationsOnLoad | False
InteractiveMode | False
IsDefaultLocaleID | False
IsolationLevel | Serializable
LastModifiedProductVersion | 13.0.800.111
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaxConcurrentExecutables | -1
MaximumErrorCount | 1
Name | EventHandlersPackage
OfflineMode | False
PackageFormatVersion | 8
PackageLocation | file:C:\Users\Alen\Desktop\SSIS packages\EventHandlersPackage.dtsx
PackagePath | C:\Users\Alen\Desktop\SSIS packages\EventHandlersPackage.dtsx
PackagePriorityClass | Default
PackageServerName |
PackageStorageType | FileSystem
PackageType | DTSDesigner100
ProtectionLevel | DontSaveSensitive
SafeRecursiveProjectPackageExecution | False
SaveCheckpoints | False
SQLFolder | \
SuppressConfigurationWarnings | False
SuspendRequired | False
TransactionOption | Supported
UpdateObjects | False
UpdatePackage | True
VersionBuild | 2
VersionComments |
VersionGUID | {F1E4A3A0-2989-4E06-A089-B7BF32BD240E}
VersionMajor | 1
VersionMinor | 0

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image Package source

Package Source

Collapse image See also

Package index


Package

Package: EventHandlersPackage

Collapse image Configuration settings

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Connection managers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Event handlers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Executables

Name | Description
Execute Process Task | Execute Process Task

Collapse image System variables

No items exist
Name Description


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | calc.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {78F51803-1EFC-4238-83E9-0B999F963F1D}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
OnError |  | EventHandlers
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package element

Package element: OnError

Collapse image Properties

Name | Value
CreationName | OnError
DebugMode | False
DelayValidation | False
Description |
Disable | False
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
ID | {D8B1D693-519C-48D7-BA87-47373E635AFC}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | OnError
SuspendRequired | False
TransactionOption | Supported

Collapse image Elements

Name | Description | Type
Execute Process Task | Execute Process Task | Executables


Package element

Package element: Execute Process Task

Collapse image Properties

Name | Value
ApartmentThreaded | True
Arguments |
CreationName | Microsoft.SqlServer.Dts.Tasks.ExecuteProcess.ExecuteProcess, Microsoft.SqlServer.ExecProcTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
DebugMode | False
DelayValidation | False
Description | Execute Process Task
Disable | False
DisableEventHandlers | False
Executable | notepad.exe
ExecutionDuration | 0
ExecutionResult | Success
ExecutionStatus | None
FailPackageOnFailure | False
FailParentOnFailure | False
FailTaskIfReturnCodeIsNotSuccessValue | True
ForcedExecutionValue | 0
ForceExecutionResult | None
ForceExecutionValue | False
HasExpressions | False
HostType | Task
ID | {2CA1CD07-0EBA-4A58-AA7C-E493B2D4F0E4}
IsDefaultLocaleID | True
IsolationLevel | Serializable
LocaleID | Russian (Russia)
LoggingMode | UseParentSetting
MaximumErrorCount | 1
Name | Execute Process Task
RequireFullFileName | True
StandardErrorVariable |
StandardInputVariable |
StandardOutputVariable |
SuccessValue | 0
SuspendRequired | False
TerminateProcessAfterTimeOut | True
TimeOut | 0
TransactionOption | Supported
Version | 0
WindowStyle | 0
WorkingDirectory |

Collapse image Elements

Name | Description | Type
ExecuteProcessExecutingProcess | Provides information regarding executing the process | LogEntryInfos
ExecuteProcessVariableRouting | Provides information regarding routing of variables | LogEntryInfos


Package

Package: EventHandlersPackage

Collapse image Log entry information

Name | Description
Diagnostic | Logs package diagnostics information, e.g. maximum concurrent executables
DiagnosticEx | Logs more information on package execution with XML format

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Log providers

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Project parameters

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image Precedence constraints

No items exist

Collapse image System variables

No items exist
Name Description


Package

Package: EventHandlersPackage

Collapse image User defined variables

No items exist

Collapse image System variables

No items exist
Name Description


Package Source

-<DTS:Executable DTS:refId="Package" DTS:CreationDate="10/30/2006 3:06:59 PM" DTS:CreationName="Microsoft.Package" DTS:CreatorComputerName="OLEG" DTS:CreatorName="DEVELOPERS\OldNick" DTS:DTSID="{00F4C0C7-B24F-4770-93C1-11234FD20162}" DTS:ExecutableType="Microsoft.Package" DTS:LastModifiedProductVersion="12.0.4100.1" DTS:LocaleID="1049" DTS:ObjectName="EventHandlersPackage" DTS:PackageType="5" DTS:ProtectionLevel="0" DTS:VersionBuild="2" DTS:VersionGUID="{0E2EED3E-B501-46DF-99FD-8B8C29807E7E}">
<DTS:Property DTS:Name="PackageFormatVersion">8</DTS:Property>
<DTS:Variables/>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{78F51803-1EFC-4238-83E9-0B999F963F1D}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1" DTS:ThreadHint="0">
<DTS:Variables/>
-<DTS:EventHandlers>
-<DTS:EventHandler DTS:refId="Package\Execute Process Task.EventHandlers[OnError]" DTS:CreationName="OnError" DTS:DTSID="{D8B1D693-519C-48D7-BA87-47373E635AFC}" DTS:EventID="0" DTS:EventName="OnError" DTS:LocaleID="-1">
-<DTS:Variables>
-<DTS:Variable DTS:CreationName="" DTS:Description="The propagate property of the event" DTS:DTSID="{396944D5-B9F8-46EA-A833-5ECFC8E1DCF5}" DTS:IncludeInDebugDump="6789" DTS:Namespace="System" DTS:ObjectName="Propagate">
<DTS:VariableValue DTS:DataType="11">-1</DTS:VariableValue>
</DTS:Variable>
</DTS:Variables>
-<DTS:Executables>
-<DTS:Executable DTS:refId="Package\Execute Process Task.EventHandlers[OnError]\Execute Process Task" DTS:CreationName="Microsoft.ExecuteProcess" DTS:Description="Execute Process Task" DTS:DTSID="{2CA1CD07-0EBA-4A58-AA7C-E493B2D4F0E4}" DTS:ExecutableType="Microsoft.ExecuteProcess" DTS:LocaleID="-1" DTS:ObjectName="Execute Process Task" DTS:TaskContact="Execute Process Task;Microsoft Corporation; Microsoft SQL Server v9; © 2004 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1">
<DTS:Variables/>
-<DTS:ObjectData>
<ExecuteProcessData Executable="notepad.exe"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
</DTS:EventHandler>
</DTS:EventHandlers>
-<DTS:ObjectData>
<ExecuteProcessData Executable="calc.exe"/>
</DTS:ObjectData>
</DTS:Executable>
</DTS:Executables>
-<DTS:PackageVariables>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{1026FD25-D09D-4DEC-A31F-31F99AF72744}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{9F63ACBD-3CE5-4D01-B580-9434968A6CEA}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{78F51803-1EFC-4238-83E9-0B999F963F1D}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{3B219901-8A88-40EC-85A6-9AB60AA1F48D}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="{D8B1D693-519C-48D7-BA87-47373E635AFC}">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><DtsEventHandler xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{2CA1CD07-0EBA-4A58-AA7C-E493B2D4F0E4}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></DtsEventHandler></DTS:Property>
</DTS:PackageVariable>
-<DTS:PackageVariable DTS:CreationName="" DTS:DTSID="{CC7C91C8-DC14-451E-8324-63ABF198CFE3}" DTS:Namespace="ssis-designer-2.0" DTS:ObjectName="package-diagram">
<DTS:Property DTS:DataType="8" DTS:Name="PackageVariableValue"><Package xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ddl2="http://schemas.microsoft.com/analysisservices/2003/engine/2" xmlns:ddl2_2="http://schemas.microsoft.com/analysisservices/2003/engine/2/2" xmlns:ddl100_100="http://schemas.microsoft.com/analysisservices/2008/engine/100/100" xmlns:ddl200="http://schemas.microsoft.com/analysisservices/2010/engine/200" xmlns:ddl200_200="http://schemas.microsoft.com/analysisservices/2010/engine/200/200" xmlns:dwd="http://schemas.microsoft.com/DataWarehouse/Designer/1.0"><dwd:LayoutInfo>&lt;GraphLayout Capacity="4" xmlns="clr-namespace:Microsoft.SqlServer.IntegrationServices.Designer.Model.Serialization;assembly=Microsoft.SqlServer.IntegrationServices.Graph"&gt;&lt;NodeLayout Size="135.773584905661,43.9245283018868" Id="{}{78F51803-1EFC-4238-83E9-0B999F963F1D}" TopLeft="5.5,5.5" /&gt;&lt;/GraphLayout&gt;</dwd:LayoutInfo></Package></DTS:Property>
</DTS:PackageVariable>
</DTS:PackageVariables>
</DTS:Executable>


Analysis Services

Collapse image Server index

Server | Server mode
ALEN-PC\SQLSERVER2016 | Multidimensional
ALEN-PC\TABULAR2016 | Tabular

Collapse image See also

About this documentation


SSAS database index

ALEN-PC\SQLSERVER2016

Collapse image SSAS database index

Database | Description
AdventureWorksDW2014Multidimensional-SE |

Collapse image See also

About this documentation


Server properties: ALEN-PC\SQLSERVER2016

Collapse image Basic properties

Name | Value | Pending value (if different) | Default value | Units
BackupDir | C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Backup |  |  | Folder
CollationName | Latin1_General_CI_AI |  |  |
CommitTimeout | 0 |  | 0 | MS
CoordinatorExecutionMode | -4 |  | -4 |
DataDir | C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Data |  | \data | Folder
DataMining\AllowAdHocOpenRowsetQueries | false |  | false |
DataMining\AllowSessionMiningModels | false |  | false |
DataMining\MaxConcurrentPredictionQueries | 0 |  | 0 |
Feature\ComUdfEnabled | false |  | false |
Feature\LinkFromOtherInstanceEnabled | false |  | false |
Feature\LinkInsideInstanceEnabled | true |  | true |
Feature\LinkToOtherInstanceEnabled | false |  | false |
ForceCommitTimeout | 30000 |  | 30000 | MS
Language | 1033 |  | 0 |
Log\FlightRecorder\Enabled | true |  | true |
Log\QueryLog\CreateQueryLogTable | false |  | false |
Log\QueryLog\QueryLogConnectionString |  |  |  |
Log\QueryLog\QueryLogSampling | 10 |  | 10 |
Log\QueryLog\QueryLogTableName | OlapQueryLog |  | OlapQueryLog |
LogDir | C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Log |  |  | Folder
Memory\HardMemoryLimit | 0 |  | 0 |
Memory\LowMemoryLimit | 6.5E1 |  | 6.5E1 |
Memory\TotalMemoryLimit | 8.E1 |  | 8.E1 |
Memory\VertiPaqMemoryLimit | 6.E1 |  | 6.E1 |
Network\ListenOnlyOnLocalConnections | false |  | false |
Network\Requests\EnableBinaryXML | false |  | false |
Network\Requests\EnableCompression | false |  | false |
Network\Responses\EnableBinaryXML | true |  | true |
Network\Responses\EnableCompression | true |  | true |
OLAP\LazyProcessing\Enabled | true |  | true |
OLAP\LazyProcessing\SleepIntervalSecs | 5 |  | 5 | Sec
OLAP\Process\DatabaseConnectionPoolConnectTimeout | 60 |  | 60 |
Port | 0 |  | 0 |
Security\RequireClientAuthentication | true |  | true |

Collapse image Advanced properties

Name | Value | Pending value (if different) | Default value | Units
AllowedBrowsingFolders | C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Backup\|C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Log\|C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Data\ |  | \data |
AutoSetDefaultInitialCatalog | true |  | true |
BackgroundSessionRollbackBatchingInterval | 2 |  | 2 | Sec
CoordinatorCancelCount | 1000 |  | 1000 |
DataMining\Algorithms\Microsoft_Association_Rules\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Clustering\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Decision_Trees\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Linear_Regression\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Logistic_Regression\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Naive_Bayes\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Neural_Network\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Sequence_Clustering\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Time_Series\Enabled | true |  | true |
DataMining\AllowedProvidersInOpenRowset |  |  |  |
DSO\LocksDirectory |  |  |  | Folder
DSO\RemoteLocksDirectory |  |  |  | Folder
DSO\RemoteRepositoryConnectionString |  |  |  |
DSO\RepositoryConnectionString |  |  |  |
ExternalCommandTimeout | 3600 |  | 3600 | Sec
ExternalConnectionTimeout | 60 |  | 60 | Sec
Feature\ResourceMonitoringEnabled | true |  | true |
FileStore\RandomFileAccessMode | 0 |  | 0 |
IdleConnectionTimeout | 0 |  | 0 | Sec
IdleOrphanSessionTimeout | 120 |  | 120 | Sec
InstanceVisible | true |  | true |
Log\File | msmdsrv.log |  | msmdsrv.log | File
Log\FlightRecorder\FileSizeMB | 10 |  | 10 | MB
Log\FlightRecorder\LogDurationSec | 3600 |  | 3600 | Sec
Log\FlightRecorder\SnapshotDefinitionFile |  |  |  | File
Log\FlightRecorder\SnapshotFrequencySec | 120 |  | 120 | Sec
Log\FlightRecorder\TraceDefinitionFile |  |  |  | File
Log\MaxFileSizeMB | 0 |  | 0 | MB
Log\MaxNumberOfLogFiles | 0 |  | 0 |
Log\MessageLogs | File;Console;System |  | File;Console;System |
Log\Trace\TraceReportFQDN | 0 |  | 0 |
MaxIdleSessionTimeout | 0 |  | 0 | Sec
Memory\HeapTypeForObjects | 0 |  | 0 |
Memory\MemoryHeapType | -1 |  | -1 |
Memory\VertiPaqPagingPolicy | 1 |  | 1 |
MinIdleSessionTimeout | 2700 |  | 2700 | Sec
Network\Listener\IPV4Support | 2 |  | 2 |
Network\Listener\IPV6Support | 2 |  | 2 |
Network\Listener\MaxAllowedRequestSize | 0 |  | 0 | Bytes
OLAP\LazyProcessing\MaxCPUUsage | 5.E-1 |  | 5.E-1 |
OLAP\LazyProcessing\MaxObjectsInParallel | 2 |  | 2 |
OLAP\Process\AggregationMemoryLimitMax | 8.E1 |  | 8.E1 |
OLAP\Process\AggregationMemoryLimitMin | 1.E1 |  | 1.E1 |
OLAP\Process\BufferMemoryLimit | 6.E1 |  | 6.E1 |
OLAP\Process\CheckDistinctRecordSortOrder | 1 |  | 1 |
OLAP\Process\DatabaseConnectionPoolMax | 50 |  | 50 |
OLAP\Process\DatabaseConnectionPoolTimeout | 120000 |  | 120000 |
OLAP\Process\DeepCompressValue | 1 |  | 1 |
OLAP\Process\ROLAPDimensionProcessingEffort | 300000 |  | 300000 |
OLAP\Process\XMLAConnectionPoolTimeout | 720000 |  | 720000 |
OLAP\ProcessPlan\MemoryLimitErrorEnabled | true |  | true |
OLAP\Query\AutoExistMemoryLimit | 6.5E1 |  | 6.5E1 |
OLAP\Query\DefaultDrillthroughMaxRows | 10000 |  | 10000 |
OLAP\Query\DisableCalcExpressNonEmpty | 0 |  | 0 |
OLAP\Query\NonEmptyBehaviorMode | 1 |  | 1 |
OLAP\Query\QueryOptimizerRatio | -1. |  | -1. |
OLAP\Query\SessionCubesMode | 1 |  | 1 |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\CLSID | 8B0958F1-D921-40F7-B19C-005B36FC14D5 |  | 8B0958F1-D921-40F7-B19C-005B36FC14D5 |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\Enabled | true |  | true |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\Manifest | PAAlgo.X.manifest |  | PAAlgo.X.manifest |
Security\BuiltinAdminsAreServerAdmins | true |  | true |
Security\CellPermissionMode | 0 |  | 0 |
Security\ServiceAccountIsServerAdmin | true |  | true |
ServerTimeout | 3600 |  | 3600 | Sec
TempDir | C:\Program Files\Microsoft SQL Server\MSAS13.SQLSERVER2016\OLAP\Temp |  |  | Folder
ThreadPool\Command\GroupAffinity |  |  |  |
ThreadPool\Command\MaxThreads | 0 |  | 0 |
ThreadPool\Command\MinThreads | 0 |  | 0 |
ThreadPool\IOProcess\GroupAffinity |  |  |  |
ThreadPool\IOProcess\MaxThreads | 0 |  | 0 |
ThreadPool\IOProcess\MinThreads | 0 |  | 0 |
ThreadPool\IOProcess\PerNumaNode | -1 |  | -1 |
ThreadPool\Parsing\Long\GroupAffinity |  |  |  |
ThreadPool\Parsing\Short\GroupAffinity |  |  |  |
ThreadPool\Process\GroupAffinity |  |  |  |
ThreadPool\Process\MaxThreads | 0 |  | 0 |
ThreadPool\Process\MinThreads | 0 |  | 0 |
ThreadPool\Query\GroupAffinity |  |  |  |
ThreadPool\Query\MaxThreads | 0 |  | 0 |
ThreadPool\Query\MinThreads | 0 |  | 0 |
VertiPaq\DefaultSegmentRowCount | 0 |  | 0 |
VertiPaq\ProcessingTimeboxSecPerMRow | -1 |  | -1 |
VertiPaq\ThreadPool\GroupAffinity |  |  |  |
WriteTransactionIdleTimeout | 0 |  | 0 | Sec

Collapse image See also

About this documentation


Database object index

AdventureWorksDW2014Multidimensional-SE

Collapse image Database information

Name | Value
Name | AdventureWorksDW2014Multidimensional-SE
Collation | Latin1_General_CI_AS
Creation date | 7/18/2014 6:44:11 PM
Estimated size | 16245728
Language | en-US
Last processed | 7/28/2014 9:46:59 PM
Last update | 9/2/2016 9:18:05 AM
Last schema update | 7/28/2014 9:58:58 PM
Processing priority | 0
Aggregation prefix |
Db storage location |
Model type | Multidimensional
Compatibility level | 1100
Direct query mode | InMemory
Read write mode | ReadWrite
Storage engine used | Traditional
Is loaded | True
Visible | True
State | Processed

Collapse image Database object index

Objects | Total
Data sources | 1
Data source views | 2
Cubes | 2
Dimensions | 15
Mining structures | 5
Roles | 0

Collapse image See also

Server index

About this documentation


Data sources

List of data sources

Collapse image Data sources

Name | Impersonation type | Last schema update | Date created
Adventure Works DW | ImpersonateServiceAccount | 7/28/2014 9:58:42 PM | 7/18/2014 6:44:11 PM
Total: 1 data source(s)

Collapse image See also

About this documentation


Data source: Adventure Works DW

Collapse image Data source properties

Property | Value
Connection string | Provider=SQLNCLI11.1;Data Source=localhost;Integrated Security=SSPI;Initial Catalog=AdventureWorksDW2014
Connection string security | Unchanged
Date created | 7/18/2014 6:44:11 PM
Impersonation type | ImpersonateServiceAccount
Is loaded | True
Isolation | ReadCommitted
Last schema update | 7/28/2014 9:58:42 PM
Maximum active connections | 10
Timeout | 00:00:00

Collapse image See also

About this documentation


Data source views

List of data source views

Collapse image Data source views

Name | Data source | Last schema update | Date created
Adventure Works DW | Adventure Works DW | 7/18/2014 6:50:54 PM | 7/18/2014 6:44:11 PM
Clustered Customers |  | 7/18/2014 6:50:54 PM | 7/18/2014 6:44:11 PM
Total: 2 data source view(s)

Collapse image See also

About this documentation


Data source view: Adventure Works DW

Collapse image Data source view properties

Property | Value
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:11 PM
Is loaded | True
Last schema update | 7/18/2014 6:50:54 PM

Collapse image Tables

Name | Type | Parent relations count | Child relations count
DimCustomer | Table | 1 | 1
DimEmployee | Table | 2 | 3
DimGeography | Table | 1 | 2
DimPromotion | Table | 0 | 3
DimReseller | Table | 1 | 1
DimDate | Table | 0 | 12
Sales Quota Facts | View | 2 | 0
DimAccount | Table | 1 | 2
DimDepartmentGroup | Table | 1 | 2
DimProductCategory | Table | 0 | 1
DimSalesTerritory | Table | 0 | 5
DimScenario | Table | 0 | 1
FactFinance | Table | 5 | 0
DimSalesReason | Table | 0 | 1
FactInternetSalesReason | Table | 2 | 0
Currency Rate Facts | View | 3 | 0
Currency | View | 0 | 4
DimProductSubcategory | Table | 1 | 2
Organization | View | 2 | 2
vAssocSeqLineItems | View | 1 | 0
vAssocSeqOrders | View | 0 | 1
vTargetMail | View | 0 | 0
vTimeSeries | View | 0 | 0
DimProduct | Table | 2 | 3
FactInternetSales | Table | 8 | 1
FactResellerSales | Table | 9 | 0
Sales Summary Facts | View | 7 | 0
Destination Currency | View | 0 | 2
Total: 28 table(s)

Collapse image See also

About this documentation


Table: DimCustomer

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimCustomer
Friendly name | Customer
Table name | dbo_DimCustomer
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimCustomer_DimGeography | GeographyKey | DimGeography | Table | GeographyKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactInternetSales_DimCustomer | CustomerKey | FactInternetSales | Table | CustomerKey
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
CustomerKey | System.Int32
GeographyKey | System.Int32
CustomerAlternateKey | System.String
FirstName | System.String
MiddleName | System.String
LastName | System.String
NameStyle | System.Boolean
BirthDate | System.DateTime
MaritalStatus | System.String
Suffix | System.String
Gender | System.String
EmailAddress | System.String
YearlyIncome | System.Decimal
TotalChildren | System.Byte
NumberChildrenAtHome | System.Byte
HouseOwnerFlag | System.String
NumberCarsOwned | System.Byte
AddressLine1 | System.String
AddressLine2 | System.String
Phone | System.String
DateFirstPurchase | System.DateTime
FullName System.String
CASE
    WHEN MiddleName IS NULL THEN
        FirstName + ' ' + LastName
    ELSE
        FirstName + ' ' + MiddleName + '.' + ' ' + LastName
END
MaritalStatusDesc System.String
CASE
    WHEN MaritalStatus = 'S' THEN
        'Single'
    ELSE
        'Married'
END
GenderDesc System.String
CASE
    WHEN Gender = 'M' THEN
        'Male'
    ELSE
        'Female'
END
HouseOwnerDesc System.String
CASE
    WHEN HouseOwnerFlag = '1' THEN
        'Yes'
    ELSE
        'No'
END
CommuteDistance | System.String
CommuteDistanceSort System.String
CASE
    WHEN CommuteDistance= '0-1 Miles'  THEN
        '1'
    WHEN CommuteDistance= '1-2 Miles'  THEN
        '2'
    WHEN CommuteDistance= '2-5 Miles'  THEN
        '3'
    WHEN CommuteDistance= '5-10 Miles' THEN
        '4'
    WHEN CommuteDistance= '10+ Miles'  THEN
        '5'
END
Title | System.String
EnglishEducation | System.String
SpanishEducation | System.String
FrenchEducation | System.String
EnglishOccupation | System.String
SpanishOccupation | System.String
FrenchOccupation | System.String
SimpleDateFirstPurchase System.String
DATENAME(mm, DateFirstPurchase) + ' ' +
DATENAME(dd, DateFirstPurchase) + ', ' +
DATENAME(yy, DateFirstPurchase)
Total: 35 column(s)

Collapse image See also

About this documentation


Table: DimEmployee

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimEmployee
Friendly name | Employee
Table name | dbo_DimEmployee
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimEmployee_DimSalesTerritory | SalesTerritoryKey | DimSalesTerritory | Table | SalesTerritoryKey
FK_DimEmployee_DimEmployee | ParentEmployeeKey | DimEmployee | Table | EmployeeKey
Total: 2 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimEmployee | EmployeeKey | FactResellerSales | Table | EmployeeKey
FK_DimEmployee_DimEmployee | EmployeeKey | DimEmployee | Table | ParentEmployeeKey
FK_FactSalesQuota_DimEmployee | EmployeeKey | Sales Quota Facts | View | EmployeeKey
Total: 3 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
EmployeeKey | System.Int32
ParentEmployeeKey | System.Int32
EmployeeNationalIDAlternateKey | System.String
ParentEmployeeNationalIDAlternateKey | System.String
FirstName | System.String
LastName | System.String
MiddleName | System.String
NameStyle | System.Boolean
Title | System.String
HireDate | System.DateTime
BirthDate | System.DateTime
LoginID | System.String
EmailAddress | System.String
Phone | System.String
MaritalStatus | System.String
EmergencyContactName | System.String
EmergencyContactPhone | System.String
SalariedFlag | System.Boolean
Gender | System.String
PayFrequency | System.Byte
BaseRate | System.Decimal
VacationHours | System.Int16
SickLeaveHours | System.Int16
CurrentFlag | System.Boolean
SalesPersonFlag | System.Boolean
DepartmentName | System.String
FullName System.String
CASE
    WHEN MiddleName IS NULL THEN
        FirstName + ' ' + LastName
    ELSE
        FirstName + ' ' + MiddleName + '.' + ' ' + LastName
END
SalesTerritoryKey | System.Int32
GenderDesc System.String
CASE
    WHEN Gender = 'M' THEN
        'Male'
    ELSE
        'Female'
END
MaritalStatusDesc System.String
CASE
    WHEN MaritalStatus = 'S' THEN
        'Single'
    ELSE
        'Married'
END
StartDate | System.DateTime
EndDate | System.DateTime
Status | System.String
PayFrequencyDesc System.String
CASE
    WHEN PayFrequency = '1' THEN
        'Monthly'
    ELSE
        'Bi-Monthly'
END
EmployeeStatus System.String
CASE
    WHEN Status = 'Current' THEN 'Active'
    ELSE 'Inactive'
END
SimpleEndDate System.String
CASE
    WHEN EndDate IS NULL THEN 'Active'
    ELSE
    DATENAME(mm, EndDate) + ' ' +
    DATENAME(dd, EndDate) + ', ' +
    DATENAME(yy, EndDate)
END
SimpleStartDate System.String
DATENAME(mm, StartDate) + ' ' +
DATENAME(dd, StartDate) + ', ' +
DATENAME(yy, StartDate)
SimpleHireDate System.String
DATENAME(mm, HireDate) + ' ' +
DATENAME(dd, HireDate) + ', ' +
DATENAME(yy, HireDate)
HireYear System.Int32
DATEPART(yy, HireDate)
SalariedFlagDesc System.String
Case
    When SalariedFlag = 0
    Then 'False'
    Else 'True'
End
SalesPersonFlagDesc System.String
Case
    When SalesPersonFlag = 0
    Then 'False'
    Else 'True'
End
EmployeePhoto | System.Byte[]
Total: 42 column(s)

Collapse image See also

About this documentation


Table: DimGeography

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimGeography
Friendly name | Geography
Table name | dbo_DimGeography
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimGeography_DimSalesTerritory | SalesTerritoryKey | DimSalesTerritory | Table | SalesTerritoryKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_DimReseller_DimGeography | GeographyKey | DimReseller | Table | GeographyKey
FK_DimCustomer_DimGeography | GeographyKey | DimCustomer | Table | GeographyKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
GeographyKey | System.Int32 |
City | System.String |
StateProvinceCode | System.String |
StateProvinceName | System.String |
CountryRegionCode | System.String |
PostalCode | System.String |
EnglishCountryRegionName | System.String |
SpanishCountryRegionName | System.String |
FrenchCountryRegionName | System.String |
SalesTerritoryKey | System.Int32 |
IpAddressLocator | System.String |
Total: 11 column(s)

Collapse image See also

About this documentation


Table: DimPromotion

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimPromotion
Friendly name | Promotion
Table name | dbo_DimPromotion
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimPromotion | PromotionKey | FactResellerSales | Table | PromotionKey
FK_FactInternetSales_DimPromotion | PromotionKey | FactInternetSales | Table | PromotionKey
FactSalesSummary-DimPromotion | PromotionKey | Sales Summary Facts | View | PromotionKey
Total: 3 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
PromotionKey | System.Int32
PromotionAlternateKey | System.Int32
DiscountPct | System.Double
StartDate | System.DateTime
EndDate | System.DateTime
MinQty | System.Int32
MaxQty | System.Int32
EnglishPromotionName | System.String
SpanishPromotionName | System.String
FrenchPromotionName | System.String
EnglishPromotionType | System.String
SpanishPromotionType | System.String
FrenchPromotionType | System.String
EnglishPromotionCategory | System.String
SpanishPromotionCategory | System.String
FrenchPromotionCategory | System.String
DiscountPctDesc System.Double
DiscountPct * 100
MaxQtyDesc System.Int32
CASE
    WHEN MaxQty IS NULL THEN '0'
    ELSE MaxQty
END
SimpleEndDate System.String
DATENAME(mm, EndDate) + ' ' +
DATENAME(dd, EndDate) + ', ' +
DATENAME(yy, EndDate)
SimpleStartDate System.String
DATENAME(mm, StartDate) + ' ' +
DATENAME(dd, StartDate) + ', ' +
DATENAME(yy, StartDate)
Total: 20 column(s)

Collapse image See also

About this documentation


Table: DimReseller

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimReseller
Friendly name | Reseller
Table name | dbo_DimReseller
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimReseller_DimGeography | GeographyKey | DimGeography | Table | GeographyKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimReseller | ResellerKey | FactResellerSales | Table | ResellerKey
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ResellerKey | System.Int32
GeographyKey | System.Int32
ResellerAlternateKey | System.String
Phone | System.String
BusinessType | System.String
ResellerName | System.String
NumberEmployees | System.Int32
AddressLine1 | System.String
AddressLine2 | System.String
AnnualSales | System.Decimal
BankName | System.String
MinPaymentType | System.Byte
MinPaymentAmount | System.Decimal
AnnualRevenue | System.Decimal
YearOpened | System.Int32
OrderFrequency | System.String
OrderMonth | System.Byte
FirstOrderYear | System.Int32
LastOrderYear | System.Int32
ProductLine | System.String
OrderFrequencyDesc System.String
CASE
    WHEN OrderFrequency = 'A' THEN
        'Annual'
    WHEN OrderFrequency = 'S' THEN
        'Bi-Annual'
    ELSE
        'Quarterly'
END
OrderMonthDesc System.String
CASE
    WHEN OrderMonth = '1' THEN
        'January'
    WHEN OrderMonth = '2' THEN
        'February'
    WHEN OrderMonth = '3' THEN
        'March'
    WHEN OrderMonth = '4' THEN
        'April'
    WHEN OrderMonth = '5' THEN
        'May'
    WHEN OrderMonth = '6' THEN
        'June'
    WHEN OrderMonth = '7' THEN
        'July'
    WHEN OrderMonth = '8' THEN
        'August'
    WHEN OrderMonth = '9' THEN
        'September'
    WHEN OrderMonth = '10' THEN
        'October'
    WHEN OrderMonth = '11' THEN
        'November'
    WHEN OrderMonth = '12' THEN
        'December'
ELSE 'Never Ordered'
END
FirstOrderYearDesc System.String
CASE
    WHEN NOT FirstOrderYear IS NULL THEN
    CONVERT(varchar,FirstOrderYear)
    ELSE 'Never Ordered'
END
LastOrderYearDesc System.String
CASE
    WHEN NOT LastOrderYear IS NULL THEN
    CONVERT(varchar,LastOrderYear)
    ELSE 'Never Ordered'
END
MinPaymentTypeDesc System.String
CASE
    WHEN MinPaymentType = '1' THEN
    CONVERT(varchar, 'No Minimum')
    WHEN MinPaymentType = '2' THEN
    CONVERT(varchar, 'Percent')
    WHEN MinPaymentType = '3' THEN
    CONVERT(varchar, 'Amount')
    ELSE 'Unspecifed'
END
MinPaymentAmountDesc System.String
CASE
    WHEN NOT MinPaymentAmount IS NULL
        THEN CONVERT(varchar, MinPaymentAmount)
    ELSE 'Not Applicable'
END
Total: 26 column(s)

Collapse image See also

About this documentation


Table: DimDate

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimDate
Friendly name | Date
Table name | dbo_DimTime
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimDate1 | DateKey | FactResellerSales | Table | DueDateKey
FK_FactResellerSales_DimDate | DateKey | FactResellerSales | Table | OrderDateKey
FK_FactResellerSales_DimDate2 | DateKey | FactResellerSales | Table | ShipDateKey
FK_FactInternetSales_DimDate2 | DateKey | FactInternetSales | Table | ShipDateKey
FK_FactInternetSales_DimDate1 | DateKey | FactInternetSales | Table | DueDateKey
FK_FactInternetSales_DimDate | DateKey | FactInternetSales | Table | OrderDateKey
FK_FactFinance_DimDate | DateKey | FactFinance | Table | DateKey
Sales Quota Facts-DimDate | CalendarYear, CalendarQuarter | Sales Quota Facts | View | CalendarYear, CalendarQuarter
Sales Summary Facts-DimDate | DateKey | Sales Summary Facts | View | OrderDateKey
Sales Summary Facts-DimDate1 | DateKey | Sales Summary Facts | View | DueDateKey
Sales Summary Facts-DimDate2 | DateKey | Sales Summary Facts | View | ShipDateKey
Currency Rate Facts-DimDate | DateKey | Currency Rate Facts | View | DateKey
Total: 12 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
FullDateAlternateKey | System.DateTime
DayNumberOfWeek | System.Byte
DayNumberOfMonth | System.Byte
DayNumberOfYear | System.Int16
WeekNumberOfYear | System.Byte
MonthNumberOfYear | System.Byte
CalendarQuarter | System.Byte
CalendarYear | System.Int16
CalendarSemester | System.Byte
FiscalQuarter | System.Byte
FiscalYear | System.Int16
FiscalSemester | System.Byte
CalendarQuarterDesc System.String
'Q' + CONVERT(CHAR (1), CalendarQuarter) +
' CY ' +
CONVERT(CHAR (4), CalendarYear)
FiscalQuarterDesc System.String
'Q' + CONVERT(CHAR (1), FiscalQuarter) +
' FY ' +
CONVERT(CHAR (4), FiscalYear)
CalendarSemesterDesc System.String
CASE
    WHEN CalendarSemester = 1
    THEN 'H1 '+'CY ' + CONVERT(CHAR (4), CalendarYear)
    ELSE 'H2 '+ 'CY '+ CONVERT(CHAR (4), CalendarYear)
END
FiscalSemesterDesc System.String
CASE
    WHEN FiscalSemester = 1
    THEN 'H1 '+'FY '+ CONVERT(CHAR (4), FiscalYear)
    ELSE  'H2 '+'FY '+ CONVERT(CHAR (4), FiscalYear)
END
EnglishDayNameOfWeek | System.String
SpanishDayNameOfWeek | System.String
FrenchDayNameOfWeek | System.String
EnglishMonthName | System.String
SpanishMonthName | System.String
FrenchMonthName | System.String
SimpleDate System.String
DATENAME(mm, FullDateAlternateKey) + ' ' +
DATENAME(dd, FullDateAlternateKey) + ', ' +
DATENAME(yy, FullDateAlternateKey)
MonthName System.String
EnglishMonthName+' '+ CONVERT(CHAR (4), CalendarYear)
CalendarSemesterOfYear System.String
CASE
    WHEN CalendarSemester = 1
    THEN 'CY H1'
    ELSE  'CY H2'
END
FiscalSemesterOfYear System.String
CASE
    WHEN FiscalSemester = 1
    THEN 'FY H1'
    ELSE  'FY H2'
END
CalendarQuarterOfYear System.String
'CY Q' + CONVERT(CHAR (1), CalendarQuarter)
FiscalQuarterOfYear System.String
'FY Q' + CONVERT(CHAR (1), FiscalQuarter)
FiscalYearDesc System.String
'FY '+ CONVERT(CHAR (4), FiscalYear)
CalendarYearDesc System.String
'CY '+ CONVERT(CHAR (4), CalendarYear)
DateKey | System.Int32
MonthNameValue System.DateTime
CAST(
           CONVERT( CHAR(2), MonthNumberOfYear)
           + '/ ' +  '1/' +
           CONVERT(CHAR(4), CalendarYear) AS DATE
         )
FiscalWeekNumberOfYear System.Int32
CASE
    WHEN WeekNumberOfYear< 27
       THEN
           WeekNumberOfYear + 27
       ELSE
           WeekNumberOfYear - 26
END
FiscalWeek System.String
CASE
    WHEN WeekNumberOfYear< 27
       THEN
           'FY Week ' + CONVERT(CHAR(2), WeekNumberOfYear + 27)
       ELSE
           'FY Week ' + CONVERT(CHAR(2), WeekNumberOfYear - 26)
END
CalendarWeek System.String
'CY Week ' +  CONVERT(CHAR(2), WeekNumberOfYear)
FiscalWeekDesc System.String
CASE
    WHEN WeekNumberOfYear< 27
       THEN
           'Week ' + CONVERT(CHAR(2), WeekNumberOfYear + 27) +
           ' FY ' + CONVERT(CHAR (4), FiscalYear)
       ELSE
           'Week ' + CONVERT(CHAR(2), WeekNumberOfYear - 26) +
           ' FY ' + CONVERT(CHAR (4), FiscalYear)
END
CalendarWeekDesc System.String
'Week ' +  CONVERT(CHAR(2), WeekNumberOfYear) +
' CY ' +  CONVERT(CHAR (4), CalendarYear)
Total: 37 column(s)

Collapse image See also

About this documentation


Table: Sales Quota Facts

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Sales Quota Facts
Friendly name | Sales Quota Facts
Table name | FactSalesQuota
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     EmployeeKey, CalendarQuarter, CalendarYear, SalesAmountQuota
FROM         dbo.FactSalesQuota

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactSalesQuota_DimEmployee | EmployeeKey | DimEmployee | Table | EmployeeKey
Sales Quota Facts-DimDate | CalendarYear, CalendarQuarter | DimDate | Table | CalendarYear, CalendarQuarter
Total: 2 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
EmployeeKey | System.Int32 |
CalendarYear | System.Int16 |
CalendarQuarter | System.Byte |
SalesAmountQuota | System.Decimal |
Total: 4 column(s)

Collapse image See also

About this documentation


Table: DimAccount

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimAccount
Friendly name | Account
Table name | dbo_DimAccount
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimAccount_DimAccount | ParentAccountKey | DimAccount | Table | AccountKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactFinance_DimAccount | AccountKey | FactFinance | Table | AccountKey
FK_DimAccount_DimAccount | AccountKey | DimAccount | Table | ParentAccountKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
AccountKey | System.Int32 |
ParentAccountKey | System.Int32 |
AccountCodeAlternateKey | System.Int32 |
ParentAccountCodeAlternateKey | System.Int32 |
AccountDescription | System.String |
AccountType | System.String |
Operator | System.String |
CustomMembers | System.String |
ValueType | System.String |
CustomMemberOptions | System.String |
Total: 10 column(s)

Collapse image See also

About this documentation


Table: DimDepartmentGroup

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimDepartmentGroup
Friendly name | Department
Table name | dbo_DimDepartmentGroup
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimDepartmentGroup_DimDepartmentGroup | ParentDepartmentGroupKey | DimDepartmentGroup | Table | DepartmentGroupKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactFinance_DimDepartmentGroup | DepartmentGroupKey | FactFinance | Table | DepartmentGroupKey
FK_DimDepartmentGroup_DimDepartmentGroup | DepartmentGroupKey | DimDepartmentGroup | Table | ParentDepartmentGroupKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
DepartmentGroupKey | System.Int32 |
ParentDepartmentGroupKey | System.Int32 |
DepartmentGroupName | System.String |
Total: 3 column(s)

Collapse image See also

About this documentation


Table: DimProductCategory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProductCategory
Friendly name | Product Category
Table name | dbo_DimProductCategory
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_DimProductSubcategory_DimProductCategory | ProductCategoryKey | DimProductSubcategory | Table | ProductCategoryKey
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ProductCategoryKey | System.Int32 |
ProductCategoryAlternateKey | System.Int32 |
EnglishProductCategoryName | System.String |
SpanishProductCategoryName | System.String |
FrenchProductCategoryName | System.String |
Total: 5 column(s)

Collapse image See also

About this documentation


Table: DimSalesTerritory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimSalesTerritory
Friendly name | Sales Territory
Table name | dbo_DimSalesTerritory
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimSalesTerritory | SalesTerritoryKey | FactResellerSales | Table | SalesTerritoryKey
FK_FactInternetSales_DimSalesTerritory | SalesTerritoryKey | FactInternetSales | Table | SalesTerritoryKey
FK_DimGeography_DimSalesTerritory | SalesTerritoryKey | DimGeography | Table | SalesTerritoryKey
FK_DimEmployee_DimSalesTerritory | SalesTerritoryKey | DimEmployee | Table | SalesTerritoryKey
FactSalesSummary-DimSalesTerritory | SalesTerritoryKey | Sales Summary Facts | View | SalesTerritoryKey
Total: 5 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
SalesTerritoryKey | System.Int32 |
SalesTerritoryAlternateKey | System.Int32 |
SalesTerritoryRegion | System.String |
SalesTerritoryCountry | System.String |
SalesTerritoryGroup | System.String |
SalesTerritoryImage | System.Byte[] |
Total: 6 column(s)

Collapse image See also

About this documentation


Table: DimScenario

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimScenario
Friendly name | Scenario
Table name | dbo_DimScenario
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactFinance_DimScenario | ScenarioKey | FactFinance | Table | ScenarioKey
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ScenarioKey | System.Int32 |
ScenarioName | System.String |
Total: 2 column(s)

Collapse image See also

About this documentation


Table: FactFinance

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactFinance
Friendly name | Finance Facts
Table name | dbo_FactFinance
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactFinance_DimScenario | ScenarioKey | DimScenario | Table | ScenarioKey
FK_FactFinance_DimDepartmentGroup | DepartmentGroupKey | DimDepartmentGroup | Table | DepartmentGroupKey
FK_FactFinance_DimAccount | AccountKey | DimAccount | Table | AccountKey
FK_FactFinance_DimDate | DateKey | DimDate | Table | DateKey
FK_FactFinance_DimOrganization | OrganizationKey | Organization | View | OrganizationKey
Total: 5 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
OrganizationKey | System.Int32 |
DepartmentGroupKey | System.Int32 |
ScenarioKey | System.Int32 |
AccountKey | System.Int32 |
Amount | System.Double |
FinanceKey | System.Int32 |
DateKey | System.Int32 |
Date | System.DateTime |
Total: 8 column(s)

Collapse image See also

About this documentation


Table: DimSalesReason

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimSalesReason
Friendly name | Sales Reason
Table name | dbo_DimSalesReason
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactInternetSalesReason_DimSalesReason | SalesReasonKey | FactInternetSalesReason | Table | SalesReasonKey
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
SalesReasonKey | System.Int32 |
SalesReasonAlternateKey | System.Int32 |
SalesReasonName | System.String |
SalesReasonReasonType | System.String |
Total: 4 column(s)

Collapse image See also

About this documentation


Table: FactInternetSalesReason

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactInternetSalesReason
Friendly name | Internet Sales Reason Facts
Table name | dbo_FactInternetSalesReason
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactInternetSalesReason_FactInternetSales | SalesOrderNumber, SalesOrderLineNumber | FactInternetSales | Table | SalesOrderNumber, SalesOrderLineNumber
FK_FactInternetSalesReason_DimSalesReason | SalesReasonKey | DimSalesReason | Table | SalesReasonKey
Total: 2 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
SalesOrderNumber | System.String |
SalesOrderLineNumber | System.Byte |
SalesReasonKey | System.Int32 |
Total: 3 column(s)

Collapse image See also

About this documentation


Table: Currency Rate Facts

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Currency Rate Facts
Friendly name | Currency Rate Facts
Table name | dbo_FactCurrencyRate
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     CurrencyKey, DateKey, AverageRate, EndOfDayRate
FROM         dbo.FactCurrencyRate

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactCurrencyRate_DimCurrency | CurrencyKey | Currency | View | CurrencyKey
FactCurrencyRate-DimDestinationCurrency | CurrencyKey | Destination Currency | View | CurrencyKey
Currency Rate Facts-DimDate | DateKey | DimDate | Table | DateKey
Total: 3 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
CurrencyKey | System.Int32 |
AverageRate | System.Double |
EndOfDayRate | System.Double |
DateKey | System.Int32 |
Total: 4 column(s)

Collapse image See also

About this documentation


Table: Currency

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Currency
Friendly name | Currency
Table name | dbo_DimCurrency
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     CurrencyKey, CurrencyAlternateKey, CurrencyName
FROM         DimCurrency

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimCurrency | CurrencyKey | FactResellerSales | Table | CurrencyKey
FK_FactInternetSales_DimCurrency | CurrencyKey | FactInternetSales | Table | CurrencyKey
FK_FactCurrencyRate_DimCurrency | CurrencyKey | Currency Rate Facts | View | CurrencyKey
FactSalesSummary-DimCurrency | CurrencyKey | Sales Summary Facts | View | CurrencyKey
Total: 4 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
CurrencyKey | System.Int32 |
CurrencyAlternateKey | System.String |
CurrencyName | System.String |
Total: 3 column(s)

Collapse image See also

About this documentation


Table: DimProductSubcategory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProductSubcategory
Friendly name | Product Subcategory
Table name | dbo_DimProductSubcategory
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimProductSubcategory_DimProductCategory | ProductCategoryKey | DimProductCategory | Table | ProductCategoryKey
Total: 1 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_DimProduct_DimProductSubcategory | ProductSubcategoryKey | DimProduct | Table | ProductSubcategoryKey
DimProduct-DimProductSubcategory | ProductSubcategoryAlternateKey | DimProduct | Table | ProductSubcategoryKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ProductSubcategoryKey | System.Int32 |
ProductSubcategoryAlternateKey | System.Int32 |
EnglishProductSubcategoryName | System.String |
SpanishProductSubcategoryName | System.String |
FrenchProductSubcategoryName | System.String |
ProductCategoryKey | System.Int32 |
Total: 6 column(s)

Collapse image See also

About this documentation


Table: Organization

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Organization
Friendly name | Organization
Table name | dbo_DimOrganization
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     o.OrganizationKey, o.ParentOrganizationKey, o.PercentageOfOwnership, o.OrganizationName, o.CurrencyKey, c.CurrencyAlternateKey
FROM         DimOrganization AS o INNER JOIN
                      DimCurrency AS c ON o.CurrencyKey = c.CurrencyKey

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimOrganization_DimOrganization | ParentOrganizationKey | Organization | View | OrganizationKey
DimOrganization-DimDestinationCurrency | CurrencyKey | Destination Currency | View | CurrencyKey
Total: 2 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_DimOrganization_DimOrganization | OrganizationKey | Organization | View | ParentOrganizationKey
FK_FactFinance_DimOrganization | OrganizationKey | FactFinance | Table | OrganizationKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
OrganizationKey | System.Int32 |
ParentOrganizationKey | System.Int32 |
PercentageOfOwnership | System.String |
OrganizationName | System.String |
CurrencyAlternateKey | System.String |
CurrencyKey | System.Int32 |
Total: 6 column(s)

Collapse image See also

About this documentation


Table: vAssocSeqLineItems

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | vAssocSeqLineItems
Friendly name | vAssocSeqLineItems
Table name | dbo_vAssocSeqLineItems
Table type | View
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
vAssocSeqLineItems-vAssocSeqOrders | OrderNumber | vAssocSeqOrders | View | OrderNumber
Total: 1 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
OrderNumber | System.String |
LineNumber | System.Byte |
Model | System.String |
Total: 3 column(s)

Collapse image See also

About this documentation


Table: vAssocSeqOrders

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | vAssocSeqOrders
Friendly name | vAssocSeqOrders
Table name | dbo_vAssocSeqOrders
Table type | View
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
vAssocSeqLineItems-vAssocSeqOrders | OrderNumber | vAssocSeqLineItems | View | OrderNumber
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
OrderNumber | System.String |
CustomerKey | System.Int32 |
Region | System.String |
IncomeGroup | System.String |
Total: 4 column(s)

Collapse image See also

About this documentation


Table: vTargetMail

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | vTargetMail
Friendly name | vTargetMail
Table name | dbo_vTargetMail
Table type | View
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
CustomerKey | System.Int32 |
GeographyKey | System.Int32 |
CustomerAlternateKey | System.String |
Title | System.String |
FirstName | System.String |
MiddleName | System.String |
LastName | System.String |
NameStyle | System.Boolean |
BirthDate | System.DateTime |
MaritalStatus | System.String |
Suffix | System.String |
Gender | System.String |
EmailAddress | System.String |
YearlyIncome | System.Decimal |
TotalChildren | System.Byte |
NumberChildrenAtHome | System.Byte |
EnglishEducation | System.String |
SpanishEducation | System.String |
FrenchEducation | System.String |
EnglishOccupation | System.String |
SpanishOccupation | System.String |
FrenchOccupation | System.String |
HouseOwnerFlag | System.String |
NumberCarsOwned | System.Byte |
AddressLine1 | System.String |
AddressLine2 | System.String |
Phone | System.String |
DateFirstPurchase | System.DateTime |
CommuteDistance | System.String |
Region | System.String |
Age | System.Int32 |
BikeBuyer | System.Int32 |
Total: 32 column(s)

Collapse image See also

About this documentation


Table: vTimeSeries

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | vTimeSeries
Friendly name | vTimeSeries
Table name | dbo_vTimeSeries
Table type | View
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

No relationships exist

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
ModelRegion | System.String |
TimeIndex | System.Int32 |
Quantity | System.Int32 |
Amount | System.Decimal |
CalendarYear | System.Int16 |
Month | System.Byte |
ReportingDate | System.DateTime |
Total: 7 column(s)

Collapse image See also

About this documentation


Table: DimProduct

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProduct
Friendly name | Product
Table name | dbo_DimProduct
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_DimProduct_DimProductSubcategory | ProductSubcategoryKey | DimProductSubcategory | Table | ProductSubcategoryKey
DimProduct-DimProductSubcategory | ProductSubcategoryKey | DimProductSubcategory | Table | ProductSubcategoryAlternateKey
Total: 2 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactResellerSales_DimProduct | ProductKey | FactResellerSales | Table | ProductKey
FK_FactInternetSales_DimProduct | ProductKey | FactInternetSales | Table | ProductKey
FactSalesSummary-DimProduct | ProductKey | Sales Summary Facts | View | ProductKey
Total: 3 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ProductKey | System.Int32
ProductAlternateKey | System.String
ProductSubcategoryKey | System.Int32
WeightUnitMeasureCode | System.String
SizeUnitMeasureCode | System.String
EnglishProductName | System.String
SpanishProductName | System.String
FrenchProductName | System.String
StandardCost | System.Decimal
FinishedGoodsFlag | System.Boolean
Color | System.String
SafetyStockLevel | System.Int16
ReorderPoint | System.Int16
ListPrice | System.Decimal
Size | System.String
SizeRange | System.String
Weight | System.Double
DaysToManufacture | System.Int32
ProductLine | System.String
DealerPrice | System.Decimal
Class | System.String
Style | System.String
ModelName | System.String
LargePhoto | System.Byte[]
EnglishDescription | System.String
FrenchDescription | System.String
ChineseDescription | System.String
ArabicDescription | System.String
HebrewDescription | System.String
ThaiDescription | System.String
StartDate | System.DateTime
EndDate | System.DateTime
Status | System.String
ProductLineName System.String
CASE ProductLine
    WHEN 'M' THEN 'Mountain'
    WHEN 'R' THEN 'Road'
    WHEN 'S' THEN 'Accessory'
    WHEN 'T' THEN 'Touring'
    ELSE 'Components'
END
WeightDesc System.String
Case
    WHEN Weight IS NULL THEN 'Unknown'
    ELSE CONVERT(CHAR (5), Weight)
END
SimpleStartDate System.String
DATENAME( mm, StartDate ) + ' ' +
DATENAME( dd, StartDate ) + ', ' +
DATENAME( yy, StartDate )
SimpleEndDate System.String
CASE
    WHEN EndDate IS NULL THEN 'Active'
    ELSE
    DATENAME(mm, EndDate) + ' ' +
    DATENAME(dd, EndDate) + ', ' +
    DATENAME(yy, EndDate)
END
StatusDesc System.String
CASE
    WHEN Status IS NULL THEN 'Historical'
    ELSE Status
END
StyleDesc System.String
CASE
    WHEN Style IS NULL THEN 'Not Applicable'
    WHEN Style = 'U' THEN 'Unisex'
    WHEN Style = 'M' THEN 'Mens'
    WHEN Style = 'W' THEN 'Womens'
END
ClassDesc System.String
CASE
    WHEN Class IS NULL THEN 'Not Applicable'
    WHEN Class = 'H' THEN  'High'
    WHEN Class = 'M' THEN 'Medium'
    WHEN Class = 'L' THEN 'Low'
END
GermanDescription | System.String
JapaneseDescription | System.String
TurkishDescription | System.String
ModelNameAssembly System.String
Case
    WHEN ModelName IS NULL THEN 'Assembly Components'
    ELSE ModelName
END
Total: 44 column(s)

Collapse image See also

About this documentation


Table: FactInternetSales

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactInternetSales
Friendly name | Internet Sales Facts
Table name | dbo_FactInternetSales
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactInternetSales_DimSalesTerritory | SalesTerritoryKey | DimSalesTerritory | Table | SalesTerritoryKey
FK_FactInternetSales_DimPromotion | PromotionKey | DimPromotion | Table | PromotionKey
FK_FactInternetSales_DimProduct | ProductKey | DimProduct | Table | ProductKey
FK_FactInternetSales_DimCustomer | CustomerKey | DimCustomer | Table | CustomerKey
FK_FactInternetSales_DimDate2 | ShipDateKey | DimDate | Table | DateKey
FK_FactInternetSales_DimDate1 | DueDateKey | DimDate | Table | DateKey
FK_FactInternetSales_DimDate | OrderDateKey | DimDate | Table | DateKey
FK_FactInternetSales_DimCurrency | CurrencyKey | Currency | View | CurrencyKey
Total: 8 parent relationship(s)

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FK_FactInternetSalesReason_FactInternetSales | SalesOrderNumber, SalesOrderLineNumber | FactInternetSalesReason | Table | SalesOrderNumber, SalesOrderLineNumber
Total: 1 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
ProductKey | System.Int32
OrderDateKey | System.Int32
DueDateKey | System.Int32
ShipDateKey | System.Int32
CustomerKey | System.Int32
PromotionKey | System.Int32
CurrencyKey | System.Int32
SalesTerritoryKey | System.Int32
SalesOrderNumber | System.String
SalesOrderLineNumber | System.Byte
RevisionNumber | System.Byte
OrderQuantity | System.Int16
UnitPrice | System.Decimal
ExtendedAmount | System.Decimal
UnitPriceDiscountPct | System.Double
DiscountAmount | System.Double
ProductStandardCost | System.Decimal
TotalProductCost | System.Decimal
SalesAmount | System.Decimal
TaxAmt | System.Decimal
Freight | System.Decimal
CarrierTrackingNumber | System.String
CustomerPONumber | System.String
SalesOrderDesc System.String
CONVERT ( CHAR ( 10 ), SalesOrderNumber )  + 'Line '  +
CONVERT ( CHAR ( 4 ), SalesOrderLineNumber )
OrderDate | System.DateTime
DueDate | System.DateTime
ShipDate | System.DateTime
Total: 27 column(s)

Collapse image See also

About this documentation


Table: FactResellerSales

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactResellerSales
Friendly name | Reseller Sales Facts
Table name | dbo_FactResellerSales
Table type | Table
Is loaded |

Collapse image Query definition

No relationships exist

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FK_FactResellerSales_DimSalesTerritory | SalesTerritoryKey | DimSalesTerritory | Table | SalesTerritoryKey
FK_FactResellerSales_DimReseller | ResellerKey | DimReseller | Table | ResellerKey
FK_FactResellerSales_DimPromotion | PromotionKey | DimPromotion | Table | PromotionKey
FK_FactResellerSales_DimProduct | ProductKey | DimProduct | Table | ProductKey
FK_FactResellerSales_DimEmployee | EmployeeKey | DimEmployee | Table | EmployeeKey
FK_FactResellerSales_DimDate1 | DueDateKey | DimDate | Table | DateKey
FK_FactResellerSales_DimDate | OrderDateKey | DimDate | Table | DateKey
FK_FactResellerSales_DimDate2 | ShipDateKey | DimDate | Table | DateKey
FK_FactResellerSales_DimCurrency | CurrencyKey | Currency | View | CurrencyKey
Total: 9 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
ProductKey | System.Int32
OrderDateKey | System.Int32
DueDateKey | System.Int32
ShipDateKey | System.Int32
ResellerKey | System.Int32
EmployeeKey | System.Int32
PromotionKey | System.Int32
CurrencyKey | System.Int32
SalesTerritoryKey | System.Int32
SalesOrderNumber | System.String
SalesOrderLineNumber | System.Byte
RevisionNumber | System.Byte
OrderQuantity | System.Int16
UnitPrice | System.Decimal
ExtendedAmount | System.Decimal
UnitPriceDiscountPct | System.Double
DiscountAmount | System.Double
ProductStandardCost | System.Decimal
TotalProductCost | System.Decimal
SalesAmount | System.Decimal
TaxAmt | System.Decimal
Freight | System.Decimal
CarrierTrackingNumber | System.String
CustomerPONumber | System.String
SalesOrderDesc System.String
CONVERT ( CHAR ( 10 ), SalesOrderNumber )  + 'Line '  +
CONVERT ( CHAR ( 4 ), SalesOrderLineNumber )
OrderDate | System.DateTime
DueDate | System.DateTime
ShipDate | System.DateTime
Total: 28 column(s)

Collapse image See also

About this documentation


Table: Sales Summary Facts

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Sales Summary Facts
Friendly name | Sales Summary Facts
Table name | FactSalesSummary
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     ProductKey, OrderDateKey, DueDateKey, ShipDateKey, ResellerKey, NULL AS CustomerKey, EmployeeKey, PromotionKey, CurrencyKey,
                      SalesTerritoryKey, SalesOrderNumber, SalesOrderLineNumber, RevisionNumber, OrderQuantity, UnitPrice, ExtendedAmount, UnitPriceDiscountPct,
                      DiscountAmount, ProductStandardCost, TotalProductCost, SalesAmount, TaxAmt, Freight, CarrierTrackingNumber, CustomerPONumber,
                      'Reseller' AS SalesChannel, CONVERT(CHAR(10), SalesOrderNumber) + 'Line ' + CONVERT(CHAR(4), SalesOrderLineNumber) AS SalesOrderDesc
FROM         FactResellerSales
UNION
SELECT     ProductKey, OrderDateKey, DueDateKey, ShipDateKey, NULL AS ResellerKey, CustomerKey, NULL AS EmployeeKey, PromotionKey, CurrencyKey,
                      SalesTerritoryKey, SalesOrderNumber, SalesOrderLineNumber, RevisionNumber, OrderQuantity, UnitPrice, ExtendedAmount, UnitPriceDiscountPct,
                      DiscountAmount, ProductStandardCost, TotalProductCost, SalesAmount, TaxAmt, Freight, CarrierTrackingNumber, CustomerPONumber,
                      'Internet' AS SalesChannel, CONVERT(CHAR(10), SalesOrderNumber) + 'Line ' + CONVERT(CHAR(4), SalesOrderLineNumber) AS SalesOrderDesc
FROM         FactInternetSales

Collapse image Parent relations

Relation name | Child (foreign key) columns | Parent name | Parent type | Parent (primary key) columns
FactSalesSummary-DimProduct | ProductKey | DimProduct | Table | ProductKey
FactSalesSummary-DimSalesTerritory | SalesTerritoryKey | DimSalesTerritory | Table | SalesTerritoryKey
FactSalesSummary-DimPromotion | PromotionKey | DimPromotion | Table | PromotionKey
FactSalesSummary-DimCurrency | CurrencyKey | Currency | View | CurrencyKey
Sales Summary Facts-DimDate | OrderDateKey | DimDate | Table | DateKey
Sales Summary Facts-DimDate1 | DueDateKey | DimDate | Table | DateKey
Sales Summary Facts-DimDate2 | ShipDateKey | DimDate | Table | DateKey
Total: 7 parent relationship(s)

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
ProductKey | System.Int32 |
OrderDateKey | System.Int32 |
DueDateKey | System.Int32 |
ShipDateKey | System.Int32 |
ResellerKey | System.Int32 |
CustomerKey | System.Int32 |
EmployeeKey | System.Int32 |
PromotionKey | System.Int32 |
CurrencyKey | System.Int32 |
SalesTerritoryKey | System.Int32 |
SalesOrderNumber | System.String |
SalesOrderLineNumber | System.Byte |
RevisionNumber | System.Byte |
OrderQuantity | System.Int16 |
UnitPrice | System.Decimal |
ExtendedAmount | System.Decimal |
UnitPriceDiscountPct | System.Double |
DiscountAmount | System.Double |
ProductStandardCost | System.Decimal |
TotalProductCost | System.Decimal |
SalesAmount | System.Decimal |
TaxAmt | System.Decimal |
Freight | System.Decimal |
CarrierTrackingNumber | System.String |
CustomerPONumber | System.String |
SalesChannel | System.String |
SalesOrderDesc | System.String |
Total: 27 column(s)

Collapse image See also

About this documentation


Table: Destination Currency

Collapse image Table properties

Property | Value
Database schema name |
Database table name | Destination Currency
Friendly name | Destination Currency
Table name | DimDestinationCurrency
Table type | View
Is loaded | True

Collapse image Query definition

SELECT     CurrencyKey, CurrencyAlternateKey, CurrencyName,
                      CASE WHEN CurrencyAlternateKey = 'ARS' THEN '11274' WHEN CurrencyAlternateKey = 'AUD' THEN '3081' WHEN CurrencyAlternateKey = 'DEM' THEN
                       '1031' WHEN CurrencyAlternateKey = 'GBP' THEN '2057' WHEN CurrencyAlternateKey = 'MXN' THEN '2058' WHEN CurrencyAlternateKey = 'CAD' THEN
                       '4105' WHEN CurrencyAlternateKey = 'SAR' THEN '1025' WHEN CurrencyAlternateKey = 'EUR' THEN '2067' WHEN CurrencyAlternateKey = 'FRF' THEN
                       '1036' WHEN CurrencyAlternateKey = 'BRL' THEN '1046' WHEN CurrencyAlternateKey = 'JPY' THEN '1041' WHEN CurrencyAlternateKey = 'CNY' THEN
                       '2052' WHEN CurrencyAlternateKey = 'VEB' THEN '16394' WHEN CurrencyAlternateKey = 'USD' THEN '1033' END AS LCID
FROM         dbo.DimCurrency
WHERE     (CurrencyKey IN
                          (SELECT DISTINCT CurrencyKey
                            FROM          dbo.FactCurrencyRate))

Collapse image Parent relations

No relationships exist

Collapse image Child relations

Relation name | Parent (primary key) columns | Child name | Child type | Child (foreign key) columns
FactCurrencyRate-DimDestinationCurrency | CurrencyKey | Currency Rate Facts | View | CurrencyKey
DimOrganization-DimDestinationCurrency | CurrencyKey | Organization | View | CurrencyKey
Total: 2 child relationship(s)

Collapse image Columns

Name | Type | Computed column expression
CurrencyKey | System.Int32 |
CurrencyAlternateKey | System.String |
CurrencyName | System.String |
LCID | System.String |
Total: 4 column(s)

Collapse image See also

About this documentation


Data source view: Clustered Customers

Collapse image Data source view properties

Property | Value
Date created | 7/18/2014 6:44:11 PM
Is loaded | True
Last schema update | 7/18/2014 6:50:54 PM

Collapse image Tables

Name | Type | Parent relations count | Child relations count
DIMENSION_CONTENT_ROWSET | Named query | 0 | 0
Total: 1 table(s)

Collapse image See also

About this documentation


Table: DIMENSION_CONTENT_ROWSET

Collapse image Table properties

Property | Value
Database schema name |
Database table name |
Friendly name |
Table name | DIMENSION_CONTENT_ROWSET
Table type | Named query
Is loaded |

Collapse image Query definition

SELECT * FROM [Customer Clusters].DIMENSION_CONTENT

Collapse image Parent relations

No relationships exist

Collapse image Child relations

No relationships exist

Collapse image Columns

Name | Type | Computed column expression
ATTRIBUTE_NAME | System.String |
NODE_NAME | System.String |
NODE_TYPE | System.Int32 |
NODE_GUID | System.String |
NODE_CAPTION | System.String |
CHILDREN_CARDINALITY | System.UInt32 |
PARENT_UNIQUE_NAME | System.String |
NODE_DESCRIPTION | System.String |
NODE_RULE | System.String |
MARGINAL_RULE | System.String |
NODE_PROBABILITY | System.Double |
MARGINAL_PROBABILITY | System.Double |
NODE_SUPPORT | System.Double |
MSOLAP_MODEL_COLUMN | System.String |
MSOLAP_NODE_SCORE | System.Double |
MSOLAP_NODE_SHORT_CAPTION | System.String |
NODE_UNIQUE_NAME | System.String |
Total: 17 column(s)

Collapse image See also

About this documentation


Cubes

List of cubes

Collapse image Cubes

Name | Data source view | Data source | State | Storage mode | Last schema update
Adventure Works | Adventure Works DW | Adventure Works DW | Processed | Molap | 7/18/2014 6:50:56 PM
Mined Customers | Adventure Works DW | Adventure Works DW | Processed | Molap | 7/18/2014 6:51:00 PM
Total: 2 cube(s)

Collapse image See also

About this documentation


Cube: Adventure Works

Collapse image Cube properties

Property | Value
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:12 PM
Default measure | [Measures].[Reseller Sales Amount]
Estimated rows | 0
Is loaded | True
Language | English (United States)
Last processed | 7/28/2014 9:46:44 PM
Last schema update | 7/18/2014 6:50:56 PM
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Visible | True

Collapse image Cube object index

Objects | Total
Actions | 5
Dimensions | 16
KPIs | 5
MDX Scripts | 1
Measure groups | 9
Perspectives | 0

Collapse image See also

About this documentation


Actions

List of actions

Collapse image Actions

Name | Type | Description
City Map | Url | This action will display the map for a given city.
Sales Reason Comparisons | Report | This action will launch a report comparing sales reasons for a given product category.
Reseller Details | DrillThrough |
Internet Details | DrillThrough |
Sales Summary Details | DrillThrough |
Total: 5 action(s)

Collapse image See also

About this documentation


Action: City Map

Collapse image Action properties

Property | Value
Caption | "View Map for " + [Geography].[City].CurrentMember.Member_Caption + "..."
Caption is Mdx | True
Description | This action will display the map for a given city.
Invocation | Interactive
Target object | [Geography].[City]
Target type | AttributeMembers
Type | Url

Collapse image See also

About this documentation


Action: Sales Reason Comparisons

Collapse image Action properties

Property | Value
Caption | "Sales Reason Comparisons for " + [Product].[Category].CurrentMember.Member_Caption + "..."
Caption is Mdx | True
Description | This action will launch a report comparing sales reasons for a given product category.
Invocation | Interactive
Target object | [Product].[Category]
Target type | AttributeMembers
Type | Report

Collapse image See also

About this documentation


Action: Reseller Details

Collapse image Action properties

Property | Value
Caption | Drillthrough...
Caption is Mdx | False
Description |
Invocation | Interactive
Target object | MeasureGroupMeasures("Reseller Sales")
Target type | Cells
Type | DrillThrough

Collapse image See also

About this documentation


Action: Internet Details

Collapse image Action properties

Property | Value
Caption | Drillthrough...
Caption is Mdx | False
Description |
Invocation | Interactive
Target object | MeasureGroupMeasures("Internet Sales")
Target type | Cells
Type | DrillThrough

Collapse image See also

About this documentation


Action: Sales Summary Details

Collapse image Action properties

Property | Value
Caption | Drillthrough...
Caption is Mdx | False
Description |
Invocation | Interactive
Target object | MeasureGroupMeasures("Sales Summary")
Target type | Cells
Type | DrillThrough

Collapse image See also

About this documentation


Dimensions

List of dimensions

Collapse image Dimensions

Name | Attribute count | Hierarchy count | Visible | Database dimension
Date | 21 | 4 | True | Date
Ship Date | 21 | 4 | True | Date
Delivery Date | 21 | 4 | True | Date
Customer | 21 | 1 | True | Customer
Reseller | 17 | 4 | True | Reseller
Geography | 5 | 1 | True | Geography
Employee | 26 | 1 | True | Employee
Promotion | 8 | 1 | True | Promotion
Product | 21 | 3 | True | Product
Sales Territory | 3 | 1 | True | Sales Territory
Source Currency | 2 | 0 | True | Source Currency
Sales Reason | 2 | 1 | True | Sales Reason
Sales Summary Order Details | 5 | 1 | True | Sales Summary Order Details
Internet Sales Order Details | 3 | 1 | True | Internet Sales Order Details
Reseller Sales Order Details | 5 | 1 | True | Reseller Sales Order Details
Sales Channel | 1 | 0 | True | Sales Channel
Total: 16 dimension(s)

Collapse image See also

About this documentation


Dimension: Date

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Time
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Fiscal Year | Default | True | True | FullyOptimized |
Date | Default | True | True | FullyOptimized |
Calendar Quarter | Default | True | False | FullyOptimized |
Fiscal Quarter | Default | True | False | FullyOptimized |
Calendar Semester | Default | True | False | FullyOptimized |
Fiscal Semester | Default | True | False | FullyOptimized |
Day of Week | Default | True | True | FullyOptimized |
Day Name | Default | True | True | FullyOptimized |
Day of Month | Default | True | True | FullyOptimized |
Day of Year | Default | True | True | FullyOptimized |
Calendar Week | Default | True | False | FullyOptimized |
Month Name | Default | True | False | FullyOptimized |
Calendar Year | Default | True | True | FullyOptimized |
Fiscal Semester of Year | Default | True | True | FullyOptimized |
Calendar Semester of Year | Default | True | True | FullyOptimized |
Fiscal Quarter of Year | Default | True | True | FullyOptimized |
Calendar Quarter of Year | Default | True | True | FullyOptimized |
Month of Year | Default | True | True | FullyOptimized |
Fiscal Week | Default | True | False | FullyOptimized |
Calendar Week of Year | Default | True | True | FullyOptimized |
Fiscal Week of Year | Default | True | True | FullyOptimized |
Total: 21 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Fiscal | True | True | FullyOptimized |
Calendar | True | True | FullyOptimized |
Calendar Weeks | True | True | FullyOptimized |
Fiscal Weeks | True | True | FullyOptimized |
Total: 4 hierarchies

Collapse image See also

About this documentation


Dimension: Ship Date

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Time
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Fiscal Year | Default | True | True | FullyOptimized |
Date | Default | True | True | FullyOptimized |
Calendar Quarter | Default | True | False | FullyOptimized |
Fiscal Quarter | Default | True | False | FullyOptimized |
Calendar Semester | Default | True | False | FullyOptimized |
Fiscal Semester | Default | True | False | FullyOptimized |
Day of Week | Default | True | True | FullyOptimized |
Day Name | Default | True | True | FullyOptimized |
Day of Month | Default | True | True | FullyOptimized |
Day of Year | Default | True | True | FullyOptimized |
Calendar Week | Default | True | False | FullyOptimized |
Month Name | Default | True | False | FullyOptimized |
Calendar Year | Default | True | True | FullyOptimized |
Fiscal Semester of Year | Default | True | True | FullyOptimized |
Calendar Semester of Year | Default | True | True | FullyOptimized |
Fiscal Quarter of Year | Default | True | True | FullyOptimized |
Calendar Quarter of Year | Default | True | True | FullyOptimized |
Month of Year | Default | True | True | FullyOptimized |
Fiscal Week | Default | True | False | FullyOptimized |
Calendar Week of Year | Default | True | True | FullyOptimized |
Fiscal Week of Year | Default | True | True | FullyOptimized |
Total: 21 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Fiscal | True | True | FullyOptimized |
Calendar | True | True | FullyOptimized |
Calendar Weeks | True | True | FullyOptimized |
Fiscal Weeks | True | True | FullyOptimized |
Total: 4 hierarchies

Collapse image See also

About this documentation


Dimension: Delivery Date

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Time
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Fiscal Year | Default | True | True | FullyOptimized |
Date | Default | True | True | FullyOptimized |
Calendar Quarter | Default | True | False | FullyOptimized |
Fiscal Quarter | Default | True | False | FullyOptimized |
Calendar Semester | Default | True | False | FullyOptimized |
Fiscal Semester | Default | True | False | FullyOptimized |
Day of Week | Default | True | True | FullyOptimized |
Day Name | Default | True | True | FullyOptimized |
Day of Month | Default | True | True | FullyOptimized |
Day of Year | Default | True | True | FullyOptimized |
Calendar Week | Default | True | False | FullyOptimized |
Month Name | Default | True | False | FullyOptimized |
Calendar Year | Default | True | True | FullyOptimized |
Fiscal Semester of Year | Default | True | True | FullyOptimized |
Calendar Semester of Year | Default | True | True | FullyOptimized |
Fiscal Quarter of Year | Default | True | True | FullyOptimized |
Calendar Quarter of Year | Default | True | True | FullyOptimized |
Month of Year | Default | True | True | FullyOptimized |
Fiscal Week | Default | True | False | FullyOptimized |
Calendar Week of Year | Default | True | True | FullyOptimized |
Fiscal Week of Year | Default | True | True | FullyOptimized |
Total: 21 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Fiscal | True | True | FullyOptimized |
Calendar | True | True | FullyOptimized |
Calendar Weeks | True | True | FullyOptimized |
Fiscal Weeks | True | True | FullyOptimized |
Total: 4 hierarchies

Collapse image See also

About this documentation


Dimension: Customer

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Customer
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Customer | Default | True | True | FullyOptimized |
Postal Code | Default | True | True | FullyOptimized |
Country | Default | True | True | FullyOptimized |
State-Province | Default | True | True | FullyOptimized |
Birth Date | Default | False | True | FullyOptimized |
City | Default | True | True | FullyOptimized |
Date of First Purchase | Default | False | True | FullyOptimized |
Phone | Default | False | True | FullyOptimized |
Email Address | Default | False | True | FullyOptimized |
Yearly Income | Default | True | True | FullyOptimized |
Total Children | Default | True | True | FullyOptimized |
Number of Cars Owned | Default | True | True | FullyOptimized |
Number of Children At Home | Default | True | True | FullyOptimized |
Education | Default | True | True | FullyOptimized |
Occupation | Default | True | True | FullyOptimized |
Marital Status | Default | True | True | FullyOptimized |
Gender | Default | True | True | FullyOptimized |
Home Owner | Default | True | True | FullyOptimized |
Commute Distance | Default | True | True | FullyOptimized |
Commute Distance Sort | Default | False | True | FullyOptimized |
Address | Default | False | True | FullyOptimized |
Total: 21 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Customer Geography | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Reseller

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Reseller
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Reseller | Default | True | True | FullyOptimized |
Product Line | Default | True | True | FullyOptimized |
Phone | Default | False | True | FullyOptimized |
Last Order Year | Default | False | True | FullyOptimized |
Business Type | Default | True | True | FullyOptimized |
First Order Year | Default | False | True | FullyOptimized |
Number of Employees | Default | True | True | FullyOptimized |
Year Opened | Default | False | True | FullyOptimized |
Annual Sales | Default | True | True | FullyOptimized |
Annual Revenue | Default | True | True | FullyOptimized |
Bank Name | Default | True | True | FullyOptimized |
Min Payment Amount | Default | False | True | FullyOptimized |
Min Payment Type | Default | False | True | FullyOptimized |
Order Frequency | Default | True | True | FullyOptimized |
Order Month | Default | True | True | FullyOptimized |
Geography Key | Default | True | False | FullyOptimized |
Address | Default | False | True | FullyOptimized |
Total: 17 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Reseller Type | True | True | FullyOptimized |
Reseller Bank | True | True | FullyOptimized |
Reseller Order Frequency | True | True | FullyOptimized |
Reseller Order Month | True | True | FullyOptimized |
Total: 4 hierarchies

Collapse image See also

About this documentation


Dimension: Geography

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Geography
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
City | Default | True | True | FullyOptimized |
State-Province | Default | True | True | FullyOptimized |
Country | Default | True | True | FullyOptimized |
Postal Code | Default | True | True | FullyOptimized |
Geography Key | Default | True | False | FullyOptimized |
Total: 5 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Geography | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Employee

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Employee
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Employee | Default | True | False | FullyOptimized |
Department Name | Default | True | True | FullyOptimized |
Sales Person Flag | Default | True | True | FullyOptimized |
Title | Default | True | True | FullyOptimized |
Hire Date | Default | True | True | FullyOptimized |
Sick Leave Hours | Default | True | True | FullyOptimized |
Birth Date | Default | False | True | FullyOptimized |
Vacation Hours | Default | True | True | FullyOptimized |
Login ID | Default | False | True | FullyOptimized |
Base Rate | Default | True | True | FullyOptimized |
Email Address | Default | False | True | FullyOptimized |
Pay Frequency | Default | True | True | FullyOptimized |
Phone | Default | True | True | FullyOptimized |
Salaried Flag | Default | True | True | FullyOptimized |
Emergency Contact Name | Default | False | True | FullyOptimized |
Emergency Contact Phone | Default | False | True | FullyOptimized |
Gender | Default | True | True | FullyOptimized |
Marital Status | Default | True | True | FullyOptimized |
Sales Territory Key | Default | True | False | FullyOptimized |
SSN | Default | False | True | FullyOptimized |
Manager SSN | Default | False | True | FullyOptimized |
Employees | Default | True | True | FullyOptimized |
Status | Default | True | True | FullyOptimized |
Start Date | Default | True | True | FullyOptimized |
End Date | Default | True | True | FullyOptimized |
Hire Year | Default | True | True | FullyOptimized |
Total: 26 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Employee Department | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Promotion

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Promotion
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Promotion | Default | True | True | FullyOptimized |
Discount Percent | Default | True | True | FullyOptimized |
Max Quantity | Default | True | True | FullyOptimized |
Promotion Type | Default | True | True | FullyOptimized |
Min Quantity | Default | True | True | FullyOptimized |
Promotion Category | Default | True | True | FullyOptimized |
End Date | Default | True | True | FullyOptimized |
Start Date | Default | True | True | FullyOptimized |
Total: 8 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Promotions | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Product

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Product
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Product | Default | True | True | FullyOptimized |
Standard Cost | Default | True | True | FullyOptimized |
Category | Default | True | True | FullyOptimized |
Color | Default | True | True | FullyOptimized |
Safety Stock Level | Default | True | True | FullyOptimized |
Reorder Point | Default | True | True | FullyOptimized |
List Price | Default | True | True | FullyOptimized |
Size | Default | True | True | FullyOptimized |
Size Range | Default | True | True | FullyOptimized |
Weight | Default | True | True | FullyOptimized |
Days to Manufacture | Default | True | True | FullyOptimized |
Dealer Price | Default | True | True | FullyOptimized |
Class | Default | True | True | FullyOptimized |
Style | Default | True | True | FullyOptimized |
Model Name | Default | True | True | FullyOptimized |
Product Line | Default | True | True | FullyOptimized |
Subcategory | Default | True | True | FullyOptimized |
Status | Default | True | True | FullyOptimized |
Start Date | Default | True | True | FullyOptimized |
End Date | Default | True | True | FullyOptimized |
Large Photo | Default | True | True | FullyOptimized |
Total: 21 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Product Categories | True | True | FullyOptimized |
Product Model Lines | True | True | FullyOptimized |
Stock Level | True | True | FullyOptimized |
Total: 3 hierarchies

Collapse image See also

About this documentation


Dimension: Sales Territory

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Sales Territory
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Sales Territory Region | Default | True | True | FullyOptimized |
Sales Territory Country | Default | True | True | FullyOptimized |
Sales Territory Group | Default | True | True | FullyOptimized |
Total: 3 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Sales Territory | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Source Currency

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Currency
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Source Currency Code | Default | True | True | FullyOptimized |
Source Currency | Default | True | True | FullyOptimized |
Total: 2 attributes(s)

Collapse image Hierarchies

No hierarchies exist

Collapse image See also

About this documentation


Dimension: Sales Reason

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Dim Sales Reason
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Sales Reason | Default | True | True | FullyOptimized |
Sales Reason Type | Default | True | True | FullyOptimized |
Total: 2 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Sales Reasons | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Sales Summary Order Details

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Fact Sales Summary 1
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Sales Order | Default | True | False | FullyOptimized |
Carrier Tracking Number | Default | True | True | FullyOptimized |
Customer PO Number | Default | True | True | FullyOptimized |
Sales Order Number | Default | True | True | FullyOptimized |
Sales Order Line | Default | True | True | FullyOptimized |
Total: 5 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Sales Orders | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Internet Sales Order Details

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Fact Internet Sales
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Internet Sales Order | Default | True | False | FullyOptimized |
Sales Order Number | Default | True | True | FullyOptimized |
Sales Order Line | Default | True | True | FullyOptimized |
Total: 3 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Internet Sales Orders | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Reseller Sales Order Details

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Fact Reseller Sales
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Reseller Sales Order | Default | True | False | FullyOptimized |
Carrier Tracking Number | Default | True | True | FullyOptimized |
Customer PO Number | Default | True | True | FullyOptimized |
Sales Order Number | Default | True | True | FullyOptimized |
Sales Order Line | Default | True | True | FullyOptimized |
Total: 5 attributes(s)

Collapse image Hierarchies

Name | Enabled | Visible | Optimized state | Description
Reseller Sales Orders | True | True | FullyOptimized |
Total: 1 hierarchies

Collapse image See also

About this documentation


Dimension: Sales Channel

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Fact Sales Summary
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Sales Channel | Default | True | True | FullyOptimized |
Total: 1 attributes(s)

Collapse image Hierarchies

No hierarchies exist

Collapse image See also

About this documentation


KPIs

List of KPIs

Collapse image KPIs

Name | Associated measure group | Description
Growth in Customer Base | Internet Sales | The ratio between the customer count in the current period to that of the previous period.
Product Gross Profit Margin | Sales Summary | Total profit earned as a percentage of sales.
Revenue | Sales Summary | Total revenue from operations.
Channel Revenue | Reseller Sales | Revenue realized through the reseller sales channel.
Internet Revenue | Internet Sales | Revenue realized through direct sales via the internet.
Total: 5 KPI(s)

Collapse image See also

About this documentation


KPI: Growth in Customer Base

Collapse image KPI properties

Property | Value
Associated measure group | Internet Sales
Description | The ratio between the customer count in the current period to that of the previous period.
Display folder | Customer Perspective\Expand Customer Base
Status indicator | Road Signs
Trend indicator | Standard Arrow

Collapse image Value expression

[Measures].[Growth in Customer Base]

Collapse image Goal expression

Case
    When [Date].[Fiscal].CurrentMember.Level Is [Date].[Fiscal].[Fiscal Year]
    Then .30
    When [Date].[Fiscal].CurrentMember.Level Is [Date].[Fiscal].[Fiscal Semester]
    Then .15
    When [Date].[Fiscal].CurrentMember.Level Is [Date].[Fiscal].[Fiscal Quarter]
    Then .075
    When [Date].[Fiscal].CurrentMember.Level Is [Date].[Fiscal].[Month]
    Then .025
    Else "NA"
End

Collapse image Status expression

Case
    When KpiValue( "Growth in Customer Base" ) >=
         KpiGoal ( "Growth in Customer Base" )
    Then 1
    When KpiValue( "Growth in Customer Base" ) >=
         KpiGoal ( "Growth in Customer Base" ) * .90
         And
         KpiValue( "Growth in Customer Base" ) <
         KpiGoal ( "Growth in Customer Base" )
    Then 0
    Else -1
End

Collapse image Trend expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then 0
    When VBA!Abs
         (
          (
            KpiValue( "Growth in Customer Base" )
            -
            (
              KpiValue( "Growth in Customer Base" ),
              ParallelPeriod
              (
                [Date].[Fiscal].[Fiscal Year],
                1,
                [Date].[Fiscal].CurrentMember
              )
            )
          )
          /
          (
            KpiValue( "Growth in Customer Base" ),
            ParallelPeriod
            (
              [Date].[Fiscal].[Fiscal Year],
              1,
              [Date].[Fiscal].CurrentMember
            )
          )
         ) <=.02
    Then 0
    When (
           KpiValue( "Growth in Customer Base" )
           -
           (
             KpiValue( "Growth in Customer Base" ),
             ParallelPeriod
             (
               [Date].[Fiscal].[Fiscal Year],
               1,
               [Date].[Fiscal].CurrentMember
             )
           )
         )
         /
         (
           KpiValue( "Growth in Customer Base" ),
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         ) >.02
    Then 1
    Else -1
End

Collapse image See also

About this documentation


KPI: Product Gross Profit Margin

Collapse image KPI properties

Property | Value
Associated measure group | Sales Summary
Description | Total profit earned as a percentage of sales.
Display folder | Financial Perspective\Maintain Overall Margins
Status indicator | Cylinder
Trend indicator | Status Arrow - Ascending

Collapse image Value expression

[Measures].[Gross Profit Margin]

Collapse image Goal expression

Case
    When [Product].[Category].CurrentMember Is [Product].[Category].[Accessories]
    Then .40
    When [Product].[Category].CurrentMember Is [Product].[Category].[Bikes]
    Then .12
    When [Product].[Category].CurrentMember Is [Product].[Category].[Clothing]
    Then .20
    When [Product].[Category].CurrentMember Is [Product].[Category].[Components]
    Then .10
    Else .12
End

Collapse image Status expression

Case
    When KpiValue( "Product Gross Profit Margin" ) /
         KpiGoal ( "Product Gross Profit Margin" ) >= .90
    Then 1
    When KpiValue( "Product Gross Profit Margin" ) /
         KpiGoal ( "Product Gross Profit Margin" ) <  .90
         And
         KpiValue( "Product Gross Profit Margin" ) /
         KpiGoal ( "Product Gross Profit Margin" ) >= .80
    Then 0
    Else -1
End

Collapse image Trend expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then 0
    When VBA!Abs
         (
          (
            KpiValue( "Product Gross Profit Margin" )
            -
            (
              KpiValue( "Product Gross Profit Margin" ),
              ParallelPeriod
              (
                [Date].[Fiscal].[Fiscal Year],
                1,
                [Date].[Fiscal].CurrentMember
              )
            )
          )
          /
          (
            KpiValue( "Product Gross Profit Margin" ),
            ParallelPeriod
            (
              [Date].[Fiscal].[Fiscal Year],
              1,
              [Date].[Fiscal].CurrentMember
            )
          )
         ) <=.02
    Then 0
    When (
           KpiValue( "Product Gross Profit Margin" )
           -
           (
             KpiValue( "Product Gross Profit Margin" ),
             ParallelPeriod
             (
               [Date].[Fiscal].[Fiscal Year],
               1,
               [Date].[Fiscal].CurrentMember
             )
           )
         )
         /
         (
           KpiValue( "Product Gross Profit Margin" ),
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         ) >.02
    Then 1
    Else -1
End

Collapse image See also

About this documentation


KPI: Revenue

Collapse image KPI properties

Property | Value
Associated measure group | Sales Summary
Description | Total revenue from operations.
Display folder | Financial Perspective\Grow Revenue
Status indicator | Cylinder
Trend indicator | Standard Arrow

Collapse image Value expression

[Measures].[Sales Amount]

Collapse image Goal expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then [Measures].[Sales Amount]
    Else 1.15 *
         (
           [Measures].[Sales Amount],
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
End

Collapse image Status expression

Case
    When KpiValue( "Revenue" ) / KpiGoal( "Revenue" ) >  1
    Then 1
    When KpiValue( "Revenue" ) / KpiGoal( "Revenue" ) <= 1
         And
         KpiValue( "Revenue" ) / KpiGoal( "Revenue" ) >= .85
    Then 0
    Else -1
End

Collapse image Trend expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then 0
    When VBA!Abs
         (
          (
            KpiValue( "Revenue" )
            -
            (
              KpiValue( "Revenue" ),
              ParallelPeriod
              (
                [Date].[Fiscal].[Fiscal Year],
                1,
                [Date].[Fiscal].CurrentMember
              )
            )
          )
          /
          (
            KpiValue( "Revenue" ),
            ParallelPeriod
            (
              [Date].[Fiscal].[Fiscal Year],
              1,
              [Date].[Fiscal].CurrentMember
            )
          )
         ) <=.02
    Then 0
    When (
           KpiValue( "Revenue" )
           -
           (
             KpiValue( "Revenue" ),
             ParallelPeriod
             (
               [Date].[Fiscal].[Fiscal Year],
               1,
               [Date].[Fiscal].CurrentMember
             )
           )
         )
         /
         (
           KpiValue( "Revenue" ),
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         ) >.02
    Then 1
    Else -1
End

Collapse image See also

About this documentation


KPI: Channel Revenue

Collapse image KPI properties

Property | Value
Associated measure group | Reseller Sales
Description | Revenue realized through the reseller sales channel.
Display folder | Financial Perspective\Grow Revenue
Status indicator | Cylinder
Trend indicator | Standard Arrow

Collapse image Value expression

[Measures].[Reseller Sales Amount]

Collapse image Goal expression

[Measures].[Sales Amount Quota]

Collapse image Status expression

Case
    When KpiValue( "Channel Revenue" ) / KpiGoal( "Channel Revenue" ) >  1
    Then 1
    When KpiValue( "Channel Revenue" ) / KpiGoal( "Channel Revenue" ) <= 1
         And
         KpiValue( "Channel Revenue" ) / KpiGoal( "Channel Revenue" ) >= .85
    Then 0
    Else -1
End

Collapse image Trend expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then 0
    When VBA!Abs
         (
          (
            KpiValue( "Channel Revenue" )
            -
            (
              KpiValue( "Channel Revenue" ),
              ParallelPeriod
              (
                [Date].[Fiscal].[Fiscal Year],
                1,
                [Date].[Fiscal].CurrentMember
              )
            )
          )
          /
          (
            KpiValue( "Channel Revenue" ),
            ParallelPeriod
            (
              [Date].[Fiscal].[Fiscal Year],
              1,
              [Date].[Fiscal].CurrentMember
            )
          )
         ) <=.02
    Then 0
    When (
           KpiValue( "Channel Revenue" )
           -
           (
             KpiValue( "Channel Revenue" ),
             ParallelPeriod
             (
               [Date].[Fiscal].[Fiscal Year],
               1,
               [Date].[Fiscal].CurrentMember
             )
           )
         )
         /
         (
           KpiValue( "Channel Revenue" ),
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         ) >.02
    Then 1
    Else -1
End

Collapse image See also

About this documentation


KPI: Internet Revenue

Collapse image KPI properties

Property | Value
Associated measure group | Internet Sales
Description | Revenue realized through direct sales via the internet.
Display folder | Financial Perspective\Grow Revenue
Status indicator | Cylinder
Trend indicator | Standard Arrow

Collapse image Value expression

[Measures].[Internet Sales Amount]

Collapse image Goal expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then [Measures].[Internet Sales Amount]
    Else 1.10 *
         (
           [Measures].[Internet Sales Amount],
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
End

Collapse image Status expression

Case
    When KpiValue( "Internet Revenue" ) / KpiGoal( "Internet Revenue" ) >  1
    Then 1
    When KpiValue( "Internet Revenue" ) / KpiGoal( "Internet Revenue" ) <= 1
         And
         KpiValue( "Internet Revenue" ) / KpiGoal( "Internet Revenue" ) >= .85
    Then 0
    Else -1
End

Collapse image Trend expression

Case
    When IsEmpty
         (
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         )
    Then 0
    When VBA!Abs
         (
          (
            KpiValue( "Internet Revenue" )
            -
            (
              KpiValue( "Internet Revenue" ),
              ParallelPeriod
              (
                [Date].[Fiscal].[Fiscal Year],
                1,
                [Date].[Fiscal].CurrentMember
              )
            )
          )
          /
          (
            KpiValue( "Internet Revenue" ),
            ParallelPeriod
            (
              [Date].[Fiscal].[Fiscal Year],
              1,
              [Date].[Fiscal].CurrentMember
            )
          )
         ) <=.02
    Then 0
    When (
           KpiValue( "Internet Revenue" )
           -
           (
             KpiValue( "Internet Revenue" ),
             ParallelPeriod
             (
               [Date].[Fiscal].[Fiscal Year],
               1,
               [Date].[Fiscal].CurrentMember
             )
           )
         )
         /
         (
           KpiValue( "Internet Revenue" ),
           ParallelPeriod
           (
             [Date].[Fiscal].[Fiscal Year],
             1,
             [Date].[Fiscal].CurrentMember
           )
         ) >.02
    Then 1
    Else -1
End

Collapse image See also

About this documentation


MDX Scripts

List of MDX scripts

Collapse image MDX scripts

Name | Calculation properties
MdxScript | 24
Total: 1 MDX script(s)

Collapse image See also

About this documentation


MDX script: MdxScript

Collapse image MDX script properties

Property | Value
Parent cube | Adventure Works
Description |
Default script | True

Collapse image Calculations

Name | Type | Description
[Measures].[Discount Percentage] | Member |
[Measures].[Internet Ratio to All Products] | Member |
[Measures].[Internet Ratio to Parent Product] | Member |
[Measures].[Reseller Ratio to All Products] | Member |
[Measures].[Reseller Ratio to Parent Product] | Member |
[Measures].[Ratio to All Products] | Member |
[Measures].[Ratio to Parent Product] | Member |
[Measures].[Growth in Customer Base] | Member |
Long Lead Products | Set |
Core Product Group | Set |
Large Resellers | Set |
High Discount Promotions | Set |
[Measures].[Reseller Average Sales Amount] | Member |
[Measures].[Reseller Average Unit Price] | Member |
[Measures].[Internet Average Unit Price] | Member |
[Measures].[Internet Average Sales Amount] | Member |
[Measures].[Internet Gross Profit] | Member |
[Measures].[Internet Gross Profit Margin] | Member |
[Measures].[Reseller Gross Profit] | Member |
[Measures].[Reseller Gross Profit Margin] | Member |
[Measures].[Gross Profit] | Member |
[Measures].[Gross Profit Margin] | Member |
[Measures].[Average Unit Price] | Member |
[Measures].[Average Sales Amount] | Member |
Total: 24 calculation(s)

Collapse image Script view

/*-- Aggregate leaf data -----------------------------------------------*/
Calculate;

/*-----------------------------------------------------------------------------
 | Internet Sales Calculations |
-----------------------------------------------------------------------------*/

Create Member CurrentCube.[Measures].[Internet Gross Profit]

 As [Measures].[Internet Sales Amount]
    -
    [Measures].[Internet Total Product Cost],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior =
 {
   [Internet Sales Amount],
   [Internet Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Internet Gross Profit Margin]

 As (
      [Measures].[Internet Sales Amount]
      -
      [Measures].[Internet Total Product Cost]
    )
    /
    [Measures].[Internet Sales Amount],

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior =
 {
   [Internet Sales Amount],
   [Internet Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Internet Average Unit Price]

 As [Measures].[Internet Unit Price]
    /
    [Measures].[Internet Transaction Count],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Unit Price];

Create Member CurrentCube.[Measures].[Internet Average Sales Amount]

 As [Measures].[Internet Sales Amount]
    /
    [Measures].[Internet Order Count],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Sales Amount];

Create Member CurrentCube.[Measures].[Internet Ratio to All Products]

 As [Measures].[Internet Sales Amount]
    /
    (
      Root( [Product] ),
      [Measures].[Internet Sales Amount]
    ),

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Sales Amount];

Create Member CurrentCube.[Measures].[Internet Ratio to Parent Product]

 As Case

        When [Product].[Product Categories].CurrentMember.Level.Ordinal
             = 0
        Then 1

        Else [Measures].[Internet Sales Amount]
             /
             ( [Product].[Product Categories].CurrentMember.Parent,
               [Measures].[Internet Sales Amount] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales';

Create Member CurrentCube.[Measures].[Growth in Customer Base]

 As Case

        When [Date].[Fiscal].CurrentMember.Level.Ordinal = 0
        Then "NA"

        When IsEmpty
             (
               (
                 [Date].[Fiscal].CurrentMember.PrevMember,
                 [Measures].[Customer Count]
               )
             )
        Then Null

        Else (
               ( [Date].[Fiscal].CurrentMember, [Measures].[Customer Count] )
               -
               ( [Date].[Fiscal].PrevMember, [Measures].[Customer Count] )
             )
             /
             ( [Date].[Fiscal].PrevMember,[Measures].[Customer Count] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales';

/*-----------------------------------------------------------------------------
 | Reseller Sales Calculations |
-----------------------------------------------------------------------------*/

Create Member CurrentCube.[Measures].[Reseller Gross Profit]

 As [Measures].[Reseller Sales Amount]
    -
    [Measures].[Reseller Total Product Cost],

Format_String = "Currency",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior =
 {
   [Reseller Sales Amount],
   [Reseller Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Reseller Gross Profit Margin]

 As (
      [Measures].[Reseller Sales Amount]
      -
      [Measures].[Reseller Total Product Cost]
    )
    /
    [Measures].[Reseller Sales Amount],

Format_String = "Percent",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior =
 {
   [Reseller Sales Amount],
   [Reseller Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Reseller Average Unit Price]

 As [Measures].[Reseller Unit Price]
    /
    [Measures].[Reseller Transaction Count],

Format_String = "Currency",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior = [Reseller Unit Price];

Create Member CurrentCube.[Measures].[Reseller Average Sales Amount]

 As [Measures].[Reseller Sales Amount]
    /
    [Measures].[Reseller Order Count],

Format_String = "Currency",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior = [Reseller Sales Amount];

Create Member CurrentCube.[Measures].[Reseller Ratio to All Products]

 As [Measures].[Reseller Sales Amount]
    /
    (
      Root( [Product] ),
      [Measures].[Reseller Sales Amount]
    ),

Format_String = "Percent",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior = [Reseller Sales Amount];

Create Member CurrentCube.[Measures].[Reseller Ratio to Parent Product]

 As Case

        When [Product].[Product Categories].CurrentMember.Level.Ordinal
             = 0
        Then 1

        Else [Measures].[Reseller Sales Amount]
             /
             ( [Product].[Product Categories].CurrentMember.Parent,
               [Measures].[Reseller Sales Amount] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Reseller Sales';

Create Member CurrentCube.[Measures].[Discount Percentage]

 As [Measures].[Discount Amount]
    /
    [Measures].[Reseller Sales Amount],

Format_String = "Percent",
Associated_Measure_Group = 'Reseller Sales',
Non_Empty_Behavior = [Discount Amount];

/*-----------------------------------------------------------------------------
 | Sales Summary Calculations |
-----------------------------------------------------------------------------*/

Create Member CurrentCube.[Measures].[Average Unit Price]

 As [Measures].[Unit Price]
    /
    [Measures].[Transaction Count],

Format_String = "Currency",
Associated_Measure_Group = 'Sales Summary',
Non_Empty_Behavior = [Unit Price];

Create Member CurrentCube.[Measures].[Average Sales Amount]

 As [Measures].[Sales Amount]
    /
    [Measures].[Order Count],

Format_String = "Currency",
Associated_Measure_Group = 'Sales Summary',
Non_Empty_Behavior = [Sales Amount];

Create Set CurrentCube.[Long Lead Products]

 As Exists
    (
       [Product].[Model Name].[Model Name].Members,
       [Product].[Days to Manufacture].&[4]
    )
,
Display_Folder = 'Sets';

Create Set CurrentCube.[Core Product Group]

As  DrillDownMember
    (
      [Product].[Product Categories].[Category].Members,
      [Product].[Product Categories].[Category].[Bikes]
    )
,
Display_Folder = 'Sets';

Create Set CurrentCube.[Large Resellers]

 As Exists
    (
       [Reseller].[Reseller].[Reseller].Members,
       [Reseller].[Number of Employees].[Number of Employees].[81 - 100]
    )
,
Display_Folder = 'Sets';

Create Set CurrentCube.[High Discount Promotions]

As  Exists
    (
       [Promotion].[Promotion].[Promotion].Members,
       Filter
       (
          [Promotion].[Discount Percent].[Discount Percent].Members,
          [Promotion].[Discount Percent].CurrentMember.MemberValue >= .30
       )
    )
,
Display_Folder = 'Sets';

Create Dynamic Set CurrentCube.[Top 25 Selling Products]

 As TopCount
    (
       [Product].[Product].[Product].Members,
       25,
       [Measures].[Sales Amount]
    )
,
Display_Folder = 'Sets';

Create Dynamic Set CurrentCube.[Top 50 Customers]

 As TopCount
    (
       [Customer].[Customer].[Customer].Members,
       50,
       [Measures].[Internet Sales Amount]
    )
,
Display_Folder = 'Sets';

Create Dynamic Set CurrentCube.[Negative Margin Products]

 As Filter
    (
       [Product].[Subcategory].[Subcategory],
       [Measures].[Gross Profit Margin] < 0
    )
,
Display_Folder = 'Sets';

Create Member CurrentCube.[Measures].[Gross Profit]

 As [Measures].[Sales Amount]
    -
    [Measures].[Total Product Cost],

Format_String = "Currency",
Associated_Measure_Group = 'Sales Summary',
Non_Empty_Behavior =
 {
   [Measures].[Sales Amount],
   [Measures].[Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Gross Profit Margin]

 As (
      [Measures].[Sales Amount]
      -
      [Measures].[Total Product Cost]
    )
    /
    [Measures].[Sales Amount],

Format_String = "Percent",
Associated_Measure_Group = 'Sales Summary',
Non_Empty_Behavior =
 {
   [Measures].[Sales Amount],
   [Measures].[Total Product Cost]
 };

Create Member CurrentCube.[Measures].[Ratio to All Products]

 As [Measures].[Sales Amount]
    /
    (
      Root( [Product] ),
      [Measures].[Sales Amount]
    ),

Format_String = "Percent",
Associated_Measure_Group = 'Sales Summary',
Non_Empty_Behavior = { [Sales Amount] };

Create Member CurrentCube.[Measures].[Ratio to Parent Product]

 As Case

        When [Product].[Product Categories].CurrentMember.Level.Ordinal
             = 0
        Then 1

        Else [Measures].[Sales Amount]
             /
             ( [Product].[Product Categories].CurrentMember.Parent,
               [Measures].[Sales Amount] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Sales Summary';

/*-----------------------------------------------------------------------------
 | Sales Quota Allocation |
-----------------------------------------------------------------------------*/

/*-- Allocate equally to quarters in H2 FY 2013 ------------------------*/

 Scope
 (
    [Date].[Fiscal Year].&[2013],
    [Date].[Fiscal].[Fiscal Quarter].Members,
    [Measures].[Sales Amount Quota]
 );

   This = ParallelPeriod
          (
             [Date].[Fiscal].[Fiscal Year], 1,
             [Date].[Fiscal].CurrentMember
          ) * 1.35;

/*-- Allocate equally to months in FY 2011 -----------------------------*/

  Scope
  (
     [Date].[Fiscal Year].&[2011],
     [Date].[Fiscal].[Month].Members
  );

    This = [Date].[Fiscal].CurrentMember.Parent / 3;

  End Scope;

/*-- Weighted allocation to remaining months ---------------------------*/

  // Pin quarterly values prior to assigning weights for months
  // This is done in order to avoid overwriting the quarterly values
  // once weights are entered for monthly values.
  Freeze
  (
     [Date].[Fiscal].[Fiscal Quarter].Members,
     [Measures].[Sales Amount Quota]
  );

  // Scope on month level in FY 2012 and onwards
  Scope
  (
     [Date].[Fiscal Year].&[2012] : Null,
     [Date].[Fiscal].[Month].Members
  );

   // Compute weights based on reseller sales ratio in previous year
   This =
   (
     ParallelPeriod         // Fetch reseller sales amount in previous year
     (
        [Date].[Fiscal].[Fiscal Year], 1,
        [Date].[Fiscal].CurrentMember
     ),
     [Measures].[Reseller Sales Amount]
   )
   /
   (
     ParallelPeriod         // Divide monthly value by quarterly value to obtain ratio
     (
        [Date].[Fiscal].[Fiscal Year], 1,
        [Date].[Fiscal].CurrentMember.Parent
     ),
     [Measures].[Reseller Sales Amount]
   );

   // Allocate quarterly values to months according to weight
   This = [Measures].CurrentMember * [Date].[Fiscal].Parent;

  End Scope;
End Scope;

Collapse image See also

About this documentation


Measure groups

List of measure groups

Collapse image Measure groups

Name | Type | Estimated size | Estimated rows | State | Last processed | Last schema update
Internet Sales | Sales | 2724507 | 60398 | Processed | 7/28/2014 9:46:38 PM | 7/18/2014 6:50:56 PM
Internet Orders | Regular | 1652598 | 0 | Processed | 7/28/2014 9:46:37 PM | 7/18/2014 6:50:56 PM
Internet Customers | Regular | 1026620 | 0 | Processed | 7/28/2014 9:46:39 PM | 7/18/2014 6:50:57 PM
Sales Reasons | Regular | 249 | 0 | Processed | 7/28/2014 9:46:29 PM | 7/18/2014 6:50:57 PM
Reseller Sales | Sales | 3621174 | 60855 | Processed | 7/28/2014 9:46:39 PM | 7/18/2014 6:50:57 PM
Reseller Orders | Regular | 1003925 | 0 | Processed | 7/28/2014 9:46:38 PM | 7/18/2014 6:50:58 PM
Sales Summary | Sales | 3242583 | 121253 | Processed | 7/28/2014 9:46:38 PM | 7/18/2014 6:50:58 PM
Sales Orders | Regular | 2063566 | 0 | Processed | 7/28/2014 9:46:44 PM | 7/18/2014 6:50:59 PM
Sales Targets | Regular | 697 | 163 | Processed | 7/28/2014 9:46:28 PM | 7/18/2014 6:50:59 PM
Total: 9 measure group(s)

Collapse image See also

About this documentation


Measure group: Internet Sales

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:13 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 60398
Estimated size | 2724507
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:38 PM
Last schema update | 7/18/2014 6:50:56 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Sales

Collapse image Measure group object index

Objects | Total
Measures | 9
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 10 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Internet Sales Amount |  | True |
Internet Order Quantity |  | True |
Internet Extended Amount |  | True |
Internet Tax Amount |  | True |
Internet Freight Cost |  | True |
Internet Unit Price |  | False |
Internet Total Product Cost |  | True |
Internet Standard Product Cost |  | True |
Internet Transaction Count |  | False |
Total: 9 measure(s)

Collapse image See also

About this documentation


Measure: Internet Sales Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Order Quantity

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Extended Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Tax Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Freight Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Unit Price

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Measure: Internet Total Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Standard Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Transaction Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Internet_Sales |  | 2724507 | 60398 | Molap | Processed | 7/18/2014 6:50:56 PM | 7/18/2014 6:44:13 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Internet_Sales

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:13 PM
Estimated rows | 60398
Estimated size | 2724507
Is loaded | True
Last schema update | 7/18/2014 6:50:56 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Internet Orders

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:13 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 1652598
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:37 PM
Last schema update | 7/18/2014 6:50:56 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 10 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Internet Order Count |  | True |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Internet Order Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Internet_Orders |  | 1652598 | 0 | Molap | Processed | 7/18/2014 6:50:57 PM | 7/18/2014 6:44:13 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Internet_Orders

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:13 PM
Estimated rows | 0
Estimated size | 1652598
Is loaded | True
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Internet Customers

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:13 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 1026620
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:39 PM
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 10 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Customer Count |  | True |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Customer Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Customer_Counts |  | 1026620 | 0 | Molap | Processed | 7/18/2014 6:50:57 PM | 7/18/2014 6:44:13 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Customer_Counts

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:13 PM
Estimated rows | 0
Estimated size | 1026620
Is loaded | True
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Sales Reasons

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:14 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 249
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:29 PM
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Total: 2 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Sales Reason Count |  | False |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Sales Reason Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Internet_Sales_Reasons |  | 249 | 0 | Molap | Processed | 7/18/2014 6:50:57 PM | 7/18/2014 6:44:14 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Internet_Sales_Reasons

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:14 PM
Estimated rows | 0
Estimated size | 249
Is loaded | True
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Reseller Sales

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:14 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 60855
Estimated size | 3621174
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:39 PM
Last schema update | 7/18/2014 6:50:57 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Sales

Collapse image Measure group object index

Objects | Total
Measures | 11
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Employee | Employee | 7/28/2014 9:46:11 PM | 7/18/2014 6:50:55 PM
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Reseller | Reseller | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Reseller Sales Order Details | Reseller Sales Order Details | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Geography | Geography | 7/28/2014 9:46:20 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 11 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Reseller Sales Amount |  | True |
Reseller Order Quantity |  | True |
Reseller Extended Amount |  | True |
Reseller Tax Amount |  | True |
Reseller Freight Cost |  | True |
Discount Amount |  | True |
Reseller Unit Price |  | False |
Unit Price Discount Percent |  | False |
Reseller Total Product Cost |  | True |
Reseller Standard Product Cost |  | True |
Reseller Transaction Count |  | False |
Total: 11 measure(s)

Collapse image See also

About this documentation


Measure: Reseller Sales Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Order Quantity

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Extended Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Tax Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Freight Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Discount Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Unit Price

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Measure: Unit Price Discount Percent

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Percent
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Total Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Standard Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Reseller Transaction Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Reseller_Sales |  | 3621174 | 60855 | Molap | Processed | 7/18/2014 6:50:58 PM | 7/18/2014 6:44:14 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Reseller_Sales

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:14 PM
Estimated rows | 60855
Estimated size | 3621174
Is loaded | True
Last schema update | 7/18/2014 6:50:58 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Reseller Orders

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:14 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 1003925
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:38 PM
Last schema update | 7/18/2014 6:50:58 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Reseller | Reseller | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Employee | Employee | 7/28/2014 9:46:11 PM | 7/18/2014 6:50:55 PM
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Geography | Geography | 7/28/2014 9:46:20 PM | 7/18/2014 6:50:55 PM
Reseller Sales Order Details | Reseller Sales Order Details | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 11 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Reseller Order Count |  | True |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Reseller Order Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Reseller_Orders |  | 1003925 | 0 | Molap | Processed | 7/18/2014 6:50:58 PM | 7/18/2014 6:44:15 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Reseller_Orders

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:15 PM
Estimated rows | 0
Estimated size | 1003925
Is loaded | True
Last schema update | 7/18/2014 6:50:58 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Sales Summary

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:15 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 121253
Estimated size | 3242583
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:38 PM
Last schema update | 7/18/2014 6:50:58 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Sales

Collapse image Measure group object index

Objects | Total
Measures | 9
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Sales Summary Order Details | Sales Summary Order Details | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Sales Channel | Sales Channel | 7/28/2014 9:46:04 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 9 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Order Quantity |  | True |
Unit Price |  | False |
Extended Amount |  | True |
Standard Product Cost |  | True |
Total Product Cost |  | True |
Sales Amount |  | True |
Tax Amount |  | True |
Freight Cost |  | True |
Transaction Count |  | False |
Total: 9 measure(s)

Collapse image See also

About this documentation


Measure: Order Quantity

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Unit Price

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Measure: Extended Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Standard Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Total Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Sales Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Tax Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Freight Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Double
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Transaction Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Total_Orders |  | 3242583 | 121253 | Molap | Processed | 7/18/2014 6:50:59 PM | 7/18/2014 6:44:15 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Total_Orders

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:15 PM
Estimated rows | 121253
Estimated size | 3242583
Is loaded | True
Last schema update | 7/18/2014 6:50:59 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Sales Orders

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:15 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 2063566
Ignore unrelated dimensions | True
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:44 PM
Last schema update | 7/18/2014 6:50:59 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Sales Summary Order Details | Sales Summary Order Details | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Sales Channel | Sales Channel | 7/28/2014 9:46:04 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Total: 9 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Order Count |  | True |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Order Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Total_Orders |  | 2063566 | 0 | Molap | Processed | 7/18/2014 6:50:59 PM | 7/18/2014 6:44:15 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Total_Orders

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:15 PM
Estimated rows | 0
Estimated size | 2063566
Is loaded | True
Last schema update | 7/18/2014 6:50:59 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Measure group: Sales Targets

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:15 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 163
Estimated size | 697
Ignore unrelated dimensions | False
Is linked | False
Is loaded | True
Last processed | 7/28/2014 9:46:28 PM
Last schema update | 7/18/2014 6:50:59 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 1

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Employee | Employee | 7/28/2014 9:46:11 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Total: 3 dimension usage(s)

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Source | Visible | Description
Sales Amount Quota |  | True |
Total: 1 measure(s)

Collapse image See also

About this documentation


Measure: Sales Amount Quota

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | False
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Binding type | Estimated size | Estimated rows | Storage mode | State | Last processed | Last schema update
Sales_Quotas |  | 697 | 163 | Molap | Processed | 7/18/2014 6:51:00 PM | 7/18/2014 6:44:16 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Sales_Quotas

Collapse image Partition properties

Property | Value
Binding type |
Data source view | Adventure Works DW
Data source | Adventure Works DW
Date created | 7/18/2014 6:44:16 PM
Estimated rows | 163
Estimated size | 697
Is loaded | True
Last schema update | 7/18/2014 6:51:00 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Table source |
Type | Data

Collapse image See also

About this documentation


Perspectives

List of perspectives

Collapse image Perspectives

No perspectives exist

Collapse image See also

About this documentation


Cube: Mined Customers

Collapse image Cube properties

Property | Value
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:16 PM
Default measure | [Measures].[Internet Sales Amount]
Estimated rows | 0
Is loaded | True
Language | English (United States)
Last processed | 7/28/2014 9:46:59 PM
Last schema update | 7/18/2014 6:51:00 PM
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Visible | True

Collapse image Cube object index

Objects | Total
Actions | 1
Dimensions | 11
KPIs | 0
MDX Scripts | 1
Measure groups | 4
Perspectives | 0

Collapse image See also

About this documentation


Actions

List of actions

Collapse image Actions

Name | Type | Description
Internet Details | DrillThrough |
Total: 1 action(s)

Collapse image See also

About this documentation


Dimensions

List of dimensions

Collapse image Dimensions

Name | Attribute count | Hierarchy count | Visible | Database dimension
Date | 21 | 4 | True | Date
Ship Date | 21 | 4 | True | Date
Delivery Date | 21 | 4 | True | Date
Product | 21 | 3 | True | Product
Promotion | 8 | 1 | True | Promotion
Customer | 21 | 1 | True | Customer
Sales Reason | 2 | 1 | True | Sales Reason
Sales Territory | 3 | 1 | True | Sales Territory
Source Currency | 2 | 0 | True | Source Currency
Clustered Customers | 3 | 0 | True | Clustered Customers
Internet Sales Order Details | 3 | 1 | True | Internet Sales Order Details
Total: 11 dimension(s)

Collapse image See also

About this documentation


Dimension: Clustered Customers

Collapse image Dimensions properties

Property | Value
All member aggregation usage | Default
Dimension Id | Clustered Customers
Hierarchy unique name style | IncludeDimensionName
Member unique name style | Native
Visible | True

Collapse image Attributes

Name | Aggregation usage | Enabled | Visible | Optimized state | Description
Attribute Name | Default | True | False | NotOptimized |
Customer Clusters | Default | True | True | FullyOptimized |
Node Unique Name | Default | True | False | FullyOptimized |
Total: 3 attributes(s)

Collapse image Hierarchies

No hierarchies exist

Collapse image See also

About this documentation


KPIs

List of KPIs

Collapse image KPIs

No KPIs exist

Collapse image See also

About this documentation


MDX Scripts

List of MDX scripts

Collapse image MDX scripts

Name | Calculation properties
MdxScript | 9
Total: 1 MDX script(s)

Collapse image See also

About this documentation


MDX script: MdxScript

Collapse image MDX script properties

Property | Value
Parent cube | Mined Customers
Description |
Default script | True

Collapse image Calculations

Name | Type | Description
[Measures].[Internet Average Unit Price] | Member |
[Measures].[Internet Average Sales Amount] | Member |
[Measures].[Internet Ratio to All Products] | Member |
[Measures].[Internet Ratio to Parent Product] | Member |
[Measures].[Growth in Customer Base] | Member |
[Measures].[Internet Gross Profit] | Member |
[Measures].[Internet Gross Profit Margin] | Member |
Long Lead Products | Set |
Core Product Group | Set |
Total: 9 calculation(s)

Collapse image Script view

/*-- Aggregate leaf data -----------------------------------------------*/
Calculate ;

/*-----------------------------------------------------------------------------
 | Internet Sales Calculations |
-----------------------------------------------------------------------------*/

Create Member CurrentCube.[Measures].[Internet Gross Profit]

 As [Measures].[Internet Sales Amount] -
    [Measures].[Internet Total Product Cost],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior =
 {
   [Internet Sales Amount],
   [Internet Total Product Cost]
 } ;

Create Member CurrentCube.[Measures].[Internet Gross Profit Margin]

 As ( [Measures].[Internet Sales Amount] -
      [Measures].[Internet Total Product Cost] )
    /
      [Measures].[Internet Sales Amount],

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior =
 {
   [Internet Sales Amount],
   [Internet Total Product Cost]
 } ;

Create Member CurrentCube.[Measures].[Internet Average Unit Price]

 As [Measures].[Internet Unit Price] /
    [Measures].[Internet Transaction Count],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Unit Price] ;

Create Member CurrentCube.[Measures].[Internet Average Sales Amount]

 As [Measures].[Internet Sales Amount] /
    [Measures].[Internet Order Count],

Format_String = "Currency",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Sales Amount] ;

Create Member CurrentCube.[Measures].[Internet Ratio to All Products]

 As [Measures].[Internet Sales Amount]
    /
    (
      Root( [Product] ),
      [Measures].[Internet Sales Amount]
    ),

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales',
Non_Empty_Behavior = [Internet Sales Amount] ;

Create Member CurrentCube.[Measures].[Internet Ratio to Parent Product]

 As Case

        When [Product].[Product Categories].CurrentMember.Level.Ordinal
             = 0
        Then 1

        Else [Measures].[Internet Sales Amount]
             /
             ( [Product].[Product Categories].CurrentMember.Parent,
               [Measures].[Internet Sales Amount] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales' ;

Create Member CurrentCube.[Measures].[Growth in Customer Base]

 As Case

        When [Date].[Fiscal].CurrentMember.Level.Ordinal = 0
        Then "NA"

        When IsEmpty
             (
               (
                 [Date].[Fiscal].CurrentMember.PrevMember,
                 [Measures].[Customer Count]
               )
             )
        Then Null

        Else (
               ( [Date].[Fiscal].CurrentMember, [Measures].[Customer Count] )
               -
               ( [Date].[Fiscal].PrevMember, [Measures].[Customer Count] )
             )
             /
             ( [Date].[Fiscal].PrevMember,[Measures].[Customer Count] )

    End,

Format_String = "Percent",
Associated_Measure_Group = 'Internet Sales' ;

Create Set CurrentCube.[Long Lead Products]

 As Exists
    (
       [Product].[Model Name].[Model Name].Members,
       [Product].[Days to Manufacture].&[4]
    )
,
Display_Folder = 'Sets' ;

Create Set CurrentCube.[Core Product Group]

As  DrillDownMember
    (
      [Product].[Product Categories].[Category].Members,
      [Product].[Product Categories].[Category].[Bikes]
    )
,
Display_Folder = 'Sets' ;

Create Dynamic Set CurrentCube.[Top 25 Selling Products]

 As TopCount
    (
       [Product].[Product].[Product].Members,
       25,
       [Measures].[Sales Amount]
    )
,
Display_Folder = 'Sets' ;

Create Dynamic Set CurrentCube.[Top 50 Customers]

 As TopCount
    (
       [Customer].[Customer].[Customer].Members,
       50,
       [Measures].[Internet Sales Amount]
    )
,
Display_Folder = 'Sets' ;

Create Dynamic Set CurrentCube.[Negative Margin Products]

 As Filter
    (
       [Product].[Subcategory].[Subcategory],
       [Measures].[Gross Profit Margin] < 0
    )
,
Display_Folder = 'Sets' ;

Collapse image See also

About this documentation


Measure groups

List of measure groups

Collapse image Measure groups

Name | Type | Estimated size | Estimated rows | State | Last processed | Last schema update
Internet Sales | Regular | 0 | 0 | Processed | 7/28/2014 9:46:59 PM | 7/18/2014 6:51:00 PM
Internet Orders | Regular | 0 | 0 | Processed | 7/28/2014 9:46:59 PM | 7/18/2014 6:51:00 PM
Internet Customers | Regular | 0 | 0 | Processed | 7/28/2014 9:46:59 PM | 7/18/2014 6:51:01 PM
Sales Reasons | Regular | 0 | 0 | Processed | 7/28/2014 9:46:59 PM | 7/18/2014 6:51:01 PM
Total: 4 measure group(s)

Collapse image See also

About this documentation


Measure group: Internet Sales

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:16 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 0
Ignore unrelated dimensions | True
Is linked | True
Is loaded | True
Last processed | 7/28/2014 9:46:59 PM
Last schema update | 7/18/2014 6:51:00 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 9
Partitions | 0

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Clustered Customers | Clustered Customers | 7/28/2014 9:46:57 PM | 7/18/2014 6:50:54 PM
Total: 11 dimension usage(s)

Collapse image See also

About this documentation


Measure: Internet Sales Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Order Quantity

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Integer
Format string | #,#
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Extended Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Tax Amount

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Freight Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Unit Price

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Measure: Internet Total Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Standard Product Cost

Collapse image Measure properties

Property | Value
Aggregate function | Sum
Data type | Currency
Format string | Currency
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure: Internet Transaction Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #,#
Is linked | True
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

No partitions exist

Collapse image See also

About this documentation


Measure group: Internet Orders

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:16 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 0
Ignore unrelated dimensions | True
Is linked | True
Is loaded | True
Last processed | 7/28/2014 9:46:59 PM
Last schema update | 7/18/2014 6:51:00 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 0

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Clustered Customers | Clustered Customers | 7/28/2014 9:46:57 PM | 7/18/2014 6:50:54 PM
Total: 11 dimension usage(s)

Collapse image See also

About this documentation


Measure: Internet Order Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure group: Internet Customers

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:16 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 0
Ignore unrelated dimensions | True
Is linked | True
Is loaded | True
Last processed | 7/28/2014 9:46:59 PM
Last schema update | 7/18/2014 6:51:01 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 0

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Promotion | Promotion | 7/28/2014 9:46:16 PM | 7/18/2014 6:50:55 PM
Product | Product | 7/28/2014 9:46:12 PM | 7/18/2014 6:50:55 PM
Customer | Customer | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Sales Territory | Sales Territory | 7/28/2014 9:46:18 PM | 7/18/2014 6:50:55 PM
Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Ship Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Delivery Date | Date | 7/28/2014 9:46:08 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Source Currency | Source Currency | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Clustered Customers | Clustered Customers | 7/28/2014 9:46:57 PM | 7/18/2014 6:50:54 PM
Total: 11 dimension usage(s)

Collapse image See also

About this documentation


Measure: Customer Count

Collapse image Measure properties

Property | Value
Aggregate function | DistinctCount
Data type | Integer
Format string | #,#
Is linked | True
Source |
Visible | True
Display folder |

Collapse image See also

About this documentation


Measure group: Sales Reasons

Collapse image Measure group properties

Property | Value
Date created | 7/18/2014 6:44:17 PM
Data aggregation | DataAndCacheAggregatable
Estimated rows | 0
Estimated size | 0
Ignore unrelated dimensions | True
Is linked | True
Is loaded | True
Last processed | 7/28/2014 9:46:59 PM
Last schema update | 7/18/2014 6:51:01 PM
Proactive caching enabled | False
Processing mode | Regular
Processing priority | 0
Storage mode | Molap
Storage location |
Type | Regular

Collapse image Measure group object index

Objects | Total
Measures | 1
Partitions | 0

Collapse image Dimension usage

Dimension name | Granularity attribute | Last processed | Schema update
Sales Reason | Sales Reason | 7/28/2014 9:46:05 PM | 7/18/2014 6:50:55 PM
Internet Sales Order Details | Internet Sales Order Details | 7/28/2014 9:46:19 PM | 7/18/2014 6:50:55 PM
Total: 2 dimension usage(s)

Collapse image See also

About this documentation


Measure: Sales Reason Count

Collapse image Measure properties

Property | Value
Aggregate function | Count
Data type | Integer
Format string | #
Is linked | True
Source |
Visible | False
Display folder |

Collapse image See also

About this documentation


Dimensions

List of dimensions

Collapse image Dimensions

Name | Data source view | Attribute count | Hierarchy count | Type | Description
Clustered Customers | Clustered Customers | 3 | 0 | Regular |
Customer | Adventure Works DW | 21 | 1 | Customers |
Date | Adventure Works DW | 21 | 4 | Time |
Employee | Adventure Works DW | 26 | 1 | Regular |
Geography | Adventure Works DW | 5 | 1 | Geography |
Internet Sales Order Details | Adventure Works DW | 3 | 1 | Regular |
Product | Adventure Works DW | 21 | 3 | Products |
Promotion | Adventure Works DW | 8 | 1 | Promotion |
Reseller Sales Order Details | Adventure Works DW | 5 | 1 | Regular |
Reseller | Adventure Works DW | 17 | 4 | Channel |
Sales Channel | Adventure Works DW | 1 | 0 | Regular |
Sales Reason | Adventure Works DW | 2 | 1 | Regular |
Sales Summary Order Details | Adventure Works DW | 5 | 1 | Regular |
Sales Territory | Adventure Works DW | 3 | 1 | Regular |
Source Currency | Adventure Works DW | 2 | 0 | Currency |
Total: 15 dimension(s)

Collapse image See also

About this documentation


Dimension: Clustered Customers

Collapse image Dimension properties

Property | Value
Attribute all member name | All Customer Clusters
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:11 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:57 PM
Last schema update | 7/18/2014 6:50:54 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 3
Hierarchies | 0

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Attribute Name | Regular | Regular | True |
Customer Clusters | Parent | Regular | True |
Node Unique Name | Key | Regular | True |
Total: 3 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Attribute Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | NotOptimized
Attribute hierarchy ordered | False
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 0
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[DIMENSION_CONTENT_ROWSET].[ATTRIBUTE_NAME] | 255 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Customer Clusters

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 0
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataHidden
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Parent

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[DIMENSION_CONTENT_ROWSET].[PARENT_UNIQUE_NAME] | 255 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Node Unique Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 0
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[DIMENSION_CONTENT_ROWSET].[NODE_UNIQUE_NAME] | 255 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Customer Clusters | Many | Mandatory | Strong | Flexible | True
Attribute Name | Many | Mandatory | Strong | Rigid | True
Total: 2 attribute relationship(s)

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

No hierarchies exist

Collapse image See also

About this documentation


Dimension: Customer

Collapse image Dimension properties

Property | Value
Attribute all member name | All Customers
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:11 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:08 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Customers
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 21
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Customer | Key | Customers | True |
Postal Code | Regular | Regular | True |
Country | Regular | Regular | True |
State-Province | Regular | Regular | True |
Birth Date | Regular | Regular | True |
City | Regular | Regular | True |
Date of First Purchase | Regular | Regular | True |
Phone | Regular | PersonContact | True |
Email Address | Regular | PersonContact | True |
Yearly Income | Regular | Regular | True |
Total Children | Regular | Regular | True |
Number of Cars Owned | Regular | Regular | True |
Number of Children At Home | Regular | Regular | True |
Education | Regular | Regular | True |
Occupation | Regular | Regular | True |
Marital Status | Regular | Regular | True |
Gender | Regular | Regular | True |
Home Owner | Regular | Regular | True |
Commute Distance | Regular | Regular | True |
Commute Distance Sort | Regular | Regular | True |
Address | Regular | Address | True |
Total: 21 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Customer

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 18484
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Customers
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[CustomerKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Date of First Purchase | Many | Mandatory | Strong | Flexible | True
Phone | Many | Mandatory | Strong | Flexible | True
Number of Cars Owned | Many | Mandatory | Strong | Flexible | True
Occupation | Many | Mandatory | Strong | Flexible | True
Education | Many | Mandatory | Strong | Flexible | True
Number of Children At Home | Many | Mandatory | Strong | Flexible | True
Total Children | Many | Mandatory | Strong | Flexible | True
Yearly Income | Many | Mandatory | Strong | Flexible | True
Email Address | One | Mandatory | Strong | Flexible | True
Birth Date | Many | Mandatory | Strong | Rigid | True
Marital Status | Many | Mandatory | Strong | Flexible | True
Gender | Many | Mandatory | Strong | Rigid | True
Home Owner | Many | Mandatory | Strong | Flexible | True
Commute Distance | Many | Mandatory | Strong | Flexible | True
Postal Code | Many | Mandatory | Strong | Flexible | True
Address | One | Mandatory | Strong | Flexible | True
Total: 16 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Postal Code

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Location
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 646
Grouping behavior | EncourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[PostalCode] | 15 | WChar |  | Automatic | Right
[dbo_DimGeography].[City] | 0 | WChar |  | Automatic | Right
[dbo_DimGeography].[StateProvinceCode] | 3 | WChar |  | Automatic | Right
Total: 3 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
City | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Country

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Location
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[EnglishCountryRegionName] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: State-Province

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Location
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 71
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[StateProvinceCode] | 50 | WChar |  | Automatic | Right
[dbo_DimGeography].[CountryRegionCode] | 0 | WChar |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Country | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Birth Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 8252
Grouping behavior | EncourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[BirthDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: City

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Location
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 587
Grouping behavior | EncourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[City] | 30 | WChar |  | Automatic | Right
[dbo_DimGeography].[StateProvinceCode] | 0 | WChar |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
State-Province | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Date of First Purchase

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 1124
Grouping behavior | EncourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[DateFirstPurchase] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Phone

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 8890
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | PersonContact
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[Phone] | 20 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Email Address

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 18484
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | PersonContact
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[EmailAddress] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Yearly Income

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 5
Discretization method | Automatic
Estimated count | 16
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[YearlyIncome] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Total Children

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[TotalChildren] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Number of Cars Owned

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[NumberCarsOwned] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Number of Children At Home

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[NumberChildrenAtHome] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Education

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[EnglishEducation] | 40 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Occupation

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[EnglishOccupation] | 100 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Marital Status

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[MaritalStatus] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Gender

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[Gender] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Home Owner

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[HouseOwnerFlag] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Commute Distance

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | AttributeKey
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[CommuteDistance] | 15 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Commute Distance Sort | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Commute Distance Sort

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[CommuteDistanceSort] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Address

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 12797
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Address
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCustomer].[AddressLine1] | 120 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Customer Geography | 5 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Customer Geography

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Country | Never |
State-Province | NoName |
City | Never |
Postal Code | Never |
Customer | Never |
Total: 5 level(s)

Collapse image See also

About this documentation


Dimension: Date

Collapse image Dimension properties

Property | Value
Attribute all member name | All Periods
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:11 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:08 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Time
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 21
Hierarchies | 4

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Fiscal Year | Regular | FiscalYears | True |
Date | Key | Date | True |
Calendar Quarter | Regular | Quarters | True |
Fiscal Quarter | Regular | FiscalQuarters | True |
Calendar Semester | Regular | HalfYears | True |
Fiscal Semester | Regular | FiscalHalfYears | True |
Day of Week | Regular | DayOfWeek | True |
Day Name | Regular | Days | True |
Day of Month | Regular | DayOfMonth | True |
Day of Year | Regular | DayOfYear | True |
Calendar Week | Regular | Weeks | True |
Month Name | Regular | Months | True |
Calendar Year | Regular | Years | True |
Fiscal Semester of Year | Regular | FiscalHalfYearOfYear | True |
Calendar Semester of Year | Regular | HalfYearOfYear | True |
Fiscal Quarter of Year | Regular | FiscalQuarterOfYear | True |
Calendar Quarter of Year | Regular | QuarterOfYear | True |
Month of Year | Regular | Regular | True |
Fiscal Week | Regular | FiscalWeeks | True |
Calendar Week of Year | Regular | WeekOfYear | True |
Fiscal Week of Year | Regular | FiscalWeekOfYear | True |
Total: 21 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Fiscal Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalYears
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalYear] | 0 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 1158
Grouping behavior | DiscourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Date
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[DateKey] | 0 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Day of Week | Many | Mandatory | Strong | Rigid | True
Day Name | Many | Mandatory | Strong | Rigid | True
Day of Month | Many | Mandatory | Strong | Rigid | True
Day of Year | Many | Mandatory | Strong | Rigid | True
Calendar Week | Many | Mandatory | Strong | Rigid | True
Month Name | Many | Mandatory | Strong | Rigid | True
Fiscal Week | Many | Mandatory | Strong | Rigid | True
Total: 7 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Calendar Quarter

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 13
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Quarters
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarYear] | 0 | SmallInt |  | Automatic | Right
[dbo_DimTime].[CalendarQuarter] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Fiscal Quarter | Many | Mandatory | Strong | Rigid | True
Calendar Semester | Many | Mandatory | Strong | Rigid | True
Calendar Semester of Year | Many | Mandatory | Strong | Rigid | True
Calendar Quarter of Year | Many | Mandatory | Strong | Rigid | True
Total: 4 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Fiscal Quarter

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 13
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalQuarters
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalYear] | 0 | SmallInt |  | Automatic | Right
[dbo_DimTime].[FiscalQuarter] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Fiscal Semester | Many | Mandatory | Strong | Rigid | True
Fiscal Semester of Year | Many | Mandatory | Strong | Rigid | True
Fiscal Quarter of Year | Many | Mandatory | Strong | Rigid | True
Total: 3 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Calendar Semester

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | HalfYears
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarYear] | 0 | SmallInt |  | Automatic | Right
[dbo_DimTime].[CalendarSemester] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Calendar Year | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Fiscal Semester

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalHalfYears
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalYear] | 0 | SmallInt |  | Automatic | Right
[dbo_DimTime].[FiscalSemester] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Fiscal Year | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Day of Week

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | DayOfWeek
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[DayNumberOfWeek] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Day Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Days
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[DayNumberOfWeek] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Day of Month

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 31
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | DayOfMonth
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[DayNumberOfMonth] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Day of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 365
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | DayOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[DayNumberOfYear] | 0 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Calendar Week

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 169
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Weeks
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[WeekNumberOfYear] | 0 | UnsignedTinyInt |  | Automatic | Right
[dbo_DimTime].[CalendarYear] | 0 | SmallInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Calendar Year | Many | Mandatory | Strong | Rigid | True
Calendar Week of Year | Many | Mandatory | Strong | Rigid | True
Total: 2 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Month Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 38
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Months
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarYear] | 0 | SmallInt |  | Automatic | Right
[dbo_DimTime].[MonthNumberOfYear] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Calendar Quarter | Many | Mandatory | Strong | Rigid | True
Month of Year | Many | Mandatory | Strong | Rigid | True
Total: 2 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Calendar Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Years
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarYear] | 0 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Fiscal Semester of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalHalfYearOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalSemesterOfYear] | 5 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Calendar Semester of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | HalfYearOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarSemesterOfYear] | 5 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Fiscal Quarter of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalQuarterOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalQuarterOfYear] | 5 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Calendar Quarter of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | QuarterOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[CalendarQuarterOfYear] | 5 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Month of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 12
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[MonthNumberOfYear] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Fiscal Week

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 169
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalWeeks
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalWeekNumberOfYear] | 0 | Integer |  | Automatic | Right
[dbo_DimTime].[FiscalYear] | 0 | SmallInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Fiscal Year | Many | Mandatory | Strong | Rigid | True
Fiscal Week of Year | Many | Mandatory | Strong | Rigid | True
Total: 2 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Calendar Week of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Calendar
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 53
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | WeekOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[WeekNumberOfYear] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Fiscal Week of Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Fiscal
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 53
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | FiscalWeekOfYear
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimTime].[FiscalWeekNumberOfYear] | 0 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Fiscal | 5 | Unprocessed | Unknown
Calendar | 5 | Unprocessed | Unknown
Calendar Weeks | 2 | Unprocessed | Unknown
Fiscal Weeks | 2 | Unprocessed | Unknown
Total: 4 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Fiscal

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Fiscal Year | Never |
Fiscal Semester | Never |
Fiscal Quarter | Never |
Month Name | Never |
Date | Never |
Total: 5 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Calendar

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Calendar Year | Never |
Calendar Semester | Never |
Calendar Quarter | Never |
Month Name | Never |
Date | Never |
Total: 5 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Calendar Weeks

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Calendar Year | Never |
Calendar Week | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Fiscal Weeks

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Fiscal Year | Never |
Fiscal Week | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Employee

Collapse image Dimension properties

Property | Value
Attribute all member name | All Employees
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:11 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 26
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Employee | Key | Regular | True |
Department Name | Regular | Regular | True |
Sales Person Flag | Regular | Regular | True |
Title | Regular | Regular | True |
Hire Date | Regular | Regular | True |
Sick Leave Hours | Regular | Regular | True |
Birth Date | Regular | Regular | True |
Vacation Hours | Regular | Regular | True |
Login ID | Regular | Regular | True |
Base Rate | Regular | Regular | True |
Email Address | Regular | PersonContact | True |
Pay Frequency | Regular | Regular | True |
Phone | Regular | PersonContact | True |
Salaried Flag | Regular | Regular | True |
Emergency Contact Name | Regular | Regular | True |
Emergency Contact Phone | Regular | Regular | True |
Gender | Regular | Regular | True |
Marital Status | Regular | Regular | True |
Sales Territory Key | Regular | Regular | True |
SSN | Regular | Regular | True |
Manager SSN | Regular | Regular | True |
Employees | Parent | Person | True |
Status | Regular | ScdStatus | True |
Start Date | Regular | ScdStartDate | True |
End Date | Regular | ScdEndDate | True |
Hire Year | Regular | Regular | True |
Total: 26 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Employee

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 291
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmployeeKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Sales Person Flag | Many | Mandatory | Strong | Flexible | True
Sick Leave Hours | Many | Mandatory | Strong | Flexible | True
Vacation Hours | Many | Mandatory | Strong | Flexible | True
Base Rate | Many | Mandatory | Strong | Flexible | True
Pay Frequency | Many | Mandatory | Strong | Flexible | True
Salaried Flag | Many | Mandatory | Strong | Flexible | True
Emergency Contact Phone | One | Mandatory | Strong | Flexible | True
Emergency Contact Name | One | Mandatory | Strong | Flexible | True
Phone | One | Mandatory | Strong | Flexible | True
Email Address | One | Mandatory | Strong | Flexible | True
Login ID | One | Mandatory | Strong | Flexible | True
Birth Date | Many | Mandatory | Strong | Rigid | True
Hire Date | Many | Mandatory | Strong | Rigid | True
Title | Many | Mandatory | Strong | Flexible | True
Gender | Many | Mandatory | Strong | Flexible | True
Marital Status | Many | Mandatory | Strong | Flexible | True
Sales Territory Key | Many | Mandatory | Strong | Flexible | False
SSN | One | Mandatory | Strong | Flexible | True
Manager SSN | Many | Mandatory | Strong | Flexible | True
Employees | Many | Mandatory | Strong | Flexible | True
Status | Many | Mandatory | Strong | Flexible | True
Start Date | Many | Mandatory | Strong | Rigid | True
End Date | Many | Mandatory | Strong | Flexible | True
Hire Year | Many | Mandatory | Strong | Rigid | True
Total: 24 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Department Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 16
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[DepartmentName] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Person Flag

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[SalesPersonFlag] | -1 | Boolean |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Title

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 67
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[Title] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Department Name | Many | Mandatory | Strong | Flexible | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Hire Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 164
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[HireDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sick Leave Hours

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 4
Discretization method | Automatic
Estimated count | 51
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[SickLeaveHours] | -1 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Birth Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 279
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[BirthDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Vacation Hours

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 4
Discretization method | Automatic
Estimated count | 100
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[VacationHours] | -1 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Login ID

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 290
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[LoginID] | 256 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Base Rate

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | Automatic
Estimated count | 53
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[BaseRate] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Email Address

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 290
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | PersonContact
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmailAddress] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Pay Frequency

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[PayFrequency] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Phone

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Contacts
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 288
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | PersonContact
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[Phone] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Salaried Flag

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[SalariedFlag] | -1 | Boolean |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Emergency Contact Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 290
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmergencyContactName] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Emergency Contact Phone

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 288
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmergencyContactPhone] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Gender

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[Gender] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Marital Status

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Demographic
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[MaritalStatusDesc] | 7 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Territory Key

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | False
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 11
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[SalesTerritoryKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: SSN

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 290
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmployeeNationalIDAlternateKey] | 15 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Manager SSN

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 290
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[ParentEmployeeNationalIDAlternateKey] | 15 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Employees

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 47
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataHidden
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Person
Usage | Parent

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[ParentEmployeeKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Status

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Organization
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdStatus
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EmployeeStatus] | 16 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Start Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 170
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdStartDate
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[StartDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: End Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdEndDate
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[EndDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Hire Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 8
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimEmployee].[HireYear] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Employee Department | 3 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Employee Department

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Department Name | Never |
Title | Never |
Employee | Never |
Total: 3 level(s)

Collapse image See also

About this documentation


Dimension: Geography

Collapse image Dimension properties

Property | Value
Attribute all member name | All Geographies
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:20 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Geography
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 5
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
City | Regular | City | True |
State-Province | Regular | StateOrProvince | True |
Country | Regular | Country | True |
Postal Code | Regular | PostalCode | True |
Geography Key | Key | Regular | True |
Total: 5 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: City

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 587
Grouping behavior | EncourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | City
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[City] | -1 | WChar |  | Automatic | Right
[dbo_DimGeography].[StateProvinceCode] | 0 | WChar |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
State-Province | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: State-Province

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 71
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | StateOrProvince
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[StateProvinceCode] | 0 | WChar |  | Automatic | Right
[dbo_DimGeography].[CountryRegionCode] | 0 | WChar |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Country | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Country

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Country
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[EnglishCountryRegionName] | 0 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Postal Code

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 646
Grouping behavior | DiscourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | PostalCode
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[PostalCode] | 0 | WChar |  | Automatic | Right
[dbo_DimGeography].[City] | 0 | WChar |  | Automatic | Right
[dbo_DimGeography].[StateProvinceCode] | 3 | WChar |  | Automatic | Right
Total: 3 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
City | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Geography Key

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | False
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 655
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimGeography].[GeographyKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Postal Code | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Geography | 4 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Geography

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Country | Never |
State-Province | NoName |
City | Never |
Postal Code | Never |
Total: 4 level(s)

Collapse image See also

About this documentation


Dimension: Internet Sales Order Details

Collapse image Dimension properties

Property | Value
Attribute all member name | All Internet Sales Orders
Collation | Latin1_General_CI_AS
Current storage mode | Rolap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:19 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Rolap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 3
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Internet Sales Order | Key | Regular | True |
Sales Order Number | Regular | Regular | True |
Sales Order Line | Regular | Regular | True |
Total: 3 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Internet Sales Order

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 60398
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactInternetSales].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
[dbo_FactInternetSales].[SalesOrderLineNumber] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Sales Order Number | Many | Mandatory | Strong | Rigid | True
Sales Order Line | Many | Mandatory | Strong | Rigid | True
Total: 2 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Order Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 27659
Grouping behavior | EncourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactInternetSales].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Order Line

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 8
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactInternetSales].[SalesOrderLineNumber] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Internet Sales Orders | 2 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Internet Sales Orders

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Sales Order Number | Never |
Internet Sales Order | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Product

Collapse image Dimension properties

Property | Value
Attribute all member name | All Products
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:12 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Products
Unknown member | Hidden
Unknown member name | Unknown Products
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 21
Hierarchies | 3

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Product | Key | Product | True |
Standard Cost | Regular | Regular | True |
Category | Regular | ProductCategory | True |
Color | Regular | Regular | True |
Safety Stock Level | Regular | Regular | True |
Reorder Point | Regular | Regular | True |
List Price | Regular | Regular | True |
Size | Regular | Regular | True |
Size Range | Regular | Regular | True |
Weight | Regular | Regular | True |
Days to Manufacture | Regular | Regular | True |
Dealer Price | Regular | Regular | True |
Class | Regular | Regular | True |
Style | Regular | Regular | True |
Model Name | Regular | Regular | True |
Product Line | Regular | Regular | True |
Subcategory | Regular | Regular | True |
Status | Regular | ScdStatus | True |
Start Date | Regular | ScdStartDate | True |
End Date | Regular | ScdEndDate | True |
Large Photo | Regular | Regular | True |
Total: 21 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Product

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 395
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Product
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ProductKey] | 0 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Model Name | Many | Mandatory | Strong | Flexible | True
Style | Many | Mandatory | Strong | Flexible | True
Class | Many | Mandatory | Strong | Flexible | True
Dealer Price | Many | Mandatory | Strong | Flexible | True
Days to Manufacture | Many | Mandatory | Strong | Flexible | True
Weight | Many | Mandatory | Strong | Flexible | True
Size Range | Many | Mandatory | Strong | Flexible | True
Size | Many | Mandatory | Strong | Flexible | True
List Price | Many | Mandatory | Strong | Flexible | True
Reorder Point | Many | Mandatory | Strong | Flexible | True
Safety Stock Level | Many | Mandatory | Strong | Flexible | True
Color | Many | Mandatory | Strong | Flexible | True
Standard Cost | Many | Mandatory | Strong | Flexible | True
Status | Many | Mandatory | Strong | Flexible | True
Start Date | Many | Mandatory | Strong | Flexible | True
End Date | Many | Mandatory | Strong | Flexible | True
Large Photo | Many | Mandatory | Strong | Flexible | True
Subcategory | Many | Mandatory | Strong | Rigid | True
Total: 18 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Standard Cost

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Financial
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 134
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[StandardCost] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Category

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ProductCategory
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProductCategory].[ProductCategoryKey] | 50 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Color

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 10
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Color] | 15 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Safety Stock Level

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[SafetyStockLevel] | -1 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Reorder Point

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ReorderPoint] | -1 | SmallInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: List Price

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Financial
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 120
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ListPrice] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Size

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 18
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Size] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Size Range

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 11
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[SizeRange] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Weight

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 127
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Weight] | 0 | Double |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Days to Manufacture

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[DaysToManufacture] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Dealer Price

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Financial
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 120
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[DealerPrice] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Class

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Stocking
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Class] | 2 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Style

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Style] | 2 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Model Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 119
Grouping behavior | EncourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ModelNameAssembly] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Product Line | Many | Mandatory | Strong | Flexible | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Product Line

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ProductLine] | 0 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Subcategory

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 37
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProductSubcategory].[ProductSubcategoryKey] | 0 | Integer |  | UnknownMember | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Category | Many | Mandatory | Strong | Flexible | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Status

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 1
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdStatus
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[Status] | 7 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Start Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdStartDate
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[StartDate] | 0 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: End Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | History
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | ScdEndDate
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[EndDate] | 0 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Large Photo

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 606
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimProduct].[ProductKey] | 0 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Product Categories | 3 | Unprocessed | Unknown
Product Model Lines | 2 | Unprocessed | Unknown
Stock Level | 2 | Unprocessed | Unknown
Total: 3 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Product Categories

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Category | Never |
Subcategory | Never |
Product | Never |
Total: 3 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Product Model Lines

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Product Line | Never |
Model Name | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Stock Level

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Safety Stock Level | Never |
Product | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Promotion

Collapse image Dimension properties

Property | Value
Attribute all member name | All Promotions
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:16 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Promotion
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 8
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Promotion | Key | Promotion | True |
Discount Percent | Regular | Regular | True |
Max Quantity | Regular | QtyRangeHigh | True |
Promotion Type | Regular | Regular | True |
Min Quantity | Regular | QtyRangeLow | True |
Promotion Category | Regular | Regular | True |
End Date | Regular | DateEnded | True |
Start Date | Regular | DateStart | True |
Total: 8 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Promotion

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 16
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | AttributeKey
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Promotion
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[PromotionKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Min Quantity | Many | Mandatory | Strong | Flexible | True
End Date | Many | Mandatory | Strong | Flexible | True
Start Date | Many | Mandatory | Strong | Flexible | True
Promotion Type | Many | Mandatory | Strong | Flexible | True
Discount Percent | Many | Mandatory | Strong | Flexible | True
Promotion Category | Many | Mandatory | Strong | Flexible | True
Max Quantity | Many | Mandatory | Strong | Flexible | True
Total: 7 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Discount Percent

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 10
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[DiscountPct] | -1 | Double |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Max Quantity

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | None
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | QtyRangeHigh
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[MaxQty] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Promotion Type

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[EnglishPromotionType] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Min Quantity

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 6
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | QtyRangeLow
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[MinQty] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Promotion Category

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[EnglishPromotionCategory] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: End Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 10
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | DateEnded
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[EndDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Start Date

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 8
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | DateStart
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimPromotion].[StartDate] | -1 | Date |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Promotions | 3 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Promotions

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Promotion Category | Never |
Promotion Type | OnlyChildWithParentName |
Promotion | OnlyChildWithParentName |
Total: 3 level(s)

Collapse image See also

About this documentation


Dimension: Reseller Sales Order Details

Collapse image Dimension properties

Property | Value
Attribute all member name | All Reseller Sales Orders
Collation | Latin1_General_CI_AS
Current storage mode | Rolap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:08 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Rolap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 5
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Reseller Sales Order | Key | Regular | True |
Carrier Tracking Number | Regular | Regular | True |
Customer PO Number | Regular | Regular | True |
Sales Order Number | Regular | Regular | True |
Sales Order Line | Regular | Regular | True |
Total: 5 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Reseller Sales Order

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 60855
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactResellerSales].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
[dbo_FactResellerSales].[SalesOrderLineNumber] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Carrier Tracking Number | Many | Mandatory | Strong | Rigid | True
Customer PO Number | Many | Mandatory | Strong | Rigid | True
Sales Order Number | Many | Mandatory | Strong | Rigid | True
Sales Order Line | Many | Mandatory | Strong | Rigid | True
Total: 4 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Carrier Tracking Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3796
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactResellerSales].[CarrierTrackingNumber] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Customer PO Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3796
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactResellerSales].[CustomerPONumber] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Order Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3796
Grouping behavior | EncourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactResellerSales].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Order Line

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 72
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_FactResellerSales].[SalesOrderLineNumber] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Reseller Sales Orders | 2 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Reseller Sales Orders

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Sales Order Number | Never |
Reseller Sales Order | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Reseller

Collapse image Dimension properties

Property | Value
Attribute all member name | All Resellers
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:08 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Channel
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 17
Hierarchies | 4

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Reseller | Key | Channel | True |
Product Line | Regular | Regular | True |
Phone | Regular | Regular | True |
Last Order Year | Regular | Regular | True |
Business Type | Regular | Regular | True |
First Order Year | Regular | Regular | True |
Number of Employees | Regular | Regular | True |
Year Opened | Regular | Regular | True |
Annual Sales | Regular | Regular | True |
Annual Revenue | Regular | Regular | True |
Bank Name | Regular | Regular | True |
Min Payment Amount | Regular | Regular | True |
Min Payment Type | Regular | Regular | True |
Order Frequency | Regular | Regular | True |
Order Month | Regular | Regular | True |
Geography Key | Regular | Regular | True |
Address | Regular | Address | True |
Total: 17 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Reseller

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 701
Grouping behavior | DiscourageGrouping
Instance selection | List
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Channel
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[ResellerKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Product Line | Many | Mandatory | Strong | Flexible | True
Last Order Year | Many | Mandatory | Strong | Flexible | True
First Order Year | Many | Mandatory | Strong | Flexible | True
Year Opened | Many | Mandatory | Strong | Rigid | True
Annual Revenue | Many | Mandatory | Strong | Flexible | True
Min Payment Amount | Many | Mandatory | Strong | Flexible | True
Min Payment Type | Many | Mandatory | Strong | Flexible | True
Bank Name | Many | Mandatory | Strong | Flexible | True
Annual Sales | Many | Mandatory | Strong | Flexible | True
Number of Employees | Many | Mandatory | Strong | Flexible | True
Business Type | Many | Mandatory | Strong | Rigid | True
Phone | One | Mandatory | Strong | Flexible | True
Order Frequency | Many | Mandatory | Strong | Flexible | True
Order Month | Many | Mandatory | Strong | Flexible | True
Geography Key | Many | Mandatory | Strong | Flexible | False
Address | One | Mandatory | Strong | Flexible | True
Total: 16 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Product Line

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[ProductLine] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Phone

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 610
Grouping behavior | DiscourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[Phone] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Last Order Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[LastOrderYear] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Business Type

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[BusinessType] | 20 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: First Order Year

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[FirstOrderYear] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Number of Employees

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 4
Discretization method | Automatic
Estimated count | 76
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[NumberEmployees] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Year Opened

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 32
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[YearOpened] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Annual Sales

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Sales Data
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[AnnualSales] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Annual Revenue

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Sales Data
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 5
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[AnnualRevenue] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Bank Name

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Order Data
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[BankName] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Min Payment Amount

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[MinPaymentAmount] | -1 | Currency |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Min Payment Type

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[MinPaymentType] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Order Frequency

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Order Data
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[OrderFrequency] | 1 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Order Month

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder | Order Data
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 12
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[OrderMonth] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Geography Key

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | False
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 510
Grouping behavior | DiscourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[GeographyKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Address

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | False
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 687
Grouping behavior | DiscourageGrouping
Instance selection | FilteredList
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Address
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimReseller].[AddressLine1] | 60 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Reseller Type | 2 | Unprocessed | Unknown
Reseller Bank | 2 | Unprocessed | Unknown
Reseller Order Frequency | 2 | Unprocessed | Unknown
Reseller Order Month | 2 | Unprocessed | Unknown
Total: 4 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Reseller Type

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Business Type | Never |
Reseller | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Reseller Bank

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Bank Name | Never |
Reseller | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Reseller Order Frequency

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Order Frequency | Never |
Reseller | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension hierarchy: Reseller Order Month

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Order Month | Never |
Reseller | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Sales Channel

Collapse image Dimension properties

Property | Value
Attribute all member name | All Sales Channels
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:04 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 1
Hierarchies | 0

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Sales Channel | Key | Regular | True |
Total: 1 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Channel

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 2
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[SalesChannel] | 8 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension: Sales Reason

Collapse image Dimension properties

Property | Value
Attribute all member name | All Sales Reasons
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:05 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 2
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Sales Reason | Key | Regular | True |
Sales Reason Type | Regular | Regular | True |
Total: 2 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Reason

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 10
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimSalesReason].[SalesReasonKey] | 0 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Sales Reason Type | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Reason Type

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimSalesReason].[SalesReasonReasonType] | 0 | WChar |  | Error | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Sales Reasons | 2 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Sales Reasons

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Sales Reason Type | Never |
Sales Reason | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Sales Summary Order Details

Collapse image Dimension properties

Property | Value
Attribute all member name | All Sales Order Details
Collation | Latin1_General_CI_AS
Current storage mode | Rolap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:08 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Rolap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 5
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Sales Order | Key | Regular | True |
Carrier Tracking Number | Regular | Regular | True |
Customer PO Number | Regular | Regular | True |
Sales Order Number | Regular | Regular | True |
Sales Order Line | Regular | Regular | True |
Total: 5 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Order

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | False
Discretization bucket count | 0
Discretization method | None
Estimated count | 121253
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
[FactSalesSummary].[SalesOrderLineNumber] | 0 | UnsignedTinyInt |  | Automatic | Right
Total: 2 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Carrier Tracking Number | Many | Mandatory | Strong | Rigid | True
Customer PO Number | Many | Mandatory | Strong | Rigid | True
Sales Order Number | Many | Mandatory | Strong | Rigid | True
Sales Order Line | Many | Mandatory | Strong | Rigid | True
Total: 4 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Carrier Tracking Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3796
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[CarrierTrackingNumber] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Customer PO Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 3796
Grouping behavior | DiscourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[CustomerPONumber] | 25 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Order Number

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 31455
Grouping behavior | EncourageGrouping
Instance selection | MandatoryFilter
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[SalesOrderNumber] | 20 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Dimension attribute: Sales Order Line

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 72
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Key
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[FactSalesSummary].[SalesOrderLineNumber] | -1 | UnsignedTinyInt |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Sales Orders | 2 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Sales Orders

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Sales Order Number | Never |
Sales Order | Never |
Total: 2 level(s)

Collapse image See also

About this documentation


Dimension: Sales Territory

Collapse image Dimension properties

Property | Value
Attribute all member name | All Sales Territories
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:18 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Regular
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 3
Hierarchies | 1

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Sales Territory Region | Key | Regular | True |
Sales Territory Country | Regular | Regular | True |
Sales Territory Group | Regular | Regular | True |
Total: 3 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Territory Region

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 11
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimSalesTerritory].[SalesTerritoryKey] | -1 | Integer |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Sales Territory Country | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Territory Country

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 7
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimSalesTerritory].[SalesTerritoryCountry] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Sales Territory Group | Many | Mandatory | Strong | Flexible | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Sales Territory Group

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 4
Grouping behavior | EncourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | Regular
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimSalesTerritory].[SalesTerritoryGroup] | 50 | WChar |  | Automatic | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Sales Territory | 3 | Unprocessed | Unknown
Total: 1 hierarchy(ies)

Collapse image See also

About this documentation


Dimension hierarchy: Sales Territory

Collapse image Hierarchy properties

Name | Value
Allow duplicate names | True
Member keys unique | NotUnique
Processing state | Unprocessed
Structure type | Unknown

Collapse image Levels

Name | Hide member if | Trimming
Sales Territory Group | Never |
Sales Territory Country | OnlyChildWithParentName |
Sales Territory Region | OnlyChildWithParentName |
Total: 3 level(s)

Collapse image See also

About this documentation


Dimension: Source Currency

Collapse image Dimension properties

Property | Value
Attribute all member name | All Source Currencies
Collation | Latin1_General_CI_AS
Current storage mode | Molap
Current string stores compatibility level | 1050
Date created | 7/18/2014 6:44:12 PM
Is linked | False
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:05 PM
Last schema update | 7/18/2014 6:50:55 PM
Mdx missing member mode | Default
Processing group | ByAttribute
Processing mode | Regular
Processing priority | 0
Processing recommendation | None
Processing state | Unprocessed
Storage mode | Molap
String stores compatibility level | 1050
Type | Currency
Unknown member | None
Unknown member name | Unknown
Write enabled | False

Collapse image Dimension object index

Objects | Total
Attributes | 2
Hierarchies | 0

Collapse image See also

About this documentation


Attributes

List of attributes

Collapse image Attributes

Name | Usage | Type | Is aggregatable | Description
Source Currency Code | Key | CurrencyIsoCode | True |
Source Currency | Regular | CurrencySource | True |
Total: 2 attribute(s)

Collapse image See also

About this documentation


Dimension attribute: Source Currency Code

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 105
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | CurrencyIsoCode
Usage | Key

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCurrency].[CurrencyKey] | 0 | Integer |  | Error | Right
Total: 1 key column(s)

Collapse image Attribute relationships

Name | Data size | Data type | Format | Null processing | Trimming
Source Currency | Many | Mandatory | Strong | Rigid | True
Total: 1 attribute relationship(s)

Collapse image See also

About this documentation


Dimension attribute: Source Currency

Collapse image Attribute properties

Name | Value
Attribute hierarchy enabled | True
Attribute hierarchy optimized state | FullyOptimized
Attribute hierarchy ordered | True
Attribute hierarchy processing state | Unprocessed
Attribute hierarchy display folder |
Attribute hierarchy visible | True
Discretization bucket count | 0
Discretization method | None
Estimated count | 101
Grouping behavior | DiscourageGrouping
Instance selection | DropDown
Is aggregatable | True
Key uniqueness guarantee | False
Member names unique | False
Members with data | NonLeafDataVisible
Order by | Name
Order by attribute | /
Processing state | Unprocessed
Root member if | ParentIsBlankSelfOrMissing
Type | CurrencySource
Usage | Regular

Collapse image Key columns

Name | Data size | Data type | Format | Null processing | Trimming
[dbo_DimCurrency].[CurrencyName] | 50 | WChar |  | Error | Right
Total: 1 key column(s)

Collapse image Attribute relationships

No attribute relationships exist

Collapse image See also

About this documentation


Mining structures

List of mining structures

Collapse image Mining structures

Name | Column count | Mining model count | State | Description
Customer Mining | 11 | 1 | Processed |
Forecasting | 4 | 1 | Processed |
Market Basket | 2 | 1 | Processed |
Sequence Clustering | 2 | 1 | Processed |
Targeted Mailing | 14 | 2 | Processed |
Total: 5 mining structure(s)

Collapse image See also

About this documentation


Mining structure: Customer Mining

Collapse image Mining structure properties

Property | Value
Cache mode | KeepTrainingCases
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:17 PM
Filter component | <?xml version="1.0" encoding="utf-16"?><Filter xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/SQLServer/reporting/QuerySpecification"><FilterItems xmlns="http://schemas.microsoft.com/AnalysisServices/QueryDefinition" /></Filter>
Holdout actual size | 0
Holdout max cases | 0
Holdout max percent | 0
Holdout seed | 0
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:55 PM
Last schema update | 7/18/2014 6:51:01 PM
Source | BB

Collapse image Mining models

Name | Columns used within 'Customer Mining' mining structure
Customer Clusters | 11
Total: 1 mining model(s)

Collapse image See also

About this documentation


Mining model: Customer Clusters

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Clustering
Allow drill through | True
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:17 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:55 PM
Last schema update | 7/18/2014 6:51:01 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Customer Counts 1 | False | Key |  |
Commute Distance | False | Input |  |
Education | False | Input |  |
Gender | False | Input |  |
Home Owner | False | Input |  |
Marital Status | False | Input |  |
Number of Cars Owned | False | Input |  |
Number of Children At Home | False | Input |  |
Occupation | False | Input |  |
Total Children | False | Input |  |
Yearly Income | False | Input |  |
Total: 11 column(s)

Collapse image See also

About this documentation


Mining model column: Customer Counts 1

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Commute Distance

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Education

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Gender

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Home Owner

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Marital Status

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number of Cars Owned

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number of Children At Home

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Occupation

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Total Children

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Yearly Income

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Customer Clusters
Parent mining structure | Customer Mining
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining structure: Forecasting

Collapse image Mining structure properties

Property | Value
Cache mode | KeepTrainingCases
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:17 PM
Filter component |
Holdout actual size | 0
Holdout max cases | 0
Holdout max percent | 0
Holdout seed | 0
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:25 PM
Last schema update | 7/18/2014 6:51:01 PM
Source | BB

Collapse image Mining models

Name | Columns used within 'Forecasting' mining structure
Forecasting | 4
Total: 1 mining model(s)

Collapse image See also

About this documentation


Mining model: Forecasting

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Time_Series
Allow drill through | True
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:18 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:25 PM
Last schema update | 7/18/2014 6:51:02 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Amount | False | PredictOnly |  |
Model Region | False | Key |  |
Quantity | False | PredictOnly |  |
Time Index | False | Key |  |
Total: 4 column(s)

Collapse image See also

About this documentation


Mining model column: Amount

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Forecasting
Parent mining structure | Forecasting
Usage | PredictOnly

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Model Region

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Forecasting
Parent mining structure | Forecasting
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Quantity

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Forecasting
Parent mining structure | Forecasting
Usage | PredictOnly

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Time Index

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Forecasting
Parent mining structure | Forecasting
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining structure: Market Basket

Collapse image Mining structure properties

Property | Value
Cache mode | KeepTrainingCases
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:18 PM
Filter component |
Holdout actual size | 0
Holdout max cases | 0
Holdout max percent | 0
Holdout seed | 0
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:32 PM
Last schema update | 7/18/2014 6:51:02 PM
Source | BB

Collapse image Mining models

Name | Columns used within 'Market Basket' mining structure
Association | 2
Total: 1 mining model(s)

Collapse image See also

About this documentation


Mining model: Association

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Association_Rules
Allow drill through | True
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:18 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:32 PM
Last schema update | 7/18/2014 6:51:02 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Order Number | False | Key |  |
v Assoc Seq Line Items | True | Predict |  |
Total: 2 column(s)

Collapse image See also

About this documentation


Mining model column: Order Number

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Association
Parent mining structure | Market Basket
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: v Assoc Seq Line Items

Collapse image Mining model column properties

Property | Value
Is nested table | True
Parent mining model | Association
Parent mining structure | Market Basket
Usage | Predict

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Model | False | Key |  |
Total: 1 column(s)

Collapse image See also

About this documentation


Mining structure: Sequence Clustering

Collapse image Mining structure properties

Property | Value
Cache mode | KeepTrainingCases
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:18 PM
Filter component |
Holdout actual size | 0
Holdout max cases | 0
Holdout max percent | 0
Holdout seed | 0
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:25 PM
Last schema update | 7/18/2014 6:51:02 PM
Source | BB

Collapse image Mining models

Name | Columns used within 'Sequence Clustering' mining structure
Sequence Clustering | 2
Total: 1 mining model(s)

Collapse image See also

About this documentation


Mining model: Sequence Clustering

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Sequence_Clustering
Allow drill through | True
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:19 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:25 PM
Last schema update | 7/18/2014 6:51:02 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Order Number | False | Key |  |
v Assoc Seq Line Items | True | Predict |  |
Total: 2 column(s)

Collapse image See also

About this documentation


Mining model column: Order Number

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | Sequence Clustering
Parent mining structure | Sequence Clustering
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: v Assoc Seq Line Items

Collapse image Mining model column properties

Property | Value
Is nested table | True
Parent mining model | Sequence Clustering
Parent mining structure | Sequence Clustering
Usage | Predict

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Line Number | False | Key |  |
Model | False | Predict |  |
Total: 2 column(s)

Collapse image See also

About this documentation


Mining structure: Targeted Mailing

Collapse image Mining structure properties

Property | Value
Cache mode | KeepTrainingCases
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:19 PM
Filter component |
Holdout actual size | 0
Holdout max cases | 0
Holdout max percent | 0
Holdout seed | 0
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:45 PM
Last schema update | 7/18/2014 6:51:02 PM
Source | BB

Collapse image Mining models

Name | Columns used within 'Targeted Mailing' mining structure
TM Decision Tree | 14
TM Naive Bayes | 13
Total: 2 mining model(s)

Collapse image See also

About this documentation


Mining model: TM Decision Tree

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Decision_Trees
Allow drill through | True
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:19 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:44 PM
Last schema update | 7/18/2014 6:51:02 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Age | False | Input |  |
Bike Buyer | False | Predict |  |
Commute Distance | False | Input |  |
Customer Key | False | Key |  |
Education | False | Input |  |
Occupation | False | Input |  |
Gender | False | Input |  |
House Owner Flag | False | Input |  |
Marital Status | False | Input |  |
Number Cars Owned | False | Input |  |
Number Children At Home | False | Input |  |
Region | False | Input |  |
Total Children | False | Input |  |
Yearly Income | False | Input |  |
Total: 14 column(s)

Collapse image See also

About this documentation


Mining model column: Age

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Bike Buyer

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Predict

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Commute Distance

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Customer Key

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Education

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Occupation

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Gender

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: House Owner Flag

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Marital Status

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number Cars Owned

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number Children At Home

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Region

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Total Children

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Yearly Income

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Decision Tree
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model: TM Naive Bayes

Collapse image Mining model properties

Property | Value
Algorithm | Microsoft_Naive_Bayes
Allow drill through | False
Collation | Latin1_General_CI_AS
Date created | 7/18/2014 6:44:20 PM
Is loaded | True
Language | en-US
Last processed | 7/28/2014 9:46:29 PM
Last schema update | 7/18/2014 6:51:02 PM

Collapse image Columns

Name | Is nested table | Usage | Filter | Description
Bike Buyer | False | Predict |  |
Commute Distance | False | Input |  |
Customer Key | False | Key |  |
Education | False | Input |  |
Occupation | False | Input |  |
Gender | False | Input |  |
House Owner Flag | False | Input |  |
Marital Status | False | Input |  |
Number Cars Owned | False | Input |  |
Number Children At Home | False | Input |  |
Region | False | Input |  |
Total Children | False | Input |  |
Age | False | Input |  |
Total: 13 column(s)

Collapse image See also

About this documentation


Mining model column: Bike Buyer

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Predict

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Commute Distance

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Customer Key

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Key

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Education

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Occupation

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Gender

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: House Owner Flag

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Marital Status

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number Cars Owned

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Number Children At Home

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Region

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Total Children

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Mining model column: Age

Collapse image Mining model column properties

Property | Value
Is nested table | False
Parent mining model | TM Naive Bayes
Parent mining structure | Targeted Mailing
Usage | Input

Collapse image Columns

No columns exist

Collapse image See also

About this documentation


Roles

List of roles

Collapse image Roles

No roles exist

Collapse image See also

About this documentation


SSAS database index

ALEN-PC\TABULAR2016

Collapse image SSAS database index

Database | Description
AW Tabular Model SQL 2014 |

Collapse image See also

About this documentation


Server properties: ALEN-PC\TABULAR2016

Collapse image Basic properties

Name | Value | Pending value (if different) | Default value | Units
BackupDir | C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Backup |  |  | Folder
CollationName | Latin1_General_CI_AI |  |  |
CommitTimeout | 0 |  | 0 | MS
CoordinatorExecutionMode | -4 |  | -4 |
DataDir | C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Data |  | \data | Folder
DataMining\AllowAdHocOpenRowsetQueries | false |  | false |
DataMining\AllowSessionMiningModels | false |  | false |
DataMining\MaxConcurrentPredictionQueries | 0 |  | 0 |
Feature\ComUdfEnabled | false |  | false |
Feature\LinkFromOtherInstanceEnabled | false |  | false |
Feature\LinkInsideInstanceEnabled | true |  | true |
Feature\LinkToOtherInstanceEnabled | false |  | false |
ForceCommitTimeout | 30000 |  | 30000 | MS
Language | 1033 |  | 0 |
Log\FlightRecorder\Enabled | true |  | true |
Log\QueryLog\CreateQueryLogTable | false |  | false |
Log\QueryLog\QueryLogConnectionString |  |  |  |
Log\QueryLog\QueryLogSampling | 10 |  | 10 |
Log\QueryLog\QueryLogTableName | OlapQueryLog |  | OlapQueryLog |
LogDir | C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Log |  |  | Folder
Memory\HardMemoryLimit | 0 |  | 0 |
Memory\LowMemoryLimit | 6.5E1 |  | 6.5E1 |
Memory\TotalMemoryLimit | 8.E1 |  | 8.E1 |
Memory\VertiPaqMemoryLimit | 6.E1 |  | 6.E1 |
Network\ListenOnlyOnLocalConnections | false |  | false |
Network\Requests\EnableBinaryXML | false |  | false |
Network\Requests\EnableCompression | false |  | false |
Network\Responses\EnableBinaryXML | true |  | true |
Network\Responses\EnableCompression | true |  | true |
OLAP\LazyProcessing\Enabled | true |  | true |
OLAP\LazyProcessing\SleepIntervalSecs | 5 |  | 5 | Sec
OLAP\Process\DatabaseConnectionPoolConnectTimeout | 60 |  | 60 |
Port | 0 |  | 0 |
Security\RequireClientAuthentication | true |  | true |

Collapse image Advanced properties

Name | Value | Pending value (if different) | Default value | Units
AllowedBrowsingFolders | C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Backup\|C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Log\|C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Data\ |  | \data |
AutoSetDefaultInitialCatalog | true |  | true |
BackgroundSessionRollbackBatchingInterval | 2 |  | 2 | Sec
CoordinatorCancelCount | 1000 |  | 1000 |
DataMining\Algorithms\Microsoft_Association_Rules\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Clustering\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Decision_Trees\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Linear_Regression\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Logistic_Regression\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Naive_Bayes\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Neural_Network\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Sequence_Clustering\Enabled | true |  | true |
DataMining\Algorithms\Microsoft_Time_Series\Enabled | true |  | true |
DataMining\AllowedProvidersInOpenRowset |  |  |  |
DSO\LocksDirectory |  |  |  | Folder
DSO\RemoteLocksDirectory |  |  |  | Folder
DSO\RemoteRepositoryConnectionString |  |  |  |
DSO\RepositoryConnectionString |  |  |  |
ExternalCommandTimeout | 3600 |  | 3600 | Sec
ExternalConnectionTimeout | 60 |  | 60 | Sec
Feature\ResourceMonitoringEnabled | true |  | true |
FileStore\RandomFileAccessMode | 0 |  | 0 |
IdleConnectionTimeout | 0 |  | 0 | Sec
IdleOrphanSessionTimeout | 120 |  | 120 | Sec
InstanceVisible | true |  | true |
Log\File | msmdsrv.log |  | msmdsrv.log | File
Log\FlightRecorder\FileSizeMB | 10 |  | 10 | MB
Log\FlightRecorder\LogDurationSec | 3600 |  | 3600 | Sec
Log\FlightRecorder\SnapshotDefinitionFile |  |  |  | File
Log\FlightRecorder\SnapshotFrequencySec | 120 |  | 120 | Sec
Log\FlightRecorder\TraceDefinitionFile |  |  |  | File
Log\MaxFileSizeMB | 0 |  | 0 | MB
Log\MaxNumberOfLogFiles | 0 |  | 0 |
Log\MessageLogs | File;Console;System |  | File;Console;System |
Log\Trace\TraceReportFQDN | 0 |  | 0 |
MaxIdleSessionTimeout | 0 |  | 0 | Sec
Memory\HeapTypeForObjects | 0 |  | 0 |
Memory\MemoryHeapType | -1 |  | -1 |
Memory\VertiPaqPagingPolicy | 1 |  | 1 |
MinIdleSessionTimeout | 2700 |  | 2700 | Sec
Network\Listener\IPV4Support | 2 |  | 2 |
Network\Listener\IPV6Support | 2 |  | 2 |
Network\Listener\MaxAllowedRequestSize | 0 |  | 0 | Bytes
OLAP\LazyProcessing\MaxCPUUsage | 5.E-1 |  | 5.E-1 |
OLAP\LazyProcessing\MaxObjectsInParallel | 2 |  | 2 |
OLAP\Process\AggregationMemoryLimitMax | 8.E1 |  | 8.E1 |
OLAP\Process\AggregationMemoryLimitMin | 1.E1 |  | 1.E1 |
OLAP\Process\BufferMemoryLimit | 6.E1 |  | 6.E1 |
OLAP\Process\CheckDistinctRecordSortOrder | 1 |  | 1 |
OLAP\Process\DatabaseConnectionPoolMax | 50 |  | 50 |
OLAP\Process\DatabaseConnectionPoolTimeout | 120000 |  | 120000 |
OLAP\Process\DeepCompressValue | 1 |  | 1 |
OLAP\Process\ROLAPDimensionProcessingEffort | 300000 |  | 300000 |
OLAP\Process\XMLAConnectionPoolTimeout | 720000 |  | 720000 |
OLAP\ProcessPlan\MemoryLimitErrorEnabled | true |  | true |
OLAP\Query\AutoExistMemoryLimit | 6.5E1 |  | 6.5E1 |
OLAP\Query\DefaultDrillthroughMaxRows | 10000 |  | 10000 |
OLAP\Query\DisableCalcExpressNonEmpty | 0 |  | 0 |
OLAP\Query\NonEmptyBehaviorMode | 1 |  | 1 |
OLAP\Query\QueryOptimizerRatio | -1. |  | -1. |
OLAP\Query\SessionCubesMode | 1 |  | 1 |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\CLSID | 8B0958F1-D921-40F7-B19C-005B36FC14D5 |  | 8B0958F1-D921-40F7-B19C-005B36FC14D5 |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\Enabled | true |  | true |
PredictiveAnalytics\AlgorithmLibraries\MicrosoftPredictiveAnalytics\Manifest | PAAlgo.X.manifest |  | PAAlgo.X.manifest |
Security\BuiltinAdminsAreServerAdmins | true |  | true |
Security\CellPermissionMode | 0 |  | 0 |
Security\ServiceAccountIsServerAdmin | true |  | true |
ServerTimeout | 3600 |  | 3600 | Sec
TempDir | C:\Program Files\Microsoft SQL Server\MSAS13.TABULAR2016\OLAP\Temp |  |  | Folder
ThreadPool\Command\GroupAffinity |  |  |  |
ThreadPool\Command\MaxThreads | 0 |  | 0 |
ThreadPool\Command\MinThreads | 0 |  | 0 |
ThreadPool\IOProcess\GroupAffinity |  |  |  |
ThreadPool\IOProcess\MaxThreads | 0 |  | 0 |
ThreadPool\IOProcess\MinThreads | 0 |  | 0 |
ThreadPool\IOProcess\PerNumaNode | -1 |  | -1 |
ThreadPool\Parsing\Long\GroupAffinity |  |  |  |
ThreadPool\Parsing\Short\GroupAffinity |  |  |  |
ThreadPool\Process\GroupAffinity |  |  |  |
ThreadPool\Process\MaxThreads | 0 |  | 0 |
ThreadPool\Process\MinThreads | 0 |  | 0 |
ThreadPool\Query\GroupAffinity |  |  |  |
ThreadPool\Query\MaxThreads | 0 |  | 0 |
ThreadPool\Query\MinThreads | 0 |  | 0 |
VertiPaq\DefaultSegmentRowCount | 0 |  | 0 |
VertiPaq\ProcessingTimeboxSecPerMRow | -1 |  | -1 |
VertiPaq\ThreadPool\GroupAffinity |  |  |  |
WriteTransactionIdleTimeout | 0 |  | 0 | Sec

Collapse image See also

About this documentation


Database object index

AW Tabular Model SQL 2014

Collapse image Database information

Name | Value
Name | AW Tabular Model SQL 2014
Date created | 7/25/2014 9:51:54 PM
Estimated size | 18336326
Language | en-US
Last processed | 7/25/2014 10:12:28 PM
Last update | 9/2/2016 9:58:03 AM
Last schema update | 7/25/2014 10:18:36 PM
Processing priority | 0
Aggregation prefix |
Db storage location |
Model type | Tabular
Compatibility level | 1103
Direct query mode | InMemory
Read write mode | ReadWrite
Storage engine used | InMemory
Is loaded | True
Visible | True
State | Processed
Scripting language | ASSL

Collapse image Database object index

Objects | Total
Connections | 1
Tables | 15
Perspectives | 3
Roles | 1

Collapse image See also

Server index

About this documentation


Connections

List of connections

Collapse image Connections

Name | Impersonation type | Last schema update | Date created
SqlServer localhost | ImpersonateServiceAccount | 7/25/2014 10:18:28 PM | 7/25/2014 9:51:54 PM
Total: 1 connection(s)

Collapse image See also

About this documentation


Connection: SqlServer localhost

Collapse image Connection properties

Property | Value
Connection string | Provider=SQLNCLI11.1;Data Source=localhost;Persist Security Info=False;Integrated Security=SSPI;Initial Catalog=AdventureWorksDW2014
Connection string security | Unchanged
Date created | 7/25/2014 9:51:54 PM
Impersonation account name |
Impersonation type | ImpersonateServiceAccount
Is loaded | True
Isolation | ReadCommitted
Last schema update | 7/25/2014 10:18:28 PM
Maximum active connections | 10
Timeout | 00:00:00

Collapse image See also

About this documentation


Tables

List of tables

Collapse image Tables

Name | Column count | Hierarchy count | Measure count | Partition count | Visible | Description | Date created
Currency | 4 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Customer | 26 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Date | 16 | 3 | 2 | 1 | True |  | 7/25/2014 9:51:54 PM
Employee | 31 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Geography | 9 | 1 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Product | 29 | 1 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Product Category | 3 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Product Subcategory | 4 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Promotion | 10 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:54 PM
Reseller | 21 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:55 PM
Sales Territory | 6 | 1 | 18 | 1 | True |  | 7/25/2014 9:51:55 PM
Internet Sales | 28 | 0 | 17 | 6 | True |  | 7/25/2014 9:51:55 PM
Product Inventory | 14 | 0 | 11 | 6 | True |  | 7/25/2014 9:51:55 PM
Reseller Sales | 29 | 0 | 19 | 6 | True |  | 7/25/2014 9:51:55 PM
Sales Quota | 8 | 0 | 0 | 1 | True |  | 7/25/2014 9:51:55 PM
Total: 15 table(s)

Collapse image See also

About this documentation


Table: Currency

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimCurrency
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:15 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 4
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

No relationships exist

Collapse image SQL Statement

      SELECT [dbo].[DimCurrency].*   FROM [dbo].[DimCurrency]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
CurrencyKey | True | System.Int64 | General | False | False
Currency Code |  |  | Text | False |
CurrencyName | False | System.String | Text | False | False
Total: 4 column(s)

Collapse image See also

About this documentation


Column: RowNumber

Collapse image Column properties

Property | Value
Data type |
Format |
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: CurrencyKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Currency Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: CurrencyName

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

No measures exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Currency | InMemory | Processed | 7/25/2014 9:51:55 PM | 7/25/2014 9:51:55 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Currency

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:55 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:55 PM
Last processed | 7/25/2014 10:12:15 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimCurrency].*         FROM [dbo].[DimCurrency]

Collapse image See also

About this documentation


Table: Customer

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimCustomer
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 26
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Customer].[GeographyKey] | [Geography].[GeographyKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimCustomer].*   FROM [dbo].[DimCustomer]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
CustomerKey | True | System.Int64 | General | False | False
GeographyKey | False | System.Int64 | General | False | False
Customer Id |  |  | Text | False |
Title | False | System.String | Text | False | False
First Name |  |  | Text | False |
Middle Name |  |  | Text | False |
Last Name |  |  | Text | False |
Name Style |  |  | Boolean | False |
Birth Date |  |  | DateTimeGeneral | False |
Marital Status |  |  | Text | False |
Suffix | False | System.String | Text | False | False
Gender | False | System.String | Text | False | False
Email Address |  |  | Text | False |
Yearly Income |  |  | Currency | False |
Total Children |  |  | General | False |
Number of Children At Home |  |  | General | False |
Education |  |  | Text | False |
Occupation |  |  | Text | False |
Owns House |  |  | Boolean | False |
Total Cars Owned |  |  | General | False |
Address Line 1 |  |  | Text | False |
Address Line 2 |  |  | Text | False |
Phone | False | System.String | Text | False | False
Date Of First Purchase |  |  | DateTimeGeneral | False |
Commute Distance |  |  | Text | False |
Total: 26 column(s)

Collapse image See also

About this documentation


Column: CustomerKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: GeographyKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Customer Id

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Title

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: First Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Middle Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Last Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Name Style

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Birth Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Marital Status

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Suffix

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Gender

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Email Address

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Yearly Income

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Total Children

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Number of Children At Home

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Education

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Occupation

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Owns House

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Total Cars Owned

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Address Line 1

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Address Line 2

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Phone

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Date Of First Purchase

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Commute Distance

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Customer | InMemory | Processed | 7/25/2014 9:51:55 PM | 7/25/2014 9:51:55 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Customer

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:55 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:55 PM
Last processed | 7/25/2014 10:12:11 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimCustomer].*         FROM [dbo].[DimCustomer]

Collapse image See also

About this documentation


Table: Date

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimDate
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:17 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 16
Hierarchies | 3
Measures | 2
Partitions | 1

Collapse image Relationships

No relationships exist

Collapse image SQL Statement

      SELECT [dbo].[DimDate].*   FROM [dbo].[DimDate]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
DateKey | True | System.Int64 | General | False | False
Date |  |  | DateTimeGeneral | False |
Day Number Of Week |  |  | General | False |
Day Name Of Week |  |  | Text | False |
Day Of Month |  |  | General | False |
Day Of Year |  |  | General | False |
Week Of Year |  |  | General | False |
Month Name |  |  | Text | False |
Month |  |  | General | False |
Calendar Quarter |  |  | General | False |
Calendar Year |  |  | General | False |
Calendar Semester |  |  | General | False |
Fiscal Quarter |  |  | General | False |
Fiscal Year |  |  | General | False |
Fiscal Semester |  |  | General | False |
Total: 16 column(s)

Collapse image See also

About this documentation


Column: DateKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Day Number Of Week

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Day Name Of Week

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Day Of Month

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Day Of Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Week Of Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Month Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Month

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Calendar Quarter

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Calendar Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Calendar Semester

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Fiscal Quarter

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Fiscal Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Fiscal Semester

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Format string | Is default field set
Days In Current Quarter to Date | '' | False
Days In Current Quarter | '' | False
Total: 2 measure(s)

Collapse image See also

About this documentation


Measure: Days In Current Quarter to Date

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Date'[Days In Current Quarter to Date]=COUNTROWS( DATESQTD( 'Date'[Date]));

Collapse image See also

About this documentation


Measure: Days In Current Quarter

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Date'[Days In Current Quarter]=COUNTROWS( DATESBETWEEN( 'Date'[Date], STARTOFQUARTER( LASTDATE('Date'[Date])), ENDOFQUARTER('Date'[Date])));

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Calendar | 5 | Processed | Unnatural
Fiscal | 5 | Processed | Unnatural
Production Calendar | 3 | Processed | Unnatural
Total: 3 hierarchy(-ies)

Collapse image See also

About this documentation


Hierarchy: Calendar

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Unnatural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
 | Never |
 | Never |
 | Never |
Total: 5 level(s)

Collapse image See also

About this documentation


Hierarchy: Fiscal

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Unnatural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
 | Never |
 | Never |
 | Never |
Total: 5 level(s)

Collapse image See also

About this documentation


Hierarchy: Production Calendar

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Unnatural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
 | Never |
Total: 3 level(s)

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Date | InMemory | Processed | 7/25/2014 9:51:56 PM | 7/25/2014 9:51:56 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Date

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:56 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:56 PM
Last processed | 7/25/2014 10:12:17 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimDate].*         FROM [dbo].[DimDate]

Collapse image See also

About this documentation


Table: Employee

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimEmployee
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 31
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Employee].[SalesTerritoryKey] | [Sales Territory].[SalesTerritoryKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimEmployee].*   FROM [dbo].[DimEmployee]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
EmployeeKey | True | System.Int64 | General | False | False
ParentEmployeeKey | False | System.Int64 | General | False | False
Employee Id |  |  | Text | False |
SalesTerritoryKey | False | System.Int64 | General | False | False
First Name |  |  | Text | False |
Last Name |  |  | Text | False |
Middle Name |  |  | Text | False |
NameStyle | False | System.Boolean | Boolean | False | False
Title | False | System.String | Text | False | False
Hire Date |  |  | DateTimeGeneral | False |
Birth Date |  |  | DateTimeGeneral | False |
Login |  |  | Text | False |
Email |  |  | Text | False |
Phone | False | System.String | Text | False | False
Marital Status |  |  | Text | False |
Emergency Contact Name |  |  | Text | False |
Emergency Contact Phone |  |  | Text | False |
Is Salaried |  |  | Boolean | False |
Gender | False | System.String | Text | False | False
Pay Frequency |  |  | General | False |
Base Rate |  |  | Currency | False |
Vacation Hours |  |  | General | False |
Sick Leave Hours |  |  | General | False |
Is Current |  |  | Boolean | False |
Is Sales Person |  |  | Boolean | False |
Department Name |  |  | Text | False |
Start Date |  |  | DateTimeGeneral | False |
End Date |  |  | DateTimeGeneral | False |
Status | False | System.String | Text | False | False
Employee Photo |  |  | General | False |
Total: 31 column(s)

Collapse image See also

About this documentation


Column: EmployeeKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: ParentEmployeeKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Employee Id

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: SalesTerritoryKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: NameStyle

Collapse image Column properties

Property | Value
Data type | System.Boolean
Format | Boolean
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Hire Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Login

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Email

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Emergency Contact Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Emergency Contact Phone

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Is Salaried

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Pay Frequency

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Base Rate

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Vacation Hours

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sick Leave Hours

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Is Current

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Is Sales Person

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Department Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Start Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: End Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Status

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Employee Photo

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Employee | InMemory | Processed | 7/25/2014 9:51:56 PM | 7/25/2014 9:51:56 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Employee

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:56 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:56 PM
Last processed | 7/25/2014 10:12:12 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimEmployee].*         FROM [dbo].[DimEmployee]

Collapse image See also

About this documentation


Table: Geography

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimGeography
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 9
Hierarchies | 1
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Geography].[SalesTerritoryKey] | [Sales Territory].[SalesTerritoryKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimGeography].*   FROM [dbo].[DimGeography]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
GeographyKey | True | System.Int64 | General | False | False
City | False | System.String | Text | False | False
State Province Code |  |  | Text | False |
State Province Name |  |  | Text | False |
Country Region Code |  |  | Text | False |
Country Region Name |  |  | Text | False |
Postal Code |  |  | Text | False |
SalesTerritoryKey | False | System.Int64 | General | False | False
Total: 9 column(s)

Collapse image See also

About this documentation


Column: City

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: State Province Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: State Province Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Country Region Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Country Region Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Postal Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Geography | 3 | Processed | Unnatural
Total: 1 hierarchy(-ies)

Collapse image See also

About this documentation


Hierarchy: Geography

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Unnatural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
City | Never |
Total: 3 level(s)

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Geography | InMemory | Processed | 7/25/2014 9:51:56 PM | 7/25/2014 9:51:56 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Geography

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:56 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:56 PM
Last processed | 7/25/2014 10:12:12 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimGeography].*         FROM [dbo].[DimGeography]

Collapse image See also

About this documentation


Table: Product

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProduct
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 29
Hierarchies | 1
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Product].[ProductSubcategoryKey] | [Product Subcategory].[ProductSubcategoryKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimProduct].*   FROM [dbo].[DimProduct]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductKey | True | System.Int64 | General | False | False
Product Id |  |  | Text | False |
ProductSubcategoryKey | False | System.Int64 | General | False | False
Weight Unit Code |  |  | Text | False |
Size Unit Code |  |  | Text | False |
Product Name |  |  | Text | False |
Standard Cost |  |  | Currency | False |
Is Finished Goods |  |  | Boolean | False |
Color | False | System.String | Text | False | False
Safety Stock Level |  |  | General | False |
Reorder Point |  |  | General | False |
List Price |  |  | Currency | False |
Size | False | System.String | Text | False | False
Size Range |  |  | Text | False |
Weight | False | System.Double | General | False | False
Days To Manufacture |  |  | General | False |
Product Line |  |  | Text | False |
Dealer Price |  |  | Currency | False |
Class | False | System.String | Text | False | False
Style | False | System.String | Text | False | False
Model Name |  |  | Text | False |
LargePhoto | False | System.Byte[] | General | False | False
Description |  |  | Text | False |
Product Start Date |  |  | DateTimeGeneral | False |
Product End Date |  |  | DateTimeGeneral | False |
Product Status |  |  | Text | False |
Product SubCategory Name |  |  | Text | False |
Product Category Name |  |  | Text | False |
Total: 29 column(s)

Collapse image See also

About this documentation


Column: ProductKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Id

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: ProductSubcategoryKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Weight Unit Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Size Unit Code

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Standard Cost

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Is Finished Goods

Collapse image Column properties

Property | Value
Data type |
Format | Boolean
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Color

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Safety Stock Level

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Reorder Point

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: List Price

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Size

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Size Range

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Weight

Collapse image Column properties

Property | Value
Data type | System.Double
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Days To Manufacture

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Line

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Dealer Price

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Class

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Style

Collapse image Column properties

Property | Value
Data type | System.String
Format | Text
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Model Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: LargePhoto

Collapse image Column properties

Property | Value
Data type | System.Byte[]
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Description

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Start Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product End Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Status

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product SubCategory Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Category Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Category | 4 | Processed | Unnatural
Total: 1 hierarchy(-ies)

Collapse image See also

About this documentation


Hierarchy: Category

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Unnatural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
 | Never |
 | Never |
Total: 4 level(s)

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Product | InMemory | Processed | 7/25/2014 9:51:56 PM | 7/25/2014 9:51:56 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Product

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:56 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:56 PM
Last processed | 7/25/2014 10:12:11 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimProduct].*         FROM [dbo].[DimProduct]

Collapse image See also

About this documentation


Table: Product Category

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProductCategory
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:13 PM
Last schema update | 7/25/2014 10:12:08 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 3
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

No relationships exist

Collapse image SQL Statement

      SELECT [dbo].[DimProductCategory].*   FROM [dbo].[DimProductCategory]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductCategoryKey | True | System.Int64 | General | False | False
Product Category Name |  |  | Text | False |
Total: 3 column(s)

Collapse image See also

About this documentation


Column: ProductCategoryKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Product Category | InMemory | Processed | 7/25/2014 9:51:56 PM | 7/25/2014 9:51:56 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Product Category

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:56 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:56 PM
Last processed | 7/25/2014 10:12:13 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimProductCategory].*         FROM [dbo].[DimProductCategory]

Collapse image See also

About this documentation


Table: Product Subcategory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimProductSubcategory
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 4
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Product Subcategory].[ProductCategoryKey] | [Product Category].[ProductCategoryKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimProductSubcategory].*   FROM [dbo].[DimProductSubcategory]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductSubcategoryKey | True | System.Int64 | General | False | False
Product Subcategory Name |  |  | Text | False |
ProductCategoryKey | False | System.Int64 | General | False | False
Total: 4 column(s)

Collapse image See also

About this documentation


Column: Product Subcategory Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Product Subcategory | InMemory | Processed | 7/25/2014 9:51:57 PM | 7/25/2014 9:51:57 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Product Subcategory

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:57 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:57 PM
Last processed | 7/25/2014 10:12:16 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimProductSubcategory].*         FROM [dbo].[DimProductSubcategory]

Collapse image See also

About this documentation


Table: Promotion

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimPromotion
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:54 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:18 PM
Last schema update | 7/25/2014 9:51:54 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 10
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

No relationships exist

Collapse image SQL Statement

      SELECT [dbo].[DimPromotion].*   FROM [dbo].[DimPromotion]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
PromotionKey | True | System.Int64 | General | False | False
Promotion Name |  |  | Text | False |
DiscountPct | False | System.Double | NumberDecimal | False | False
Promotion Type |  |  | Text | False |
Promotion Category |  |  | Text | False |
Promotion Start Date |  |  | DateTimeGeneral | False |
Promotion End Date |  |  | DateTimeGeneral | False |
Min Quantity |  |  | General | False |
Max Quantity |  |  | General | False |
Total: 10 column(s)

Collapse image See also

About this documentation


Column: PromotionKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Promotion Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: DiscountPct

Collapse image Column properties

Property | Value
Data type | System.Double
Format | NumberDecimal
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Promotion Type

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Promotion Category

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Promotion Start Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Promotion End Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Min Quantity

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Max Quantity

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Promotion | InMemory | Processed | 7/25/2014 9:51:57 PM | 7/25/2014 9:51:57 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Promotion

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:57 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:57 PM
Last processed | 7/25/2014 10:12:18 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimPromotion].*         FROM [dbo].[DimPromotion]

Collapse image See also

About this documentation


Table: Reseller

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimReseller
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 21
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Reseller].[GeographyKey] | [Geography].[GeographyKey]
Total: 1 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[DimReseller].*   FROM [dbo].[DimReseller]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ResellerKey | True | System.Int64 | General | False | False
GeographyKey | False | System.Int64 | General | False | False
Reseller Id |  |  | Text | False |
Reseller Phone |  |  | Text | False |
Business Type |  |  | Text | False |
Reseller Name |  |  | Text | False |
Number Employees |  |  | General | False |
Order Frequency |  |  | Text | False |
Order Month |  |  | General | False |
First Order Year |  |  | General | False |
Last Order Year |  |  | General | False |
Product Line |  |  | Text | False |
Address Line 1 |  |  | Text | False |
Address Line 2 |  |  | Text | False |
Annual Sales |  |  | Currency | False |
Bank Name |  |  | Text | False |
Min Payment Type |  |  | General | False |
Min Payment Amount |  |  | Currency | False |
Annua Revenue |  |  | Currency | False |
Year Opened |  |  | General | False |
Total: 21 column(s)

Collapse image See also

About this documentation


Column: ResellerKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Reseller Id

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Reseller Phone

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Business Type

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Reseller Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Number Employees

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Order Frequency

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Order Month

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: First Order Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Last Order Year

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Annual Sales

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Bank Name

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Min Payment Type

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Min Payment Amount

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Annua Revenue

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Year Opened

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Reseller | InMemory | Processed | 7/25/2014 9:51:57 PM | 7/25/2014 9:51:57 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Reseller

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:57 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:57 PM
Last processed | 7/25/2014 10:12:15 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimReseller].*         FROM [dbo].[DimReseller]

Collapse image See also

About this documentation


Table: Sales Territory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | DimSalesTerritory
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:14 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 6
Hierarchies | 1
Measures | 18
Partitions | 1

Collapse image Relationships

No relationships exist

Collapse image SQL Statement

      SELECT [dbo].[DimSalesTerritory].*   FROM [dbo].[DimSalesTerritory]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
SalesTerritoryKey | True | System.Int64 | General | False | False
Sales Territory Region |  |  | Text | False |
Sales Territory Country |  |  | Text | False |
Sales Territory Group |  |  | Text | False |
Sales Territory Image |  |  | General | False |
Total: 6 column(s)

Collapse image See also

About this documentation


Column: Sales Territory Region

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Territory Country

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Territory Group

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Territory Image

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Format string | Is default field set
Distinct Count Sales Orders | '#,0' | False
Total Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Discount Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Products Cost | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Tax Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Freight | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Units Sold | '#,0' | False
Order Lines Count | '#,0' | False
Total Previous Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Current Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Previous Quarter Gross Profit Proportion to QTD | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Previous Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Current Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Previous Quarter Sales Proportion to QTD | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Sales - Sales Territory sliced by Employee | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Current Quarter Sales Performance | '' | False
Total Current Quarter Gross Profit Performance | '' | False
Total: 18 measure(s)

Collapse image See also

About this documentation


Measure: Distinct Count Sales Orders

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Distinct Count Sales Orders]=[Reseller Distinct Count Sales Order] + [Internet Distinct Count Sales Order];

Collapse image See also

About this documentation


Measure: Total Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Sales]=[Reseller Total Sales] + [Internet Total Sales];

Collapse image See also

About this documentation


Measure: Total Discount Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Discount Amount]=[Reseller Total Discount Amount] + [Internet Total Discount Amount];

Collapse image See also

About this documentation


Measure: Total Products Cost

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Products Cost]=[Reseller Total Product Cost] + [Internet Total Product Cost];

Collapse image See also

About this documentation


Measure: Total Tax Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Tax Amount]=[Reseller Total Tax Amount] + [Internet Total Tax Amount];

Collapse image See also

About this documentation


Measure: Total Freight

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Freight]=[Reseller Total Freight] + [Internet Total Freight];

Collapse image See also

About this documentation


Measure: Total Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Gross Profit]=[Reseller Total Gross Profit] + [Internet Total Gross Profit];

Collapse image See also

About this documentation


Measure: Total Units Sold

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Units Sold]=[Reseller Total Units] + [Internet Total Units];

Collapse image See also

About this documentation


Measure: Order Lines Count

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Order Lines Count]=[Reseller Order Lines Count] + [Internet Order Lines Count];

Collapse image See also

About this documentation


Measure: Total Previous Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Previous Quarter Gross Profit]=CALCULATE([Total Gross Profit], PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Total Current Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Current Quarter Gross Profit]=TOTALQTD([Total Gross Profit],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Total Previous Quarter Gross Profit Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Previous Quarter Gross Profit Proportion to QTD]=[Total Previous Quarter Gross Profit]*([Days In Current Quarter to Date]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Total Previous Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Previous Quarter Sales]=CALCULATE([Total Sales], PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Total Current Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Current Quarter Sales]=TOTALQTD([Total Sales],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Total Previous Quarter Sales Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Previous Quarter Sales Proportion to QTD]=[Total Previous Quarter Sales]*([Days In Current Quarter to Date]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Total Sales - Sales Territory sliced by Employee

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Sales - Sales Territory sliced by Employee]=[Reseller Total Sales - Sales Territory sliced by Employee] + [Internet Total Sales];

Collapse image See also

About this documentation


Measure: Total Current Quarter Sales Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Current Quarter Sales Performance]=IFERROR([Total Current Quarter Sales]/[Total Previous Quarter Sales Proportion to QTD],BLANK());
CREATE MEASURE 'Sales Territory'[_Total Current Quarter Sales Performance Goal] = 1.1;
CREATE MEASURE 'Sales Territory'[_Total Current Quarter Sales Performance Status] = if(ISBLANK('Sales Territory'[Total Current Quarter Sales Performance]),BLANK(),
        If('Sales Territory'[Total Current Quarter Sales Performance]<0.8,-1,
        If('Sales Territory'[Total Current Quarter Sales Performance]<1.07,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Total Current Quarter Sales Performance] AS Measures.[Total Current Quarter Sales Performance], ASSOCIATED_MEASURE_GROUP = 'Sales Territory', GOAL = Measures.[_Total Current Quarter Sales Performance Goal], STATUS = Measures.[_Total Current Quarter Sales Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Total Current Quarter Gross Profit Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Sales Territory'[Total Current Quarter Gross Profit Performance]=IF([Total Previous Quarter Gross Profit Proportion to QTD]<>0,([Total Current Quarter Gross Profit]-[Total Previous Quarter Gross Profit Proportion to QTD])/[Total Previous Quarter Gross Profit Proportion to QTD],BLANK());
CREATE MEASURE 'Sales Territory'[_Total Current Quarter Gross Profit Performance Goal] = 1.25;
CREATE MEASURE 'Sales Territory'[_Total Current Quarter Gross Profit Performance Status] = if(ISBLANK('Sales Territory'[Total Current Quarter Gross Profit Performance]),BLANK(),
        If('Sales Territory'[Total Current Quarter Gross Profit Performance]<0.8,-1,
        If('Sales Territory'[Total Current Quarter Gross Profit Performance]<1.03,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Total Current Quarter Gross Profit Performance] AS Measures.[Total Current Quarter Gross Profit Performance], ASSOCIATED_MEASURE_GROUP = 'Sales Territory', GOAL = Measures.[_Total Current Quarter Gross Profit Performance Goal], STATUS = Measures.[_Total Current Quarter Gross Profit Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Hierarchies

List of hierarchies

Collapse image Hierarchies

Name | Level count | Processing state | Structure type
Territory | 3 | Processed | Natural
Total: 1 hierarchy(-ies)

Collapse image See also

About this documentation


Hierarchy: Territory

Collapse image Hierarchy properties

Property | Value
Allow duplicate names | True
Member keys unique | NotUnique
Structure type | Natural
Processing state | Processed

Collapse image Levels

Name | Hide member if | Description
 | Never |
 | Never |
 | Never |
Total: 3 level(s)

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Sales Territory | InMemory | Processed | 7/25/2014 9:51:57 PM | 7/25/2014 9:51:57 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Sales Territory

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:57 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:57 PM
Last processed | 7/25/2014 10:12:14 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[DimSalesTerritory].*         FROM [dbo].[DimSalesTerritory]

Collapse image See also

About this documentation


Table: Internet Sales

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactInternetSales
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 28
Hierarchies | 0
Measures | 17
Partitions | 6

Collapse image Relationships

Foreign key column | Primary key column
[Internet Sales].[CurrencyKey] | [Currency].[CurrencyKey]
[Internet Sales].[CustomerKey] | [Customer].[CustomerKey]
[Internet Sales].[OrderDateKey] | [Date].[DateKey]
[Internet Sales].[DueDateKey] | [Date].[DateKey]
[Internet Sales].[ShipDateKey] | [Date].[DateKey]
[Internet Sales].[ProductKey] | [Product].[ProductKey]
[Internet Sales].[PromotionKey] | [Promotion].[PromotionKey]
[Internet Sales].[SalesTerritoryKey] | [Sales Territory].[SalesTerritoryKey]
Total: 8 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductKey | False | System.Int64 | General | False | False
OrderDateKey | False | System.Int64 | General | False | False
DueDateKey | False | System.Int64 | General | False | False
ShipDateKey | False | System.Int64 | General | False | False
CustomerKey | False | System.Int64 | General | False | False
PromotionKey | False | System.Int64 | General | False | False
CurrencyKey | False | System.Int64 | General | False | False
SalesTerritoryKey | False | System.Int64 | General | False | False
Sales Order Number |  |  | Text | False |
Sales Order Line Number |  |  | General | False |
Revision Number |  |  | General | False |
Order Quantity |  |  | General | False |
Unit Price |  |  | Currency | False |
Extended Amount |  |  | Currency | False |
Unit Price Discount Pct |  |  | General | False |
Discount Amount |  |  | Currency | False |
Product Standard Cost |  |  | Currency | False |
Total Product Cost |  |  | Currency | False |
Sales Amount |  |  | Currency | False |
Tax Amount |  |  | Currency | False |
Freight | False | System.Decimal | Currency | False | False
Carrier Tracking Number |  |  | Text | False |
Customer PO Number |  |  | Text | False |
Order Date |  |  | DateTimeGeneral | False |
Due Date |  |  | DateTimeGeneral | False |
Ship Date |  |  | DateTimeGeneral | False |
Gross Profit |  |  | Currency | False |
Total: 28 column(s)

Collapse image See also

About this documentation


Column: OrderDateKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: DueDateKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: ShipDateKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Order Number

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Order Line Number

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Revision Number

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Order Quantity

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Unit Price

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Extended Amount

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Unit Price Discount Pct

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Discount Amount

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product Standard Cost

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Total Product Cost

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Amount

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Tax Amount

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Freight

Collapse image Column properties

Property | Value
Data type | System.Decimal
Format | Currency
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Carrier Tracking Number

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Customer PO Number

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Order Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Due Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Ship Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeGeneral
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Gross Profit

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Format string | Is default field set
Internet Distinct Count Sales Order | '#,0' | False
Internet Total Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Discount Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Product Cost | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Tax Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Freight | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Total Units | '#,0' | False
Internet Order Lines Count | '#,0' | False
Internet Previous Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Current Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Previous Quarter Gross Profit Proportion to QTD | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Previous Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Current Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Previous Quarter Sales Proportion to QTD | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Internet Current Quarter Sales Performance | '' | False
Internet Current Quarter Gross Profit Performance | '' | False
Total: 17 measure(s)

Collapse image See also

About this documentation


Measure: Internet Distinct Count Sales Order

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Distinct Count Sales Order]=DISTINCTCOUNT([Sales Order Number]);

Collapse image See also

About this documentation


Measure: Internet Total Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Sales]=SUM([Sales Amount]);

Collapse image See also

About this documentation


Measure: Internet Total Discount Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Discount Amount]=SUM([Discount Amount]);

Collapse image See also

About this documentation


Measure: Internet Total Product Cost

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Product Cost]=SUM([Total Product Cost]);

Collapse image See also

About this documentation


Measure: Internet Total Tax Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Tax Amount]=SUM([Tax Amount]);

Collapse image See also

About this documentation


Measure: Internet Total Freight

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Freight]=SUM([Freight]);

Collapse image See also

About this documentation


Measure: Internet Total Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Gross Profit]=SUM([Gross Profit]);

Collapse image See also

About this documentation


Measure: Internet Total Units

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Total Units]=SUM([Order Quantity]);

Collapse image See also

About this documentation


Measure: Internet Order Lines Count

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Order Lines Count]=COUNT([Sales Order Line Number]);

Collapse image See also

About this documentation


Measure: Internet Previous Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Previous Quarter Gross Profit]=CALCULATE([Internet Total Gross Profit],PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Internet Current Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Current Quarter Gross Profit]=TOTALQTD([Internet Total Gross Profit],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Internet Previous Quarter Gross Profit Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Previous Quarter Gross Profit Proportion to QTD]=[Internet Previous Quarter Gross Profit]*([Days In Current Quarter to Date]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Internet Previous Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Previous Quarter Sales]=CALCULATE([Internet Total Sales],PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Internet Current Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Current Quarter Sales]=TOTALQTD([Internet Total Sales],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Internet Previous Quarter Sales Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Previous Quarter Sales Proportion to QTD]=[Internet Previous Quarter Sales]*([Days In Current Quarter]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Internet Current Quarter Sales Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Current Quarter Sales Performance]=IFERROR([Internet Current Quarter Sales]/[Internet Previous Quarter Sales Proportion to QTD],BLANK());
CREATE MEASURE 'Internet Sales'[_Internet Current Quarter Sales Performance Goal] = 1.1;
CREATE MEASURE 'Internet Sales'[_Internet Current Quarter Sales Performance Status] = if(ISBLANK('Internet Sales'[Internet Current Quarter Sales Performance]),BLANK(),
        If('Internet Sales'[Internet Current Quarter Sales Performance]<1,-1,
        If('Internet Sales'[Internet Current Quarter Sales Performance]<1.07,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Internet Current Quarter Sales Performance] AS Measures.[Internet Current Quarter Sales Performance], ASSOCIATED_MEASURE_GROUP = 'Internet Sales', GOAL = Measures.[_Internet Current Quarter Sales Performance Goal], STATUS = Measures.[_Internet Current Quarter Sales Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Internet Current Quarter Gross Profit Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Internet Sales'[Internet Current Quarter Gross Profit Performance]=IF([Internet Previous Quarter Gross Profit Proportion to QTD]<>0,([Internet Current Quarter Gross Profit]-[Internet Previous Quarter Gross Profit Proportion to QTD])/[Internet Previous Quarter Gross Profit Proportion to QTD],BLANK());
CREATE MEASURE 'Internet Sales'[_Internet Current Quarter Gross Profit Performance Goal] = 1.25;
CREATE MEASURE 'Internet Sales'[_Internet Current Quarter Gross Profit Performance Status] = if(ISBLANK('Internet Sales'[Internet Current Quarter Gross Profit Performance]),BLANK(),
        If('Internet Sales'[Internet Current Quarter Gross Profit Performance]<0.8,-1,
        If('Internet Sales'[Internet Current Quarter Gross Profit Performance]<1.03,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Internet Current Quarter Gross Profit Performance] AS Measures.[Internet Current Quarter Gross Profit Performance], ASSOCIATED_MEASURE_GROUP = 'Internet Sales', GOAL = Measures.[_Internet Current Quarter Gross Profit Performance Goal], STATUS = Measures.[_Internet Current Quarter Gross Profit Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Internet Sales 2009 | InMemory | Processed | 7/25/2014 9:51:57 PM | 7/25/2014 9:51:57 PM
Internet Sales 2010 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Internet Sales 2011 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Internet Sales 2012 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Internet Sales 2013 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Internet Sales 2014 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Total: 6 partition(s)

Collapse image See also

About this documentation


Partition: Internet Sales 2009

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:57 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:57 PM
Last processed | 7/25/2014 10:12:10 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20090101) AND ([OrderDateKey] <= 20091231))

Collapse image See also

About this documentation


Partition: Internet Sales 2010

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:12 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20100101) AND ([OrderDateKey] <= 20101231))

Collapse image See also

About this documentation


Partition: Internet Sales 2011

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:13 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20110101) AND ([OrderDateKey] <= 20111231))

Collapse image See also

About this documentation


Partition: Internet Sales 2012

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:14 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20120101) AND ([OrderDateKey] <= 20121231))

Collapse image See also

About this documentation


Partition: Internet Sales 2013

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:15 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20130101) AND ([OrderDateKey] <= 20131231))

Collapse image See also

About this documentation


Partition: Internet Sales 2014

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:17 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactInternetSales].*   FROM [dbo].[FactInternetSales]  WHERE (([OrderDateKey] >= 20140101) AND ([OrderDateKey] <= 20141231))

Collapse image See also

About this documentation


Table: Product Inventory

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactProductInventory
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 14
Hierarchies | 0
Measures | 11
Partitions | 6

Collapse image Relationships

Foreign key column | Primary key column
[Product Inventory].[DateKey] | [Date].[DateKey]
[Product Inventory].[ProductKey] | [Product].[ProductKey]
Total: 2 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[FactProductInventory].*   FROM [dbo].[FactProductInventory]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductKey | True | System.Int64 | General | False | False
DateKey | True | System.Int64 | General | False | False
Movement Date |  |  | DateTimeShortDatePattern | False |
Unit Cost |  |  | Currency | False |
Units In |  |  | General | False |
Units Out |  |  | General | False |
Units Balance |  |  | General | False |
Product-Date Inventory Value |  |  | Currency | False |
Product-Date Optimal Inventory Value |  |  | Currency | False |
Product-Date Max Inventory Value |  |  | Currency | False |
Product-Date OverStocked |  |  | General | False |
Product-Date UnderStocked |  |  | General | False |
Product-Date Negative Stock |  |  | General | False |
Total: 14 column(s)

Collapse image See also

About this documentation


Column: Movement Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeShortDatePattern
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Unit Cost

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Units In

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Units Out

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Units Balance

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date Inventory Value

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date Optimal Inventory Value

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date Max Inventory Value

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date OverStocked

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date UnderStocked

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Product-Date Negative Stock

Collapse image Column properties

Property | Value
Data type |
Format | General
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Format string | Is default field set
Total Units In | '#,0' | False
Total Units Out | '#,0' | False
Total Units Movement | '#,0' | False
Total Units | '#,0' | False
Total Inventory Value | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Inventory Optimal Value | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Inventory Maximum Value | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Total Inventory Value Performance | '' | False
Products OverStocked | '' | False
Products UnderStocked | '' | False
Products with Negative Stock | '' | False
Total: 11 measure(s)

Collapse image See also

About this documentation


Measure: Total Units In

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Units In]=SUM([Units In]);

Collapse image See also

About this documentation


Measure: Total Units Out

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Units Out]=SUM([Units Out]);

Collapse image See also

About this documentation


Measure: Total Units Movement

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Units Movement]=[Total Units In]-[Total Units Out];

Collapse image See also

About this documentation


Measure: Total Units

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Units]=CALCULATE(SUM([Units Balance]),LASTDATE('Product Inventory'[Movement Date]));

Collapse image See also

About this documentation


Measure: Total Inventory Value

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Inventory Value]=CALCULATE(SUM([Product-Date Inventory Value]),LASTDATE('Product Inventory'[Movement Date]));

Collapse image See also

About this documentation


Measure: Total Inventory Optimal Value

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Inventory Optimal Value]=CALCULATE(SUM([Product-Date Optimal Inventory Value]),LASTDATE('Product Inventory'[Movement Date]));

Collapse image See also

About this documentation


Measure: Total Inventory Maximum Value

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Inventory Maximum Value]=CALCULATE(SUM([Product-Date Max Inventory Value]),LASTDATE('Product Inventory'[Movement Date]));

Collapse image See also

About this documentation


Measure: Total Inventory Value Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Total Inventory Value Performance]=IF([Total Inventory Value]<[Total Inventory Optimal Value],-(1-([Total Inventory Value]/[Total Inventory Optimal Value])),([Total Inventory Value]-[Total Inventory Optimal Value])/([Total Inventory Maximum Value]-[Total Inventory Optimal Value]));
CREATE MEASURE 'Product Inventory'[_Total Inventory Value Performance Goal] = 0;
CREATE MEASURE 'Product Inventory'[_Total Inventory Value Performance Status] = if(ISBLANK('Product Inventory'[Total Inventory Value Performance]),BLANK(),
    If('Product Inventory'[Total Inventory Value Performance]<0,
        If('Product Inventory'[Total Inventory Value Performance]<-0.2,-1,0),
        If('Product Inventory'[Total Inventory Value Performance]<0.6,1,
            If('Product Inventory'[Total Inventory Value Performance]<1,0,-1)
        )
    )
)
;
CREATE KPI CURRENTCUBE.[Total Inventory Value Performance] AS Measures.[Total Inventory Value Performance], ASSOCIATED_MEASURE_GROUP = 'Product Inventory', GOAL = Measures.[_Total Inventory Value Performance Goal], STATUS = Measures.[_Total Inventory Value Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Products OverStocked

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Products OverStocked]=CALCULATE(SUM([Product-Date OverStocked]),LASTDATE('Product Inventory'[Movement Date]));
CREATE MEASURE 'Product Inventory'[_Products OverStocked Goal] = 0;
CREATE MEASURE 'Product Inventory'[_Products OverStocked Status] = if(ISBLANK('Product Inventory'[Products OverStocked]),BLANK(),
        If('Product Inventory'[Products OverStocked]<1,1,
        If('Product Inventory'[Products OverStocked]<5,0,-1)
    )
)
;
CREATE KPI CURRENTCUBE.[Products OverStocked] AS Measures.[Products OverStocked], ASSOCIATED_MEASURE_GROUP = 'Product Inventory', GOAL = Measures.[_Products OverStocked Goal], STATUS = Measures.[_Products OverStocked Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Products UnderStocked

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Products UnderStocked]=CALCULATE(SUM([Product-Date UnderStocked]),LASTDATE('Product Inventory'[Movement Date]));
CREATE MEASURE 'Product Inventory'[_Products UnderStocked Goal] = 0;
CREATE MEASURE 'Product Inventory'[_Products UnderStocked Status] = if(ISBLANK('Product Inventory'[Products UnderStocked]),BLANK(),
        If('Product Inventory'[Products UnderStocked]<5,1,
        If('Product Inventory'[Products UnderStocked]<15,0,-1)
    )
)
;
CREATE KPI CURRENTCUBE.[Products UnderStocked] AS Measures.[Products UnderStocked], ASSOCIATED_MEASURE_GROUP = 'Product Inventory', GOAL = Measures.[_Products UnderStocked Goal], STATUS = Measures.[_Products UnderStocked Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Products with Negative Stock

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Product Inventory'[Products with Negative Stock]=CALCULATE(SUM([Product-Date Negative Stock]),LASTDATE('Product Inventory'[Movement Date]));
CREATE MEASURE 'Product Inventory'[_Products with Negative Stock Goal] = 0;
CREATE MEASURE 'Product Inventory'[_Products with Negative Stock Status] = if(ISBLANK('Product Inventory'[Products with Negative Stock]),BLANK(),
        If('Product Inventory'[Products with Negative Stock]<0.1,1,
        If('Product Inventory'[Products with Negative Stock]<5,0,-1)
    )
)
;
CREATE KPI CURRENTCUBE.[Products with Negative Stock] AS Measures.[Products with Negative Stock], ASSOCIATED_MEASURE_GROUP = 'Product Inventory', GOAL = Measures.[_Products with Negative Stock Goal], STATUS = Measures.[_Products with Negative Stock Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Product Inventory 2005 | InMemory | Processed | 7/25/2014 9:51:58 PM | 7/25/2014 9:51:58 PM
Product Inventory 2006 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Product Inventory 2007 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Product Inventory 2008 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Product Inventory 2009 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Product Inventory 2010 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Total: 6 partition(s)

Collapse image See also

About this documentation


Partition: Product Inventory 2005

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:58 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:58 PM
Last processed | 7/25/2014 10:12:18 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20050101) AND ([DateKey] <= 20051231))

Collapse image See also

About this documentation


Partition: Product Inventory 2006

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:19 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20060101) AND ([DateKey] <= 20061231))

Collapse image See also

About this documentation


Partition: Product Inventory 2007

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:20 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20070101) AND ([DateKey] <= 20071231))

Collapse image See also

About this documentation


Partition: Product Inventory 2008

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:21 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20080101) AND ([DateKey] <= 20081231))

Collapse image See also

About this documentation


Partition: Product Inventory 2009

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:21 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20090101) AND ([DateKey] <= 20091231))

Collapse image See also

About this documentation


Partition: Product Inventory 2010

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:22 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactProductInventory].*         FROM [dbo].[FactProductInventory]  WHERE (([DateKey] >= 20100101) AND ([DateKey] <= 20101231))

Collapse image See also

About this documentation


Table: Reseller Sales

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactResellerSales
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 29
Hierarchies | 0
Measures | 19
Partitions | 6

Collapse image Relationships

Foreign key column | Primary key column
[Reseller Sales].[CurrencyKey] | [Currency].[CurrencyKey]
[Reseller Sales].[OrderDateKey] | [Date].[DateKey]
[Reseller Sales].[DueDateKey] | [Date].[DateKey]
[Reseller Sales].[ShipDateKey] | [Date].[DateKey]
[Reseller Sales].[EmployeeKey] | [Employee].[EmployeeKey]
[Reseller Sales].[ProductKey] | [Product].[ProductKey]
[Reseller Sales].[PromotionKey] | [Promotion].[PromotionKey]
[Reseller Sales].[ResellerKey] | [Reseller].[ResellerKey]
[Reseller Sales].[SalesTerritoryKey] | [Sales Territory].[SalesTerritoryKey]
Total: 9 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
ProductKey | False | System.Int64 | General | False | False
OrderDateKey | False | System.Int64 | General | False | False
DueDateKey | False | System.Int64 | General | False | False
ShipDateKey | False | System.Int64 | General | False | False
ResellerKey | False | System.Int64 | General | False | False
EmployeeKey | False | System.Int64 | General | False | False
PromotionKey | False | System.Int64 | General | False | False
CurrencyKey | False | System.Int64 | General | False | False
SalesTerritoryKey | False | System.Int64 | General | False | False
Sales Order Number |  |  | Text | False |
Sales Order Line Number |  |  | General | False |
Revision Number |  |  | General | False |
Order Quantity |  |  | General | False |
Unit Price |  |  | Currency | False |
Extended Amount |  |  | Currency | False |
Unit Price Discount Pct |  |  | General | False |
Discount Amount |  |  | Currency | False |
Product Standard Cost |  |  | Currency | False |
Total Product Cost |  |  | Currency | False |
Sales Amount |  |  | Currency | False |
Tax Amount |  |  | Currency | False |
Freight | False | System.Decimal | Currency | False | False
Carrier Tracking Number |  |  | Text | False |
Reseller PO Number |  |  | Text | False |
Order Date |  |  | DateTimeShortDatePattern | False |
Due Date |  |  | DateTimeShortDatePattern | False |
Ship Date |  |  | DateTimeShortDatePattern | False |
Gross Profit |  |  | Currency | False |
Total: 29 column(s)

Collapse image See also

About this documentation


Column: Reseller PO Number

Collapse image Column properties

Property | Value
Data type |
Format | Text
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Order Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeShortDatePattern
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Due Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeShortDatePattern
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Ship Date

Collapse image Column properties

Property | Value
Data type |
Format | DateTimeShortDatePattern
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Measures

List of measures

Collapse image Measures

Name | Format string | Is default field set
Reseller Distinct Count Sales Order | '#,0' | False
Reseller Total Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Discount Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Product Cost | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Tax Amount | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Freight | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Units | '#,0' | False
Reseller Order Lines Count | '#,0' | False
Reseller Previous Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Current Quarter Gross Profit | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Previous Quarter Gross Profit Proportion to QTD | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Previous Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Current Quarter Sales | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Previous Quarter Sales Proportion to QTD | '' | False
Reseller Total Sales - Sales Territory sliced by Employee | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Total Sales - Sales Territory sliced by Reseller | '\$#,0.00;(\$#,0.00);\$#,0.00' | False
Reseller Current Quarter Sales Performance | '' | False
Reseller Current Quarter Gross Profit Performance | '' | False
Total: 19 measure(s)

Collapse image See also

About this documentation


Measure: Reseller Distinct Count Sales Order

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Distinct Count Sales Order]=DISTINCTCOUNT([Sales Order Number]);

Collapse image See also

About this documentation


Measure: Reseller Total Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Sales]=SUM([Sales Amount]);

Collapse image See also

About this documentation


Measure: Reseller Total Discount Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Discount Amount]=SUM([Discount Amount]);

Collapse image See also

About this documentation


Measure: Reseller Total Product Cost

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Product Cost]=SUM([Total Product Cost]);

Collapse image See also

About this documentation


Measure: Reseller Total Tax Amount

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Tax Amount]=SUM([Tax Amount]);

Collapse image See also

About this documentation


Measure: Reseller Total Freight

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Freight]=SUM([Freight]);

Collapse image See also

About this documentation


Measure: Reseller Total Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Gross Profit]=SUM([Gross Profit]);

Collapse image See also

About this documentation


Measure: Reseller Total Units

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Units]=SUM([Order Quantity]);

Collapse image See also

About this documentation


Measure: Reseller Order Lines Count

Collapse image Measure properties

Property | Value
Format |
Format string | '#,0'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Order Lines Count]=COUNT([Sales Order Line Number]);

Collapse image See also

About this documentation


Measure: Reseller Previous Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Previous Quarter Gross Profit]=CALCULATE([Reseller Total Gross Profit],PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Reseller Current Quarter Gross Profit

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Current Quarter Gross Profit]=TOTALQTD([Reseller Total Gross Profit],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Reseller Previous Quarter Gross Profit Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Previous Quarter Gross Profit Proportion to QTD]=[Reseller Previous Quarter Gross Profit]*([Days In Current Quarter to Date]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Reseller Previous Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Previous Quarter Sales]=CALCULATE([Reseller Total Sales],PREVIOUSQUARTER('Date'[Date]));

Collapse image See also

About this documentation


Measure: Reseller Current Quarter Sales

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Current Quarter Sales]=TOTALQTD([Reseller Total Sales],'Date'[Date]);

Collapse image See also

About this documentation


Measure: Reseller Previous Quarter Sales Proportion to QTD

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Previous Quarter Sales Proportion to QTD]=[Reseller Previous Quarter Sales]*([Days In Current Quarter to Date]/[Days In Current Quarter]);

Collapse image See also

About this documentation


Measure: Reseller Total Sales - Sales Territory sliced by Employee

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Sales - Sales Territory sliced by Employee]=CALCULATE(SUM('Reseller Sales'[Sales Amount]),USERELATIONSHIP(Employee[EmployeeKey],'Reseller Sales'[EmployeeKey]),USERELATIONSHIP('Sales Territory'[SalesTerritoryKey],Employee[SalesTerritoryKey]));

Collapse image See also

About this documentation


Measure: Reseller Total Sales - Sales Territory sliced by Reseller

Collapse image Measure properties

Property | Value
Format |
Format string | '\$#,0.00;(\$#,0.00);\$#,0.00'
Measure type | User
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Total Sales - Sales Territory sliced by Reseller]=CALCULATE(SUM('Reseller Sales'[Sales Amount]), USERELATIONSHIP(Reseller[ResellerKey], 'Reseller Sales'[ResellerKey]), USERELATIONSHIP(Geography[GeographyKey], Reseller[GeographyKey]), USERELATIONSHIP('Sales Territory'[SalesTerritoryKey], Geography[SalesTerritoryKey]));

Collapse image See also

About this documentation


Measure: Reseller Current Quarter Sales Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Current Quarter Sales Performance]=IFERROR([Reseller Current Quarter Sales]/[Reseller Previous Quarter Sales Proportion to QTD],BLANK());
CREATE MEASURE 'Reseller Sales'[_Reseller Current Quarter Sales Performance Goal] = 1.1;
CREATE MEASURE 'Reseller Sales'[_Reseller Current Quarter Sales Performance Status] = if(ISBLANK('Reseller Sales'[Reseller Current Quarter Sales Performance]),BLANK(),
        If('Reseller Sales'[Reseller Current Quarter Sales Performance]<0.8,-1,
        If('Reseller Sales'[Reseller Current Quarter Sales Performance]<1.07,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Reseller Current Quarter Sales Performance] AS Measures.[Reseller Current Quarter Sales Performance], ASSOCIATED_MEASURE_GROUP = 'Reseller Sales', GOAL = Measures.[_Reseller Current Quarter Sales Performance Goal], STATUS = Measures.[_Reseller Current Quarter Sales Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Measure: Reseller Current Quarter Gross Profit Performance

Collapse image Measure properties

Property | Value
Format |
Format string | ''
Measure type | Kpi
Is default field set | False

Collapse image Command

----------------------------------------------------------
-- PowerPivot measures command (do not modify manually) --
----------------------------------------------------------

CREATE MEASURE 'Reseller Sales'[Reseller Current Quarter Gross Profit Performance]=IF([Reseller Previous Quarter Gross Profit Proportion to QTD]<>0,([Reseller Current Quarter Gross Profit]-[Reseller Previous Quarter Gross Profit Proportion to QTD])/[Reseller Previous Quarter Gross Profit Proportion to QTD],BLANK());
CREATE MEASURE 'Reseller Sales'[_Reseller Current Quarter Gross Profit Performance Goal] = 1.25;
CREATE MEASURE 'Reseller Sales'[_Reseller Current Quarter Gross Profit Performance Status] = if(ISBLANK('Reseller Sales'[Reseller Current Quarter Gross Profit Performance]),BLANK(),
        If('Reseller Sales'[Reseller Current Quarter Gross Profit Performance]<0.8,-1,
        If('Reseller Sales'[Reseller Current Quarter Gross Profit Performance]<1.03,0,1)
    )
)
;
CREATE KPI CURRENTCUBE.[Reseller Current Quarter Gross Profit Performance] AS Measures.[Reseller Current Quarter Gross Profit Performance], ASSOCIATED_MEASURE_GROUP = 'Reseller Sales', GOAL = Measures.[_Reseller Current Quarter Gross Profit Performance Goal], STATUS = Measures.[_Reseller Current Quarter Gross Profit Performance Status], STATUS_GRAPHIC = 'Three Symbols UnCircled Colored';

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Reseller Sales 2009 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Reseller Sales 2010 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Reseller Sales 2011 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Reseller Sales 2012 | InMemory | Processed | 7/25/2014 9:51:59 PM | 7/25/2014 9:51:59 PM
Reseller Sales 2013 | InMemory | Processed | 7/25/2014 9:52:00 PM | 7/25/2014 9:52:00 PM
Reseller Sales 2014 | InMemory | Processed | 7/25/2014 9:52:00 PM | 7/25/2014 9:52:00 PM
Total: 6 partition(s)

Collapse image See also

About this documentation


Partition: Reseller Sales 2009

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:14 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20090101) AND ([OrderDateKey] <= 20091231))

Collapse image See also

About this documentation


Partition: Reseller Sales 2010

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:14 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20100101) AND ([OrderDateKey] <= 20101231))

Collapse image See also

About this documentation


Partition: Reseller Sales 2011

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:16 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20110101) AND ([OrderDateKey] <= 20111231))

Collapse image See also

About this documentation


Partition: Reseller Sales 2012

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:51:59 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:59 PM
Last processed | 7/25/2014 10:12:17 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20120101) AND ([OrderDateKey] <= 20121231))

Collapse image See also

About this documentation


Partition: Reseller Sales 2013

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:52:00 PM
Is loaded | True
Last schema update | 7/25/2014 9:52:00 PM
Last processed | 7/25/2014 10:12:19 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20130101) AND ([OrderDateKey] <= 20131231))

Collapse image See also

About this documentation


Partition: Reseller Sales 2014

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:52:00 PM
Is loaded | True
Last schema update | 7/25/2014 9:52:00 PM
Last processed | 7/25/2014 10:12:19 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactResellerSales].*   FROM [dbo].[FactResellerSales]  WHERE (([OrderDateKey] >= 20140101) AND ([OrderDateKey] <= 20141231))

Collapse image See also

About this documentation


Table: Sales Quota

Collapse image Table properties

Property | Value
Database schema name | dbo
Database table name | FactSalesQuota
Is logical | True
Case sensitive | False
Table type | View
Date created | 7/25/2014 9:51:55 PM
Has errors | False
Hidden | False
Is initialized | True
Is loaded | True
Last processed | 7/25/2014 10:12:28 PM
Last schema update | 7/25/2014 9:51:55 PM
State | Processed

Collapse image Table object index

Objects | Total
Columns | 8
Hierarchies | 0
Measures | 0
Partitions | 1

Collapse image Relationships

Foreign key column | Primary key column
[Sales Quota].[DateKey] | [Date].[DateKey]
[Sales Quota].[EmployeeKey] | [Employee].[EmployeeKey]
Total: 2 relationship(s)

Collapse image SQL Statement

      SELECT [dbo].[FactSalesQuota].*   FROM [dbo].[FactSalesQuota]

Collapse image See also

About this documentation


Columns

List of columns

Collapse image Columns

Name | Row identifier | Data type | Format | Is default field set | Is expression
RowNumber |  |  |  | False |
SalesQuotaKey | True | System.Int64 | General | False | False
EmployeeKey | False | System.Int64 | General | False | False
DateKey | False | System.Int64 | General | False | False
Calendar Year |  |  | General | False |
Calendar Quarter |  |  | General | False |
Sales Amount Quota |  |  | Currency | False |
Date | False | System.DateTime | DateTimeShortDatePattern | False | False
Total: 8 column(s)

Collapse image See also

About this documentation


Column: SalesQuotaKey

Collapse image Column properties

Property | Value
Data type | System.Int64
Format | General
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Sales Amount Quota

Collapse image Column properties

Property | Value
Data type |
Format | Currency
Is default field set | False
Is expression |

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Column: Date

Collapse image Column properties

Property | Value
Data type | System.DateTime
Format | DateTimeShortDatePattern
Is default field set | False
Is expression | False

Collapse image Relationships

No relationships exist

Collapse image See also

About this documentation


Partitions

List of partitions

Collapse image Partitions

Name | Storage mode | Status | Last schema update | Date created
Sales Quota | InMemory | Processed | 7/25/2014 9:52:00 PM | 7/25/2014 9:52:00 PM
Total: 1 partition(s)

Collapse image See also

About this documentation


Partition: Sales Quota

Collapse image Partition properties

Property | Value
Data source | SqlServer localhost
Date created | 7/25/2014 9:52:00 PM
Is loaded | True
Last schema update | 7/25/2014 9:52:00 PM
Last processed | 7/25/2014 10:12:17 PM
Proactive caching enabled | False
Processing priority | 0
Processing mode | Regular
Storage mode | InMemory
Type | Data

Collapse image Query definition

SELECT [dbo].[FactSalesQuota].*         FROM [dbo].[FactSalesQuota]

Collapse image See also

About this documentation


Perspectives

List of perspectives

Collapse image Perspectives

Name | Table count | Column count | Is loaded | Last schema update
Inventory | 5 | 61 | True | 7/25/2014 9:51:55 PM
Internet Operation | 10 | 125 | True | 7/25/2014 9:51:55 PM
Reseller Operation | 12 | 158 | True | 7/25/2014 9:51:55 PM
Total: 3 perspective(s)

Collapse image See also

About this documentation


Perspective: Inventory

Collapse image Perspective properties

Property | Value
Date created | 7/25/2014 9:51:55 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:55 PM

Collapse image Tables

Collapse image Product

Collapse image Columns

Name | Type | Description
Product SubCategory Name | Regular |
Style | Regular |
Model Name | Regular |
Product Name | Regular |
Product Start Date | Regular |
Weight Unit Code | Regular |
Safety Stock Level | Regular |
Product Id | Regular |
Standard Cost | Regular |
Color | Regular |
Days To Manufacture | Regular |
Dealer Price | Regular |
ProductKey | Regular |
LargePhoto | Regular |
Size | Regular |
Is Finished Goods | Regular |
Description | Regular |
Product Line | Regular |
Size Unit Code | Regular |
List Price | Regular |
Class | Regular |
Size Range | Regular |
Reorder Point | Regular |
Product Status | Regular |
Weight | Regular |
ProductSubcategoryKey | Regular |
Product Category Name | Regular |
Product End Date | Regular |
Total: 28 column(s)
Click here to view details for table 'Product'

Collapse image Date

Collapse image Columns

Name | Type | Description
Month Name | Regular |
Calendar Quarter | Regular |
Month | Regular |
Week Of Year | Regular |
Calendar Year | Regular |
Fiscal Quarter | Regular |
Day Of Month | Regular |
Fiscal Year | Regular |
Day Name Of Week | Regular |
Day Of Year | Regular |
DateKey | Regular |
Date | Regular |
Fiscal Semester | Regular |
Day Number Of Week | Regular |
Calendar Semester | Regular |
Total: 15 column(s)
Click here to view details for table 'Date'

Collapse image Product Subcategory

Collapse image Columns

Name | Type | Description
Product Subcategory Name | Regular |
ProductSubcategoryKey | Regular |
ProductCategoryKey | Regular |
Total: 3 column(s)
Click here to view details for table 'Product Subcategory'

Collapse image Product Inventory

Collapse image Columns

Name | Type | Description
Units In | Regular |
Product-Date OverStocked | Regular |
Units Balance | Regular |
Product-Date Max Inventory Value | Regular |
Product-Date Negative Stock | Regular |
Unit Cost | Regular |
DateKey | Regular |
Product-Date Inventory Value | Regular |
Movement Date | Regular |
Product-Date UnderStocked | Regular |
Units Out | Regular |
ProductKey | Regular |
Product-Date Optimal Inventory Value | Regular |
Total: 13 column(s)
Click here to view details for table 'Product Inventory'

Collapse image Product Category

Collapse image Columns

Name | Type | Description
Product Category Name | Regular |
ProductCategoryKey | Regular |
Total: 2 column(s)
Click here to view details for table 'Product Category'
Total: 5 table(s)

Collapse image See also

About this documentation


Perspective: Internet Operation

Collapse image Perspective properties

Property | Value
Date created | 7/25/2014 9:51:55 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:55 PM

Collapse image Tables

Collapse image Product

Collapse image Columns

Name | Type | Description
Product SubCategory Name | Regular |
Style | Regular |
Model Name | Regular |
Product Name | Regular |
Product Start Date | Regular |
Weight Unit Code | Regular |
Safety Stock Level | Regular |
Product Id | Regular |
Standard Cost | Regular |
Color | Regular |
Days To Manufacture | Regular |
Dealer Price | Regular |
ProductKey | Regular |
LargePhoto | Regular |
Size | Regular |
Is Finished Goods | Regular |
Description | Regular |
Product Line | Regular |
Size Unit Code | Regular |
List Price | Regular |
Class | Regular |
Size Range | Regular |
Reorder Point | Regular |
Product Status | Regular |
Weight | Regular |
ProductSubcategoryKey | Regular |
Product Category Name | Regular |
Product End Date | Regular |
Total: 28 column(s)
Click here to view details for table 'Product'

Collapse image Date

Collapse image Columns

Name | Type | Description
Month Name | Regular |
Calendar Quarter | Regular |
Month | Regular |
Week Of Year | Regular |
Calendar Year | Regular |
Fiscal Quarter | Regular |
Day Of Month | Regular |
Fiscal Year | Regular |
Day Name Of Week | Regular |
Day Of Year | Regular |
DateKey | Regular |
Date | Regular |
Fiscal Semester | Regular |
Day Number Of Week | Regular |
Calendar Semester | Regular |
Total: 15 column(s)
Click here to view details for table 'Date'

Collapse image Promotion

Collapse image Columns

Name | Type | Description
Promotion Name | Regular |
Max Quantity | Regular |
Promotion Type | Regular |
Promotion Start Date | Regular |
Min Quantity | Regular |
Promotion Category | Regular |
DiscountPct | Regular |
PromotionKey | Regular |
Promotion End Date | Regular |
Total: 9 column(s)
Click here to view details for table 'Promotion'

Collapse image Internet Sales

Collapse image Columns

Name | Type | Description
Carrier Tracking Number | Regular |
Order Date | Regular |
Sales Order Line Number | Regular |
CustomerKey | Regular |
Gross Profit | Regular |
Due Date | Regular |
Sales Order Number | Regular |
Discount Amount | Regular |
Sales Amount | Regular |
PromotionKey | Regular |
Customer PO Number | Regular |
ProductKey | Regular |
Unit Price | Regular |
Freight | Regular |
Total Product Cost | Regular |
CurrencyKey | Regular |
ShipDateKey | Regular |
Product Standard Cost | Regular |
Extended Amount | Regular |
Order Quantity | Regular |
Revision Number | Regular |
SalesTerritoryKey | Regular |
Tax Amount | Regular |
OrderDateKey | Regular |
Unit Price Discount Pct | Regular |
Ship Date | Regular |
DueDateKey | Regular |
Total: 27 column(s)
Click here to view details for table 'Internet Sales'

Collapse image Product Subcategory

Collapse image Columns

Name | Type | Description
Product Subcategory Name | Regular |
ProductSubcategoryKey | Regular |
ProductCategoryKey | Regular |
Total: 3 column(s)
Click here to view details for table 'Product Subcategory'

Collapse image Geography

Collapse image Columns

Name | Type | Description
City | Regular |
State Province Name | Regular |
Country Region Code | Regular |
State Province Code | Regular |
SalesTerritoryKey | Regular |
GeographyKey | Regular |
Country Region Name | Regular |
Postal Code | Regular |
Total: 8 column(s)
Click here to view details for table 'Geography'

Collapse image Customer

Collapse image Columns

Name | Type | Description
CustomerKey | Regular |
Number of Children At Home | Regular |
Middle Name | Regular |
Name Style | Regular |
Date Of First Purchase | Regular |
Address Line 2 | Regular |
GeographyKey | Regular |
Yearly Income | Regular |
Marital Status | Regular |
Phone | Regular |
Email Address | Regular |
Gender | Regular |
Occupation | Regular |
Address Line 1 | Regular |
Total Cars Owned | Regular |
Total Children | Regular |
Suffix | Regular |
First Name | Regular |
Birth Date | Regular |
Education | Regular |
Last Name | Regular |
Commute Distance | Regular |
Customer Id | Regular |
Title | Regular |
Owns House | Regular |
Total: 25 column(s)
Click here to view details for table 'Customer'

Collapse image Currency

Collapse image Columns

Name | Type | Description
CurrencyKey | Regular |
Currency Code | Regular |
CurrencyName | Regular |
Total: 3 column(s)
Click here to view details for table 'Currency'

Collapse image Sales Territory

Collapse image Columns

Name | Type | Description
Sales Territory Region | Regular |
SalesTerritoryKey | Regular |
Sales Territory Country | Regular |
Sales Territory Group | Regular |
Sales Territory Image | Regular |
Total: 5 column(s)
Click here to view details for table 'Sales Territory'

Collapse image Product Category

Collapse image Columns

Name | Type | Description
Product Category Name | Regular |
ProductCategoryKey | Regular |
Total: 2 column(s)
Click here to view details for table 'Product Category'
Total: 10 table(s)

Collapse image See also

About this documentation


Perspective: Reseller Operation

Collapse image Perspective properties

Property | Value
Date created | 7/25/2014 9:51:55 PM
Is loaded | True
Last schema update | 7/25/2014 9:51:55 PM

Collapse image Tables

Collapse image Product

Collapse image Columns

Name | Type | Description
Product SubCategory Name | Regular |
Style | Regular |
Model Name | Regular |
Product Name | Regular |
Product Start Date | Regular |
Weight Unit Code | Regular |
Safety Stock Level | Regular |
Product Id | Regular |
Standard Cost | Regular |
Color | Regular |
Days To Manufacture | Regular |
Dealer Price | Regular |
ProductKey | Regular |
LargePhoto | Regular |
Size | Regular |
Is Finished Goods | Regular |
Description | Regular |
Product Line | Regular |
Size Unit Code | Regular |
List Price | Regular |
Class | Regular |
Size Range | Regular |
Reorder Point | Regular |
Product Status | Regular |
Weight | Regular |
ProductSubcategoryKey | Regular |
Product Category Name | Regular |
Product End Date | Regular |
Total: 28 column(s)
Click here to view details for table 'Product'

Collapse image Date

Collapse image Columns

Name | Type | Description
Month Name | Regular |
Calendar Quarter | Regular |
Month | Regular |
Week Of Year | Regular |
Calendar Year | Regular |
Fiscal Quarter | Regular |
Day Of Month | Regular |
Fiscal Year | Regular |
Day Name Of Week | Regular |
Day Of Year | Regular |
DateKey | Regular |
Date | Regular |
Fiscal Semester | Regular |
Day Number Of Week | Regular |
Calendar Semester | Regular |
Total: 15 column(s)
Click here to view details for table 'Date'

Collapse image Promotion

Collapse image Columns

Name | Type | Description
Promotion Name | Regular |
Max Quantity | Regular |
Promotion Type | Regular |
Promotion Start Date | Regular |
Min Quantity | Regular |
Promotion Category | Regular |
DiscountPct | Regular |
PromotionKey | Regular |
Promotion End Date | Regular |
Total: 9 column(s)
Click here to view details for table 'Promotion'

Collapse image Product Subcategory

Collapse image Columns

Name | Type | Description
Product Subcategory Name | Regular |
ProductSubcategoryKey | Regular |
ProductCategoryKey | Regular |
Total: 3 column(s)
Click here to view details for table 'Product Subcategory'

Collapse image Employee

Collapse image Columns

Name | Type | Description
ParentEmployeeKey | Regular |
Middle Name | Regular |
NameStyle | Regular |
Hire Date | Regular |
Marital Status | Regular |
Pay Frequency | Regular |
Phone | Regular |
Email | Regular |
Gender | Regular |
Vacation Hours | Regular |
Employee Id | Regular |
Is Current | Regular |
Login | Regular |
First Name | Regular |
Is Salaried | Regular |
Base Rate | Regular |
Birth Date | Regular |
Sick Leave Hours | Regular |
Last Name | Regular |
SalesTerritoryKey | Regular |
Status | Regular |
Emergency Contact Name | Regular |
Title | Regular |
Department Name | Regular |
Emergency Contact Phone | Regular |
EmployeeKey | Regular |
End Date | Regular |
Is Sales Person | Regular |
Employee Photo | Regular |
Start Date | Regular |
Total: 30 column(s)
Click here to view details for table 'Employee'

Collapse image Geography

Collapse image Columns

Name | Type | Description
City | Regular |
State Province Name | Regular |
Country Region Code | Regular |
State Province Code | Regular |
SalesTerritoryKey | Regular |
GeographyKey | Regular |
Country Region Name | Regular |
Postal Code | Regular |
Total: 8 column(s)
Click here to view details for table 'Geography'

Collapse image Reseller Sales

Collapse image Columns

Name | Type | Description
Sales Order Line Number | Regular |
Due Date | Regular |
Gross Profit | Regular |
Sales Order Number | Regular |
Discount Amount | Regular |
Sales Amount | Regular |
PromotionKey | Regular |
ProductKey | Regular |
Reseller PO Number | Regular |
Unit Price | Regular |
Freight | Regular |
Total Product Cost | Regular |
CurrencyKey | Regular |
ShipDateKey | Regular |
Product Standard Cost | Regular |
Extended Amount | Regular |
Order Quantity | Regular |
Revision Number | Regular |
SalesTerritoryKey | Regular |
Tax Amount | Regular |
OrderDateKey | Regular |
Unit Price Discount Pct | Regular |
Ship Date | Regular |
ResellerKey | Regular |
DueDateKey | Regular |
EmployeeKey | Regular |
Carrier Tracking Number | Regular |
Order Date | Regular |
Total: 28 column(s)
Click here to view details for table 'Reseller Sales'

Collapse image Reseller

Collapse image Columns

Name | Type | Description
Year Opened | Regular |
Order Month | Regular |
Business Type | Regular |
Annual Sales | Regular |
Number Employees | Regular |
Reseller Id | Regular |
Address Line 2 | Regular |
GeographyKey | Regular |
Reseller Phone | Regular |
ResellerKey | Regular |
Min Payment Type | Regular |
Address Line 1 | Regular |
Bank Name | Regular |
Annua Revenue | Regular |
Reseller Name | Regular |
Min Payment Amount | Regular |
Product Line | Regular |
Last Order Year | Regular |
First Order Year | Regular |
Order Frequency | Regular |
Total: 20 column(s)
Click here to view details for table 'Reseller'

Collapse image Sales Quota

Collapse image Columns

Name | Type | Description
Calendar Quarter | Regular |
Sales Amount Quota | Regular |
Calendar Year | Regular |
Date | Regular |
DateKey | Regular |
EmployeeKey | Regular |
SalesQuotaKey | Regular |
Total: 7 column(s)
Click here to view details for table 'Sales Quota'

Collapse image Currency

Collapse image Columns

Name | Type | Description
CurrencyKey | Regular |
Currency Code | Regular |
CurrencyName | Regular |
Total: 3 column(s)
Click here to view details for table 'Currency'

Collapse image Sales Territory

Collapse image Columns

Name | Type | Description
Sales Territory Region | Regular |
SalesTerritoryKey | Regular |
Sales Territory Country | Regular |
Sales Territory Group | Regular |
Sales Territory Image | Regular |
Total: 5 column(s)
Click here to view details for table 'Sales Territory'

Collapse image Product Category

Collapse image Columns

Name | Type | Description
Product Category Name | Regular |
ProductCategoryKey | Regular |
Total: 2 column(s)
Click here to view details for table 'Product Category'
Total: 12 table(s)

Collapse image See also

About this documentation


Roles

List of roles

Collapse image Roles

Name | Permissions | Date created | Last schema update | Description
Users | DatabasePermission | 7/25/2014 9:51:54 PM | 7/25/2014 9:51:54 PM | All allowed users to query the model
Admins | DatabasePermission 1 | 7/25/2014 9:51:54 PM | 7/25/2014 9:51:54 PM | All administrators
Analysts | DatabasePermission 2 | 7/25/2014 9:51:54 PM | 7/25/2014 9:51:54 PM | All users responsible for the status of the model
Operators | DatabasePermission 3 | 7/25/2014 9:51:54 PM | 7/25/2014 9:51:54 PM | All users responsible for updating the data
Total: 4 role(s)

Collapse image See also

About this documentation


Role: Users

Collapse image Role properties

Property | Value
Date created | 7/25/2014 9:51:54 PM
Description | All allowed users to query the model
Is loaded | True
Last schema update | 7/25/2014 9:51:54 PM
Permissions | DatabasePermission

Collapse image See also

About this documentation


Role: Admins

Collapse image Role properties

Property | Value
Date created | 7/25/2014 9:51:54 PM
Description | All administrators
Is loaded | True
Last schema update | 7/25/2014 9:51:54 PM
Permissions | DatabasePermission 1

Collapse image See also

About this documentation


Role: Analysts

Collapse image Role properties

Property | Value
Date created | 7/25/2014 9:51:54 PM
Description | All users responsible for the status of the model
Is loaded | True
Last schema update | 7/25/2014 9:51:54 PM
Permissions | DatabasePermission 2

Collapse image See also

About this documentation


Role: Operators

Collapse image Role properties

Property | Value
Date created | 7/25/2014 9:51:54 PM
Description | All users responsible for updating the data
Is loaded | True
Last schema update | 7/25/2014 9:51:54 PM
Permissions | DatabasePermission 3

Collapse image See also

About this documentation


Reporting Services

Collapse image Reporting items index

Name
AdventureWorks Sample Reports 2012.rptproj
AdventureWorks.rds
Company Sales.rdl

Collapse image See also

About this documentation


Project: AdventureWorks Sample Reports 2012.rptproj

Collapse image Project properties

Property | Value
Full path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\AdventureWorks Sample Reports 2012.rptproj

Collapse image Reports

Name | Description
Company Sales.rdl | Adventure Works sales by quarter and product category. This report illustrates the use of a matrix data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of background images.
Customers_Near_Stores.rdl | Purpose: Drillthrough report from store markers in Sales_by_Region_2008R2. Displays information about customers who live within the specified number of miles from a store. The store geolocation is a String parameter that contains a Well Known Text (WKT) value.
Employee_Sales_Summary.rdl | Purpose: Summary report. Displays year over year sales for all categories, for individual categories, and for quotas. Includes charts (line, sparkline, column with scale breaks, databar), tablix (toggle rows, row group, indicators at table and group level), group and report variables, rectangle containers, shared datasets, shared data source, custom code for chart line color, bookmarks, drilthrough action, multivalue parameters, and parameters to control conditional visibility of text boxes and toggle rows.
Product Catalog.rdl | Adventure Works full product catalog with pictures. This report illustrates the use of embedded images, database images, page breaks, page footers, tables, conditional formatting, and a document map.
Product Line Sales.rdl | Adventure Works top five sales people and stores. This report illustrates a dataset with queries containing the TOP clause. It also illustrates the use of tables, charts, parameters, calculated fields, and drillthrough links.
Sales Order Detail.rdl | Detail of an individual Adventure Works order. This report can be accessed as a drillthrough report from the Employee Sales Summary and Territory Sales drilldown report. This report illustrates the use of lists, tables, parameters, and expressions.
Sales Reason Comparisons.rdl | Shows sales reason comparison data from an Analysis Services cube. Also illustrates the use of a multivalued parameter. The Sales Reason Comparisons report requires SQL Server Analysis Services and the AdventureWorks Analysis Services database.
Sales_by_Region.rdl | Purpose: Map report. For each state, displays sales totals for individuals, sales totals for reseller stores, and store locations. Includes the US map from the map gallery, analytical data from a dataset, polygon layer (one for each state), polygon fill for no sales, polygon color rules based on individual sales, markers for stores, marker colors based on store sales, marker drillthrough action, multiple map titles and legends, and use of Lookup function.
Store_Contacts.rdl | Purpose: Subreport. Displays store contact information. Used in Sales_Order_Details_2008R2 to display multiple store contacts. Includes page header and footer items that are not included when the report is rendered as a subreport.
Territory Sales Drilldown.rdl | Adventure Works sales by territory. This report drills down through salesperson and order number with drillthrough to individual orders. This report illustrates the use of a table data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of drillthrough links and conditional formatting.
Total: 10 report(s)

Collapse image Shared datasets

Name | Parameter count | Shared data source reference
DataSet1.rsd | 1 |
EmployeeSalesDetail.rsd | 3 |
EmployeeSalesYearOverYear.rsd | 3 |
EmpSalesMonth.rsd | 3 |
SalesEmployees.rsd | 1 |
Total: 5 shared dataset(s)

Collapse image Shared data sources

Name | Data source type
AdventureWorks.rds | SQL
AdventureWorksAS.rds | OLEDB-MD
DataSource1.rds | SQLAZURE
DataSource2.rds | SQL
DataSource3.rds | OLEDB-MD
Total: 5 shared data source(s)

Collapse image See also

About this documentation


List of Reports

Collapse image Reports index

Name | Description
Company Sales.rdl | Adventure Works sales by quarter and product category. This report illustrates the use of a matrix data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of background images.
Customers_Near_Stores.rdl | Purpose: Drillthrough report from store markers in Sales_by_Region_2008R2. Displays information about customers who live within the specified number of miles from a store. The store geolocation is a String parameter that contains a Well Known Text (WKT) value.
Employee_Sales_Summary.rdl | Purpose: Summary report. Displays year over year sales for all categories, for individual categories, and for quotas. Includes charts (line, sparkline, column with scale breaks, databar), tablix (toggle rows, row group, indicators at table and group level), group and report variables, rectangle containers, shared datasets, shared data source, custom code for chart line color, bookmarks, drilthrough action, multivalue parameters, and parameters to control conditional visibility of text boxes and toggle rows.
Product Catalog.rdl | Adventure Works full product catalog with pictures. This report illustrates the use of embedded images, database images, page breaks, page footers, tables, conditional formatting, and a document map.
Product Line Sales.rdl | Adventure Works top five sales people and stores. This report illustrates a dataset with queries containing the TOP clause. It also illustrates the use of tables, charts, parameters, calculated fields, and drillthrough links.
Sales Order Detail.rdl | Detail of an individual Adventure Works order. This report can be accessed as a drillthrough report from the Employee Sales Summary and Territory Sales drilldown report. This report illustrates the use of lists, tables, parameters, and expressions.
Sales Reason Comparisons.rdl | Shows sales reason comparison data from an Analysis Services cube. Also illustrates the use of a multivalued parameter. The Sales Reason Comparisons report requires SQL Server Analysis Services and the AdventureWorks Analysis Services database.
Sales_by_Region.rdl | Purpose: Map report. For each state, displays sales totals for individuals, sales totals for reseller stores, and store locations. Includes the US map from the map gallery, analytical data from a dataset, polygon layer (one for each state), polygon fill for no sales, polygon color rules based on individual sales, markers for stores, marker colors based on store sales, marker drillthrough action, multiple map titles and legends, and use of Lookup function.
Store_Contacts.rdl | Purpose: Subreport. Displays store contact information. Used in Sales_Order_Details_2008R2 to display multiple store contacts. Includes page header and footer items that are not included when the report is rendered as a subreport.
Territory Sales Drilldown.rdl | Adventure Works sales by territory. This report drills down through salesperson and order number with drillthrough to individual orders. This report illustrates the use of a table data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of drillthrough links and conditional formatting.
Total: 10 report(s)

Collapse image See also

About this documentation


Report: Company Sales.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Adventure Works sales by quarter and product category. This report illustrates the use of a matrix data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of background images.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Company Sales.rdl
Report unit type | Inch
Width | 3.22917in

Collapse image Report object index

Objects | Total
Parameters | 0
Embeded images | 1
Data sources | 1
Datasets | 1
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

No parameters exist

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
logoback | 438 x 194 | image/jpeg
Total: 1 embeded image(s)

Collapse image See also

About this documentation


Embedded image: logoback

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | logoback
Size (width x height) | 438 x 194
Type | image/jpeg

Collapse image See also

About this documentation


List of Data sources

Collapse image Data sources

Name | Data source type
AdventureWorks |
Total: 1 datasource(s)

Collapse image See also

About this documentation


Data source: AdventureWorks

Collapse image Data source properties

Property | Value
Referenced data source | AdventureWorks
Security type | None
Data source type |
Connection string |
Use single transaction | False

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
Sales |  | AdventureWorks | Query | 0 | 5 | 0
Total: 1 dataset(s)

Collapse image See also

About this documentation


Dataset: Sales

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
ProdCat | ProdCat | System.String |  |  |
SubCat | SubCat | System.String |  |  |
OrderYear | OrderYear | System.Int32 |  |  |
OrderQtr | OrderQtr | System.String |  |  |
Sales | Sales | System.Decimal |  |  |
Total: 5 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SET DATEFORMAT mdy
SELECT      PC.Name AS ProdCat, PS.Name AS SubCat, DATEPART(yy, SOH.OrderDate) AS OrderYear, 'Q' + DATENAME(qq, SOH.OrderDate) AS OrderQtr,
            SUM(SOD.UnitPrice * SOD.OrderQty) AS Sales
FROM        Production.ProductSubcategory PS INNER JOIN
            Sales.SalesOrderHeader SOH INNER JOIN
            Sales.SalesOrderDetail SOD ON SOH.SalesOrderID = SOD.SalesOrderID INNER JOIN
            Production.Product P ON SOD.ProductID = P.ProductID ON PS.ProductSubcategoryID = P.ProductSubcategoryID INNER JOIN
            Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE       (SOH.OrderDate BETWEEN '1/1/2002' AND '12/31/2009')
GROUP BY    DATEPART(yy, SOH.OrderDate), PC.Name, PS.Name, 'Q' + DATENAME(qq, SOH.OrderDate), PS.ProductSubcategoryID

Collapse image See also

About this documentation


Page header

Collapse image Page header properties

Property | Value
Heigth | 1in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page header items

No page header items exist

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 1.8125in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
SalesMatrix | Tablix |  |
Title | Textbox |  |
Total: 2 page body item(s)

Collapse image See also

About this documentation


Tablix: SalesMatrix

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | Sales
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 1.0625in, 0.0625in
Repeat column headers | True
Repeat row headers | True
Size (width, height) | 3.125in, 0.75in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: Title

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Adventure Works 2002 - 2003 Sales | Tahoma | 18pt |  | ExtraBold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 1in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page footer items

No page footer items exist

Collapse image See also

About this documentation


Report: Customers_Near_Stores.rdl

Collapse image Report properties

Property | Value
Author | Mary Lingel MSFT
Auto refresh | 0
Description | Purpose: Drillthrough report from store markers in Sales_by_Region_2008R2. Displays information about customers who live within the specified number of miles from a store. The store geolocation is a String parameter that contains a Well Known Text (WKT) value.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Customers_Near_Stores.rdl
Report unit type | Inch
Width | 9.78in

Collapse image Report object index

Objects | Total
Parameters | 3
Embeded images | 3
Data sources | 1
Datasets | 2
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
GeoLocation | String | Store location? | False | False | False | True
Radius | Integer | Distance in miles? | False | False | False | True
ShowAll | Boolean | Show all information? | False | False | False | True
Total: 3 parameter(s)

Collapse image See also

About this documentation


Report parameter: GeoLocation

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | String
Has default value | True
Hidden | False
Name | GeoLocation
Nullable | False
Prompt | Store location?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | POINT (-82.4151596338717 40.7459610884615)
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: Radius

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | False
Name | Radius
Nullable | False
Prompt | Distance in miles?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 100
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: ShowAll

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Boolean
Has default value | True
Hidden | False
Name | ShowAll
Nullable | False
Prompt | Show all information?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | false
Total: 1 default value(s)

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
AdventureWorksLogo | 362 x 92 | image/jpeg
ID20160607_132817 | 1028 x 625 | image/png
ID20160607_131946 | 1023 x 635 | image/png
Total: 3 embeded image(s)

Collapse image See also

About this documentation


Embedded image: AdventureWorksLogo

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | AdventureWorksLogo
Size (width x height) | 362 x 92
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: ID20160607_132817

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | ID20160607_132817
Size (width x height) | 1028 x 625
Type | image/png

Collapse image See also

About this documentation


Embedded image: ID20160607_131946

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | ID20160607_131946
Size (width x height) | 1023 x 635
Type | image/png

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
CustomerLocations |  | AdventureWorks | Query | 2 | 13 | 0
StoreLocation |  | AdventureWorks | Query | 0 | 4 | 0
Total: 2 dataset(s)

Collapse image See also

About this documentation


Dataset: CustomerLocations

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@GeoLocation
@Radius
Total: 2 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
CustomerID | CustomerID | System.Int32 |  |  |
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
Name1 | Name1 | System.String |  |  |
Name2 | Name2 | System.String |  |  |
EmailAddress | EmailAddress | System.String |  |  |
City | City | System.String |  |  |
PostalCode | PostalCode | System.String |  |  |
StateProvince | StateProvince | System.String |  |  |
StateProvinceCode | StateProvinceCode | System.String |  |  |
DistanceinMiles | DistanceinMiles | System.Double |  |  |
SpatialLocation | SpatialLocation | Microsoft.SqlServer.Types.SqlGeography |  |  |
NumberCarsOwned | NumberCarsOwned | System.Int32 |  |  |
CommuteDistance | CommuteDistance | System.String |  |  |
Total: 13 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT c.CustomerID, c.PersonID AS BusinessEntityID, p.FirstName AS Name1, p.LastName AS Name2, ea.EmailAddress, ad.City, ad.PostalCode,
                  sp.Name AS StateProvince, sp.StateProvinceCode, ad.SpatialLocation.STDistance(@GeoLocation) / 1609.344 AS DistanceinMiles, ad.SpatialLocation,
                  p.Demographics.value('declare namespace awns="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey"; (awns:IndividualSurvey/awns:NumberCarsOwned) [1]',
                   'int') AS NumberCarsOwned,
                  p.Demographics.value('declare namespace awns="http://schemas.microsoft.com/sqlserver/2004/07/adventure-works/IndividualSurvey"; (awns:IndividualSurvey/awns:CommuteDistance) [1]',
                   'varchar(30)') AS CommuteDistance
FROM     Sales.Customer AS c INNER JOIN
                  Person.Person AS p ON p.BusinessEntityID = c.PersonID INNER JOIN
                  Person.BusinessEntityAddress AS a ON a.BusinessEntityID = p.BusinessEntityID INNER JOIN
                  Person.AddressType AS t ON a.AddressTypeID = t.AddressTypeID INNER JOIN
                  Person.Address AS ad ON ad.AddressID = a.AddressID INNER JOIN
                  Person.EmailAddress AS ea ON ea.BusinessEntityID = p.BusinessEntityID INNER JOIN
                  Person.StateProvince AS sp ON sp.StateProvinceID = ad.StateProvinceID
WHERE  (c.StoreID IS NULL) AND (t.Name = N'Home') AND (sp.CountryRegionCode = N'US') AND (ad.SpatialLocation.STDistance(@GeoLocation) / 1609.344 < @Radius)

Collapse image See also

About this documentation


Dataset: StoreLocation

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
Store | Store | System.String |  |  |
PostalCode | PostalCode | System.String |  |  |
GeoLocation | GeoLocation | System.String |  |  |
Total: 4 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT
    [StoreID] as BusinessEntityID
    , s.Name as Store
   -- , t.Name as AddressType -- Main Office or Shipping
   , ad.PostalCode
   -- , sp.CountryRegionCode
   --, sp.Name as StateProvince
   --, sp.StateProvinceCode
   , ad.SpatialLocation.ToString() as GeoLocation
  FROM [Sales].[Customer] c
    INNER JOIN Sales.Store s ON s.BusinessEntityID = c.StoreID
    INNER JOIN Person.BusinessEntityAddress a ON a.BusinessEntityID = s.BusinessEntityID
    INNER JOIN Person.AddressType t ON a.AddressTypeID=t.AddressTypeID
    INNER JOIN Person.[Address] ad ON ad.AddressID = a.AddressID
    INNER JOIN Person.StateProvince sp ON sp.StateProvinceID = ad.StateProvinceID
 WHERE  -- PersonID IS NULL means Customer is a store
   PersonID IS NULL
   AND t.Name = N'Main Office'
   AND sp.CountryRegionCode = N'US'

Collapse image See also

About this documentation


Page header

Collapse image Page header properties

Property | Value
Heigth | 2.38417in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color | LightGrey

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style | Dashed
Width | 1pt

Collapse image Page header items

Name | Item type | Height | ZIndex
ReportName |  |  |
tbBackInstructions |  |  |
tbTitle |  |  |
Rectangle1 |  |  |
Total: 4 page header item(s)

Collapse image See also

About this documentation


Textbox: ReportName

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Globals!ReportName |  |  | Italic |  |  | CornflowerBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbBackInstructions

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
To return to the main report, use the browser |  |  |  |  |  | Brown
Back |  |  |  | Bold |  | Brown
button. |  |  |  |  |  | Brown
Total: 3 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbTitle

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Demographics for the |  | 12pt |  |  |  | Brown
=CountDistinct(Fields!CustomerID.Value,"CustomerLocations") |  | 12pt |  |  |  | Brown
 |  | 12pt |  |  |  | Brown
=IIF(CountDistinct(Fields!CustomerID.Value,"CustomerLocations")=1,"Customer","Customers") |  | 12pt |  | Normal |  | Brown
living within |  | 12pt |  |  |  | Brown
=Parameters!Radius.Value |  | 12pt |  |  |  | Brown
miles of the store |  | 12pt |  |  |  | Brown
=Parameters!GeoLocation.Label |  | 12pt |  |  |  | Brown
 |  | 12pt |  |  |  | Brown
Grouped by Commute Distance |  |  | Italic |  |  | Brown
Total: 10 paragraph(s)

Collapse image See also

About this documentation


Rectangle: Rectangle1

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 1.11111in, 1.72792in
Size (width, height) | 2.85417in, 1.1793in
ZIndex | 5

Collapse image See also

About this documentation


Rectangle: Rectangle2

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.08555in, 0.50597in
Size (width, height) | 2in, 1in
ZIndex | 0

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 8.03125in

Collapse image Style

Property | Value
Background color | Indigo

Collapse image Background image

Property | Value
Background repeat | RepeatX
MIME type | image/bmp
Source | Embedded
Value | ID20160607_132817

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
tblxTable_Demographics | Tablix |  |
Tablix1 | Tablix |  |
Rectangle3 | Rectangle |  |
Tablix2 | Tablix |  |
Chart1 | Chart |  |
DataBar1 | Chart |  |
Sparkline1vds | Chart |  |
Rectangle6 | Rectangle |  |
Total: 8 page body item(s)

Collapse image See also

About this documentation


Tablix: tblxTable_Demographics

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | CustomerLocations
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.04167in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 6.5in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Tablix: Tablix1

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name |
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.61458in, 4.155in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Rectangle: Rectangle3

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.70833in, 1.51958in
Size (width, height) | 0.35417in, 0.40625in
ZIndex | 3

Collapse image See also

About this documentation


Tablix: Tablix2

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name |
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.70833in, 2.3068in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 0.54167in, 0.5625in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Chart: Chart1

Collapse image Chart properties

Property | Value
Border color default | LightGrey
Border style default | Solid
Dataset name |
Chart type |
Location (top, left) | 1.88542in, 0.11333in
Name | Chart1
No data message |
No rows message |
Palette | BrightPastel
Size (width, height) | 3in, 2in
ZIndex | 7

Collapse image Chart titles

Name | Caption | Position | Text order
Default | Chart Title |  |
Total: 1 chart title(s)

Collapse image Chart legends

Name | Title | Position | Layout
Default |  |  |
Total: 1 chart legends(s)

Collapse image Chart values

No chart values exist

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Chart: DataBar1

Collapse image Chart properties

Property | Value
Border color default | LightGrey
Border style default | Solid
Dataset name | StoreLocation
Chart type |
Location (top, left) | 3.47917in, 7.42583in
Name | DataBar1
No data message |
No rows message |
Palette | Excel
Size (width, height) | 1.5in, 0.5in
ZIndex | 10

Collapse image Chart titles

No chart titles exist

Collapse image Chart legends

No chart legends exist

Collapse image Chart values

No chart values exist

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Chart: Sparkline1vds

Collapse image Chart properties

Property | Value
Border color default | LightGrey
Border style default | Solid
Dataset name | StoreLocation
Chart type |
Location (top, left) | 4.53125in, 6.60292in
Name | Sparkline1vds
No data message |
No rows message |
Palette | Excel
Size (width, height) | 1.5in, 1in
ZIndex | 11

Collapse image Chart titles

No chart titles exist

Collapse image Chart legends

No chart legends exist

Collapse image Chart values

No chart values exist

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Rectangle: Rectangle6

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 6.76042in, 2.16542in
Size (width, height) | 2.625in, 1.27083in
ZIndex | 13

Collapse image See also

About this documentation


Rectangle: Rectangle7

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.125in, 0.40402in
Size (width, height) | 2in, 1in
ZIndex | 0

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 1.30208in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color | Silver

Collapse image Background image

Property | Value
Background repeat | Repeat
MIME type | image/jpeg
Source | External
Value | =First(Fields!Name1.Value, "CustomerLocations")

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page footer items

Name | Item type | Height | ZIndex
tbDescription |  |  |
Rectangle5 |  |  |
Total: 2 page footer item(s)

Collapse image See also

About this documentation


Textbox: tbDescription

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Purpose: Drillthrough report from store markers in Sales_by_Region_2008R2. Displays information about customers who live within the specified number of miles from a store. The store geolocation is a String parameter that contains a Well Known Text (WKT) value. |  |  |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Rectangle: Rectangle5

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.125in, 6.45708in
Size (width, height) | 2in, 1in
ZIndex | 2

Collapse image See also

About this documentation


Report: Employee_Sales_Summary.rdl

Collapse image Report properties

Property | Value
Author | Mary Lingel MSFT
Auto refresh | 0
Description | Purpose: Summary report. Displays year over year sales for all categories, for individual categories, and for quotas. Includes charts (line, sparkline, column with scale breaks, databar), tablix (toggle rows, row group, indicators at table and group level), group and report variables, rectangle containers, shared datasets, shared data source, custom code for chart line color, bookmarks, drilthrough action, multivalue parameters, and parameters to control conditional visibility of text boxes and toggle rows.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Employee_Sales_Summary.rdl
Report unit type | Inch
Width | 7.35418in

Collapse image Report object index

Objects | Total
Parameters | 6
Embeded images | 1
Data sources | 1
Datasets | 5
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
ReportMonth | Integer | Report Month | False | False | False | True
ReportYear | Integer | Report Year | False | False | False | True
EmployeeID | Integer | Employee | False | False | False | True
ShowAll | Boolean | Show all information? | False | False | False | True
ExpandAllTableRows | Boolean | Expand all table rows? | False | False | False | True
CategoryQuota | Float | Category quotas (Accessories, Bikes, Clothing, Components): | False | False | False | False
Total: 6 parameter(s)

Collapse image See also

About this documentation


Report parameter: ReportMonth

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | False
Name | ReportMonth
Nullable | False
Prompt | Report Month
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 11
Item value 2 | 1
Item value 3 | 2
Item value 4 | 3
Item value 5 | 4
Item value 6 | 5
Item value 7 | 6
Item value 8 | 7
Item value 9 | 8
Item value 10 | 9
Item value 11 | 10
Item value 12 | 11
Item value 13 | 12
Total: 13 default value(s)

Collapse image See also

About this documentation


Report parameter: ReportYear

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | False
Name | ReportYear
Nullable | False
Prompt | Report Year
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 2007
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: EmployeeID

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | False
Name | EmployeeID
Nullable | False
Prompt | Employee
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 283
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: ExpandAllTableRows

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Boolean
Has default value | True
Hidden | False
Name | ExpandAllTableRows
Nullable | False
Prompt | Expand all table rows?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | false
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: CategoryQuota

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | True
Data type | Float
Has default value | False
Hidden | False
Name | CategoryQuota
Nullable | False
Prompt | Category quotas (Accessories, Bikes, Clothing, Components):
Used in Query | False

Collapse image Default values

No default values exist

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
AdventureWorksLogo | 362 x 92 | image/jpeg
Total: 1 embeded image(s)

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
EmployeeSalesYearOverYear | EmployeeSalesYearOverYear |  |  |  | 5 | 0
EmployeeSalesDetail | EmployeeSalesDetail |  |  |  | 9 | 0
EmpSalesMonth | EmpSalesMonth |  |  |  | 6 | 0
SalesEmployees | SalesEmployees |  |  |  | 3 | 0
CategoryQuotas |  | AdventureWorks | Query | 0 | 5 | 0
Total: 5 dataset(s)

Collapse image See also

About this documentation


Dataset: EmployeeSalesYearOverYear

Collapse image Dataset properties

Property | Value
Data source name |
Referenced data set | EmployeeSalesYearOverYear
Command type |

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Employee | Employee | System.String |  |  |
Year | Year | System.Int32 |  |  |
MonthNumber | MonthNumber | System.Int32 |  |  |
Month | Month | System.String |  |  |
Sales | Sales | System.Decimal |  |  |
Total: 5 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT        P.FirstName + ' ' + P.LastName AS Employee, DATEPART(Year, SOH.OrderDate) AS Year, DATEPART(Month, SOH.OrderDate) AS MonthNumber, DATENAME(Month,
                         SOH.OrderDate) AS Month, SUM(DET.LineTotal) AS Sales
FROM            Sales.SalesPerson AS SP INNER JOIN
                         Sales.SalesOrderHeader AS SOH ON SP.BusinessEntityID = SOH.SalesPersonID INNER JOIN
                         Sales.SalesOrderDetail AS DET ON SOH.SalesOrderID = DET.SalesOrderID INNER JOIN
                         Sales.SalesTerritory AS ST ON SP.TerritoryID = ST.TerritoryID INNER JOIN
                         HumanResources.Employee AS E ON SOH.SalesPersonID = E.BusinessEntityID INNER JOIN
                         Person.Person AS P ON P.BusinessEntityID = SP.BusinessEntityID
WHERE        (DATEPART(Year, SOH.OrderDate) <= @ReportYear - 1 OR
                         DATEPART(Year, SOH.OrderDate) = @ReportYear AND DATEPART(Month, SOH.OrderDate) <= @ReportMonth) AND (SOH.SalesPersonID = @EmployeeID)
GROUP BY P.FirstName + ' ' + P.LastName, SOH.SalesPersonID, DATEPART(Year, SOH.OrderDate), DATEPART(Month, SOH.OrderDate), DATENAME(Month, SOH.OrderDate)

Collapse image See also

About this documentation


Dataset: EmployeeSalesDetail

Collapse image Dataset properties

Property | Value
Data source name |
Referenced data set | EmployeeSalesDetail
Command type |

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Employee | Employee | System.String |  |  |
Subcategory | Subcategory | System.String |  |  |
Sales | Sales | System.Decimal |  |  |
SalesOrderID | SalesOrderID | System.Int32 |  |  |
SalesOrderNumber | SalesOrderNumber | System.String |  |  |
Product | Product | System.String |  |  |
OrderQty | OrderQty | System.Int32 |  |  |
UnitPrice | UnitPrice | System.Decimal |  |  |
Category | Category | System.String |  |  |
Total: 9 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT PER.FirstName + ' ' + PER.LastName AS Employee,
   PS.Name AS Subcategory, SUM(DET.LineTotal) AS Sales,
   SOH.SalesOrderID,  SOH.SalesOrderNumber,
   P.Name AS Product,
   SUM(DET.OrderQty) AS OrderQty, DET.UnitPrice,
   PC.Name AS Category
FROM Sales.SalesOrderHeader SOH
   INNER JOIN [Sales].[SalesPerson] SP ON SP.[BusinessEntityID] = SOH.[SalesPersonID]
   INNER JOIN Sales.SalesOrderDetail DET ON SOH.SalesOrderID = DET.SalesOrderID
   INNER JOIN [HumanResources].[Employee] E ON SOH.[SalesPersonID] = E.[BusinessEntityID]
   INNER JOIN [Person].[Person] PER ON PER.[BusinessEntityID] = SP.[BusinessEntityID]
   INNER JOIN Production.Product P ON DET.ProductID = P.ProductID
   INNER JOIN Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID
   INNER JOIN Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE (DATEPART(Year, SOH.OrderDate) = @ReportYear) AND
   (DATEPART(Month, SOH.OrderDate) = @ReportMonth) AND
    (SOH.SalesPersonID = @EmployeeID)
GROUP BY PER.FirstName + ' ' + PER.LastName,
   DATEPART(Month, SOH.OrderDate), SOH.SalesOrderID, SOH.SalesOrderNumber,
   P.Name, PS.Name, DET.UnitPrice, PC.Name

Collapse image See also

About this documentation


Dataset: EmpSalesMonth

Collapse image Dataset properties

Property | Value
Data source name |
Referenced data set | EmpSalesMonth
Command type |

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Employee | Employee | System.String |  |  |
Year | Year | System.Int32 |  |  |
MonthNumber | MonthNumber | System.Int32 |  |  |
Month | Month | System.String |  |  |
Category | Category | System.String |  |  |
Sales | Sales | System.Decimal |  |  |
Total: 6 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT PER.FirstName + ' ' + PER.LastName AS Employee,
   DATEPART(Year, SOH.OrderDate) AS [Year],
   DATEPART(Month, SOH.OrderDate) AS [MonthNumber],
   DATENAME(Month, SOH.OrderDate) AS [Month],
   PC.Name AS Category, SUM(DET.LineTotal) AS Sales
FROM Sales.SalesOrderHeader SOH
   INNER JOIN [Sales].[SalesPerson] SP ON SP.[BusinessEntityID] = SOH.[SalesPersonID]
   INNER JOIN Sales.SalesOrderDetail DET ON SOH.SalesOrderID = DET.SalesOrderID
   INNER JOIN [HumanResources].[Employee] E ON SOH.[SalesPersonID] = E.[BusinessEntityID]
   INNER JOIN [Person].[Person] PER ON PER.[BusinessEntityID] = SP.[BusinessEntityID]
   INNER JOIN Production.Product P ON DET.ProductID = P.ProductID
   INNER JOIN Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID
   INNER JOIN Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE
   (DATEPART(Year, SOH.OrderDate) <= @ReportYear)
   AND (DATEPART(Month, SOH.OrderDate) = @ReportMonth)
   AND (SOH.SalesPersonID = @EmployeeID)
GROUP BY PER.FirstName + ' ' + PER.LastName,
   DATEPART(Year, SOH.OrderDate), DATEPART(Month, SOH.OrderDate),
   DATENAME(Month, SOH.OrderDate), PC.Name

Collapse image See also

About this documentation


Dataset: SalesEmployees

Collapse image Dataset properties

Property | Value
Data source name |
Referenced data set | SalesEmployees
Command type |

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
Employee | Employee | System.String |  |  |
JobTitle | JobTitle | System.String |  |  |
Total: 3 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT s.[BusinessEntityID], p.[FirstName] + N' ' + p.LastName AS Employee, e.[JobTitle]
FROM [Sales].[SalesPerson] s
   INNER JOIN [HumanResources].[Employee] e ON e.[BusinessEntityID] = s.[BusinessEntityID]
   INNER JOIN [Person].[Person] p ON p.[BusinessEntityID] = s.[BusinessEntityID]

Collapse image See also

About this documentation


Dataset: CategoryQuotas

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
ID | ID | System.Int32 |  |  |
Category | Category | System.String |  |  |
Quota | Quota | System.Int32 |  |  |
PercentDeviation | PercentDeviation | System.Int32 |  |  |
QuotaF |  |  |  |  |
Total: 5 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT 1 as ID, 'Accessories' as Category,
   1000 as Quota, 25 as PercentDeviation
UNION SELECT 2 as ID, 'Bikes' as Category,
   70000 as Quota, 5 as PercentDeviation
UNION SELECT 3 as ID, 'Clothing' as Category,
   2500 as Quota, 20 as PercentDeviation
UNION SELECT 4 as ID, 'Components' as Category,
   20000 as Quota, 10 as PercentDeviation

Collapse image See also

About this documentation


Page header

Collapse image Page header properties

Property | Value
Heigth | 0.78in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page header items

Name | Item type | Height | ZIndex
ReportName |  |  |
Textbox5 |  |  |
Total: 2 page header item(s)

Collapse image See also

About this documentation


Textbox: Textbox5

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Sales Report for |  | 14pt |  |  |  | DarkBlue
=Parameters!EmployeeID.Label |  | 14pt |  |  |  | DarkBlue
=Parameters!ReportMonth.Label |  | 14pt |  |  |  | DarkBlue
, |  | 14pt |  |  |  | DarkBlue
=Parameters!ReportYear.Value |  | 14pt |  |  |  | DarkBlue
Total: 5 paragraph(s)

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 7.64458in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
tbToggle | Textbox |  |
tbScenarioText | Textbox |  |
Rectangle1 | Rectangle |  |
rectCharts | Rectangle |  |
rectMatrix | Rectangle |  |
rectSeasonalSales | Rectangle |  |
Total: 6 page body item(s)

Collapse image See also

About this documentation


Textbox: tbToggle

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Click + to view the scenario story. |  |  |  |  |  | CornflowerBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbScenarioText

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
As a salesperson for AdventureWorks, I want to know how my sales compare to seasonal sales in previous years. The |  |  |  |  |  | Brown
line |  |  |  |  | Underline | Blue
and |  |  |  |  |  | Brown
sparkline |  |  |  |  | Underline | Blue
charts show year over year sales for all categories . The |  |  |  |  |  | Brown
matrix |  |  |  |  | Underline | Blue
with indicators shows current sales compared to quotas. Change quota values on the reportviewer toolbar. The |  |  |  |  |  | Brown
column |  |  |  |  | Underline | Blue
and |  |  |  |  |  | Brown
databar |  |  |  |  | Underline | Blue
charts show sales in each category. |  |  |  |  |  | Brown
Total: 11 paragraph(s)

Collapse image See also

About this documentation


Rectangle: Rectangle1

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 6.63764in, 0.00001in
Size (width, height) | 6.35417in, 1.00694in
ZIndex | 2

Collapse image See also

About this documentation


Textbox: ParameterValues

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Report Month: [@ReportMonth] [@ReportMonth.Label] |  |  |  |  |  | Brown
Report Year: |  |  |  |  |  | Brown
=Parameters!ReportYear.Value |  |  |  |  |  | Brown
EmployeeID: [@EmployeeID] [@EmployeeID.Label] |  |  |  |  |  | Brown
Total: 4 paragraph(s)

Collapse image See also

About this documentation


Textbox: DataSourceandDatasets

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Data Source: |  |  |  |  |  | Brown
=DataSources!AdventureWorks.DataSourceReference |  |  |  |  |  | Brown
Dataset EmployeeSalesYearOverYear: |  |  |  |  |  | Brown
=DataSets!EmployeeSalesYearOverYear.CommandText |  |  |  |  |  | Brown
Dataset EmployeeSalesDetail: |  |  |  |  |  | Brown
=DataSets!EmployeeSalesDetail.CommandText |  |  |  |  |  | Brown
Dataset EmpSalesMonth: |  |  |  |  |  | Brown
=DataSets!EmpSalesMonth.CommandText |  |  |  |  |  | Brown
Dataset SalesEmployees: |  |  |  |  |  | Brown
=DataSets!SalesEmployees.CommandText |  |  |  |  |  | Brown
Total: 10 paragraph(s)

Collapse image See also

About this documentation


Rectangle: rectCharts

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.5in,
Size (width, height) | 3.11459in, 3.26042in
ZIndex | 3

Collapse image See also

About this documentation


Textbox: tbChartPurpose

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Compare seasonal sales by year. |  | 14pt |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Chart: Chart1

Collapse image Chart properties

Property | Value
Border color default | LightGrey
Border style default | Solid
Dataset name | EmployeeSalesYearOverYear
Chart type |
Location (top, left) | 0.27778in, 0.00001in
Name | Chart1
No data message |
No rows message |
Palette | BrightPastel
Size (width, height) | 3.11458in, 2.375in
ZIndex | 1

Collapse image Chart titles

Name | Caption | Position | Text order
Default | Yearly Sales Comparison |  |
Total: 1 chart title(s)

Collapse image Chart legends

Name | Title | Position | Layout
Default |  | BottomCenter |
Total: 1 chart legends(s)

Collapse image Chart values

No chart values exist

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Tablix: Tablix1

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | EmployeeSalesYearOverYear
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 2.68056in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.11459in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Rectangle: rectMatrix

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 0.51388in, 3.63417in
Size (width, height) | 3.60543in, 2.49307in
ZIndex | 4

Collapse image See also

About this documentation


Textbox: tbChartPurpose2

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Compare sales to quotas by category. |  | 14pt |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Tablix: Tablix2

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | EmployeeSalesDetail
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.29167in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.60543in, 2.20139in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: Textbox21

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Met |  |  |  | Bold |  | White
Quota? |  |  |  | Bold |  | White
Total: 2 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbMatrixQuotas

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Quota: |  | 8pt |  | Bold |  | White
=Variables!SumofAllParameterThresholds.Value |  | 8pt |  | Bold |  | White
Total: |  | 8pt |  | Bold |  | White
=Sum(Fields!Sales.Value) |  | 8pt |  | Bold |  | White
Total: 4 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbCategoryQuotas

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Quota: |  | 8pt |  |  |  |
=CDbl(Parameters!CategoryQuota.Value((Variables!IndextoCategoryQuota.Value)-1)) |  | 8pt |  |  |  |
- |  | 8pt |  |  |  |
=FormatPercent(Variables!PercentDeviation.Value,0) |  | 8pt |  |  |  |
: |  | 8pt |  |  |  |
=(1.0-Variables!PercentDeviation.Value) * CDec(Parameters!CategoryQuota.Value((Variables!IndextoCategoryQuota.Value)-1)) |  | 8pt |  |  |  |
+ |  | 8pt |  |  |  |
=FormatPercent(Variables!PercentDeviation.Value,0) |  | 8pt |  |  |  |
: |  | 8pt |  |  |  |
=(1.0+Variables!PercentDeviation.Value) * CDec(Parameters!CategoryQuota.Value((Variables!IndextoCategoryQuota.Value)-1)) |  | 8pt |  |  |  |
Total: 10 paragraph(s)

Collapse image See also

About this documentation


Rectangle: rectSeasonalSales

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 3.91666in, 0.00444in
Size (width, height) | 7.34974in, 2.5682in
ZIndex | 5

Collapse image See also

About this documentation


Chart: Chart2

Collapse image Chart properties

Property | Value
Border color default | LightGrey
Border style default | Solid
Dataset name | EmpSalesMonth
Chart type |
Location (top, left) | 0.32292in, 0.07419in
Name | Chart2
No data message |
No rows message |
Palette | BrightPastel
Size (width, height) | 3.39582in, 2.24528in
ZIndex | 0

Collapse image Chart titles

Name | Caption | Position | Text order
Default | =Parameters!ReportMonth.Label & " Sales Comparison" |  |
Total: 1 chart title(s)

Collapse image Chart legends

Name | Title | Position | Layout
Default |  | BottomCenter |
Total: 1 chart legends(s)

Collapse image Chart values

No chart values exist

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Tablix: Tablix3

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | EmpSalesMonth
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.35069in, 3.62973in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.72in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: tbChartPurpose3

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Compare seasonal sales for |  | 14pt |  |  |  | Brown
=Parameters!ReportMonth.Label |  | 14pt |  |  |  | Brown
for each category. |  | 14pt |  |  |  | Brown
Total: 3 paragraph(s)

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 1in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page footer items

Name | Item type | Height | ZIndex
tbDescription |  |  |
Total: 1 page footer item(s)

Collapse image See also

About this documentation


Textbox: tbDescription

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Purpose: Summary report. Displays year over year sales for all categories, for individual categories, and for quotas. Includes charts (line, sparkline, column with scale breaks, databar), tablix (toggle rows, row group, indicators at table and group level), group and report variables, rectangle containers, shared datasets, shared data source, custom code for chart line color, bookmarks, drilthrough action, multivalue parameters, and parameters to control conditional visibility of text boxes and toggle rows. |  |  |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Product Catalog.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Adventure Works full product catalog with pictures. This report illustrates the use of embedded images, database images, page breaks, page footers, tables, conditional formatting, and a document map.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Product Catalog.rdl
Report unit type | Inch
Width | 6.9375in

Collapse image Report object index

Objects | Total
Parameters | 0
Embeded images | 6
Data sources | 1
Datasets | 1
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
cover4 | 126 x 190 | image/jpeg
logopart | 176 x 75 | image/jpeg
logofull | 357 x 114 | image/jpeg
cover3 | 190 x 125 | image/jpeg
cover2 | 125 x 190 | image/jpeg
cover1 | 125 x 190 | image/jpeg
Total: 6 embeded image(s)

Collapse image See also

About this documentation


Embedded image: cover4

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | cover4
Size (width x height) | 126 x 190
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: logopart

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | logopart
Size (width x height) | 176 x 75
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: logofull

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | logofull
Size (width x height) | 357 x 114
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: cover3

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | cover3
Size (width x height) | 190 x 125
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: cover2

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | cover2
Size (width x height) | 125 x 190
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: cover1

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | cover1
Size (width x height) | 125 x 190
Type | image/jpeg

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
ProductCatalog |  | AdventureWorks | Query | 1 | 14 | 0
Total: 1 dataset(s)

Collapse image See also

About this documentation


Dataset: ProductCatalog

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@Language
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
ProdSubCat | ProdSubCat | System.String |  |  |
ProdModel | ProdModel | System.String |  |  |
ProdCat | ProdCat | System.String |  |  |
Description | Description | System.String |  |  |
LargePhoto | LargePhoto | System.Byte[] |  |  |
ProdName | ProdName | System.String |  |  |
ProductNumber | ProductNumber | System.String |  |  |
Color | Color | System.String |  |  |
Size | Size | System.String |  |  |
Weight | Weight | System.Decimal |  |  |
StandardCost | StandardCost | System.Decimal |  |  |
Style | Style | System.String |  |  |
Class | Class | System.String |  |  |
ListPrice | ListPrice | System.Decimal |  |  |
Total: 14 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT      PS.Name AS ProdSubCat, PM.Name AS ProdModel, PC.Name AS ProdCat, PD.Description, PP.LargePhoto, P.Name AS ProdName, P.ProductNumber,
            P.Color, P.Size, P.Weight, P.StandardCost, P.Style, P.Class, P.ListPrice
FROM        Production.Product P INNER JOIN
            Production.ProductSubcategory PS INNER JOIN
            Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID ON P.ProductSubcategoryID = PS.ProductSubcategoryID INNER JOIN
            Production.ProductProductPhoto PPP ON P.ProductID = PPP.ProductID INNER JOIN
            Production.ProductPhoto PP ON PPP.ProductPhotoID = PP.ProductPhotoID LEFT OUTER JOIN
            Production.ProductDescription PD INNER JOIN
            Production.ProductModel PM INNER JOIN
            Production.ProductModelProductDescriptionCulture PMPDCL ON PM.ProductModelID = PMPDCL.ProductModelID ON
            PD.ProductDescriptionID = PMPDCL.ProductDescriptionID ON P.ProductModelID = PM.ProductModelID
WHERE       (PMPDCL.CultureID = @Language)

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 9.25in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
ProductTable | Tablix |  |
Title | Textbox |  |
Total: 2 page body item(s)

Collapse image See also

About this documentation


Tablix: ProductTable

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | ProductCatalog
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 6.75in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 6.9375in, 2.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: Title

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Product Catalog |  | 20pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 0.4375in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page footer items

Name | Item type | Height | ZIndex
FooterBanner |  |  |
Total: 1 page footer item(s)

Collapse image See also

About this documentation


Rectangle: FooterBanner

Collapse image Rectangle properties

Property | Value
Border style default |
Location (top, left) | 0.0625in,
Size (width, height) | 6.9375in, 0.375in
ZIndex | 0

Collapse image See also

About this documentation


Textbox: PageNumber

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
="Page " & Globals.PageNumber |  | 9pt | Italic |  |  | White
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: OrderOnline

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
http://www.adventure-works.com |  | 9pt |  |  |  | White
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Product Line Sales.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Adventure Works top five sales people and stores. This report illustrates a dataset with queries containing the TOP clause. It also illustrates the use of tables, charts, parameters, calculated fields, and drillthrough links.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Product Line Sales.rdl
Report unit type | Inch
Width | 7in

Collapse image Report object index

Objects | Total
Parameters | 4
Embeded images | 2
Data sources | 1
Datasets | 4
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
ProductCategory | Integer | Category: | False | False | False | True
ProductSubcategory | Integer | Subcategory: | False | False | False | True
StartDate | DateTime | Start Date: | False | True | False | True
EndDate | DateTime | End Date: | False | True | False | True
Total: 4 parameter(s)

Collapse image See also

About this documentation


Report parameter: ProductCategory

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | False
Name | ProductCategory
Nullable | False
Prompt | Category:
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 1
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: ProductSubcategory

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | True
Data type | Integer
Has default value | True
Hidden | False
Name | ProductSubcategory
Nullable | False
Prompt | Subcategory:
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 2
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: StartDate

Collapse image Report parameter properties

Property | Value
Allow blank | True
Allow multiple values | False
Data type | DateTime
Has default value | True
Hidden | False
Name | StartDate
Nullable | False
Prompt | Start Date:
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 2003-1-1
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: EndDate

Collapse image Report parameter properties

Property | Value
Allow blank | True
Allow multiple values | False
Data type | DateTime
Has default value | True
Hidden | False
Name | EndDate
Nullable | False
Prompt | End Date:
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 2009-12-31
Total: 1 default value(s)

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
tires | 264 x 19 | image/jpeg
wholelogolft_lowres | 361 x 115 | image/jpeg
Total: 2 embeded image(s)

Collapse image See also

About this documentation


Embedded image: tires

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | tires
Size (width x height) | 264 x 19
Type | image/jpeg

Collapse image See also

About this documentation


Embedded image: wholelogolft_lowres

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | wholelogolft_lowres
Size (width x height) | 361 x 115
Type | image/jpeg

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
TopEmployees |  | AdventureWorks | Query | 4 | 5 | 0
ProductCategories |  | AdventureWorks | Query | 0 | 2 | 0
TopCustomers |  | AdventureWorks | Query | 4 | 4 | 0
ProductSubcategories |  | AdventureWorks | Query | 1 | 3 | 0
Total: 4 dataset(s)

Collapse image See also

About this documentation


Dataset: TopEmployees

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@ProductCategory
@ProductSubcategory
@StartDate
@EndDate
Total: 4 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
LastName | LastName | System.String |  |  |
FirstName | FirstName | System.String |  |  |
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
SaleAmount | SaleAmount | System.Decimal |  |  |
FullName |  |  |  |  |
Total: 5 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT TOP 5 C.LastName, C.FirstName, E.BusinessEntityID, SUM(SOH.SubTotal) AS SaleAmount
FROM        Sales.SalesPerson SP INNER JOIN
            HumanResources.Employee E ON SP.BusinessEntityID = E.BusinessEntityID INNER JOIN
            Person.Person C ON E.BusinessEntityID = C.BusinessEntityID INNER JOIN
            Sales.SalesOrderHeader SOH ON SP.BusinessEntityID = SOH.SalesPersonID INNER JOIN
            Sales.SalesOrderDetail SOD ON SOH.SalesOrderID = SOD.SalesOrderID INNER JOIN
            Production.Product P ON SOD.ProductID = P.ProductID INNER JOIN
            Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID INNER JOIN
            Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE       (PC.ProductCategoryID = @ProductCategory) AND (PS.ProductSubcategoryID IN (@ProductSubcategory)) AND
            (SOH.OrderDate > @StartDate) AND (SOH.OrderDate < @EndDate)
GROUP BY    C.LastName, C.FirstName, E.BusinessEntityID, PC.ProductCategoryID, PS.ProductSubcategoryID
ORDER BY    SUM(SOH.SubTotal) DESC

Collapse image See also

About this documentation


Dataset: ProductCategories

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
ProductCategoryID | ProductCategoryID | System.Int32 |  |  |
Name | Name | System.String |  |  |
Total: 2 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT DISTINCT ProductCategoryID, Name
FROM        Production.ProductCategory
ORDER BY    Name

Collapse image See also

About this documentation


Dataset: TopCustomers

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@ProductSubcategory
@StartDate
@EndDate
@ProductCategory
Total: 4 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
StoreName | StoreName | System.String |  |  |
SaleAmount | SaleAmount | System.Decimal |  |  |
ProductSubcategoryID | ProductSubcategoryID | System.Int32 |  |  |
ProductCategoryID | ProductCategoryID | System.Int32 |  |  |
Total: 4 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT TOP 5 S.Name AS StoreName, SUM(SOH.SubTotal) AS SaleAmount, PS.ProductSubcategoryID,
            PS.ProductCategoryID
FROM        Production.Product P INNER JOIN
            Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID INNER JOIN
            Sales.SalesOrderDetail SOD ON P.ProductID = SOD.ProductID INNER JOIN
            Sales.Customer CU INNER JOIN
            Sales.SalesOrderHeader SOH ON CU.CustomerID = SOH.CustomerID INNER JOIN
            Sales.Store S ON CU.CustomerID = S.BusinessEntityID ON SOD.SalesOrderID = SOH.SalesOrderID
WHERE       (SOH.OrderDate > @StartDate) AND
            (SOH.OrderDate < @EndDate) AND (PS.ProductCategoryID = @ProductCategory) AND (PS.ProductSubcategoryID IN (@ProductSubcategory))
GROUP BY    S.Name, PS.ProductSubcategoryID, PS.ProductCategoryID
ORDER BY    SUM(SOH.SubTotal) DESC

Collapse image See also

About this documentation


Dataset: ProductSubcategories

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@ProductCategory
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
ProductSubcategoryID | ProductSubcategoryID | System.Int16 |  |  |
ProductCategoryID | ProductCategoryID | System.Int32 |  |  |
Name | Name | System.String |  |  |
Total: 3 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT      ProductSubcategoryID, ProductCategoryID, Name
FROM        Production.ProductSubcategory
WHERE       (ProductCategoryID = @ProductCategory)

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 8.0625in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
TopEmployees | Rectangle |  |
DateRange | Textbox |  |
Banner | Rectangle |  |
TopEmployeesHeader | Textbox |  |
CategorySelection | Textbox |  |
TopStores | Rectangle |  |
Total: 6 page body item(s)

Collapse image See also

About this documentation


Rectangle: TopEmployees

Collapse image Rectangle properties

Property | Value
Border style default |
Location (top, left) | 2.375in, 0.0625in
Size (width, height) | 6.875in, 2.4375in
ZIndex | 0

Collapse image See also

About this documentation


Tablix: TopEmployeesTable

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | TopEmployees
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.125in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.1875in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Chart: TopEmployeesChart

Collapse image Chart properties

Property | Value
Border color default | Black
Border style default |
Dataset name | TopEmployees
Chart type |
Location (top, left) | , 3.25in
Name | TopEmployeesChart
No data message |
No rows message |
Palette | Excel
Size (width, height) | 3.625in, 2.375in
ZIndex | 1

Collapse image Chart titles

No chart titles exist

Collapse image Chart legends

Name | Title | Position | Layout
Default |  | RightCenter | Column
Total: 1 chart legends(s)

Collapse image Chart values

Name | Type | X-Value | Y-Value | Value axis | Category axis
Series1 | Bar |  | =Sum(Fields!SaleAmount.Value)/1000 | Primary | Primary
Total: 1 chart legends(s)

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Textbox: DateRange

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Parameters!StartDate.Value + " through " + Parameters!EndDate.Value |  | 12pt |  | Bold |  | SlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Rectangle: Banner

Collapse image Rectangle properties

Property | Value
Border style default |
Location (top, left) | 1.25in, 0.0625in
Size (width, height) | 6.875in, 0.25in
ZIndex | 3

Collapse image See also

About this documentation


Rectangle: BannerLeft

Collapse image Rectangle properties

Property | Value
Border style default |
Location (top, left) | ,
Size (width, height) | 3.125in, 0.25in
ZIndex | 0

Collapse image See also

About this documentation


Textbox: TopEmployeesHeader

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Top Employees |  | 12pt |  | Bold |  | White
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: CategorySelection

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Parameters!ProductCategory.Label + " (" + Join(Parameters!ProductSubcategory.Label, ", ") + ")" |  | 12pt |  | Bold |  | SlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Rectangle: TopStores

Collapse image Rectangle properties

Property | Value
Border style default |
Location (top, left) | 4.875in, 0.0625in
Size (width, height) | 6.875in, 3.1875in
ZIndex | 6

Collapse image See also

About this documentation


Textbox: TopStoresHeader

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Top Stores |  | 12pt |  | Bold |  | White
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Tablix: TopStoresTable

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | TopCustomers
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.375in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.125in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Chart: TopStoresChart

Collapse image Chart properties

Property | Value
Border color default | Black
Border style default |
Dataset name | TopCustomers
Chart type |
Location (top, left) | 0.25in, 3.25in
Name | TopStoresChart
No data message |
No rows message |
Palette | SemiTransparent
Size (width, height) | 3.625in, 2.875in
ZIndex | 2

Collapse image Chart titles

No chart titles exist

Collapse image Chart legends

Name | Title | Position | Layout
Default |  | BottomCenter |
Total: 1 chart legends(s)

Collapse image Chart values

Name | Type | X-Value | Y-Value | Value axis | Category axis
Series1 | Shape |  | =Sum(Fields!SaleAmount.Value)/1000 | Primary | Primary
Total: 1 chart legends(s)

Collapse image Chart category groups

No category groups exist

Collapse image Chart series groups

No series groups exist

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 0.5in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page footer items

Name | Item type | Height | ZIndex
FooterDate |  |  |
FooterCompany |  |  |
FooterURL |  |  |
Total: 3 page footer item(s)

Collapse image See also

About this documentation


Textbox: FooterDate

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Now() |  |  |  |  |  | SlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: FooterCompany

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Adventure Works Cycles |  |  |  |  |  | SlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: FooterURL

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
www.adventure-works.com |  |  |  |  |  | SlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Sales Order Detail.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Detail of an individual Adventure Works order. This report can be accessed as a drillthrough report from the Employee Sales Summary and Territory Sales drilldown report. This report illustrates the use of lists, tables, parameters, and expressions.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Sales Order Detail.rdl
Report unit type | Inch
Width | 7.9375in

Collapse image Report object index

Objects | Total
Parameters | 1
Embeded images | 1
Data sources | 1
Datasets | 2
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
SalesOrderNumber | String | Sales Order Number | False | False | False | True
Total: 1 parameter(s)

Collapse image See also

About this documentation


Report parameter: SalesOrderNumber

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | String
Has default value | True
Hidden | False
Name | SalesOrderNumber
Nullable | False
Prompt | Sales Order Number
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | SO50750
Total: 1 default value(s)

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
logofull | 357 x 114 | image/jpeg
Total: 1 embeded image(s)

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
SalesOrder |  | AdventureWorks | Query | 1 | 23 | 0
SalesOrderDetail |  | AdventureWorks | Query | 1 | 9 | 0
Total: 2 dataset(s)

Collapse image See also

About this documentation


Dataset: SalesOrder

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@SalesOrderNumber
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
SalesOrderNumber | SalesOrderNumber | System.String |  |  |
Store | Store | System.String |  |  |
OrderDate | OrderDate | System.DateTime |  |  |
SalesFirstName | SalesFirstName | System.String |  |  |
SalesLastName | SalesLastName | System.String |  |  |
SalesTitle | SalesTitle | System.String |  |  |
PurchaseOrderNumber | PurchaseOrderNumber | System.String |  |  |
ShipMethod | ShipMethod | System.String |  |  |
BillAddress1 | BillAddress1 | System.String |  |  |
BillAddress2 | BillAddress2 | System.String |  |  |
BillCity | BillCity | System.String |  |  |
BillPostalCode | BillPostalCode | System.String |  |  |
BillStateProvince | BillStateProvince | System.String |  |  |
BillCountryRegion | BillCountryRegion | System.String |  |  |
ShipAddress1 | ShipAddress1 | System.String |  |  |
ShipAddress2 | ShipAddress2 | System.String |  |  |
ShipCity | ShipCity | System.String |  |  |
ShipPostalCode | ShipPostalCode | System.String |  |  |
ShipStateProvince | ShipStateProvince | System.String |  |  |
ShipCountryRegion | ShipCountryRegion | System.String |  |  |
CustPhone | CustPhone | System.String |  |  |
CustFirstName | CustFirstName | System.String |  |  |
CustLastName | CustLastName | System.String |  |  |
Total: 23 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT     SOH.SalesOrderNumber, S.Name AS Store, SOH.OrderDate, C.FirstName AS SalesFirstName, C.LastName AS SalesLastName, E.JobTitle AS SalesTitle,
                      SOH.PurchaseOrderNumber, SM.Name AS ShipMethod, BA.AddressLine1 AS BillAddress1, BA.AddressLine2 AS BillAddress2, BA.City AS BillCity,
                      BA.PostalCode AS BillPostalCode, BSP.Name AS BillStateProvince, BCR.Name AS BillCountryRegion, SA.AddressLine1 AS ShipAddress1,
                      SA.AddressLine2 AS ShipAddress2, SA.City AS ShipCity, SA.PostalCode AS ShipPostalCode, SSP.Name AS ShipStateProvince, SCR.Name AS ShipCountryRegion,
                      PPP.PhoneNumber AS CustPhone, CC.FirstName AS CustFirstName, CC.LastName AS CustLastName
FROM         Person.Address AS SA INNER JOIN
                      Person.StateProvince AS SSP ON SA.StateProvinceID = SSP.StateProvinceID INNER JOIN
                      Person.CountryRegion AS SCR ON SSP.CountryRegionCode = SCR.CountryRegionCode RIGHT OUTER JOIN
                      Sales.SalesOrderHeader AS SOH LEFT OUTER JOIN
                      Sales.Customer AS SC ON SOH.CustomerID = SC.CustomerID LEFT OUTER JOIN
              Person.Person AS CC ON SC.PersonID = CC.BusinessEntityID INNER JOIN
              Person.PersonPhone AS PPP ON CC.BusinessEntityID = PPP.BusinessEntityID LEFT OUTER JOIN
                      Person.Address AS BA INNER JOIN
                      Person.StateProvince AS BSP ON BA.StateProvinceID = BSP.StateProvinceID INNER JOIN
                      Person.CountryRegion AS BCR ON BSP.CountryRegionCode = BCR.CountryRegionCode ON SOH.BillToAddressID = BA.AddressID ON
                      SA.AddressID = SOH.ShipToAddressID LEFT OUTER JOIN
                      Person.Person AS C RIGHT OUTER JOIN
                      HumanResources.Employee AS E ON C.BusinessEntityID = E.BusinessEntityID ON SOH.SalesPersonID = E.BusinessEntityID LEFT OUTER JOIN
                      Purchasing.ShipMethod AS SM ON SOH.ShipMethodID = SM.ShipMethodID LEFT OUTER JOIN
                      Sales.Store AS S ON SOH.SalesPersonID = S.BusinessEntityID
WHERE     (SOH.SalesOrderNumber = @SalesOrderNumber)

Collapse image See also

About this documentation


Dataset: SalesOrderDetail

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@SalesOrderNumber
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
SalesOrderDetailID | SalesOrderDetailID | System.Int32 |  |  |
OrderQty | OrderQty | System.Int16 |  |  |
UnitPrice | UnitPrice | System.Decimal |  |  |
UnitPriceDiscount | UnitPriceDiscount | System.Decimal |  |  |
LineTotal | LineTotal | System.Decimal |  |  |
CarrierTrackingNumber | CarrierTrackingNumber | System.String |  |  |
SalesOrderID | SalesOrderID | System.Int32 |  |  |
Name | Name | System.String |  |  |
ProductNumber | ProductNumber | System.String |  |  |
Total: 9 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT      SOD.SalesOrderDetailID, SOD.OrderQty, SOD.UnitPrice,
            CASE WHEN SOD.UnitPriceDiscount IS NULL THEN 0 ELSE SOD.UnitPriceDiscount END AS UnitPriceDiscount,
            SOD.LineTotal, SOD.CarrierTrackingNumber, SOD.SalesOrderID, P.Name, P.ProductNumber
FROM        Sales.SalesOrderDetail SOD INNER JOIN
            Production.Product P ON SOD.ProductID = P.ProductID INNER JOIN
            Sales.SalesOrderHeader SOH ON SOD.SalesOrderID = SOH.SalesOrderID
WHERE       (SOH.SalesOrderNumber = @SalesOrderNumber)
ORDER BY    SOD.SalesOrderDetailID

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 4.0625in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
OrderDetail | Tablix |  |
OrderHeader | Tablix |  |
Total: 2 page body item(s)

Collapse image See also

About this documentation


Tablix: OrderDetail

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | SalesOrderDetail
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 3.5in, 0.0625in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 7.81294in, 0.5625in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Tablix: OrderHeader

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | SalesOrder
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | ,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 7.9375in, 3.4375in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: OrderNumber

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
="Order # " & Fields!SalesOrderNumber.Value | Tahoma | 14pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: Title

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Sales Order | Tahoma | 22pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToAddress1

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!BillAddress1.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToPostalCode

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!BillPostalCode.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToCity

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!BillCity.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipMethod

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipMethod.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: CustomerPhone

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
="Ph: " & Fields!CustPhone.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToRegion

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipCountryRegion.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: SalesPersonLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Sales Person |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: SalesPerson

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!SalesFirstName.Value + " " + Fields!SalesLastName.Value + ", " + Fields!SalesTitle.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToPostalCode

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipPostalCode.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Bill To: |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToCity

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipCity.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: OrderDateLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Order Date |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipMethodLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Shipment Method |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: CustomerName

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!CustFirstName.Value + " " + Fields!CustLastName.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: CurrentDate

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Now() |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: CurrentDateLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Date |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToAddress1

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipAddress1.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: OrderDate

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!OrderDate.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToRegion

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!BillCountryRegion.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Ship To: |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: PurchaseOrder

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!PurchaseOrderNumber.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: PurchaseOrderLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Purchase Order |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToStore

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!Store.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToStore

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!Store.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: BillToStateProvince

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!BillStateProvince.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ShipToStateProvince

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
=Fields!ShipStateProvince.Value |  | 9pt |  |  |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: ContactLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Contact: |  | 9pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Sales Reason Comparisons.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Shows sales reason comparison data from an Analysis Services cube. Also illustrates the use of a multivalued parameter. The Sales Reason Comparisons report requires SQL Server Analysis Services and the AdventureWorks Analysis Services database.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Sales Reason Comparisons.rdl
Report unit type | Inch
Width | 5.0625in

Collapse image Report object index

Objects | Total
Parameters | 1
Embeded images | 1
Data sources | 1
Datasets | 2
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
ProductCategory | String | Product Category | False | True | False | True
Total: 1 parameter(s)

Collapse image See also

About this documentation


Report parameter: ProductCategory

Collapse image Report parameter properties

Property | Value
Allow blank | True
Allow multiple values | True
Data type | String
Has default value | True
Hidden | False
Name | ProductCategory
Nullable | False
Prompt | Product Category
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | [Product].[Category].&[1]
Item value 2 | [Product].[Category].&[2]
Total: 2 default value(s)

Collapse image See also

About this documentation


List of Embeded Images

Collapse image Embeded images

Name | Size (Width x Heigth) | Type
logopart_xs | 71 x 30 | image/jpeg
Total: 1 embeded image(s)

Collapse image See also

About this documentation


Embedded image: logopart_xs

Collapse image Embedded image

Collapse image Embedded image properties

Property | Value
Name | logopart_xs
Size (width x height) | 71 x 30
Type | image/jpeg

Collapse image See also

About this documentation


List of Data sources

Collapse image Data sources

Name | Data source type
AdventureWorksAS |
Total: 1 datasource(s)

Collapse image See also

About this documentation


Data source: AdventureWorksAS

Collapse image Data source properties

Property | Value
Referenced data source | AdventureWorksAS
Security type | None
Data source type |
Connection string |
Use single transaction | False

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
ProductData |  | AdventureWorksAS | Query | 1 | 5 | 0
ProductList |  | AdventureWorksAS | Query | 0 | 4 | 0
Total: 2 dataset(s)

Collapse image See also

About this documentation


Dataset: ProductData

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorksAS
Referenced data set |
Command type | Query

Collapse image Parameters

Name
ProductCategory
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Sales_Reason |  | System.String |  |  |
Sales_Territory_Group |  | System.String |  |  |
Internet_Order_Quantity |  | System.Int32 |  |  |
Internet_Sales_Amount |  | System.Int32 |  |  |
Internet_Total_Product_Cost |  | System.Int32 |  |  |
Total: 5 field(s)

Collapse image Filters

No filters exist

Collapse image Query

WITH MEMBER [Measures].[Profit] AS '[Measures].[Sales Amount]-[Measures].[Standard Product Cost]' SELECT NON EMPTY { [Measures].[Internet Sales Amount], [Measures].[Internet Total Product Cost], [Measures].[Internet Order Quantity] } ON COLUMNS, NON EMPTY { ([Sales Reason].[Sales Reason].[Sales Reason].ALLMEMBERS * [Sales Territory].[Sales Territory Group].[Sales Territory Group].ALLMEMBERS ) } DIMENSION PROPERTIES MEMBER_CAPTION, MEMBER_UNIQUE_NAME, [Sales Reason].[Sales Reason].[Sales Reason].KEY, [Sales Territory].[Sales Territory Group].[Sales Territory Group].KEY ON ROWS FROM ( SELECT ( STRTOSET(@ProductCategory, CONSTRAINED) ) ON COLUMNS FROM [Adventure Works]) WHERE ( IIF( STRTOSET(@ProductCategory, CONSTRAINED).Count = 1, STRTOSET(@ProductCategory, CONSTRAINED), [Product].[Category].currentmember ) ) CELL PROPERTIES VALUE, BACK_COLOR, FORE_COLOR, FORMATTED_VALUE, FORMAT_STRING, FONT_NAME, FONT_SIZE, FONT_FLAGS

Collapse image See also

About this documentation


Dataset: ProductList

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorksAS
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Category |  | System.String |  |  |
ParameterCaption |  | System.Int32 |  |  |
ParameterValue |  | System.Int32 |  |  |
ParameterLevel |  | System.Int32 |  |  |
Total: 4 field(s)

Collapse image Filters

No filters exist

Collapse image Query

WITH MEMBER [Measures].[ParameterCaption] AS '[Product].[Category].CURRENTMEMBER.MEMBER_CAPTION' MEMBER [Measures].[ParameterValue] AS '[Product].[Category].CURRENTMEMBER.UNIQUENAME' MEMBER [Measures].[ParameterLevel] AS '[Product].[Category].CURRENTMEMBER.LEVEL.ORDINAL' SELECT {[Measures].[ParameterCaption], [Measures].[ParameterValue], [Measures].[ParameterLevel]} ON COLUMNS , [Product].[Category].ALLMEMBERS ON ROWS FROM [Adventure Works]

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 1.25in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
matrix1 | Tablix |  |
Total: 1 page body item(s)

Collapse image See also

About this documentation


Tablix: matrix1

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | ProductData
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.125in, 0.125in
Repeat column headers | True
Repeat row headers | True
Size (width, height) | 4.875in, 1.125in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: textbox1

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Sales Reason |  |  |  | Bold |  |
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Sales_by_Region.rdl

Collapse image Report properties

Property | Value
Author | Mary Lingel MSFT
Auto refresh | 0
Description | Purpose: Map report. For each state, displays sales totals for individuals, sales totals for reseller stores, and store locations. Includes the US map from the map gallery, analytical data from a dataset, polygon layer (one for each state), polygon fill for no sales, polygon color rules based on individual sales, markers for stores, marker colors based on store sales, marker drillthrough action, multiple map titles and legends, and use of Lookup function.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Sales_by_Region.rdl
Report unit type | Inch
Width | 10.44097in

Collapse image Report object index

Objects | Total
Parameters | 5
Embeded images | 1
Data sources | 1
Datasets | 3
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
Distance | Integer | Distance in miles? | False | False | True | True
ShowBingMaps | String | Show Bing Map layer? | False | False | False | True
BingMapTileType | String | Bing Map tile type? | False | False | False | True
USStatesTransparency | Float | Transparency for US States? | False | False | False | True
ShowAll | Boolean | Show all information? | False | False | False | True
Total: 5 parameter(s)

Collapse image See also

About this documentation


Report parameter: Distance

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Integer
Has default value | True
Hidden | True
Name | Distance
Nullable | False
Prompt | Distance in miles?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 50
Total: 1 default value(s)

Collapse image See also

About this documentation


Report parameter: ShowBingMaps

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | String
Has default value | True
Hidden | False
Name | ShowBingMaps
Nullable | False
Prompt | Show Bing Map layer?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | Hidden
Item value 2 | Visible
Item value 3 | Hidden
Total: 3 default value(s)

Collapse image See also

About this documentation


Report parameter: BingMapTileType

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | String
Has default value | True
Hidden | False
Name | BingMapTileType
Nullable | False
Prompt | Bing Map tile type?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | Aerial
Item value 2 | Road
Item value 3 | Aerial
Item value 4 | Hybrid
Total: 4 default value(s)

Collapse image See also

About this documentation


Report parameter: USStatesTransparency

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | Float
Has default value | True
Hidden | False
Name | USStatesTransparency
Nullable | False
Prompt | Transparency for US States?
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 0
Item value 2 | 0
Item value 3 | 10
Item value 4 | 25
Item value 5 | 35
Item value 6 | 50
Item value 7 | 75
Total: 7 default value(s)

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
IndividualCustomerSales |  | AdventureWorks | Query | 0 | 10 | 0
StoreSales |  | AdventureWorks | Query | 0 | 9 | 0
StoreSaleTotals |  | AdventureWorks | Query | 0 | 3 | 0
Total: 3 dataset(s)

Collapse image See also

About this documentation


Dataset: IndividualCustomerSales

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
SalesOrderID | SalesOrderID | System.Int32 |  |  |
TotalDue | TotalDue | System.Decimal |  |  |
OrderDate | OrderDate | System.DateTime |  |  |
CustomerID | CustomerID | System.Int32 |  |  |
FirstName | FirstName | System.String |  |  |
LastName | LastName | System.String |  |  |
StateProvinceCode | StateProvinceCode | System.String |  |  |
City | City | System.String |  |  |
PostalCode | PostalCode | System.String |  |  |
SpatialLocation | SpatialLocation | Microsoft.SqlServer.Types.SqlGeography |  |  |
Total: 10 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT soh.SalesOrderID, soh.TotalDue, soh.OrderDate,
  c.CustomerID, p.FirstName, p.LastName,
    RTRIM(sp.StateProvinceCode) as StateProvinceCode,
    ad.City, ad.PostalCode, ad.SpatialLocation
FROM Sales.SalesOrderHeader AS soh INNER JOIN
   Sales.Customer AS c ON soh.CustomerID = c.CustomerID INNER JOIN
   Person.BusinessEntity AS b ON b.BusinessEntityID = c.PersonID INNER JOIN
   Person.Person AS p ON p.BusinessEntityID = b.BusinessEntityID INNER JOIN
   Person.BusinessEntityAddress AS a ON a.BusinessEntityID = b.BusinessEntityID INNER JOIN
   Person.Address AS ad ON ad.AddressID = a.AddressID INNER JOIN
   Person.AddressType AS at ON at.AddressTypeID = a.AddressTypeID INNER JOIN
   Person.StateProvince AS sp ON sp.StateProvinceID = ad.StateProvinceID
WHERE(c.PersonID IS NOT NULL)
   AND (at.Name = N'Home')
   AND (sp.CountryRegionCode = N'US')

Collapse image See also

About this documentation


Dataset: StoreSales

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
SalesOrderID | SalesOrderID | System.Int32 |  |  |
TotalDue | TotalDue | System.Decimal |  |  |
OrderDate | OrderDate | System.DateTime |  |  |
CustomerID | CustomerID | System.Int32 |  |  |
Store | Store | System.String |  |  |
StateProvinceCode | StateProvinceCode | System.String |  |  |
City | City | System.String |  |  |
PostalCode | PostalCode | System.String |  |  |
SpatialLocation | SpatialLocation | Microsoft.SqlServer.Types.SqlGeography |  |  |
Total: 9 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT soh.SalesOrderID, soh.TotalDue, soh.OrderDate, c.CustomerID,
   st.Name AS Store,
   sp.StateProvinceCode,
-- StateProvinceCode is 3 chars.
--    Use RTRIM here or in the expression for the match field.
   ad.City, ad.PostalCode, ad.SpatialLocation
FROM Sales.SalesOrderHeader AS soh INNER JOIN
  Sales.Customer AS c ON soh.CustomerID = c.CustomerID INNER JOIN
  Person.BusinessEntity AS b ON b.BusinessEntityID = c.StoreID INNER JOIN
  Sales.Store AS st ON st.BusinessEntityID
     = b.BusinessEntityID INNER JOIN
  Person.BusinessEntityAddress AS a
     ON a.BusinessEntityID = b.BusinessEntityID INNER JOIN
  Person.Address AS ad ON ad.AddressID = a.AddressID INNER JOIN
  Person.AddressType AS at ON at.AddressTypeID = a.AddressTypeID
     INNER JOIN Person.StateProvince AS sp
     ON sp.StateProvinceID = ad.StateProvinceID
WHERE (c.StoreID IS NOT NULL)
   AND (at.Name = N'Main Office')
   AND (sp.CountryRegionCode = N'US')

Collapse image See also

About this documentation


Dataset: StoreSaleTotals

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
StateProvinceCode | StateProvinceCode | System.String |  |  |
NStores | NStores | System.Int32 |  |  |
Total | Total | System.Decimal |  |  |
Total: 3 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT sp.StateProvinceCode, COUNT(DISTINCT (c.StoreID)) as NStores, SUM(soh.TotalDue) AS Total
FROM Sales.SalesOrderHeader AS soh INNER JOIN
   Sales.Customer AS c ON soh.CustomerID = c.CustomerID INNER JOIN
   Person.BusinessEntity AS b ON b.BusinessEntityID = c.StoreID INNER JOIN
   Sales.Store AS st ON st.BusinessEntityID = b.BusinessEntityID INNER JOIN
   Person.BusinessEntityAddress AS a ON a.BusinessEntityID = b.BusinessEntityID INNER JOIN
   Person.Address AS ad ON ad.AddressID = a.AddressID INNER JOIN
   Person.AddressType AS at ON at.AddressTypeID = a.AddressTypeID INNER JOIN
   Person.StateProvince AS sp ON sp.StateProvinceID = ad.StateProvinceID
WHERE (c.StoreID IS NOT NULL) AND (at.Name = N'Main Office') AND (sp.CountryRegionCode = N'US')
GROUP BY sp.StateProvinceCode
ORDER BY sp.StateProvinceCode

Collapse image See also

About this documentation


Page header

Collapse image Page header properties

Property | Value
Heigth | 0.55208in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page header items

Name | Item type | Height | ZIndex
ReportName |  |  |
Total: 1 page header item(s)

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 6.78in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
tbToggle | Textbox |  |
tbScenarioText | Textbox |  |
Tablix1 | Tablix |  |
rectStoresbyState | Rectangle |  |
Total: 4 page body item(s)

Collapse image See also

About this documentation


Textbox: tbScenarioText

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
AdventureWorks customer sales come from reseller stores and individual internet sales. State color is based on the sales amounts for all individual sales. Marker color is based on sales amounts for reseller stores. Markers indicate the location of each store. Click the marker to find individuals who live within [@Distance] miles of the store. |  |  |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Tablix: Tablix1

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | IndividualCustomerSales
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.41666in, 7.20833in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 3.09376in, 0.61458in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Rectangle: rectStoresbyState

Collapse image Rectangle properties

Property | Value
Border style default | None
Location (top, left) | 5.66666in,
Size (width, height) | 4.67708in, 1.11334in
ZIndex | 4

Collapse image See also

About this documentation


Tablix: tblxMatrix_StoresbyState

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | StoreSales
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.36806in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 4.46875in, 0.5in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: tbStoresbyStateLabel

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Store sales in each state. |  | 16pt |  |  |  | White
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Textbox: tbDescription

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Purpose: Map report. For each state, displays sales totals for individuals, sales totals for reseller stores, and store locations. Includes the US map from the map gallery, analytical data from a dataset, polygon layer (one for each state), polygon fill for no sales, polygon color rules based on individual sales, markers for stores, marker colors based on store sales, marker drillthrough action, multiple map titles and legends, and use of Lookup function. |  |  |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Store_Contacts.rdl

Collapse image Report properties

Property | Value
Author | Mary Lingel MSFT
Auto refresh | 0
Description | Purpose: Subreport. Displays store contact information. Used in Sales_Order_Details_2008R2 to display multiple store contacts. Includes page header and footer items that are not included when the report is rendered as a subreport.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Store_Contacts.rdl
Report unit type | Inch
Width | 4.6875in

Collapse image Report object index

Objects | Total
Parameters | 2
Embeded images | 1
Data sources | 1
Datasets | 2
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Report Parameters

Collapse image Parameters

Name | Type | Prompt | Nullable | Allow blank | Hidden | Has default value
StoreID | String | Store: | False | False | False | True
ShowAll | Boolean | Show all information? | False | False | False | True
Total: 2 parameter(s)

Collapse image See also

About this documentation


Report parameter: StoreID

Collapse image Report parameter properties

Property | Value
Allow blank | False
Allow multiple values | False
Data type | String
Has default value | True
Hidden | False
Name | StoreID
Nullable | False
Prompt | Store:
Used in Query | False

Collapse image Default values

Name | Value
Item value 1 | 642
Total: 1 default value(s)

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
StoreContacts |  | AdventureWorks | Query | 1 | 6 | 0
Stores |  | AdventureWorks | Query | 0 | 2 | 0
Total: 2 dataset(s)

Collapse image See also

About this documentation


Dataset: StoreContacts

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

Name
@StoreID
Total: 1 parameter(s)

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
Store | Store | System.String |  |  |
Title | Title | System.String |  |  |
FirstName | FirstName | System.String |  |  |
LastName | LastName | System.String |  |  |
PhoneNumber | PhoneNumber | System.String |  |  |
Total: 6 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT s.BusinessEntityID, s.Name AS Store, ct.Name AS Title, p.FirstName, p.LastName, ph.PhoneNumber
FROM Sales.Store AS s INNER JOIN
   Person.BusinessEntityContact AS bec ON bec.BusinessEntityID = s.BusinessEntityID INNER JOIN
   Person.ContactType AS ct ON ct.ContactTypeID = bec.ContactTypeID INNER JOIN
   Person.Person AS p ON p.BusinessEntityID = bec.PersonID INNER JOIN
   Person.PersonPhone AS ph ON p.BusinessEntityID = ph.BusinessEntityID
WHERE (s.BusinessEntityID = @StoreID)

Collapse image See also

About this documentation


Dataset: Stores

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
Store | Store | System.String |  |  |
Total: 2 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT DISTINCT BusinessEntityID, Name as Store
FROM Sales.Store

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 0.22916in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
tblxContactInformation | Tablix |  |
Total: 1 page body item(s)

Collapse image See also

About this documentation


Tablix: tblxContactInformation

Collapse image Tablix properties

Property | Value
Border style default | None
Dataset name | StoreContacts
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 0.04167in,
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 4.32292in, 0.14583in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Page footer

Collapse image Page footer properties

Property | Value
Heigth | 0.76389in
Print between sections | False
Print on first page | True
Print on last page | True

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style | None
Width | 1pt

Collapse image Page footer items

Name | Item type | Height | ZIndex
tbDescription |  |  |
Total: 1 page footer item(s)

Collapse image See also

About this documentation


Textbox: tbDescription

Collapse image Textbox properties

Property | Value
Action type |
Border style default | None

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Purpose: Subreport. Displays store contact information. Used in Sales_Order_Details_2008R2 to display multiple store contacts. Includes page header and footer items that are not included when the report is rendered as a subreport. |  |  |  |  |  | Brown
Total: 1 paragraph(s)

Collapse image See also

About this documentation


Report: Territory Sales Drilldown.rdl

Collapse image Report properties

Property | Value
Author |
Auto refresh | 0
Description | Adventure Works sales by territory. This report drills down through salesperson and order number with drillthrough to individual orders. This report illustrates the use of a table data region that provides drilldown from summary data into detail data by showing and hiding rows. This report also illustrates the use of drillthrough links and conditional formatting.
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\Territory Sales Drilldown.rdl
Report unit type | Inch
Width | 5.97917in

Collapse image Report object index

Objects | Total
Parameters | 0
Embeded images | 1
Data sources | 1
Datasets | 1
Header items |
Body items |
Footer items |

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Referenced data set | Data source name | Command type | Parameter count | Field count | Filter count
TerritorySales |  | AdventureWorks | Query | 0 | 6 | 0
Total: 1 dataset(s)

Collapse image See also

About this documentation


Dataset: TerritorySales

Collapse image Dataset properties

Property | Value
Data source name | AdventureWorks
Referenced data set |
Command type | Query

Collapse image Parameters

No parameters exist

Collapse image Fields

Name | Source column | Data type | Caption | Value | Is calculated field
Name | Name | System.String |  |  |
BusinessEntityID | BusinessEntityID | System.Int32 |  |  |
FirstName | FirstName | System.String |  |  |
LastName | LastName | System.String |  |  |
SalesOrderNumber | SalesOrderNumber | System.String |  |  |
TotalDue | TotalDue | System.Decimal |  |  |
Total: 6 field(s)

Collapse image Filters

No filters exist

Collapse image Query

SELECT      ST.Name, SP.BusinessEntityID, C.FirstName, C.LastName, SOH.SalesOrderNumber, SOH.TotalDue
FROM        Sales.SalesTerritory ST INNER JOIN
            Sales.SalesPerson SP ON ST.TerritoryID = SP.TerritoryID INNER JOIN
            HumanResources.Employee E ON SP.BusinessEntityID = E.BusinessEntityID INNER JOIN
            Person.Person C ON E.BusinessEntityID = C.BusinessEntityID INNER JOIN
            Sales.SalesOrderHeader SOH ON SP.BusinessEntityID = SOH.SalesPersonID
GROUP BY    ST.Name, SP.BusinessEntityID, C.FirstName, C.LastName, SOH.SalesOrderNumber, SOH.TotalDue
ORDER BY    ST.Name

Collapse image See also

About this documentation


Page body

Collapse image Page body properties

Property | Value
Heigth | 2.125in

Collapse image Style

Property | Value
Background color |

Collapse image Background image

Property | Value
Background repeat | Default
MIME type |
Source | External
Value |

Collapse image Border

Property | Value
Color | Black
Style |
Width | 1pt

Collapse image Page body items

Name | Item type | Height | ZIndex
SalesTable | Tablix |  |
Title | Textbox |  |
Total: 2 page body item(s)

Collapse image See also

About this documentation


Tablix: SalesTable

Collapse image Tablix properties

Property | Value
Border style default |
Dataset name | TerritorySales
Filters count | 0
Fixed column headers | False
Fixed row headers | False
Layout direction |
Location (top, left) | 1.375in, 0.0625in
Repeat column headers | False
Repeat row headers | False
Size (width, height) | 5.80984in, 0.75in
Tablix dimensions (rows, columns) | 0, 0

Collapse image See also

About this documentation


Textbox: Title

Collapse image Textbox properties

Property | Value
Action type |
Border style default |

Collapse image Paragraphs

Value | Font family | Font size | Font style | Font weight | Font decoration | Font color
Territory Sales | Tahoma | 20pt |  | Bold |  | DarkSlateBlue
Total: 1 paragraph(s)

Collapse image See also

About this documentation


List of Datasets

Collapse image Datasets

Name | Parameter count | Shared data source reference
DataSet1.rsd | 1 |
EmployeeSalesDetail.rsd | 3 |
EmployeeSalesYearOverYear.rsd | 3 |
EmpSalesMonth.rsd | 3 |
SalesEmployees.rsd | 1 |
Total: 5 dataset(s)

Collapse image See also

About this documentation


Dataset: DataSet1.rsd

Collapse image Dataset properties

Property | Value
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\DataSet1.rsd
Data source | DataSource3

Collapse image Parameters

Name | Data type | Nullable | Omit from query | Read only
cddsf | Boolean | True | True | True
Total: 1 parameter(s)

Collapse image Fields

Name | Field source column | Data type
Country |  | System.String
State_Province |  | System.String
City |  | System.String
Postal_Code |  | System.String
Customer |  | System.String
Growth_in_Customer_Base_Value |  | System.Int32
Growth_in_Customer_Base_Goal |  | System.Int32
Product_Gross_Profit_Margin_Value |  | System.Int32
Internet_Order_Count |  | System.Int32
Reseller_Order_Count |  | System.Int32
Sales_Amount_Quota |  | System.Int32
Total: 11 field(s)

Collapse image Query

 SELECT NON EMPTY { KPIValue("Growth in Customer Base"), KPIGoal("Growth in Customer Base"), KPIValue("Product Gross Profit Margin"), [Measures].[Internet Order Count], [Measures].[Reseller Order Count], [Measures].[Sales Amount Quota] } ON COLUMNS, NON EMPTY { ([Customer].[Customer Geography].[Customer].ALLMEMBERS ) } DIMENSION PROPERTIES MEMBER_CAPTION, MEMBER_UNIQUE_NAME ON ROWS FROM [Adventure Works] CELL PROPERTIES VALUE, BACK_COLOR, FORE_COLOR, FORMATTED_VALUE, FORMAT_STRING, FONT_NAME, FONT_SIZE, FONT_FLAGS

Collapse image See also

About this documentation


Dataset: EmployeeSalesDetail.rsd

Collapse image Dataset properties

Property | Value
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\EmployeeSalesDetail.rsd
Data source | AdventureWorks

Collapse image Parameters

Name | Data type | Nullable | Omit from query | Read only
@ReportYear | Object | False | False | False
@ReportMonth | Object | False | False | False
@EmployeeID | Object | False | False | False
Total: 3 parameter(s)

Collapse image Fields

Name | Field source column | Data type
Employee | Employee | System.String
Subcategory | Subcategory | System.String
Sales | Sales | System.Decimal
SalesOrderID | SalesOrderID | System.Int32
SalesOrderNumber | SalesOrderNumber | System.String
Product | Product | System.String
OrderQty | OrderQty | System.Int32
UnitPrice | UnitPrice | System.Decimal
Category | Category | System.String
Total: 9 field(s)

Collapse image Query

SELECT PER.FirstName + ' ' + PER.LastName AS Employee,
   PS.Name AS Subcategory, SUM(DET.LineTotal) AS Sales,
   SOH.SalesOrderID,  SOH.SalesOrderNumber,
   P.Name AS Product,
   SUM(DET.OrderQty) AS OrderQty, DET.UnitPrice,
   PC.Name AS Category
FROM Sales.SalesOrderHeader SOH
   INNER JOIN [Sales].[SalesPerson] SP ON SP.[BusinessEntityID] = SOH.[SalesPersonID]
   INNER JOIN Sales.SalesOrderDetail DET ON SOH.SalesOrderID = DET.SalesOrderID
   INNER JOIN [HumanResources].[Employee] E ON SOH.[SalesPersonID] = E.[BusinessEntityID]
   INNER JOIN [Person].[Person] PER ON PER.[BusinessEntityID] = SP.[BusinessEntityID]
   INNER JOIN Production.Product P ON DET.ProductID = P.ProductID
   INNER JOIN Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID
   INNER JOIN Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE (DATEPART(Year, SOH.OrderDate) = @ReportYear) AND
   (DATEPART(Month, SOH.OrderDate) = @ReportMonth) AND
    (SOH.SalesPersonID = @EmployeeID)
GROUP BY PER.FirstName + ' ' + PER.LastName,
   DATEPART(Month, SOH.OrderDate), SOH.SalesOrderID, SOH.SalesOrderNumber,
   P.Name, PS.Name, DET.UnitPrice, PC.Name

Collapse image See also

About this documentation


Dataset: EmployeeSalesYearOverYear.rsd

Collapse image Dataset properties

Property | Value
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\EmployeeSalesYearOverYear.rsd
Data source | AdventureWorks

Collapse image Parameters

Name | Data type | Nullable | Omit from query | Read only
@ReportYear | Object | False | False | False
@ReportMonth | Object | False | False | False
@EmployeeID | Object | False | False | False
Total: 3 parameter(s)

Collapse image Fields

Name | Field source column | Data type
Employee | Employee | System.String
Year | Year | System.Int32
MonthNumber | MonthNumber | System.Int32
Month | Month | System.String
Sales | Sales | System.Decimal
Total: 5 field(s)

Collapse image Query

SELECT        P.FirstName + ' ' + P.LastName AS Employee, DATEPART(Year, SOH.OrderDate) AS Year, DATEPART(Month, SOH.OrderDate) AS MonthNumber, DATENAME(Month,
                         SOH.OrderDate) AS Month, SUM(DET.LineTotal) AS Sales
FROM            Sales.SalesPerson AS SP INNER JOIN
                         Sales.SalesOrderHeader AS SOH ON SP.BusinessEntityID = SOH.SalesPersonID INNER JOIN
                         Sales.SalesOrderDetail AS DET ON SOH.SalesOrderID = DET.SalesOrderID INNER JOIN
                         Sales.SalesTerritory AS ST ON SP.TerritoryID = ST.TerritoryID INNER JOIN
                         HumanResources.Employee AS E ON SOH.SalesPersonID = E.BusinessEntityID INNER JOIN
                         Person.Person AS P ON P.BusinessEntityID = SP.BusinessEntityID
WHERE        (DATEPART(Year, SOH.OrderDate) <= @ReportYear - 1 OR
                         DATEPART(Year, SOH.OrderDate) = @ReportYear AND DATEPART(Month, SOH.OrderDate) <= @ReportMonth) AND (SOH.SalesPersonID = @EmployeeID)
GROUP BY P.FirstName + ' ' + P.LastName, SOH.SalesPersonID, DATEPART(Year, SOH.OrderDate), DATEPART(Month, SOH.OrderDate), DATENAME(Month, SOH.OrderDate)

Collapse image See also

About this documentation


Dataset: EmpSalesMonth.rsd

Collapse image Dataset properties

Property | Value
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\EmpSalesMonth.rsd
Data source | AdventureWorks

Collapse image Parameters

Name | Data type | Nullable | Omit from query | Read only
@ReportYear | Object | False | False | False
@ReportMonth | Object | False | False | False
@EmployeeID | Object | False | False | False
Total: 3 parameter(s)

Collapse image Fields

Name | Field source column | Data type
Employee | Employee | System.String
Year | Year | System.Int32
MonthNumber | MonthNumber | System.Int32
Month | Month | System.String
Category | Category | System.String
Sales | Sales | System.Decimal
Total: 6 field(s)

Collapse image Query

SELECT PER.FirstName + ' ' + PER.LastName AS Employee,
   DATEPART(Year, SOH.OrderDate) AS [Year],
   DATEPART(Month, SOH.OrderDate) AS [MonthNumber],
   DATENAME(Month, SOH.OrderDate) AS [Month],
   PC.Name AS Category, SUM(DET.LineTotal) AS Sales
FROM Sales.SalesOrderHeader SOH
   INNER JOIN [Sales].[SalesPerson] SP ON SP.[BusinessEntityID] = SOH.[SalesPersonID]
   INNER JOIN Sales.SalesOrderDetail DET ON SOH.SalesOrderID = DET.SalesOrderID
   INNER JOIN [HumanResources].[Employee] E ON SOH.[SalesPersonID] = E.[BusinessEntityID]
   INNER JOIN [Person].[Person] PER ON PER.[BusinessEntityID] = SP.[BusinessEntityID]
   INNER JOIN Production.Product P ON DET.ProductID = P.ProductID
   INNER JOIN Production.ProductSubcategory PS ON P.ProductSubcategoryID = PS.ProductSubcategoryID
   INNER JOIN Production.ProductCategory PC ON PS.ProductCategoryID = PC.ProductCategoryID
WHERE
   (DATEPART(Year, SOH.OrderDate) <= @ReportYear)
   AND (DATEPART(Month, SOH.OrderDate) = @ReportMonth)
   AND (SOH.SalesPersonID = @EmployeeID)
GROUP BY PER.FirstName + ' ' + PER.LastName,
   DATEPART(Year, SOH.OrderDate), DATEPART(Month, SOH.OrderDate),
   DATENAME(Month, SOH.OrderDate), PC.Name

Collapse image See also

About this documentation


Dataset: SalesEmployees.rsd

Collapse image Dataset properties

Property | Value
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\SalesEmployees.rsd
Data source | AdventureWorks

Collapse image Parameters

Name | Data type | Nullable | Omit from query | Read only
fdsf | String | True | True | True
Total: 1 parameter(s)

Collapse image Fields

Name | Field source column | Data type
BusinessEntityID | BusinessEntityID | System.Int32
Employee | Employee | System.String
JobTitle | JobTitle | System.String
Total: 3 field(s)

Collapse image Query

SELECT s.[BusinessEntityID], p.[FirstName] + N' ' + p.LastName AS Employee, e.[JobTitle]
FROM [Sales].[SalesPerson] s
   INNER JOIN [HumanResources].[Employee] e ON e.[BusinessEntityID] = s.[BusinessEntityID]
   INNER JOIN [Person].[Person] p ON p.[BusinessEntityID] = s.[BusinessEntityID]

Collapse image See also

About this documentation


List of Data sources

Collapse image Data sources

Name | Data source type
AdventureWorks.rds | SQL
AdventureWorksAS.rds | OLEDB-MD
DataSource1.rds | SQLAZURE
DataSource2.rds | SQL
DataSource3.rds | OLEDB-MD
Total: 5 datasource(s)

Collapse image See also

About this documentation


Data source: AdventureWorks.rds

Collapse image Data source properties

Property | Value
Connection string | Data Source=(local);Initial Catalog=AdventureWorks2012
Data source type | SQL
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\AdventureWorks.rds

Collapse image See also

About this documentation


Data source: AdventureWorksAS.rds

Collapse image Data source properties

Property | Value
Connection string | Data Source=(local);Initial Catalog=AdventureWorksDW2012Multidimensional-EE
Data source type | OLEDB-MD
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\AdventureWorksAS.rds

Collapse image See also

About this documentation


Data source: DataSource1.rds

Collapse image Data source properties

Property | Value
Connection string | Encrypt=True;TrustServerCertificate=False
Data source type | SQLAZURE
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\DataSource1.rds

Collapse image See also

About this documentation


Data source: DataSource2.rds

Collapse image Data source properties

Property | Value
Connection string | Data Source=BOY\MSSQLSERVER14ASM;Initial Catalog=AdventureWorks2014
Data source type | SQL
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\DataSource2.rds

Collapse image See also

About this documentation


Data source: DataSource3.rds

Collapse image Data source properties

Property | Value
Connection string | Data Source=BOY\MSSQLSERVER14ASM;Initial Catalog=AdventureWorksDW2014Multidimensional-SE
Data source type | OLEDB-MD
Path | C:\Users\Alen\Desktop\SSRS items\AdventureWorks 2012 SSRS Samples - Copy\DataSource3.rds

Collapse image See also

About this documentation


About

About this documentation

Collapse image Database documentation details

Author | ApexSQL
Created | 26.10.2016
Comments | ©2016 ApexSQL, LLC

Collapse image See also

Server index


SQL Servers

Collapse image Server index

Server
ALEN-PC\SQLSERVER2016

Collapse image See also

About this documentation


Database index

ALEN-PC\SQLSERVER2016

Collapse image Database index

Database | Description
AdventureWorks2016CTP3 | AdventureWorks 2014 Sample OLTP Database

Collapse image See also

About this documentation
Server info


List of defaults

Collapse image See also

Rules

Datatypes

Database overview


FullText stoplists

List of fulltext stoplists

Collapse image FullText stoplist

No fulltext stoplists exist

Collapse image See also

Database overview


List of rules

Collapse image See also

Defaults

Datatypes

Database overview


Sequences

List of sequences

Collapse image Sequences

No sequences exist


Column permissions

Column permissions on Table CustomerPII for User/role SalesManagers

CollapseAll image

Collapse image See also

Sales.CustomerPII

SalesManagers


Column permissions

Column permissions on Table CustomerPII for User/role SalesPersons

CollapseAll image

Collapse image See also

Sales.CustomerPII

SalesPersons